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1. Configuration of CaoSQLConfig  

1. Start CaoSQLConfig from “Start” -> “All Programs” -> “ORiN2” -> “CAOSQL” -> “CaoSQLConfig”  

2. Select “Edit” -> “Add Controller…” in menu bar. 

 

 

3. Assign a controller name in alphanumeric string. (\, $, #, :, ! cannot be used in the string) 

example: “RC1” 

4. Setup controller information in “Controller” tab -> “CaoController” 

Controller Name  : <alphanumeric string(null is possible)> string assigned in 3 is set 

Provider Name    : CaoProv.DENSO.NetwoRC 
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Machine Name  : <null> 

Option  : Conn=eth:<IP address>  example:"Conn=eth:133.192.232.235" 

   

For other details, please refer “CaoSQL Users Guide.” 

5. Select “Edit” -> “Add Item…” in menu bar. 

 

 

6. Assign item name in alphanumeric string. (\, $, #, :, ! cannot be used in the string) 

example : “Item1” 

7. Setup Item information in “Item” tab -> “CaoVariable.”  

Variable Name  : <string(depends on provider)> default is string assigned in 6.  

Option    : <null> 

Class   : “Controller Class” 

Object Name : <null> 

 

For other details, please refer “CaoSQL Users Guide.”  

8. Save setup into a file. 

 

2. CaoSQL operation test using CaoSQL Tester 

 CaoSQLTester is a test tool for CaoSQL with CaoSQL interface implementation and it can access controllers 
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and items configured by CaoSQLConfig.  

Now we will test the controller and the item configured in 1 

 

1. Start CaoSQLTester from “Start” -> “All Programs” -> “ORiN2” -> “CAOSQL” -> “CaoSQLTester” 

2. After starting the software, confirm that controller “RC1” configured by CaoSQLConfig is displayed in 

the tree view. 

    

 

3. Double click “RC1” to display controller information. Right side is controller information. Confirm that 

“State” is set to “1” (Active). 

    

 

4. Confirm that double click operation in 3shows CAoSQLConfig configured item “Item1” in a tree view.  

   

 

5. Double click “Item1” to display item information. Right side is item information. Confirm that “State” is 
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set to “0”(Succeeded).  

 

 

6. The variable name for this item is assigned to “I1”, so confirm that controller variable “I1” is acquired.  

 

 

7. After confirming correct value acquisition, check that value can be written. On the right side of item 

information dialog, set values as following. 

Property   : “Value”  

Type     : <Type of the variable to be written> 

Value   : <A value with the type assigned in “Type”> 
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  Press “Put” and confirm that value on the controller is changed.  

 

3. CaoSQL programming with Visual Basic 

This section explains an example of CaoSQL programming with Microsoft Visual Basic 6.0.  

 

1. Start Microsoft Visual Basic6.0. 

2. Select “Standard EXE” in “New Project” selection dialog. 

3. There are two ways to use CaoSQL in Visual Basic. 

(With early binding) 

Select “Project”->”Reference setup…” in menu bar.  

 Check “Cao SQL 1.0 Type Library” in “Referable library file”  

  (With late binding) 

    CaoSQL function will be available by adding the following statement.  

(csqlEngine need to be declared as a variable) 

Set csqlEngine = CreateObject(“CaoSQL.CaoSQLEngine”)  

4. In design mode of “Form1”, add one TextBox control and two “CommandButton” controls to “Form1”. 

In the TextBox property, select “Text” and delete default string “Text1”. 
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In the CommandButton property, select “Capital” and change to “Get” and “Put” respectively.  

 

   

 

5. In the code mode of “Form1”, input the following code. (This is an example of early binding.)．Use 

controller name and item name as defined in 1Configuration of CaoSQLConfig” (Caution: For clarity, 

this example does not include necessary error handling code.) 

 

Private csqlEng As New CaoSQLEngine 
 
Private Sub Command1_Click() 
    Text1.Text = csqlEng.Controller("RC1").Item("Item1").Value 
End Sub 
 
Private Sub Command2_Click() 
    csqlEng.Controller("RC1").Item("Item1").Value = Text1.Text 
End Sub 

 

6. After input the code, try to execute. After ”Form1” is displayed, press “Get” button.  

Please confirm that the value of “Item1”(I1) is displayed in TextBox. 

7. Input a value in TextBox and press “Put” button. Please confirm that the value of controller variable I1 is 

changed to the input value.  
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4. CaoSQL WEB programming with ASP 

This section explains a procedure of CaoSQL WEB programming with ASP. 

 

1. Install IIS (Internet Information Service) before WEB programming. 

2. After IIS installation, create a virtual directory with IIS management tool. 

Assign the reference place of the virtual directory.  

3. After IIS setup, continue DCOM setup. 

For CaoSQL setup for DCOM, start DCOM configuration tool "dcomcnfg.exe", and open [CaoSQL] 

property dialog. 

4. Setup security policy for virtual directories created in 2. (Add ”IUSR_?????” and ”IWAM_?????” to 

[Access Permissions] and [Launch and Activation Permissions]). 

For details of DCOM, please refer section 5.1 of  “ORiN2\Doc\ORiN2_ProgrammersGuide_en.pdf”. 

5. After configuration is finished, open “notepad”, and input the code below.  

 

<% 
 Dim CSQLEng  ' CaoSQLEngine 
 Dim CSQLCtrl  ' CaoSQLController 
 Dim CSQLItem  ' CaoSQLItem 

  
Set CSQLEng = CreateObject("CaoSQL.CaoSQLEngine") 
Set CSQLCtrl = CSQLEng.Controller(“RC1”) 

%> 
 
<html> 
<head> 

<meta http-equiv="Content-Type" content="text/html; charset=shift_jis"> 
<title>Item Value</title> 

</head> 
<body> 

<table border="0" width="100%"> 
  <tr> 
     <td width="50%" align="right"> 

<form name="refform"> 
<input type="button" value="Update" name="Update"onclick="location.reload()"> 

     </form> 
 </td> 
  </tr> 

</table> 
<table border="1" width="100%" cellspacing="0" cellpadding="2" rules="all"> 

  <tr> 
     <td width="50%" align="center" bgcolor="#99CCFF"><b>Controller Name</b></td> 
          <td width="50%" align="center" bgcolor="#99CCFF"><b>Value</b></td> 
    </tr> 

<% 
Dim Val ' Item value 
 
Set CSQLItem = CSQLCtrl.Item(“Item1”) 
Val = CSQLItem.Value 
 
Response.Write("<tr>"&chr(13)) 
Response.Write("<td width=50% align='center'><b>"&CSQLItem.Name&"</b></td>"&chr(13)) 
 
if (IsEmpty(Val) or IsNull(Val)) then 
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Response.Write("<td width=50% align='center'></td>"&chr(13)) 
else 

Response.Write("<td width=50% align='center'><b>"&Val&"</b></td>"&chr(13)) 
end if 
 
Response.Write("</tr>"&chr(13)) 
 
Set CSQLItem = nothing  
Response.End 

%> 
</table> 

<% 
Set CSQLCtrl = nothing 
Set CSQLEng = nothing 

%> 
 
</body> 
</html> 

 

6. After input the code, save as a file with appropriate file name and extension “.asp” in the virtual directory 

what you choose . 

7. Using web browser like Internet Explorer, go to a virtual directory created in 2, and open a file in the 

directory created in 6. 

8. Confirm that browser displays the specified controller item. 

 

Section 2.3.4 “Active Server Page” of “ORiN2\CaoSQL\Doc\CaoSQL_UsersGuide_en.pdf” describes ASP 

sample using CaoSQL.  

 

5. History function 

 

 This section explains the procedure of recording data to database automatically with CaoSQL, and recording 

data to database at a specified timing from application programs.  

 

5.1. Procedure for automatic recording 

1. After ORiN2 installation, a file “skeleton2000_en.mdb” will be stored in “ORiN2\CaoSQL” directory. 

Make a copy of this template file. 

2. Add check to “Engine” tab – “History” of CaoSQLConfig.  

 

   

 

3. Select “History” as “Table Type”.  
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4. Press “Database…” button. 

5. “CaoSQL History” configuration dialog will be displayed. Configure connection parameters as following.  

(This document uses Microsoft Access, so the configuration is for Access.) 

OLEDB Provider  : “Microsoft.Jet.OLEDB.4.0” (defined in ADO Connection String Database 

Server) 

Data Source    : <Path to a database file to record data> database file created in 1.  

Initial Catalog : <empty> 

User ID  : <empty> (some databases require to specify ID) 

Password  : <empty> (some database require to specify password.) 

Extended Properties: <empty> 

Misc.  : <empty> 

   

At “Table Name” field, input ”caosql_history”. (“caosql_history” is a name of the preset table in the 

template database file.) 

 

   

 

6. Save CaoSQLConfig configuration. 

7. Start CaoSQLTester. 

8. After startup CaoSQLTester, double click “CaoSQLHistory” in the tree view.  
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9. Double click “CaoSQLHistory” to display “CaoSQLHistory” dialog. Check that top item of “Enabled” is 

set to ”true”. 

 

     

 

10. Confirm that “SQL Command” field is set as” Select * From caosql_history”(this is a default setting), and 

press “Execute” button.  

 

    

 

11. When “Result” field shows the query result, confirm that the result is the value of controller “RC1” – 

“Item1” data that is acquired at CaoSQL startup.  

 

5.2. Procedure for recording data from application program (Programming using Snapshot) 

 

1. Take same procedure of step 1. – 6. of 5.1 

2. Proceed to step3 of “3CaoSQL programming with Visual Basic”. 
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3. In the design mode of “Form1”, paste one Command button on ”Form1”. Change the “Caption” property 

of the pasted Command button as ”Snap Shot”. 

 

 
 

4. In the code mode of  “Form1”, input the following code. (This is an example of early binding.). Use 

controller name and item name as defined in ”1Configuration of CaoSQLConfig". (Caution: For clarity, 

this example does not include necessary error handling code.) 

 

Private csqlEng As New CaoSQLEngine 
 
Private Sub Command1_Click() 
    csqlEng.Controller("RC1").Snapshot 
End Sub 

 

5. Run the program, and press “Snap Shot” button.. 

6. Start CaoSQLTester, and take procedures of 5.1steps 8.-10. to confirm that controller “RC1” – item 

“Item1” value is recorded.  

Different from automatic recording, the number of data record to the database is the number of the times 

“Snap Shot” button is pressed.
1
 You can also confirm this. 

 

6. DDE server function 

This section explains a procedure of displaying controller variable graph without programming, using DDE 

server function of CaoSQL and Excel. 

 

1. Start “ORiN2\CaoSQL\Bin\CaoSQLConfig.exe”  

2. At “Action” -> “Option…” -> “API”, check DDE Server
2
 and press “OK” button. 

3. Select “Edit” menu -> “Add Controller”, and input "RC7" in the dialog. 

(””quotation should not be input. Simply input RC7.) 

                                                        
1 If you use same database used in 5.1, the record number and button press number may be different. In that case please confirm the database 

recording time and the “Snap Shot” button pressed time. 
2 ORiN2\CaoSQL\Doc\CaoSQL_UsersGuide_ja.pdf describes detailed information on DDE server function. 
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4. To the added controller, input following. 

Controller Name  : RC7 

Provider Name  : CaoProv.DENSO.NetwoRC 

Machine Name  : <empty> 

Option  : Conn=eth:<IP address>  example :"Conn=eth:10.8.109.116" 

 

5. Select “Edit” menu -> “Add Item”, and input “F0” in the dialog. 

6. Also input “F1” – “F5” using the same procedure as 5. 

 

7. Save the configuration with “File” menu -> “Save”. 

8. Start “ORiN2\CaoSQL\Bin\CaoSQLLauncher.exe”, and press “Start” button. 

9. Go back to CaoSQLConfig, and select the added item “F0”. Select “Edit” menu -> “Copy DDE string”.
3
 

10. Start Excel, select an cell, and paste. 

11. Also paste F1 – F5using the same procedure as 9 and 10. 

12. In Excel, make a graph using the pasted items F0 – F5.  

13. Use teach pendant to change the value of F0 – F5, and confirm that the graph is changed. 

 

 

 

                                                        
3 Please start CaoSQLLauncher.exe earlier than Excel so that it may operate as DDEServer. 
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7. RAC server function 

 

This section explains a procedure to receive data from CaoSQL running on a different controller, using RAC 

server function of CaoSQL. 

(Two PCs are connected with RS-232C, and assigned as a server and a client) 

 

Server configuration 

1. Start CaoSQLConfig 

2. Select “Action” -> “Option…” -> “RAC”, and add check to “RAC Server”. Configure the items as 

following. 

Conn  : “COM:1” (Any port is possible, baud rate also can be specified.) 

Packet Opt  : “4:0:0:0” 

Ether Opt  : <empty> 

Timeout  : “1000” 

  Press “Add” button to finish configuration. 

 

  

 

3. CaoSQL.exe will be manually started later, so startCaoSQLTester or CaoSQLLauncher at this moment. 
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Client configuration 

1. Windows XP standard application “Hyper Terminal” is used as a client program. In Windows, select 

“Start” -> “All Programs” -> “Accessories” -> “Communications” -> “Hyper Terminal”.  

2. “Connection To” dialog will be shown. Input client information.  

For “Communication using”, select ”COM:8” (Port number “8” should be appropriate number). COM 

setting dialog will be displayed. Configure the port as following.  

Bits per seconds : “38400”   (Select the same baud rate as server configuration.) 

Data bits  : “8” 

Parity  : <empty> 

Stop bits  : “1” 

Flow control : “Hardware” 

 

      

 

3. Select HyperTerminal menu ”File” -> “Property”. 

Select “Settings” tab – “ASCII setup…” and setup operation environment.  

  In “ASCII Setup”, add check to “Send line ends with line feeds”, “Echo typed characters locally”, and 

“Append line feeds to incoming line ends”  
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1    

 

Execution 

1. Input following RAC command into the client “HyperTerminal” console.  

“Get：RC1：：Item1：” (!) Input the correct numbers of colons. 

 

  This is a command to get controller item value specified in “1Configuration of CaoSQLConfig”. 

2. After input the command, press Enter. 

3. Confirm that the value of Controller “RC1” – Item “Item1” is displayed on “HyperTerminal” console.  

Received data: “0, 3, 1” 

The first data is HRESULT of the RAC command. 

The second data is the type of the returned data. 

The third data is the value of the returned data. 

 

             

 

For details of the RAC command, please refer “ORiN2\CAO\ProviderLib\RAC\Doc\RAC_ProvGuide_en. 
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pdf”. 

 

8. CoAP server function 

This section explains a procedure to receive data from CaoSQL running on a different controller, using 

CoAP server function of CaoSQL. 

(Two PCs are connected with ethernet, and assigned as a server and a client) 

 

Server configuration 

4. Start CaoSQLConfig 

5. Select “Action” -> “Option…” -> “CoAP”, and add check to “CoAP Server”. Configure the items as 

following. 

Conn  : “udp:255.255.255.255:5683” (Any IP address and port are possible.) 

SendRetry : “5” 

RecvRetry : “5” 

Timeout  : “500” 

Packet Opt  : “0:0:0” 

  Press “Add” button to finish configuration. 

   

 

6. CaoSQL.exe will be manually started later, so startCaoSQLTester or CaoSQLLauncher at this moment. 
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Client configuration 

1. CaoTester is used as a client program. Start ORiN2\CAO\Tools\CaoTester\Bin\CaoTester.exe. 

2. Input AddController options in “Workspace” dialog as follows, and then press “Add” button. 

Controller Name : Any 

Provider Name : “CaoProv.IETF.CoAP” 

Machine Name : <empty> 

Option  : “Conn=udp:<Server IP address>:<CoAP server port>, 

   CoAPClient=True, Sync=True, PacketOpt=<Same as CoAP server>” 

3. Input AddVariable options in “Controller” dialog as follows, and then press “Add” button. 

Controller Name :[<Controller name>/]<Item name> 

Option  :<empty> 

4. Press “Get” button of “Value” property, and confirm that the value of Controller “RC1” – Item “Item1” is 

displayed. 
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