メインページ

DENSO WAVE CaoSQL Project ドキュメント

1.0

Generated on Tue Dec 13 12:25:22 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


File Index

DENSO WAVE CaoSQL Project ファイル一覧

これはファイル一覧です。
CAO_i.c |
CaoSQL.cpp | WinMain のインプリメンテーション
CaoSQL.h [コード] |
CaoSQL.idl [コード] | CaoSQL.exe 用の IDL ソース ファイル
CaoSQL_i.c |
CaoSQL_p.c |
CaoSQLAdviser.cpp | CCaoSQLAdviser クラスのインプリメンテーション
CaoSQLAdviser.h [コード] | CCaoSQLAdviser クラスのインターフェイス
CaoSQLCalcItem.cpp |
CaoSQLCalcItem.h [コード] |
CaoSQLController.cpp | CCaoSQLControllerのインプリメンテーション
CaoSQLController.h [コード] | CCaoSQLController の宣言
CaoSQLCP.h [コード] | CProxy_ICaoSQLEvents の宣言
CaoSQLData.h [コード] | CaoSQLで使用されるデータの宣言
CaoSQLEngine.cpp | CCaoSQLEngine のインプリメンテーション
CaoSQLEngine.h [コード] | CCaoSQLEngine の宣言
CaoSQLEngineMan.cpp | CCaoSQLEngineManクラスのインプリメンテーション
CaoSQLEngineMan.h [コード] | CCaoSQLEngineMan クラスのインターフェイス
CAOSQLEventInfo.h [コード] |
CaoSQLHistory.cpp | CCaoSQLHistory のインプリメンテーション
CaoSQLHistory.h [コード] | CCaoSQLHistory の宣言
CaoSQLHistoryMan.cpp | CCaoSQLHistoryManクラスのインプリメンテーション
CaoSQLHistoryMan.h [コード] | CCaoSQLHistoryMan クラスのインターフェイス
CaoSQLItem.cpp | CCaoSQLItemのインプリメンテーション
CaoSQLItem.h [コード] | CCaoSQLItem の宣言
CaoSQLLinkObserver.cpp | CCaoSQLLinkObserver クラスのインプリメンテーション
CaoSQLLinkObserver.h [コード] | CCaoSQLLinkObserver クラスのインターフェイス
CaoSQLObserver.cpp |
CaoSQLObserver.h [コード] | CCaoSQLObserver クラス
CaoSQLOnChangeObserver.cpp | CCaoSQLOnChangeObserver クラスのインプリメンテーション
CaoSQLOnChangeObserver.h [コード] | CCaoSQLOnChangeObserver クラスのインターフェイス
CaoSQLRACSvr.cpp |
CaoSQLRACSvr.h [コード] |
CaoSQLTriggerObserver.cpp | CCaoSQLTriggerObserver クラスのインプリメンテーション
CaoSQLTriggerObserver.h [コード] | CCaoSQLTriggerObserver クラスのインターフェイス
CorbaCaoSQL.idl [コード] | CaoSQL.exe 用の CORBA(OMG) IDL ソース ファイル
DDEServer.cpp | CDDEServer クラスのインプリメンテーション
DDEServer.h [コード] | CDDEServer クラスのインターフェイス
dlldata.c |
EventSink.cpp | CRACEventSinkクラスの実装
EventSink.h [コード] |
LockCriticalSection.h [コード] | CLockCriticalSection クラスのインターフェイス
RACServer.cpp |
RACServer.h [コード] |
ReadXML.h [コード] |
RegKeyEx.cpp |
RegKeyEx.h [コード] | CRegKeyEx クラスのインターフェイス
resource.h [コード] |
StdAfx.cpp | 標準インクルードファイルを含むソースファイル
StdAfx.h [コード] | 標準のシステムインクルードファイル
Generated on Tue Dec 13 12:25:22 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CAO_i.c File Reference

CAO_i.c の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

構成

struct | _IID

Typedef

typedef _IID | IID
typedef IID | CLSID

変数

const IID | IID_ICaoEngine = {0x5acfd9fe,0x41f0,0x43f6,{0xa0,0xd6,0xc1,0x0c,0x07,0x93,0x15,0xfc}}
const IID | IID_ICaoWorkspaces = {0x8dcdfb4e,0xcf07,0x47ca,{0x89,0x5f,0xdb,0x1d,0x5a,0xfa,0x8f,0x74}}
const IID | IID_ICaoWorkspace = {0x0ed07c17,0xb078,0x40cf,{0x9b,0x0f,0x3a,0x49,0x74,0xde,0x55,0xe5}}
const IID | IID_ICaoControllers = {0x474b2753,0x9f06,0x41e0,{0x84,0x0b,0x1f,0x26,0xb1,0xac,0x1c,0x2c}}
const IID | IID_ICaoController = {0xc94e794f,0xec5b,0x43f2,{0x87,0x9f,0x77,0x7a,0x49,0xe7,0x30,0x5b}}
const IID | IID_ICaoExtensions = {0xc5cd2d49,0xd7b9,0x4c6d,{0x8d,0x0d,0x56,0xa5,0x66,0xb7,0x80,0x42}}
const IID | IID_ICaoExtension = {0xa2e8ab44,0x325e,0x4fd8,{0x8e,0x92,0x55,0xa9,0x1d,0x21,0x3d,0x19}}
const IID | IID_ICaoFiles = {0x9f1e5eaf,0x4c53,0x4718,{0x9d,0x79,0xef,0xc3,0xf8,0x75,0x8d,0x02}}
const IID | IID_ICaoFile = {0x9a4617d6,0x3e02,0x499d,{0xa1,0xb9,0x3d,0x33,0xbc,0xa0,0x56,0x9f}}
const IID | IID_ICaoRobots = {0x76cddba4,0x09e9,0x4292,{0x95,0xef,0x1a,0x5a,0x85,0xdc,0xbe,0xa9}}
const IID | IID_ICaoRobot = {0x02105032,0x6ae1,0x4251,{0xa7,0x2f,0x9a,0xad,0xc0,0x4f,0x66,0x59}}
const IID | IID_ICaoTasks = {0xa2a35844,0x148b,0x4762,{0x8b,0x41,0x68,0x01,0x5b,0xbc,0x26,0xf7}}
const IID | IID_ICaoTask = {0xcc23c152,0x1d58,0x4c70,{0xbd,0x1b,0x53,0x9f,0xd0,0x32,0x9a,0xe2}}
const IID | IID_ICaoVariables = {0x8d392e7a,0xeb9e,0x46ef,{0x86,0xc6,0x8e,0x7a,0xcd,0x0e,0xce,0xab}}
const IID | IID_ICaoVariable = {0x3dc12940,0x6c7b,0x43e4,{0xb3,0x75,0x13,0x6c,0x3e,0x6e,0x7e,0x3a}}
const IID | IID_ICaoCommands = {0x480CA4D6,0xADCB,0x4cb4,{0x81,0x2B,0x7E,0x41,0xBE,0x89,0x1E,0x03}}
const IID | IID_ICaoCommand = {0x3DA3B42D,0xEA6A,0x468b,{0xA5,0x7F,0xC3,0x75,0xDE,0xFD,0x11,0xE9}}
const IID | IID_ICaoMessage = {0x964497c9,0xa444,0x48e3,{0xad,0x6c,0x78,0xb1,0xfa,0x5b,0xe4,0x6f}}
const IID | IID_ICaoEngineStatus = {0x9b77d6e0,0xb941,0x4513,{0x8a,0x63,0x08,0xc5,0x9c,0x99,0x29,0x91}}
const IID | IID_IEventSink = {0x2b27bcbf,0xc3c2,0x45dd,{0xba,0x66,0x8a,0xc0,0xfa,0x89,0x8c,0x1c}}
const IID | LIBID_CAOLib = {0xe2f77a83,0x3965,0x44e7,{0x99,0xa5,0xe7,0x5c,0x6b,0x07,0xd5,0x9c}}
const IID | DIID__ICaoControllerEvents = {0xa7b43ef1,0x0215,0x4940,{0xa6,0xf6,0x21,0x74,0x4b,0x8c,0xba,0x52}}
const IID | DIID__ICaoCommandEvents = {0xDC17F478,0xF7B2,0x4ce7,{0x81,0x9D,0x8E,0xF3,0x4F,0x70,0xE3,0x51}}
const CLSID | CLSID_CaoEngine = {0x60555f1b,0xe473,0x4250,{0xbb,0x43,0x93,0x39,0x90,0xfb,0xec,0xed}}
const CLSID | CLSID_CaoWorkspaces = {0xf7430785,0x4ec2,0x4193,{0x85,0x52,0xf5,0xcb,0x2d,0x6b,0xe7,0x32}}
const CLSID | CLSID_CaoWorkspace = {0x22fc99b8,0x9c3a,0x48c9,{0x9f,0x4d,0x8e,0xee,0x16,0xed,0x36,0x5a}}
const CLSID | CLSID_CaoControllers = {0x41c404be,0xbfd1,0x40ce,{0x84,0x54,0x2f,0x47,0xe0,0x4a,0x09,0xb1}}
const CLSID | CLSID_CaoController = {0xd1baa44e,0x9ca9,0x4075,{0x8a,0xd1,0x48,0x1a,0xa2,0x14,0x34,0xa8}}
const CLSID | CLSID_CaoExtensions = {0x0AF9CEC7,0x4F11,0x4EA4,{0x80,0x33,0x14,0x2C,0xF4,0xE4,0x55,0x12}}
const CLSID | CLSID_CaoExtension = {0xFE266A3E,0x9435,0x4F25,{0x85,0xE2,0xB4,0x35,0x0A,0x37,0x8B,0x81}}
const CLSID | CLSID_CaoFiles = {0x2d662501,0x91ce,0x49e0,{0xba,0xfa,0x45,0x3a,0x2d,0x61,0x0b,0x50}}
const CLSID | CLSID_CaoFile = {0xb7466915,0x2234,0x4382,{0xb9,0xe7,0xda,0x74,0xa3,0x4a,0xca,0xff}}
const CLSID | CLSID_CaoRobots = {0xf6981128,0x7e0f,0x4159,{0x86,0xb0,0x73,0x97,0xeb,0x15,0x96,0xa3}}
const CLSID | CLSID_CaoRobot = {0xc486acdd,0x451e,0x4fb5,{0xa2,0x0b,0x3c,0xc7,0x47,0xf8,0xcc,0x2e}}
const CLSID | CLSID_CaoTasks = {0xeb5211bb,0xdd98,0x4e91,{0xb8,0x4f,0xa6,0x19,0xf6,0x36,0xde,0x30}}
const CLSID | CLSID_CaoTask = {0x1ab45162,0xd81d,0x475c,{0xa7,0x3f,0x3f,0x9b,0xbc,0x0f,0x07,0x68}}
const CLSID | CLSID_CaoVariables = {0x5691304f,0x610a,0x4645,{0x8d,0x58,0x64,0x13,0x8e,0x05,0x98,0x24}}
const CLSID | CLSID_CaoVariable = {0x2c9b6656,0x32d1,0x425c,{0xad,0x61,0x53,0x6c,0x5a,0x07,0xc7,0x73}}
const CLSID | CLSID_CaoCommands = {0x887FFEAF,0x3E41,0x4d54,{0xA5,0x58,0xDE,0x75,0xE7,0xE1,0x1B,0x44}}
const CLSID | CLSID_CaoCommand = {0x9289DBE4,0xADEC,0x4001,{0x9C,0xF0,0xC5,0x8C,0x75,0x6B,0x2E,0x79}}
const CLSID | CLSID_CaoMessage = {0x4f2f3700,0x71c8,0x452a,{0x81,0xac,0x5a,0x85,0x39,0xb8,0xa5,0xc6}}
const CLSID | CLSID_CaoEngineStatus = {0xf5e9b29c,0xe1d6,0x4f78,{0xac,0x18,0xa8,0x5a,0xe4,0x9d,0xbb,0xb2}}
const CLSID | CLSID_EventSink = {0x12654e13,0xf7bc,0x4f1a,{0x83,0x1d,0xa7,0xa9,0x3e,0x73,0x3c,0xb7}}

Typedef の解説

typedef IID CLSID

typedef struct _IID IID

変数の解説

const CLSID CLSID_CaoCommand = {0x9289DBE4,0xADEC,0x4001,{0x9C,0xF0,0xC5,0x8C,0x75,0x6B,0x2E,0x79}}

const CLSID CLSID_CaoCommands = {0x887FFEAF,0x3E41,0x4d54,{0xA5,0x58,0xDE,0x75,0xE7,0xE1,0x1B,0x44}}

const CLSID CLSID_CaoController = {0xd1baa44e,0x9ca9,0x4075,{0x8a,0xd1,0x48,0x1a,0xa2,0x14,0x34,0xa8}}

const CLSID CLSID_CaoControllers = {0x41c404be,0xbfd1,0x40ce,{0x84,0x54,0x2f,0x47,0xe0,0x4a,0x09,0xb1}}

const CLSID CLSID_CaoEngine = {0x60555f1b,0xe473,0x4250,{0xbb,0x43,0x93,0x39,0x90,0xfb,0xec,0xed}}

const CLSID CLSID_CaoEngineStatus = {0xf5e9b29c,0xe1d6,0x4f78,{0xac,0x18,0xa8,0x5a,0xe4,0x9d,0xbb,0xb2}}

const CLSID CLSID_CaoExtension = {0xFE266A3E,0x9435,0x4F25,{0x85,0xE2,0xB4,0x35,0x0A,0x37,0x8B,0x81}}

const CLSID CLSID_CaoExtensions = {0x0AF9CEC7,0x4F11,0x4EA4,{0x80,0x33,0x14,0x2C,0xF4,0xE4,0x55,0x12}}

const CLSID CLSID_CaoFile = {0xb7466915,0x2234,0x4382,{0xb9,0xe7,0xda,0x74,0xa3,0x4a,0xca,0xff}}

const CLSID CLSID_CaoFiles = {0x2d662501,0x91ce,0x49e0,{0xba,0xfa,0x45,0x3a,0x2d,0x61,0x0b,0x50}}

const CLSID CLSID_CaoMessage = {0x4f2f3700,0x71c8,0x452a,{0x81,0xac,0x5a,0x85,0x39,0xb8,0xa5,0xc6}}

const CLSID CLSID_CaoRobot = {0xc486acdd,0x451e,0x4fb5,{0xa2,0x0b,0x3c,0xc7,0x47,0xf8,0xcc,0x2e}}

const CLSID CLSID_CaoRobots = {0xf6981128,0x7e0f,0x4159,{0x86,0xb0,0x73,0x97,0xeb,0x15,0x96,0xa3}}

const CLSID CLSID_CaoTask = {0x1ab45162,0xd81d,0x475c,{0xa7,0x3f,0x3f,0x9b,0xbc,0x0f,0x07,0x68}}

const CLSID CLSID_CaoTasks = {0xeb5211bb,0xdd98,0x4e91,{0xb8,0x4f,0xa6,0x19,0xf6,0x36,0xde,0x30}}

const CLSID CLSID_CaoVariable = {0x2c9b6656,0x32d1,0x425c,{0xad,0x61,0x53,0x6c,0x5a,0x07,0xc7,0x73}}

const CLSID CLSID_CaoVariables = {0x5691304f,0x610a,0x4645,{0x8d,0x58,0x64,0x13,0x8e,0x05,0x98,0x24}}

const CLSID CLSID_CaoWorkspace = {0x22fc99b8,0x9c3a,0x48c9,{0x9f,0x4d,0x8e,0xee,0x16,0xed,0x36,0x5a}}

const CLSID CLSID_CaoWorkspaces = {0xf7430785,0x4ec2,0x4193,{0x85,0x52,0xf5,0xcb,0x2d,0x6b,0xe7,0x32}}

const CLSID CLSID_EventSink = {0x12654e13,0xf7bc,0x4f1a,{0x83,0x1d,0xa7,0xa9,0x3e,0x73,0x3c,0xb7}}

const IID DIID__ICaoCommandEvents = {0xDC17F478,0xF7B2,0x4ce7,{0x81,0x9D,0x8E,0xF3,0x4F,0x70,0xE3,0x51}}

const IID DIID__ICaoControllerEvents = {0xa7b43ef1,0x0215,0x4940,{0xa6,0xf6,0x21,0x74,0x4b,0x8c,0xba,0x52}}

const IID IID_ICaoCommand = {0x3DA3B42D,0xEA6A,0x468b,{0xA5,0x7F,0xC3,0x75,0xDE,0xFD,0x11,0xE9}}

const IID IID_ICaoCommands = {0x480CA4D6,0xADCB,0x4cb4,{0x81,0x2B,0x7E,0x41,0xBE,0x89,0x1E,0x03}}

const IID IID_ICaoController = {0xc94e794f,0xec5b,0x43f2,{0x87,0x9f,0x77,0x7a,0x49,0xe7,0x30,0x5b}}

const IID IID_ICaoControllers = {0x474b2753,0x9f06,0x41e0,{0x84,0x0b,0x1f,0x26,0xb1,0xac,0x1c,0x2c}}

const IID IID_ICaoEngine = {0x5acfd9fe,0x41f0,0x43f6,{0xa0,0xd6,0xc1,0x0c,0x07,0x93,0x15,0xfc}}

const IID IID_ICaoEngineStatus = {0x9b77d6e0,0xb941,0x4513,{0x8a,0x63,0x08,0xc5,0x9c,0x99,0x29,0x91}}

const IID IID_ICaoExtension = {0xa2e8ab44,0x325e,0x4fd8,{0x8e,0x92,0x55,0xa9,0x1d,0x21,0x3d,0x19}}

const IID IID_ICaoExtensions = {0xc5cd2d49,0xd7b9,0x4c6d,{0x8d,0x0d,0x56,0xa5,0x66,0xb7,0x80,0x42}}

const IID IID_ICaoFile = {0x9a4617d6,0x3e02,0x499d,{0xa1,0xb9,0x3d,0x33,0xbc,0xa0,0x56,0x9f}}

const IID IID_ICaoFiles = {0x9f1e5eaf,0x4c53,0x4718,{0x9d,0x79,0xef,0xc3,0xf8,0x75,0x8d,0x02}}

const IID IID_ICaoMessage = {0x964497c9,0xa444,0x48e3,{0xad,0x6c,0x78,0xb1,0xfa,0x5b,0xe4,0x6f}}

const IID IID_ICaoRobot = {0x02105032,0x6ae1,0x4251,{0xa7,0x2f,0x9a,0xad,0xc0,0x4f,0x66,0x59}}

const IID IID_ICaoRobots = {0x76cddba4,0x09e9,0x4292,{0x95,0xef,0x1a,0x5a,0x85,0xdc,0xbe,0xa9}}

const IID IID_ICaoTask = {0xcc23c152,0x1d58,0x4c70,{0xbd,0x1b,0x53,0x9f,0xd0,0x32,0x9a,0xe2}}

const IID IID_ICaoTasks = {0xa2a35844,0x148b,0x4762,{0x8b,0x41,0x68,0x01,0x5b,0xbc,0x26,0xf7}}

const IID IID_ICaoVariable = {0x3dc12940,0x6c7b,0x43e4,{0xb3,0x75,0x13,0x6c,0x3e,0x6e,0x7e,0x3a}}

const IID IID_ICaoVariables = {0x8d392e7a,0xeb9e,0x46ef,{0x86,0xc6,0x8e,0x7a,0xcd,0x0e,0xce,0xab}}

const IID IID_ICaoWorkspace = {0x0ed07c17,0xb078,0x40cf,{0x9b,0x0f,0x3a,0x49,0x74,0xde,0x55,0xe5}}

const IID IID_ICaoWorkspaces = {0x8dcdfb4e,0xcf07,0x47ca,{0x89,0x5f,0xdb,0x1d,0x5a,0xfa,0x8f,0x74}}

const IID IID_IEventSink = {0x2b27bcbf,0xc3c2,0x45dd,{0xba,0x66,0x8a,0xc0,0xfa,0x89,0x8c,0x1c}}

const IID LIBID_CAOLib = {0xe2f77a83,0x3965,0x44e7,{0x99,0xa5,0xe7,0x5c,0x6b,0x07,0xd5,0x9c}}

Generated on Tue Dec 13 12:25:24 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQL.cpp File Reference

CaoSQL.cpp の解説

WinMain のインプリメンテーション. [詳細]

#include "stdafx.h"
#include "resource.h"
#include <initguid.h>
#include "CaoSQL.h"
#include "CaoSQL_i.c"
#include <stdio.h>
#include <locale.h>
#include "CaoSQLEngine.h"
#include "CaoSQLEngineMan.h"
#include "CaoSQLController.h"
#include "CaoSQLItem.h"
#include "CaoSQLHistoryMan.h"
#include "DDEServer.h"
#include "RACServer.h"
#include "../Src.EventInfo/CaoSQLEventInfo.h"

CaoSQL.cppのインクルード依存関係図

Include dependency graph

関数

LPCTSTR | FindOneOf (LPCTSTR p1, LPCTSTR p2)
int WINAPI | _tWinMain (HINSTANCE hInstance, HINSTANCE, LPTSTR lpCmdLine, int)

変数

CServiceModule _Module
const int | THREAD_PRIORITY [7]
const int | PROCESS_PRIORITY [4]

解説

WinMain のインプリメンテーション.

Proxy/Stub 情報 別々の proxy/stub DLL をビルドするためには、プロジェクトのディレクトリで nmake -f CaoSQLps.mak を実行してください。

バージョン:
1.0
日付:
Wed May 15 14:09:56 2002
作者:
DENSO WAVE

関数の解説

int WINAPI _tWinMain | ( | HINSTANCE | hInstance,
 |  | HINSTANCE | ,
 |  | LPTSTR | lpCmdLine,
 |  | int |
 | ) |

LPCTSTR FindOneOf | ( | LPCTSTR | p1,
 |  | LPCTSTR | p2
 | ) |

変数の解説

CServiceModule _Module

const int PROCESS_PRIORITY[4]

初期値:

{
    IDLE_PRIORITY_CLASS,
    NORMAL_PRIORITY_CLASS,
    HIGH_PRIORITY_CLASS,
    REALTIME_PRIORITY_CLASS
}

const int THREAD_PRIORITY[7]

初期値:

{
    THREAD_PRIORITY_IDLE,
    THREAD_PRIORITY_LOWEST,
    THREAD_PRIORITY_BELOW_NORMAL,
    THREAD_PRIORITY_NORMAL,
    THREAD_PRIORITY_ABOVE_NORMAL,
    THREAD_PRIORITY_HIGHEST,
    THREAD_PRIORITY_TIME_CRITICAL,
}

Generated on Tue Dec 13 12:25:24 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQL.h File Reference

CaoSQL.h の解説

#include "rpc.h"
#include "rpcndr.h"
#include "windows.h"
#include "ole2.h"
#include "oaidl.h"
#include "ocidl.h"

CaoSQL.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

マクロ定義

#define | __REQUIRED_RPCNDR_H_VERSION__ 440

Typedef

typedef interface ICaoSQLEngine | ICaoSQLEngine
typedef interface ICaoSQLController | ICaoSQLController
typedef interface ICaoSQLItem | ICaoSQLItem
typedef interface ICaoSQLHistory | ICaoSQLHistory
typedef interface IRACEventSink | IRACEventSink
typedef CaoSQLEngine | CaoSQLEngine
typedef interface _ICaoSQLControllerEvents | _ICaoSQLControllerEvents
typedef interface IRACSever | IRACSever
typedef CaoSQLController | CaoSQLController
typedef CaoSQLItem | CaoSQLItem
typedef CaoSQLHistory | CaoSQLHistory
typedef RACEventSink | RACEventSink
typedef enum enmCaoVariableClass | _enmCaoVariableClass
typedef enum enmCaoSQLCtrlState | _enmCaoSQLCtrlState
typedef enum enmCaoSQLCtrlScantime | _enmCaoSQLCtrlScantime
typedef enum enmCaoSQLItemState | _enmCaoSQLItemState
typedef enum enmCaoSQLItemAttribute | _enmCaoSQLItemAttribute
typedef _enmCaoVariableClass | enmCaoVariableClass
typedef _enmCaoSQLCtrlState | enmCaoSQLCtrlState
typedef _enmCaoSQLCtrlScantime | enmCaoSQLCtrlScantime
typedef _enmCaoSQLItemState | enmCaoSQLItemState
typedef _enmCaoSQLItemAttribute | enmCaoSQLItemAttribute

Enum

enum | enmCaoVariableClass { csVarClassController = 0, csVarClassTask = 1, csVarClassRobot = 2, csVarClassExtension = 3 }
enum enmCaoSQLCtrlState {
csCtrlThreadUninit = 0, csCtrlThreadActive = 0x1, csCtrlThreadDeactive = 0x2, csCtrlThreadError = 0x3,
csCtrlThreadTerminated = 0x4
}
enum | enmCaoSQLCtrlScantime { csCtrlScantimeLast = 0, csCtrlScantimeMin = 0x1, csCtrlScantimeMax = 0x2 }
enum | enmCaoSQLItemState { csItemSucceeded = 0, csItemFailed = 0x1, csItemUndefined = 0x2 }
enum | enmCaoSQLItemAttribute { csItemReadWrite = 0, csItemReadOnly = 0x1, csItemWriteOnly = 0x2 }

関数

void __RPC_FAR *__RPC_USER | MIDL_user_allocate (size_t)
void __RPC_USER | MIDL_user_free (void __RPC_FAR *)
virtual HRESULT STDMETHODCALLTYPE | get_Controller (VARIANT vntIndex, ICaoSQLController __RPC_FAR *__RPC_FAR *ppICSCtrl)=0
virtual HRESULT STDMETHODCALLTYPE | Start (void)=0
virtual HRESULT STDMETHODCALLTYPE | Stop (void)=0
virtual HRESULT STDMETHODCALLTYPE | Snapshot (void)=0
virtual HRESULT STDMETHODCALLTYPE | Execute (BSTR bstrCmdText, VARIANT __RPC_FAR *pvntVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_CaoSQLHistory (ICaoSQLHistory __RPC_FAR *__RPC_FAR *ppICSHstry)=0
virtual HRESULT STDMETHODCALLTYPE | get_ControllerNames (VARIANT __RPC_FAR *pvntVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Count (long __RPC_FAR *plVal)=0
HRESULT STDMETHODCALLTYPE | ICaoSQLEngine_get__NewEnum_Proxy (ICaoSQLEngine __RPC_FAR *This, LPUNKNOWN __RPC_FAR *pVal)
void __RPC_STUB | ICaoSQLEngine_get__NewEnum_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLEngine_get_Controller_Proxy (ICaoSQLEngine __RPC_FAR *This, VARIANT vntIndex, ICaoSQLController __RPC_FAR *__RPC_FAR *ppICSCtrl)
void __RPC_STUB | ICaoSQLEngine_get_Controller_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLEngine_Start_Proxy (ICaoSQLEngine __RPC_FAR *This)
void __RPC_STUB | ICaoSQLEngine_Start_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLEngine_Stop_Proxy (ICaoSQLEngine __RPC_FAR *This)
void __RPC_STUB | ICaoSQLEngine_Stop_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLEngine_Snapshot_Proxy (ICaoSQLEngine __RPC_FAR *This)
void __RPC_STUB | ICaoSQLEngine_Snapshot_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLEngine_Execute_Proxy (ICaoSQLEngine __RPC_FAR *This, BSTR bstrCmdText, VARIANT __RPC_FAR *pvntVal)
void __RPC_STUB | ICaoSQLEngine_Execute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLEngine_get_CaoSQLHistory_Proxy (ICaoSQLEngine __RPC_FAR *This, ICaoSQLHistory __RPC_FAR *__RPC_FAR *ppICSHstry)
void __RPC_STUB | ICaoSQLEngine_get_CaoSQLHistory_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLEngine_get_ControllerNames_Proxy (ICaoSQLEngine __RPC_FAR *This, VARIANT __RPC_FAR *pvntVal)
void __RPC_STUB | ICaoSQLEngine_get_ControllerNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLEngine_get_Count_Proxy (ICaoSQLEngine __RPC_FAR *This, long __RPC_FAR *plVal)
void __RPC_STUB | ICaoSQLEngine_get_Count_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | get_Item (VARIANT vntIndex, ICaoSQLItem __RPC_FAR *__RPC_FAR *ppICSItem)=0
virtual HRESULT STDMETHODCALLTYPE | AddItem (VARIANT vntDataArray)=0
virtual HRESULT STDMETHODCALLTYPE | RemoveItem (VARIANT vntIndex)=0
virtual HRESULT STDMETHODCALLTYPE | Execute (BSTR bstrCommand, VARIANT vntParam, VARIANT __RPC_FAR *pvntVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Index (long __RPC_FAR *plVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_ItemNames (VARIANT __RPC_FAR *pvntVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_ScanTimes (long lIndex, long __RPC_FAR *plVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_State (long __RPC_FAR *plVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Tag (VARIANT __RPC_FAR *pvntVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Tag (VARIANT vntNewVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Description (BSTR __RPC_FAR *pbstrVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Name (BSTR __RPC_FAR *pbstrVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_SettingData (VARIANT vntName, VARIANT __RPC_FAR *pvntVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_SettingData (VARIANT vntName, VARIANT vntNewVal)=0
HRESULT STDMETHODCALLTYPE | ICaoSQLController_get__NewEnum_Proxy (ICaoSQLController __RPC_FAR *This, LPUNKNOWN __RPC_FAR *pVal)
void __RPC_STUB | ICaoSQLController_get__NewEnum_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_get_Item_Proxy (ICaoSQLController __RPC_FAR *This, VARIANT vntIndex, ICaoSQLItem __RPC_FAR *__RPC_FAR *ppICSItem)
void __RPC_STUB | ICaoSQLController_get_Item_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_Start_Proxy (ICaoSQLController __RPC_FAR *This)
void __RPC_STUB | ICaoSQLController_Start_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_Stop_Proxy (ICaoSQLController __RPC_FAR *This)
void __RPC_STUB | ICaoSQLController_Stop_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_Snapshot_Proxy (ICaoSQLController __RPC_FAR *This)
void __RPC_STUB | ICaoSQLController_Snapshot_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_AddItem_Proxy (ICaoSQLController __RPC_FAR *This, VARIANT vntDataArray)
void __RPC_STUB | ICaoSQLController_AddItem_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_RemoveItem_Proxy (ICaoSQLController __RPC_FAR *This, VARIANT vntIndex)
void __RPC_STUB | ICaoSQLController_RemoveItem_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_Execute_Proxy (ICaoSQLController __RPC_FAR *This, BSTR bstrCommand, VARIANT vntParam, VARIANT __RPC_FAR *pvntVal)
void __RPC_STUB | ICaoSQLController_Execute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_get_Count_Proxy (ICaoSQLController __RPC_FAR *This, long __RPC_FAR *plVal)
void __RPC_STUB | ICaoSQLController_get_Count_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_get_Index_Proxy (ICaoSQLController __RPC_FAR *This, long __RPC_FAR *plVal)
void __RPC_STUB | ICaoSQLController_get_Index_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_get_ItemNames_Proxy (ICaoSQLController __RPC_FAR *This, VARIANT __RPC_FAR *pvntVal)
void __RPC_STUB | ICaoSQLController_get_ItemNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_get_ScanTimes_Proxy (ICaoSQLController __RPC_FAR *This, long lIndex, long __RPC_FAR *plVal)
void __RPC_STUB | ICaoSQLController_get_ScanTimes_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_get_State_Proxy (ICaoSQLController __RPC_FAR *This, long __RPC_FAR *plVal)
void __RPC_STUB | ICaoSQLController_get_State_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_get_Tag_Proxy (ICaoSQLController __RPC_FAR *This, VARIANT __RPC_FAR *pvntVal)
void __RPC_STUB | ICaoSQLController_get_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_put_Tag_Proxy (ICaoSQLController __RPC_FAR *This, VARIANT vntNewVal)
void __RPC_STUB | ICaoSQLController_put_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_get_Description_Proxy (ICaoSQLController __RPC_FAR *This, BSTR __RPC_FAR *pbstrVal)
void __RPC_STUB | ICaoSQLController_get_Description_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_get_Name_Proxy (ICaoSQLController __RPC_FAR *This, BSTR __RPC_FAR *pbstrVal)
void __RPC_STUB | ICaoSQLController_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_get_SettingData_Proxy (ICaoSQLController __RPC_FAR *This, VARIANT vntName, VARIANT __RPC_FAR *pvntVal)
void __RPC_STUB | ICaoSQLController_get_SettingData_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLController_put_SettingData_Proxy (ICaoSQLController __RPC_FAR *This, VARIANT vntName, VARIANT vntNewVal)
void __RPC_STUB | ICaoSQLController_put_SettingData_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | put_Value (VARIANT vntNewVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Activation (VARIANT_BOOL __RPC_FAR *pbVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Activation (VARIANT_BOOL bNewVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_DateTime (VARIANT __RPC_FAR *pvntVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_LinkActivation (VARIANT_BOOL __RPC_FAR *pbVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_LinkActivation (VARIANT_BOOL bNewVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Microsecond (long __RPC_FAR *plVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_ValueEx (long lDelay, VARIANT vntNewVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Attribute (long __RPC_FAR *plVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Element (long lIndex1, long lIndex2, long lIndex3, VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Element (long lIndex1, long lIndex2, long lIndex3, VARIANT newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_ID (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_ID (VARIANT newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_LinkItemNames (VARIANT __RPC_FAR *pvntVal)=0
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_get_Value_Proxy (ICaoSQLItem __RPC_FAR *This, VARIANT __RPC_FAR *pvntVal)
void __RPC_STUB | ICaoSQLItem_get_Value_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_put_Value_Proxy (ICaoSQLItem __RPC_FAR *This, VARIANT vntNewVal)
void __RPC_STUB | ICaoSQLItem_put_Value_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_Snapshot_Proxy (ICaoSQLItem __RPC_FAR *This)
void __RPC_STUB | ICaoSQLItem_Snapshot_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_get_Activation_Proxy (ICaoSQLItem __RPC_FAR *This, VARIANT_BOOL __RPC_FAR *pbVal)
void __RPC_STUB | ICaoSQLItem_get_Activation_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_put_Activation_Proxy (ICaoSQLItem __RPC_FAR *This, VARIANT_BOOL bNewVal)
void __RPC_STUB | ICaoSQLItem_put_Activation_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_get_DateTime_Proxy (ICaoSQLItem __RPC_FAR *This, VARIANT __RPC_FAR *pvntVal)
void __RPC_STUB | ICaoSQLItem_get_DateTime_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_get_Index_Proxy (ICaoSQLItem __RPC_FAR *This, long __RPC_FAR *plVal)
void __RPC_STUB | ICaoSQLItem_get_Index_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_get_LinkActivation_Proxy (ICaoSQLItem __RPC_FAR *This, VARIANT_BOOL __RPC_FAR *pbVal)
void __RPC_STUB | ICaoSQLItem_get_LinkActivation_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_put_LinkActivation_Proxy (ICaoSQLItem __RPC_FAR *This, VARIANT_BOOL bNewVal)
void __RPC_STUB | ICaoSQLItem_put_LinkActivation_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_get_Microsecond_Proxy (ICaoSQLItem __RPC_FAR *This, long __RPC_FAR *plVal)
void __RPC_STUB | ICaoSQLItem_get_Microsecond_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_get_State_Proxy (ICaoSQLItem __RPC_FAR *This, long __RPC_FAR *plVal)
void __RPC_STUB | ICaoSQLItem_get_State_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_get_Tag_Proxy (ICaoSQLItem __RPC_FAR *This, VARIANT __RPC_FAR *pvntVal)
void __RPC_STUB | ICaoSQLItem_get_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_put_Tag_Proxy (ICaoSQLItem __RPC_FAR *This, VARIANT vntNewVal)
void __RPC_STUB | ICaoSQLItem_put_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_put_ValueEx_Proxy (ICaoSQLItem __RPC_FAR *This, long lDelay, VARIANT vntNewVal)
void __RPC_STUB | ICaoSQLItem_put_ValueEx_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_get_Attribute_Proxy (ICaoSQLItem __RPC_FAR *This, long __RPC_FAR *plVal)
void __RPC_STUB | ICaoSQLItem_get_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_get_Description_Proxy (ICaoSQLItem __RPC_FAR *This, BSTR __RPC_FAR *pbstrVal)
void __RPC_STUB | ICaoSQLItem_get_Description_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_get_Element_Proxy (ICaoSQLItem __RPC_FAR *This, long lIndex1, long lIndex2, long lIndex3, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoSQLItem_get_Element_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_put_Element_Proxy (ICaoSQLItem __RPC_FAR *This, long lIndex1, long lIndex2, long lIndex3, VARIANT newVal)
void __RPC_STUB | ICaoSQLItem_put_Element_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_get_ID_Proxy (ICaoSQLItem __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoSQLItem_get_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_put_ID_Proxy (ICaoSQLItem __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoSQLItem_put_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_get_LinkItemNames_Proxy (ICaoSQLItem __RPC_FAR *This, VARIANT __RPC_FAR *pvntVal)
void __RPC_STUB | ICaoSQLItem_get_LinkItemNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_get_Name_Proxy (ICaoSQLItem __RPC_FAR *This, BSTR __RPC_FAR *pbstrVal)
void __RPC_STUB | ICaoSQLItem_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_get_SettingData_Proxy (ICaoSQLItem __RPC_FAR *This, VARIANT vntName, VARIANT __RPC_FAR *pvntVal)
void __RPC_STUB | ICaoSQLItem_get_SettingData_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLItem_put_SettingData_Proxy (ICaoSQLItem __RPC_FAR *This, VARIANT vntName, VARIANT vntNewVal)
void __RPC_STUB | ICaoSQLItem_put_SettingData_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | get_ConnectionString (long lIndex, BSTR __RPC_FAR *pbstrVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Enable (VARIANT_BOOL __RPC_FAR *pbVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_MaxRecord (long lIndex, long __RPC_FAR *plVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_TableName (long lIndex, BSTR __RPC_FAR *pbstrVal)=0
HRESULT STDMETHODCALLTYPE | ICaoSQLHistory_Execute_Proxy (ICaoSQLHistory __RPC_FAR *This, BSTR bstrCmdText, VARIANT __RPC_FAR *pvntVal)
void __RPC_STUB | ICaoSQLHistory_Execute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLHistory_get_ConnectionString_Proxy (ICaoSQLHistory __RPC_FAR *This, long lIndex, BSTR __RPC_FAR *pbstrVal)
void __RPC_STUB | ICaoSQLHistory_get_ConnectionString_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLHistory_get_Enable_Proxy (ICaoSQLHistory __RPC_FAR *This, VARIANT_BOOL __RPC_FAR *pbVal)
void __RPC_STUB | ICaoSQLHistory_get_Enable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLHistory_get_MaxRecord_Proxy (ICaoSQLHistory __RPC_FAR *This, long lIndex, long __RPC_FAR *plVal)
void __RPC_STUB | ICaoSQLHistory_get_MaxRecord_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoSQLHistory_get_TableName_Proxy (ICaoSQLHistory __RPC_FAR *This, long lIndex, BSTR __RPC_FAR *pbstrVal)
void __RPC_STUB | ICaoSQLHistory_get_TableName_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRACEventSink_OnMessage_Proxy (IRACEventSink __RPC_FAR *This, IUnknown __RPC_FAR *pIVal)
void __RPC_STUB | IRACEventSink_OnMessage_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
class | DECLSPEC_UUID ("95615A16-A369-4937-A8F9-B3A909E9C5CE") CaoSQLEngine
class | DECLSPEC_UUID ("54A724F0-70FF-4e2d-BC81-ADEE8AD34682") CaoSQLController
class | DECLSPEC_UUID ("B5A90BCB-508F-462e-B714-BAEB106A5100") CaoSQLItem
class | DECLSPEC_UUID ("495F2699-4037-4fd7-A444-F66A77DB6610") CaoSQLHistory
class | DECLSPEC_UUID ("BC7F2ADB-E49A-4f9e-9B57-822AF4CA3D32") RACEventSink
unsigned long __RPC_USER | BSTR_UserSize (unsigned long __RPC_FAR *, unsigned long, BSTR __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | BSTR_UserMarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | BSTR_UserUnmarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR *)
void __RPC_USER | BSTR_UserFree (unsigned long __RPC_FAR *, BSTR __RPC_FAR *)
unsigned long __RPC_USER | VARIANT_UserSize (unsigned long __RPC_FAR *, unsigned long, VARIANT __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | VARIANT_UserMarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, VARIANT __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | VARIANT_UserUnmarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, VARIANT __RPC_FAR *)
void __RPC_USER | VARIANT_UserFree (unsigned long __RPC_FAR *, VARIANT __RPC_FAR *)

変数

RPC_IF_HANDLE | __MIDL_itf_CaoSQL_0000_v0_0_c_ifspec
RPC_IF_HANDLE | __MIDL_itf_CaoSQL_0000_v0_0_s_ifspec
EXTERN_C const IID | IID_ICaoSQLEngine
ICaoSQLEngine __pad0__
EXTERN_C const IID | IID_ICaoSQLController
ICaoSQLController __pad1__
EXTERN_C const IID | IID_ICaoSQLItem
ICaoSQLItem __pad2__
EXTERN_C const IID | IID_ICaoSQLHistory
ICaoSQLHistory __pad3__
ICaoSQLHistory VARIANT __RPC_FAR * | pvntVal = 0
EXTERN_C const IID | IID_IRACEventSink
IRACEventSink __pad4__
EXTERN_C const IID | LIBID_CaoSQLLib
EXTERN_C const CLSID | CLSID_CaoSQLEngine
EXTERN_C const IID | DIID__ICaoSQLControllerEvents
_ICaoSQLControllerEvents __pad5__
EXTERN_C const IID | IID_IRACSever
IRACSever __pad6__
EXTERN_C const CLSID | CLSID_CaoSQLController
EXTERN_C const CLSID | CLSID_CaoSQLItem
EXTERN_C const CLSID | CLSID_CaoSQLHistory
EXTERN_C const CLSID | CLSID_RACEventSink

マクロ定義の解説

#define __REQUIRED_RPCNDR_H_VERSION__ 440

Typedef の解説

typedef enum enmCaoSQLCtrlScantime _enmCaoSQLCtrlScantime

typedef enum enmCaoSQLCtrlState _enmCaoSQLCtrlState

typedef enum enmCaoSQLItemAttribute _enmCaoSQLItemAttribute

typedef enum enmCaoSQLItemState _enmCaoSQLItemState

typedef enum enmCaoVariableClass _enmCaoVariableClass

typedef interface _ICaoSQLControllerEvents _ICaoSQLControllerEvents

typedef class CaoSQLController CaoSQLController

typedef class CaoSQLEngine CaoSQLEngine

typedef class CaoSQLHistory CaoSQLHistory

typedef class CaoSQLItem CaoSQLItem

typedef _enmCaoSQLCtrlScantime enmCaoSQLCtrlScantime

typedef _enmCaoSQLCtrlState enmCaoSQLCtrlState

typedef _enmCaoSQLItemAttribute enmCaoSQLItemAttribute

typedef _enmCaoSQLItemState enmCaoSQLItemState

typedef _enmCaoVariableClass enmCaoVariableClass

typedef interface ICaoSQLController ICaoSQLController

typedef interface ICaoSQLEngine ICaoSQLEngine

typedef interface ICaoSQLHistory ICaoSQLHistory

typedef interface ICaoSQLItem ICaoSQLItem

typedef interface IRACEventSink IRACEventSink

typedef interface IRACSever IRACSever

typedef class RACEventSink RACEventSink

Enum の解説

enum enmCaoSQLCtrlScantime

Enum 値:
csCtrlScantimeLast
csCtrlScantimeMin
csCtrlScantimeMax

enum enmCaoSQLCtrlState

Enum 値:
csCtrlThreadUninit
csCtrlThreadActive
csCtrlThreadDeactive
csCtrlThreadError
csCtrlThreadTerminated

enum enmCaoSQLItemAttribute

Enum 値:
csItemReadWrite
csItemReadOnly
csItemWriteOnly

enum enmCaoSQLItemState

Enum 値:
csItemSucceeded
csItemFailed
csItemUndefined

enum enmCaoVariableClass

Enum 値:
csVarClassController
csVarClassTask
csVarClassRobot
csVarClassExtension

関数の解説

virtual HRESULT STDMETHODCALLTYPE AddItem ( VARIANT vntDataArray ) [pure virtual]

void __RPC_USER BSTR_UserFree | ( | unsigned long __RPC_FAR * | ,
 |  | BSTR __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER BSTR_UserMarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | BSTR __RPC_FAR * |
 | ) |

unsigned long __RPC_USER BSTR_UserSize | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned | long,
 |  | BSTR __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER BSTR_UserUnmarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | BSTR __RPC_FAR * |
 | ) |

class DECLSPEC_UUID ( "BC7F2ADB-E49A-4f9e-9B57-822AF4CA3D32" )

class DECLSPEC_UUID ( "495F2699-4037-4fd7-A444-F66A77DB6610" )

class DECLSPEC_UUID ( "B5A90BCB-508F-462e-B714-BAEB106A5100" )

class DECLSPEC_UUID ( "54A724F0-70FF-4e2d-BC81-ADEE8AD34682" )

class DECLSPEC_UUID ( "95615A16-A369-4937-A8F9-B3A909E9C5CE" )

virtual HRESULT STDMETHODCALLTYPE Execute | ( | BSTR | bstrCommand,
 |  | VARIANT | vntParam,
 |  | VARIANT __RPC_FAR * | pvntVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Execute | ( | BSTR | bstrCmdText,
 |  | VARIANT __RPC_FAR * | pvntVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Activation ( VARIANT_BOOL __RPC_FAR * pbVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Attribute ( long __RPC_FAR * plVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_CaoSQLHistory ( ICaoSQLHistory __RPC_FAR *__RPC_FAR * ppICSHstry ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_ConnectionString | ( | long | lIndex,
 |  | BSTR __RPC_FAR * | pbstrVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Controller | ( | VARIANT | vntIndex,
 |  | ICaoSQLController __RPC_FAR *__RPC_FAR * | ppICSCtrl
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_ControllerNames ( VARIANT __RPC_FAR * pvntVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_Count ( long __RPC_FAR * plVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_DateTime ( VARIANT __RPC_FAR * pvntVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_Description ( BSTR __RPC_FAR * pbstrVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Element | ( | long | lIndex1,
 |  | long | lIndex2,
 |  | long | lIndex3,
 |  | VARIANT __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Enable ( VARIANT_BOOL __RPC_FAR * pbVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_ID ( VARIANT __RPC_FAR * pVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_Index ( long __RPC_FAR * plVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Item | ( | VARIANT | vntIndex,
 |  | ICaoSQLItem __RPC_FAR *__RPC_FAR * | ppICSItem
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_ItemNames ( VARIANT __RPC_FAR * pvntVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_LinkActivation ( VARIANT_BOOL __RPC_FAR * pbVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_LinkItemNames ( VARIANT __RPC_FAR * pvntVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_MaxRecord | ( | long | lIndex,
 |  | long __RPC_FAR * | plVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Microsecond ( long __RPC_FAR * plVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_Name ( BSTR __RPC_FAR * pbstrVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_ScanTimes | ( | long | lIndex,
 |  | long __RPC_FAR * | plVal
 | ) | [pure virtual]

HRESULT STDMETHODCALLTYPE get_SettingData | ( | VARIANT | vntName,
 |  | VARIANT __RPC_FAR * | pvntVal
 | ) | [pure virtual]

HRESULT STDMETHODCALLTYPE get_State ( long __RPC_FAR * plVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_TableName | ( | long | lIndex,
 |  | BSTR __RPC_FAR * | pbstrVal
 | ) | [pure virtual]

HRESULT STDMETHODCALLTYPE get_Tag ( VARIANT __RPC_FAR * pvntVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE ICaoSQLController_AddItem_Proxy | ( | ICaoSQLController __RPC_FAR * | This,
 |  | VARIANT | vntDataArray
 | ) |

void __RPC_STUB ICaoSQLController_AddItem_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_Execute_Proxy | ( | ICaoSQLController __RPC_FAR * | This,
 |  | BSTR | bstrCommand,
 |  | VARIANT | vntParam,
 |  | VARIANT __RPC_FAR * | pvntVal
 | ) |

void __RPC_STUB ICaoSQLController_Execute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_get__NewEnum_Proxy | ( | ICaoSQLController __RPC_FAR * | This,
 |  | LPUNKNOWN __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoSQLController_get__NewEnum_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_get_Count_Proxy | ( | ICaoSQLController __RPC_FAR * | This,
 |  | long __RPC_FAR * | plVal
 | ) |

void __RPC_STUB ICaoSQLController_get_Count_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_get_Description_Proxy | ( | ICaoSQLController __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pbstrVal
 | ) |

void __RPC_STUB ICaoSQLController_get_Description_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_get_Index_Proxy | ( | ICaoSQLController __RPC_FAR * | This,
 |  | long __RPC_FAR * | plVal
 | ) |

void __RPC_STUB ICaoSQLController_get_Index_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_get_Item_Proxy | ( | ICaoSQLController __RPC_FAR * | This,
 |  | VARIANT | vntIndex,
 |  | ICaoSQLItem __RPC_FAR *__RPC_FAR * | ppICSItem
 | ) |

void __RPC_STUB ICaoSQLController_get_Item_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_get_ItemNames_Proxy | ( | ICaoSQLController __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pvntVal
 | ) |

void __RPC_STUB ICaoSQLController_get_ItemNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_get_Name_Proxy | ( | ICaoSQLController __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pbstrVal
 | ) |

void __RPC_STUB ICaoSQLController_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_get_ScanTimes_Proxy | ( | ICaoSQLController __RPC_FAR * | This,
 |  | long | lIndex,
 |  | long __RPC_FAR * | plVal
 | ) |

void __RPC_STUB ICaoSQLController_get_ScanTimes_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_get_SettingData_Proxy | ( | ICaoSQLController __RPC_FAR * | This,
 |  | VARIANT | vntName,
 |  | VARIANT __RPC_FAR * | pvntVal
 | ) |

void __RPC_STUB ICaoSQLController_get_SettingData_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_get_State_Proxy | ( | ICaoSQLController __RPC_FAR * | This,
 |  | long __RPC_FAR * | plVal
 | ) |

void __RPC_STUB ICaoSQLController_get_State_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_get_Tag_Proxy | ( | ICaoSQLController __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pvntVal
 | ) |

void __RPC_STUB ICaoSQLController_get_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_put_SettingData_Proxy | ( | ICaoSQLController __RPC_FAR * | This,
 |  | VARIANT | vntName,
 |  | VARIANT | vntNewVal
 | ) |

void __RPC_STUB ICaoSQLController_put_SettingData_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_put_Tag_Proxy | ( | ICaoSQLController __RPC_FAR * | This,
 |  | VARIANT | vntNewVal
 | ) |

void __RPC_STUB ICaoSQLController_put_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_RemoveItem_Proxy | ( | ICaoSQLController __RPC_FAR * | This,
 |  | VARIANT | vntIndex
 | ) |

void __RPC_STUB ICaoSQLController_RemoveItem_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_Snapshot_Proxy ( ICaoSQLController __RPC_FAR * This )

void __RPC_STUB ICaoSQLController_Snapshot_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_Start_Proxy ( ICaoSQLController __RPC_FAR * This )

void __RPC_STUB ICaoSQLController_Start_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLController_Stop_Proxy ( ICaoSQLController __RPC_FAR * This )

void __RPC_STUB ICaoSQLController_Stop_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLEngine_Execute_Proxy | ( | ICaoSQLEngine __RPC_FAR * | This,
 |  | BSTR | bstrCmdText,
 |  | VARIANT __RPC_FAR * | pvntVal
 | ) |

void __RPC_STUB ICaoSQLEngine_Execute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLEngine_get__NewEnum_Proxy | ( | ICaoSQLEngine __RPC_FAR * | This,
 |  | LPUNKNOWN __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoSQLEngine_get__NewEnum_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLEngine_get_CaoSQLHistory_Proxy | ( | ICaoSQLEngine __RPC_FAR * | This,
 |  | ICaoSQLHistory __RPC_FAR *__RPC_FAR * | ppICSHstry
 | ) |

void __RPC_STUB ICaoSQLEngine_get_CaoSQLHistory_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLEngine_get_Controller_Proxy | ( | ICaoSQLEngine __RPC_FAR * | This,
 |  | VARIANT | vntIndex,
 |  | ICaoSQLController __RPC_FAR *__RPC_FAR * | ppICSCtrl
 | ) |

void __RPC_STUB ICaoSQLEngine_get_Controller_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLEngine_get_ControllerNames_Proxy | ( | ICaoSQLEngine __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pvntVal
 | ) |

void __RPC_STUB ICaoSQLEngine_get_ControllerNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLEngine_get_Count_Proxy | ( | ICaoSQLEngine __RPC_FAR * | This,
 |  | long __RPC_FAR * | plVal
 | ) |

void __RPC_STUB ICaoSQLEngine_get_Count_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLEngine_Snapshot_Proxy ( ICaoSQLEngine __RPC_FAR * This )

void __RPC_STUB ICaoSQLEngine_Snapshot_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLEngine_Start_Proxy ( ICaoSQLEngine __RPC_FAR * This )

void __RPC_STUB ICaoSQLEngine_Start_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLEngine_Stop_Proxy ( ICaoSQLEngine __RPC_FAR * This )

void __RPC_STUB ICaoSQLEngine_Stop_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLHistory_Execute_Proxy | ( | ICaoSQLHistory __RPC_FAR * | This,
 |  | BSTR | bstrCmdText,
 |  | VARIANT __RPC_FAR * | pvntVal
 | ) |

void __RPC_STUB ICaoSQLHistory_Execute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLHistory_get_ConnectionString_Proxy | ( | ICaoSQLHistory __RPC_FAR * | This,
 |  | long | lIndex,
 |  | BSTR __RPC_FAR * | pbstrVal
 | ) |

void __RPC_STUB ICaoSQLHistory_get_ConnectionString_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLHistory_get_Enable_Proxy | ( | ICaoSQLHistory __RPC_FAR * | This,
 |  | VARIANT_BOOL __RPC_FAR * | pbVal
 | ) |

void __RPC_STUB ICaoSQLHistory_get_Enable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLHistory_get_MaxRecord_Proxy | ( | ICaoSQLHistory __RPC_FAR * | This,
 |  | long | lIndex,
 |  | long __RPC_FAR * | plVal
 | ) |

void __RPC_STUB ICaoSQLHistory_get_MaxRecord_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLHistory_get_TableName_Proxy | ( | ICaoSQLHistory __RPC_FAR * | This,
 |  | long | lIndex,
 |  | BSTR __RPC_FAR * | pbstrVal
 | ) |

void __RPC_STUB ICaoSQLHistory_get_TableName_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Activation_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | VARIANT_BOOL __RPC_FAR * | pbVal
 | ) |

void __RPC_STUB ICaoSQLItem_get_Activation_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Attribute_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | long __RPC_FAR * | plVal
 | ) |

void __RPC_STUB ICaoSQLItem_get_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_DateTime_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pvntVal
 | ) |

void __RPC_STUB ICaoSQLItem_get_DateTime_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Description_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pbstrVal
 | ) |

void __RPC_STUB ICaoSQLItem_get_Description_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Element_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | long | lIndex1,
 |  | long | lIndex2,
 |  | long | lIndex3,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoSQLItem_get_Element_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_ID_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoSQLItem_get_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Index_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | long __RPC_FAR * | plVal
 | ) |

void __RPC_STUB ICaoSQLItem_get_Index_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_LinkActivation_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | VARIANT_BOOL __RPC_FAR * | pbVal
 | ) |

void __RPC_STUB ICaoSQLItem_get_LinkActivation_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_LinkItemNames_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pvntVal
 | ) |

void __RPC_STUB ICaoSQLItem_get_LinkItemNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Microsecond_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | long __RPC_FAR * | plVal
 | ) |

void __RPC_STUB ICaoSQLItem_get_Microsecond_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Name_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pbstrVal
 | ) |

void __RPC_STUB ICaoSQLItem_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_SettingData_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | VARIANT | vntName,
 |  | VARIANT __RPC_FAR * | pvntVal
 | ) |

void __RPC_STUB ICaoSQLItem_get_SettingData_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_State_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | long __RPC_FAR * | plVal
 | ) |

void __RPC_STUB ICaoSQLItem_get_State_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Tag_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pvntVal
 | ) |

void __RPC_STUB ICaoSQLItem_get_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Value_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pvntVal
 | ) |

void __RPC_STUB ICaoSQLItem_get_Value_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_put_Activation_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | VARIANT_BOOL | bNewVal
 | ) |

void __RPC_STUB ICaoSQLItem_put_Activation_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_put_Element_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | long | lIndex1,
 |  | long | lIndex2,
 |  | long | lIndex3,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoSQLItem_put_Element_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_put_ID_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoSQLItem_put_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_put_LinkActivation_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | VARIANT_BOOL | bNewVal
 | ) |

void __RPC_STUB ICaoSQLItem_put_LinkActivation_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_put_SettingData_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | VARIANT | vntName,
 |  | VARIANT | vntNewVal
 | ) |

void __RPC_STUB ICaoSQLItem_put_SettingData_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_put_Tag_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | VARIANT | vntNewVal
 | ) |

void __RPC_STUB ICaoSQLItem_put_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_put_Value_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | VARIANT | vntNewVal
 | ) |

void __RPC_STUB ICaoSQLItem_put_Value_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_put_ValueEx_Proxy | ( | ICaoSQLItem __RPC_FAR * | This,
 |  | long | lDelay,
 |  | VARIANT | vntNewVal
 | ) |

void __RPC_STUB ICaoSQLItem_put_ValueEx_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoSQLItem_Snapshot_Proxy ( ICaoSQLItem __RPC_FAR * This )

void __RPC_STUB ICaoSQLItem_Snapshot_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRACEventSink_OnMessage_Proxy | ( | IRACEventSink __RPC_FAR * | This,
 |  | IUnknown __RPC_FAR * | pIVal
 | ) |

void __RPC_STUB IRACEventSink_OnMessage_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

void __RPC_FAR* __RPC_USER MIDL_user_allocate ( size_t )

void __RPC_USER MIDL_user_free ( void __RPC_FAR * )

virtual HRESULT STDMETHODCALLTYPE put_Activation ( VARIANT_BOOL bNewVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_Element | ( | long | lIndex1,
 |  | long | lIndex2,
 |  | long | lIndex3,
 |  | VARIANT | newVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_ID ( VARIANT newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_LinkActivation ( VARIANT_BOOL bNewVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE put_SettingData | ( | VARIANT | vntName,
 |  | VARIANT | vntNewVal
 | ) | [pure virtual]

HRESULT STDMETHODCALLTYPE put_Tag ( VARIANT vntNewVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_Value ( VARIANT vntNewVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_ValueEx | ( | long | lDelay,
 |  | VARIANT | vntNewVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE RemoveItem ( VARIANT vntIndex ) [pure virtual]

HRESULT STDMETHODCALLTYPE Snapshot ( void ) [pure virtual]

HRESULT STDMETHODCALLTYPE Start ( void ) [pure virtual]

HRESULT STDMETHODCALLTYPE Stop ( void ) [pure virtual]

void __RPC_USER VARIANT_UserFree | ( | unsigned long __RPC_FAR * | ,
 |  | VARIANT __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER VARIANT_UserMarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | VARIANT __RPC_FAR * |
 | ) |

unsigned long __RPC_USER VARIANT_UserSize | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned | long,
 |  | VARIANT __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER VARIANT_UserUnmarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | VARIANT __RPC_FAR * |
 | ) |

変数の解説

RPC_IF_HANDLE __MIDL_itf_CaoSQL_0000_v0_0_c_ifspec

RPC_IF_HANDLE __MIDL_itf_CaoSQL_0000_v0_0_s_ifspec

ICaoSQLEngine __pad0__

ICaoSQLController __pad1__

ICaoSQLItem __pad2__

ICaoSQLHistory __pad3__

IRACEventSink __pad4__

_ICaoSQLControllerEvents __pad5__

IRACSever __pad6__

EXTERN_C const CLSID CLSID_CaoSQLController

EXTERN_C const CLSID CLSID_CaoSQLEngine

EXTERN_C const CLSID CLSID_CaoSQLHistory

EXTERN_C const CLSID CLSID_CaoSQLItem

EXTERN_C const CLSID CLSID_RACEventSink

EXTERN_C const IID DIID__ICaoSQLControllerEvents

EXTERN_C const IID IID_ICaoSQLController

EXTERN_C const IID IID_ICaoSQLEngine

EXTERN_C const IID IID_ICaoSQLHistory

EXTERN_C const IID IID_ICaoSQLItem

EXTERN_C const IID IID_IRACEventSink

EXTERN_C const IID IID_IRACSever

EXTERN_C const IID LIBID_CaoSQLLib

ICaoSQLHistory VARIANT __RPC_FAR* pvntVal = 0

Generated on Tue Dec 13 12:25:25 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQL.idl File Reference

CaoSQL.idl の解説

CaoSQL.exe 用の IDL ソース ファイル. [詳細]

ソースコードを見る。

名前空間

namespace | CaoSQLLib

構成

interface | ICaoSQLController
ICaoSQLController Interface. [詳細]

interface | ICaoSQLEngine
ICaoSQLEngine Interface. [詳細]

interface | ICaoSQLHistory
ICaoSQLHistory Interface. [詳細]

interface | ICaoSQLItem
ICaoSQLItem Interface. [詳細]

interface | IRACEventSink

Typedef

typedef enum enmCaoVariableClass | _enmCaoVariableClass
CaoSQL VariableClass Enumration.

typedef enum enmCaoSQLCtrlState | _enmCaoSQLCtrlState
CaoSQL Controller State Enumration.

typedef enum enmCaoSQLCtrlScantime | _enmCaoSQLCtrlScantime
CaoSQL Controller ScanTime Enumration.

typedef enum enmCaoSQLItemState | _enmCaoSQLItemState
CaoSQL Item State Enumration.

typedef enum enmCaoSQLItemAttribute | _enmCaoSQLItemAttribute
CaoSQL Item Attribute Enumration.

Enum

enum | enmCaoVariableClass { csVarClassController = 0, csVarClassTask = 1, csVarClassRobot = 2, csVarClassExtension = 3 }
CaoSQL VariableClass Enumration. [詳細]

enum enmCaoSQLCtrlState {
csCtrlThreadUninit = 0x0000, csCtrlThreadActive = 0x0001, csCtrlThreadDeactive = 0x0002, csCtrlThreadError = 0x0003,
csCtrlThreadTerminated = 0x0004
}
CaoSQL Controller State Enumration. [詳細]

enum | enmCaoSQLCtrlScantime { csCtrlScantimeLast = 0x0000, csCtrlScantimeMin = 0x0001, csCtrlScantimeMax = 0x0002 }
CaoSQL Controller ScanTime Enumration. [詳細]

enum | enmCaoSQLItemState { csItemSucceeded = 0x0000, csItemFailed = 0x0001, csItemUndefined = 0x0002 }
CaoSQL Item State Enumration. [詳細]

enum | enmCaoSQLItemAttribute { csItemReadWrite = 0x0000, csItemReadOnly = 0x0001, csItemWriteOnly = 0x0002 }
CaoSQL Item Attribute Enumration. [詳細]

解説

CaoSQL.exe 用の IDL ソース ファイル.

このファイルはタイプ ライブラリ (CaoSQL.tlb) を作成するために タイプ ライブラリ作成ツール MIDL によって処理されます。

バージョン:
1.0
日付:
Wed May 8 16:10:16 2002
作者:
DENSO WAVE

Typedef の解説

typedef enum enmCaoSQLCtrlScantime _enmCaoSQLCtrlScantime

CaoSQL Controller ScanTime Enumration.

typedef enum enmCaoSQLCtrlState _enmCaoSQLCtrlState

CaoSQL Controller State Enumration.

typedef enum enmCaoSQLItemAttribute _enmCaoSQLItemAttribute

CaoSQL Item Attribute Enumration.

typedef enum enmCaoSQLItemState _enmCaoSQLItemState

CaoSQL Item State Enumration.

typedef enum enmCaoVariableClass _enmCaoVariableClass

CaoSQL VariableClass Enumration.

Enum の解説

enum enmCaoSQLCtrlScantime

CaoSQL Controller ScanTime Enumration.

Enum 値:
csCtrlScantimeLast | 現在のスキャン時間
csCtrlScantimeMin | 最短スキャン時間
csCtrlScantimeMax | 最長スキャン時間

enum enmCaoSQLCtrlState

CaoSQL Controller State Enumration.

Enum 値:
csCtrlThreadUninit | スレッド状態 [未初期化]
csCtrlThreadActive | スレッド状態 [アクティブ]
csCtrlThreadDeactive | スレッド状態 [ディアクティブ]
csCtrlThreadError | スレッド状態 [エラー]
csCtrlThreadTerminated | スレッド状態 [終了]

enum enmCaoSQLItemAttribute

CaoSQL Item Attribute Enumration.

Enum 値:
csItemReadWrite | アイテムは読み取り/書き込み属性
csItemReadOnly | アイテムは読み取り専用属性
csItemWriteOnly | アイテムは書き込み専用属性

enum enmCaoSQLItemState

CaoSQL Item State Enumration.

Enum 値:
csItemSucceeded | アイテムの値取得/設定は成功しました
csItemFailed | アイテムの値取得/設定は失敗しました
csItemUndefined | アイテムの値取得/設定は不定です

enum enmCaoVariableClass

CaoSQL VariableClass Enumration.

Enum 値:
csVarClassController | コントローラクラスの変数
csVarClassTask | タスククラスの変数
csVarClassRobot | ロボットクラスの変数
csVarClassExtension | 拡張ボードクラスの変数

Generated on Tue Dec 13 12:25:26 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQL_i.c File Reference

CaoSQL_i.c の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

構成

struct | _IID

Typedef

typedef _IID | IID
typedef IID | CLSID

変数

const IID | IID_ICaoSQLEngine = {0x82353932,0x2585,0x4f53,{0x94,0x12,0x58,0x58,0xD1,0xB9,0xDF,0xE0}}
const IID | IID_ICaoSQLController = {0x1C61BAA2,0x7E70,0x44e9,{0x81,0x60,0xEB,0x34,0x9E,0xD2,0xC0,0xD8}}
const IID | IID_ICaoSQLItem = {0xA49597A1,0x5DF3,0x4c09,{0x93,0x39,0x3F,0xFF,0x80,0xA6,0xB6,0x9F}}
const IID | IID_ICaoSQLHistory = {0x48697BDE,0x1C16,0x4629,{0xB5,0xE3,0xD8,0xB8,0xC4,0x00,0x0F,0xBF}}
const IID | IID_IRACEventSink = {0x1AA6DA40,0x2799,0x43b3,{0x89,0x0D,0x99,0xE2,0x1D,0x89,0x8B,0x97}}
const IID | LIBID_CaoSQLLib = {0xFCBF9FC1,0x2FD5,0x4668,{0xBA,0x36,0x85,0x8D,0x9B,0x7D,0x80,0x82}}
const CLSID | CLSID_CaoSQLEngine = {0x95615A16,0xA369,0x4937,{0xA8,0xF9,0xB3,0xA9,0x09,0xE9,0xC5,0xCE}}
const IID | DIID__ICaoSQLControllerEvents = {0xB6E12C86,0x10B8,0x459e,{0xA2,0x9D,0xE5,0x41,0x99,0x88,0x5E,0xC6}}
const IID | IID_IRACSever = {0x3253EA5F,0x90F2,0x4DB1,{0xB4,0x49,0x47,0x67,0xF8,0xED,0xF8,0x2F}}
const CLSID | CLSID_CaoSQLController = {0x54A724F0,0x70FF,0x4e2d,{0xBC,0x81,0xAD,0xEE,0x8A,0xD3,0x46,0x82}}
const CLSID | CLSID_CaoSQLItem = {0xB5A90BCB,0x508F,0x462e,{0xB7,0x14,0xBA,0xEB,0x10,0x6A,0x51,0x00}}
const CLSID | CLSID_CaoSQLHistory = {0x495F2699,0x4037,0x4fd7,{0xA4,0x44,0xF6,0x6A,0x77,0xDB,0x66,0x10}}
const CLSID | CLSID_RACEventSink = {0xBC7F2ADB,0xE49A,0x4f9e,{0x9B,0x57,0x82,0x2A,0xF4,0xCA,0x3D,0x32}}

Typedef の解説

typedef IID CLSID

typedef struct _IID IID

変数の解説

const CLSID CLSID_CaoSQLController = {0x54A724F0,0x70FF,0x4e2d,{0xBC,0x81,0xAD,0xEE,0x8A,0xD3,0x46,0x82}}

const CLSID CLSID_CaoSQLEngine = {0x95615A16,0xA369,0x4937,{0xA8,0xF9,0xB3,0xA9,0x09,0xE9,0xC5,0xCE}}

const CLSID CLSID_CaoSQLHistory = {0x495F2699,0x4037,0x4fd7,{0xA4,0x44,0xF6,0x6A,0x77,0xDB,0x66,0x10}}

const CLSID CLSID_CaoSQLItem = {0xB5A90BCB,0x508F,0x462e,{0xB7,0x14,0xBA,0xEB,0x10,0x6A,0x51,0x00}}

const CLSID CLSID_RACEventSink = {0xBC7F2ADB,0xE49A,0x4f9e,{0x9B,0x57,0x82,0x2A,0xF4,0xCA,0x3D,0x32}}

const IID DIID__ICaoSQLControllerEvents = {0xB6E12C86,0x10B8,0x459e,{0xA2,0x9D,0xE5,0x41,0x99,0x88,0x5E,0xC6}}

const IID IID_ICaoSQLController = {0x1C61BAA2,0x7E70,0x44e9,{0x81,0x60,0xEB,0x34,0x9E,0xD2,0xC0,0xD8}}

const IID IID_ICaoSQLEngine = {0x82353932,0x2585,0x4f53,{0x94,0x12,0x58,0x58,0xD1,0xB9,0xDF,0xE0}}

const IID IID_ICaoSQLHistory = {0x48697BDE,0x1C16,0x4629,{0xB5,0xE3,0xD8,0xB8,0xC4,0x00,0x0F,0xBF}}

const IID IID_ICaoSQLItem = {0xA49597A1,0x5DF3,0x4c09,{0x93,0x39,0x3F,0xFF,0x80,0xA6,0xB6,0x9F}}

const IID IID_IRACEventSink = {0x1AA6DA40,0x2799,0x43b3,{0x89,0x0D,0x99,0xE2,0x1D,0x89,0x8B,0x97}}

const IID IID_IRACSever = {0x3253EA5F,0x90F2,0x4DB1,{0xB4,0x49,0x47,0x67,0xF8,0xED,0xF8,0x2F}}

const IID LIBID_CaoSQLLib = {0xFCBF9FC1,0x2FD5,0x4668,{0xBA,0x36,0x85,0x8D,0x9B,0x7D,0x80,0x82}}

Generated on Tue Dec 13 12:25:26 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQL_p.c File Reference

CaoSQL_p.c の解説

#include "rpcproxy.h"
#include "CaoSQL.h"

CaoSQL_p.cのインクルード依存関係図

Include dependency graph

構成

struct | _MIDL_PROC_FORMAT_STRING
struct | _MIDL_TYPE_FORMAT_STRING

マクロ定義

#define | USE_STUBLESS_PROXY
#define | __REQUIRED_RPCPROXY_H_VERSION__ 440
#define | TYPE_FORMAT_STRING_SIZE 1095
#define | PROC_FORMAT_STRING_SIZE 1509

Typedef

typedef _MIDL_TYPE_FORMAT_STRING | MIDL_TYPE_FORMAT_STRING
typedef _MIDL_PROC_FORMAT_STRING | MIDL_PROC_FORMAT_STRING

関数

CINTERFACE_PROXY_VTABLE (16) _ICaoSQLEngineProxyVtbl=

変数

const MIDL_TYPE_FORMAT_STRING | __MIDL_TypeFormatString
const MIDL_PROC_FORMAT_STRING | __MIDL_ProcFormatString
const MIDL_STUB_DESC | Object_StubDesc
const MIDL_SERVER_INFO | ICaoSQLEngine_ServerInfo
const unsigned short | ICaoSQLEngine_FormatStringOffsetTable []
const MIDL_STUBLESS_PROXY_INFO | ICaoSQLEngine_ProxyInfo

マクロ定義の解説

#define __REQUIRED_RPCPROXY_H_VERSION__ 440

#define PROC_FORMAT_STRING_SIZE 1509

#define TYPE_FORMAT_STRING_SIZE 1095

#define USE_STUBLESS_PROXY

Typedef の解説

typedef struct _MIDL_PROC_FORMAT_STRING MIDL_PROC_FORMAT_STRING

typedef struct _MIDL_TYPE_FORMAT_STRING MIDL_TYPE_FORMAT_STRING

関数の解説

CINTERFACE_PROXY_VTABLE ( 16 )

変数の解説

const MIDL_PROC_FORMAT_STRING __MIDL_ProcFormatString

const MIDL_TYPE_FORMAT_STRING __MIDL_TypeFormatString

const unsigned short ICaoSQLEngine_FormatStringOffsetTable[] [static]

初期値:

    {
    (unsigned short) -1,
    (unsigned short) -1,
    (unsigned short) -1,
    (unsigned short) -1,
    0,
    28,
    62,
    84,
    106,
    128,
    162,
    190,
    218
    }

const MIDL_STUBLESS_PROXY_INFO ICaoSQLEngine_ProxyInfo [static]

初期値:

    {
    &Object_StubDesc,
    __MIDL_ProcFormatString.Format,
    &ICaoSQLEngine_FormatStringOffsetTable[-3],
    0,
    0,
    0
    }

const MIDL_SERVER_INFO ICaoSQLEngine_ServerInfo

初期値:

    {
    &Object_StubDesc,
    0,
    __MIDL_ProcFormatString.Format,
    &ICaoSQLEngine_FormatStringOffsetTable[-3],
    0,
    0,
    0,
    0
    }

const MIDL_STUB_DESC Object_StubDesc

Generated on Tue Dec 13 12:25:26 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLAdviser.cpp File Reference

CaoSQLAdviser.cpp の解説

CCaoSQLAdviser クラスのインプリメンテーション. [詳細]

#include "stdafx.h"
#include "CaoSQLAdviser.h"
#include "CaoSQLObserver.h"

CaoSQLAdviser.cppのインクルード依存関係図

Include dependency graph

解説

CCaoSQLAdviser クラスのインプリメンテーション.

バージョン:
1.0
日付:
Fri May 31 10:49:55 2002
作者:
DENSO WAVE
Generated on Tue Dec 13 12:25:26 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLAdviser.h File Reference

CaoSQLAdviser.h の解説

CCaoSQLAdviser クラスのインターフェイス. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaoSQLAdviser
CCaoSQLAdviserクラス. [詳細]

マクロ定義

#define | AFX_CaoSQLADVISER_H__3C38D8B6_4413_4E45_8C64_E82E3AA4C5FC__INCLUDED_

Typedef

typedef std::vector< CCaoSQLObserver * > | VEC_OBSVS

解説

CCaoSQLAdviser クラスのインターフェイス.

バージョン:
1.0
日付:
Thu May 16 10:29:10 2002
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CaoSQLADVISER_H__3C38D8B6_4413_4E45_8C64_E82E3AA4C5FC__INCLUDED_

Typedef の解説

typedef std::vector<CCaoSQLObserver *> VEC_OBSVS

Generated on Tue Dec 13 12:25:26 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLCalcItem.cpp File Reference

CaoSQLCalcItem.cpp の解説

#include "stdafx.h"
#include "CaoSQL.h"
#include "CaoSQLCalcItem.h"
#include "CaoSQLEngineMan.h"
#include "CaoSQLController.h"
#include "CaoSQLItem.h"

CaoSQLCalcItem.cppのインクルード依存関係図

Include dependency graph
Generated on Tue Dec 13 12:25:27 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLCalcItem.h File Reference

CaoSQLCalcItem.h の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaoSQLCalcItem

マクロ定義

#define | AFX_CaoSQLCALCITEM_H__E1C734F8_9F5E_4A54_A143_008BC18C49F5__INCLUDED_

マクロ定義の解説

#define AFX_CaoSQLCALCITEM_H__E1C734F8_9F5E_4A54_A143_008BC18C49F5__INCLUDED_

Generated on Tue Dec 13 12:25:27 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLController.cpp File Reference

CaoSQLController.cpp の解説

CCaoSQLControllerのインプリメンテーション. [詳細]

#include "stdafx.h"
#include "CaoSQLController.h"
#include "CaoSQLEngineMan.h"
#include "CaoSQLItem.h"
#include "CaoSQLTriggerObserver.h"
#include "CaoSQLHistoryMan.h"
#include "DDEServer.h"

CaoSQLController.cppのインクルード依存関係図

Include dependency graph

変数

const VARTYPE PARAM_TYPE [14] = { VT_BOOL, VT_I1, VT_UI1, VT_I2, VT_UI2, VT_I4, VT_UI4, VT_R4, VT_R8, VT_BSTR, VT_DATE, VT_CY, VT_EMPTY, VT_NULL }

解説

CCaoSQLControllerのインプリメンテーション.

バージョン:
1.0
日付:
Tue Jun 4 14:59:03 2002
作者:
DENSO WAVE

変数の解説

const VARTYPE PARAM_TYPE[14] = { VT_BOOL, VT_I1, VT_UI1, VT_I2, VT_UI2, VT_I4, VT_UI4, VT_R4, VT_R8, VT_BSTR, VT_DATE, VT_CY, VT_EMPTY, VT_NULL }

Generated on Tue Dec 13 12:25:27 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLController.h File Reference

CaoSQLController.h の解説

CCaoSQLController の宣言. [詳細]

#include "resource.h"
#include "CaoSQLCP.h"

CaoSQLController.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaoSQLController
CaoSQLのControllerクラス. [詳細]

Typedef

typedef std::vector< CCaoSQLTriggerObserver * > | VEC_TRIGGEROVSV
トリガ情報のベクタ

typedef std::vector< CCaoSQLItem * > | VEC_CSITEM
typedef enum enmCaoSQLSysInfoId | _enmCaoSQLSysInfoId

Enum

enum | enmCaoSQLSysInfoId { csSysInfoStart = 0, csSysInfoStop = 1, csSysInfoBegin = 2, csSysInfoEnd = 3 }

解説

CCaoSQLController の宣言.

バージョン:
1.0
日付:
Tue Jun 4 14:59:05 2002
作者:
DENSO WAVE

Typedef の解説

typedef enum enmCaoSQLSysInfoId _enmCaoSQLSysInfoId

typedef std::vector<CCaoSQLItem *> VEC_CSITEM

typedef std::vector<CCaoSQLTriggerObserver *> VEC_TRIGGEROVSV

トリガ情報のベクタ

Enum の解説

enum enmCaoSQLSysInfoId

Enum 値:
csSysInfoStart
csSysInfoStop
csSysInfoBegin
csSysInfoEnd

Generated on Tue Dec 13 12:25:27 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLCP.h File Reference

CaoSQLCP.h の解説

CProxy_ICaoSQLEvents の宣言. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CProxy_ICaoSQLEvents
CaoSQLのイベントプロキシテンプレートクラス. [詳細]

解説

CProxy_ICaoSQLEvents の宣言.

バージョン:
1.0
日付:
Thu May 30 14:24:41 2002
作者:
DENSO WAVE
Generated on Tue Dec 13 12:25:27 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLData.h File Reference

CaoSQLData.h の解説

CaoSQLで使用されるデータの宣言. [詳細]

#include "CaoSQL.h"
#include <map>
#include <vector>

CaoSQLData.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

マクロ定義

#define | CSQ_C_NULL_CHAR L'\0'
#define | CSQ_REG_ROOT HKEY_CLASSES_ROOT
レジストリ保存場所のルート

#define | CSQ_KEY_NAME _T("SoftWare\\CaoSQL")
レジストリ保存場所へのパス

#define | CSQ_MAX_BUFFER 1024
wsprintfの扱える最大サイズ

#define | CSQ_SLEEPTIME 10
停止の最小時間

#define | SIZEOFARRAY(array) (sizeof(array)/sizeof(array[0]))
配列のサイズを調べる

#define | BSTR_TO_BOOL(bstr, b) { if (wcsicmp(bstr, L"true") == 0) { b = true; } else if (wcsicmp(bstr, L"false") == 0) { b = false; } }
BSTR→boolにし、bに格納.

#define | VARIANT_TO_BSTR(in, out) { if ((in.vt == VT_BSTR) && (in.bstrVal != NULL)) { out = SysAllocString(in.bstrVal); } }
VARIANT型のBSTRをBSTR型にコピー.

#define | VARIANT_TO_BOOL(in, out) { if (in.vt == VT_BOOL) { if (in.boolVal == VARIANT_TRUE) { out = true; } else { out = false; } } }
VARIANT型のBOOLをbool型にコピー.

#define | CSQ_THREAD_START_TIMEOUT 3000
スレッド開始タイムアウト

#define | CSQ_THREAD_END_TIMEOUT 3000
スレッド停止タイムアウト

#define | CSQ_RETRY_INTVL_DEFAULT 3000
リトライデフォルト間隔

#define | CSQ_EVENT_MAX 1000
OnChangeイベントの最大プール数.

#define | CSQ_CFG_CTRL_NAME 0
コントローラ名

#define | CSQ_CFG_CTRL_PROV 1
プロバイダ名

#define | CSQ_CFG_CTRL_MACH 2
マシン名

#define | CSQ_CFG_CTRL_OPT 3
オプション

#define | CSQ_CFG_CTRL_HIST 4
UseHistory.

#define | CSQ_CFG_CTRL_CACHE 5
WriteToCache.

#define | CSQ_CFG_CTRL_TIMESTAMP 6
TimeStamp.

#define | CSQ_CFG_CTRL_SAMPRATE 7
Samplig Time.

#define | CSQ_TIMESTAMP_NA 0
TimeStamp (n/a).

#define | CSQ_TIMESTAMP_DEVICE 1
TimeStamp DEVICE.

#define | CSQ_TIMESTAMP_LOCAL 2
TimeStamp LOCAL.

#define | CSQ_TIMESTAMP_SYSTEM 3
TimeStamp SYSTEM.

#define | CSQ_WDT_DEFAULT 3
WatchdogTimer Default.

#define | CSQ_WDT_ACTION_NOACTION 0
WatchdogTimer Action:NoAction.

#define | CSQ_WDT_ACTION_STOP 1
WatchdogTimer Action:Atop.

#define | CSQ_DLMTR_S_YEN L"\\"
デリミタ文字列："<Controller><Item>"の様に使用する

#define | CSQ_DLMTR_S_COMMA L","
デミリタ文字列："<Item>,<Item>"の様に使用する

#define | CSQ_DLMTR_C_YEN L'\\'
デリミタ文字："<Controller><Item>"の様に使用する

#define | CSQ_DLMTR_C_COMMA L','
デミリタ文字："<Item>,<Item>"の様に使用する

#define | CSQ_CACHE_OPT_NOEVENT 1
_CacheValue() オプション

#define | CSQ_FORCETOCHANGE_READING 1
ForceToChange オプション (at the time of Reading).

#define | CSQ_FORCETOCHANGE_WRITING 2
ForceToChange オプション (at the time of Writing).

#define | CSQ_SETTINGDATA_ITEM_VAR_NAME 0
#define | CSQ_SETTINGDATA_ITEM_OPTION 1
#define | CSQ_SETTINGDATA_ITEM_CLASS 2
#define | CSQ_SETTINGDATA_ITEM_OBJECT_NAME 3
#define | CSQ_CFG_ITEM_NAME 0
#define | CSQ_CFG_ITEM_VAR_ENABLED 1
#define | CSQ_CFG_ITEM_VAR_NAME 2
#define | CSQ_CFG_ITEM_VAR_OPT 3
#define | CSQ_CFG_ITEM_VAR_CLS 4
#define | CSQ_CFG_ITEM_VAR_OBJ 5
#define | CSQ_CFG_ITEM_DESC 6
#define | CSQ_CFG_ITEM_ATTR 7
#define | CSQ_CFG_ITEM_LINK_ITEM 8
#define | CSQ_CFG_ITEM_INIT 9
#define | CSQ_CFG_ITEM_INIT_DATA 10
#define | CSQ_CFG_ITEM_INIT_DATA_TYPE 11
#define | CSQ_CFG_ITEM_USE_EMPTY 12
#define | CSQ_CFG_ITEM_USE_HSTRY 13
#define | CSQ_CFG_ITEM_ON_CNG_EVT 14
#define | CSQ_CFG_ITEM_FORCECHANGE 15
#define | CSQ_CFG_ITEM_DEADBAND 16
#define | CSQ_CFG_ITEM_DEADBAND_MIN 17
#define | CSQ_CFG_ITEM_DEADBAND_MAX 18
#define | CSQ_CFG_ITEM_MINMAX 19
#define | CSQ_CFG_ITEM_MINMAX_MIN 20
#define | CSQ_CFG_ITEM_MIXMAX_MAX 21
#define | CSQ_CFG_ITEM_MASK_ENABLED 22
#define | CSQ_CFG_ITEM_MASK 23
#define | CSQ_CFG_ITEM_BCD 24
#define | CSQ_CFG_ITEM_CALC_INDEX 25
#define | CSQ_CFG_ITEM_2NDITEM 26
#define | CSQ_CFG_ITEM_CHANGE_TYPE 27
#define | CSQ_CFG_ITEM_REQUEST 28
#define | CSQ_ADDITEM_BND 0
AddItemのデータ配列インデックス下限値.

#define | CSQ_ADDITEM_MAX 28
AddItemのデータ配列要素数.

#define | CSQ_HST_FLDNAME_CTRLNAME _T("controller_name")
CaoSQLHistoryが記録するフィールド.

#define | CSQ_HST_FLDNAME_ITEMNAME _T("item_name")
CaoSQLHistoryが記録するフィールド.

#define | CSQ_HST_FLDNAME_VALUE _T("item_value")
CaoSQLHistoryが記録するフィールド.

#define | CSQ_HST_FLDNAME_VARTYPE _T("item_vartype")
CaoSQLHistoryが記録するフィールド.

#define | CSQ_HST_FLDNAME_DATETIME _T("item_time")
CaoSQLHistoryが記録するフィールド.

#define | CSQ_HST_FLDNAME_MILLISEC _T("item_time_ms")
CaoSQLHistoryが記録するフィールド.

#define | CSQ_HST_FLDNAME_FLAGS _T("flags")
CaoSQLHistoryが記録するフィールド.

#define | CSQ_HST_IDX_INS_CTRLNAME 0
AddHistoryの引数インデックス.

#define | CSQ_HST_IDX_INS_ITEMNAME 1
AddHistoryの引数インデックス.

#define | CSQ_HST_IDX_INS_VALUE 2
AddHistoryの引数インデックス.

#define | CSQ_HST_IDX_INS_VARTYPE 3
AddHistoryの引数インデックス.

#define | CSQ_HST_IDX_INS_DATETIME 4
AddHistoryの引数インデックス.

#define | CSQ_HST_IDX_INS_TIME_MS 5
AddHistoryの引数インデックス.

#define | CSQ_HST_IDX_INS_FLAGS 6
AddHistoryの引数インデックス.

#define | CSQ_HST_IDX_UPD_VALUE 0
AddHistoryの引数インデックス.

#define | CSQ_HST_IDX_UPD_VARTYPE 1
AddHistoryの引数インデックス.

#define | CSQ_HST_IDX_UPD_DATETIME 2
AddHistoryの引数インデックス.

#define | CSQ_HST_IDX_UPD_TIME_MS 3
AddHistoryの引数インデックス.

#define | CSQ_HST_IDX_UPD_CTRLNAME 4
AddHistoryの引数インデックス.

#define | CSQ_HST_IDX_UPD_ITEMNAME 5
AddHistoryの引数インデックス.

#define | CSQ_HST_IDX_UPD_FLAGS 6
AddHistoryの引数インデックス.

#define | CSQ_HST_FLD_SIZE 7
AddHistoryの引数サイズ.

#define | CSQ_DDE_SERV_NAME _T("CaoSQL")
DDE Server名.

#define | CSQL_DDE_MAX_BUF 256
DDE StringHandleの最大文字列長.

#define | CSQ_DDE_MAX_DATA 1024
DDE DataHandleの最大サイズの指定.

#define | CSQ_WM_ADVREQ WM_APP + 1
DDE AdviseRequestをする.

#define | CSQ_TRG_CND_EQ 0L
トリガ条件式　"=="

#define | CSQ_TRG_CND_NE 1L
トリガ条件式　"!="

#define | CSQ_TRG_CND_LT 2L
トリガ条件式　"<"

#define | CSQ_TRG_CND_GT 3L
トリガ条件式　">"

#define | CSQ_TRG_CND_LE 4L
トリガ条件式　"<="

#define | CSQ_TRG_CND_GE 5L
トリガ条件式　">="

#define | CSQ_TRG_ACT_NO 0L
トリガアクション NoAction

#define | CSQ_TRG_ACT_START 1L
トリガアクション Start

#define | CSQ_TRG_ACT_STOP 2L
トリガアクション Stop

#define | CSQ_TRG_ACT_ONETIME 3L
トリガアクション 1回実行

#define | CSQ_TRG_CMD_START -1L
開始コマンド

#define | CSQ_TRG_CMD_STOP 0L
停止コマンド

#define | CSQ_TRG_CMD_ONETIME 1L
一回実行コマンド

#define | CSQ_DLMTR_C_COLON L':'
#define | CSQ_DLMTR_C_EXCLAM L'!'

Typedef

typedef unsigned | CSQ_THREADID
スレッドID

typedef unsigned(__stdcall * | CSQ_THREADFUNC )(LPVOID)
スレッドの関数型

typedef std::map< long, CCaoSQLController * > | MAP_CSCTRL
CaoSQLControllerのマップ.

typedef std::map< long, CCaoSQLItem * > | MAP_CSITEM
CaoSQLItemのマップ.

解説

CaoSQLで使用されるデータの宣言.

バージョン:
1.0
日付:
Thu May 30 14:05:52 2002
作者:
DENSO WAVE

マクロ定義の解説

#define BSTR_TO_BOOL | ( | bstr,
 |  | b | ) | { if (wcsicmp(bstr, L"true") == 0) { b = true; } else if (wcsicmp(bstr, L"false") == 0) { b = false; } }

BSTR→boolにし、bに格納.

#define CSQ_ADDITEM_BND 0

AddItemのデータ配列インデックス下限値.

#define CSQ_ADDITEM_MAX 28

AddItemのデータ配列要素数.

#define CSQ_C_NULL_CHAR L'\0'

#define CSQ_CACHE_OPT_NOEVENT 1

_CacheValue() オプション

#define CSQ_CFG_CTRL_CACHE 5

WriteToCache.

#define CSQ_CFG_CTRL_HIST 4

UseHistory.

#define CSQ_CFG_CTRL_MACH 2

マシン名

#define CSQ_CFG_CTRL_NAME 0

コントローラ名

#define CSQ_CFG_CTRL_OPT 3

オプション

#define CSQ_CFG_CTRL_PROV 1

プロバイダ名

#define CSQ_CFG_CTRL_SAMPRATE 7

Samplig Time.

#define CSQ_CFG_CTRL_TIMESTAMP 6

TimeStamp.

#define CSQ_CFG_ITEM_2NDITEM 26

#define CSQ_CFG_ITEM_ATTR 7

#define CSQ_CFG_ITEM_BCD 24

#define CSQ_CFG_ITEM_CALC_INDEX 25

#define CSQ_CFG_ITEM_CHANGE_TYPE 27

#define CSQ_CFG_ITEM_DEADBAND 16

#define CSQ_CFG_ITEM_DEADBAND_MAX 18

#define CSQ_CFG_ITEM_DEADBAND_MIN 17

#define CSQ_CFG_ITEM_DESC 6

#define CSQ_CFG_ITEM_FORCECHANGE 15

#define CSQ_CFG_ITEM_INIT 9

#define CSQ_CFG_ITEM_INIT_DATA 10

#define CSQ_CFG_ITEM_INIT_DATA_TYPE 11

#define CSQ_CFG_ITEM_LINK_ITEM 8

#define CSQ_CFG_ITEM_MASK 23

#define CSQ_CFG_ITEM_MASK_ENABLED 22

#define CSQ_CFG_ITEM_MINMAX 19

#define CSQ_CFG_ITEM_MINMAX_MIN 20

#define CSQ_CFG_ITEM_MIXMAX_MAX 21

#define CSQ_CFG_ITEM_NAME 0

#define CSQ_CFG_ITEM_ON_CNG_EVT 14

#define CSQ_CFG_ITEM_REQUEST 28

#define CSQ_CFG_ITEM_USE_EMPTY 12

#define CSQ_CFG_ITEM_USE_HSTRY 13

#define CSQ_CFG_ITEM_VAR_CLS 4

#define CSQ_CFG_ITEM_VAR_ENABLED 1

#define CSQ_CFG_ITEM_VAR_NAME 2

#define CSQ_CFG_ITEM_VAR_OBJ 5

#define CSQ_CFG_ITEM_VAR_OPT 3

#define CSQ_DDE_MAX_DATA 1024

DDE DataHandleの最大サイズの指定.

#define CSQ_DDE_SERV_NAME _T("CaoSQL")

DDE Server名.

#define CSQ_DLMTR_C_COLON L':'

#define CSQ_DLMTR_C_COMMA L','

デミリタ文字："<Item>,<Item>"の様に使用する

#define CSQ_DLMTR_C_EXCLAM L'!'

#define CSQ_DLMTR_C_YEN L'\\'

デリミタ文字："<Controller><Item>"の様に使用する

#define CSQ_DLMTR_S_COMMA L","

デミリタ文字列："<Item>,<Item>"の様に使用する

#define CSQ_DLMTR_S_YEN L"\\"

デリミタ文字列："<Controller><Item>"の様に使用する

#define CSQ_EVENT_MAX 1000

OnChangeイベントの最大プール数.

#define CSQ_FORCETOCHANGE_READING 1

ForceToChange オプション (at the time of Reading).

#define CSQ_FORCETOCHANGE_WRITING 2

ForceToChange オプション (at the time of Writing).

#define CSQ_HST_FLD_SIZE 7

AddHistoryの引数サイズ.

#define CSQ_HST_FLDNAME_CTRLNAME _T("controller_name")

CaoSQLHistoryが記録するフィールド.

#define CSQ_HST_FLDNAME_DATETIME _T("item_time")

CaoSQLHistoryが記録するフィールド.

#define CSQ_HST_FLDNAME_FLAGS _T("flags")

CaoSQLHistoryが記録するフィールド.

#define CSQ_HST_FLDNAME_ITEMNAME _T("item_name")

CaoSQLHistoryが記録するフィールド.

#define CSQ_HST_FLDNAME_MILLISEC _T("item_time_ms")

CaoSQLHistoryが記録するフィールド.

#define CSQ_HST_FLDNAME_VALUE _T("item_value")

CaoSQLHistoryが記録するフィールド.

#define CSQ_HST_FLDNAME_VARTYPE _T("item_vartype")

CaoSQLHistoryが記録するフィールド.

#define CSQ_HST_IDX_INS_CTRLNAME 0

AddHistoryの引数インデックス.

#define CSQ_HST_IDX_INS_DATETIME 4

AddHistoryの引数インデックス.

#define CSQ_HST_IDX_INS_FLAGS 6

AddHistoryの引数インデックス.

#define CSQ_HST_IDX_INS_ITEMNAME 1

AddHistoryの引数インデックス.

#define CSQ_HST_IDX_INS_TIME_MS 5

AddHistoryの引数インデックス.

#define CSQ_HST_IDX_INS_VALUE 2

AddHistoryの引数インデックス.

#define CSQ_HST_IDX_INS_VARTYPE 3

AddHistoryの引数インデックス.

#define CSQ_HST_IDX_UPD_CTRLNAME 4

AddHistoryの引数インデックス.

#define CSQ_HST_IDX_UPD_DATETIME 2

AddHistoryの引数インデックス.

#define CSQ_HST_IDX_UPD_FLAGS 6

AddHistoryの引数インデックス.

#define CSQ_HST_IDX_UPD_ITEMNAME 5

AddHistoryの引数インデックス.

#define CSQ_HST_IDX_UPD_TIME_MS 3

AddHistoryの引数インデックス.

#define CSQ_HST_IDX_UPD_VALUE 0

AddHistoryの引数インデックス.

#define CSQ_HST_IDX_UPD_VARTYPE 1

AddHistoryの引数インデックス.

#define CSQ_KEY_NAME _T("SoftWare\\CaoSQL")

レジストリ保存場所へのパス

#define CSQ_MAX_BUFFER 1024

wsprintfの扱える最大サイズ

#define CSQ_REG_ROOT HKEY_CLASSES_ROOT

レジストリ保存場所のルート

#define CSQ_RETRY_INTVL_DEFAULT 3000

リトライデフォルト間隔

#define CSQ_SETTINGDATA_ITEM_CLASS 2

#define CSQ_SETTINGDATA_ITEM_OBJECT_NAME 3

#define CSQ_SETTINGDATA_ITEM_OPTION 1

#define CSQ_SETTINGDATA_ITEM_VAR_NAME 0

#define CSQ_SLEEPTIME 10

停止の最小時間

#define CSQ_THREAD_END_TIMEOUT 3000

スレッド停止タイムアウト

#define CSQ_THREAD_START_TIMEOUT 3000

スレッド開始タイムアウト

#define CSQ_TIMESTAMP_DEVICE 1

TimeStamp DEVICE.

#define CSQ_TIMESTAMP_LOCAL 2

TimeStamp LOCAL.

#define CSQ_TIMESTAMP_NA 0

TimeStamp (n/a).

#define CSQ_TIMESTAMP_SYSTEM 3

TimeStamp SYSTEM.

#define CSQ_TRG_ACT_NO 0L

トリガアクション NoAction

#define CSQ_TRG_ACT_ONETIME 3L

トリガアクション 1回実行

#define CSQ_TRG_ACT_START 1L

トリガアクション Start

#define CSQ_TRG_ACT_STOP 2L

トリガアクション Stop

#define CSQ_TRG_CMD_ONETIME 1L

一回実行コマンド

#define CSQ_TRG_CMD_START -1L

開始コマンド

#define CSQ_TRG_CMD_STOP 0L

停止コマンド

#define CSQ_TRG_CND_EQ 0L

トリガ条件式　"=="

#define CSQ_TRG_CND_GE 5L

トリガ条件式　">="

#define CSQ_TRG_CND_GT 3L

トリガ条件式　">"

#define CSQ_TRG_CND_LE 4L

トリガ条件式　"<="

#define CSQ_TRG_CND_LT 2L

トリガ条件式　"<"

#define CSQ_TRG_CND_NE 1L

トリガ条件式　"!="

#define CSQ_WDT_ACTION_NOACTION 0

WatchdogTimer Action:NoAction.

#define CSQ_WDT_ACTION_STOP 1

WatchdogTimer Action:Atop.

#define CSQ_WDT_DEFAULT 3

WatchdogTimer Default.

#define CSQ_WM_ADVREQ WM_APP + 1

DDE AdviseRequestをする.

#define CSQL_DDE_MAX_BUF 256

DDE StringHandleの最大文字列長.

#define SIZEOFARRAY ( array ) (sizeof(array)/sizeof(array[0]))

配列のサイズを調べる

#define VARIANT_TO_BOOL | ( | in,
 |  | out | ) | { if (in.vt == VT_BOOL) { if (in.boolVal == VARIANT_TRUE) { out = true; } else { out = false; } } }

VARIANT型のBOOLをbool型にコピー.

#define VARIANT_TO_BSTR | ( | in,
 |  | out | ) | { if ((in.vt == VT_BSTR) && (in.bstrVal != NULL)) { out = SysAllocString(in.bstrVal); } }

VARIANT型のBSTRをBSTR型にコピー.

Typedef の解説

typedef unsigned(__stdcall * CSQ_THREADFUNC)(LPVOID)

スレッドの関数型

typedef unsigned CSQ_THREADID

スレッドID

typedef std::map<long, CCaoSQLController*> MAP_CSCTRL

CaoSQLControllerのマップ.

typedef std::map<long, CCaoSQLItem*> MAP_CSITEM

CaoSQLItemのマップ.

Generated on Tue Dec 13 12:25:28 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLEngine.cpp File Reference

CaoSQLEngine.cpp の解説

CCaoSQLEngine のインプリメンテーション. [詳細]

#include "stdafx.h"
#include "CaoSQLEngine.h"
#include "CaoSQLEngineMan.h"
#include "CaoSQLController.h"
#include "CaoSQLHistoryMan.h"

CaoSQLEngine.cppのインクルード依存関係図

Include dependency graph

解説

CCaoSQLEngine のインプリメンテーション.

バージョン:
1.0
日付:
Fri May 31 11:26:37 2002
作者:
DENSO WAVE
Generated on Tue Dec 13 12:25:28 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLEngine.h File Reference

CaoSQLEngine.h の解説

CCaoSQLEngine の宣言. [詳細]

#include "resource.h"

CaoSQLEngine.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoSQLEngine
CaoSQLのEngineクラス. [詳細]

解説

CCaoSQLEngine の宣言.

バージョン:
1.0
日付:
Fri May 31 10:50:14 2002
作者:
DENSO WAVE
Generated on Tue Dec 13 12:25:28 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLEngineMan.cpp File Reference

CaoSQLEngineMan.cpp の解説

CCaoSQLEngineManクラスのインプリメンテーション. [詳細]

#include "stdafx.h"
#include "CaoSQLEngineMan.h"
#include "CaoSQLController.h"
#include "CaoSQLHistory.h"
#include "CaoSQLHistoryMan.h"
#include "DDEServer.h"
#include "RACServer.h"

CaoSQLEngineMan.cppのインクルード依存関係図

Include dependency graph

解説

CCaoSQLEngineManクラスのインプリメンテーション.

バージョン:
1.0
日付:
Tue Jun 4 14:58:57 2002
作者:
DENSO WAVE
Generated on Tue Dec 13 12:25:28 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLEngineMan.h File Reference

CaoSQLEngineMan.h の解説

CCaoSQLEngineMan クラスのインターフェイス. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaoSQLEngineMan
CaoSQLEngineのManagerクラス. [詳細]

マクロ定義

#define | AFX_CaoSQLENGINEMAN_H__6FBB6452_10AF_4D96_8DCF_28A2A6FA9600__INCLUDED_

解説

CCaoSQLEngineMan クラスのインターフェイス.

バージョン:
1.0
日付:
Fri May 31 10:50:09 2002
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CaoSQLENGINEMAN_H__6FBB6452_10AF_4D96_8DCF_28A2A6FA9600__INCLUDED_

Generated on Tue Dec 13 12:25:28 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CAOSQLEventInfo.h File Reference

CAOSQLEventInfo.h の解説

ソースコードを見る。

マクロ定義

#define | FACILITY_WARNING 0xF02
#define | FACILITY_INFORMATIONAL 0xF01
#define | FACILITY_ERROR 0xF03
#define | STATUS_SEVERITY_WARNING 0x2
#define | STATUS_SEVERITY_INFORMATIONAL 0x1
#define | STATUS_SEVERITY_ERROR 0x3
#define | MSG_CAOSQL_LOG ((DWORD)0x4F010000L)

マクロ定義の解説

#define FACILITY_ERROR 0xF03

#define FACILITY_INFORMATIONAL 0xF01

#define FACILITY_WARNING 0xF02

#define MSG_CAOSQL_LOG ((DWORD)0x4F010000L)

#define STATUS_SEVERITY_ERROR 0x3

#define STATUS_SEVERITY_INFORMATIONAL 0x1

#define STATUS_SEVERITY_WARNING 0x2

Generated on Tue Dec 13 12:25:28 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLHistory.cpp File Reference

CaoSQLHistory.cpp の解説

CCaoSQLHistory のインプリメンテーション. [詳細]

#include "stdafx.h"
#include "CaoSQLHistory.h"
#include "CaoSQLHistoryMan.h"

CaoSQLHistory.cppのインクルード依存関係図

Include dependency graph

解説

CCaoSQLHistory のインプリメンテーション.

バージョン:
1.0
日付:
Fri May 31 10:50:11 2002
作者:
DENSO WAVE
Generated on Tue Dec 13 12:25:29 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLHistory.h File Reference

CaoSQLHistory.h の解説

CCaoSQLHistory の宣言. [詳細]

#include "resource.h"

CaoSQLHistory.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoSQLHistory
CaoSQLHistoryクラス. [詳細]

解説

CCaoSQLHistory の宣言.

バージョン:
1.0
日付:
Wed May 8 16:10:09 2002
作者:
DENSO WAVE
Generated on Tue Dec 13 12:25:29 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLHistoryMan.cpp File Reference

CaoSQLHistoryMan.cpp の解説

CCaoSQLHistoryManクラスのインプリメンテーション. [詳細]

#include "stdafx.h"
#include "CaoSQLHistoryMan.h"
#include "CaoSQLEngineMan.h"
#include "CaoSQLHistory.h"

CaoSQLHistoryMan.cppのインクルード依存関係図

Include dependency graph

解説

CCaoSQLHistoryManクラスのインプリメンテーション.

バージョン:
1.0
日付:
Fri May 31 10:49:57 2002
作者:
DENSO WAVE
Generated on Tue Dec 13 12:25:29 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLHistoryMan.h File Reference

CaoSQLHistoryMan.h の解説

CCaoSQLHistoryMan クラスのインターフェイス. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaoSQLHistoryMan
CaoSQLHistoryManクラス. [詳細]

マクロ定義

#define | AFX_CaoSQLHISTORY_H__170E0EB9_D84D_4BB7_ABD6_F6C81C5F8D62__INCLUDED_
#define | CAOSQL_HSTRY_VALUE_MAXLEN 254
#define | CAOSQL_HSTRY_NAME_MAXLEN 31
#define | CAOSQL_HSTRY_CMD_ADD _T("INSERT INTO %ls(%s, %s, %s, %s, %s, %s, %s) VALUES(?, ?, ?, ?, ?, ?, ?)")
#define | CAOSQL_HSTRY_CMD_CNT _T("SELECT COUNT(*) FROM %ls")
#define | CAOSQL_HSTRY_CMD_UPDATE _T("UPDATE %ls SET %s = ?, %s = ?, %s = ?, %s = ? WHERE %s = ? AND %s = ? AND %s = ?")
#define | CAOSQL_HSTRY_TYPE_HSTRY 1
#define | CAOSQL_HSTRY_TYPE_CURVAL 2
#define | CAOSQL_HSTRY_FLAG_CURVAL 1

関数

void | TESTHR (HRESULT x)

解説

CCaoSQLHistoryMan クラスのインターフェイス.

バージョン:
1.0
日付:
Fri May 31 10:50:12 2002
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CaoSQLHISTORY_H__170E0EB9_D84D_4BB7_ABD6_F6C81C5F8D62__INCLUDED_

#define CAOSQL_HSTRY_CMD_ADD _T("INSERT INTO %ls(%s, %s, %s, %s, %s, %s, %s) VALUES(?, ?, ?, ?, ?, ?, ?)")

#define CAOSQL_HSTRY_CMD_CNT _T("SELECT COUNT(*) FROM %ls")

#define CAOSQL_HSTRY_CMD_UPDATE _T("UPDATE %ls SET %s = ?, %s = ?, %s = ?, %s = ? WHERE %s = ? AND %s = ? AND %s = ?")

#define CAOSQL_HSTRY_FLAG_CURVAL 1

#define CAOSQL_HSTRY_NAME_MAXLEN 31

#define CAOSQL_HSTRY_TYPE_CURVAL 2

#define CAOSQL_HSTRY_TYPE_HSTRY 1

#define CAOSQL_HSTRY_VALUE_MAXLEN 254

関数の解説

void TESTHR ( HRESULT x ) [inline]

Generated on Tue Dec 13 12:25:29 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLItem.cpp File Reference

CaoSQLItem.cpp の解説

CCaoSQLItemのインプリメンテーション. [詳細]

#include "stdafx.h"
#include "CaoSQLItem.h"
#include "CaoSQLController.h"
#include "CaoSQLEngineMan.h"
#include "CaoSQLHistoryMan.h"
#include "DDEServer.h"
#include <algorithm>

CaoSQLItem.cppのインクルード依存関係図

Include dependency graph

変数

const VARTYPE | REQUEST_TYPE [13] = { VT_BOOL, VT_I1, VT_UI1, VT_I2, VT_UI2, VT_I4, VT_UI4, VT_R4, VT_R8, VT_BSTR, VT_DATE, VT_CY, VT_VARIANT }
const VARTYPE | INIT_TYPE [12] = { VT_BOOL, VT_I1, VT_UI1, VT_I2, VT_UI2, VT_I4, VT_UI4, VT_R4, VT_R8, VT_BSTR, VT_DATE, VT_CY }

解説

CCaoSQLItemのインプリメンテーション.

バージョン:
1.0
日付:
Tue Jun 4 14:59:14 2002
作者:
DENSO WAVE

変数の解説

const VARTYPE INIT_TYPE[12] = { VT_BOOL, VT_I1, VT_UI1, VT_I2, VT_UI2, VT_I4, VT_UI4, VT_R4, VT_R8, VT_BSTR, VT_DATE, VT_CY }

const VARTYPE REQUEST_TYPE[13] = { VT_BOOL, VT_I1, VT_UI1, VT_I2, VT_UI2, VT_I4, VT_UI4, VT_R4, VT_R8, VT_BSTR, VT_DATE, VT_CY, VT_VARIANT }

Generated on Tue Dec 13 12:25:29 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLItem.h File Reference

CaoSQLItem.h の解説

CCaoSQLItem の宣言. [詳細]

#include <queue>
#include "resource.h"
#include "CaoSQLAdviser.h"
#include "CaoSQLOnChangeObserver.h"
#include "CaoSQLLinkObserver.h"
#include "CaoSQLCalcItem.h"

CaoSQLItem.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaoSQLItem
CaoSQLのControllerクラス. [詳細]

struct | QUE_VALUEEX

解説

CCaoSQLItem の宣言.

バージョン:
1.0
日付:
Tue Jun 4 14:59:12 2002
作者:
DENSO WAVE
Generated on Tue Dec 13 12:25:29 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLLinkObserver.cpp File Reference

CaoSQLLinkObserver.cpp の解説

CCaoSQLLinkObserver クラスのインプリメンテーション. [詳細]

#include "stdafx.h"
#include "CaoSQLLinkObserver.h"
#include "CaoSQLEngineMan.h"
#include "CaoSQLController.h"
#include "CaoSQLItem.h"

CaoSQLLinkObserver.cppのインクルード依存関係図

Include dependency graph

解説

CCaoSQLLinkObserver クラスのインプリメンテーション.

バージョン:
1.0
日付:
Tue Jun 4 14:59:08 2002
作者:
DENSO WAVE
Generated on Tue Dec 13 12:25:30 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLLinkObserver.h File Reference

CaoSQLLinkObserver.h の解説

CCaoSQLLinkObserver クラスのインターフェイス. [詳細]

#include "CaoSQLObserver.h"

CaoSQLLinkObserver.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaoSQLLinkObserver
CCaoSQLLinkObserverクラス. [詳細]

マクロ定義

#define | AFX_CaoSQLLINKOBSERVER_H__E953E6C2_C41B_4BB1_92D1_D2F4DA6B85E0__INCLUDED_

解説

CCaoSQLLinkObserver クラスのインターフェイス.

バージョン:
1.0
日付:
Thu May 2 14:17:15 2002
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CaoSQLLINKOBSERVER_H__E953E6C2_C41B_4BB1_92D1_D2F4DA6B85E0__INCLUDED_

Generated on Tue Dec 13 12:25:30 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLObserver.cpp File Reference

CaoSQLObserver.cpp の解説

#include "stdafx.h"
#include "CaoSQLObserver.h"

CaoSQLObserver.cppのインクルード依存関係図

Include dependency graph
Generated on Tue Dec 13 12:25:30 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLObserver.h File Reference

CaoSQLObserver.h の解説

CCaoSQLObserver クラス. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaoSQLObserver
CCaoSQLObserverクラス. [詳細]

マクロ定義

#define | AFX_CaoSQLOBSERVER_H__57092436_381D_48A1_8834_1DF4095969D2__INCLUDED_

解説

CCaoSQLObserver クラス.

バージョン:
1.0
日付:
Thu May 2 13:15:02 2002
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CaoSQLOBSERVER_H__57092436_381D_48A1_8834_1DF4095969D2__INCLUDED_

Generated on Tue Dec 13 12:25:30 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLOnChangeObserver.cpp File Reference

CaoSQLOnChangeObserver.cpp の解説

CCaoSQLOnChangeObserver クラスのインプリメンテーション. [詳細]

#include "stdafx.h"
#include "CaoSQLOnChangeObserver.h"
#include "CaoSQLEngineMan.h"
#include "CaoSQLController.h"
#include "CaoSQLItem.h"

CaoSQLOnChangeObserver.cppのインクルード依存関係図

Include dependency graph

解説

CCaoSQLOnChangeObserver クラスのインプリメンテーション.

バージョン:
1.0
日付:
Thu May 30 14:05:55 2002
作者:
DENSO WAVE
Generated on Tue Dec 13 12:25:30 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLOnChangeObserver.h File Reference

CaoSQLOnChangeObserver.h の解説

CCaoSQLOnChangeObserver クラスのインターフェイス. [詳細]

#include "CaoSQLObserver.h"

CaoSQLOnChangeObserver.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaoSQLOnChangeObserver
CCaoSQLOnChangeObserverクラス. [詳細]

マクロ定義

#define | AFX_CaoSQLONCHANGEOBSERVER_H__75A18619_43CC_4784_A432_80816F03836D__INCLUDED_

解説

CCaoSQLOnChangeObserver クラスのインターフェイス.

バージョン:
1.0
日付:
Fri Apr 26 13:29:34 2002
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CaoSQLONCHANGEOBSERVER_H__75A18619_43CC_4784_A432_80816F03836D__INCLUDED_

Generated on Tue Dec 13 12:25:30 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLRACSvr.cpp File Reference

CaoSQLRACSvr.cpp の解説

#include "stdafx.h"
#include "CaoSQL.h"
#include "CaoSQLRACSvr.h"
#include "CaoSQLRACSvrMan.h"
#include "EventSink.h"

CaoSQLRACSvr.cppのインクルード依存関係図

Include dependency graph
Generated on Tue Dec 13 12:25:30 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLRACSvr.h File Reference

CaoSQLRACSvr.h の解説

#include "resource.h"
#include "CaoSQLRACSvrMan.h"

CaoSQLRACSvr.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaoSQLRACSvr

マクロ定義

#define | AFX_CAOSQLRACSVR_H__04737F87_3A5D_465A_9EEF_0FD7FDE625F7__INCLUDED_

マクロ定義の解説

#define AFX_CAOSQLRACSVR_H__04737F87_3A5D_465A_9EEF_0FD7FDE625F7__INCLUDED_

Generated on Tue Dec 13 12:25:31 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLTriggerObserver.cpp File Reference

CaoSQLTriggerObserver.cpp の解説

CCaoSQLTriggerObserver クラスのインプリメンテーション. [詳細]

#include "stdafx.h"
#include "CaoSQLTriggerObserver.h"
#include "CaoSQLController.h"

CaoSQLTriggerObserver.cppのインクルード依存関係図

Include dependency graph

解説

CCaoSQLTriggerObserver クラスのインプリメンテーション.

バージョン:
1.0
日付:
Thu May 30 14:05:48 2002
作者:
DENSO WAVE
Generated on Tue Dec 13 12:25:31 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLTriggerObserver.h File Reference

CaoSQLTriggerObserver.h の解説

CCaoSQLTriggerObserver クラスのインターフェイス. [詳細]

#include "CaoSQLObserver.h"

CaoSQLTriggerObserver.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaoSQLTriggerObserver
CCaoSQLTriggerObserverクラス. [詳細]

マクロ定義

#define | AFX_CaoSQLTRIGGEROBSERVER_H__5A4499B7_7C92_4F5F_8E2C_57E315C582C3__INCLUDED_

解説

CCaoSQLTriggerObserver クラスのインターフェイス.

バージョン:
1.0
日付:
Wed May 29 14:30:32 2002
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CaoSQLTRIGGEROBSERVER_H__5A4499B7_7C92_4F5F_8E2C_57E315C582C3__INCLUDED_

Generated on Tue Dec 13 12:25:31 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CorbaCaoSQL.idl File Reference

CorbaCaoSQL.idl の解説

CaoSQL.exe 用の CORBA(OMG) IDL ソース ファイル. [詳細]

ソースコードを見る。

構成

interface | ICaoSQLController
ICaoSQLController Interface. [詳細]

interface | ICaoSQLEngine
ICaoSQLEngine Interface. [詳細]

interface | ICaoSQLItem
ICaoSQLItem Interface. [詳細]

Typedef

typedef unsigned long | rsHRESULT

Enum

enum | enmCaoSQLControllerState { rsCtrlThreadActive, rsCtrlThreadStop, rsCtrlThreadWaiting }
CaoSQL Controller Status Enumration. [詳細]

enum | enmCaoSQLItemState { rsItemSucceeded, rsItemFailed, rsItemUndefined }
CaoSQL Item Status Enumration. [詳細]

enum | enmCaoSQLSystemType { rsSystemTypeNone, rsSystemTypeController, rsSystemTypeTask, rsSystemTypeRobot }
CaoSQL SystemType Enumration. [詳細]

解説

CaoSQL.exe 用の CORBA(OMG) IDL ソース ファイル.

バージョン:
1.0
日付:
Sep 9, 2003
作者:
Toshihiro INUKAI
注意:
Event(call-back) and ICaoSQLHistory interfaces are NOT implemented.

Typedef の解説

typedef unsigned long rsHRESULT

Enum の解説

enum enmCaoSQLControllerState

CaoSQL Controller Status Enumration.

Enum 値:
rsCtrlThreadActive
rsCtrlThreadStop
rsCtrlThreadWaiting

enum enmCaoSQLItemState

CaoSQL Item Status Enumration.

Enum 値:
rsItemSucceeded
rsItemFailed
rsItemUndefined

enum enmCaoSQLSystemType

CaoSQL SystemType Enumration.

Enum 値:
rsSystemTypeNone
rsSystemTypeController
rsSystemTypeTask
rsSystemTypeRobot

Generated on Tue Dec 13 12:25:31 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


DDEServer.cpp File Reference

DDEServer.cpp の解説

CDDEServer クラスのインプリメンテーション. [詳細]

#include "stdafx.h"
#include "DDEServer.h"
#include "CaoSQLEngineMan.h"
#include "CaoSQLController.h"
#include "CaoSQLItem.h"

DDEServer.cppのインクルード依存関係図

Include dependency graph

解説

CDDEServer クラスのインプリメンテーション.

バージョン:
1.0
日付:
Fri May 31 10:50:06 2002
作者:
DENSO WAVE
Generated on Tue Dec 13 12:25:31 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


DDEServer.h File Reference

DDEServer.h の解説

CDDEServer クラスのインターフェイス. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CDDEServer
DDEのServer処理を行うクラス. [詳細]

マクロ定義

#define | AFX_DDESERVER_H__977788A3_7507_4394_9C16_7E9C12E2949A__INCLUDED_

解説

CDDEServer クラスのインターフェイス.

バージョン:
1.0
日付:
Thu May 30 14:05:53 2002
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_DDESERVER_H__977788A3_7507_4394_9C16_7E9C12E2949A__INCLUDED_

Generated on Tue Dec 13 12:25:31 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


dlldata.c File Reference

dlldata.c の解説

#include <rpcproxy.h>

dlldata.cのインクルード依存関係図

Include dependency graph

マクロ定義

#define | PROXY_DELEGATION

関数

PROXYFILE_LIST_START | REFERENCE_PROXY_FILE (CaoSQL)

マクロ定義の解説

#define PROXY_DELEGATION

関数の解説

PROXYFILE_LIST_START REFERENCE_PROXY_FILE ( CaoSQL )

Generated on Tue Dec 13 12:25:31 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


EventSink.cpp File Reference

EventSink.cpp の解説

CRACEventSinkクラスの実装. [詳細]

#include "stdafx.h"
#include "EventSink.h"

EventSink.cppのインクルード依存関係図

Include dependency graph

解説

CRACEventSinkクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Tue Dec 13 12:25:31 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


EventSink.h File Reference

EventSink.h の解説

#include "resource.h"
#include "CaoSQLEngine.h"
#include "CaoSQLEngineMan.h"
#include "CaoSQLController.h"
#include "CaoSQLItem.h"
#include <queue>

EventSink.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CRACEventSink
CAOプロバイダのRACEventSinkクラス. [詳細]

マクロ定義

#define | MSG_MAX 1000
< メイン シンボル

#define | RAC_PARA_NUM 5

マクロ定義の解説

#define MSG_MAX 1000

< メイン シンボル

#define RAC_PARA_NUM 5

Generated on Tue Dec 13 12:25:31 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


LockCriticalSection.h File Reference

LockCriticalSection.h の解説

CLockCriticalSection クラスのインターフェイス. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CLockCriticalSection
CLockCriticalSection クラス. [詳細]

マクロ定義

#define | AFX_LOCKCRITICALSECTION_H__087FFCA1_BC60_4A67_89CE_01D147DBC7F9__INCLUDED_

解説

CLockCriticalSection クラスのインターフェイス.

バージョン:
1.0
日付:
Thu May 2 13:09:45 2002
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_LOCKCRITICALSECTION_H__087FFCA1_BC60_4A67_89CE_01D147DBC7F9__INCLUDED_

Generated on Tue Dec 13 12:25:32 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


RACServer.cpp File Reference

RACServer.cpp の解説

#include "stdafx.h"
#include "CaoSQL.h"
#include "CaoSQLController.h"
#include "CaoSQLEngineMan.h"
#include "RACServer.h"

RACServer.cppのインクルード依存関係図

Include dependency graph
Generated on Tue Dec 13 12:25:32 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


RACServer.h File Reference

RACServer.h の解説

#include "resource.h"
#include "EventSink.h"

RACServer.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CRACServer
struct | ST_RAC_DATA

マクロ定義

#define | AFX_RACSERVER_H__B3CD89B9_5548_44A7_BA86_CB0ACFF529CA__INCLUDED_

マクロ定義の解説

#define AFX_RACSERVER_H__B3CD89B9_5548_44A7_BA86_CB0ACFF529CA__INCLUDED_

Generated on Tue Dec 13 12:25:32 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


ReadXML.h File Reference

ReadXML.h の解説

#include "stdafx.h"

ReadXML.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CReadXML
XMLファイルノード読取操作のクラス. [詳細]

マクロ定義

#define | AFX_READXMLINFO_H__81702906_B32D_4E6C_832B_35307A879ACB__INCLUDED_

マクロ定義の解説

#define AFX_READXMLINFO_H__81702906_B32D_4E6C_832B_35307A879ACB__INCLUDED_

Generated on Tue Dec 13 12:25:32 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


RegKeyEx.cpp File Reference

RegKeyEx.cpp の解説

Generated on Tue Dec 13 12:25:32 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


RegKeyEx.h File Reference

RegKeyEx.h の解説

CRegKeyEx クラスのインターフェイス. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CRegKeyEx
レジストリ操作のクラス [詳細]

マクロ定義

#define | AFX_REGKEYEX_H__796E4BB2_32BB_42C9_BC51_01772E752FED__INCLUDED_

解説

CRegKeyEx クラスのインターフェイス.

バージョン:
1.0
日付:
Tue May 28 14:10:17 2002
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_REGKEYEX_H__796E4BB2_32BB_42C9_BC51_01772E752FED__INCLUDED_

Generated on Tue Dec 13 12:25:32 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


resource.h File Reference

resource.h の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

マクロ定義

#define | IDS_SERVICENAME 100
#define | IDR_CaoSQL 100
#define | IDR_CaoSQLENGINE 101
#define | IDR_CaoSQLCONTROLLER 102
#define | IDR_CaoSQLITEM 103
#define | IDR_CaoSQLHISTORY 104
#define | IDR_RACSERVER 105
#define | IDI_CAOSQL 204

マクロ定義の解説

#define IDI_CAOSQL 204

#define IDR_CaoSQL 100

#define IDR_CaoSQLCONTROLLER 102

#define IDR_CaoSQLENGINE 101

#define IDR_CaoSQLHISTORY 104

#define IDR_CaoSQLITEM 103

#define IDR_RACSERVER 105

#define IDS_SERVICENAME 100

Generated on Tue Dec 13 12:25:32 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


StdAfx.cpp File Reference

StdAfx.cpp の解説

標準インクルードファイルを含むソースファイル [詳細]

#include "stdafx.h"
#include "CAO_i.c"
#include <atlimpl.cpp>

StdAfx.cppのインクルード依存関係図

Include dependency graph

解説

標準インクルードファイルを含むソースファイル

stdafx.pch 生成されるプリコンパイル済ヘッダー stdafx.obj 生成されるプリコンパイル済タイプ情報

バージョン:
1.0
日付:
Tue Apr 2 19:54:03 2002
作者:
DENSO WAVE
Generated on Tue Dec 13 12:25:32 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


StdAfx.h File Reference

StdAfx.h の解説

標準のシステムインクルードファイル [詳細]

#include <process.h>
#include <atlbase.h>
#include <limits.h>
#include <comdef.h>
#include "CAO.h"
#include "CaoSQLData.h"
#include "RegKeyEx.h"
#include "ReadXML.h"
#include "LockCriticalSection.h"
#include "CaoSQL.h"
#include "CaoSystem.h"
#include "CAOERROR.h"
#include "RACData.h"
#include <atlcom.h>

StdAfx.hのインクルード依存関係図

Include dependency graph

ソースコードを見る。

名前空間

namespace | MSXML2

構成

class | CServiceModule
CaoSQLのサービスモジュール. [詳細]

マクロ定義

#define | AFX_STDAFX_H__0954E884_8A01_4881_A9C7_616986F8647E__INCLUDED_
< warning C4786抑止

#define | STRICT
#define | _WIN32_WINNT 0x0400
#define | _ATL_FREE_THREADED
#define | SCANTIME(st, en) ((en < st)? (ULONG_MAX - st + en) : (en - st))
#define | XPATH_DOC_PROPERTY L"SelectionNamespaces"
#define | XML_VARIDATION VARIANT_TRUE
#define | XML_LOAD_ASYNC VARIANT_FALSE
#define | CAOSQL_LOG_MSGBOX "\r\n\r\nClick [Cancel] to output a message into 'Debug Viewer' after this. "

変数

CServiceModule _Module
const int | THREAD_PRIORITY [7]
const int | PROCESS_PRIORITY [4]

解説

標準のシステムインクルードファイル

参照回数が多く、かつあまり変更されない プロジェクト専用のインクルード ファイルを記述します．

バージョン:
1.0
日付:
Fri May 31 10:50:08 2002
作者:
DENSO WAVE

マクロ定義の解説

#define _ATL_FREE_THREADED

#define _WIN32_WINNT 0x0400

#define AFX_STDAFX_H__0954E884_8A01_4881_A9C7_616986F8647E__INCLUDED_

< warning C4786抑止

#define CAOSQL_LOG_MSGBOX "\r\n\r\nClick [Cancel] to output a message into 'Debug Viewer' after this. "

#define SCANTIME | ( | st,
 |  | en | ) | ((en < st)? (ULONG_MAX - st + en) : (en - st))

#define STRICT

#define XML_LOAD_ASYNC VARIANT_FALSE

#define XML_VARIDATION VARIANT_TRUE

#define XPATH_DOC_PROPERTY L"SelectionNamespaces"

変数の解説

CServiceModule _Module

const int PROCESS_PRIORITY[4]

const int THREAD_PRIORITY[7]

Generated on Tue Dec 13 12:25:33 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


Annotated Index

DENSO WAVE CaoSQL Project 構成

クラス、構造体、共用体、インタフェースの解説です。
CaoSQLLib::_ICaoSQLControllerEvents |
_IID |
_MIDL_PROC_FORMAT_STRING |
_MIDL_TYPE_FORMAT_STRING |
CaoSQLLib::CaoSQLController |
CaoSQLLib::CaoSQLEngine |
CaoSQLLib::CaoSQLHistory |
CaoSQLLib::CaoSQLItem |
CCaoSQLAdviser | CCaoSQLAdviserクラス
CCaoSQLCalcItem |
CCaoSQLController | CaoSQLのControllerクラス
CCaoSQLEngine | CaoSQLのEngineクラス
CCaoSQLEngineMan | CaoSQLEngineのManagerクラス
CCaoSQLHistory | CaoSQLHistoryクラス
CCaoSQLHistoryMan | CaoSQLHistoryManクラス
CCaoSQLItem | CaoSQLのControllerクラス
CCaoSQLLinkObserver | CCaoSQLLinkObserverクラス
CCaoSQLObserver | CCaoSQLObserverクラス
CCaoSQLOnChangeObserver | CCaoSQLOnChangeObserverクラス
CCaoSQLRACSvr |
CCaoSQLTriggerObserver | CCaoSQLTriggerObserverクラス
CDDEServer | DDEのServer処理を行うクラス
CLockCriticalSection | CLockCriticalSection クラス
CProxy_ICaoSQLEvents< T > | CaoSQLのイベントプロキシテンプレートクラス
CRACEventSink | CAOプロバイダのRACEventSinkクラス
CRACServer |
CReadXML | XMLファイルノード読取操作のクラス
CRegKeyEx | レジストリ操作のクラス
CServiceModule | CaoSQLのサービスモジュール
ICaoSQLController | ICaoSQLController Interface
ICaoSQLEngine | ICaoSQLEngine Interface
ICaoSQLHistory | ICaoSQLHistory Interface
ICaoSQLItem | ICaoSQLItem Interface
IConnectionPointImpl |
IRACEventSink |
CaoSQLLib::IRACSever |
CaoSQLLib::RACEventSink |
Generated on Tue Dec 13 12:25:33 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLLib::_ICaoSQLControllerEvents interface Reference

インタフェースCaoSQLLib::_ICaoSQLControllerEvents の解説

import "CaoSQL.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | OnChangeItem ([in] ICaoSQLItem *pICSItem)
HRESULT | OnChangeState ([in] long lNewVal)

メソッドの解説

HRESULT CaoSQLLib::_ICaoSQLControllerEvents::OnChangeItem ( [in] ICaoSQLItem * pICSItem )

HRESULT CaoSQLLib::_ICaoSQLControllerEvents::OnChangeState ( [in] long lNewVal )

このインタフェースの解説は次のファイルから生成されました:
  • CaoSQL.idl
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


_IID struct Reference

構造体 _IID の解説

すべてのメンバ一覧

Public 変数

unsigned long | x
unsigned short | s1
unsigned short | s2
unsigned char | c [8]

変数の解説

unsigned char _IID::c

unsigned short _IID::s1

unsigned short _IID::s2

unsigned long _IID::x

この構造体の解説は次のファイルから生成されました:
  • CAO_i.c
  • CaoSQL_i.c
Generated on Tue Dec 13 12:25:33 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


_MIDL_PROC_FORMAT_STRING struct Reference

構造体 _MIDL_PROC_FORMAT_STRING の解説

すべてのメンバ一覧

Public 変数

short | Pad
unsigned char | Format [PROC_FORMAT_STRING_SIZE]

変数の解説

unsigned char _MIDL_PROC_FORMAT_STRING::Format[ PROC_FORMAT_STRING_SIZE ]

short _MIDL_PROC_FORMAT_STRING::Pad

この構造体の解説は次のファイルから生成されました:
  • CaoSQL_p.c
Generated on Tue Dec 13 12:25:33 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


_MIDL_TYPE_FORMAT_STRING struct Reference

構造体 _MIDL_TYPE_FORMAT_STRING の解説

すべてのメンバ一覧

Public 変数

short | Pad
unsigned char | Format [TYPE_FORMAT_STRING_SIZE]

変数の解説

unsigned char _MIDL_TYPE_FORMAT_STRING::Format[ TYPE_FORMAT_STRING_SIZE ]

short _MIDL_TYPE_FORMAT_STRING::Pad

この構造体の解説は次のファイルから生成されました:
  • CaoSQL_p.c
Generated on Tue Dec 13 12:25:33 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLLib::CaoSQLController class Reference

クラス CaoSQLLib::CaoSQLController の解説

import "CaoSQL.idl";

このクラスの解説は次のファイルから生成されました:
  • CaoSQL.idl
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLLib::CaoSQLEngine class Reference

クラス CaoSQLLib::CaoSQLEngine の解説

import "CaoSQL.idl";

このクラスの解説は次のファイルから生成されました:
  • CaoSQL.idl
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLLib::CaoSQLHistory class Reference

クラス CaoSQLLib::CaoSQLHistory の解説

import "CaoSQL.idl";

このクラスの解説は次のファイルから生成されました:
  • CaoSQL.idl
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLLib::CaoSQLItem class Reference

クラス CaoSQLLib::CaoSQLItem の解説

import "CaoSQL.idl";

このクラスの解説は次のファイルから生成されました:
  • CaoSQL.idl
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CCaoSQLAdviser class Reference

クラス CCaoSQLAdviser の解説

CCaoSQLAdviserクラス. [詳細]

#include <CaoSQLAdviser.h>

CCaoSQLAdviserに対する継承グラフ

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoSQLAdviser ()
コンストラクタ

virtual | ~CCaoSQLAdviser ()
デストラクタ

void | AddObserver (CCaoSQLObserver *pVal)
Observerクラスの登録.

void | DeleteObserver (CCaoSQLObserver *pVal)
Observerクラスの抹消.

void | NotifyObservers (VARIANT vntNewVal)
登録したObserverへ通知する

void | ReleaseObservers ()
登録したObserverを全て解放

解説

CCaoSQLAdviserクラス.

CCaoSQLObserverを集中管理するクラス．

コンストラクタとデストラクタの解説

CCaoSQLAdviser::CCaoSQLAdviser ( )

コンストラクタ

オブジェクト生成時の処理．

CCaoSQLAdviser::~CCaoSQLAdviser ( ) [virtual]

デストラクタ

オブジェクト消去時の処理．

メソッドの解説

void CCaoSQLAdviser::AddObserver ( CCaoSQLObserver * pVal )

Observerクラスの登録.

CCaoSQLObserverクラスを追加します．

引数:
pVal : [in] 追加するCCaoSQLobserverへのポインタ

void CCaoSQLAdviser::DeleteObserver ( CCaoSQLObserver * pVal )

Observerクラスの抹消.

登録済みのCCaoSQLObserverクラスを抹消します．
個別に登録を抹消したいとき以外に使用する必要はありません．
通常はデストラクタで登録を全て抹消します．

引数:
pVal : [in] 抹消するCCaoSQLobserverへのポインタ

void CCaoSQLAdviser::NotifyObservers ( VARIANT vntNewVal )

登録したObserverへ通知する

登録したObserverへ通知を行います．

引数:
vntNewVal : [in] 通知したい内容

void CCaoSQLAdviser::ReleaseObservers ( )

登録したObserverを全て解放

登録したObserverを全て解放します．

このクラスの解説は次のファイルから生成されました:
  • CaoSQLAdviser.h
  • CaoSQLAdviser.cpp
Generated on Tue Dec 13 12:25:33 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CCaoSQLCalcItem class Reference

クラス CCaoSQLCalcItem の解説

#include <CaoSQLCalcItem.h>

CCaoSQLCalcItemのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoSQLCalcItem ()
コンストラクタ

virtual | ~CCaoSQLCalcItem ()
デストラクタ

HRESULT | Initialize (CCaoSQLItem *pItem, long lCalcIndex, BSTR bstr2ndItem)
初期化処理

HRESULT | Calculate (LPVARIANT pvntLeft, LPVARIANT pvntResult)
演算実行

コンストラクタとデストラクタの解説

CCaoSQLCalcItem::CCaoSQLCalcItem ( )

コンストラクタ

オブジェクト生成時の処理．

CCaoSQLCalcItem::~CCaoSQLCalcItem ( ) [virtual]

デストラクタ

オブジェクト消去時の処理．

メソッドの解説

HRESULT CCaoSQLCalcItem::Calculate | ( | LPVARIANT | pvntLeft,
 |  | LPVARIANT | pvntResult
 | ) |

演算実行

演算を実行する．

引数:
pvntLeft | : [in] 左項
pvntResult | : [in] 演算結果

HRESULT CCaoSQLCalcItem::Initialize | ( | CCaoSQLItem * | pItem,
 |  | long | lCalcIndex,
 |  | BSTR | bstrCalcItem
 | ) |

初期化処理

演算対象のアイテムのポインタを保存します．

引数:
pItem | : [in] CCaoSQLItemへのポインタ
lCalcIndex | : [in] 二項演算子
bstrCalcItem | : [in] 演算対象アイテム名

このクラスの解説は次のファイルから生成されました:
  • CaoSQLCalcItem.h
  • CaoSQLCalcItem.cpp
Generated on Tue Dec 13 12:25:33 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CCaoSQLController class Reference

クラス CCaoSQLController の解説

CaoSQLのControllerクラス. [詳細]

#include <CaoSQLController.h>

CCaoSQLControllerに対する継承グラフ

[凡例]
CCaoSQLControllerのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoSQLController ()
コンストラクタ

~CCaoSQLController ()
デストラクタ

HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | _Activate ()
コントローラの起動処理

void | _Deactivate ()
コントローラの不活性処理

HRESULT | _Initialize (long lID, IXMLDOMNode *pCtrlNode)
初期化処理

void | _Terminate ()
CCaoSQLControllerの終了処理.

HRESULT | _GetVariable (long lSysType, BSTR bstrVarName, BSTR bstrVarOpt, BSTR bstrSysObjName, ICaoVariable **ppVal)
CaoVariableの取得.

HRESULT | _GetVariables (long lSysType, BSTR bstrSysObjName, ICaoVariables **ppICaoVars)
CaoVariablesの取得.

void | _SetTriggerState (long newVal)
トリガ状態の設定

HSZ | _GetHSZ ()
DDE文字列ハンドルの取得.

CCaoSQLItem * | _GetItem (BSTR bstrName)
アイテム名によるアイテムオブジェクトの取得

HRESULT | get__NewEnum (LPUNKNOWN *pVal)
コレクション内の列挙子オブジェクトの取得

HRESULT | get_Item (VARIANT vntIndex, ICaoSQLItem **ppICSItem)
アイテムのIFポインタを取得します

HRESULT | Stop ()
サンプリングスレッドの停止

HRESULT | Start ()
サンプリングスレッドの開始

HRESULT | Snapshot ()
スナップショットの実行

HRESULT | AddItem (VARIANT vntDataArray)
アイテムの動的登録

HRESULT | RemoveItem (VARIANT vntIndex)
アイテムの動的削除

HRESULT | Execute (BSTR bstrCommand, VARIANT vntParam, VARIANT *pvntVal)
コマンドの取得 CaoController::Executeにコマンドを送り，実行します

HRESULT | get_Count (long *plVal)
Itemの数の取得.

HRESULT | get_Description (BSTR *pbstrVal)
コントローラについての詳細取得

HRESULT | get_Index (long *plVal)
Indexの取得.

HRESULT | get_ItemNames (VARIANT *pvntVal)
Itemの名前を列挙して取得.

HRESULT | get_Name (BSTR *pbstrVal)
コントローラマネージャ名の取得

HRESULT | get_ScanTimes (long lNewVal, long *plVal)
スキャン時間の取得

HRESULT | get_SettingData (VARIANT vntName, VARIANT *pvntVal)
各種データ取得

HRESULT | put_SettingData (VARIANT vntName, VARIANT vntNewVal)
各種データ設定(未実装)

HRESULT | get_State (long *plVal)
状態の取得

HRESULT | get_Tag (VARIANT *vntVal)
タグの取得

HRESULT | put_Tag (VARIANT vntNewVal)
タグの設定

解説

CaoSQLのControllerクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoSQLControllerを参照．
CaoSQLEngineクラスから呼び出されるクラス。外部からインスタンスの作成は不可能．
CaoSQLItemクラスのコレクションクラスとなっている．
CaoSQLConfigで設定したController情報の閲覧とスレッドの起動/停止命令が可能．

コンストラクタとデストラクタの解説

CCaoSQLController::CCaoSQLController ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoSQLController::~CCaoSQLController ( ) [inline]

デストラクタ

オブジェクト消去時の処理．

メソッドの解説

HRESULT CCaoSQLController::_Activate ( )

コントローラの起動処理

Controllerをオープンし，スレッドの起動を行います．

戻り値:
HRESULT

void CCaoSQLController::_Deactivate ( )

コントローラの不活性処理

Controllerを終了する前に

  • スレッドの終了
  • Itemの不活性処理
  • TriggerObserverの破棄等の終了前処理を行います．
    この処理によってObserverが全て破棄され、安全に終了する状態になります．

HSZ CCaoSQLController::_GetHSZ ( )

DDE文字列ハンドルの取得.

このアイテムが持つDDEの文字列ハンドルを取得します．

戻り値:
: DDE文字列ハンドル

CCaoSQLItem * CCaoSQLController::_GetItem ( BSTR bstrName )

アイテム名によるアイテムオブジェクトの取得

このコントローラに属しているアイテムオブジェクトへのポインタを取得します．

引数:
bstrName : アイテム名
戻り値:
A | イテムへのポインタ
NULL | : 指定したアイテムは存在しませんでした

HRESULT CCaoSQLController::_GetVariable | ( | long | lSysType,
 |  | BSTR | bstrVarName,
 |  | BSTR | bstrVarOpt,
 |  | BSTR | bstrSysObjName,
 |  | ICaoVariable ** | ppVal
 | ) |

CaoVariableの取得.

GetVariableで取得に失敗した場合，CaoはNULLポインタを返すことに注意． 既に同名の変数が存在した場合、既存の変数を使用する

引数:
lSysType | : [in] システムタイプ
bstrVarName | : [in] 取得したい変数名
bstrVarOpt | : [in] 変数取得時のオプション文字列
bstrSysObjName | : [in] システムクラスの名前
ppVal | : [out] ICaoVariableへのIFポインタ
戻り値:
HRESULT

HRESULT CCaoSQLController::_GetVariables | ( | long | lSysType,
 |  | BSTR | bstrSysObjName,
 |  | ICaoVariables ** | pICaoVars
 | ) |

CaoVariablesの取得.

GetVariablesで取得に失敗した場合，CaoはNULLポインタを返すことに注意．

引数:
lSysType | : [in] システムクラス種別
bstrSysObjName | : [in] システムオブジェクト名
pICaoVars | : [out] ICaoVariablesへのIFポインタ
戻り値:
HRESULT

HRESULT CCaoSQLController::_Initialize | ( | long | lIndex,
 |  | IXMLDOMNode * | pCtrlNode
 | ) |

初期化処理

オブジェクトの初期化処理を行います．

引数:
lIndex | : コレクションのIndex
pCtrlNode | : オブジェクトのノード
戻り値:
HRESULT

void CCaoSQLController::_SetTriggerState ( long newVal )

トリガ状態の設定

引数:
newVal : [in] トリガ状態
戻り値:
HRESULT

void CCaoSQLController::_Terminate ( )

CCaoSQLControllerの終了処理.

アイテムの解放，スレッドの終了

STDMETHODIMP CCaoSQLController::AddItem ( VARIANT vntDataArray )

アイテムの動的登録

アイテムを動的に登録します．

引数:
vntDataArray : [in] アイテムのデータ配列
戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::Execute | ( | BSTR | bstrCommand,
 |  | VARIANT | vntParam,
 |  | VARIANT * | pvntVal
 | ) |

コマンドの取得 CaoController::Executeにコマンドを送り，実行します

引数:
bstrCommand | : [in] コマンド
vntParam | : [in] パラメータ
pvntVal | : [out] 実行結果
戻り値:
HRESULT

HRESULT CCaoSQLController::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

戻り値:
HRESULT

void CCaoSQLController::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoSQLController::get__NewEnum ( LPUNKNOWN * pVal )

コレクション内の列挙子オブジェクトの取得

スクリプトコードから直接アクセスは禁止されています(restricted)．

引数:
pVal : 列挙子オブジェクト
戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::get_Count ( long * plVal )

Itemの数の取得.

引数:
plVal : [out] Item数
戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::get_Description ( BSTR * pbstrVal )

コントローラについての詳細取得

引数:
pbstrVal : [out] 詳細情報
戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::get_Index ( long * plVal )

Indexの取得.

引数:
plVal : [out] Index
戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::get_Item | ( | VARIANT | vntIndex,
 |  | ICaoSQLItem ** | ppICSItem
 | ) |

アイテムのIFポインタを取得します

ICaoSQLControllerのデフォルトメンバです．

引数:
vntIndex : [in] アイテムのインデックス
VT_BSTR(名前指定)とVT_I4,I2(Index指定)が可能です．
ppICSItem : [out] ICaoSQLItemへのIFポインタへの参照
戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::get_ItemNames ( VARIANT * pvntVal )

Itemの名前を列挙して取得.

引数:
pvntVal : [out] アイテム名(VT_ARRAY | VT_BSTR で値を返します)
戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::get_Name ( BSTR * pbstrVal )

コントローラマネージャ名の取得

引数:
pbstrVal : [out] 名前
戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::get_ScanTimes | ( | long | lNewVal,
 |  | long * | plVal
 | ) |

スキャン時間の取得

引数:
lNewVal | : [in] スキャン時間の種類(番号)
plVal | : [out] 選択した種類のスキャン時間
戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::get_SettingData | ( | VARIANT | vntName,
 |  | VARIANT * | pVal
 | ) |

各種データ取得

引数:
vntName | : [in] 取得するデータ(番号 or 名前)
pVal | : [out] 取得したデータ
戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::get_State ( long * plVal )

状態の取得

enmCaoSQLCtrlStateを参照．

引数:
plVal : [out] ステート
戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::get_Tag ( VARIANT * pVal )

タグの取得

  ユーザが自由に使える多目的変数．

引数:
pVal : [out] タグデータ
戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

目的のオートメーションIFがエラーオブジェクトをサポートしているかの判定をします．
riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : インタフェース
戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::put_SettingData | ( | VARIANT | vntName,
 |  | VARIANT | newVal
 | ) |

各種データ設定(未実装)

引数:
vntName | : [in] 設定するデータ(番号 or 名前)
newVal | : [in] 設定する値
戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::put_Tag ( VARIANT vntNewVal )

タグの設定

  ユーザが自由に使える多目的変数．

引数:
vntNewVal : [in] タグデータ
戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::RemoveItem ( VARIANT vntIndex )

アイテムの動的削除

アイテムを動的に削除します．

引数:
vntIndex : [in] 削除するアイテム名/インデックス番号
戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::Snapshot ( )

スナップショットの実行

戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::Start ( )

サンプリングスレッドの開始

戻り値:
HRESULT

STDMETHODIMP CCaoSQLController::Stop ( )

サンプリングスレッドの停止

戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoSQLController.h
  • CaoSQLController.cpp
Generated on Tue Dec 13 12:25:33 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CCaoSQLEngine class Reference

クラス CCaoSQLEngine の解説

CaoSQLのEngineクラス. [詳細]

#include <CaoSQLEngine.h>

CCaoSQLEngineのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoSQLEngine ()
コンストラクタ

~CCaoSQLEngine ()
デストラクタ

HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | get__NewEnum (LPUNKNOWN *pVal)
コレクション内の列挙子オブジェクトの取得

HRESULT | get_Controller (VARIANT vntIndex, ICaoSQLController **ppICSCtrl)
コントローラのIFポインタを取得します

HRESULT | Start ()
サンプリングスレッドの開始

HRESULT | Stop ()
サンプリングスレッドの停止

HRESULT | Snapshot ()
スナップショットの実行

HRESULT | Execute (BSTR bstrCommandText, VARIANT *pvntVal)
Execute実行(未実装).

HRESULT | get_Count (long *plVal)
Controllerの数の取得.

HRESULT | get_ControllerNames (VARIANT *pvntVal)
Controllerの名前を列挙して取得.

HRESULT | get_CaoSQLHistory (ICaoSQLHistory **ppICSHstry)
CaoSQLHistoryのIFポインタを取得します.

解説

CaoSQLのEngineクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoSQLEngineを参照．
CaoSQLにおいてCOMクライアントが唯一インスタンス作成可能なクラス．
CaoSQLControllerのコレクションクラスとなっている．

コンストラクタとデストラクタの解説

CCaoSQLEngine::CCaoSQLEngine ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoSQLEngine::~CCaoSQLEngine ( ) [inline]

デストラクタ

オブジェクト消去時の処理．

メソッドの解説

STDMETHODIMP CCaoSQLEngine::Execute | ( | BSTR | bstrCommandText,
 |  | VARIANT * | pvntVal
 | ) |

Execute実行(未実装).

引数:
bstrCommandText | : [in] コマンド文字列
pvntVal | : [in] 結果
戻り値:
HRESULT

HRESULT CCaoSQLEngine::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoSQLEngine::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoSQLEngine::get__NewEnum ( LPUNKNOWN * pVal )

コレクション内の列挙子オブジェクトの取得

スクリプトコードから直接アクセスは禁止されています(restricted)．

引数:
pVal : 列挙子オブジェクト
戻り値:
HRESULT

STDMETHODIMP CCaoSQLEngine::get_CaoSQLHistory ( ICaoSQLHistory ** ppICSHstry )

CaoSQLHistoryのIFポインタを取得します.

引数:
ppICSHstry : [out] ICaoSQLHistoryのIFポインタへの参照
戻り値:
HRESULT

STDMETHODIMP CCaoSQLEngine::get_Controller | ( | VARIANT | vntIndex,
 |  | ICaoSQLController ** | ppICSCtrl
 | ) |

コントローラのIFポインタを取得します

ICaoSQLEngineのデフォルトメンバです．

引数:
vntIndex : [in] コントローラのインデックス
VT_BSTR(名前指定)とVT_I4,I2(Index指定)が可能です．
ppICSCtrl : [out] ICaoSQLControllerへのIFポインタへの参照
戻り値:
HRESULT

STDMETHODIMP CCaoSQLEngine::get_ControllerNames ( VARIANT * pvntVal )

Controllerの名前を列挙して取得.

引数:
pvntVal : [out]
戻り値:
HRESULT

STDMETHODIMP CCaoSQLEngine::get_Count ( long * plVal )

Controllerの数の取得.

引数:
plVal : [out] Controller数
戻り値:
HRESULT

STDMETHODIMP CCaoSQLEngine::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

目的のオートメーションIFがエラーオブジェクトをサポートしているかの判定をします．
riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : インタフェース
戻り値:
HRESULT

STDMETHODIMP CCaoSQLEngine::Snapshot ( )

スナップショットの実行

戻り値:
HRESULT

STDMETHODIMP CCaoSQLEngine::Start ( )

サンプリングスレッドの開始

戻り値:
HRESULT

STDMETHODIMP CCaoSQLEngine::Stop ( )

サンプリングスレッドの停止

戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoSQLEngine.h
  • CaoSQLEngine.cpp
Generated on Tue Dec 13 12:25:34 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CCaoSQLEngineMan class Reference

クラス CCaoSQLEngineMan の解説

CaoSQLEngineのManagerクラス. [詳細]

#include <CaoSQLEngineMan.h>

すべてのメンバ一覧

Public メソッド

HRESULT | Initialize ()
初期化処理

void | Terminate ()
終了処理

BSTR | GetDefCtrlName ()
デフォルトコントローラ名の取得

HRESULT | CopyCollection (MAP_CSCTRL *pmap)
ICaoSQLControllerのマップコピー.

HRESULT | AddWorkspace (BSTR bstrName, BSTR bstrOpt, ICaoWorkspace **ppICaoWs)
新規ワークスペースの追加

CCaoSQLController * | GetController (BSTR bstrName)
コントローラオブジェクトの取得

HRESULT | GetCaoSQLHistory (ICaoSQLHistory **ppVal)
ICaoSQLHistoryのIFポインタ取得.

long | GetRetryCount ()
リトライ回数の取得

long | GetRetryInterval ()
リトライ間隔の取得

void | AddRef ()
参照カウンタを1増やす

void | Release ()
参照カウンタを1減らす

Static Public メソッド

CCaoSQLEngineMan * | Instance ()
唯一のインスタンスを取得する．

解説

CaoSQLEngineのManagerクラス.

CaoSQLConfigでの設定情報に基づきCaoSQL全体の管理を行うクラス．
このクラスを最初に使用するときはInitializeを実行してください．
このクラスを使用し終えたらTerminateを実行してください．
ICaoSQLControllerをコレクションしておきます．
デザインパターンSingletonを適用．

  • このクラスのインスタンスは一つしか生成されません
  • コンストラクタはprivateなので外部からnew出来ません
  • インスタンスの取得をするには唯一Instanceメソッドのみが用意されています

メソッドの解説

void CCaoSQLEngineMan::AddRef ( )

参照カウンタを1増やす

HRESULT CCaoSQLEngineMan::AddWorkspace | ( | BSTR | bstrName,
 |  | BSTR | bstrOpt,
 |  | ICaoWorkspace ** | ppICaoWs
 | ) |

新規ワークスペースの追加

新規ワークスペースを追加します．

引数:
bstrName | : [in] ワークスペース名
bstrOpt | : [in] オプション文字列
ppICaoWs | : [out] ICaoWorkspace IF ポインタ
戻り値:
HRESULT

HRESULT CCaoSQLEngineMan::CopyCollection ( MAP_CSCTRL * pmap )

ICaoSQLControllerのマップコピー.

引数:
pmap : コピー先のMAP_CSCTRLへのポインタ
戻り値:
HRESULT

HRESULT CCaoSQLEngineMan::GetCaoSQLHistory ( ICaoSQLHistory ** ppVal )

ICaoSQLHistoryのIFポインタ取得.

引数:
ppVal : [out] ICaoSQLHistoryのIFポインタ
戻り値:
HRESULT

CCaoSQLController * CCaoSQLEngineMan::GetController ( BSTR bstrName )

コントローラオブジェクトの取得

指定した名前のコントローラオブジェクトへのポインタを取得します．

引数:
bstrName : コントローラ名
戻り値:
R | ントローラへのポインタ
NULL | 指定したアイテムは存在しませんでした

BSTR CCaoSQLEngineMan::GetDefCtrlName ( )

デフォルトコントローラ名の取得

戻り値:
f フォルトコントローラ名

long CCaoSQLEngineMan::GetRetryCount ( )

リトライ回数の取得

戻り値:
-1 | : 無限にリトライ
0 | 以上 : リトライ回数

long CCaoSQLEngineMan::GetRetryInterval ( )

リトライ間隔の取得

戻り値:
g ライ間隔(ms)

HRESULT CCaoSQLEngineMan::Initialize ( )

初期化処理

CaoEngineの生成等の初期化処理を行います．

戻り値:
HRESULT

CCaoSQLEngineMan * CCaoSQLEngineMan::Instance ( ) [static]

唯一のインスタンスを取得する．

インスタンスの取得

戻り値:
CCaoSQLEngineManのインスタンスへのポインタ

void CCaoSQLEngineMan::Release ( )

参照カウンタを1減らす

参照カウントが0以下になれば自分自身を破棄する

void CCaoSQLEngineMan::Terminate ( )

終了処理

CaoSQLEngineManの終了処理を行います．
デストラクタは効かないのでメモリやリソースはここで処分する．

このクラスの解説は次のファイルから生成されました:
  • CaoSQLEngineMan.h
  • CaoSQLEngineMan.cpp
Generated on Tue Dec 13 12:25:34 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CCaoSQLHistory class Reference

クラス CCaoSQLHistory の解説

CaoSQLHistoryクラス. [詳細]

#include <CaoSQLHistory.h>

CCaoSQLHistoryのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoSQLHistory ()
コンストラクタ

~CCaoSQLHistory ()
デストラクタ

HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | Execute (BSTR bstrCmdText, VARIANT *pvntVal)
ADOConnectionオブジェクトのExecuteをコールする.

HRESULT | get_ConnectionString (long lIndex, BSTR *pbstrVal)
ADO接続文字列の取得.

HRESULT | get_Enable (VARIANT_BOOL *pbVal)
Historyが使用できる設定かどうかの取得.

HRESULT | get_MaxRecord (long lIndex, long *plVal)
最大レコード数の取得

HRESULT | get_TableName (long lIndex, BSTR *pbstrVal)
テーブル名の取得

解説

CaoSQLHistoryクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoSQLControllerを参照．
CaoSQLEngineクラスから呼び出されるクラス。外部からインスタンスの作成は不可能．
CaoSQLConfigで設定したHistory情報の閲覧とADOコマンドの実行が可能．

コンストラクタとデストラクタの解説

CCaoSQLHistory::CCaoSQLHistory ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoSQLHistory::~CCaoSQLHistory ( ) [inline]

デストラクタ

オブジェクト消去時の処理．

メソッドの解説

STDMETHODIMP CCaoSQLHistory::Execute | ( | BSTR | bstrCmdText,
 |  | VARIANT * | pvntVal
 | ) |

ADOConnectionオブジェクトのExecuteをコールする.

ADO::Connectionオブジェクトから直接Executeをコールします．
任意のSQL文の実行が出来ます．(adCmdTextをサポート)

引数:
bstrCmdText : [in] 実行コマンド文字列
pvntVal : [out] ADO::Connection::Executeの戻り値
VT_DISPATCHにADO::RecordsetかNULLが返る
戻り値:
HRESULT

HRESULT CCaoSQLHistory::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoSQLHistory::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoSQLHistory::get_ConnectionString | ( | long | lIndex,
 |  | BSTR * | pbstrVal
 | ) |

ADO接続文字列の取得.

ADO::Connectionオブジェクトのオープンパラメータを取得します．

引数:
lIndex | : [out] 1 = プライマリ，2 = セカンダリ
pbstrVal | : [out] 接続文字列
戻り値:
HRESULT

STDMETHODIMP CCaoSQLHistory::get_Enable ( VARIANT_BOOL * pbVal )

Historyが使用できる設定かどうかの取得.

Historyが使用できる設定かどうかを取得します．

引数:
pbVal : [out] 使用可能フラグ
戻り値:
HRESULT

STDMETHODIMP CCaoSQLHistory::get_MaxRecord | ( | long | lIndex,
 |  | long * | plVal
 | ) |

最大レコード数の取得

最大レコードの制限を取得します．

引数:
lIndex | : [out] 1 = プライマリ，2 = セカンダリ
plVal | : [out] 最大レコード数
戻り値:
HRESULT

STDMETHODIMP CCaoSQLHistory::get_TableName | ( | long | lIndex,
 |  | BSTR * | pbstrVal
 | ) |

テーブル名の取得

Historyが利用しているテーブル名を取得します．

引数:
lIndex | : [out] 1 = プライマリ，2 = セカンダリ
pbstrVal | : [out] テーブル名
戻り値:
HRESULT

STDMETHODIMP CCaoSQLHistory::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

目的のオートメーションIFがエラーオブジェクトをサポートしているかの判定をします．
riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : インタフェース
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoSQLHistory.h
  • CaoSQLHistory.cpp
Generated on Tue Dec 13 12:25:34 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CCaoSQLHistoryMan class Reference

クラス CCaoSQLHistoryMan の解説

CaoSQLHistoryManクラス. [詳細]

#include <CaoSQLHistoryMan.h>

すべてのメンバ一覧

Public メソッド

HRESULT | Initialize ()
オブジェクトの初期化処理

void | Terminate ()
終了処理

HRESULT | AddHistory (BSTR bstrCtrlName, BSTR bstrItemName, VARIANT vntValue, VARIANT vntDateTime, long lMicrosecond)
Histroyデータをデータベースに追加します。.

HRESULT | Execute (BSTR bstrCmd, VARIANT *pVal)
ADOConnectionオブジェクトのExecuteをコールする.

HRESULT | GetConnectionString (long lIndex, BSTR *pVal)
ADO接続文字列の取得.

HRESULT | GetTableName (long lIndex, BSTR *pVal)
テーブル名の取得

HRESULT | GetMaxRecord (long lIndex, DWORD *pVal)
最大レコード数の取得

HRESULT | GetEnableHistory (VARIANT_BOOL *pVal)
History使用状況の取得.

HRESULT | GetEnableSysInfo (VARIANT_BOOL *pVal)
SysInfo使用状況の取得.

HRESULT | BeginTrans (long *plLevel=NULL)
トランザクションの開始

HRESULT | CommitTrans ()
トランザクションの終了

HRESULT | RollbackTrans ()
トランザクションの破棄

Static Public メソッド

CCaoSQLHistoryMan * | Instance ()
唯一のインスタンスを取得する

解説

CaoSQLHistoryManクラス.

CaoSQLのHistory情報をデータベースと接続して書込みを行う．
デザインパターンSingletonを適用．

  • このクラスのインスタンスは一つしか生成されません
  • コンストラクタはprivateなので外部からnew出来ません
  • インスタンスの取得をするには唯一Instanceメソッドのみが用意されています

メソッドの解説

HRESULT CCaoSQLHistoryMan::AddHistory | ( | BSTR | bstrCtrlName,
 |  | BSTR | bstrItemName,
 |  | VARIANT | vntValue,
 |  | VARIANT | vntDateTime,
 |  | long | lMicrosecond
 | ) |

Histroyデータをデータベースに追加します。.

引数:
bstrCtrlName | : コントローラ名
bstrItemName | : アイテム名
vntValue | : 値
vntDateTime | : 日時
lMicrosecond | : マイクロ秒
戻り値:
HRESULT

HRESULT CCaoSQLHistoryMan::BeginTrans ( long * plLevel = NULL )

トランザクションの開始

現在のADO::Connectionに対してトランザクションを開始します．

引数:
plLevel : トランザクションレベル(Option)
戻り値:
HRESULT

HRESULT CCaoSQLHistoryMan::CommitTrans ( )

トランザクションの終了

現在のトランザクションを終了します．

戻り値:
HRESULT

HRESULT CCaoSQLHistoryMan::Execute | ( | BSTR | bstrCmd,
 |  | VARIANT * | pVal
 | ) |

ADOConnectionオブジェクトのExecuteをコールする.

ADO::Connectionオブジェクトから直接Executeをコールします．
任意のSQL文の実行が出来ます．(adCmdTextをサポート)

引数:
bstrCmd : 実行コマンド文字列
pVal : ADO::Connection::Executeの戻り値
VT_DISPATCHにADO::RecordsetかNULLが返る
戻り値:
HRESULT

HRESULT CCaoSQLHistoryMan::GetConnectionString | ( | long | lIndex,
 |  | BSTR * | pVal
 | ) |

ADO接続文字列の取得.

CaoSQLHistoryのADO接続文字列を取得します．

引数:
lIndex | : [out] 1 = プライマリ，2 = セカンダリ
pVal | : [out] ADO接続文字列
戻り値:
HRESULT

HRESULT CCaoSQLHistoryMan::GetEnableHistory ( VARIANT_BOOL * pVal )

History使用状況の取得.

CaoSQLHistoryを使用する設定になっているかどうかを取得します．

引数:
pVal : [out] 使用状況
戻り値:
HRESULT

HRESULT CCaoSQLHistoryMan::GetEnableSysInfo ( VARIANT_BOOL * pVal )

SysInfo使用状況の取得.

SysInfoを追加する設定になっているかどうかを取得します．

引数:
pVal : [out] 使用状況
戻り値:
HRESULT

HRESULT CCaoSQLHistoryMan::GetMaxRecord | ( | long | lIndex,
 |  | DWORD * | pVal
 | ) |

最大レコード数の取得

CaoSQLHistoryの最大レコード数を取得します．

引数:
lIndex | : [out] 1 = プライマリ，2 = セカンダリ
pVal | : [out] 最大レコード数
戻り値:
HRESULT

HRESULT CCaoSQLHistoryMan::GetTableName | ( | long | lIndex,
 |  | BSTR * | pVal
 | ) |

テーブル名の取得

CaoSQLHistoryの対象テーブル名を取得します．

引数:
lIndex | : [out] 1 = プライマリ，2 = セカンダリ
pVal | : [out] テーブル名
戻り値:
HRESULT

HRESULT CCaoSQLHistoryMan::Initialize ( )

オブジェクトの初期化処理

レジストリ情報の読込みとConnectionの確立

戻り値:
HRESULT

CCaoSQLHistoryMan * CCaoSQLHistoryMan::Instance ( ) [static]

唯一のインスタンスを取得する

戻り値:
CCaoSQLHistoryMan ：　インスタンス

HRESULT CCaoSQLHistoryMan::RollbackTrans ( )

トランザクションの破棄

現在のトランザクションを破棄します．

戻り値:
HRESULT

void CCaoSQLHistoryMan::Terminate ( )

終了処理

CaoSQLHistoryの終了処理を行います．
デストラクタは効かないのでリソースはここで処分する．

このクラスの解説は次のファイルから生成されました:
  • CaoSQLHistoryMan.h
  • CaoSQLHistoryMan.cpp
Generated on Tue Dec 13 12:25:34 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CCaoSQLItem class Reference

クラス CCaoSQLItem の解説

CaoSQLのControllerクラス. [詳細]

#include <CaoSQLItem.h>

CCaoSQLItemに対する継承グラフ

[凡例]
CCaoSQLItemのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoSQLItem ()
コンストラクタ

~CCaoSQLItem ()
デストラクタ

HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | _Initialize (long lID, IXMLDOMNode *pItemNode, CCaoSQLController *pCtrl)
初期化処理(CaoSQL起動時)

HRESULT | _Initialize (long lID, VARIANT vntArrayData, CCaoSQLController *pCtrl)
初期化処理(AddItem時)

HRESULT | _Activate ()
アイテムの起動処理

void | _Deactivate ()
アイテムの不活性処理

HRESULT | _CacheValue (int iOpt=0)
ポーリング実行

CCaoSQLController * _GetController ()
親コントローラの取得

bool | _IsDynamicItem ()
動的アイテムフラグの取得

void | _IncrementDDEAdviseRef ()
DDEのHotLink参照数の追加.

void | _DecrementDDEAdviseRef ()
DDEのHotLink参照数を減らす.

DWORD | _GetDDEAdivseRef ()
DDEのHotLink参照数の取得.

HSZ | _GetHSZ ()
DDE文字列ハンドルの取得.

HRESULT | get_Value (VARIANT *pvntVal)
値の取得

HRESULT | put_Value (VARIANT vntNewVal)
値の設定

HRESULT | Snapshot ()
スナップショットの実行

HRESULT | get_Activation (VARIANT_BOOL *pbVal)
Activationの取得.

HRESULT | put_Activation (VARIANT_BOOL bNewVal)
Activationの設定.

HRESULT | get_DateTime (VARIANT *pvntVal)
値更新時刻の取得

HRESULT | get_Index (long *plVal)
Indexの取得.

HRESULT | get_LinkActivation (VARIANT_BOOL *pbVal)
LinkActivationの取得.

HRESULT | put_LinkActivation (VARIANT_BOOL pbVal)
LinkActivationの設定.

HRESULT | get_Microsecond (long *plVal)
マイクロ秒の取得

HRESULT | get_State (long *plVal)
状態の取得

HRESULT | get_Tag (VARIANT *pvntVal)
タグの取得

HRESULT | put_Tag (VARIANT vntNewVal)
タグの設定

HRESULT | put_ValueEx (long lDelay, VARIANT vntNewVal)
拡張値取得

HRESULT | get_Attribute (long *plVal)
Attributeの取得.

HRESULT | get_Description (BSTR *pbstrVal)
アイテムについての詳細取得

HRESULT | get_LinkItemNames (VARIANT *pvntVal)
リンクアイテム名の取得

HRESULT | get_Name (BSTR *pbstrVal)
アイテムマネージャ名の取得

HRESULT | get_SettingData (VARIANT vntName, VARIANT *pvntVal)
各種データ取得

HRESULT | put_SettingData (VARIANT vntName, VARIANT vntNewVal)
各種データ設定(未実装)

HRESULT | get_ID (VARIANT *pVal)
IDの取得.

HRESULT | put_ID (VARIANT newVal)
IDの設定.

HRESULT | get_Element (long lIndex1, long lIndex2, long lIndex3, VARIANT *pVal)
Elementの取得.

HRESULT | put_Element (long lIndex1, long lIndex2, long lIndex3, VARIANT newVal)
Elementの設定.

解説

CaoSQLのControllerクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoSQLItemを参照．
CaoSQLControllerクラスから呼び出されるクラス。外部からインスタンスの作成は不可能．
CaoSQLConfigで設定したItem情報の閲覧とItemの現在の値取得/設定等を行える．

コンストラクタとデストラクタの解説

CCaoSQLItem::CCaoSQLItem ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoSQLItem::~CCaoSQLItem ( ) [inline]

デストラクタ

オブジェクト消去時の処理．

メソッドの解説

HRESULT CCaoSQLItem::_Activate ( )

アイテムの起動処理

CaoVariableを取得し，サンプリングできる状態にします．

HRESULT CCaoSQLItem::_CacheValue ( int iOpt = 0 )

ポーリング実行

CaoSQLControllerのスレッドから呼び出されます．
CaoSQLController以外から呼び出す場合は_CacheValue()を使用してください．
CaoVariable::get_Valueの結果はメンバ変数m_vntValueに保存されます．
値の変更通知，アイテムのリンク処理等を行います．

引数:
iOpt : 値変化通知の設定
戻り値:
HRESULT

void CCaoSQLItem::_Deactivate ( )

アイテムの不活性処理

アイテムを終了する前にOnChangeObserver, LinkObserverの破棄等の終了前処理を行います．
この処理によって、安全に終了できる状態になります．

void CCaoSQLItem::_DecrementDDEAdviseRef ( )

DDEのHotLink参照数を減らす.

このアイテムにDDEのHotLinkが参照している数を１減らします．

CCaoSQLController * CCaoSQLItem::_GetController ( )

親コントローラの取得

このアイテム属する親コントローラへのポインタを取得します．

戻り値:
e コントローラへのポインタ

DWORD CCaoSQLItem::_GetDDEAdivseRef ( )

DDEのHotLink参照数の取得.

このアイテムにDDEのHotLinkが参照している数を取得します．

HSZ CCaoSQLItem::_GetHSZ ( )

DDE文字列ハンドルの取得.

このアイテムが持つDDEの文字列ハンドルを取得します．

戻り値:
DDE 文字列ハンドル

void CCaoSQLItem::_IncrementDDEAdviseRef ( )

DDEのHotLink参照数の追加.

このアイテムにDDEのHotLinkが参照している数を１増やします．

HRESULT CCaoSQLItem::_Initialize | ( | long | lIndex,
 |  | VARIANT | vntArrayData,
 |  | CCaoSQLController * | pCSCtrl
 | ) |

初期化処理(AddItem時)

AddItem()実行時のオブジェクト初期化処理を行います．

引数:
lIndex | : コレクションのIndex
vntArrayData: アイテムデータの配列
pCSCtrl | : 対応するCaoSQLControllerへのポインタ
戻り値:
HRESULT

HRESULT CCaoSQLItem::_Initialize | ( | long | lIndex,
 |  | IXMLDOMNode * | pItemNode,
 |  | CCaoSQLController * | pCSCtrl
 | ) |

初期化処理(CaoSQL起動時)

CaoSQL起動時のオブジェクト初期化処理を行います．

引数:
lIndex | : コレクションのIndex
pItemNode | : アイテムのノードへのポインタ
pCSCtrl | : 対応するCaoSQLControllerへのポインタ
戻り値:
HRESULT

bool CCaoSQLItem::_IsDynamicItem ( )

動的アイテムフラグの取得

このアイテムが動的アイテムであるかどうかのフラグを取得します．

HRESULT CCaoSQLItem::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoSQLItem::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoSQLItem::get_Activation ( VARIANT_BOOL * pbVal )

Activationの取得.

引数:
pbVal : [out] 使う/使わない
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::get_Attribute ( long * plVal )

Attributeの取得.

引数:
plVal : [out] 状態情報
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::get_DateTime ( VARIANT * pvntVal )

値更新時刻の取得

値が最後に更新された時刻を取得する．

引数:
pvntVal : [out] 時刻(VT_DATE)
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::get_Description ( BSTR * pbstrVal )

アイテムについての詳細取得

引数:
pbstrVal : [out] 詳細情報
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::get_Element | ( | long | lIndex1,
 |  | long | lIndex2,
 |  | long | lIndex3,
 |  | VARIANT * | pVal
 | ) |

Elementの取得.

CCaoItemに設定されているElementを取得します。

引数:
lIndex1 | : [in] 1次元目の要素番号
lIndex2 | : [in] 2次元目の要素番号
lIndex3 | : [in] 3次元目の要素番号
pVal | : [out] 要素値
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::get_ID ( VARIANT * pVal )

IDの取得.

CCaoItemに設定されているIDを取得する．

引数:
pVal : [out] ID
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::get_Index ( long * plVal )

Indexの取得.

引数:
plVal : [out] Index
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::get_LinkActivation ( VARIANT_BOOL * pbVal )

LinkActivationの取得.

引数:
pbVal : [out] 使う/使わない
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::get_LinkItemNames ( VARIANT * pvntVal )

リンクアイテム名の取得

引数:
pvntVal : [out] リンクアイテム名一覧(VT_ARRAY|VT_BSTR)
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::get_Microsecond ( long * plVal )

マイクロ秒の取得

引数:
plVal : [out] マイクロ秒
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::get_Name ( BSTR * pbstrVal )

アイテムマネージャ名の取得

引数:
pbstrVal : [out] 名前
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::get_SettingData | ( | VARIANT | vntName,
 |  | VARIANT * | pvntVal
 | ) |

各種データ取得

アイテムに関する各種データを取得します。

引数:
vntName | : [in] 取得するデータ(番号 or 名前)
pvntVal | : [out] 取得したデータ
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::get_State ( long * plVal )

状態の取得

CCaoSQLItemの状態を取得する．
詳細はenmCaoSQLItemStateを参照．

引数:
plVal : [out] ステータス
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::get_Tag ( VARIANT * pvntVal )

タグの取得

  ユーザが自由に使える多目的変数．

引数:
pvntVal : [out] タグデータ
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::get_Value ( VARIANT * pvntVal )

値の取得

CCaoItemが保持している値を取得する．

引数:
pvntVal : [out] 値
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

目的のオートメーションIFがエラーオブジェクトをサポートしているかの判定をします．
riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : インタフェース
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::put_Activation ( VARIANT_BOOL bNewVal )

Activationの設定.

引数:
bNewVal : [in] 使う/使わない
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::put_Element | ( | long | lIndex1,
 |  | long | lIndex2,
 |  | long | lIndex3,
 |  | VARIANT | newVal
 | ) |

Elementの設定.

CCaoItemのElementを設定する．

引数:
lIndex1 | : [in] 1次元目の要素番号
lIndex2 | : [in] 2次元目の要素番号
lIndex3 | : [in] 3次元目の要素番号
newVal | : [in] 要素値
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::put_ID ( VARIANT newVal )

IDの設定.

CCaoItemのIDを設定する．

引数:
newVal : [in] ID
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::put_LinkActivation ( VARIANT_BOOL bNewVal )

LinkActivationの設定.

引数:
bNewVal : [in] 使う/使わない
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::put_SettingData | ( | VARIANT | vntName,
 |  | VARIANT | vntNewVal
 | ) |

各種データ設定(未実装)

引数:
vntName | : [in] 設定するデータ(番号 or 名前)
vntNewVal | : [in] 設定する値
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::put_Tag ( VARIANT vntNewVal )

タグの設定

  ユーザが自由に使える多目的変数．

引数:
vntNewVal : [in] タグデータ
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::put_Value ( VARIANT vntNewVal )

値の設定

CCaoItemの値を設定する．

引数:
vntNewVal : [in] 値
戻り値:
HRESULT

STDMETHODIMP CCaoSQLItem::put_ValueEx | ( | long | lDelay,
 |  | VARIANT | vntNewVal
 | ) |

拡張値取得

  指定したディレイ時間分待ってから値を取得します．

引数:
lDelay | : [in] ディレイ時間
vntNewVal | : [in] タグデータ
戻り値:
HRESULT

HRESULT CCaoSQLItem::Snapshot ( )

スナップショットの実行

現在の値をHistoryに書き込みます．

戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoSQLItem.h
  • CaoSQLItem.cpp
Generated on Tue Dec 13 12:25:34 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CCaoSQLLinkObserver class Reference

クラス CCaoSQLLinkObserver の解説

CCaoSQLLinkObserverクラス. [詳細]

#include <CaoSQLLinkObserver.h>

CCaoSQLLinkObserverに対する継承グラフ

[凡例]
CCaoSQLLinkObserverのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoSQLLinkObserver ()
コンストラクタ

virtual | ~CCaoSQLLinkObserver ()
デストラクタ

HRESULT | Activate (VARIANT_BOOL bActive)
Activateメソッド.

HRESULT | Initialize (CCaoSQLItem *pItem)
初期化処理

HRESULT | Update (VARIANT vntNewVal)
更新メソッド

解説

CCaoSQLLinkObserverクラス.

CCaoSQLObserverを継承したクラス．
Link通知する役割を持ちます．

コンストラクタとデストラクタの解説

CCaoSQLLinkObserver::CCaoSQLLinkObserver ( )

コンストラクタ

オブジェクト生成時の処理．

CCaoSQLLinkObserver::~CCaoSQLLinkObserver ( ) [virtual]

デストラクタ

オブジェクト消去時の処理．

メソッドの解説

HRESULT CCaoSQLLinkObserver::Activate ( VARIANT_BOOL bActive )

Activateメソッド.

Link先更新をするか否かの設定行います．

引数:
bActive : [in] 更新設定

HRESULT CCaoSQLLinkObserver::Initialize ( CCaoSQLItem * pItem )

初期化処理

生成元のCCaoSQLItemのポインタ，親コントローラへのポインタを保存します．

引数:
pItem : [in] CCaoSQLItemへのポインタ

HRESULT CCaoSQLLinkObserver::Update ( VARIANT vntNewVal ) [virtual]

更新メソッド

Link先の更新を行います．

引数:
vntNewVal : [in] 更新する値

CCaoSQLObserverに実装されています.

このクラスの解説は次のファイルから生成されました:
  • CaoSQLLinkObserver.h
  • CaoSQLLinkObserver.cpp
Generated on Tue Dec 13 12:25:34 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CCaoSQLObserver class Reference

クラス CCaoSQLObserver の解説

CCaoSQLObserverクラス. [詳細]

#include <CaoSQLObserver.h>

CCaoSQLObserverに対する継承グラフ

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoSQLObserver ()
コンストラクタ

virtual | ~CCaoSQLObserver ()
デストラクタ

virtual HRESULT | Update (VARIANT vntNewVal)=0
更新通知メソッド

解説

CCaoSQLObserverクラス.

抽象クラスなのでインスタンスの作成はできません．
継承して使用します．

コンストラクタとデストラクタの解説

CCaoSQLObserver::CCaoSQLObserver ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoSQLObserver::~CCaoSQLObserver ( ) [inline, virtual]

デストラクタ

メソッドの解説

virtual HRESULT CCaoSQLObserver::Update ( VARIANT vntNewVal ) [pure virtual]

更新通知メソッド

純粋仮想関数です．このクラスを継承するクラスは必ずこのメソッドを オーバーライドしてください．

引数:
vntNewVal : 通知内容
戻り値:
HRESULT

CCaoSQLLinkObserver, CCaoSQLOnChangeObserver, と CCaoSQLTriggerObserverを実装しています.

このクラスの解説は次のファイルから生成されました:
  • CaoSQLObserver.h
  • CaoSQLObserver.cpp
Generated on Tue Dec 13 12:25:34 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CCaoSQLOnChangeObserver class Reference

クラス CCaoSQLOnChangeObserver の解説

CCaoSQLOnChangeObserverクラス. [詳細]

#include <CaoSQLOnChangeObserver.h>

CCaoSQLOnChangeObserverに対する継承グラフ

[凡例]
CCaoSQLOnChangeObserverのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoSQLOnChangeObserver ()
コンストラクタ

virtual | ~CCaoSQLOnChangeObserver ()
デストラクタ

HRESULT | Initialize (CCaoSQLItem *pItem)
初期化処理

HRESULT | Update (VARIANT vntNewVal)
更新メソッド

解説

CCaoSQLOnChangeObserverクラス.

CCaoSQLObserverを継承したクラス．
更新通知する役割を持ちます．

コンストラクタとデストラクタの解説

CCaoSQLOnChangeObserver::CCaoSQLOnChangeObserver ( )

コンストラクタ

オブジェクト生成時の処理．

CCaoSQLOnChangeObserver::~CCaoSQLOnChangeObserver ( ) [virtual]

デストラクタ

オブジェクト消去時の処理．

メソッドの解説

HRESULT CCaoSQLOnChangeObserver::Initialize ( CCaoSQLItem * pItem )

初期化処理

生成元のCCaoSQLItemのポインタ，親コントローラへのポインタを保存します．

引数:
pItem : [in] CCaoSQLItemへのポインタ

HRESULT CCaoSQLOnChangeObserver::Update ( VARIANT vntNewVal ) [virtual]

更新メソッド

OnChangeItemイベントの発生を行います．

CCaoSQLObserverに実装されています.

このクラスの解説は次のファイルから生成されました:
  • CaoSQLOnChangeObserver.h
  • CaoSQLOnChangeObserver.cpp
Generated on Tue Dec 13 12:25:35 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CCaoSQLRACSvr class Reference

クラス CCaoSQLRACSvr の解説

#include <CaoSQLRACSvr.h>

CCaoSQLRACSvrのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoSQLRACSvr ()
~CCaoSQLRACSvr ()
HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

コンストラクタとデストラクタの解説

CCaoSQLRACSvr::CCaoSQLRACSvr ( ) [inline]

CCaoSQLRACSvr::~CCaoSQLRACSvr ( ) [inline]

メソッドの解説

HRESULT CCaoSQLRACSvr::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoSQLRACSvr::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoSQLRACSvr::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

目的のオートメーションIFがエラーオブジェクトをサポートしているかの判定をします．
riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : インタフェース
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoSQLRACSvr.h
  • CaoSQLRACSvr.cpp
Generated on Tue Dec 13 12:25:35 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CCaoSQLTriggerObserver class Reference

クラス CCaoSQLTriggerObserver の解説

CCaoSQLTriggerObserverクラス. [詳細]

#include <CaoSQLTriggerObserver.h>

CCaoSQLTriggerObserverに対する継承グラフ

[凡例]
CCaoSQLTriggerObserverのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoSQLTriggerObserver ()
コンストラクタ

virtual | ~CCaoSQLTriggerObserver ()
デストラクタ

HRESULT | Initialize (CCaoSQLController *pCSCtrl)
初期化処理

HRESULT | RegisterTriggerItem (long lAction, long lCondition, BSTR bstrThreshold)
トリガ条件を登録します

HRESULT | Update (VARIANT vntNewVal)
更新メソッド

解説

CCaoSQLTriggerObserverクラス.

CCaoSQLObserverを継承したクラス．
条件トリガのマッチを通知します．

コンストラクタとデストラクタの解説

CCaoSQLTriggerObserver::CCaoSQLTriggerObserver ( )

コンストラクタ

オブジェクト生成時の処理．

CCaoSQLTriggerObserver::~CCaoSQLTriggerObserver ( ) [virtual]

デストラクタ

オブジェクト消去時の処理．

メソッドの解説

HRESULT CCaoSQLTriggerObserver::Initialize ( CCaoSQLController * pCSCtrl )

初期化処理

トリガ実行するCCaoSQLContrllerのポインタを保存します．

引数:
pCSCtrl : [in] CCaoSQLontrollerへのポインタ
戻り値:
S_OK

HRESULT CCaoSQLTriggerObserver::RegisterTriggerItem | ( | long | lAction,
 |  | long | lCondition,
 |  | BSTR | bstrThreshold
 | ) |

トリガ条件を登録します

トリガする条件をメンバに保存しておきます．

引数:
lAction | : [in] トリガアクション
lCondition | : [in] トリガ判定条件
bstrThreshold | : [in] トリガ閾値
戻り値:
HRESULT

HRESULT CCaoSQLTriggerObserver::Update ( VARIANT vntNewVal ) [virtual]

更新メソッド

トリガします

引数:
vntNewVal : [in] 状態

CCaoSQLObserverに実装されています.

このクラスの解説は次のファイルから生成されました:
  • CaoSQLTriggerObserver.h
  • CaoSQLTriggerObserver.cpp
Generated on Tue Dec 13 12:25:35 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CDDEServer class Reference

クラス CDDEServer の解説

DDEのServer処理を行うクラス. [詳細]

#include <DDEServer.h>

すべてのメンバ一覧

Public メソッド

HRESULT | Initialize ()
初期化処理

void | Terminate ()
終了処理

DWORD | GetInstanceID ()
DDEのインスタンスIDの取得.

Static Public メソッド

CDDEServer * | Instance ()
唯一のインスタンスを取得する．

解説

DDEのServer処理を行うクラス.

DDEクライアントからの要求に対して処理を行うクラス．
このクラスを最初に使用するときはInitializeを実行してください．
このクラスを使用し終えたらTerminateを実行してください．
デザインパターンSingletonを適用．

  • このクラスのインスタンスは必ず一つしか生成されません
  • コンストラクタはprivateなので外部からnew出来ません
  • インスタンスの取得をするには唯一Instanceメソッドのみが用意されています

メソッドの解説

DWORD CDDEServer::GetInstanceID ( )

DDEのインスタンスIDの取得.

DDEのインスタンスIDを取得します

HRESULT CDDEServer::Initialize ( )

初期化処理

オブジェクト生成後の初期化処理．

戻り値:
HRESULT

CDDEServer * CDDEServer::Instance ( ) [static]

唯一のインスタンスを取得する．

インスタンスの取得

戻り値:
CDDEServerのインスタンスへのポインタ

void CDDEServer::Terminate ( )

終了処理

オブジェクト消去前の終了処理

このクラスの解説は次のファイルから生成されました:
  • DDEServer.h
  • DDEServer.cpp
Generated on Tue Dec 13 12:25:35 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CLockCriticalSection class Reference

クラス CLockCriticalSection の解説

CLockCriticalSection クラス. [詳細]

#include <LockCriticalSection.h>

すべてのメンバ一覧

Public メソッド

CLockCriticalSection (CRITICAL_SECTION &cs)
コンストラクタ

~CLockCriticalSection ()
デストラクタ

void | Lock ()
ロック

void | Unlock ()
アンロック

Public 変数

CRITICAL_SECTION & | m_cs
クリティカルセクションオブジェクトへの参照

解説

CLockCriticalSection クラス.

クリティカルセクションをロックするクラス．
初期化時にCRITICAL_SECTIONを指定する必要があります．

コンストラクタとデストラクタの解説

CLockCriticalSection::CLockCriticalSection ( CRITICAL_SECTION & cs ) [inline]

コンストラクタ

クラスの初期化時にm_csの初期化が必要なので CRITICAL_SECTIONオブジェクトを指定する必要があります．

引数:
cs : CRITICAL_SECTIONオブジェクトへの参照

CLockCriticalSection::~CLockCriticalSection ( ) [inline]

デストラクタ

クラスの解放時に、ロックされたクリティカルセクションを解放します

メソッドの解説

void CLockCriticalSection::Lock ( ) [inline]

ロック

クリティカルセクションをロックします

void CLockCriticalSection::Unlock ( ) [inline]

アンロック

クリティカルセクションのロックを解除します

変数の解説

CRITICAL_SECTION& CLockCriticalSection::m_cs

クリティカルセクションオブジェクトへの参照

このクラスの解説は次のファイルから生成されました:
  • LockCriticalSection.h
Generated on Tue Dec 13 12:25:35 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


TemplateCProxy_ICaoSQLEvents< T > class Reference

クラス テンプレートCProxy_ICaoSQLEvents< T > の解説

CaoSQLのイベントプロキシテンプレートクラス. [詳細]

#include <CaoSQLCP.h>

CProxy_ICaoSQLEvents< T >に対する継承グラフ

[凡例]
CProxy_ICaoSQLEvents< T >のコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

HRESULT | Fire_OnChangeItem (ICaoSQLItem *pICSItem)
アイテム値の変更の通知

HRESULT | Fire_OnChangeState (long lNewVal)
コントローラの状態変更通知

解説

template<class T>
class CProxy_ICaoSQLEvents< T >

CaoSQLのイベントプロキシテンプレートクラス.

クライアントに対してイベントのコネクションポインタを公開するテンプレート．
OnChangeイベントのIFを持つ．
このテンプレートクラスを継承することによってOnChangeイベントを発生させることが可能となる．

メソッドの解説

template<class T>
HRESULT CProxy_ICaoSQLEvents< T >::Fire_OnChangeItem ( ICaoSQLItem * pICSItem ) [inline]

アイテム値の変更の通知

このメソッドをコールするとクライアントでイベントが発生します．

引数:
pICSItem : CaoSQLItem IFポインタ
戻り値:
HRESULT

template<class T>
HRESULT CProxy_ICaoSQLEvents< T >::Fire_OnChangeState ( long lNewVal ) [inline]

コントローラの状態変更通知

このメソッドをコールするとクライアントでイベントが発生します．

引数:
lNewVal : 状態
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoSQLCP.h
Generated on Tue Dec 13 12:25:35 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CRACEventSink class Reference

クラス CRACEventSink の解説

CAOプロバイダのRACEventSinkクラス. [詳細]

#include <EventSink.h>

CRACEventSinkのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CRACEventSink ()
コンストラクタ

~CRACEventSink ()
HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

HRESULT | _Terminate ()
後処理

HRESULT | OnMessage (IUnknown *pVal)
OnMessageのイベント処理.

解説

CAOプロバイダのRACEventSinkクラス.

CAOからのOnMessageイベントを受け取り，RACコマンドの処理を行う．

コンストラクタとデストラクタの解説

CRACEventSink::CRACEventSink ( ) [inline]

コンストラクタ

  オブジェクト生成時の処理．

CRACEventSink::~CRACEventSink ( ) [inline]

メソッドの解説

STDMETHODIMP CRACEventSink::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in]　vntArgs[0] - CaoSQLControllerのIFポインタ(接続先) 　　　　　 vntArgs[1] - RacDataのIFポインタ
戻り値:
HRESULT

STDMETHODIMP CRACEventSink::_Terminate ( )

後処理

  オブジェクト消滅時の後処理は FinalRelease() を使うこと．

戻り値:
HRESULT

HRESULT CRACEventSink::FinalConstruct ( )

ファイナルコンストラクタ

  オブジェクト生成時に一度だけ呼ばれます．

void CRACEventSink::FinalRelease ( )

ファイナルデストラクタ

  オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CRACEventSink::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

  riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : [in] インタフェース
戻り値:
HRESULT

STDMETHODIMP CRACEventSink::OnMessage ( IUnknown * pVal )

OnMessageのイベント処理.

  CaoProviderで発生したOnMessageイベントを処理する．

引数:
pVal : [in]　メッセージ
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • EventSink.h
  • EventSink.cpp
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CRACServer class Reference

クラス CRACServer の解説

#include <RACServer.h>

すべてのメンバ一覧

Public メソッド

HRESULT | Initialize ()
オブジェクトの初期化処理

void | Terminate ()
終了処理

Static Public メソッド

CRACServer * | Instance ()
唯一のインスタンスを取得する

メソッドの解説

HRESULT CRACServer::Initialize ( )

オブジェクトの初期化処理

レジストリ情報の読込みとConnectionの確立

戻り値:
HRESULT

CRACServer * CRACServer::Instance ( ) [static]

唯一のインスタンスを取得する

戻り値:
インスタンス

void CRACServer::Terminate ( )

終了処理

CRACServerの終了処理を行います．

このクラスの解説は次のファイルから生成されました:
  • RACServer.h
  • RACServer.cpp
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CReadXML class Reference

クラス CReadXML の解説

XMLファイルノード読取操作のクラス. [詳細]

#include <ReadXML.h>

すべてのメンバ一覧

Public メソッド

CReadXML::CReadXML ()
コンストラクタ

CReadXML::~CReadXML ()
デストラクタ

HRESULT QueryValue (IXMLDOMNode *pINode, BSTR bstrNodeName, BSTR *pbstrData)
指定したノード内で、指定したタグの値を取得します．

解説

XMLファイルノード読取操作のクラス.

コンストラクタとデストラクタの解説

CReadXML::CReadXML::~CReadXML ( ) [inline]

デストラクタ

オブジェクト消去時の処理．

メソッドの解説

CReadXML::CReadXML::CReadXML ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

HRESULT CReadXML::QueryValue | ( | IXMLDOMNode * | pINode,
 |  | BSTR | bstrNodeName,
 |  | BSTR * | pbstrData
 | ) | [inline]

指定したノード内で、指定したタグの値を取得します．

引数:
pINode | : [in] 検索対象ノード
bstrNodeName | : [in] 検索対象タグ名
pbstrData | : [out] タグの値
戻り値:
S_OK : 関数の成功
S_OK以外 : 関数の失敗

このクラスの解説は次のファイルから生成されました:
  • ReadXML.h
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CRegKeyEx class Reference

クラス CRegKeyEx の解説

レジストリ操作のクラス [詳細]

#include <RegKeyEx.h>

すべてのメンバ一覧

Public メソッド

CRegKeyEx ()
コンストラクタ

~CRegKeyEx ()
デストラクタ

LONG | EnumKeys (DWORD dwIndex, LPTSTR lpName, LPDWORD lpcName)
サブキーを列挙します

LONG | QueryValue (LPTSTR szValue, LPCTSTR lpszValueName, DWORD *pdwCount)
指定された値フィールドのデータを取得します．

LONG | QueryValue (DWORD &dwValue, LPCTSTR lpszValueName)
指定された値フィールドのデータを取得します．

解説

レジストリ操作のクラス

ATLのCRegKeyの実装を継承し拡張しています．

コンストラクタとデストラクタの解説

CRegKeyEx::CRegKeyEx ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CRegKeyEx::~CRegKeyEx ( ) [inline]

デストラクタ

オブジェクト消去時の処理．

メソッドの解説

LONG CRegKeyEx::EnumKeys | ( | DWORD | dwIndex,
 |  | LPTSTR | lpName,
 |  | LPDWORD | lpcName
 | ) | [inline]

サブキーを列挙します

内部でRegEnumKeyExをコールしています．

戻り値:
ERROR_SUCCESS | : 関数の成功
ERROR_SUCCESS | 以外 : 関数の失敗
引数:
dwIndex : 取得するべきサブキーのインデックス番号を指定します．
最初にこの関数を呼び出すときは，0 を指定します．
そして，次の呼び出し時は 1，その次は 2 と，1 つずつ増やしていきます．
サブキーはインデックス番号の順に配置されているわけではないので，
新しいサブキーを作成した場合，任意のインデックス番号が割り当てられます
（現在の最大のインデックス番号に 1 を足した値とは限りません）．
言い換えると，この関数で指定したインデックス番号と，
返されるサブキーの間に直接の関係はなく，実行してみるまでは，
どのサブキーが返されるのかわかりません．
lpName : 1 個のバッファへのポインタを指定します．関数から制御が返ると，このバッファに
サブキーと最後の NULL が格納されます．この関数は，サブキーの名前だけを格納します．
階層全体を格納するわけではありません．
lpcName : lpName パラメータで指定したバッファのサイズ（終端の NULL 文字を含む）を
TCHAR 単位で保持している，1 個の変数へのポインタを指定します．
関数から制御が返ると，この変数に同じバッファに格納された文字数が格納されます
（終端の NULL 文字を除く）．

LONG CRegKeyEx::QueryValue | ( | DWORD & | dwValue,
 |  | LPCTSTR | lpszValueName
 | ) | [inline]

指定された値フィールドのデータを取得します．

フィールドの値がREG_DWORDの場合はこちらのオーバーロード関数を使用します． CRegKey::QueryValue(DWORD&, LPCTSTR)をコールします． CRegKeyEx::QueryValue関数をオーバーライドした為，QueryValue関数のオーバーロード関数で あるCRegKey::QueryValue(DWORD&, LPCTSTR)もオーバーライドしてあります．

戻り値:
ERROR_SUCCESS | : 関数の成功
ERROR_SUCCESS | 以外 : 関数の失敗
引数:
dwValue | : [out] 値フィールドの数値データ．
lpszValueName | : [in] レジストリエントリ名．

LONG CRegKeyEx::QueryValue | ( | LPTSTR | szValue,
 |  | LPCTSTR | lpszValueName,
 |  | DWORD * | pdwCount
 | ) | [inline]

指定された値フィールドのデータを取得します．

フィールドの値がREG_SZの場合はこちらのオーバーロード関数を使用します． バッファをクリアしてからCRegKey::QueryValue(LPTSTR, LPCTSTR, DWORD*)をコールします．

戻り値:
ERROR_SUCCESS | : 関数の成功
ERROR_SUCCESS | 以外 : 関数の失敗
引数:
szValue | : [out] 値フィールドの文字列データ．
lpszValueName | : [in] レジストリエントリ名．
pdwCount | : [in/out] 文字列データのサイズ．初期値は，バッファ szValue のサイズに設定されます．

このクラスの解説は次のファイルから生成されました:
  • RegKeyEx.h
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CServiceModule class Reference

クラス CServiceModule の解説

CaoSQLのサービスモジュール. [詳細]

#include <StdAfx.h>

すべてのメンバ一覧

Public メソッド

CServiceModule ()
コンストラクタ

~CServiceModule ()
デストラクタ

HRESULT | RegisterServer (BOOL bRegTypeLib, BOOL bService)
HRESULT | UnregisterServer ()
void | Init (_ATL_OBJMAP_ENTRY *p, HINSTANCE h, UINT nServiceNameID, const GUID *plibid=NULL)
void | Start ()
void | ServiceMain (DWORD dwArgc, LPTSTR *lpszArgv)
void | Handler (DWORD dwOpcode)
void | Run ()
BOOL | IsInstalled ()
BOOL | Install ()
BOOL | Uninstall ()
LONG | Unlock ()
void | LogEvent (DWORD dwLevel, LPCTSTR pFormat,...)
イベントログに出力

void | SetServiceStatus (DWORD dwState)
void | SetupAsLocalServer ()

Public 変数

TCHAR | m_szServiceName [256]
サービス名

TCHAR | m_szDataPath [FILENAME_MAX]
データファイルパス

SERVICE_STATUS_HANDLE | m_hServiceStatus
サービスステータスハンドル

SERVICE_STATUS | m_status
サービスステータス

DWORD | dwThreadID
スレッドID

BOOL | m_bService
サービスの有無

LCID | m_lcid
ロケールID

BOOL | m_bNotRepeatError
エラーログを繰り返し出力する/しない

BOOL | m_bDCOMEnabled
DCOMの有効／無効スイッチ.

BOOL | m_bDDEEnabled
DDEサーバの有効／無効スイッチ.

BOOL | m_bJNIEnabled
JNIの有効／無効スイッチ.

BOOL | m_bCORBAEnabled
CORBAの有効／無効スイッチ.

BSTR | m_bstrCORBAOption
CORBAオプション文字列.

BOOL | m_bRACSvrEnabled
RACServerの有効／無効スイッチ.

解説

CaoSQLのサービスモジュール.

CaoSQL.exeはサービスとしてインプリメントされています．
CaoSQL.exeをサービスとして登録するには以下のコマンドを実行します．

  • CaoSQL.exe /Service
    CaoSQL.exeをCOMサーバとして登録するには以下のコマンドを実行します．
  • CaoSQL.exe /Regserver
    CaoSQL.exeの登録を消去するには以下のコマンドを実行します．
  • CaoSQL.exe /UnRegserver
警告:
CComModule クラスから派生したクラスを使用して、オーバーライドする場合 _Module の名前は変更しないでください．

コンストラクタとデストラクタの解説

CServiceModule::CServiceModule ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CServiceModule::~CServiceModule ( ) [inline]

デストラクタ

オブジェクト消去時の処理．

メソッドの解説

void CServiceModule::Handler ( DWORD dwOpcode ) [inline]

void CServiceModule::Init | ( | _ATL_OBJMAP_ENTRY * | p,
 |  | HINSTANCE | h,
 |  | UINT | nServiceNameID,
 |  | const GUID * | plibid = NULL
 | ) | [inline]

BOOL CServiceModule::Install ( ) [inline]

BOOL CServiceModule::IsInstalled ( )

void CServiceModule::LogEvent | ( | DWORD | dwLevel,
 |  | LPCTSTR | pFormat,
 |  | ... |
 | ) |

イベントログに出力

  インライン展開されます

引数:
dwLevel | : [in] メッセージのログレベル
pFormat | : [in] 書式制御
... : [in] オプションの引数

HRESULT CServiceModule::RegisterServer | ( | BOOL | bRegTypeLib,
 |  | BOOL | bService
 | ) | [inline]

void CServiceModule::Run ( )

void CServiceModule::ServiceMain | ( | DWORD | dwArgc,
 |  | LPTSTR * | lpszArgv
 | ) | [inline]

void CServiceModule::SetServiceStatus ( DWORD dwState )

void CServiceModule::SetupAsLocalServer ( )

void CServiceModule::Start ( ) [inline]

BOOL CServiceModule::Uninstall ( ) [inline]

LONG CServiceModule::Unlock ( )

HRESULT CServiceModule::UnregisterServer ( ) [inline]

変数の解説

DWORD CServiceModule::dwThreadID

スレッドID

BOOL CServiceModule::m_bCORBAEnabled

CORBAの有効／無効スイッチ.

BOOL CServiceModule::m_bDCOMEnabled

DCOMの有効／無効スイッチ.

BOOL CServiceModule::m_bDDEEnabled

DDEサーバの有効／無効スイッチ.

BOOL CServiceModule::m_bJNIEnabled

JNIの有効／無効スイッチ.

BOOL CServiceModule::m_bNotRepeatError

エラーログを繰り返し出力する/しない

BOOL CServiceModule::m_bRACSvrEnabled

RACServerの有効／無効スイッチ.

BOOL CServiceModule::m_bService

サービスの有無

BSTR CServiceModule::m_bstrCORBAOption

CORBAオプション文字列.

SERVICE_STATUS_HANDLE CServiceModule::m_hServiceStatus

サービスステータスハンドル

LCID CServiceModule::m_lcid

ロケールID

SERVICE_STATUS CServiceModule::m_status

サービスステータス

TCHAR CServiceModule::m_szDataPath[FILENAME_MAX]

データファイルパス

TCHAR CServiceModule::m_szServiceName[256]

サービス名

このクラスの解説は次のファイルから生成されました:
  • StdAfx.h
  • CaoSQL.cpp
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


ICaoSQLController interface Reference

インタフェースICaoSQLController の解説

ICaoSQLController Interface. [詳細]

import "CaoSQL.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | _NewEnum ([out, retval] LPUNKNOWN *pVal)
HRESULT | Item ([in] VARIANT vntIndex,[out, retval] ICaoSQLItem **ppICSItem)
HRESULT | Start ()
HRESULT | Stop ()
HRESULT | Snapshot ()
HRESULT | AddItem ([in] VARIANT vntDataArray)
HRESULT | RemoveItem ([in] VARIANT vntIndex)
HRESULT | Execute ([in] BSTR bstrCommand,[in, optional] VARIANT vntParam,[out, retval] VARIANT *pvntVal)
HRESULT | Count ([out, retval] long *plVal)
HRESULT | Index ([out, retval] long *plVal)
HRESULT | ItemNames ([out, retval] VARIANT *pvntVal)
HRESULT | ScanTimes ([in] long lIndex,[out, retval] long *plVal)
HRESULT | State ([out, retval] long *plVal)
HRESULT | Tag ([out, retval] VARIANT *pvntVal)
HRESULT | Tag ([in] VARIANT vntNewVal)
HRESULT | Description ([out, retval] BSTR *pbstrVal)
HRESULT | Name ([out, retval] BSTR *pbstrVal)
HRESULT | SettingData ([in] VARIANT vntName,[out, retval] VARIANT *pvntVal)
HRESULT | SettingData ([in] VARIANT vntName,[in] VARIANT vntNewVal)
rsHRESULT | get_ItemNames (out any pVal)
rsHRESULT | get_Item (in any vntIndex, out ICaoSQLItem piItem)
rsHRESULT | get_Count (out long pVal)
rsHRESULT | get_Name (out string pVal)
rsHRESULT | get_Provider (out string pVal)
rsHRESULT | get_Machine (out string pVal)
rsHRESULT | get_ControllerName (out string pVal)
rsHRESULT | get_Parameter (out string pVal)
rsHRESULT | get_SamplingRate (out long pVal)
rsHRESULT | get_Description (out string pVal)
rsHRESULT | get_UseOnChange (out boolean pVal)
rsHRESULT | get_UseHistory (out boolean pVal)
rsHRESULT | get_State (out enmCaoSQLControllerState pVal)
rsHRESULT | get_ID (out long pVal)
rsHRESULT | get_Tag (out any pVal)
rsHRESULT | put_Tag (in any newVal)
rsHRESULT Start ()
rsHRESULT Stop ()
rsHRESULT | Snapshot (in string newVal)

解説

ICaoSQLController Interface.

メソッドの解説

HRESULT ICaoSQLController::_NewEnum ( [out, retval] LPUNKNOWN * pVal )

HRESULT ICaoSQLController::AddItem ( [in] VARIANT vntDataArray )

HRESULT ICaoSQLController::Count ( [out, retval] long * plVal )

HRESULT ICaoSQLController::Description ( [out, retval] BSTR * pbstrVal )

HRESULT ICaoSQLController::Execute | ( | [in] BSTR | bstrCommand,
 |  | [in, optional] VARIANT | vntParam,
 |  | [out, retval] VARIANT * | pvntVal
 | ) |

rsHRESULT ICaoSQLController::get_ControllerName ( out string pVal )

rsHRESULT ICaoSQLController::get_Count ( out long pVal )

rsHRESULT ICaoSQLController::get_Description ( out string pVal )

rsHRESULT ICaoSQLController::get_ID ( out long pVal )

rsHRESULT ICaoSQLController::get_Item | ( | in any | vntIndex,
 |  | out ICaoSQLItem | piItem
 | ) |

rsHRESULT ICaoSQLController::get_ItemNames ( out any pVal )

rsHRESULT ICaoSQLController::get_Machine ( out string pVal )

rsHRESULT ICaoSQLController::get_Name ( out string pVal )

rsHRESULT ICaoSQLController::get_Parameter ( out string pVal )

rsHRESULT ICaoSQLController::get_Provider ( out string pVal )

rsHRESULT ICaoSQLController::get_SamplingRate ( out long pVal )

rsHRESULT ICaoSQLController::get_State ( out enmCaoSQLControllerState pVal )

rsHRESULT ICaoSQLController::get_Tag ( out any pVal )

rsHRESULT ICaoSQLController::get_UseHistory ( out boolean pVal )

rsHRESULT ICaoSQLController::get_UseOnChange ( out boolean pVal )

HRESULT ICaoSQLController::Index ( [out, retval] long * plVal )

HRESULT ICaoSQLController::Item | ( | [in] VARIANT | vntIndex,
 |  | [out, retval] ICaoSQLItem ** | ppICSItem
 | ) |

HRESULT ICaoSQLController::ItemNames ( [out, retval] VARIANT * pvntVal )

HRESULT ICaoSQLController::Name ( [out, retval] BSTR * pbstrVal )

rsHRESULT ICaoSQLController::put_Tag ( in any newVal )

HRESULT ICaoSQLController::RemoveItem ( [in] VARIANT vntIndex )

HRESULT ICaoSQLController::ScanTimes | ( | [in] long | lIndex,
 |  | [out, retval] long * | plVal
 | ) |

HRESULT ICaoSQLController::SettingData | ( | [in] VARIANT | vntName,
 |  | [in] VARIANT | vntNewVal
 | ) |

HRESULT ICaoSQLController::SettingData | ( | [in] VARIANT | vntName,
 |  | [out, retval] VARIANT * | pvntVal
 | ) |

rsHRESULT ICaoSQLController::Snapshot ( in string newVal )

HRESULT ICaoSQLController::Snapshot ( )

rsHRESULT ICaoSQLController::Start ( )

HRESULT ICaoSQLController::Start ( )

HRESULT ICaoSQLController::State ( [out, retval] long * plVal )

rsHRESULT ICaoSQLController::Stop ( )

HRESULT ICaoSQLController::Stop ( )

HRESULT ICaoSQLController::Tag ( [in] VARIANT vntNewVal )

HRESULT ICaoSQLController::Tag ( [out, retval] VARIANT * pvntVal )

このインタフェースの解説は次のファイルから生成されました:
  • CaoSQL.idl
  • CorbaCaoSQL.idl
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


ICaoSQLEngine interface Reference

インタフェースICaoSQLEngine の解説

ICaoSQLEngine Interface. [詳細]

import "CaoSQL.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | _NewEnum ([out, retval] LPUNKNOWN *pVal)
HRESULT | Controller ([in] VARIANT vntIndex,[out, retval] ICaoSQLController **ppICSCtrl)
HRESULT | Start ()
HRESULT | Stop ()
HRESULT | Snapshot ()
HRESULT | Execute ([in] BSTR bstrCmdText,[out, retval] VARIANT *pvntVal)
HRESULT | CaoSQLHistory ([out, retval] ICaoSQLHistory **ppICSHstry)
HRESULT | ControllerNames ([out, retval] VARIANT *pvntVal)
HRESULT | Count ([out, retval] long *plVal)
rsHRESULT | get_ControllerNames (out any pVal)
rsHRESULT | get_Controller (in any vntIndex, out ICaoSQLController piCtrl)
rsHRESULT | get_Count (out long pVal)
rsHRESULT | Start (in string newVal)
rsHRESULT | Stop (in string newVal)
rsHRESULT | Snapshot (in string newVal)

解説

ICaoSQLEngine Interface.

メソッドの解説

HRESULT ICaoSQLEngine::_NewEnum ( [out, retval] LPUNKNOWN * pVal )

HRESULT ICaoSQLEngine::CaoSQLHistory ( [out, retval] ICaoSQLHistory ** ppICSHstry )

HRESULT ICaoSQLEngine::Controller | ( | [in] VARIANT | vntIndex,
 |  | [out, retval] ICaoSQLController ** | ppICSCtrl
 | ) |

HRESULT ICaoSQLEngine::ControllerNames ( [out, retval] VARIANT * pvntVal )

HRESULT ICaoSQLEngine::Count ( [out, retval] long * plVal )

HRESULT ICaoSQLEngine::Execute | ( | [in] BSTR | bstrCmdText,
 |  | [out, retval] VARIANT * | pvntVal
 | ) |

rsHRESULT ICaoSQLEngine::get_Controller | ( | in any | vntIndex,
 |  | out ICaoSQLController | piCtrl
 | ) |

rsHRESULT ICaoSQLEngine::get_ControllerNames ( out any pVal )

rsHRESULT ICaoSQLEngine::get_Count ( out long pVal )

rsHRESULT ICaoSQLEngine::Snapshot ( in string newVal )

HRESULT ICaoSQLEngine::Snapshot ( )

rsHRESULT ICaoSQLEngine::Start ( in string newVal )

HRESULT ICaoSQLEngine::Start ( )

rsHRESULT ICaoSQLEngine::Stop ( in string newVal )

HRESULT ICaoSQLEngine::Stop ( )

このインタフェースの解説は次のファイルから生成されました:
  • CaoSQL.idl
  • CorbaCaoSQL.idl
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


ICaoSQLHistory interface Reference

インタフェースICaoSQLHistory の解説

ICaoSQLHistory Interface. [詳細]

import "CaoSQL.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | Execute ([in] BSTR bstrCmdText,[out, retval] VARIANT *pvntVal)
HRESULT | ConnectionString ([in] long lIndex,[out, retval] BSTR *pbstrVal)
HRESULT | Enable ([out, retval] VARIANT_BOOL *pbVal)
HRESULT | MaxRecord ([in] long lIndex,[out, retval] long *plVal)
HRESULT | TableName ([in] long lIndex,[out, retval] BSTR *pbstrVal)

解説

ICaoSQLHistory Interface.

メソッドの解説

HRESULT ICaoSQLHistory::ConnectionString | ( | [in] long | lIndex,
 |  | [out, retval] BSTR * | pbstrVal
 | ) |

HRESULT ICaoSQLHistory::Enable ( [out, retval] VARIANT_BOOL * pbVal )

HRESULT ICaoSQLHistory::Execute | ( | [in] BSTR | bstrCmdText,
 |  | [out, retval] VARIANT * | pvntVal
 | ) |

HRESULT ICaoSQLHistory::MaxRecord | ( | [in] long | lIndex,
 |  | [out, retval] long * | plVal
 | ) |

HRESULT ICaoSQLHistory::TableName | ( | [in] long | lIndex,
 |  | [out, retval] BSTR * | pbstrVal
 | ) |

このインタフェースの解説は次のファイルから生成されました:
  • CaoSQL.idl
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


ICaoSQLItem interface Reference

インタフェースICaoSQLItem の解説

ICaoSQLItem Interface. [詳細]

import "CaoSQL.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | Value ([out, retval] VARIANT *pvntVal)
HRESULT | Value ([in] VARIANT vntNewVal)
HRESULT | Snapshot ()
HRESULT | Activation ([out, retval] VARIANT_BOOL *pbVal)
HRESULT | Activation ([in] VARIANT_BOOL bNewVal)
HRESULT | DateTime ([out, retval] VARIANT *pvntVal)
HRESULT | Index ([out, retval] long *plVal)
HRESULT | LinkActivation ([out, retval] VARIANT_BOOL *pbVal)
HRESULT | LinkActivation ([in] VARIANT_BOOL bNewVal)
HRESULT | Microsecond ([out, retval] long *plVal)
HRESULT | State ([out, retval] long *plVal)
HRESULT | Tag ([out, retval] VARIANT *pvntVal)
HRESULT | Tag ([in] VARIANT vntNewVal)
HRESULT | ValueEx ([in, defaultvalue(0)] long lDelay, VARIANT vntNewVal)
HRESULT | Attribute ([out, retval] long *plVal)
HRESULT | Description ([out, retval] BSTR *pbstrVal)
HRESULT | Element ([in] long lIndex1,[in, defaultvalue(0)] long lIndex2,[in, defaultvalue(0)] long lIndex3,[out, retval] VARIANT *pVal)
HRESULT | Element ([in] long lIndex1,[in, defaultvalue(0)] long lIndex2,[in, defaultvalue(0)] long lIndex3,[in] VARIANT newVal)
HRESULT | ID ([out, retval] VARIANT *pVal)
HRESULT | ID ([in] VARIANT newVal)
HRESULT | LinkItemNames ([out, retval] VARIANT *pvntVal)
HRESULT | Name ([out, retval] BSTR *pbstrVal)
HRESULT | SettingData ([in] VARIANT vntName,[out, retval] VARIANT *pvntVal)
HRESULT | SettingData ([in] VARIANT vntName,[in] VARIANT vntNewVal)
rsHRESULT | get_Value (out any pVal)
rsHRESULT | put_Value (in any newVal)
rsHRESULT | get_DateTime (out any pVal)
rsHRESULT | get_State (out enmCaoSQLItemState pVal)
rsHRESULT | get_ID (out long pVal)
rsHRESULT | get_Tag (out any pVal)
rsHRESULT | put_Tag (in any newVal)
rsHRESULT | get_Name (out string pVal)
rsHRESULT | get_VariableName (out string pVal)
rsHRESULT | get_SystemType (out enmCaoSQLSystemType pVal)
rsHRESULT | get_LinkItemName (out string pVal)
rsHRESULT | get_Description (out string pVal)
rsHRESULT | get_UseHistory (out boolean pVal)
rsHRESULT | get_UseEmpty (out boolean pVal)

解説

ICaoSQLItem Interface.

メソッドの解説

HRESULT ICaoSQLItem::Activation ( [in] VARIANT_BOOL bNewVal )

HRESULT ICaoSQLItem::Activation ( [out, retval] VARIANT_BOOL * pbVal )

HRESULT ICaoSQLItem::Attribute ( [out, retval] long * plVal )

HRESULT ICaoSQLItem::DateTime ( [out, retval] VARIANT * pvntVal )

HRESULT ICaoSQLItem::Description ( [out, retval] BSTR * pbstrVal )

HRESULT ICaoSQLItem::Element | ( | [in] long | lIndex1,
 |  | [in, defaultvalue(0)] long | lIndex2,
 |  | [in, defaultvalue(0)] long | lIndex3,
 |  | [in] VARIANT | newVal
 | ) |

HRESULT ICaoSQLItem::Element | ( | [in] long | lIndex1,
 |  | [in, defaultvalue(0)] long | lIndex2,
 |  | [in, defaultvalue(0)] long | lIndex3,
 |  | [out, retval] VARIANT * | pVal
 | ) |

rsHRESULT ICaoSQLItem::get_DateTime ( out any pVal )

rsHRESULT ICaoSQLItem::get_Description ( out string pVal )

rsHRESULT ICaoSQLItem::get_ID ( out long pVal )

rsHRESULT ICaoSQLItem::get_LinkItemName ( out string pVal )

rsHRESULT ICaoSQLItem::get_Name ( out string pVal )

rsHRESULT ICaoSQLItem::get_State ( out enmCaoSQLItemState pVal )

rsHRESULT ICaoSQLItem::get_SystemType ( out enmCaoSQLSystemType pVal )

rsHRESULT ICaoSQLItem::get_Tag ( out any pVal )

rsHRESULT ICaoSQLItem::get_UseEmpty ( out boolean pVal )

rsHRESULT ICaoSQLItem::get_UseHistory ( out boolean pVal )

rsHRESULT ICaoSQLItem::get_Value ( out any pVal )

rsHRESULT ICaoSQLItem::get_VariableName ( out string pVal )

HRESULT ICaoSQLItem::ID ( [in] VARIANT newVal )

HRESULT ICaoSQLItem::ID ( [out, retval] VARIANT * pVal )

HRESULT ICaoSQLItem::Index ( [out, retval] long * plVal )

HRESULT ICaoSQLItem::LinkActivation ( [in] VARIANT_BOOL bNewVal )

HRESULT ICaoSQLItem::LinkActivation ( [out, retval] VARIANT_BOOL * pbVal )

HRESULT ICaoSQLItem::LinkItemNames ( [out, retval] VARIANT * pvntVal )

HRESULT ICaoSQLItem::Microsecond ( [out, retval] long * plVal )

HRESULT ICaoSQLItem::Name ( [out, retval] BSTR * pbstrVal )

rsHRESULT ICaoSQLItem::put_Tag ( in any newVal )

rsHRESULT ICaoSQLItem::put_Value ( in any newVal )

HRESULT ICaoSQLItem::SettingData | ( | [in] VARIANT | vntName,
 |  | [in] VARIANT | vntNewVal
 | ) |

HRESULT ICaoSQLItem::SettingData | ( | [in] VARIANT | vntName,
 |  | [out, retval] VARIANT * | pvntVal
 | ) |

HRESULT ICaoSQLItem::Snapshot ( )

HRESULT ICaoSQLItem::State ( [out, retval] long * plVal )

HRESULT ICaoSQLItem::Tag ( [in] VARIANT vntNewVal )

HRESULT ICaoSQLItem::Tag ( [out, retval] VARIANT * pvntVal )

HRESULT ICaoSQLItem::Value ( [in] VARIANT vntNewVal )

HRESULT ICaoSQLItem::Value ( [out, retval] VARIANT * pvntVal )

HRESULT ICaoSQLItem::ValueEx | ( | [in, defaultvalue(0)] long | lDelay,
 |  | VARIANT | vntNewVal
 | ) |

このインタフェースの解説は次のファイルから生成されました:
  • CaoSQL.idl
  • CorbaCaoSQL.idl
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


IConnectionPointImpl class Reference

クラス IConnectionPointImpl の解説

IConnectionPointImplに対する継承グラフ

[凡例]
このクラスの解説は次のファイルから生成されました:
  • CaoSQLCP.h
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


IRACEventSink interface Reference

インタフェースIRACEventSink の解説

import "CaoSQL.idl";

すべてのメンバ一覧

Public メソッド

HRESULT OnMessage ([in] IUnknown *pIVal)

メソッドの解説

HRESULT IRACEventSink::OnMessage ( [in] IUnknown * pIVal )

このインタフェースの解説は次のファイルから生成されました:
  • CaoSQL.idl
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLLib::IRACSever interface Reference

インタフェースCaoSQLLib::IRACSever の解説

import "CaoSQL.idl";

このインタフェースの解説は次のファイルから生成されました:
  • CaoSQL.idl
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLLib::RACEventSink class Reference

クラス CaoSQLLib::RACEventSink の解説

import "CaoSQL.idl";

このクラスの解説は次のファイルから生成されました:
  • CaoSQL.idl
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


Hierarchical Index

DENSO WAVE CaoSQL Project クラス階層

クラス階層図を見る。

この継承一覧はおおまかにはソートされていますが、完全にアルファベット順でソートされてはいません。

  • CaoSQLLib::_ICaoSQLControllerEvents
  • _IID
  • _MIDL_PROC_FORMAT_STRING
  • _MIDL_TYPE_FORMAT_STRING
  • CaoSQLLib::CaoSQLController
  • CaoSQLLib::CaoSQLEngine
  • CaoSQLLib::CaoSQLHistory
  • CaoSQLLib::CaoSQLItem
  • CCaoSQLAdviser
    • CCaoSQLItem
  • CCaoSQLCalcItem
  • CCaoSQLEngine
  • CCaoSQLEngineMan
  • CCaoSQLHistory
  • CCaoSQLHistoryMan
  • CCaoSQLObserver
    • CCaoSQLLinkObserver
    • CCaoSQLOnChangeObserver
    • CCaoSQLTriggerObserver
  • CCaoSQLRACSvr
  • CDDEServer
  • CLockCriticalSection
  • CRACEventSink
  • CRACServer
  • CReadXML
  • CRegKeyEx
  • CServiceModule
  • ICaoSQLController
  • ICaoSQLEngine
  • ICaoSQLHistory
  • ICaoSQLItem
  • IConnectionPointImpl
    • CProxy_ICaoSQLEvents< T >
    • CProxy_ICaoSQLEvents< CCaoSQLController >
      • CCaoSQLController
  • IRACEventSink
  • CaoSQLLib::IRACSever
  • CaoSQLLib::RACEventSink
Generated on Tue Dec 13 12:25:33 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


Compound Member Index

DENSO WAVE CaoSQL Project 構成メンバ

_ | a | b | c | d | e | f | g | h | i | l | m | n | o | p | q | r | s | t | u | v | x | ~

これはクラスメンバの一覧で、それぞれが属しているクラスの解説へリンクしています。

- _ -

  • _Activate() : CCaoSQLItem, CCaoSQLController
  • _CacheValue() : CCaoSQLItem
  • _Deactivate() : CCaoSQLItem, CCaoSQLController
  • _DecrementDDEAdviseRef() : CCaoSQLItem
  • _GetController() : CCaoSQLItem
  • _GetDDEAdivseRef() : CCaoSQLItem
  • _GetHSZ() : CCaoSQLItem, CCaoSQLController
  • _GetItem() : CCaoSQLController
  • _GetVariable() : CCaoSQLController
  • _GetVariables() : CCaoSQLController
  • _IncrementDDEAdviseRef() : CCaoSQLItem
  • _Initialize() : CRACEventSink, CCaoSQLItem, CCaoSQLController
  • _IsDynamicItem() : CCaoSQLItem
  • _NewEnum() : ICaoSQLController, ICaoSQLEngine
  • _SetTriggerState() : CCaoSQLController
  • _Terminate() : CRACEventSink, CCaoSQLController

- a -

  • Activate() : CCaoSQLLinkObserver
  • Activation() : ICaoSQLItem
  • AddHistory() : CCaoSQLHistoryMan
  • AddItem() : CCaoSQLController, ICaoSQLController
  • AddObserver() : CCaoSQLAdviser
  • AddRef() : CCaoSQLEngineMan
  • AddWorkspace() : CCaoSQLEngineMan
  • Attribute() : ICaoSQLItem

- b -

  • BeginTrans() : CCaoSQLHistoryMan

- c -

  • c : _IID
  • Calculate() : CCaoSQLCalcItem
  • CaoSQLHistory() : ICaoSQLEngine
  • CCaoSQLAdviser() : CCaoSQLAdviser
  • CCaoSQLCalcItem() : CCaoSQLCalcItem
  • CCaoSQLController() : CCaoSQLController
  • CCaoSQLEngine() : CCaoSQLEngine
  • CCaoSQLHistory() : CCaoSQLHistory
  • CCaoSQLItem() : CCaoSQLItem
  • CCaoSQLLinkObserver() : CCaoSQLLinkObserver
  • CCaoSQLObserver() : CCaoSQLObserver
  • CCaoSQLOnChangeObserver() : CCaoSQLOnChangeObserver
  • CCaoSQLRACSvr() : CCaoSQLRACSvr
  • CCaoSQLTriggerObserver() : CCaoSQLTriggerObserver
  • CLockCriticalSection() : CLockCriticalSection
  • CommitTrans() : CCaoSQLHistoryMan
  • ConnectionString() : ICaoSQLHistory
  • Controller() : ICaoSQLEngine
  • ControllerNames() : ICaoSQLEngine
  • CopyCollection() : CCaoSQLEngineMan
  • Count() : ICaoSQLController, ICaoSQLEngine
  • CRACEventSink() : CRACEventSink
  • CReadXML::CReadXML() : CReadXML
  • CReadXML::~CReadXML() : CReadXML
  • CRegKeyEx() : CRegKeyEx
  • CServiceModule() : CServiceModule

- d -

  • DateTime() : ICaoSQLItem
  • DeleteObserver() : CCaoSQLAdviser
  • Description() : ICaoSQLItem, ICaoSQLController
  • dwThreadID : CServiceModule

- e -

  • Element() : ICaoSQLItem
  • Enable() : ICaoSQLHistory
  • EnumKeys() : CRegKeyEx
  • Execute() : CCaoSQLHistoryMan, CCaoSQLHistory, CCaoSQLEngine, CCaoSQLController, ICaoSQLHistory, ICaoSQLController, ICaoSQLEngine

- f -

  • FinalConstruct() : CRACEventSink, CCaoSQLRACSvr, CCaoSQLItem, CCaoSQLHistory, CCaoSQLEngine, CCaoSQLController
  • FinalRelease() : CRACEventSink, CCaoSQLRACSvr, CCaoSQLItem, CCaoSQLHistory, CCaoSQLEngine, CCaoSQLController
  • Fire_OnChangeItem() : CProxy_ICaoSQLEvents< T >
  • Fire_OnChangeState() : CProxy_ICaoSQLEvents< T >
  • Format : _MIDL_PROC_FORMAT_STRING, _MIDL_TYPE_FORMAT_STRING

- g -

  • get__NewEnum() : CCaoSQLEngine, CCaoSQLController
  • get_Activation() : CCaoSQLItem
  • get_Attribute() : CCaoSQLItem
  • get_CaoSQLHistory() : CCaoSQLEngine
  • get_ConnectionString() : CCaoSQLHistory
  • get_Controller() : ICaoSQLEngine, CCaoSQLEngine
  • get_ControllerName() : ICaoSQLController
  • get_ControllerNames() : ICaoSQLEngine, CCaoSQLEngine
  • get_Count() : ICaoSQLController, ICaoSQLEngine, CCaoSQLEngine, CCaoSQLController
  • get_DateTime() : ICaoSQLItem, CCaoSQLItem
  • get_Description() : ICaoSQLItem, ICaoSQLController, CCaoSQLItem, CCaoSQLController
  • get_Element() : CCaoSQLItem
  • get_Enable() : CCaoSQLHistory
  • get_ID() : ICaoSQLItem, ICaoSQLController, CCaoSQLItem
  • get_Index() : CCaoSQLItem, CCaoSQLController
  • get_Item() : ICaoSQLController, CCaoSQLController
  • get_ItemNames() : ICaoSQLController, CCaoSQLController
  • get_LinkActivation() : CCaoSQLItem
  • get_LinkItemName() : ICaoSQLItem
  • get_LinkItemNames() : CCaoSQLItem
  • get_Machine() : ICaoSQLController
  • get_MaxRecord() : CCaoSQLHistory
  • get_Microsecond() : CCaoSQLItem
  • get_Name() : ICaoSQLItem, ICaoSQLController, CCaoSQLItem, CCaoSQLController
  • get_Parameter() : ICaoSQLController
  • get_Provider() : ICaoSQLController
  • get_SamplingRate() : ICaoSQLController
  • get_ScanTimes() : CCaoSQLController
  • get_SettingData() : CCaoSQLItem, CCaoSQLController
  • get_State() : ICaoSQLItem, ICaoSQLController, CCaoSQLItem, CCaoSQLController
  • get_SystemType() : ICaoSQLItem
  • get_TableName() : CCaoSQLHistory
  • get_Tag() : ICaoSQLItem, ICaoSQLController, CCaoSQLItem, CCaoSQLController
  • get_UseEmpty() : ICaoSQLItem
  • get_UseHistory() : ICaoSQLItem, ICaoSQLController
  • get_UseOnChange() : ICaoSQLController
  • get_Value() : ICaoSQLItem, CCaoSQLItem
  • get_VariableName() : ICaoSQLItem
  • GetCaoSQLHistory() : CCaoSQLEngineMan
  • GetConnectionString() : CCaoSQLHistoryMan
  • GetController() : CCaoSQLEngineMan
  • GetDefCtrlName() : CCaoSQLEngineMan
  • GetEnableHistory() : CCaoSQLHistoryMan
  • GetEnableSysInfo() : CCaoSQLHistoryMan
  • GetInstanceID() : CDDEServer
  • GetMaxRecord() : CCaoSQLHistoryMan
  • GetRetryCount() : CCaoSQLEngineMan
  • GetRetryInterval() : CCaoSQLEngineMan
  • GetTableName() : CCaoSQLHistoryMan

- h -

  • Handler() : CServiceModule

- i -

  • ID() : ICaoSQLItem
  • Index() : ICaoSQLItem, ICaoSQLController
  • Init() : CServiceModule
  • Initialize() : CRACServer, CDDEServer, CCaoSQLTriggerObserver, CCaoSQLOnChangeObserver, CCaoSQLLinkObserver, CCaoSQLHistoryMan, CCaoSQLEngineMan, CCaoSQLCalcItem
  • Install() : CServiceModule
  • Instance() : CRACServer, CDDEServer, CCaoSQLHistoryMan, CCaoSQLEngineMan
  • InterfaceSupportsErrorInfo() : CRACEventSink, CCaoSQLRACSvr, CCaoSQLItem, CCaoSQLHistory, CCaoSQLEngine, CCaoSQLController
  • IsInstalled() : CServiceModule
  • Item() : ICaoSQLController
  • ItemNames() : ICaoSQLController

- l -

  • LinkActivation() : ICaoSQLItem
  • LinkItemNames() : ICaoSQLItem
  • Lock() : CLockCriticalSection
  • LogEvent() : CServiceModule

- m -

  • m_bCORBAEnabled : CServiceModule
  • m_bDCOMEnabled : CServiceModule
  • m_bDDEEnabled : CServiceModule
  • m_bJNIEnabled : CServiceModule
  • m_bNotRepeatError : CServiceModule
  • m_bRACSvrEnabled : CServiceModule
  • m_bService : CServiceModule
  • m_bstrCORBAOption : CServiceModule
  • m_cs : CLockCriticalSection
  • m_hServiceStatus : CServiceModule
  • m_lcid : CServiceModule
  • m_status : CServiceModule
  • m_szDataPath : CServiceModule
  • m_szServiceName : CServiceModule
  • MaxRecord() : ICaoSQLHistory
  • Microsecond() : ICaoSQLItem

- n -

  • Name() : ICaoSQLItem, ICaoSQLController
  • NotifyObservers() : CCaoSQLAdviser

- o -

  • OnChangeItem() : CaoSQLLib::_ICaoSQLControllerEvents
  • OnChangeState() : CaoSQLLib::_ICaoSQLControllerEvents
  • OnMessage() : CRACEventSink, IRACEventSink

- p -

  • Pad : _MIDL_PROC_FORMAT_STRING, _MIDL_TYPE_FORMAT_STRING
  • put_Activation() : CCaoSQLItem
  • put_Element() : CCaoSQLItem
  • put_ID() : CCaoSQLItem
  • put_LinkActivation() : CCaoSQLItem
  • put_SettingData() : CCaoSQLItem, CCaoSQLController
  • put_Tag() : ICaoSQLItem, ICaoSQLController, CCaoSQLItem, CCaoSQLController
  • put_Value() : ICaoSQLItem, CCaoSQLItem
  • put_ValueEx() : CCaoSQLItem

- q -

  • QueryValue() : CRegKeyEx, CReadXML

- r -

  • RegisterServer() : CServiceModule
  • RegisterTriggerItem() : CCaoSQLTriggerObserver
  • Release() : CCaoSQLEngineMan
  • ReleaseObservers() : CCaoSQLAdviser
  • RemoveItem() : CCaoSQLController, ICaoSQLController
  • RollbackTrans() : CCaoSQLHistoryMan
  • Run() : CServiceModule

- s -

  • s1 : _IID
  • s2 : _IID
  • ScanTimes() : ICaoSQLController
  • ServiceMain() : CServiceModule
  • SetServiceStatus() : CServiceModule
  • SettingData() : ICaoSQLItem, ICaoSQLController
  • SetupAsLocalServer() : CServiceModule
  • Snapshot() : ICaoSQLController, ICaoSQLEngine, CCaoSQLItem, CCaoSQLEngine, CCaoSQLController, ICaoSQLItem, ICaoSQLController, ICaoSQLEngine
  • Start() : CServiceModule, ICaoSQLController, ICaoSQLEngine, CCaoSQLEngine, CCaoSQLController, ICaoSQLController, ICaoSQLEngine
  • State() : ICaoSQLItem, ICaoSQLController
  • Stop() : ICaoSQLController, ICaoSQLEngine, CCaoSQLEngine, CCaoSQLController, ICaoSQLController, ICaoSQLEngine

- t -

  • TableName() : ICaoSQLHistory
  • Tag() : ICaoSQLItem, ICaoSQLController
  • Terminate() : CRACServer, CDDEServer, CCaoSQLHistoryMan, CCaoSQLEngineMan

- u -

  • Uninstall() : CServiceModule
  • Unlock() : CServiceModule, CLockCriticalSection
  • UnregisterServer() : CServiceModule
  • Update() : CCaoSQLTriggerObserver, CCaoSQLOnChangeObserver, CCaoSQLObserver, CCaoSQLLinkObserver

- v -

  • Value() : ICaoSQLItem
  • ValueEx() : ICaoSQLItem

- x -

  • x : _IID

- ~ -

  • ~CCaoSQLAdviser() : CCaoSQLAdviser
  • ~CCaoSQLCalcItem() : CCaoSQLCalcItem
  • ~CCaoSQLController() : CCaoSQLController
  • ~CCaoSQLEngine() : CCaoSQLEngine
  • ~CCaoSQLHistory() : CCaoSQLHistory
  • ~CCaoSQLItem() : CCaoSQLItem
  • ~CCaoSQLLinkObserver() : CCaoSQLLinkObserver
  • ~CCaoSQLObserver() : CCaoSQLObserver
  • ~CCaoSQLOnChangeObserver() : CCaoSQLOnChangeObserver
  • ~CCaoSQLRACSvr() : CCaoSQLRACSvr
  • ~CCaoSQLTriggerObserver() : CCaoSQLTriggerObserver
  • ~CLockCriticalSection() : CLockCriticalSection
  • ~CRACEventSink() : CRACEventSink
  • ~CRegKeyEx() : CRegKeyEx
  • ~CServiceModule() : CServiceModule
Generated on Tue Dec 13 12:25:33 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


Namespace Index

DENSO WAVE CaoSQL Project 名前空間一覧

名前空間の一覧です。
CaoSQLLib | CaoSQL typelibrary
MSXML2 |
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLLib Namespace Reference

名前空間 CaoSQLLib の解説

CaoSQL typelibrary. [詳細]

構成

interface | _ICaoSQLControllerEvents
class | CaoSQLController
class | CaoSQLEngine
class | CaoSQLHistory
class | CaoSQLItem
interface | IRACSever
class | RACEventSink

Typedef

typedef _enmCaoVariableClass | enmCaoVariableClass
typedef _enmCaoSQLCtrlState | enmCaoSQLCtrlState
typedef _enmCaoSQLCtrlScantime | enmCaoSQLCtrlScantime
typedef _enmCaoSQLItemState | enmCaoSQLItemState
typedef _enmCaoSQLItemAttribute | enmCaoSQLItemAttribute

関数

importlib ("stdole32.tlb")
importlib ("stdole2.tlb")

解説

CaoSQL typelibrary.

Typedef の解説

typedef _enmCaoSQLCtrlScantime CaoSQLLib::enmCaoSQLCtrlScantime

typedef _enmCaoSQLCtrlState CaoSQLLib::enmCaoSQLCtrlState

typedef _enmCaoSQLItemAttribute CaoSQLLib::enmCaoSQLItemAttribute

typedef _enmCaoSQLItemState CaoSQLLib::enmCaoSQLItemState

typedef _enmCaoVariableClass CaoSQLLib::enmCaoVariableClass

関数の解説

importlib ( "stdole2.tlb" )

importlib ( "stdole32.tlb" )

Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


MSXML2 Namespace Reference

名前空間 MSXML2 の解説

Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


File Member Index

DENSO WAVE CaoSQL Project ファイルメンバ

_ | a | b | c | d | e | f | g | i | l | m | o | p | r | s | t | u | v | x

これはファイルメンバの一覧です。それぞれが属しているファイルの解説へリンクしています。

- _ -

  • __MIDL_itf_CaoSQL_0000_v0_0_c_ifspec : CaoSQL.h
  • __MIDL_itf_CaoSQL_0000_v0_0_s_ifspec : CaoSQL.h
  • __MIDL_ProcFormatString : CaoSQL_p.c
  • __MIDL_TypeFormatString : CaoSQL_p.c
  • __pad0__ : CaoSQL.h
  • __pad1__ : CaoSQL.h
  • __pad2__ : CaoSQL.h
  • __pad3__ : CaoSQL.h
  • __pad4__ : CaoSQL.h
  • __pad5__ : CaoSQL.h
  • __pad6__ : CaoSQL.h
  • __REQUIRED_RPCNDR_H_VERSION__ : CaoSQL.h
  • __REQUIRED_RPCPROXY_H_VERSION__ : CaoSQL_p.c
  • _ATL_FREE_THREADED : StdAfx.h
  • _enmCaoSQLCtrlScantime : CaoSQL.idl, CaoSQL.h
  • _enmCaoSQLCtrlState : CaoSQL.idl, CaoSQL.h
  • _enmCaoSQLItemAttribute : CaoSQL.idl, CaoSQL.h
  • _enmCaoSQLItemState : CaoSQL.idl, CaoSQL.h
  • _enmCaoSQLSysInfoId : CaoSQLController.h
  • _enmCaoVariableClass : CaoSQL.idl, CaoSQL.h
  • _ICaoSQLControllerEvents : CaoSQL.h
  • _Module : StdAfx.h, CaoSQL.cpp
  • _tWinMain() : CaoSQL.cpp
  • _WIN32_WINNT : StdAfx.h

- a -

  • AddItem() : CaoSQL.h
  • AFX_CaoSQLADVISER_H__3C38D8B6_4413_4E45_8C64_E82E3AA4C5FC__INCLUDED_ : CaoSQLAdviser.h
  • AFX_CaoSQLCALCITEM_H__E1C734F8_9F5E_4A54_A143_008BC18C49F5__INCLUDED_ : CaoSQLCalcItem.h
  • AFX_CaoSQLENGINEMAN_H__6FBB6452_10AF_4D96_8DCF_28A2A6FA9600__INCLUDED_ : CaoSQLEngineMan.h
  • AFX_CaoSQLHISTORY_H__170E0EB9_D84D_4BB7_ABD6_F6C81C5F8D62__INCLUDED_ : CaoSQLHistoryMan.h
  • AFX_CaoSQLLINKOBSERVER_H__E953E6C2_C41B_4BB1_92D1_D2F4DA6B85E0__INCLUDED_ : CaoSQLLinkObserver.h
  • AFX_CaoSQLOBSERVER_H__57092436_381D_48A1_8834_1DF4095969D2__INCLUDED_ : CaoSQLObserver.h
  • AFX_CaoSQLONCHANGEOBSERVER_H__75A18619_43CC_4784_A432_80816F03836D__INCLUDED_ : CaoSQLOnChangeObserver.h
  • AFX_CAOSQLRACSVR_H__04737F87_3A5D_465A_9EEF_0FD7FDE625F7__INCLUDED_ : CaoSQLRACSvr.h
  • AFX_CaoSQLTRIGGEROBSERVER_H__5A4499B7_7C92_4F5F_8E2C_57E315C582C3__INCLUDED_ : CaoSQLTriggerObserver.h
  • AFX_DDESERVER_H__977788A3_7507_4394_9C16_7E9C12E2949A__INCLUDED_ : DDEServer.h
  • AFX_LOCKCRITICALSECTION_H__087FFCA1_BC60_4A67_89CE_01D147DBC7F9__INCLUDED_ : LockCriticalSection.h
  • AFX_RACSERVER_H__B3CD89B9_5548_44A7_BA86_CB0ACFF529CA__INCLUDED_ : RACServer.h
  • AFX_READXMLINFO_H__81702906_B32D_4E6C_832B_35307A879ACB__INCLUDED_ : ReadXML.h
  • AFX_REGKEYEX_H__796E4BB2_32BB_42C9_BC51_01772E752FED__INCLUDED_ : RegKeyEx.h
  • AFX_STDAFX_H__0954E884_8A01_4881_A9C7_616986F8647E__INCLUDED_ : StdAfx.h

- b -

  • BSTR_TO_BOOL : CaoSQLData.h
  • BSTR_UserFree() : CaoSQL.h
  • BSTR_UserMarshal() : CaoSQL.h
  • BSTR_UserSize() : CaoSQL.h
  • BSTR_UserUnmarshal() : CaoSQL.h

- c -

  • CAOSQL_HSTRY_CMD_ADD : CaoSQLHistoryMan.h
  • CAOSQL_HSTRY_CMD_CNT : CaoSQLHistoryMan.h
  • CAOSQL_HSTRY_CMD_UPDATE : CaoSQLHistoryMan.h
  • CAOSQL_HSTRY_FLAG_CURVAL : CaoSQLHistoryMan.h
  • CAOSQL_HSTRY_NAME_MAXLEN : CaoSQLHistoryMan.h
  • CAOSQL_HSTRY_TYPE_CURVAL : CaoSQLHistoryMan.h
  • CAOSQL_HSTRY_TYPE_HSTRY : CaoSQLHistoryMan.h
  • CAOSQL_HSTRY_VALUE_MAXLEN : CaoSQLHistoryMan.h
  • CAOSQL_LOG_MSGBOX : StdAfx.h
  • CaoSQLController : CaoSQL.h
  • CaoSQLEngine : CaoSQL.h
  • CaoSQLHistory : CaoSQL.h
  • CaoSQLItem : CaoSQL.h
  • CINTERFACE_PROXY_VTABLE() : CaoSQL_p.c
  • CLSID : CaoSQL_i.c, CAO_i.c
  • CLSID_CaoCommand : CAO_i.c
  • CLSID_CaoCommands : CAO_i.c
  • CLSID_CaoController : CAO_i.c
  • CLSID_CaoControllers : CAO_i.c
  • CLSID_CaoEngine : CAO_i.c
  • CLSID_CaoEngineStatus : CAO_i.c
  • CLSID_CaoExtension : CAO_i.c
  • CLSID_CaoExtensions : CAO_i.c
  • CLSID_CaoFile : CAO_i.c
  • CLSID_CaoFiles : CAO_i.c
  • CLSID_CaoMessage : CAO_i.c
  • CLSID_CaoRobot : CAO_i.c
  • CLSID_CaoRobots : CAO_i.c
  • CLSID_CaoSQLController : CaoSQL_i.c, CaoSQL.h
  • CLSID_CaoSQLEngine : CaoSQL_i.c, CaoSQL.h
  • CLSID_CaoSQLHistory : CaoSQL_i.c, CaoSQL.h
  • CLSID_CaoSQLItem : CaoSQL_i.c, CaoSQL.h
  • CLSID_CaoTask : CAO_i.c
  • CLSID_CaoTasks : CAO_i.c
  • CLSID_CaoVariable : CAO_i.c
  • CLSID_CaoVariables : CAO_i.c
  • CLSID_CaoWorkspace : CAO_i.c
  • CLSID_CaoWorkspaces : CAO_i.c
  • CLSID_EventSink : CAO_i.c
  • CLSID_RACEventSink : CaoSQL_i.c, CaoSQL.h
  • csCtrlScantimeLast : CaoSQL.idl, CaoSQL.h
  • csCtrlScantimeMax : CaoSQL.idl, CaoSQL.h
  • csCtrlScantimeMin : CaoSQL.idl, CaoSQL.h
  • csCtrlThreadActive : CaoSQL.idl, CaoSQL.h
  • csCtrlThreadDeactive : CaoSQL.idl, CaoSQL.h
  • csCtrlThreadError : CaoSQL.idl, CaoSQL.h
  • csCtrlThreadTerminated : CaoSQL.idl, CaoSQL.h
  • csCtrlThreadUninit : CaoSQL.idl, CaoSQL.h
  • csItemFailed : CaoSQL.idl, CaoSQL.h
  • csItemReadOnly : CaoSQL.idl, CaoSQL.h
  • csItemReadWrite : CaoSQL.idl, CaoSQL.h
  • csItemSucceeded : CaoSQL.idl, CaoSQL.h
  • csItemUndefined : CaoSQL.idl, CaoSQL.h
  • csItemWriteOnly : CaoSQL.idl, CaoSQL.h
  • CSQ_ADDITEM_BND : CaoSQLData.h
  • CSQ_ADDITEM_MAX : CaoSQLData.h
  • CSQ_C_NULL_CHAR : CaoSQLData.h
  • CSQ_CACHE_OPT_NOEVENT : CaoSQLData.h
  • CSQ_CFG_CTRL_CACHE : CaoSQLData.h
  • CSQ_CFG_CTRL_HIST : CaoSQLData.h
  • CSQ_CFG_CTRL_MACH : CaoSQLData.h
  • CSQ_CFG_CTRL_NAME : CaoSQLData.h
  • CSQ_CFG_CTRL_OPT : CaoSQLData.h
  • CSQ_CFG_CTRL_PROV : CaoSQLData.h
  • CSQ_CFG_CTRL_SAMPRATE : CaoSQLData.h
  • CSQ_CFG_CTRL_TIMESTAMP : CaoSQLData.h
  • CSQ_CFG_ITEM_2NDITEM : CaoSQLData.h
  • CSQ_CFG_ITEM_ATTR : CaoSQLData.h
  • CSQ_CFG_ITEM_BCD : CaoSQLData.h
  • CSQ_CFG_ITEM_CALC_INDEX : CaoSQLData.h
  • CSQ_CFG_ITEM_CHANGE_TYPE : CaoSQLData.h
  • CSQ_CFG_ITEM_DEADBAND : CaoSQLData.h
  • CSQ_CFG_ITEM_DEADBAND_MAX : CaoSQLData.h
  • CSQ_CFG_ITEM_DEADBAND_MIN : CaoSQLData.h
  • CSQ_CFG_ITEM_DESC : CaoSQLData.h
  • CSQ_CFG_ITEM_FORCECHANGE : CaoSQLData.h
  • CSQ_CFG_ITEM_INIT : CaoSQLData.h
  • CSQ_CFG_ITEM_INIT_DATA : CaoSQLData.h
  • CSQ_CFG_ITEM_INIT_DATA_TYPE : CaoSQLData.h
  • CSQ_CFG_ITEM_LINK_ITEM : CaoSQLData.h
  • CSQ_CFG_ITEM_MASK : CaoSQLData.h
  • CSQ_CFG_ITEM_MASK_ENABLED : CaoSQLData.h
  • CSQ_CFG_ITEM_MINMAX : CaoSQLData.h
  • CSQ_CFG_ITEM_MINMAX_MIN : CaoSQLData.h
  • CSQ_CFG_ITEM_MIXMAX_MAX : CaoSQLData.h
  • CSQ_CFG_ITEM_NAME : CaoSQLData.h
  • CSQ_CFG_ITEM_ON_CNG_EVT : CaoSQLData.h
  • CSQ_CFG_ITEM_REQUEST : CaoSQLData.h
  • CSQ_CFG_ITEM_USE_EMPTY : CaoSQLData.h
  • CSQ_CFG_ITEM_USE_HSTRY : CaoSQLData.h
  • CSQ_CFG_ITEM_VAR_CLS : CaoSQLData.h
  • CSQ_CFG_ITEM_VAR_ENABLED : CaoSQLData.h
  • CSQ_CFG_ITEM_VAR_NAME : CaoSQLData.h
  • CSQ_CFG_ITEM_VAR_OBJ : CaoSQLData.h
  • CSQ_CFG_ITEM_VAR_OPT : CaoSQLData.h
  • CSQ_DDE_MAX_DATA : CaoSQLData.h
  • CSQ_DDE_SERV_NAME : CaoSQLData.h
  • CSQ_DLMTR_C_COLON : CaoSQLData.h
  • CSQ_DLMTR_C_COMMA : CaoSQLData.h
  • CSQ_DLMTR_C_EXCLAM : CaoSQLData.h
  • CSQ_DLMTR_C_YEN : CaoSQLData.h
  • CSQ_DLMTR_S_COMMA : CaoSQLData.h
  • CSQ_DLMTR_S_YEN : CaoSQLData.h
  • CSQ_EVENT_MAX : CaoSQLData.h
  • CSQ_FORCETOCHANGE_READING : CaoSQLData.h
  • CSQ_FORCETOCHANGE_WRITING : CaoSQLData.h
  • CSQ_HST_FLD_SIZE : CaoSQLData.h
  • CSQ_HST_FLDNAME_CTRLNAME : CaoSQLData.h
  • CSQ_HST_FLDNAME_DATETIME : CaoSQLData.h
  • CSQ_HST_FLDNAME_FLAGS : CaoSQLData.h
  • CSQ_HST_FLDNAME_ITEMNAME : CaoSQLData.h
  • CSQ_HST_FLDNAME_MILLISEC : CaoSQLData.h
  • CSQ_HST_FLDNAME_VALUE : CaoSQLData.h
  • CSQ_HST_FLDNAME_VARTYPE : CaoSQLData.h
  • CSQ_HST_IDX_INS_CTRLNAME : CaoSQLData.h
  • CSQ_HST_IDX_INS_DATETIME : CaoSQLData.h
  • CSQ_HST_IDX_INS_FLAGS : CaoSQLData.h
  • CSQ_HST_IDX_INS_ITEMNAME : CaoSQLData.h
  • CSQ_HST_IDX_INS_TIME_MS : CaoSQLData.h
  • CSQ_HST_IDX_INS_VALUE : CaoSQLData.h
  • CSQ_HST_IDX_INS_VARTYPE : CaoSQLData.h
  • CSQ_HST_IDX_UPD_CTRLNAME : CaoSQLData.h
  • CSQ_HST_IDX_UPD_DATETIME : CaoSQLData.h
  • CSQ_HST_IDX_UPD_FLAGS : CaoSQLData.h
  • CSQ_HST_IDX_UPD_ITEMNAME : CaoSQLData.h
  • CSQ_HST_IDX_UPD_TIME_MS : CaoSQLData.h
  • CSQ_HST_IDX_UPD_VALUE : CaoSQLData.h
  • CSQ_HST_IDX_UPD_VARTYPE : CaoSQLData.h
  • CSQ_KEY_NAME : CaoSQLData.h
  • CSQ_MAX_BUFFER : CaoSQLData.h
  • CSQ_REG_ROOT : CaoSQLData.h
  • CSQ_RETRY_INTVL_DEFAULT : CaoSQLData.h
  • CSQ_SETTINGDATA_ITEM_CLASS : CaoSQLData.h
  • CSQ_SETTINGDATA_ITEM_OBJECT_NAME : CaoSQLData.h
  • CSQ_SETTINGDATA_ITEM_OPTION : CaoSQLData.h
  • CSQ_SETTINGDATA_ITEM_VAR_NAME : CaoSQLData.h
  • CSQ_SLEEPTIME : CaoSQLData.h
  • CSQ_THREAD_END_TIMEOUT : CaoSQLData.h
  • CSQ_THREAD_START_TIMEOUT : CaoSQLData.h
  • CSQ_THREADFUNC : CaoSQLData.h
  • CSQ_THREADID : CaoSQLData.h
  • CSQ_TIMESTAMP_DEVICE : CaoSQLData.h
  • CSQ_TIMESTAMP_LOCAL : CaoSQLData.h
  • CSQ_TIMESTAMP_NA : CaoSQLData.h
  • CSQ_TIMESTAMP_SYSTEM : CaoSQLData.h
  • CSQ_TRG_ACT_NO : CaoSQLData.h
  • CSQ_TRG_ACT_ONETIME : CaoSQLData.h
  • CSQ_TRG_ACT_START : CaoSQLData.h
  • CSQ_TRG_ACT_STOP : CaoSQLData.h
  • CSQ_TRG_CMD_ONETIME : CaoSQLData.h
  • CSQ_TRG_CMD_START : CaoSQLData.h
  • CSQ_TRG_CMD_STOP : CaoSQLData.h
  • CSQ_TRG_CND_EQ : CaoSQLData.h
  • CSQ_TRG_CND_GE : CaoSQLData.h
  • CSQ_TRG_CND_GT : CaoSQLData.h
  • CSQ_TRG_CND_LE : CaoSQLData.h
  • CSQ_TRG_CND_LT : CaoSQLData.h
  • CSQ_TRG_CND_NE : CaoSQLData.h
  • CSQ_WDT_ACTION_NOACTION : CaoSQLData.h
  • CSQ_WDT_ACTION_STOP : CaoSQLData.h
  • CSQ_WDT_DEFAULT : CaoSQLData.h
  • CSQ_WM_ADVREQ : CaoSQLData.h
  • CSQL_DDE_MAX_BUF : CaoSQLData.h
  • csSysInfoBegin : CaoSQLController.h
  • csSysInfoEnd : CaoSQLController.h
  • csSysInfoStart : CaoSQLController.h
  • csSysInfoStop : CaoSQLController.h
  • csVarClassController : CaoSQL.idl, CaoSQL.h
  • csVarClassExtension : CaoSQL.idl, CaoSQL.h
  • csVarClassRobot : CaoSQL.idl, CaoSQL.h
  • csVarClassTask : CaoSQL.idl, CaoSQL.h

- d -

  • DECLSPEC_UUID() : CaoSQL.h
  • DIID__ICaoCommandEvents : CAO_i.c
  • DIID__ICaoControllerEvents : CAO_i.c
  • DIID__ICaoSQLControllerEvents : CaoSQL_i.c, CaoSQL.h

- e -

  • enmCaoSQLControllerState : CorbaCaoSQL.idl
  • enmCaoSQLCtrlScantime : CaoSQL.idl, CaoSQL.h
  • enmCaoSQLCtrlState : CaoSQL.idl, CaoSQL.h
  • enmCaoSQLItemAttribute : CaoSQL.idl, CaoSQL.h
  • enmCaoSQLItemState : CorbaCaoSQL.idl, CaoSQL.idl, CaoSQL.h
  • enmCaoSQLSysInfoId : CaoSQLController.h
  • enmCaoSQLSystemType : CorbaCaoSQL.idl
  • enmCaoVariableClass : CaoSQL.idl, CaoSQL.h
  • Execute() : CaoSQL.h

- f -

  • FACILITY_ERROR : CAOSQLEventInfo.h
  • FACILITY_INFORMATIONAL : CAOSQLEventInfo.h
  • FACILITY_WARNING : CAOSQLEventInfo.h
  • FindOneOf() : CaoSQL.cpp

- g -

  • get_Activation() : CaoSQL.h
  • get_Attribute() : CaoSQL.h
  • get_CaoSQLHistory() : CaoSQL.h
  • get_ConnectionString() : CaoSQL.h
  • get_Controller() : CaoSQL.h
  • get_ControllerNames() : CaoSQL.h
  • get_Count() : CaoSQL.h
  • get_DateTime() : CaoSQL.h
  • get_Description() : CaoSQL.h
  • get_Element() : CaoSQL.h
  • get_Enable() : CaoSQL.h
  • get_ID() : CaoSQL.h
  • get_Index() : CaoSQL.h
  • get_Item() : CaoSQL.h
  • get_ItemNames() : CaoSQL.h
  • get_LinkActivation() : CaoSQL.h
  • get_LinkItemNames() : CaoSQL.h
  • get_MaxRecord() : CaoSQL.h
  • get_Microsecond() : CaoSQL.h
  • get_Name() : CaoSQL.h
  • get_ScanTimes() : CaoSQL.h
  • get_SettingData() : CaoSQL.h
  • get_State() : CaoSQL.h
  • get_TableName() : CaoSQL.h
  • get_Tag() : CaoSQL.h

- i -

  • ICaoSQLController : CaoSQL.h
  • ICaoSQLController_AddItem_Proxy() : CaoSQL.h
  • ICaoSQLController_AddItem_Stub() : CaoSQL.h
  • ICaoSQLController_Execute_Proxy() : CaoSQL.h
  • ICaoSQLController_Execute_Stub() : CaoSQL.h
  • ICaoSQLController_get__NewEnum_Proxy() : CaoSQL.h
  • ICaoSQLController_get__NewEnum_Stub() : CaoSQL.h
  • ICaoSQLController_get_Count_Proxy() : CaoSQL.h
  • ICaoSQLController_get_Count_Stub() : CaoSQL.h
  • ICaoSQLController_get_Description_Proxy() : CaoSQL.h
  • ICaoSQLController_get_Description_Stub() : CaoSQL.h
  • ICaoSQLController_get_Index_Proxy() : CaoSQL.h
  • ICaoSQLController_get_Index_Stub() : CaoSQL.h
  • ICaoSQLController_get_Item_Proxy() : CaoSQL.h
  • ICaoSQLController_get_Item_Stub() : CaoSQL.h
  • ICaoSQLController_get_ItemNames_Proxy() : CaoSQL.h
  • ICaoSQLController_get_ItemNames_Stub() : CaoSQL.h
  • ICaoSQLController_get_Name_Proxy() : CaoSQL.h
  • ICaoSQLController_get_Name_Stub() : CaoSQL.h
  • ICaoSQLController_get_ScanTimes_Proxy() : CaoSQL.h
  • ICaoSQLController_get_ScanTimes_Stub() : CaoSQL.h
  • ICaoSQLController_get_SettingData_Proxy() : CaoSQL.h
  • ICaoSQLController_get_SettingData_Stub() : CaoSQL.h
  • ICaoSQLController_get_State_Proxy() : CaoSQL.h
  • ICaoSQLController_get_State_Stub() : CaoSQL.h
  • ICaoSQLController_get_Tag_Proxy() : CaoSQL.h
  • ICaoSQLController_get_Tag_Stub() : CaoSQL.h
  • ICaoSQLController_put_SettingData_Proxy() : CaoSQL.h
  • ICaoSQLController_put_SettingData_Stub() : CaoSQL.h
  • ICaoSQLController_put_Tag_Proxy() : CaoSQL.h
  • ICaoSQLController_put_Tag_Stub() : CaoSQL.h
  • ICaoSQLController_RemoveItem_Proxy() : CaoSQL.h
  • ICaoSQLController_RemoveItem_Stub() : CaoSQL.h
  • ICaoSQLController_Snapshot_Proxy() : CaoSQL.h
  • ICaoSQLController_Snapshot_Stub() : CaoSQL.h
  • ICaoSQLController_Start_Proxy() : CaoSQL.h
  • ICaoSQLController_Start_Stub() : CaoSQL.h
  • ICaoSQLController_Stop_Proxy() : CaoSQL.h
  • ICaoSQLController_Stop_Stub() : CaoSQL.h
  • ICaoSQLEngine : CaoSQL.h
  • ICaoSQLEngine_Execute_Proxy() : CaoSQL.h
  • ICaoSQLEngine_Execute_Stub() : CaoSQL.h
  • ICaoSQLEngine_FormatStringOffsetTable : CaoSQL_p.c
  • ICaoSQLEngine_get__NewEnum_Proxy() : CaoSQL.h
  • ICaoSQLEngine_get__NewEnum_Stub() : CaoSQL.h
  • ICaoSQLEngine_get_CaoSQLHistory_Proxy() : CaoSQL.h
  • ICaoSQLEngine_get_CaoSQLHistory_Stub() : CaoSQL.h
  • ICaoSQLEngine_get_Controller_Proxy() : CaoSQL.h
  • ICaoSQLEngine_get_Controller_Stub() : CaoSQL.h
  • ICaoSQLEngine_get_ControllerNames_Proxy() : CaoSQL.h
  • ICaoSQLEngine_get_ControllerNames_Stub() : CaoSQL.h
  • ICaoSQLEngine_get_Count_Proxy() : CaoSQL.h
  • ICaoSQLEngine_get_Count_Stub() : CaoSQL.h
  • ICaoSQLEngine_ProxyInfo : CaoSQL_p.c
  • ICaoSQLEngine_ServerInfo : CaoSQL_p.c
  • ICaoSQLEngine_Snapshot_Proxy() : CaoSQL.h
  • ICaoSQLEngine_Snapshot_Stub() : CaoSQL.h
  • ICaoSQLEngine_Start_Proxy() : CaoSQL.h
  • ICaoSQLEngine_Start_Stub() : CaoSQL.h
  • ICaoSQLEngine_Stop_Proxy() : CaoSQL.h
  • ICaoSQLEngine_Stop_Stub() : CaoSQL.h
  • ICaoSQLHistory : CaoSQL.h
  • ICaoSQLHistory_Execute_Proxy() : CaoSQL.h
  • ICaoSQLHistory_Execute_Stub() : CaoSQL.h
  • ICaoSQLHistory_get_ConnectionString_Proxy() : CaoSQL.h
  • ICaoSQLHistory_get_ConnectionString_Stub() : CaoSQL.h
  • ICaoSQLHistory_get_Enable_Proxy() : CaoSQL.h
  • ICaoSQLHistory_get_Enable_Stub() : CaoSQL.h
  • ICaoSQLHistory_get_MaxRecord_Proxy() : CaoSQL.h
  • ICaoSQLHistory_get_MaxRecord_Stub() : CaoSQL.h
  • ICaoSQLHistory_get_TableName_Proxy() : CaoSQL.h
  • ICaoSQLHistory_get_TableName_Stub() : CaoSQL.h
  • ICaoSQLItem : CaoSQL.h
  • ICaoSQLItem_get_Activation_Proxy() : CaoSQL.h
  • ICaoSQLItem_get_Activation_Stub() : CaoSQL.h
  • ICaoSQLItem_get_Attribute_Proxy() : CaoSQL.h
  • ICaoSQLItem_get_Attribute_Stub() : CaoSQL.h
  • ICaoSQLItem_get_DateTime_Proxy() : CaoSQL.h
  • ICaoSQLItem_get_DateTime_Stub() : CaoSQL.h
  • ICaoSQLItem_get_Description_Proxy() : CaoSQL.h
  • ICaoSQLItem_get_Description_Stub() : CaoSQL.h
  • ICaoSQLItem_get_Element_Proxy() : CaoSQL.h
  • ICaoSQLItem_get_Element_Stub() : CaoSQL.h
  • ICaoSQLItem_get_ID_Proxy() : CaoSQL.h
  • ICaoSQLItem_get_ID_Stub() : CaoSQL.h
  • ICaoSQLItem_get_Index_Proxy() : CaoSQL.h
  • ICaoSQLItem_get_Index_Stub() : CaoSQL.h
  • ICaoSQLItem_get_LinkActivation_Proxy() : CaoSQL.h
  • ICaoSQLItem_get_LinkActivation_Stub() : CaoSQL.h
  • ICaoSQLItem_get_LinkItemNames_Proxy() : CaoSQL.h
  • ICaoSQLItem_get_LinkItemNames_Stub() : CaoSQL.h
  • ICaoSQLItem_get_Microsecond_Proxy() : CaoSQL.h
  • ICaoSQLItem_get_Microsecond_Stub() : CaoSQL.h
  • ICaoSQLItem_get_Name_Proxy() : CaoSQL.h
  • ICaoSQLItem_get_Name_Stub() : CaoSQL.h
  • ICaoSQLItem_get_SettingData_Proxy() : CaoSQL.h
  • ICaoSQLItem_get_SettingData_Stub() : CaoSQL.h
  • ICaoSQLItem_get_State_Proxy() : CaoSQL.h
  • ICaoSQLItem_get_State_Stub() : CaoSQL.h
  • ICaoSQLItem_get_Tag_Proxy() : CaoSQL.h
  • ICaoSQLItem_get_Tag_Stub() : CaoSQL.h
  • ICaoSQLItem_get_Value_Proxy() : CaoSQL.h
  • ICaoSQLItem_get_Value_Stub() : CaoSQL.h
  • ICaoSQLItem_put_Activation_Proxy() : CaoSQL.h
  • ICaoSQLItem_put_Activation_Stub() : CaoSQL.h
  • ICaoSQLItem_put_Element_Proxy() : CaoSQL.h
  • ICaoSQLItem_put_Element_Stub() : CaoSQL.h
  • ICaoSQLItem_put_ID_Proxy() : CaoSQL.h
  • ICaoSQLItem_put_ID_Stub() : CaoSQL.h
  • ICaoSQLItem_put_LinkActivation_Proxy() : CaoSQL.h
  • ICaoSQLItem_put_LinkActivation_Stub() : CaoSQL.h
  • ICaoSQLItem_put_SettingData_Proxy() : CaoSQL.h
  • ICaoSQLItem_put_SettingData_Stub() : CaoSQL.h
  • ICaoSQLItem_put_Tag_Proxy() : CaoSQL.h
  • ICaoSQLItem_put_Tag_Stub() : CaoSQL.h
  • ICaoSQLItem_put_Value_Proxy() : CaoSQL.h
  • ICaoSQLItem_put_Value_Stub() : CaoSQL.h
  • ICaoSQLItem_put_ValueEx_Proxy() : CaoSQL.h
  • ICaoSQLItem_put_ValueEx_Stub() : CaoSQL.h
  • ICaoSQLItem_Snapshot_Proxy() : CaoSQL.h
  • ICaoSQLItem_Snapshot_Stub() : CaoSQL.h
  • IDI_CAOSQL : resource.h
  • IDR_CaoSQL : resource.h
  • IDR_CaoSQLCONTROLLER : resource.h
  • IDR_CaoSQLENGINE : resource.h
  • IDR_CaoSQLHISTORY : resource.h
  • IDR_CaoSQLITEM : resource.h
  • IDR_RACSERVER : resource.h
  • IDS_SERVICENAME : resource.h
  • IID : CaoSQL_i.c, CAO_i.c
  • IID_ICaoCommand : CAO_i.c
  • IID_ICaoCommands : CAO_i.c
  • IID_ICaoController : CAO_i.c
  • IID_ICaoControllers : CAO_i.c
  • IID_ICaoEngine : CAO_i.c
  • IID_ICaoEngineStatus : CAO_i.c
  • IID_ICaoExtension : CAO_i.c
  • IID_ICaoExtensions : CAO_i.c
  • IID_ICaoFile : CAO_i.c
  • IID_ICaoFiles : CAO_i.c
  • IID_ICaoMessage : CAO_i.c
  • IID_ICaoRobot : CAO_i.c
  • IID_ICaoRobots : CAO_i.c
  • IID_ICaoSQLController : CaoSQL_i.c, CaoSQL.h
  • IID_ICaoSQLEngine : CaoSQL_i.c, CaoSQL.h
  • IID_ICaoSQLHistory : CaoSQL_i.c, CaoSQL.h
  • IID_ICaoSQLItem : CaoSQL_i.c, CaoSQL.h
  • IID_ICaoTask : CAO_i.c
  • IID_ICaoTasks : CAO_i.c
  • IID_ICaoVariable : CAO_i.c
  • IID_ICaoVariables : CAO_i.c
  • IID_ICaoWorkspace : CAO_i.c
  • IID_ICaoWorkspaces : CAO_i.c
  • IID_IEventSink : CAO_i.c
  • IID_IRACEventSink : CaoSQL_i.c, CaoSQL.h
  • IID_IRACSever : CaoSQL_i.c, CaoSQL.h
  • INIT_TYPE : CaoSQLItem.cpp
  • IRACEventSink : CaoSQL.h
  • IRACEventSink_OnMessage_Proxy() : CaoSQL.h
  • IRACEventSink_OnMessage_Stub() : CaoSQL.h
  • IRACSever : CaoSQL.h

- l -

  • LIBID_CAOLib : CAO_i.c
  • LIBID_CaoSQLLib : CaoSQL_i.c, CaoSQL.h

- m -

  • MAP_CSCTRL : CaoSQLData.h
  • MAP_CSITEM : CaoSQLData.h
  • MIDL_PROC_FORMAT_STRING : CaoSQL_p.c
  • MIDL_TYPE_FORMAT_STRING : CaoSQL_p.c
  • MIDL_user_allocate() : CaoSQL.h
  • MIDL_user_free() : CaoSQL.h
  • MSG_CAOSQL_LOG : CAOSQLEventInfo.h
  • MSG_MAX : EventSink.h

- o -

  • Object_StubDesc : CaoSQL_p.c

- p -

  • PARAM_TYPE : CaoSQLController.cpp
  • PROC_FORMAT_STRING_SIZE : CaoSQL_p.c
  • PROCESS_PRIORITY : StdAfx.h, CaoSQL.cpp
  • PROXY_DELEGATION : dlldata.c
  • put_Activation() : CaoSQL.h
  • put_Element() : CaoSQL.h
  • put_ID() : CaoSQL.h
  • put_LinkActivation() : CaoSQL.h
  • put_SettingData() : CaoSQL.h
  • put_Tag() : CaoSQL.h
  • put_Value() : CaoSQL.h
  • put_ValueEx() : CaoSQL.h
  • pvntVal : CaoSQL.h

- r -

  • RAC_PARA_NUM : EventSink.h
  • RACEventSink : CaoSQL.h
  • REFERENCE_PROXY_FILE() : dlldata.c
  • RemoveItem() : CaoSQL.h
  • REQUEST_TYPE : CaoSQLItem.cpp
  • rsCtrlThreadActive : CorbaCaoSQL.idl
  • rsCtrlThreadStop : CorbaCaoSQL.idl
  • rsCtrlThreadWaiting : CorbaCaoSQL.idl
  • rsHRESULT : CorbaCaoSQL.idl
  • rsItemFailed : CorbaCaoSQL.idl
  • rsItemSucceeded : CorbaCaoSQL.idl
  • rsItemUndefined : CorbaCaoSQL.idl
  • rsSystemTypeController : CorbaCaoSQL.idl
  • rsSystemTypeNone : CorbaCaoSQL.idl
  • rsSystemTypeRobot : CorbaCaoSQL.idl
  • rsSystemTypeTask : CorbaCaoSQL.idl

- s -

  • SCANTIME : StdAfx.h
  • SIZEOFARRAY : CaoSQLData.h
  • Snapshot() : CaoSQL.h
  • Start() : CaoSQL.h
  • STATUS_SEVERITY_ERROR : CAOSQLEventInfo.h
  • STATUS_SEVERITY_INFORMATIONAL : CAOSQLEventInfo.h
  • STATUS_SEVERITY_WARNING : CAOSQLEventInfo.h
  • Stop() : CaoSQL.h
  • STRICT : StdAfx.h

- t -

  • TESTHR() : CaoSQLHistoryMan.h
  • THREAD_PRIORITY : StdAfx.h, CaoSQL.cpp
  • TYPE_FORMAT_STRING_SIZE : CaoSQL_p.c

- u -

  • USE_STUBLESS_PROXY : CaoSQL_p.c

- v -

  • VARIANT_TO_BOOL : CaoSQLData.h
  • VARIANT_TO_BSTR : CaoSQLData.h
  • VARIANT_UserFree() : CaoSQL.h
  • VARIANT_UserMarshal() : CaoSQL.h
  • VARIANT_UserSize() : CaoSQL.h
  • VARIANT_UserUnmarshal() : CaoSQL.h
  • VEC_CSITEM : CaoSQLController.h
  • VEC_OBSVS : CaoSQLAdviser.h
  • VEC_TRIGGEROVSV : CaoSQLController.h

- x -

  • XML_LOAD_ASYNC : StdAfx.h
  • XML_VARIDATION : StdAfx.h
  • XPATH_DOC_PROPERTY : StdAfx.h
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


Namespace Member Index

DENSO WAVE CaoSQL Project 名前空間メンバ

e | i

これは名前空間の一覧です。それぞれの名前空間の解説へリンクしています。

- e -

  • enmCaoSQLCtrlScantime : CaoSQLLib
  • enmCaoSQLCtrlState : CaoSQLLib
  • enmCaoSQLItemAttribute : CaoSQLLib
  • enmCaoSQLItemState : CaoSQLLib
  • enmCaoVariableClass : CaoSQLLib

- i -

  • importlib() : CaoSQLLib
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


Graphical Class Hierarchy

DENSO WAVE CaoSQL Project クラス階層図

クラス階層図を見る。

Generated on Tue Dec 13 12:25:38 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQL.h Source File

CaoSQL.h

解説を見る。
00001 /* this ALWAYS GENERATED file contains the definitions for the interfaces */
00002
00003
00004 /* File created by MIDL compiler version 5.01.0164 */
00005 /* at Tue Dec 13 12:25:13 2005
00006  */
00007 /* Compiler settings for D:\ORiN2\CaoSQL\Src\CaoSQL.idl:
00008     Oicf (OptLev=i2), W1, Zp8, env=Win32, ms_ext, c_ext
00009     error checks: allocation ref bounds_check enum stub_data
00010 */
00011 //@@MIDL_FILE_HEADING(  )
00012
00013
00014 /* verify that the <rpcndr.h> version is high enough to compile this file*/
00015 #ifndef __REQUIRED_RPCNDR_H_VERSION__
00016 #define __REQUIRED_RPCNDR_H_VERSION__ 440
00017 #endif
00018
00019 #include "rpc.h"
00020 #include "rpcndr.h"
00021
00022 #ifndef __RPCNDR_H_VERSION__
00023 #error this stub requires an updated version of <rpcndr.h>
00024 #endif // __RPCNDR_H_VERSION__
00025
00026 #ifndef COM_NO_WINDOWS_H
00027 #include "windows.h"
00028 #include "ole2.h"
00029 #endif /*COM_NO_WINDOWS_H*/
00030
00031 #ifndef __CaoSQL_h__
00032 #define __CaoSQL_h__
00033
00034 #ifdef __cplusplus
00035 extern "C"{
00036 #endif
00037
00038 /* Forward Declarations */
00039
00040 #ifndef __ICaoSQLEngine_FWD_DEFINED__
00041 #define __ICaoSQLEngine_FWD_DEFINED__
00042 typedef interface ICaoSQLEngine ICaoSQLEngine;
00043 #endif  /* __ICaoSQLEngine_FWD_DEFINED__ */
00044
00045
00046 #ifndef __ICaoSQLController_FWD_DEFINED__
00047 #define __ICaoSQLController_FWD_DEFINED__
00048 typedef interface ICaoSQLController ICaoSQLController;
00049 #endif  /* __ICaoSQLController_FWD_DEFINED__ */
00050
00051
00052 #ifndef __ICaoSQLItem_FWD_DEFINED__
00053 #define __ICaoSQLItem_FWD_DEFINED__
00054 typedef interface ICaoSQLItem ICaoSQLItem;
00055 #endif  /* __ICaoSQLItem_FWD_DEFINED__ */
00056
00057
00058 #ifndef __ICaoSQLHistory_FWD_DEFINED__
00059 #define __ICaoSQLHistory_FWD_DEFINED__
00060 typedef interface ICaoSQLHistory ICaoSQLHistory;
00061 #endif  /* __ICaoSQLHistory_FWD_DEFINED__ */
00062
00063
00064 #ifndef __IRACEventSink_FWD_DEFINED__
00065 #define __IRACEventSink_FWD_DEFINED__
00066 typedef interface IRACEventSink IRACEventSink;
00067 #endif  /* __IRACEventSink_FWD_DEFINED__ */
00068
00069
00070 #ifndef __CaoSQLEngine_FWD_DEFINED__
00071 #define __CaoSQLEngine_FWD_DEFINED__
00072
00073 #ifdef __cplusplus
00074 typedef class CaoSQLEngine CaoSQLEngine;
00075 #else
00076 typedef struct CaoSQLEngine CaoSQLEngine;
00077 #endif /* __cplusplus */
00078
00079 #endif  /* __CaoSQLEngine_FWD_DEFINED__ */
00080
00081
00082 #ifndef ___ICaoSQLControllerEvents_FWD_DEFINED__
00083 #define ___ICaoSQLControllerEvents_FWD_DEFINED__
00084 typedef interface _ICaoSQLControllerEvents _ICaoSQLControllerEvents;
00085 #endif  /* ___ICaoSQLControllerEvents_FWD_DEFINED__ */
00086
00087
00088 #ifndef __IRACSever_FWD_DEFINED__
00089 #define __IRACSever_FWD_DEFINED__
00090 typedef interface IRACSever IRACSever;
00091 #endif  /* __IRACSever_FWD_DEFINED__ */
00092
00093
00094 #ifndef __CaoSQLController_FWD_DEFINED__
00095 #define __CaoSQLController_FWD_DEFINED__
00096
00097 #ifdef __cplusplus
00098 typedef class CaoSQLController CaoSQLController;
00099 #else
00100 typedef struct CaoSQLController CaoSQLController;
00101 #endif /* __cplusplus */
00102
00103 #endif  /* __CaoSQLController_FWD_DEFINED__ */
00104
00105
00106 #ifndef __CaoSQLItem_FWD_DEFINED__
00107 #define __CaoSQLItem_FWD_DEFINED__
00108
00109 #ifdef __cplusplus
00110 typedef class CaoSQLItem CaoSQLItem;
00111 #else
00112 typedef struct CaoSQLItem CaoSQLItem;
00113 #endif /* __cplusplus */
00114
00115 #endif  /* __CaoSQLItem_FWD_DEFINED__ */
00116
00117
00118 #ifndef __CaoSQLHistory_FWD_DEFINED__
00119 #define __CaoSQLHistory_FWD_DEFINED__
00120
00121 #ifdef __cplusplus
00122 typedef class CaoSQLHistory CaoSQLHistory;
00123 #else
00124 typedef struct CaoSQLHistory CaoSQLHistory;
00125 #endif /* __cplusplus */
00126
00127 #endif  /* __CaoSQLHistory_FWD_DEFINED__ */
00128
00129
00130 #ifndef __RACEventSink_FWD_DEFINED__
00131 #define __RACEventSink_FWD_DEFINED__
00132
00133 #ifdef __cplusplus
00134 typedef class RACEventSink RACEventSink;
00135 #else
00136 typedef struct RACEventSink RACEventSink;
00137 #endif /* __cplusplus */
00138
00139 #endif  /* __RACEventSink_FWD_DEFINED__ */
00140
00141
00142 /* header files for imported files */
00143 #include "oaidl.h"
00144 #include "ocidl.h"
00145
00146 void __RPC_FAR * __RPC_USER MIDL_user_allocate(size_t);
00147 void __RPC_USER MIDL_user_free( void __RPC_FAR * );
00148
00149 /* interface __MIDL_itf_CaoSQL_0000 */
00150 /* [local] */
00151
00152
00153
00154
00155
00156 typedef
00157 enum enmCaoVariableClass
00158     {   csVarClassController    = 0,
00159     csVarClassTask  = 1,
00160     csVarClassRobot = 2,
00161     csVarClassExtension = 3
00162     }   _enmCaoVariableClass;
00163
00164 typedef
00165 enum enmCaoSQLCtrlState
00166     {   csCtrlThreadUninit  = 0,
00167     csCtrlThreadActive  = 0x1,
00168     csCtrlThreadDeactive    = 0x2,
00169     csCtrlThreadError   = 0x3,
00170     csCtrlThreadTerminated  = 0x4
00171     }   _enmCaoSQLCtrlState;
00172
00173 typedef
00174 enum enmCaoSQLCtrlScantime
00175     {   csCtrlScantimeLast  = 0,
00176     csCtrlScantimeMin   = 0x1,
00177     csCtrlScantimeMax   = 0x2
00178     }   _enmCaoSQLCtrlScantime;
00179
00180 typedef
00181 enum enmCaoSQLItemState
00182     {   csItemSucceeded = 0,
00183     csItemFailed    = 0x1,
00184     csItemUndefined = 0x2
00185     }   _enmCaoSQLItemState;
00186
00187 typedef
00188 enum enmCaoSQLItemAttribute
00189     {   csItemReadWrite = 0,
00190     csItemReadOnly  = 0x1,
00191     csItemWriteOnly = 0x2
00192     }   _enmCaoSQLItemAttribute;
00193
00194
00195
00196 extern RPC_IF_HANDLE __MIDL_itf_CaoSQL_0000_v0_0_c_ifspec;
00197 extern RPC_IF_HANDLE __MIDL_itf_CaoSQL_0000_v0_0_s_ifspec;
00198
00199 #ifndef __ICaoSQLEngine_INTERFACE_DEFINED__
00200 #define __ICaoSQLEngine_INTERFACE_DEFINED__
00201
00202 /* interface ICaoSQLEngine */
00203 /* [unique][helpstring][dual][uuid][object] */
00204
00205
00206 EXTERN_C const IID IID_ICaoSQLEngine;
00207
00208 #if defined(__cplusplus) && !defined(CINTERFACE)
00209
00210     MIDL_INTERFACE("82353932-2585-4f53-9412-5858D1B9DFE0")
00211     ICaoSQLEngine : public IDispatch
00212     {
00213     public:
00214         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get__NewEnum(
00215             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal) = 0;
00216
00217         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Controller(
00218             /* [in] */ VARIANT vntIndex,
00219             /* [retval][out] */ ICaoSQLController __RPC_FAR *__RPC_FAR *ppICSCtrl) = 0;
00220
00221         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Start( void) = 0;
00222
00223         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Stop( void) = 0;
00224
00225         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Snapshot( void) = 0;
00226
00227         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Execute(
00228             /* [in] */ BSTR bstrCmdText,
00229             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal) = 0;
00230
00231         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_CaoSQLHistory(
00232             /* [retval][out] */ ICaoSQLHistory __RPC_FAR *__RPC_FAR *ppICSHstry) = 0;
00233
00234         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ControllerNames(
00235             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal) = 0;
00236
00237         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Count(
00238             /* [retval][out] */ long __RPC_FAR *plVal) = 0;
00239
00240     };
00241
00242 #else   /* C style interface */
00243
00244     typedef struct ICaoSQLEngineVtbl
00245     {
00246         BEGIN_INTERFACE
00247
00248         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
00249             ICaoSQLEngine __RPC_FAR * This,
00250             /* [in] */ REFIID riid,
00251             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
00252
00253         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
00254             ICaoSQLEngine __RPC_FAR * This);
00255
00256         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
00257             ICaoSQLEngine __RPC_FAR * This);
00258
00259         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
00260             ICaoSQLEngine __RPC_FAR * This,
00261             /* [out] */ UINT __RPC_FAR *pctinfo);
00262
00263         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
00264             ICaoSQLEngine __RPC_FAR * This,
00265             /* [in] */ UINT iTInfo,
00266             /* [in] */ LCID lcid,
00267             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
00268
00269         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
00270             ICaoSQLEngine __RPC_FAR * This,
00271             /* [in] */ REFIID riid,
00272             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
00273             /* [in] */ UINT cNames,
00274             /* [in] */ LCID lcid,
00275             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
00276
00277         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
00278             ICaoSQLEngine __RPC_FAR * This,
00279             /* [in] */ DISPID dispIdMember,
00280             /* [in] */ REFIID riid,
00281             /* [in] */ LCID lcid,
00282             /* [in] */ WORD wFlags,
00283             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
00284             /* [out] */ VARIANT __RPC_FAR *pVarResult,
00285             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
00286             /* [out] */ UINT __RPC_FAR *puArgErr);
00287
00288         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get__NewEnum )(
00289             ICaoSQLEngine __RPC_FAR * This,
00290             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
00291
00292         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Controller )(
00293             ICaoSQLEngine __RPC_FAR * This,
00294             /* [in] */ VARIANT vntIndex,
00295             /* [retval][out] */ ICaoSQLController __RPC_FAR *__RPC_FAR *ppICSCtrl);
00296
00297         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Start )(
00298             ICaoSQLEngine __RPC_FAR * This);
00299
00300         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Stop )(
00301             ICaoSQLEngine __RPC_FAR * This);
00302
00303         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Snapshot )(
00304             ICaoSQLEngine __RPC_FAR * This);
00305
00306         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Execute )(
00307             ICaoSQLEngine __RPC_FAR * This,
00308             /* [in] */ BSTR bstrCmdText,
00309             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
00310
00311         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_CaoSQLHistory )(
00312             ICaoSQLEngine __RPC_FAR * This,
00313             /* [retval][out] */ ICaoSQLHistory __RPC_FAR *__RPC_FAR *ppICSHstry);
00314
00315         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ControllerNames )(
00316             ICaoSQLEngine __RPC_FAR * This,
00317             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
00318
00319         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Count )(
00320             ICaoSQLEngine __RPC_FAR * This,
00321             /* [retval][out] */ long __RPC_FAR *plVal);
00322
00323         END_INTERFACE
00324     } ICaoSQLEngineVtbl;
00325
00326     interface ICaoSQLEngine
00327     {
00328         CONST_VTBL struct ICaoSQLEngineVtbl __RPC_FAR *lpVtbl;
00329     };
00330
00331
00332
00333 #ifdef COBJMACROS
00334
00335
00336 #define ICaoSQLEngine_QueryInterface(This,riid,ppvObject)   \
00337     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
00338
00339 #define ICaoSQLEngine_AddRef(This)  \
00340     (This)->lpVtbl -> AddRef(This)
00341
00342 #define ICaoSQLEngine_Release(This) \
00343     (This)->lpVtbl -> Release(This)
00344
00345
00346 #define ICaoSQLEngine_GetTypeInfoCount(This,pctinfo)    \
00347     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
00348
00349 #define ICaoSQLEngine_GetTypeInfo(This,iTInfo,lcid,ppTInfo) \
00350     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
00351
00352 #define ICaoSQLEngine_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)   \
00353     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
00354
00355 #define ICaoSQLEngine_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr) \
00356     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
00357
00358
00359 #define ICaoSQLEngine_get__NewEnum(This,pVal)   \
00360     (This)->lpVtbl -> get__NewEnum(This,pVal)
00361
00362 #define ICaoSQLEngine_get_Controller(This,vntIndex,ppICSCtrl)   \
00363     (This)->lpVtbl -> get_Controller(This,vntIndex,ppICSCtrl)
00364
00365 #define ICaoSQLEngine_Start(This)   \
00366     (This)->lpVtbl -> Start(This)
00367
00368 #define ICaoSQLEngine_Stop(This)    \
00369     (This)->lpVtbl -> Stop(This)
00370
00371 #define ICaoSQLEngine_Snapshot(This)    \
00372     (This)->lpVtbl -> Snapshot(This)
00373
00374 #define ICaoSQLEngine_Execute(This,bstrCmdText,pvntVal) \
00375     (This)->lpVtbl -> Execute(This,bstrCmdText,pvntVal)
00376
00377 #define ICaoSQLEngine_get_CaoSQLHistory(This,ppICSHstry)    \
00378     (This)->lpVtbl -> get_CaoSQLHistory(This,ppICSHstry)
00379
00380 #define ICaoSQLEngine_get_ControllerNames(This,pvntVal) \
00381     (This)->lpVtbl -> get_ControllerNames(This,pvntVal)
00382
00383 #define ICaoSQLEngine_get_Count(This,plVal) \
00384     (This)->lpVtbl -> get_Count(This,plVal)
00385
00386 #endif /* COBJMACROS */
00387
00388
00389 #endif  /* C style interface */
00390
00391
00392
00393 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLEngine_get__NewEnum_Proxy(
00394     ICaoSQLEngine __RPC_FAR * This,
00395     /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
00396
00397
00398 void __RPC_STUB ICaoSQLEngine_get__NewEnum_Stub(
00399     IRpcStubBuffer *This,
00400     IRpcChannelBuffer *_pRpcChannelBuffer,
00401     PRPC_MESSAGE _pRpcMessage,
00402     DWORD *_pdwStubPhase);
00403
00404
00405 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLEngine_get_Controller_Proxy(
00406     ICaoSQLEngine __RPC_FAR * This,
00407     /* [in] */ VARIANT vntIndex,
00408     /* [retval][out] */ ICaoSQLController __RPC_FAR *__RPC_FAR *ppICSCtrl);
00409
00410
00411 void __RPC_STUB ICaoSQLEngine_get_Controller_Stub(
00412     IRpcStubBuffer *This,
00413     IRpcChannelBuffer *_pRpcChannelBuffer,
00414     PRPC_MESSAGE _pRpcMessage,
00415     DWORD *_pdwStubPhase);
00416
00417
00418 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoSQLEngine_Start_Proxy(
00419     ICaoSQLEngine __RPC_FAR * This);
00420
00421
00422 void __RPC_STUB ICaoSQLEngine_Start_Stub(
00423     IRpcStubBuffer *This,
00424     IRpcChannelBuffer *_pRpcChannelBuffer,
00425     PRPC_MESSAGE _pRpcMessage,
00426     DWORD *_pdwStubPhase);
00427
00428
00429 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoSQLEngine_Stop_Proxy(
00430     ICaoSQLEngine __RPC_FAR * This);
00431
00432
00433 void __RPC_STUB ICaoSQLEngine_Stop_Stub(
00434     IRpcStubBuffer *This,
00435     IRpcChannelBuffer *_pRpcChannelBuffer,
00436     PRPC_MESSAGE _pRpcMessage,
00437     DWORD *_pdwStubPhase);
00438
00439
00440 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoSQLEngine_Snapshot_Proxy(
00441     ICaoSQLEngine __RPC_FAR * This);
00442
00443
00444 void __RPC_STUB ICaoSQLEngine_Snapshot_Stub(
00445     IRpcStubBuffer *This,
00446     IRpcChannelBuffer *_pRpcChannelBuffer,
00447     PRPC_MESSAGE _pRpcMessage,
00448     DWORD *_pdwStubPhase);
00449
00450
00451 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoSQLEngine_Execute_Proxy(
00452     ICaoSQLEngine __RPC_FAR * This,
00453     /* [in] */ BSTR bstrCmdText,
00454     /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
00455
00456
00457 void __RPC_STUB ICaoSQLEngine_Execute_Stub(
00458     IRpcStubBuffer *This,
00459     IRpcChannelBuffer *_pRpcChannelBuffer,
00460     PRPC_MESSAGE _pRpcMessage,
00461     DWORD *_pdwStubPhase);
00462
00463
00464 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLEngine_get_CaoSQLHistory_Proxy(
00465     ICaoSQLEngine __RPC_FAR * This,
00466     /* [retval][out] */ ICaoSQLHistory __RPC_FAR *__RPC_FAR *ppICSHstry);
00467
00468
00469 void __RPC_STUB ICaoSQLEngine_get_CaoSQLHistory_Stub(
00470     IRpcStubBuffer *This,
00471     IRpcChannelBuffer *_pRpcChannelBuffer,
00472     PRPC_MESSAGE _pRpcMessage,
00473     DWORD *_pdwStubPhase);
00474
00475
00476 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLEngine_get_ControllerNames_Proxy(
00477     ICaoSQLEngine __RPC_FAR * This,
00478     /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
00479
00480
00481 void __RPC_STUB ICaoSQLEngine_get_ControllerNames_Stub(
00482     IRpcStubBuffer *This,
00483     IRpcChannelBuffer *_pRpcChannelBuffer,
00484     PRPC_MESSAGE _pRpcMessage,
00485     DWORD *_pdwStubPhase);
00486
00487
00488 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLEngine_get_Count_Proxy(
00489     ICaoSQLEngine __RPC_FAR * This,
00490     /* [retval][out] */ long __RPC_FAR *plVal);
00491
00492
00493 void __RPC_STUB ICaoSQLEngine_get_Count_Stub(
00494     IRpcStubBuffer *This,
00495     IRpcChannelBuffer *_pRpcChannelBuffer,
00496     PRPC_MESSAGE _pRpcMessage,
00497     DWORD *_pdwStubPhase);
00498
00499
00500
00501 #endif  /* __ICaoSQLEngine_INTERFACE_DEFINED__ */
00502
00503
00504 #ifndef __ICaoSQLController_INTERFACE_DEFINED__
00505 #define __ICaoSQLController_INTERFACE_DEFINED__
00506
00507 /* interface ICaoSQLController */
00508 /* [unique][helpstring][dual][uuid][object] */
00509
00510
00511 EXTERN_C const IID IID_ICaoSQLController;
00512
00513 #if defined(__cplusplus) && !defined(CINTERFACE)
00514
00515     MIDL_INTERFACE("1C61BAA2-7E70-44e9-8160-EB349ED2C0D8")
00516     ICaoSQLController : public IDispatch
00517     {
00518     public:
00519         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get__NewEnum(
00520             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal) = 0;
00521
00522         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Item(
00523             /* [in] */ VARIANT vntIndex,
00524             /* [retval][out] */ ICaoSQLItem __RPC_FAR *__RPC_FAR *ppICSItem) = 0;
00525
00526         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Start( void) = 0;
00527
00528         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Stop( void) = 0;
00529
00530         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Snapshot( void) = 0;
00531
00532         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE AddItem(
00533             /* [in] */ VARIANT vntDataArray) = 0;
00534
00535         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE RemoveItem(
00536             /* [in] */ VARIANT vntIndex) = 0;
00537
00538         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Execute(
00539             /* [in] */ BSTR bstrCommand,
00540             /* [optional][in] */ VARIANT vntParam,
00541             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal) = 0;
00542
00543         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Count(
00544             /* [retval][out] */ long __RPC_FAR *plVal) = 0;
00545
00546         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Index(
00547             /* [retval][out] */ long __RPC_FAR *plVal) = 0;
00548
00549         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ItemNames(
00550             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal) = 0;
00551
00552         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ScanTimes(
00553             /* [in] */ long lIndex,
00554             /* [retval][out] */ long __RPC_FAR *plVal) = 0;
00555
00556         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_State(
00557             /* [retval][out] */ long __RPC_FAR *plVal) = 0;
00558
00559         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Tag(
00560             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal) = 0;
00561
00562         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Tag(
00563             /* [in] */ VARIANT vntNewVal) = 0;
00564
00565         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Description(
00566             /* [retval][out] */ BSTR __RPC_FAR *pbstrVal) = 0;
00567
00568         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
00569             /* [retval][out] */ BSTR __RPC_FAR *pbstrVal) = 0;
00570
00571         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_SettingData(
00572             /* [in] */ VARIANT vntName,
00573             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal) = 0;
00574
00575         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_SettingData(
00576             /* [in] */ VARIANT vntName,
00577             /* [in] */ VARIANT vntNewVal) = 0;
00578
00579     };
00580
00581 #else   /* C style interface */
00582
00583     typedef struct ICaoSQLControllerVtbl
00584     {
00585         BEGIN_INTERFACE
00586
00587         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
00588             ICaoSQLController __RPC_FAR * This,
00589             /* [in] */ REFIID riid,
00590             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
00591
00592         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
00593             ICaoSQLController __RPC_FAR * This);
00594
00595         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
00596             ICaoSQLController __RPC_FAR * This);
00597
00598         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
00599             ICaoSQLController __RPC_FAR * This,
00600             /* [out] */ UINT __RPC_FAR *pctinfo);
00601
00602         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
00603             ICaoSQLController __RPC_FAR * This,
00604             /* [in] */ UINT iTInfo,
00605             /* [in] */ LCID lcid,
00606             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
00607
00608         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
00609             ICaoSQLController __RPC_FAR * This,
00610             /* [in] */ REFIID riid,
00611             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
00612             /* [in] */ UINT cNames,
00613             /* [in] */ LCID lcid,
00614             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
00615
00616         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
00617             ICaoSQLController __RPC_FAR * This,
00618             /* [in] */ DISPID dispIdMember,
00619             /* [in] */ REFIID riid,
00620             /* [in] */ LCID lcid,
00621             /* [in] */ WORD wFlags,
00622             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
00623             /* [out] */ VARIANT __RPC_FAR *pVarResult,
00624             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
00625             /* [out] */ UINT __RPC_FAR *puArgErr);
00626
00627         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get__NewEnum )(
00628             ICaoSQLController __RPC_FAR * This,
00629             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
00630
00631         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Item )(
00632             ICaoSQLController __RPC_FAR * This,
00633             /* [in] */ VARIANT vntIndex,
00634             /* [retval][out] */ ICaoSQLItem __RPC_FAR *__RPC_FAR *ppICSItem);
00635
00636         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Start )(
00637             ICaoSQLController __RPC_FAR * This);
00638
00639         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Stop )(
00640             ICaoSQLController __RPC_FAR * This);
00641
00642         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Snapshot )(
00643             ICaoSQLController __RPC_FAR * This);
00644
00645         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *AddItem )(
00646             ICaoSQLController __RPC_FAR * This,
00647             /* [in] */ VARIANT vntDataArray);
00648
00649         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *RemoveItem )(
00650             ICaoSQLController __RPC_FAR * This,
00651             /* [in] */ VARIANT vntIndex);
00652
00653         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Execute )(
00654             ICaoSQLController __RPC_FAR * This,
00655             /* [in] */ BSTR bstrCommand,
00656             /* [optional][in] */ VARIANT vntParam,
00657             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
00658
00659         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Count )(
00660             ICaoSQLController __RPC_FAR * This,
00661             /* [retval][out] */ long __RPC_FAR *plVal);
00662
00663         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Index )(
00664             ICaoSQLController __RPC_FAR * This,
00665             /* [retval][out] */ long __RPC_FAR *plVal);
00666
00667         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ItemNames )(
00668             ICaoSQLController __RPC_FAR * This,
00669             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
00670
00671         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ScanTimes )(
00672             ICaoSQLController __RPC_FAR * This,
00673             /* [in] */ long lIndex,
00674             /* [retval][out] */ long __RPC_FAR *plVal);
00675
00676         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_State )(
00677             ICaoSQLController __RPC_FAR * This,
00678             /* [retval][out] */ long __RPC_FAR *plVal);
00679
00680         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Tag )(
00681             ICaoSQLController __RPC_FAR * This,
00682             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
00683
00684         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Tag )(
00685             ICaoSQLController __RPC_FAR * This,
00686             /* [in] */ VARIANT vntNewVal);
00687
00688         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Description )(
00689             ICaoSQLController __RPC_FAR * This,
00690             /* [retval][out] */ BSTR __RPC_FAR *pbstrVal);
00691
00692         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
00693             ICaoSQLController __RPC_FAR * This,
00694             /* [retval][out] */ BSTR __RPC_FAR *pbstrVal);
00695
00696         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_SettingData )(
00697             ICaoSQLController __RPC_FAR * This,
00698             /* [in] */ VARIANT vntName,
00699             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
00700
00701         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_SettingData )(
00702             ICaoSQLController __RPC_FAR * This,
00703             /* [in] */ VARIANT vntName,
00704             /* [in] */ VARIANT vntNewVal);
00705
00706         END_INTERFACE
00707     } ICaoSQLControllerVtbl;
00708
00709     interface ICaoSQLController
00710     {
00711         CONST_VTBL struct ICaoSQLControllerVtbl __RPC_FAR *lpVtbl;
00712     };
00713
00714
00715
00716 #ifdef COBJMACROS
00717
00718
00719 #define ICaoSQLController_QueryInterface(This,riid,ppvObject)   \
00720     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
00721
00722 #define ICaoSQLController_AddRef(This)  \
00723     (This)->lpVtbl -> AddRef(This)
00724
00725 #define ICaoSQLController_Release(This) \
00726     (This)->lpVtbl -> Release(This)
00727
00728
00729 #define ICaoSQLController_GetTypeInfoCount(This,pctinfo)    \
00730     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
00731
00732 #define ICaoSQLController_GetTypeInfo(This,iTInfo,lcid,ppTInfo) \
00733     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
00734
00735 #define ICaoSQLController_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)   \
00736     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
00737
00738 #define ICaoSQLController_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr) \
00739     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
00740
00741
00742 #define ICaoSQLController_get__NewEnum(This,pVal)   \
00743     (This)->lpVtbl -> get__NewEnum(This,pVal)
00744
00745 #define ICaoSQLController_get_Item(This,vntIndex,ppICSItem) \
00746     (This)->lpVtbl -> get_Item(This,vntIndex,ppICSItem)
00747
00748 #define ICaoSQLController_Start(This)   \
00749     (This)->lpVtbl -> Start(This)
00750
00751 #define ICaoSQLController_Stop(This)    \
00752     (This)->lpVtbl -> Stop(This)
00753
00754 #define ICaoSQLController_Snapshot(This)    \
00755     (This)->lpVtbl -> Snapshot(This)
00756
00757 #define ICaoSQLController_AddItem(This,vntDataArray)    \
00758     (This)->lpVtbl -> AddItem(This,vntDataArray)
00759
00760 #define ICaoSQLController_RemoveItem(This,vntIndex) \
00761     (This)->lpVtbl -> RemoveItem(This,vntIndex)
00762
00763 #define ICaoSQLController_Execute(This,bstrCommand,vntParam,pvntVal)    \
00764     (This)->lpVtbl -> Execute(This,bstrCommand,vntParam,pvntVal)
00765
00766 #define ICaoSQLController_get_Count(This,plVal) \
00767     (This)->lpVtbl -> get_Count(This,plVal)
00768
00769 #define ICaoSQLController_get_Index(This,plVal) \
00770     (This)->lpVtbl -> get_Index(This,plVal)
00771
00772 #define ICaoSQLController_get_ItemNames(This,pvntVal)   \
00773     (This)->lpVtbl -> get_ItemNames(This,pvntVal)
00774
00775 #define ICaoSQLController_get_ScanTimes(This,lIndex,plVal)  \
00776     (This)->lpVtbl -> get_ScanTimes(This,lIndex,plVal)
00777
00778 #define ICaoSQLController_get_State(This,plVal) \
00779     (This)->lpVtbl -> get_State(This,plVal)
00780
00781 #define ICaoSQLController_get_Tag(This,pvntVal) \
00782     (This)->lpVtbl -> get_Tag(This,pvntVal)
00783
00784 #define ICaoSQLController_put_Tag(This,vntNewVal)   \
00785     (This)->lpVtbl -> put_Tag(This,vntNewVal)
00786
00787 #define ICaoSQLController_get_Description(This,pbstrVal)    \
00788     (This)->lpVtbl -> get_Description(This,pbstrVal)
00789
00790 #define ICaoSQLController_get_Name(This,pbstrVal)   \
00791     (This)->lpVtbl -> get_Name(This,pbstrVal)
00792
00793 #define ICaoSQLController_get_SettingData(This,vntName,pvntVal) \
00794     (This)->lpVtbl -> get_SettingData(This,vntName,pvntVal)
00795
00796 #define ICaoSQLController_put_SettingData(This,vntName,vntNewVal)   \
00797     (This)->lpVtbl -> put_SettingData(This,vntName,vntNewVal)
00798
00799 #endif /* COBJMACROS */
00800
00801
00802 #endif  /* C style interface */
00803
00804
00805
00806 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_get__NewEnum_Proxy(
00807     ICaoSQLController __RPC_FAR * This,
00808     /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
00809
00810
00811 void __RPC_STUB ICaoSQLController_get__NewEnum_Stub(
00812     IRpcStubBuffer *This,
00813     IRpcChannelBuffer *_pRpcChannelBuffer,
00814     PRPC_MESSAGE _pRpcMessage,
00815     DWORD *_pdwStubPhase);
00816
00817
00818 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_get_Item_Proxy(
00819     ICaoSQLController __RPC_FAR * This,
00820     /* [in] */ VARIANT vntIndex,
00821     /* [retval][out] */ ICaoSQLItem __RPC_FAR *__RPC_FAR *ppICSItem);
00822
00823
00824 void __RPC_STUB ICaoSQLController_get_Item_Stub(
00825     IRpcStubBuffer *This,
00826     IRpcChannelBuffer *_pRpcChannelBuffer,
00827     PRPC_MESSAGE _pRpcMessage,
00828     DWORD *_pdwStubPhase);
00829
00830
00831 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_Start_Proxy(
00832     ICaoSQLController __RPC_FAR * This);
00833
00834
00835 void __RPC_STUB ICaoSQLController_Start_Stub(
00836     IRpcStubBuffer *This,
00837     IRpcChannelBuffer *_pRpcChannelBuffer,
00838     PRPC_MESSAGE _pRpcMessage,
00839     DWORD *_pdwStubPhase);
00840
00841
00842 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_Stop_Proxy(
00843     ICaoSQLController __RPC_FAR * This);
00844
00845
00846 void __RPC_STUB ICaoSQLController_Stop_Stub(
00847     IRpcStubBuffer *This,
00848     IRpcChannelBuffer *_pRpcChannelBuffer,
00849     PRPC_MESSAGE _pRpcMessage,
00850     DWORD *_pdwStubPhase);
00851
00852
00853 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_Snapshot_Proxy(
00854     ICaoSQLController __RPC_FAR * This);
00855
00856
00857 void __RPC_STUB ICaoSQLController_Snapshot_Stub(
00858     IRpcStubBuffer *This,
00859     IRpcChannelBuffer *_pRpcChannelBuffer,
00860     PRPC_MESSAGE _pRpcMessage,
00861     DWORD *_pdwStubPhase);
00862
00863
00864 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_AddItem_Proxy(
00865     ICaoSQLController __RPC_FAR * This,
00866     /* [in] */ VARIANT vntDataArray);
00867
00868
00869 void __RPC_STUB ICaoSQLController_AddItem_Stub(
00870     IRpcStubBuffer *This,
00871     IRpcChannelBuffer *_pRpcChannelBuffer,
00872     PRPC_MESSAGE _pRpcMessage,
00873     DWORD *_pdwStubPhase);
00874
00875
00876 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_RemoveItem_Proxy(
00877     ICaoSQLController __RPC_FAR * This,
00878     /* [in] */ VARIANT vntIndex);
00879
00880
00881 void __RPC_STUB ICaoSQLController_RemoveItem_Stub(
00882     IRpcStubBuffer *This,
00883     IRpcChannelBuffer *_pRpcChannelBuffer,
00884     PRPC_MESSAGE _pRpcMessage,
00885     DWORD *_pdwStubPhase);
00886
00887
00888 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_Execute_Proxy(
00889     ICaoSQLController __RPC_FAR * This,
00890     /* [in] */ BSTR bstrCommand,
00891     /* [optional][in] */ VARIANT vntParam,
00892     /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
00893
00894
00895 void __RPC_STUB ICaoSQLController_Execute_Stub(
00896     IRpcStubBuffer *This,
00897     IRpcChannelBuffer *_pRpcChannelBuffer,
00898     PRPC_MESSAGE _pRpcMessage,
00899     DWORD *_pdwStubPhase);
00900
00901
00902 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_get_Count_Proxy(
00903     ICaoSQLController __RPC_FAR * This,
00904     /* [retval][out] */ long __RPC_FAR *plVal);
00905
00906
00907 void __RPC_STUB ICaoSQLController_get_Count_Stub(
00908     IRpcStubBuffer *This,
00909     IRpcChannelBuffer *_pRpcChannelBuffer,
00910     PRPC_MESSAGE _pRpcMessage,
00911     DWORD *_pdwStubPhase);
00912
00913
00914 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_get_Index_Proxy(
00915     ICaoSQLController __RPC_FAR * This,
00916     /* [retval][out] */ long __RPC_FAR *plVal);
00917
00918
00919 void __RPC_STUB ICaoSQLController_get_Index_Stub(
00920     IRpcStubBuffer *This,
00921     IRpcChannelBuffer *_pRpcChannelBuffer,
00922     PRPC_MESSAGE _pRpcMessage,
00923     DWORD *_pdwStubPhase);
00924
00925
00926 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_get_ItemNames_Proxy(
00927     ICaoSQLController __RPC_FAR * This,
00928     /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
00929
00930
00931 void __RPC_STUB ICaoSQLController_get_ItemNames_Stub(
00932     IRpcStubBuffer *This,
00933     IRpcChannelBuffer *_pRpcChannelBuffer,
00934     PRPC_MESSAGE _pRpcMessage,
00935     DWORD *_pdwStubPhase);
00936
00937
00938 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_get_ScanTimes_Proxy(
00939     ICaoSQLController __RPC_FAR * This,
00940     /* [in] */ long lIndex,
00941     /* [retval][out] */ long __RPC_FAR *plVal);
00942
00943
00944 void __RPC_STUB ICaoSQLController_get_ScanTimes_Stub(
00945     IRpcStubBuffer *This,
00946     IRpcChannelBuffer *_pRpcChannelBuffer,
00947     PRPC_MESSAGE _pRpcMessage,
00948     DWORD *_pdwStubPhase);
00949
00950
00951 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_get_State_Proxy(
00952     ICaoSQLController __RPC_FAR * This,
00953     /* [retval][out] */ long __RPC_FAR *plVal);
00954
00955
00956 void __RPC_STUB ICaoSQLController_get_State_Stub(
00957     IRpcStubBuffer *This,
00958     IRpcChannelBuffer *_pRpcChannelBuffer,
00959     PRPC_MESSAGE _pRpcMessage,
00960     DWORD *_pdwStubPhase);
00961
00962
00963 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_get_Tag_Proxy(
00964     ICaoSQLController __RPC_FAR * This,
00965     /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
00966
00967
00968 void __RPC_STUB ICaoSQLController_get_Tag_Stub(
00969     IRpcStubBuffer *This,
00970     IRpcChannelBuffer *_pRpcChannelBuffer,
00971     PRPC_MESSAGE _pRpcMessage,
00972     DWORD *_pdwStubPhase);
00973
00974
00975 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_put_Tag_Proxy(
00976     ICaoSQLController __RPC_FAR * This,
00977     /* [in] */ VARIANT vntNewVal);
00978
00979
00980 void __RPC_STUB ICaoSQLController_put_Tag_Stub(
00981     IRpcStubBuffer *This,
00982     IRpcChannelBuffer *_pRpcChannelBuffer,
00983     PRPC_MESSAGE _pRpcMessage,
00984     DWORD *_pdwStubPhase);
00985
00986
00987 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_get_Description_Proxy(
00988     ICaoSQLController __RPC_FAR * This,
00989     /* [retval][out] */ BSTR __RPC_FAR *pbstrVal);
00990
00991
00992 void __RPC_STUB ICaoSQLController_get_Description_Stub(
00993     IRpcStubBuffer *This,
00994     IRpcChannelBuffer *_pRpcChannelBuffer,
00995     PRPC_MESSAGE _pRpcMessage,
00996     DWORD *_pdwStubPhase);
00997
00998
00999 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_get_Name_Proxy(
01000     ICaoSQLController __RPC_FAR * This,
01001     /* [retval][out] */ BSTR __RPC_FAR *pbstrVal);
01002
01003
01004 void __RPC_STUB ICaoSQLController_get_Name_Stub(
01005     IRpcStubBuffer *This,
01006     IRpcChannelBuffer *_pRpcChannelBuffer,
01007     PRPC_MESSAGE _pRpcMessage,
01008     DWORD *_pdwStubPhase);
01009
01010
01011 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_get_SettingData_Proxy(
01012     ICaoSQLController __RPC_FAR * This,
01013     /* [in] */ VARIANT vntName,
01014     /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
01015
01016
01017 void __RPC_STUB ICaoSQLController_get_SettingData_Stub(
01018     IRpcStubBuffer *This,
01019     IRpcChannelBuffer *_pRpcChannelBuffer,
01020     PRPC_MESSAGE _pRpcMessage,
01021     DWORD *_pdwStubPhase);
01022
01023
01024 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoSQLController_put_SettingData_Proxy(
01025     ICaoSQLController __RPC_FAR * This,
01026     /* [in] */ VARIANT vntName,
01027     /* [in] */ VARIANT vntNewVal);
01028
01029
01030 void __RPC_STUB ICaoSQLController_put_SettingData_Stub(
01031     IRpcStubBuffer *This,
01032     IRpcChannelBuffer *_pRpcChannelBuffer,
01033     PRPC_MESSAGE _pRpcMessage,
01034     DWORD *_pdwStubPhase);
01035
01036
01037
01038 #endif  /* __ICaoSQLController_INTERFACE_DEFINED__ */
01039
01040
01041 #ifndef __ICaoSQLItem_INTERFACE_DEFINED__
01042 #define __ICaoSQLItem_INTERFACE_DEFINED__
01043
01044 /* interface ICaoSQLItem */
01045 /* [unique][helpstring][dual][uuid][object] */
01046
01047
01048 EXTERN_C const IID IID_ICaoSQLItem;
01049
01050 #if defined(__cplusplus) && !defined(CINTERFACE)
01051
01052     MIDL_INTERFACE("A49597A1-5DF3-4c09-9339-3FFF80A6B69F")
01053     ICaoSQLItem : public IDispatch
01054     {
01055     public:
01056         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Value(
01057             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal) = 0;
01058
01059         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Value(
01060             /* [in] */ VARIANT vntNewVal) = 0;
01061
01062         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Snapshot( void) = 0;
01063
01064         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Activation(
01065             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pbVal) = 0;
01066
01067         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Activation(
01068             /* [in] */ VARIANT_BOOL bNewVal) = 0;
01069
01070         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_DateTime(
01071             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal) = 0;
01072
01073         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Index(
01074             /* [retval][out] */ long __RPC_FAR *plVal) = 0;
01075
01076         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_LinkActivation(
01077             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pbVal) = 0;
01078
01079         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_LinkActivation(
01080             /* [in] */ VARIANT_BOOL bNewVal) = 0;
01081
01082         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Microsecond(
01083             /* [retval][out] */ long __RPC_FAR *plVal) = 0;
01084
01085         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_State(
01086             /* [retval][out] */ long __RPC_FAR *plVal) = 0;
01087
01088         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Tag(
01089             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal) = 0;
01090
01091         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Tag(
01092             /* [in] */ VARIANT vntNewVal) = 0;
01093
01094         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ValueEx(
01095             /* [defaultvalue][in] */ long lDelay,
01096             VARIANT vntNewVal) = 0;
01097
01098         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Attribute(
01099             /* [retval][out] */ long __RPC_FAR *plVal) = 0;
01100
01101         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Description(
01102             /* [retval][out] */ BSTR __RPC_FAR *pbstrVal) = 0;
01103
01104         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Element(
01105             /* [in] */ long lIndex1,
01106             /* [defaultvalue][in] */ long lIndex2,
01107             /* [defaultvalue][in] */ long lIndex3,
01108             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
01109
01110         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Element(
01111             /* [in] */ long lIndex1,
01112             /* [defaultvalue][in] */ long lIndex2,
01113             /* [defaultvalue][in] */ long lIndex3,
01114             /* [in] */ VARIANT newVal) = 0;
01115
01116         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ID(
01117             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
01118
01119         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ID(
01120             /* [in] */ VARIANT newVal) = 0;
01121
01122         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_LinkItemNames(
01123             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal) = 0;
01124
01125         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
01126             /* [retval][out] */ BSTR __RPC_FAR *pbstrVal) = 0;
01127
01128         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_SettingData(
01129             /* [in] */ VARIANT vntName,
01130             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal) = 0;
01131
01132         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_SettingData(
01133             /* [in] */ VARIANT vntName,
01134             /* [in] */ VARIANT vntNewVal) = 0;
01135
01136     };
01137
01138 #else   /* C style interface */
01139
01140     typedef struct ICaoSQLItemVtbl
01141     {
01142         BEGIN_INTERFACE
01143
01144         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
01145             ICaoSQLItem __RPC_FAR * This,
01146             /* [in] */ REFIID riid,
01147             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
01148
01149         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
01150             ICaoSQLItem __RPC_FAR * This);
01151
01152         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
01153             ICaoSQLItem __RPC_FAR * This);
01154
01155         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
01156             ICaoSQLItem __RPC_FAR * This,
01157             /* [out] */ UINT __RPC_FAR *pctinfo);
01158
01159         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
01160             ICaoSQLItem __RPC_FAR * This,
01161             /* [in] */ UINT iTInfo,
01162             /* [in] */ LCID lcid,
01163             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
01164
01165         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
01166             ICaoSQLItem __RPC_FAR * This,
01167             /* [in] */ REFIID riid,
01168             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
01169             /* [in] */ UINT cNames,
01170             /* [in] */ LCID lcid,
01171             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
01172
01173         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
01174             ICaoSQLItem __RPC_FAR * This,
01175             /* [in] */ DISPID dispIdMember,
01176             /* [in] */ REFIID riid,
01177             /* [in] */ LCID lcid,
01178             /* [in] */ WORD wFlags,
01179             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
01180             /* [out] */ VARIANT __RPC_FAR *pVarResult,
01181             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
01182             /* [out] */ UINT __RPC_FAR *puArgErr);
01183
01184         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Value )(
01185             ICaoSQLItem __RPC_FAR * This,
01186             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
01187
01188         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Value )(
01189             ICaoSQLItem __RPC_FAR * This,
01190             /* [in] */ VARIANT vntNewVal);
01191
01192         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Snapshot )(
01193             ICaoSQLItem __RPC_FAR * This);
01194
01195         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Activation )(
01196             ICaoSQLItem __RPC_FAR * This,
01197             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pbVal);
01198
01199         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Activation )(
01200             ICaoSQLItem __RPC_FAR * This,
01201             /* [in] */ VARIANT_BOOL bNewVal);
01202
01203         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_DateTime )(
01204             ICaoSQLItem __RPC_FAR * This,
01205             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
01206
01207         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Index )(
01208             ICaoSQLItem __RPC_FAR * This,
01209             /* [retval][out] */ long __RPC_FAR *plVal);
01210
01211         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_LinkActivation )(
01212             ICaoSQLItem __RPC_FAR * This,
01213             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pbVal);
01214
01215         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_LinkActivation )(
01216             ICaoSQLItem __RPC_FAR * This,
01217             /* [in] */ VARIANT_BOOL bNewVal);
01218
01219         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Microsecond )(
01220             ICaoSQLItem __RPC_FAR * This,
01221             /* [retval][out] */ long __RPC_FAR *plVal);
01222
01223         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_State )(
01224             ICaoSQLItem __RPC_FAR * This,
01225             /* [retval][out] */ long __RPC_FAR *plVal);
01226
01227         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Tag )(
01228             ICaoSQLItem __RPC_FAR * This,
01229             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
01230
01231         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Tag )(
01232             ICaoSQLItem __RPC_FAR * This,
01233             /* [in] */ VARIANT vntNewVal);
01234
01235         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ValueEx )(
01236             ICaoSQLItem __RPC_FAR * This,
01237             /* [defaultvalue][in] */ long lDelay,
01238             VARIANT vntNewVal);
01239
01240         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Attribute )(
01241             ICaoSQLItem __RPC_FAR * This,
01242             /* [retval][out] */ long __RPC_FAR *plVal);
01243
01244         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Description )(
01245             ICaoSQLItem __RPC_FAR * This,
01246             /* [retval][out] */ BSTR __RPC_FAR *pbstrVal);
01247
01248         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Element )(
01249             ICaoSQLItem __RPC_FAR * This,
01250             /* [in] */ long lIndex1,
01251             /* [defaultvalue][in] */ long lIndex2,
01252             /* [defaultvalue][in] */ long lIndex3,
01253             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01254
01255         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Element )(
01256             ICaoSQLItem __RPC_FAR * This,
01257             /* [in] */ long lIndex1,
01258             /* [defaultvalue][in] */ long lIndex2,
01259             /* [defaultvalue][in] */ long lIndex3,
01260             /* [in] */ VARIANT newVal);
01261
01262         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ID )(
01263             ICaoSQLItem __RPC_FAR * This,
01264             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01265
01266         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ID )(
01267             ICaoSQLItem __RPC_FAR * This,
01268             /* [in] */ VARIANT newVal);
01269
01270         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_LinkItemNames )(
01271             ICaoSQLItem __RPC_FAR * This,
01272             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
01273
01274         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
01275             ICaoSQLItem __RPC_FAR * This,
01276             /* [retval][out] */ BSTR __RPC_FAR *pbstrVal);
01277
01278         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_SettingData )(
01279             ICaoSQLItem __RPC_FAR * This,
01280             /* [in] */ VARIANT vntName,
01281             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
01282
01283         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_SettingData )(
01284             ICaoSQLItem __RPC_FAR * This,
01285             /* [in] */ VARIANT vntName,
01286             /* [in] */ VARIANT vntNewVal);
01287
01288         END_INTERFACE
01289     } ICaoSQLItemVtbl;
01290
01291     interface ICaoSQLItem
01292     {
01293         CONST_VTBL struct ICaoSQLItemVtbl __RPC_FAR *lpVtbl;
01294     };
01295
01296
01297
01298 #ifdef COBJMACROS
01299
01300
01301 #define ICaoSQLItem_QueryInterface(This,riid,ppvObject) \
01302     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
01303
01304 #define ICaoSQLItem_AddRef(This)    \
01305     (This)->lpVtbl -> AddRef(This)
01306
01307 #define ICaoSQLItem_Release(This)   \
01308     (This)->lpVtbl -> Release(This)
01309
01310
01311 #define ICaoSQLItem_GetTypeInfoCount(This,pctinfo)  \
01312     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
01313
01314 #define ICaoSQLItem_GetTypeInfo(This,iTInfo,lcid,ppTInfo)   \
01315     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
01316
01317 #define ICaoSQLItem_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId) \
01318     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
01319
01320 #define ICaoSQLItem_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)   \
01321     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
01322
01323
01324 #define ICaoSQLItem_get_Value(This,pvntVal) \
01325     (This)->lpVtbl -> get_Value(This,pvntVal)
01326
01327 #define ICaoSQLItem_put_Value(This,vntNewVal)   \
01328     (This)->lpVtbl -> put_Value(This,vntNewVal)
01329
01330 #define ICaoSQLItem_Snapshot(This)  \
01331     (This)->lpVtbl -> Snapshot(This)
01332
01333 #define ICaoSQLItem_get_Activation(This,pbVal)  \
01334     (This)->lpVtbl -> get_Activation(This,pbVal)
01335
01336 #define ICaoSQLItem_put_Activation(This,bNewVal)    \
01337     (This)->lpVtbl -> put_Activation(This,bNewVal)
01338
01339 #define ICaoSQLItem_get_DateTime(This,pvntVal)  \
01340     (This)->lpVtbl -> get_DateTime(This,pvntVal)
01341
01342 #define ICaoSQLItem_get_Index(This,plVal)   \
01343     (This)->lpVtbl -> get_Index(This,plVal)
01344
01345 #define ICaoSQLItem_get_LinkActivation(This,pbVal)  \
01346     (This)->lpVtbl -> get_LinkActivation(This,pbVal)
01347
01348 #define ICaoSQLItem_put_LinkActivation(This,bNewVal)    \
01349     (This)->lpVtbl -> put_LinkActivation(This,bNewVal)
01350
01351 #define ICaoSQLItem_get_Microsecond(This,plVal) \
01352     (This)->lpVtbl -> get_Microsecond(This,plVal)
01353
01354 #define ICaoSQLItem_get_State(This,plVal)   \
01355     (This)->lpVtbl -> get_State(This,plVal)
01356
01357 #define ICaoSQLItem_get_Tag(This,pvntVal)   \
01358     (This)->lpVtbl -> get_Tag(This,pvntVal)
01359
01360 #define ICaoSQLItem_put_Tag(This,vntNewVal) \
01361     (This)->lpVtbl -> put_Tag(This,vntNewVal)
01362
01363 #define ICaoSQLItem_put_ValueEx(This,lDelay,vntNewVal)  \
01364     (This)->lpVtbl -> put_ValueEx(This,lDelay,vntNewVal)
01365
01366 #define ICaoSQLItem_get_Attribute(This,plVal)   \
01367     (This)->lpVtbl -> get_Attribute(This,plVal)
01368
01369 #define ICaoSQLItem_get_Description(This,pbstrVal)  \
01370     (This)->lpVtbl -> get_Description(This,pbstrVal)
01371
01372 #define ICaoSQLItem_get_Element(This,lIndex1,lIndex2,lIndex3,pVal)  \
01373     (This)->lpVtbl -> get_Element(This,lIndex1,lIndex2,lIndex3,pVal)
01374
01375 #define ICaoSQLItem_put_Element(This,lIndex1,lIndex2,lIndex3,newVal)    \
01376     (This)->lpVtbl -> put_Element(This,lIndex1,lIndex2,lIndex3,newVal)
01377
01378 #define ICaoSQLItem_get_ID(This,pVal)   \
01379     (This)->lpVtbl -> get_ID(This,pVal)
01380
01381 #define ICaoSQLItem_put_ID(This,newVal) \
01382     (This)->lpVtbl -> put_ID(This,newVal)
01383
01384 #define ICaoSQLItem_get_LinkItemNames(This,pvntVal) \
01385     (This)->lpVtbl -> get_LinkItemNames(This,pvntVal)
01386
01387 #define ICaoSQLItem_get_Name(This,pbstrVal) \
01388     (This)->lpVtbl -> get_Name(This,pbstrVal)
01389
01390 #define ICaoSQLItem_get_SettingData(This,vntName,pvntVal)   \
01391     (This)->lpVtbl -> get_SettingData(This,vntName,pvntVal)
01392
01393 #define ICaoSQLItem_put_SettingData(This,vntName,vntNewVal) \
01394     (This)->lpVtbl -> put_SettingData(This,vntName,vntNewVal)
01395
01396 #endif /* COBJMACROS */
01397
01398
01399 #endif  /* C style interface */
01400
01401
01402
01403 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Value_Proxy(
01404     ICaoSQLItem __RPC_FAR * This,
01405     /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
01406
01407
01408 void __RPC_STUB ICaoSQLItem_get_Value_Stub(
01409     IRpcStubBuffer *This,
01410     IRpcChannelBuffer *_pRpcChannelBuffer,
01411     PRPC_MESSAGE _pRpcMessage,
01412     DWORD *_pdwStubPhase);
01413
01414
01415 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_put_Value_Proxy(
01416     ICaoSQLItem __RPC_FAR * This,
01417     /* [in] */ VARIANT vntNewVal);
01418
01419
01420 void __RPC_STUB ICaoSQLItem_put_Value_Stub(
01421     IRpcStubBuffer *This,
01422     IRpcChannelBuffer *_pRpcChannelBuffer,
01423     PRPC_MESSAGE _pRpcMessage,
01424     DWORD *_pdwStubPhase);
01425
01426
01427 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_Snapshot_Proxy(
01428     ICaoSQLItem __RPC_FAR * This);
01429
01430
01431 void __RPC_STUB ICaoSQLItem_Snapshot_Stub(
01432     IRpcStubBuffer *This,
01433     IRpcChannelBuffer *_pRpcChannelBuffer,
01434     PRPC_MESSAGE _pRpcMessage,
01435     DWORD *_pdwStubPhase);
01436
01437
01438 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Activation_Proxy(
01439     ICaoSQLItem __RPC_FAR * This,
01440     /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pbVal);
01441
01442
01443 void __RPC_STUB ICaoSQLItem_get_Activation_Stub(
01444     IRpcStubBuffer *This,
01445     IRpcChannelBuffer *_pRpcChannelBuffer,
01446     PRPC_MESSAGE _pRpcMessage,
01447     DWORD *_pdwStubPhase);
01448
01449
01450 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_put_Activation_Proxy(
01451     ICaoSQLItem __RPC_FAR * This,
01452     /* [in] */ VARIANT_BOOL bNewVal);
01453
01454
01455 void __RPC_STUB ICaoSQLItem_put_Activation_Stub(
01456     IRpcStubBuffer *This,
01457     IRpcChannelBuffer *_pRpcChannelBuffer,
01458     PRPC_MESSAGE _pRpcMessage,
01459     DWORD *_pdwStubPhase);
01460
01461
01462 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_DateTime_Proxy(
01463     ICaoSQLItem __RPC_FAR * This,
01464     /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
01465
01466
01467 void __RPC_STUB ICaoSQLItem_get_DateTime_Stub(
01468     IRpcStubBuffer *This,
01469     IRpcChannelBuffer *_pRpcChannelBuffer,
01470     PRPC_MESSAGE _pRpcMessage,
01471     DWORD *_pdwStubPhase);
01472
01473
01474 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Index_Proxy(
01475     ICaoSQLItem __RPC_FAR * This,
01476     /* [retval][out] */ long __RPC_FAR *plVal);
01477
01478
01479 void __RPC_STUB ICaoSQLItem_get_Index_Stub(
01480     IRpcStubBuffer *This,
01481     IRpcChannelBuffer *_pRpcChannelBuffer,
01482     PRPC_MESSAGE _pRpcMessage,
01483     DWORD *_pdwStubPhase);
01484
01485
01486 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_LinkActivation_Proxy(
01487     ICaoSQLItem __RPC_FAR * This,
01488     /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pbVal);
01489
01490
01491 void __RPC_STUB ICaoSQLItem_get_LinkActivation_Stub(
01492     IRpcStubBuffer *This,
01493     IRpcChannelBuffer *_pRpcChannelBuffer,
01494     PRPC_MESSAGE _pRpcMessage,
01495     DWORD *_pdwStubPhase);
01496
01497
01498 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_put_LinkActivation_Proxy(
01499     ICaoSQLItem __RPC_FAR * This,
01500     /* [in] */ VARIANT_BOOL bNewVal);
01501
01502
01503 void __RPC_STUB ICaoSQLItem_put_LinkActivation_Stub(
01504     IRpcStubBuffer *This,
01505     IRpcChannelBuffer *_pRpcChannelBuffer,
01506     PRPC_MESSAGE _pRpcMessage,
01507     DWORD *_pdwStubPhase);
01508
01509
01510 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Microsecond_Proxy(
01511     ICaoSQLItem __RPC_FAR * This,
01512     /* [retval][out] */ long __RPC_FAR *plVal);
01513
01514
01515 void __RPC_STUB ICaoSQLItem_get_Microsecond_Stub(
01516     IRpcStubBuffer *This,
01517     IRpcChannelBuffer *_pRpcChannelBuffer,
01518     PRPC_MESSAGE _pRpcMessage,
01519     DWORD *_pdwStubPhase);
01520
01521
01522 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_State_Proxy(
01523     ICaoSQLItem __RPC_FAR * This,
01524     /* [retval][out] */ long __RPC_FAR *plVal);
01525
01526
01527 void __RPC_STUB ICaoSQLItem_get_State_Stub(
01528     IRpcStubBuffer *This,
01529     IRpcChannelBuffer *_pRpcChannelBuffer,
01530     PRPC_MESSAGE _pRpcMessage,
01531     DWORD *_pdwStubPhase);
01532
01533
01534 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Tag_Proxy(
01535     ICaoSQLItem __RPC_FAR * This,
01536     /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
01537
01538
01539 void __RPC_STUB ICaoSQLItem_get_Tag_Stub(
01540     IRpcStubBuffer *This,
01541     IRpcChannelBuffer *_pRpcChannelBuffer,
01542     PRPC_MESSAGE _pRpcMessage,
01543     DWORD *_pdwStubPhase);
01544
01545
01546 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_put_Tag_Proxy(
01547     ICaoSQLItem __RPC_FAR * This,
01548     /* [in] */ VARIANT vntNewVal);
01549
01550
01551 void __RPC_STUB ICaoSQLItem_put_Tag_Stub(
01552     IRpcStubBuffer *This,
01553     IRpcChannelBuffer *_pRpcChannelBuffer,
01554     PRPC_MESSAGE _pRpcMessage,
01555     DWORD *_pdwStubPhase);
01556
01557
01558 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_put_ValueEx_Proxy(
01559     ICaoSQLItem __RPC_FAR * This,
01560     /* [defaultvalue][in] */ long lDelay,
01561     VARIANT vntNewVal);
01562
01563
01564 void __RPC_STUB ICaoSQLItem_put_ValueEx_Stub(
01565     IRpcStubBuffer *This,
01566     IRpcChannelBuffer *_pRpcChannelBuffer,
01567     PRPC_MESSAGE _pRpcMessage,
01568     DWORD *_pdwStubPhase);
01569
01570
01571 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Attribute_Proxy(
01572     ICaoSQLItem __RPC_FAR * This,
01573     /* [retval][out] */ long __RPC_FAR *plVal);
01574
01575
01576 void __RPC_STUB ICaoSQLItem_get_Attribute_Stub(
01577     IRpcStubBuffer *This,
01578     IRpcChannelBuffer *_pRpcChannelBuffer,
01579     PRPC_MESSAGE _pRpcMessage,
01580     DWORD *_pdwStubPhase);
01581
01582
01583 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Description_Proxy(
01584     ICaoSQLItem __RPC_FAR * This,
01585     /* [retval][out] */ BSTR __RPC_FAR *pbstrVal);
01586
01587
01588 void __RPC_STUB ICaoSQLItem_get_Description_Stub(
01589     IRpcStubBuffer *This,
01590     IRpcChannelBuffer *_pRpcChannelBuffer,
01591     PRPC_MESSAGE _pRpcMessage,
01592     DWORD *_pdwStubPhase);
01593
01594
01595 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Element_Proxy(
01596     ICaoSQLItem __RPC_FAR * This,
01597     /* [in] */ long lIndex1,
01598     /* [defaultvalue][in] */ long lIndex2,
01599     /* [defaultvalue][in] */ long lIndex3,
01600     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01601
01602
01603 void __RPC_STUB ICaoSQLItem_get_Element_Stub(
01604     IRpcStubBuffer *This,
01605     IRpcChannelBuffer *_pRpcChannelBuffer,
01606     PRPC_MESSAGE _pRpcMessage,
01607     DWORD *_pdwStubPhase);
01608
01609
01610 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_put_Element_Proxy(
01611     ICaoSQLItem __RPC_FAR * This,
01612     /* [in] */ long lIndex1,
01613     /* [defaultvalue][in] */ long lIndex2,
01614     /* [defaultvalue][in] */ long lIndex3,
01615     /* [in] */ VARIANT newVal);
01616
01617
01618 void __RPC_STUB ICaoSQLItem_put_Element_Stub(
01619     IRpcStubBuffer *This,
01620     IRpcChannelBuffer *_pRpcChannelBuffer,
01621     PRPC_MESSAGE _pRpcMessage,
01622     DWORD *_pdwStubPhase);
01623
01624
01625 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_ID_Proxy(
01626     ICaoSQLItem __RPC_FAR * This,
01627     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01628
01629
01630 void __RPC_STUB ICaoSQLItem_get_ID_Stub(
01631     IRpcStubBuffer *This,
01632     IRpcChannelBuffer *_pRpcChannelBuffer,
01633     PRPC_MESSAGE _pRpcMessage,
01634     DWORD *_pdwStubPhase);
01635
01636
01637 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_put_ID_Proxy(
01638     ICaoSQLItem __RPC_FAR * This,
01639     /* [in] */ VARIANT newVal);
01640
01641
01642 void __RPC_STUB ICaoSQLItem_put_ID_Stub(
01643     IRpcStubBuffer *This,
01644     IRpcChannelBuffer *_pRpcChannelBuffer,
01645     PRPC_MESSAGE _pRpcMessage,
01646     DWORD *_pdwStubPhase);
01647
01648
01649 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_LinkItemNames_Proxy(
01650     ICaoSQLItem __RPC_FAR * This,
01651     /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
01652
01653
01654 void __RPC_STUB ICaoSQLItem_get_LinkItemNames_Stub(
01655     IRpcStubBuffer *This,
01656     IRpcChannelBuffer *_pRpcChannelBuffer,
01657     PRPC_MESSAGE _pRpcMessage,
01658     DWORD *_pdwStubPhase);
01659
01660
01661 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_Name_Proxy(
01662     ICaoSQLItem __RPC_FAR * This,
01663     /* [retval][out] */ BSTR __RPC_FAR *pbstrVal);
01664
01665
01666 void __RPC_STUB ICaoSQLItem_get_Name_Stub(
01667     IRpcStubBuffer *This,
01668     IRpcChannelBuffer *_pRpcChannelBuffer,
01669     PRPC_MESSAGE _pRpcMessage,
01670     DWORD *_pdwStubPhase);
01671
01672
01673 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_get_SettingData_Proxy(
01674     ICaoSQLItem __RPC_FAR * This,
01675     /* [in] */ VARIANT vntName,
01676     /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
01677
01678
01679 void __RPC_STUB ICaoSQLItem_get_SettingData_Stub(
01680     IRpcStubBuffer *This,
01681     IRpcChannelBuffer *_pRpcChannelBuffer,
01682     PRPC_MESSAGE _pRpcMessage,
01683     DWORD *_pdwStubPhase);
01684
01685
01686 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoSQLItem_put_SettingData_Proxy(
01687     ICaoSQLItem __RPC_FAR * This,
01688     /* [in] */ VARIANT vntName,
01689     /* [in] */ VARIANT vntNewVal);
01690
01691
01692 void __RPC_STUB ICaoSQLItem_put_SettingData_Stub(
01693     IRpcStubBuffer *This,
01694     IRpcChannelBuffer *_pRpcChannelBuffer,
01695     PRPC_MESSAGE _pRpcMessage,
01696     DWORD *_pdwStubPhase);
01697
01698
01699
01700 #endif  /* __ICaoSQLItem_INTERFACE_DEFINED__ */
01701
01702
01703 #ifndef __ICaoSQLHistory_INTERFACE_DEFINED__
01704 #define __ICaoSQLHistory_INTERFACE_DEFINED__
01705
01706 /* interface ICaoSQLHistory */
01707 /* [unique][helpstring][dual][uuid][object] */
01708
01709
01710 EXTERN_C const IID IID_ICaoSQLHistory;
01711
01712 #if defined(__cplusplus) && !defined(CINTERFACE)
01713
01714     MIDL_INTERFACE("48697BDE-1C16-4629-B5E3-D8B8C4000FBF")
01715     ICaoSQLHistory : public IDispatch
01716     {
01717     public:
01718         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Execute(
01719             /* [in] */ BSTR bstrCmdText,
01720             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal) = 0;
01721
01722         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ConnectionString(
01723             /* [in] */ long lIndex,
01724             /* [retval][out] */ BSTR __RPC_FAR *pbstrVal) = 0;
01725
01726         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Enable(
01727             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pbVal) = 0;
01728
01729         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_MaxRecord(
01730             /* [in] */ long lIndex,
01731             /* [retval][out] */ long __RPC_FAR *plVal) = 0;
01732
01733         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_TableName(
01734             /* [in] */ long lIndex,
01735             /* [retval][out] */ BSTR __RPC_FAR *pbstrVal) = 0;
01736
01737     };
01738
01739 #else   /* C style interface */
01740
01741     typedef struct ICaoSQLHistoryVtbl
01742     {
01743         BEGIN_INTERFACE
01744
01745         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
01746             ICaoSQLHistory __RPC_FAR * This,
01747             /* [in] */ REFIID riid,
01748             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
01749
01750         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
01751             ICaoSQLHistory __RPC_FAR * This);
01752
01753         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
01754             ICaoSQLHistory __RPC_FAR * This);
01755
01756         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
01757             ICaoSQLHistory __RPC_FAR * This,
01758             /* [out] */ UINT __RPC_FAR *pctinfo);
01759
01760         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
01761             ICaoSQLHistory __RPC_FAR * This,
01762             /* [in] */ UINT iTInfo,
01763             /* [in] */ LCID lcid,
01764             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
01765
01766         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
01767             ICaoSQLHistory __RPC_FAR * This,
01768             /* [in] */ REFIID riid,
01769             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
01770             /* [in] */ UINT cNames,
01771             /* [in] */ LCID lcid,
01772             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
01773
01774         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
01775             ICaoSQLHistory __RPC_FAR * This,
01776             /* [in] */ DISPID dispIdMember,
01777             /* [in] */ REFIID riid,
01778             /* [in] */ LCID lcid,
01779             /* [in] */ WORD wFlags,
01780             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
01781             /* [out] */ VARIANT __RPC_FAR *pVarResult,
01782             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
01783             /* [out] */ UINT __RPC_FAR *puArgErr);
01784
01785         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Execute )(
01786             ICaoSQLHistory __RPC_FAR * This,
01787             /* [in] */ BSTR bstrCmdText,
01788             /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
01789
01790         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ConnectionString )(
01791             ICaoSQLHistory __RPC_FAR * This,
01792             /* [in] */ long lIndex,
01793             /* [retval][out] */ BSTR __RPC_FAR *pbstrVal);
01794
01795         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Enable )(
01796             ICaoSQLHistory __RPC_FAR * This,
01797             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pbVal);
01798
01799         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_MaxRecord )(
01800             ICaoSQLHistory __RPC_FAR * This,
01801             /* [in] */ long lIndex,
01802             /* [retval][out] */ long __RPC_FAR *plVal);
01803
01804         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_TableName )(
01805             ICaoSQLHistory __RPC_FAR * This,
01806             /* [in] */ long lIndex,
01807             /* [retval][out] */ BSTR __RPC_FAR *pbstrVal);
01808
01809         END_INTERFACE
01810     } ICaoSQLHistoryVtbl;
01811
01812     interface ICaoSQLHistory
01813     {
01814         CONST_VTBL struct ICaoSQLHistoryVtbl __RPC_FAR *lpVtbl;
01815     };
01816
01817
01818
01819 #ifdef COBJMACROS
01820
01821
01822 #define ICaoSQLHistory_QueryInterface(This,riid,ppvObject)  \
01823     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
01824
01825 #define ICaoSQLHistory_AddRef(This) \
01826     (This)->lpVtbl -> AddRef(This)
01827
01828 #define ICaoSQLHistory_Release(This)    \
01829     (This)->lpVtbl -> Release(This)
01830
01831
01832 #define ICaoSQLHistory_GetTypeInfoCount(This,pctinfo)   \
01833     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
01834
01835 #define ICaoSQLHistory_GetTypeInfo(This,iTInfo,lcid,ppTInfo)    \
01836     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
01837
01838 #define ICaoSQLHistory_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)  \
01839     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
01840
01841 #define ICaoSQLHistory_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)    \
01842     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
01843
01844
01845 #define ICaoSQLHistory_Execute(This,bstrCmdText,pvntVal)    \
01846     (This)->lpVtbl -> Execute(This,bstrCmdText,pvntVal)
01847
01848 #define ICaoSQLHistory_get_ConnectionString(This,lIndex,pbstrVal)   \
01849     (This)->lpVtbl -> get_ConnectionString(This,lIndex,pbstrVal)
01850
01851 #define ICaoSQLHistory_get_Enable(This,pbVal)   \
01852     (This)->lpVtbl -> get_Enable(This,pbVal)
01853
01854 #define ICaoSQLHistory_get_MaxRecord(This,lIndex,plVal) \
01855     (This)->lpVtbl -> get_MaxRecord(This,lIndex,plVal)
01856
01857 #define ICaoSQLHistory_get_TableName(This,lIndex,pbstrVal)  \
01858     (This)->lpVtbl -> get_TableName(This,lIndex,pbstrVal)
01859
01860 #endif /* COBJMACROS */
01861
01862
01863 #endif  /* C style interface */
01864
01865
01866
01867 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoSQLHistory_Execute_Proxy(
01868     ICaoSQLHistory __RPC_FAR * This,
01869     /* [in] */ BSTR bstrCmdText,
01870     /* [retval][out] */ VARIANT __RPC_FAR *pvntVal);
01871
01872
01873 void __RPC_STUB ICaoSQLHistory_Execute_Stub(
01874     IRpcStubBuffer *This,
01875     IRpcChannelBuffer *_pRpcChannelBuffer,
01876     PRPC_MESSAGE _pRpcMessage,
01877     DWORD *_pdwStubPhase);
01878
01879
01880 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLHistory_get_ConnectionString_Proxy(
01881     ICaoSQLHistory __RPC_FAR * This,
01882     /* [in] */ long lIndex,
01883     /* [retval][out] */ BSTR __RPC_FAR *pbstrVal);
01884
01885
01886 void __RPC_STUB ICaoSQLHistory_get_ConnectionString_Stub(
01887     IRpcStubBuffer *This,
01888     IRpcChannelBuffer *_pRpcChannelBuffer,
01889     PRPC_MESSAGE _pRpcMessage,
01890     DWORD *_pdwStubPhase);
01891
01892
01893 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLHistory_get_Enable_Proxy(
01894     ICaoSQLHistory __RPC_FAR * This,
01895     /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pbVal);
01896
01897
01898 void __RPC_STUB ICaoSQLHistory_get_Enable_Stub(
01899     IRpcStubBuffer *This,
01900     IRpcChannelBuffer *_pRpcChannelBuffer,
01901     PRPC_MESSAGE _pRpcMessage,
01902     DWORD *_pdwStubPhase);
01903
01904
01905 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLHistory_get_MaxRecord_Proxy(
01906     ICaoSQLHistory __RPC_FAR * This,
01907     /* [in] */ long lIndex,
01908     /* [retval][out] */ long __RPC_FAR *plVal);
01909
01910
01911 void __RPC_STUB ICaoSQLHistory_get_MaxRecord_Stub(
01912     IRpcStubBuffer *This,
01913     IRpcChannelBuffer *_pRpcChannelBuffer,
01914     PRPC_MESSAGE _pRpcMessage,
01915     DWORD *_pdwStubPhase);
01916
01917
01918 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoSQLHistory_get_TableName_Proxy(
01919     ICaoSQLHistory __RPC_FAR * This,
01920     /* [in] */ long lIndex,
01921     /* [retval][out] */ BSTR __RPC_FAR *pbstrVal);
01922
01923
01924 void __RPC_STUB ICaoSQLHistory_get_TableName_Stub(
01925     IRpcStubBuffer *This,
01926     IRpcChannelBuffer *_pRpcChannelBuffer,
01927     PRPC_MESSAGE _pRpcMessage,
01928     DWORD *_pdwStubPhase);
01929
01930
01931
01932 #endif  /* __ICaoSQLHistory_INTERFACE_DEFINED__ */
01933
01934
01935 #ifndef __IRACEventSink_INTERFACE_DEFINED__
01936 #define __IRACEventSink_INTERFACE_DEFINED__
01937
01938 /* interface IRACEventSink */
01939 /* [unique][helpstring][dual][uuid][object] */
01940
01941
01942 EXTERN_C const IID IID_IRACEventSink;
01943
01944 #if defined(__cplusplus) && !defined(CINTERFACE)
01945
01946     MIDL_INTERFACE("1AA6DA40-2799-43b3-890D-99E21D898B97")
01947     IRACEventSink : public IDispatch
01948     {
01949     public:
01950         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE OnMessage(
01951             /* [in] */ IUnknown __RPC_FAR *pIVal) = 0;
01952
01953     };
01954
01955 #else   /* C style interface */
01956
01957     typedef struct IRACEventSinkVtbl
01958     {
01959         BEGIN_INTERFACE
01960
01961         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
01962             IRACEventSink __RPC_FAR * This,
01963             /* [in] */ REFIID riid,
01964             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
01965
01966         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
01967             IRACEventSink __RPC_FAR * This);
01968
01969         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
01970             IRACEventSink __RPC_FAR * This);
01971
01972         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
01973             IRACEventSink __RPC_FAR * This,
01974             /* [out] */ UINT __RPC_FAR *pctinfo);
01975
01976         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
01977             IRACEventSink __RPC_FAR * This,
01978             /* [in] */ UINT iTInfo,
01979             /* [in] */ LCID lcid,
01980             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
01981
01982         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
01983             IRACEventSink __RPC_FAR * This,
01984             /* [in] */ REFIID riid,
01985             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
01986             /* [in] */ UINT cNames,
01987             /* [in] */ LCID lcid,
01988             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
01989
01990         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
01991             IRACEventSink __RPC_FAR * This,
01992             /* [in] */ DISPID dispIdMember,
01993             /* [in] */ REFIID riid,
01994             /* [in] */ LCID lcid,
01995             /* [in] */ WORD wFlags,
01996             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
01997             /* [out] */ VARIANT __RPC_FAR *pVarResult,
01998             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
01999             /* [out] */ UINT __RPC_FAR *puArgErr);
02000
02001         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *OnMessage )(
02002             IRACEventSink __RPC_FAR * This,
02003             /* [in] */ IUnknown __RPC_FAR *pIVal);
02004
02005         END_INTERFACE
02006     } IRACEventSinkVtbl;
02007
02008     interface IRACEventSink
02009     {
02010         CONST_VTBL struct IRACEventSinkVtbl __RPC_FAR *lpVtbl;
02011     };
02012
02013
02014
02015 #ifdef COBJMACROS
02016
02017
02018 #define IRACEventSink_QueryInterface(This,riid,ppvObject)   \
02019     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
02020
02021 #define IRACEventSink_AddRef(This)  \
02022     (This)->lpVtbl -> AddRef(This)
02023
02024 #define IRACEventSink_Release(This) \
02025     (This)->lpVtbl -> Release(This)
02026
02027
02028 #define IRACEventSink_GetTypeInfoCount(This,pctinfo)    \
02029     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
02030
02031 #define IRACEventSink_GetTypeInfo(This,iTInfo,lcid,ppTInfo) \
02032     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
02033
02034 #define IRACEventSink_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)   \
02035     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
02036
02037 #define IRACEventSink_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr) \
02038     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
02039
02040
02041 #define IRACEventSink_OnMessage(This,pIVal) \
02042     (This)->lpVtbl -> OnMessage(This,pIVal)
02043
02044 #endif /* COBJMACROS */
02045
02046
02047 #endif  /* C style interface */
02048
02049
02050
02051 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE IRACEventSink_OnMessage_Proxy(
02052     IRACEventSink __RPC_FAR * This,
02053     /* [in] */ IUnknown __RPC_FAR *pIVal);
02054
02055
02056 void __RPC_STUB IRACEventSink_OnMessage_Stub(
02057     IRpcStubBuffer *This,
02058     IRpcChannelBuffer *_pRpcChannelBuffer,
02059     PRPC_MESSAGE _pRpcMessage,
02060     DWORD *_pdwStubPhase);
02061
02062
02063
02064 #endif  /* __IRACEventSink_INTERFACE_DEFINED__ */
02065
02066
02067
02068 #ifndef __CaoSQLLib_LIBRARY_DEFINED__
02069 #define __CaoSQLLib_LIBRARY_DEFINED__
02070
02071 /* library CaoSQLLib */
02072 /* [helpstring][version][uuid] */
02073
02074 typedef /* [v1_enum][helpstring][public] */ _enmCaoVariableClass enmCaoVariableClass;
02075
02076 typedef /* [v1_enum][helpstring][public] */ _enmCaoSQLCtrlState enmCaoSQLCtrlState;
02077
02078 typedef /* [v1_enum][helpstring][public] */ _enmCaoSQLCtrlScantime enmCaoSQLCtrlScantime;
02079
02080 typedef /* [v1_enum][helpstring][public] */ _enmCaoSQLItemState enmCaoSQLItemState;
02081
02082 typedef /* [v1_enum][helpstring][public] */ _enmCaoSQLItemAttribute enmCaoSQLItemAttribute;
02083
02084
02085 EXTERN_C const IID LIBID_CaoSQLLib;
02086
02087 EXTERN_C const CLSID CLSID_CaoSQLEngine;
02088
02089 #ifdef __cplusplus
02090
02091 class DECLSPEC_UUID("95615A16-A369-4937-A8F9-B3A909E9C5CE")
02092 CaoSQLEngine;
02093 #endif
02094
02095 #ifndef ___ICaoSQLControllerEvents_DISPINTERFACE_DEFINED__
02096 #define ___ICaoSQLControllerEvents_DISPINTERFACE_DEFINED__
02097
02098 /* dispinterface _ICaoSQLControllerEvents */
02099 /* [helpstring][uuid] */
02100
02101
02102 EXTERN_C const IID DIID__ICaoSQLControllerEvents;
02103
02104 #if defined(__cplusplus) && !defined(CINTERFACE)
02105
02106     MIDL_INTERFACE("B6E12C86-10B8-459e-A29D-E54199885EC6")
02107     _ICaoSQLControllerEvents : public IDispatch
02108     {
02109     };
02110
02111 #else   /* C style interface */
02112
02113     typedef struct _ICaoSQLControllerEventsVtbl
02114     {
02115         BEGIN_INTERFACE
02116
02117         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
02118             _ICaoSQLControllerEvents __RPC_FAR * This,
02119             /* [in] */ REFIID riid,
02120             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
02121
02122         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
02123             _ICaoSQLControllerEvents __RPC_FAR * This);
02124
02125         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
02126             _ICaoSQLControllerEvents __RPC_FAR * This);
02127
02128         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
02129             _ICaoSQLControllerEvents __RPC_FAR * This,
02130             /* [out] */ UINT __RPC_FAR *pctinfo);
02131
02132         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
02133             _ICaoSQLControllerEvents __RPC_FAR * This,
02134             /* [in] */ UINT iTInfo,
02135             /* [in] */ LCID lcid,
02136             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
02137
02138         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
02139             _ICaoSQLControllerEvents __RPC_FAR * This,
02140             /* [in] */ REFIID riid,
02141             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
02142             /* [in] */ UINT cNames,
02143             /* [in] */ LCID lcid,
02144             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
02145
02146         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
02147             _ICaoSQLControllerEvents __RPC_FAR * This,
02148             /* [in] */ DISPID dispIdMember,
02149             /* [in] */ REFIID riid,
02150             /* [in] */ LCID lcid,
02151             /* [in] */ WORD wFlags,
02152             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
02153             /* [out] */ VARIANT __RPC_FAR *pVarResult,
02154             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
02155             /* [out] */ UINT __RPC_FAR *puArgErr);
02156
02157         END_INTERFACE
02158     } _ICaoSQLControllerEventsVtbl;
02159
02160     interface _ICaoSQLControllerEvents
02161     {
02162         CONST_VTBL struct _ICaoSQLControllerEventsVtbl __RPC_FAR *lpVtbl;
02163     };
02164
02165
02166
02167 #ifdef COBJMACROS
02168
02169
02170 #define _ICaoSQLControllerEvents_QueryInterface(This,riid,ppvObject)    \
02171     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
02172
02173 #define _ICaoSQLControllerEvents_AddRef(This)   \
02174     (This)->lpVtbl -> AddRef(This)
02175
02176 #define _ICaoSQLControllerEvents_Release(This)  \
02177     (This)->lpVtbl -> Release(This)
02178
02179
02180 #define _ICaoSQLControllerEvents_GetTypeInfoCount(This,pctinfo) \
02181     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
02182
02183 #define _ICaoSQLControllerEvents_GetTypeInfo(This,iTInfo,lcid,ppTInfo)  \
02184     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
02185
02186 #define _ICaoSQLControllerEvents_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)    \
02187     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
02188
02189 #define _ICaoSQLControllerEvents_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)  \
02190     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
02191
02192 #endif /* COBJMACROS */
02193
02194
02195 #endif  /* C style interface */
02196
02197
02198 #endif  /* ___ICaoSQLControllerEvents_DISPINTERFACE_DEFINED__ */
02199
02200
02201 #ifndef __IRACSever_INTERFACE_DEFINED__
02202 #define __IRACSever_INTERFACE_DEFINED__
02203
02204 /* interface IRACSever */
02205 /* [unique][helpstring][dual][uuid][object] */
02206
02207
02208 EXTERN_C const IID IID_IRACSever;
02209
02210 #if defined(__cplusplus) && !defined(CINTERFACE)
02211
02212     MIDL_INTERFACE("3253EA5F-90F2-4DB1-B449-4767F8EDF82F")
02213     IRACSever : public IDispatch
02214     {
02215     public:
02216     };
02217
02218 #else   /* C style interface */
02219
02220     typedef struct IRACSeverVtbl
02221     {
02222         BEGIN_INTERFACE
02223
02224         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
02225             IRACSever __RPC_FAR * This,
02226             /* [in] */ REFIID riid,
02227             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
02228
02229         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
02230             IRACSever __RPC_FAR * This);
02231
02232         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
02233             IRACSever __RPC_FAR * This);
02234
02235         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
02236             IRACSever __RPC_FAR * This,
02237             /* [out] */ UINT __RPC_FAR *pctinfo);
02238
02239         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
02240             IRACSever __RPC_FAR * This,
02241             /* [in] */ UINT iTInfo,
02242             /* [in] */ LCID lcid,
02243             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
02244
02245         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
02246             IRACSever __RPC_FAR * This,
02247             /* [in] */ REFIID riid,
02248             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
02249             /* [in] */ UINT cNames,
02250             /* [in] */ LCID lcid,
02251             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
02252
02253         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
02254             IRACSever __RPC_FAR * This,
02255             /* [in] */ DISPID dispIdMember,
02256             /* [in] */ REFIID riid,
02257             /* [in] */ LCID lcid,
02258             /* [in] */ WORD wFlags,
02259             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
02260             /* [out] */ VARIANT __RPC_FAR *pVarResult,
02261             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
02262             /* [out] */ UINT __RPC_FAR *puArgErr);
02263
02264         END_INTERFACE
02265     } IRACSeverVtbl;
02266
02267     interface IRACSever
02268     {
02269         CONST_VTBL struct IRACSeverVtbl __RPC_FAR *lpVtbl;
02270     };
02271
02272
02273
02274 #ifdef COBJMACROS
02275
02276
02277 #define IRACSever_QueryInterface(This,riid,ppvObject)   \
02278     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
02279
02280 #define IRACSever_AddRef(This)  \
02281     (This)->lpVtbl -> AddRef(This)
02282
02283 #define IRACSever_Release(This) \
02284     (This)->lpVtbl -> Release(This)
02285
02286
02287 #define IRACSever_GetTypeInfoCount(This,pctinfo)    \
02288     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
02289
02290 #define IRACSever_GetTypeInfo(This,iTInfo,lcid,ppTInfo) \
02291     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
02292
02293 #define IRACSever_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)   \
02294     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
02295
02296 #define IRACSever_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr) \
02297     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
02298
02299
02300 #endif /* COBJMACROS */
02301
02302
02303 #endif  /* C style interface */
02304
02305
02306
02307
02308 #endif  /* __IRACSever_INTERFACE_DEFINED__ */
02309
02310
02311 EXTERN_C const CLSID CLSID_CaoSQLController;
02312
02313 #ifdef __cplusplus
02314
02315 class DECLSPEC_UUID("54A724F0-70FF-4e2d-BC81-ADEE8AD34682")
02316 CaoSQLController;
02317 #endif
02318
02319 EXTERN_C const CLSID CLSID_CaoSQLItem;
02320
02321 #ifdef __cplusplus
02322
02323 class DECLSPEC_UUID("B5A90BCB-508F-462e-B714-BAEB106A5100")
02324 CaoSQLItem;
02325 #endif
02326
02327 EXTERN_C const CLSID CLSID_CaoSQLHistory;
02328
02329 #ifdef __cplusplus
02330
02331 class DECLSPEC_UUID("495F2699-4037-4fd7-A444-F66A77DB6610")
02332 CaoSQLHistory;
02333 #endif
02334
02335 EXTERN_C const CLSID CLSID_RACEventSink;
02336
02337 #ifdef __cplusplus
02338
02339 class DECLSPEC_UUID("BC7F2ADB-E49A-4f9e-9B57-822AF4CA3D32")
02340 RACEventSink;
02341 #endif
02342 #endif /* __CaoSQLLib_LIBRARY_DEFINED__ */
02343
02344 /* Additional Prototypes for ALL interfaces */
02345
02346 unsigned long             __RPC_USER  BSTR_UserSize(     unsigned long __RPC_FAR *, unsigned long            , BSTR __RPC_FAR * );
02347 unsigned char __RPC_FAR * __RPC_USER  BSTR_UserMarshal(  unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR * );
02348 unsigned char __RPC_FAR * __RPC_USER  BSTR_UserUnmarshal(unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR * );
02349 void                      __RPC_USER  BSTR_UserFree(     unsigned long __RPC_FAR *, BSTR __RPC_FAR * );
02350
02351 unsigned long             __RPC_USER  VARIANT_UserSize(     unsigned long __RPC_FAR *, unsigned long            , VARIANT __RPC_FAR * );
02352 unsigned char __RPC_FAR * __RPC_USER  VARIANT_UserMarshal(  unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, VARIANT __RPC_FAR * );
02353 unsigned char __RPC_FAR * __RPC_USER  VARIANT_UserUnmarshal(unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, VARIANT __RPC_FAR * );
02354 void                      __RPC_USER  VARIANT_UserFree(     unsigned long __RPC_FAR *, VARIANT __RPC_FAR * );
02355
02356 /* end of Additional Prototypes */
02357
02358 #ifdef __cplusplus
02359 }
02360 #endif
02361
02362 #endif
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQL.idl Source File

CaoSQL.idl

解説を見る。
00001
00015 import "oaidl.idl";
00016 import "ocidl.idl";
00017
00018 /* ---------------------------------- */
00019 /*    CaoSQL Interface Definitions    */
00020 /* ---------------------------------- */
00021
00022 interface ICaoSQLEngine;
00023 interface ICaoSQLController;
00024 interface ICaoSQLItem;
00025 interface ICaoSQLHistory;
00026
00027
00029 typedef enum enmCaoVariableClass
00030 {
00032     [helpstring("CaoController Class Variable")] csVarClassController   = 0,
00034     [helpstring("CaoTask Class Variable")] csVarClassTask               = 1,
00036     [helpstring("CaoRobot Class Variable")] csVarClassRobot             = 2,
00038     [helpstring("CaoExtension Class Variable")] csVarClassExtension     = 3
00039
00040 } _enmCaoVariableClass;
00041
00043 typedef enum enmCaoSQLCtrlState
00044 {
00046     [helpstring("Controller Thread Uninitialized")] csCtrlThreadUninit  = 0x0000,
00048     [helpstring("Controller Thread Active")] csCtrlThreadActive         = 0x0001,
00050     [helpstring("Controller Thread Deactive")] csCtrlThreadDeactive     = 0x0002,
00052     [helpstring("Controller Thread Error")] csCtrlThreadError           = 0x0003,
00054     [helpstring("Controller Thread Terminated")] csCtrlThreadTerminated = 0x0004
00055
00056 } _enmCaoSQLCtrlState;
00057
00059 typedef enum enmCaoSQLCtrlScantime
00060 {
00062     [helpstring("Controller Last Scantime")] csCtrlScantimeLast             = 0x0000,
00064     [helpstring("Controller Min Scantime")] csCtrlScantimeMin               = 0x0001,
00066     [helpstring("Controller Max Scantime")] csCtrlScantimeMax               = 0x0002
00067
00068 } _enmCaoSQLCtrlScantime;
00069
00072 typedef enum enmCaoSQLItemState
00073 {
00075     [helpstring("Item Action Succeeded")] csItemSucceeded                   = 0x0000,
00077     [helpstring("Item Action Failed")] csItemFailed                         = 0x0001,
00079     [helpstring("Item Action Undefined")] csItemUndefined                   = 0x0002
00080
00081 } _enmCaoSQLItemState;
00082
00085 typedef enum enmCaoSQLItemAttribute
00086 {
00088     [helpstring("Item Attribute Read/Write")] csItemReadWrite               = 0x0000,
00090     [helpstring("Item Attribute Read Only")] csItemReadOnly                 = 0x0001,
00092     [helpstring("Item Attribute Write Only")] csItemWriteOnly               = 0x0002
00093
00094 } _enmCaoSQLItemAttribute;
00095
00096
00100 [
00101     object,
00102     uuid(82353932-2585-4f53-9412-5858D1B9DFE0),
00103     dual,
00104     helpstring("ICaoSQLEngine Interface"),
00105     pointer_default(unique)
00106 ]
00107 interface ICaoSQLEngine : IDispatch
00108 {
00109         [propget, id(-4), helpstring("Property _NewEnum"), restricted] HRESULT _NewEnum([out, retval] LPUNKNOWN *pVal);
00110         [propget, id(0), helpstring("Property Controller")] HRESULT Controller([in] VARIANT vntIndex, [out, retval] ICaoSQLController** ppICSCtrl);
00111
00112         [id(1), helpstring("Method Start")] HRESULT Start();
00113         [id(2), helpstring("Method Stop")] HRESULT Stop();
00114         [id(3), helpstring("Method Snapshot")] HRESULT Snapshot();
00115         [id(4), helpstring("Method Execute")] HRESULT Execute([in] BSTR bstrCmdText, [out, retval] VARIANT* pvntVal);
00116
00117         [propget, id(5), helpstring("Property CaoSQLHistory")] HRESULT CaoSQLHistory([out, retval] ICaoSQLHistory** ppICSHstry);
00118         [propget, id(6), helpstring("Property ControllerNames")] HRESULT ControllerNames([out, retval] VARIANT *pvntVal);
00119         [propget, id(7), helpstring("Property Count")] HRESULT Count([out, retval] long *plVal);
00120 };
00121
00122
00126 [
00127     object,
00128     uuid(1C61BAA2-7E70-44e9-8160-EB349ED2C0D8),
00129     dual,
00130     helpstring("ICaoSQLController Interface"),
00131     pointer_default(unique)
00132 ]
00133 interface ICaoSQLController : IDispatch
00134 {
00135         [propget, id(-4), helpstring("Property _NewEnum"), restricted] HRESULT _NewEnum([out, retval] LPUNKNOWN *pVal);
00136         [propget, id(0), helpstring("Property Item")] HRESULT Item([in] VARIANT vntIndex, [out, retval] ICaoSQLItem** ppICSItem);
00137
00138         [id(1), helpstring("Method Start")] HRESULT Start();
00139         [id(2), helpstring("Method Stop")] HRESULT Stop();
00140         [id(3), helpstring("Method Snapshot")] HRESULT Snapshot();
00141         [id(4), helpstring("Method AddItem")] HRESULT AddItem([in] VARIANT vntDataArray);
00142         [id(5), helpstring("Method RemoveItem")] HRESULT RemoveItem([in] VARIANT vntIndex);
00143         [id(6), helpstring("Method Execute")] HRESULT Execute([in] BSTR bstrCommand, [in, optional] VARIANT vntParam, [out, retval] VARIANT* pvntVal);
00144
00145         [propget, id(7), helpstring("Property Count")] HRESULT Count([out, retval] long *plVal);
00146         [propget, id(8), helpstring("Property Index")] HRESULT Index([out, retval] long *plVal);
00147         [propget, id(9), helpstring("Property ItemNames")] HRESULT ItemNames([out, retval] VARIANT *pvntVal);
00148         [propget, id(10), helpstring("Property ScanTimes")] HRESULT ScanTimes([in] long lIndex, [out, retval] long *plVal);
00149         [propget, id(11), helpstring("Property State")] HRESULT State([out, retval] long *plVal);
00150         [propget, id(12), helpstring("Property Tag")] HRESULT Tag([out, retval] VARIANT *pvntVal);
00151         [propput, id(12), helpstring("Property Tag")] HRESULT Tag([in] VARIANT vntNewVal);
00152
00153         // setting data
00154         [propget, id(13), helpstring("Property Description")] HRESULT Description([out, retval] BSTR *pbstrVal);
00155         [propget, id(14), helpstring("Property Name")] HRESULT Name([out, retval] BSTR *pbstrVal);
00156         [propget, id(15), helpstring("Property SettingData")] HRESULT SettingData([in] VARIANT vntName, [out, retval] VARIANT *pvntVal);
00157         [propput, id(15), helpstring("Property SettingData")] HRESULT SettingData([in] VARIANT vntName, [in] VARIANT vntNewVal);
00158
00159 };
00160
00161
00165 [
00166     object,
00167     uuid(A49597A1-5DF3-4c09-9339-3FFF80A6B69F),
00168     dual,
00169     helpstring("ICaoSQLItem Interface"),
00170     pointer_default(unique)
00171 ]
00172 interface ICaoSQLItem : IDispatch
00173 {
00174
00175         [propget, id(0), helpstring("Property Value")] HRESULT Value([out, retval] VARIANT *pvntVal);
00176         [propput, id(0), helpstring("Property Value")] HRESULT Value([in] VARIANT vntNewVal);
00177
00178         [id(1), helpstring("Method Snapshot")] HRESULT Snapshot();
00179
00180         [propget, id(2), helpstring("Property Activation")] HRESULT Activation([out, retval] VARIANT_BOOL *pbVal);
00181         [propput, id(2), helpstring("Property Activation")] HRESULT Activation([in] VARIANT_BOOL bNewVal);
00182         [propget, id(3), helpstring("Property DateTime")] HRESULT DateTime([out, retval] VARIANT *pvntVal);
00183         [propget, id(4), helpstring("Property Index")] HRESULT Index([out, retval] long *plVal);
00184         [propget, id(5), helpstring("Property LinkActivation")] HRESULT LinkActivation([out, retval] VARIANT_BOOL *pbVal);
00185         [propput, id(5), helpstring("Property LinkActivation")] HRESULT LinkActivation([in] VARIANT_BOOL bNewVal);
00186         [propget, id(6), helpstring("Property Microsecond")] HRESULT Microsecond([out, retval] long *plVal);
00187         [propget, id(7), helpstring("Property State")] HRESULT State([out, retval] long *plVal);
00188         [propget, id(8), helpstring("Property Tag")] HRESULT Tag([out, retval] VARIANT *pvntVal);
00189         [propput, id(8), helpstring("Property Tag")] HRESULT Tag([in] VARIANT vntNewVal);
00190         [propput, id(9), helpstring("Property ValueEx")] HRESULT ValueEx([in, defaultvalue(0)] long lDelay, VARIANT vntNewVal);
00191
00192         // setting data
00193         [propget, id(10), helpstring("Property Attribute")] HRESULT Attribute([out, retval] long *plVal);
00194         [propget, id(11), helpstring("Property Description")] HRESULT Description([out, retval] BSTR *pbstrVal);
00195         [propget, id(12), helpstring("Property Element")] HRESULT Element([in] long lIndex1, [in, defaultvalue(0)] long lIndex2, [in, defaultvalue(0)] long lIndex3, [out, retval] VARIANT *pVal);
00196         [propput, id(12), helpstring("Property Element")] HRESULT Element([in] long lIndex1, [in, defaultvalue(0)] long lIndex2, [in, defaultvalue(0)] long lIndex3,  [in] VARIANT newVal);
00197         [propget, id(13), helpstring("Property ID")] HRESULT ID([out, retval] VARIANT *pVal);
00198         [propput, id(13), helpstring("Property ID")] HRESULT ID([in] VARIANT newVal);
00199         [propget, id(14), helpstring("Property LinkItemNames")] HRESULT LinkItemNames([out, retval] VARIANT *pvntVal);
00200         [propget, id(15), helpstring("Property Name")] HRESULT Name([out, retval] BSTR *pbstrVal);
00201         [propget, id(16), helpstring("Property SettingData")] HRESULT SettingData([in] VARIANT vntName, [out, retval] VARIANT *pvntVal);
00202         [propput, id(16), helpstring("Property SettingData")] HRESULT SettingData([in] VARIANT vntName, [in] VARIANT vntNewVal);
00203
00204 };
00205
00206
00210 [
00211     object,
00212     uuid(48697BDE-1C16-4629-B5E3-D8B8C4000FBF),
00213     dual,
00214     helpstring("ICaoSQLHistory Interface"),
00215     pointer_default(unique)
00216 ]
00217 interface ICaoSQLHistory : IDispatch
00218 {
00219         [id(1), helpstring("Method Execute")] HRESULT Execute([in] BSTR bstrCmdText, [out, retval] VARIANT* pvntVal);
00220
00221         [propget, id(2), helpstring("Property ConnectionString")] HRESULT ConnectionString([in] long lIndex, [out, retval] BSTR *pbstrVal);
00222         [propget, id(3), helpstring("Property Enable")] HRESULT Enable([out, retval] VARIANT_BOOL *pbVal);
00223         [propget, id(4), helpstring("Property MaxRecord")] HRESULT MaxRecord([in] long lIndex, [out, retval] long *plVal);
00224         [propget, id(5), helpstring("Property TableName")] HRESULT TableName([in] long lIndex, [out, retval] BSTR *pbstrVal);
00225 };
00226
00227 // IRACEventSink Interface
00228 [
00229     object,
00230     uuid(1AA6DA40-2799-43b3-890D-99E21D898B97),
00231     dual,
00232     helpstring("IRACEventSink Interface"),
00233     pointer_default(unique)
00234 ]
00235 interface IRACEventSink : IDispatch
00236 {
00237     [id(1), helpstring("Method OnMessage")] HRESULT OnMessage([in] IUnknown *pIVal);
00238
00239 };
00240
00244 [
00245     uuid(FCBF9FC1-2FD5-4668-BA36-858D9B7D8082),
00246     version(1.0),
00247     helpstring("CaoSQL 1.0 ﾀｲﾌﾟ ﾗｲﾌﾞﾗﾘ")
00248 ]
00249 library CaoSQLLib
00250 {
00251     importlib("stdole32.tlb");
00252     importlib("stdole2.tlb");
00253
00254     typedef
00255     [
00256         public,
00257         helpstring("CaoSQL VariableClass Enumration"),
00258         v1_enum
00259     ] _enmCaoVariableClass enmCaoVariableClass;
00260     typedef
00261     [
00262         public,
00263         helpstring("CaoSQL Controller Status Enumration"),
00264         v1_enum
00265     ] _enmCaoSQLCtrlState enmCaoSQLCtrlState;
00266     typedef
00267     [
00268         public,
00269         helpstring("CaoSQL Controller Scantime Enumration"),
00270         v1_enum
00271     ] _enmCaoSQLCtrlScantime enmCaoSQLCtrlScantime;
00272     typedef
00273     [
00274         public,
00275         helpstring("CaoSQL Item Status Enumration"),
00276         v1_enum
00277     ] _enmCaoSQLItemState enmCaoSQLItemState;
00278     typedef
00279     [
00280         public,
00281         helpstring("CaoSQL Item Attribute Enumration"),
00282         v1_enum
00283     ] _enmCaoSQLItemAttribute enmCaoSQLItemAttribute;
00284
00285     // CaoSQLEngine Class
00286     [
00287         uuid(95615A16-A369-4937-A8F9-B3A909E9C5CE),
00288         helpstring("CaoSQLEngine Class")
00289     ]
00290     coclass CaoSQLEngine
00291     {
00292         [default] interface ICaoSQLEngine;
00293     };
00294
00295     // CaoSQLControllerEvents dispinterface
00296     [
00297         uuid(B6E12C86-10B8-459e-A29D-E54199885EC6),
00298         helpstring("_ICaoSQLControllerEvents Interface")
00299     ]
00300     dispinterface _ICaoSQLControllerEvents
00301     {
00302         properties:
00303         methods:
00304         [id(1), helpstring("Method OnChangeItem")] HRESULT OnChangeItem([in] ICaoSQLItem* pICSItem);
00305         [id(2), helpstring("Method OnChangeState")] HRESULT OnChangeState([in] long lNewVal);
00306     };
00307
00308     // RACSever Class
00309     [
00310         object,
00311         uuid(3253EA5F-90F2-4DB1-B449-4767F8EDF82F),
00312         dual,
00313         helpstring("IRACSever Interface"),
00314         pointer_default(unique)
00315     ]
00316     interface IRACSever : IDispatch
00317     {
00318     };
00319
00320     // CaoSQLController Class
00321     [
00322         uuid(54A724F0-70FF-4e2d-BC81-ADEE8AD34682),
00323         helpstring("CaoSQLController Class")
00324     ]
00325     coclass CaoSQLController
00326     {
00327         [default] interface ICaoSQLController;
00328         [default, source] dispinterface _ICaoSQLControllerEvents;
00329     };
00330
00331     // ICaoSQLItem Class
00332     [
00333         uuid(B5A90BCB-508F-462e-B714-BAEB106A5100),
00334         helpstring("CaoSQLItem Class")
00335     ]
00336     coclass CaoSQLItem
00337     {
00338         [default] interface ICaoSQLItem;
00339     };
00340
00341     // ICaoSQLHistory Class
00342     [
00343         uuid(495F2699-4037-4fd7-A444-F66A77DB6610),
00344         helpstring("CaoSQLHistory Class")
00345     ]
00346     coclass CaoSQLHistory
00347     {
00348         [default] interface ICaoSQLHistory;
00349     };
00350
00351     // RACEventSink Class
00352     [
00353         uuid(BC7F2ADB-E49A-4f9e-9B57-822AF4CA3D32),
00354         helpstring("RACEventSink Class")
00355     ]
00356     coclass RACEventSink
00357     {
00358         [default] interface IRACEventSink;
00359     };
00360
00361 };
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLAdviser.h Source File

CaoSQLAdviser.h

解説を見る。
00001
00011 #if !defined(AFX_CaoSQLADVISER_H__3C38D8B6_4413_4E45_8C64_E82E3AA4C5FC__INCLUDED_)
00012 #define AFX_CaoSQLADVISER_H__3C38D8B6_4413_4E45_8C64_E82E3AA4C5FC__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00018 class CCaoSQLObserver;
00019 typedef std::vector<CCaoSQLObserver *>  VEC_OBSVS;
00020
00026 class CCaoSQLAdviser
00027 {
00028 public:
00029     CCaoSQLAdviser();
00030     virtual ~CCaoSQLAdviser();
00031     void AddObserver(CCaoSQLObserver* pVal);
00032     void DeleteObserver(CCaoSQLObserver* pVal);
00033     void NotifyObservers(VARIANT vntNewVal);
00034     void ReleaseObservers();
00035
00036 private:
00037     // local Variable
00038     VEC_OBSVS           m_vecObservers;
00039     CRITICAL_SECTION    m_csAdviser;
00040
00041 };
00042
00043 #endif // !defined(AFX_CaoSQLADVISER_H__3C38D8B6_4413_4E45_8C64_E82E3AA4C5FC__INCLUDED_)
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLCalcItem.h Source File

CaoSQLCalcItem.h

解説を見る。
00001 // CaoSQLCalcItem.h: CCaoSQLCalcItem クラスのインターフェイス
00002 //
00004
00005 #if !defined(AFX_CaoSQLCALCITEM_H__E1C734F8_9F5E_4A54_A143_008BC18C49F5__INCLUDED_)
00006 #define AFX_CaoSQLCALCITEM_H__E1C734F8_9F5E_4A54_A143_008BC18C49F5__INCLUDED_
00007
00008 #if _MSC_VER > 1000
00009 #pragma once
00010 #endif // _MSC_VER > 1000
00011
00012 class CCaoSQLCalcItem
00013 {
00014 public:
00015     CCaoSQLCalcItem();
00016     virtual ~CCaoSQLCalcItem();
00017
00018     // (注)本来はCCaoSQLLinkObserverと同じようにpItemから他の情報を取得すべきであるが，IDLの変更が必要になるのでver.2.0で実施予定．
00019     HRESULT Initialize(CCaoSQLItem* pItem, long lCalcIndex, BSTR bstr2ndItem);
00020     HRESULT Calculate(LPVARIANT pvntLeft, LPVARIANT pvntResult);
00021
00022 private:
00023     HRESULT ParseParameter(BSTR bstrParam, WCHAR* pwszDelimiter, VARIANT *pvntVal);
00024     HRESULT (__stdcall *pvntCalc)(LPVARIANT pvntLeft, LPVARIANT  pvntRight, LPVARIANT pvntResult);
00025     static HRESULT __stdcall VarLbsh(LPVARIANT pvntLeft, LPVARIANT pvntRight, LPVARIANT pvntResult);
00026     static HRESULT __stdcall VarRbsh(LPVARIANT pvntLeft, LPVARIANT pvntRight, LPVARIANT pvntResult);
00027     static HRESULT __stdcall VarBsh(LPVARIANT pvntLeft, LPVARIANT pvntRight, LPVARIANT pvntResult, int iDir);
00028     static HRESULT __stdcall VarEq(LPVARIANT pvntLeft, LPVARIANT pvntRight, LPVARIANT pvntResult);
00029     static HRESULT __stdcall VarNeq(LPVARIANT pvntLeft, LPVARIANT pvntRight, LPVARIANT pvntResult);
00030     static HRESULT __stdcall VarLeq(LPVARIANT pvntLeft, LPVARIANT pvntRight, LPVARIANT pvntResult);
00031     static HRESULT __stdcall VarLt(LPVARIANT pvntLeft, LPVARIANT pvntRight, LPVARIANT pvntResult);
00032     static HRESULT __stdcall VarGeq(LPVARIANT pvntLeft, LPVARIANT pvntRight, LPVARIANT pvntResult);
00033     static HRESULT __stdcall VarGt(LPVARIANT pvntLeft, LPVARIANT pvntRight, LPVARIANT pvntResult);
00034
00035 // data members
00036 private:
00037     // Local Variable
00038     CCaoSQLItem*    m_pCSItem;
00039     VARIANT         m_vntConst;
00040
00041 };
00042
00043 #endif // !defined(AFX_CaoSQLCALCITEM_H__E1C734F8_9F5E_4A54_A143_008BC18C49F5__INCLUDED_)
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLController.h Source File

CaoSQLController.h

解説を見る。
00001
00012 #ifndef __CaoSQLCONTROLLER_H_
00013 #define __CaoSQLCONTROLLER_H_
00014
00015 #include "resource.h"       // メイン シンボル
00016 #include "CaoSQLCP.h"
00017
00018 class CCaoSQLItem;
00019 class CCaoSQLTriggerObserver;
00020 class CCaoSQLHistoryMan;
00021
00022 typedef std::vector<CCaoSQLTriggerObserver *> VEC_TRIGGEROVSV;
00023 typedef std::vector<CCaoSQLItem *> VEC_CSITEM;
00024 typedef enum enmCaoSQLSysInfoId {
00025     csSysInfoStart = 0,
00026     csSysInfoStop = 1,
00027     csSysInfoBegin = 2,
00028     csSysInfoEnd = 3
00029 } _enmCaoSQLSysInfoId;
00030
00039 class ATL_NO_VTABLE CCaoSQLController :
00040     public CComObjectRootEx<CComMultiThreadModel>,
00041     public CComCoClass<CCaoSQLController, &CLSID_CaoSQLController>,
00042     public ISupportErrorInfo,
00043     public IDispatchImpl<ICaoSQLController, &IID_ICaoSQLController, &LIBID_CaoSQLLib>,
00044     public CProxy_ICaoSQLEvents<CCaoSQLController>,
00045     public IConnectionPointContainerImpl<CCaoSQLController>,
00046     public IProvideClassInfo2Impl<&CLSID_CaoSQLController, &DIID__ICaoSQLControllerEvents, &LIBID_CaoSQLLib>,
00047     public IPersistImpl<CCaoSQLController>
00048 {
00049 public:
00055     CCaoSQLController()
00056     {
00057         m_pHistory = NULL;
00058         m_hszCtrl = NULL;
00059         m_hThread = NULL;
00060         m_hContinue = NULL;
00061         m_hTerminate  = NULL;
00062         m_hOnChangeExit = NULL;
00063
00064         m_lIndex = -1;
00065         m_lState = csCtrlThreadUninit;
00066         m_lTriggerState = CSQ_TRG_CMD_START;
00067         m_bSysInfo = VARIANT_FALSE;
00068         m_lBeginCnt = 0;
00069         m_pICaoWs = NULL;
00070         m_pICaoCtrl = NULL;
00071         m_dwLastScantime = 0;
00072         m_dwMinScantime = LONG_MAX;
00073         m_dwMaxScantime = 0;
00074         m_vntDateTime.vt = VT_DATE;
00075         m_vntDateTime.date = 0;
00076         m_lMicrosecond = 0;
00077         VariantInit(&m_vntTag);
00078
00079         // initialize XML data
00080         m_bEnabled = true;
00081         m_lSamplingRate = 300;      // default sampling rate
00082         m_bDistribute = false;
00083         m_iThreadPriority = THREAD_PRIORITY_NORMAL;
00084         m_bStartup = true;
00085         m_bUseHistory = true;
00086         m_bstrDescription = NULL;
00087         m_bUseTrigger=false;
00088         m_bstrRSQLCtrlName = NULL;
00089         m_bstrTrgCtrlName = NULL;
00090         m_bstrTrgItemName = NULL;
00091         m_dwNewEnum = 0;
00092         m_dwCount = 0;
00093         m_bstrMachine = NULL;
00094         m_bstrCtrlName = NULL;
00095         m_bstrParam = NULL;
00096         m_bstrProvider = NULL;
00097         m_bWriteToCache = false;
00098         m_lTimeStamp = CSQ_TIMESTAMP_LOCAL;
00099         m_bWDT = false;
00100         m_lWDTCount = CSQ_WDT_DEFAULT;
00101         m_lWDTCntr = 0;
00102
00103     }
00104
00110     ~CCaoSQLController()
00111     {
00112         SAFE_RELEASE(m_pICaoCtrl);
00113         SAFE_RELEASE(m_pICaoWs);
00114         SAFE_CLOSE(m_hTerminate);
00115         SAFE_CLOSE(m_hContinue);
00116         SAFE_CLOSE(m_hOnChangeExit);
00117         SysFreeString(m_bstrMachine);
00118         SysFreeString(m_bstrCtrlName);
00119         SysFreeString(m_bstrParam);
00120         SysFreeString(m_bstrDescription);
00121         SysFreeString(m_bstrRSQLCtrlName);
00122         SysFreeString(m_bstrTrgCtrlName);
00123         SysFreeString(m_bstrTrgItemName);
00124         VariantClear(&m_vntDateTime);
00125         VariantClear(&m_vntTag);
00126
00127     }
00128
00129 DECLARE_PROTECT_FINAL_CONSTRUCT()
00130
00131 BEGIN_COM_MAP(CCaoSQLController)
00132     COM_INTERFACE_ENTRY(ICaoSQLController)
00133     COM_INTERFACE_ENTRY(IDispatch)
00134     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00135     COM_INTERFACE_ENTRY(IConnectionPointContainer)
00136     COM_INTERFACE_ENTRY_IMPL(IConnectionPointContainer)
00137     COM_INTERFACE_ENTRY(IPersist)
00138     COM_INTERFACE_ENTRY(IProvideClassInfo2)
00139 END_COM_MAP()
00140
00141 BEGIN_CONNECTION_POINT_MAP(CCaoSQLController)
00142     CONNECTION_POINT_ENTRY(DIID__ICaoSQLControllerEvents)
00143 END_CONNECTION_POINT_MAP()
00144
00145 // ISupportsErrorInfo
00146     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00147
00148 // ICaoSQLController
00149 public:
00150     HRESULT FinalConstruct();
00151     void FinalRelease();
00152
00153     HRESULT _Activate();
00154     void _Deactivate();
00155     HRESULT _Initialize(long lID, IXMLDOMNode *pCtrlNode);
00156     void _Terminate();
00157     HRESULT _GetVariable(long lSysType, BSTR bstrVarName, BSTR bstrVarOpt, BSTR bstrSysObjName, ICaoVariable** ppVal);
00158     HRESULT _GetVariables(long lSysType,  BSTR bstrSysObjName, ICaoVariables** ppICaoVars);
00159     void _SetTriggerState(long newVal);
00160     HSZ _GetHSZ();
00161     CCaoSQLItem* _GetItem(BSTR bstrName);
00162
00163     STDMETHOD(get__NewEnum)(/*[out, retval]*/ LPUNKNOWN *pVal);
00164     STDMETHOD(get_Item)(/*[in]*/ VARIANT vntIndex, /*[out, retval]*/ ICaoSQLItem** ppICSItem);
00165
00166     STDMETHOD(Stop)();
00167     STDMETHOD(Start)();
00168     STDMETHOD(Snapshot)();
00169     STDMETHOD(AddItem)(/*[in]*/ VARIANT vntDataArray);
00170     STDMETHOD(RemoveItem)(/*[in]*/ VARIANT vntIndex);
00171     STDMETHOD(Execute)(/*[in, optional]*/ BSTR bstrCommand, /*[in, optional]*/ VARIANT vntParam, /*[out, retval]*/ VARIANT* pvntVal);
00172
00173     STDMETHOD(get_Count)(/*[out, retval]*/ long *plVal);
00174     STDMETHOD(get_Description)(/*[out, revatl]*/ BSTR *pbstrVal);
00175     STDMETHOD(get_Index)(/*[out, retval]*/ long *plVal);
00176     STDMETHOD(get_ItemNames)(/*[out, retval]*/ VARIANT *pvntVal);
00177     STDMETHOD(get_Name)(/*[out, retval]*/ BSTR *pbstrVal);
00178     STDMETHOD(get_ScanTimes)(/*[in]*/ long lNewVal, /*[out, retval]*/ long *plVal);
00179     STDMETHOD(get_SettingData)(/*[in]*/ VARIANT vntName, /*[out, retval]*/ VARIANT *pvntVal);
00180     STDMETHOD(put_SettingData)(/*[in]*/ VARIANT vntName, /*[in]*/ VARIANT vntNewVal);
00181     STDMETHOD(get_State)(/*[out, retval]*/ long *plVal);
00182     STDMETHOD(get_Tag)(/*[out, retval]*/ VARIANT *vntVal);
00183     STDMETHOD(put_Tag)(/*[in]*/ VARIANT vntNewVal);
00184
00185 private:
00186     HRESULT ReadXMLInfo(IXMLDOMNode *pCtrlNode);
00187     HRESULT ReadXMLTriggerInfo(IXMLDOMNode *pIXMLclsCtrl);
00188     HRESULT ReadXMLTriggerItem(IXMLDOMNode *pIXMLTrgItemNode, BSTR bstrTrgItemName);
00189     HRESULT GetItemNames(VARIANT* pvntVal);
00190     HRESULT GetIndex(VARIANT Index, long *lVal);
00191     HRESULT GenerateIndex(long *lID);
00192     HRESULT CreateWorkerThread();
00193     HRESULT TerminateWorkerThread();
00194     HRESULT OpenController();
00195     HRESULT AddSystemInfoRecord(_enmCaoSQLSysInfoId numSysInfoId);
00196     void ChangeState(long lNewVal);
00197     static int VarCmpA(const void *vntVal1, const void *vntVal2);
00198     void UpdateTime();
00199
00200     // main operation thread
00201     static DWORD __stdcall SamplingThread0(LPVOID pObj);
00202     void SamplingThread();
00203     static VOID __stdcall TimerAPCProc(LPVOID lpArgToCompletionRoutine, DWORD dwTimerLowValue, DWORD dwTimerHighValue);
00204     void Watchdog();
00205
00206
00207 // Data Members
00208 private:
00209     // local Variable
00210     ICaoWorkspace*                  m_pICaoWs;
00211     CRITICAL_SECTION                m_csCtrl;
00212     HSZ                             m_hszCtrl;
00213     HANDLE                          m_hThread;
00214     HANDLE                          m_hContinue;
00215     HANDLE                          m_hTerminate;
00216     HANDLE                          m_hOnChangeExit;
00217     VEC_TRIGGEROVSV                 m_vecTriggerObsv;
00218     ICaoController*                 m_pICaoCtrl;
00219     MAP_CSITEM                      m_map;
00220     VEC_CSITEM                      m_vecTrig;
00221     CCaoSQLHistoryMan*              m_pHistory;
00222     DWORD                           m_dwLastScantime;
00223     DWORD                           m_dwMinScantime;
00224     DWORD                           m_dwMaxScantime;
00225     VARIANT                         m_vntDateTime;
00226     long                            m_lMicrosecond;
00227     VARIANT                         m_vntTag;
00228
00229     // XML Variable
00230     bool                            m_bEnabled;
00231     bool                            m_bStartup;
00232     BSTR                            m_bstrDescription;
00233     int                             m_iThreadPriority;
00234     bool                            m_bDistribute;
00235     long                            m_lTriggerState;
00236     bool                            m_bUseTrigger;
00237     long                            m_lBeginCnt;
00238     BSTR                            m_bstrRSQLCtrlName;
00239     BSTR                            m_bstrTrgCtrlName;
00240     BSTR                            m_bstrTrgItemName;
00241     VARIANT_BOOL                    m_bSysInfo;
00242     DWORD                           m_dwNewEnum;
00243     DWORD                           m_dwCount;
00244     long                            m_lTimeStamp;
00245     bool                            m_bWDT;
00246     long                            m_lWDTCount;
00247     long                            m_lWDTAction;
00248
00249     // idl Variable
00250     long                            m_lState;
00251
00252     // XML/idl Variable
00253     BSTR                            m_bstrMachine;
00254     BSTR                            m_bstrCtrlName;
00255     BSTR                            m_bstrParam;
00256     BSTR                            m_bstrProvider;
00257     long                            m_lSamplingRate;
00258     bool                            m_bUseHistory;
00259     bool                            m_bWriteToCache;
00260     long                            m_lIndex;
00261     long                            m_lWDTCntr;
00262
00263 };
00264
00265 #endif //__CaoSQLCONTROLLER_H_
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLCP.h Source File

CaoSQLCP.h

解説を見る。
00001
00011 #ifndef _CaoSQLCP_H_
00012 #define _CaoSQLCP_H_
00013
00014 /*----------------------------------*/
00015 /*   CProxy_ICaoSQLEvents Class     */
00016 /*----------------------------------*/
00017
00025 template <class T>
00026 class CProxy_ICaoSQLEvents:
00027     public IConnectionPointImpl<T, &DIID__ICaoSQLControllerEvents, CComDynamicUnkArray>
00028 {
00029 public:
00038     HRESULT Fire_OnChangeItem(ICaoSQLItem* pICSItem)
00039     {
00040         CComVariant vntResult;
00041         T* pT = static_cast<T*>(this);
00042         int nConnectionIndex;
00043         CComVariant pvnt;
00044
00045         int nConnections = pT->m_vec.GetSize();
00046
00047         vntResult.scode = S_OK;
00048         for (nConnectionIndex = 0; nConnectionIndex < nConnections; nConnectionIndex++) {
00049             pT->Lock();
00050             CComPtr<IUnknown> sp = pT->m_vec.GetAt(nConnectionIndex);
00051             pT->Unlock();
00052             IDispatch* pDispatch = reinterpret_cast<IDispatch*>(sp.p);
00053             if (pDispatch != NULL) {
00054                 pvnt = pICSItem;
00055                 VariantClear(&vntResult);
00056                 DISPPARAMS disp = { &pvnt, NULL, 1, 0 };
00057                 pDispatch->Invoke(0x01, IID_NULL, LOCALE_USER_DEFAULT, DISPATCH_METHOD, &disp, &vntResult, NULL, NULL);
00058             }
00059         }
00060         return vntResult.scode;
00061     }
00062
00071     HRESULT Fire_OnChangeState(long lNewVal)
00072     {
00073         CComVariant vntResult;
00074         T* pT = static_cast<T*>(this);
00075         int nConnectionIndex;
00076         CComVariant vntVal;
00077
00078         int nConnections = pT->m_vec.GetSize();
00079
00080         vntResult.scode = S_OK;
00081         for (nConnectionIndex = 0; nConnectionIndex < nConnections; nConnectionIndex++) {
00082             pT->Lock();
00083             CComPtr<IUnknown> sp = pT->m_vec.GetAt(nConnectionIndex);
00084             pT->Unlock();
00085             IDispatch* pDispatch = reinterpret_cast<IDispatch*>(sp.p);
00086             if (pDispatch != NULL) {
00087                 vntVal = lNewVal;
00088                 VariantClear(&vntResult);
00089                 DISPPARAMS disp = { &vntVal, NULL, 1, 0 };
00090                 pDispatch->Invoke(0x02, IID_NULL, LOCALE_USER_DEFAULT, DISPATCH_METHOD, &disp, &vntResult, NULL, NULL);
00091             }
00092         }
00093         return vntResult.scode;
00094     }
00095 };
00096
00097 #endif
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLData.h Source File

CaoSQLData.h

解説を見る。
00001
00012 #ifndef _CaoSQLDATA_H_
00013 #define _CaoSQLDATA_H_
00014
00015 #include "CaoSQL.h"
00016
00017 #pragma warning(disable:4786) // これがないと C4786のwarningが大量に出る
00018
00019 #include <map>
00020 #include <vector>
00021
00022
00023 class CCaoSQLController;
00024 class CCaoSQLItem;
00025
00026 // CaoSQL General
00027 #define     CSQ_C_NULL_CHAR                     L'\0'
00028
00029 #define     CSQ_REG_ROOT                        HKEY_CLASSES_ROOT
00030 #define     CSQ_KEY_NAME                        _T("SoftWare\\CaoSQL")
00031
00032 #define     CSQ_MAX_BUFFER                      1024
00033 #define     CSQ_SLEEPTIME                       10
00034
00035 #define SIZEOFARRAY(array) (sizeof(array)/sizeof(array[0]))
00036 #define BSTR_TO_BOOL(bstr,b) { if (wcsicmp(bstr, L"true") == 0) { b = true; } else if (wcsicmp(bstr, L"false") == 0) { b = false; } }
00037
00038 #define VARIANT_TO_BSTR(in,out) { if ((in.vt == VT_BSTR) && (in.bstrVal != NULL)) { out = SysAllocString(in.bstrVal); } }
00039
00040 #define VARIANT_TO_BOOL(in,out) { if (in.vt == VT_BOOL) { if (in.boolVal == VARIANT_TRUE) { out = true; } else { out = false; } } }
00041
00042
00043 typedef unsigned CSQ_THREADID;
00044 typedef unsigned (__stdcall *CSQ_THREADFUNC)(LPVOID);
00045
00046 // CaoSQL Controller
00047 #define     CSQ_THREAD_START_TIMEOUT            3000
00048 #define     CSQ_THREAD_END_TIMEOUT              3000
00049 #define     CSQ_RETRY_INTVL_DEFAULT             3000
00050 #define     CSQ_EVENT_MAX                       1000
00051 #define     CSQ_CFG_CTRL_NAME                   0
00052 #define     CSQ_CFG_CTRL_PROV                   1
00053 #define     CSQ_CFG_CTRL_MACH                   2
00054 #define     CSQ_CFG_CTRL_OPT                    3
00055 #define     CSQ_CFG_CTRL_HIST                   4
00056 #define     CSQ_CFG_CTRL_CACHE                  5
00057 #define     CSQ_CFG_CTRL_TIMESTAMP              6
00058 #define     CSQ_CFG_CTRL_SAMPRATE               7
00059 #define     CSQ_TIMESTAMP_NA                    0
00060 #define     CSQ_TIMESTAMP_DEVICE                1
00061 #define     CSQ_TIMESTAMP_LOCAL                 2
00062 #define     CSQ_TIMESTAMP_SYSTEM                3
00063 #define     CSQ_WDT_DEFAULT                     3
00064 #define     CSQ_WDT_ACTION_NOACTION             0
00065 #define     CSQ_WDT_ACTION_STOP                 1
00066
00067 typedef std::map<long, CCaoSQLController*>      MAP_CSCTRL;
00068
00069 // CaoSQL Item
00070 #define     CSQ_DLMTR_S_YEN                     L"\\"
00071 #define     CSQ_DLMTR_S_COMMA                   L","
00072 #define     CSQ_DLMTR_C_YEN                     L'\\'
00073 #define     CSQ_DLMTR_C_COMMA                   L','
00074 #define     CSQ_CACHE_OPT_NOEVENT               1
00075 #define     CSQ_FORCETOCHANGE_READING           1
00076 #define     CSQ_FORCETOCHANGE_WRITING           2
00077
00078 #define     CSQ_SETTINGDATA_ITEM_VAR_NAME       0
00079 #define     CSQ_SETTINGDATA_ITEM_OPTION         1
00080 #define     CSQ_SETTINGDATA_ITEM_CLASS          2
00081 #define     CSQ_SETTINGDATA_ITEM_OBJECT_NAME    3
00082
00083 typedef std::map<long, CCaoSQLItem*>            MAP_CSITEM;
00084
00085
00086 // AddItemのデータ配列(VARIANT):各データ要素位置
00087 #define     CSQ_CFG_ITEM_NAME                   0
00088 #define     CSQ_CFG_ITEM_VAR_ENABLED            1
00089 #define     CSQ_CFG_ITEM_VAR_NAME               2
00090 #define     CSQ_CFG_ITEM_VAR_OPT                3
00091 #define     CSQ_CFG_ITEM_VAR_CLS                4
00092 #define     CSQ_CFG_ITEM_VAR_OBJ                5
00093 #define     CSQ_CFG_ITEM_DESC                   6
00094 #define     CSQ_CFG_ITEM_ATTR                   7
00095 #define     CSQ_CFG_ITEM_LINK_ITEM              8
00096 #define     CSQ_CFG_ITEM_INIT                   9
00097 #define     CSQ_CFG_ITEM_INIT_DATA              10
00098 #define     CSQ_CFG_ITEM_INIT_DATA_TYPE         11
00099 #define     CSQ_CFG_ITEM_USE_EMPTY              12
00100 #define     CSQ_CFG_ITEM_USE_HSTRY              13
00101 #define     CSQ_CFG_ITEM_ON_CNG_EVT             14
00102 #define     CSQ_CFG_ITEM_FORCECHANGE            15
00103 #define     CSQ_CFG_ITEM_DEADBAND               16
00104 #define     CSQ_CFG_ITEM_DEADBAND_MIN           17
00105 #define     CSQ_CFG_ITEM_DEADBAND_MAX           18
00106 #define     CSQ_CFG_ITEM_MINMAX                 19
00107 #define     CSQ_CFG_ITEM_MINMAX_MIN             20
00108 #define     CSQ_CFG_ITEM_MIXMAX_MAX             21
00109 #define     CSQ_CFG_ITEM_MASK_ENABLED           22
00110 #define     CSQ_CFG_ITEM_MASK                   23
00111 #define     CSQ_CFG_ITEM_BCD                    24
00112 #define     CSQ_CFG_ITEM_CALC_INDEX             25
00113 #define     CSQ_CFG_ITEM_2NDITEM                26
00114 #define     CSQ_CFG_ITEM_CHANGE_TYPE            27
00115 #define     CSQ_CFG_ITEM_REQUEST                28
00116
00117 #define     CSQ_ADDITEM_BND                     0
00118 #define     CSQ_ADDITEM_MAX                     28
00119
00120
00121 // CaoSQL History
00122 #define     CSQ_HST_FLDNAME_CTRLNAME            _T("controller_name")
00123 #define     CSQ_HST_FLDNAME_ITEMNAME            _T("item_name")
00124 #define     CSQ_HST_FLDNAME_VALUE               _T("item_value")
00125 #define     CSQ_HST_FLDNAME_VARTYPE             _T("item_vartype")
00126 #define     CSQ_HST_FLDNAME_DATETIME            _T("item_time")
00127 #define     CSQ_HST_FLDNAME_MILLISEC            _T("item_time_ms")
00128 #define     CSQ_HST_FLDNAME_FLAGS               _T("flags")
00129 #define     CSQ_HST_IDX_INS_CTRLNAME            0
00130 #define     CSQ_HST_IDX_INS_ITEMNAME            1
00131 #define     CSQ_HST_IDX_INS_VALUE               2
00132 #define     CSQ_HST_IDX_INS_VARTYPE             3
00133 #define     CSQ_HST_IDX_INS_DATETIME            4
00134 #define     CSQ_HST_IDX_INS_TIME_MS             5
00135 #define     CSQ_HST_IDX_INS_FLAGS               6
00136 #define     CSQ_HST_IDX_UPD_VALUE               0
00137 #define     CSQ_HST_IDX_UPD_VARTYPE             1
00138 #define     CSQ_HST_IDX_UPD_DATETIME            2
00139 #define     CSQ_HST_IDX_UPD_TIME_MS             3
00140 #define     CSQ_HST_IDX_UPD_CTRLNAME            4
00141 #define     CSQ_HST_IDX_UPD_ITEMNAME            5
00142 #define     CSQ_HST_IDX_UPD_FLAGS               6
00143 #define     CSQ_HST_FLD_SIZE                    7
00144
00145
00146 // CaoSQL DDE Server
00147 #define     CSQ_DDE_SERV_NAME               _T("CaoSQL")
00148 #define     CSQL_DDE_MAX_BUF                256
00149 #define     CSQ_DDE_MAX_DATA                1024
00150 #define     CSQ_WM_ADVREQ                   WM_APP + 1
00151
00152
00153 // CaoSQL Trigger
00154 #define     CSQ_TRG_CND_EQ                  0L
00155 #define     CSQ_TRG_CND_NE                  1L
00156 #define     CSQ_TRG_CND_LT                  2L
00157 #define     CSQ_TRG_CND_GT                  3L
00158 #define     CSQ_TRG_CND_LE                  4L
00159 #define     CSQ_TRG_CND_GE                  5L
00160
00161 #define     CSQ_TRG_ACT_NO                  0L
00162 #define     CSQ_TRG_ACT_START               1L
00163 #define     CSQ_TRG_ACT_STOP                2L
00164 #define     CSQ_TRG_ACT_ONETIME             3L
00165
00166 #define     CSQ_TRG_CMD_START               -1L
00167 #define     CSQ_TRG_CMD_STOP                0L
00168 #define     CSQ_TRG_CMD_ONETIME             1L
00169
00170 // CaoSQL RAC Server
00171 #define     CSQ_DLMTR_C_COLON               L':'
00172 #define     CSQ_DLMTR_C_EXCLAM              L'!'
00173
00174 #endif      // _CaoSQLDATA_H_
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLEngine.h Source File

CaoSQLEngine.h

解説を見る。
00001
00012 #ifndef __CaoSQLENGINE_H_
00013 #define __CaoSQLENGINE_H_
00014
00015 #include "resource.h"       // メイン シンボル
00016
00017 class CCaoSQLEngineMan;
00018 class CCaoSQLController;
00019
00020
00028 class ATL_NO_VTABLE CCaoSQLEngine :
00029     public CComObjectRootEx<CComMultiThreadModel>,
00030     public CComCoClass<CCaoSQLEngine, &CLSID_CaoSQLEngine>,
00031     public ISupportErrorInfo,
00032     public IDispatchImpl<ICaoSQLEngine, &IID_ICaoSQLEngine, &LIBID_CaoSQLLib>
00033 {
00034 public:
00040     CCaoSQLEngine()
00041     {
00042         m_pEngMan = NULL;
00043     }
00044
00050     ~CCaoSQLEngine()
00051     {
00052         m_pEngMan = NULL;
00053     }
00054
00055 DECLARE_REGISTRY_RESOURCEID(IDR_CaoSQLENGINE)
00056
00057 DECLARE_PROTECT_FINAL_CONSTRUCT()
00058
00059 BEGIN_COM_MAP(CCaoSQLEngine)
00060     COM_INTERFACE_ENTRY(ICaoSQLEngine)
00061     COM_INTERFACE_ENTRY(IDispatch)
00062     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00063 END_COM_MAP()
00064
00065 // ISupportsErrorInfo
00066     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00067
00068 // ICaoSQLEngine
00069 public:
00070     HRESULT FinalConstruct();
00071     void FinalRelease();
00072     STDMETHOD(get__NewEnum)(/*[out, retval]*/ LPUNKNOWN *pVal);
00073     STDMETHOD(get_Controller)(/*[in]*/ VARIANT vntIndex, /*[out, retval]*/ ICaoSQLController** ppICSCtrl);
00074
00075     STDMETHOD(Start)();
00076     STDMETHOD(Stop)();
00077     STDMETHOD(Snapshot)();
00078     STDMETHOD(Execute)(/*[in]*/ BSTR bstrCommandText, /*[out, retval]*/ VARIANT* pvntVal);
00079     STDMETHOD(get_Count)(/*[out, retval]*/ long *plVal);
00080     STDMETHOD(get_ControllerNames)(/*[out, retval]*/ VARIANT *pvntVal);
00081     STDMETHOD(get_CaoSQLHistory)(/*[out, retval]*/ ICaoSQLHistory** ppICSHstry);
00082
00083 private:
00084     HRESULT GetControllerNames(VARIANT* pVal);
00085     static int VarCmpA(const void *vntVal1, const void *vntVal2);
00086
00087 // Data Membsers
00088 private:
00089     // local Variable
00090     CCaoSQLEngineMan*   m_pEngMan;
00091     MAP_CSCTRL          m_map;
00092
00093 };
00094
00095 #endif //__CaoSQLENGINE_H_
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLEngineMan.h Source File

CaoSQLEngineMan.h

解説を見る。
00001
00012 #if !defined(AFX_CaoSQLENGINEMAN_H__6FBB6452_10AF_4D96_8DCF_28A2A6FA9600__INCLUDED_)
00013 #define AFX_CaoSQLENGINEMAN_H__6FBB6452_10AF_4D96_8DCF_28A2A6FA9600__INCLUDED_
00014
00015 #if _MSC_VER > 1000
00016 #pragma once
00017 #endif // _MSC_VER > 1000
00018
00019 class CCaoSQLController;
00020
00033 class CCaoSQLEngineMan
00034 {
00035 // methods
00036 public:
00037     static CCaoSQLEngineMan* Instance();
00038     HRESULT Initialize();
00039     void Terminate();
00040
00041     BSTR GetDefCtrlName();
00042     HRESULT CopyCollection(MAP_CSCTRL* pmap);
00043     HRESULT AddWorkspace(BSTR bstrName, BSTR bstrOpt, ICaoWorkspace** ppICaoWs);
00044     CCaoSQLController* GetController(BSTR bstrName);
00045
00046     HRESULT GetCaoSQLHistory(ICaoSQLHistory** ppVal);
00047
00048     long GetRetryCount();
00049     long GetRetryInterval();
00050
00051     void AddRef();
00052     void Release();
00053
00054 private:
00055     CCaoSQLEngineMan();
00056     CCaoSQLEngineMan(const CCaoSQLEngineMan&);
00057     CCaoSQLEngineMan& operator=(const CCaoSQLEngineMan&);
00058     virtual ~CCaoSQLEngineMan();
00059
00060     HRESULT ReadXMLInfo(IXMLDOMNode *pIXMLWSNode);
00061     void ReleaseControllers();
00062     HRESULT CreateCaoEngine();
00063     HRESULT ActivateControllers();
00064     HRESULT GenerateIndex(long* lID);
00065
00066     static DWORD __stdcall ActivateControllerAsync(LPVOID pObj);
00067
00068 // data members
00069 private:
00070     // local Variable
00071     static CCaoSQLEngineMan*    m_pInstance;
00072     MAP_CSCTRL                  m_map;
00073     long                        m_lRefCnt;
00074     ICaoEngine*                 m_pICaoEng;
00075     ICaoSQLHistory*             m_pICSHst;
00076
00077     // XML Variable
00078     BSTR                        m_bstrCaoHost;
00079     BSTR                        m_bstrDefCtrlName;
00080     long                        m_lRetryCnt;
00081     long                        m_lRetryInterval;
00082
00083 };
00084
00085 #endif // !defined(AFX_CaoSQLENGINEMAN_H__6FBB6452_10AF_4D96_8DCF_28A2A6FA9600__INCLUDED_)
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CAOSQLEventInfo.h Source File

CAOSQLEventInfo.h

解説を見る。
00001 #ifndef _CAOSQLEVENTINFO_MC_
00002 #define _CAOSQLEVENTINFO_MC_
00003 //
00004 //  Values are 32 bit values layed out as follows:
00005 //
00006 //   3 3 2 2 2 2 2 2 2 2 2 2 1 1 1 1 1 1 1 1 1 1
00007 //   1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0
00008 //  +---+-+-+-----------------------+-------------------------------+
00009 //  |Sev|C|R|     Facility          |               Code            |
00010 //  +---+-+-+-----------------------+-------------------------------+
00011 //
00012 //  where
00013 //
00014 //      Sev - is the severity code
00015 //
00016 //          00 - Success
00017 //          01 - Informational
00018 //          10 - Warning
00019 //          11 - Error
00020 //
00021 //      C - is the Customer code flag
00022 //
00023 //      R - is a reserved bit
00024 //
00025 //      Facility - is the facility code
00026 //
00027 //      Code - is the facility's status code
00028 //
00029 //
00030 // Define the facility codes
00031 //
00032 #define FACILITY_WARNING                 0xF02
00033 #define FACILITY_INFORMATIONAL           0xF01
00034 #define FACILITY_ERROR                   0xF03
00035
00036
00037 //
00038 // Define the severity codes
00039 //
00040 #define STATUS_SEVERITY_WARNING          0x2
00041 #define STATUS_SEVERITY_INFORMATIONAL    0x1
00042 #define STATUS_SEVERITY_ERROR            0x3
00043
00044
00045 //
00046 // MessageId: MSG_CAOSQL_LOG
00047 //
00048 // MessageText:
00049 //
00050 //  %1
00051 //
00052 #define MSG_CAOSQL_LOG                   ((DWORD)0x4F010000L)
00053
00054 #endif // _CAOSQLINFO_MC_
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLHistory.h Source File

CaoSQLHistory.h

解説を見る。
00001
00012 #ifndef __CaoSQLHISTORY_H_
00013 #define __CaoSQLHISTORY_H_
00014
00015 #include "resource.h"       // メイン シンボル
00016
00017 class CCaoSQLHistoryMan;
00018
00026 class ATL_NO_VTABLE CCaoSQLHistory :
00027     public CComObjectRootEx<CComSingleThreadModel>,
00028     public CComCoClass<CCaoSQLHistory, &CLSID_CaoSQLHistory>,
00029     public ISupportErrorInfo,
00030     public IDispatchImpl<ICaoSQLHistory, &IID_ICaoSQLHistory, &LIBID_CaoSQLLib>
00031 {
00032 public:
00038     CCaoSQLHistory()
00039     {
00040     }
00041
00047     ~CCaoSQLHistory()
00048     {
00049     }
00050
00051 DECLARE_REGISTRY_RESOURCEID(IDR_CaoSQLHISTORY)
00052
00053 DECLARE_PROTECT_FINAL_CONSTRUCT()
00054
00055 BEGIN_COM_MAP(CCaoSQLHistory)
00056     COM_INTERFACE_ENTRY(ICaoSQLHistory)
00057     COM_INTERFACE_ENTRY(IDispatch)
00058     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00059 END_COM_MAP()
00060
00061 // ISupportsErrorInfo
00062     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00063
00064 // ICaoSQLHistory
00065 public:
00066     HRESULT FinalConstruct();
00067     void FinalRelease();
00068
00069     STDMETHOD(Execute)(/*[in]*/ BSTR bstrCmdText, /*[out, retval]*/ VARIANT* pvntVal);
00070     STDMETHOD(get_ConnectionString)(/*[in]*/ long lIndex, /*[out, retval]*/ BSTR *pbstrVal);
00071     STDMETHOD(get_Enable)(/*[out, retval]*/ VARIANT_BOOL *pbVal);
00072     STDMETHOD(get_MaxRecord)(/*[in]*/ long lIndex,/*[out, retval]*/ long *plVal);
00073     STDMETHOD(get_TableName)(/*[in]*/ long lIndex,/*[out, retval]*/ BSTR *pbstrVal);
00074
00075 // Data Members
00076 private:
00077     // local Variable
00078     CCaoSQLHistoryMan*                      m_pHistoryMan;
00079
00080 };
00081
00082 #endif //__CaoSQLHISTORY_H_
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLHistoryMan.h Source File

CaoSQLHistoryMan.h

解説を見る。
00001
00012 #if !defined(AFX_CaoSQLHISTORY_H__170E0EB9_D84D_4BB7_ABD6_F6C81C5F8D62__INCLUDED_)
00013 #define AFX_CaoSQLHISTORY_H__170E0EB9_D84D_4BB7_ABD6_F6C81C5F8D62__INCLUDED_
00014
00015 #if _MSC_VER > 1000
00016 #pragma once
00017 #endif // _MSC_VER > 1000
00018
00019 // for ADO
00020 #import "C:\program files\common files\system\ado\msado15.dll" \
00021         no_namespace rename( "EOF", "adoEOF" )
00022
00023 inline void TESTHR(HRESULT x) {if FAILED(x) _com_issue_error(x);};
00024
00025 // Definitions
00026 #define     CAOSQL_HSTRY_VALUE_MAXLEN       254 // 255 - 1(\0)
00027 #define     CAOSQL_HSTRY_NAME_MAXLEN        31  // 32 - 1(\0)
00028
00029 #define     CAOSQL_HSTRY_CMD_ADD            _T("INSERT INTO %ls(%s, %s, %s, %s, %s, %s, %s) VALUES(?, ?, ?, ?, ?, ?, ?)")
00030 #define     CAOSQL_HSTRY_CMD_CNT            _T("SELECT COUNT(*) FROM %ls")
00031 #define     CAOSQL_HSTRY_CMD_UPDATE         _T("UPDATE %ls SET %s = ?, %s = ?, %s = ?, %s = ? WHERE %s = ? AND %s = ? AND %s = ?")
00032
00033 #define     CAOSQL_HSTRY_TYPE_HSTRY         1
00034 #define     CAOSQL_HSTRY_TYPE_CURVAL        2
00035
00036 #define     CAOSQL_HSTRY_FLAG_CURVAL        1
00037
00047 class CCaoSQLHistoryMan
00048 {
00049 // methods
00050 public:
00051     static CCaoSQLHistoryMan* Instance();
00052     HRESULT Initialize();
00053     void Terminate();
00054
00055     HRESULT AddHistory(BSTR bstrCtrlName, BSTR bstrItemName, VARIANT vntValue, VARIANT vntDateTime, long lMicrosecond);
00056     HRESULT Execute(BSTR bstrCmd, VARIANT* pVal);
00057
00058     HRESULT GetConnectionString(long lIndex, BSTR* pVal);
00059     HRESULT GetTableName(long lIndex, BSTR* pVal);
00060     HRESULT GetMaxRecord(long lIndex, DWORD* pVal);
00061     HRESULT GetEnableHistory(VARIANT_BOOL* pVal);
00062     HRESULT GetEnableSysInfo(VARIANT_BOOL* pVal);
00063
00064     HRESULT BeginTrans(long* plLevel = NULL);
00065     HRESULT CommitTrans();
00066     HRESULT RollbackTrans();
00067
00068 private:
00069     CCaoSQLHistoryMan();
00070     CCaoSQLHistoryMan(const CCaoSQLHistoryMan&);
00071     CCaoSQLHistoryMan& operator=(const CCaoSQLHistoryMan&);
00072     virtual ~CCaoSQLHistoryMan();
00073
00074     bool IsOpen();
00075     HRESULT OpenConnection();
00076     void CloseConnection();
00077     HRESULT SwitchDatabase();
00078     HRESULT AddHistory0(BSTR bstrCtrlName, BSTR bstrItemName, VARIANT vntValue, VARIANT vntDateTime, long lMicrosecond, long lFlag);
00079     HRESULT AddHistory1(BSTR bstrCtrlName, BSTR bstrItemName, VARIANT vntValue, VARIANT vntDateTime, long lMicrosecond);
00080     HRESULT UpdateHistory(BSTR bstrCtrlName, BSTR bstrItemName, VARIANT vntValue, VARIANT vntDateTime, long lMicrosecond);
00081     HRESULT GetRecordCount(long* plVal);
00082     HRESULT ReadXMLInfo();
00083
00084 // Data Members
00085 private:
00086     // local Variable
00087     static CCaoSQLHistoryMan*   m_pInstance;
00088     CRITICAL_SECTION            m_csHistory;
00089
00090     _ConnectionPtr              m_pConnection;
00091     _CommandPtr                 m_pAddCmd;
00092     _CommandPtr                 m_pCountCmd;
00093     _CommandPtr                 m_pUpdateCmd;
00094     _ParameterPtr               m_pPrmAdd[CSQ_HST_FLD_SIZE];
00095     _ParameterPtr               m_pPrmUpdate[CSQ_HST_FLD_SIZE];
00096
00097     bool                        m_bError;
00098     bool                        m_bIsOpen;
00099     bool                        m_b2ndDB;
00100     long                        m_lTransCnt;
00101
00102     BSTR                        m_bstrCurrentADOCon;
00103     BSTR                        m_bstrCurrentTblName;
00104     long                        m_lCurrentMaxRcrd;
00105
00106     long                        m_lRecCnt;
00107     bool                        m_bGetRecordCount;
00108
00109     // XML Variable
00110     BSTR                        m_bstrHistoryADOCon;
00111     BSTR                        m_bstrTableName;
00112     long                        m_lMaxRecord;
00113     BSTR                        m_bstrHistoryADOCon2nd;
00114     BSTR                        m_bstrTableName2nd;
00115     long                        m_lMaxRecord2nd;
00116     bool                        m_bEnableHistory;
00117     bool                        m_bAutoSwitch;
00118     bool                        m_bSysInfo;
00119     long                        m_lTableType;
00120
00121 };
00122
00123 #endif // !defined(AFX_CaoSQLHISTORY_H__170E0EB9_D84D_4BB7_ABD6_F6C81C5F8D62__INCLUDED_)
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLItem.h Source File

CaoSQLItem.h

解説を見る。
00001
00012 #ifndef __CaoSQLITEM_H_
00013 #define __CaoSQLITEM_H_
00014
00015 #include <queue>
00016
00017 #include "resource.h"       // メイン シンボル
00018 #include "CaoSQLAdviser.h"
00019 #include "CaoSQLOnChangeObserver.h"
00020 #include "CaoSQLLinkObserver.h"
00021 #include "CaoSQLCalcItem.h"
00022
00023 class CCaoSQLHistoryMan;
00024 class CCaoSQLController;
00025
00026
00027
00035 class ATL_NO_VTABLE CCaoSQLItem : public CCaoSQLAdviser,
00036     public CComObjectRootEx<CComMultiThreadModel>,
00037     public CComCoClass<CCaoSQLItem, &CLSID_CaoSQLItem>,
00038     public ISupportErrorInfo,
00039     public IDispatchImpl<ICaoSQLItem, &IID_ICaoSQLItem, &LIBID_CaoSQLLib>
00040 {
00041 public:
00047     CCaoSQLItem()
00048     {
00049         // local Variable
00050         m_pCSCtrl = NULL;
00051         m_pHistory = NULL;
00052         m_pOnChngObsv = NULL;
00053         m_pLinkObsv = NULL;
00054         m_pICaoVar = NULL;
00055         m_pCalcItem = NULL;
00056         m_hszItem = NULL;
00057         m_dwDDEAdvRef = 0;
00058         VariantInit(&m_vntValue);
00059         VariantInit(&m_vntTag);
00060         VariantInit(&m_vntPutValue);
00061         m_lIndex = -1;
00062         m_bWritten = false;
00063         m_bWriteToCache = false;
00064         m_bGetElem = false;
00065         m_lElemIndices[0] = 0;
00066         m_lElemIndices[1] = 0;
00067         m_lElemIndices[2] = 0;
00068         m_bDynamicItem = false;
00069         m_lTimeStamp = CSQ_TIMESTAMP_LOCAL;
00070         m_lChatCount = 0;
00071         VariantInit(&m_vntLastValue);
00072
00073         // XML Variable
00074         m_bEnabled = false;
00075         m_bVariableEnabled = false;
00076         m_bstrCtrlName = NULL;
00077         m_bstrVarName = NULL;
00078         m_bstrOption = NULL;
00079         m_lVarClass = csVarClassController;
00080         m_bstrSysObjName = NULL;
00081         m_bInitialize = false;
00082         m_bstrInitData = NULL;
00083         m_vtInitDataType = VT_I2;
00084         m_lForceChange = 0;
00085         m_bUseEmpty = false;
00086         m_bUseHistory = true;
00087         m_bOnChangeEvent = true;
00088         m_bDeadBand = false;
00089         m_fDeadBandMin = 0;
00090         m_fDeadBandMax = 0;
00091         m_bMinMax = false;
00092         m_fMin = 0;
00093         m_fMax = 0;
00094         m_bChatEnabled = false;
00095         m_lChatMax = 0;
00096         m_bMaskEnabled = false;
00097         m_lMask = 0;
00098         m_bBCD = false;
00099         m_lCalcIndex = 0;
00100         m_bstr2ndItem = NULL;
00101         m_bChangeType = false;
00102         m_vtRequest = VT_VARIANT;
00103
00104         // idl Variable
00105         m_bActivation = VARIANT_TRUE;
00106         m_bLinkActivation = VARIANT_TRUE;
00107         m_vntDateTime.vt = VT_DATE;
00108         m_vntDateTime.date = 0;
00109         m_lMicrosecond = 0;
00110         m_lState = csItemUndefined;
00111
00112         // XML/idl Variable
00113         m_bstrItemName = NULL;
00114         m_bstrDescription = NULL;
00115         m_lAttribute = csItemReadWrite;
00116     }
00117
00123     ~CCaoSQLItem()
00124     {
00125         SAFE_RELEASE(m_pICaoVar);
00126         SAFE_DELETE(m_pOnChngObsv);
00127         SAFE_DELETE(m_pLinkObsv);
00128         SAFE_DELETE(m_pCalcItem);
00129         VariantClear(&m_vntValue);
00130         VariantClear(&m_vntTag);
00131         VariantClear(&m_vntPutValue);
00132         VariantClear(&m_vntLastValue);
00133         VariantClear(&m_vntDateTime);
00134         SysFreeString(m_bstrCtrlName);
00135         SysFreeString(m_bstrVarName);
00136         SysFreeString(m_bstrOption);
00137         SysFreeString(m_bstrSysObjName);
00138         SysFreeString(m_bstrInitData);
00139         SysFreeString(m_bstr2ndItem);
00140         SysFreeString(m_bstrItemName);
00141         SysFreeString(m_bstrDescription);
00142     }
00143
00144 //DECLARE_REGISTRY_RESOURCEID(IDR_CaoSQLITEM)
00145
00146 DECLARE_PROTECT_FINAL_CONSTRUCT()
00147
00148 BEGIN_COM_MAP(CCaoSQLItem)
00149     COM_INTERFACE_ENTRY(ICaoSQLItem)
00150     COM_INTERFACE_ENTRY(IDispatch)
00151     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00152 END_COM_MAP()
00153
00154 // ISupportsErrorInfo
00155     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00156
00157 // ICaoSQLItem
00158 public:
00159     HRESULT FinalConstruct();
00160     void FinalRelease();
00161
00162     HRESULT _Initialize(long lID, IXMLDOMNode *pItemNode, CCaoSQLController* pCtrl);
00163     HRESULT _Initialize(long lID, VARIANT vntArrayData, CCaoSQLController* pCtrl);
00164     HRESULT _Activate();
00165     void _Deactivate();
00166
00167     HRESULT _CacheValue(int iOpt = 0);
00168     CCaoSQLController* _GetController();
00169     bool _IsDynamicItem();
00170
00171     // for DDE
00172     void _IncrementDDEAdviseRef();
00173     void _DecrementDDEAdviseRef();
00174     DWORD _GetDDEAdivseRef();
00175     HSZ _GetHSZ();
00176
00177     STDMETHOD(get_Value)(/*[out, retval]*/ VARIANT *pvntVal);
00178     STDMETHOD(put_Value)(/*[in]*/ VARIANT vntNewVal);
00179
00180     STDMETHOD(Snapshot)();
00181
00182     STDMETHOD(get_Activation)(/*[out, retval]*/ VARIANT_BOOL *pbVal);
00183     STDMETHOD(put_Activation)(/*[in]*/ VARIANT_BOOL bNewVal);
00184     STDMETHOD(get_DateTime)(/*[out, retval]*/ VARIANT *pvntVal);
00185     STDMETHOD(get_Index)(/*[out, retval]*/ long *plVal);
00186     STDMETHOD(get_LinkActivation)(/*[out, retval]*/ VARIANT_BOOL *pbVal);
00187     STDMETHOD(put_LinkActivation)(/*[in]*/ VARIANT_BOOL pbVal);
00188     STDMETHOD(get_Microsecond)(/*[out, retval]*/ long *plVal);
00189     STDMETHOD(get_State)(/*[out, retval]*/ long *plVal);
00190     STDMETHOD(get_Tag)(/*[out, retval]*/ VARIANT *pvntVal);
00191     STDMETHOD(put_Tag)(/*[out, retval]*/ VARIANT vntNewVal);
00192     STDMETHOD(put_ValueEx)(/*[out, retval]*/ long lDelay, VARIANT vntNewVal);
00193
00194     STDMETHOD(get_Attribute)(/*[out, retval]*/ long *plVal);
00195     STDMETHOD(get_Description)(/*[out, retval]*/ BSTR *pbstrVal);
00196     STDMETHOD(get_LinkItemNames)(/*[out, retval]*/ VARIANT *pvntVal);
00197     STDMETHOD(get_Name)(/*[out, retval]*/ BSTR *pbstrVal);
00198     STDMETHOD(get_SettingData)(/*[in]*/ VARIANT vntName, /*[out, retval]*/ VARIANT *pvntVal);
00199     STDMETHOD(put_SettingData)(/*[in]*/ VARIANT vntName, /*[in]*/ VARIANT vntNewVal);
00200     STDMETHOD(get_ID)(/*[out, retval]*/ VARIANT *pVal);
00201     STDMETHOD(put_ID)(/*[in]*/ VARIANT newVal);
00202     STDMETHOD(get_Element)(/*[in]*/ long lIndex1, /*[in]*/ long lIndex2, /*[in]*/ long lIndex3, /*[out, retval]*/ VARIANT *pVal);
00203     STDMETHOD(put_Element)(/*[in]*/ long lIndex1, /*[in]*/ long lIndex2, /*[in]*/ long lIndex3, /*[in]*/ VARIANT newVal);
00204
00205 private:
00206     HRESULT ReadXMLInfo(IXMLDOMNode *pItemNode);
00207     HRESULT Initialize0();
00208     void UpdateTime();
00209     void ChangeState(long newVal);
00210     HRESULT MaskValue(VARIANT* pvntVal);
00211     HRESULT ConvertValue(VARIANT* pvntVal, bool bToBCD);
00212     HRESULT CheckIllegalChar(BSTR bstrItemName);
00213     HRESULT CheckName(BSTR bstrName);
00214     bool CheckDeadband(VARIANT* pvntVal);
00215     bool CheckRange(VARIANT* pvntVal);
00216     HRESULT ChangeType(VARIANT* pvntVal, VARIANT* pvntNewVal);
00217     HRESULT GetElement(VARIANT *pvntVal, VARIANT *vntNewVal);
00218     HRESULT GetElement0(VARIANT *pvntVal, long *plIndex, VARIANT *vntNewVal);
00219     HRESULT ParseParameter(BSTR bstrParam, WCHAR* pwszDelimiter, VARIANT *pvntVal);
00220     static int VarCmpA(const void *vntVal1, const void *vntVal2);
00221     BSTR TrimBSTR(BSTR bstrString);
00222     static DWORD __stdcall PutValueAsync0(LPVOID pObj);
00223     void PutValueAsync();
00224
00225 // Data Members
00226 private:
00227     // local Variable
00228     CRITICAL_SECTION                m_csItem;
00229     CRITICAL_SECTION                m_csItemPut;
00230     CRITICAL_SECTION                m_csItemLast;
00231     CRITICAL_SECTION                m_csValueEx;
00232     CCaoSQLController*              m_pCSCtrl;
00233     CCaoSQLHistoryMan*              m_pHistory;
00234     CCaoSQLOnChangeObserver*        m_pOnChngObsv;
00235     CCaoSQLLinkObserver*            m_pLinkObsv;
00236     ICaoVariable*                   m_pICaoVar;
00237     CCaoSQLCalcItem*                m_pCalcItem;
00238     HSZ                             m_hszItem;
00239     DWORD                           m_dwDDEAdvRef;
00240     VARIANT                         m_vntValue;
00241     VARIANT                         m_vntTag;
00242     VARIANT                         m_vntPutValue;
00243     long                            m_lIndex;
00244     bool                            m_bWritten;
00245     bool                            m_bWriteToCache;
00246     bool                            m_bGetElem;
00247     long                            m_lElemIndices[3];
00248     bool                            m_bDynamicItem;
00249     long                            m_lTimeStamp;
00250     long                            m_lChatCount;
00251     VARIANT                         m_vntLastValue;
00252     DWORD                           m_dwLastUpdated;
00253     long                            m_lSamplingRate;
00254     typedef struct {
00255         long                        lDelay;
00256         VARIANT                     vntValue;
00257         HANDLE                      hThread;
00258     } QUE_VALUEEX;
00259     std::queue<QUE_VALUEEX>         m_queValueEx;
00260
00261     // XML Variable
00262     bool                            m_bEnabled;
00263     bool                            m_bVariableEnabled;
00264     BSTR                            m_bstrCtrlName;
00265     BSTR                            m_bstrVarName;
00266     BSTR                            m_bstrOption;
00267     long                            m_lVarClass;
00268     BSTR                            m_bstrSysObjName;
00269     bool                            m_bInitialize;
00270     BSTR                            m_bstrInitData;
00271     VARTYPE                         m_vtInitDataType;
00272     long                            m_lForceChange;
00273     bool                            m_bUseEmpty;
00274     bool                            m_bUseHistory;
00275     bool                            m_bOnChangeEvent;
00276     bool                            m_bDeadBand;
00277     float                           m_fDeadBandMin;
00278     float                           m_fDeadBandMax;
00279     bool                            m_bMinMax;
00280     float                           m_fMin;
00281     float                           m_fMax;
00282     bool                            m_bChatEnabled;
00283     long                            m_lChatMax;
00284     bool                            m_bMaskEnabled;
00285     long                            m_lMask;
00286     bool                            m_bBCD;
00287     long                            m_lCalcIndex;
00288     BSTR                            m_bstr2ndItem;
00289     bool                            m_bChangeType;
00290     VARTYPE                         m_vtRequest;
00291
00292     // idl Variable
00293     VARIANT_BOOL                    m_bActivation;
00294     VARIANT_BOOL                    m_bLinkActivation;
00295     VARIANT                         m_vntDateTime;
00296     long                            m_lMicrosecond;
00297     long                            m_lState;
00298
00299     // XML/idl Variable
00300     BSTR                            m_bstrItemName;
00301     BSTR                            m_bstrDescription;
00302     long                            m_lAttribute;
00303     std::vector<BSTR>               m_vecLinkItems;
00304
00305 };
00306
00307 #endif //__CaoSQLITEM_H_
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLLinkObserver.h Source File

CaoSQLLinkObserver.h

解説を見る。
00001
00011 #if !defined(AFX_CaoSQLLINKOBSERVER_H__E953E6C2_C41B_4BB1_92D1_D2F4DA6B85E0__INCLUDED_)
00012 #define AFX_CaoSQLLINKOBSERVER_H__E953E6C2_C41B_4BB1_92D1_D2F4DA6B85E0__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00018 #include "CaoSQLObserver.h"
00019
00020 class CCaoSQLItem;
00021
00028 class CCaoSQLLinkObserver : public CCaoSQLObserver
00029 {
00030 // methods
00031 public:
00032     CCaoSQLLinkObserver();
00033     virtual ~CCaoSQLLinkObserver();
00034
00035     HRESULT Activate(VARIANT_BOOL bActive);
00036     HRESULT Initialize(CCaoSQLItem* pItem);
00037     HRESULT Update(VARIANT vntNewVal);
00038
00039 private:
00040     HRESULT ParseParameter(BSTR bstrParam, WCHAR* pwszDelimiter, VARIANT *pvntVal);
00041
00042 // data members
00043 private:
00044     std::vector<CCaoSQLItem*>       m_vecCSItem;
00045     VARIANT_BOOL                    m_bActive;
00046
00047 };
00048
00049 #endif // !defined(AFX_CaoSQLLINKOBSERVER_H__E953E6C2_C41B_4BB1_92D1_D2F4DA6B85E0__INCLUDED_)
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLObserver.h Source File

CaoSQLObserver.h

解説を見る。
00001
00012 #if !defined(AFX_CaoSQLOBSERVER_H__57092436_381D_48A1_8834_1DF4095969D2__INCLUDED_)
00013 #define AFX_CaoSQLOBSERVER_H__57092436_381D_48A1_8834_1DF4095969D2__INCLUDED_
00014
00015 #if _MSC_VER > 1000
00016 #pragma once
00017 #endif // _MSC_VER > 1000
00018
00019
00026 class CCaoSQLObserver
00027 {
00028 public:
00034     CCaoSQLObserver()
00035     {
00036     }
00037
00039     virtual ~CCaoSQLObserver()
00040     {
00041     }
00042
00052     virtual HRESULT Update(VARIANT vntNewVal) = 0;
00053
00054 };
00055
00056 #endif // !defined(AFX_CaoSQLOBSERVER_H__57092436_381D_48A1_8834_1DF4095969D2__INCLUDED_)
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLOnChangeObserver.h Source File

CaoSQLOnChangeObserver.h

解説を見る。
00001
00012 #if !defined(AFX_CaoSQLONCHANGEOBSERVER_H__75A18619_43CC_4784_A432_80816F03836D__INCLUDED_)
00013 #define AFX_CaoSQLONCHANGEOBSERVER_H__75A18619_43CC_4784_A432_80816F03836D__INCLUDED_
00014
00015 #if _MSC_VER > 1000
00016 #pragma once
00017 #endif // _MSC_VER > 1000
00018
00019 #include "CaoSQLObserver.h"
00020
00021 class CCaoSQLController;
00022 class CCaoSQLItem;
00023
00030 class CCaoSQLOnChangeObserver : public CCaoSQLObserver
00031 {
00032 public:
00033     CCaoSQLOnChangeObserver();
00034     virtual ~CCaoSQLOnChangeObserver();
00035
00036     HRESULT Initialize(CCaoSQLItem* pItem);
00037     HRESULT Update(VARIANT vntNewVal);
00038
00039 private:
00040     // local Variable
00041     CCaoSQLController*      m_pCSCtrl;
00042     CCaoSQLItem*            m_pCSItem;
00043     BSTR                    m_bstrName;
00044     long                    m_lIndex;
00045
00046 };
00047
00048 #endif // !defined(AFX_CaoSQLONCHANGEOBSERVER_H__75A18619_43CC_4784_A432_80816F03836D__INCLUDED_)
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLRACSvr.h Source File

CaoSQLRACSvr.h

解説を見る。
00001 // CaoSQLRACSvr.h: CCaoSQLRACSvr クラスの定義
00002 //
00004
00005 #if !defined(AFX_CAOSQLRACSVR_H__04737F87_3A5D_465A_9EEF_0FD7FDE625F7__INCLUDED_)
00006 #define AFX_CAOSQLRACSVR_H__04737F87_3A5D_465A_9EEF_0FD7FDE625F7__INCLUDED_
00007
00008 #if _MSC_VER > 1000
00009 #pragma once
00010 #endif // _MSC_VER > 1000
00011
00012 #include "resource.h"       // メイン シンボル
00013 #include "CaoSQLRACSvrMan.h"
00014
00016 // CCaoSQLRACSvr
00017
00018 class ATL_NO_VTABLE CCaoSQLRACSvr :
00019     public IDispatchImpl<ICaoSQLRACSvr, &IID_ICaoSQLRACSvr, &LIBID_CaoSQLLib>,
00020     public ISupportErrorInfo,
00021     public CComObjectRoot,
00022     public CComCoClass<CCaoSQLRACSvr,&CLSID_CaoSQLRACSvr>
00023 {
00024 public:
00025     CCaoSQLRACSvr()
00026     {
00027     }
00028
00029     ~CCaoSQLRACSvr()
00030     {
00031     }
00032
00033 BEGIN_COM_MAP(CCaoSQLRACSvr)
00034     COM_INTERFACE_ENTRY(IDispatch)
00035     COM_INTERFACE_ENTRY(ICaoSQLRACSvr)
00036     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00037 END_COM_MAP()
00038 //DECLARE_NOT_AGGREGATABLE(CCaoSQLRACSvr)
00039 // オブジェクトでアグリゲーションをサポートしない場合は
00040 // 上の行からコメントを削除してください。
00041
00042 DECLARE_REGISTRY_RESOURCEID(IDR_CaoSQLRACSvr)
00043 // ISupportsErrorInfo
00044     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00045
00046 // ICaoSQLRACSvr
00047 public:
00048     HRESULT FinalConstruct();
00049     void FinalRelease();
00050 private:
00051     // local Variable
00052     CRACServer*                 m_pRACServer;
00053
00054 };
00055
00056 #endif // !defined(AFX_CAOSQLRACSVR_H__04737F87_3A5D_465A_9EEF_0FD7FDE625F7__INCLUDED_)
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CaoSQLTriggerObserver.h Source File

CaoSQLTriggerObserver.h

解説を見る。
00001
00012 #if !defined(AFX_CaoSQLTRIGGEROBSERVER_H__5A4499B7_7C92_4F5F_8E2C_57E315C582C3__INCLUDED_)
00013 #define AFX_CaoSQLTRIGGEROBSERVER_H__5A4499B7_7C92_4F5F_8E2C_57E315C582C3__INCLUDED_
00014
00015 #if _MSC_VER > 1000
00016 #pragma once
00017 #endif // _MSC_VER > 1000
00018
00019 #include "CaoSQLObserver.h"
00020
00021 class CCaoSQLController;
00022
00029 class CCaoSQLTriggerObserver : public CCaoSQLObserver
00030 {
00031 // methods
00032 public:
00033     CCaoSQLTriggerObserver();
00034     virtual ~CCaoSQLTriggerObserver();
00035
00036     HRESULT Initialize(CCaoSQLController* pCSCtrl);
00037     HRESULT RegisterTriggerItem(long lAction, long lCondition, BSTR bstrThreshold);
00038     HRESULT Update(VARIANT vntNewVal);
00039
00040 private:
00041     HRESULT DoAction();
00042
00043 // data members
00044 private:
00045     // local Variable
00046     CCaoSQLController*              m_pCSCtrl;
00047     long                            m_lAction;
00048     long                            m_lCondition;
00049     VARIANT                         m_vntThreshold;
00050
00051 };
00052
00053 #endif // !defined(AFX_CaoSQLTRIGGEROBSERVER_H__5A4499B7_7C92_4F5F_8E2C_57E315C582C3__INCLUDED_)
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoSQLAdviser メンバ一覧

これは全メンバの一覧です。CCaoSQLAdviser継承メンバも含んでいます。
AddObserver(CCaoSQLObserver *pVal) | CCaoSQLAdviser |
CCaoSQLAdviser() | CCaoSQLAdviser |
DeleteObserver(CCaoSQLObserver *pVal) | CCaoSQLAdviser |
NotifyObservers(VARIANT vntNewVal) | CCaoSQLAdviser |
ReleaseObservers() | CCaoSQLAdviser |
~CCaoSQLAdviser() | CCaoSQLAdviser | [virtual]
Generated on Tue Dec 13 12:25:33 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoSQLCalcItem メンバ一覧

これは全メンバの一覧です。CCaoSQLCalcItem継承メンバも含んでいます。
Calculate(LPVARIANT pvntLeft, LPVARIANT pvntResult) | CCaoSQLCalcItem |
CCaoSQLCalcItem() | CCaoSQLCalcItem |
Initialize(CCaoSQLItem *pItem, long lCalcIndex, BSTR bstr2ndItem) | CCaoSQLCalcItem |
~CCaoSQLCalcItem() | CCaoSQLCalcItem | [virtual]
Generated on Tue Dec 13 12:25:33 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoSQLController メンバ一覧

これは全メンバの一覧です。CCaoSQLController継承メンバも含んでいます。
_Activate() | CCaoSQLController |
_Deactivate() | CCaoSQLController |
_GetHSZ() | CCaoSQLController |
_GetItem(BSTR bstrName) | CCaoSQLController |
_GetVariable(long lSysType, BSTR bstrVarName, BSTR bstrVarOpt, BSTR bstrSysObjName, ICaoVariable **ppVal) | CCaoSQLController |
_GetVariables(long lSysType, BSTR bstrSysObjName, ICaoVariables **ppICaoVars) | CCaoSQLController |
_Initialize(long lID, IXMLDOMNode *pCtrlNode) | CCaoSQLController |
_SetTriggerState(long newVal) | CCaoSQLController |
_Terminate() | CCaoSQLController |
AddItem(VARIANT vntDataArray) | CCaoSQLController |
CCaoSQLController() | CCaoSQLController | [inline]
Execute(BSTR bstrCommand, VARIANT vntParam, VARIANT *pvntVal) | CCaoSQLController |
FinalConstruct() | CCaoSQLController |
FinalRelease() | CCaoSQLController |
Fire_OnChangeItem(ICaoSQLItem *pICSItem) | CProxy_ICaoSQLEvents< CCaoSQLController > | [inline]
Fire_OnChangeState(long lNewVal) | CProxy_ICaoSQLEvents< CCaoSQLController > | [inline]
get__NewEnum(LPUNKNOWN *pVal) | CCaoSQLController |
get_Count(long *plVal) | CCaoSQLController |
get_Description(BSTR *pbstrVal) | CCaoSQLController |
get_Index(long *plVal) | CCaoSQLController |
get_Item(VARIANT vntIndex, ICaoSQLItem **ppICSItem) | CCaoSQLController |
get_ItemNames(VARIANT *pvntVal) | CCaoSQLController |
get_Name(BSTR *pbstrVal) | CCaoSQLController |
get_ScanTimes(long lNewVal, long *plVal) | CCaoSQLController |
get_SettingData(VARIANT vntName, VARIANT *pvntVal) | CCaoSQLController |
get_State(long *plVal) | CCaoSQLController |
get_Tag(VARIANT *vntVal) | CCaoSQLController |
InterfaceSupportsErrorInfo(REFIID riid) | CCaoSQLController |
put_SettingData(VARIANT vntName, VARIANT vntNewVal) | CCaoSQLController |
put_Tag(VARIANT vntNewVal) | CCaoSQLController |
RemoveItem(VARIANT vntIndex) | CCaoSQLController |
Snapshot() | CCaoSQLController |
Start() | CCaoSQLController |
Stop() | CCaoSQLController |
~CCaoSQLController() | CCaoSQLController | [inline]
Generated on Tue Dec 13 12:25:33 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoSQLEngine メンバ一覧

これは全メンバの一覧です。CCaoSQLEngine継承メンバも含んでいます。
CCaoSQLEngine() | CCaoSQLEngine | [inline]
Execute(BSTR bstrCommandText, VARIANT *pvntVal) | CCaoSQLEngine |
FinalConstruct() | CCaoSQLEngine |
FinalRelease() | CCaoSQLEngine |
get__NewEnum(LPUNKNOWN *pVal) | CCaoSQLEngine |
get_CaoSQLHistory(ICaoSQLHistory **ppICSHstry) | CCaoSQLEngine |
get_Controller(VARIANT vntIndex, ICaoSQLController **ppICSCtrl) | CCaoSQLEngine |
get_ControllerNames(VARIANT *pvntVal) | CCaoSQLEngine |
get_Count(long *plVal) | CCaoSQLEngine |
InterfaceSupportsErrorInfo(REFIID riid) | CCaoSQLEngine |
Snapshot() | CCaoSQLEngine |
Start() | CCaoSQLEngine |
Stop() | CCaoSQLEngine |
~CCaoSQLEngine() | CCaoSQLEngine | [inline]
Generated on Tue Dec 13 12:25:34 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoSQLEngineMan メンバ一覧

これは全メンバの一覧です。CCaoSQLEngineMan継承メンバも含んでいます。
AddRef() | CCaoSQLEngineMan |
AddWorkspace(BSTR bstrName, BSTR bstrOpt, ICaoWorkspace **ppICaoWs) | CCaoSQLEngineMan |
CopyCollection(MAP_CSCTRL *pmap) | CCaoSQLEngineMan |
GetCaoSQLHistory(ICaoSQLHistory **ppVal) | CCaoSQLEngineMan |
GetController(BSTR bstrName) | CCaoSQLEngineMan |
GetDefCtrlName() | CCaoSQLEngineMan |
GetRetryCount() | CCaoSQLEngineMan |
GetRetryInterval() | CCaoSQLEngineMan |
Initialize() | CCaoSQLEngineMan |
Instance() | CCaoSQLEngineMan | [static]
Release() | CCaoSQLEngineMan |
Terminate() | CCaoSQLEngineMan |
Generated on Tue Dec 13 12:25:34 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoSQLHistory メンバ一覧

これは全メンバの一覧です。CCaoSQLHistory継承メンバも含んでいます。
CCaoSQLHistory() | CCaoSQLHistory | [inline]
Execute(BSTR bstrCmdText, VARIANT *pvntVal) | CCaoSQLHistory |
FinalConstruct() | CCaoSQLHistory |
FinalRelease() | CCaoSQLHistory |
get_ConnectionString(long lIndex, BSTR *pbstrVal) | CCaoSQLHistory |
get_Enable(VARIANT_BOOL *pbVal) | CCaoSQLHistory |
get_MaxRecord(long lIndex, long *plVal) | CCaoSQLHistory |
get_TableName(long lIndex, BSTR *pbstrVal) | CCaoSQLHistory |
InterfaceSupportsErrorInfo(REFIID riid) | CCaoSQLHistory |
~CCaoSQLHistory() | CCaoSQLHistory | [inline]
Generated on Tue Dec 13 12:25:34 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoSQLHistoryMan メンバ一覧

これは全メンバの一覧です。CCaoSQLHistoryMan継承メンバも含んでいます。
AddHistory(BSTR bstrCtrlName, BSTR bstrItemName, VARIANT vntValue, VARIANT vntDateTime, long lMicrosecond) | CCaoSQLHistoryMan |
BeginTrans(long *plLevel=NULL) | CCaoSQLHistoryMan |
CommitTrans() | CCaoSQLHistoryMan |
Execute(BSTR bstrCmd, VARIANT *pVal) | CCaoSQLHistoryMan |
GetConnectionString(long lIndex, BSTR *pVal) | CCaoSQLHistoryMan |
GetEnableHistory(VARIANT_BOOL *pVal) | CCaoSQLHistoryMan |
GetEnableSysInfo(VARIANT_BOOL *pVal) | CCaoSQLHistoryMan |
GetMaxRecord(long lIndex, DWORD *pVal) | CCaoSQLHistoryMan |
GetTableName(long lIndex, BSTR *pVal) | CCaoSQLHistoryMan |
Initialize() | CCaoSQLHistoryMan |
Instance() | CCaoSQLHistoryMan | [static]
RollbackTrans() | CCaoSQLHistoryMan |
Terminate() | CCaoSQLHistoryMan |
Generated on Tue Dec 13 12:25:34 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoSQLItem メンバ一覧

これは全メンバの一覧です。CCaoSQLItem継承メンバも含んでいます。
_Activate() | CCaoSQLItem |
_CacheValue(int iOpt=0) | CCaoSQLItem |
_Deactivate() | CCaoSQLItem |
_DecrementDDEAdviseRef() | CCaoSQLItem |
_GetController() | CCaoSQLItem |
_GetDDEAdivseRef() | CCaoSQLItem |
_GetHSZ() | CCaoSQLItem |
_IncrementDDEAdviseRef() | CCaoSQLItem |
_Initialize(long lID, IXMLDOMNode *pItemNode, CCaoSQLController *pCtrl) | CCaoSQLItem |
_Initialize(long lID, VARIANT vntArrayData, CCaoSQLController *pCtrl) | CCaoSQLItem |
_IsDynamicItem() | CCaoSQLItem |
AddObserver(CCaoSQLObserver *pVal) | CCaoSQLAdviser |
CCaoSQLAdviser() | CCaoSQLAdviser |
CCaoSQLItem() | CCaoSQLItem | [inline]
DeleteObserver(CCaoSQLObserver *pVal) | CCaoSQLAdviser |
FinalConstruct() | CCaoSQLItem |
FinalRelease() | CCaoSQLItem |
get_Activation(VARIANT_BOOL *pbVal) | CCaoSQLItem |
get_Attribute(long *plVal) | CCaoSQLItem |
get_DateTime(VARIANT *pvntVal) | CCaoSQLItem |
get_Description(BSTR *pbstrVal) | CCaoSQLItem |
get_Element(long lIndex1, long lIndex2, long lIndex3, VARIANT *pVal) | CCaoSQLItem |
get_ID(VARIANT *pVal) | CCaoSQLItem |
get_Index(long *plVal) | CCaoSQLItem |
get_LinkActivation(VARIANT_BOOL *pbVal) | CCaoSQLItem |
get_LinkItemNames(VARIANT *pvntVal) | CCaoSQLItem |
get_Microsecond(long *plVal) | CCaoSQLItem |
get_Name(BSTR *pbstrVal) | CCaoSQLItem |
get_SettingData(VARIANT vntName, VARIANT *pvntVal) | CCaoSQLItem |
get_State(long *plVal) | CCaoSQLItem |
get_Tag(VARIANT *pvntVal) | CCaoSQLItem |
get_Value(VARIANT *pvntVal) | CCaoSQLItem |
InterfaceSupportsErrorInfo(REFIID riid) | CCaoSQLItem |
NotifyObservers(VARIANT vntNewVal) | CCaoSQLAdviser |
put_Activation(VARIANT_BOOL bNewVal) | CCaoSQLItem |
put_Element(long lIndex1, long lIndex2, long lIndex3, VARIANT newVal) | CCaoSQLItem |
put_ID(VARIANT newVal) | CCaoSQLItem |
put_LinkActivation(VARIANT_BOOL pbVal) | CCaoSQLItem |
put_SettingData(VARIANT vntName, VARIANT vntNewVal) | CCaoSQLItem |
put_Tag(VARIANT vntNewVal) | CCaoSQLItem |
put_Value(VARIANT vntNewVal) | CCaoSQLItem |
put_ValueEx(long lDelay, VARIANT vntNewVal) | CCaoSQLItem |
ReleaseObservers() | CCaoSQLAdviser |
Snapshot() | CCaoSQLItem |
~CCaoSQLAdviser() | CCaoSQLAdviser | [virtual]
~CCaoSQLItem() | CCaoSQLItem | [inline]
Generated on Tue Dec 13 12:25:34 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoSQLLinkObserver メンバ一覧

これは全メンバの一覧です。CCaoSQLLinkObserver継承メンバも含んでいます。
Activate(VARIANT_BOOL bActive) | CCaoSQLLinkObserver |
CCaoSQLLinkObserver() | CCaoSQLLinkObserver |
CCaoSQLObserver() | CCaoSQLObserver | [inline]
Initialize(CCaoSQLItem *pItem) | CCaoSQLLinkObserver |
Update(VARIANT vntNewVal) | CCaoSQLLinkObserver | [virtual]
~CCaoSQLLinkObserver() | CCaoSQLLinkObserver | [virtual]
~CCaoSQLObserver() | CCaoSQLObserver | [inline, virtual]
Generated on Tue Dec 13 12:25:34 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoSQLObserver メンバ一覧

これは全メンバの一覧です。CCaoSQLObserver継承メンバも含んでいます。
CCaoSQLObserver() | CCaoSQLObserver | [inline]
Update(VARIANT vntNewVal)=0 | CCaoSQLObserver | [pure virtual]
~CCaoSQLObserver() | CCaoSQLObserver | [inline, virtual]
Generated on Tue Dec 13 12:25:34 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoSQLOnChangeObserver メンバ一覧

これは全メンバの一覧です。CCaoSQLOnChangeObserver継承メンバも含んでいます。
CCaoSQLObserver() | CCaoSQLObserver | [inline]
CCaoSQLOnChangeObserver() | CCaoSQLOnChangeObserver |
Initialize(CCaoSQLItem *pItem) | CCaoSQLOnChangeObserver |
Update(VARIANT vntNewVal) | CCaoSQLOnChangeObserver | [virtual]
~CCaoSQLObserver() | CCaoSQLObserver | [inline, virtual]
~CCaoSQLOnChangeObserver() | CCaoSQLOnChangeObserver | [virtual]
Generated on Tue Dec 13 12:25:35 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoSQLRACSvr メンバ一覧

これは全メンバの一覧です。CCaoSQLRACSvr継承メンバも含んでいます。
CCaoSQLRACSvr() | CCaoSQLRACSvr | [inline]
FinalConstruct() | CCaoSQLRACSvr |
FinalRelease() | CCaoSQLRACSvr |
InterfaceSupportsErrorInfo(REFIID riid) | CCaoSQLRACSvr |
~CCaoSQLRACSvr() | CCaoSQLRACSvr | [inline]
Generated on Tue Dec 13 12:25:35 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoSQLTriggerObserver メンバ一覧

これは全メンバの一覧です。CCaoSQLTriggerObserver継承メンバも含んでいます。
CCaoSQLObserver() | CCaoSQLObserver | [inline]
CCaoSQLTriggerObserver() | CCaoSQLTriggerObserver |
Initialize(CCaoSQLController *pCSCtrl) | CCaoSQLTriggerObserver |
RegisterTriggerItem(long lAction, long lCondition, BSTR bstrThreshold) | CCaoSQLTriggerObserver |
Update(VARIANT vntNewVal) | CCaoSQLTriggerObserver | [virtual]
~CCaoSQLObserver() | CCaoSQLObserver | [inline, virtual]
~CCaoSQLTriggerObserver() | CCaoSQLTriggerObserver | [virtual]
Generated on Tue Dec 13 12:25:35 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CDDEServer メンバ一覧

これは全メンバの一覧です。CDDEServer継承メンバも含んでいます。
GetInstanceID() | CDDEServer |
Initialize() | CDDEServer |
Instance() | CDDEServer | [static]
Terminate() | CDDEServer |
Generated on Tue Dec 13 12:25:35 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CLockCriticalSection メンバ一覧

これは全メンバの一覧です。CLockCriticalSection継承メンバも含んでいます。
CLockCriticalSection(CRITICAL_SECTION &cs) | CLockCriticalSection | [inline]
Lock() | CLockCriticalSection | [inline]
m_cs | CLockCriticalSection |
Unlock() | CLockCriticalSection | [inline]
~CLockCriticalSection() | CLockCriticalSection | [inline]
Generated on Tue Dec 13 12:25:35 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CProxy_ICaoSQLEvents< T > メンバ一覧

これは全メンバの一覧です。CProxy_ICaoSQLEvents< T >継承メンバも含んでいます。
Fire_OnChangeItem(ICaoSQLItem *pICSItem) | CProxy_ICaoSQLEvents< T > | [inline]
Fire_OnChangeState(long lNewVal) | CProxy_ICaoSQLEvents< T > | [inline]
Generated on Tue Dec 13 12:25:35 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CRACEventSink メンバ一覧

これは全メンバの一覧です。CRACEventSink継承メンバも含んでいます。
_Initialize(VARIANT vntArgs[]) | CRACEventSink |
_Terminate() | CRACEventSink |
CRACEventSink() | CRACEventSink | [inline]
FinalConstruct() | CRACEventSink |
FinalRelease() | CRACEventSink |
InterfaceSupportsErrorInfo(REFIID riid) | CRACEventSink |
OnMessage(IUnknown *pVal) | CRACEventSink |
~CRACEventSink() | CRACEventSink | [inline]
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CRACServer メンバ一覧

これは全メンバの一覧です。CRACServer継承メンバも含んでいます。
Initialize() | CRACServer |
Instance() | CRACServer | [static]
Terminate() | CRACServer |
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CReadXML メンバ一覧

これは全メンバの一覧です。CReadXML継承メンバも含んでいます。
CReadXML::CReadXML() | CReadXML | [inline]
CReadXML::~CReadXML() | CReadXML | [inline]
QueryValue(IXMLDOMNode *pINode, BSTR bstrNodeName, BSTR *pbstrData) | CReadXML | [inline]
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CRegKeyEx メンバ一覧

これは全メンバの一覧です。CRegKeyEx継承メンバも含んでいます。
CRegKeyEx() | CRegKeyEx | [inline]
EnumKeys(DWORD dwIndex, LPTSTR lpName, LPDWORD lpcName) | CRegKeyEx | [inline]
QueryValue(LPTSTR szValue, LPCTSTR lpszValueName, DWORD *pdwCount) | CRegKeyEx | [inline]
QueryValue(DWORD &dwValue, LPCTSTR lpszValueName) | CRegKeyEx | [inline]
~CRegKeyEx() | CRegKeyEx | [inline]
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CServiceModule メンバ一覧

これは全メンバの一覧です。CServiceModule継承メンバも含んでいます。
CServiceModule() | CServiceModule | [inline]
dwThreadID | CServiceModule |
Handler(DWORD dwOpcode) | CServiceModule | [inline]
Init(_ATL_OBJMAP_ENTRY *p, HINSTANCE h, UINT nServiceNameID, const GUID *plibid=NULL) | CServiceModule | [inline]
Install() | CServiceModule | [inline]
IsInstalled() | CServiceModule |
LogEvent(DWORD dwLevel, LPCTSTR pFormat,...) | CServiceModule |
m_bCORBAEnabled | CServiceModule |
m_bDCOMEnabled | CServiceModule |
m_bDDEEnabled | CServiceModule |
m_bJNIEnabled | CServiceModule |
m_bNotRepeatError | CServiceModule |
m_bRACSvrEnabled | CServiceModule |
m_bService | CServiceModule |
m_bstrCORBAOption | CServiceModule |
m_hServiceStatus | CServiceModule |
m_lcid | CServiceModule |
m_status | CServiceModule |
m_szDataPath | CServiceModule |
m_szServiceName | CServiceModule |
RegisterServer(BOOL bRegTypeLib, BOOL bService) | CServiceModule | [inline]
Run() | CServiceModule |
ServiceMain(DWORD dwArgc, LPTSTR *lpszArgv) | CServiceModule | [inline]
SetServiceStatus(DWORD dwState) | CServiceModule |
SetupAsLocalServer() | CServiceModule |
Start() | CServiceModule | [inline]
Uninstall() | CServiceModule | [inline]
Unlock() | CServiceModule |
UnregisterServer() | CServiceModule | [inline]
~CServiceModule() | CServiceModule | [inline]
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


CorbaCaoSQL.idl Source File

CorbaCaoSQL.idl

解説を見る。
00001
00013 interface ICaoSQLEngine;
00014 interface ICaoSQLController;
00015 interface ICaoSQLItem;
00016 typedef unsigned long rsHRESULT;
00017
00020 enum enmCaoSQLControllerState
00021 {
00022     rsCtrlThreadActive, // スレッドはアクティブです
00023     rsCtrlThreadStop,   // スレッドは稼動していません
00024     rsCtrlThreadWaiting // スレッドは待機中です
00025 };
00026
00029 enum enmCaoSQLItemState
00030 {
00031     rsItemSucceeded,    // アイテムの値取得/設定は成功しました
00032     rsItemFailed,       // アイテムの値取得/設定は失敗しました
00033     rsItemUndefined     // アイテムの値取得/設定は不定で
00034 };
00035
00038 enum enmCaoSQLSystemType
00039 {
00040     rsSystemTypeNone,   // ユーザ変数
00041     rsSystemTypeController, // コントローラクラスのシステム変数
00042     rsSystemTypeTask,   // タスククラスのシステム変数
00043     rsSystemTypeRobot   // ロボットクラスのシステム変数
00044 };
00045
00048 interface ICaoSQLEngine
00049 {
00050     rsHRESULT get_ControllerNames(out any pVal);
00051     rsHRESULT get_Controller(in any vntIndex, out ICaoSQLController piCtrl);
00052     rsHRESULT get_Count(out long pVal);
00053
00054     rsHRESULT Start(in string newVal);
00055     rsHRESULT Stop(in string newVal);
00056     rsHRESULT Snapshot(in string newVal);
00057 };
00058
00061 interface ICaoSQLController
00062 {
00063     rsHRESULT get_ItemNames(out any pVal);
00064     rsHRESULT get_Item(in any vntIndex, out ICaoSQLItem piItem);
00065     rsHRESULT get_Count(out long pVal);
00066     rsHRESULT get_Name(out string pVal);
00067     rsHRESULT get_Provider(out string pVal);
00068     rsHRESULT get_Machine(out string pVal);
00069     rsHRESULT get_ControllerName(out string pVal);
00070     rsHRESULT get_Parameter(out string pVal);
00071     rsHRESULT get_SamplingRate(out long pVal);
00072     rsHRESULT get_Description(out string pVal);
00073     rsHRESULT get_UseOnChange(out boolean pVal);
00074     rsHRESULT get_UseHistory(out boolean pVal);
00075     rsHRESULT get_State(out enmCaoSQLControllerState pVal);
00076     rsHRESULT get_ID(out long pVal);
00077     rsHRESULT get_Tag(out any pVal);
00078     rsHRESULT put_Tag(in any newVal);
00079
00080     rsHRESULT Start();
00081     rsHRESULT Stop();
00082     rsHRESULT Snapshot(in string newVal);
00083 };
00084
00087 interface ICaoSQLItem
00088 {
00089     rsHRESULT get_Value(out any pVal);
00090     rsHRESULT put_Value(in any newVal);
00091     rsHRESULT get_DateTime(out any pVal);
00092     rsHRESULT get_State(out enmCaoSQLItemState pVal);
00093     rsHRESULT get_ID(out long pVal);
00094     rsHRESULT get_Tag(out any pVal);
00095     rsHRESULT put_Tag(in any newVal);
00096     rsHRESULT get_Name(out string pVal);
00097     rsHRESULT get_VariableName(out string pVal);
00098     rsHRESULT get_SystemType(out enmCaoSQLSystemType pVal);
00099     rsHRESULT get_LinkItemName(out string pVal);
00100     rsHRESULT get_Description(out string pVal);
00101     rsHRESULT get_UseHistory(out boolean pVal);
00102     rsHRESULT get_UseEmpty(out boolean pVal);
00103 };
00104
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


DDEServer.h Source File

DDEServer.h

解説を見る。
00001
00011 #if !defined(AFX_DDESERVER_H__977788A3_7507_4394_9C16_7E9C12E2949A__INCLUDED_)
00012 #define AFX_DDESERVER_H__977788A3_7507_4394_9C16_7E9C12E2949A__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00018 class CCaoSQLItem;
00019
00031 class CDDEServer
00032 {
00033 // methods
00034 public:
00035     static CDDEServer* Instance();
00036
00037     HRESULT Initialize();
00038     void Terminate();
00039
00040     DWORD GetInstanceID();
00041
00042 private:
00043     CDDEServer();
00044     CDDEServer(const CDDEServer&);
00045     CDDEServer& operator=(const CDDEServer&);
00046     virtual ~CDDEServer();
00047
00048     HRESULT CreateDdeHandles();
00049     void FreeDdeHandles();
00050     HRESULT SearchTarget(LPCTSTR pszCtrlName, LPCTSTR pszItemName, CCaoSQLItem** ppItem);
00051     HRESULT MakeData(VARIANT vntValue, LPTSTR pszData);
00052
00053     static HDDEDATA CALLBACK DdeCallback(UINT uType, UINT uFmt, HCONV hconv, HSZ hsz1, HSZ hsz2, HDDEDATA hdata, DWORD dwData1, DWORD dwData2);
00054
00055 // data members
00056 private:
00057     // local Variable
00058     static CDDEServer*      m_pInstance;
00059     DWORD                   m_dwIdInst;
00060     HSZ                     m_hszService;
00061
00062 };
00063
00064 #endif // !defined(AFX_DDESERVER_H__977788A3_7507_4394_9C16_7E9C12E2949A__INCLUDED_)
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


EventSink.h Source File

EventSink.h

解説を見る。
00001 // @(s)
00002 //  CRACEventSink の宣言
00003 //
00004
00005 #ifndef __RACEventSink_H_
00006 #define __RACEventSink_H_
00007
00008 #include "resource.h"
00009 #include "CaoSQLEngine.h"
00010 #include "CaoSQLEngineMan.h"
00011 #include "CaoSQLController.h"
00012 #include "CaoSQLItem.h"
00013
00014 #include <queue>
00015
00016 #define MSG_MAX         1000    // メッセージキューの最大サイズ
00017 #define RAC_PARA_NUM    5       // RACコマンド配列要素数
00018
00019 class CCaoProvController;
00020
00026 class ATL_NO_VTABLE CRACEventSink :
00027     public CComObjectRootEx<CComMultiThreadModel>,
00028     public CComCoClass<CRACEventSink, &CLSID_RACEventSink>,
00029     public ISupportErrorInfo,
00030     public IDispatchImpl<IRACEventSink, &IID_IRACEventSink, &LIBID_CaoSQLLib>
00031 {
00032 public:
00038     CRACEventSink() : m_dwCookie(0)
00039     {
00040         m_pICaoCtrl = NULL;
00041         m_pIRacRes = NULL;
00042
00043         m_bstrBeforeCtrlName = NULL;
00044         m_pCaoSQLCtrl = NULL;
00045     }
00046
00047     ~CRACEventSink()
00048     {
00049         m_pIRacRes = NULL;
00050         m_pICaoCtrl = NULL;
00051         m_pCaoSQLCtrl = NULL;
00052     }
00053
00054 //DECLARE_REGISTRY_RESOURCEID(IDR_RACEventSink)
00055
00056 DECLARE_PROTECT_FINAL_CONSTRUCT()
00057
00058 BEGIN_COM_MAP(CRACEventSink)
00059     COM_INTERFACE_ENTRY(IRACEventSink)
00060     COM_INTERFACE_ENTRY(IDispatch)
00061     COM_INTERFACE_ENTRY_IID(__uuidof(_ICaoControllerEvents), IDispatch)
00062     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00063 END_COM_MAP()
00064
00065 // ISupportsErrorInfo
00066     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00067
00068 // FinalConstruct / FinalRelease
00069     HRESULT FinalConstruct();
00070     void FinalRelease();
00071
00072 // IRACEventSink
00073     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00074     STDMETHOD(_Terminate)();
00075     STDMETHOD(OnMessage)(IUnknown *pVal);
00076
00077 private:
00078     HRESULT AnalyzeMessage(VARIANT vntVal, BSTR* pbstrRetVal);
00079
00080     static void __cdecl ExecMessage0(LPVOID pArglist);
00081     void ExecMessage();
00082
00083     // local Variable
00084     ICaoController* m_pICaoCtrl;        // CaoControllerのIFポインタ
00085     DWORD           m_dwCookie;         // 接続を一意に識別するクッキー
00086     IRacRes*        m_pIRacRes;         // RacDataオブジェクトのIFポインタ
00087
00088     // 非同期スレッド用
00089     HANDLE          m_hMsgThread;       // イベント処理スレッドのハンドル
00090     HANDLE          m_hTerminate;       // スレッド終了イベントハンドル
00091     HANDLE          m_hMsgSem;          // イベント処理用のセマフォ
00092     std::queue<ICaoMessage*> m_queMsg;  // 非同期コマンドキュー
00093     CRITICAL_SECTION m_csMsg;           // スレッド対応用のクリティカルセクション
00094
00095     // RACメッセージ解析用バッファ
00096     BSTR m_bstrBeforeCtrlName;
00097     CCaoSQLController* m_pCaoSQLCtrl;
00098
00099 #ifdef _DEBUG
00100     BSTR                m_bstrName;
00101 #endif
00102 };
00103
00104 #endif //__RACEventSink_H_
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


Graph Legend

グラフの凡例

このページでは、doxygen で生成されたグラフをどのようにみたらよいかを説明します。

次の例を考えてみます。

/*! 省略されて見えないクラス */
class Invisible { };

/*! 省略されたクラス(継承関係は隠されている) */
class Truncated : public Invisible { };

/* doxygen コメントによるドキュメントがないクラス */
class Undocumented { };

/*! public で継承されたクラス */
class PublicBase : public Truncated { };

/*! protected で継承されたクラス */
class ProtectedBase { };

/*! private で継承されたクラス */
class PrivateBase { };

/*! 継承されたクラスで使われているクラス */
class Used { };

/*! 複数のクラスを継承している上位クラス */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
{
  private:
    Used *m_usedClass;
};
設定ファイル中で、タグ MAX_DOT_GRAPH_HEIGHT が 200 にセットされた場合、次のようなグラフとなります。

上のグラフ内のボックスには次のような意味があります。

  • 黒く塗りつぶされたボックスは、このグラフに対応する構造体やクラスを表します。
  • 黒枠のボックスはドキュメントがある構造体やクラスを表します。
  • 灰色の枠のボックスはドキュメントがない構造体やクラスを表します。
  • 赤枠のボックスはドキュメントがある構造体やクラスを表しますが、指定されたサイズに収まらないために継承・包含関係をすべて図示することができなかったことを示します。
矢印には次のような意味があります。
  • 青い矢印は二つのクラス間の public 継承関係を示します。
  • 緑の矢印は protected 継承関係を示します。
  • 赤の矢印は private 継承関係を示します。
  • 紫の破線矢印は、そのクラスが他のクラスに含まれていたり、利用されていることを示します。また、矢印が指しているクラスや構造体をどの変数でアクセスできるかを矢印のラベルとして示しています。
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CaoSQLLib::_ICaoSQLControllerEvents メンバ一覧

これは全メンバの一覧です。CaoSQLLib::_ICaoSQLControllerEvents継承メンバも含んでいます。
OnChangeItem([in] ICaoSQLItem *pICSItem) | CaoSQLLib::_ICaoSQLControllerEvents
OnChangeState([in] long lNewVal) | CaoSQLLib::_ICaoSQLControllerEvents
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoSQLController メンバ一覧

これは全メンバの一覧です。ICaoSQLController継承メンバも含んでいます。
_NewEnum([out, retval] LPUNKNOWN *pVal) | ICaoSQLController
AddItem([in] VARIANT vntDataArray) | ICaoSQLController
Count([out, retval] long *plVal) | ICaoSQLController
Description([out, retval] BSTR *pbstrVal) | ICaoSQLController
Execute([in] BSTR bstrCommand,[in, optional] VARIANT vntParam,[out, retval] VARIANT *pvntVal) | ICaoSQLController
get_ControllerName(out string pVal) | ICaoSQLController
get_Count(out long pVal) | ICaoSQLController
get_Description(out string pVal) | ICaoSQLController
get_ID(out long pVal) | ICaoSQLController
get_Item(in any vntIndex, out ICaoSQLItem piItem) | ICaoSQLController
get_ItemNames(out any pVal) | ICaoSQLController
get_Machine(out string pVal) | ICaoSQLController
get_Name(out string pVal) | ICaoSQLController
get_Parameter(out string pVal) | ICaoSQLController
get_Provider(out string pVal) | ICaoSQLController
get_SamplingRate(out long pVal) | ICaoSQLController
get_State(out enmCaoSQLControllerState pVal) | ICaoSQLController
get_Tag(out any pVal) | ICaoSQLController
get_UseHistory(out boolean pVal) | ICaoSQLController
get_UseOnChange(out boolean pVal) | ICaoSQLController
Index([out, retval] long *plVal) | ICaoSQLController
Item([in] VARIANT vntIndex,[out, retval] ICaoSQLItem **ppICSItem) | ICaoSQLController
ItemNames([out, retval] VARIANT *pvntVal) | ICaoSQLController
Name([out, retval] BSTR *pbstrVal) | ICaoSQLController
put_Tag(in any newVal) | ICaoSQLController
RemoveItem([in] VARIANT vntIndex) | ICaoSQLController
ScanTimes([in] long lIndex,[out, retval] long *plVal) | ICaoSQLController
SettingData([in] VARIANT vntName,[out, retval] VARIANT *pvntVal) | ICaoSQLController
SettingData([in] VARIANT vntName,[in] VARIANT vntNewVal) | ICaoSQLController
Snapshot() | ICaoSQLController
Snapshot(in string newVal) | ICaoSQLController
Start() | ICaoSQLController
Start() | ICaoSQLController
State([out, retval] long *plVal) | ICaoSQLController
Stop() | ICaoSQLController
Stop() | ICaoSQLController
Tag([out, retval] VARIANT *pvntVal) | ICaoSQLController
Tag([in] VARIANT vntNewVal) | ICaoSQLController
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoSQLEngine メンバ一覧

これは全メンバの一覧です。ICaoSQLEngine継承メンバも含んでいます。
_NewEnum([out, retval] LPUNKNOWN *pVal) | ICaoSQLEngine
CaoSQLHistory([out, retval] ICaoSQLHistory **ppICSHstry) | ICaoSQLEngine
Controller([in] VARIANT vntIndex,[out, retval] ICaoSQLController **ppICSCtrl) | ICaoSQLEngine
ControllerNames([out, retval] VARIANT *pvntVal) | ICaoSQLEngine
Count([out, retval] long *plVal) | ICaoSQLEngine
Execute([in] BSTR bstrCmdText,[out, retval] VARIANT *pvntVal) | ICaoSQLEngine
get_Controller(in any vntIndex, out ICaoSQLController piCtrl) | ICaoSQLEngine
get_ControllerNames(out any pVal) | ICaoSQLEngine
get_Count(out long pVal) | ICaoSQLEngine
Snapshot() | ICaoSQLEngine
Snapshot(in string newVal) | ICaoSQLEngine
Start() | ICaoSQLEngine
Start(in string newVal) | ICaoSQLEngine
Stop() | ICaoSQLEngine
Stop(in string newVal) | ICaoSQLEngine
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoSQLHistory メンバ一覧

これは全メンバの一覧です。ICaoSQLHistory継承メンバも含んでいます。
ConnectionString([in] long lIndex,[out, retval] BSTR *pbstrVal) | ICaoSQLHistory
Enable([out, retval] VARIANT_BOOL *pbVal) | ICaoSQLHistory
Execute([in] BSTR bstrCmdText,[out, retval] VARIANT *pvntVal) | ICaoSQLHistory
MaxRecord([in] long lIndex,[out, retval] long *plVal) | ICaoSQLHistory
TableName([in] long lIndex,[out, retval] BSTR *pbstrVal) | ICaoSQLHistory
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoSQLItem メンバ一覧

これは全メンバの一覧です。ICaoSQLItem継承メンバも含んでいます。
Activation([out, retval] VARIANT_BOOL *pbVal) | ICaoSQLItem
Activation([in] VARIANT_BOOL bNewVal) | ICaoSQLItem
Attribute([out, retval] long *plVal) | ICaoSQLItem
DateTime([out, retval] VARIANT *pvntVal) | ICaoSQLItem
Description([out, retval] BSTR *pbstrVal) | ICaoSQLItem
Element([in] long lIndex1,[in, defaultvalue(0)] long lIndex2,[in, defaultvalue(0)] long lIndex3,[out, retval] VARIANT *pVal) | ICaoSQLItem
Element([in] long lIndex1,[in, defaultvalue(0)] long lIndex2,[in, defaultvalue(0)] long lIndex3,[in] VARIANT newVal) | ICaoSQLItem
get_DateTime(out any pVal) | ICaoSQLItem
get_Description(out string pVal) | ICaoSQLItem
get_ID(out long pVal) | ICaoSQLItem
get_LinkItemName(out string pVal) | ICaoSQLItem
get_Name(out string pVal) | ICaoSQLItem
get_State(out enmCaoSQLItemState pVal) | ICaoSQLItem
get_SystemType(out enmCaoSQLSystemType pVal) | ICaoSQLItem
get_Tag(out any pVal) | ICaoSQLItem
get_UseEmpty(out boolean pVal) | ICaoSQLItem
get_UseHistory(out boolean pVal) | ICaoSQLItem
get_Value(out any pVal) | ICaoSQLItem
get_VariableName(out string pVal) | ICaoSQLItem
ID([out, retval] VARIANT *pVal) | ICaoSQLItem
ID([in] VARIANT newVal) | ICaoSQLItem
Index([out, retval] long *plVal) | ICaoSQLItem
LinkActivation([out, retval] VARIANT_BOOL *pbVal) | ICaoSQLItem
LinkActivation([in] VARIANT_BOOL bNewVal) | ICaoSQLItem
LinkItemNames([out, retval] VARIANT *pvntVal) | ICaoSQLItem
Microsecond([out, retval] long *plVal) | ICaoSQLItem
Name([out, retval] BSTR *pbstrVal) | ICaoSQLItem
put_Tag(in any newVal) | ICaoSQLItem
put_Value(in any newVal) | ICaoSQLItem
SettingData([in] VARIANT vntName,[out, retval] VARIANT *pvntVal) | ICaoSQLItem
SettingData([in] VARIANT vntName,[in] VARIANT vntNewVal) | ICaoSQLItem
Snapshot() | ICaoSQLItem
State([out, retval] long *plVal) | ICaoSQLItem
Tag([out, retval] VARIANT *pvntVal) | ICaoSQLItem
Tag([in] VARIANT vntNewVal) | ICaoSQLItem
Value([out, retval] VARIANT *pvntVal) | ICaoSQLItem
Value([in] VARIANT vntNewVal) | ICaoSQLItem
ValueEx([in, defaultvalue(0)] long lDelay, VARIANT vntNewVal) | ICaoSQLItem
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

IRACEventSink メンバ一覧

これは全メンバの一覧です。IRACEventSink継承メンバも含んでいます。
OnMessage([in] IUnknown *pIVal) IRACEventSink
Generated on Tue Dec 13 12:25:36 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


LockCriticalSection.h Source File

LockCriticalSection.h

解説を見る。
00001
00011 #if !defined(AFX_LOCKCRITICALSECTION_H__087FFCA1_BC60_4A67_89CE_01D147DBC7F9__INCLUDED_)
00012 #define AFX_LOCKCRITICALSECTION_H__087FFCA1_BC60_4A67_89CE_01D147DBC7F9__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00018
00025 class CLockCriticalSection
00026 {
00027 public:
00028
00037     CLockCriticalSection(CRITICAL_SECTION& cs) : m_cs(cs)
00038     {
00039         m_bIsLock = false;
00040         Lock();
00041     }
00042
00048     ~CLockCriticalSection()
00049     {
00050         Unlock();
00051     }
00052
00058     void Lock()
00059     {
00060         EnterCriticalSection(&m_cs);
00061         m_bIsLock = true;
00062     }
00063
00069     void Unlock()
00070     {
00071         // ロックされていないクリティカルセクションに対してLeaveCriticalSectionは危険
00072         if (m_bIsLock) {
00073             LeaveCriticalSection(&m_cs);
00074         }
00075         m_bIsLock = false;
00076     }
00077
00078     CRITICAL_SECTION&   m_cs;
00079
00080 private:
00081     // local Variable
00082     bool                m_bIsLock;
00083
00084 };
00085
00086 #endif // !defined(AFX_LOCKCRITICALSECTION_H__087FFCA1_BC60_4A67_89CE_01D147DBC7F9__INCLUDED_)
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


RACServer.h Source File

RACServer.h

解説を見る。
00001 // CRACServer.h: CRACServer クラスの定義
00002 //
00004
00005 #if !defined(AFX_RACSERVER_H__B3CD89B9_5548_44A7_BA86_CB0ACFF529CA__INCLUDED_)
00006 #define AFX_RACSERVER_H__B3CD89B9_5548_44A7_BA86_CB0ACFF529CA__INCLUDED_
00007
00008 #if _MSC_VER > 1000
00009 #pragma once
00010 #endif // _MSC_VER > 1000
00011
00012 #include "resource.h"       // メイン シンボル
00013 #include "EventSink.h"
00014
00016 // CRACServer
00017
00018 class CRACServer
00019 {
00020 public:
00021     static CRACServer* Instance();
00022
00023     HRESULT Initialize();
00024     void Terminate();
00025
00026 private:
00027     CRACServer()
00028     {
00029         m_pInstance = NULL;
00030         m_pICaoEng = NULL;
00031         m_pICaoWs = NULL;
00032         m_dwRACSvrCount = 0;
00033     }
00034
00035     ~CRACServer()
00036     {
00037         m_pInstance = NULL;
00038         m_pICaoEng = NULL;
00039         m_pICaoWs = NULL;
00040     }
00041
00042     HRESULT EntryController();
00043
00044 // Data member
00045 private:
00046     // local Variable
00047     static CRACServer*                  m_pInstance;
00048     typedef struct {
00049         BSTR                            bstrRACParam;
00050         ICaoController*                 pICaoCtrl;
00051         CRACEventSink*                  pRACEventSink;
00052     } ST_RAC_DATA;
00053     typedef std::vector<ST_RAC_DATA>    VEC_RAC_DATA;
00054     VEC_RAC_DATA                        m_vecRACData;
00055     ICaoEngine*                         m_pICaoEng;
00056     ICaoWorkspace*                      m_pICaoWs;
00057
00058     // Registry Variable
00059     DWORD                               m_dwRACSvrCount;
00060
00061 };
00062
00063 #endif // !defined(AFX_RACSERVER_H__B3CD89B9_5548_44A7_BA86_CB0ACFF529CA__INCLUDED_)
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


ReadXML.h Source File

ReadXML.h

解説を見る。
00001 // ReadXMLInfo.h: CReadXMLInfo クラスのインターフェイス
00002 //
00004
00005 #include "stdafx.h"
00006
00007 #if !defined(AFX_READXMLINFO_H__81702906_B32D_4E6C_832B_35307A879ACB__INCLUDED_)
00008 #define AFX_READXMLINFO_H__81702906_B32D_4E6C_832B_35307A879ACB__INCLUDED_
00009
00010 #if _MSC_VER > 1000
00011 #pragma once
00012 #endif // _MSC_VER > 1000
00013
00016 class CReadXML
00017 {
00018 public:
00019
00025     CReadXML::CReadXML()
00026     {
00027     }
00028
00034     CReadXML::~CReadXML()
00035     {
00036     };
00037
00047     HRESULT QueryValue(IXMLDOMNode *pINode, BSTR bstrNodeName, BSTR *pbstrData)
00048     {
00049         IXMLDOMNodePtr pResTagNode;
00050         CComBSTR bstrText;
00051
00052         HRESULT hr = pINode->selectSingleNode(bstrNodeName,&pResTagNode);
00053         if (S_OK != hr) {
00054             return hr;
00055         }
00056         hr = pResTagNode->get_text(&bstrText);
00057         if (S_OK != hr) {
00058             return hr;
00059         }
00060         *pbstrData = bstrText.Copy();
00061         return hr;
00062     }
00063
00064 };
00065
00066 #endif // !defined(AFX_READXMLINFO_H__81702906_B32D_4E6C_832B_35307A879ACB__INCLUDED_)
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


RegKeyEx.h Source File

RegKeyEx.h

解説を見る。
00001
00011 #if !defined(AFX_REGKEYEX_H__796E4BB2_32BB_42C9_BC51_01772E752FED__INCLUDED_)
00012 #define AFX_REGKEYEX_H__796E4BB2_32BB_42C9_BC51_01772E752FED__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00023 class CRegKeyEx  : public CRegKey
00024 {
00025 public:
00026
00032     CRegKeyEx()
00033     {
00034     };
00035
00041     ~CRegKeyEx()
00042     {
00043     };
00044
00070     LONG EnumKeys(DWORD dwIndex, LPTSTR lpName, LPDWORD lpcName)
00071     {
00072         FILETIME ftUpdate;
00073         ATLASSERT(lpcName != NULL);
00074         if (lpName) {
00075             memset((void *)lpName, 0, *lpcName);
00076         }
00077         return RegEnumKeyEx(m_hKey, dwIndex, lpName, lpcName, NULL, NULL, NULL, &ftUpdate);
00078     }
00079
00093     LONG QueryValue(LPTSTR szValue, LPCTSTR lpszValueName, DWORD* pdwCount)
00094     {
00095         ATLASSERT(pdwCount != NULL);
00096         if (szValue) {
00097             memset((void *)szValue, 0, *pdwCount);
00098         }
00099         return CRegKey::QueryValue(szValue, lpszValueName, pdwCount);
00100     }
00101
00116     LONG QueryValue(DWORD& dwValue, LPCTSTR lpszValueName)
00117     {
00118         return CRegKey::QueryValue(dwValue, lpszValueName);
00119     }
00120
00121 };
00122
00123 #endif // !defined(AFX_REGKEYEX_H__796E4BB2_32BB_42C9_BC51_01772E752FED__INCLUDED_)
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


resource.h Source File

resource.h

解説を見る。
00001 //{{NO_DEPENDENCIES}}
00002 // Microsoft Developer Studio generated include file.
00003 // Used by CaoSQL.rc
00004 //
00005 #define IDS_SERVICENAME                 100
00006 #define IDR_CaoSQL                      100
00007 #define IDR_CaoSQLENGINE                101
00008 #define IDR_CaoSQLCONTROLLER            102
00009 #define IDR_CaoSQLITEM                  103
00010 #define IDR_CaoSQLHISTORY               104
00011 #define IDR_RACSERVER                   105
00012 #define IDI_CAOSQL                      204
00013
00014 // Next default values for new objects
00015 //
00016 #ifdef APSTUDIO_INVOKED
00017 #ifndef APSTUDIO_READONLY_SYMBOLS
00018 #define _APS_NEXT_RESOURCE_VALUE        205
00019 #define _APS_NEXT_COMMAND_VALUE         32768
00020 #define _APS_NEXT_CONTROL_VALUE         201
00021 #define _APS_NEXT_SYMED_VALUE           109
00022 #endif
00023 #endif
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


StdAfx.h Source File

StdAfx.h

解説を見る。
00001
00013 #pragma warning (disable: 4786)
00014
00015 #if !defined(AFX_STDAFX_H__0954E884_8A01_4881_A9C7_616986F8647E__INCLUDED_)
00016 #define AFX_STDAFX_H__0954E884_8A01_4881_A9C7_616986F8647E__INCLUDED_
00017
00018 #if _MSC_VER > 1000
00019 #pragma once
00020 #endif // _MSC_VER > 1000
00021
00022 #define STRICT
00023 #ifndef _WIN32_WINNT
00024 #define _WIN32_WINNT 0x0400
00025 #endif
00026 // #define _ATL_APARTMENT_THREADED
00027 #define _ATL_FREE_THREADED
00028 #define SCANTIME(st, en)    ((en < st)? (ULONG_MAX - st + en) : (en - st))
00029 // XML define
00030 #define XPATH_DOC_PROPERTY          L"SelectionNamespaces"
00031 #define XML_VARIDATION              VARIANT_TRUE
00032 #define XML_LOAD_ASYNC              VARIANT_FALSE
00033 // Log String
00034 #define CAOSQL_LOG_MSGBOX           "\r\n\r\nClick [Cancel] to output a message into 'Debug Viewer' after this. "
00035
00036 #import <msxml4.dll> named_guids raw_interfaces_only
00037 //#include "msxml2.h"
00038 using namespace MSXML2;
00039
00040 #include <process.h>
00041 #include <atlbase.h>
00042 #include <limits.h>
00043 #include <comdef.h>
00044
00045 #include "CAO.h"
00046 #include "CaoSQLData.h"
00047 #include "RegKeyEx.h"
00048 #include "ReadXML.h"
00049 #include "LockCriticalSection.h"
00050 #include "CaoSQL.h"
00051 #include "CaoSystem.h"
00052 #include "CAOERROR.h"
00053 #include "RACData.h"
00054
00069 class CServiceModule : public CComModule
00070 {
00071 public:
00072
00078     CServiceModule()
00079     {
00080         memset(m_szServiceName, CSQ_C_NULL_CHAR, sizeof(m_szServiceName));
00081         m_hServiceStatus = NULL;
00082         dwThreadID = 0;
00083         m_bService = FALSE;
00084         memset(m_szLogFile, CSQ_C_NULL_CHAR, FILENAME_MAX);
00085         memset(m_szDataPath, CSQ_C_NULL_CHAR, FILENAME_MAX);
00086
00087         // initialize XML data
00088         m_iProcessPriority = HIGH_PRIORITY_CLASS;
00089         m_dwLogLevel = CAO_LOG_INFO;
00090         m_dwLogType = 2L;
00091         m_lcid = LOCALE_USER_DEFAULT;
00092         m_bDCOMEnabled = TRUE;
00093         m_bDDEEnabled = FALSE;                      // DDE Server : off
00094         m_bNotRepeatError = FALSE;
00095         m_bJNIEnabled = FALSE;
00096         m_bCORBAEnabled = FALSE;
00097         m_bstrCORBAOption = FALSE;
00098         m_bRACSvrEnabled = FALSE;
00099     }
00100
00106     ~CServiceModule()
00107     {
00108     }
00109
00110     HRESULT RegisterServer(BOOL bRegTypeLib, BOOL bService);
00111     HRESULT UnregisterServer();
00112     void Init(_ATL_OBJMAP_ENTRY* p, HINSTANCE h, UINT nServiceNameID, const GUID* plibid = NULL);
00113     void Start();
00114     void ServiceMain(DWORD dwArgc, LPTSTR* lpszArgv);
00115     void Handler(DWORD dwOpcode);
00116     void Run();
00117     BOOL IsInstalled();
00118     BOOL Install();
00119     BOOL Uninstall();
00120     LONG Unlock();
00121     void LogEvent(DWORD dwLevel, LPCTSTR pFormat, ...);
00122     void SetServiceStatus(DWORD dwState);
00123     void SetupAsLocalServer();
00124
00125 // インプリメンテーション
00126 private:
00127     static void WINAPI _ServiceMain(DWORD dwArgc, LPTSTR* lpszArgv);
00128     static void WINAPI _Handler(DWORD dwOpcode);
00129     HRESULT ReadRegInfo();
00130     HRESULT CreateSingletons();
00131
00132 // データ メンバ
00133 public:
00134     // local Variable
00135     TCHAR                   m_szServiceName[256];
00136     TCHAR                   m_szDataPath[FILENAME_MAX];
00137     SERVICE_STATUS_HANDLE   m_hServiceStatus;
00138     SERVICE_STATUS          m_status;
00139     DWORD                   dwThreadID;
00140     BOOL                    m_bService;
00141
00142     // XML data
00143     LCID                    m_lcid;
00144     BOOL                    m_bNotRepeatError;
00145     BOOL                    m_bDCOMEnabled;
00146     BOOL                    m_bDDEEnabled;
00147     BOOL                    m_bJNIEnabled;
00148     BOOL                    m_bCORBAEnabled;
00149     BSTR                    m_bstrCORBAOption;
00150     BOOL                    m_bRACSvrEnabled;
00151
00152 private:
00153     // XML data
00154     int                     m_iProcessPriority;
00155     DWORD                   m_dwLogType;
00156     DWORD                   m_dwLogLevel;
00157     TCHAR                   m_szLogFile[FILENAME_MAX];
00158
00159 };
00160
00161 extern CServiceModule _Module;
00162 extern const int THREAD_PRIORITY[7];
00163 extern const int PROCESS_PRIORITY[4];
00164
00165 #include <atlcom.h>
00166
00167 //{{AFX_INSERT_LOCATION}}
00168 // Microsoft Visual C++ は前行の直前に追加の宣言を挿入します。
00169
00170 #endif // !defined(AFX_STDAFX_H__0954E884_8A01_4881_A9C7_616986F8647E__INCLUDED)
Generated on Tue Dec 13 12:25:23 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_IID メンバ一覧

これは全メンバの一覧です。_IID継承メンバも含んでいます。
c | _IID
s1 | _IID
s2 | _IID
x | _IID
Generated on Tue Dec 13 12:25:33 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_MIDL_PROC_FORMAT_STRING メンバ一覧

これは全メンバの一覧です。_MIDL_PROC_FORMAT_STRING継承メンバも含んでいます。
Format | _MIDL_PROC_FORMAT_STRING
Pad | _MIDL_PROC_FORMAT_STRING
Generated on Tue Dec 13 12:25:33 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_MIDL_TYPE_FORMAT_STRING メンバ一覧

これは全メンバの一覧です。_MIDL_TYPE_FORMAT_STRING継承メンバも含んでいます。
Format | _MIDL_TYPE_FORMAT_STRING
Pad | _MIDL_TYPE_FORMAT_STRING
Generated on Tue Dec 13 12:25:33 2005 for DENSO WAVE CaoSQL Project by doxygen 1.2.18, © 1997-2001