メインページ

RACData Project ドキュメント

1.0

Generated on Wed Jul 21 14:16:35 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


File Index

RACData Project ファイル一覧

これはファイル一覧です。
dlldata.c
dlldatax.c
dlldatax.h [コード]
RACData.cpp
RACData.h [コード]
RACData.idl [コード]
RACData_i.c
RACData_p.c
RacRes.cpp
RacRes.h [コード]
resource.h [コード]
StdAfx.cpp
StdAfx.h [コード]
Generated on Wed Jul 21 14:16:35 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


dlldata.c File Reference

dlldata.c の解説

#include <rpcproxy.h>

dlldata.cのインクルード依存関係図

Include dependency graph

マクロ定義

#define | PROXY_DELEGATION

関数

PROXYFILE_LIST_START | REFERENCE_PROXY_FILE (RACData)

マクロ定義の解説

#define PROXY_DELEGATION

関数の解説

PROXYFILE_LIST_START REFERENCE_PROXY_FILE ( RACData )

Generated on Wed Jul 21 14:16:35 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


dlldatax.c File Reference

dlldatax.c の解説

Generated on Wed Jul 21 14:16:35 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


dlldatax.h File Reference

dlldatax.h の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

マクロ定義

#define AFX_DLLDATAX_H__28211376_F951_4CD6_98F1_123DF7CAB30E__INCLUDED_

マクロ定義の解説

#define AFX_DLLDATAX_H__28211376_F951_4CD6_98F1_123DF7CAB30E__INCLUDED_

Generated on Wed Jul 21 14:16:35 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


RACData.cpp File Reference

RACData.cpp の解説

#include "stdafx.h"
#include "resource.h"
#include <initguid.h>
#include "RACData.h"
#include "dlldatax.h"
#include "RACData_i.c"
#include "RacRes.h"

RACData.cppのインクルード依存関係図

Include dependency graph

関数

BOOL WINAPI | DllMain (HINSTANCE hInstance, DWORD dwReason, LPVOID lpReserved)
STDAPI | DllCanUnloadNow (void)
STDAPI | DllGetClassObject (REFCLSID rclsid, REFIID riid, LPVOID *ppv)
STDAPI | DllRegisterServer (void)
STDAPI | DllUnregisterServer (void)

変数

CComModule | _Module

関数の解説

STDAPI DllCanUnloadNow ( void )

STDAPI DllGetClassObject | ( | REFCLSID | rclsid,
 |  | REFIID | riid,
 |  | LPVOID * | ppv
 | ) |

BOOL WINAPI DllMain | ( | HINSTANCE | hInstance,
 |  | DWORD | dwReason,
 |  | LPVOID | lpReserved
 | ) |

STDAPI DllRegisterServer ( void )

STDAPI DllUnregisterServer ( void )

変数の解説

CComModule _Module

Generated on Wed Jul 21 14:16:35 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


RACData.h File Reference

RACData.h の解説

#include "rpc.h"
#include "rpcndr.h"
#include "windows.h"
#include "ole2.h"
#include "oaidl.h"
#include "ocidl.h"

RACData.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

マクロ定義

#define | __REQUIRED_RPCNDR_H_VERSION__ 440

Typedef

typedef interface IRacRes | IRacRes
typedef RacRes | RacRes

関数

void __RPC_FAR *__RPC_USER | MIDL_user_allocate (size_t)
void __RPC_USER | MIDL_user_free (void __RPC_FAR *)
virtual HRESULT STDMETHODCALLTYPE | BstrFromVariant (VARIANT vntVal, BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | EncodeEscape (BYTE wcEscChar, BSTR bstrSrc, BSTR __RPC_FAR *pbstrDest)=0
virtual HRESULT STDMETHODCALLTYPE | DecodeEscape (BYTE wcEscChar, BSTR bstrSrc, BSTR __RPC_FAR *pbstrDest)=0
HRESULT STDMETHODCALLTYPE | IRacRes_VariantFromBstr_Proxy (IRacRes __RPC_FAR *This, BSTR bstrSrc, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | IRacRes_VariantFromBstr_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRacRes_BstrFromVariant_Proxy (IRacRes __RPC_FAR *This, VARIANT vntVal, BSTR __RPC_FAR *pVal)
void __RPC_STUB | IRacRes_BstrFromVariant_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRacRes_EncodeEscape_Proxy (IRacRes __RPC_FAR *This, BYTE wcEscChar, BSTR bstrSrc, BSTR __RPC_FAR *pbstrDest)
void __RPC_STUB | IRacRes_EncodeEscape_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRacRes_DecodeEscape_Proxy (IRacRes __RPC_FAR *This, BYTE wcEscChar, BSTR bstrSrc, BSTR __RPC_FAR *pbstrDest)
void __RPC_STUB | IRacRes_DecodeEscape_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
class | DECLSPEC_UUID ("1301A84B-FEE3-4EAD-87DD-BF15A7C72E47") RacRes
unsigned long __RPC_USER | BSTR_UserSize (unsigned long __RPC_FAR *, unsigned long, BSTR __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | BSTR_UserMarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | BSTR_UserUnmarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR *)
void __RPC_USER | BSTR_UserFree (unsigned long __RPC_FAR *, BSTR __RPC_FAR *)
unsigned long __RPC_USER | VARIANT_UserSize (unsigned long __RPC_FAR *, unsigned long, VARIANT __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | VARIANT_UserMarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, VARIANT __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | VARIANT_UserUnmarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, VARIANT __RPC_FAR *)
void __RPC_USER | VARIANT_UserFree (unsigned long __RPC_FAR *, VARIANT __RPC_FAR *)

変数

EXTERN_C const IID | IID_IRacRes
IRacRes __pad0__
IRacRes VARIANT __RPC_FAR * | pVal = 0
EXTERN_C const IID | LIBID_RACDATALib
EXTERN_C const CLSID | CLSID_RacRes

マクロ定義の解説

#define __REQUIRED_RPCNDR_H_VERSION__ 440

Typedef の解説

typedef interface IRacRes IRacRes

typedef class RacRes RacRes

関数の解説

void __RPC_USER BSTR_UserFree | ( | unsigned long __RPC_FAR * | ,
 |  | BSTR __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER BSTR_UserMarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | BSTR __RPC_FAR * |
 | ) |

unsigned long __RPC_USER BSTR_UserSize | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned | long,
 |  | BSTR __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER BSTR_UserUnmarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | BSTR __RPC_FAR * |
 | ) |

virtual HRESULT STDMETHODCALLTYPE BstrFromVariant | ( | VARIANT | vntVal,
 |  | BSTR __RPC_FAR * | pVal
 | ) | [pure virtual]

class DECLSPEC_UUID ( "1301A84B-FEE3-4EAD-87DD-BF15A7C72E47" )

virtual HRESULT STDMETHODCALLTYPE DecodeEscape | ( | BYTE | wcEscChar,
 |  | BSTR | bstrSrc,
 |  | BSTR __RPC_FAR * | pbstrDest
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE EncodeEscape | ( | BYTE | wcEscChar,
 |  | BSTR | bstrSrc,
 |  | BSTR __RPC_FAR * | pbstrDest
 | ) | [pure virtual]

HRESULT STDMETHODCALLTYPE IRacRes_BstrFromVariant_Proxy | ( | IRacRes __RPC_FAR * | This,
 |  | VARIANT | vntVal,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRacRes_BstrFromVariant_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRacRes_DecodeEscape_Proxy | ( | IRacRes __RPC_FAR * | This,
 |  | BYTE | wcEscChar,
 |  | BSTR | bstrSrc,
 |  | BSTR __RPC_FAR * | pbstrDest
 | ) |

void __RPC_STUB IRacRes_DecodeEscape_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRacRes_EncodeEscape_Proxy | ( | IRacRes __RPC_FAR * | This,
 |  | BYTE | wcEscChar,
 |  | BSTR | bstrSrc,
 |  | BSTR __RPC_FAR * | pbstrDest
 | ) |

void __RPC_STUB IRacRes_EncodeEscape_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRacRes_VariantFromBstr_Proxy | ( | IRacRes __RPC_FAR * | This,
 |  | BSTR | bstrSrc,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRacRes_VariantFromBstr_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

void __RPC_FAR* __RPC_USER MIDL_user_allocate ( size_t )

void __RPC_USER MIDL_user_free ( void __RPC_FAR * )

void __RPC_USER VARIANT_UserFree | ( | unsigned long __RPC_FAR * | ,
 |  | VARIANT __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER VARIANT_UserMarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | VARIANT __RPC_FAR * |
 | ) |

unsigned long __RPC_USER VARIANT_UserSize | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned | long,
 |  | VARIANT __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER VARIANT_UserUnmarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | VARIANT __RPC_FAR * |
 | ) |

変数の解説

IRacRes __pad0__

EXTERN_C const CLSID CLSID_RacRes

EXTERN_C const IID IID_IRacRes

EXTERN_C const IID LIBID_RACDATALib

IRacRes VARIANT __RPC_FAR* pVal = 0

Generated on Wed Jul 21 14:16:35 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


RACData.idl File Reference

RACData.idl の解説

ソースコードを見る。

名前空間

namespace | RACDATALib

構成

interface | IRacRes

Generated on Wed Jul 21 14:16:35 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


RACData_i.c File Reference

RACData_i.c の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

構成

struct | _IID

Typedef

typedef _IID | IID
typedef IID | CLSID

変数

const IID | IID_IRacRes = {0xC15D94F8,0x21B1,0x4916,{0xAD,0x23,0xB7,0x42,0x74,0x64,0x70,0x3E}}
const IID | LIBID_RACDATALib = {0xF07B82CB,0x337F,0x4DE4,{0xB2,0xB3,0xAC,0xE3,0xED,0xA6,0x0D,0xF6}}
const CLSID | CLSID_RacRes = {0x1301A84B,0xFEE3,0x4EAD,{0x87,0xDD,0xBF,0x15,0xA7,0xC7,0x2E,0x47}}

Typedef の解説

typedef IID CLSID

typedef struct _IID IID

変数の解説

const CLSID CLSID_RacRes = {0x1301A84B,0xFEE3,0x4EAD,{0x87,0xDD,0xBF,0x15,0xA7,0xC7,0x2E,0x47}}

const IID IID_IRacRes = {0xC15D94F8,0x21B1,0x4916,{0xAD,0x23,0xB7,0x42,0x74,0x64,0x70,0x3E}}

const IID LIBID_RACDATALib = {0xF07B82CB,0x337F,0x4DE4,{0xB2,0xB3,0xAC,0xE3,0xED,0xA6,0x0D,0xF6}}

Generated on Wed Jul 21 14:16:35 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


RACData_p.c File Reference

RACData_p.c の解説

#include "rpcproxy.h"
#include "RACData.h"

RACData_p.cのインクルード依存関係図

Include dependency graph

構成

struct | _MIDL_PROC_FORMAT_STRING
struct | _MIDL_TYPE_FORMAT_STRING

マクロ定義

#define | USE_STUBLESS_PROXY
#define | __REQUIRED_RPCPROXY_H_VERSION__ 440
#define | TYPE_FORMAT_STRING_SIZE 1017
#define | PROC_FORMAT_STRING_SIZE 149

Typedef

typedef _MIDL_TYPE_FORMAT_STRING | MIDL_TYPE_FORMAT_STRING
typedef _MIDL_PROC_FORMAT_STRING | MIDL_PROC_FORMAT_STRING

関数

CINTERFACE_PROXY_VTABLE (11) _IRacResProxyVtbl=

変数

const MIDL_TYPE_FORMAT_STRING | __MIDL_TypeFormatString
const MIDL_PROC_FORMAT_STRING | __MIDL_ProcFormatString
const MIDL_STUB_DESC | Object_StubDesc
const MIDL_SERVER_INFO | IRacRes_ServerInfo
const USER_MARSHAL_ROUTINE_QUADRUPLE | UserMarshalRoutines [2]
const unsigned short | IRacRes_FormatStringOffsetTable []
const MIDL_STUBLESS_PROXY_INFO | IRacRes_ProxyInfo

マクロ定義の解説

#define __REQUIRED_RPCPROXY_H_VERSION__ 440

#define PROC_FORMAT_STRING_SIZE 149

#define TYPE_FORMAT_STRING_SIZE 1017

#define USE_STUBLESS_PROXY

Typedef の解説

typedef struct _MIDL_PROC_FORMAT_STRING MIDL_PROC_FORMAT_STRING

typedef struct _MIDL_TYPE_FORMAT_STRING MIDL_TYPE_FORMAT_STRING

関数の解説

CINTERFACE_PROXY_VTABLE ( 11 )

変数の解説

const MIDL_PROC_FORMAT_STRING __MIDL_ProcFormatString

const MIDL_TYPE_FORMAT_STRING __MIDL_TypeFormatString

const unsigned short IRacRes_FormatStringOffsetTable[] [static]

初期値:

    {
    (unsigned short) -1,
    (unsigned short) -1,
    (unsigned short) -1,
    (unsigned short) -1,
    0,
    34,
    68,
    108
    }

const MIDL_STUBLESS_PROXY_INFO IRacRes_ProxyInfo [static]

初期値:

    {
    &Object_StubDesc,
    __MIDL_ProcFormatString.Format,
    &IRacRes_FormatStringOffsetTable[-3],
    0,
    0,
    0
    }

const MIDL_SERVER_INFO IRacRes_ServerInfo

初期値:

    {
    &Object_StubDesc,
    0,
    __MIDL_ProcFormatString.Format,
    &IRacRes_FormatStringOffsetTable[-3],
    0,
    0,
    0,
    0
    }

const MIDL_STUB_DESC Object_StubDesc

初期値:

    {
    0,
    NdrOleAllocate,
    NdrOleFree,
    0,
    0,
    0,
    0,
    0,
    __MIDL_TypeFormatString.Format,
    1,
    0x20000,
    0,
    0x50100a4,
    0,
    UserMarshalRoutines,
    0,
    1,
    0,
    0,
    0
    }

const USER_MARSHAL_ROUTINE_QUADRUPLE UserMarshalRoutines[2]

Generated on Wed Jul 21 14:16:36 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


RacRes.cpp File Reference

RacRes.cpp の解説

#include "stdafx.h"
#include "RACData.h"
#include "RacRes.h"

RacRes.cppのインクルード依存関係図

Include dependency graph
Generated on Wed Jul 21 14:16:36 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


RacRes.h File Reference

RacRes.h の解説

#include "resource.h"

RacRes.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CRacRes


resource.h File Reference

resource.h の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

マクロ定義

#define | IDS_PROJNAME 100
#define | IDR_RACRES 101

マクロ定義の解説

#define IDR_RACRES 101

#define IDS_PROJNAME 100

Generated on Wed Jul 21 14:16:36 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


StdAfx.cpp File Reference

StdAfx.cpp の解説

#include "stdafx.h"
#include <atlimpl.cpp>

StdAfx.cppのインクルード依存関係図

Include dependency graph
Generated on Wed Jul 21 14:16:36 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


StdAfx.h File Reference

StdAfx.h の解説

#include <atlbase.h>
#include <atlcom.h>

StdAfx.hのインクルード依存関係図

Include dependency graph

ソースコードを見る。

マクロ定義

#define | AFX_STDAFX_H__31F6E6CB_9E01_41EA_83B0_53805D5E2E99__INCLUDED_
#define | STRICT
#define | _WIN32_WINNT 0x0400
#define | _ATL_APARTMENT_THREADED

変数

CComModule | _Module

マクロ定義の解説

#define _ATL_APARTMENT_THREADED

#define _WIN32_WINNT 0x0400

#define AFX_STDAFX_H__31F6E6CB_9E01_41EA_83B0_53805D5E2E99__INCLUDED_

#define STRICT

変数の解説

CComModule _Module

Generated on Wed Jul 21 14:16:36 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


Annotated Index

RACData Project 構成

クラス、構造体、共用体、インタフェースの解説です。
_IID
_MIDL_PROC_FORMAT_STRING
_MIDL_TYPE_FORMAT_STRING
CRacRes
IRacRes
RACDATALib::RacRes
Generated on Wed Jul 21 14:16:36 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


_IID struct Reference

構造体 _IID の解説

すべてのメンバ一覧

Public 変数

unsigned long | x
unsigned short | s1
unsigned short | s2
unsigned char | c [8]

変数の解説

unsigned char _IID::c[8]

unsigned short _IID::s1

unsigned short _IID::s2

unsigned long _IID::x

この構造体の解説は次のファイルから生成されました:
  • RACData_i.c


_MIDL_PROC_FORMAT_STRING struct Reference

構造体 _MIDL_PROC_FORMAT_STRING の解説

すべてのメンバ一覧

Public 変数

short | Pad
unsigned char | Format [PROC_FORMAT_STRING_SIZE]

変数の解説

unsigned char _MIDL_PROC_FORMAT_STRING::Format[ PROC_FORMAT_STRING_SIZE ]

short _MIDL_PROC_FORMAT_STRING::Pad

この構造体の解説は次のファイルから生成されました:
  • RACData_p.c


_MIDL_TYPE_FORMAT_STRING struct Reference

構造体 _MIDL_TYPE_FORMAT_STRING の解説

すべてのメンバ一覧

Public 変数

short | Pad
unsigned char | Format [TYPE_FORMAT_STRING_SIZE]

変数の解説

unsigned char _MIDL_TYPE_FORMAT_STRING::Format[ TYPE_FORMAT_STRING_SIZE ]

short _MIDL_TYPE_FORMAT_STRING::Pad

この構造体の解説は次のファイルから生成されました:
  • RACData_p.c


CRacRes class Reference

クラス CRacRes の解説

#include <RacRes.h>

すべてのメンバ一覧

Public メソッド

CRacRes ()
HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
HRESULT | EncodeEscape (BYTE wcEscChar, BSTR bstrSrc, BSTR *pbstrDest)
文字列エンコード

HRESULT | DecodeEscape (BYTE wcEscChar, BSTR bstrSrc, BSTR *pbstrDest)
文字列デコード

HRESULT | BstrFromVariant (VARIANT varVal, BSTR *pVal)
データ変換(VARIAN -> BSTR)

HRESULT | VariantFromBstr (BSTR bstrSrc, VARIANT *pVal)
データ変換(BSTR -> VARIANT)

コンストラクタとデストラクタの解説

CRacRes::CRacRes ( ) [inline]

メソッドの解説

STDMETHODIMP CRacRes::BstrFromVariant | ( | VARIANT | vntVal,
 |  | BSTR * | pVal
 | ) |

データ変換(VARIAN -> BSTR)

  VARIANTをBSTRに変換する。
  配列は"データ型,データ1,データ2,データ3,･･･"のようにカンマを区切りとする。 配列は１次元配列のみ変換できる。 　データの変換はVariantChangeTypeで変換できる型のみ可能です。

引数:
vntVal | : [in] 変換前文字列"<データ型>,<データ>"
pVal | : [out] 変換後データ
戻り値:
HRESULT

STDMETHODIMP CRacRes::DecodeEscape | ( | BYTE | wcEscChar,
 |  | BSTR | bstrSrc,
 |  | BSTR * | bstrDest
 | ) |

文字列デコード

  「+」は半角スペースに変換する。
  「指定したエスケープ文字+16進数2桁の文字コード」は文字コードに対応する文字に変換する。

引数:
wcEscChar | : [in] エスケープ文字
bstrSrc | : [in] 変換前文字列
bstrDest | : [out] 変換後文字列
戻り値:
HRESULT

STDMETHODIMP CRacRes::EncodeEscape | ( | BYTE | wcEscChar,
 |  | BSTR | bstrSrc,
 |  | BSTR * | pbstrDest
 | ) |

文字列エンコード

  １バイトの英文字 (A-Z、a-z、0-9) と記号の一部 (*-.@_) は変換しない。
  半角スペースは「+」に変換する。
  その他の文字は「指定したエスケープ文字+16進数2桁の文字コード」に変換する。

引数:
wcEscChar | : [in] エスケープ文字
bstrSrc | : [in] 変換前文字列
pbstrDest | : [out] 変換後文字列
戻り値:
HRESULT

STDMETHODIMP CRacRes::InterfaceSupportsErrorInfo ( REFIID riid )

STDMETHODIMP CRacRes::VariantFromBstr | ( | BSTR | bstrSrc,
 |  | VARIANT * | pVal
 | ) |

データ変換(BSTR -> VARIANT)

  BSTR型を指定した型のVARIANTに変換する。
  配列は"データ1,データ2,データ3,･･･"のようにカンマを区切りとする。 　データの変換はVariantChangeTypeで変換できる型のみ可能です。

引数:
bstrSrc | : [in] 変換前文字列
pVal | : [out] 変換後データ
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • RacRes.h
  • RacRes.cpp


IRacRes interface Reference

インタフェースIRacRes の解説

import "RACData.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | VariantFromBstr ([in] BSTR bstrSrc,[out, retval] VARIANT *pVal)
HRESULT | BstrFromVariant ([in] VARIANT vntVal,[out, retval] BSTR *pVal)
HRESULT | EncodeEscape ([in] BYTE wcEscChar,[in] BSTR bstrSrc,[out, retval]BSTR *pbstrDest)
HRESULT | DecodeEscape ([in] BYTE wcEscChar,[in] BSTR bstrSrc,[out, retval]BSTR *pbstrDest)

メソッドの解説

HRESULT IRacRes::BstrFromVariant | ( | [in] VARIANT | vntVal,
 |  | [out, retval] BSTR * | pVal
 | ) |

HRESULT IRacRes::DecodeEscape | ( | [in] BYTE | wcEscChar,
 |  | [in] BSTR | bstrSrc,
 |  | [out, retval] BSTR * | pbstrDest
 | ) |

HRESULT IRacRes::EncodeEscape | ( | [in] BYTE | wcEscChar,
 |  | [in] BSTR | bstrSrc,
 |  | [out, retval] BSTR * | pbstrDest
 | ) |

HRESULT IRacRes::VariantFromBstr | ( | [in] BSTR | bstrSrc,
 |  | [out, retval] VARIANT * | pVal
 | ) |

このインタフェースの解説は次のファイルから生成されました:
  • RACData.idl


RACDATALib::RacRes class Reference

クラス RACDATALib::RacRes の解説

import "RACData.idl";

このクラスの解説は次のファイルから生成されました:
  • RACData.idl


Compound Member Index

RACData Project 構成メンバ

これはクラスメンバの一覧で、それぞれが属しているクラスの解説へリンクしています。
  • BstrFromVariant() : CRacRes, IRacRes
  • c : _IID
  • CRacRes() : CRacRes
  • DecodeEscape() : CRacRes, IRacRes
  • EncodeEscape() : CRacRes, IRacRes
  • Format : _MIDL_PROC_FORMAT_STRING, _MIDL_TYPE_FORMAT_STRING
  • InterfaceSupportsErrorInfo() : CRacRes
  • Pad : _MIDL_PROC_FORMAT_STRING, _MIDL_TYPE_FORMAT_STRING
  • s1 : _IID
  • s2 : _IID
  • VariantFromBstr() : CRacRes, IRacRes
  • x : _IID


Namespace Index

RACData Project 名前空間一覧

名前空間の一覧です。
RACDATALib
Generated on Wed Jul 21 14:16:36 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


RACDATALib Namespace Reference

名前空間 RACDATALib の解説

構成

class RacRes

関数

importlib ("stdole32.tlb")
importlib ("stdole2.tlb")

関数の解説

importlib ( "stdole2.tlb" )

importlib ( "stdole32.tlb" )


File Member Index

RACData Project ファイルメンバ

これはファイルメンバの一覧です。それぞれが属しているファイルの解説へリンクしています。
  • __MIDL_ProcFormatString : RACData_p.c
  • __MIDL_TypeFormatString : RACData_p.c
  • __pad0__ : RACData.h
  • __REQUIRED_RPCNDR_H_VERSION__ : RACData.h
  • __REQUIRED_RPCPROXY_H_VERSION__ : RACData_p.c
  • _ATL_APARTMENT_THREADED : StdAfx.h
  • _Module : StdAfx.h, RACData.cpp
  • _WIN32_WINNT : StdAfx.h
  • AFX_DLLDATAX_H__28211376_F951_4CD6_98F1_123DF7CAB30E__INCLUDED_ : dlldatax.h
  • AFX_STDAFX_H__31F6E6CB_9E01_41EA_83B0_53805D5E2E99__INCLUDED_ : StdAfx.h
  • BSTR_UserFree() : RACData.h
  • BSTR_UserMarshal() : RACData.h
  • BSTR_UserSize() : RACData.h
  • BSTR_UserUnmarshal() : RACData.h
  • BstrFromVariant() : RACData.h
  • CINTERFACE_PROXY_VTABLE() : RACData_p.c
  • CLSID : RACData_i.c
  • CLSID_RacRes : RACData_i.c, RACData.h
  • DECLSPEC_UUID() : RACData.h
  • DecodeEscape() : RACData.h
  • DllCanUnloadNow() : RACData.cpp
  • DllGetClassObject() : RACData.cpp
  • DllMain() : RACData.cpp
  • DllRegisterServer() : RACData.cpp
  • DllUnregisterServer() : RACData.cpp
  • EncodeEscape() : RACData.h
  • IDR_RACRES : resource.h
  • IDS_PROJNAME : resource.h
  • IID : RACData_i.c
  • IID_IRacRes : RACData_i.c, RACData.h
  • IRacRes : RACData.h
  • IRacRes_BstrFromVariant_Proxy() : RACData.h
  • IRacRes_BstrFromVariant_Stub() : RACData.h
  • IRacRes_DecodeEscape_Proxy() : RACData.h
  • IRacRes_DecodeEscape_Stub() : RACData.h
  • IRacRes_EncodeEscape_Proxy() : RACData.h
  • IRacRes_EncodeEscape_Stub() : RACData.h
  • IRacRes_FormatStringOffsetTable : RACData_p.c
  • IRacRes_ProxyInfo : RACData_p.c
  • IRacRes_ServerInfo : RACData_p.c
  • IRacRes_VariantFromBstr_Proxy() : RACData.h
  • IRacRes_VariantFromBstr_Stub() : RACData.h
  • LIBID_RACDATALib : RACData_i.c, RACData.h
  • MIDL_PROC_FORMAT_STRING : RACData_p.c
  • MIDL_TYPE_FORMAT_STRING : RACData_p.c
  • MIDL_user_allocate() : RACData.h
  • MIDL_user_free() : RACData.h
  • Object_StubDesc : RACData_p.c
  • PROC_FORMAT_STRING_SIZE : RACData_p.c
  • PROXY_DELEGATION : dlldata.c
  • pVal : RACData.h
  • RacRes : RACData.h
  • REFERENCE_PROXY_FILE() : dlldata.c
  • STRICT : StdAfx.h
  • TYPE_FORMAT_STRING_SIZE : RACData_p.c
  • USE_STUBLESS_PROXY : RACData_p.c
  • UserMarshalRoutines : RACData_p.c
  • VARIANT_UserFree() : RACData.h
  • VARIANT_UserMarshal() : RACData.h
  • VARIANT_UserSize() : RACData.h
  • VARIANT_UserUnmarshal() : RACData.h


Namespace Member Index

RACData Project 名前空間メンバ

これは名前空間の一覧です。それぞれの名前空間の解説へリンクしています。
  • importlib() : RACDATALib


メンバ一覧

CRacRes メンバ一覧

これは全メンバの一覧です。CRacRes継承メンバも含んでいます。
BstrFromVariant(VARIANT varVal, BSTR *pVal) | CRacRes |
CRacRes() | CRacRes | [inline]
DecodeEscape(BYTE wcEscChar, BSTR bstrSrc, BSTR *pbstrDest) | CRacRes |
EncodeEscape(BYTE wcEscChar, BSTR bstrSrc, BSTR *pbstrDest) | CRacRes |
InterfaceSupportsErrorInfo(REFIID riid) | CRacRes |
VariantFromBstr(BSTR bstrSrc, VARIANT *pVal) | CRacRes |


dlldatax.h Source File

dlldatax.h

解説を見る。
00001 #if !defined(AFX_DLLDATAX_H__28211376_F951_4CD6_98F1_123DF7CAB30E__INCLUDED_)
00002 #define AFX_DLLDATAX_H__28211376_F951_4CD6_98F1_123DF7CAB30E__INCLUDED_
00003
00004 #if _MSC_VER > 1000
00005 #pragma once
00006 #endif // _MSC_VER > 1000
00007
00008 #ifdef _MERGE_PROXYSTUB
00009
00010 extern "C"
00011 {
00012 BOOL WINAPI PrxDllMain(HINSTANCE hInstance, DWORD dwReason,
00013     LPVOID lpReserved);
00014 STDAPI PrxDllCanUnloadNow(void);
00015 STDAPI PrxDllGetClassObject(REFCLSID rclsid, REFIID riid, LPVOID* ppv);
00016 STDAPI PrxDllRegisterServer(void);
00017 STDAPI PrxDllUnregisterServer(void);
00018 }
00019
00020 #endif
00021
00022 //{{AFX_INSERT_LOCATION}}
00023 // Microsoft Visual C++ は前行の直前に追加の宣言を挿入します。
00024
00025 #endif // !defined(AFX_DLLDATAX_H__28211376_F951_4CD6_98F1_123DF7CAB30E__INCLUDED_)
Generated on Wed Jul 21 14:16:35 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


Graph Legend

グラフの凡例

このページでは、doxygen で生成されたグラフをどのようにみたらよいかを説明します。

次の例を考えてみます。

/*! 省略されて見えないクラス */
class Invisible { };

/*! 省略されたクラス(継承関係は隠されている) */
class Truncated : public Invisible { };

/* doxygen コメントによるドキュメントがないクラス */
class Undocumented { };

/*! public で継承されたクラス */
class PublicBase : public Truncated { };

/*! protected で継承されたクラス */
class ProtectedBase { };

/*! private で継承されたクラス */
class PrivateBase { };

/*! 継承されたクラスで使われているクラス */
class Used { };

/*! 複数のクラスを継承している上位クラス */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
{
  private:
    Used *m_usedClass;
};
設定ファイル中で、タグ MAX_DOT_GRAPH_HEIGHT が 200 にセットされた場合、次のようなグラフとなります。

上のグラフ内のボックスには次のような意味があります。

  • 黒く塗りつぶされたボックスは、このグラフに対応する構造体やクラスを表します。
  • 黒枠のボックスはドキュメントがある構造体やクラスを表します。
  • 灰色の枠のボックスはドキュメントがない構造体やクラスを表します。
  • 赤枠のボックスはドキュメントがある構造体やクラスを表しますが、指定されたサイズに収まらないために継承・包含関係をすべて図示することができなかったことを示します。
矢印には次のような意味があります。
  • 青い矢印は二つのクラス間の public 継承関係を示します。
  • 緑の矢印は protected 継承関係を示します。
  • 赤の矢印は private 継承関係を示します。
  • 紫の破線矢印は、そのクラスが他のクラスに含まれていたり、利用されていることを示します。また、矢印が指しているクラスや構造体をどの変数でアクセスできるかを矢印のラベルとして示しています。


メンバ一覧

IRacRes メンバ一覧

これは全メンバの一覧です。IRacRes継承メンバも含んでいます。
BstrFromVariant([in] VARIANT vntVal,[out, retval] BSTR *pVal) | IRacRes
DecodeEscape([in] BYTE wcEscChar,[in] BSTR bstrSrc,[out, retval]BSTR *pbstrDest) | IRacRes
EncodeEscape([in] BYTE wcEscChar,[in] BSTR bstrSrc,[out, retval]BSTR *pbstrDest) | IRacRes
VariantFromBstr([in] BSTR bstrSrc,[out, retval] VARIANT *pVal) | IRacRes


RACData.h Source File

RACData.h

解説を見る。
00001 /* this ALWAYS GENERATED file contains the definitions for the interfaces */
00002
00003
00004 /* File created by MIDL compiler version 5.01.0164 */
00005 /* at Wed Jul 21 12:56:23 2004
00006  */
00007 /* Compiler settings for D:\ORiN2\CAO\ProviderLib\RAC\RACData\Src\RACData.idl:
00008     Oicf (OptLev=i2), W1, Zp8, env=Win32, ms_ext, c_ext
00009     error checks: allocation ref bounds_check enum stub_data
00010 */
00011 //@@MIDL_FILE_HEADING(  )
00012
00013
00014 /* verify that the <rpcndr.h> version is high enough to compile this file*/
00015 #ifndef __REQUIRED_RPCNDR_H_VERSION__
00016 #define __REQUIRED_RPCNDR_H_VERSION__ 440
00017 #endif
00018
00019 #include "rpc.h"
00020 #include "rpcndr.h"
00021
00022 #ifndef __RPCNDR_H_VERSION__
00023 #error this stub requires an updated version of <rpcndr.h>
00024 #endif // __RPCNDR_H_VERSION__
00025
00026 #ifndef COM_NO_WINDOWS_H
00027 #include "windows.h"
00028 #include "ole2.h"
00029 #endif /*COM_NO_WINDOWS_H*/
00030
00031 #ifndef __RACData_h__
00032 #define __RACData_h__
00033
00034 #ifdef __cplusplus
00035 extern "C"{
00036 #endif
00037
00038 /* Forward Declarations */
00039
00040 #ifndef __IRacRes_FWD_DEFINED__
00041 #define __IRacRes_FWD_DEFINED__
00042 typedef interface IRacRes IRacRes;
00043 #endif  /* __IRacRes_FWD_DEFINED__ */
00044
00045
00046 #ifndef __RacRes_FWD_DEFINED__
00047 #define __RacRes_FWD_DEFINED__
00048
00049 #ifdef __cplusplus
00050 typedef class RacRes RacRes;
00051 #else
00052 typedef struct RacRes RacRes;
00053 #endif /* __cplusplus */
00054
00055 #endif  /* __RacRes_FWD_DEFINED__ */
00056
00057
00058 /* header files for imported files */
00059 #include "oaidl.h"
00060 #include "ocidl.h"
00061
00062 void __RPC_FAR * __RPC_USER MIDL_user_allocate(size_t);
00063 void __RPC_USER MIDL_user_free( void __RPC_FAR * );
00064
00065 #ifndef __IRacRes_INTERFACE_DEFINED__
00066 #define __IRacRes_INTERFACE_DEFINED__
00067
00068 /* interface IRacRes */
00069 /* [unique][helpstring][dual][uuid][object] */
00070
00071
00072 EXTERN_C const IID IID_IRacRes;
00073
00074 #if defined(__cplusplus) && !defined(CINTERFACE)
00075
00076     MIDL_INTERFACE("C15D94F8-21B1-4916-AD23-B7427464703E")
00077     IRacRes : public IDispatch
00078     {
00079     public:
00080         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE VariantFromBstr(
00081             /* [in] */ BSTR bstrSrc,
00082             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
00083
00084         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE BstrFromVariant(
00085             /* [in] */ VARIANT vntVal,
00086             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
00087
00088         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE EncodeEscape(
00089             /* [in] */ BYTE wcEscChar,
00090             /* [in] */ BSTR bstrSrc,
00091             /* [retval][out] */ BSTR __RPC_FAR *pbstrDest) = 0;
00092
00093         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE DecodeEscape(
00094             /* [in] */ BYTE wcEscChar,
00095             /* [in] */ BSTR bstrSrc,
00096             /* [retval][out] */ BSTR __RPC_FAR *pbstrDest) = 0;
00097
00098     };
00099
00100 #else   /* C style interface */
00101
00102     typedef struct IRacResVtbl
00103     {
00104         BEGIN_INTERFACE
00105
00106         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
00107             IRacRes __RPC_FAR * This,
00108             /* [in] */ REFIID riid,
00109             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
00110
00111         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
00112             IRacRes __RPC_FAR * This);
00113
00114         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
00115             IRacRes __RPC_FAR * This);
00116
00117         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
00118             IRacRes __RPC_FAR * This,
00119             /* [out] */ UINT __RPC_FAR *pctinfo);
00120
00121         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
00122             IRacRes __RPC_FAR * This,
00123             /* [in] */ UINT iTInfo,
00124             /* [in] */ LCID lcid,
00125             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
00126
00127         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
00128             IRacRes __RPC_FAR * This,
00129             /* [in] */ REFIID riid,
00130             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
00131             /* [in] */ UINT cNames,
00132             /* [in] */ LCID lcid,
00133             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
00134
00135         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
00136             IRacRes __RPC_FAR * This,
00137             /* [in] */ DISPID dispIdMember,
00138             /* [in] */ REFIID riid,
00139             /* [in] */ LCID lcid,
00140             /* [in] */ WORD wFlags,
00141             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
00142             /* [out] */ VARIANT __RPC_FAR *pVarResult,
00143             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
00144             /* [out] */ UINT __RPC_FAR *puArgErr);
00145
00146         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *VariantFromBstr )(
00147             IRacRes __RPC_FAR * This,
00148             /* [in] */ BSTR bstrSrc,
00149             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
00150
00151         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *BstrFromVariant )(
00152             IRacRes __RPC_FAR * This,
00153             /* [in] */ VARIANT vntVal,
00154             /* [retval][out] */ BSTR __RPC_FAR *pVal);
00155
00156         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *EncodeEscape )(
00157             IRacRes __RPC_FAR * This,
00158             /* [in] */ BYTE wcEscChar,
00159             /* [in] */ BSTR bstrSrc,
00160             /* [retval][out] */ BSTR __RPC_FAR *pbstrDest);
00161
00162         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *DecodeEscape )(
00163             IRacRes __RPC_FAR * This,
00164             /* [in] */ BYTE wcEscChar,
00165             /* [in] */ BSTR bstrSrc,
00166             /* [retval][out] */ BSTR __RPC_FAR *pbstrDest);
00167
00168         END_INTERFACE
00169     } IRacResVtbl;
00170
00171     interface IRacRes
00172     {
00173         CONST_VTBL struct IRacResVtbl __RPC_FAR *lpVtbl;
00174     };
00175
00176
00177
00178 #ifdef COBJMACROS
00179
00180
00181 #define IRacRes_QueryInterface(This,riid,ppvObject) \
00182     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
00183
00184 #define IRacRes_AddRef(This)    \
00185     (This)->lpVtbl -> AddRef(This)
00186
00187 #define IRacRes_Release(This)   \
00188     (This)->lpVtbl -> Release(This)
00189
00190
00191 #define IRacRes_GetTypeInfoCount(This,pctinfo)  \
00192     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
00193
00194 #define IRacRes_GetTypeInfo(This,iTInfo,lcid,ppTInfo)   \
00195     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
00196
00197 #define IRacRes_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId) \
00198     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
00199
00200 #define IRacRes_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)   \
00201     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
00202
00203
00204 #define IRacRes_VariantFromBstr(This,bstrSrc,pVal)  \
00205     (This)->lpVtbl -> VariantFromBstr(This,bstrSrc,pVal)
00206
00207 #define IRacRes_BstrFromVariant(This,vntVal,pVal)   \
00208     (This)->lpVtbl -> BstrFromVariant(This,vntVal,pVal)
00209
00210 #define IRacRes_EncodeEscape(This,wcEscChar,bstrSrc,pbstrDest)  \
00211     (This)->lpVtbl -> EncodeEscape(This,wcEscChar,bstrSrc,pbstrDest)
00212
00213 #define IRacRes_DecodeEscape(This,wcEscChar,bstrSrc,pbstrDest)  \
00214     (This)->lpVtbl -> DecodeEscape(This,wcEscChar,bstrSrc,pbstrDest)
00215
00216 #endif /* COBJMACROS */
00217
00218
00219 #endif  /* C style interface */
00220
00221
00222
00223 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE IRacRes_VariantFromBstr_Proxy(
00224     IRacRes __RPC_FAR * This,
00225     /* [in] */ BSTR bstrSrc,
00226     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
00227
00228
00229 void __RPC_STUB IRacRes_VariantFromBstr_Stub(
00230     IRpcStubBuffer *This,
00231     IRpcChannelBuffer *_pRpcChannelBuffer,
00232     PRPC_MESSAGE _pRpcMessage,
00233     DWORD *_pdwStubPhase);
00234
00235
00236 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE IRacRes_BstrFromVariant_Proxy(
00237     IRacRes __RPC_FAR * This,
00238     /* [in] */ VARIANT vntVal,
00239     /* [retval][out] */ BSTR __RPC_FAR *pVal);
00240
00241
00242 void __RPC_STUB IRacRes_BstrFromVariant_Stub(
00243     IRpcStubBuffer *This,
00244     IRpcChannelBuffer *_pRpcChannelBuffer,
00245     PRPC_MESSAGE _pRpcMessage,
00246     DWORD *_pdwStubPhase);
00247
00248
00249 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE IRacRes_EncodeEscape_Proxy(
00250     IRacRes __RPC_FAR * This,
00251     /* [in] */ BYTE wcEscChar,
00252     /* [in] */ BSTR bstrSrc,
00253     /* [retval][out] */ BSTR __RPC_FAR *pbstrDest);
00254
00255
00256 void __RPC_STUB IRacRes_EncodeEscape_Stub(
00257     IRpcStubBuffer *This,
00258     IRpcChannelBuffer *_pRpcChannelBuffer,
00259     PRPC_MESSAGE _pRpcMessage,
00260     DWORD *_pdwStubPhase);
00261
00262
00263 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE IRacRes_DecodeEscape_Proxy(
00264     IRacRes __RPC_FAR * This,
00265     /* [in] */ BYTE wcEscChar,
00266     /* [in] */ BSTR bstrSrc,
00267     /* [retval][out] */ BSTR __RPC_FAR *pbstrDest);
00268
00269
00270 void __RPC_STUB IRacRes_DecodeEscape_Stub(
00271     IRpcStubBuffer *This,
00272     IRpcChannelBuffer *_pRpcChannelBuffer,
00273     PRPC_MESSAGE _pRpcMessage,
00274     DWORD *_pdwStubPhase);
00275
00276
00277
00278 #endif  /* __IRacRes_INTERFACE_DEFINED__ */
00279
00280
00281
00282 #ifndef __RACDATALib_LIBRARY_DEFINED__
00283 #define __RACDATALib_LIBRARY_DEFINED__
00284
00285 /* library RACDATALib */
00286 /* [helpstring][version][uuid] */
00287
00288
00289 EXTERN_C const IID LIBID_RACDATALib;
00290
00291 EXTERN_C const CLSID CLSID_RacRes;
00292
00293 #ifdef __cplusplus
00294
00295 class DECLSPEC_UUID("1301A84B-FEE3-4EAD-87DD-BF15A7C72E47")
00296 RacRes;
00297 #endif
00298 #endif /* __RACDATALib_LIBRARY_DEFINED__ */
00299
00300 /* Additional Prototypes for ALL interfaces */
00301
00302 unsigned long             __RPC_USER  BSTR_UserSize(     unsigned long __RPC_FAR *, unsigned long            , BSTR __RPC_FAR * );
00303 unsigned char __RPC_FAR * __RPC_USER  BSTR_UserMarshal(  unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR * );
00304 unsigned char __RPC_FAR * __RPC_USER  BSTR_UserUnmarshal(unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR * );
00305 void                      __RPC_USER  BSTR_UserFree(     unsigned long __RPC_FAR *, BSTR __RPC_FAR * );
00306
00307 unsigned long             __RPC_USER  VARIANT_UserSize(     unsigned long __RPC_FAR *, unsigned long            , VARIANT __RPC_FAR * );
00308 unsigned char __RPC_FAR * __RPC_USER  VARIANT_UserMarshal(  unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, VARIANT __RPC_FAR * );
00309 unsigned char __RPC_FAR * __RPC_USER  VARIANT_UserUnmarshal(unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, VARIANT __RPC_FAR * );
00310 void                      __RPC_USER  VARIANT_UserFree(     unsigned long __RPC_FAR *, VARIANT __RPC_FAR * );
00311
00312 /* end of Additional Prototypes */
00313
00314 #ifdef __cplusplus
00315 }
00316 #endif
00317
00318 #endif
Generated on Wed Jul 21 14:16:35 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


RACData.idl Source File

RACData.idl

解説を見る。
00001 // RACData.idl : RACData.dll 用の IDL ソース ファイル
00002 //
00003
00004 // このファイルはタイプ ライブラリ (RACData.tlb) を作成するために
00005 // タイプ ライブラリ作成ツール MIDL によって処理されます。
00006
00007 import "oaidl.idl";
00008 import "ocidl.idl";
00009     [
00010         object,
00011         uuid(C15D94F8-21B1-4916-AD23-B7427464703E),
00012         dual,
00013         helpstring("IRacRes Interface"),
00014         pointer_default(unique)
00015     ]
00016     interface IRacRes : IDispatch
00017     {
00018         [id(1), helpstring("ﾒｿｯﾄﾞ VariantFromBstr")] HRESULT VariantFromBstr([in] BSTR bstrSrc, [out, retval] VARIANT *pVal);
00019         [id(2), helpstring("ﾒｿｯﾄﾞ BstrFromVariant")] HRESULT BstrFromVariant([in] VARIANT vntVal, [out, retval] BSTR *pVal);
00020         [id(3), helpstring("ﾒｿｯﾄﾞ EncodeEscape")] HRESULT EncodeEscape([in] BYTE wcEscChar, [in] BSTR bstrSrc, [out, retval]BSTR *pbstrDest);
00021         [id(4), helpstring("ﾒｿｯﾄﾞ DecodeEscape")] HRESULT DecodeEscape([in] BYTE wcEscChar, [in] BSTR bstrSrc, [out, retval]BSTR *pbstrDest);
00022     };
00023
00024 [
00025     uuid(F07B82CB-337F-4DE4-B2B3-ACE3EDA60DF6),
00026     version(1.0),
00027     helpstring("RACData 1.0 ﾀｲﾌﾟ ﾗｲﾌﾞﾗﾘ")
00028 ]
00029 library RACDATALib
00030 {
00031     importlib("stdole32.tlb");
00032     importlib("stdole2.tlb");
00033
00034     [
00035         uuid(1301A84B-FEE3-4EAD-87DD-BF15A7C72E47),
00036         helpstring("RacRes Class")
00037     ]
00038     coclass RacRes
00039     {
00040         [default] interface IRacRes;
00041     };
00042 };
Generated on Wed Jul 21 14:16:35 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


RacRes.h Source File

RacRes.h

解説を見る。
00001 // RacRes.h : CRacRes の宣言
00002
00003 #ifndef __RACRES_H_
00004 #define __RACRES_H_
00005
00006 #include "resource.h"       // メイン シンボル
00007
00009 // CRacRes
00010 class ATL_NO_VTABLE CRacRes :
00011     public CComObjectRootEx<CComMultiThreadModel>,
00012     public CComCoClass<CRacRes, &CLSID_RacRes>,
00013     public ISupportErrorInfo,
00014     public IDispatchImpl<IRacRes, &IID_IRacRes, &LIBID_RACDATALib>
00015 {
00016 public:
00017     CRacRes()
00018     {
00019     }
00020
00021 DECLARE_REGISTRY_RESOURCEID(IDR_RACRES)
00022
00023 DECLARE_PROTECT_FINAL_CONSTRUCT()
00024
00025 BEGIN_COM_MAP(CRacRes)
00026     COM_INTERFACE_ENTRY(IRacRes)
00027     COM_INTERFACE_ENTRY(IDispatch)
00028     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00029 END_COM_MAP()
00030
00031 // ISupportsErrorInfo
00032     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00033
00034 // IRacRes
00035 public:
00036     STDMETHOD(EncodeEscape)(/*[in]*/ BYTE wcEscChar, /*[in]*/ BSTR bstrSrc, /*[out, retval]*/BSTR *pbstrDest);
00037     STDMETHOD(DecodeEscape)(/*[in]*/ BYTE wcEscChar, /*[in]*/ BSTR bstrSrc, /*[out, retval]*/BSTR *pbstrDest);
00038     STDMETHOD(BstrFromVariant)(/*[in]*/ VARIANT varVal, /*[out, retval]*/ BSTR *pVal);
00039     STDMETHOD(VariantFromBstr)(/*[in]*/ BSTR bstrSrc, /*[out, retval]*/ VARIANT *pVal);
00040 };
00041
00042 #endif //__RACRES_H_
Generated on Wed Jul 21 14:16:35 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


resource.h Source File

resource.h

解説を見る。
00001 //{{NO_DEPENDENCIES}}
00002 // Microsoft Developer Studio generated include file.
00003 // Used by RACData.rc
00004 //
00005 #define IDS_PROJNAME                    100
00006 #define IDR_RACRES                      101
00007
00008 // Next default values for new objects
00009 //
00010 #ifdef APSTUDIO_INVOKED
00011 #ifndef APSTUDIO_READONLY_SYMBOLS
00012 #define _APS_NEXT_RESOURCE_VALUE        201
00013 #define _APS_NEXT_COMMAND_VALUE         32768
00014 #define _APS_NEXT_CONTROL_VALUE         201
00015 #define _APS_NEXT_SYMED_VALUE           102
00016 #endif
00017 #endif
Generated on Wed Jul 21 14:16:35 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


StdAfx.h Source File

StdAfx.h

解説を見る。
00001 // stdafx.h : 標準のシステム インクルード ファイル、
00002 //            または参照回数が多く、かつあまり変更されない
00003 //            プロジェクト専用のインクルード ファイルを記述します。
00004
00005 #if !defined(AFX_STDAFX_H__31F6E6CB_9E01_41EA_83B0_53805D5E2E99__INCLUDED_)
00006 #define AFX_STDAFX_H__31F6E6CB_9E01_41EA_83B0_53805D5E2E99__INCLUDED_
00007
00008 #if _MSC_VER > 1000
00009 #pragma once
00010 #endif // _MSC_VER > 1000
00011
00012 #define STRICT
00013 #ifndef _WIN32_WINNT
00014 #define _WIN32_WINNT 0x0400
00015 #endif
00016 #define _ATL_APARTMENT_THREADED
00017
00018 #include <atlbase.h>
00019 // CComModule クラスから派生したクラスを使用して、オーバーライドする場合
00020 // _Module の名前は変更しないでください。
00021 extern CComModule _Module;
00022 #include <atlcom.h>
00023
00024 //{{AFX_INSERT_LOCATION}}
00025 // Microsoft Visual C++ は前行の直前に追加の宣言を挿入します。
00026
00027 #endif // !defined(AFX_STDAFX_H__31F6E6CB_9E01_41EA_83B0_53805D5E2E99__INCLUDED)
Generated on Wed Jul 21 14:16:35 2004 for RACData Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_IID メンバ一覧

これは全メンバの一覧です。_IID継承メンバも含んでいます。
c | _IID
s1 | _IID
s2 | _IID
x | _IID


メンバ一覧

_MIDL_PROC_FORMAT_STRING メンバ一覧

これは全メンバの一覧です。_MIDL_PROC_FORMAT_STRING継承メンバも含んでいます。
Format | _MIDL_PROC_FORMAT_STRING
Pad | _MIDL_PROC_FORMAT_STRING


メンバ一覧

_MIDL_TYPE_FORMAT_STRING メンバ一覧

これは全メンバの一覧です。_MIDL_TYPE_FORMAT_STRING継承メンバも含んでいます。
Format | _MIDL_TYPE_FORMAT_STRING
Pad | _MIDL_TYPE_FORMAT_STRING