メインページ

DENSO WAVE ROBOTalk Project ドキュメント

1.0

Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


File Index

DENSO WAVE ROBOTalk Project ファイル一覧

これはファイル一覧です。
Device.cpp | CDevice クラスのインプリメンテーション
Device.h [コード] | CDevice クラスのインターフェイス
dlldata.c |
EtherUDP.cpp | CEtherUDP クラスのインプリメンテーション
EtherUDP.h [コード] | CEtherUDP クラスのインターフェイス
RbtlkArm.cpp |
RbtlkArm.h [コード] | RbtlkArm の宣言
RbtlkController.cpp | CRbtlkController のインプリメンテーション
RbtlkController.h [コード] | CRbtlkController の宣言
RbtlkEngine.cpp | CRbtlkEngine のインプリメンテーション
RbtlkEngine.h [コード] | CRbtlkEngine の宣言
RbtlkFile.cpp | CRbtlkFile のインプリメンテーション
RbtlkFile.h [コード] | CRbtlkFile の宣言
RbtlkHeader.h [コード] |
RbtlkIO.cpp | CRbtlkIO のインプリメンテーション
RbtlkIO.h [コード] | CRbtlkIO の宣言
RbtlkTask.cpp | CRbtlkTask のインプリメンテーション
RbtlkTask.h [コード] | CRbtlkTask の宣言
RbtlkVariable.cpp | CRbtlkVariableのインプリメンテーション
RbtlkVariable.h [コード] | CRbtlkVariableの宣言
resource.h [コード] |
ROBOTalk.cpp |
ROBOTalk.h [コード] |
ROBOTalk.idl [コード] |
ROBOTalk_i.c |
ROBOTalk_p.c |
Serial.cpp | CSerial クラスのインプリメンテーション
Serial.h [コード] | CSerial クラスのインターフェイス
StdAfx.cpp |
StdAfx.h [コード] |
Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


Device.cpp File Reference

Device.cpp の解説

CDevice クラスのインプリメンテーション. [詳細]

#include "stdafx.h"
#include "Device.h"

Device.cppのインクルード依存関係図

Include dependency graph

解説

CDevice クラスのインプリメンテーション.

バージョン:
1.0
日付:
2004/2/19
作者:
DENSO WAVE
Generated on Wed Sep 29 10:57:35 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


Device.h File Reference

Device.h の解説

CDevice クラスのインターフェイス. [詳細]

#include <limits.h>

Device.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CDevice
Deviceクラス. [詳細]

マクロ定義

#define | AFX_DEVICE_H__27399E95_B5DF_4C1C_BD53_842D96EDF6D8__INCLUDED_
#define | DEV_TIME_OUT 500L
#define | DEV_RETRY 3
#define | E_TIMEOUT _HRESULT_TYPEDEF_(0x80000900L)
#define | LOCAL_BUFFER_MAX SHRT_MAX
#define | ST_MODE_BINARY 0
#define | ST_MODE_TEXT 1
#define | ST_MODE_WBSTOWCS 2
#define | ST_MODE_ASCTOISO 4
#define | ST_MODE_ASCTOEIA 8
#define | TABLE_ASCTOISO 0
#define | TABLE_ISOTOASC 1
#define | TABLE_ASCTOEIA 2
#define | TABLE_EIATOASC 3

変数

const BYTE | g_CharTable [4][256]

解説

CDevice クラスのインターフェイス.

バージョン:
1.0
日付:
2004/2/19
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_DEVICE_H__27399E95_B5DF_4C1C_BD53_842D96EDF6D8__INCLUDED_

#define DEV_RETRY 3

#define DEV_TIME_OUT 500L

#define E_TIMEOUT _HRESULT_TYPEDEF_(0x80000900L)

#define LOCAL_BUFFER_MAX SHRT_MAX

#define ST_MODE_ASCTOEIA 8

#define ST_MODE_ASCTOISO 4

#define ST_MODE_BINARY 0

#define ST_MODE_TEXT 1

#define ST_MODE_WBSTOWCS 2

#define TABLE_ASCTOEIA 2

#define TABLE_ASCTOISO 0

#define TABLE_EIATOASC 3

#define TABLE_ISOTOASC 1

変数の解説

const BYTE g_CharTable[4][256] [static]

Generated on Wed Sep 29 10:57:35 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


dlldata.c File Reference

dlldata.c の解説

#include <rpcproxy.h>

dlldata.cのインクルード依存関係図

Include dependency graph

関数

PROXYFILE_LIST_START REFERENCE_PROXY_FILE (ROBOTalk)

関数の解説

PROXYFILE_LIST_START REFERENCE_PROXY_FILE ( ROBOTalk )

Generated on Wed Sep 29 10:57:35 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


EtherUDP.cpp File Reference

EtherUDP.cpp の解説

CEtherUDP クラスのインプリメンテーション. [詳細]

#include "stdafx.h"
#include "EtherUDP.h"

EtherUDP.cppのインクルード依存関係図

Include dependency graph

解説

CEtherUDP クラスのインプリメンテーション.

バージョン:
1.0
日付:
2004/8/19
作者:
DENSO WAVE
Generated on Wed Sep 29 10:57:35 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


EtherUDP.h File Reference

EtherUDP.h の解説

CEtherUDP クラスのインターフェイス. [詳細]

#include "Device.h"
#include <winsock.h>

EtherUDP.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CEtherUDP

マクロ定義

#define | AFX_ETHERUDP_H__7DA23D74_7712_46A2_81F7_94F952EEDDB3__INCLUDED_
#define | ETHER_BASE_TIMEOUT 50

解説

CEtherUDP クラスのインターフェイス.

バージョン:
1.0
日付:
2004/2/19
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_ETHERUDP_H__7DA23D74_7712_46A2_81F7_94F952EEDDB3__INCLUDED_

#define ETHER_BASE_TIMEOUT 50

Generated on Wed Sep 29 10:57:35 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkArm.cpp File Reference

RbtlkArm.cpp の解説

#include "stdafx.h"
#include "ROBOTalk.h"
#include "RbtlkArm.h"
#include "RbtlkController.h"

RbtlkArm.cppのインクルード依存関係図

Include dependency graph
Generated on Wed Sep 29 10:57:36 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkArm.h File Reference

RbtlkArm.h の解説

RbtlkArm の宣言. [詳細]

#include "resource.h"
#include "RbtlkEngine.h"

RbtlkArm.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CRbtlkArm

解説

RbtlkArm の宣言.

バージョン:
1.0
日付:
2004/2/19
作者:
DENSO WAVE
Generated on Wed Sep 29 10:57:36 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkController.cpp File Reference

RbtlkController.cpp の解説

CRbtlkController のインプリメンテーション. [詳細]

#include "stdafx.h"
#include "ROBOTalk.h"
#include "RbtlkController.h"

RbtlkController.cppのインクルード依存関係図

Include dependency graph

解説

CRbtlkController のインプリメンテーション.

バージョン:
1.0
日付:
2004/9/23
作者:
DENSO WAVE
Generated on Wed Sep 29 10:57:36 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkController.h File Reference

RbtlkController.h の解説

CRbtlkController の宣言. [詳細]

#include "resource.h"
#include "RbtlkEngine.h"

RbtlkController.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CRbtlkController

解説

CRbtlkController の宣言.

バージョン:
1.0
日付:
2004/9/23
作者:
DENSO WAVE
Generated on Wed Sep 29 10:57:37 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkEngine.cpp File Reference

RbtlkEngine.cpp の解説

CRbtlkEngine のインプリメンテーション. [詳細]

#include "stdafx.h"
#include "ROBOTalk.h"
#include "RbtlkEngine.h"
#include "RbtlkController.h"
#include "RbtlkVariable.h"
#include "RbtlkIO.h"
#include "RbtlkArm.h"
#include "RbtlkTask.h"
#include "RbtlkFile.h"

RbtlkEngine.cppのインクルード依存関係図

Include dependency graph

解説

CRbtlkEngine のインプリメンテーション.

バージョン:
1.0
日付:
2004/9/23
作者:
DENSO WAVE
Generated on Wed Sep 29 10:57:37 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkEngine.h File Reference

RbtlkEngine.h の解説

CRbtlkEngine の宣言. [詳細]

#include "resource.h"
#include "Serial.h"
#include "EtherUDP.h"
#include "ROBOTalk.h"

RbtlkEngine.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CRbtlkEngine

解説

CRbtlkEngine の宣言.

バージョン:
1.0
日付:
2004/9/23
作者:
DENSO WAVE
Generated on Wed Sep 29 10:57:37 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkFile.cpp File Reference

RbtlkFile.cpp の解説

CRbtlkFile のインプリメンテーション. [詳細]

#include "stdafx.h"
#include "ROBOTalk.h"
#include "RbtlkFile.h"
#include "RbtlkController.h"

RbtlkFile.cppのインクルード依存関係図

Include dependency graph

解説

CRbtlkFile のインプリメンテーション.

バージョン:
1.0
日付:
2004/9/23
作者:
DENSO WAVE
Generated on Wed Sep 29 10:57:38 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkFile.h File Reference

RbtlkFile.h の解説

CRbtlkFile の宣言. [詳細]

#include "resource.h"
#include "RbtlkEngine.h"

RbtlkFile.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CRbtlkFile

マクロ定義

#define | RBTLK_DEFAULT_PATH ("/rom/prj")

解説

CRbtlkFile の宣言.

バージョン:
1.0
日付:
2004/9/23
作者:
DENSO WAVE

マクロ定義の解説

#define RBTLK_DEFAULT_PATH ("/rom/prj")

Generated on Wed Sep 29 10:57:38 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkHeader.h File Reference

RbtlkHeader.h の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

マクロ定義

#define | E_SEND_NAK _HRESULT_TYPEDEF_(0x80000900L)
#define | E_REJECTED _HRESULT_TYPEDEF_(0x80000902L)
#define | E_ABNORMAL_R_PACKET _HRESULT_TYPEDEF_(0x80000903L)

Enum

enum RTK_INDEX_SIZE {
RTK_VEC_SIZE = 8, RTK_POS_SIZE = 9, RTK_JNT_SIZE = 10, RTK_TRN_SIZE = 11,
RTK_CTRL_SIZE = 12
}
enum RTK_PACKET_LEN {
RTK_HEAD_LEN = 6, RTK_DATA_MAXLEN = 248, RTK_PACKET_MAXLEN = 256, RTK_SUM_LEN = 2,
RTK_ENQ_PTR = 0, RTK_LEN_PTR = 1, RTK_CMD_PTR = 2, RTK_ID1_PTR = 4,
RTK_ID2_PTR = 5, RTK_DAT_PTR = 6, RTK_ENQ = 0x05
}
enum | RTK_DEVICE { RTK_DEV_NON = 0, RTK_DEV_COM = 1, RTK_DEV_TEL = 2, RTK_DEV_ETH = 3 }
enum RTK_COMMAND {
RTK_CMD_OR = 0x1000, RTK_CMD_AND = 0x0FFF, RTK_CMD_REJ = 0x0E01, RTK_CMD_ACK = 0x0E02,
RTK_CMD_NAK = 0x0E82, RTK_CMD_GETDATETIME = 0x0E20, RTK_CMD_LETDATETIME = 0x0E21, RTK_CMD_GETFREEMEM = 0x0E22,
RTK_CMD_GETOPELOG = 0x0E50, RTK_CMD_GETERRLOG = 0x0E51, RTK_CMD_GETCTRLLOG = 0x0E52, RTK_CMD_CLEARCTRLLOG = 0x0E60,
RTK_CMD_STARTCTRLLOG = 0x0E61, RTK_CMD_STOPCTRLLOG = 0x0E62, RTK_CMD_FLUSHCTRLLOG = 0x0E63, RTK_CMD_GETPARAMCTRLLOG = 0x0E64,
RTK_CMD_SWITCHCTRLLOG = 0x0E65, RTK_CMD_CANCELCTRLLOG = 0x0E66, RTK_CMD_GETSTATUS = 0x0E70, RTK_CMD_LETSTATUS = 0x0E71,
RTK_CMD_GETCONFIG = 0x0E72, RTK_CMD_LETCONFIG = 0x0E73, RTK_CMD_CHANGECONFIG = 0x0E74, RTK_CMD_GETVERSIONS = 0x0E75,
RTK_CMD_GETROBOTTYPE = 0x0E76, RTK_CMD_SRVJOINTPARAM = 0x0E78, RTK_CMD_SRVJOINTDATA = 0x0E79, RTK_CMD_SRVJOINTCANCEL = 0x0E7A,
RTK_CMD_GETJOINTINFO = 0x0E7B, RTK_CMD_SETMODE = 0x0E80, RTK_CMD_GETMODE = 0x0E81, RTK_CMD_GETJOBSTATUS = 0x0E90,
RTK_CMD_LETJOBSTATUS = 0x0E91, RTK_CMD_CLEARERROR = 0x0EB0, RTK_CMD_GETERROR = 0x0EB1, RTK_CMD_REQUESTFILESAVE = 0x0EFA,
RTK_CMD_GETTRANSMODE = 0x0EFB, RTK_CMD_REQUESTROMUPDATE = 0x0EFC, RTK_CMD_NOTICEROMVERSION = 0x0EFD, RTK_CMD_DOSIGNAL = 0x0EFE,
RTK_CMD_SETOPTION = 0x0EFF, RTK_CMD_COMCNF = 0x0001, RTK_CMD_ARMCNF = 0x0002, RTK_CMD_VISCNF = 0x0003,
RTK_CMD_PACCNF = 0x0004, RTK_CMD_SRVCNF = 0x0005, RTK_CMD_SPDCNF = 0x0006, RTK_CMD_ITPCNF = 0x0007,
RTK_CMD_DIOCNF = 0x0008, RTK_CMD_SYSCNF = 0x0009, RTK_CMD_REQUESTUPLOAD0 = 0x0D00, RTK_CMD_UPLOAD0 = 0x0D01,
RTK_CMD_CANCELUPLOAD0 = 0x0D02, RTK_CMD_REQUESTDOWNLOAD0 = 0x0D10, RTK_CMD_DOWNLOAD0 = 0x0D11, RTK_CMD_CANCELDOWNLOAD0 = 0x0D12,
RTK_CMD_REQUESTUPLOAD = 0x0D03, RTK_CMD_UPLOAD = 0x0D04, RTK_CMD_CANCELUPLOAD = 0x0D05, RTK_CMD_REQUESTDOWNLOAD = 0x0D13,
RTK_CMD_DOWNLOAD = 0x0D14, RTK_CMD_CANCELDOWNLOAD = 0x0D15, RTK_CMD_DELFILE0 = 0x0D22, RTK_CMD_DELFILE = 0x0D25,
RTK_CMD_COPYFILE = 0x0D26, RTK_CMD_MOVEFILE = 0x0D27, RTK_CMD_GETFILECNT0 = 0x0D32, RTK_CMD_GETFILENAME0 = 0x0D33,
RTK_CMD_GETPRGSTATUS = 0x0D35, RTK_CMD_LOADNIC = 0x0D40, RTK_CMD_STARTPRG = 0x0D41, RTK_CMD_STOPPRG = 0x0D42,
RTK_CMD_STEPFORWARD = 0x0D43, RTK_CMD_STEPBACKWARD = 0x0D44, RTK_CMD_PUTSTARTLINE = 0x0D47, RTK_CMD_KILLPROG = 0x0D48,
RTK_CMD_GETPROGINDEX = 0x0D50, RTK_CMD_GETPROGIC = 0x0D51, RTK_CMD_FILEUPLOADSTART = 0x0D60, RTK_CMD_FILEUPLOADEND = 0x0D61,
RTK_CMD_GETFILECNT = 0x0D72, RTK_CMD_GETFILENAME = 0x0D73, RTK_CMD_GETATTRB = 0x0D74, RTK_CMD_GETDATACREATED = 0x0D75,
RTK_CMD_GETLASTMODIFIED = 0x0D76, RTK_CMD_GETLASTACCESSED = 0x0D77, RTK_CMD_GETFILESIZE = 0x0D78, RTK_CMD_GETPRGLISTLEN = 0x0800,
RTK_CMD_GETPRGLIST = 0x0801, RTK_CMD_GETTASKSTATUS = 0x0802, RTK_CMD_GETTABLEN = 0x0904, RTK_CMD_GETINTVAR = 0x0910,
RTK_CMD_GETSNGVAR = 0x0911, RTK_CMD_GETDBLVAR = 0x0912, RTK_CMD_GETSTRVAR = 0x0913, RTK_CMD_GETPOSVAR = 0x0914,
RTK_CMD_GETJNTVAR = 0x0915, RTK_CMD_GETTRNVAR = 0x0916, RTK_CMD_GETVECVAR = 0x0917, RTK_CMD_GETDEFIOVAR = 0x0918,
RTK_CMD_LETINTVAR = 0x0920, RTK_CMD_LETSNGVAR = 0x0921, RTK_CMD_LETDBLVAR = 0x0922, RTK_CMD_LETSTRVAR = 0x0923,
RTK_CMD_LETPOSVAR = 0x0924, RTK_CMD_LETJNTVAR = 0x0925, RTK_CMD_LETTRNVAR = 0x0926, RTK_CMD_LETVECVAR = 0x0927,
RTK_CMD_LETDEFIOVAR = 0x0928, RTK_CMD_GETVALUEBYNAME = 0x0930, RTK_CMD_GETIO = 0x0A00, RTK_CMD_GETIO8 = 0x0A20,
RTK_CMD_GETIO16 = 0x0A40, RTK_CMD_CHANGELABEL = 0x0A50, RTK_CMD_SETIO = 0x0A80, RTK_CMD_SETIO8 = 0x0A81,
RTK_CMD_SETIO16 = 0x0A82, RTK_CMD_SETDUMMY = 0x0A90, RTK_CMD_GETCURPOS = 0x0B11, RTK_CMD_GETCURJNT = 0x0B12,
RTK_CMD_GETCURTRN = 0x0B13, RTK_CMD_GETTOOL = 0x0B60, RTK_CMD_LETTOOL = 0x0B61, RTK_CMD_GETTOOLINDEX = 0x0B62,
RTK_CMD_GETWORK = 0x0B64, RTK_CMD_LETWORK = 0x0B65, RTK_CMD_GETWORKINDEX = 0x0B66, RTK_CMD_GETAREA = 0x0B68,
RTK_CMD_LETAREA = 0x0B69, RTK_CMD_ENABLEAREA = 0x0B6A, RTK_CMD_DISABLEAREA = 0x0B6B
}

マクロ定義の解説

#define E_ABNORMAL_R_PACKET _HRESULT_TYPEDEF_(0x80000903L)

#define E_REJECTED _HRESULT_TYPEDEF_(0x80000902L)

#define E_SEND_NAK _HRESULT_TYPEDEF_(0x80000900L)

Enum の解説

enum RTK_COMMAND

Enum 値:
RTK_CMD_OR
RTK_CMD_AND
RTK_CMD_REJ
RTK_CMD_ACK
RTK_CMD_NAK
RTK_CMD_GETDATETIME
RTK_CMD_LETDATETIME
RTK_CMD_GETFREEMEM
RTK_CMD_GETOPELOG
RTK_CMD_GETERRLOG
RTK_CMD_GETCTRLLOG
RTK_CMD_CLEARCTRLLOG
RTK_CMD_STARTCTRLLOG
RTK_CMD_STOPCTRLLOG
RTK_CMD_FLUSHCTRLLOG
RTK_CMD_GETPARAMCTRLLOG
RTK_CMD_SWITCHCTRLLOG
RTK_CMD_CANCELCTRLLOG
RTK_CMD_GETSTATUS
RTK_CMD_LETSTATUS
RTK_CMD_GETCONFIG
RTK_CMD_LETCONFIG
RTK_CMD_CHANGECONFIG
RTK_CMD_GETVERSIONS
RTK_CMD_GETROBOTTYPE
RTK_CMD_SRVJOINTPARAM
RTK_CMD_SRVJOINTDATA
RTK_CMD_SRVJOINTCANCEL
RTK_CMD_GETJOINTINFO
RTK_CMD_SETMODE
RTK_CMD_GETMODE
RTK_CMD_GETJOBSTATUS
RTK_CMD_LETJOBSTATUS
RTK_CMD_CLEARERROR
RTK_CMD_GETERROR
RTK_CMD_REQUESTFILESAVE
RTK_CMD_GETTRANSMODE
RTK_CMD_REQUESTROMUPDATE
RTK_CMD_NOTICEROMVERSION
RTK_CMD_DOSIGNAL
RTK_CMD_SETOPTION
RTK_CMD_COMCNF
RTK_CMD_ARMCNF
RTK_CMD_VISCNF
RTK_CMD_PACCNF
RTK_CMD_SRVCNF
RTK_CMD_SPDCNF
RTK_CMD_ITPCNF
RTK_CMD_DIOCNF
RTK_CMD_SYSCNF
RTK_CMD_REQUESTUPLOAD0
RTK_CMD_UPLOAD0
RTK_CMD_CANCELUPLOAD0
RTK_CMD_REQUESTDOWNLOAD0
RTK_CMD_DOWNLOAD0
RTK_CMD_CANCELDOWNLOAD0
RTK_CMD_REQUESTUPLOAD
RTK_CMD_UPLOAD
RTK_CMD_CANCELUPLOAD
RTK_CMD_REQUESTDOWNLOAD
RTK_CMD_DOWNLOAD
RTK_CMD_CANCELDOWNLOAD
RTK_CMD_DELFILE0
RTK_CMD_DELFILE
RTK_CMD_COPYFILE
RTK_CMD_MOVEFILE
RTK_CMD_GETFILECNT0
RTK_CMD_GETFILENAME0
RTK_CMD_GETPRGSTATUS
RTK_CMD_LOADNIC
RTK_CMD_STARTPRG
RTK_CMD_STOPPRG
RTK_CMD_STEPFORWARD
RTK_CMD_STEPBACKWARD
RTK_CMD_PUTSTARTLINE
RTK_CMD_KILLPROG
RTK_CMD_GETPROGINDEX
RTK_CMD_GETPROGIC
RTK_CMD_FILEUPLOADSTART
RTK_CMD_FILEUPLOADEND
RTK_CMD_GETFILECNT
RTK_CMD_GETFILENAME
RTK_CMD_GETATTRB
RTK_CMD_GETDATACREATED
RTK_CMD_GETLASTMODIFIED
RTK_CMD_GETLASTACCESSED
RTK_CMD_GETFILESIZE
RTK_CMD_GETPRGLISTLEN
RTK_CMD_GETPRGLIST
RTK_CMD_GETTASKSTATUS
RTK_CMD_GETTABLEN
RTK_CMD_GETINTVAR
RTK_CMD_GETSNGVAR
RTK_CMD_GETDBLVAR
RTK_CMD_GETSTRVAR
RTK_CMD_GETPOSVAR
RTK_CMD_GETJNTVAR
RTK_CMD_GETTRNVAR
RTK_CMD_GETVECVAR
RTK_CMD_GETDEFIOVAR
RTK_CMD_LETINTVAR
RTK_CMD_LETSNGVAR
RTK_CMD_LETDBLVAR
RTK_CMD_LETSTRVAR
RTK_CMD_LETPOSVAR
RTK_CMD_LETJNTVAR
RTK_CMD_LETTRNVAR
RTK_CMD_LETVECVAR
RTK_CMD_LETDEFIOVAR
RTK_CMD_GETVALUEBYNAME
RTK_CMD_GETIO
RTK_CMD_GETIO8
RTK_CMD_GETIO16
RTK_CMD_CHANGELABEL
RTK_CMD_SETIO
RTK_CMD_SETIO8
RTK_CMD_SETIO16
RTK_CMD_SETDUMMY
RTK_CMD_GETCURPOS
RTK_CMD_GETCURJNT
RTK_CMD_GETCURTRN
RTK_CMD_GETTOOL
RTK_CMD_LETTOOL
RTK_CMD_GETTOOLINDEX
RTK_CMD_GETWORK
RTK_CMD_LETWORK
RTK_CMD_GETWORKINDEX
RTK_CMD_GETAREA
RTK_CMD_LETAREA
RTK_CMD_ENABLEAREA
RTK_CMD_DISABLEAREA

enum RTK_DEVICE

Enum 値:
RTK_DEV_NON
RTK_DEV_COM
RTK_DEV_TEL
RTK_DEV_ETH

enum RTK_INDEX_SIZE

Enum 値:
RTK_VEC_SIZE
RTK_POS_SIZE
RTK_JNT_SIZE
RTK_TRN_SIZE
RTK_CTRL_SIZE

enum RTK_PACKET_LEN

Enum 値:
RTK_HEAD_LEN
RTK_DATA_MAXLEN
RTK_PACKET_MAXLEN
RTK_SUM_LEN
RTK_ENQ_PTR
RTK_LEN_PTR
RTK_CMD_PTR
RTK_ID1_PTR
RTK_ID2_PTR
RTK_DAT_PTR
RTK_ENQ

Generated on Wed Sep 29 10:57:38 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkIO.cpp File Reference

RbtlkIO.cpp の解説

CRbtlkIO のインプリメンテーション. [詳細]

#include "stdafx.h"
#include "ROBOTalk.h"
#include "RbtlkIO.h"
#include "RbtlkController.h"

RbtlkIO.cppのインクルード依存関係図

Include dependency graph

解説

CRbtlkIO のインプリメンテーション.

バージョン:
1.0
日付:
2004/9/23
作者:
DENSO WAVE
Generated on Wed Sep 29 10:57:38 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkIO.h File Reference

RbtlkIO.h の解説

CRbtlkIO の宣言. [詳細]

#include "resource.h"
#include "RbtlkEngine.h"

RbtlkIO.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CRbtlkIO

解説

CRbtlkIO の宣言.

バージョン:
1.0
日付:
2004/9/23
作者:
DENSO WAVE
Generated on Wed Sep 29 10:57:39 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkTask.cpp File Reference

RbtlkTask.cpp の解説

CRbtlkTask のインプリメンテーション. [詳細]

#include "stdafx.h"
#include "ROBOTalk.h"
#include "RbtlkTask.h"

RbtlkTask.cppのインクルード依存関係図

Include dependency graph

解説

CRbtlkTask のインプリメンテーション.

バージョン:
1.0
日付:
2004/9/23
作者:
DENSO WAVE
Generated on Wed Sep 29 10:57:39 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkTask.h File Reference

RbtlkTask.h の解説

CRbtlkTask の宣言. [詳細]

#include "resource.h"
#include "RbtlkEngine.h"

RbtlkTask.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CRbtlkTask

解説

CRbtlkTask の宣言.

バージョン:
1.0
日付:
2004/9/23
作者:
DENSO WAVE
Generated on Wed Sep 29 10:57:39 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkVariable.cpp File Reference

RbtlkVariable.cpp の解説

CRbtlkVariableのインプリメンテーション. [詳細]

#include "stdafx.h"
#include "ROBOTalk.h"
#include "RbtlkVariable.h"
#include "RbtlkController.h"

RbtlkVariable.cppのインクルード依存関係図

Include dependency graph

解説

CRbtlkVariableのインプリメンテーション.

バージョン:
1.0
日付:
2004/9/23
作者:
DENSO WAVE
Generated on Wed Sep 29 10:57:40 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkVariable.h File Reference

RbtlkVariable.h の解説

CRbtlkVariableの宣言. [詳細]

#include "resource.h"
#include "RbtlkEngine.h"

RbtlkVariable.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CRbtlkVariable

解説

CRbtlkVariableの宣言.

バージョン:
1.0
日付:
2004/9/23
作者:
DENSO WAVE
Generated on Wed Sep 29 10:57:40 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


resource.h File Reference

resource.h の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

マクロ定義

#define | IDS_PROJNAME 100
#define | IDR_RBTLKENGINE 101

マクロ定義の解説

#define IDR_RBTLKENGINE 101

#define IDS_PROJNAME 100

Generated on Wed Sep 29 10:57:40 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


ROBOTalk.cpp File Reference

ROBOTalk.cpp の解説

#include "stdafx.h"
#include "resource.h"
#include <initguid.h>
#include "ROBOTalk.h"
#include "ROBOTalk_i.c"
#include "RbtlkEngine.h"

ROBOTalk.cppのインクルード依存関係図

Include dependency graph

関数

BOOL WINAPI | DllMain (HINSTANCE hInstance, DWORD dwReason, LPVOID)
STDAPI | DllCanUnloadNow (void)
STDAPI | DllGetClassObject (REFCLSID rclsid, REFIID riid, LPVOID *ppv)
STDAPI | DllRegisterServer (void)
STDAPI | DllUnregisterServer (void)

変数

CComModule | _Module
std::map< BYTE, PVOID > | g_mapID

関数の解説

STDAPI DllCanUnloadNow ( void )

STDAPI DllGetClassObject | ( | REFCLSID | rclsid,
 |  | REFIID | riid,
 |  | LPVOID * | ppv
 | ) |

BOOL WINAPI DllMain | ( | HINSTANCE | hInstance,
 |  | DWORD | dwReason,
 |  | LPVOID |
 | ) |

STDAPI DllRegisterServer ( void )

STDAPI DllUnregisterServer ( void )

変数の解説

CComModule _Module

std::map<BYTE, PVOID> g_mapID

Generated on Wed Sep 29 10:57:40 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


ROBOTalk.h File Reference

ROBOTalk.h の解説

#include "rpc.h"
#include "rpcndr.h"
#include "windows.h"
#include "ole2.h"
#include "oaidl.h"
#include "ocidl.h"

ROBOTalk.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

struct | __MIDL_IRbtlkEngine_0002

マクロ定義

#define | __REQUIRED_RPCNDR_H_VERSION__ 440

Typedef

typedef interface IRbtlkEngine | IRbtlkEngine
typedef interface IRbtlkController | IRbtlkController
typedef interface IRbtlkVariable | IRbtlkVariable
typedef interface IRbtlkIO | IRbtlkIO
typedef interface IRbtlkArm | IRbtlkArm
typedef interface IRbtlkTask | IRbtlkTask
typedef interface IRbtlkFile | IRbtlkFile
typedef RbtlkEngine | RbtlkEngine
typedef RbtlkController | RbtlkController
typedef RbtlkVariable | RbtlkVariable
typedef RbtlkIO | RbtlkIO
typedef RbtlkArm | RbtlkArm
typedef RbtlkTask | RbtlkTask
typedef RbtlkFile | RbtlkFile
typedef __MIDL_IRbtlkEngine_0002 | RTK_PACKET
typedef enum __MIDL_IRbtlkEngine_0003 | RTK_CTRL_STATUS
typedef enum __MIDL_IRbtlkArm_0001 | RTK_ARM_STATUS
typedef enum __MIDL_IRbtlkTask_0001 | RTK_PAC_CONF
typedef enum __MIDL_IRbtlkTask_0002 | RTK_ITP_CONF

Enum

enum __MIDL_IRbtlkEngine_0001 {
NIC_GV_INT = ( short )0x1018, NIC_GV_SNG = ( short )0x1019, NIC_GV_DBL = ( short )0x101a, NIC_GV_VEC = ( short )0x101c,
NIC_GV_POS = ( short )0x1015, NIC_GV_JNT = ( short )0x101e, NIC_GV_TRN = ( short )0x101d, NIC_GV_STR = ( short )0x101b,
NIC_GV_IO = ( short )0xffff
}
enum | __MIDL_IRbtlkEngine_0003 { RTK_CST_ERROR = 2, RTK_CST_RUNNING = 3, RTK_CST_EMGSTOP = 4 }
enum | __MIDL_IRbtlkArm_0001 { RTK_AST_SERVO = 16, RTK_AST_MODE = 17, RTK_AST_CALEND = 18 }
enum | __MIDL_IRbtlkTask_0001 { RTK_PC_LANG_MODE = 18, RTK_PC_ROBOTTYPE = 19 }
enum | __MIDL_IRbtlkTask_0002 { RTK_IP_TASKNUM = 1, RTK_IP_RSTKSIZE = 2 }

関数

void __RPC_FAR *__RPC_USER | MIDL_user_allocate (size_t)
void __RPC_USER | MIDL_user_free (void __RPC_FAR *)
virtual HRESULT STDMETHODCALLTYPE | DisconnectServer (void)=0
virtual HRESULT STDMETHODCALLTYPE | Cancel (void)=0
virtual HRESULT STDMETHODCALLTYPE | GetVarInfo (CHAR __RPC_FAR *szVar, short __RPC_FAR *sType, short __RPC_FAR *sIndex)=0
virtual HRESULT STDMETHODCALLTYPE | get_RbtlkController (IRbtlkController __RPC_FAR *__RPC_FAR *ppVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_RbtlkVariable (IRbtlkVariable __RPC_FAR *__RPC_FAR *ppVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_RbtlkArm (IRbtlkArm __RPC_FAR *__RPC_FAR *ppVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_RbtlkIO (IRbtlkIO __RPC_FAR *__RPC_FAR *ppVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_RbtlkTask (IRbtlkTask __RPC_FAR *__RPC_FAR *ppVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_RbtlkFile (IRbtlkFile __RPC_FAR *__RPC_FAR *ppVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_TimeOut (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_TimeOut (long newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_TimeOutRetry (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_TimeOutRetry (long newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_NakRetry (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_NakRetry (long newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_LastError (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Version (double __RPC_FAR *pVal)=0
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_ConnectServer_Proxy (IRbtlkEngine __RPC_FAR *This, CHAR __RPC_FAR *szPara)
void __RPC_STUB | IRbtlkEngine_ConnectServer_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_DisconnectServer_Proxy (IRbtlkEngine __RPC_FAR *This)
void __RPC_STUB | IRbtlkEngine_DisconnectServer_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_Cancel_Proxy (IRbtlkEngine __RPC_FAR *This)
void __RPC_STUB | IRbtlkEngine_Cancel_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_GetVarInfo_Proxy (IRbtlkEngine __RPC_FAR *This, CHAR __RPC_FAR *szVar, short __RPC_FAR *sType, short __RPC_FAR *sIndex)
void __RPC_STUB | IRbtlkEngine_GetVarInfo_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_get_RbtlkController_Proxy (IRbtlkEngine __RPC_FAR *This, IRbtlkController __RPC_FAR *__RPC_FAR *ppVal)
void __RPC_STUB | IRbtlkEngine_get_RbtlkController_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_get_RbtlkVariable_Proxy (IRbtlkEngine __RPC_FAR *This, IRbtlkVariable __RPC_FAR *__RPC_FAR *ppVal)
void __RPC_STUB | IRbtlkEngine_get_RbtlkVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_get_RbtlkArm_Proxy (IRbtlkEngine __RPC_FAR *This, IRbtlkArm __RPC_FAR *__RPC_FAR *ppVal)
void __RPC_STUB | IRbtlkEngine_get_RbtlkArm_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_get_RbtlkIO_Proxy (IRbtlkEngine __RPC_FAR *This, IRbtlkIO __RPC_FAR *__RPC_FAR *ppVal)
void __RPC_STUB | IRbtlkEngine_get_RbtlkIO_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_get_RbtlkTask_Proxy (IRbtlkEngine __RPC_FAR *This, IRbtlkTask __RPC_FAR *__RPC_FAR *ppVal)
void __RPC_STUB | IRbtlkEngine_get_RbtlkTask_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_get_RbtlkFile_Proxy (IRbtlkEngine __RPC_FAR *This, IRbtlkFile __RPC_FAR *__RPC_FAR *ppVal)
void __RPC_STUB | IRbtlkEngine_get_RbtlkFile_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_get_TimeOut_Proxy (IRbtlkEngine __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkEngine_get_TimeOut_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_put_TimeOut_Proxy (IRbtlkEngine __RPC_FAR *This, long newVal)
void __RPC_STUB | IRbtlkEngine_put_TimeOut_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_get_TimeOutRetry_Proxy (IRbtlkEngine __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkEngine_get_TimeOutRetry_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_put_TimeOutRetry_Proxy (IRbtlkEngine __RPC_FAR *This, long newVal)
void __RPC_STUB | IRbtlkEngine_put_TimeOutRetry_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_get_NakRetry_Proxy (IRbtlkEngine __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkEngine_get_NakRetry_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_put_NakRetry_Proxy (IRbtlkEngine __RPC_FAR *This, long newVal)
void __RPC_STUB | IRbtlkEngine_put_NakRetry_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_get_LastError_Proxy (IRbtlkEngine __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkEngine_get_LastError_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkEngine_get_Version_Proxy (IRbtlkEngine __RPC_FAR *This, double __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkEngine_get_Version_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | cmdGetDateTime (short __RPC_FAR *psDateTime)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLetDateTime (short __RPC_FAR *psDateTime)=0
virtual HRESULT STDMETHODCALLTYPE | cmdClearCtrlLog (void)=0
virtual HRESULT STDMETHODCALLTYPE | cmdStartCtrlLog (void)=0
virtual HRESULT STDMETHODCALLTYPE | cmdStopCtrlLog (void)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetParamCtrlLog (long __RPC_FAR *pSmpCnt, long __RPC_FAR *pSmpRate)=0
virtual HRESULT STDMETHODCALLTYPE | cmdSwitchCtrlLog (short sMode)=0
virtual HRESULT STDMETHODCALLTYPE | cmdCancelCtrlLog (void)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetMode (short __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdSetMode (short iMode)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetFreeMemory (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetRobotType (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetJointInfo (short sMode, short __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetJobStatus (long JobID, short __RPC_FAR *pStatus)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLetJobStatus (long JobID, short sStatus)=0
virtual HRESULT STDMETHODCALLTYPE | cmdRequestFileSave (short __RPC_FAR *pTransMode, long __RPC_FAR *pTaskID)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetTransMode (short __RPC_FAR *pTransMode)=0
virtual HRESULT STDMETHODCALLTYPE | cmdRequestRomUpdate (void)=0
virtual HRESULT STDMETHODCALLTYPE | cmdNoticeRomVersion (short sVer)=0
virtual HRESULT STDMETHODCALLTYPE | cmdDoSignal (short sMode, short sAction)=0
virtual HRESULT STDMETHODCALLTYPE | cmdSrvJointParam (short __RPC_FAR *pJoint, short __RPC_FAR *pInterval, short __RPC_FAR *pCounts, short __RPC_FAR *pData1, short __RPC_FAR *pData2)=0
virtual HRESULT STDMETHODCALLTYPE | cmdSrvJointData (short sOffset, short sCounts, float __RPC_FAR *__RPC_FAR *pData1, float __RPC_FAR *__RPC_FAR *pData2)=0
virtual HRESULT STDMETHODCALLTYPE | cmdSrvJointCancel (void)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetErrorCode (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdClearError (long lErrCode, short __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetOperationLog (short sIndex, short __RPC_FAR *pCode, CHAR __RPC_FAR *szDate, CHAR __RPC_FAR *szTime, CHAR __RPC_FAR *szModule, CHAR __RPC_FAR *szMsg)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetErrorLog (short sIndex, short __RPC_FAR *pCode, short __RPC_FAR *pLevel, CHAR __RPC_FAR *szDate, CHAR __RPC_FAR *szTime, CHAR __RPC_FAR *szModule, CHAR __RPC_FAR *szMsg)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetControlLog (short sIndex, float __RPC_FAR pData[8][4], float __RPC_FAR *pReg, short __RPC_FAR *pProgNo, short __RPC_FAR *pLineNo)=0
virtual HRESULT STDMETHODCALLTYPE | cmdSetOption (short sMode, long lKey, CHAR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdChangeConfig (short sMode)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLetConfig (short sMode, short sIndex, long newVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetConfig (short sMode, short sIndex, long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetStatus (short sModule, short sIndex, short __RPC_FAR *pVal)=0
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetVersions_Proxy (IRbtlkController __RPC_FAR *This, short sIndex, CHAR __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkController_cmdGetVersions_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetDateTime_Proxy (IRbtlkController __RPC_FAR *This, short __RPC_FAR *psDateTime)
void __RPC_STUB | IRbtlkController_cmdGetDateTime_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdLetDateTime_Proxy (IRbtlkController __RPC_FAR *This, short __RPC_FAR *psDateTime)
void __RPC_STUB | IRbtlkController_cmdLetDateTime_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdClearCtrlLog_Proxy (IRbtlkController __RPC_FAR *This)
void __RPC_STUB | IRbtlkController_cmdClearCtrlLog_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdStartCtrlLog_Proxy (IRbtlkController __RPC_FAR *This)
void __RPC_STUB | IRbtlkController_cmdStartCtrlLog_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdStopCtrlLog_Proxy (IRbtlkController __RPC_FAR *This)
void __RPC_STUB | IRbtlkController_cmdStopCtrlLog_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetParamCtrlLog_Proxy (IRbtlkController __RPC_FAR *This, long __RPC_FAR *pSmpCnt, long __RPC_FAR *pSmpRate)
void __RPC_STUB | IRbtlkController_cmdGetParamCtrlLog_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdSwitchCtrlLog_Proxy (IRbtlkController __RPC_FAR *This, short sMode)
void __RPC_STUB | IRbtlkController_cmdSwitchCtrlLog_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdCancelCtrlLog_Proxy (IRbtlkController __RPC_FAR *This)
void __RPC_STUB | IRbtlkController_cmdCancelCtrlLog_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetMode_Proxy (IRbtlkController __RPC_FAR *This, short __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkController_cmdGetMode_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdSetMode_Proxy (IRbtlkController __RPC_FAR *This, short iMode)
void __RPC_STUB | IRbtlkController_cmdSetMode_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetFreeMemory_Proxy (IRbtlkController __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkController_cmdGetFreeMemory_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetRobotType_Proxy (IRbtlkController __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkController_cmdGetRobotType_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetJointInfo_Proxy (IRbtlkController __RPC_FAR *This, short sMode, short __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkController_cmdGetJointInfo_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetJobStatus_Proxy (IRbtlkController __RPC_FAR *This, long JobID, short __RPC_FAR *pStatus)
void __RPC_STUB | IRbtlkController_cmdGetJobStatus_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdLetJobStatus_Proxy (IRbtlkController __RPC_FAR *This, long JobID, short sStatus)
void __RPC_STUB | IRbtlkController_cmdLetJobStatus_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdRequestFileSave_Proxy (IRbtlkController __RPC_FAR *This, short __RPC_FAR *pTransMode, long __RPC_FAR *pTaskID)
void __RPC_STUB | IRbtlkController_cmdRequestFileSave_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetTransMode_Proxy (IRbtlkController __RPC_FAR *This, short __RPC_FAR *pTransMode)
void __RPC_STUB | IRbtlkController_cmdGetTransMode_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdRequestRomUpdate_Proxy (IRbtlkController __RPC_FAR *This)
void __RPC_STUB | IRbtlkController_cmdRequestRomUpdate_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdNoticeRomVersion_Proxy (IRbtlkController __RPC_FAR *This, short sVer)
void __RPC_STUB | IRbtlkController_cmdNoticeRomVersion_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdDoSignal_Proxy (IRbtlkController __RPC_FAR *This, short sMode, short sAction)
void __RPC_STUB | IRbtlkController_cmdDoSignal_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdSrvJointParam_Proxy (IRbtlkController __RPC_FAR *This, short __RPC_FAR *pJoint, short __RPC_FAR *pInterval, short __RPC_FAR *pCounts, short __RPC_FAR *pData1, short __RPC_FAR *pData2)
void __RPC_STUB | IRbtlkController_cmdSrvJointParam_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdSrvJointData_Proxy (IRbtlkController __RPC_FAR *This, short sOffset, short sCounts, float __RPC_FAR *__RPC_FAR *pData1, float __RPC_FAR *__RPC_FAR *pData2)
void __RPC_STUB | IRbtlkController_cmdSrvJointData_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdSrvJointCancel_Proxy (IRbtlkController __RPC_FAR *This)
void __RPC_STUB | IRbtlkController_cmdSrvJointCancel_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetErrorCode_Proxy (IRbtlkController __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkController_cmdGetErrorCode_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdClearError_Proxy (IRbtlkController __RPC_FAR *This, long lErrCode, short __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkController_cmdClearError_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetOperationLog_Proxy (IRbtlkController __RPC_FAR *This, short sIndex, short __RPC_FAR *pCode, CHAR __RPC_FAR *szDate, CHAR __RPC_FAR *szTime, CHAR __RPC_FAR *szModule, CHAR __RPC_FAR *szMsg)
void __RPC_STUB | IRbtlkController_cmdGetOperationLog_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetErrorLog_Proxy (IRbtlkController __RPC_FAR *This, short sIndex, short __RPC_FAR *pCode, short __RPC_FAR *pLevel, CHAR __RPC_FAR *szDate, CHAR __RPC_FAR *szTime, CHAR __RPC_FAR *szModule, CHAR __RPC_FAR *szMsg)
void __RPC_STUB | IRbtlkController_cmdGetErrorLog_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetControlLog_Proxy (IRbtlkController __RPC_FAR *This, short sIndex, float __RPC_FAR pData[8][4], float __RPC_FAR *pReg, short __RPC_FAR *pProgNo, short __RPC_FAR *pLineNo)
void __RPC_STUB | IRbtlkController_cmdGetControlLog_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdSetOption_Proxy (IRbtlkController __RPC_FAR *This, short sMode, long lKey, CHAR __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkController_cmdSetOption_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdChangeConfig_Proxy (IRbtlkController __RPC_FAR *This, short sMode)
void __RPC_STUB | IRbtlkController_cmdChangeConfig_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdLetConfig_Proxy (IRbtlkController __RPC_FAR *This, short sMode, short sIndex, long newVal)
void __RPC_STUB | IRbtlkController_cmdLetConfig_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetConfig_Proxy (IRbtlkController __RPC_FAR *This, short sMode, short sIndex, long __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkController_cmdGetConfig_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetStatus_Proxy (IRbtlkController __RPC_FAR *This, short sModule, short sIndex, short __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkController_cmdGetStatus_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | cmdLetI (short sIC, short sIndex, long newVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetF (short sIC, short sIndex, float __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLetF (short sIC, short sIndex, float newVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetP (short sIC, short sIndex, float __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLetP (short sIC, short sIndex, float __RPC_FAR *newVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetJ (short sIC, short sIndex, float __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLetJ (short sIC, short sIndex, float __RPC_FAR *newVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetD (short sIC, short sIndex, double __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLetD (short sIC, short sIndex, double newVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetS (short sIC, short sIndex, CHAR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLetS (short sIC, short sIndex, CHAR __RPC_FAR *newVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetV (short sIC, short sIndex, float __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLetV (short sIC, short sIndex, float __RPC_FAR *newVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetT (short sIC, short sIndex, float __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLetT (short sIC, short sIndex, float __RPC_FAR *newVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetTabLen (short sPrgIC, short sTypeIC, short __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetDefIO (short sPort, short sType, long lMask, long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLetDefIO (short sPort, short sType, long lMask, long lVal)=0
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdGetI_Proxy (IRbtlkVariable __RPC_FAR *This, short sIC, short sIndex, long __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkVariable_cmdGetI_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdLetI_Proxy (IRbtlkVariable __RPC_FAR *This, short sIC, short sIndex, long newVal)
void __RPC_STUB | IRbtlkVariable_cmdLetI_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdGetF_Proxy (IRbtlkVariable __RPC_FAR *This, short sIC, short sIndex, float __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkVariable_cmdGetF_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdLetF_Proxy (IRbtlkVariable __RPC_FAR *This, short sIC, short sIndex, float newVal)
void __RPC_STUB | IRbtlkVariable_cmdLetF_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdGetP_Proxy (IRbtlkVariable __RPC_FAR *This, short sIC, short sIndex, float __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkVariable_cmdGetP_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdLetP_Proxy (IRbtlkVariable __RPC_FAR *This, short sIC, short sIndex, float __RPC_FAR *newVal)
void __RPC_STUB | IRbtlkVariable_cmdLetP_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdGetJ_Proxy (IRbtlkVariable __RPC_FAR *This, short sIC, short sIndex, float __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkVariable_cmdGetJ_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdLetJ_Proxy (IRbtlkVariable __RPC_FAR *This, short sIC, short sIndex, float __RPC_FAR *newVal)
void __RPC_STUB | IRbtlkVariable_cmdLetJ_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdGetD_Proxy (IRbtlkVariable __RPC_FAR *This, short sIC, short sIndex, double __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkVariable_cmdGetD_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdLetD_Proxy (IRbtlkVariable __RPC_FAR *This, short sIC, short sIndex, double newVal)
void __RPC_STUB | IRbtlkVariable_cmdLetD_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdGetS_Proxy (IRbtlkVariable __RPC_FAR *This, short sIC, short sIndex, CHAR __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkVariable_cmdGetS_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdLetS_Proxy (IRbtlkVariable __RPC_FAR *This, short sIC, short sIndex, CHAR __RPC_FAR *newVal)
void __RPC_STUB | IRbtlkVariable_cmdLetS_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdGetV_Proxy (IRbtlkVariable __RPC_FAR *This, short sIC, short sIndex, float __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkVariable_cmdGetV_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdLetV_Proxy (IRbtlkVariable __RPC_FAR *This, short sIC, short sIndex, float __RPC_FAR *newVal)
void __RPC_STUB | IRbtlkVariable_cmdLetV_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdGetT_Proxy (IRbtlkVariable __RPC_FAR *This, short sIC, short sIndex, float __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkVariable_cmdGetT_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdLetT_Proxy (IRbtlkVariable __RPC_FAR *This, short sIC, short sIndex, float __RPC_FAR *newVal)
void __RPC_STUB | IRbtlkVariable_cmdLetT_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdGetTabLen_Proxy (IRbtlkVariable __RPC_FAR *This, short sPrgIC, short sTypeIC, short __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkVariable_cmdGetTabLen_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdGetDefIO_Proxy (IRbtlkVariable __RPC_FAR *This, short sPort, short sType, long lMask, long __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkVariable_cmdGetDefIO_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkVariable_cmdLetDefIO_Proxy (IRbtlkVariable __RPC_FAR *This, short sPort, short sType, long lMask, long lVal)
void __RPC_STUB | IRbtlkVariable_cmdLetDefIO_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | cmdDout (short sIndex, BOOL newVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdDummy (short sIndex, short newVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdDin8 (short sIndex, short __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdDout8 (short sIndex, short newVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdDin16 (short sIndex, short __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdDout16 (short sIndex, short newVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdChangeLabel (short sPlateNo, short sButtonNo, CHAR __RPC_FAR *newVal)=0
HRESULT STDMETHODCALLTYPE | IRbtlkIO_cmdDin_Proxy (IRbtlkIO __RPC_FAR *This, short sIndex, BOOL __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkIO_cmdDin_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkIO_cmdDout_Proxy (IRbtlkIO __RPC_FAR *This, short sIndex, BOOL newVal)
void __RPC_STUB | IRbtlkIO_cmdDout_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkIO_cmdDummy_Proxy (IRbtlkIO __RPC_FAR *This, short sIndex, short newVal)
void __RPC_STUB | IRbtlkIO_cmdDummy_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkIO_cmdDin8_Proxy (IRbtlkIO __RPC_FAR *This, short sIndex, short __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkIO_cmdDin8_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkIO_cmdDout8_Proxy (IRbtlkIO __RPC_FAR *This, short sIndex, short newVal)
void __RPC_STUB | IRbtlkIO_cmdDout8_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkIO_cmdDin16_Proxy (IRbtlkIO __RPC_FAR *This, short sIndex, short __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkIO_cmdDin16_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkIO_cmdDout16_Proxy (IRbtlkIO __RPC_FAR *This, short sIndex, short newVal)
void __RPC_STUB | IRbtlkIO_cmdDout16_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkIO_cmdChangeLabel_Proxy (IRbtlkIO __RPC_FAR *This, short sPlateNo, short sButtonNo, CHAR __RPC_FAR *newVal)
void __RPC_STUB | IRbtlkIO_cmdChangeLabel_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | cmdJHere (float __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetTool (short sNo, float __RPC_FAR *pf)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLetTool (short sNo, float __RPC_FAR *pf)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetWork (short sNo, float __RPC_FAR *pf)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLetWork (short sNo, float __RPC_FAR *pf)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetArea (short sNo, float __RPC_FAR *pf, short __RPC_FAR *psIO, short __RPC_FAR *psPos)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLetArea (short sNo, float __RPC_FAR *pf, short sIO, short sPos)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetAreaEx (short sNo, float __RPC_FAR *pf, short __RPC_FAR *psIO, short __RPC_FAR *psPos, short __RPC_FAR *psErr, short __RPC_FAR *psEnable)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLetAreaEx (short sNo, float __RPC_FAR *pf, short sIO, short sPos, short sErr, short sEnable)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetToolIndex (short __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetWorkIndex (short __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdThere (float __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdEnableArea (short sNo)=0
virtual HRESULT STDMETHODCALLTYPE | cmdDisableArea (short sNo)=0
HRESULT STDMETHODCALLTYPE | IRbtlkArm_cmdHere_Proxy (IRbtlkArm __RPC_FAR *This, float __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkArm_cmdHere_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkArm_cmdJHere_Proxy (IRbtlkArm __RPC_FAR *This, float __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkArm_cmdJHere_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkArm_cmdGetTool_Proxy (IRbtlkArm __RPC_FAR *This, short sNo, float __RPC_FAR *pf)
void __RPC_STUB | IRbtlkArm_cmdGetTool_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkArm_cmdLetTool_Proxy (IRbtlkArm __RPC_FAR *This, short sNo, float __RPC_FAR *pf)
void __RPC_STUB | IRbtlkArm_cmdLetTool_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkArm_cmdGetWork_Proxy (IRbtlkArm __RPC_FAR *This, short sNo, float __RPC_FAR *pf)
void __RPC_STUB | IRbtlkArm_cmdGetWork_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkArm_cmdLetWork_Proxy (IRbtlkArm __RPC_FAR *This, short sNo, float __RPC_FAR *pf)
void __RPC_STUB | IRbtlkArm_cmdLetWork_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkArm_cmdGetArea_Proxy (IRbtlkArm __RPC_FAR *This, short sNo, float __RPC_FAR *pf, short __RPC_FAR *psIO, short __RPC_FAR *psPos)
void __RPC_STUB | IRbtlkArm_cmdGetArea_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkArm_cmdLetArea_Proxy (IRbtlkArm __RPC_FAR *This, short sNo, float __RPC_FAR *pf, short sIO, short sPos)
void __RPC_STUB | IRbtlkArm_cmdLetArea_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkArm_cmdGetAreaEx_Proxy (IRbtlkArm __RPC_FAR *This, short sNo, float __RPC_FAR *pf, short __RPC_FAR *psIO, short __RPC_FAR *psPos, short __RPC_FAR *psErr, short __RPC_FAR *psEnable)
void __RPC_STUB | IRbtlkArm_cmdGetAreaEx_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkArm_cmdLetAreaEx_Proxy (IRbtlkArm __RPC_FAR *This, short sNo, float __RPC_FAR *pf, short sIO, short sPos, short sErr, short sEnable)
void __RPC_STUB | IRbtlkArm_cmdLetAreaEx_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkArm_cmdGetToolIndex_Proxy (IRbtlkArm __RPC_FAR *This, short __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkArm_cmdGetToolIndex_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkArm_cmdGetWorkIndex_Proxy (IRbtlkArm __RPC_FAR *This, short __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkArm_cmdGetWorkIndex_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkArm_cmdThere_Proxy (IRbtlkArm __RPC_FAR *This, float __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkArm_cmdThere_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkArm_cmdEnableArea_Proxy (IRbtlkArm __RPC_FAR *This, short sNo)
void __RPC_STUB | IRbtlkArm_cmdEnableArea_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkArm_cmdDisableArea_Proxy (IRbtlkArm __RPC_FAR *This, short sNo)
void __RPC_STUB | IRbtlkArm_cmdDisableArea_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | cmdGetPrgList (short sIndex, short __RPC_FAR *newVal, CHAR __RPC_FAR *szName)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetTaskStatus (short sPrgIC, short __RPC_FAR *pStatus)=0
virtual HRESULT STDMETHODCALLTYPE | cmdContPrgStatus (short sPrgIC, short __RPC_FAR *pStatus, short __RPC_FAR *pPriority, short __RPC_FAR *pInterval, short __RPC_FAR *pLineNo, short __RPC_FAR *pIOBlock, short __RPC_FAR *pMode, long __RPC_FAR *pCT)=0
HRESULT STDMETHODCALLTYPE | IRbtlkTask_cmdGetPrgListLen_Proxy (IRbtlkTask __RPC_FAR *This, short __RPC_FAR *newVal)
void __RPC_STUB | IRbtlkTask_cmdGetPrgListLen_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkTask_cmdGetPrgList_Proxy (IRbtlkTask __RPC_FAR *This, short sIndex, short __RPC_FAR *newVal, CHAR __RPC_FAR *szName)
void __RPC_STUB | IRbtlkTask_cmdGetPrgList_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkTask_cmdGetTaskStatus_Proxy (IRbtlkTask __RPC_FAR *This, short sPrgIC, short __RPC_FAR *pStatus)
void __RPC_STUB | IRbtlkTask_cmdGetTaskStatus_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkTask_cmdContPrgStatus_Proxy (IRbtlkTask __RPC_FAR *This, short sPrgIC, short __RPC_FAR *pStatus, short __RPC_FAR *pPriority, short __RPC_FAR *pInterval, short __RPC_FAR *pLineNo, short __RPC_FAR *pIOBlock, short __RPC_FAR *pMode, long __RPC_FAR *pCT)
void __RPC_STUB | IRbtlkTask_cmdContPrgStatus_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | cmdFileUploadEnd (void)=0
virtual HRESULT STDMETHODCALLTYPE | cmdRequestUpload (short sBlocks, long lSize, short sFileProp, short sFileFlag, CHAR __RPC_FAR *szName, short __RPC_FAR *psFileID)=0
virtual HRESULT STDMETHODCALLTYPE | cmdRequestDownload (short sFileFlag, CHAR __RPC_FAR *szName, short __RPC_FAR *psFileID, short __RPC_FAR *psBlocks, short __RPC_FAR *sFileProp, long __RPC_FAR *plSize)=0
virtual HRESULT STDMETHODCALLTYPE | cmdUpload (short sFileID, short sBlockNo, BSTR bstrData)=0
virtual HRESULT STDMETHODCALLTYPE | cmdDownload (short sFileID, short __RPC_FAR *psFileID, short __RPC_FAR *psBlockNo, BSTR __RPC_FAR *pbstrData)=0
virtual HRESULT STDMETHODCALLTYPE | cmdCancelUpload (short sFileID)=0
virtual HRESULT STDMETHODCALLTYPE | cmdCancelDownload (short sFileID)=0
virtual HRESULT STDMETHODCALLTYPE | cmdDeleteFile (CHAR __RPC_FAR *szName)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetFileCnt (CHAR __RPC_FAR *szName, short __RPC_FAR *psFiles)=0
virtual HRESULT STDMETHODCALLTYPE | cmdCopyFile (CHAR __RPC_FAR *szFrom, CHAR __RPC_FAR *szTo)=0
virtual HRESULT STDMETHODCALLTYPE | cmdMoveFile (CHAR __RPC_FAR *szFrom, CHAR __RPC_FAR *szTo)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetFileName (short sIndex, CHAR __RPC_FAR *szDirName, CHAR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetAttributes (short iSystem, CHAR __RPC_FAR *szName, long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetDataCreated (short iSystem, CHAR __RPC_FAR *szName, short __RPC_FAR *pDateTime)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetLastModified (short iSystem, CHAR __RPC_FAR *szName, short __RPC_FAR *pDateTime)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetLastAccessed (short iSystem, CHAR __RPC_FAR *szName, short __RPC_FAR *pDateTime)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetSize (short iSystem, CHAR __RPC_FAR *szName, long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdStartPrg (short iProgIC, short iStartMode)=0
virtual HRESULT STDMETHODCALLTYPE | cmdStopPrg (short iProgIC, short iStopMode)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetProgramIC (CHAR __RPC_FAR *szName, short __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdStepForward (short iProgIC)=0
virtual HRESULT STDMETHODCALLTYPE | cmdStepBackward (short iProgIC)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLetStartLine (short iLineNo, short iProgIC, short __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdKillProg (short iActMode, short iProgIC)=0
virtual HRESULT STDMETHODCALLTYPE | cmdLoadNic (long __RPC_FAR *pID)=0
virtual HRESULT STDMETHODCALLTYPE | cmdRequestUpload0 (short sBlocks, long lSize, CHAR __RPC_FAR *szName, CHAR __RPC_FAR *szAttribute, CHAR __RPC_FAR *szUsage, short __RPC_FAR *psFileID)=0
virtual HRESULT STDMETHODCALLTYPE | cmdRequestDownload0 (CHAR __RPC_FAR *szName, short __RPC_FAR *psFileID, short __RPC_FAR *psBlocks, long __RPC_FAR *plSize, CHAR __RPC_FAR *szAttribute, CHAR __RPC_FAR *szUsage)=0
virtual HRESULT STDMETHODCALLTYPE | cmdUpload0 (short sFileID, short sBlockNo, BSTR bstrData)=0
virtual HRESULT STDMETHODCALLTYPE | cmdDownload0 (short sFileID, short __RPC_FAR *psFileID, short __RPC_FAR *psBlockNo, BSTR __RPC_FAR *pbstrData)=0
virtual HRESULT STDMETHODCALLTYPE | cmdCancelUpload0 (short sFileID)=0
virtual HRESULT STDMETHODCALLTYPE | cmdCancelDownload0 (short sFileID)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetProgramIndex (CHAR __RPC_FAR *szName, short __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | cmdDeleteFile0 (CHAR __RPC_FAR *szName)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetFileCnt0 (short __RPC_FAR *psFiles)=0
virtual HRESULT STDMETHODCALLTYPE | cmdGetFileName0 (short sIndex, CHAR __RPC_FAR *pVal)=0
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdFileUploadStart_Proxy (IRbtlkFile __RPC_FAR *This)
void __RPC_STUB | IRbtlkFile_cmdFileUploadStart_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdFileUploadEnd_Proxy (IRbtlkFile __RPC_FAR *This)
void __RPC_STUB | IRbtlkFile_cmdFileUploadEnd_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdRequestUpload_Proxy (IRbtlkFile __RPC_FAR *This, short sBlocks, long lSize, short sFileProp, short sFileFlag, CHAR __RPC_FAR *szName, short __RPC_FAR *psFileID)
void __RPC_STUB | IRbtlkFile_cmdRequestUpload_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdRequestDownload_Proxy (IRbtlkFile __RPC_FAR *This, short sFileFlag, CHAR __RPC_FAR *szName, short __RPC_FAR *psFileID, short __RPC_FAR *psBlocks, short __RPC_FAR *sFileProp, long __RPC_FAR *plSize)
void __RPC_STUB | IRbtlkFile_cmdRequestDownload_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdUpload_Proxy (IRbtlkFile __RPC_FAR *This, short sFileID, short sBlockNo, BSTR bstrData)
void __RPC_STUB | IRbtlkFile_cmdUpload_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdDownload_Proxy (IRbtlkFile __RPC_FAR *This, short sFileID, short __RPC_FAR *psFileID, short __RPC_FAR *psBlockNo, BSTR __RPC_FAR *pbstrData)
void __RPC_STUB | IRbtlkFile_cmdDownload_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdCancelUpload_Proxy (IRbtlkFile __RPC_FAR *This, short sFileID)
void __RPC_STUB | IRbtlkFile_cmdCancelUpload_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdCancelDownload_Proxy (IRbtlkFile __RPC_FAR *This, short sFileID)
void __RPC_STUB | IRbtlkFile_cmdCancelDownload_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdDeleteFile_Proxy (IRbtlkFile __RPC_FAR *This, CHAR __RPC_FAR *szName)
void __RPC_STUB | IRbtlkFile_cmdDeleteFile_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdGetFileCnt_Proxy (IRbtlkFile __RPC_FAR *This, CHAR __RPC_FAR *szName, short __RPC_FAR *psFiles)
void __RPC_STUB | IRbtlkFile_cmdGetFileCnt_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdCopyFile_Proxy (IRbtlkFile __RPC_FAR *This, CHAR __RPC_FAR *szFrom, CHAR __RPC_FAR *szTo)
void __RPC_STUB | IRbtlkFile_cmdCopyFile_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdMoveFile_Proxy (IRbtlkFile __RPC_FAR *This, CHAR __RPC_FAR *szFrom, CHAR __RPC_FAR *szTo)
void __RPC_STUB | IRbtlkFile_cmdMoveFile_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdGetFileName_Proxy (IRbtlkFile __RPC_FAR *This, short sIndex, CHAR __RPC_FAR *szDirName, CHAR __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkFile_cmdGetFileName_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdGetAttributes_Proxy (IRbtlkFile __RPC_FAR *This, short iSystem, CHAR __RPC_FAR *szName, long __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkFile_cmdGetAttributes_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdGetDataCreated_Proxy (IRbtlkFile __RPC_FAR *This, short iSystem, CHAR __RPC_FAR *szName, short __RPC_FAR *pDateTime)
void __RPC_STUB | IRbtlkFile_cmdGetDataCreated_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdGetLastModified_Proxy (IRbtlkFile __RPC_FAR *This, short iSystem, CHAR __RPC_FAR *szName, short __RPC_FAR *pDateTime)
void __RPC_STUB | IRbtlkFile_cmdGetLastModified_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdGetLastAccessed_Proxy (IRbtlkFile __RPC_FAR *This, short iSystem, CHAR __RPC_FAR *szName, short __RPC_FAR *pDateTime)
void __RPC_STUB | IRbtlkFile_cmdGetLastAccessed_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdGetSize_Proxy (IRbtlkFile __RPC_FAR *This, short iSystem, CHAR __RPC_FAR *szName, long __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkFile_cmdGetSize_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdStartPrg_Proxy (IRbtlkFile __RPC_FAR *This, short iProgIC, short iStartMode)
void __RPC_STUB | IRbtlkFile_cmdStartPrg_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdStopPrg_Proxy (IRbtlkFile __RPC_FAR *This, short iProgIC, short iStopMode)
void __RPC_STUB | IRbtlkFile_cmdStopPrg_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdGetProgramIC_Proxy (IRbtlkFile __RPC_FAR *This, CHAR __RPC_FAR *szName, short __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkFile_cmdGetProgramIC_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdStepForward_Proxy (IRbtlkFile __RPC_FAR *This, short iProgIC)
void __RPC_STUB | IRbtlkFile_cmdStepForward_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdStepBackward_Proxy (IRbtlkFile __RPC_FAR *This, short iProgIC)
void __RPC_STUB | IRbtlkFile_cmdStepBackward_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdLetStartLine_Proxy (IRbtlkFile __RPC_FAR *This, short iLineNo, short iProgIC, short __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkFile_cmdLetStartLine_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdKillProg_Proxy (IRbtlkFile __RPC_FAR *This, short iActMode, short iProgIC)
void __RPC_STUB | IRbtlkFile_cmdKillProg_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdLoadNic_Proxy (IRbtlkFile __RPC_FAR *This, long __RPC_FAR *pID)
void __RPC_STUB | IRbtlkFile_cmdLoadNic_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdRequestUpload0_Proxy (IRbtlkFile __RPC_FAR *This, short sBlocks, long lSize, CHAR __RPC_FAR *szName, CHAR __RPC_FAR *szAttribute, CHAR __RPC_FAR *szUsage, short __RPC_FAR *psFileID)
void __RPC_STUB | IRbtlkFile_cmdRequestUpload0_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdRequestDownload0_Proxy (IRbtlkFile __RPC_FAR *This, CHAR __RPC_FAR *szName, short __RPC_FAR *psFileID, short __RPC_FAR *psBlocks, long __RPC_FAR *plSize, CHAR __RPC_FAR *szAttribute, CHAR __RPC_FAR *szUsage)
void __RPC_STUB | IRbtlkFile_cmdRequestDownload0_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdUpload0_Proxy (IRbtlkFile __RPC_FAR *This, short sFileID, short sBlockNo, BSTR bstrData)
void __RPC_STUB | IRbtlkFile_cmdUpload0_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdDownload0_Proxy (IRbtlkFile __RPC_FAR *This, short sFileID, short __RPC_FAR *psFileID, short __RPC_FAR *psBlockNo, BSTR __RPC_FAR *pbstrData)
void __RPC_STUB | IRbtlkFile_cmdDownload0_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdCancelUpload0_Proxy (IRbtlkFile __RPC_FAR *This, short sFileID)
void __RPC_STUB | IRbtlkFile_cmdCancelUpload0_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdCancelDownload0_Proxy (IRbtlkFile __RPC_FAR *This, short sFileID)
void __RPC_STUB | IRbtlkFile_cmdCancelDownload0_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdGetProgramIndex_Proxy (IRbtlkFile __RPC_FAR *This, CHAR __RPC_FAR *szName, short __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkFile_cmdGetProgramIndex_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdDeleteFile0_Proxy (IRbtlkFile __RPC_FAR *This, CHAR __RPC_FAR *szName)
void __RPC_STUB | IRbtlkFile_cmdDeleteFile0_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdGetFileCnt0_Proxy (IRbtlkFile __RPC_FAR *This, short __RPC_FAR *psFiles)
void __RPC_STUB | IRbtlkFile_cmdGetFileCnt0_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdGetFileName0_Proxy (IRbtlkFile __RPC_FAR *This, short sIndex, CHAR __RPC_FAR *pVal)
void __RPC_STUB | IRbtlkFile_cmdGetFileName0_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
class | DECLSPEC_UUID ("2567A726-828B-4D30-8E2E-E661F9921D99") RbtlkEngine
class | DECLSPEC_UUID ("E218CEA4-EA72-4ab3-A5E5-6AE4B2835995") RbtlkController
class | DECLSPEC_UUID ("8D476744-65EC-456e-A6C7-641D07520C13") RbtlkVariable
class | DECLSPEC_UUID ("BA8055B8-4ED2-4d3e-ADFD-8A8DB628EF39") RbtlkIO
class | DECLSPEC_UUID ("8403C89E-8C66-4d0b-BBB4-8A170A767F6F") RbtlkArm
class | DECLSPEC_UUID ("2A783DB8-5443-4950-B460-43FA8E7E0BF2") RbtlkTask
class | DECLSPEC_UUID ("448B9ED4-44D4-4a29-A30C-953CA7A2910B") RbtlkFile
unsigned long __RPC_USER | BSTR_UserSize (unsigned long __RPC_FAR *, unsigned long, BSTR __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | BSTR_UserMarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | BSTR_UserUnmarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR *)
void __RPC_USER | BSTR_UserFree (unsigned long __RPC_FAR *, BSTR __RPC_FAR *)

変数

RPC_IF_HANDLE | __MIDL_itf_ROBOTalk_0000_v0_0_c_ifspec
RPC_IF_HANDLE | __MIDL_itf_ROBOTalk_0000_v0_0_s_ifspec
EXTERN_C const IID | IID_IRbtlkEngine
IRbtlkEngine __pad0__
EXTERN_C const IID | IID_IRbtlkController
IRbtlkController __pad1__
IRbtlkController CHAR __RPC_FAR * | pVal = 0
EXTERN_C const IID | IID_IRbtlkVariable
IRbtlkVariable __pad2__
IRbtlkVariable short | sIndex
EXTERN_C const IID | IID_IRbtlkIO
IRbtlkIO __pad3__
EXTERN_C const IID | IID_IRbtlkArm
IRbtlkArm __pad4__
EXTERN_C const IID | IID_IRbtlkTask
IRbtlkTask __pad5__
EXTERN_C const IID | IID_IRbtlkFile
IRbtlkFile __pad6__
EXTERN_C const IID | LIBID_ROBOTALKLib
EXTERN_C const CLSID | CLSID_RbtlkEngine
EXTERN_C const CLSID | CLSID_RbtlkController
EXTERN_C const CLSID | CLSID_RbtlkVariable
EXTERN_C const CLSID | CLSID_RbtlkIO
EXTERN_C const CLSID | CLSID_RbtlkArm
EXTERN_C const CLSID | CLSID_RbtlkTask
EXTERN_C const CLSID | CLSID_RbtlkFile

マクロ定義の解説

#define __REQUIRED_RPCNDR_H_VERSION__ 440

Typedef の解説

typedef interface IRbtlkArm IRbtlkArm

typedef interface IRbtlkController IRbtlkController

typedef interface IRbtlkEngine IRbtlkEngine

typedef interface IRbtlkFile IRbtlkFile

typedef interface IRbtlkIO IRbtlkIO

typedef interface IRbtlkTask IRbtlkTask

typedef interface IRbtlkVariable IRbtlkVariable

typedef class RbtlkArm RbtlkArm

typedef class RbtlkController RbtlkController

typedef class RbtlkEngine RbtlkEngine

typedef class RbtlkFile RbtlkFile

typedef class RbtlkIO RbtlkIO

typedef class RbtlkTask RbtlkTask

typedef class RbtlkVariable RbtlkVariable

typedef enum __MIDL_IRbtlkArm_0001 RTK_ARM_STATUS

typedef enum __MIDL_IRbtlkEngine_0003 RTK_CTRL_STATUS

typedef enum __MIDL_IRbtlkTask_0002 RTK_ITP_CONF

typedef enum __MIDL_IRbtlkTask_0001 RTK_PAC_CONF

typedef struct __MIDL_IRbtlkEngine_0002 RTK_PACKET

Enum の解説

enum __MIDL_IRbtlkArm_0001

Enum 値:
RTK_AST_SERVO
RTK_AST_MODE
RTK_AST_CALEND

enum __MIDL_IRbtlkEngine_0001

Enum 値:
NIC_GV_INT
NIC_GV_SNG
NIC_GV_DBL
NIC_GV_VEC
NIC_GV_POS
NIC_GV_JNT
NIC_GV_TRN
NIC_GV_STR
NIC_GV_IO

enum __MIDL_IRbtlkEngine_0003

Enum 値:
RTK_CST_ERROR
RTK_CST_RUNNING
RTK_CST_EMGSTOP

enum __MIDL_IRbtlkTask_0001

Enum 値:
RTK_PC_LANG_MODE
RTK_PC_ROBOTTYPE

enum __MIDL_IRbtlkTask_0002

Enum 値:
RTK_IP_TASKNUM
RTK_IP_RSTKSIZE

関数の解説

void __RPC_USER BSTR_UserFree | ( | unsigned long __RPC_FAR * | ,
 |  | BSTR __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER BSTR_UserMarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | BSTR __RPC_FAR * |
 | ) |

unsigned long __RPC_USER BSTR_UserSize | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned | long,
 |  | BSTR __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER BSTR_UserUnmarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | BSTR __RPC_FAR * |
 | ) |

virtual HRESULT STDMETHODCALLTYPE Cancel ( void ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdCancelCtrlLog ( void ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdCancelDownload ( short sFileID ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdCancelDownload0 ( short sFileID ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdCancelUpload ( short sFileID ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdCancelUpload0 ( short sFileID ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdChangeConfig ( short sMode ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdChangeLabel | ( | short | sPlateNo,
 |  | short | sButtonNo,
 |  | CHAR __RPC_FAR * | newVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdClearCtrlLog ( void ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdClearError | ( | long | lErrCode,
 |  | short __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdContPrgStatus | ( | short | sPrgIC,
 |  | short __RPC_FAR * | pStatus,
 |  | short __RPC_FAR * | pPriority,
 |  | short __RPC_FAR * | pInterval,
 |  | short __RPC_FAR * | pLineNo,
 |  | short __RPC_FAR * | pIOBlock,
 |  | short __RPC_FAR * | pMode,
 |  | long __RPC_FAR * | pCT
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdCopyFile | ( | CHAR __RPC_FAR * | szFrom,
 |  | CHAR __RPC_FAR * | szTo
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdDeleteFile ( CHAR __RPC_FAR * szName ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdDeleteFile0 ( CHAR __RPC_FAR * szName ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdDin16 | ( | short | sIndex,
 |  | short __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdDin8 | ( | short | sIndex,
 |  | short __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdDisableArea ( short sNo ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdDoSignal | ( | short | sMode,
 |  | short | sAction
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdDout | ( | short | sIndex,
 |  | BOOL | newVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdDout16 | ( | short | sIndex,
 |  | short | newVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdDout8 | ( | short | sIndex,
 |  | short | newVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdDownload | ( | short | sFileID,
 |  | short __RPC_FAR * | psFileID,
 |  | short __RPC_FAR * | psBlockNo,
 |  | BSTR __RPC_FAR * | pbstrData
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdDownload0 | ( | short | sFileID,
 |  | short __RPC_FAR * | psFileID,
 |  | short __RPC_FAR * | psBlockNo,
 |  | BSTR __RPC_FAR * | pbstrData
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdDummy | ( | short | sIndex,
 |  | short | newVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdEnableArea ( short sNo ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdFileUploadEnd ( void ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetArea | ( | short | sNo,
 |  | float __RPC_FAR * | pf,
 |  | short __RPC_FAR * | psIO,
 |  | short __RPC_FAR * | psPos
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetAreaEx | ( | short | sNo,
 |  | float __RPC_FAR * | pf,
 |  | short __RPC_FAR * | psIO,
 |  | short __RPC_FAR * | psPos,
 |  | short __RPC_FAR * | psErr,
 |  | short __RPC_FAR * | psEnable
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetAttributes | ( | short | iSystem,
 |  | CHAR __RPC_FAR * | szName,
 |  | long __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetConfig | ( | short | sMode,
 |  | short | sIndex,
 |  | long __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetControlLog | ( | short | sIndex,
 |  | float __RPC_FAR | pData[8][4],
 |  | float __RPC_FAR * | pReg,
 |  | short __RPC_FAR * | pProgNo,
 |  | short __RPC_FAR * | pLineNo
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetD | ( | short | sIC,
 |  | short | sIndex,
 |  | double __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetDataCreated | ( | short | iSystem,
 |  | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | pDateTime
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetDateTime ( short __RPC_FAR * psDateTime ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetDefIO | ( | short | sPort,
 |  | short | sType,
 |  | long | lMask,
 |  | long __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetErrorCode ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetErrorLog | ( | short | sIndex,
 |  | short __RPC_FAR * | pCode,
 |  | short __RPC_FAR * | pLevel,
 |  | CHAR __RPC_FAR * | szDate,
 |  | CHAR __RPC_FAR * | szTime,
 |  | CHAR __RPC_FAR * | szModule,
 |  | CHAR __RPC_FAR * | szMsg
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetF | ( | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetFileCnt | ( | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | psFiles
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetFileCnt0 ( short __RPC_FAR * psFiles ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetFileName | ( | short | sIndex,
 |  | CHAR __RPC_FAR * | szDirName,
 |  | CHAR __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetFileName0 | ( | short | sIndex,
 |  | CHAR __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetFreeMemory ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetJ | ( | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetJobStatus | ( | long | JobID,
 |  | short __RPC_FAR * | pStatus
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetJointInfo | ( | short | sMode,
 |  | short __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetLastAccessed | ( | short | iSystem,
 |  | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | pDateTime
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetLastModified | ( | short | iSystem,
 |  | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | pDateTime
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetMode ( short __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetOperationLog | ( | short | sIndex,
 |  | short __RPC_FAR * | pCode,
 |  | CHAR __RPC_FAR * | szDate,
 |  | CHAR __RPC_FAR * | szTime,
 |  | CHAR __RPC_FAR * | szModule,
 |  | CHAR __RPC_FAR * | szMsg
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetP | ( | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetParamCtrlLog | ( | long __RPC_FAR * | pSmpCnt,
 |  | long __RPC_FAR * | pSmpRate
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetPrgList | ( | short | sIndex,
 |  | short __RPC_FAR * | newVal,
 |  | CHAR __RPC_FAR * | szName
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetProgramIC | ( | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetProgramIndex | ( | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetRobotType ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetS | ( | short | sIC,
 |  | short | sIndex,
 |  | CHAR __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetSize | ( | short | iSystem,
 |  | CHAR __RPC_FAR * | szName,
 |  | long __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetStatus | ( | short | sModule,
 |  | short | sIndex,
 |  | short __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetT | ( | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetTabLen | ( | short | sPrgIC,
 |  | short | sTypeIC,
 |  | short __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetTaskStatus | ( | short | sPrgIC,
 |  | short __RPC_FAR * | pStatus
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetTool | ( | short | sNo,
 |  | float __RPC_FAR * | pf
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetToolIndex ( short __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetTransMode ( short __RPC_FAR * pTransMode ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetV | ( | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetWork | ( | short | sNo,
 |  | float __RPC_FAR * | pf
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdGetWorkIndex ( short __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdJHere ( float __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdKillProg | ( | short | iActMode,
 |  | short | iProgIC
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetArea | ( | short | sNo,
 |  | float __RPC_FAR * | pf,
 |  | short | sIO,
 |  | short | sPos
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetAreaEx | ( | short | sNo,
 |  | float __RPC_FAR * | pf,
 |  | short | sIO,
 |  | short | sPos,
 |  | short | sErr,
 |  | short | sEnable
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetConfig | ( | short | sMode,
 |  | short | sIndex,
 |  | long | newVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetD | ( | short | sIC,
 |  | short | sIndex,
 |  | double | newVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetDateTime ( short __RPC_FAR * psDateTime ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetDefIO | ( | short | sPort,
 |  | short | sType,
 |  | long | lMask,
 |  | long | lVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetF | ( | short | sIC,
 |  | short | sIndex,
 |  | float | newVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetI | ( | short | sIC,
 |  | short | sIndex,
 |  | long | newVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetJ | ( | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | newVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetJobStatus | ( | long | JobID,
 |  | short | sStatus
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetP | ( | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | newVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetS | ( | short | sIC,
 |  | short | sIndex,
 |  | CHAR __RPC_FAR * | newVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetStartLine | ( | short | iLineNo,
 |  | short | iProgIC,
 |  | short __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetT | ( | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | newVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetTool | ( | short | sNo,
 |  | float __RPC_FAR * | pf
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetV | ( | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | newVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLetWork | ( | short | sNo,
 |  | float __RPC_FAR * | pf
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdLoadNic ( long __RPC_FAR * pID ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdMoveFile | ( | CHAR __RPC_FAR * | szFrom,
 |  | CHAR __RPC_FAR * | szTo
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdNoticeRomVersion ( short sVer ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdRequestDownload | ( | short | sFileFlag,
 |  | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | psFileID,
 |  | short __RPC_FAR * | psBlocks,
 |  | short __RPC_FAR * | sFileProp,
 |  | long __RPC_FAR * | plSize
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdRequestDownload0 | ( | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | psFileID,
 |  | short __RPC_FAR * | psBlocks,
 |  | long __RPC_FAR * | plSize,
 |  | CHAR __RPC_FAR * | szAttribute,
 |  | CHAR __RPC_FAR * | szUsage
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdRequestFileSave | ( | short __RPC_FAR * | pTransMode,
 |  | long __RPC_FAR * | pTaskID
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdRequestRomUpdate ( void ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdRequestUpload | ( | short | sBlocks,
 |  | long | lSize,
 |  | short | sFileProp,
 |  | short | sFileFlag,
 |  | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | psFileID
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdRequestUpload0 | ( | short | sBlocks,
 |  | long | lSize,
 |  | CHAR __RPC_FAR * | szName,
 |  | CHAR __RPC_FAR * | szAttribute,
 |  | CHAR __RPC_FAR * | szUsage,
 |  | short __RPC_FAR * | psFileID
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdSetMode ( short iMode ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdSetOption | ( | short | sMode,
 |  | long | lKey,
 |  | CHAR __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdSrvJointCancel ( void ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdSrvJointData | ( | short | sOffset,
 |  | short | sCounts,
 |  | float __RPC_FAR *__RPC_FAR * | pData1,
 |  | float __RPC_FAR *__RPC_FAR * | pData2
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdSrvJointParam | ( | short __RPC_FAR * | pJoint,
 |  | short __RPC_FAR * | pInterval,
 |  | short __RPC_FAR * | pCounts,
 |  | short __RPC_FAR * | pData1,
 |  | short __RPC_FAR * | pData2
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdStartCtrlLog ( void ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdStartPrg | ( | short | iProgIC,
 |  | short | iStartMode
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdStepBackward ( short iProgIC ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdStepForward ( short iProgIC ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdStopCtrlLog ( void ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdStopPrg | ( | short | iProgIC,
 |  | short | iStopMode
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdSwitchCtrlLog ( short sMode ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdThere ( float __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdUpload | ( | short | sFileID,
 |  | short | sBlockNo,
 |  | BSTR | bstrData
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE cmdUpload0 | ( | short | sFileID,
 |  | short | sBlockNo,
 |  | BSTR | bstrData
 | ) | [pure virtual]

class DECLSPEC_UUID ( "448B9ED4-44D4-4a29-A30C-953CA7A2910B" )

class DECLSPEC_UUID ( "2A783DB8-5443-4950-B460-43FA8E7E0BF2" )

class DECLSPEC_UUID ( "8403C89E-8C66-4d0b-BBB4-8A170A767F6F" )

class DECLSPEC_UUID ( "BA8055B8-4ED2-4d3e-ADFD-8A8DB628EF39" )

class DECLSPEC_UUID ( "8D476744-65EC-456e-A6C7-641D07520C13" )

class DECLSPEC_UUID ( "E218CEA4-EA72-4ab3-A5E5-6AE4B2835995" )

class DECLSPEC_UUID ( "2567A726-828B-4D30-8E2E-E661F9921D99" )

virtual HRESULT STDMETHODCALLTYPE DisconnectServer ( void ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_LastError ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_NakRetry ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_RbtlkArm ( IRbtlkArm __RPC_FAR *__RPC_FAR * ppVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_RbtlkController ( IRbtlkController __RPC_FAR *__RPC_FAR * ppVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_RbtlkFile ( IRbtlkFile __RPC_FAR *__RPC_FAR * ppVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_RbtlkIO ( IRbtlkIO __RPC_FAR *__RPC_FAR * ppVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_RbtlkTask ( IRbtlkTask __RPC_FAR *__RPC_FAR * ppVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_RbtlkVariable ( IRbtlkVariable __RPC_FAR *__RPC_FAR * ppVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_TimeOut ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_TimeOutRetry ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Version ( double __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE GetVarInfo | ( | CHAR __RPC_FAR * | szVar,
 |  | short __RPC_FAR * | sType,
 |  | short __RPC_FAR * | sIndex
 | ) | [pure virtual]

HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdDisableArea_Proxy | ( | IRbtlkArm __RPC_FAR * | This,
 |  | short | sNo
 | ) |

void __RPC_STUB IRbtlkArm_cmdDisableArea_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdEnableArea_Proxy | ( | IRbtlkArm __RPC_FAR * | This,
 |  | short | sNo
 | ) |

void __RPC_STUB IRbtlkArm_cmdEnableArea_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdGetArea_Proxy | ( | IRbtlkArm __RPC_FAR * | This,
 |  | short | sNo,
 |  | float __RPC_FAR * | pf,
 |  | short __RPC_FAR * | psIO,
 |  | short __RPC_FAR * | psPos
 | ) |

void __RPC_STUB IRbtlkArm_cmdGetArea_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdGetAreaEx_Proxy | ( | IRbtlkArm __RPC_FAR * | This,
 |  | short | sNo,
 |  | float __RPC_FAR * | pf,
 |  | short __RPC_FAR * | psIO,
 |  | short __RPC_FAR * | psPos,
 |  | short __RPC_FAR * | psErr,
 |  | short __RPC_FAR * | psEnable
 | ) |

void __RPC_STUB IRbtlkArm_cmdGetAreaEx_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdGetTool_Proxy | ( | IRbtlkArm __RPC_FAR * | This,
 |  | short | sNo,
 |  | float __RPC_FAR * | pf
 | ) |

void __RPC_STUB IRbtlkArm_cmdGetTool_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdGetToolIndex_Proxy | ( | IRbtlkArm __RPC_FAR * | This,
 |  | short __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkArm_cmdGetToolIndex_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdGetWork_Proxy | ( | IRbtlkArm __RPC_FAR * | This,
 |  | short | sNo,
 |  | float __RPC_FAR * | pf
 | ) |

void __RPC_STUB IRbtlkArm_cmdGetWork_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdGetWorkIndex_Proxy | ( | IRbtlkArm __RPC_FAR * | This,
 |  | short __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkArm_cmdGetWorkIndex_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdHere_Proxy | ( | IRbtlkArm __RPC_FAR * | This,
 |  | float __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkArm_cmdHere_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdJHere_Proxy | ( | IRbtlkArm __RPC_FAR * | This,
 |  | float __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkArm_cmdJHere_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdLetArea_Proxy | ( | IRbtlkArm __RPC_FAR * | This,
 |  | short | sNo,
 |  | float __RPC_FAR * | pf,
 |  | short | sIO,
 |  | short | sPos
 | ) |

void __RPC_STUB IRbtlkArm_cmdLetArea_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdLetAreaEx_Proxy | ( | IRbtlkArm __RPC_FAR * | This,
 |  | short | sNo,
 |  | float __RPC_FAR * | pf,
 |  | short | sIO,
 |  | short | sPos,
 |  | short | sErr,
 |  | short | sEnable
 | ) |

void __RPC_STUB IRbtlkArm_cmdLetAreaEx_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdLetTool_Proxy | ( | IRbtlkArm __RPC_FAR * | This,
 |  | short | sNo,
 |  | float __RPC_FAR * | pf
 | ) |

void __RPC_STUB IRbtlkArm_cmdLetTool_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdLetWork_Proxy | ( | IRbtlkArm __RPC_FAR * | This,
 |  | short | sNo,
 |  | float __RPC_FAR * | pf
 | ) |

void __RPC_STUB IRbtlkArm_cmdLetWork_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdThere_Proxy | ( | IRbtlkArm __RPC_FAR * | This,
 |  | float __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkArm_cmdThere_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdCancelCtrlLog_Proxy ( IRbtlkController __RPC_FAR * This )

void __RPC_STUB IRbtlkController_cmdCancelCtrlLog_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdChangeConfig_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sMode
 | ) |

void __RPC_STUB IRbtlkController_cmdChangeConfig_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdClearCtrlLog_Proxy ( IRbtlkController __RPC_FAR * This )

void __RPC_STUB IRbtlkController_cmdClearCtrlLog_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdClearError_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | long | lErrCode,
 |  | short __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkController_cmdClearError_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdDoSignal_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sMode,
 |  | short | sAction
 | ) |

void __RPC_STUB IRbtlkController_cmdDoSignal_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetConfig_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sMode,
 |  | short | sIndex,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkController_cmdGetConfig_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetControlLog_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sIndex,
 |  | float __RPC_FAR | pData[8][4],
 |  | float __RPC_FAR * | pReg,
 |  | short __RPC_FAR * | pProgNo,
 |  | short __RPC_FAR * | pLineNo
 | ) |

void __RPC_STUB IRbtlkController_cmdGetControlLog_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetDateTime_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short __RPC_FAR * | psDateTime
 | ) |

void __RPC_STUB IRbtlkController_cmdGetDateTime_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetErrorCode_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkController_cmdGetErrorCode_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetErrorLog_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sIndex,
 |  | short __RPC_FAR * | pCode,
 |  | short __RPC_FAR * | pLevel,
 |  | CHAR __RPC_FAR * | szDate,
 |  | CHAR __RPC_FAR * | szTime,
 |  | CHAR __RPC_FAR * | szModule,
 |  | CHAR __RPC_FAR * | szMsg
 | ) |

void __RPC_STUB IRbtlkController_cmdGetErrorLog_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetFreeMemory_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkController_cmdGetFreeMemory_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetJobStatus_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | long | JobID,
 |  | short __RPC_FAR * | pStatus
 | ) |

void __RPC_STUB IRbtlkController_cmdGetJobStatus_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetJointInfo_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sMode,
 |  | short __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkController_cmdGetJointInfo_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetMode_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkController_cmdGetMode_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetOperationLog_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sIndex,
 |  | short __RPC_FAR * | pCode,
 |  | CHAR __RPC_FAR * | szDate,
 |  | CHAR __RPC_FAR * | szTime,
 |  | CHAR __RPC_FAR * | szModule,
 |  | CHAR __RPC_FAR * | szMsg
 | ) |

void __RPC_STUB IRbtlkController_cmdGetOperationLog_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetParamCtrlLog_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | long __RPC_FAR * | pSmpCnt,
 |  | long __RPC_FAR * | pSmpRate
 | ) |

void __RPC_STUB IRbtlkController_cmdGetParamCtrlLog_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetRobotType_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkController_cmdGetRobotType_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetStatus_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sModule,
 |  | short | sIndex,
 |  | short __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkController_cmdGetStatus_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetTransMode_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short __RPC_FAR * | pTransMode
 | ) |

void __RPC_STUB IRbtlkController_cmdGetTransMode_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetVersions_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sIndex,
 |  | CHAR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkController_cmdGetVersions_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdLetConfig_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sMode,
 |  | short | sIndex,
 |  | long | newVal
 | ) |

void __RPC_STUB IRbtlkController_cmdLetConfig_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdLetDateTime_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short __RPC_FAR * | psDateTime
 | ) |

void __RPC_STUB IRbtlkController_cmdLetDateTime_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdLetJobStatus_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | long | JobID,
 |  | short | sStatus
 | ) |

void __RPC_STUB IRbtlkController_cmdLetJobStatus_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdNoticeRomVersion_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sVer
 | ) |

void __RPC_STUB IRbtlkController_cmdNoticeRomVersion_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdRequestFileSave_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short __RPC_FAR * | pTransMode,
 |  | long __RPC_FAR * | pTaskID
 | ) |

void __RPC_STUB IRbtlkController_cmdRequestFileSave_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdRequestRomUpdate_Proxy ( IRbtlkController __RPC_FAR * This )

void __RPC_STUB IRbtlkController_cmdRequestRomUpdate_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdSetMode_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | iMode
 | ) |

void __RPC_STUB IRbtlkController_cmdSetMode_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdSetOption_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sMode,
 |  | long | lKey,
 |  | CHAR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkController_cmdSetOption_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdSrvJointCancel_Proxy ( IRbtlkController __RPC_FAR * This )

void __RPC_STUB IRbtlkController_cmdSrvJointCancel_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdSrvJointData_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sOffset,
 |  | short | sCounts,
 |  | float __RPC_FAR *__RPC_FAR * | pData1,
 |  | float __RPC_FAR *__RPC_FAR * | pData2
 | ) |

void __RPC_STUB IRbtlkController_cmdSrvJointData_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdSrvJointParam_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short __RPC_FAR * | pJoint,
 |  | short __RPC_FAR * | pInterval,
 |  | short __RPC_FAR * | pCounts,
 |  | short __RPC_FAR * | pData1,
 |  | short __RPC_FAR * | pData2
 | ) |

void __RPC_STUB IRbtlkController_cmdSrvJointParam_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdStartCtrlLog_Proxy ( IRbtlkController __RPC_FAR * This )

void __RPC_STUB IRbtlkController_cmdStartCtrlLog_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdStopCtrlLog_Proxy ( IRbtlkController __RPC_FAR * This )

void __RPC_STUB IRbtlkController_cmdStopCtrlLog_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdSwitchCtrlLog_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sMode
 | ) |

void __RPC_STUB IRbtlkController_cmdSwitchCtrlLog_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_Cancel_Proxy ( IRbtlkEngine __RPC_FAR * This )

void __RPC_STUB IRbtlkEngine_Cancel_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_ConnectServer_Proxy | ( | IRbtlkEngine __RPC_FAR * | This,
 |  | CHAR __RPC_FAR * | szPara
 | ) |

void __RPC_STUB IRbtlkEngine_ConnectServer_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_DisconnectServer_Proxy ( IRbtlkEngine __RPC_FAR * This )

void __RPC_STUB IRbtlkEngine_DisconnectServer_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_LastError_Proxy | ( | IRbtlkEngine __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkEngine_get_LastError_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_NakRetry_Proxy | ( | IRbtlkEngine __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkEngine_get_NakRetry_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_RbtlkArm_Proxy | ( | IRbtlkEngine __RPC_FAR * | This,
 |  | IRbtlkArm __RPC_FAR *__RPC_FAR * | ppVal
 | ) |

void __RPC_STUB IRbtlkEngine_get_RbtlkArm_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_RbtlkController_Proxy | ( | IRbtlkEngine __RPC_FAR * | This,
 |  | IRbtlkController __RPC_FAR *__RPC_FAR * | ppVal
 | ) |

void __RPC_STUB IRbtlkEngine_get_RbtlkController_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_RbtlkFile_Proxy | ( | IRbtlkEngine __RPC_FAR * | This,
 |  | IRbtlkFile __RPC_FAR *__RPC_FAR * | ppVal
 | ) |

void __RPC_STUB IRbtlkEngine_get_RbtlkFile_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_RbtlkIO_Proxy | ( | IRbtlkEngine __RPC_FAR * | This,
 |  | IRbtlkIO __RPC_FAR *__RPC_FAR * | ppVal
 | ) |

void __RPC_STUB IRbtlkEngine_get_RbtlkIO_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_RbtlkTask_Proxy | ( | IRbtlkEngine __RPC_FAR * | This,
 |  | IRbtlkTask __RPC_FAR *__RPC_FAR * | ppVal
 | ) |

void __RPC_STUB IRbtlkEngine_get_RbtlkTask_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_RbtlkVariable_Proxy | ( | IRbtlkEngine __RPC_FAR * | This,
 |  | IRbtlkVariable __RPC_FAR *__RPC_FAR * | ppVal
 | ) |

void __RPC_STUB IRbtlkEngine_get_RbtlkVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_TimeOut_Proxy | ( | IRbtlkEngine __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkEngine_get_TimeOut_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_TimeOutRetry_Proxy | ( | IRbtlkEngine __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkEngine_get_TimeOutRetry_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_Version_Proxy | ( | IRbtlkEngine __RPC_FAR * | This,
 |  | double __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkEngine_get_Version_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_GetVarInfo_Proxy | ( | IRbtlkEngine __RPC_FAR * | This,
 |  | CHAR __RPC_FAR * | szVar,
 |  | short __RPC_FAR * | sType,
 |  | short __RPC_FAR * | sIndex
 | ) |

void __RPC_STUB IRbtlkEngine_GetVarInfo_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_put_NakRetry_Proxy | ( | IRbtlkEngine __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB IRbtlkEngine_put_NakRetry_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_put_TimeOut_Proxy | ( | IRbtlkEngine __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB IRbtlkEngine_put_TimeOut_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkEngine_put_TimeOutRetry_Proxy | ( | IRbtlkEngine __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB IRbtlkEngine_put_TimeOutRetry_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdCancelDownload0_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sFileID
 | ) |

void __RPC_STUB IRbtlkFile_cmdCancelDownload0_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdCancelDownload_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sFileID
 | ) |

void __RPC_STUB IRbtlkFile_cmdCancelDownload_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdCancelUpload0_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sFileID
 | ) |

void __RPC_STUB IRbtlkFile_cmdCancelUpload0_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdCancelUpload_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sFileID
 | ) |

void __RPC_STUB IRbtlkFile_cmdCancelUpload_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdCopyFile_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | CHAR __RPC_FAR * | szFrom,
 |  | CHAR __RPC_FAR * | szTo
 | ) |

void __RPC_STUB IRbtlkFile_cmdCopyFile_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdDeleteFile0_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | CHAR __RPC_FAR * | szName
 | ) |

void __RPC_STUB IRbtlkFile_cmdDeleteFile0_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdDeleteFile_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | CHAR __RPC_FAR * | szName
 | ) |

void __RPC_STUB IRbtlkFile_cmdDeleteFile_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdDownload0_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sFileID,
 |  | short __RPC_FAR * | psFileID,
 |  | short __RPC_FAR * | psBlockNo,
 |  | BSTR __RPC_FAR * | pbstrData
 | ) |

void __RPC_STUB IRbtlkFile_cmdDownload0_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdDownload_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sFileID,
 |  | short __RPC_FAR * | psFileID,
 |  | short __RPC_FAR * | psBlockNo,
 |  | BSTR __RPC_FAR * | pbstrData
 | ) |

void __RPC_STUB IRbtlkFile_cmdDownload_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdFileUploadEnd_Proxy ( IRbtlkFile __RPC_FAR * This )

void __RPC_STUB IRbtlkFile_cmdFileUploadEnd_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdFileUploadStart_Proxy ( IRbtlkFile __RPC_FAR * This )

void __RPC_STUB IRbtlkFile_cmdFileUploadStart_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetAttributes_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | iSystem,
 |  | CHAR __RPC_FAR * | szName,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkFile_cmdGetAttributes_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetDataCreated_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | iSystem,
 |  | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | pDateTime
 | ) |

void __RPC_STUB IRbtlkFile_cmdGetDataCreated_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetFileCnt0_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short __RPC_FAR * | psFiles
 | ) |

void __RPC_STUB IRbtlkFile_cmdGetFileCnt0_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetFileCnt_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | psFiles
 | ) |

void __RPC_STUB IRbtlkFile_cmdGetFileCnt_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetFileName0_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sIndex,
 |  | CHAR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkFile_cmdGetFileName0_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetFileName_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sIndex,
 |  | CHAR __RPC_FAR * | szDirName,
 |  | CHAR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkFile_cmdGetFileName_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetLastAccessed_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | iSystem,
 |  | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | pDateTime
 | ) |

void __RPC_STUB IRbtlkFile_cmdGetLastAccessed_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetLastModified_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | iSystem,
 |  | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | pDateTime
 | ) |

void __RPC_STUB IRbtlkFile_cmdGetLastModified_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetProgramIC_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkFile_cmdGetProgramIC_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetProgramIndex_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkFile_cmdGetProgramIndex_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetSize_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | iSystem,
 |  | CHAR __RPC_FAR * | szName,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkFile_cmdGetSize_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdKillProg_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | iActMode,
 |  | short | iProgIC
 | ) |

void __RPC_STUB IRbtlkFile_cmdKillProg_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdLetStartLine_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | iLineNo,
 |  | short | iProgIC,
 |  | short __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkFile_cmdLetStartLine_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdLoadNic_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | long __RPC_FAR * | pID
 | ) |

void __RPC_STUB IRbtlkFile_cmdLoadNic_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdMoveFile_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | CHAR __RPC_FAR * | szFrom,
 |  | CHAR __RPC_FAR * | szTo
 | ) |

void __RPC_STUB IRbtlkFile_cmdMoveFile_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdRequestDownload0_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | psFileID,
 |  | short __RPC_FAR * | psBlocks,
 |  | long __RPC_FAR * | plSize,
 |  | CHAR __RPC_FAR * | szAttribute,
 |  | CHAR __RPC_FAR * | szUsage
 | ) |

void __RPC_STUB IRbtlkFile_cmdRequestDownload0_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdRequestDownload_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sFileFlag,
 |  | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | psFileID,
 |  | short __RPC_FAR * | psBlocks,
 |  | short __RPC_FAR * | sFileProp,
 |  | long __RPC_FAR * | plSize
 | ) |

void __RPC_STUB IRbtlkFile_cmdRequestDownload_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdRequestUpload0_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sBlocks,
 |  | long | lSize,
 |  | CHAR __RPC_FAR * | szName,
 |  | CHAR __RPC_FAR * | szAttribute,
 |  | CHAR __RPC_FAR * | szUsage,
 |  | short __RPC_FAR * | psFileID
 | ) |

void __RPC_STUB IRbtlkFile_cmdRequestUpload0_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdRequestUpload_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sBlocks,
 |  | long | lSize,
 |  | short | sFileProp,
 |  | short | sFileFlag,
 |  | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | psFileID
 | ) |

void __RPC_STUB IRbtlkFile_cmdRequestUpload_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdStartPrg_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | iProgIC,
 |  | short | iStartMode
 | ) |

void __RPC_STUB IRbtlkFile_cmdStartPrg_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdStepBackward_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | iProgIC
 | ) |

void __RPC_STUB IRbtlkFile_cmdStepBackward_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdStepForward_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | iProgIC
 | ) |

void __RPC_STUB IRbtlkFile_cmdStepForward_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdStopPrg_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | iProgIC,
 |  | short | iStopMode
 | ) |

void __RPC_STUB IRbtlkFile_cmdStopPrg_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdUpload0_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sFileID,
 |  | short | sBlockNo,
 |  | BSTR | bstrData
 | ) |

void __RPC_STUB IRbtlkFile_cmdUpload0_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdUpload_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sFileID,
 |  | short | sBlockNo,
 |  | BSTR | bstrData
 | ) |

void __RPC_STUB IRbtlkFile_cmdUpload_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkIO_cmdChangeLabel_Proxy | ( | IRbtlkIO __RPC_FAR * | This,
 |  | short | sPlateNo,
 |  | short | sButtonNo,
 |  | CHAR __RPC_FAR * | newVal
 | ) |

void __RPC_STUB IRbtlkIO_cmdChangeLabel_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkIO_cmdDin16_Proxy | ( | IRbtlkIO __RPC_FAR * | This,
 |  | short | sIndex,
 |  | short __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkIO_cmdDin16_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkIO_cmdDin8_Proxy | ( | IRbtlkIO __RPC_FAR * | This,
 |  | short | sIndex,
 |  | short __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkIO_cmdDin8_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkIO_cmdDin_Proxy | ( | IRbtlkIO __RPC_FAR * | This,
 |  | short | sIndex,
 |  | BOOL __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkIO_cmdDin_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkIO_cmdDout16_Proxy | ( | IRbtlkIO __RPC_FAR * | This,
 |  | short | sIndex,
 |  | short | newVal
 | ) |

void __RPC_STUB IRbtlkIO_cmdDout16_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkIO_cmdDout8_Proxy | ( | IRbtlkIO __RPC_FAR * | This,
 |  | short | sIndex,
 |  | short | newVal
 | ) |

void __RPC_STUB IRbtlkIO_cmdDout8_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkIO_cmdDout_Proxy | ( | IRbtlkIO __RPC_FAR * | This,
 |  | short | sIndex,
 |  | BOOL | newVal
 | ) |

void __RPC_STUB IRbtlkIO_cmdDout_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkIO_cmdDummy_Proxy | ( | IRbtlkIO __RPC_FAR * | This,
 |  | short | sIndex,
 |  | short | newVal
 | ) |

void __RPC_STUB IRbtlkIO_cmdDummy_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkTask_cmdContPrgStatus_Proxy | ( | IRbtlkTask __RPC_FAR * | This,
 |  | short | sPrgIC,
 |  | short __RPC_FAR * | pStatus,
 |  | short __RPC_FAR * | pPriority,
 |  | short __RPC_FAR * | pInterval,
 |  | short __RPC_FAR * | pLineNo,
 |  | short __RPC_FAR * | pIOBlock,
 |  | short __RPC_FAR * | pMode,
 |  | long __RPC_FAR * | pCT
 | ) |

void __RPC_STUB IRbtlkTask_cmdContPrgStatus_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkTask_cmdGetPrgList_Proxy | ( | IRbtlkTask __RPC_FAR * | This,
 |  | short | sIndex,
 |  | short __RPC_FAR * | newVal,
 |  | CHAR __RPC_FAR * | szName
 | ) |

void __RPC_STUB IRbtlkTask_cmdGetPrgList_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkTask_cmdGetPrgListLen_Proxy | ( | IRbtlkTask __RPC_FAR * | This,
 |  | short __RPC_FAR * | newVal
 | ) |

void __RPC_STUB IRbtlkTask_cmdGetPrgListLen_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkTask_cmdGetTaskStatus_Proxy | ( | IRbtlkTask __RPC_FAR * | This,
 |  | short | sPrgIC,
 |  | short __RPC_FAR * | pStatus
 | ) |

void __RPC_STUB IRbtlkTask_cmdGetTaskStatus_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetD_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sIC,
 |  | short | sIndex,
 |  | double __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdGetD_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetDefIO_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sPort,
 |  | short | sType,
 |  | long | lMask,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdGetDefIO_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetF_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdGetF_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetI_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sIC,
 |  | short | sIndex,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdGetI_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetJ_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdGetJ_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetP_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdGetP_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetS_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sIC,
 |  | short | sIndex,
 |  | CHAR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdGetS_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetT_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdGetT_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetTabLen_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sPrgIC,
 |  | short | sTypeIC,
 |  | short __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdGetTabLen_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetV_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdGetV_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetD_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sIC,
 |  | short | sIndex,
 |  | double | newVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdLetD_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetDefIO_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sPort,
 |  | short | sType,
 |  | long | lMask,
 |  | long | lVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdLetDefIO_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetF_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sIC,
 |  | short | sIndex,
 |  | float | newVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdLetF_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetI_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sIC,
 |  | short | sIndex,
 |  | long | newVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdLetI_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetJ_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | newVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdLetJ_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetP_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | newVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdLetP_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetS_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sIC,
 |  | short | sIndex,
 |  | CHAR __RPC_FAR * | newVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdLetS_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetT_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | newVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdLetT_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetV_Proxy | ( | IRbtlkVariable __RPC_FAR * | This,
 |  | short | sIC,
 |  | short | sIndex,
 |  | float __RPC_FAR * | newVal
 | ) |

void __RPC_STUB IRbtlkVariable_cmdLetV_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

void __RPC_FAR* __RPC_USER MIDL_user_allocate ( size_t )

void __RPC_USER MIDL_user_free ( void __RPC_FAR * )

virtual HRESULT STDMETHODCALLTYPE put_NakRetry ( long newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_TimeOut ( long newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_TimeOutRetry ( long newVal ) [pure virtual]

変数の解説

RPC_IF_HANDLE __MIDL_itf_ROBOTalk_0000_v0_0_c_ifspec

RPC_IF_HANDLE __MIDL_itf_ROBOTalk_0000_v0_0_s_ifspec

IRbtlkEngine __pad0__

IRbtlkController __pad1__

IRbtlkVariable __pad2__

IRbtlkIO __pad3__

IRbtlkArm __pad4__

IRbtlkTask __pad5__

IRbtlkFile __pad6__

EXTERN_C const CLSID CLSID_RbtlkArm

EXTERN_C const CLSID CLSID_RbtlkController

EXTERN_C const CLSID CLSID_RbtlkEngine

EXTERN_C const CLSID CLSID_RbtlkFile

EXTERN_C const CLSID CLSID_RbtlkIO

EXTERN_C const CLSID CLSID_RbtlkTask

EXTERN_C const CLSID CLSID_RbtlkVariable

EXTERN_C const IID IID_IRbtlkArm

EXTERN_C const IID IID_IRbtlkController

EXTERN_C const IID IID_IRbtlkEngine

EXTERN_C const IID IID_IRbtlkFile

EXTERN_C const IID IID_IRbtlkIO

EXTERN_C const IID IID_IRbtlkTask

EXTERN_C const IID IID_IRbtlkVariable

EXTERN_C const IID LIBID_ROBOTALKLib

IRbtlkIO BOOL __RPC_FAR * pVal = 0

IRbtlkVariable short sIndex

Generated on Wed Sep 29 10:57:42 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


ROBOTalk.idl File Reference

ROBOTalk.idl の解説

ソースコードを見る。

名前空間

namespace | ROBOTALKLib

構成

interface | IRbtlkArm
interface | IRbtlkController
interface | IRbtlkEngine
struct | RTK_PACKET
interface | IRbtlkFile
interface | IRbtlkIO
interface | IRbtlkTask
interface | IRbtlkVariable

Generated on Wed Sep 29 10:57:42 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


ROBOTalk_i.c File Reference

ROBOTalk_i.c の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

構成

struct | _IID

Typedef

typedef _IID | IID
typedef IID | CLSID

変数

const IID | IID_IRbtlkEngine = {0xF7D1E6C8,0xC6D4,0x4696,{0xBD,0x58,0x28,0x21,0x34,0xD4,0x01,0x34}}
const IID | IID_IRbtlkController = {0xC85F8BB2,0xEFF4,0x485e,{0xBB,0x44,0xF5,0xDE,0xD2,0x9F,0x27,0x01}}
const IID | IID_IRbtlkVariable = {0x9C5AD78B,0x2D87,0x4bc0,{0x95,0xCC,0xA0,0xCD,0x89,0x7C,0xEE,0xF0}}
const IID | IID_IRbtlkIO = {0xB8937F48,0x2FB7,0x4807,{0x8D,0x2D,0x22,0x00,0x68,0x38,0x01,0xFA}}
const IID | IID_IRbtlkArm = {0xE59220A9,0x344B,0x4aa6,{0x8E,0x8B,0x45,0x55,0xA3,0xA4,0x2D,0xFF}}
const IID | IID_IRbtlkTask = {0x2E97DAF4,0x77AC,0x4d04,{0xB9,0xB0,0x1C,0x33,0x99,0x1A,0x78,0xF0}}
const IID | IID_IRbtlkFile = {0x0CF06FBD,0x2D74,0x4b39,{0xB2,0x99,0xEA,0x20,0xF6,0xCA,0x84,0xAC}}
const IID | LIBID_ROBOTALKLib = {0x90A12141,0xBF93,0x4D03,{0x9D,0x76,0x6E,0x70,0xA8,0x3F,0xEC,0x10}}
const CLSID | CLSID_RbtlkEngine = {0x2567A726,0x828B,0x4D30,{0x8E,0x2E,0xE6,0x61,0xF9,0x92,0x1D,0x99}}
const CLSID | CLSID_RbtlkController = {0xE218CEA4,0xEA72,0x4ab3,{0xA5,0xE5,0x6A,0xE4,0xB2,0x83,0x59,0x95}}
const CLSID | CLSID_RbtlkVariable = {0x8D476744,0x65EC,0x456e,{0xA6,0xC7,0x64,0x1D,0x07,0x52,0x0C,0x13}}
const CLSID | CLSID_RbtlkIO = {0xBA8055B8,0x4ED2,0x4d3e,{0xAD,0xFD,0x8A,0x8D,0xB6,0x28,0xEF,0x39}}
const CLSID | CLSID_RbtlkArm = {0x8403C89E,0x8C66,0x4d0b,{0xBB,0xB4,0x8A,0x17,0x0A,0x76,0x7F,0x6F}}
const CLSID | CLSID_RbtlkTask = {0x2A783DB8,0x5443,0x4950,{0xB4,0x60,0x43,0xFA,0x8E,0x7E,0x0B,0xF2}}
const CLSID | CLSID_RbtlkFile = {0x448B9ED4,0x44D4,0x4a29,{0xA3,0x0C,0x95,0x3C,0xA7,0xA2,0x91,0x0B}}

Typedef の解説

typedef IID CLSID

typedef struct _IID IID

変数の解説

const CLSID CLSID_RbtlkArm = {0x8403C89E,0x8C66,0x4d0b,{0xBB,0xB4,0x8A,0x17,0x0A,0x76,0x7F,0x6F}}

const CLSID CLSID_RbtlkController = {0xE218CEA4,0xEA72,0x4ab3,{0xA5,0xE5,0x6A,0xE4,0xB2,0x83,0x59,0x95}}

const CLSID CLSID_RbtlkEngine = {0x2567A726,0x828B,0x4D30,{0x8E,0x2E,0xE6,0x61,0xF9,0x92,0x1D,0x99}}

const CLSID CLSID_RbtlkFile = {0x448B9ED4,0x44D4,0x4a29,{0xA3,0x0C,0x95,0x3C,0xA7,0xA2,0x91,0x0B}}

const CLSID CLSID_RbtlkIO = {0xBA8055B8,0x4ED2,0x4d3e,{0xAD,0xFD,0x8A,0x8D,0xB6,0x28,0xEF,0x39}}

const CLSID CLSID_RbtlkTask = {0x2A783DB8,0x5443,0x4950,{0xB4,0x60,0x43,0xFA,0x8E,0x7E,0x0B,0xF2}}

const CLSID CLSID_RbtlkVariable = {0x8D476744,0x65EC,0x456e,{0xA6,0xC7,0x64,0x1D,0x07,0x52,0x0C,0x13}}

const IID IID_IRbtlkArm = {0xE59220A9,0x344B,0x4aa6,{0x8E,0x8B,0x45,0x55,0xA3,0xA4,0x2D,0xFF}}

const IID IID_IRbtlkController = {0xC85F8BB2,0xEFF4,0x485e,{0xBB,0x44,0xF5,0xDE,0xD2,0x9F,0x27,0x01}}

const IID IID_IRbtlkEngine = {0xF7D1E6C8,0xC6D4,0x4696,{0xBD,0x58,0x28,0x21,0x34,0xD4,0x01,0x34}}

const IID IID_IRbtlkFile = {0x0CF06FBD,0x2D74,0x4b39,{0xB2,0x99,0xEA,0x20,0xF6,0xCA,0x84,0xAC}}

const IID IID_IRbtlkIO = {0xB8937F48,0x2FB7,0x4807,{0x8D,0x2D,0x22,0x00,0x68,0x38,0x01,0xFA}}

const IID IID_IRbtlkTask = {0x2E97DAF4,0x77AC,0x4d04,{0xB9,0xB0,0x1C,0x33,0x99,0x1A,0x78,0xF0}}

const IID IID_IRbtlkVariable = {0x9C5AD78B,0x2D87,0x4bc0,{0x95,0xCC,0xA0,0xCD,0x89,0x7C,0xEE,0xF0}}

const IID LIBID_ROBOTALKLib = {0x90A12141,0xBF93,0x4D03,{0x9D,0x76,0x6E,0x70,0xA8,0x3F,0xEC,0x10}}

Generated on Wed Sep 29 10:57:42 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


ROBOTalk_p.c File Reference

ROBOTalk_p.c の解説

#include "rpcproxy.h"
#include "ROBOTalk.h"

ROBOTalk_p.cのインクルード依存関係図

Include dependency graph

構成

struct | _MIDL_PROC_FORMAT_STRING
struct | _MIDL_TYPE_FORMAT_STRING

マクロ定義

#define | USE_STUBLESS_PROXY
#define | __REQUIRED_RPCPROXY_H_VERSION__ 440
#define | TYPE_FORMAT_STRING_SIZE 243
#define | PROC_FORMAT_STRING_SIZE 4619
#define | _ROBOTalk_CHECK_IID(n) IID_GENERIC_CHECK_IID( _ROBOTalk, pIID, n)

Typedef

typedef _MIDL_TYPE_FORMAT_STRING | MIDL_TYPE_FORMAT_STRING
typedef _MIDL_PROC_FORMAT_STRING | MIDL_PROC_FORMAT_STRING

関数

CINTERFACE_PROXY_VTABLE (21) _IRbtlkEngineProxyVtbl=
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdSetOption_Proxy (IRbtlkController __RPC_FAR *This, short sMode, long lKey, CHAR __RPC_FAR *pVal)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdChangeConfig_Proxy (IRbtlkController __RPC_FAR *This, short sMode)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdLetConfig_Proxy (IRbtlkController __RPC_FAR *This, short sMode, short sIndex, long newVal)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetConfig_Proxy (IRbtlkController __RPC_FAR *This, short sMode, short sIndex, long __RPC_FAR *pVal)
HRESULT STDMETHODCALLTYPE | IRbtlkController_cmdGetStatus_Proxy (IRbtlkController __RPC_FAR *This, short sModule, short sIndex, short __RPC_FAR *pVal)
CINTERFACE_PROXY_VTABLE (37) _IRbtlkControllerProxyVtbl=
CINTERFACE_PROXY_VTABLE (11) _IRbtlkIOProxyVtbl=
CINTERFACE_PROXY_VTABLE (7) _IRbtlkTaskProxyVtbl=
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdDownload0_Proxy (IRbtlkFile __RPC_FAR *This, short sFileID, short __RPC_FAR *psFileID, short __RPC_FAR *psBlockNo, BSTR __RPC_FAR *pbstrData)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdCancelUpload0_Proxy (IRbtlkFile __RPC_FAR *This, short sFileID)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdCancelDownload0_Proxy (IRbtlkFile __RPC_FAR *This, short sFileID)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdGetProgramIndex_Proxy (IRbtlkFile __RPC_FAR *This, CHAR __RPC_FAR *szName, short __RPC_FAR *pVal)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdDeleteFile0_Proxy (IRbtlkFile __RPC_FAR *This, CHAR __RPC_FAR *szName)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdGetFileCnt0_Proxy (IRbtlkFile __RPC_FAR *This, short __RPC_FAR *psFiles)
HRESULT STDMETHODCALLTYPE | IRbtlkFile_cmdGetFileName0_Proxy (IRbtlkFile __RPC_FAR *This, short sIndex, CHAR __RPC_FAR *pVal)
int __stdcall | _ROBOTalk_IID_Lookup (const IID *pIID, int *pIndex)

変数

const MIDL_TYPE_FORMAT_STRING | __MIDL_TypeFormatString
const MIDL_PROC_FORMAT_STRING | __MIDL_ProcFormatString
const MIDL_STUB_DESC | Object_StubDesc
const MIDL_SERVER_INFO | IRbtlkEngine_ServerInfo
const unsigned short | IRbtlkEngine_FormatStringOffsetTable []
const MIDL_STUBLESS_PROXY_INFO | IRbtlkEngine_ProxyInfo
const CInterfaceStubVtbl | _IRbtlkEngineStubVtbl
const MIDL_SERVER_INFO | IRbtlkController_ServerInfo
const unsigned short | IRbtlkController_FormatStringOffsetTable []
const MIDL_STUBLESS_PROXY_INFO | IRbtlkController_ProxyInfo
const CInterfaceStubVtbl | _IRbtlkControllerStubVtbl
const MIDL_SERVER_INFO | IRbtlkVariable_ServerInfo
const unsigned short | IRbtlkVariable_FormatStringOffsetTable []
const MIDL_STUBLESS_PROXY_INFO | IRbtlkVariable_ProxyInfo
const CInterfaceStubVtbl | _IRbtlkVariableStubVtbl
const MIDL_SERVER_INFO | IRbtlkIO_ServerInfo
const unsigned short | IRbtlkIO_FormatStringOffsetTable []
const MIDL_STUBLESS_PROXY_INFO | IRbtlkIO_ProxyInfo
const CInterfaceStubVtbl | _IRbtlkIOStubVtbl
const MIDL_SERVER_INFO | IRbtlkArm_ServerInfo
const unsigned short | IRbtlkArm_FormatStringOffsetTable []
const MIDL_STUBLESS_PROXY_INFO | IRbtlkArm_ProxyInfo
const CInterfaceStubVtbl | _IRbtlkArmStubVtbl
const MIDL_SERVER_INFO | IRbtlkTask_ServerInfo
const unsigned short | IRbtlkTask_FormatStringOffsetTable []
const MIDL_STUBLESS_PROXY_INFO | IRbtlkTask_ProxyInfo
const CInterfaceStubVtbl | _IRbtlkTaskStubVtbl
const MIDL_SERVER_INFO | IRbtlkFile_ServerInfo
const USER_MARSHAL_ROUTINE_QUADRUPLE | UserMarshalRoutines [1]
const unsigned short | IRbtlkFile_FormatStringOffsetTable []
const MIDL_STUBLESS_PROXY_INFO | IRbtlkFile_ProxyInfo
const CInterfaceStubVtbl | _IRbtlkFileStubVtbl
const CInterfaceProxyVtbl * | _ROBOTalk_ProxyVtblList []
const CInterfaceStubVtbl * | _ROBOTalk_StubVtblList []
PCInterfaceName const | _ROBOTalk_InterfaceNamesList []
const ExtendedProxyFileInfo | ROBOTalk_ProxyFileInfo

マクロ定義の解説

#define __REQUIRED_RPCPROXY_H_VERSION__ 440

#define _ROBOTalk_CHECK_IID ( n ) IID_GENERIC_CHECK_IID( _ROBOTalk, pIID, n)

#define PROC_FORMAT_STRING_SIZE 4619

#define TYPE_FORMAT_STRING_SIZE 243

#define USE_STUBLESS_PROXY

Typedef の解説

typedef struct _MIDL_PROC_FORMAT_STRING MIDL_PROC_FORMAT_STRING

typedef struct _MIDL_TYPE_FORMAT_STRING MIDL_TYPE_FORMAT_STRING

関数の解説

int __stdcall _ROBOTalk_IID_Lookup | ( | const IID * | pIID,
 |  | int * | pIndex
 | ) |

CINTERFACE_PROXY_VTABLE ( 7 )

CINTERFACE_PROXY_VTABLE ( 11 )

CINTERFACE_PROXY_VTABLE ( 37 )

CINTERFACE_PROXY_VTABLE ( 21 )

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdChangeConfig_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sMode
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetConfig_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sMode,
 |  | short | sIndex,
 |  | long __RPC_FAR * | pVal
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetStatus_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sModule,
 |  | short | sIndex,
 |  | short __RPC_FAR * | pVal
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdLetConfig_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sMode,
 |  | short | sIndex,
 |  | long | newVal
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkController_cmdSetOption_Proxy | ( | IRbtlkController __RPC_FAR * | This,
 |  | short | sMode,
 |  | long | lKey,
 |  | CHAR __RPC_FAR * | pVal
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdCancelDownload0_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sFileID
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdCancelUpload0_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sFileID
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdDeleteFile0_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | CHAR __RPC_FAR * | szName
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdDownload0_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sFileID,
 |  | short __RPC_FAR * | psFileID,
 |  | short __RPC_FAR * | psBlockNo,
 |  | BSTR __RPC_FAR * | pbstrData
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetFileCnt0_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short __RPC_FAR * | psFiles
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetFileName0_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | short | sIndex,
 |  | CHAR __RPC_FAR * | pVal
 | ) |

HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetProgramIndex_Proxy | ( | IRbtlkFile __RPC_FAR * | This,
 |  | CHAR __RPC_FAR * | szName,
 |  | short __RPC_FAR * | pVal
 | ) |

変数の解説

const MIDL_PROC_FORMAT_STRING __MIDL_ProcFormatString

const MIDL_TYPE_FORMAT_STRING __MIDL_TypeFormatString

const CInterfaceStubVtbl _IRbtlkArmStubVtbl

初期値:

{
    &IID_IRbtlkArm,
    &IRbtlkArm_ServerInfo,
    18,
    0,
    CStdStubBuffer_METHODS
}

const CInterfaceStubVtbl _IRbtlkControllerStubVtbl

初期値:

{
    &IID_IRbtlkController,
    &IRbtlkController_ServerInfo,
    37,
    0,
    CStdStubBuffer_METHODS
}

const CInterfaceStubVtbl _IRbtlkEngineStubVtbl

初期値:

{
    &IID_IRbtlkEngine,
    &IRbtlkEngine_ServerInfo,
    21,
    0,
    CStdStubBuffer_METHODS
}

const CInterfaceStubVtbl _IRbtlkFileStubVtbl

初期値:

{
    &IID_IRbtlkFile,
    &IRbtlkFile_ServerInfo,
    39,
    0,
    CStdStubBuffer_METHODS
}

const CInterfaceStubVtbl _IRbtlkIOStubVtbl

初期値:

{
    &IID_IRbtlkIO,
    &IRbtlkIO_ServerInfo,
    11,
    0,
    CStdStubBuffer_METHODS
}

const CInterfaceStubVtbl _IRbtlkTaskStubVtbl

初期値:

{
    &IID_IRbtlkTask,
    &IRbtlkTask_ServerInfo,
    7,
    0,
    CStdStubBuffer_METHODS
}

const CInterfaceStubVtbl _IRbtlkVariableStubVtbl

初期値:

{
    &IID_IRbtlkVariable,
    &IRbtlkVariable_ServerInfo,
    22,
    0,
    CStdStubBuffer_METHODS
}

PCInterfaceName const _ROBOTalk_InterfaceNamesList[]

初期値:

{
    "IRbtlkIO",
    "IRbtlkVariable",
    "IRbtlkArm",
    "IRbtlkController",
    "IRbtlkFile",
    "IRbtlkEngine",
    "IRbtlkTask",
    0
}

const CInterfaceProxyVtbl* _ROBOTalk_ProxyVtblList[]

初期値:

{
    ( CInterfaceProxyVtbl *) &_IRbtlkIOProxyVtbl,
    ( CInterfaceProxyVtbl *) &_IRbtlkVariableProxyVtbl,
    ( CInterfaceProxyVtbl *) &_IRbtlkArmProxyVtbl,
    ( CInterfaceProxyVtbl *) &_IRbtlkControllerProxyVtbl,
    ( CInterfaceProxyVtbl *) &_IRbtlkFileProxyVtbl,
    ( CInterfaceProxyVtbl *) &_IRbtlkEngineProxyVtbl,
    ( CInterfaceProxyVtbl *) &_IRbtlkTaskProxyVtbl,
    0
}

const CInterfaceStubVtbl* _ROBOTalk_StubVtblList[]

初期値:

{
    ( CInterfaceStubVtbl *) &_IRbtlkIOStubVtbl,
    ( CInterfaceStubVtbl *) &_IRbtlkVariableStubVtbl,
    ( CInterfaceStubVtbl *) &_IRbtlkArmStubVtbl,
    ( CInterfaceStubVtbl *) &_IRbtlkControllerStubVtbl,
    ( CInterfaceStubVtbl *) &_IRbtlkFileStubVtbl,
    ( CInterfaceStubVtbl *) &_IRbtlkEngineStubVtbl,
    ( CInterfaceStubVtbl *) &_IRbtlkTaskStubVtbl,
    0
}

const unsigned short IRbtlkArm_FormatStringOffsetTable[] [static]

初期値:

    {
    2670,
    2698,
    2726,
    2760,
    2794,
    2828,
    2862,
    2908,
    2954,
    3012,
    3070,
    3098,
    3126,
    3154,
    3182
    }

const MIDL_STUBLESS_PROXY_INFO IRbtlkArm_ProxyInfo [static]

初期値:

    {
    &Object_StubDesc,
    __MIDL_ProcFormatString.Format,
    &IRbtlkArm_FormatStringOffsetTable[-3],
    0,
    0,
    0
    }

const MIDL_SERVER_INFO IRbtlkArm_ServerInfo

初期値:

    {
    &Object_StubDesc,
    0,
    __MIDL_ProcFormatString.Format,
    &IRbtlkArm_FormatStringOffsetTable[-3],
    0,
    0,
    0,
    0
    }

const unsigned short IRbtlkController_FormatStringOffsetTable[] [static]

const MIDL_STUBLESS_PROXY_INFO IRbtlkController_ProxyInfo [static]

初期値:

    {
    &Object_StubDesc,
    __MIDL_ProcFormatString.Format,
    &IRbtlkController_FormatStringOffsetTable[-3],
    0,
    0,
    0
    }

const MIDL_SERVER_INFO IRbtlkController_ServerInfo

初期値:

    {
    &Object_StubDesc,
    0,
    __MIDL_ProcFormatString.Format,
    &IRbtlkController_FormatStringOffsetTable[-3],
    0,
    0,
    0,
    0
    }

const unsigned short IRbtlkEngine_FormatStringOffsetTable[] [static]

初期値:

    {
    0,
    28,
    50,
    72,
    112,
    140,
    168,
    196,
    224,
    252,
    280,
    308,
    336,
    364,
    392,
    420,
    448,
    476
    }

const MIDL_STUBLESS_PROXY_INFO IRbtlkEngine_ProxyInfo [static]

初期値:

    {
    &Object_StubDesc,
    __MIDL_ProcFormatString.Format,
    &IRbtlkEngine_FormatStringOffsetTable[-3],
    0,
    0,
    0
    }

const MIDL_SERVER_INFO IRbtlkEngine_ServerInfo

初期値:

    {
    &Object_StubDesc,
    0,
    __MIDL_ProcFormatString.Format,
    &IRbtlkEngine_FormatStringOffsetTable[-3],
    0,
    0,
    0,
    0
    }

const unsigned short IRbtlkFile_FormatStringOffsetTable[] [static]

const MIDL_STUBLESS_PROXY_INFO IRbtlkFile_ProxyInfo [static]

初期値:

    {
    &Object_StubDesc,
    __MIDL_ProcFormatString.Format,
    &IRbtlkFile_FormatStringOffsetTable[-3],
    0,
    0,
    0
    }

const MIDL_SERVER_INFO IRbtlkFile_ServerInfo

初期値:

    {
    &Object_StubDesc,
    0,
    __MIDL_ProcFormatString.Format,
    &IRbtlkFile_FormatStringOffsetTable[-3],
    0,
    0,
    0,
    0
    }

const unsigned short IRbtlkIO_FormatStringOffsetTable[] [static]

初期値:

    {
    2392,
    2426,
    2460,
    2494,
    2528,
    2562,
    2596,
    2630
    }

const MIDL_STUBLESS_PROXY_INFO IRbtlkIO_ProxyInfo [static]

初期値:

    {
    &Object_StubDesc,
    __MIDL_ProcFormatString.Format,
    &IRbtlkIO_FormatStringOffsetTable[-3],
    0,
    0,
    0
    }

const MIDL_SERVER_INFO IRbtlkIO_ServerInfo

初期値:

    {
    &Object_StubDesc,
    0,
    __MIDL_ProcFormatString.Format,
    &IRbtlkIO_FormatStringOffsetTable[-3],
    0,
    0,
    0,
    0
    }

const unsigned short IRbtlkTask_FormatStringOffsetTable[] [static]

初期値:

    {
    3210,
    3238,
    3278,
    3312
    }

const MIDL_STUBLESS_PROXY_INFO IRbtlkTask_ProxyInfo [static]

初期値:

    {
    &Object_StubDesc,
    __MIDL_ProcFormatString.Format,
    &IRbtlkTask_FormatStringOffsetTable[-3],
    0,
    0,
    0
    }

const MIDL_SERVER_INFO IRbtlkTask_ServerInfo

初期値:

    {
    &Object_StubDesc,
    0,
    __MIDL_ProcFormatString.Format,
    &IRbtlkTask_FormatStringOffsetTable[-3],
    0,
    0,
    0,
    0
    }

const unsigned short IRbtlkVariable_FormatStringOffsetTable[] [static]

初期値:

    {
    1620,
    1660,
    1700,
    1740,
    1780,
    1820,
    1860,
    1900,
    1940,
    1980,
    2020,
    2060,
    2100,
    2140,
    2180,
    2220,
    2260,
    2300,
    2346
    }

const MIDL_STUBLESS_PROXY_INFO IRbtlkVariable_ProxyInfo [static]

初期値:

    {
    &Object_StubDesc,
    __MIDL_ProcFormatString.Format,
    &IRbtlkVariable_FormatStringOffsetTable[-3],
    0,
    0,
    0
    }

const MIDL_SERVER_INFO IRbtlkVariable_ServerInfo

初期値:

    {
    &Object_StubDesc,
    0,
    __MIDL_ProcFormatString.Format,
    &IRbtlkVariable_FormatStringOffsetTable[-3],
    0,
    0,
    0,
    0
    }

const MIDL_STUB_DESC Object_StubDesc

初期値:

    {
    0,
    NdrOleAllocate,
    NdrOleFree,
    0,
    0,
    0,
    0,
    0,
    __MIDL_TypeFormatString.Format,
    1,
    0x20000,
    0,
    0x50100a4,
    0,
    UserMarshalRoutines,
    0,
    1,
    0,
    0,
    0
    }

const ExtendedProxyFileInfo ROBOTalk_ProxyFileInfo

初期値:

{
    (PCInterfaceProxyVtblList *) & _ROBOTalk_ProxyVtblList,
    (PCInterfaceStubVtblList *) & _ROBOTalk_StubVtblList,
    (const PCInterfaceName * ) & _ROBOTalk_InterfaceNamesList,
    0,
    & _ROBOTalk_IID_Lookup,
    7,
    2,
    0,
    0,
    0,
    0
}

const USER_MARSHAL_ROUTINE_QUADRUPLE UserMarshalRoutines

初期値:

        {

            {
            BSTR_UserSize
            ,BSTR_UserMarshal
            ,BSTR_UserUnmarshal
            ,BSTR_UserFree
            }

        }

Generated on Wed Sep 29 10:57:42 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


Serial.cpp File Reference

Serial.cpp の解説

CSerial クラスのインプリメンテーション. [詳細]

#include "stdafx.h"
#include "Serial.h"

Serial.cppのインクルード依存関係図

Include dependency graph

解説

CSerial クラスのインプリメンテーション.

バージョン:
1.0
日付:
2004/2/19
作者:
DENSO WAVE
Generated on Wed Sep 29 10:57:42 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


Serial.h File Reference

Serial.h の解説

CSerial クラスのインターフェイス. [詳細]

#include "Device.h"
#include <stdio.h>

Serial.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CSerial
Serial通信用クラス. [詳細]

マクロ定義

#define | AFX_SERIAL_H__DEDDC022_9FCD_43A7_A7DD_A620C7D69DCA__INCLUDED_
#define | SERIAL_PORT_MAX 256
#define | SERIAL_BASE_TIMEOUT 50

解説

CSerial クラスのインターフェイス.

バージョン:
1.0
日付:
2004/2/19
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_SERIAL_H__DEDDC022_9FCD_43A7_A7DD_A620C7D69DCA__INCLUDED_

#define SERIAL_BASE_TIMEOUT 50

#define SERIAL_PORT_MAX 256

Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


StdAfx.cpp File Reference

StdAfx.cpp の解説

#include "stdafx.h"
#include <atlimpl.cpp>

StdAfx.cppのインクルード依存関係図

Include dependency graph
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


StdAfx.h File Reference

StdAfx.h の解説

#include <atlbase.h>
#include <atlcom.h>
#include "RbtlkHeader.h"
#include <map>

StdAfx.hのインクルード依存関係図

Include dependency graph

ソースコードを見る。

構成

struct | EtherParam
Connect()引数のパラメータ構造体 (EtherNetクライアント). [詳細]

struct | SerialParam
Connect()引数のパラメータ構造体. [詳細]

マクロ定義

#define | AFX_STDAFX_H__CC0FF5A6_2B7E_440F_90F4_45B40D643078__INCLUDED_
#define | STRICT
#define | _WIN32_WINNT 0x0400
#define | _ATL_APARTMENT_THREADED
#define | E_ABNORMAL_S_PACKET _HRESULT_TYPEDEF_(0x80000904L)

変数

CComModule | _Module
std::map< BYTE, PVOID > | g_mapID

マクロ定義の解説

#define _ATL_APARTMENT_THREADED

#define _WIN32_WINNT 0x0400

#define AFX_STDAFX_H__CC0FF5A6_2B7E_440F_90F4_45B40D643078__INCLUDED_

#define E_ABNORMAL_S_PACKET _HRESULT_TYPEDEF_(0x80000904L)

#define STRICT

変数の解説

CComModule _Module

std::map<BYTE, PVOID> g_mapID

Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


Annotated Index

DENSO WAVE ROBOTalk Project 構成

クラス、構造体、共用体、インタフェースの解説です。
__MIDL_IRbtlkEngine_0002 |
_IID |
_MIDL_PROC_FORMAT_STRING |
_MIDL_TYPE_FORMAT_STRING |
CDevice | Deviceクラス
CEtherUDP |
CRbtlkArm |
CRbtlkController |
CRbtlkEngine |
CRbtlkFile |
CRbtlkIO |
CRbtlkTask |
CRbtlkVariable |
CSerial | Serial通信用クラス
EtherParam | Connect()引数のパラメータ構造体 (EtherNetクライアント)
IRbtlkArm |
IRbtlkController |
IRbtlkEngine |
IRbtlkEngine::RTK_PACKET |
IRbtlkFile |
IRbtlkIO |
IRbtlkTask |
IRbtlkVariable |
ROBOTALKLib::RbtlkArm |
ROBOTALKLib::RbtlkController |
ROBOTALKLib::RbtlkEngine |
ROBOTALKLib::RbtlkFile |
ROBOTALKLib::RbtlkIO |
ROBOTALKLib::RbtlkTask |
ROBOTALKLib::RbtlkVariable |
SerialParam | Connect()引数のパラメータ構造体
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


__MIDL_IRbtlkEngine_0002 struct Reference

構造体 __MIDL_IRbtlkEngine_0002 の解説

#include <ROBOTalk.h>

すべてのメンバ一覧

Public 変数

BYTE | bEnq
BYTE | bLength
WORD | wCommand
BYTE | bID1
BYTE | bID2
BYTE | bData [248]
BYTE | bCDH
BYTE | bCDL

変数の解説

BYTE __MIDL_IRbtlkEngine_0002::bCDH

BYTE __MIDL_IRbtlkEngine_0002::bCDL

BYTE __MIDL_IRbtlkEngine_0002::bData[ 248 ]

BYTE __MIDL_IRbtlkEngine_0002::bEnq

BYTE __MIDL_IRbtlkEngine_0002::bID1

BYTE __MIDL_IRbtlkEngine_0002::bID2

BYTE __MIDL_IRbtlkEngine_0002::bLength

WORD __MIDL_IRbtlkEngine_0002::wCommand

この構造体の解説は次のファイルから生成されました:
  • ROBOTalk.h
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


_IID struct Reference

構造体 _IID の解説

すべてのメンバ一覧

Public 変数

unsigned long | x
unsigned short | s1
unsigned short | s2
unsigned char | c [8]

変数の解説

unsigned char _IID::c[8]

unsigned short _IID::s1

unsigned short _IID::s2

unsigned long _IID::x

この構造体の解説は次のファイルから生成されました:
  • ROBOTalk_i.c
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


_MIDL_PROC_FORMAT_STRING struct Reference

構造体 _MIDL_PROC_FORMAT_STRING の解説

すべてのメンバ一覧

Public 変数

short | Pad
unsigned char | Format [PROC_FORMAT_STRING_SIZE]

変数の解説

unsigned char _MIDL_PROC_FORMAT_STRING::Format[ PROC_FORMAT_STRING_SIZE ]

short _MIDL_PROC_FORMAT_STRING::Pad

この構造体の解説は次のファイルから生成されました:
  • ROBOTalk_p.c
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


_MIDL_TYPE_FORMAT_STRING struct Reference

構造体 _MIDL_TYPE_FORMAT_STRING の解説

すべてのメンバ一覧

Public 変数

short | Pad
unsigned char | Format [TYPE_FORMAT_STRING_SIZE]

変数の解説

unsigned char _MIDL_TYPE_FORMAT_STRING::Format[ TYPE_FORMAT_STRING_SIZE ]

short _MIDL_TYPE_FORMAT_STRING::Pad

この構造体の解説は次のファイルから生成されました:
  • ROBOTalk_p.c
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


CDevice class Reference

クラス CDevice の解説

Deviceクラス. [詳細]

#include <Device.h>

CDeviceに対する継承グラフ

[凡例]
すべてのメンバ一覧

Public メソッド

CDevice ()
CDevice のコンストラクタ.

virtual | ~CDevice ()
CDevice のデストラクタ.

virtual HRESULT | Initialize (PVOID pArgs[])
初期化処理処理

virtual HRESULT | Connect (CDevice **ppNewDevice=NULL)
接続処理

virtual HRESULT | Disconnect (void)
切断処理

HRESULT | Send (LPBYTE lpszData, DWORD dwSendLen=0)
データ送信

HRESULT | Receive (LPBYTE lpszData, DWORD dwBufSize, DWORD *pdwReceivedLen, int nTermCount=1)
データ受信

virtual HRESULT | SendAndReceive (LPBYTE lpszSendData, LPBYTE lpszReceiveData, DWORD dwRecvSize, DWORD *pdwRecvLen, int nTermCount=1, DWORD dwRetryCnt=0)
送受信一括処理

virtual HRESULT | Flush (void)
バッファクリア

virtual HRESULT | SetTimeOut (DWORD dwTimeout)
タイムアウト時間の更新

virtual DWORD | GetTimeOut (void)
タイムアウト時間の取得

virtual DWORD | GetReceivedCount (void)
データ受信数の取得

Protected メソッド

HRESULT | GetRecivePacket (LPSTR lpszData, DWORD dwBufSize, DWORD *pdwReceivedLen, int nTermCount=1)
受信パケットの取得

Protected 変数

BOOL | m_bConnected
DWORD | m_dwRetryCnt
DWORD | m_dwTotalTimeout
DWORD | m_dwMode
動作モード

DWORD | m_dwHeaderLen
ヘッダ長

CHAR * | m_pcHeader
ヘッダコード : CR->cTerm[0]=0x0D, LF->cTerm[0]=0x0A, CR+LF ->cTerm[0]=0x0D,cTerm[1]=0x0A

DWORD | m_dwTermLen
ターミネータ長 : 0,1,2

CHAR * | m_pcTerm
ターミネータコード : CR->cTerm[0]=0x0D, LF->cTerm[0]=0x0A, CR+LF ->cTerm[0]=0x0D,cTerm[1]=0x0A

char | m_szLocalBuffer [LOCAL_BUFFER_MAX]
ローカル受信バッファ

DWORD | m_dwLocalBufferLen
ローカル受信バッファ長

解説

Deviceクラス.

Stream通信用のメソッドを提供する基本クラス．
実際にStream通信を実装する時には，このクラスを継承すること．

コンストラクタとデストラクタの解説

CDevice::CDevice ( )

CDevice のコンストラクタ.

CDevice::~CDevice ( ) [virtual]

CDevice のデストラクタ.

メソッドの解説

HRESULT CDevice::Connect ( CDevice ** ppNewDevice = NULL ) [virtual]

接続処理

  ターゲットとの接続をする

引数:
ppNewDevice : [out] 接続済みデバイス
戻り値:
HRESULT

CEtherUDP, と CSerialで再定義されています。

HRESULT CDevice::Disconnect ( void ) [virtual]

切断処理

  ターゲットとの接続を切断する

戻り値:
HRESULT

CEtherUDP, と CSerialで再定義されています。

HRESULT CDevice::Flush ( void ) [virtual]

バッファクリア

  バッファクリアとエラークリア処理を行う

戻り値:
HRESULT

CEtherUDP, と CSerialで再定義されています。

DWORD CDevice::GetReceivedCount ( void ) [virtual]

データ受信数の取得

  現在受信バッファにあるデータ数を取得する

戻り値:
DWORD : データ受信数

CEtherUDP, と CSerialで再定義されています。

HRESULT CDevice::GetRecivePacket | ( | LPSTR | lpszData,
 |  | DWORD | dwBufSize,
 |  | DWORD * | pdwRecvedLen,
 |  | int | nTermCount = 1
 | ) | [protected]

受信パケットの取得

  ローカル受信バッファからパケットを取得する． 　パケットの区切りはInitialize()で設定した終了コードで識別する． 　受信データがないとき，及びターミネータがないときはS_FALSEを返す．

引数:
lpszData | : [in] 受信データの格納先アドレス
dwBufSize | : [in] lpszDataのバッファサイズ（Bytes）
pdwRecvedLen | : [in] 受信データ数(Bytes)
nTermCount | : [in] 受信完了を判定するためのターミネータ受信回数
戻り値:
HRESULT

DWORD CDevice::GetTimeOut ( void ) [virtual]

タイムアウト時間の取得

  タイムアウト時間の取得を行う

戻り値:
DWORD : [out] タイムアウト時間

HRESULT CDevice::Initialize ( PVOID pArgs[] ) [virtual]

初期化処理処理

  ターゲットとの接続をする

引数:
pArgs [] : [in]　pArgs[0] - ヘッダコード
          pArgs[1] - ターミネータコード
          pArgs[2] - 動作モード
戻り値:
HRESULT

CEtherUDP, と CSerialで再定義されています。

HRESULT CDevice::Receive | ( | LPBYTE | lpszData,
 |  | DWORD | dwBufSize,
 |  | DWORD * | pdwRecvedLen,
 |  | int | nTermCount = 1
 | ) |

データ受信

  ターゲットから文字列データを受信する(未実装) 　モードによって受信した文字コードを変換して返す．

引数:
lpszData | : [in] 受信データの格納先アドレス
dwBufSize | : [in] lpszDataのバッファサイズ（Bytes）
pdwRecvedLen | : [in] 受信データ数(Bytes)
nTermCount | : [in] 受信完了を判定するためのターミネータ受信回数
戻り値:
HRESULT

HRESULT CDevice::Send | ( | LPBYTE | lpszData,
 |  | DWORD | dwSendLen = 0
 | ) |

データ送信

  指定文字列データをターゲットに送信する.
  モードによって文字コードを変換して送信する．

引数:
lpszData | : [in] 文字列データ
dwSendLen | : [out] データ長
戻り値:
HRESULT

HRESULT CDevice::SendAndReceive | ( | LPBYTE | lpszSendData,
 |  | LPBYTE | lpszReceiveData,
 |  | DWORD | dwRecvSize,
 |  | DWORD * | pdwRecvLen,
 |  | int | nTermCnt = 1,
 |  | DWORD | dwRetryCnt = 0
 | ) | [virtual]

送受信一括処理

  送信->受信を一括して処理する．応答がなかった場合はリトライを行う

引数:
lpszSendData | : [in] 送信データ文字列
lpszReceiveData | : [in] 受信データの格納先アドレス
dwRecvSize | : [in] lpszDataのバッファサイズ（Bytes）
pdwRecvLen | : [in] 受信データ数(Bytes)
nTermCnt | : [in] 受信完了を判定するためのターミネータ受信回数
dwRetryCnt | : [in] リトライ回数
戻り値:
HRESULT

HRESULT CDevice::SetTimeOut ( DWORD dwTimeout ) [virtual]

タイムアウト時間の更新

  タイムアウト時間の更新を行う

引数:
dwTimeout : [in] タイムアウト時間
戻り値:
HRESULT

CEtherUDP, と CSerialで再定義されています。

変数の解説

BOOL CDevice::m_bConnected [protected]

DWORD CDevice::m_dwHeaderLen [protected]

ヘッダ長

DWORD CDevice::m_dwLocalBufferLen [protected]

ローカル受信バッファ長

DWORD CDevice::m_dwMode [protected]

動作モード

DWORD CDevice::m_dwRetryCnt [protected]

DWORD CDevice::m_dwTermLen [protected]

ターミネータ長 : 0,1,2

DWORD CDevice::m_dwTotalTimeout [protected]

CHAR* CDevice::m_pcHeader [protected]

ヘッダコード : CR->cTerm[0]=0x0D, LF->cTerm[0]=0x0A, CR+LF ->cTerm[0]=0x0D,cTerm[1]=0x0A

CHAR* CDevice::m_pcTerm [protected]

ターミネータコード : CR->cTerm[0]=0x0D, LF->cTerm[0]=0x0A, CR+LF ->cTerm[0]=0x0D,cTerm[1]=0x0A

char CDevice::m_szLocalBuffer[LOCAL_BUFFER_MAX] [protected]

ローカル受信バッファ

このクラスの解説は次のファイルから生成されました:
  • Device.h
  • Device.cpp
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


CEtherUDP class Reference

クラス CEtherUDP の解説

#include <EtherUDP.h>

CEtherUDPに対する継承グラフ

[凡例]
CEtherUDPのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CEtherUDP ()
CEtherUDP のコンストラクタ.

virtual | ~CEtherUDP ()
CEtherUDP のデストラクタ.

virtual HRESULT | Connect (CDevice **ppNewDevice=NULL)
接続処理(ETHER)

virtual HRESULT | Disconnect (void)
切断処理

virtual HRESULT | Flush (void)
バッファクリア

virtual HRESULT | SetTimeOut (DWORD dwTimeout)
タイムアウト時間の更新

virtual DWORD | GetReceivedCount ()
データ受信数の取得

HRESULT | Initialize (PVOID pArgs[])
初期化処理処理

コンストラクタとデストラクタの解説

CEtherUDP::CEtherUDP ( )

CEtherUDP のコンストラクタ.

CEtherUDP::~CEtherUDP ( ) [virtual]

CEtherUDP のデストラクタ.

メソッドの解説

HRESULT CEtherUDP::Connect ( CDevice ** ppNewDevice = NULL ) [virtual]

接続処理(ETHER)

  ターゲットとの接続をする

引数:
ppNewDevice : [out] 接続済みデバイス
戻り値:
HRESULT

CDeviceを再定義しています。

HRESULT CEtherUDP::Disconnect ( void ) [virtual]

切断処理

  ターゲットとの切断処理を行う．

戻り値:
HRESULT

CDeviceを再定義しています。

HRESULT CEtherUDP::Flush ( void ) [virtual]

バッファクリア

  バッファクリアとエラークリア処理を行う

戻り値:
HRESULT

CDeviceを再定義しています。

DWORD CEtherUDP::GetReceivedCount ( void ) [virtual]

データ受信数の取得

  現在受信バッファにあるデータ数を取得する

戻り値:
DWORD : データ受信数

CDeviceを再定義しています。

HRESULT CEtherUDP::Initialize ( PVOID pArgs[] ) [virtual]

初期化処理処理

  ターゲットとの接続をする

引数:
pArgs [] : [in]　pArgs[0] - ターミネータ長
          pArgs[1] - ターミネータコード
          pArgs[2] - 動作モード
          pArgs[3] - IPアドレス inet_addr()形式
          pArgs[4] - ポートの番号
戻り値:
HRESULT

CDeviceを再定義しています。

HRESULT CEtherUDP::SetTimeOut ( DWORD dwTimeout ) [virtual]

タイムアウト時間の更新

  タイムアウト時間の更新を行う

引数:
dwTimeout : [in] タイムアウト時間
戻り値:
HRESULT

CDeviceを再定義しています。

このクラスの解説は次のファイルから生成されました:
  • EtherUDP.h
  • EtherUDP.cpp
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


CRbtlkArm class Reference

クラス CRbtlkArm の解説

#include <RbtlkArm.h>

CRbtlkArmのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CRbtlkArm ()
HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | cmdThere (float *pVal)
ロボット現在位置の取得

HRESULT | cmdGetWorkIndex (short *pVal)
使用中のワーク番号取得

HRESULT | cmdGetToolIndex (short *pVal)
使用中のツール番号取得

HRESULT | cmdLetAreaEx (short sNo, float *pf, short sIO, short sPos, short sErr, short sEnable)
エリア 設定値 設定

HRESULT | cmdGetAreaEx (short sNo, float *pf, short *psIO, short *psPos, short *psErr, short *psEnable)
エリア 設定値 取得

HRESULT | cmdLetArea (short sNo, float *pf, short sIO, short sPos)
エリア 設定値 設定

HRESULT | cmdGetArea (short sNo, float *pf, short *psIO, short *psPos)
エリア 設定値 取得

HRESULT | cmdLetWork (short sNo, float *pf)
ワーク 設定値 設定

HRESULT | cmdGetWork (short sNo, float *pf)
ワーク 設定値 取得

HRESULT | cmdLetTool (short sNo, float *pf)
ツール 設定値 設定

HRESULT | cmdGetTool (short sNo, float *pf)
ツール 設定値 取得

HRESULT | cmdJHere (float *pVal)
ロボット現在軸値取得

HRESULT | cmdHere (float *pVal)
ロボット現在位置の取得

HRESULT | cmdEnableArea (short sNo)
指定のエリア機能を有効にする

HRESULT | cmdDisableArea (short sNo)
指定のエリア機能を無効にする

HRESULT | Initialize (CRbtlkEngine *pIRbtlkEng)
初期化関数

コンストラクタとデストラクタの解説

CRbtlkArm::CRbtlkArm ( ) [inline]

メソッドの解説

STDMETHODIMP CRbtlkArm::cmdDisableArea ( short sNo )

指定のエリア機能を無効にする

引数:
sNo : [out] エリア番号
戻り値:
HRESULT

STDMETHODIMP CRbtlkArm::cmdEnableArea ( short sNo )

指定のエリア機能を有効にする

引数:
sNo : [out] エリア番号
戻り値:
HRESULT

STDMETHODIMP CRbtlkArm::cmdGetArea | ( | short | sNo,
 |  | float * | pf,
 |  | short * | psIO,
 |  | short * | psPos
 | ) |

エリア 設定値 取得

  エリアを示すベクトル(float*9)、ポート番号(short)、ポジション番号(short)を取得する． 返り値のメモリ領域はこのメソッドでは確保しないので、呼び出し側で確保すること．

引数:
sNo | : [in] エリア番号
pf | : [out] エリアを示すベクトル
psIO | : [out] ポート番号
psPos | : [out] ポジション番号
戻り値:
HRESULT

STDMETHODIMP CRbtlkArm::cmdGetAreaEx | ( | short | sNo,
 |  | float * | pf,
 |  | short * | psIO,
 |  | short * | psPos,
 |  | short * | psErr,
 |  | short * | psEnable
 | ) |

エリア 設定値 取得

  エリアを示すベクトル(float*9)、ポート番号(short)、ポジション番号(short)、エラーフラグ(short)、機能の有効無効(short)を取得する． 返り値のメモリ領域はこのメソッドでは確保しないので、呼び出し側で確保すること．

引数:
sNo | : [in] エリア番号
pf | : [out] エリアを示すベクトル
psIO | : [out] ポート番号
psPos | : [out] ポジション番号
psErr | : [out] エラーフラグ
psEnable | : [out] 機能の有効無効
戻り値:
HRESULT

STDMETHODIMP CRbtlkArm::cmdGetTool | ( | short | sNo,
 |  | float * | pf
 | ) |

ツール 設定値 取得

  ツール座標(float*6)を返す． 返り値のメモリ領域はこのメソッドでは確保しないので、呼び出し側で確保すること．

引数:
sNo | : [in] ツール番号
pf | : [out] ツール座標
戻り値:
HRESULT

STDMETHODIMP CRbtlkArm::cmdGetToolIndex ( short * pVal )

使用中のツール番号取得

引数:
pVal : [out] ツール番号
戻り値:
HRESULT

STDMETHODIMP CRbtlkArm::cmdGetWork | ( | short | sNo,
 |  | float * | pf
 | ) |

ワーク 設定値 取得

  ワーク座標(float*6)を取得する． 返り値のメモリ領域はこのメソッドでは確保しないので、呼び出し側で確保すること．

引数:
sNo | : [in] ツール番号
pf | : [out] ワーク座標
戻り値:
HRESULT

STDMETHODIMP CRbtlkArm::cmdGetWorkIndex ( short * pVal )

使用中のワーク番号取得

引数:
pVal : [out] ワーク番号
戻り値:
HRESULT

STDMETHODIMP CRbtlkArm::cmdHere ( float * pVal )

ロボット現在位置の取得

  P型変数(float*7)で現在位置を返す． 返り値のメモリ領域はこのメソッドでは確保しないので、呼び出し側で確保すること．

引数:
pVal : [out] 現在位置
戻り値:
HRESULT

STDMETHODIMP CRbtlkArm::cmdJHere ( float * pVal )

ロボット現在軸値取得

  J型変数(float*8)で現在位置を返す． 返り値のメモリ領域はこのメソッドでは確保しないので、呼び出し側で確保すること．

引数:
pVal : [out] 現在軸値
戻り値:
HRESULT

STDMETHODIMP CRbtlkArm::cmdLetArea | ( | short | sNo,
 |  | float * | pf,
 |  | short | sIO,
 |  | short | sPos
 | ) |

エリア 設定値 設定

  エリアを示すベクトル(float*9)、ポート番号(short)、ポジション番号(short)を設定する． このメソッドでは、メモリ領域のチェックは行いません。

引数:
sNo | : [in] エリア番号
pf | : [in] エリアを示すベクトル
sIO | : [in] ポート番号
sPos | : [in] ポジション番号
戻り値:
HRESULT

STDMETHODIMP CRbtlkArm::cmdLetAreaEx | ( | short | sNo,
 |  | float * | pf,
 |  | short | sIO,
 |  | short | sPos,
 |  | short | sErr,
 |  | short | sEnable
 | ) |

エリア 設定値 設定

  エリアを示すベクトル(float*9)、ポート番号(short)、ポジション番号(short)、エラーフラグ(short)、機能の有効無効(short)を設定する． このメソッドでは、メモリ領域のチェックは行いません。

引数:
sNo | : [in] エリア番号
pf | : [in] エリアを示すベクトル
sIO | : [in] ポート番号
sPos | : [in] ポジション番号
sErr | : [in] エラーフラグ
sEnable | : [in] 機能の有効無効
戻り値:
HRESULT

STDMETHODIMP CRbtlkArm::cmdLetTool | ( | short | sNo,
 |  | float * | pf
 | ) |

ツール 設定値 設定

  ツール座標(float*6)を設定する． このメソッドでは、メモリ領域のチェックは行いません。

引数:
sNo | : [in] ツール番号
pf | : [in] ツール座標
戻り値:
HRESULT

STDMETHODIMP CRbtlkArm::cmdLetWork | ( | short | sNo,
 |  | float * | pf
 | ) |

ワーク 設定値 設定

  ワーク座標(float*6)を設定する． このメソッドでは、メモリ領域のチェックは行いません。

引数:
sNo | : [in] ツール番号
pf | : [in] ワーク座標
戻り値:
HRESULT

STDMETHODIMP CRbtlkArm::cmdThere ( float * pVal )

ロボット現在位置の取得

  T型変数(float*10)で現在位置を返す． 返り値のメモリ領域はこのメソッドでは確保しないので、呼び出し側で確保すること．

引数:
pVal : [out] 現在位置
戻り値:
HRESULT

HRESULT CRbtlkArm::FinalConstruct ( )

ファイナルコンストラクタ

  オブジェクト生成時の処理

戻り値:
HRESULT

void CRbtlkArm::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

HRESULT CRbtlkArm::Initialize ( CRbtlkEngine * pIRbtlkEng )

初期化関数

引数:
pIRbtlkEng : [in] RoboTalkEngine IFポインタ
戻り値:
HRESULT

STDMETHODIMP CRbtlkArm::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

  riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : [in] インタフェース
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • RbtlkArm.h
  • RbtlkArm.cpp
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


CRbtlkController class Reference

クラス CRbtlkController の解説

#include <RbtlkController.h>

CRbtlkControllerのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CRbtlkController ()
HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | cmdSetOption (short sMode, long lKey, CHAR *pVal)
コントローラ・オプション機能の操作

HRESULT | cmdGetControlLog (short sIndex, float pData[8][4], float *pReg, short *pProgNo, short *pLineNo)
制御ログデータ取得

HRESULT | cmdGetErrorLog (short sIndex, short *pCode, short *pLevel, CHAR *szDate, CHAR *szTime, CHAR *szModule, CHAR *szMsg)
エラーログデータ取得

HRESULT | cmdGetOperationLog (short sIndex, short *pCode, CHAR *szDate, CHAR *szTime, CHAR *szModule, CHAR *szMsg)
操作ログデータ取得

HRESULT | cmdClearError (long lErrCode, short *pVal)
発生中のエラーのクリア

HRESULT | cmdGetErrorCode (long *pVal)
発生中のエラー番号の取得

HRESULT | cmdSrvJointCancel ()
単軸制御ログ取得取り消し

HRESULT | cmdSrvJointData (short sOffset, short sCounts, float **pData1, float **pData2)
単軸制御ログデータ取得

HRESULT | cmdSrvJointParam (short *pJoint, short *pInterval, short *pCounts, short *pData1, short *pData2)
単軸制御ログパラメータ取得

HRESULT | cmdDoSignal (short sMode, short sAction)
タイミング通知

HRESULT | cmdNoticeRomVersion (short sVer)
ROMバージョン通知.

HRESULT | cmdRequestRomUpdate ()
ROMアップデート開始.

HRESULT | cmdGetTransMode (short *pTransMode)
転送モードの取得

HRESULT | cmdRequestFileSave (short *pTransMode, long *pTaskID)
ファイル保存要求

HRESULT | cmdLetJobStatus (long JobID, short sStatus)
指定処理の状態設定

HRESULT | cmdGetJobStatus (long JobID, short *pStatus)
指定処理の状態取得

HRESULT | cmdGetJointInfo (short sMode, short *pVal)
軸情報の取得

HRESULT | cmdGetRobotType (long *pVal)
ロボットタイプの取得

HRESULT | cmdGetFreeMemory (long *pVal)
DRAM空き容量取得.

HRESULT | cmdGetVersions (short sIndex, CHAR *pVal)
バージョン情報 取得

HRESULT | cmdGetDateTime (short *psDateTime)
日時の取得

HRESULT | cmdLetDateTime (short *psDateTime)
日時の設定

HRESULT | cmdClearCtrlLog ()
制御ログのクリア

HRESULT | cmdStartCtrlLog ()
制御ログの記録開始

HRESULT | cmdStopCtrlLog ()
制御ログの記録停止

HRESULT | cmdGetParamCtrlLog (long *pSmpCnt, long *pSmpRate)
制御ログのパラメータ取得

HRESULT | cmdSwitchCtrlLog (short sMode)
制御ログの取り出し先を設定する

HRESULT | cmdCancelCtrlLog ()
制御ログ取り出し中止

HRESULT | cmdGetMode (short *pVal)
コントローラのモード取得

HRESULT | cmdSetMode (short iMode)
コントローラのモード設定

HRESULT | cmdChangeConfig (short sMode)
設定値変更イベント (CNFテーブル変更後に通知)

HRESULT | cmdLetConfig (short sMode, short sIndex, long newVal)
設定値 設定 共通ルーチン

HRESULT | cmdGetConfig (short sMode, short sIndex, long *pVal)
設定値 取得 共通ルーチン

HRESULT | cmdGetStatus (short sModule, short sIndex, short *pVal)
状態テーブルの値取得

HRESULT | Initialize (CRbtlkEngine *pIRbtlkEng)
初期化関数

コンストラクタとデストラクタの解説

CRbtlkController::CRbtlkController ( ) [inline]

メソッドの解説

STDMETHODIMP CRbtlkController::cmdCancelCtrlLog ( )

制御ログ取り出し中止

戻り値:
HRESULT

HRESULT CRbtlkController::cmdChangeConfig ( short sMode )

設定値変更イベント (CNFテーブル変更後に通知)

引数:
sMode : [in] テーブル番号
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdClearCtrlLog ( )

制御ログのクリア

戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdClearError | ( | long | lErrCode,
 |  | short * | pVal
 | ) |

発生中のエラーのクリア

引数:
lErrCode | : [in] エラー番号
pVal | : [out] 結果
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdDoSignal | ( | short | sMode,
 |  | short | sAction
 | ) |

タイミング通知

  コントローラへ処理開始のタイミングを通知する

引数:
sMode | : [in] モード
sAction | : [in] アクション
戻り値:
HRESULT

HRESULT CRbtlkController::cmdGetConfig | ( | short | sMode,
 |  | short | sIndex,
 |  | long * | pVal
 | ) |

設定値 取得 共通ルーチン

  コンフィグレイションの取得をする

引数:
sMode | : [in] テーブル番号
sIndex | : [in] 要素番号
pVal | : [out] 設定値
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdGetControlLog | ( | short | sIndex,
 |  | float | pData[8][4],
 |  | float * | pReg,
 |  | short * | pProgNo,
 |  | short * | pLineNo
 | ) |

制御ログデータ取得

引数:
sIndex | : [in] レコード番号
pData | : [out] データ
pReg | : [out] RID
pProgNo | : [out] IC
pLineNo | : [out] ライン
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdGetDateTime ( short * psDateTime )

日時の取得

引数:
psDateTime : [out] 日時
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdGetErrorCode ( long * pVal )

発生中のエラー番号の取得

引数:
pVal : [out] エラー番号
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdGetErrorLog | ( | short | sIndex,
 |  | short * | pCode,
 |  | short * | pLevel,
 |  | CHAR * | szDate,
 |  | CHAR * | szTime,
 |  | CHAR * | szModule,
 |  | CHAR * | szMsg
 | ) |

エラーログデータ取得

引数:
sIndex | : [in] レコード番号
pCode | : [out] コード
pLevel | : [out] レベル
szDate | : [out] 日付
szTime | : [out] 時間
szModule | : [out] モジュール
szMsg | : [out] メッセージ
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdGetFreeMemory ( long * pVal )

DRAM空き容量取得.

引数:
pVal : [out] 空きByte数
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdGetJobStatus | ( | long | JobID,
 |  | short * | pStatus
 | ) |

指定処理の状態取得

  処理に時間を要する処理は要求時にタスクIDを返す。cmdLoadNic参照

引数:
JobID | : [in] タスクID
pStatus | : [out] ステータス
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdGetJointInfo | ( | short | sMode,
 |  | short * | pVal
 | ) |

軸情報の取得

引数:
sMode | : [in] 取得情報の種類
pVal | : [out] 取得データ
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdGetMode ( short * pVal )

コントローラのモード取得

  モード 1: 手動, 2: ティーチチェック, 3: 自動, 4: 外部

引数:
pVal : [out] モード設定
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdGetOperationLog | ( | short | sIndex,
 |  | short * | pCode,
 |  | CHAR * | szDate,
 |  | CHAR * | szTime,
 |  | CHAR * | szModule,
 |  | CHAR * | szMsg
 | ) |

操作ログデータ取得

引数:
sIndex | : [in] レコード番号
pCode | : [out] コード
szDate | : [out] 日付
szTime | : [out] 時間
szModule | : [out] モジュール
szMsg | : [out] メッセージ
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdGetParamCtrlLog | ( | long * | pSmpCnt,
 |  | long * | pSmpRate
 | ) |

制御ログのパラメータ取得

  制御ログのパラメータ（サンプリング回数、サンプリング間隔）を得る．

引数:
pSmpCnt | : [in] サンプリング数
pSmpRate | : [in] サンプリング間隔
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdGetRobotType ( long * pVal )

ロボットタイプの取得

引数:
pVal : [out] ロボットタイプ
戻り値:
HRESULT

HRESULT CRbtlkController::cmdGetStatus | ( | short | sModule,
 |  | short | sIndex,
 |  | short * | pVal
 | ) |

状態テーブルの値取得

コンフィグレイションの設定をする

引数:
sModule | : [in] テーブル番号
sIndex | : [in] 要素番号
pVal | : [out] ステータス
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdGetTransMode ( short * pTransMode )

転送モードの取得

  コントローラ内の転送モードの取得を行う 0 : FLASH保存ありモード 1 : FLASH保存なしモード(高速転送モード) -1 : 従来互換モード(Ver1.5未満のコントローラ,ファイル化未対応) (注意)WINCAPSIIでは -1 -> 2 が返る

引数:
pTransMode : [out] 転送モード
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdGetVersions | ( | short | sIndex,
 |  | CHAR * | pVal
 | ) |

バージョン情報 取得

  本来 LOG Class に実装するもの

引数:
sIndex | : [in] モジュールID
pVal | : [out] バージョン情報
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdLetConfig | ( | short | sMode,
 |  | short | sIndex,
 |  | long | newVal
 | ) |

設定値 設定 共通ルーチン

コンフィグレイションの設定をする

引数:
sMode | : [in] テーブル番号
sIndex | : [in] 要素番号
newVal | : [in] 設定値
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdLetDateTime ( short * psDateTime )

日時の設定

引数:
psDateTime : [in] 日時
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdLetJobStatus | ( | long | JobID,
 |  | short | sStatus
 | ) |

指定処理の状態設定

  キャンセル等の操作が可能

引数:
JobID | : [in] タスクID
sStatus | : [in] ステータス
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdNoticeRomVersion ( short sVer )

ROMバージョン通知.

引数:
sVer : [in] バージョン
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdRequestFileSave | ( | short * | pTransMode,
 |  | long * | pTaskID
 | ) |

ファイル保存要求

引数:
pTransMode | : [out] 転送モード
pTaskID | : [out] タスクID
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdRequestRomUpdate ( )

ROMアップデート開始.

戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdSetMode ( short iMode )

コントローラのモード設定

  モード 1: 手動, 2: ティーチチェック, 3: 自動, 4: 外部

引数:
iMode : [in] モード設定
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdSetOption | ( | short | sMode,
 |  | long | lKey,
 |  | CHAR * | pVal
 | ) |

コントローラ・オプション機能の操作

引数:
sMode | : [in] モード
lKey | : [in] パスワード
pVal | : [out] 応答文字列
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdSrvJointCancel ( )

単軸制御ログ取得取り消し

戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdSrvJointData | ( | short | sOffset,
 |  | short | sCounts,
 |  | float ** | pData1,
 |  | float ** | pData2
 | ) |

単軸制御ログデータ取得

引数:
sOffset | : [in] データオフセット
sCounts | : [in] 取得データ数
pData1 | : [out] データ１
pData2 | : [out] データ２
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdSrvJointParam | ( | short * | pJoint,
 |  | short * | pInterval,
 |  | short * | pCounts,
 |  | short * | pData1,
 |  | short * | pData2
 | ) |

単軸制御ログパラメータ取得

  未実装のバージョン(Ver1.5未満)の場合は 0個, 0msec の値が返る

引数:
pJoint | : [out] 軸番号
pInterval | : [out] サンプリング間隔
pCounts | : [out] サンプリング数
pData1 | : [out] データ１選択番号
pData2 | : [out] データ２選択番号
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdStartCtrlLog ( )

制御ログの記録開始

戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdStopCtrlLog ( )

制御ログの記録停止

戻り値:
HRESULT

STDMETHODIMP CRbtlkController::cmdSwitchCtrlLog ( short sMode )

制御ログの取り出し先を設定する

  制御ログの取り出し先をRAMかFlushか設定する

引数:
sMode : [in] 取り出し先
戻り値:
HRESULT

HRESULT CRbtlkController::FinalConstruct ( )

ファイナルコンストラクタ

  オブジェクト生成時の処理

戻り値:
HRESULT

void CRbtlkController::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

HRESULT CRbtlkController::Initialize ( CRbtlkEngine * pIRbtlkEng )

初期化関数

引数:
pIRbtlkEng : [in] RoboTalkEngine IFポインタ
戻り値:
HRESULT

STDMETHODIMP CRbtlkController::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

  riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : [in] インタフェース
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • RbtlkController.h
  • RbtlkController.cpp
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


CRbtlkEngine class Reference

クラス CRbtlkEngine の解説

#include <RbtlkEngine.h>

CRbtlkEngineのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CRbtlkEngine ()
HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | ConnectServer (char *szPara)
コントローラとの接続

HRESULT | DisconnectServer ()
コントローラとの接続解除

HRESULT | get_RbtlkController (IRbtlkController **ppVal)
RbtlkControllerオブジェクトを取得.

HRESULT | get_RbtlkFile (IRbtlkFile **ppVal)
RbtlkFileオブジェクトを取得.

HRESULT | get_RbtlkTask (IRbtlkTask **ppVal)
RbtlkTaskオブジェクトを取得.

HRESULT | get_RbtlkIO (IRbtlkIO **ppVal)
RbtlkIOオブジェクトを取得.

HRESULT | get_RbtlkArm (IRbtlkArm **ppVal)
RbtlkArmオブジェクトを取得.

HRESULT | get_RbtlkVariable (IRbtlkVariable **ppVal)
RbtlkVariableオブジェクトを取得.

HRESULT | Cancel ()
送受信の中止

HRESULT | GetVarInfo (CHAR *szVar, short *sType, short *sIndex)
文字列からサポートタイプ(変数)とインデックスを返す

HRESULT | get_TimeOutRetry (long *pVal)
コントローラとのTimeOutリトライ数取得

HRESULT | put_TimeOutRetry (long newVal)
コントローラとのTimeOutリトライ数設定

HRESULT | get_TimeOut (long *pVal)
コントローラとのTimeOut値取得

HRESULT | put_TimeOut (long newVal)
コントローラとのTimeOut値設定

HRESULT | get_NakRetry (long *pVal)
コントローラとのNAKリトライ数取得

HRESULT | put_NakRetry (long newVal)
コントローラとのNAKリトライ数設定

HRESULT | get_LastError (long *pVal)
最新のエラー状態の取得

HRESULT | get_Version (double *pVal)
接続コントローラとのバージョンを取得する

HRESULT | ByteToBSTR (unsigned char *from, int fsz, int *flen, BSTR *to)
送信用データのバイト(ANSI)文字列をBSTRデータに変換

HRESULT | BSTRToByte (BSTR *from, unsigned char *to, int tsz, int *tlen)
BSTRデータを送信用データのバイト(ANSI)文字列に変換.

HRESULT | ByteToSingle (unsigned char *from, float *to)
送信用データの4Byteをfloatデータに変換

HRESULT | SingleToByte (float *from, unsigned char *to)
floatデータを送信用データの4Byteに変換

HRESULT | ByteToDouble (unsigned char *from, double *to)
送信用データの8ByteをDoubleデータに変換

HRESULT | DoubleToByte (double *from, unsigned char *to)
Doubleデータを送信用データの8Byteに変換.

HRESULT | ByteToLong (unsigned char *from, long *to)
送信用データの4ByteをLongデータに変換

HRESULT | LongToByte (long *from, unsigned char *to)
Longデータを送信用データの4Byteに変換.

HRESULT | ByteToShort (unsigned char *from, short *to)
送信用データの2ByteをShortデータに変換

HRESULT | ShortToByte (short *from, unsigned char *to)
Shortデータを送信用データの2Byteに変換.

HRESULT | SendWithWait (RTK_PACKET *sndPck, RTK_PACKET *recPck)
パケット送受信

HRESULT | SendWithWaitA (RTK_PACKET *sndPck, RTK_PACKET *recPck)
パケット送受信

HRESULT | GetVarTabSize (short sTabIndex, short *pVal)
要素数 取得

コンストラクタとデストラクタの解説

CRbtlkEngine::CRbtlkEngine ( ) [inline]

メソッドの解説

HRESULT CRbtlkEngine::BSTRToByte | ( | BSTR * | from,
 |  | unsigned char * | to,
 |  | int | tsz,
 |  | int * | tlen
 | ) |

BSTRデータを送信用データのバイト(ANSI)文字列に変換.

引数:
from | : [in] 変換前文字列
to | : [out] 変換後文字列
tsz | : [in] バッファサイズ
tlen | : [out] 変換済み文字数
戻り値:
HRESULT

HRESULT CRbtlkEngine::ByteToBSTR | ( | unsigned char * | from,
 |  | int | fsz,
 |  | int * | flen,
 |  | BSTR * | to
 | ) |

送信用データのバイト(ANSI)文字列をBSTRデータに変換

引数:
from | : [in] 変換前文字列
fsz | : [in] バッファサイズ
flen | : [out] 変換済み文字数
to | : [out] 変換後文字列
戻り値:
HRESULT

HRESULT CRbtlkEngine::ByteToDouble | ( | unsigned char * | from,
 |  | double * | to
 | ) |

送信用データの8ByteをDoubleデータに変換

引数:
from | : [in] 変換前データ
to | : [out] 変換後データ
戻り値:
HRESULT

HRESULT CRbtlkEngine::ByteToLong | ( | unsigned char * | from,
 |  | long * | to
 | ) |

送信用データの4ByteをLongデータに変換

引数:
from | : [in] 変換前データ
to | : [out] 変換後データ
戻り値:
HRESULT

HRESULT CRbtlkEngine::ByteToShort | ( | unsigned char * | from,
 |  | short * | to
 | ) |

送信用データの2ByteをShortデータに変換

引数:
from | : [in] 変換前データ
to | : [out] 変換後データ
戻り値:
HRESULT

HRESULT CRbtlkEngine::ByteToSingle | ( | unsigned char * | from,
 |  | float * | to
 | ) |

送信用データの4Byteをfloatデータに変換

引数:
from | : [in] 変換前データ
to | : [out] 変換後データ
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::Cancel ( )

送受信の中止

  現在実行中の送受信を中止します

戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::ConnectServer ( char * szPara )

コントローラとの接続

  パラメータを解析しコントローラと接続します

引数:
szPara : [in] 接続パラメータ
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::DisconnectServer ( )

コントローラとの接続解除

  コントローラとの接続解除をします

戻り値:
HRESULT

HRESULT CRbtlkEngine::DoubleToByte | ( | double * | from,
 |  | unsigned char * | to
 | ) |

Doubleデータを送信用データの8Byteに変換.

引数:
from | : [in] 変換前データ
to | : [out] 変換後データ
戻り値:
HRESULT

HRESULT CRbtlkEngine::FinalConstruct ( )

ファイナルコンストラクタ

  オブジェクト生成時の処理

戻り値:
HRESULT

void CRbtlkEngine::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CRbtlkEngine::get_LastError ( long * pVal )

最新のエラー状態の取得

  最後に実行されたSendWithWait()の返り値を返す．

引数:
pVal : [out] エラーコード
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::get_NakRetry ( long * pVal )

コントローラとのNAKリトライ数取得

引数:
pVal : [out] リトライ回数
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::get_RbtlkArm ( IRbtlkArm ** ppVal )

RbtlkArmオブジェクトを取得.

引数:
ppVal : [in] RbtlkArm IFポインタ
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::get_RbtlkController ( IRbtlkController ** ppVal )

RbtlkControllerオブジェクトを取得.

引数:
ppVal : [in] RbtlkController IFポインタ
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::get_RbtlkFile ( IRbtlkFile ** ppVal )

RbtlkFileオブジェクトを取得.

引数:
ppVal : [in] RbtlkFile IFポインタ
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::get_RbtlkIO ( IRbtlkIO ** ppVal )

RbtlkIOオブジェクトを取得.

引数:
ppVal : [in] RbtlkIO IFポインタ
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::get_RbtlkTask ( IRbtlkTask ** ppVal )

RbtlkTaskオブジェクトを取得.

引数:
ppVal : [in] RbtlkTask IFポインタ
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::get_RbtlkVariable ( IRbtlkVariable ** ppVal )

RbtlkVariableオブジェクトを取得.

引数:
ppVal : [in] RbtlkVariable IFポインタ
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::get_TimeOut ( long * pVal )

コントローラとのTimeOut値取得

引数:
pVal : [out] タイムアウト時間
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::get_TimeOutRetry ( long * pVal )

コントローラとのTimeOutリトライ数取得

引数:
pVal : [out] リトライ回数
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::get_Version ( double * pVal )

接続コントローラとのバージョンを取得する

  ConnectServerで取得したコントローラのバージョンを返す

引数:
pVal : [out] バージョン
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::GetVarInfo | ( | CHAR * | szVar,
 |  | short * | sType,
 |  | short * | sIndex
 | ) |

文字列からサポートタイプ(変数)とインデックスを返す

  変数のI[1],i[1],I1 や IOのIO[1],IO1を識別する 　_ARM[1],_ARM0 や _PAC[1],_PAC1 ("_"+<CNF名>)にも対応

  例. "I[15]" -> 15, "F10" -> 10, "D001" -> 1 "IO1" -> 1, "IO[1]" -> 1, "1" -> NG "???[1]" -> NG, "?[1]2" -> NG

引数:
szVar | : [in] 文字列
sType | : [out] サポートタイプ(変数)
sIndex | : [out] インデックス
戻り値:
HRESULT

HRESULT CRbtlkEngine::GetVarTabSize | ( | short | sTabIndex,
 |  | short * | pVal
 | ) |

要素数 取得

  ロボット要素数を取得する

引数:
sTabIndex | : [in] 変数種別インデックス
pVal | : [out] 要素数
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

  riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : [in] インタフェース
戻り値:
HRESULT

HRESULT CRbtlkEngine::LongToByte | ( | long * | from,
 |  | unsigned char * | to
 | ) |

Longデータを送信用データの4Byteに変換.

引数:
from | : [in] 変換前データ
to | : [out] 変換後データ
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::put_NakRetry ( long newVal )

コントローラとのNAKリトライ数設定

引数:
newVal : [in] リトライ回数
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::put_TimeOut ( long newVal )

コントローラとのTimeOut値設定

引数:
newVal : [in] タイムアウト時間
戻り値:
HRESULT

STDMETHODIMP CRbtlkEngine::put_TimeOutRetry ( long newVal )

コントローラとのTimeOutリトライ数設定

引数:
newVal : [in] リトライ回数
戻り値:
HRESULT

HRESULT CRbtlkEngine::SendWithWait | ( | RTK_PACKET * | sndPck,
 |  | RTK_PACKET * | recPck
 | ) |

パケット送受信

引数:
sndPck | : [in] 送信パケット情報
recPck | : [out] 受信パケット情報
戻り値:
HRESULT

HRESULT CRbtlkEngine::SendWithWaitA | ( | RTK_PACKET * | sndPck,
 |  | RTK_PACKET * | recPck
 | ) |

パケット送受信

  NAKリトラは，コマンドにリトライフラグを付けない． 　タイムアウトリトライは，コマンドにリトライフラグを付ける． 　タイムアウトリトライは，NAKリトライ数を超えない．

引数:
sndPck | : [in] 送信パケット情報
recPck | : [out] 受信パケット情報
戻り値:
HRESULT

HRESULT CRbtlkEngine::ShortToByte | ( | short * | from,
 |  | unsigned char * | to
 | ) |

Shortデータを送信用データの2Byteに変換.

引数:
from | : [in] 変換前データ
to | : [out] 変換後データ
戻り値:
HRESULT

HRESULT CRbtlkEngine::SingleToByte | ( | float * | from,
 |  | unsigned char * | to
 | ) |

floatデータを送信用データの4Byteに変換

引数:
from | : [in] 変換前データ
to | : [out] 変換後データ
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • RbtlkEngine.h
  • RbtlkEngine.cpp
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


CRbtlkFile class Reference

クラス CRbtlkFile の解説

#include <RbtlkFile.h>

CRbtlkFileのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CRbtlkFile ()
HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | cmdGetFileName0 (short sIndex, CHAR *pVal)
ファイル名の取得

HRESULT | cmdGetFileCnt0 (short *psFiles)
プログラム数取得

HRESULT | cmdDeleteFile0 (CHAR *szName)
コントローラのファイルを削除

HRESULT | cmdGetProgramIndex (CHAR *szName, short *pVal)
プログラムインデックスを取得

HRESULT | cmdRequestUpload0 (short sBlocks, long lSize, CHAR *szName, CHAR *szAttribute, CHAR *szUsage, short *psFileID)
(旧)ファイル アップロード リクエスト(ファイルIDを返す)

HRESULT | cmdRequestDownload0 (CHAR *szName, short *psFileID, short *psBlocks, long *plSize, CHAR *szAttribute, CHAR *szUsage)
(旧)ファイル アップロード リクエスト(ファイルIDを返す)

HRESULT | cmdUpload0 (short sFileID, short sBlockNo, BSTR bstrData)
(旧)ファイル アップロード

HRESULT | cmdDownload0 (short sFileID, short *psFileID, short *psBlockNo, BSTR *pbstrData)
(旧)ファイル ダウンロード

HRESULT | cmdCancelUpload0 (short sFileID)
(旧)ファイル アップロード キャンセル

HRESULT | cmdCancelDownload0 (short sFileID)
(旧)ファイル ダウンロード キャンセル

HRESULT | cmdLoadNic (long *pID)
NICファイルロード要求.

HRESULT | cmdFileUploadStart ()
ファイル転送開始通知

HRESULT | cmdFileUploadEnd ()
ファイル転送終了通知

HRESULT | cmdRequestUpload (short sBlocks, long lSize, short sFileProp, short sFileFlag, CHAR *szName, short *psFileID)
汎用ファイル アップロード リクエスト(ファイルIDを返す)

HRESULT | cmdRequestDownload (short sFileFlag, CHAR *szName, short *psFileID, short *psBlocks, short *psFileProp, long *plSize)
汎用ファイル ダウンロード リクエスト(ファイルIDを返す)

HRESULT | cmdUpload (short sFileID, short sBlockNo, BSTR bstrData)
汎用ファイル アップロード

HRESULT | cmdDownload (short sFileID, short *psFileID, short *psBlockNo, BSTR *pbstrData)
汎用ファイル ダウンロード

HRESULT | cmdCancelUpload (short sFileID)
汎用ファイル アップロード キャンセル

HRESULT | cmdCancelDownload (short psFileID)
汎用ファイル ダウンロード キャンセル

HRESULT | cmdDeleteFile (CHAR *szName)
コントローラの汎用ファイルを削除

HRESULT | cmdCopyFile (CHAR *szFrom, CHAR *szTo)
汎用ファイルのコピー

HRESULT | cmdMoveFile (CHAR *szFrom, CHAR *szTo)
汎用ファイルの移動

HRESULT | cmdGetFileCnt (CHAR *szName, short *psFiles)
汎用コントローラ数取得

HRESULT | cmdGetFileName (short sIndex, CHAR *szDirName, CHAR *pVal)
汎用ファイル名の取得

HRESULT | cmdGetAttributes (short iSystem, CHAR *szName, long *pVal)
汎用ファイルの属性取得

HRESULT | cmdGetDataCreated (short iSystem, CHAR *szName, short *pDateTime)
汎用ファイルの作成日時の取得

HRESULT | cmdGetLastModified (short iSystem, CHAR *szName, short *pDateTime)
汎用ファイルの最終更新日の取得

HRESULT | cmdGetLastAccessed (short iSystem, CHAR *szName, short *pDateTime)
汎用ファイルの最終アクセス日時の取得

HRESULT | cmdGetSize (short iSystem, CHAR *szName, long *pVal)
汎用ファイルのサイズ取得

HRESULT | cmdStartPrg (short iProgIC, short iStartMode)
プログラムのスタート

HRESULT | cmdStopPrg (short iProgIC, short iStopMode)
プログラムの停止

HRESULT | cmdGetProgramIC (CHAR *szName, short *pVal)
プログラムICを取得

HRESULT | cmdStepForward (short iProgIC)
プログラムをステップ送りする

HRESULT | cmdStepBackward (short iProgIC)
プログラムをステップ戻しする

HRESULT | cmdLetStartLine (short iLineNo, short iProgIC, short *pVal)
プログラム開始行番号の設定

HRESULT | cmdKillProg (short iActMode, short iProgIC)
プログラムの初期化

HRESULT | Initialize (CRbtlkEngine *pIRbtlkEng)
初期化関数

コンストラクタとデストラクタの解説

CRbtlkFile::CRbtlkFile ( ) [inline]

メソッドの解説

STDMETHODIMP CRbtlkFile::cmdCancelDownload ( short sFileID )

汎用ファイル ダウンロード キャンセル

引数:
sFileID : [in] ファイルID
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdCancelDownload0 ( short sFileID )

(旧)ファイル ダウンロード キャンセル

引数:
sFileID : [in] ファイルID
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdCancelUpload ( short sFileID )

汎用ファイル アップロード キャンセル

引数:
sFileID : [in] ファイルID
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdCancelUpload0 ( short sFileID )

(旧)ファイル アップロード キャンセル

引数:
sFileID : [in] ファイルID
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdCopyFile | ( | CHAR * | szFrom,
 |  | CHAR * | szTo
 | ) |

汎用ファイルのコピー

引数:
szFrom | : [in] コピー元
szTo | : [in] コピー先
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdDeleteFile ( CHAR * szName )

コントローラの汎用ファイルを削除

引数:
szName : [in] ファイル名
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdDeleteFile0 ( CHAR * szName )

コントローラのファイルを削除

  プログラム領域内のファイルのみでパスは指定できない。 　コントローラVer1.3以前及びVision21互換のために存在しています 　通常はcmdDeleteFileを使用するようにしてください

引数:
szName : [in] ファイル名
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdDownload | ( | short | sFileID,
 |  | short * | psFileID,
 |  | short * | psBlockNo,
 |  | BSTR * | pbstrData
 | ) |

汎用ファイル ダウンロード

引数:
sFileID | : [in] ファイルID
psFileID | : [out] ファイルID
psBlockNo | : [out] ブロック番号
pbstrData | : [out] データ
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdDownload0 | ( | short | sFileID,
 |  | short * | psFileID,
 |  | short * | psBlockNo,
 |  | BSTR * | pbstrData
 | ) |

(旧)ファイル ダウンロード

引数:
sFileID | : [in] ファイルID
psFileID | : [out] ファイルID
psBlockNo | : [out] ブロック数
pbstrData | : [out] データ
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdFileUploadEnd ( )

ファイル転送終了通知

戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdFileUploadStart ( )

ファイル転送開始通知

戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdGetAttributes | ( | short | iSystem,
 |  | CHAR * | szName,
 |  | long * | pVal
 | ) |

汎用ファイルの属性取得

引数:
iSystem | : [in] プログラム番号
szName | : [in] ファイルパス
pVal | : [out] 属性値
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdGetDataCreated | ( | short | iSystem,
 |  | CHAR * | szName,
 |  | short * | pDateTime
 | ) |

汎用ファイルの作成日時の取得

引数:
iSystem | : [in] プログラム番号
szName | : [in] ファイルパス
pDateTime | : [out] 日時
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdGetFileCnt | ( | CHAR * | szName,
 |  | short * | psFiles
 | ) |

汎用コントローラ数取得

引数:
szName | : [in] ファイルパス
psFiles | : [out] プログラム数
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdGetFileCnt0 ( short * psFiles )

プログラム数取得

  コントローラVer1.708までの互換維持用に存在。 　通常は cmdGetFileCnt を使用してください。

引数:
psFiles : [out] プログラム数
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdGetFileName | ( | short | sIndex,
 |  | CHAR * | szName,
 |  | CHAR * | pVal
 | ) |

汎用ファイル名の取得

引数:
sIndex | : [in] プログラム番号
szName | : [in] ディレクトリ名
pVal | : [out] ファイルパス
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdGetFileName0 | ( | short | sIndex,
 |  | CHAR * | pVal
 | ) |

ファイル名の取得

  コントローラVer1.708までの互換維持用に存在。 　通常は cmdGetFileName を使用してください。

引数:
sIndex | : [in] プログラム番号
pVal | : [out] ファイル名
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdGetLastAccessed | ( | short | iSystem,
 |  | CHAR * | szName,
 |  | short * | pDateTime
 | ) |

汎用ファイルの最終アクセス日時の取得

引数:
iSystem | : [in] プログラム番号
szName | : [in] ファイルパス
pDateTime | : [out] 日時
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdGetLastModified | ( | short | iSystem,
 |  | CHAR * | szName,
 |  | short * | pDateTime
 | ) |

汎用ファイルの最終更新日の取得

引数:
iSystem | : [in] プログラム番号
szName | : [in] ファイルパス
pDateTime | : [out] 日時
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdGetProgramIC | ( | CHAR * | szName,
 |  | short * | pVal
 | ) |

プログラムICを取得

引数:
szName | : [in] プログラム名
pVal | : [out] プログラムID
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdGetProgramIndex | ( | CHAR * | szName,
 |  | short * | pVal
 | ) |

プログラムインデックスを取得

  コントローラVer1.708までの互換維持用に存在。 　通常は cmdGetProgramIC を使用してください。

引数:
szName | : [in] プログラム名
pVal | : [out] プログラムID
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdGetSize | ( | short | iSystem,
 |  | CHAR * | szName,
 |  | long * | pVal
 | ) |

汎用ファイルのサイズ取得

引数:
iSystem | : [in] プログラム番号
szName | : [in] ファイルパス
pVal | : [out] バイト数
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdKillProg | ( | short | iActMode,
 |  | short | iProgIC
 | ) |

プログラムの初期化

引数:
iActMode | : [in] 動作モード
iProgIC | : [in] プログラムID
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdLetStartLine | ( | short | iLineNo,
 |  | short | iProgIC,
 |  | short * | pVal
 | ) |

プログラム開始行番号の設定

引数:
iLineNo | : [in] 行番号
iProgIC | : [in] プログラムID
pVal | : [out] 設定された行番号
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdLoadNic ( long * pID )

NICファイルロード要求.

引数:
pID : [in] タスクID
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdMoveFile | ( | CHAR * | szFrom,
 |  | CHAR * | szTo
 | ) |

汎用ファイルの移動

引数:
szFrom | : [in] 移動元
szTo | : [in] 移動先
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdRequestDownload | ( | short | sFileFlag,
 |  | CHAR * | szName,
 |  | short * | psFileID,
 |  | short * | psBlocks,
 |  | short * | psFileProp,
 |  | long * | plSize
 | ) |

汎用ファイル ダウンロード リクエスト(ファイルIDを返す)

  '\0'も文字数(ファイル名の)，データに含む

引数:
sFileFlag | : [in] システム属性
szName | : [in] ファイル名
psFileID | : [out] ファイルID
psBlocks | : [out] ブロック数
psFileProp | : [out] ファイル属性
plSize | : [out] ファイルサイズ
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdRequestDownload0 | ( | CHAR * | szName,
 |  | short * | psFileID,
 |  | short * | psBlocks,
 |  | long * | plSize,
 |  | CHAR * | szAttribute,
 |  | CHAR * | szUsage
 | ) |

(旧)ファイル アップロード リクエスト(ファイルIDを返す)

引数:
szName | : [in] ファイル名
psFileID | : [out] ファイルID
psBlocks | : [out] ブロック数
plSize | : [out] ファイルサイズ
szAttribute | : [out] 編集権
szUsage | : [out] 使用・未使用
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdRequestUpload | ( | short | sBlocks,
 |  | long | lSize,
 |  | short | sFileProp,
 |  | short | sFileFlag,
 |  | CHAR * | szName,
 |  | short * | psFileID
 | ) |

汎用ファイル アップロード リクエスト(ファイルIDを返す)

  '\0'も文字数(ファイル名の)，データに含む

引数:
sBlocks | : [in] ブロック数
lSize | : [in] ファイルサイズ
sFileProp | : [in] ファイル属性
sFileFlag | : [in] システム属性
szName | : [in] ファイル名
psFileID | : [out] ファイルID
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdRequestUpload0 | ( | short | sBlocks,
 |  | long | lSize,
 |  | CHAR * | szName,
 |  | CHAR * | szAttribute,
 |  | CHAR * | szUsage,
 |  | short * | psFileID
 | ) |

(旧)ファイル アップロード リクエスト(ファイルIDを返す)

引数:
sBlocks | : [in] ブロック数
lSize | : [in] ファイルサイズ
szName | : [in] ファイル名
szAttribute | : [in] 編集権
szUsage | : [in] 使用・未使用
psFileID | : [out] ファイルID
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdStartPrg | ( | short | iProgIC,
 |  | short | iStartMode
 | ) |

プログラムのスタート

引数:
iProgIC | : [in] プログラム番号
iStartMode | : [in] スタートモード
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdStepBackward ( short iProgIC )

プログラムをステップ戻しする

引数:
iProgIC : [in] プログラムID
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdStepForward ( short iProgIC )

プログラムをステップ送りする

引数:
iProgIC : [in] プログラムID
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdStopPrg | ( | short | iProgIC,
 |  | short | iStopMode
 | ) |

プログラムの停止

引数:
iProgIC | : [in] プログラム番号
iStopMode | : [in] エンドモード
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdUpload | ( | short | sFileID,
 |  | short | sBlockNo,
 |  | BSTR | bstrData
 | ) |

汎用ファイル アップロード

引数:
sFileID | : [in] ファイルID
sBlockNo | : [in] ブロック番号
bstrData | : [in] データ
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::cmdUpload0 | ( | short | sFileID,
 |  | short | sBlockNo,
 |  | BSTR | bstrData
 | ) |

(旧)ファイル アップロード

引数:
sFileID | : [in] ファイルID
sBlockNo | : [in] ブロック数
bstrData | : [in] データ
戻り値:
HRESULT

HRESULT CRbtlkFile::FinalConstruct ( )

ファイナルコンストラクタ

  オブジェクト生成時の処理

戻り値:
HRESULT

void CRbtlkFile::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

HRESULT CRbtlkFile::Initialize ( CRbtlkEngine * pIRbtlkEng )

初期化関数

引数:
pIRbtlkEng : [in] RoboTalkEngine IFポインタ
戻り値:
HRESULT

STDMETHODIMP CRbtlkFile::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

  riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : [in] インタフェース
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • RbtlkFile.h
  • RbtlkFile.cpp
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


CRbtlkIO class Reference

クラス CRbtlkIO の解説

#include <RbtlkIO.h>

CRbtlkIOのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CRbtlkIO ()
HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | cmdDummy (short sIndex, short newVal)
Dummy.

HRESULT | cmdDin (short sIndex, BOOL *pVal)
IOデータ取得.

HRESULT | cmdDout (short sIndex, BOOL newVal)
IOデータ設定.

HRESULT | cmdDin8 (short sIndex, short *pVal)
IOデータ取得(8bit).

HRESULT | cmdDout8 (short sIndex, short newVal)
IOデータ設定(8bit).

HRESULT | cmdDin16 (short sIndex, short *pVal)
IOデータ取得(16bit).

HRESULT | cmdDout16 (short sIndex, short newVal)
IOデータ設定(16bit).

HRESULT | cmdChangeLabel (short sPlateNo, short sButtonNo, CHAR *newVal)
ボタンのラベル名を変更する

HRESULT | Initialize (CRbtlkEngine *pIRbtlkEng)
初期化関数

コンストラクタとデストラクタの解説

CRbtlkIO::CRbtlkIO ( ) [inline]

メソッドの解説

STDMETHODIMP CRbtlkIO::cmdChangeLabel | ( | short | sPlateNo,
 |  | short | sButtonNo,
 |  | CHAR * | newVal
 | ) |

ボタンのラベル名を変更する

引数:
sPlateNo | : [in] プレート番号
sButtonNo | : [in] ボタン番号
newVal | : [in] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkIO::cmdDin | ( | short | sIndex,
 |  | BOOL * | pVal
 | ) |

IOデータ取得.

引数:
sIndex | : [in] IOポート番号
pVal | : [out] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkIO::cmdDin16 | ( | short | sIndex,
 |  | short * | pVal
 | ) |

IOデータ取得(16bit).

引数:
sIndex | : [in] IOポート番号
pVal | : [out] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkIO::cmdDin8 | ( | short | sIndex,
 |  | short * | pVal
 | ) |

IOデータ取得(8bit).

引数:
sIndex | : [in] IOポート番号
pVal | : [out] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkIO::cmdDout | ( | short | sIndex,
 |  | BOOL | newVal
 | ) |

IOデータ設定.

引数:
sIndex | : [in] IOポート番号
newVal | : [in] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkIO::cmdDout16 | ( | short | sIndex,
 |  | short | newVal
 | ) |

IOデータ設定(16bit).

引数:
sIndex | : [in] IOポート番号
newVal | : [in] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkIO::cmdDout8 | ( | short | sIndex,
 |  | short | newVal
 | ) |

IOデータ設定(8bit).

引数:
sIndex | : [in] IOポート番号
newVal | : [in] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkIO::cmdDummy | ( | short | sIndex,
 |  | short | newVal
 | ) |

Dummy.

引数:
sIndex | : [in] IOポート番号
newVal | : [in] 値
戻り値:
HRESULT

HRESULT CRbtlkIO::FinalConstruct ( )

ファイナルコンストラクタ

  オブジェクト生成時の処理

戻り値:
HRESULT

void CRbtlkIO::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

HRESULT CRbtlkIO::Initialize ( CRbtlkEngine * pIRbtlkEng )

初期化関数

引数:
pIRbtlkEng : [in] RoboTalkEngine IFポインタ
戻り値:
HRESULT

STDMETHODIMP CRbtlkIO::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

  riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : [in] インタフェース
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • RbtlkIO.h
  • RbtlkIO.cpp
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


CRbtlkTask class Reference

クラス CRbtlkTask の解説

#include <RbtlkTask.h>

CRbtlkTaskのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CRbtlkTask ()
HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | cmdGetPrgListLen (short *newVal)
存在するプログラムリストの数を取得する．

HRESULT | cmdGetPrgList (short sIndex, short *newVal, CHAR *szName)
リスト番号からプログラムICとプログラム名を取得する．

HRESULT | cmdGetTaskStatus (short sPrgIC, short *pStatus)
プログラムICからタスク状態を取得

HRESULT | cmdContPrgStatus (short sPrgIC, short *pStatus, short *pPriority, short *pInterval, short *pLineNo, short *pIOBlock, short *pMode, long *pCT)
プログラムICからタスク状態を取得

HRESULT | Initialize (CRbtlkEngine *pIRbtlkEng)
初期化関数

コンストラクタとデストラクタの解説

CRbtlkTask::CRbtlkTask ( ) [inline]

メソッドの解説

STDMETHODIMP CRbtlkTask::cmdContPrgStatus | ( | short | sPrgIC,
 |  | short * | pStatus,
 |  | short * | pPriority,
 |  | short * | pInterval,
 |  | short * | pLineNo,
 |  | short * | pIOBlock,
 |  | short * | pMode,
 |  | long * | pCT
 | ) |

プログラムICからタスク状態を取得

引数:
sPrgIC | : [in] プログラムID
pStatus | : [out] タスクステータス
pPriority | : [out] プライオリティ
pInterval | : [out] 起動周期
pLineNo | : [out] 行番号
pIOBlock | : [out] I/Oブロック
pMode | : [out] モード
pCT | : [out] サイクルタイム
戻り値:
HRESULT

STDMETHODIMP CRbtlkTask::cmdGetPrgList | ( | short | sIndex,
 |  | short * | newVal,
 |  | CHAR * | szName
 | ) |

リスト番号からプログラムICとプログラム名を取得する．

引数:
sIndex | : [in] リスト番号
newVal | : [out] プログラムID
szName | : [out] プログラム名
戻り値:
HRESULT

STDMETHODIMP CRbtlkTask::cmdGetPrgListLen ( short * newVal )

存在するプログラムリストの数を取得する．

引数:
newVal : [out] リスト数
戻り値:
HRESULT

STDMETHODIMP CRbtlkTask::cmdGetTaskStatus | ( | short | sPrgIC,
 |  | short * | pStatus
 | ) |

プログラムICからタスク状態を取得

引数:
sPrgIC | : [in] プログラムID
pStatus | : [out] 状態
戻り値:
HRESULT

HRESULT CRbtlkTask::FinalConstruct ( )

ファイナルコンストラクタ

  オブジェクト生成時の処理

戻り値:
HRESULT

void CRbtlkTask::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

HRESULT CRbtlkTask::Initialize ( CRbtlkEngine * pIRbtlkEng )

初期化関数

引数:
pIRbtlkEng : [in] RoboTalkEngine IFポインタ
戻り値:
HRESULT

STDMETHODIMP CRbtlkTask::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

  riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : [in] インタフェース
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • RbtlkTask.h
  • RbtlkTask.cpp
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


CRbtlkVariable class Reference

クラス CRbtlkVariable の解説

#include <RbtlkVariable.h>

CRbtlkVariableのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CRbtlkVariable ()
HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | cmdGetDefIO (short sPort, short sType, long lMask, long *pVal)
DEFIOの値を取得.

HRESULT | cmdLetDefIO (short sPort, short sType, long lMask, long lVal)
DEFIOの値を設定.

HRESULT | cmdGetTabLen (short sPrgIC, short sTypeIC, short *pVal)
テーブルの長さを取得

HRESULT | cmdGetT (short sIC, short sIndex, float *pVal)
変数Tの取得

HRESULT | cmdLetT (short sIC, short sIndex, float *newVal)
変数Tの設定

HRESULT | cmdGetV (short sIC, short sIndex, float *pVal)
変数Vの取得

HRESULT | cmdLetV (short sIC, short sIndex, float *newVal)
変数Vの設定

HRESULT | cmdGetS (short sIC, short sIndex, CHAR *pVal)
変数Sの取得

HRESULT | cmdLetS (short sIC, short sIndex, CHAR *newVal)
変数Sの設定

HRESULT | cmdGetD (short sIC, short sIndex, double *pVal)
変数Dの取得

HRESULT | cmdLetD (short sIC, short sIndex, double newVal)
変数Dの設定

HRESULT | cmdGetJ (short sIC, short sIndex, float *pVal)
変数Jの取得

HRESULT | cmdLetJ (short sIC, short sIndex, float *newVal)
変数Jの設定

HRESULT | cmdGetP (short sIC, short sIndex, float *pVal)
変数Pの取得

HRESULT | cmdLetP (short sIC, short sIndex, float *newVal)
変数Pの設定

HRESULT | cmdGetF (short sIC, short sIndex, float *pVal)
変数Fの取得

HRESULT | cmdLetF (short sIC, short sIndex, float newVal)
変数Fの設定

HRESULT | cmdGetI (short sIC, short sIndex, long *pVal)
HRESULT | cmdLetI (short sIC, short sIndex, long newVal)
変数Iの設定

HRESULT | Initialize (CRbtlkEngine *pIRbtlkEng)
初期化関数

コンストラクタとデストラクタの解説

CRbtlkVariable::CRbtlkVariable ( ) [inline]

メソッドの解説

STDMETHODIMP CRbtlkVariable::cmdGetD | ( | short | sIC,
 |  | short | sIndex,
 |  | double * | pVal
 | ) |

変数Dの取得

引数:
sIC | : [in] IC
sIndex | : [in] 要素番号
pVal | : [out] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdGetDefIO | ( | short | sPort,
 |  | short | sType,
 |  | long | lMask,
 |  | long * | pVal
 | ) |

DEFIOの値を取得.

引数:
sPort | : [in] ポートアドレス
sType | : [in] I/Oタイプ
lMask | : [in] マスク情報
pVal | : [out] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdGetF | ( | short | sIC,
 |  | short | sIndex,
 |  | float * | pVal
 | ) |

変数Fの取得

引数:
sIC | : [in] IC
sIndex | : [in] 要素番号
pVal | : [out] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdGetI | ( | short | sIC,
 |  | short | sIndex,
 |  | long * | pVal
 | ) |

STDMETHODIMP CRbtlkVariable::cmdGetJ | ( | short | sIC,
 |  | short | sIndex,
 |  | float * | pVal
 | ) |

変数Jの取得

引数:
sIC | : [in] IC
sIndex | : [in] 要素番号
pVal | : [out] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdGetP | ( | short | sIC,
 |  | short | sIndex,
 |  | float * | pVal
 | ) |

変数Pの取得

引数:
sIC | : [in] IC
sIndex | : [in] 要素番号
pVal | : [out] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdGetS | ( | short | sIC,
 |  | short | sIndex,
 |  | CHAR * | pVal
 | ) |

変数Sの取得

引数:
sIC | : [in] IC
sIndex | : [in] 要素番号
pVal | : [out] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdGetT | ( | short | sIC,
 |  | short | sIndex,
 |  | float * | pVal
 | ) |

変数Tの取得

引数:
sIC | : [in] IC
sIndex | : [in] 要素番号
pVal | : [out] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdGetTabLen | ( | short | sPrgIC,
 |  | short | sTypeIC,
 |  | short * | pVal
 | ) |

テーブルの長さを取得

引数:
sPrgIC | : [in] IC
sTypeIC | : [in] 要素番号
pVal | : [out] 配列サイズ
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdGetV | ( | short | sIC,
 |  | short | sIndex,
 |  | float * | pVal
 | ) |

変数Vの取得

引数:
sIC | : [in] IC
sIndex | : [in] 要素番号
pVal | : [out] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdLetD | ( | short | sIC,
 |  | short | sIndex,
 |  | double | newVal
 | ) |

変数Dの設定

引数:
sIC | : [in] IC
sIndex | : [in] 要素番号
newVal | : [in] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdLetDefIO | ( | short | sPort,
 |  | short | sType,
 |  | long | lMask,
 |  | long | lVal
 | ) |

DEFIOの値を設定.

引数:
sPort | : [in] ポートアドレス
sType | : [in] I/Oタイプ
lMask | : [in] マスク情報
lVal | : [in] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdLetF | ( | short | sIC,
 |  | short | sIndex,
 |  | float | newVal
 | ) |

変数Fの設定

引数:
sIC | : [in] IC
sIndex | : [in] 要素番号
newVal | : [in] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdLetI | ( | short | sIC,
 |  | short | sIndex,
 |  | long | newVal
 | ) |

変数Iの設定

引数:
sIC | : [in] IC
sIndex | : [in] 要素番号
newVal | : [in] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdLetJ | ( | short | sIC,
 |  | short | sIndex,
 |  | float * | newVal
 | ) |

変数Jの設定

引数:
sIC | : [in] IC
sIndex | : [in] 要素番号
newVal | : [in] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdLetP | ( | short | sIC,
 |  | short | sIndex,
 |  | float * | newVal
 | ) |

変数Pの設定

引数:
sIC | : [in] IC
sIndex | : [in] 要素番号
newVal | : [in] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdLetS | ( | short | sIC,
 |  | short | sIndex,
 |  | CHAR * | newVal
 | ) |

変数Sの設定

引数:
sIC | : [in] IC
sIndex | : [in] 要素番号
newVal | : [in] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdLetT | ( | short | sIC,
 |  | short | sIndex,
 |  | float * | newVal
 | ) |

変数Tの設定

引数:
sIC | : [in] IC
sIndex | : [in] 要素番号
newVal | : [in] 値
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::cmdLetV | ( | short | sIC,
 |  | short | sIndex,
 |  | float * | newVal
 | ) |

変数Vの設定

引数:
sIC | : [in] IC
sIndex | : [in] 要素番号
newVal | : [in] 値
戻り値:
HRESULT

HRESULT CRbtlkVariable::FinalConstruct ( )

ファイナルコンストラクタ

  オブジェクト生成時の処理

戻り値:
HRESULT

void CRbtlkVariable::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

HRESULT CRbtlkVariable::Initialize ( CRbtlkEngine * pIRbtlkEng )

初期化関数

引数:
pIRbtlkEng : [in] RoboTalkEngine IFポインタ
戻り値:
HRESULT

STDMETHODIMP CRbtlkVariable::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

  riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : [in] インタフェース
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • RbtlkVariable.h
  • RbtlkVariable.cpp
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


CSerial class Reference

クラス CSerial の解説

Serial通信用クラス. [詳細]

#include <Serial.h>

CSerialに対する継承グラフ

[凡例]
CSerialのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CSerial ()
接続パラメータ

virtual | ~CSerial ()
CSerial のデストラクタ.

virtual HRESULT | Connect (CDevice **ppNewDevice=NULL)
接続処理(RS232C)

virtual HRESULT | Disconnect (void)
切断処理

virtual HRESULT | Flush (void)
バッファクリア

virtual HRESULT | SetTimeOut (DWORD dwTimeout)
タイムアウト時間の更新

virtual DWORD | GetReceivedCount (void)
データ受信数の取得

HRESULT | GetState (DCB *pDCB)
制御設定情報の取得

HRESULT | SetState (DCB *pDCB)
制御設定情報の設定

virtual HRESULT | Initialize (PVOID pArgs[])
初期化処理処理

Protected 変数

HANDLE | m_hComHandle
COMハンドル.

DWORD | m_dwReceiveRetry
タイムアウトリトライ回数

解説

Serial通信用クラス.

RS-232Cでの接続，切断及び通信を実装しているクラス．
このクラスはCDeviceクラスを継承して実装されている．

コンストラクタとデストラクタの解説

CSerial::CSerial ( )

接続パラメータ

CSerial::~CSerial ( ) [virtual]

CSerial のデストラクタ.

メソッドの解説

HRESULT CSerial::Connect ( CDevice ** ppNewDevice = NULL ) [virtual]

接続処理(RS232C)

  ターゲットとの接続をする

引数:
ppNewDevice : [out] 接続済みデバイス
戻り値:
HRESULT

CDeviceを再定義しています。

HRESULT CSerial::Disconnect ( void ) [virtual]

切断処理

  ターゲットとの接続を切断する

戻り値:
HRESULT

CDeviceを再定義しています。

HRESULT CSerial::Flush ( void ) [virtual]

バッファクリア

  バッファクリアとエラークリア処理を行う

戻り値:
HRESULT

CDeviceを再定義しています。

DWORD CSerial::GetReceivedCount ( void ) [virtual]

データ受信数の取得

  現在受信バッファにあるデータ数を取得する

戻り値:
DWORD : データ受信数

CDeviceを再定義しています。

HRESULT CSerial::GetState ( DCB * pDCB )

制御設定情報の取得

引数:
pDCB : [out] 制御設定情報
戻り値:
HRESULT

HRESULT CSerial::Initialize ( PVOID pArgs[] ) [virtual]

初期化処理処理

  ターゲットとの接続をする

引数:
pArgs [] : [in]　pArgs[0] - ターミネータ長
          pArgs[1] - ターミネータコード
          pArgs[2] - 動作モード
          pArgs[3] - ポートの番号
戻り値:
HRESULT

CDeviceを再定義しています。

HRESULT CSerial::SetState ( DCB * pDCB )

制御設定情報の設定

引数:
pDCB : [in] 制御設定情報
戻り値:
HRESULT

HRESULT CSerial::SetTimeOut ( DWORD dwTimeout ) [virtual]

タイムアウト時間の更新

  タイムアウト時間の更新を行う

引数:
dwTimeout : [in] タイムアウト時間
戻り値:
HRESULT

CDeviceを再定義しています。

変数の解説

DWORD CSerial::m_dwReceiveRetry [protected]

タイムアウトリトライ回数

HANDLE CSerial::m_hComHandle [protected]

COMハンドル.

このクラスの解説は次のファイルから生成されました:
  • Serial.h
  • Serial.cpp
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


EtherParam struct Reference

構造体 EtherParam の解説

Connect()引数のパラメータ構造体 (EtherNetクライアント). [詳細]

#include <StdAfx.h>

すべてのメンバ一覧

Public 変数

DWORD | dwIPAdr
IPアドレス inet_addr()形式.

DWORD | dwPortNo
ポートの番号

解説

Connect()引数のパラメータ構造体 (EtherNetクライアント).

変数の解説

DWORD EtherParam::dwIPAdr

IPアドレス inet_addr()形式.

DWORD EtherParam::dwPortNo

ポートの番号

この構造体の解説は次のファイルから生成されました:
  • StdAfx.h
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


IRbtlkArm interface Reference

インタフェースIRbtlkArm の解説

import "ROBOTalk.idl";

すべてのメンバ一覧

Public 型

enum | RTK_ARM_STATUS { RTK_AST_SERVO = 16, RTK_AST_MODE = 17, RTK_AST_CALEND = 18 }

Public メソッド

HRESULT | cmdHere ([out] float *pVal)
HRESULT | cmdJHere ([out] float *pVal)
HRESULT | cmdGetTool ([in] short sNo,[out] float *pf)
HRESULT | cmdLetTool ([in] short sNo,[in] float *pf)
HRESULT | cmdGetWork ([in] short sNo,[out] float *pf)
HRESULT | cmdLetWork ([in] short sNo,[in] float *pf)
HRESULT | cmdGetArea ([in] short sNo,[out] float *pf,[out] short *psIO,[out] short *psPos)
HRESULT | cmdLetArea ([in] short sNo,[in] float *pf,[in] short sIO,[in] short sPos)
HRESULT | cmdGetAreaEx ([in] short sNo,[out] float *pf,[out] short *psIO,[out] short *psPos,[out] short *psErr,[out] short *psEnable)
HRESULT | cmdLetAreaEx ([in] short sNo,[in] float *pf,[in] short sIO,[in] short sPos,[in] short sErr,[in] short sEnable)
HRESULT | cmdGetToolIndex ([out] short *pVal)
HRESULT | cmdGetWorkIndex ([out] short *pVal)
HRESULT | cmdThere ([out] float *pVal)
HRESULT | cmdEnableArea ([in] short sNo)
HRESULT | cmdDisableArea ([in] short sNo)

Enum の解説

enum IRbtlkArm::RTK_ARM_STATUS

Enum 値:
RTK_AST_SERVO
RTK_AST_MODE
RTK_AST_CALEND

メソッドの解説

HRESULT IRbtlkArm::cmdDisableArea ( [in] short sNo )

HRESULT IRbtlkArm::cmdEnableArea ( [in] short sNo )

HRESULT IRbtlkArm::cmdGetArea | ( | [in] short | sNo,
 |  | [out] float * | pf,
 |  | [out] short * | psIO,
 |  | [out] short * | psPos
 | ) |

HRESULT IRbtlkArm::cmdGetAreaEx | ( | [in] short | sNo,
 |  | [out] float * | pf,
 |  | [out] short * | psIO,
 |  | [out] short * | psPos,
 |  | [out] short * | psErr,
 |  | [out] short * | psEnable
 | ) |

HRESULT IRbtlkArm::cmdGetTool | ( | [in] short | sNo,
 |  | [out] float * | pf
 | ) |

HRESULT IRbtlkArm::cmdGetToolIndex ( [out] short * pVal )

HRESULT IRbtlkArm::cmdGetWork | ( | [in] short | sNo,
 |  | [out] float * | pf
 | ) |

HRESULT IRbtlkArm::cmdGetWorkIndex ( [out] short * pVal )

HRESULT IRbtlkArm::cmdHere ( [out] float * pVal )

HRESULT IRbtlkArm::cmdJHere ( [out] float * pVal )

HRESULT IRbtlkArm::cmdLetArea | ( | [in] short | sNo,
 |  | [in] float * | pf,
 |  | [in] short | sIO,
 |  | [in] short | sPos
 | ) |

HRESULT IRbtlkArm::cmdLetAreaEx | ( | [in] short | sNo,
 |  | [in] float * | pf,
 |  | [in] short | sIO,
 |  | [in] short | sPos,
 |  | [in] short | sErr,
 |  | [in] short | sEnable
 | ) |

HRESULT IRbtlkArm::cmdLetTool | ( | [in] short | sNo,
 |  | [in] float * | pf
 | ) |

HRESULT IRbtlkArm::cmdLetWork | ( | [in] short | sNo,
 |  | [in] float * | pf
 | ) |

HRESULT IRbtlkArm::cmdThere ( [out] float * pVal )

このインタフェースの解説は次のファイルから生成されました:
  • ROBOTalk.idl
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


IRbtlkController interface Reference

インタフェースIRbtlkController の解説

import "ROBOTalk.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | cmdGetVersions ([in] short sIndex,[out] CHAR *pVal)
HRESULT | cmdGetDateTime ([out] short *psDateTime)
HRESULT | cmdLetDateTime ([in] short *psDateTime)
HRESULT | cmdClearCtrlLog ()
HRESULT | cmdStartCtrlLog ()
HRESULT | cmdStopCtrlLog ()
HRESULT | cmdGetParamCtrlLog ([out] long *pSmpCnt,[out] long *pSmpRate)
HRESULT | cmdSwitchCtrlLog ([in] short sMode)
HRESULT | cmdCancelCtrlLog ()
HRESULT | cmdGetMode ([out] short *pVal)
HRESULT | cmdSetMode ([in] short iMode)
HRESULT | cmdGetFreeMemory ([out] long *pVal)
HRESULT | cmdGetRobotType ([out] long *pVal)
HRESULT | cmdGetJointInfo ([in] short sMode,[out] short *pVal)
HRESULT | cmdGetJobStatus ([in] long JobID,[out] short *pStatus)
HRESULT | cmdLetJobStatus ([in] long JobID,[in] short sStatus)
HRESULT | cmdRequestFileSave ([out] short *pTransMode,[out] long *pTaskID)
HRESULT | cmdGetTransMode ([out] short *pTransMode)
HRESULT | cmdRequestRomUpdate ()
HRESULT | cmdNoticeRomVersion ([in] short sVer)
HRESULT | cmdDoSignal ([in] short sMode,[in] short sAction)
HRESULT | cmdSrvJointParam ([out] short *pJoint,[out] short *pInterval,[out] short *pCounts,[out] short *pData1,[out] short *pData2)
HRESULT | cmdSrvJointData ([in] short sOffset,[in] short sCounts,[out] float **pData1,[out] float **pData2)
HRESULT | cmdSrvJointCancel ()
HRESULT | cmdGetErrorCode ([out] long *pVal)
HRESULT | cmdClearError ([in] long lErrCode,[out] short *pVal)
HRESULT | cmdGetOperationLog ([in] short sIndex,[out] short *pCode,[out] CHAR *szDate,[out] CHAR *szTime,[out] CHAR *szModule,[out] CHAR *szMsg)
HRESULT | cmdGetErrorLog ([in] short sIndex,[out] short *pCode,[out] short *pLevel,[out] CHAR *szDate,[out] CHAR *szTime,[out] CHAR *szModule,[out] CHAR *szMsg)
HRESULT | cmdGetControlLog ([in] short sIndex,[out] float pData[8][4],[out] float *pReg,[out] short *pProgNo,[out] short *pLineNo)
HRESULT | cmdSetOption ([in] short sMode,[in] long lKey,[out] CHAR *pVal)
HRESULT | cmdChangeConfig ([in] short sMode)
HRESULT | cmdLetConfig ([in] short sMode,[in] short sIndex,[in] long newVal)
HRESULT | cmdGetConfig ([in] short sMode,[in] short sIndex,[out] long *pVal)
HRESULT | cmdGetStatus ([in] short sModule,[in] short sIndex,[out] short *pVal)

メソッドの解説

HRESULT IRbtlkController::cmdCancelCtrlLog ( )

HRESULT IRbtlkController::cmdChangeConfig ( [in] short sMode )

HRESULT IRbtlkController::cmdClearCtrlLog ( )

HRESULT IRbtlkController::cmdClearError | ( | [in] long | lErrCode,
 |  | [out] short * | pVal
 | ) |

HRESULT IRbtlkController::cmdDoSignal | ( | [in] short | sMode,
 |  | [in] short | sAction
 | ) |

HRESULT IRbtlkController::cmdGetConfig | ( | [in] short | sMode,
 |  | [in] short | sIndex,
 |  | [out] long * | pVal
 | ) |

HRESULT IRbtlkController::cmdGetControlLog | ( | [in] short | sIndex,
 |  | [out] float | pData[8][4],
 |  | [out] float * | pReg,
 |  | [out] short * | pProgNo,
 |  | [out] short * | pLineNo
 | ) |

HRESULT IRbtlkController::cmdGetDateTime ( [out] short * psDateTime )

HRESULT IRbtlkController::cmdGetErrorCode ( [out] long * pVal )

HRESULT IRbtlkController::cmdGetErrorLog | ( | [in] short | sIndex,
 |  | [out] short * | pCode,
 |  | [out] short * | pLevel,
 |  | [out] CHAR * | szDate,
 |  | [out] CHAR * | szTime,
 |  | [out] CHAR * | szModule,
 |  | [out] CHAR * | szMsg
 | ) |

HRESULT IRbtlkController::cmdGetFreeMemory ( [out] long * pVal )

HRESULT IRbtlkController::cmdGetJobStatus | ( | [in] long | JobID,
 |  | [out] short * | pStatus
 | ) |

HRESULT IRbtlkController::cmdGetJointInfo | ( | [in] short | sMode,
 |  | [out] short * | pVal
 | ) |

HRESULT IRbtlkController::cmdGetMode ( [out] short * pVal )

HRESULT IRbtlkController::cmdGetOperationLog | ( | [in] short | sIndex,
 |  | [out] short * | pCode,
 |  | [out] CHAR * | szDate,
 |  | [out] CHAR * | szTime,
 |  | [out] CHAR * | szModule,
 |  | [out] CHAR * | szMsg
 | ) |

HRESULT IRbtlkController::cmdGetParamCtrlLog | ( | [out] long * | pSmpCnt,
 |  | [out] long * | pSmpRate
 | ) |

HRESULT IRbtlkController::cmdGetRobotType ( [out] long * pVal )

HRESULT IRbtlkController::cmdGetStatus | ( | [in] short | sModule,
 |  | [in] short | sIndex,
 |  | [out] short * | pVal
 | ) |

HRESULT IRbtlkController::cmdGetTransMode ( [out] short * pTransMode )

HRESULT IRbtlkController::cmdGetVersions | ( | [in] short | sIndex,
 |  | [out] CHAR * | pVal
 | ) |

HRESULT IRbtlkController::cmdLetConfig | ( | [in] short | sMode,
 |  | [in] short | sIndex,
 |  | [in] long | newVal
 | ) |

HRESULT IRbtlkController::cmdLetDateTime ( [in] short * psDateTime )

HRESULT IRbtlkController::cmdLetJobStatus | ( | [in] long | JobID,
 |  | [in] short | sStatus
 | ) |

HRESULT IRbtlkController::cmdNoticeRomVersion ( [in] short sVer )

HRESULT IRbtlkController::cmdRequestFileSave | ( | [out] short * | pTransMode,
 |  | [out] long * | pTaskID
 | ) |

HRESULT IRbtlkController::cmdRequestRomUpdate ( )

HRESULT IRbtlkController::cmdSetMode ( [in] short iMode )

HRESULT IRbtlkController::cmdSetOption | ( | [in] short | sMode,
 |  | [in] long | lKey,
 |  | [out] CHAR * | pVal
 | ) |

HRESULT IRbtlkController::cmdSrvJointCancel ( )

HRESULT IRbtlkController::cmdSrvJointData | ( | [in] short | sOffset,
 |  | [in] short | sCounts,
 |  | [out] float ** | pData1,
 |  | [out] float ** | pData2
 | ) |

HRESULT IRbtlkController::cmdSrvJointParam | ( | [out] short * | pJoint,
 |  | [out] short * | pInterval,
 |  | [out] short * | pCounts,
 |  | [out] short * | pData1,
 |  | [out] short * | pData2
 | ) |

HRESULT IRbtlkController::cmdStartCtrlLog ( )

HRESULT IRbtlkController::cmdStopCtrlLog ( )

HRESULT IRbtlkController::cmdSwitchCtrlLog ( [in] short sMode )

このインタフェースの解説は次のファイルから生成されました:
  • ROBOTalk.idl
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


IRbtlkEngine interface Reference

インタフェースIRbtlkEngine の解説

import "ROBOTalk.idl";

すべてのメンバ一覧

Public 型

enum NIC_GVAR_IC {
NIC_GV_INT = (short)0x1018, NIC_GV_SNG = (short)0x1019, NIC_GV_DBL = (short)0x101A, NIC_GV_VEC = (short)0x101C,
NIC_GV_POS = (short)0x1015, NIC_GV_JNT = (short)0x101E, NIC_GV_TRN = (short)0x101D, NIC_GV_STR = (short)0x101B,
NIC_GV_IO = (short)0xFFFF
}
enum | RTK_CTRL_STATUS { RTK_CST_ERROR = 2, RTK_CST_RUNNING = 3, RTK_CST_EMGSTOP = 4 }

Public メソッド

HRESULT | ConnectServer ([in] CHAR *szPara)
HRESULT | DisconnectServer ()
HRESULT | Cancel ()
HRESULT | GetVarInfo ([in] CHAR *szVar,[out] short *sType,[out] short *sIndex)
HRESULT | RbtlkController ([out, retval] IRbtlkController **ppVal)
HRESULT | RbtlkVariable ([out, retval] IRbtlkVariable **ppVal)
HRESULT | RbtlkArm ([out, retval] IRbtlkArm **ppVal)
HRESULT | RbtlkIO ([out, retval] IRbtlkIO **ppVal)
HRESULT | RbtlkTask ([out, retval] IRbtlkTask **ppVal)
HRESULT | RbtlkFile ([out, retval] IRbtlkFile **ppVal)
HRESULT | TimeOut ([out, retval] long *pVal)
HRESULT | TimeOut ([in] long newVal)
HRESULT | TimeOutRetry ([out, retval] long *pVal)
HRESULT | TimeOutRetry ([in] long newVal)
HRESULT | NakRetry ([out, retval] long *pVal)
HRESULT | NakRetry ([in] long newVal)
HRESULT | LastError ([out, retval] long *pVal)
HRESULT | Version ([out, retval] double *pVal)

Enum の解説

enum IRbtlkEngine::NIC_GVAR_IC

Enum 値:
NIC_GV_INT
NIC_GV_SNG
NIC_GV_DBL
NIC_GV_VEC
NIC_GV_POS
NIC_GV_JNT
NIC_GV_TRN
NIC_GV_STR
NIC_GV_IO

enum IRbtlkEngine::RTK_CTRL_STATUS

Enum 値:
RTK_CST_ERROR
RTK_CST_RUNNING
RTK_CST_EMGSTOP

メソッドの解説

HRESULT IRbtlkEngine::Cancel ( )

HRESULT IRbtlkEngine::ConnectServer ( [in] CHAR * szPara )

HRESULT IRbtlkEngine::DisconnectServer ( )

HRESULT IRbtlkEngine::GetVarInfo | ( | [in] CHAR * | szVar,
 |  | [out] short * | sType,
 |  | [out] short * | sIndex
 | ) |

HRESULT IRbtlkEngine::LastError ( [out, retval] long * pVal )

HRESULT IRbtlkEngine::NakRetry ( [in] long newVal )

HRESULT IRbtlkEngine::NakRetry ( [out, retval] long * pVal )

HRESULT IRbtlkEngine::RbtlkArm ( [out, retval] IRbtlkArm ** ppVal )

HRESULT IRbtlkEngine::RbtlkController ( [out, retval] IRbtlkController ** ppVal )

HRESULT IRbtlkEngine::RbtlkFile ( [out, retval] IRbtlkFile ** ppVal )

HRESULT IRbtlkEngine::RbtlkIO ( [out, retval] IRbtlkIO ** ppVal )

HRESULT IRbtlkEngine::RbtlkTask ( [out, retval] IRbtlkTask ** ppVal )

HRESULT IRbtlkEngine::RbtlkVariable ( [out, retval] IRbtlkVariable ** ppVal )

HRESULT IRbtlkEngine::TimeOut ( [in] long newVal )

HRESULT IRbtlkEngine::TimeOut ( [out, retval] long * pVal )

HRESULT IRbtlkEngine::TimeOutRetry ( [in] long newVal )

HRESULT IRbtlkEngine::TimeOutRetry ( [out, retval] long * pVal )

HRESULT IRbtlkEngine::Version ( [out, retval] double * pVal )

このインタフェースの解説は次のファイルから生成されました:
  • ROBOTalk.idl
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


IRbtlkEngine::RTK_PACKET struct Reference

構造体 IRbtlkEngine::RTK_PACKET の解説

import "ROBOTalk.idl";

すべてのメンバ一覧

Public 変数

BYTE | bEnq
BYTE | bLength
WORD | wCommand
BYTE | bID1
BYTE | bID2
BYTE | bData [248]
BYTE | bCDH
BYTE | bCDL

変数の解説

BYTE IRbtlkEngine::RTK_PACKET::bCDH

BYTE IRbtlkEngine::RTK_PACKET::bCDL

BYTE IRbtlkEngine::RTK_PACKET::bData[248]

BYTE IRbtlkEngine::RTK_PACKET::bEnq

BYTE IRbtlkEngine::RTK_PACKET::bID1

BYTE IRbtlkEngine::RTK_PACKET::bID2

BYTE IRbtlkEngine::RTK_PACKET::bLength

WORD IRbtlkEngine::RTK_PACKET::wCommand

この構造体の解説は次のファイルから生成されました:
  • ROBOTalk.idl
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


IRbtlkFile interface Reference

インタフェースIRbtlkFile の解説

import "ROBOTalk.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | cmdFileUploadStart ()
HRESULT | cmdFileUploadEnd ()
HRESULT | cmdRequestUpload ([in] short sBlocks,[in] long lSize,[in] short sFileProp,[in] short sFileFlag,[in] CHAR *szName,[out] short *psFileID)
HRESULT | cmdRequestDownload ([in] short sFileFlag,[in] CHAR *szName,[out] short *psFileID,[out] short *psBlocks,[out] short *sFileProp,[out] long *plSize)
HRESULT | cmdUpload ([in] short sFileID,[in] short sBlockNo,[in] BSTR bstrData)
HRESULT | cmdDownload ([in] short sFileID,[out] short *psFileID,[out] short *psBlockNo,[out] BSTR *pbstrData)
HRESULT | cmdCancelUpload ([in] short sFileID)
HRESULT | cmdCancelDownload ([in] short sFileID)
HRESULT | cmdDeleteFile ([in] CHAR *szName)
HRESULT | cmdGetFileCnt ([in] CHAR *szName,[out] short *psFiles)
HRESULT | cmdCopyFile ([in] CHAR *szFrom,[in] CHAR *szTo)
HRESULT | cmdMoveFile ([in] CHAR *szFrom,[in] CHAR *szTo)
HRESULT | cmdGetFileName ([in] short sIndex,[in] CHAR *szDirName,[out] CHAR *pVal)
HRESULT | cmdGetAttributes ([in] short iSystem,[in] CHAR *szName,[out] long *pVal)
HRESULT | cmdGetDataCreated ([in] short iSystem,[in] CHAR *szName,[out] short *pDateTime)
HRESULT | cmdGetLastModified ([in] short iSystem,[in] CHAR *szName,[out] short *pDateTime)
HRESULT | cmdGetLastAccessed ([in] short iSystem,[in] CHAR *szName,[out] short *pDateTime)
HRESULT | cmdGetSize ([in] short iSystem,[in] CHAR *szName,[out] long *pVal)
HRESULT | cmdStartPrg ([in] short iProgIC,[in] short iStartMode)
HRESULT | cmdStopPrg ([in] short iProgIC,[in] short iStopMode)
HRESULT | cmdGetProgramIC ([in] CHAR *szName,[out] short *pVal)
HRESULT | cmdStepForward ([in] short iProgIC)
HRESULT | cmdStepBackward ([in] short iProgIC)
HRESULT | cmdLetStartLine ([in] short iLineNo,[in] short iProgIC,[out] short *pVal)
HRESULT | cmdKillProg ([in] short iActMode,[in] short iProgIC)
HRESULT | cmdLoadNic ([out] long *pID)
HRESULT | cmdRequestUpload0 ([in] short sBlocks,[in] long lSize,[in] CHAR *szName,[in] CHAR *szAttribute,[in] CHAR *szUsage,[out] short *psFileID)
HRESULT | cmdRequestDownload0 ([in] CHAR *szName,[out] short *psFileID,[out] short *psBlocks,[out] long *plSize,[out] CHAR *szAttribute,[out] CHAR *szUsage)
HRESULT | cmdUpload0 ([in] short sFileID,[in] short sBlockNo,[in] BSTR bstrData)
HRESULT | cmdDownload0 ([in] short sFileID,[out] short *psFileID,[out] short *psBlockNo,[out] BSTR *pbstrData)
HRESULT | cmdCancelUpload0 ([in] short sFileID)
HRESULT | cmdCancelDownload0 ([in] short sFileID)
HRESULT | cmdGetProgramIndex ([in] CHAR *szName,[out] short *pVal)
HRESULT | cmdDeleteFile0 ([in] CHAR *szName)
HRESULT | cmdGetFileCnt0 ([out] short *psFiles)
HRESULT | cmdGetFileName0 ([in] short sIndex,[out] CHAR *pVal)

メソッドの解説

HRESULT IRbtlkFile::cmdCancelDownload ( [in] short sFileID )

HRESULT IRbtlkFile::cmdCancelDownload0 ( [in] short sFileID )

HRESULT IRbtlkFile::cmdCancelUpload ( [in] short sFileID )

HRESULT IRbtlkFile::cmdCancelUpload0 ( [in] short sFileID )

HRESULT IRbtlkFile::cmdCopyFile | ( | [in] CHAR * | szFrom,
 |  | [in] CHAR * | szTo
 | ) |

HRESULT IRbtlkFile::cmdDeleteFile ( [in] CHAR * szName )

HRESULT IRbtlkFile::cmdDeleteFile0 ( [in] CHAR * szName )

HRESULT IRbtlkFile::cmdDownload | ( | [in] short | sFileID,
 |  | [out] short * | psFileID,
 |  | [out] short * | psBlockNo,
 |  | [out] BSTR * | pbstrData
 | ) |

HRESULT IRbtlkFile::cmdDownload0 | ( | [in] short | sFileID,
 |  | [out] short * | psFileID,
 |  | [out] short * | psBlockNo,
 |  | [out] BSTR * | pbstrData
 | ) |

HRESULT IRbtlkFile::cmdFileUploadEnd ( )

HRESULT IRbtlkFile::cmdFileUploadStart ( )

HRESULT IRbtlkFile::cmdGetAttributes | ( | [in] short | iSystem,
 |  | [in] CHAR * | szName,
 |  | [out] long * | pVal
 | ) |

HRESULT IRbtlkFile::cmdGetDataCreated | ( | [in] short | iSystem,
 |  | [in] CHAR * | szName,
 |  | [out] short * | pDateTime
 | ) |

HRESULT IRbtlkFile::cmdGetFileCnt | ( | [in] CHAR * | szName,
 |  | [out] short * | psFiles
 | ) |

HRESULT IRbtlkFile::cmdGetFileCnt0 ( [out] short * psFiles )

HRESULT IRbtlkFile::cmdGetFileName | ( | [in] short | sIndex,
 |  | [in] CHAR * | szDirName,
 |  | [out] CHAR * | pVal
 | ) |

HRESULT IRbtlkFile::cmdGetFileName0 | ( | [in] short | sIndex,
 |  | [out] CHAR * | pVal
 | ) |

HRESULT IRbtlkFile::cmdGetLastAccessed | ( | [in] short | iSystem,
 |  | [in] CHAR * | szName,
 |  | [out] short * | pDateTime
 | ) |

HRESULT IRbtlkFile::cmdGetLastModified | ( | [in] short | iSystem,
 |  | [in] CHAR * | szName,
 |  | [out] short * | pDateTime
 | ) |

HRESULT IRbtlkFile::cmdGetProgramIC | ( | [in] CHAR * | szName,
 |  | [out] short * | pVal
 | ) |

HRESULT IRbtlkFile::cmdGetProgramIndex | ( | [in] CHAR * | szName,
 |  | [out] short * | pVal
 | ) |

HRESULT IRbtlkFile::cmdGetSize | ( | [in] short | iSystem,
 |  | [in] CHAR * | szName,
 |  | [out] long * | pVal
 | ) |

HRESULT IRbtlkFile::cmdKillProg | ( | [in] short | iActMode,
 |  | [in] short | iProgIC
 | ) |

HRESULT IRbtlkFile::cmdLetStartLine | ( | [in] short | iLineNo,
 |  | [in] short | iProgIC,
 |  | [out] short * | pVal
 | ) |

HRESULT IRbtlkFile::cmdLoadNic ( [out] long * pID )

HRESULT IRbtlkFile::cmdMoveFile | ( | [in] CHAR * | szFrom,
 |  | [in] CHAR * | szTo
 | ) |

HRESULT IRbtlkFile::cmdRequestDownload | ( | [in] short | sFileFlag,
 |  | [in] CHAR * | szName,
 |  | [out] short * | psFileID,
 |  | [out] short * | psBlocks,
 |  | [out] short * | sFileProp,
 |  | [out] long * | plSize
 | ) |

HRESULT IRbtlkFile::cmdRequestDownload0 | ( | [in] CHAR * | szName,
 |  | [out] short * | psFileID,
 |  | [out] short * | psBlocks,
 |  | [out] long * | plSize,
 |  | [out] CHAR * | szAttribute,
 |  | [out] CHAR * | szUsage
 | ) |

HRESULT IRbtlkFile::cmdRequestUpload | ( | [in] short | sBlocks,
 |  | [in] long | lSize,
 |  | [in] short | sFileProp,
 |  | [in] short | sFileFlag,
 |  | [in] CHAR * | szName,
 |  | [out] short * | psFileID
 | ) |

HRESULT IRbtlkFile::cmdRequestUpload0 | ( | [in] short | sBlocks,
 |  | [in] long | lSize,
 |  | [in] CHAR * | szName,
 |  | [in] CHAR * | szAttribute,
 |  | [in] CHAR * | szUsage,
 |  | [out] short * | psFileID
 | ) |

HRESULT IRbtlkFile::cmdStartPrg | ( | [in] short | iProgIC,
 |  | [in] short | iStartMode
 | ) |

HRESULT IRbtlkFile::cmdStepBackward ( [in] short iProgIC )

HRESULT IRbtlkFile::cmdStepForward ( [in] short iProgIC )

HRESULT IRbtlkFile::cmdStopPrg | ( | [in] short | iProgIC,
 |  | [in] short | iStopMode
 | ) |

HRESULT IRbtlkFile::cmdUpload | ( | [in] short | sFileID,
 |  | [in] short | sBlockNo,
 |  | [in] BSTR | bstrData
 | ) |

HRESULT IRbtlkFile::cmdUpload0 | ( | [in] short | sFileID,
 |  | [in] short | sBlockNo,
 |  | [in] BSTR | bstrData
 | ) |

このインタフェースの解説は次のファイルから生成されました:
  • ROBOTalk.idl
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


IRbtlkIO interface Reference

インタフェースIRbtlkIO の解説

import "ROBOTalk.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | cmdDin ([in] short sIndex,[out] BOOL *pVal)
HRESULT | cmdDout ([in] short sIndex,[in] BOOL newVal)
HRESULT | cmdDummy ([in] short sIndex,[in] short newVal)
HRESULT | cmdDin8 ([in] short sIndex,[out] short *pVal)
HRESULT | cmdDout8 ([in] short sIndex,[in] short newVal)
HRESULT | cmdDin16 ([in] short sIndex,[out] short *pVal)
HRESULT | cmdDout16 ([in] short sIndex,[in] short newVal)
HRESULT | cmdChangeLabel ([in] short sPlateNo,[in] short sButtonNo,[in] CHAR *newVal)

メソッドの解説

HRESULT IRbtlkIO::cmdChangeLabel | ( | [in] short | sPlateNo,
 |  | [in] short | sButtonNo,
 |  | [in] CHAR * | newVal
 | ) |

HRESULT IRbtlkIO::cmdDin | ( | [in] short | sIndex,
 |  | [out] BOOL * | pVal
 | ) |

HRESULT IRbtlkIO::cmdDin16 | ( | [in] short | sIndex,
 |  | [out] short * | pVal
 | ) |

HRESULT IRbtlkIO::cmdDin8 | ( | [in] short | sIndex,
 |  | [out] short * | pVal
 | ) |

HRESULT IRbtlkIO::cmdDout | ( | [in] short | sIndex,
 |  | [in] BOOL | newVal
 | ) |

HRESULT IRbtlkIO::cmdDout16 | ( | [in] short | sIndex,
 |  | [in] short | newVal
 | ) |

HRESULT IRbtlkIO::cmdDout8 | ( | [in] short | sIndex,
 |  | [in] short | newVal
 | ) |

HRESULT IRbtlkIO::cmdDummy | ( | [in] short | sIndex,
 |  | [in] short | newVal
 | ) |

このインタフェースの解説は次のファイルから生成されました:
  • ROBOTalk.idl
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


IRbtlkTask interface Reference

インタフェースIRbtlkTask の解説

import "ROBOTalk.idl";

すべてのメンバ一覧

Public 型

enum | RTK_PAC_CONF { RTK_PC_LANG_MODE = 18, RTK_PC_ROBOTTYPE = 19 }
enum | RTK_ITP_CONF { RTK_IP_TASKNUM = 1, RTK_IP_RSTKSIZE = 2 }

Public メソッド

HRESULT | cmdGetPrgListLen ([out] short *newVal)
HRESULT | cmdGetPrgList ([in] short sIndex,[out] short *newVal,[out] CHAR *szName)
HRESULT | cmdGetTaskStatus ([in] short sPrgIC,[out] short *pStatus)
HRESULT | cmdContPrgStatus ([in] short sPrgIC,[out] short *pStatus,[out] short *pPriority,[out] short *pInterval,[out] short *pLineNo,[out] short *pIOBlock,[out] short *pMode,[out] long *pCT)

Enum の解説

enum IRbtlkTask::RTK_ITP_CONF

Enum 値:
RTK_IP_TASKNUM
RTK_IP_RSTKSIZE

enum IRbtlkTask::RTK_PAC_CONF

Enum 値:
RTK_PC_LANG_MODE
RTK_PC_ROBOTTYPE

メソッドの解説

HRESULT IRbtlkTask::cmdContPrgStatus | ( | [in] short | sPrgIC,
 |  | [out] short * | pStatus,
 |  | [out] short * | pPriority,
 |  | [out] short * | pInterval,
 |  | [out] short * | pLineNo,
 |  | [out] short * | pIOBlock,
 |  | [out] short * | pMode,
 |  | [out] long * | pCT
 | ) |

HRESULT IRbtlkTask::cmdGetPrgList | ( | [in] short | sIndex,
 |  | [out] short * | newVal,
 |  | [out] CHAR * | szName
 | ) |

HRESULT IRbtlkTask::cmdGetPrgListLen ( [out] short * newVal )

HRESULT IRbtlkTask::cmdGetTaskStatus | ( | [in] short | sPrgIC,
 |  | [out] short * | pStatus
 | ) |

このインタフェースの解説は次のファイルから生成されました:
  • ROBOTalk.idl
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


IRbtlkVariable interface Reference

インタフェースIRbtlkVariable の解説

import "ROBOTalk.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | cmdGetI ([in] short sIC,[in] short sIndex,[out] long *pVal)
HRESULT | cmdLetI ([in] short sIC,[in] short sIndex,[in] long newVal)
HRESULT | cmdGetF ([in] short sIC,[in] short sIndex,[out] float *pVal)
HRESULT | cmdLetF ([in] short sIC,[in] short sIndex,[in] float newVal)
HRESULT | cmdGetP ([in] short sIC,[in] short sIndex,[out] float *pVal)
HRESULT | cmdLetP ([in] short sIC,[in] short sIndex,[in] float *newVal)
HRESULT | cmdGetJ ([in] short sIC,[in] short sIndex,[out] float *pVal)
HRESULT | cmdLetJ ([in] short sIC,[in] short sIndex,[in] float *newVal)
HRESULT | cmdGetD ([in] short sIC,[in] short sIndex,[out] double *pVal)
HRESULT | cmdLetD ([in] short sIC,[in] short sIndex,[in] double newVal)
HRESULT | cmdGetS ([in] short sIC,[in] short sIndex,[out] CHAR *pVal)
HRESULT | cmdLetS ([in] short sIC,[in] short sIndex,[in] CHAR *newVal)
HRESULT | cmdGetV ([in] short sIC,[in] short sIndex,[out] float *pVal)
HRESULT | cmdLetV ([in] short sIC,[in] short sIndex,[in] float *newVal)
HRESULT | cmdGetT ([in] short sIC,[in] short sIndex,[out] float *pVal)
HRESULT | cmdLetT ([in] short sIC,[in] short sIndex,[in] float *newVal)
HRESULT | cmdGetTabLen ([in] short sPrgIC,[in] short sTypeIC,[out] short *pVal)
HRESULT | cmdGetDefIO ([in] short sPort,[in] short sType,[in] long lMask,[out] long *pVal)
HRESULT | cmdLetDefIO ([in] short sPort,[in] short sType,[in] long lMask,[in] long lVal)

メソッドの解説

HRESULT IRbtlkVariable::cmdGetD | ( | [in] short | sIC,
 |  | [in] short | sIndex,
 |  | [out] double * | pVal
 | ) |

HRESULT IRbtlkVariable::cmdGetDefIO | ( | [in] short | sPort,
 |  | [in] short | sType,
 |  | [in] long | lMask,
 |  | [out] long * | pVal
 | ) |

HRESULT IRbtlkVariable::cmdGetF | ( | [in] short | sIC,
 |  | [in] short | sIndex,
 |  | [out] float * | pVal
 | ) |

HRESULT IRbtlkVariable::cmdGetI | ( | [in] short | sIC,
 |  | [in] short | sIndex,
 |  | [out] long * | pVal
 | ) |

HRESULT IRbtlkVariable::cmdGetJ | ( | [in] short | sIC,
 |  | [in] short | sIndex,
 |  | [out] float * | pVal
 | ) |

HRESULT IRbtlkVariable::cmdGetP | ( | [in] short | sIC,
 |  | [in] short | sIndex,
 |  | [out] float * | pVal
 | ) |

HRESULT IRbtlkVariable::cmdGetS | ( | [in] short | sIC,
 |  | [in] short | sIndex,
 |  | [out] CHAR * | pVal
 | ) |

HRESULT IRbtlkVariable::cmdGetT | ( | [in] short | sIC,
 |  | [in] short | sIndex,
 |  | [out] float * | pVal
 | ) |

HRESULT IRbtlkVariable::cmdGetTabLen | ( | [in] short | sPrgIC,
 |  | [in] short | sTypeIC,
 |  | [out] short * | pVal
 | ) |

HRESULT IRbtlkVariable::cmdGetV | ( | [in] short | sIC,
 |  | [in] short | sIndex,
 |  | [out] float * | pVal
 | ) |

HRESULT IRbtlkVariable::cmdLetD | ( | [in] short | sIC,
 |  | [in] short | sIndex,
 |  | [in] double | newVal
 | ) |

HRESULT IRbtlkVariable::cmdLetDefIO | ( | [in] short | sPort,
 |  | [in] short | sType,
 |  | [in] long | lMask,
 |  | [in] long | lVal
 | ) |

HRESULT IRbtlkVariable::cmdLetF | ( | [in] short | sIC,
 |  | [in] short | sIndex,
 |  | [in] float | newVal
 | ) |

HRESULT IRbtlkVariable::cmdLetI | ( | [in] short | sIC,
 |  | [in] short | sIndex,
 |  | [in] long | newVal
 | ) |

HRESULT IRbtlkVariable::cmdLetJ | ( | [in] short | sIC,
 |  | [in] short | sIndex,
 |  | [in] float * | newVal
 | ) |

HRESULT IRbtlkVariable::cmdLetP | ( | [in] short | sIC,
 |  | [in] short | sIndex,
 |  | [in] float * | newVal
 | ) |

HRESULT IRbtlkVariable::cmdLetS | ( | [in] short | sIC,
 |  | [in] short | sIndex,
 |  | [in] CHAR * | newVal
 | ) |

HRESULT IRbtlkVariable::cmdLetT | ( | [in] short | sIC,
 |  | [in] short | sIndex,
 |  | [in] float * | newVal
 | ) |

HRESULT IRbtlkVariable::cmdLetV | ( | [in] short | sIC,
 |  | [in] short | sIndex,
 |  | [in] float * | newVal
 | ) |

このインタフェースの解説は次のファイルから生成されました:
  • ROBOTalk.idl
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


ROBOTALKLib::RbtlkArm class Reference

クラス ROBOTALKLib::RbtlkArm の解説

import "ROBOTalk.idl";

このクラスの解説は次のファイルから生成されました:
  • ROBOTalk.idl
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


ROBOTALKLib::RbtlkController class Reference

クラス ROBOTALKLib::RbtlkController の解説

import "ROBOTalk.idl";

このクラスの解説は次のファイルから生成されました:
  • ROBOTalk.idl
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


ROBOTALKLib::RbtlkEngine class Reference

クラス ROBOTALKLib::RbtlkEngine の解説

import "ROBOTalk.idl";

このクラスの解説は次のファイルから生成されました:
  • ROBOTalk.idl
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


ROBOTALKLib::RbtlkFile class Reference

クラス ROBOTALKLib::RbtlkFile の解説

import "ROBOTalk.idl";

このクラスの解説は次のファイルから生成されました:
  • ROBOTalk.idl
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


ROBOTALKLib::RbtlkIO class Reference

クラス ROBOTALKLib::RbtlkIO の解説

import "ROBOTalk.idl";

このクラスの解説は次のファイルから生成されました:
  • ROBOTalk.idl
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


ROBOTALKLib::RbtlkTask class Reference

クラス ROBOTALKLib::RbtlkTask の解説

import "ROBOTalk.idl";

このクラスの解説は次のファイルから生成されました:
  • ROBOTalk.idl
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


ROBOTALKLib::RbtlkVariable class Reference

クラス ROBOTALKLib::RbtlkVariable の解説

import "ROBOTalk.idl";

このクラスの解説は次のファイルから生成されました:
  • ROBOTalk.idl
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


SerialParam struct Reference

構造体 SerialParam の解説

Connect()引数のパラメータ構造体. [詳細]

#include <StdAfx.h>

すべてのメンバ一覧

Public 変数

DWORD | dwPortNo
COMポートの番号 : COM1(1) ～.

DWORD | dwBaudRate
スピード(bps) : 4800bps(4800), ～ マクロ ：CBR_4800,CBR_9600,...

DWORD | dwParity
パリティ : 0 ～4 = None, Odd, Even, Mark, Space マクロ ：NOPARITY,ODDPARITY,EVENPARITY,MARKPARITY,SPACEPARITY

DWORD | dwDataBits
データビット数 : 4bits(4) ～ 8bits(8)

DWORD | dwStopBits
ストップビット数 : 0 ～2 = 1,1.5,2 bit(s) マクロ：ONESTOPBIT,ONE5STOPBITS,TWOSTOPBITS

CComBSTR | bstrATCmd
ATコマンド.

解説

Connect()引数のパラメータ構造体.

変数の解説

CComBSTR SerialParam::bstrATCmd

ATコマンド.

DWORD SerialParam::dwBaudRate

スピード(bps) : 4800bps(4800), ～ マクロ ：CBR_4800,CBR_9600,...

DWORD SerialParam::dwDataBits

データビット数 : 4bits(4) ～ 8bits(8)

DWORD SerialParam::dwParity

パリティ : 0 ～4 = None, Odd, Even, Mark, Space マクロ ：NOPARITY,ODDPARITY,EVENPARITY,MARKPARITY,SPACEPARITY

DWORD SerialParam::dwPortNo

COMポートの番号 : COM1(1) ～.

DWORD SerialParam::dwStopBits

ストップビット数 : 0 ～2 = 1,1.5,2 bit(s) マクロ：ONESTOPBIT,ONE5STOPBITS,TWOSTOPBITS

この構造体の解説は次のファイルから生成されました:
  • StdAfx.h
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


Hierarchical Index

DENSO WAVE ROBOTalk Project クラス階層

クラス階層図を見る。

この継承一覧はおおまかにはソートされていますが、完全にアルファベット順でソートされてはいません。

  • __MIDL_IRbtlkEngine_0002
  • _IID
  • _MIDL_PROC_FORMAT_STRING
  • _MIDL_TYPE_FORMAT_STRING
  • CDevice
    • CEtherUDP
    • CSerial
  • CRbtlkArm
  • CRbtlkController
  • CRbtlkEngine
  • CRbtlkFile
  • CRbtlkIO
  • CRbtlkTask
  • CRbtlkVariable
  • EtherParam
  • IRbtlkArm
  • IRbtlkController
  • IRbtlkEngine
  • IRbtlkEngine::RTK_PACKET
  • IRbtlkFile
  • IRbtlkIO
  • IRbtlkTask
  • IRbtlkVariable
  • ROBOTALKLib::RbtlkArm
  • ROBOTALKLib::RbtlkController
  • ROBOTALKLib::RbtlkEngine
  • ROBOTALKLib::RbtlkFile
  • ROBOTALKLib::RbtlkIO
  • ROBOTALKLib::RbtlkTask
  • ROBOTALKLib::RbtlkVariable
  • SerialParam
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


Compound Member Index

DENSO WAVE ROBOTalk Project 構成メンバ

b | c | d | f | g | i | l | m | n | p | r | s | t | v | w | x | ~

これはクラスメンバの一覧で、それぞれが属しているクラスの解説へリンクしています。

- b -

  • bCDH : IRbtlkEngine::RTK_PACKET, __MIDL_IRbtlkEngine_0002
  • bCDL : IRbtlkEngine::RTK_PACKET, __MIDL_IRbtlkEngine_0002
  • bData : IRbtlkEngine::RTK_PACKET, __MIDL_IRbtlkEngine_0002
  • bEnq : IRbtlkEngine::RTK_PACKET, __MIDL_IRbtlkEngine_0002
  • bID1 : IRbtlkEngine::RTK_PACKET, __MIDL_IRbtlkEngine_0002
  • bID2 : IRbtlkEngine::RTK_PACKET, __MIDL_IRbtlkEngine_0002
  • bLength : IRbtlkEngine::RTK_PACKET, __MIDL_IRbtlkEngine_0002
  • bstrATCmd : SerialParam
  • BSTRToByte() : CRbtlkEngine
  • ByteToBSTR() : CRbtlkEngine
  • ByteToDouble() : CRbtlkEngine
  • ByteToLong() : CRbtlkEngine
  • ByteToShort() : CRbtlkEngine
  • ByteToSingle() : CRbtlkEngine

- c -

  • c : _IID
  • Cancel() : IRbtlkEngine, CRbtlkEngine
  • CDevice() : CDevice
  • CEtherUDP() : CEtherUDP
  • cmdCancelCtrlLog() : IRbtlkController, CRbtlkController
  • cmdCancelDownload() : IRbtlkFile, CRbtlkFile
  • cmdCancelDownload0() : IRbtlkFile, CRbtlkFile
  • cmdCancelUpload() : IRbtlkFile, CRbtlkFile
  • cmdCancelUpload0() : IRbtlkFile, CRbtlkFile
  • cmdChangeConfig() : IRbtlkController, CRbtlkController
  • cmdChangeLabel() : IRbtlkIO, CRbtlkIO
  • cmdClearCtrlLog() : IRbtlkController, CRbtlkController
  • cmdClearError() : IRbtlkController, CRbtlkController
  • cmdContPrgStatus() : IRbtlkTask, CRbtlkTask
  • cmdCopyFile() : IRbtlkFile, CRbtlkFile
  • cmdDeleteFile() : IRbtlkFile, CRbtlkFile
  • cmdDeleteFile0() : IRbtlkFile, CRbtlkFile
  • cmdDin() : IRbtlkIO, CRbtlkIO
  • cmdDin16() : IRbtlkIO, CRbtlkIO
  • cmdDin8() : IRbtlkIO, CRbtlkIO
  • cmdDisableArea() : IRbtlkArm, CRbtlkArm
  • cmdDoSignal() : IRbtlkController, CRbtlkController
  • cmdDout() : IRbtlkIO, CRbtlkIO
  • cmdDout16() : IRbtlkIO, CRbtlkIO
  • cmdDout8() : IRbtlkIO, CRbtlkIO
  • cmdDownload() : IRbtlkFile, CRbtlkFile
  • cmdDownload0() : IRbtlkFile, CRbtlkFile
  • cmdDummy() : IRbtlkIO, CRbtlkIO
  • cmdEnableArea() : IRbtlkArm, CRbtlkArm
  • cmdFileUploadEnd() : IRbtlkFile, CRbtlkFile
  • cmdFileUploadStart() : IRbtlkFile, CRbtlkFile
  • cmdGetArea() : IRbtlkArm, CRbtlkArm
  • cmdGetAreaEx() : IRbtlkArm, CRbtlkArm
  • cmdGetAttributes() : IRbtlkFile, CRbtlkFile
  • cmdGetConfig() : IRbtlkController, CRbtlkController
  • cmdGetControlLog() : IRbtlkController, CRbtlkController
  • cmdGetD() : IRbtlkVariable, CRbtlkVariable
  • cmdGetDataCreated() : IRbtlkFile, CRbtlkFile
  • cmdGetDateTime() : IRbtlkController, CRbtlkController
  • cmdGetDefIO() : IRbtlkVariable, CRbtlkVariable
  • cmdGetErrorCode() : IRbtlkController, CRbtlkController
  • cmdGetErrorLog() : IRbtlkController, CRbtlkController
  • cmdGetF() : IRbtlkVariable, CRbtlkVariable
  • cmdGetFileCnt() : IRbtlkFile, CRbtlkFile
  • cmdGetFileCnt0() : IRbtlkFile, CRbtlkFile
  • cmdGetFileName() : IRbtlkFile, CRbtlkFile
  • cmdGetFileName0() : IRbtlkFile, CRbtlkFile
  • cmdGetFreeMemory() : IRbtlkController, CRbtlkController
  • cmdGetI() : IRbtlkVariable, CRbtlkVariable
  • cmdGetJ() : IRbtlkVariable, CRbtlkVariable
  • cmdGetJobStatus() : IRbtlkController, CRbtlkController
  • cmdGetJointInfo() : IRbtlkController, CRbtlkController
  • cmdGetLastAccessed() : IRbtlkFile, CRbtlkFile
  • cmdGetLastModified() : IRbtlkFile, CRbtlkFile
  • cmdGetMode() : IRbtlkController, CRbtlkController
  • cmdGetOperationLog() : IRbtlkController, CRbtlkController
  • cmdGetP() : IRbtlkVariable, CRbtlkVariable
  • cmdGetParamCtrlLog() : IRbtlkController, CRbtlkController
  • cmdGetPrgList() : IRbtlkTask, CRbtlkTask
  • cmdGetPrgListLen() : IRbtlkTask, CRbtlkTask
  • cmdGetProgramIC() : IRbtlkFile, CRbtlkFile
  • cmdGetProgramIndex() : IRbtlkFile, CRbtlkFile
  • cmdGetRobotType() : IRbtlkController, CRbtlkController
  • cmdGetS() : IRbtlkVariable, CRbtlkVariable
  • cmdGetSize() : IRbtlkFile, CRbtlkFile
  • cmdGetStatus() : IRbtlkController, CRbtlkController
  • cmdGetT() : IRbtlkVariable, CRbtlkVariable
  • cmdGetTabLen() : IRbtlkVariable, CRbtlkVariable
  • cmdGetTaskStatus() : IRbtlkTask, CRbtlkTask
  • cmdGetTool() : IRbtlkArm, CRbtlkArm
  • cmdGetToolIndex() : IRbtlkArm, CRbtlkArm
  • cmdGetTransMode() : IRbtlkController, CRbtlkController
  • cmdGetV() : IRbtlkVariable, CRbtlkVariable
  • cmdGetVersions() : IRbtlkController, CRbtlkController
  • cmdGetWork() : IRbtlkArm, CRbtlkArm
  • cmdGetWorkIndex() : IRbtlkArm, CRbtlkArm
  • cmdHere() : IRbtlkArm, CRbtlkArm
  • cmdJHere() : IRbtlkArm, CRbtlkArm
  • cmdKillProg() : IRbtlkFile, CRbtlkFile
  • cmdLetArea() : IRbtlkArm, CRbtlkArm
  • cmdLetAreaEx() : IRbtlkArm, CRbtlkArm
  • cmdLetConfig() : IRbtlkController, CRbtlkController
  • cmdLetD() : IRbtlkVariable, CRbtlkVariable
  • cmdLetDateTime() : IRbtlkController, CRbtlkController
  • cmdLetDefIO() : IRbtlkVariable, CRbtlkVariable
  • cmdLetF() : IRbtlkVariable, CRbtlkVariable
  • cmdLetI() : IRbtlkVariable, CRbtlkVariable
  • cmdLetJ() : IRbtlkVariable, CRbtlkVariable
  • cmdLetJobStatus() : IRbtlkController, CRbtlkController
  • cmdLetP() : IRbtlkVariable, CRbtlkVariable
  • cmdLetS() : IRbtlkVariable, CRbtlkVariable
  • cmdLetStartLine() : IRbtlkFile, CRbtlkFile
  • cmdLetT() : IRbtlkVariable, CRbtlkVariable
  • cmdLetTool() : IRbtlkArm, CRbtlkArm
  • cmdLetV() : IRbtlkVariable, CRbtlkVariable
  • cmdLetWork() : IRbtlkArm, CRbtlkArm
  • cmdLoadNic() : IRbtlkFile, CRbtlkFile
  • cmdMoveFile() : IRbtlkFile, CRbtlkFile
  • cmdNoticeRomVersion() : IRbtlkController, CRbtlkController
  • cmdRequestDownload() : IRbtlkFile, CRbtlkFile
  • cmdRequestDownload0() : IRbtlkFile, CRbtlkFile
  • cmdRequestFileSave() : IRbtlkController, CRbtlkController
  • cmdRequestRomUpdate() : IRbtlkController, CRbtlkController
  • cmdRequestUpload() : IRbtlkFile, CRbtlkFile
  • cmdRequestUpload0() : IRbtlkFile, CRbtlkFile
  • cmdSetMode() : IRbtlkController, CRbtlkController
  • cmdSetOption() : IRbtlkController, CRbtlkController
  • cmdSrvJointCancel() : IRbtlkController, CRbtlkController
  • cmdSrvJointData() : IRbtlkController, CRbtlkController
  • cmdSrvJointParam() : IRbtlkController, CRbtlkController
  • cmdStartCtrlLog() : IRbtlkController, CRbtlkController
  • cmdStartPrg() : IRbtlkFile, CRbtlkFile
  • cmdStepBackward() : IRbtlkFile, CRbtlkFile
  • cmdStepForward() : IRbtlkFile, CRbtlkFile
  • cmdStopCtrlLog() : IRbtlkController, CRbtlkController
  • cmdStopPrg() : IRbtlkFile, CRbtlkFile
  • cmdSwitchCtrlLog() : IRbtlkController, CRbtlkController
  • cmdThere() : IRbtlkArm, CRbtlkArm
  • cmdUpload() : IRbtlkFile, CRbtlkFile
  • cmdUpload0() : IRbtlkFile, CRbtlkFile
  • Connect() : CSerial, CEtherUDP, CDevice
  • ConnectServer() : IRbtlkEngine, CRbtlkEngine
  • CRbtlkArm() : CRbtlkArm
  • CRbtlkController() : CRbtlkController
  • CRbtlkEngine() : CRbtlkEngine
  • CRbtlkFile() : CRbtlkFile
  • CRbtlkIO() : CRbtlkIO
  • CRbtlkTask() : CRbtlkTask
  • CRbtlkVariable() : CRbtlkVariable
  • CSerial() : CSerial

- d -

  • Disconnect() : CSerial, CEtherUDP, CDevice
  • DisconnectServer() : IRbtlkEngine, CRbtlkEngine
  • DoubleToByte() : CRbtlkEngine
  • dwBaudRate : SerialParam
  • dwDataBits : SerialParam
  • dwIPAdr : EtherParam
  • dwParity : SerialParam
  • dwPortNo : SerialParam, EtherParam
  • dwStopBits : SerialParam

- f -

  • FinalConstruct() : CRbtlkVariable, CRbtlkTask, CRbtlkIO, CRbtlkFile, CRbtlkEngine, CRbtlkController, CRbtlkArm
  • FinalRelease() : CRbtlkVariable, CRbtlkTask, CRbtlkIO, CRbtlkFile, CRbtlkEngine, CRbtlkController, CRbtlkArm
  • Flush() : CSerial, CEtherUDP, CDevice
  • Format : _MIDL_PROC_FORMAT_STRING, _MIDL_TYPE_FORMAT_STRING

- g -

  • get_LastError() : CRbtlkEngine
  • get_NakRetry() : CRbtlkEngine
  • get_RbtlkArm() : CRbtlkEngine
  • get_RbtlkController() : CRbtlkEngine
  • get_RbtlkFile() : CRbtlkEngine
  • get_RbtlkIO() : CRbtlkEngine
  • get_RbtlkTask() : CRbtlkEngine
  • get_RbtlkVariable() : CRbtlkEngine
  • get_TimeOut() : CRbtlkEngine
  • get_TimeOutRetry() : CRbtlkEngine
  • get_Version() : CRbtlkEngine
  • GetReceivedCount() : CSerial, CEtherUDP, CDevice
  • GetRecivePacket() : CDevice
  • GetState() : CSerial
  • GetTimeOut() : CDevice
  • GetVarInfo() : IRbtlkEngine, CRbtlkEngine
  • GetVarTabSize() : CRbtlkEngine

- i -

  • Initialize() : CSerial, CRbtlkVariable, CRbtlkTask, CRbtlkIO, CRbtlkFile, CRbtlkController, CRbtlkArm, CEtherUDP, CDevice
  • InterfaceSupportsErrorInfo() : CRbtlkVariable, CRbtlkTask, CRbtlkIO, CRbtlkFile, CRbtlkEngine, CRbtlkController, CRbtlkArm

- l -

  • LastError() : IRbtlkEngine
  • LongToByte() : CRbtlkEngine

- m -

  • m_bConnected : CDevice
  • m_dwHeaderLen : CDevice
  • m_dwLocalBufferLen : CDevice
  • m_dwMode : CDevice
  • m_dwReceiveRetry : CSerial
  • m_dwRetryCnt : CDevice
  • m_dwTermLen : CDevice
  • m_dwTotalTimeout : CDevice
  • m_hComHandle : CSerial
  • m_pcHeader : CDevice
  • m_pcTerm : CDevice
  • m_szLocalBuffer : CDevice

- n -

  • NakRetry() : IRbtlkEngine
  • NIC_GV_DBL : IRbtlkEngine
  • NIC_GV_INT : IRbtlkEngine
  • NIC_GV_IO : IRbtlkEngine
  • NIC_GV_JNT : IRbtlkEngine
  • NIC_GV_POS : IRbtlkEngine
  • NIC_GV_SNG : IRbtlkEngine
  • NIC_GV_STR : IRbtlkEngine
  • NIC_GV_TRN : IRbtlkEngine
  • NIC_GV_VEC : IRbtlkEngine
  • NIC_GVAR_IC : IRbtlkEngine

- p -

  • Pad : _MIDL_PROC_FORMAT_STRING, _MIDL_TYPE_FORMAT_STRING
  • put_NakRetry() : CRbtlkEngine
  • put_TimeOut() : CRbtlkEngine
  • put_TimeOutRetry() : CRbtlkEngine

- r -

  • RbtlkArm() : IRbtlkEngine
  • RbtlkController() : IRbtlkEngine
  • RbtlkFile() : IRbtlkEngine
  • RbtlkIO() : IRbtlkEngine
  • RbtlkTask() : IRbtlkEngine
  • RbtlkVariable() : IRbtlkEngine
  • Receive() : CDevice
  • RTK_ARM_STATUS : IRbtlkArm
  • RTK_AST_CALEND : IRbtlkArm
  • RTK_AST_MODE : IRbtlkArm
  • RTK_AST_SERVO : IRbtlkArm
  • RTK_CST_EMGSTOP : IRbtlkEngine
  • RTK_CST_ERROR : IRbtlkEngine
  • RTK_CST_RUNNING : IRbtlkEngine
  • RTK_CTRL_STATUS : IRbtlkEngine
  • RTK_IP_RSTKSIZE : IRbtlkTask
  • RTK_IP_TASKNUM : IRbtlkTask
  • RTK_ITP_CONF : IRbtlkTask
  • RTK_PAC_CONF : IRbtlkTask
  • RTK_PC_LANG_MODE : IRbtlkTask
  • RTK_PC_ROBOTTYPE : IRbtlkTask

- s -

  • s1 : _IID
  • s2 : _IID
  • Send() : CDevice
  • SendAndReceive() : CDevice
  • SendWithWait() : CRbtlkEngine
  • SendWithWaitA() : CRbtlkEngine
  • SetState() : CSerial
  • SetTimeOut() : CSerial, CEtherUDP, CDevice
  • ShortToByte() : CRbtlkEngine
  • SingleToByte() : CRbtlkEngine

- t -

  • TimeOut() : IRbtlkEngine
  • TimeOutRetry() : IRbtlkEngine

- v -

  • Version() : IRbtlkEngine

- w -

  • wCommand : IRbtlkEngine::RTK_PACKET, __MIDL_IRbtlkEngine_0002

- x -

  • x : _IID

- ~ -

  • ~CDevice() : CDevice
  • ~CEtherUDP() : CEtherUDP
  • ~CSerial() : CSerial
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


Namespace Index

DENSO WAVE ROBOTalk Project 名前空間一覧

名前空間の一覧です。
ROBOTALKLib
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


ROBOTALKLib Namespace Reference

名前空間 ROBOTALKLib の解説

構成

class | RbtlkArm
class | RbtlkController
class | RbtlkEngine
class | RbtlkFile
class | RbtlkIO
class | RbtlkTask
class | RbtlkVariable

関数

importlib ("stdole32.tlb")
importlib ("stdole2.tlb")

関数の解説

importlib ( "stdole2.tlb" )

importlib ( "stdole32.tlb" )

Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


File Member Index

DENSO WAVE ROBOTalk Project ファイルメンバ

_ | a | b | c | d | e | g | i | l | m | n | o | p | r | s | t | u

これはファイルメンバの一覧です。それぞれが属しているファイルの解説へリンクしています。

- _ -

  • __MIDL_IRbtlkArm_0001 : ROBOTalk.h
  • __MIDL_IRbtlkEngine_0001 : ROBOTalk.h
  • __MIDL_IRbtlkEngine_0003 : ROBOTalk.h
  • __MIDL_IRbtlkTask_0001 : ROBOTalk.h
  • __MIDL_IRbtlkTask_0002 : ROBOTalk.h
  • __MIDL_itf_ROBOTalk_0000_v0_0_c_ifspec : ROBOTalk.h
  • __MIDL_itf_ROBOTalk_0000_v0_0_s_ifspec : ROBOTalk.h
  • __MIDL_ProcFormatString : ROBOTalk_p.c
  • __MIDL_TypeFormatString : ROBOTalk_p.c
  • __pad0__ : ROBOTalk.h
  • __pad1__ : ROBOTalk.h
  • __pad2__ : ROBOTalk.h
  • __pad3__ : ROBOTalk.h
  • __pad4__ : ROBOTalk.h
  • __pad5__ : ROBOTalk.h
  • __pad6__ : ROBOTalk.h
  • __REQUIRED_RPCNDR_H_VERSION__ : ROBOTalk.h
  • __REQUIRED_RPCPROXY_H_VERSION__ : ROBOTalk_p.c
  • _ATL_APARTMENT_THREADED : StdAfx.h
  • _IRbtlkArmStubVtbl : ROBOTalk_p.c
  • _IRbtlkControllerStubVtbl : ROBOTalk_p.c
  • _IRbtlkEngineStubVtbl : ROBOTalk_p.c
  • _IRbtlkFileStubVtbl : ROBOTalk_p.c
  • _IRbtlkIOStubVtbl : ROBOTalk_p.c
  • _IRbtlkTaskStubVtbl : ROBOTalk_p.c
  • _IRbtlkVariableStubVtbl : ROBOTalk_p.c
  • _Module : StdAfx.h, ROBOTalk.cpp
  • _ROBOTalk_CHECK_IID : ROBOTalk_p.c
  • _ROBOTalk_IID_Lookup() : ROBOTalk_p.c
  • _ROBOTalk_InterfaceNamesList : ROBOTalk_p.c
  • _ROBOTalk_ProxyVtblList : ROBOTalk_p.c
  • _ROBOTalk_StubVtblList : ROBOTalk_p.c
  • _WIN32_WINNT : StdAfx.h

- a -

  • AFX_DEVICE_H__27399E95_B5DF_4C1C_BD53_842D96EDF6D8__INCLUDED_ : Device.h
  • AFX_ETHERUDP_H__7DA23D74_7712_46A2_81F7_94F952EEDDB3__INCLUDED_ : EtherUDP.h
  • AFX_SERIAL_H__DEDDC022_9FCD_43A7_A7DD_A620C7D69DCA__INCLUDED_ : Serial.h
  • AFX_STDAFX_H__CC0FF5A6_2B7E_440F_90F4_45B40D643078__INCLUDED_ : StdAfx.h

- b -

  • BSTR_UserFree() : ROBOTalk.h
  • BSTR_UserMarshal() : ROBOTalk.h
  • BSTR_UserSize() : ROBOTalk.h
  • BSTR_UserUnmarshal() : ROBOTalk.h

- c -

  • Cancel() : ROBOTalk.h
  • CINTERFACE_PROXY_VTABLE() : ROBOTalk_p.c
  • CLSID : ROBOTalk_i.c
  • CLSID_RbtlkArm : ROBOTalk_i.c, ROBOTalk.h
  • CLSID_RbtlkController : ROBOTalk_i.c, ROBOTalk.h
  • CLSID_RbtlkEngine : ROBOTalk_i.c, ROBOTalk.h
  • CLSID_RbtlkFile : ROBOTalk_i.c, ROBOTalk.h
  • CLSID_RbtlkIO : ROBOTalk_i.c, ROBOTalk.h
  • CLSID_RbtlkTask : ROBOTalk_i.c, ROBOTalk.h
  • CLSID_RbtlkVariable : ROBOTalk_i.c, ROBOTalk.h
  • cmdCancelCtrlLog() : ROBOTalk.h
  • cmdCancelDownload() : ROBOTalk.h
  • cmdCancelDownload0() : ROBOTalk.h
  • cmdCancelUpload() : ROBOTalk.h
  • cmdCancelUpload0() : ROBOTalk.h
  • cmdChangeConfig() : ROBOTalk.h
  • cmdChangeLabel() : ROBOTalk.h
  • cmdClearCtrlLog() : ROBOTalk.h
  • cmdClearError() : ROBOTalk.h
  • cmdContPrgStatus() : ROBOTalk.h
  • cmdCopyFile() : ROBOTalk.h
  • cmdDeleteFile() : ROBOTalk.h
  • cmdDeleteFile0() : ROBOTalk.h
  • cmdDin16() : ROBOTalk.h
  • cmdDin8() : ROBOTalk.h
  • cmdDisableArea() : ROBOTalk.h
  • cmdDoSignal() : ROBOTalk.h
  • cmdDout() : ROBOTalk.h
  • cmdDout16() : ROBOTalk.h
  • cmdDout8() : ROBOTalk.h
  • cmdDownload() : ROBOTalk.h
  • cmdDownload0() : ROBOTalk.h
  • cmdDummy() : ROBOTalk.h
  • cmdEnableArea() : ROBOTalk.h
  • cmdFileUploadEnd() : ROBOTalk.h
  • cmdGetArea() : ROBOTalk.h
  • cmdGetAreaEx() : ROBOTalk.h
  • cmdGetAttributes() : ROBOTalk.h
  • cmdGetConfig() : ROBOTalk.h
  • cmdGetControlLog() : ROBOTalk.h
  • cmdGetD() : ROBOTalk.h
  • cmdGetDataCreated() : ROBOTalk.h
  • cmdGetDateTime() : ROBOTalk.h
  • cmdGetDefIO() : ROBOTalk.h
  • cmdGetErrorCode() : ROBOTalk.h
  • cmdGetErrorLog() : ROBOTalk.h
  • cmdGetF() : ROBOTalk.h
  • cmdGetFileCnt() : ROBOTalk.h
  • cmdGetFileCnt0() : ROBOTalk.h
  • cmdGetFileName() : ROBOTalk.h
  • cmdGetFileName0() : ROBOTalk.h
  • cmdGetFreeMemory() : ROBOTalk.h
  • cmdGetJ() : ROBOTalk.h
  • cmdGetJobStatus() : ROBOTalk.h
  • cmdGetJointInfo() : ROBOTalk.h
  • cmdGetLastAccessed() : ROBOTalk.h
  • cmdGetLastModified() : ROBOTalk.h
  • cmdGetMode() : ROBOTalk.h
  • cmdGetOperationLog() : ROBOTalk.h
  • cmdGetP() : ROBOTalk.h
  • cmdGetParamCtrlLog() : ROBOTalk.h
  • cmdGetPrgList() : ROBOTalk.h
  • cmdGetProgramIC() : ROBOTalk.h
  • cmdGetProgramIndex() : ROBOTalk.h
  • cmdGetRobotType() : ROBOTalk.h
  • cmdGetS() : ROBOTalk.h
  • cmdGetSize() : ROBOTalk.h
  • cmdGetStatus() : ROBOTalk.h
  • cmdGetT() : ROBOTalk.h
  • cmdGetTabLen() : ROBOTalk.h
  • cmdGetTaskStatus() : ROBOTalk.h
  • cmdGetTool() : ROBOTalk.h
  • cmdGetToolIndex() : ROBOTalk.h
  • cmdGetTransMode() : ROBOTalk.h
  • cmdGetV() : ROBOTalk.h
  • cmdGetWork() : ROBOTalk.h
  • cmdGetWorkIndex() : ROBOTalk.h
  • cmdJHere() : ROBOTalk.h
  • cmdKillProg() : ROBOTalk.h
  • cmdLetArea() : ROBOTalk.h
  • cmdLetAreaEx() : ROBOTalk.h
  • cmdLetConfig() : ROBOTalk.h
  • cmdLetD() : ROBOTalk.h
  • cmdLetDateTime() : ROBOTalk.h
  • cmdLetDefIO() : ROBOTalk.h
  • cmdLetF() : ROBOTalk.h
  • cmdLetI() : ROBOTalk.h
  • cmdLetJ() : ROBOTalk.h
  • cmdLetJobStatus() : ROBOTalk.h
  • cmdLetP() : ROBOTalk.h
  • cmdLetS() : ROBOTalk.h
  • cmdLetStartLine() : ROBOTalk.h
  • cmdLetT() : ROBOTalk.h
  • cmdLetTool() : ROBOTalk.h
  • cmdLetV() : ROBOTalk.h
  • cmdLetWork() : ROBOTalk.h
  • cmdLoadNic() : ROBOTalk.h
  • cmdMoveFile() : ROBOTalk.h
  • cmdNoticeRomVersion() : ROBOTalk.h
  • cmdRequestDownload() : ROBOTalk.h
  • cmdRequestDownload0() : ROBOTalk.h
  • cmdRequestFileSave() : ROBOTalk.h
  • cmdRequestRomUpdate() : ROBOTalk.h
  • cmdRequestUpload() : ROBOTalk.h
  • cmdRequestUpload0() : ROBOTalk.h
  • cmdSetMode() : ROBOTalk.h
  • cmdSetOption() : ROBOTalk.h
  • cmdSrvJointCancel() : ROBOTalk.h
  • cmdSrvJointData() : ROBOTalk.h
  • cmdSrvJointParam() : ROBOTalk.h
  • cmdStartCtrlLog() : ROBOTalk.h
  • cmdStartPrg() : ROBOTalk.h
  • cmdStepBackward() : ROBOTalk.h
  • cmdStepForward() : ROBOTalk.h
  • cmdStopCtrlLog() : ROBOTalk.h
  • cmdStopPrg() : ROBOTalk.h
  • cmdSwitchCtrlLog() : ROBOTalk.h
  • cmdThere() : ROBOTalk.h
  • cmdUpload() : ROBOTalk.h
  • cmdUpload0() : ROBOTalk.h

- d -

  • DECLSPEC_UUID() : ROBOTalk.h
  • DEV_RETRY : Device.h
  • DEV_TIME_OUT : Device.h
  • DisconnectServer() : ROBOTalk.h
  • DllCanUnloadNow() : ROBOTalk.cpp
  • DllGetClassObject() : ROBOTalk.cpp
  • DllMain() : ROBOTalk.cpp
  • DllRegisterServer() : ROBOTalk.cpp
  • DllUnregisterServer() : ROBOTalk.cpp

- e -

  • E_ABNORMAL_R_PACKET : RbtlkHeader.h
  • E_ABNORMAL_S_PACKET : StdAfx.h
  • E_REJECTED : RbtlkHeader.h
  • E_SEND_NAK : RbtlkHeader.h
  • E_TIMEOUT : Device.h
  • ETHER_BASE_TIMEOUT : EtherUDP.h

- g -

  • g_CharTable : Device.h
  • g_mapID : StdAfx.h, ROBOTalk.cpp
  • get_LastError() : ROBOTalk.h
  • get_NakRetry() : ROBOTalk.h
  • get_RbtlkArm() : ROBOTalk.h
  • get_RbtlkController() : ROBOTalk.h
  • get_RbtlkFile() : ROBOTalk.h
  • get_RbtlkIO() : ROBOTalk.h
  • get_RbtlkTask() : ROBOTalk.h
  • get_RbtlkVariable() : ROBOTalk.h
  • get_TimeOut() : ROBOTalk.h
  • get_TimeOutRetry() : ROBOTalk.h
  • get_Version() : ROBOTalk.h
  • GetVarInfo() : ROBOTalk.h

- i -

  • IDR_RBTLKENGINE : resource.h
  • IDS_PROJNAME : resource.h
  • IID : ROBOTalk_i.c
  • IID_IRbtlkArm : ROBOTalk_i.c, ROBOTalk.h
  • IID_IRbtlkController : ROBOTalk_i.c, ROBOTalk.h
  • IID_IRbtlkEngine : ROBOTalk_i.c, ROBOTalk.h
  • IID_IRbtlkFile : ROBOTalk_i.c, ROBOTalk.h
  • IID_IRbtlkIO : ROBOTalk_i.c, ROBOTalk.h
  • IID_IRbtlkTask : ROBOTalk_i.c, ROBOTalk.h
  • IID_IRbtlkVariable : ROBOTalk_i.c, ROBOTalk.h
  • IRbtlkArm : ROBOTalk.h
  • IRbtlkArm_cmdDisableArea_Proxy() : ROBOTalk.h
  • IRbtlkArm_cmdDisableArea_Stub() : ROBOTalk.h
  • IRbtlkArm_cmdEnableArea_Proxy() : ROBOTalk.h
  • IRbtlkArm_cmdEnableArea_Stub() : ROBOTalk.h
  • IRbtlkArm_cmdGetArea_Proxy() : ROBOTalk.h
  • IRbtlkArm_cmdGetArea_Stub() : ROBOTalk.h
  • IRbtlkArm_cmdGetAreaEx_Proxy() : ROBOTalk.h
  • IRbtlkArm_cmdGetAreaEx_Stub() : ROBOTalk.h
  • IRbtlkArm_cmdGetTool_Proxy() : ROBOTalk.h
  • IRbtlkArm_cmdGetTool_Stub() : ROBOTalk.h
  • IRbtlkArm_cmdGetToolIndex_Proxy() : ROBOTalk.h
  • IRbtlkArm_cmdGetToolIndex_Stub() : ROBOTalk.h
  • IRbtlkArm_cmdGetWork_Proxy() : ROBOTalk.h
  • IRbtlkArm_cmdGetWork_Stub() : ROBOTalk.h
  • IRbtlkArm_cmdGetWorkIndex_Proxy() : ROBOTalk.h
  • IRbtlkArm_cmdGetWorkIndex_Stub() : ROBOTalk.h
  • IRbtlkArm_cmdHere_Proxy() : ROBOTalk.h
  • IRbtlkArm_cmdHere_Stub() : ROBOTalk.h
  • IRbtlkArm_cmdJHere_Proxy() : ROBOTalk.h
  • IRbtlkArm_cmdJHere_Stub() : ROBOTalk.h
  • IRbtlkArm_cmdLetArea_Proxy() : ROBOTalk.h
  • IRbtlkArm_cmdLetArea_Stub() : ROBOTalk.h
  • IRbtlkArm_cmdLetAreaEx_Proxy() : ROBOTalk.h
  • IRbtlkArm_cmdLetAreaEx_Stub() : ROBOTalk.h
  • IRbtlkArm_cmdLetTool_Proxy() : ROBOTalk.h
  • IRbtlkArm_cmdLetTool_Stub() : ROBOTalk.h
  • IRbtlkArm_cmdLetWork_Proxy() : ROBOTalk.h
  • IRbtlkArm_cmdLetWork_Stub() : ROBOTalk.h
  • IRbtlkArm_cmdThere_Proxy() : ROBOTalk.h
  • IRbtlkArm_cmdThere_Stub() : ROBOTalk.h
  • IRbtlkArm_FormatStringOffsetTable : ROBOTalk_p.c
  • IRbtlkArm_ProxyInfo : ROBOTalk_p.c
  • IRbtlkArm_ServerInfo : ROBOTalk_p.c
  • IRbtlkController : ROBOTalk.h
  • IRbtlkController_cmdCancelCtrlLog_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdCancelCtrlLog_Stub() : ROBOTalk.h
  • IRbtlkController_cmdChangeConfig_Proxy() : ROBOTalk_p.c, ROBOTalk.h
  • IRbtlkController_cmdChangeConfig_Stub() : ROBOTalk.h
  • IRbtlkController_cmdClearCtrlLog_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdClearCtrlLog_Stub() : ROBOTalk.h
  • IRbtlkController_cmdClearError_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdClearError_Stub() : ROBOTalk.h
  • IRbtlkController_cmdDoSignal_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdDoSignal_Stub() : ROBOTalk.h
  • IRbtlkController_cmdGetConfig_Proxy() : ROBOTalk_p.c, ROBOTalk.h
  • IRbtlkController_cmdGetConfig_Stub() : ROBOTalk.h
  • IRbtlkController_cmdGetControlLog_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdGetControlLog_Stub() : ROBOTalk.h
  • IRbtlkController_cmdGetDateTime_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdGetDateTime_Stub() : ROBOTalk.h
  • IRbtlkController_cmdGetErrorCode_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdGetErrorCode_Stub() : ROBOTalk.h
  • IRbtlkController_cmdGetErrorLog_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdGetErrorLog_Stub() : ROBOTalk.h
  • IRbtlkController_cmdGetFreeMemory_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdGetFreeMemory_Stub() : ROBOTalk.h
  • IRbtlkController_cmdGetJobStatus_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdGetJobStatus_Stub() : ROBOTalk.h
  • IRbtlkController_cmdGetJointInfo_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdGetJointInfo_Stub() : ROBOTalk.h
  • IRbtlkController_cmdGetMode_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdGetMode_Stub() : ROBOTalk.h
  • IRbtlkController_cmdGetOperationLog_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdGetOperationLog_Stub() : ROBOTalk.h
  • IRbtlkController_cmdGetParamCtrlLog_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdGetParamCtrlLog_Stub() : ROBOTalk.h
  • IRbtlkController_cmdGetRobotType_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdGetRobotType_Stub() : ROBOTalk.h
  • IRbtlkController_cmdGetStatus_Proxy() : ROBOTalk_p.c, ROBOTalk.h
  • IRbtlkController_cmdGetStatus_Stub() : ROBOTalk.h
  • IRbtlkController_cmdGetTransMode_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdGetTransMode_Stub() : ROBOTalk.h
  • IRbtlkController_cmdGetVersions_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdGetVersions_Stub() : ROBOTalk.h
  • IRbtlkController_cmdLetConfig_Proxy() : ROBOTalk_p.c, ROBOTalk.h
  • IRbtlkController_cmdLetConfig_Stub() : ROBOTalk.h
  • IRbtlkController_cmdLetDateTime_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdLetDateTime_Stub() : ROBOTalk.h
  • IRbtlkController_cmdLetJobStatus_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdLetJobStatus_Stub() : ROBOTalk.h
  • IRbtlkController_cmdNoticeRomVersion_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdNoticeRomVersion_Stub() : ROBOTalk.h
  • IRbtlkController_cmdRequestFileSave_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdRequestFileSave_Stub() : ROBOTalk.h
  • IRbtlkController_cmdRequestRomUpdate_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdRequestRomUpdate_Stub() : ROBOTalk.h
  • IRbtlkController_cmdSetMode_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdSetMode_Stub() : ROBOTalk.h
  • IRbtlkController_cmdSetOption_Proxy() : ROBOTalk_p.c, ROBOTalk.h
  • IRbtlkController_cmdSetOption_Stub() : ROBOTalk.h
  • IRbtlkController_cmdSrvJointCancel_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdSrvJointCancel_Stub() : ROBOTalk.h
  • IRbtlkController_cmdSrvJointData_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdSrvJointData_Stub() : ROBOTalk.h
  • IRbtlkController_cmdSrvJointParam_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdSrvJointParam_Stub() : ROBOTalk.h
  • IRbtlkController_cmdStartCtrlLog_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdStartCtrlLog_Stub() : ROBOTalk.h
  • IRbtlkController_cmdStopCtrlLog_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdStopCtrlLog_Stub() : ROBOTalk.h
  • IRbtlkController_cmdSwitchCtrlLog_Proxy() : ROBOTalk.h
  • IRbtlkController_cmdSwitchCtrlLog_Stub() : ROBOTalk.h
  • IRbtlkController_FormatStringOffsetTable : ROBOTalk_p.c
  • IRbtlkController_ProxyInfo : ROBOTalk_p.c
  • IRbtlkController_ServerInfo : ROBOTalk_p.c
  • IRbtlkEngine : ROBOTalk.h
  • IRbtlkEngine_Cancel_Proxy() : ROBOTalk.h
  • IRbtlkEngine_Cancel_Stub() : ROBOTalk.h
  • IRbtlkEngine_ConnectServer_Proxy() : ROBOTalk.h
  • IRbtlkEngine_ConnectServer_Stub() : ROBOTalk.h
  • IRbtlkEngine_DisconnectServer_Proxy() : ROBOTalk.h
  • IRbtlkEngine_DisconnectServer_Stub() : ROBOTalk.h
  • IRbtlkEngine_FormatStringOffsetTable : ROBOTalk_p.c
  • IRbtlkEngine_get_LastError_Proxy() : ROBOTalk.h
  • IRbtlkEngine_get_LastError_Stub() : ROBOTalk.h
  • IRbtlkEngine_get_NakRetry_Proxy() : ROBOTalk.h
  • IRbtlkEngine_get_NakRetry_Stub() : ROBOTalk.h
  • IRbtlkEngine_get_RbtlkArm_Proxy() : ROBOTalk.h
  • IRbtlkEngine_get_RbtlkArm_Stub() : ROBOTalk.h
  • IRbtlkEngine_get_RbtlkController_Proxy() : ROBOTalk.h
  • IRbtlkEngine_get_RbtlkController_Stub() : ROBOTalk.h
  • IRbtlkEngine_get_RbtlkFile_Proxy() : ROBOTalk.h
  • IRbtlkEngine_get_RbtlkFile_Stub() : ROBOTalk.h
  • IRbtlkEngine_get_RbtlkIO_Proxy() : ROBOTalk.h
  • IRbtlkEngine_get_RbtlkIO_Stub() : ROBOTalk.h
  • IRbtlkEngine_get_RbtlkTask_Proxy() : ROBOTalk.h
  • IRbtlkEngine_get_RbtlkTask_Stub() : ROBOTalk.h
  • IRbtlkEngine_get_RbtlkVariable_Proxy() : ROBOTalk.h
  • IRbtlkEngine_get_RbtlkVariable_Stub() : ROBOTalk.h
  • IRbtlkEngine_get_TimeOut_Proxy() : ROBOTalk.h
  • IRbtlkEngine_get_TimeOut_Stub() : ROBOTalk.h
  • IRbtlkEngine_get_TimeOutRetry_Proxy() : ROBOTalk.h
  • IRbtlkEngine_get_TimeOutRetry_Stub() : ROBOTalk.h
  • IRbtlkEngine_get_Version_Proxy() : ROBOTalk.h
  • IRbtlkEngine_get_Version_Stub() : ROBOTalk.h
  • IRbtlkEngine_GetVarInfo_Proxy() : ROBOTalk.h
  • IRbtlkEngine_GetVarInfo_Stub() : ROBOTalk.h
  • IRbtlkEngine_ProxyInfo : ROBOTalk_p.c
  • IRbtlkEngine_put_NakRetry_Proxy() : ROBOTalk.h
  • IRbtlkEngine_put_NakRetry_Stub() : ROBOTalk.h
  • IRbtlkEngine_put_TimeOut_Proxy() : ROBOTalk.h
  • IRbtlkEngine_put_TimeOut_Stub() : ROBOTalk.h
  • IRbtlkEngine_put_TimeOutRetry_Proxy() : ROBOTalk.h
  • IRbtlkEngine_put_TimeOutRetry_Stub() : ROBOTalk.h
  • IRbtlkEngine_ServerInfo : ROBOTalk_p.c
  • IRbtlkFile : ROBOTalk.h
  • IRbtlkFile_cmdCancelDownload0_Proxy() : ROBOTalk_p.c, ROBOTalk.h
  • IRbtlkFile_cmdCancelDownload0_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdCancelDownload_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdCancelDownload_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdCancelUpload0_Proxy() : ROBOTalk_p.c, ROBOTalk.h
  • IRbtlkFile_cmdCancelUpload0_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdCancelUpload_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdCancelUpload_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdCopyFile_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdCopyFile_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdDeleteFile0_Proxy() : ROBOTalk_p.c, ROBOTalk.h
  • IRbtlkFile_cmdDeleteFile0_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdDeleteFile_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdDeleteFile_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdDownload0_Proxy() : ROBOTalk_p.c, ROBOTalk.h
  • IRbtlkFile_cmdDownload0_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdDownload_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdDownload_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdFileUploadEnd_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdFileUploadEnd_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdFileUploadStart_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdFileUploadStart_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdGetAttributes_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdGetAttributes_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdGetDataCreated_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdGetDataCreated_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdGetFileCnt0_Proxy() : ROBOTalk_p.c, ROBOTalk.h
  • IRbtlkFile_cmdGetFileCnt0_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdGetFileCnt_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdGetFileCnt_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdGetFileName0_Proxy() : ROBOTalk_p.c, ROBOTalk.h
  • IRbtlkFile_cmdGetFileName0_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdGetFileName_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdGetFileName_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdGetLastAccessed_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdGetLastAccessed_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdGetLastModified_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdGetLastModified_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdGetProgramIC_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdGetProgramIC_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdGetProgramIndex_Proxy() : ROBOTalk_p.c, ROBOTalk.h
  • IRbtlkFile_cmdGetProgramIndex_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdGetSize_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdGetSize_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdKillProg_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdKillProg_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdLetStartLine_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdLetStartLine_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdLoadNic_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdLoadNic_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdMoveFile_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdMoveFile_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdRequestDownload0_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdRequestDownload0_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdRequestDownload_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdRequestDownload_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdRequestUpload0_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdRequestUpload0_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdRequestUpload_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdRequestUpload_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdStartPrg_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdStartPrg_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdStepBackward_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdStepBackward_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdStepForward_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdStepForward_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdStopPrg_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdStopPrg_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdUpload0_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdUpload0_Stub() : ROBOTalk.h
  • IRbtlkFile_cmdUpload_Proxy() : ROBOTalk.h
  • IRbtlkFile_cmdUpload_Stub() : ROBOTalk.h
  • IRbtlkFile_FormatStringOffsetTable : ROBOTalk_p.c
  • IRbtlkFile_ProxyInfo : ROBOTalk_p.c
  • IRbtlkFile_ServerInfo : ROBOTalk_p.c
  • IRbtlkIO : ROBOTalk.h
  • IRbtlkIO_cmdChangeLabel_Proxy() : ROBOTalk.h
  • IRbtlkIO_cmdChangeLabel_Stub() : ROBOTalk.h
  • IRbtlkIO_cmdDin16_Proxy() : ROBOTalk.h
  • IRbtlkIO_cmdDin16_Stub() : ROBOTalk.h
  • IRbtlkIO_cmdDin8_Proxy() : ROBOTalk.h
  • IRbtlkIO_cmdDin8_Stub() : ROBOTalk.h
  • IRbtlkIO_cmdDin_Proxy() : ROBOTalk.h
  • IRbtlkIO_cmdDin_Stub() : ROBOTalk.h
  • IRbtlkIO_cmdDout16_Proxy() : ROBOTalk.h
  • IRbtlkIO_cmdDout16_Stub() : ROBOTalk.h
  • IRbtlkIO_cmdDout8_Proxy() : ROBOTalk.h
  • IRbtlkIO_cmdDout8_Stub() : ROBOTalk.h
  • IRbtlkIO_cmdDout_Proxy() : ROBOTalk.h
  • IRbtlkIO_cmdDout_Stub() : ROBOTalk.h
  • IRbtlkIO_cmdDummy_Proxy() : ROBOTalk.h
  • IRbtlkIO_cmdDummy_Stub() : ROBOTalk.h
  • IRbtlkIO_FormatStringOffsetTable : ROBOTalk_p.c
  • IRbtlkIO_ProxyInfo : ROBOTalk_p.c
  • IRbtlkIO_ServerInfo : ROBOTalk_p.c
  • IRbtlkTask : ROBOTalk.h
  • IRbtlkTask_cmdContPrgStatus_Proxy() : ROBOTalk.h
  • IRbtlkTask_cmdContPrgStatus_Stub() : ROBOTalk.h
  • IRbtlkTask_cmdGetPrgList_Proxy() : ROBOTalk.h
  • IRbtlkTask_cmdGetPrgList_Stub() : ROBOTalk.h
  • IRbtlkTask_cmdGetPrgListLen_Proxy() : ROBOTalk.h
  • IRbtlkTask_cmdGetPrgListLen_Stub() : ROBOTalk.h
  • IRbtlkTask_cmdGetTaskStatus_Proxy() : ROBOTalk.h
  • IRbtlkTask_cmdGetTaskStatus_Stub() : ROBOTalk.h
  • IRbtlkTask_FormatStringOffsetTable : ROBOTalk_p.c
  • IRbtlkTask_ProxyInfo : ROBOTalk_p.c
  • IRbtlkTask_ServerInfo : ROBOTalk_p.c
  • IRbtlkVariable : ROBOTalk.h
  • IRbtlkVariable_cmdGetD_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdGetD_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdGetDefIO_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdGetDefIO_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdGetF_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdGetF_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdGetI_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdGetI_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdGetJ_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdGetJ_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdGetP_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdGetP_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdGetS_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdGetS_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdGetT_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdGetT_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdGetTabLen_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdGetTabLen_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdGetV_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdGetV_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdLetD_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdLetD_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdLetDefIO_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdLetDefIO_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdLetF_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdLetF_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdLetI_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdLetI_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdLetJ_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdLetJ_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdLetP_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdLetP_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdLetS_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdLetS_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdLetT_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdLetT_Stub() : ROBOTalk.h
  • IRbtlkVariable_cmdLetV_Proxy() : ROBOTalk.h
  • IRbtlkVariable_cmdLetV_Stub() : ROBOTalk.h
  • IRbtlkVariable_FormatStringOffsetTable : ROBOTalk_p.c
  • IRbtlkVariable_ProxyInfo : ROBOTalk_p.c
  • IRbtlkVariable_ServerInfo : ROBOTalk_p.c

- l -

  • LIBID_ROBOTALKLib : ROBOTalk_i.c, ROBOTalk.h
  • LOCAL_BUFFER_MAX : Device.h

- m -

  • MIDL_PROC_FORMAT_STRING : ROBOTalk_p.c
  • MIDL_TYPE_FORMAT_STRING : ROBOTalk_p.c
  • MIDL_user_allocate() : ROBOTalk.h
  • MIDL_user_free() : ROBOTalk.h

- n -

  • NIC_GV_DBL : ROBOTalk.h
  • NIC_GV_INT : ROBOTalk.h
  • NIC_GV_IO : ROBOTalk.h
  • NIC_GV_JNT : ROBOTalk.h
  • NIC_GV_POS : ROBOTalk.h
  • NIC_GV_SNG : ROBOTalk.h
  • NIC_GV_STR : ROBOTalk.h
  • NIC_GV_TRN : ROBOTalk.h
  • NIC_GV_VEC : ROBOTalk.h

- o -

  • Object_StubDesc : ROBOTalk_p.c

- p -

  • PROC_FORMAT_STRING_SIZE : ROBOTalk_p.c
  • put_NakRetry() : ROBOTalk.h
  • put_TimeOut() : ROBOTalk.h
  • put_TimeOutRetry() : ROBOTalk.h
  • pVal : ROBOTalk.h

- r -

  • RBTLK_DEFAULT_PATH : RbtlkFile.h
  • RbtlkArm : ROBOTalk.h
  • RbtlkController : ROBOTalk.h
  • RbtlkEngine : ROBOTalk.h
  • RbtlkFile : ROBOTalk.h
  • RbtlkIO : ROBOTalk.h
  • RbtlkTask : ROBOTalk.h
  • RbtlkVariable : ROBOTalk.h
  • REFERENCE_PROXY_FILE() : dlldata.c
  • ROBOTalk_ProxyFileInfo : ROBOTalk_p.c
  • RTK_ARM_STATUS : ROBOTalk.h
  • RTK_AST_CALEND : ROBOTalk.h
  • RTK_AST_MODE : ROBOTalk.h
  • RTK_AST_SERVO : ROBOTalk.h
  • RTK_CMD_ACK : RbtlkHeader.h
  • RTK_CMD_AND : RbtlkHeader.h
  • RTK_CMD_ARMCNF : RbtlkHeader.h
  • RTK_CMD_CANCELCTRLLOG : RbtlkHeader.h
  • RTK_CMD_CANCELDOWNLOAD : RbtlkHeader.h
  • RTK_CMD_CANCELDOWNLOAD0 : RbtlkHeader.h
  • RTK_CMD_CANCELUPLOAD : RbtlkHeader.h
  • RTK_CMD_CANCELUPLOAD0 : RbtlkHeader.h
  • RTK_CMD_CHANGECONFIG : RbtlkHeader.h
  • RTK_CMD_CHANGELABEL : RbtlkHeader.h
  • RTK_CMD_CLEARCTRLLOG : RbtlkHeader.h
  • RTK_CMD_CLEARERROR : RbtlkHeader.h
  • RTK_CMD_COMCNF : RbtlkHeader.h
  • RTK_CMD_COPYFILE : RbtlkHeader.h
  • RTK_CMD_DELFILE : RbtlkHeader.h
  • RTK_CMD_DELFILE0 : RbtlkHeader.h
  • RTK_CMD_DIOCNF : RbtlkHeader.h
  • RTK_CMD_DISABLEAREA : RbtlkHeader.h
  • RTK_CMD_DOSIGNAL : RbtlkHeader.h
  • RTK_CMD_DOWNLOAD : RbtlkHeader.h
  • RTK_CMD_DOWNLOAD0 : RbtlkHeader.h
  • RTK_CMD_ENABLEAREA : RbtlkHeader.h
  • RTK_CMD_FILEUPLOADEND : RbtlkHeader.h
  • RTK_CMD_FILEUPLOADSTART : RbtlkHeader.h
  • RTK_CMD_FLUSHCTRLLOG : RbtlkHeader.h
  • RTK_CMD_GETAREA : RbtlkHeader.h
  • RTK_CMD_GETATTRB : RbtlkHeader.h
  • RTK_CMD_GETCONFIG : RbtlkHeader.h
  • RTK_CMD_GETCTRLLOG : RbtlkHeader.h
  • RTK_CMD_GETCURJNT : RbtlkHeader.h
  • RTK_CMD_GETCURPOS : RbtlkHeader.h
  • RTK_CMD_GETCURTRN : RbtlkHeader.h
  • RTK_CMD_GETDATACREATED : RbtlkHeader.h
  • RTK_CMD_GETDATETIME : RbtlkHeader.h
  • RTK_CMD_GETDBLVAR : RbtlkHeader.h
  • RTK_CMD_GETDEFIOVAR : RbtlkHeader.h
  • RTK_CMD_GETERRLOG : RbtlkHeader.h
  • RTK_CMD_GETERROR : RbtlkHeader.h
  • RTK_CMD_GETFILECNT : RbtlkHeader.h
  • RTK_CMD_GETFILECNT0 : RbtlkHeader.h
  • RTK_CMD_GETFILENAME : RbtlkHeader.h
  • RTK_CMD_GETFILENAME0 : RbtlkHeader.h
  • RTK_CMD_GETFILESIZE : RbtlkHeader.h
  • RTK_CMD_GETFREEMEM : RbtlkHeader.h
  • RTK_CMD_GETINTVAR : RbtlkHeader.h
  • RTK_CMD_GETIO : RbtlkHeader.h
  • RTK_CMD_GETIO16 : RbtlkHeader.h
  • RTK_CMD_GETIO8 : RbtlkHeader.h
  • RTK_CMD_GETJNTVAR : RbtlkHeader.h
  • RTK_CMD_GETJOBSTATUS : RbtlkHeader.h
  • RTK_CMD_GETJOINTINFO : RbtlkHeader.h
  • RTK_CMD_GETLASTACCESSED : RbtlkHeader.h
  • RTK_CMD_GETLASTMODIFIED : RbtlkHeader.h
  • RTK_CMD_GETMODE : RbtlkHeader.h
  • RTK_CMD_GETOPELOG : RbtlkHeader.h
  • RTK_CMD_GETPARAMCTRLLOG : RbtlkHeader.h
  • RTK_CMD_GETPOSVAR : RbtlkHeader.h
  • RTK_CMD_GETPRGLIST : RbtlkHeader.h
  • RTK_CMD_GETPRGLISTLEN : RbtlkHeader.h
  • RTK_CMD_GETPRGSTATUS : RbtlkHeader.h
  • RTK_CMD_GETPROGIC : RbtlkHeader.h
  • RTK_CMD_GETPROGINDEX : RbtlkHeader.h
  • RTK_CMD_GETROBOTTYPE : RbtlkHeader.h
  • RTK_CMD_GETSNGVAR : RbtlkHeader.h
  • RTK_CMD_GETSTATUS : RbtlkHeader.h
  • RTK_CMD_GETSTRVAR : RbtlkHeader.h
  • RTK_CMD_GETTABLEN : RbtlkHeader.h
  • RTK_CMD_GETTASKSTATUS : RbtlkHeader.h
  • RTK_CMD_GETTOOL : RbtlkHeader.h
  • RTK_CMD_GETTOOLINDEX : RbtlkHeader.h
  • RTK_CMD_GETTRANSMODE : RbtlkHeader.h
  • RTK_CMD_GETTRNVAR : RbtlkHeader.h
  • RTK_CMD_GETVALUEBYNAME : RbtlkHeader.h
  • RTK_CMD_GETVECVAR : RbtlkHeader.h
  • RTK_CMD_GETVERSIONS : RbtlkHeader.h
  • RTK_CMD_GETWORK : RbtlkHeader.h
  • RTK_CMD_GETWORKINDEX : RbtlkHeader.h
  • RTK_CMD_ITPCNF : RbtlkHeader.h
  • RTK_CMD_KILLPROG : RbtlkHeader.h
  • RTK_CMD_LETAREA : RbtlkHeader.h
  • RTK_CMD_LETCONFIG : RbtlkHeader.h
  • RTK_CMD_LETDATETIME : RbtlkHeader.h
  • RTK_CMD_LETDBLVAR : RbtlkHeader.h
  • RTK_CMD_LETDEFIOVAR : RbtlkHeader.h
  • RTK_CMD_LETINTVAR : RbtlkHeader.h
  • RTK_CMD_LETJNTVAR : RbtlkHeader.h
  • RTK_CMD_LETJOBSTATUS : RbtlkHeader.h
  • RTK_CMD_LETPOSVAR : RbtlkHeader.h
  • RTK_CMD_LETSNGVAR : RbtlkHeader.h
  • RTK_CMD_LETSTATUS : RbtlkHeader.h
  • RTK_CMD_LETSTRVAR : RbtlkHeader.h
  • RTK_CMD_LETTOOL : RbtlkHeader.h
  • RTK_CMD_LETTRNVAR : RbtlkHeader.h
  • RTK_CMD_LETVECVAR : RbtlkHeader.h
  • RTK_CMD_LETWORK : RbtlkHeader.h
  • RTK_CMD_LOADNIC : RbtlkHeader.h
  • RTK_CMD_MOVEFILE : RbtlkHeader.h
  • RTK_CMD_NAK : RbtlkHeader.h
  • RTK_CMD_NOTICEROMVERSION : RbtlkHeader.h
  • RTK_CMD_OR : RbtlkHeader.h
  • RTK_CMD_PACCNF : RbtlkHeader.h
  • RTK_CMD_PTR : RbtlkHeader.h
  • RTK_CMD_PUTSTARTLINE : RbtlkHeader.h
  • RTK_CMD_REJ : RbtlkHeader.h
  • RTK_CMD_REQUESTDOWNLOAD : RbtlkHeader.h
  • RTK_CMD_REQUESTDOWNLOAD0 : RbtlkHeader.h
  • RTK_CMD_REQUESTFILESAVE : RbtlkHeader.h
  • RTK_CMD_REQUESTROMUPDATE : RbtlkHeader.h
  • RTK_CMD_REQUESTUPLOAD : RbtlkHeader.h
  • RTK_CMD_REQUESTUPLOAD0 : RbtlkHeader.h
  • RTK_CMD_SETDUMMY : RbtlkHeader.h
  • RTK_CMD_SETIO : RbtlkHeader.h
  • RTK_CMD_SETIO16 : RbtlkHeader.h
  • RTK_CMD_SETIO8 : RbtlkHeader.h
  • RTK_CMD_SETMODE : RbtlkHeader.h
  • RTK_CMD_SETOPTION : RbtlkHeader.h
  • RTK_CMD_SPDCNF : RbtlkHeader.h
  • RTK_CMD_SRVCNF : RbtlkHeader.h
  • RTK_CMD_SRVJOINTCANCEL : RbtlkHeader.h
  • RTK_CMD_SRVJOINTDATA : RbtlkHeader.h
  • RTK_CMD_SRVJOINTPARAM : RbtlkHeader.h
  • RTK_CMD_STARTCTRLLOG : RbtlkHeader.h
  • RTK_CMD_STARTPRG : RbtlkHeader.h
  • RTK_CMD_STEPBACKWARD : RbtlkHeader.h
  • RTK_CMD_STEPFORWARD : RbtlkHeader.h
  • RTK_CMD_STOPCTRLLOG : RbtlkHeader.h
  • RTK_CMD_STOPPRG : RbtlkHeader.h
  • RTK_CMD_SWITCHCTRLLOG : RbtlkHeader.h
  • RTK_CMD_SYSCNF : RbtlkHeader.h
  • RTK_CMD_UPLOAD : RbtlkHeader.h
  • RTK_CMD_UPLOAD0 : RbtlkHeader.h
  • RTK_CMD_VISCNF : RbtlkHeader.h
  • RTK_COMMAND : RbtlkHeader.h
  • RTK_CST_EMGSTOP : ROBOTalk.h
  • RTK_CST_ERROR : ROBOTalk.h
  • RTK_CST_RUNNING : ROBOTalk.h
  • RTK_CTRL_SIZE : RbtlkHeader.h
  • RTK_CTRL_STATUS : ROBOTalk.h
  • RTK_DAT_PTR : RbtlkHeader.h
  • RTK_DATA_MAXLEN : RbtlkHeader.h
  • RTK_DEV_COM : RbtlkHeader.h
  • RTK_DEV_ETH : RbtlkHeader.h
  • RTK_DEV_NON : RbtlkHeader.h
  • RTK_DEV_TEL : RbtlkHeader.h
  • RTK_DEVICE : RbtlkHeader.h
  • RTK_ENQ : RbtlkHeader.h
  • RTK_ENQ_PTR : RbtlkHeader.h
  • RTK_HEAD_LEN : RbtlkHeader.h
  • RTK_ID1_PTR : RbtlkHeader.h
  • RTK_ID2_PTR : RbtlkHeader.h
  • RTK_INDEX_SIZE : RbtlkHeader.h
  • RTK_IP_RSTKSIZE : ROBOTalk.h
  • RTK_IP_TASKNUM : ROBOTalk.h
  • RTK_ITP_CONF : ROBOTalk.h
  • RTK_JNT_SIZE : RbtlkHeader.h
  • RTK_LEN_PTR : RbtlkHeader.h
  • RTK_PAC_CONF : ROBOTalk.h
  • RTK_PACKET : ROBOTalk.h
  • RTK_PACKET_LEN : RbtlkHeader.h
  • RTK_PACKET_MAXLEN : RbtlkHeader.h
  • RTK_PC_LANG_MODE : ROBOTalk.h
  • RTK_PC_ROBOTTYPE : ROBOTalk.h
  • RTK_POS_SIZE : RbtlkHeader.h
  • RTK_SUM_LEN : RbtlkHeader.h
  • RTK_TRN_SIZE : RbtlkHeader.h
  • RTK_VEC_SIZE : RbtlkHeader.h

- s -

  • SERIAL_BASE_TIMEOUT : Serial.h
  • SERIAL_PORT_MAX : Serial.h
  • sIndex : ROBOTalk.h
  • ST_MODE_ASCTOEIA : Device.h
  • ST_MODE_ASCTOISO : Device.h
  • ST_MODE_BINARY : Device.h
  • ST_MODE_TEXT : Device.h
  • ST_MODE_WBSTOWCS : Device.h
  • STRICT : StdAfx.h

- t -

  • TABLE_ASCTOEIA : Device.h
  • TABLE_ASCTOISO : Device.h
  • TABLE_EIATOASC : Device.h
  • TABLE_ISOTOASC : Device.h
  • TYPE_FORMAT_STRING_SIZE : ROBOTalk_p.c

- u -

  • USE_STUBLESS_PROXY : ROBOTalk_p.c
  • UserMarshalRoutines : ROBOTalk_p.c
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


Namespace Member Index

DENSO WAVE ROBOTalk Project 名前空間メンバ

i

これは名前空間の一覧です。それぞれの名前空間の解説へリンクしています。

- i -

  • importlib() : ROBOTALKLib
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


Graphical Class Hierarchy

DENSO WAVE ROBOTalk Project クラス階層図

クラス階層図を見る。

Generated on Wed Sep 29 10:57:46 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CDevice メンバ一覧

これは全メンバの一覧です。CDevice継承メンバも含んでいます。
CDevice() | CDevice |
Connect(CDevice **ppNewDevice=NULL) | CDevice | [virtual]
Disconnect(void) | CDevice | [virtual]
Flush(void) | CDevice | [virtual]
GetReceivedCount(void) | CDevice | [virtual]
GetRecivePacket(LPSTR lpszData, DWORD dwBufSize, DWORD *pdwReceivedLen, int nTermCount=1) | CDevice | [protected]
GetTimeOut(void) | CDevice | [virtual]
Initialize(PVOID pArgs[]) | CDevice | [virtual]
m_bConnected | CDevice | [protected]
m_dwHeaderLen | CDevice | [protected]
m_dwLocalBufferLen | CDevice | [protected]
m_dwMode | CDevice | [protected]
m_dwRetryCnt | CDevice | [protected]
m_dwTermLen | CDevice | [protected]
m_dwTotalTimeout | CDevice | [protected]
m_pcHeader | CDevice | [protected]
m_pcTerm | CDevice | [protected]
m_szLocalBuffer | CDevice | [protected]
Receive(LPBYTE lpszData, DWORD dwBufSize, DWORD *pdwReceivedLen, int nTermCount=1) | CDevice |
Send(LPBYTE lpszData, DWORD dwSendLen=0) | CDevice |
SendAndReceive(LPBYTE lpszSendData, LPBYTE lpszReceiveData, DWORD dwRecvSize, DWORD *pdwRecvLen, int nTermCount=1, DWORD dwRetryCnt=0) | CDevice | [virtual]
SetTimeOut(DWORD dwTimeout) | CDevice | [virtual]
~CDevice() | CDevice | [virtual]
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CEtherUDP メンバ一覧

これは全メンバの一覧です。CEtherUDP継承メンバも含んでいます。
CDevice() | CDevice |
CEtherUDP() | CEtherUDP |
Connect(CDevice **ppNewDevice=NULL) | CEtherUDP | [virtual]
Disconnect(void) | CEtherUDP | [virtual]
Flush(void) | CEtherUDP | [virtual]
GetReceivedCount() | CEtherUDP | [virtual]
GetRecivePacket(LPSTR lpszData, DWORD dwBufSize, DWORD *pdwReceivedLen, int nTermCount=1) | CDevice | [protected]
GetTimeOut(void) | CDevice | [virtual]
Initialize(PVOID pArgs[]) | CEtherUDP | [virtual]
m_bConnected | CDevice | [protected]
m_dwHeaderLen | CDevice | [protected]
m_dwLocalBufferLen | CDevice | [protected]
m_dwMode | CDevice | [protected]
m_dwRetryCnt | CDevice | [protected]
m_dwTermLen | CDevice | [protected]
m_dwTotalTimeout | CDevice | [protected]
m_pcHeader | CDevice | [protected]
m_pcTerm | CDevice | [protected]
m_szLocalBuffer | CDevice | [protected]
Receive(LPBYTE lpszData, DWORD dwBufSize, DWORD *pdwReceivedLen, int nTermCount=1) | CDevice |
Send(LPBYTE lpszData, DWORD dwSendLen=0) | CDevice |
SendAndReceive(LPBYTE lpszSendData, LPBYTE lpszReceiveData, DWORD dwRecvSize, DWORD *pdwRecvLen, int nTermCount=1, DWORD dwRetryCnt=0) | CDevice | [virtual]
SetTimeOut(DWORD dwTimeout) | CEtherUDP | [virtual]
~CDevice() | CDevice | [virtual]
~CEtherUDP() | CEtherUDP | [virtual]
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CRbtlkArm メンバ一覧

これは全メンバの一覧です。CRbtlkArm継承メンバも含んでいます。
cmdDisableArea(short sNo) | CRbtlkArm |
cmdEnableArea(short sNo) | CRbtlkArm |
cmdGetArea(short sNo, float *pf, short *psIO, short *psPos) | CRbtlkArm |
cmdGetAreaEx(short sNo, float *pf, short *psIO, short *psPos, short *psErr, short *psEnable) | CRbtlkArm |
cmdGetTool(short sNo, float *pf) | CRbtlkArm |
cmdGetToolIndex(short *pVal) | CRbtlkArm |
cmdGetWork(short sNo, float *pf) | CRbtlkArm |
cmdGetWorkIndex(short *pVal) | CRbtlkArm |
cmdHere(float *pVal) | CRbtlkArm |
cmdJHere(float *pVal) | CRbtlkArm |
cmdLetArea(short sNo, float *pf, short sIO, short sPos) | CRbtlkArm |
cmdLetAreaEx(short sNo, float *pf, short sIO, short sPos, short sErr, short sEnable) | CRbtlkArm |
cmdLetTool(short sNo, float *pf) | CRbtlkArm |
cmdLetWork(short sNo, float *pf) | CRbtlkArm |
cmdThere(float *pVal) | CRbtlkArm |
CRbtlkArm() | CRbtlkArm | [inline]
FinalConstruct() | CRbtlkArm |
FinalRelease() | CRbtlkArm |
Initialize(CRbtlkEngine *pIRbtlkEng) | CRbtlkArm |
InterfaceSupportsErrorInfo(REFIID riid) | CRbtlkArm |
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CRbtlkController メンバ一覧

これは全メンバの一覧です。CRbtlkController継承メンバも含んでいます。
cmdCancelCtrlLog() | CRbtlkController |
cmdChangeConfig(short sMode) | CRbtlkController |
cmdClearCtrlLog() | CRbtlkController |
cmdClearError(long lErrCode, short *pVal) | CRbtlkController |
cmdDoSignal(short sMode, short sAction) | CRbtlkController |
cmdGetConfig(short sMode, short sIndex, long *pVal) | CRbtlkController |
cmdGetControlLog(short sIndex, float pData[8][4], float *pReg, short *pProgNo, short *pLineNo) | CRbtlkController |
cmdGetDateTime(short *psDateTime) | CRbtlkController |
cmdGetErrorCode(long *pVal) | CRbtlkController |
cmdGetErrorLog(short sIndex, short *pCode, short *pLevel, CHAR *szDate, CHAR *szTime, CHAR *szModule, CHAR *szMsg) | CRbtlkController |
cmdGetFreeMemory(long *pVal) | CRbtlkController |
cmdGetJobStatus(long JobID, short *pStatus) | CRbtlkController |
cmdGetJointInfo(short sMode, short *pVal) | CRbtlkController |
cmdGetMode(short *pVal) | CRbtlkController |
cmdGetOperationLog(short sIndex, short *pCode, CHAR *szDate, CHAR *szTime, CHAR *szModule, CHAR *szMsg) | CRbtlkController |
cmdGetParamCtrlLog(long *pSmpCnt, long *pSmpRate) | CRbtlkController |
cmdGetRobotType(long *pVal) | CRbtlkController |
cmdGetStatus(short sModule, short sIndex, short *pVal) | CRbtlkController |
cmdGetTransMode(short *pTransMode) | CRbtlkController |
cmdGetVersions(short sIndex, CHAR *pVal) | CRbtlkController |
cmdLetConfig(short sMode, short sIndex, long newVal) | CRbtlkController |
cmdLetDateTime(short *psDateTime) | CRbtlkController |
cmdLetJobStatus(long JobID, short sStatus) | CRbtlkController |
cmdNoticeRomVersion(short sVer) | CRbtlkController |
cmdRequestFileSave(short *pTransMode, long *pTaskID) | CRbtlkController |
cmdRequestRomUpdate() | CRbtlkController |
cmdSetMode(short iMode) | CRbtlkController |
cmdSetOption(short sMode, long lKey, CHAR *pVal) | CRbtlkController |
cmdSrvJointCancel() | CRbtlkController |
cmdSrvJointData(short sOffset, short sCounts, float **pData1, float **pData2) | CRbtlkController |
cmdSrvJointParam(short *pJoint, short *pInterval, short *pCounts, short *pData1, short *pData2) | CRbtlkController |
cmdStartCtrlLog() | CRbtlkController |
cmdStopCtrlLog() | CRbtlkController |
cmdSwitchCtrlLog(short sMode) | CRbtlkController |
CRbtlkController() | CRbtlkController | [inline]
FinalConstruct() | CRbtlkController |
FinalRelease() | CRbtlkController |
Initialize(CRbtlkEngine *pIRbtlkEng) | CRbtlkController |
InterfaceSupportsErrorInfo(REFIID riid) | CRbtlkController |
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CRbtlkEngine メンバ一覧

これは全メンバの一覧です。CRbtlkEngine継承メンバも含んでいます。
BSTRToByte(BSTR *from, unsigned char *to, int tsz, int *tlen) | CRbtlkEngine |
ByteToBSTR(unsigned char *from, int fsz, int *flen, BSTR *to) | CRbtlkEngine |
ByteToDouble(unsigned char *from, double *to) | CRbtlkEngine |
ByteToLong(unsigned char *from, long *to) | CRbtlkEngine |
ByteToShort(unsigned char *from, short *to) | CRbtlkEngine |
ByteToSingle(unsigned char *from, float *to) | CRbtlkEngine |
Cancel() | CRbtlkEngine |
ConnectServer(char *szPara) | CRbtlkEngine |
CRbtlkEngine() | CRbtlkEngine | [inline]
DisconnectServer() | CRbtlkEngine |
DoubleToByte(double *from, unsigned char *to) | CRbtlkEngine |
FinalConstruct() | CRbtlkEngine |
FinalRelease() | CRbtlkEngine |
get_LastError(long *pVal) | CRbtlkEngine |
get_NakRetry(long *pVal) | CRbtlkEngine |
get_RbtlkArm(IRbtlkArm **ppVal) | CRbtlkEngine |
get_RbtlkController(IRbtlkController **ppVal) | CRbtlkEngine |
get_RbtlkFile(IRbtlkFile **ppVal) | CRbtlkEngine |
get_RbtlkIO(IRbtlkIO **ppVal) | CRbtlkEngine |
get_RbtlkTask(IRbtlkTask **ppVal) | CRbtlkEngine |
get_RbtlkVariable(IRbtlkVariable **ppVal) | CRbtlkEngine |
get_TimeOut(long *pVal) | CRbtlkEngine |
get_TimeOutRetry(long *pVal) | CRbtlkEngine |
get_Version(double *pVal) | CRbtlkEngine |
GetVarInfo(CHAR *szVar, short *sType, short *sIndex) | CRbtlkEngine |
GetVarTabSize(short sTabIndex, short *pVal) | CRbtlkEngine |
InterfaceSupportsErrorInfo(REFIID riid) | CRbtlkEngine |
LongToByte(long *from, unsigned char *to) | CRbtlkEngine |
put_NakRetry(long newVal) | CRbtlkEngine |
put_TimeOut(long newVal) | CRbtlkEngine |
put_TimeOutRetry(long newVal) | CRbtlkEngine |
SendWithWait(RTK_PACKET *sndPck, RTK_PACKET *recPck) | CRbtlkEngine |
SendWithWaitA(RTK_PACKET *sndPck, RTK_PACKET *recPck) | CRbtlkEngine |
ShortToByte(short *from, unsigned char *to) | CRbtlkEngine |
SingleToByte(float *from, unsigned char *to) | CRbtlkEngine |
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CRbtlkFile メンバ一覧

これは全メンバの一覧です。CRbtlkFile継承メンバも含んでいます。
cmdCancelDownload(short psFileID) | CRbtlkFile |
cmdCancelDownload0(short sFileID) | CRbtlkFile |
cmdCancelUpload(short sFileID) | CRbtlkFile |
cmdCancelUpload0(short sFileID) | CRbtlkFile |
cmdCopyFile(CHAR *szFrom, CHAR *szTo) | CRbtlkFile |
cmdDeleteFile(CHAR *szName) | CRbtlkFile |
cmdDeleteFile0(CHAR *szName) | CRbtlkFile |
cmdDownload(short sFileID, short *psFileID, short *psBlockNo, BSTR *pbstrData) | CRbtlkFile |
cmdDownload0(short sFileID, short *psFileID, short *psBlockNo, BSTR *pbstrData) | CRbtlkFile |
cmdFileUploadEnd() | CRbtlkFile |
cmdFileUploadStart() | CRbtlkFile |
cmdGetAttributes(short iSystem, CHAR *szName, long *pVal) | CRbtlkFile |
cmdGetDataCreated(short iSystem, CHAR *szName, short *pDateTime) | CRbtlkFile |
cmdGetFileCnt(CHAR *szName, short *psFiles) | CRbtlkFile |
cmdGetFileCnt0(short *psFiles) | CRbtlkFile |
cmdGetFileName(short sIndex, CHAR *szDirName, CHAR *pVal) | CRbtlkFile |
cmdGetFileName0(short sIndex, CHAR *pVal) | CRbtlkFile |
cmdGetLastAccessed(short iSystem, CHAR *szName, short *pDateTime) | CRbtlkFile |
cmdGetLastModified(short iSystem, CHAR *szName, short *pDateTime) | CRbtlkFile |
cmdGetProgramIC(CHAR *szName, short *pVal) | CRbtlkFile |
cmdGetProgramIndex(CHAR *szName, short *pVal) | CRbtlkFile |
cmdGetSize(short iSystem, CHAR *szName, long *pVal) | CRbtlkFile |
cmdKillProg(short iActMode, short iProgIC) | CRbtlkFile |
cmdLetStartLine(short iLineNo, short iProgIC, short *pVal) | CRbtlkFile |
cmdLoadNic(long *pID) | CRbtlkFile |
cmdMoveFile(CHAR *szFrom, CHAR *szTo) | CRbtlkFile |
cmdRequestDownload(short sFileFlag, CHAR *szName, short *psFileID, short *psBlocks, short *psFileProp, long *plSize) | CRbtlkFile |
cmdRequestDownload0(CHAR *szName, short *psFileID, short *psBlocks, long *plSize, CHAR *szAttribute, CHAR *szUsage) | CRbtlkFile |
cmdRequestUpload(short sBlocks, long lSize, short sFileProp, short sFileFlag, CHAR *szName, short *psFileID) | CRbtlkFile |
cmdRequestUpload0(short sBlocks, long lSize, CHAR *szName, CHAR *szAttribute, CHAR *szUsage, short *psFileID) | CRbtlkFile |
cmdStartPrg(short iProgIC, short iStartMode) | CRbtlkFile |
cmdStepBackward(short iProgIC) | CRbtlkFile |
cmdStepForward(short iProgIC) | CRbtlkFile |
cmdStopPrg(short iProgIC, short iStopMode) | CRbtlkFile |
cmdUpload(short sFileID, short sBlockNo, BSTR bstrData) | CRbtlkFile |
cmdUpload0(short sFileID, short sBlockNo, BSTR bstrData) | CRbtlkFile |
CRbtlkFile() | CRbtlkFile | [inline]
FinalConstruct() | CRbtlkFile |
FinalRelease() | CRbtlkFile |
Initialize(CRbtlkEngine *pIRbtlkEng) | CRbtlkFile |
InterfaceSupportsErrorInfo(REFIID riid) | CRbtlkFile |
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CRbtlkIO メンバ一覧

これは全メンバの一覧です。CRbtlkIO継承メンバも含んでいます。
cmdChangeLabel(short sPlateNo, short sButtonNo, CHAR *newVal) | CRbtlkIO |
cmdDin(short sIndex, BOOL *pVal) | CRbtlkIO |
cmdDin16(short sIndex, short *pVal) | CRbtlkIO |
cmdDin8(short sIndex, short *pVal) | CRbtlkIO |
cmdDout(short sIndex, BOOL newVal) | CRbtlkIO |
cmdDout16(short sIndex, short newVal) | CRbtlkIO |
cmdDout8(short sIndex, short newVal) | CRbtlkIO |
cmdDummy(short sIndex, short newVal) | CRbtlkIO |
CRbtlkIO() | CRbtlkIO | [inline]
FinalConstruct() | CRbtlkIO |
FinalRelease() | CRbtlkIO |
Initialize(CRbtlkEngine *pIRbtlkEng) | CRbtlkIO |
InterfaceSupportsErrorInfo(REFIID riid) | CRbtlkIO |
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CRbtlkTask メンバ一覧

これは全メンバの一覧です。CRbtlkTask継承メンバも含んでいます。
cmdContPrgStatus(short sPrgIC, short *pStatus, short *pPriority, short *pInterval, short *pLineNo, short *pIOBlock, short *pMode, long *pCT) | CRbtlkTask |
cmdGetPrgList(short sIndex, short *newVal, CHAR *szName) | CRbtlkTask |
cmdGetPrgListLen(short *newVal) | CRbtlkTask |
cmdGetTaskStatus(short sPrgIC, short *pStatus) | CRbtlkTask |
CRbtlkTask() | CRbtlkTask | [inline]
FinalConstruct() | CRbtlkTask |
FinalRelease() | CRbtlkTask |
Initialize(CRbtlkEngine *pIRbtlkEng) | CRbtlkTask |
InterfaceSupportsErrorInfo(REFIID riid) | CRbtlkTask |
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CRbtlkVariable メンバ一覧

これは全メンバの一覧です。CRbtlkVariable継承メンバも含んでいます。
cmdGetD(short sIC, short sIndex, double *pVal) | CRbtlkVariable |
cmdGetDefIO(short sPort, short sType, long lMask, long *pVal) | CRbtlkVariable |
cmdGetF(short sIC, short sIndex, float *pVal) | CRbtlkVariable |
cmdGetI(short sIC, short sIndex, long *pVal) | CRbtlkVariable |
cmdGetJ(short sIC, short sIndex, float *pVal) | CRbtlkVariable |
cmdGetP(short sIC, short sIndex, float *pVal) | CRbtlkVariable |
cmdGetS(short sIC, short sIndex, CHAR *pVal) | CRbtlkVariable |
cmdGetT(short sIC, short sIndex, float *pVal) | CRbtlkVariable |
cmdGetTabLen(short sPrgIC, short sTypeIC, short *pVal) | CRbtlkVariable |
cmdGetV(short sIC, short sIndex, float *pVal) | CRbtlkVariable |
cmdLetD(short sIC, short sIndex, double newVal) | CRbtlkVariable |
cmdLetDefIO(short sPort, short sType, long lMask, long lVal) | CRbtlkVariable |
cmdLetF(short sIC, short sIndex, float newVal) | CRbtlkVariable |
cmdLetI(short sIC, short sIndex, long newVal) | CRbtlkVariable |
cmdLetJ(short sIC, short sIndex, float *newVal) | CRbtlkVariable |
cmdLetP(short sIC, short sIndex, float *newVal) | CRbtlkVariable |
cmdLetS(short sIC, short sIndex, CHAR *newVal) | CRbtlkVariable |
cmdLetT(short sIC, short sIndex, float *newVal) | CRbtlkVariable |
cmdLetV(short sIC, short sIndex, float *newVal) | CRbtlkVariable |
CRbtlkVariable() | CRbtlkVariable | [inline]
FinalConstruct() | CRbtlkVariable |
FinalRelease() | CRbtlkVariable |
Initialize(CRbtlkEngine *pIRbtlkEng) | CRbtlkVariable |
InterfaceSupportsErrorInfo(REFIID riid) | CRbtlkVariable |
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CSerial メンバ一覧

これは全メンバの一覧です。CSerial継承メンバも含んでいます。
CDevice() | CDevice |
Connect(CDevice **ppNewDevice=NULL) | CSerial | [virtual]
CSerial() | CSerial |
Disconnect(void) | CSerial | [virtual]
Flush(void) | CSerial | [virtual]
GetReceivedCount(void) | CSerial | [virtual]
GetRecivePacket(LPSTR lpszData, DWORD dwBufSize, DWORD *pdwReceivedLen, int nTermCount=1) | CDevice | [protected]
GetState(DCB *pDCB) | CSerial |
GetTimeOut(void) | CDevice | [virtual]
Initialize(PVOID pArgs[]) | CSerial | [virtual]
m_bConnected | CDevice | [protected]
m_dwHeaderLen | CDevice | [protected]
m_dwLocalBufferLen | CDevice | [protected]
m_dwMode | CDevice | [protected]
m_dwReceiveRetry | CSerial | [protected]
m_dwRetryCnt | CDevice | [protected]
m_dwTermLen | CDevice | [protected]
m_dwTotalTimeout | CDevice | [protected]
m_hComHandle | CSerial | [protected]
m_pcHeader | CDevice | [protected]
m_pcTerm | CDevice | [protected]
m_szLocalBuffer | CDevice | [protected]
Receive(LPBYTE lpszData, DWORD dwBufSize, DWORD *pdwReceivedLen, int nTermCount=1) | CDevice |
Send(LPBYTE lpszData, DWORD dwSendLen=0) | CDevice |
SendAndReceive(LPBYTE lpszSendData, LPBYTE lpszReceiveData, DWORD dwRecvSize, DWORD *pdwRecvLen, int nTermCount=1, DWORD dwRetryCnt=0) | CDevice | [virtual]
SetState(DCB *pDCB) | CSerial |
SetTimeOut(DWORD dwTimeout) | CSerial | [virtual]
~CDevice() | CDevice | [virtual]
~CSerial() | CSerial | [virtual]
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


Device.h Source File

Device.h

解説を見る。
00001
00011 #if !defined(AFX_DEVICE_H__27399E95_B5DF_4C1C_BD53_842D96EDF6D8__INCLUDED_)
00012 #define AFX_DEVICE_H__27399E95_B5DF_4C1C_BD53_842D96EDF6D8__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00018 #include <limits.h>
00019
00020 #define DEV_TIME_OUT        500L        // タイムアウト時間: 500ms
00021 #define DEV_RETRY           3           // リトライ回数: 3回
00022
00023 #define E_TIMEOUT           _HRESULT_TYPEDEF_(0x80000900L)
00024 #define LOCAL_BUFFER_MAX    SHRT_MAX
00025
00026 #define ST_MODE_BINARY      0       // バイナリモード
00027 #define ST_MODE_TEXT        1       // テキストモード
00028 #define ST_MODE_WBSTOWCS    2       // UNICODE変換
00029 #define ST_MODE_ASCTOISO    4       // ISO変換
00030 #define ST_MODE_ASCTOEIA    8       // EIA変換
00031
00032 // 文字コード変換テーブルインデックス
00033 #define TABLE_ASCTOISO      0       // ASCII → ISO
00034 #define TABLE_ISOTOASC      1       // ISO → ASCII
00035 #define TABLE_ASCTOEIA      2       // ASCII → EIA
00036 #define TABLE_EIATOASC      3       // EIA → ASCII
00037
00038
00039 // 文字コード変換テーブル(変換しない場合はテーブルの添え字と同じ値を返します)
00040 static const BYTE g_CharTable[4][256] = {
00041     // ASCII →　ISO
00042     { 0x00, 0x81, 0x82, 0x03, 0x84, 0x05, 0x06, 0x87, 0x88, 0x09, 0x0a, 0x8b, 0x0c, 0x8d, 0x8e, 0x0f,
00043       0x90, 0x11, 0x12, 0x93, 0x14, 0x95, 0x96, 0x17, 0x18, 0x99, 0x9a, 0x1b, 0x9c, 0x1d, 0x1e, 0x9f,
00044       0xa0, 0x21, 0x22, 0xa3, 0x24, 0xa5, 0xa6, 0x27, 0x28, 0xa9, 0xaa, 0x2b, 0xac, 0x2d, 0x2e, 0xaf,
00045       0x30, 0xb1, 0xb2, 0x33, 0xb4, 0x35, 0x36, 0xb7, 0xb8, 0x39, 0x3a, 0xbb, 0x3c, 0xbd, 0xbe, 0x3f,
00046       0xc0, 0x41, 0x42, 0xc3, 0x44, 0xc5, 0xc6, 0x47, 0x48, 0xc9, 0xca, 0x4b, 0xcc, 0x4d, 0x4e, 0xcf,
00047       0x50, 0xd1, 0xd2, 0x53, 0xd4, 0x55, 0x56, 0xd7, 0xd8, 0x59, 0x5a, 0xdb, 0x5c, 0xdd, 0xde, 0x5f,
00048       0x60, 0xe1, 0xe2, 0x63, 0xe4, 0x65, 0x66, 0xe7, 0xe8, 0x69, 0x6a, 0xeb, 0x6c, 0xed, 0xee, 0x6f,
00049       0xf0, 0x71, 0x72, 0xf3, 0x74, 0xf5, 0xf6, 0x77, 0x78, 0xf9, 0xfa, 0x7b, 0xfc, 0x7d, 0x7e, 0xff,
00050       0x80, 0x81, 0x82, 0x83, 0x84, 0x85, 0x86, 0x87, 0x88, 0x89, 0x8a, 0x8b, 0x8c, 0x8d, 0x8e, 0x8f,
00051       0x90, 0x91, 0x92, 0x93, 0x94, 0x95, 0x96, 0x97, 0x98, 0x99, 0x9a, 0x9b, 0x9c, 0x9d, 0x9e, 0x9f,
00052       0xa0, 0xa1, 0xa2, 0xa3, 0xa4, 0xa5, 0xa6, 0xa7, 0xa8, 0xa9, 0xaa, 0xab, 0xac, 0xad, 0xae, 0xaf,
00053       0xb0, 0xb1, 0xb2, 0xb3, 0xb4, 0xb5, 0xb6, 0xb7, 0xb8, 0xb9, 0xba, 0xbb, 0xbc, 0xbd, 0xbe, 0xbf,
00054       0xc0, 0xc1, 0xc2, 0xc3, 0xc4, 0xc5, 0xc6, 0xc7, 0xc8, 0xc9, 0xca, 0xcb, 0xcc, 0xcd, 0xce, 0xcf,
00055       0xd0, 0xd1, 0xd2, 0xd3, 0xd4, 0xd5, 0xd6, 0xd7, 0xd8, 0xd9, 0xda, 0xdb, 0xdc, 0xdd, 0xde, 0xdf,
00056       0xe0, 0xe1, 0xe2, 0xe3, 0xe4, 0xe5, 0xe6, 0xe7, 0xe8, 0xe9, 0xea, 0xeb, 0xec, 0xed, 0xee, 0xef,
00057       0xf0, 0xf1, 0xf2, 0xf3, 0xf4, 0xf5, 0xf6, 0xf7, 0xf8, 0xf9, 0xfa, 0xfb, 0xfc, 0xfd, 0xfe, 0xff},
00058
00059       // ISO →　ASCII
00060     { 0x00, 0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08, 0x09, 0x0a, 0x0b, 0x0c, 0x0d, 0x0e, 0x0f,
00061       0x10, 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18, 0x19, 0x1a, 0x1b, 0x1c, 0x1d, 0x1e, 0x1f,
00062       0x20, 0x21, 0x22, 0x23, 0x24, 0x25, 0x26, 0x27, 0x28, 0x29, 0x2a, 0x2b, 0x2c, 0x2d, 0x2e, 0x2f,
00063       0x30, 0x31, 0x32, 0x33, 0x34, 0x35, 0x36, 0x37, 0x38, 0x39, 0x3a, 0x3b, 0x3c, 0x3d, 0x3e, 0x3f,
00064       0x40, 0x41, 0x42, 0x43, 0x44, 0x45, 0x46, 0x47, 0x48, 0x49, 0x4a, 0x4b, 0x4c, 0x4d, 0x4e, 0x4f,
00065       0x50, 0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58, 0x59, 0x5a, 0x5b, 0x5c, 0x5d, 0x5e, 0x5f,
00066       0x60, 0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68, 0x69, 0x6a, 0x6b, 0x6c, 0x6d, 0x6e, 0x6f,
00067       0x70, 0x71, 0x72, 0x73, 0x74, 0x75, 0x76, 0x77, 0x78, 0x79, 0x7a, 0x7b, 0x7c, 0x7d, 0x7e, 0x7f,
00068       0x80, 0x01, 0x02, 0x83, 0x04, 0x85, 0x86, 0x07, 0x08, 0x89, 0x8a, 0x0b, 0x8c, 0x0d, 0x0e, 0x8f,
00069       0x10, 0x91, 0x92, 0x13, 0x94, 0x15, 0x16, 0x97, 0x98, 0x19, 0x1a, 0x9b, 0x1c, 0x9d, 0x9e, 0x1f,
00070       0x20, 0xa1, 0xa2, 0x23, 0xa4, 0x25, 0x26, 0xa7, 0xa8, 0x29, 0x2a, 0xab, 0x2c, 0xad, 0xae, 0x2f,
00071       0xb0, 0x31, 0x32, 0xb3, 0x34, 0xb5, 0xb6, 0x37, 0x38, 0xb9, 0xba, 0x3b, 0xbc, 0x3d, 0x3e, 0xbf,
00072       0x40, 0xc1, 0xc2, 0x43, 0xc4, 0x45, 0x46, 0xc7, 0xc8, 0x49, 0x4a, 0xcb, 0x4c, 0xcd, 0xce, 0x4f,
00073       0xd0, 0x51, 0x52, 0xd3, 0x54, 0xd5, 0xd6, 0x57, 0x58, 0xd9, 0xda, 0x5b, 0xdc, 0x5d, 0x5e, 0xdf,
00074       0xe0, 0x61, 0x62, 0xe3, 0x64, 0xe5, 0xe6, 0x67, 0x68, 0xe9, 0xea, 0x6b, 0xec, 0x6d, 0x6e, 0xef,
00075       0x70, 0xf1, 0xf2, 0x73, 0xf4, 0x75, 0x76, 0xf7, 0xf8, 0x79, 0x7a, 0xfb, 0x7c, 0xfd, 0xfe, 0x7f},
00076
00077       // ASCII →　EIA
00078     { 0x00, 0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x2a, 0x3e, 0x80, 0x0b, 0x0c, 0x0d, 0x0e, 0x0f,
00079       0x10, 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18, 0x19, 0x1a, 0x1b, 0x1c, 0x1d, 0x1e, 0x1f,
00080       0x10, 0x21, 0x22, 0x23, 0x94, 0x0b, 0x0e, 0x27, 0x1a, 0x4a, 0x98, 0x70, 0x3b, 0x40, 0x6b, 0x31,
00081       0x20, 0x01, 0x02, 0x13, 0x04, 0x15, 0x16, 0x07, 0x08, 0x19, 0x3a, 0x3b, 0x3c, 0x8c, 0x3e, 0x9e,
00082       0x8f, 0x61, 0x62, 0x73, 0x64, 0x75, 0x76, 0x67, 0x68, 0x79, 0x51, 0x52, 0x43, 0x54, 0x45, 0x46,
00083       0x57, 0x58, 0x49, 0x32, 0x23, 0x34, 0x25, 0x26, 0x37, 0x38, 0x29, 0xb0, 0x5c, 0xa2, 0x5e, 0x5f,
00084       0x60, 0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68, 0x69, 0x6a, 0x6b, 0x6c, 0x6d, 0x6e, 0x6f,
00085       0x70, 0x71, 0x72, 0x73, 0x74, 0x75, 0x76, 0x77, 0x78, 0x79, 0x7a, 0x7b, 0x7c, 0x7d, 0x7e, 0x7f,
00086       0x80, 0x81, 0x82, 0x83, 0x84, 0x85, 0x86, 0x87, 0x88, 0x89, 0x8a, 0x8b, 0x8c, 0x8d, 0x8e, 0x8f,
00087       0x90, 0x91, 0x92, 0x93, 0x94, 0x95, 0x96, 0x97, 0x98, 0x99, 0x9a, 0x9b, 0x9c, 0x9d, 0x9e, 0x9f,
00088       0xa0, 0xa1, 0xa2, 0xa3, 0xa4, 0xa5, 0xa6, 0xa7, 0xa8, 0xa9, 0xaa, 0xab, 0xac, 0xad, 0xae, 0xaf,
00089       0xb0, 0xb1, 0xb2, 0xb3, 0xb4, 0xb5, 0xb6, 0xb7, 0xb8, 0xb9, 0xba, 0xbb, 0xbc, 0xbd, 0xbe, 0xbf,
00090       0xc0, 0xc1, 0xc2, 0xc3, 0xc4, 0xc5, 0xc6, 0xc7, 0xc8, 0xc9, 0xca, 0xcb, 0xcc, 0xcd, 0xce, 0xcf,
00091       0xd0, 0xd1, 0xd2, 0xd3, 0xd4, 0xd5, 0xd6, 0xd7, 0xd8, 0xd9, 0xda, 0xdb, 0xdc, 0xdd, 0xde, 0xdf,
00092       0xe0, 0xe1, 0xe2, 0xe3, 0xe4, 0xe5, 0xe6, 0xe7, 0xe8, 0xe9, 0xea, 0xeb, 0xec, 0xed, 0xee, 0xef,
00093       0xf0, 0xf1, 0xf2, 0xf3, 0xf4, 0xf5, 0xf6, 0xf7, 0xf8, 0xf9, 0xfa, 0xfb, 0xfc, 0xfd, 0xfe, 0xff},
00094
00095 // EIA → ASCII
00096     { 0x00, 0x31, 0x32, 0x03, 0x34, 0x05, 0x06, 0x37, 0x38, 0x09, 0x0a, 0x25, 0x0c, 0x0d, 0x26, 0x0f,
00097       0x20, 0x11, 0x12, 0x33, 0x14, 0x35, 0x36, 0x17, 0x18, 0x39, 0x28, 0x1b, 0x1c, 0x1d, 0x1e, 0x1f,
00098       0x30, 0x21, 0x22, 0x54, 0x24, 0x56, 0x57, 0x27, 0x28, 0x5a, 0x08, 0x2b, 0x2c, 0x2d, 0x2e, 0x2f,
00099       0x30, 0x2f, 0x53, 0x33, 0x55, 0x35, 0x36, 0x58, 0x59, 0x39, 0x3a, 0x2c, 0x3c, 0x3d, 0x09, 0x3f,
00100       0x2d, 0x41, 0x42, 0x4c, 0x44, 0x4e, 0x4f, 0x47, 0x48, 0x52, 0x29, 0x4b, 0x4c, 0x4d, 0x4e, 0x4f,
00101       0x50, 0x4a, 0x4b, 0x53, 0x4d, 0x55, 0x56, 0x50, 0x51, 0x59, 0x5a, 0x5b, 0x5c, 0x5d, 0x5e, 0x5f,
00102       0x60, 0x41, 0x42, 0x63, 0x44, 0x65, 0x66, 0x47, 0x48, 0x69, 0x6a, 0x2e, 0x6c, 0x6d, 0x6e, 0x6f,
00103       0x2b, 0x71, 0x72, 0x43, 0x74, 0x45, 0x46, 0x77, 0x78, 0x49, 0x7a, 0x7b, 0x7c, 0x7d, 0x7e, 0x7f,
00104       0x0a, 0x81, 0x82, 0x83, 0x84, 0x85, 0x86, 0x87, 0x88, 0x89, 0x8a, 0x8b, 0x3d, 0x8d, 0x8e, 0x40,
00105       0x90, 0x91, 0x92, 0x93, 0x24, 0x95, 0x96, 0x97, 0x2a, 0x99, 0x9a, 0x9b, 0x9c, 0x9d, 0x3f, 0x9f,
00106       0xa0, 0xa1, 0x5d, 0xa3, 0xa4, 0xa5, 0xa6, 0xa7, 0xa8, 0xa9, 0xaa, 0xab, 0xac, 0xad, 0xae, 0xaf,
00107       0x5b, 0xb1, 0xb2, 0xb3, 0xb4, 0xb5, 0xb6, 0xb7, 0xb8, 0xb9, 0xba, 0xbb, 0xbc, 0xbd, 0xbe, 0xbf,
00108       0xc0, 0xc1, 0xc2, 0xc3, 0xc4, 0xc5, 0xc6, 0xc7, 0xc8, 0xc9, 0xca, 0xcb, 0xcc, 0xcd, 0xce, 0xcf,
00109       0xd0, 0xd1, 0xd2, 0xd3, 0xd4, 0xd5, 0xd6, 0xd7, 0xd8, 0xd9, 0xda, 0xdb, 0xdc, 0xdd, 0xde, 0xdf,
00110       0xe0, 0xe1, 0xe2, 0xe3, 0xe4, 0xe5, 0xe6, 0xe7, 0xe8, 0xe9, 0xea, 0xeb, 0xec, 0xed, 0xee, 0xef,
00111       0xf0, 0xf1, 0xf2, 0xf3, 0xf4, 0xf5, 0xf6, 0xf7, 0xf8, 0xf9, 0xfa, 0xfb, 0xfc, 0xfd, 0xfe, 0xff}
00112 };
00113
00120 class CDevice
00121 {
00122 // データメンバ
00123 private:
00124
00125 protected:
00126     BOOL  m_bConnected;     // 接続フラグ
00127     DWORD m_dwRetryCnt;     // リトライを行う最大回数
00128     DWORD m_dwTotalTimeout; // 文字列を送受信完了するまでの最大待ち時間 (ms)
00129
00131     DWORD m_dwMode;
00133     DWORD m_dwHeaderLen;
00135     CHAR  *m_pcHeader;
00137     DWORD m_dwTermLen;
00139     CHAR  *m_pcTerm;
00141     char m_szLocalBuffer[LOCAL_BUFFER_MAX];
00143     DWORD m_dwLocalBufferLen;
00144
00145 public:
00146
00147 // メソッド
00148 protected:
00149 // 受信パケットの取得
00150     HRESULT GetRecivePacket(LPSTR lpszData, DWORD dwBufSize, DWORD *pdwReceivedLen, int nTermCount = 1);
00151
00152 public:
00153 // コンストラクタ
00154     CDevice();
00155 // デストラクタ
00156     virtual ~CDevice();
00157
00158 // 初期化処理
00159     virtual HRESULT Initialize(PVOID pArgs[]);
00160
00161 // 接続
00162     virtual HRESULT Connect(CDevice** ppNewDevice = NULL);
00163 // 切断
00164     virtual HRESULT Disconnect(void);
00165 // 送信 (dwSendLen = 0 のとき NULL終端まで出力)
00166     HRESULT Send(LPBYTE lpszData, DWORD dwSendLen = 0);
00167 // 受信
00168     HRESULT Receive(LPBYTE lpszData, DWORD dwBufSize, DWORD *pdwReceivedLen, int nTermCount = 1);
00169 // 送信 -> 受信処理(リトライ対応)
00170     virtual HRESULT SendAndReceive(LPBYTE lpszSendData, LPBYTE lpszReceiveData, DWORD dwRecvSize, DWORD *pdwRecvLen, int nTermCount = 1, DWORD dwRetryCnt = 0);
00171 // バッファクリア
00172     virtual HRESULT Flush(void);
00173 // タイムアウト時間の更新
00174     virtual HRESULT SetTimeOut(DWORD dwTimeout);
00175 // タイムアウト時間の取得
00176     virtual DWORD GetTimeOut(void);
00177 // 受信個数
00178     virtual DWORD GetReceivedCount(void);
00179
00180 private:
00181     virtual HRESULT SendData(LPCSTR lpszData, DWORD dwSendLen = 0);
00182     virtual HRESULT ReceiveData(LPSTR lpszData, DWORD dwBufSize, DWORD *pdwReceivedLen, int nTermCount = 1);
00183
00184 };
00185
00186 #endif // !defined(AFX_DEVICE_H__27399E95_B5DF_4C1C_BD53_842D96EDF6D8__INCLUDED_)
Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


EtherUDP.h Source File

EtherUDP.h

解説を見る。
00001
00011 #if !defined(AFX_ETHERUDP_H__7DA23D74_7712_46A2_81F7_94F952EEDDB3__INCLUDED_)
00012 #define AFX_ETHERUDP_H__7DA23D74_7712_46A2_81F7_94F952EEDDB3__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00018 #include "Device.h"
00019 #include <winsock.h>
00020 #pragma comment(lib, "wsock32.lib")
00021
00022 #define ETHER_BASE_TIMEOUT  50          // 基準タイムアウト時間
00023
00024 class CEtherUDP : public CDevice
00025 {
00026 public:
00027 // コンストラクタ
00028     CEtherUDP();
00029 // デストラクタ
00030     virtual ~CEtherUDP();
00031
00032 // 接続
00033     virtual HRESULT Connect(CDevice** ppNewDevice = NULL);
00034 // 切断
00035     virtual HRESULT Disconnect(void);
00036 // バッファクリア
00037     virtual HRESULT Flush(void);
00038 // タイムアウト時間の更新
00039     virtual HRESULT SetTimeOut(DWORD dwTimeout);
00040 // 受信個数
00041     virtual DWORD GetReceivedCount();
00042
00043 // 初期化処理
00044     HRESULT Initialize(PVOID pArgs[]);
00045
00046 private:
00047
00048 // 送信 (dwSendLen = 0 のとき NULL終端まで出力)
00049     virtual HRESULT SendData(LPCSTR lpszData, DWORD dwSendLen = 0);
00050 // 受信
00051     virtual HRESULT ReceiveData(LPSTR lpszData, DWORD dwBufSize, DWORD *pdwReceivedLen, int nTermCount = 1);
00052
00053 // データメンバ
00054 private:
00056     WSADATA     m_wsaData;
00058     SOCKET      m_hSocket;
00060     struct  sockaddr_in m_stServer;
00062     DWORD m_dwReceiveRetry;
00063
00064 };
00065
00066 #endif // !defined(AFX_ETHERUDP_H__7DA23D74_7712_46A2_81F7_94F952EEDDB3__INCLUDED_)
Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


Graph Legend

グラフの凡例

このページでは、doxygen で生成されたグラフをどのようにみたらよいかを説明します。

次の例を考えてみます。

/*! 省略されて見えないクラス */
class Invisible { };

/*! 省略されたクラス(継承関係は隠されている) */
class Truncated : public Invisible { };

/* doxygen コメントによるドキュメントがないクラス */
class Undocumented { };

/*! public で継承されたクラス */
class PublicBase : public Truncated { };

/*! protected で継承されたクラス */
class ProtectedBase { };

/*! private で継承されたクラス */
class PrivateBase { };

/*! 継承されたクラスで使われているクラス */
class Used { };

/*! 複数のクラスを継承している上位クラス */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
{
  private:
    Used *m_usedClass;
};
設定ファイル中で、タグ MAX_DOT_GRAPH_HEIGHT が 200 にセットされた場合、次のようなグラフとなります。

上のグラフ内のボックスには次のような意味があります。

  • 黒く塗りつぶされたボックスは、このグラフに対応する構造体やクラスを表します。
  • 黒枠のボックスはドキュメントがある構造体やクラスを表します。
  • 灰色の枠のボックスはドキュメントがない構造体やクラスを表します。
  • 赤枠のボックスはドキュメントがある構造体やクラスを表しますが、指定されたサイズに収まらないために継承・包含関係をすべて図示することができなかったことを示します。
矢印には次のような意味があります。
  • 青い矢印は二つのクラス間の public 継承関係を示します。
  • 緑の矢印は protected 継承関係を示します。
  • 赤の矢印は private 継承関係を示します。
  • 紫の破線矢印は、そのクラスが他のクラスに含まれていたり、利用されていることを示します。また、矢印が指しているクラスや構造体をどの変数でアクセスできるかを矢印のラベルとして示しています。
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

IRbtlkArm メンバ一覧

これは全メンバの一覧です。IRbtlkArm継承メンバも含んでいます。
cmdDisableArea([in] short sNo) | IRbtlkArm
cmdEnableArea([in] short sNo) | IRbtlkArm
cmdGetArea([in] short sNo,[out] float *pf,[out] short *psIO,[out] short *psPos) | IRbtlkArm
cmdGetAreaEx([in] short sNo,[out] float *pf,[out] short *psIO,[out] short *psPos,[out] short *psErr,[out] short *psEnable) | IRbtlkArm
cmdGetTool([in] short sNo,[out] float *pf) | IRbtlkArm
cmdGetToolIndex([out] short *pVal) | IRbtlkArm
cmdGetWork([in] short sNo,[out] float *pf) | IRbtlkArm
cmdGetWorkIndex([out] short *pVal) | IRbtlkArm
cmdHere([out] float *pVal) | IRbtlkArm
cmdJHere([out] float *pVal) | IRbtlkArm
cmdLetArea([in] short sNo,[in] float *pf,[in] short sIO,[in] short sPos) | IRbtlkArm
cmdLetAreaEx([in] short sNo,[in] float *pf,[in] short sIO,[in] short sPos,[in] short sErr,[in] short sEnable) | IRbtlkArm
cmdLetTool([in] short sNo,[in] float *pf) | IRbtlkArm
cmdLetWork([in] short sNo,[in] float *pf) | IRbtlkArm
cmdThere([out] float *pVal) | IRbtlkArm
RTK_ARM_STATUS Enum | IRbtlkArm
RTK_AST_CALEND Enum 値 | IRbtlkArm
RTK_AST_MODE Enum 値 | IRbtlkArm
RTK_AST_SERVO Enum 値 | IRbtlkArm
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

IRbtlkController メンバ一覧

これは全メンバの一覧です。IRbtlkController継承メンバも含んでいます。
cmdCancelCtrlLog() | IRbtlkController
cmdChangeConfig([in] short sMode) | IRbtlkController
cmdClearCtrlLog() | IRbtlkController
cmdClearError([in] long lErrCode,[out] short *pVal) | IRbtlkController
cmdDoSignal([in] short sMode,[in] short sAction) | IRbtlkController
cmdGetConfig([in] short sMode,[in] short sIndex,[out] long *pVal) | IRbtlkController
cmdGetControlLog([in] short sIndex,[out] float pData[8][4],[out] float *pReg,[out] short *pProgNo,[out] short *pLineNo) | IRbtlkController
cmdGetDateTime([out] short *psDateTime) | IRbtlkController
cmdGetErrorCode([out] long *pVal) | IRbtlkController
cmdGetErrorLog([in] short sIndex,[out] short *pCode,[out] short *pLevel,[out] CHAR *szDate,[out] CHAR *szTime,[out] CHAR *szModule,[out] CHAR *szMsg) | IRbtlkController
cmdGetFreeMemory([out] long *pVal) | IRbtlkController
cmdGetJobStatus([in] long JobID,[out] short *pStatus) | IRbtlkController
cmdGetJointInfo([in] short sMode,[out] short *pVal) | IRbtlkController
cmdGetMode([out] short *pVal) | IRbtlkController
cmdGetOperationLog([in] short sIndex,[out] short *pCode,[out] CHAR *szDate,[out] CHAR *szTime,[out] CHAR *szModule,[out] CHAR *szMsg) | IRbtlkController
cmdGetParamCtrlLog([out] long *pSmpCnt,[out] long *pSmpRate) | IRbtlkController
cmdGetRobotType([out] long *pVal) | IRbtlkController
cmdGetStatus([in] short sModule,[in] short sIndex,[out] short *pVal) | IRbtlkController
cmdGetTransMode([out] short *pTransMode) | IRbtlkController
cmdGetVersions([in] short sIndex,[out] CHAR *pVal) | IRbtlkController
cmdLetConfig([in] short sMode,[in] short sIndex,[in] long newVal) | IRbtlkController
cmdLetDateTime([in] short *psDateTime) | IRbtlkController
cmdLetJobStatus([in] long JobID,[in] short sStatus) | IRbtlkController
cmdNoticeRomVersion([in] short sVer) | IRbtlkController
cmdRequestFileSave([out] short *pTransMode,[out] long *pTaskID) | IRbtlkController
cmdRequestRomUpdate() | IRbtlkController
cmdSetMode([in] short iMode) | IRbtlkController
cmdSetOption([in] short sMode,[in] long lKey,[out] CHAR *pVal) | IRbtlkController
cmdSrvJointCancel() | IRbtlkController
cmdSrvJointData([in] short sOffset,[in] short sCounts,[out] float **pData1,[out] float **pData2) | IRbtlkController
cmdSrvJointParam([out] short *pJoint,[out] short *pInterval,[out] short *pCounts,[out] short *pData1,[out] short *pData2) | IRbtlkController
cmdStartCtrlLog() | IRbtlkController
cmdStopCtrlLog() | IRbtlkController
cmdSwitchCtrlLog([in] short sMode) | IRbtlkController
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

IRbtlkEngine メンバ一覧

これは全メンバの一覧です。IRbtlkEngine継承メンバも含んでいます。
Cancel() | IRbtlkEngine
ConnectServer([in] CHAR *szPara) | IRbtlkEngine
DisconnectServer() | IRbtlkEngine
GetVarInfo([in] CHAR *szVar,[out] short *sType,[out] short *sIndex) | IRbtlkEngine
LastError([out, retval] long *pVal) | IRbtlkEngine
NakRetry([out, retval] long *pVal) | IRbtlkEngine
NakRetry([in] long newVal) | IRbtlkEngine
NIC_GV_DBL Enum 値 | IRbtlkEngine
NIC_GV_INT Enum 値 | IRbtlkEngine
NIC_GV_IO Enum 値 | IRbtlkEngine
NIC_GV_JNT Enum 値 | IRbtlkEngine
NIC_GV_POS Enum 値 | IRbtlkEngine
NIC_GV_SNG Enum 値 | IRbtlkEngine
NIC_GV_STR Enum 値 | IRbtlkEngine
NIC_GV_TRN Enum 値 | IRbtlkEngine
NIC_GV_VEC Enum 値 | IRbtlkEngine
NIC_GVAR_IC Enum | IRbtlkEngine
RbtlkArm([out, retval] IRbtlkArm **ppVal) | IRbtlkEngine
RbtlkController([out, retval] IRbtlkController **ppVal) | IRbtlkEngine
RbtlkFile([out, retval] IRbtlkFile **ppVal) | IRbtlkEngine
RbtlkIO([out, retval] IRbtlkIO **ppVal) | IRbtlkEngine
RbtlkTask([out, retval] IRbtlkTask **ppVal) | IRbtlkEngine
RbtlkVariable([out, retval] IRbtlkVariable **ppVal) | IRbtlkEngine
RTK_CST_EMGSTOP Enum 値 | IRbtlkEngine
RTK_CST_ERROR Enum 値 | IRbtlkEngine
RTK_CST_RUNNING Enum 値 | IRbtlkEngine
RTK_CTRL_STATUS Enum | IRbtlkEngine
TimeOut([out, retval] long *pVal) | IRbtlkEngine
TimeOut([in] long newVal) | IRbtlkEngine
TimeOutRetry([out, retval] long *pVal) | IRbtlkEngine
TimeOutRetry([in] long newVal) | IRbtlkEngine
Version([out, retval] double *pVal) | IRbtlkEngine
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

IRbtlkFile メンバ一覧

これは全メンバの一覧です。IRbtlkFile継承メンバも含んでいます。
cmdCancelDownload([in] short sFileID) | IRbtlkFile
cmdCancelDownload0([in] short sFileID) | IRbtlkFile
cmdCancelUpload([in] short sFileID) | IRbtlkFile
cmdCancelUpload0([in] short sFileID) | IRbtlkFile
cmdCopyFile([in] CHAR *szFrom,[in] CHAR *szTo) | IRbtlkFile
cmdDeleteFile([in] CHAR *szName) | IRbtlkFile
cmdDeleteFile0([in] CHAR *szName) | IRbtlkFile
cmdDownload([in] short sFileID,[out] short *psFileID,[out] short *psBlockNo,[out] BSTR *pbstrData) | IRbtlkFile
cmdDownload0([in] short sFileID,[out] short *psFileID,[out] short *psBlockNo,[out] BSTR *pbstrData) | IRbtlkFile
cmdFileUploadEnd() | IRbtlkFile
cmdFileUploadStart() | IRbtlkFile
cmdGetAttributes([in] short iSystem,[in] CHAR *szName,[out] long *pVal) | IRbtlkFile
cmdGetDataCreated([in] short iSystem,[in] CHAR *szName,[out] short *pDateTime) | IRbtlkFile
cmdGetFileCnt([in] CHAR *szName,[out] short *psFiles) | IRbtlkFile
cmdGetFileCnt0([out] short *psFiles) | IRbtlkFile
cmdGetFileName([in] short sIndex,[in] CHAR *szDirName,[out] CHAR *pVal) | IRbtlkFile
cmdGetFileName0([in] short sIndex,[out] CHAR *pVal) | IRbtlkFile
cmdGetLastAccessed([in] short iSystem,[in] CHAR *szName,[out] short *pDateTime) | IRbtlkFile
cmdGetLastModified([in] short iSystem,[in] CHAR *szName,[out] short *pDateTime) | IRbtlkFile
cmdGetProgramIC([in] CHAR *szName,[out] short *pVal) | IRbtlkFile
cmdGetProgramIndex([in] CHAR *szName,[out] short *pVal) | IRbtlkFile
cmdGetSize([in] short iSystem,[in] CHAR *szName,[out] long *pVal) | IRbtlkFile
cmdKillProg([in] short iActMode,[in] short iProgIC) | IRbtlkFile
cmdLetStartLine([in] short iLineNo,[in] short iProgIC,[out] short *pVal) | IRbtlkFile
cmdLoadNic([out] long *pID) | IRbtlkFile
cmdMoveFile([in] CHAR *szFrom,[in] CHAR *szTo) | IRbtlkFile
cmdRequestDownload([in] short sFileFlag,[in] CHAR *szName,[out] short *psFileID,[out] short *psBlocks,[out] short *sFileProp,[out] long *plSize) | IRbtlkFile
cmdRequestDownload0([in] CHAR *szName,[out] short *psFileID,[out] short *psBlocks,[out] long *plSize,[out] CHAR *szAttribute,[out] CHAR *szUsage) | IRbtlkFile
cmdRequestUpload([in] short sBlocks,[in] long lSize,[in] short sFileProp,[in] short sFileFlag,[in] CHAR *szName,[out] short *psFileID) | IRbtlkFile
cmdRequestUpload0([in] short sBlocks,[in] long lSize,[in] CHAR *szName,[in] CHAR *szAttribute,[in] CHAR *szUsage,[out] short *psFileID) | IRbtlkFile
cmdStartPrg([in] short iProgIC,[in] short iStartMode) | IRbtlkFile
cmdStepBackward([in] short iProgIC) | IRbtlkFile
cmdStepForward([in] short iProgIC) | IRbtlkFile
cmdStopPrg([in] short iProgIC,[in] short iStopMode) | IRbtlkFile
cmdUpload([in] short sFileID,[in] short sBlockNo,[in] BSTR bstrData) | IRbtlkFile
cmdUpload0([in] short sFileID,[in] short sBlockNo,[in] BSTR bstrData) | IRbtlkFile
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

IRbtlkIO メンバ一覧

これは全メンバの一覧です。IRbtlkIO継承メンバも含んでいます。
cmdChangeLabel([in] short sPlateNo,[in] short sButtonNo,[in] CHAR *newVal) | IRbtlkIO
cmdDin([in] short sIndex,[out] BOOL *pVal) | IRbtlkIO
cmdDin16([in] short sIndex,[out] short *pVal) | IRbtlkIO
cmdDin8([in] short sIndex,[out] short *pVal) | IRbtlkIO
cmdDout([in] short sIndex,[in] BOOL newVal) | IRbtlkIO
cmdDout16([in] short sIndex,[in] short newVal) | IRbtlkIO
cmdDout8([in] short sIndex,[in] short newVal) | IRbtlkIO
cmdDummy([in] short sIndex,[in] short newVal) | IRbtlkIO
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

IRbtlkTask メンバ一覧

これは全メンバの一覧です。IRbtlkTask継承メンバも含んでいます。
cmdContPrgStatus([in] short sPrgIC,[out] short *pStatus,[out] short *pPriority,[out] short *pInterval,[out] short *pLineNo,[out] short *pIOBlock,[out] short *pMode,[out] long *pCT) | IRbtlkTask
cmdGetPrgList([in] short sIndex,[out] short *newVal,[out] CHAR *szName) | IRbtlkTask
cmdGetPrgListLen([out] short *newVal) | IRbtlkTask
cmdGetTaskStatus([in] short sPrgIC,[out] short *pStatus) | IRbtlkTask
RTK_IP_RSTKSIZE Enum 値 | IRbtlkTask
RTK_IP_TASKNUM Enum 値 | IRbtlkTask
RTK_ITP_CONF Enum | IRbtlkTask
RTK_PAC_CONF Enum | IRbtlkTask
RTK_PC_LANG_MODE Enum 値 | IRbtlkTask
RTK_PC_ROBOTTYPE Enum 値 | IRbtlkTask
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

IRbtlkVariable メンバ一覧

これは全メンバの一覧です。IRbtlkVariable継承メンバも含んでいます。
cmdGetD([in] short sIC,[in] short sIndex,[out] double *pVal) | IRbtlkVariable
cmdGetDefIO([in] short sPort,[in] short sType,[in] long lMask,[out] long *pVal) | IRbtlkVariable
cmdGetF([in] short sIC,[in] short sIndex,[out] float *pVal) | IRbtlkVariable
cmdGetI([in] short sIC,[in] short sIndex,[out] long *pVal) | IRbtlkVariable
cmdGetJ([in] short sIC,[in] short sIndex,[out] float *pVal) | IRbtlkVariable
cmdGetP([in] short sIC,[in] short sIndex,[out] float *pVal) | IRbtlkVariable
cmdGetS([in] short sIC,[in] short sIndex,[out] CHAR *pVal) | IRbtlkVariable
cmdGetT([in] short sIC,[in] short sIndex,[out] float *pVal) | IRbtlkVariable
cmdGetTabLen([in] short sPrgIC,[in] short sTypeIC,[out] short *pVal) | IRbtlkVariable
cmdGetV([in] short sIC,[in] short sIndex,[out] float *pVal) | IRbtlkVariable
cmdLetD([in] short sIC,[in] short sIndex,[in] double newVal) | IRbtlkVariable
cmdLetDefIO([in] short sPort,[in] short sType,[in] long lMask,[in] long lVal) | IRbtlkVariable
cmdLetF([in] short sIC,[in] short sIndex,[in] float newVal) | IRbtlkVariable
cmdLetI([in] short sIC,[in] short sIndex,[in] long newVal) | IRbtlkVariable
cmdLetJ([in] short sIC,[in] short sIndex,[in] float *newVal) | IRbtlkVariable
cmdLetP([in] short sIC,[in] short sIndex,[in] float *newVal) | IRbtlkVariable
cmdLetS([in] short sIC,[in] short sIndex,[in] CHAR *newVal) | IRbtlkVariable
cmdLetT([in] short sIC,[in] short sIndex,[in] float *newVal) | IRbtlkVariable
cmdLetV([in] short sIC,[in] short sIndex,[in] float *newVal) | IRbtlkVariable
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkArm.h Source File

RbtlkArm.h

解説を見る。
00001
00011 #ifndef __RBTLKARM_H_
00012 #define __RBTLKARM_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include "RbtlkEngine.h"
00016
00018 // CRbtlkArm
00019 class ATL_NO_VTABLE CRbtlkArm :
00020     public CComObjectRootEx<CComMultiThreadModel>,
00021     public CComCoClass<CRbtlkArm, &CLSID_RbtlkArm>,
00022     public ISupportErrorInfo,
00023     public IRbtlkArm
00024 {
00025 public:
00026     CRbtlkArm()
00027     {
00028     }
00029
00030 //DECLARE_REGISTRY_RESOURCEID(IDR_RBTLKARM)
00031
00032 DECLARE_PROTECT_FINAL_CONSTRUCT()
00033
00034 BEGIN_COM_MAP(CRbtlkArm)
00035     COM_INTERFACE_ENTRY(IRbtlkArm)
00036     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00037 END_COM_MAP()
00038
00039 // ISupportsErrorInfo
00040     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00041
00042 // FinalConstruct / FinalRelease
00043     HRESULT FinalConstruct();
00044     void FinalRelease();
00045
00046 // IRbtlkArm
00047 public:
00048     STDMETHOD(cmdThere)(/*[out]*/ float *pVal);
00049     STDMETHOD(cmdGetWorkIndex)(/*[out]*/ short *pVal);
00050     STDMETHOD(cmdGetToolIndex)(/*[out]*/ short *pVal);
00051     STDMETHOD(cmdLetAreaEx)(/*[in]*/ short sNo, /*[in]*/ float *pf, /*[in]*/ short sIO, /*[in]*/ short sPos, /*[in]*/ short sErr, /*[in]*/ short sEnable);
00052     STDMETHOD(cmdGetAreaEx)(/*[in]*/ short sNo, /*[out]*/ float *pf, /*[out]*/ short *psIO, /*[out]*/ short *psPos, /*[out]*/ short *psErr, /*[out]*/ short *psEnable);
00053     STDMETHOD(cmdLetArea)(/*[in]*/ short sNo, /*[in]*/ float *pf, /*[in]*/ short sIO, /*[in]*/ short sPos );
00054     STDMETHOD(cmdGetArea)(/*[in]*/ short sNo, /*[out]*/ float *pf, /*[out]*/ short *psIO, /*[out]*/ short *psPos);
00055     STDMETHOD(cmdLetWork)(/*[in]*/ short sNo, /*[in]*/ float *pf);
00056     STDMETHOD(cmdGetWork)(/*[in]*/ short sNo, /*[out]*/ float *pf);
00057     STDMETHOD(cmdLetTool)(/*[in]*/ short sNo, /*[in]*/ float *pf);
00058     STDMETHOD(cmdGetTool)(/*[in]*/ short sNo, /*[out]*/ float *pf);
00059     STDMETHOD(cmdJHere)(/*[out]*/ float *pVal);
00060     STDMETHOD(cmdHere)(/*[out]*/ float *pVal);
00061     STDMETHOD(cmdEnableArea)(/*[in]*/ short sNo);
00062     STDMETHOD(cmdDisableArea)(/*[in]*/ short sNo);
00063
00064     HRESULT Initialize(CRbtlkEngine *pIRbtlkEng);
00065
00066 private:
00067     CRbtlkEngine *m_pCRbtlkEng; // RbtlkEngineのポインタ
00068
00069 };
00070
00071 #endif //__RBTLKARM_H_
Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkController.h Source File

RbtlkController.h

解説を見る。
00001
00011 #ifndef __RBTLKCONTROLLER_H_
00012 #define __RBTLKCONTROLLER_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include "RbtlkEngine.h"
00016
00018 // CRbtlkController
00019 class ATL_NO_VTABLE CRbtlkController :
00020     public CComObjectRootEx<CComMultiThreadModel>,
00021     public CComCoClass<CRbtlkController, &CLSID_RbtlkController>,
00022     public ISupportErrorInfo,
00023     public IRbtlkController
00024 {
00025 public:
00026     CRbtlkController()
00027     {
00028     }
00029
00030 //DECLARE_REGISTRY_RESOURCEID(IDR_RBTLKCONTROLLER)
00031
00032 DECLARE_PROTECT_FINAL_CONSTRUCT()
00033
00034 BEGIN_COM_MAP(CRbtlkController)
00035     COM_INTERFACE_ENTRY(IRbtlkController)
00036     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00037 END_COM_MAP()
00038
00039 // ISupportsErrorInfo
00040     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00041
00042 // FinalConstruct / FinalRelease
00043     HRESULT FinalConstruct();
00044     void FinalRelease();
00045
00046 // IRbtlkController
00047 public:
00048     STDMETHOD(cmdSetOption)(/*[in]*/ short sMode, /*[in]*/ long lKey, /*[out]*/ CHAR *pVal);
00049     STDMETHOD(cmdGetControlLog)(/*[in]*/ short sIndex, /*[out]*/ float pData[8][4], /*[out]*/ float *pReg, /*[out]*/ short *pProgNo, /*[out]*/ short *pLineNo);
00050     STDMETHOD(cmdGetErrorLog)(/*[in]*/ short sIndex, /*[out]*/ short *pCode, /*[out]*/ short *pLevel, /*[out]*/ CHAR *szDate, /*[out]*/ CHAR *szTime, /*[out]*/ CHAR *szModule, /*[out]*/ CHAR *szMsg);
00051     STDMETHOD(cmdGetOperationLog)(/*[in]*/ short sIndex, /*[out]*/ short *pCode, /*[out]*/ CHAR *szDate, /*[out]*/ CHAR *szTime, /*[out]*/ CHAR *szModule, /*[out]*/ CHAR *szMsg);
00052     STDMETHOD(cmdClearError)(/*[in]*/ long lErrCode, /*[out]*/ short *pVal);
00053     STDMETHOD(cmdGetErrorCode)(/*[out]*/ long *pVal);
00054     STDMETHOD(cmdSrvJointCancel)();
00055     STDMETHOD(cmdSrvJointData)(/*[in]*/ short sOffset, /*[in]*/ short sCounts, /*[out]*/ float **pData1, /*[out]*/ float **pData2);
00056     STDMETHOD(cmdSrvJointParam)(/*[out]*/ short *pJoint, /*[out]*/ short *pInterval, /*[out]*/ short *pCounts, /*[out]*/ short *pData1, /*[out]*/ short *pData2);
00057     STDMETHOD(cmdDoSignal)(/*[in]*/ short sMode, /*[in]*/ short sAction);
00058     STDMETHOD(cmdNoticeRomVersion)(/*[in]*/ short sVer);
00059     STDMETHOD(cmdRequestRomUpdate)();
00060     STDMETHOD(cmdGetTransMode)(/*[out]*/ short *pTransMode);
00061     STDMETHOD(cmdRequestFileSave)(/*[out]*/ short *pTransMode, long *pTaskID);
00062     STDMETHOD(cmdLetJobStatus)(/*[in]*/ long JobID, /*[in]*/ short sStatus);
00063     STDMETHOD(cmdGetJobStatus)(/*[in]*/ long JobID, /*[out]*/ short* pStatus);
00064     STDMETHOD(cmdGetJointInfo)(/*[in]*/ short sMode, /*[out]*/ short* pVal);
00065     STDMETHOD(cmdGetRobotType)(/*[out]*/ long *pVal);
00066     STDMETHOD(cmdGetFreeMemory)(/*[out]*/ long *pVal);
00067     STDMETHOD(cmdGetVersions)(/*[in]*/ short sIndex, /*[out]*/ CHAR *pVal);
00068     STDMETHOD(cmdGetDateTime)(/*[out]*/ short *psDateTime);
00069     STDMETHOD(cmdLetDateTime)(/*[in]*/ short *psDateTime);
00070     STDMETHOD(cmdClearCtrlLog)();
00071     STDMETHOD(cmdStartCtrlLog)();
00072     STDMETHOD(cmdStopCtrlLog)();
00073     STDMETHOD(cmdGetParamCtrlLog)(/*[out]*/ long *pSmpCnt, /*[out]*/ long *pSmpRate);
00074     STDMETHOD(cmdSwitchCtrlLog)(/*[in]*/ short sMode);
00075     STDMETHOD(cmdCancelCtrlLog)();
00076     STDMETHOD(cmdGetMode)(/*[out]*/ short* pVal );
00077     STDMETHOD(cmdSetMode)(/*[in]*/ short iMode );
00078     STDMETHOD(cmdChangeConfig)(/*[in]*/ short sMode);
00079     STDMETHOD(cmdLetConfig)(/*[in]*/ short sMode, /*[in]*/ short sIndex, /*[in]*/ long newVal);
00080     STDMETHOD(cmdGetConfig)(/*[in]*/ short sMode, /*[in]*/ short sIndex, /*[out]*/ long *pVal);
00081     STDMETHOD(cmdGetStatus)(/*[in]*/ short sModule, /*[in]*/ short sIndex, /*[out]*/ short *pVal);
00082
00083     HRESULT Initialize(CRbtlkEngine *pIRbtlkEng);
00084
00085 private:
00086     CRbtlkEngine *m_pCRbtlkEng; // RbtlkEngineのポインタ
00087
00088 };
00089
00090 #endif //__RBTLKCONTROLLER_H_
Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkEngine.h Source File

RbtlkEngine.h

解説を見る。
00001
00011 #ifndef __RBTLKENGINE_H_
00012 #define __RBTLKENGINE_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015
00016 #include "Serial.h"
00017 #include "EtherUDP.h"
00018
00019 #include "ROBOTalk.h"
00020
00022 // CRbtlkEngine
00023 class ATL_NO_VTABLE CRbtlkEngine :
00024     public CComObjectRootEx<CComMultiThreadModel>,
00025     public CComCoClass<CRbtlkEngine, &CLSID_RbtlkEngine>,
00026     public ISupportErrorInfo,
00027     public IRbtlkEngine
00028 {
00029 public:
00030     CRbtlkEngine()
00031     {
00032         // 要素の初期値を設定する
00033         m_sVarCtrlSize  = 8;        // 軸の要素数
00034         m_sVarVecSize   = 3;        // ベクトルの要素数
00035         m_sVarPosSize   = 7;        // ポーズの要素数
00036         m_sVarJntSize   = 6;        // ジョイントの要素数
00037         m_sVarTrnSize   = 10;       // Trnの要素数
00038
00039         m_dwRbtlkDevice     = 0;
00040         m_dwRbtlkTimer      = 0;
00041         m_hrLast            = S_OK;
00042
00044         m_hMutex            = NULL;
00045
00047         m_dwRbtlkTimer      = 3000L;    // 1秒
00048
00050         m_lRbtlkTOutRetry   = 3L;       // タイムアウト発生時(MAX=7)
00051         m_lRbtlkRetry       = 3L;       // NAK回答発生時
00052
00053         // DisconnectServer() 完了処理フラグ初期化
00054         m_bDisconnected = TRUE;
00055
00056         // 接続コントローラのバージョン初期化
00057         m_dVersion = 0.0;
00058     }
00059
00060 DECLARE_REGISTRY_RESOURCEID(IDR_RBTLKENGINE)
00061
00062 DECLARE_PROTECT_FINAL_CONSTRUCT()
00063
00064 BEGIN_COM_MAP(CRbtlkEngine)
00065     COM_INTERFACE_ENTRY(IRbtlkEngine)
00066     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00067 END_COM_MAP()
00068
00069 // ISupportsErrorInfo
00070     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00071
00072 // FinalConstruct / FinalRelease
00073     HRESULT FinalConstruct();
00074     void FinalRelease();
00075
00076 // IRbtlkEngine
00077 public:
00078     STDMETHOD(ConnectServer)(/*[in]*/ char *szPara);
00079     STDMETHOD(DisconnectServer)();
00080     STDMETHOD(get_RbtlkController)(/*[out, retval]*/ IRbtlkController **ppVal);
00081     STDMETHOD(get_RbtlkFile)(/*[out, retval]*/ IRbtlkFile **ppVal);
00082     STDMETHOD(get_RbtlkTask)(/*[out, retval]*/ IRbtlkTask **ppVal);
00083     STDMETHOD(get_RbtlkIO)(/*[out, retval]*/ IRbtlkIO **ppVal);
00084     STDMETHOD(get_RbtlkArm)(/*[out, retval]*/ IRbtlkArm **ppVal);
00085     STDMETHOD(get_RbtlkVariable)(/*[out, retval]*/ IRbtlkVariable **ppVal);
00086
00087     STDMETHOD(Cancel)();
00088     STDMETHOD(GetVarInfo)(/*[in]*/ CHAR *szVar, /*[out]*/ short *sType, /*[out]*/ short *sIndex );
00089
00090     STDMETHOD(get_TimeOutRetry)(/*[out, retval]*/ long *pVal);
00091     STDMETHOD(put_TimeOutRetry)(/*[in]*/ long newVal);
00092     STDMETHOD(get_TimeOut)(/*[out, retval]*/ long *pVal);
00093     STDMETHOD(put_TimeOut)(/*[in]*/ long newVal);
00094     STDMETHOD(get_NakRetry)(/*[out, retval]*/ long *pVal);
00095     STDMETHOD(put_NakRetry)(/*[in]*/ long newVal);
00096     STDMETHOD(get_LastError)(/*[out, retval]*/ long *pVal);
00097     STDMETHOD(get_Version)(/*[out, retval]*/ double *pVal);
00098
00099     HRESULT ByteToBSTR(/*[in]*/ unsigned char *from,/*[in]*/ int fsz, /*[out]*/ int *flen, /*[out]*/ BSTR *to);
00100     HRESULT BSTRToByte(/*[in]*/ BSTR *from, /*[out]*/ unsigned char *to,/*[in]*/ int tsz, /*[out]*/ int *tlen);
00101     HRESULT ByteToSingle(/*[in]*/ unsigned char *from, /*[out]*/ float *to);
00102     HRESULT SingleToByte(/*[in]*/ float *from, /*[in]*/ unsigned char *to);
00103     HRESULT ByteToDouble(/*[in]*/ unsigned char *from, /*[out]*/ double *to);
00104     HRESULT DoubleToByte(/*[in]*/ double *from, /*[in]*/ unsigned char *to);
00105     HRESULT ByteToLong(/*[in]*/ unsigned char *from, /*[out]*/long *to);
00106     HRESULT LongToByte(/*[in]*/ long *from, /*[in]*/ unsigned char *to);
00107     HRESULT ByteToShort(/*[in]*/ unsigned char *from, /*[out]*/ short *to);
00108     HRESULT ShortToByte(/*[in]*/ short *from, /*[in]*/ unsigned char *to);
00109
00110     HRESULT SendWithWait(RTK_PACKET *sndPck, RTK_PACKET *recPck);
00111     HRESULT SendWithWaitA(RTK_PACKET *sndPck, RTK_PACKET *recPck);
00112     HRESULT GetVarTabSize(/*[in]*/ short sTabIndex, /*[out, retval]*/ short *pVal);
00113
00114 private:
00115     HRESULT ConnectEther(char *szPara);
00116     HRESULT ConnectRS232C(char *szPara);
00117     HRESULT FinalDisconnect();
00118
00119     HRESULT ParseSerialParameter(char *szParam, SerialParam *pParam);
00120     HRESULT ParseEtherParameter(char *szParam, EtherParam *pParam);
00121
00122     HRESULT SendPacket(RTK_PACKET *sndPck);
00123     HRESULT ReceivePacket(RTK_PACKET *recPck, long lRetryT);
00124     HRESULT SendNAK();
00125
00126     HRESULT GetVarIndex(CHAR *pszVar, DWORD dwStrLen, long *retVal);
00127
00128 // データメンバ
00129 private:
00130     // インターフェイスポインタ
00131     IRbtlkController    *m_pIRbtlkCtrl;     // RbtlkControllerインターフェイスポインタ
00132     IRbtlkVariable      *m_pIRbtlkVar;      // RbtlkVariableインターフェイスポインタ
00133     IRbtlkArm           *m_pIRbtlkArm;      // RbtlkArmインターフェイスポインタ
00134     IRbtlkIO            *m_pIRbtlkIO;       // RbtlkIOインターフェイスポインタ
00135     IRbtlkTask          *m_pIRbtlkTask;     // RbtlkTaskインターフェイスポインタ
00136     IRbtlkFile          *m_pIRbtlkFile;     // RbtlkFileインターフェイスポインタ
00137
00138     bool m_bDisconnected;                       // DiscommectServer() 処理を行ったかの判定フラグ
00139                                                 // 注意が必要！！
00140     // ROBOTalkデータ
00141     short m_sVarCtrlSize;               // 軸の要素数
00142     short m_sVarVecSize;                // ベクトルの要素数
00143     short m_sVarPosSize;                // ポーズの要素数
00144     short m_sVarJntSize;                // ジョイントの要素数
00145     short m_sVarTrnSize;                // 同次変換型の要素数
00146     double m_dVersion;                  // 接続コントローラのバージョン
00147
00148     WORD        m_wCancelFlag;          // Ctrl::Cancelメソッド用フラグ
00149
00150     CDevice     *m_pDevice;             // デバイスオブジェクトへのポインタ
00151
00152     HANDLE      m_hMutex;               // ミューテックスハンドル
00153     WORD        m_dwRbtlkDevice;        // 0:接続なし，1:RS-232C, 2:公衆回線 3:Ethernet
00154     DWORD       m_dwRbtlkTimer;         // タイムアウト値 ミリ秒
00155     long        m_lRbtlkTOutRetry;      // コントローラとのリトライ数（Time Out）
00156     long        m_lRbtlkRetry;          // コントローラとのリトライ数（NAK）
00157     HRESULT     m_hrLast;               // 最新のリターンコード
00158     BYTE        m_bytID;                // ROBOTalk の送信元ID
00159
00160 };
00161
00162 #endif //__RBTLKENGINE_H_
Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkFile.h Source File

RbtlkFile.h

解説を見る。
00001
00011 #ifndef __RBTLKFILE_H_
00012 #define __RBTLKFILE_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include "RbtlkEngine.h"
00016
00017 #define RBTLK_DEFAULT_PATH  ("/rom/prj")
00018
00020 // CRbtlkFile
00021 class ATL_NO_VTABLE CRbtlkFile :
00022     public CComObjectRootEx<CComMultiThreadModel>,
00023     public CComCoClass<CRbtlkFile, &CLSID_RbtlkFile>,
00024     public ISupportErrorInfo,
00025     public IRbtlkFile
00026 {
00027 public:
00028     CRbtlkFile()
00029     {
00030     }
00031
00032 //DECLARE_REGISTRY_RESOURCEID(IDR_RBTLKFILE)
00033
00034 DECLARE_PROTECT_FINAL_CONSTRUCT()
00035
00036 BEGIN_COM_MAP(CRbtlkFile)
00037     COM_INTERFACE_ENTRY(IRbtlkFile)
00038     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00039 END_COM_MAP()
00040
00041 // ISupportsErrorInfo
00042     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00043
00044 // FinalConstruct / FinalRelease
00045     HRESULT FinalConstruct();
00046     void FinalRelease();
00047
00048 // IRbtlkFile
00049 public:
00050     STDMETHOD(cmdGetFileName0)(/*[in]*/ short sIndex, /*[out]*/ CHAR* pVal);
00051     STDMETHOD(cmdGetFileCnt0)(/*[out]*/ short* psFiles);
00052     STDMETHOD(cmdDeleteFile0)(/*[in]*/ CHAR *szName);
00053     STDMETHOD(cmdGetProgramIndex)(/*[in]*/ CHAR *szName, /*[out]*/short* pVal );
00054     STDMETHOD(cmdRequestUpload0)(/*[in]*/ short sBlocks, /*[in]*/ long lSize, /*[in]*/ CHAR *szName, /*[in]*/ CHAR *szAttribute, /*[in]*/ CHAR *szUsage, /*[out]*/ short *psFileID);
00055     STDMETHOD(cmdRequestDownload0)(/*[in]*/ CHAR *szName, /*[out]*/ short *psFileID, /*[out]*/ short *psBlocks, /*[out]*/ long *plSize, /*[out]*/ CHAR *szAttribute, /*[out]*/ CHAR *szUsage);
00056     STDMETHOD(cmdUpload0)(/*[in]*/ short sFileID, /*[in]*/ short sBlockNo, /*[in]*/ BSTR bstrData );
00057     STDMETHOD(cmdDownload0)(/*[in]*/ short sFileID, /*[out]*/ short* psFileID, /*[out]*/ short* psBlockNo, /*[out]*/ BSTR* pbstrData);
00058     STDMETHOD(cmdCancelUpload0)(/*[in]*/ short sFileID);
00059     STDMETHOD(cmdCancelDownload0)(/*[in]*/ short sFileID);
00060     STDMETHOD(cmdLoadNic)(/*[out]*/ long *pID);
00061     STDMETHOD(cmdFileUploadStart)();
00062     STDMETHOD(cmdFileUploadEnd)();
00063     STDMETHOD(cmdRequestUpload)(/*[in]*/ short sBlocks, /*[in]*/ long lSize, /*[in]*/ short sFileProp, /*[in]*/ short sFileFlag, /*[in]*/ CHAR *szName, /*[out]*/ short *psFileID);
00064     STDMETHOD(cmdRequestDownload)(/*[in]*/ short sFileFlag, /*[in]*/ CHAR *szName, /*[out]*/ short *psFileID, /*[out]*/ short *psBlocks, /*[out]*/ short* psFileProp, /*[out]*/ long *plSize);
00065     STDMETHOD(cmdUpload)(/*[in]*/ short sFileID, /*[in]*/short sBlockNo, /*[in]*/BSTR bstrData);
00066     STDMETHOD(cmdDownload)(/*[in]*/ short sFileID, /*[out]*/ short* psFileID, /*[out]*/ short *psBlockNo, /*[out]*/ BSTR *pbstrData);
00067     STDMETHOD(cmdCancelUpload)(/*[in]*/ short sFileID);
00068     STDMETHOD(cmdCancelDownload)(/*[in]*/ short psFileID);
00069     STDMETHOD(cmdDeleteFile)(/*[in]*/ CHAR *szName);
00070     STDMETHOD(cmdCopyFile)(/*[in]*/ CHAR *szFrom, /*[in]*/ CHAR *szTo );
00071     STDMETHOD(cmdMoveFile)(/*[in]*/ CHAR *szFrom, /*[in]*/ CHAR *szTo );
00072     STDMETHOD(cmdGetFileCnt)(/*[in]*/ CHAR *szName, /*[out]*/ short* psFiles);
00073     STDMETHOD(cmdGetFileName)(/*[in]*/ short sIndex, /*[in]*/ CHAR *szDirName, /*[out]*/ CHAR *pVal);
00074     STDMETHOD(cmdGetAttributes)(/*[in]*/ short iSystem, /*[in]*/ CHAR *szName, /*[out]*/ long* pVal);
00075     STDMETHOD(cmdGetDataCreated)(/*[in]*/ short iSystem, /*[in]*/ CHAR *szName, /*[out]*/ short* pDateTime);
00076     STDMETHOD(cmdGetLastModified)(/*[in]*/ short iSystem, /*[in]*/ CHAR *szName, /*[out]*/ short* pDateTime);
00077     STDMETHOD(cmdGetLastAccessed)(/*[in]*/ short iSystem, /*[in]*/ CHAR *szName, /*[out]*/ short* pDateTime);
00078     STDMETHOD(cmdGetSize)(/*[in]*/ short iSystem, /*[in]*/ CHAR *szName, /*[out]*/ long* pVal);
00079     STDMETHOD(cmdStartPrg)(/*[in]*/ short iProgIC, /*[in]*/short iStartMode );
00080     STDMETHOD(cmdStopPrg)(/*[in]*/ short iProgIC, /*[in]*/short iStopMode );
00081     STDMETHOD(cmdGetProgramIC)(/*[in]*/ CHAR *szName, /*[out]*/short* pVal );
00082     STDMETHOD(cmdStepForward)(/*[in]*/ short iProgIC );
00083     STDMETHOD(cmdStepBackward)(/*[in]*/ short iProgIC );
00084     STDMETHOD(cmdLetStartLine)(/*[in]*/ short iLineNo, /*[in]*/ short iProgIC, /*[out]*/ short* pVal );
00085     STDMETHOD(cmdKillProg)(/*[in]*/ short iActMode, /*[in]*/ short iProgIC );
00086
00087     HRESULT Initialize(CRbtlkEngine *pIRbtlkEng);
00088
00089 private:
00090     CRbtlkEngine *m_pCRbtlkEng; // RbtlkEngineのポインタ
00091
00092 };
00093
00094 #endif //__RBTLKFILE_H_
Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkHeader.h Source File

RbtlkHeader.h

解説を見る。
00001 // @(h) RbtlkHeader.h       ver 0.5 ( '02.07.25 Yukishige FUKAYA )
00002 // @(h) RbtlkHeader.h       ver 0.4 ( '02.07.17 Yukishige FUKAYA )
00003 // @(h) RbtlkHeader.h       ver 0.3 ( '01.06.20 Yukishige FUKAYA )
00004 // @(h) RbtlkHeader.h       ver 0.1 ( '99.08.30 Hisanao SAKAKIBARA )
00005
00006 // @(s)
00007 //  ROBOTalk用 宣言
00008 //
00009
00010 #ifndef _RBTLKHEADER_H_
00011 #define _RBTLKHEADER_H_
00012
00013 // ========== ロボット座標軸要素数 ==========
00014 typedef enum {
00015     RTK_VEC_SIZE = 8,   // ベクトルの要素数
00016     RTK_POS_SIZE = 9,   // ポーズの要素数
00017     RTK_JNT_SIZE = 10,  // ジョイントの要素数
00018     RTK_TRN_SIZE = 11,  // ???の要素数
00019     RTK_CTRL_SIZE = 12  // ???の要素数  追加
00020 } RTK_INDEX_SIZE;
00021
00022 // ========== ROBOTalk パケット ==========
00023 typedef enum {
00024     RTK_HEAD_LEN        = 6,        // パケットヘッダ長
00025     RTK_DATA_MAXLEN     = 248,      // ROBOTalk データ領域 最大データ長
00026     RTK_PACKET_MAXLEN   = 256,      // 通信プロトコル パケット最大データ長
00027     RTK_SUM_LEN         = 2,        // パケットサム長
00028
00029     RTK_ENQ_PTR         = 0,        // スタートコードの位置
00030     RTK_LEN_PTR         = 1,        // データ領域の長さ情報の位置
00031     RTK_CMD_PTR         = 2,        // コマンドの位置
00032     RTK_ID1_PTR         = 4,        // 発信元情報の位置
00033     RTK_ID2_PTR         = 5,        // 送信先情報の位置
00034     RTK_DAT_PTR         = 6,        // データ領域の位置
00035
00036     // ROBOTalk パケット内コード
00037     RTK_ENQ             = 0x05,     // ENQコード
00038 } RTK_PACKET_LEN;
00039
00040 // ========== パケット送信メディア ==========
00041 typedef enum {
00042     RTK_DEV_NON         = 0,        // 未設定
00043     RTK_DEV_COM         = 1,        // RS-232C
00044     RTK_DEV_TEL         = 2,        // 公衆回線
00045     RTK_DEV_ETH         = 3,        // Ethernet
00046 } RTK_DEVICE;
00047
00048 // ========== ROBOTalk コマンド ==========
00049 typedef enum {
00050     // Retry
00051     RTK_CMD_OR              = 0x1000,   // リトライ時 コマンド
00052     RTK_CMD_AND             = 0x0FFF,   // リトライ時 コマンド マスク
00053
00054     // System & Log Manager
00055     RTK_CMD_REJ             = 0x0E01,
00056     RTK_CMD_ACK             = 0x0E02,
00057     RTK_CMD_NAK             = 0x0E82,
00058
00059     RTK_CMD_GETDATETIME     = 0x0E20,
00060     RTK_CMD_LETDATETIME     = 0x0E21,
00061     RTK_CMD_GETFREEMEM      = 0x0E22,
00062
00063     RTK_CMD_GETOPELOG       = 0x0E50,
00064     RTK_CMD_GETERRLOG       = 0x0E51,
00065     RTK_CMD_GETCTRLLOG      = 0x0E52,
00066
00067     RTK_CMD_CLEARCTRLLOG    = 0x0E60,
00068     RTK_CMD_STARTCTRLLOG    = 0x0E61,
00069     RTK_CMD_STOPCTRLLOG     = 0x0E62,
00070     RTK_CMD_FLUSHCTRLLOG    = 0x0E63,
00071     RTK_CMD_GETPARAMCTRLLOG = 0x0E64,   // ver 0.5
00072     RTK_CMD_SWITCHCTRLLOG   = 0x0E65,
00073     RTK_CMD_CANCELCTRLLOG   = 0x0E66,
00074
00075     RTK_CMD_GETSTATUS       = 0x0E70,
00076     RTK_CMD_LETSTATUS       = 0x0E71,
00077     RTK_CMD_GETCONFIG       = 0x0E72,
00078     RTK_CMD_LETCONFIG       = 0x0E73,
00079     RTK_CMD_CHANGECONFIG    = 0x0E74,
00080     RTK_CMD_GETVERSIONS     = 0x0E75,
00081     RTK_CMD_GETROBOTTYPE    = 0x0E76,
00082
00083     RTK_CMD_SRVJOINTPARAM   = 0x0E78,
00084     RTK_CMD_SRVJOINTDATA    = 0x0E79,
00085     RTK_CMD_SRVJOINTCANCEL  = 0x0E7A,
00086     RTK_CMD_GETJOINTINFO    = 0x0E7B,
00087
00088     RTK_CMD_SETMODE         = 0x0E80,
00089     RTK_CMD_GETMODE         = 0x0E81,
00090
00091     RTK_CMD_GETJOBSTATUS    = 0x0E90,
00092     RTK_CMD_LETJOBSTATUS    = 0x0E91,
00093
00094     RTK_CMD_CLEARERROR      = 0x0EB0,
00095     RTK_CMD_GETERROR        = 0x0EB1,
00096
00097     RTK_CMD_REQUESTFILESAVE = 0x0EFA,
00098
00099     RTK_CMD_GETTRANSMODE    = 0x0EFB,
00100
00101     RTK_CMD_REQUESTROMUPDATE= 0x0EFC,
00102     RTK_CMD_NOTICEROMVERSION= 0x0EFD,
00103
00104     RTK_CMD_DOSIGNAL        = 0x0EFE,
00105
00106     RTK_CMD_SETOPTION       = 0x0EFF,   // Ver 0.4
00107
00108     RTK_CMD_COMCNF          = 0x0001,
00109     RTK_CMD_ARMCNF          = 0x0002,
00110     RTK_CMD_VISCNF          = 0x0003,
00111     RTK_CMD_PACCNF          = 0x0004,
00112     RTK_CMD_SRVCNF          = 0x0005,
00113     RTK_CMD_SPDCNF          = 0x0006,
00114     RTK_CMD_ITPCNF          = 0x0007,
00115     RTK_CMD_DIOCNF          = 0x0008,
00116     RTK_CMD_SYSCNF          = 0x0009,
00117
00118     // PAC Manager
00119     RTK_CMD_REQUESTUPLOAD0          = 0x0D00,
00120     RTK_CMD_UPLOAD0                 = 0x0D01,
00121     RTK_CMD_CANCELUPLOAD0           = 0x0D02,
00122     RTK_CMD_REQUESTDOWNLOAD0        = 0x0D10,
00123     RTK_CMD_DOWNLOAD0               = 0x0D11,
00124     RTK_CMD_CANCELDOWNLOAD0         = 0x0D12,
00125
00126     RTK_CMD_REQUESTUPLOAD           = 0x0D03,
00127     RTK_CMD_UPLOAD                  = 0x0D04,
00128     RTK_CMD_CANCELUPLOAD            = 0x0D05,
00129     RTK_CMD_REQUESTDOWNLOAD         = 0x0D13,
00130     RTK_CMD_DOWNLOAD                = 0x0D14,
00131     RTK_CMD_CANCELDOWNLOAD          = 0x0D15,
00132
00133     RTK_CMD_DELFILE0                = 0x0D22,   // Ver 0.4 (互換維持用)
00134     RTK_CMD_DELFILE                 = 0x0D25,
00135     RTK_CMD_COPYFILE                = 0x0D26,
00136     RTK_CMD_MOVEFILE                = 0x0D27,
00137
00138 //  RTK_CMD_GETPRGCNT               = 0x0D30,
00139 //  RTK_CMD_GETPRGNAME              = 0x0D31,
00140     RTK_CMD_GETFILECNT0             = 0x0D32,   // Ver 0.4 (互換維持用) <- 0x0D72
00141     RTK_CMD_GETFILENAME0            = 0x0D33,   // Ver 0.4 (互換維持用) <- 0x0D73
00142 //  RTK_CMD_GETPRGSTATUS0           = 0x0D34,   // Ver 0.4 不要:RTK_CMD_GETPRGSTATUSで代用
00143     RTK_CMD_GETPRGSTATUS            = 0x0D35,
00144     RTK_CMD_LOADNIC                 = 0x0D40,
00145     RTK_CMD_STARTPRG                = 0x0D41,
00146     RTK_CMD_STOPPRG                 = 0x0D42,
00147     RTK_CMD_STEPFORWARD             = 0x0D43,
00148     RTK_CMD_STEPBACKWARD            = 0x0D44,
00149     RTK_CMD_PUTSTARTLINE            = 0x0D47,
00150     RTK_CMD_KILLPROG                = 0x0D48,
00151     RTK_CMD_GETPROGINDEX            = 0x0D50,   // Ver 0.4 (INDEX取得用)
00152     RTK_CMD_GETPROGIC               = 0x0D51,
00153     RTK_CMD_FILEUPLOADSTART         = 0x0D60,
00154     RTK_CMD_FILEUPLOADEND           = 0x0D61,
00155
00156     RTK_CMD_GETFILECNT              = 0x0D72,   // Ver 0.4 RTK_CMD_FILECNT -> RTK_CMD_GETFILECNT
00157     RTK_CMD_GETFILENAME             = 0x0D73,   // Ver 0.4 RTK_CMD_FILENAME -> RTK_CMD_GETFILENAME
00158
00159     RTK_CMD_GETATTRB            = 0x0D74,
00160     RTK_CMD_GETDATACREATED      = 0x0D75,
00161     RTK_CMD_GETLASTMODIFIED     = 0x0D76,
00162     RTK_CMD_GETLASTACCESSED     = 0x0D77,
00163     RTK_CMD_GETFILESIZE         = 0x0D78,
00164
00165     RTK_CMD_GETPRGLISTLEN   = 0x0800,
00166     RTK_CMD_GETPRGLIST      = 0x0801,
00167     RTK_CMD_GETTASKSTATUS   = 0x0802,
00168
00169     // Variable
00170     RTK_CMD_GETTABLEN       = 0x0904,
00171     RTK_CMD_GETINTVAR       = 0x0910,
00172     RTK_CMD_GETSNGVAR       = 0x0911,
00173     RTK_CMD_GETDBLVAR       = 0x0912,
00174     RTK_CMD_GETSTRVAR       = 0x0913,
00175     RTK_CMD_GETPOSVAR       = 0x0914,
00176     RTK_CMD_GETJNTVAR       = 0x0915,
00177     RTK_CMD_GETTRNVAR       = 0x0916,
00178     RTK_CMD_GETVECVAR       = 0x0917,
00179     RTK_CMD_GETDEFIOVAR     = 0x0918,   // Ver 0.4
00180
00181     RTK_CMD_LETINTVAR       = 0x0920,
00182     RTK_CMD_LETSNGVAR       = 0x0921,
00183     RTK_CMD_LETDBLVAR       = 0x0922,
00184     RTK_CMD_LETSTRVAR       = 0x0923,
00185     RTK_CMD_LETPOSVAR       = 0x0924,
00186     RTK_CMD_LETJNTVAR       = 0x0925,
00187     RTK_CMD_LETTRNVAR       = 0x0926,
00188     RTK_CMD_LETVECVAR       = 0x0927,
00189     RTK_CMD_LETDEFIOVAR     = 0x0928,   // Ver 0.4
00190
00191     RTK_CMD_GETVALUEBYNAME  = 0x0930,
00192
00193     // DIO Manager
00194     RTK_CMD_GETIO           = 0x0A00,
00195     RTK_CMD_GETIO8          = 0x0A20,
00196     RTK_CMD_GETIO16         = 0x0A40,
00197     RTK_CMD_CHANGELABEL     = 0x0A50,
00198     RTK_CMD_SETIO           = 0x0A80,
00199     RTK_CMD_SETIO8          = 0x0A81,
00200     RTK_CMD_SETIO16         = 0x0A82,
00201
00202     RTK_CMD_SETDUMMY        = 0x0A90,
00203
00204     // Arm Manager
00205 //  RTK_CMD_SWITCHMOTOR     = 0x0B00,
00206 //  RTK_CMD_CALIBRATE       = 0x0B02,
00207 //  RTK_CMD_SWITCHLOCK      = 0x0B71,
00208     RTK_CMD_GETCURPOS       = 0x0B11,
00209     RTK_CMD_GETCURJNT       = 0x0B12,
00210     RTK_CMD_GETCURTRN       = 0x0B13,
00211 //  RTK_CMD_MOVEPOS         = 0x0B20,
00212 //  RTK_CMD_MOVEJNT         = 0x0B21,
00213 //  RTK_CMD_MOVETRN         = 0x0B22,
00214 //  RTK_CMD_MOVEMAN         = 0x0B23,
00215 //  RTK_CMD_MOVEDONE        = 0x0B24,
00216 //  RTK_CMD_DRIVE           = 0x0B25,
00217     RTK_CMD_GETTOOL         = 0x0B60,
00218     RTK_CMD_LETTOOL         = 0x0B61,
00219     RTK_CMD_GETTOOLINDEX    = 0x0B62,
00220 //  RTK_CMD_LETTOOLINDEX    = 0x0B63,
00221     RTK_CMD_GETWORK         = 0x0B64,
00222     RTK_CMD_LETWORK         = 0x0B65,
00223     RTK_CMD_GETWORKINDEX    = 0x0B66,
00224 //  RTK_CMD_LETWORKINDEX    = 0x0B67,
00225     RTK_CMD_GETAREA         = 0x0B68,
00226     RTK_CMD_LETAREA         = 0x0B69,
00227     RTK_CMD_ENABLEAREA      = 0x0B6A,
00228     RTK_CMD_DISABLEAREA     = 0x0B6B,
00229 //  RTK_CMD_GETEXTSPEED     = 0x0B80,
00230 //  RTK_CMD_LETEXTSPEED     = 0x0B81,
00231 //  RTK_CMD_GETEXTACCEL     = 0x0B82,
00232 //  RTK_CMD_LETEXTACCEL     = 0x0B83,
00233 //  RTK_CMD_GETEXTDECEL     = 0x0B84,
00234 //  RTK_CMD_LETEXTDECEL     = 0x0B85,
00235 //  RTK_CMD_GETEXTJSPEED    = 0x0B86,
00236 //  RTK_CMD_LETEXTJSPEED    = 0x0B87,
00237 //  RTK_CMD_GETEXTJACCEL    = 0x0B88,
00238 //  RTK_CMD_LETEXTJACCEL    = 0x0B89,
00239 //  RTK_CMD_GETEXTJDECEL    = 0x0B8A,
00240 //  RTK_CMD_LETEXTJDECEL    = 0x0B8B,
00241 //  RTK_CMD_GETSPEED        = 0x0B90,
00242 //  RTK_CMD_LETSPEED        = 0x0B91,
00243 //  RTK_CMD_GETACCEL        = 0x0B92,
00244 //  RTK_CMD_LETACCEL        = 0x0B93,
00245 //  RTK_CMD_GETDECEL        = 0x0B94,
00246 //  RTK_CMD_LETDECEL        = 0x0B95,
00247 //  RTK_CMD_GETJSPEED       = 0x0B96,
00248 //  RTK_CMD_LETJSPEED       = 0x0B97,
00249 //  RTK_CMD_GETJACCEL       = 0x0B98,
00250 //  RTK_CMD_LETJACCEL       = 0x0B99,
00251 //  RTK_CMD_GETJDECEL       = 0x0B9A,
00252 //  RTK_CMD_LETJDECEL       = 0x0B9B
00253
00254 } RTK_COMMAND;
00255
00256 #endif
00257
00258 // ERROR CODE
00259 //
00260 // MessageId: E_SEND_NAK
00261 //
00262 // MessageText:
00263 //
00264 //  NAK送信に失敗しました．
00265 //
00266 #define E_SEND_NAK        _HRESULT_TYPEDEF_(0x80000900L)
00267
00268 //
00269 // MessageId: E_TIMEOUT
00270 //
00271 // MessageText:
00272 //
00273 //  TimeOutが生じました．
00274 //
00275 //#define E_TIMEOUT        _HRESULT_TYPEDEF_(0x80000901L)
00276
00277 //
00278 // MessageId: E_REJECTED
00279 //
00280 // MessageText:
00281 //
00282 //  通信が拒否されました．
00283 //
00284 #define E_REJECTED        _HRESULT_TYPEDEF_(0x80000902L)
00285
00286 //
00287 // MessageId: E_ABNORMAL_R_PACKET
00288 //
00289 // MessageText:
00290 //
00291 //  受信パケットに異常があります．
00292 //
00293 #define E_ABNORMAL_R_PACKET        _HRESULT_TYPEDEF_(0x80000903L)
00294
00295 //
00296 // MessageId: E_ABNORMAL_S_PACKET
00297 //
00298 // MessageText:
00299 //
00300 //  送信パケットに異常があります．
00301 //
00302 #define E_ABNORMAL_S_PACKET        _HRESULT_TYPEDEF_(0x80000904L)
Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkIO.h Source File

RbtlkIO.h

解説を見る。
00001
00011 #ifndef __RBTLKIO_H_
00012 #define __RBTLKIO_H_
00013
00014 #include "resource.h"           // メイン シンボル
00015 #include "RbtlkEngine.h"
00016
00018 // CRbtlkIO
00019 class ATL_NO_VTABLE CRbtlkIO :
00020     public CComObjectRootEx<CComMultiThreadModel>,
00021     public CComCoClass<CRbtlkIO, &CLSID_RbtlkIO>,
00022     public ISupportErrorInfo,
00023     public IRbtlkIO
00024 {
00025 public:
00026     CRbtlkIO()
00027     {
00028     }
00029
00030 //DECLARE_REGISTRY_RESOURCEID(IDR_RBTLKIO)
00031
00032 DECLARE_PROTECT_FINAL_CONSTRUCT()
00033
00034 BEGIN_COM_MAP(CRbtlkIO)
00035     COM_INTERFACE_ENTRY(IRbtlkIO)
00036     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00037 END_COM_MAP()
00038
00039 // ISupportsErrorInfo
00040     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00041
00042 // FinalConstruct / FinalRelease
00043     HRESULT FinalConstruct();
00044     void FinalRelease();
00045
00046 // IRbtlkIO
00047 public:
00048     STDMETHOD(cmdDummy)(/*[in]*/ short sIndex, /*[in]*/ short newVal);
00049     STDMETHOD(cmdDin)(/*[in]*/ short sIndex, /*[out]*/ BOOL *pVal);
00050     STDMETHOD(cmdDout)(/*[in]*/ short sIndex, /*[in]*/ BOOL newVal);
00051     STDMETHOD(cmdDin8)(/*[in]*/ short sIndex, /*[out]*/ short *pVal);
00052     STDMETHOD(cmdDout8)(/*[in]*/ short sIndex, /*[in]*/ short newVal);
00053     STDMETHOD(cmdDin16)(/*[in]*/ short sIndex, /*[out]*/ short *pVal);
00054     STDMETHOD(cmdDout16)(/*[in]*/ short sIndex, /*[in]*/ short newVal);
00055     STDMETHOD(cmdChangeLabel)(/*[in]*/ short sPlateNo, /*[in]*/ short sButtonNo, /*[in]*/ CHAR *newVal);
00056
00057     HRESULT Initialize(CRbtlkEngine *pIRbtlkEng);
00058
00059 private:
00060     CRbtlkEngine *m_pCRbtlkEng; // RbtlkEngineのポインタ
00061
00062 };
00063
00064 #endif //__RBTLKIO_H_
Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkTask.h Source File

RbtlkTask.h

解説を見る。
00001
00011 #ifndef __RbtlkTask_H_
00012 #define __RbtlkTask_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include "RbtlkEngine.h"
00016
00018 // CRbtlkTask
00019 class ATL_NO_VTABLE CRbtlkTask :
00020     public CComObjectRootEx<CComMultiThreadModel>,
00021     public CComCoClass<CRbtlkTask, &CLSID_RbtlkTask>,
00022     public ISupportErrorInfo,
00023     public IRbtlkTask
00024 {
00025 public:
00026     CRbtlkTask()
00027     {
00028     }
00029
00030 //DECLARE_REGISTRY_RESOURCEID(IDR_RbtlkTask)
00031
00032 DECLARE_PROTECT_FINAL_CONSTRUCT()
00033
00034 BEGIN_COM_MAP(CRbtlkTask)
00035     COM_INTERFACE_ENTRY(IRbtlkTask)
00036     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00037 END_COM_MAP()
00038
00039 // ISupportsErrorInfo
00040     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00041
00042 // FinalConstruct / FinalRelease
00043     HRESULT FinalConstruct();
00044     void FinalRelease();
00045
00046 // IRbtlkTask
00047 public:
00048     STDMETHOD(cmdGetPrgListLen)(/*[out]*/ short* newVal);
00049     STDMETHOD(cmdGetPrgList)(/*[in]*/short sIndex, /*[out]*/ short* newVal, /*[out]*/ CHAR *szName);
00050     STDMETHOD(cmdGetTaskStatus)(/*[in]*/ short sPrgIC, /*[out]*/ short* pStatus );
00051     STDMETHOD(cmdContPrgStatus)(/*[in]*/ short sPrgIC, /*[out]*/ short* pStatus, /*[out]*/ short* pPriority, /*[out]*/ short* pInterval, /*[out]*/ short* pLineNo, /*[out]*/ short* pIOBlock, /*[out]*/ short* pMode, /*[out]*/ long* pCT );
00052
00053     HRESULT Initialize(CRbtlkEngine *pIRbtlkEng);
00054
00055 private:
00056     CRbtlkEngine *m_pCRbtlkEng; // RbtlkEngineのポインタ
00057
00058 };
00059
00060 #endif //__RbtlkTask_H_
Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


RbtlkVariable.h Source File

RbtlkVariable.h

解説を見る。
00001
00011 #ifndef __RBTLKVARIABLE_H_
00012 #define __RBTLKVARIABLE_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include "RbtlkEngine.h"
00016
00018 // CRbtlkVariable
00019 class ATL_NO_VTABLE CRbtlkVariable :
00020     public CComObjectRootEx<CComMultiThreadModel>,
00021     public CComCoClass<CRbtlkVariable, &CLSID_RbtlkVariable>,
00022     public ISupportErrorInfo,
00023     public IRbtlkVariable
00024 {
00025 public:
00026     CRbtlkVariable()
00027     {
00028     }
00029
00030 //DECLARE_REGISTRY_RESOURCEID(IDR_RBTLKVARIABLE)
00031
00032 DECLARE_PROTECT_FINAL_CONSTRUCT()
00033
00034 BEGIN_COM_MAP(CRbtlkVariable)
00035     COM_INTERFACE_ENTRY(IRbtlkVariable)
00036     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00037 END_COM_MAP()
00038
00039 // ISupportsErrorInfo
00040     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00041
00042 // FinalConstruct / FinalRelease
00043     HRESULT FinalConstruct();
00044     void FinalRelease();
00045
00046 // IRbtlkVariable
00047 public:
00048     STDMETHOD(cmdGetDefIO)(/*[in]*/ short sPort, /*[in]*/ short sType, /*[in]*/ long lMask, /*[out]*/ long *pVal);
00049     STDMETHOD(cmdLetDefIO)(/*[in]*/ short sPort, /*[in]*/ short sType, /*[in]*/ long lMask, /*[in]*/ long lVal);
00050     // Ver 0.4 -----
00051
00052     STDMETHOD(cmdGetTabLen)(/*[in]*/ short sPrgIC, /*[in]*/ short sTypeIC, /*[out]*/ short *pVal);
00053     STDMETHOD(cmdGetT)(/*[in]*/ short sIC, /*[in]*/ short sIndex, /*[out]*/ float *pVal);
00054     STDMETHOD(cmdLetT)(/*[in]*/ short sIC, /*[in]*/ short sIndex, /*[in]*/ float *newVal);
00055     STDMETHOD(cmdGetV)(/*[in]*/ short sIC, /*[in]*/ short sIndex, /*[out]*/ float *pVal);
00056     STDMETHOD(cmdLetV)(/*[in]*/ short sIC, /*[in]*/ short sIndex, /*[in]*/ float *newVal);
00057     STDMETHOD(cmdGetS)(/*[in]*/ short sIC, /*[in]*/ short sIndex, /*[out]*/ CHAR *pVal);
00058     STDMETHOD(cmdLetS)(/*[in]*/ short sIC, /*[in]*/ short sIndex, /*[in]*/ CHAR *newVal);
00059     STDMETHOD(cmdGetD)(/*[in]*/ short sIC, /*[in]*/ short sIndex, /*[out]*/ double *pVal);
00060     STDMETHOD(cmdLetD)(/*[in]*/ short sIC, /*[in]*/ short sIndex, /*[in]*/ double newVal);
00061     STDMETHOD(cmdGetJ)(/*[in]*/ short sIC, /*[in]*/ short sIndex, /*[out]*/ float *pVal);
00062     STDMETHOD(cmdLetJ)(/*[in]*/ short sIC, /*[in]*/ short sIndex, /*[in]*/ float *newVal);
00063     STDMETHOD(cmdGetP)(/*[in]*/ short sIC, /*[in]*/ short sIndex, /*[out]*/ float *pVal);
00064     STDMETHOD(cmdLetP)(/*[in]*/ short sIC, /*[in]*/ short sIndex, /*[in]*/ float *newVal);
00065     STDMETHOD(cmdGetF)(/*[in]*/ short sIC ,/*[in]*/ short sIndex, /*[out]*/ float *pVal);
00066     STDMETHOD(cmdLetF)(/*[in]*/ short sIC ,/*[in]*/ short sIndex, /*[in]*/ float newVal);
00067     STDMETHOD(cmdGetI)(/*[in]*/ short sIC, /*[in]*/ short sIndex, /*[out]*/ long *pVal);
00068     STDMETHOD(cmdLetI)(/*[in]*/ short sIC, /*[in]*/ short sIndex, /*[in]*/ long newVal);
00069
00070     HRESULT Initialize(CRbtlkEngine *pIRbtlkEng);
00071
00072 private:
00073     CRbtlkEngine *m_pCRbtlkEng; // RbtlkEngineのポインタ
00074
00075 };
00076
00077 #endif //__RBTLKVARIABLE_H_
Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


resource.h Source File

resource.h

解説を見る。
00001 //{{NO_DEPENDENCIES}}
00002 // Microsoft Developer Studio generated include file.
00003 // Used by ROBOTalk.rc
00004 //
00005 #define IDS_PROJNAME                    100
00006 #define IDR_RBTLKENGINE                 101
00007
00008 // Next default values for new objects
00009 //
00010 #ifdef APSTUDIO_INVOKED
00011 #ifndef APSTUDIO_READONLY_SYMBOLS
00012 #define _APS_NEXT_RESOURCE_VALUE        201
00013 #define _APS_NEXT_COMMAND_VALUE         32768
00014 #define _APS_NEXT_CONTROL_VALUE         201
00015 #define _APS_NEXT_SYMED_VALUE           102
00016 #endif
00017 #endif
Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


ROBOTalk.h Source File

ROBOTalk.h

解説を見る。
00001 /* this ALWAYS GENERATED file contains the definitions for the interfaces */
00002
00003
00004 /* File created by MIDL compiler version 5.01.0164 */
00005 /* at Wed Sep 29 10:57:08 2004
00006  */
00007 /* Compiler settings for D:\ORiN2\CAO\ProviderLib\DENSO\NetwoRC\ROBOTalk\Src\ROBOTalk.idl:
00008     Oicf (OptLev=i2), W1, Zp8, env=Win32, ms_ext, c_ext
00009     error checks: allocation ref bounds_check enum stub_data
00010 */
00011 //@@MIDL_FILE_HEADING(  )
00012
00013
00014 /* verify that the <rpcndr.h> version is high enough to compile this file*/
00015 #ifndef __REQUIRED_RPCNDR_H_VERSION__
00016 #define __REQUIRED_RPCNDR_H_VERSION__ 440
00017 #endif
00018
00019 #include "rpc.h"
00020 #include "rpcndr.h"
00021
00022 #ifndef __RPCNDR_H_VERSION__
00023 #error this stub requires an updated version of <rpcndr.h>
00024 #endif // __RPCNDR_H_VERSION__
00025
00026 #ifndef COM_NO_WINDOWS_H
00027 #include "windows.h"
00028 #include "ole2.h"
00029 #endif /*COM_NO_WINDOWS_H*/
00030
00031 #ifndef __ROBOTalk_h__
00032 #define __ROBOTalk_h__
00033
00034 #ifdef __cplusplus
00035 extern "C"{
00036 #endif
00037
00038 /* Forward Declarations */
00039
00040 #ifndef __IRbtlkEngine_FWD_DEFINED__
00041 #define __IRbtlkEngine_FWD_DEFINED__
00042 typedef interface IRbtlkEngine IRbtlkEngine;
00043 #endif  /* __IRbtlkEngine_FWD_DEFINED__ */
00044
00045
00046 #ifndef __IRbtlkController_FWD_DEFINED__
00047 #define __IRbtlkController_FWD_DEFINED__
00048 typedef interface IRbtlkController IRbtlkController;
00049 #endif  /* __IRbtlkController_FWD_DEFINED__ */
00050
00051
00052 #ifndef __IRbtlkVariable_FWD_DEFINED__
00053 #define __IRbtlkVariable_FWD_DEFINED__
00054 typedef interface IRbtlkVariable IRbtlkVariable;
00055 #endif  /* __IRbtlkVariable_FWD_DEFINED__ */
00056
00057
00058 #ifndef __IRbtlkIO_FWD_DEFINED__
00059 #define __IRbtlkIO_FWD_DEFINED__
00060 typedef interface IRbtlkIO IRbtlkIO;
00061 #endif  /* __IRbtlkIO_FWD_DEFINED__ */
00062
00063
00064 #ifndef __IRbtlkArm_FWD_DEFINED__
00065 #define __IRbtlkArm_FWD_DEFINED__
00066 typedef interface IRbtlkArm IRbtlkArm;
00067 #endif  /* __IRbtlkArm_FWD_DEFINED__ */
00068
00069
00070 #ifndef __IRbtlkTask_FWD_DEFINED__
00071 #define __IRbtlkTask_FWD_DEFINED__
00072 typedef interface IRbtlkTask IRbtlkTask;
00073 #endif  /* __IRbtlkTask_FWD_DEFINED__ */
00074
00075
00076 #ifndef __IRbtlkFile_FWD_DEFINED__
00077 #define __IRbtlkFile_FWD_DEFINED__
00078 typedef interface IRbtlkFile IRbtlkFile;
00079 #endif  /* __IRbtlkFile_FWD_DEFINED__ */
00080
00081
00082 #ifndef __RbtlkEngine_FWD_DEFINED__
00083 #define __RbtlkEngine_FWD_DEFINED__
00084
00085 #ifdef __cplusplus
00086 typedef class RbtlkEngine RbtlkEngine;
00087 #else
00088 typedef struct RbtlkEngine RbtlkEngine;
00089 #endif /* __cplusplus */
00090
00091 #endif  /* __RbtlkEngine_FWD_DEFINED__ */
00092
00093
00094 #ifndef __RbtlkController_FWD_DEFINED__
00095 #define __RbtlkController_FWD_DEFINED__
00096
00097 #ifdef __cplusplus
00098 typedef class RbtlkController RbtlkController;
00099 #else
00100 typedef struct RbtlkController RbtlkController;
00101 #endif /* __cplusplus */
00102
00103 #endif  /* __RbtlkController_FWD_DEFINED__ */
00104
00105
00106 #ifndef __RbtlkVariable_FWD_DEFINED__
00107 #define __RbtlkVariable_FWD_DEFINED__
00108
00109 #ifdef __cplusplus
00110 typedef class RbtlkVariable RbtlkVariable;
00111 #else
00112 typedef struct RbtlkVariable RbtlkVariable;
00113 #endif /* __cplusplus */
00114
00115 #endif  /* __RbtlkVariable_FWD_DEFINED__ */
00116
00117
00118 #ifndef __RbtlkIO_FWD_DEFINED__
00119 #define __RbtlkIO_FWD_DEFINED__
00120
00121 #ifdef __cplusplus
00122 typedef class RbtlkIO RbtlkIO;
00123 #else
00124 typedef struct RbtlkIO RbtlkIO;
00125 #endif /* __cplusplus */
00126
00127 #endif  /* __RbtlkIO_FWD_DEFINED__ */
00128
00129
00130 #ifndef __RbtlkArm_FWD_DEFINED__
00131 #define __RbtlkArm_FWD_DEFINED__
00132
00133 #ifdef __cplusplus
00134 typedef class RbtlkArm RbtlkArm;
00135 #else
00136 typedef struct RbtlkArm RbtlkArm;
00137 #endif /* __cplusplus */
00138
00139 #endif  /* __RbtlkArm_FWD_DEFINED__ */
00140
00141
00142 #ifndef __RbtlkTask_FWD_DEFINED__
00143 #define __RbtlkTask_FWD_DEFINED__
00144
00145 #ifdef __cplusplus
00146 typedef class RbtlkTask RbtlkTask;
00147 #else
00148 typedef struct RbtlkTask RbtlkTask;
00149 #endif /* __cplusplus */
00150
00151 #endif  /* __RbtlkTask_FWD_DEFINED__ */
00152
00153
00154 #ifndef __RbtlkFile_FWD_DEFINED__
00155 #define __RbtlkFile_FWD_DEFINED__
00156
00157 #ifdef __cplusplus
00158 typedef class RbtlkFile RbtlkFile;
00159 #else
00160 typedef struct RbtlkFile RbtlkFile;
00161 #endif /* __cplusplus */
00162
00163 #endif  /* __RbtlkFile_FWD_DEFINED__ */
00164
00165
00166 /* header files for imported files */
00167 #include "oaidl.h"
00168 #include "ocidl.h"
00169
00170 void __RPC_FAR * __RPC_USER MIDL_user_allocate(size_t);
00171 void __RPC_USER MIDL_user_free( void __RPC_FAR * );
00172
00173 /* interface __MIDL_itf_ROBOTalk_0000 */
00174 /* [local] */
00175
00176
00177
00178
00179
00180
00181
00182
00183
00184 extern RPC_IF_HANDLE __MIDL_itf_ROBOTalk_0000_v0_0_c_ifspec;
00185 extern RPC_IF_HANDLE __MIDL_itf_ROBOTalk_0000_v0_0_s_ifspec;
00186
00187 #ifndef __IRbtlkEngine_INTERFACE_DEFINED__
00188 #define __IRbtlkEngine_INTERFACE_DEFINED__
00189
00190 /* interface IRbtlkEngine */
00191 /* [unique][helpstring][uuid][object] */
00192
00193 typedef /* [public] */
00194 enum __MIDL_IRbtlkEngine_0001
00195     {   NIC_GV_INT  = ( short  )0x1018,
00196     NIC_GV_SNG  = ( short  )0x1019,
00197     NIC_GV_DBL  = ( short  )0x101a,
00198     NIC_GV_VEC  = ( short  )0x101c,
00199     NIC_GV_POS  = ( short  )0x1015,
00200     NIC_GV_JNT  = ( short  )0x101e,
00201     NIC_GV_TRN  = ( short  )0x101d,
00202     NIC_GV_STR  = ( short  )0x101b,
00203     NIC_GV_IO   = ( short  )0xffff
00204     }   ;
00205
00206 typedef /* [public] */ struct  __MIDL_IRbtlkEngine_0002
00207     {
00208     BYTE bEnq;
00209     BYTE bLength;
00210     WORD wCommand;
00211     BYTE bID1;
00212     BYTE bID2;
00213     BYTE bData[ 248 ];
00214     BYTE bCDH;
00215     BYTE bCDL;
00216     }   RTK_PACKET;
00217
00218 typedef /* [public] */
00219 enum __MIDL_IRbtlkEngine_0003
00220     {   RTK_CST_ERROR   = 2,
00221     RTK_CST_RUNNING = 3,
00222     RTK_CST_EMGSTOP = 4
00223     }   RTK_CTRL_STATUS;
00224
00225
00226 EXTERN_C const IID IID_IRbtlkEngine;
00227
00228 #if defined(__cplusplus) && !defined(CINTERFACE)
00229
00230     MIDL_INTERFACE("F7D1E6C8-C6D4-4696-BD58-282134D40134")
00231     IRbtlkEngine : public IUnknown
00232     {
00233     public:
00234         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE ConnectServer(
00235             /* [in] */ CHAR __RPC_FAR *szPara) = 0;
00236
00237         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE DisconnectServer( void) = 0;
00238
00239         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE Cancel( void) = 0;
00240
00241         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE GetVarInfo(
00242             /* [in] */ CHAR __RPC_FAR *szVar,
00243             /* [out] */ short __RPC_FAR *sType,
00244             /* [out] */ short __RPC_FAR *sIndex) = 0;
00245
00246         virtual /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE get_RbtlkController(
00247             /* [retval][out] */ IRbtlkController __RPC_FAR *__RPC_FAR *ppVal) = 0;
00248
00249         virtual /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE get_RbtlkVariable(
00250             /* [retval][out] */ IRbtlkVariable __RPC_FAR *__RPC_FAR *ppVal) = 0;
00251
00252         virtual /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE get_RbtlkArm(
00253             /* [retval][out] */ IRbtlkArm __RPC_FAR *__RPC_FAR *ppVal) = 0;
00254
00255         virtual /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE get_RbtlkIO(
00256             /* [retval][out] */ IRbtlkIO __RPC_FAR *__RPC_FAR *ppVal) = 0;
00257
00258         virtual /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE get_RbtlkTask(
00259             /* [retval][out] */ IRbtlkTask __RPC_FAR *__RPC_FAR *ppVal) = 0;
00260
00261         virtual /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE get_RbtlkFile(
00262             /* [retval][out] */ IRbtlkFile __RPC_FAR *__RPC_FAR *ppVal) = 0;
00263
00264         virtual /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE get_TimeOut(
00265             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
00266
00267         virtual /* [helpstring][propput] */ HRESULT STDMETHODCALLTYPE put_TimeOut(
00268             /* [in] */ long newVal) = 0;
00269
00270         virtual /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE get_TimeOutRetry(
00271             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
00272
00273         virtual /* [helpstring][propput] */ HRESULT STDMETHODCALLTYPE put_TimeOutRetry(
00274             /* [in] */ long newVal) = 0;
00275
00276         virtual /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE get_NakRetry(
00277             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
00278
00279         virtual /* [helpstring][propput] */ HRESULT STDMETHODCALLTYPE put_NakRetry(
00280             /* [in] */ long newVal) = 0;
00281
00282         virtual /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE get_LastError(
00283             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
00284
00285         virtual /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE get_Version(
00286             /* [retval][out] */ double __RPC_FAR *pVal) = 0;
00287
00288     };
00289
00290 #else   /* C style interface */
00291
00292     typedef struct IRbtlkEngineVtbl
00293     {
00294         BEGIN_INTERFACE
00295
00296         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
00297             IRbtlkEngine __RPC_FAR * This,
00298             /* [in] */ REFIID riid,
00299             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
00300
00301         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
00302             IRbtlkEngine __RPC_FAR * This);
00303
00304         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
00305             IRbtlkEngine __RPC_FAR * This);
00306
00307         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *ConnectServer )(
00308             IRbtlkEngine __RPC_FAR * This,
00309             /* [in] */ CHAR __RPC_FAR *szPara);
00310
00311         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *DisconnectServer )(
00312             IRbtlkEngine __RPC_FAR * This);
00313
00314         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Cancel )(
00315             IRbtlkEngine __RPC_FAR * This);
00316
00317         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetVarInfo )(
00318             IRbtlkEngine __RPC_FAR * This,
00319             /* [in] */ CHAR __RPC_FAR *szVar,
00320             /* [out] */ short __RPC_FAR *sType,
00321             /* [out] */ short __RPC_FAR *sIndex);
00322
00323         /* [helpstring][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_RbtlkController )(
00324             IRbtlkEngine __RPC_FAR * This,
00325             /* [retval][out] */ IRbtlkController __RPC_FAR *__RPC_FAR *ppVal);
00326
00327         /* [helpstring][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_RbtlkVariable )(
00328             IRbtlkEngine __RPC_FAR * This,
00329             /* [retval][out] */ IRbtlkVariable __RPC_FAR *__RPC_FAR *ppVal);
00330
00331         /* [helpstring][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_RbtlkArm )(
00332             IRbtlkEngine __RPC_FAR * This,
00333             /* [retval][out] */ IRbtlkArm __RPC_FAR *__RPC_FAR *ppVal);
00334
00335         /* [helpstring][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_RbtlkIO )(
00336             IRbtlkEngine __RPC_FAR * This,
00337             /* [retval][out] */ IRbtlkIO __RPC_FAR *__RPC_FAR *ppVal);
00338
00339         /* [helpstring][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_RbtlkTask )(
00340             IRbtlkEngine __RPC_FAR * This,
00341             /* [retval][out] */ IRbtlkTask __RPC_FAR *__RPC_FAR *ppVal);
00342
00343         /* [helpstring][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_RbtlkFile )(
00344             IRbtlkEngine __RPC_FAR * This,
00345             /* [retval][out] */ IRbtlkFile __RPC_FAR *__RPC_FAR *ppVal);
00346
00347         /* [helpstring][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_TimeOut )(
00348             IRbtlkEngine __RPC_FAR * This,
00349             /* [retval][out] */ long __RPC_FAR *pVal);
00350
00351         /* [helpstring][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_TimeOut )(
00352             IRbtlkEngine __RPC_FAR * This,
00353             /* [in] */ long newVal);
00354
00355         /* [helpstring][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_TimeOutRetry )(
00356             IRbtlkEngine __RPC_FAR * This,
00357             /* [retval][out] */ long __RPC_FAR *pVal);
00358
00359         /* [helpstring][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_TimeOutRetry )(
00360             IRbtlkEngine __RPC_FAR * This,
00361             /* [in] */ long newVal);
00362
00363         /* [helpstring][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_NakRetry )(
00364             IRbtlkEngine __RPC_FAR * This,
00365             /* [retval][out] */ long __RPC_FAR *pVal);
00366
00367         /* [helpstring][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_NakRetry )(
00368             IRbtlkEngine __RPC_FAR * This,
00369             /* [in] */ long newVal);
00370
00371         /* [helpstring][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_LastError )(
00372             IRbtlkEngine __RPC_FAR * This,
00373             /* [retval][out] */ long __RPC_FAR *pVal);
00374
00375         /* [helpstring][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Version )(
00376             IRbtlkEngine __RPC_FAR * This,
00377             /* [retval][out] */ double __RPC_FAR *pVal);
00378
00379         END_INTERFACE
00380     } IRbtlkEngineVtbl;
00381
00382     interface IRbtlkEngine
00383     {
00384         CONST_VTBL struct IRbtlkEngineVtbl __RPC_FAR *lpVtbl;
00385     };
00386
00387
00388
00389 #ifdef COBJMACROS
00390
00391
00392 #define IRbtlkEngine_QueryInterface(This,riid,ppvObject)    \
00393     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
00394
00395 #define IRbtlkEngine_AddRef(This)   \
00396     (This)->lpVtbl -> AddRef(This)
00397
00398 #define IRbtlkEngine_Release(This)  \
00399     (This)->lpVtbl -> Release(This)
00400
00401
00402 #define IRbtlkEngine_ConnectServer(This,szPara) \
00403     (This)->lpVtbl -> ConnectServer(This,szPara)
00404
00405 #define IRbtlkEngine_DisconnectServer(This) \
00406     (This)->lpVtbl -> DisconnectServer(This)
00407
00408 #define IRbtlkEngine_Cancel(This)   \
00409     (This)->lpVtbl -> Cancel(This)
00410
00411 #define IRbtlkEngine_GetVarInfo(This,szVar,sType,sIndex)    \
00412     (This)->lpVtbl -> GetVarInfo(This,szVar,sType,sIndex)
00413
00414 #define IRbtlkEngine_get_RbtlkController(This,ppVal)    \
00415     (This)->lpVtbl -> get_RbtlkController(This,ppVal)
00416
00417 #define IRbtlkEngine_get_RbtlkVariable(This,ppVal)  \
00418     (This)->lpVtbl -> get_RbtlkVariable(This,ppVal)
00419
00420 #define IRbtlkEngine_get_RbtlkArm(This,ppVal)   \
00421     (This)->lpVtbl -> get_RbtlkArm(This,ppVal)
00422
00423 #define IRbtlkEngine_get_RbtlkIO(This,ppVal)    \
00424     (This)->lpVtbl -> get_RbtlkIO(This,ppVal)
00425
00426 #define IRbtlkEngine_get_RbtlkTask(This,ppVal)  \
00427     (This)->lpVtbl -> get_RbtlkTask(This,ppVal)
00428
00429 #define IRbtlkEngine_get_RbtlkFile(This,ppVal)  \
00430     (This)->lpVtbl -> get_RbtlkFile(This,ppVal)
00431
00432 #define IRbtlkEngine_get_TimeOut(This,pVal) \
00433     (This)->lpVtbl -> get_TimeOut(This,pVal)
00434
00435 #define IRbtlkEngine_put_TimeOut(This,newVal)   \
00436     (This)->lpVtbl -> put_TimeOut(This,newVal)
00437
00438 #define IRbtlkEngine_get_TimeOutRetry(This,pVal)    \
00439     (This)->lpVtbl -> get_TimeOutRetry(This,pVal)
00440
00441 #define IRbtlkEngine_put_TimeOutRetry(This,newVal)  \
00442     (This)->lpVtbl -> put_TimeOutRetry(This,newVal)
00443
00444 #define IRbtlkEngine_get_NakRetry(This,pVal)    \
00445     (This)->lpVtbl -> get_NakRetry(This,pVal)
00446
00447 #define IRbtlkEngine_put_NakRetry(This,newVal)  \
00448     (This)->lpVtbl -> put_NakRetry(This,newVal)
00449
00450 #define IRbtlkEngine_get_LastError(This,pVal)   \
00451     (This)->lpVtbl -> get_LastError(This,pVal)
00452
00453 #define IRbtlkEngine_get_Version(This,pVal) \
00454     (This)->lpVtbl -> get_Version(This,pVal)
00455
00456 #endif /* COBJMACROS */
00457
00458
00459 #endif  /* C style interface */
00460
00461
00462
00463 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_ConnectServer_Proxy(
00464     IRbtlkEngine __RPC_FAR * This,
00465     /* [in] */ CHAR __RPC_FAR *szPara);
00466
00467
00468 void __RPC_STUB IRbtlkEngine_ConnectServer_Stub(
00469     IRpcStubBuffer *This,
00470     IRpcChannelBuffer *_pRpcChannelBuffer,
00471     PRPC_MESSAGE _pRpcMessage,
00472     DWORD *_pdwStubPhase);
00473
00474
00475 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_DisconnectServer_Proxy(
00476     IRbtlkEngine __RPC_FAR * This);
00477
00478
00479 void __RPC_STUB IRbtlkEngine_DisconnectServer_Stub(
00480     IRpcStubBuffer *This,
00481     IRpcChannelBuffer *_pRpcChannelBuffer,
00482     PRPC_MESSAGE _pRpcMessage,
00483     DWORD *_pdwStubPhase);
00484
00485
00486 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_Cancel_Proxy(
00487     IRbtlkEngine __RPC_FAR * This);
00488
00489
00490 void __RPC_STUB IRbtlkEngine_Cancel_Stub(
00491     IRpcStubBuffer *This,
00492     IRpcChannelBuffer *_pRpcChannelBuffer,
00493     PRPC_MESSAGE _pRpcMessage,
00494     DWORD *_pdwStubPhase);
00495
00496
00497 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_GetVarInfo_Proxy(
00498     IRbtlkEngine __RPC_FAR * This,
00499     /* [in] */ CHAR __RPC_FAR *szVar,
00500     /* [out] */ short __RPC_FAR *sType,
00501     /* [out] */ short __RPC_FAR *sIndex);
00502
00503
00504 void __RPC_STUB IRbtlkEngine_GetVarInfo_Stub(
00505     IRpcStubBuffer *This,
00506     IRpcChannelBuffer *_pRpcChannelBuffer,
00507     PRPC_MESSAGE _pRpcMessage,
00508     DWORD *_pdwStubPhase);
00509
00510
00511 /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_RbtlkController_Proxy(
00512     IRbtlkEngine __RPC_FAR * This,
00513     /* [retval][out] */ IRbtlkController __RPC_FAR *__RPC_FAR *ppVal);
00514
00515
00516 void __RPC_STUB IRbtlkEngine_get_RbtlkController_Stub(
00517     IRpcStubBuffer *This,
00518     IRpcChannelBuffer *_pRpcChannelBuffer,
00519     PRPC_MESSAGE _pRpcMessage,
00520     DWORD *_pdwStubPhase);
00521
00522
00523 /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_RbtlkVariable_Proxy(
00524     IRbtlkEngine __RPC_FAR * This,
00525     /* [retval][out] */ IRbtlkVariable __RPC_FAR *__RPC_FAR *ppVal);
00526
00527
00528 void __RPC_STUB IRbtlkEngine_get_RbtlkVariable_Stub(
00529     IRpcStubBuffer *This,
00530     IRpcChannelBuffer *_pRpcChannelBuffer,
00531     PRPC_MESSAGE _pRpcMessage,
00532     DWORD *_pdwStubPhase);
00533
00534
00535 /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_RbtlkArm_Proxy(
00536     IRbtlkEngine __RPC_FAR * This,
00537     /* [retval][out] */ IRbtlkArm __RPC_FAR *__RPC_FAR *ppVal);
00538
00539
00540 void __RPC_STUB IRbtlkEngine_get_RbtlkArm_Stub(
00541     IRpcStubBuffer *This,
00542     IRpcChannelBuffer *_pRpcChannelBuffer,
00543     PRPC_MESSAGE _pRpcMessage,
00544     DWORD *_pdwStubPhase);
00545
00546
00547 /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_RbtlkIO_Proxy(
00548     IRbtlkEngine __RPC_FAR * This,
00549     /* [retval][out] */ IRbtlkIO __RPC_FAR *__RPC_FAR *ppVal);
00550
00551
00552 void __RPC_STUB IRbtlkEngine_get_RbtlkIO_Stub(
00553     IRpcStubBuffer *This,
00554     IRpcChannelBuffer *_pRpcChannelBuffer,
00555     PRPC_MESSAGE _pRpcMessage,
00556     DWORD *_pdwStubPhase);
00557
00558
00559 /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_RbtlkTask_Proxy(
00560     IRbtlkEngine __RPC_FAR * This,
00561     /* [retval][out] */ IRbtlkTask __RPC_FAR *__RPC_FAR *ppVal);
00562
00563
00564 void __RPC_STUB IRbtlkEngine_get_RbtlkTask_Stub(
00565     IRpcStubBuffer *This,
00566     IRpcChannelBuffer *_pRpcChannelBuffer,
00567     PRPC_MESSAGE _pRpcMessage,
00568     DWORD *_pdwStubPhase);
00569
00570
00571 /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_RbtlkFile_Proxy(
00572     IRbtlkEngine __RPC_FAR * This,
00573     /* [retval][out] */ IRbtlkFile __RPC_FAR *__RPC_FAR *ppVal);
00574
00575
00576 void __RPC_STUB IRbtlkEngine_get_RbtlkFile_Stub(
00577     IRpcStubBuffer *This,
00578     IRpcChannelBuffer *_pRpcChannelBuffer,
00579     PRPC_MESSAGE _pRpcMessage,
00580     DWORD *_pdwStubPhase);
00581
00582
00583 /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_TimeOut_Proxy(
00584     IRbtlkEngine __RPC_FAR * This,
00585     /* [retval][out] */ long __RPC_FAR *pVal);
00586
00587
00588 void __RPC_STUB IRbtlkEngine_get_TimeOut_Stub(
00589     IRpcStubBuffer *This,
00590     IRpcChannelBuffer *_pRpcChannelBuffer,
00591     PRPC_MESSAGE _pRpcMessage,
00592     DWORD *_pdwStubPhase);
00593
00594
00595 /* [helpstring][propput] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_put_TimeOut_Proxy(
00596     IRbtlkEngine __RPC_FAR * This,
00597     /* [in] */ long newVal);
00598
00599
00600 void __RPC_STUB IRbtlkEngine_put_TimeOut_Stub(
00601     IRpcStubBuffer *This,
00602     IRpcChannelBuffer *_pRpcChannelBuffer,
00603     PRPC_MESSAGE _pRpcMessage,
00604     DWORD *_pdwStubPhase);
00605
00606
00607 /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_TimeOutRetry_Proxy(
00608     IRbtlkEngine __RPC_FAR * This,
00609     /* [retval][out] */ long __RPC_FAR *pVal);
00610
00611
00612 void __RPC_STUB IRbtlkEngine_get_TimeOutRetry_Stub(
00613     IRpcStubBuffer *This,
00614     IRpcChannelBuffer *_pRpcChannelBuffer,
00615     PRPC_MESSAGE _pRpcMessage,
00616     DWORD *_pdwStubPhase);
00617
00618
00619 /* [helpstring][propput] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_put_TimeOutRetry_Proxy(
00620     IRbtlkEngine __RPC_FAR * This,
00621     /* [in] */ long newVal);
00622
00623
00624 void __RPC_STUB IRbtlkEngine_put_TimeOutRetry_Stub(
00625     IRpcStubBuffer *This,
00626     IRpcChannelBuffer *_pRpcChannelBuffer,
00627     PRPC_MESSAGE _pRpcMessage,
00628     DWORD *_pdwStubPhase);
00629
00630
00631 /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_NakRetry_Proxy(
00632     IRbtlkEngine __RPC_FAR * This,
00633     /* [retval][out] */ long __RPC_FAR *pVal);
00634
00635
00636 void __RPC_STUB IRbtlkEngine_get_NakRetry_Stub(
00637     IRpcStubBuffer *This,
00638     IRpcChannelBuffer *_pRpcChannelBuffer,
00639     PRPC_MESSAGE _pRpcMessage,
00640     DWORD *_pdwStubPhase);
00641
00642
00643 /* [helpstring][propput] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_put_NakRetry_Proxy(
00644     IRbtlkEngine __RPC_FAR * This,
00645     /* [in] */ long newVal);
00646
00647
00648 void __RPC_STUB IRbtlkEngine_put_NakRetry_Stub(
00649     IRpcStubBuffer *This,
00650     IRpcChannelBuffer *_pRpcChannelBuffer,
00651     PRPC_MESSAGE _pRpcMessage,
00652     DWORD *_pdwStubPhase);
00653
00654
00655 /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_LastError_Proxy(
00656     IRbtlkEngine __RPC_FAR * This,
00657     /* [retval][out] */ long __RPC_FAR *pVal);
00658
00659
00660 void __RPC_STUB IRbtlkEngine_get_LastError_Stub(
00661     IRpcStubBuffer *This,
00662     IRpcChannelBuffer *_pRpcChannelBuffer,
00663     PRPC_MESSAGE _pRpcMessage,
00664     DWORD *_pdwStubPhase);
00665
00666
00667 /* [helpstring][propget] */ HRESULT STDMETHODCALLTYPE IRbtlkEngine_get_Version_Proxy(
00668     IRbtlkEngine __RPC_FAR * This,
00669     /* [retval][out] */ double __RPC_FAR *pVal);
00670
00671
00672 void __RPC_STUB IRbtlkEngine_get_Version_Stub(
00673     IRpcStubBuffer *This,
00674     IRpcChannelBuffer *_pRpcChannelBuffer,
00675     PRPC_MESSAGE _pRpcMessage,
00676     DWORD *_pdwStubPhase);
00677
00678
00679
00680 #endif  /* __IRbtlkEngine_INTERFACE_DEFINED__ */
00681
00682
00683 #ifndef __IRbtlkController_INTERFACE_DEFINED__
00684 #define __IRbtlkController_INTERFACE_DEFINED__
00685
00686 /* interface IRbtlkController */
00687 /* [unique][helpstring][uuid][object] */
00688
00689
00690 EXTERN_C const IID IID_IRbtlkController;
00691
00692 #if defined(__cplusplus) && !defined(CINTERFACE)
00693
00694     MIDL_INTERFACE("C85F8BB2-EFF4-485e-BB44-F5DED29F2701")
00695     IRbtlkController : public IUnknown
00696     {
00697     public:
00698         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetVersions(
00699             /* [in] */ short sIndex,
00700             /* [out] */ CHAR __RPC_FAR *pVal) = 0;
00701
00702         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetDateTime(
00703             /* [out] */ short __RPC_FAR *psDateTime) = 0;
00704
00705         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetDateTime(
00706             /* [in] */ short __RPC_FAR *psDateTime) = 0;
00707
00708         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdClearCtrlLog( void) = 0;
00709
00710         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdStartCtrlLog( void) = 0;
00711
00712         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdStopCtrlLog( void) = 0;
00713
00714         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetParamCtrlLog(
00715             /* [out] */ long __RPC_FAR *pSmpCnt,
00716             /* [out] */ long __RPC_FAR *pSmpRate) = 0;
00717
00718         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdSwitchCtrlLog(
00719             /* [in] */ short sMode) = 0;
00720
00721         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdCancelCtrlLog( void) = 0;
00722
00723         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetMode(
00724             /* [out] */ short __RPC_FAR *pVal) = 0;
00725
00726         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdSetMode(
00727             /* [in] */ short iMode) = 0;
00728
00729         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetFreeMemory(
00730             /* [out] */ long __RPC_FAR *pVal) = 0;
00731
00732         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetRobotType(
00733             /* [out] */ long __RPC_FAR *pVal) = 0;
00734
00735         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetJointInfo(
00736             /* [in] */ short sMode,
00737             /* [out] */ short __RPC_FAR *pVal) = 0;
00738
00739         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetJobStatus(
00740             /* [in] */ long JobID,
00741             /* [out] */ short __RPC_FAR *pStatus) = 0;
00742
00743         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetJobStatus(
00744             /* [in] */ long JobID,
00745             /* [in] */ short sStatus) = 0;
00746
00747         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdRequestFileSave(
00748             /* [out] */ short __RPC_FAR *pTransMode,
00749             /* [out] */ long __RPC_FAR *pTaskID) = 0;
00750
00751         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetTransMode(
00752             /* [out] */ short __RPC_FAR *pTransMode) = 0;
00753
00754         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdRequestRomUpdate( void) = 0;
00755
00756         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdNoticeRomVersion(
00757             /* [in] */ short sVer) = 0;
00758
00759         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdDoSignal(
00760             /* [in] */ short sMode,
00761             /* [in] */ short sAction) = 0;
00762
00763         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdSrvJointParam(
00764             /* [out] */ short __RPC_FAR *pJoint,
00765             /* [out] */ short __RPC_FAR *pInterval,
00766             /* [out] */ short __RPC_FAR *pCounts,
00767             /* [out] */ short __RPC_FAR *pData1,
00768             /* [out] */ short __RPC_FAR *pData2) = 0;
00769
00770         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdSrvJointData(
00771             /* [in] */ short sOffset,
00772             /* [in] */ short sCounts,
00773             /* [out] */ float __RPC_FAR *__RPC_FAR *pData1,
00774             /* [out] */ float __RPC_FAR *__RPC_FAR *pData2) = 0;
00775
00776         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdSrvJointCancel( void) = 0;
00777
00778         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetErrorCode(
00779             /* [out] */ long __RPC_FAR *pVal) = 0;
00780
00781         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdClearError(
00782             /* [in] */ long lErrCode,
00783             /* [out] */ short __RPC_FAR *pVal) = 0;
00784
00785         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetOperationLog(
00786             /* [in] */ short sIndex,
00787             /* [out] */ short __RPC_FAR *pCode,
00788             /* [out] */ CHAR __RPC_FAR *szDate,
00789             /* [out] */ CHAR __RPC_FAR *szTime,
00790             /* [out] */ CHAR __RPC_FAR *szModule,
00791             /* [out] */ CHAR __RPC_FAR *szMsg) = 0;
00792
00793         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetErrorLog(
00794             /* [in] */ short sIndex,
00795             /* [out] */ short __RPC_FAR *pCode,
00796             /* [out] */ short __RPC_FAR *pLevel,
00797             /* [out] */ CHAR __RPC_FAR *szDate,
00798             /* [out] */ CHAR __RPC_FAR *szTime,
00799             /* [out] */ CHAR __RPC_FAR *szModule,
00800             /* [out] */ CHAR __RPC_FAR *szMsg) = 0;
00801
00802         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetControlLog(
00803             /* [in] */ short sIndex,
00804             /* [out] */ float __RPC_FAR pData[ 8 ][ 4 ],
00805             /* [out] */ float __RPC_FAR *pReg,
00806             /* [out] */ short __RPC_FAR *pProgNo,
00807             /* [out] */ short __RPC_FAR *pLineNo) = 0;
00808
00809         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdSetOption(
00810             /* [in] */ short sMode,
00811             /* [in] */ long lKey,
00812             /* [out] */ CHAR __RPC_FAR *pVal) = 0;
00813
00814         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdChangeConfig(
00815             /* [in] */ short sMode) = 0;
00816
00817         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetConfig(
00818             /* [in] */ short sMode,
00819             /* [in] */ short sIndex,
00820             /* [in] */ long newVal) = 0;
00821
00822         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetConfig(
00823             /* [in] */ short sMode,
00824             /* [in] */ short sIndex,
00825             /* [out] */ long __RPC_FAR *pVal) = 0;
00826
00827         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetStatus(
00828             /* [in] */ short sModule,
00829             /* [in] */ short sIndex,
00830             /* [out] */ short __RPC_FAR *pVal) = 0;
00831
00832     };
00833
00834 #else   /* C style interface */
00835
00836     typedef struct IRbtlkControllerVtbl
00837     {
00838         BEGIN_INTERFACE
00839
00840         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
00841             IRbtlkController __RPC_FAR * This,
00842             /* [in] */ REFIID riid,
00843             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
00844
00845         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
00846             IRbtlkController __RPC_FAR * This);
00847
00848         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
00849             IRbtlkController __RPC_FAR * This);
00850
00851         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetVersions )(
00852             IRbtlkController __RPC_FAR * This,
00853             /* [in] */ short sIndex,
00854             /* [out] */ CHAR __RPC_FAR *pVal);
00855
00856         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetDateTime )(
00857             IRbtlkController __RPC_FAR * This,
00858             /* [out] */ short __RPC_FAR *psDateTime);
00859
00860         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetDateTime )(
00861             IRbtlkController __RPC_FAR * This,
00862             /* [in] */ short __RPC_FAR *psDateTime);
00863
00864         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdClearCtrlLog )(
00865             IRbtlkController __RPC_FAR * This);
00866
00867         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdStartCtrlLog )(
00868             IRbtlkController __RPC_FAR * This);
00869
00870         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdStopCtrlLog )(
00871             IRbtlkController __RPC_FAR * This);
00872
00873         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetParamCtrlLog )(
00874             IRbtlkController __RPC_FAR * This,
00875             /* [out] */ long __RPC_FAR *pSmpCnt,
00876             /* [out] */ long __RPC_FAR *pSmpRate);
00877
00878         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdSwitchCtrlLog )(
00879             IRbtlkController __RPC_FAR * This,
00880             /* [in] */ short sMode);
00881
00882         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdCancelCtrlLog )(
00883             IRbtlkController __RPC_FAR * This);
00884
00885         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetMode )(
00886             IRbtlkController __RPC_FAR * This,
00887             /* [out] */ short __RPC_FAR *pVal);
00888
00889         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdSetMode )(
00890             IRbtlkController __RPC_FAR * This,
00891             /* [in] */ short iMode);
00892
00893         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetFreeMemory )(
00894             IRbtlkController __RPC_FAR * This,
00895             /* [out] */ long __RPC_FAR *pVal);
00896
00897         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetRobotType )(
00898             IRbtlkController __RPC_FAR * This,
00899             /* [out] */ long __RPC_FAR *pVal);
00900
00901         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetJointInfo )(
00902             IRbtlkController __RPC_FAR * This,
00903             /* [in] */ short sMode,
00904             /* [out] */ short __RPC_FAR *pVal);
00905
00906         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetJobStatus )(
00907             IRbtlkController __RPC_FAR * This,
00908             /* [in] */ long JobID,
00909             /* [out] */ short __RPC_FAR *pStatus);
00910
00911         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetJobStatus )(
00912             IRbtlkController __RPC_FAR * This,
00913             /* [in] */ long JobID,
00914             /* [in] */ short sStatus);
00915
00916         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdRequestFileSave )(
00917             IRbtlkController __RPC_FAR * This,
00918             /* [out] */ short __RPC_FAR *pTransMode,
00919             /* [out] */ long __RPC_FAR *pTaskID);
00920
00921         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetTransMode )(
00922             IRbtlkController __RPC_FAR * This,
00923             /* [out] */ short __RPC_FAR *pTransMode);
00924
00925         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdRequestRomUpdate )(
00926             IRbtlkController __RPC_FAR * This);
00927
00928         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdNoticeRomVersion )(
00929             IRbtlkController __RPC_FAR * This,
00930             /* [in] */ short sVer);
00931
00932         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdDoSignal )(
00933             IRbtlkController __RPC_FAR * This,
00934             /* [in] */ short sMode,
00935             /* [in] */ short sAction);
00936
00937         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdSrvJointParam )(
00938             IRbtlkController __RPC_FAR * This,
00939             /* [out] */ short __RPC_FAR *pJoint,
00940             /* [out] */ short __RPC_FAR *pInterval,
00941             /* [out] */ short __RPC_FAR *pCounts,
00942             /* [out] */ short __RPC_FAR *pData1,
00943             /* [out] */ short __RPC_FAR *pData2);
00944
00945         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdSrvJointData )(
00946             IRbtlkController __RPC_FAR * This,
00947             /* [in] */ short sOffset,
00948             /* [in] */ short sCounts,
00949             /* [out] */ float __RPC_FAR *__RPC_FAR *pData1,
00950             /* [out] */ float __RPC_FAR *__RPC_FAR *pData2);
00951
00952         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdSrvJointCancel )(
00953             IRbtlkController __RPC_FAR * This);
00954
00955         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetErrorCode )(
00956             IRbtlkController __RPC_FAR * This,
00957             /* [out] */ long __RPC_FAR *pVal);
00958
00959         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdClearError )(
00960             IRbtlkController __RPC_FAR * This,
00961             /* [in] */ long lErrCode,
00962             /* [out] */ short __RPC_FAR *pVal);
00963
00964         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetOperationLog )(
00965             IRbtlkController __RPC_FAR * This,
00966             /* [in] */ short sIndex,
00967             /* [out] */ short __RPC_FAR *pCode,
00968             /* [out] */ CHAR __RPC_FAR *szDate,
00969             /* [out] */ CHAR __RPC_FAR *szTime,
00970             /* [out] */ CHAR __RPC_FAR *szModule,
00971             /* [out] */ CHAR __RPC_FAR *szMsg);
00972
00973         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetErrorLog )(
00974             IRbtlkController __RPC_FAR * This,
00975             /* [in] */ short sIndex,
00976             /* [out] */ short __RPC_FAR *pCode,
00977             /* [out] */ short __RPC_FAR *pLevel,
00978             /* [out] */ CHAR __RPC_FAR *szDate,
00979             /* [out] */ CHAR __RPC_FAR *szTime,
00980             /* [out] */ CHAR __RPC_FAR *szModule,
00981             /* [out] */ CHAR __RPC_FAR *szMsg);
00982
00983         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetControlLog )(
00984             IRbtlkController __RPC_FAR * This,
00985             /* [in] */ short sIndex,
00986             /* [out] */ float __RPC_FAR pData[ 8 ][ 4 ],
00987             /* [out] */ float __RPC_FAR *pReg,
00988             /* [out] */ short __RPC_FAR *pProgNo,
00989             /* [out] */ short __RPC_FAR *pLineNo);
00990
00991         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdSetOption )(
00992             IRbtlkController __RPC_FAR * This,
00993             /* [in] */ short sMode,
00994             /* [in] */ long lKey,
00995             /* [out] */ CHAR __RPC_FAR *pVal);
00996
00997         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdChangeConfig )(
00998             IRbtlkController __RPC_FAR * This,
00999             /* [in] */ short sMode);
01000
01001         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetConfig )(
01002             IRbtlkController __RPC_FAR * This,
01003             /* [in] */ short sMode,
01004             /* [in] */ short sIndex,
01005             /* [in] */ long newVal);
01006
01007         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetConfig )(
01008             IRbtlkController __RPC_FAR * This,
01009             /* [in] */ short sMode,
01010             /* [in] */ short sIndex,
01011             /* [out] */ long __RPC_FAR *pVal);
01012
01013         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetStatus )(
01014             IRbtlkController __RPC_FAR * This,
01015             /* [in] */ short sModule,
01016             /* [in] */ short sIndex,
01017             /* [out] */ short __RPC_FAR *pVal);
01018
01019         END_INTERFACE
01020     } IRbtlkControllerVtbl;
01021
01022     interface IRbtlkController
01023     {
01024         CONST_VTBL struct IRbtlkControllerVtbl __RPC_FAR *lpVtbl;
01025     };
01026
01027
01028
01029 #ifdef COBJMACROS
01030
01031
01032 #define IRbtlkController_QueryInterface(This,riid,ppvObject)    \
01033     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
01034
01035 #define IRbtlkController_AddRef(This)   \
01036     (This)->lpVtbl -> AddRef(This)
01037
01038 #define IRbtlkController_Release(This)  \
01039     (This)->lpVtbl -> Release(This)
01040
01041
01042 #define IRbtlkController_cmdGetVersions(This,sIndex,pVal)   \
01043     (This)->lpVtbl -> cmdGetVersions(This,sIndex,pVal)
01044
01045 #define IRbtlkController_cmdGetDateTime(This,psDateTime)    \
01046     (This)->lpVtbl -> cmdGetDateTime(This,psDateTime)
01047
01048 #define IRbtlkController_cmdLetDateTime(This,psDateTime)    \
01049     (This)->lpVtbl -> cmdLetDateTime(This,psDateTime)
01050
01051 #define IRbtlkController_cmdClearCtrlLog(This)  \
01052     (This)->lpVtbl -> cmdClearCtrlLog(This)
01053
01054 #define IRbtlkController_cmdStartCtrlLog(This)  \
01055     (This)->lpVtbl -> cmdStartCtrlLog(This)
01056
01057 #define IRbtlkController_cmdStopCtrlLog(This)   \
01058     (This)->lpVtbl -> cmdStopCtrlLog(This)
01059
01060 #define IRbtlkController_cmdGetParamCtrlLog(This,pSmpCnt,pSmpRate)  \
01061     (This)->lpVtbl -> cmdGetParamCtrlLog(This,pSmpCnt,pSmpRate)
01062
01063 #define IRbtlkController_cmdSwitchCtrlLog(This,sMode)   \
01064     (This)->lpVtbl -> cmdSwitchCtrlLog(This,sMode)
01065
01066 #define IRbtlkController_cmdCancelCtrlLog(This) \
01067     (This)->lpVtbl -> cmdCancelCtrlLog(This)
01068
01069 #define IRbtlkController_cmdGetMode(This,pVal)  \
01070     (This)->lpVtbl -> cmdGetMode(This,pVal)
01071
01072 #define IRbtlkController_cmdSetMode(This,iMode) \
01073     (This)->lpVtbl -> cmdSetMode(This,iMode)
01074
01075 #define IRbtlkController_cmdGetFreeMemory(This,pVal)    \
01076     (This)->lpVtbl -> cmdGetFreeMemory(This,pVal)
01077
01078 #define IRbtlkController_cmdGetRobotType(This,pVal) \
01079     (This)->lpVtbl -> cmdGetRobotType(This,pVal)
01080
01081 #define IRbtlkController_cmdGetJointInfo(This,sMode,pVal)   \
01082     (This)->lpVtbl -> cmdGetJointInfo(This,sMode,pVal)
01083
01084 #define IRbtlkController_cmdGetJobStatus(This,JobID,pStatus)    \
01085     (This)->lpVtbl -> cmdGetJobStatus(This,JobID,pStatus)
01086
01087 #define IRbtlkController_cmdLetJobStatus(This,JobID,sStatus)    \
01088     (This)->lpVtbl -> cmdLetJobStatus(This,JobID,sStatus)
01089
01090 #define IRbtlkController_cmdRequestFileSave(This,pTransMode,pTaskID)    \
01091     (This)->lpVtbl -> cmdRequestFileSave(This,pTransMode,pTaskID)
01092
01093 #define IRbtlkController_cmdGetTransMode(This,pTransMode)   \
01094     (This)->lpVtbl -> cmdGetTransMode(This,pTransMode)
01095
01096 #define IRbtlkController_cmdRequestRomUpdate(This)  \
01097     (This)->lpVtbl -> cmdRequestRomUpdate(This)
01098
01099 #define IRbtlkController_cmdNoticeRomVersion(This,sVer) \
01100     (This)->lpVtbl -> cmdNoticeRomVersion(This,sVer)
01101
01102 #define IRbtlkController_cmdDoSignal(This,sMode,sAction)    \
01103     (This)->lpVtbl -> cmdDoSignal(This,sMode,sAction)
01104
01105 #define IRbtlkController_cmdSrvJointParam(This,pJoint,pInterval,pCounts,pData1,pData2)  \
01106     (This)->lpVtbl -> cmdSrvJointParam(This,pJoint,pInterval,pCounts,pData1,pData2)
01107
01108 #define IRbtlkController_cmdSrvJointData(This,sOffset,sCounts,pData1,pData2)    \
01109     (This)->lpVtbl -> cmdSrvJointData(This,sOffset,sCounts,pData1,pData2)
01110
01111 #define IRbtlkController_cmdSrvJointCancel(This)    \
01112     (This)->lpVtbl -> cmdSrvJointCancel(This)
01113
01114 #define IRbtlkController_cmdGetErrorCode(This,pVal) \
01115     (This)->lpVtbl -> cmdGetErrorCode(This,pVal)
01116
01117 #define IRbtlkController_cmdClearError(This,lErrCode,pVal)  \
01118     (This)->lpVtbl -> cmdClearError(This,lErrCode,pVal)
01119
01120 #define IRbtlkController_cmdGetOperationLog(This,sIndex,pCode,szDate,szTime,szModule,szMsg) \
01121     (This)->lpVtbl -> cmdGetOperationLog(This,sIndex,pCode,szDate,szTime,szModule,szMsg)
01122
01123 #define IRbtlkController_cmdGetErrorLog(This,sIndex,pCode,pLevel,szDate,szTime,szModule,szMsg)  \
01124     (This)->lpVtbl -> cmdGetErrorLog(This,sIndex,pCode,pLevel,szDate,szTime,szModule,szMsg)
01125
01126 #define IRbtlkController_cmdGetControlLog(This,sIndex,pData,pReg,pProgNo,pLineNo)   \
01127     (This)->lpVtbl -> cmdGetControlLog(This,sIndex,pData,pReg,pProgNo,pLineNo)
01128
01129 #define IRbtlkController_cmdSetOption(This,sMode,lKey,pVal) \
01130     (This)->lpVtbl -> cmdSetOption(This,sMode,lKey,pVal)
01131
01132 #define IRbtlkController_cmdChangeConfig(This,sMode)    \
01133     (This)->lpVtbl -> cmdChangeConfig(This,sMode)
01134
01135 #define IRbtlkController_cmdLetConfig(This,sMode,sIndex,newVal) \
01136     (This)->lpVtbl -> cmdLetConfig(This,sMode,sIndex,newVal)
01137
01138 #define IRbtlkController_cmdGetConfig(This,sMode,sIndex,pVal)   \
01139     (This)->lpVtbl -> cmdGetConfig(This,sMode,sIndex,pVal)
01140
01141 #define IRbtlkController_cmdGetStatus(This,sModule,sIndex,pVal) \
01142     (This)->lpVtbl -> cmdGetStatus(This,sModule,sIndex,pVal)
01143
01144 #endif /* COBJMACROS */
01145
01146
01147 #endif  /* C style interface */
01148
01149
01150
01151 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetVersions_Proxy(
01152     IRbtlkController __RPC_FAR * This,
01153     /* [in] */ short sIndex,
01154     /* [out] */ CHAR __RPC_FAR *pVal);
01155
01156
01157 void __RPC_STUB IRbtlkController_cmdGetVersions_Stub(
01158     IRpcStubBuffer *This,
01159     IRpcChannelBuffer *_pRpcChannelBuffer,
01160     PRPC_MESSAGE _pRpcMessage,
01161     DWORD *_pdwStubPhase);
01162
01163
01164 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetDateTime_Proxy(
01165     IRbtlkController __RPC_FAR * This,
01166     /* [out] */ short __RPC_FAR *psDateTime);
01167
01168
01169 void __RPC_STUB IRbtlkController_cmdGetDateTime_Stub(
01170     IRpcStubBuffer *This,
01171     IRpcChannelBuffer *_pRpcChannelBuffer,
01172     PRPC_MESSAGE _pRpcMessage,
01173     DWORD *_pdwStubPhase);
01174
01175
01176 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdLetDateTime_Proxy(
01177     IRbtlkController __RPC_FAR * This,
01178     /* [in] */ short __RPC_FAR *psDateTime);
01179
01180
01181 void __RPC_STUB IRbtlkController_cmdLetDateTime_Stub(
01182     IRpcStubBuffer *This,
01183     IRpcChannelBuffer *_pRpcChannelBuffer,
01184     PRPC_MESSAGE _pRpcMessage,
01185     DWORD *_pdwStubPhase);
01186
01187
01188 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdClearCtrlLog_Proxy(
01189     IRbtlkController __RPC_FAR * This);
01190
01191
01192 void __RPC_STUB IRbtlkController_cmdClearCtrlLog_Stub(
01193     IRpcStubBuffer *This,
01194     IRpcChannelBuffer *_pRpcChannelBuffer,
01195     PRPC_MESSAGE _pRpcMessage,
01196     DWORD *_pdwStubPhase);
01197
01198
01199 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdStartCtrlLog_Proxy(
01200     IRbtlkController __RPC_FAR * This);
01201
01202
01203 void __RPC_STUB IRbtlkController_cmdStartCtrlLog_Stub(
01204     IRpcStubBuffer *This,
01205     IRpcChannelBuffer *_pRpcChannelBuffer,
01206     PRPC_MESSAGE _pRpcMessage,
01207     DWORD *_pdwStubPhase);
01208
01209
01210 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdStopCtrlLog_Proxy(
01211     IRbtlkController __RPC_FAR * This);
01212
01213
01214 void __RPC_STUB IRbtlkController_cmdStopCtrlLog_Stub(
01215     IRpcStubBuffer *This,
01216     IRpcChannelBuffer *_pRpcChannelBuffer,
01217     PRPC_MESSAGE _pRpcMessage,
01218     DWORD *_pdwStubPhase);
01219
01220
01221 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetParamCtrlLog_Proxy(
01222     IRbtlkController __RPC_FAR * This,
01223     /* [out] */ long __RPC_FAR *pSmpCnt,
01224     /* [out] */ long __RPC_FAR *pSmpRate);
01225
01226
01227 void __RPC_STUB IRbtlkController_cmdGetParamCtrlLog_Stub(
01228     IRpcStubBuffer *This,
01229     IRpcChannelBuffer *_pRpcChannelBuffer,
01230     PRPC_MESSAGE _pRpcMessage,
01231     DWORD *_pdwStubPhase);
01232
01233
01234 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdSwitchCtrlLog_Proxy(
01235     IRbtlkController __RPC_FAR * This,
01236     /* [in] */ short sMode);
01237
01238
01239 void __RPC_STUB IRbtlkController_cmdSwitchCtrlLog_Stub(
01240     IRpcStubBuffer *This,
01241     IRpcChannelBuffer *_pRpcChannelBuffer,
01242     PRPC_MESSAGE _pRpcMessage,
01243     DWORD *_pdwStubPhase);
01244
01245
01246 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdCancelCtrlLog_Proxy(
01247     IRbtlkController __RPC_FAR * This);
01248
01249
01250 void __RPC_STUB IRbtlkController_cmdCancelCtrlLog_Stub(
01251     IRpcStubBuffer *This,
01252     IRpcChannelBuffer *_pRpcChannelBuffer,
01253     PRPC_MESSAGE _pRpcMessage,
01254     DWORD *_pdwStubPhase);
01255
01256
01257 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetMode_Proxy(
01258     IRbtlkController __RPC_FAR * This,
01259     /* [out] */ short __RPC_FAR *pVal);
01260
01261
01262 void __RPC_STUB IRbtlkController_cmdGetMode_Stub(
01263     IRpcStubBuffer *This,
01264     IRpcChannelBuffer *_pRpcChannelBuffer,
01265     PRPC_MESSAGE _pRpcMessage,
01266     DWORD *_pdwStubPhase);
01267
01268
01269 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdSetMode_Proxy(
01270     IRbtlkController __RPC_FAR * This,
01271     /* [in] */ short iMode);
01272
01273
01274 void __RPC_STUB IRbtlkController_cmdSetMode_Stub(
01275     IRpcStubBuffer *This,
01276     IRpcChannelBuffer *_pRpcChannelBuffer,
01277     PRPC_MESSAGE _pRpcMessage,
01278     DWORD *_pdwStubPhase);
01279
01280
01281 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetFreeMemory_Proxy(
01282     IRbtlkController __RPC_FAR * This,
01283     /* [out] */ long __RPC_FAR *pVal);
01284
01285
01286 void __RPC_STUB IRbtlkController_cmdGetFreeMemory_Stub(
01287     IRpcStubBuffer *This,
01288     IRpcChannelBuffer *_pRpcChannelBuffer,
01289     PRPC_MESSAGE _pRpcMessage,
01290     DWORD *_pdwStubPhase);
01291
01292
01293 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetRobotType_Proxy(
01294     IRbtlkController __RPC_FAR * This,
01295     /* [out] */ long __RPC_FAR *pVal);
01296
01297
01298 void __RPC_STUB IRbtlkController_cmdGetRobotType_Stub(
01299     IRpcStubBuffer *This,
01300     IRpcChannelBuffer *_pRpcChannelBuffer,
01301     PRPC_MESSAGE _pRpcMessage,
01302     DWORD *_pdwStubPhase);
01303
01304
01305 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetJointInfo_Proxy(
01306     IRbtlkController __RPC_FAR * This,
01307     /* [in] */ short sMode,
01308     /* [out] */ short __RPC_FAR *pVal);
01309
01310
01311 void __RPC_STUB IRbtlkController_cmdGetJointInfo_Stub(
01312     IRpcStubBuffer *This,
01313     IRpcChannelBuffer *_pRpcChannelBuffer,
01314     PRPC_MESSAGE _pRpcMessage,
01315     DWORD *_pdwStubPhase);
01316
01317
01318 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetJobStatus_Proxy(
01319     IRbtlkController __RPC_FAR * This,
01320     /* [in] */ long JobID,
01321     /* [out] */ short __RPC_FAR *pStatus);
01322
01323
01324 void __RPC_STUB IRbtlkController_cmdGetJobStatus_Stub(
01325     IRpcStubBuffer *This,
01326     IRpcChannelBuffer *_pRpcChannelBuffer,
01327     PRPC_MESSAGE _pRpcMessage,
01328     DWORD *_pdwStubPhase);
01329
01330
01331 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdLetJobStatus_Proxy(
01332     IRbtlkController __RPC_FAR * This,
01333     /* [in] */ long JobID,
01334     /* [in] */ short sStatus);
01335
01336
01337 void __RPC_STUB IRbtlkController_cmdLetJobStatus_Stub(
01338     IRpcStubBuffer *This,
01339     IRpcChannelBuffer *_pRpcChannelBuffer,
01340     PRPC_MESSAGE _pRpcMessage,
01341     DWORD *_pdwStubPhase);
01342
01343
01344 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdRequestFileSave_Proxy(
01345     IRbtlkController __RPC_FAR * This,
01346     /* [out] */ short __RPC_FAR *pTransMode,
01347     /* [out] */ long __RPC_FAR *pTaskID);
01348
01349
01350 void __RPC_STUB IRbtlkController_cmdRequestFileSave_Stub(
01351     IRpcStubBuffer *This,
01352     IRpcChannelBuffer *_pRpcChannelBuffer,
01353     PRPC_MESSAGE _pRpcMessage,
01354     DWORD *_pdwStubPhase);
01355
01356
01357 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetTransMode_Proxy(
01358     IRbtlkController __RPC_FAR * This,
01359     /* [out] */ short __RPC_FAR *pTransMode);
01360
01361
01362 void __RPC_STUB IRbtlkController_cmdGetTransMode_Stub(
01363     IRpcStubBuffer *This,
01364     IRpcChannelBuffer *_pRpcChannelBuffer,
01365     PRPC_MESSAGE _pRpcMessage,
01366     DWORD *_pdwStubPhase);
01367
01368
01369 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdRequestRomUpdate_Proxy(
01370     IRbtlkController __RPC_FAR * This);
01371
01372
01373 void __RPC_STUB IRbtlkController_cmdRequestRomUpdate_Stub(
01374     IRpcStubBuffer *This,
01375     IRpcChannelBuffer *_pRpcChannelBuffer,
01376     PRPC_MESSAGE _pRpcMessage,
01377     DWORD *_pdwStubPhase);
01378
01379
01380 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdNoticeRomVersion_Proxy(
01381     IRbtlkController __RPC_FAR * This,
01382     /* [in] */ short sVer);
01383
01384
01385 void __RPC_STUB IRbtlkController_cmdNoticeRomVersion_Stub(
01386     IRpcStubBuffer *This,
01387     IRpcChannelBuffer *_pRpcChannelBuffer,
01388     PRPC_MESSAGE _pRpcMessage,
01389     DWORD *_pdwStubPhase);
01390
01391
01392 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdDoSignal_Proxy(
01393     IRbtlkController __RPC_FAR * This,
01394     /* [in] */ short sMode,
01395     /* [in] */ short sAction);
01396
01397
01398 void __RPC_STUB IRbtlkController_cmdDoSignal_Stub(
01399     IRpcStubBuffer *This,
01400     IRpcChannelBuffer *_pRpcChannelBuffer,
01401     PRPC_MESSAGE _pRpcMessage,
01402     DWORD *_pdwStubPhase);
01403
01404
01405 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdSrvJointParam_Proxy(
01406     IRbtlkController __RPC_FAR * This,
01407     /* [out] */ short __RPC_FAR *pJoint,
01408     /* [out] */ short __RPC_FAR *pInterval,
01409     /* [out] */ short __RPC_FAR *pCounts,
01410     /* [out] */ short __RPC_FAR *pData1,
01411     /* [out] */ short __RPC_FAR *pData2);
01412
01413
01414 void __RPC_STUB IRbtlkController_cmdSrvJointParam_Stub(
01415     IRpcStubBuffer *This,
01416     IRpcChannelBuffer *_pRpcChannelBuffer,
01417     PRPC_MESSAGE _pRpcMessage,
01418     DWORD *_pdwStubPhase);
01419
01420
01421 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdSrvJointData_Proxy(
01422     IRbtlkController __RPC_FAR * This,
01423     /* [in] */ short sOffset,
01424     /* [in] */ short sCounts,
01425     /* [out] */ float __RPC_FAR *__RPC_FAR *pData1,
01426     /* [out] */ float __RPC_FAR *__RPC_FAR *pData2);
01427
01428
01429 void __RPC_STUB IRbtlkController_cmdSrvJointData_Stub(
01430     IRpcStubBuffer *This,
01431     IRpcChannelBuffer *_pRpcChannelBuffer,
01432     PRPC_MESSAGE _pRpcMessage,
01433     DWORD *_pdwStubPhase);
01434
01435
01436 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdSrvJointCancel_Proxy(
01437     IRbtlkController __RPC_FAR * This);
01438
01439
01440 void __RPC_STUB IRbtlkController_cmdSrvJointCancel_Stub(
01441     IRpcStubBuffer *This,
01442     IRpcChannelBuffer *_pRpcChannelBuffer,
01443     PRPC_MESSAGE _pRpcMessage,
01444     DWORD *_pdwStubPhase);
01445
01446
01447 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetErrorCode_Proxy(
01448     IRbtlkController __RPC_FAR * This,
01449     /* [out] */ long __RPC_FAR *pVal);
01450
01451
01452 void __RPC_STUB IRbtlkController_cmdGetErrorCode_Stub(
01453     IRpcStubBuffer *This,
01454     IRpcChannelBuffer *_pRpcChannelBuffer,
01455     PRPC_MESSAGE _pRpcMessage,
01456     DWORD *_pdwStubPhase);
01457
01458
01459 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdClearError_Proxy(
01460     IRbtlkController __RPC_FAR * This,
01461     /* [in] */ long lErrCode,
01462     /* [out] */ short __RPC_FAR *pVal);
01463
01464
01465 void __RPC_STUB IRbtlkController_cmdClearError_Stub(
01466     IRpcStubBuffer *This,
01467     IRpcChannelBuffer *_pRpcChannelBuffer,
01468     PRPC_MESSAGE _pRpcMessage,
01469     DWORD *_pdwStubPhase);
01470
01471
01472 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetOperationLog_Proxy(
01473     IRbtlkController __RPC_FAR * This,
01474     /* [in] */ short sIndex,
01475     /* [out] */ short __RPC_FAR *pCode,
01476     /* [out] */ CHAR __RPC_FAR *szDate,
01477     /* [out] */ CHAR __RPC_FAR *szTime,
01478     /* [out] */ CHAR __RPC_FAR *szModule,
01479     /* [out] */ CHAR __RPC_FAR *szMsg);
01480
01481
01482 void __RPC_STUB IRbtlkController_cmdGetOperationLog_Stub(
01483     IRpcStubBuffer *This,
01484     IRpcChannelBuffer *_pRpcChannelBuffer,
01485     PRPC_MESSAGE _pRpcMessage,
01486     DWORD *_pdwStubPhase);
01487
01488
01489 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetErrorLog_Proxy(
01490     IRbtlkController __RPC_FAR * This,
01491     /* [in] */ short sIndex,
01492     /* [out] */ short __RPC_FAR *pCode,
01493     /* [out] */ short __RPC_FAR *pLevel,
01494     /* [out] */ CHAR __RPC_FAR *szDate,
01495     /* [out] */ CHAR __RPC_FAR *szTime,
01496     /* [out] */ CHAR __RPC_FAR *szModule,
01497     /* [out] */ CHAR __RPC_FAR *szMsg);
01498
01499
01500 void __RPC_STUB IRbtlkController_cmdGetErrorLog_Stub(
01501     IRpcStubBuffer *This,
01502     IRpcChannelBuffer *_pRpcChannelBuffer,
01503     PRPC_MESSAGE _pRpcMessage,
01504     DWORD *_pdwStubPhase);
01505
01506
01507 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetControlLog_Proxy(
01508     IRbtlkController __RPC_FAR * This,
01509     /* [in] */ short sIndex,
01510     /* [out] */ float __RPC_FAR pData[ 8 ][ 4 ],
01511     /* [out] */ float __RPC_FAR *pReg,
01512     /* [out] */ short __RPC_FAR *pProgNo,
01513     /* [out] */ short __RPC_FAR *pLineNo);
01514
01515
01516 void __RPC_STUB IRbtlkController_cmdGetControlLog_Stub(
01517     IRpcStubBuffer *This,
01518     IRpcChannelBuffer *_pRpcChannelBuffer,
01519     PRPC_MESSAGE _pRpcMessage,
01520     DWORD *_pdwStubPhase);
01521
01522
01523 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdSetOption_Proxy(
01524     IRbtlkController __RPC_FAR * This,
01525     /* [in] */ short sMode,
01526     /* [in] */ long lKey,
01527     /* [out] */ CHAR __RPC_FAR *pVal);
01528
01529
01530 void __RPC_STUB IRbtlkController_cmdSetOption_Stub(
01531     IRpcStubBuffer *This,
01532     IRpcChannelBuffer *_pRpcChannelBuffer,
01533     PRPC_MESSAGE _pRpcMessage,
01534     DWORD *_pdwStubPhase);
01535
01536
01537 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdChangeConfig_Proxy(
01538     IRbtlkController __RPC_FAR * This,
01539     /* [in] */ short sMode);
01540
01541
01542 void __RPC_STUB IRbtlkController_cmdChangeConfig_Stub(
01543     IRpcStubBuffer *This,
01544     IRpcChannelBuffer *_pRpcChannelBuffer,
01545     PRPC_MESSAGE _pRpcMessage,
01546     DWORD *_pdwStubPhase);
01547
01548
01549 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdLetConfig_Proxy(
01550     IRbtlkController __RPC_FAR * This,
01551     /* [in] */ short sMode,
01552     /* [in] */ short sIndex,
01553     /* [in] */ long newVal);
01554
01555
01556 void __RPC_STUB IRbtlkController_cmdLetConfig_Stub(
01557     IRpcStubBuffer *This,
01558     IRpcChannelBuffer *_pRpcChannelBuffer,
01559     PRPC_MESSAGE _pRpcMessage,
01560     DWORD *_pdwStubPhase);
01561
01562
01563 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetConfig_Proxy(
01564     IRbtlkController __RPC_FAR * This,
01565     /* [in] */ short sMode,
01566     /* [in] */ short sIndex,
01567     /* [out] */ long __RPC_FAR *pVal);
01568
01569
01570 void __RPC_STUB IRbtlkController_cmdGetConfig_Stub(
01571     IRpcStubBuffer *This,
01572     IRpcChannelBuffer *_pRpcChannelBuffer,
01573     PRPC_MESSAGE _pRpcMessage,
01574     DWORD *_pdwStubPhase);
01575
01576
01577 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkController_cmdGetStatus_Proxy(
01578     IRbtlkController __RPC_FAR * This,
01579     /* [in] */ short sModule,
01580     /* [in] */ short sIndex,
01581     /* [out] */ short __RPC_FAR *pVal);
01582
01583
01584 void __RPC_STUB IRbtlkController_cmdGetStatus_Stub(
01585     IRpcStubBuffer *This,
01586     IRpcChannelBuffer *_pRpcChannelBuffer,
01587     PRPC_MESSAGE _pRpcMessage,
01588     DWORD *_pdwStubPhase);
01589
01590
01591
01592 #endif  /* __IRbtlkController_INTERFACE_DEFINED__ */
01593
01594
01595 #ifndef __IRbtlkVariable_INTERFACE_DEFINED__
01596 #define __IRbtlkVariable_INTERFACE_DEFINED__
01597
01598 /* interface IRbtlkVariable */
01599 /* [unique][helpstring][uuid][object] */
01600
01601
01602 EXTERN_C const IID IID_IRbtlkVariable;
01603
01604 #if defined(__cplusplus) && !defined(CINTERFACE)
01605
01606     MIDL_INTERFACE("9C5AD78B-2D87-4bc0-95CC-A0CD897CEEF0")
01607     IRbtlkVariable : public IUnknown
01608     {
01609     public:
01610         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetI(
01611             /* [in] */ short sIC,
01612             /* [in] */ short sIndex,
01613             /* [out] */ long __RPC_FAR *pVal) = 0;
01614
01615         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetI(
01616             /* [in] */ short sIC,
01617             /* [in] */ short sIndex,
01618             /* [in] */ long newVal) = 0;
01619
01620         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetF(
01621             /* [in] */ short sIC,
01622             /* [in] */ short sIndex,
01623             /* [out] */ float __RPC_FAR *pVal) = 0;
01624
01625         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetF(
01626             /* [in] */ short sIC,
01627             /* [in] */ short sIndex,
01628             /* [in] */ float newVal) = 0;
01629
01630         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetP(
01631             /* [in] */ short sIC,
01632             /* [in] */ short sIndex,
01633             /* [out] */ float __RPC_FAR *pVal) = 0;
01634
01635         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetP(
01636             /* [in] */ short sIC,
01637             /* [in] */ short sIndex,
01638             /* [in] */ float __RPC_FAR *newVal) = 0;
01639
01640         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetJ(
01641             /* [in] */ short sIC,
01642             /* [in] */ short sIndex,
01643             /* [out] */ float __RPC_FAR *pVal) = 0;
01644
01645         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetJ(
01646             /* [in] */ short sIC,
01647             /* [in] */ short sIndex,
01648             /* [in] */ float __RPC_FAR *newVal) = 0;
01649
01650         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetD(
01651             /* [in] */ short sIC,
01652             /* [in] */ short sIndex,
01653             /* [out] */ double __RPC_FAR *pVal) = 0;
01654
01655         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetD(
01656             /* [in] */ short sIC,
01657             /* [in] */ short sIndex,
01658             /* [in] */ double newVal) = 0;
01659
01660         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetS(
01661             /* [in] */ short sIC,
01662             /* [in] */ short sIndex,
01663             /* [out] */ CHAR __RPC_FAR *pVal) = 0;
01664
01665         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetS(
01666             /* [in] */ short sIC,
01667             /* [in] */ short sIndex,
01668             /* [in] */ CHAR __RPC_FAR *newVal) = 0;
01669
01670         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetV(
01671             /* [in] */ short sIC,
01672             /* [in] */ short sIndex,
01673             /* [out] */ float __RPC_FAR *pVal) = 0;
01674
01675         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetV(
01676             /* [in] */ short sIC,
01677             /* [in] */ short sIndex,
01678             /* [in] */ float __RPC_FAR *newVal) = 0;
01679
01680         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetT(
01681             /* [in] */ short sIC,
01682             /* [in] */ short sIndex,
01683             /* [out] */ float __RPC_FAR *pVal) = 0;
01684
01685         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetT(
01686             /* [in] */ short sIC,
01687             /* [in] */ short sIndex,
01688             /* [in] */ float __RPC_FAR *newVal) = 0;
01689
01690         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetTabLen(
01691             /* [in] */ short sPrgIC,
01692             /* [in] */ short sTypeIC,
01693             /* [out] */ short __RPC_FAR *pVal) = 0;
01694
01695         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetDefIO(
01696             /* [in] */ short sPort,
01697             /* [in] */ short sType,
01698             /* [in] */ long lMask,
01699             /* [out] */ long __RPC_FAR *pVal) = 0;
01700
01701         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetDefIO(
01702             /* [in] */ short sPort,
01703             /* [in] */ short sType,
01704             /* [in] */ long lMask,
01705             /* [in] */ long lVal) = 0;
01706
01707     };
01708
01709 #else   /* C style interface */
01710
01711     typedef struct IRbtlkVariableVtbl
01712     {
01713         BEGIN_INTERFACE
01714
01715         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
01716             IRbtlkVariable __RPC_FAR * This,
01717             /* [in] */ REFIID riid,
01718             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
01719
01720         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
01721             IRbtlkVariable __RPC_FAR * This);
01722
01723         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
01724             IRbtlkVariable __RPC_FAR * This);
01725
01726         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetI )(
01727             IRbtlkVariable __RPC_FAR * This,
01728             /* [in] */ short sIC,
01729             /* [in] */ short sIndex,
01730             /* [out] */ long __RPC_FAR *pVal);
01731
01732         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetI )(
01733             IRbtlkVariable __RPC_FAR * This,
01734             /* [in] */ short sIC,
01735             /* [in] */ short sIndex,
01736             /* [in] */ long newVal);
01737
01738         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetF )(
01739             IRbtlkVariable __RPC_FAR * This,
01740             /* [in] */ short sIC,
01741             /* [in] */ short sIndex,
01742             /* [out] */ float __RPC_FAR *pVal);
01743
01744         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetF )(
01745             IRbtlkVariable __RPC_FAR * This,
01746             /* [in] */ short sIC,
01747             /* [in] */ short sIndex,
01748             /* [in] */ float newVal);
01749
01750         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetP )(
01751             IRbtlkVariable __RPC_FAR * This,
01752             /* [in] */ short sIC,
01753             /* [in] */ short sIndex,
01754             /* [out] */ float __RPC_FAR *pVal);
01755
01756         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetP )(
01757             IRbtlkVariable __RPC_FAR * This,
01758             /* [in] */ short sIC,
01759             /* [in] */ short sIndex,
01760             /* [in] */ float __RPC_FAR *newVal);
01761
01762         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetJ )(
01763             IRbtlkVariable __RPC_FAR * This,
01764             /* [in] */ short sIC,
01765             /* [in] */ short sIndex,
01766             /* [out] */ float __RPC_FAR *pVal);
01767
01768         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetJ )(
01769             IRbtlkVariable __RPC_FAR * This,
01770             /* [in] */ short sIC,
01771             /* [in] */ short sIndex,
01772             /* [in] */ float __RPC_FAR *newVal);
01773
01774         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetD )(
01775             IRbtlkVariable __RPC_FAR * This,
01776             /* [in] */ short sIC,
01777             /* [in] */ short sIndex,
01778             /* [out] */ double __RPC_FAR *pVal);
01779
01780         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetD )(
01781             IRbtlkVariable __RPC_FAR * This,
01782             /* [in] */ short sIC,
01783             /* [in] */ short sIndex,
01784             /* [in] */ double newVal);
01785
01786         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetS )(
01787             IRbtlkVariable __RPC_FAR * This,
01788             /* [in] */ short sIC,
01789             /* [in] */ short sIndex,
01790             /* [out] */ CHAR __RPC_FAR *pVal);
01791
01792         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetS )(
01793             IRbtlkVariable __RPC_FAR * This,
01794             /* [in] */ short sIC,
01795             /* [in] */ short sIndex,
01796             /* [in] */ CHAR __RPC_FAR *newVal);
01797
01798         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetV )(
01799             IRbtlkVariable __RPC_FAR * This,
01800             /* [in] */ short sIC,
01801             /* [in] */ short sIndex,
01802             /* [out] */ float __RPC_FAR *pVal);
01803
01804         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetV )(
01805             IRbtlkVariable __RPC_FAR * This,
01806             /* [in] */ short sIC,
01807             /* [in] */ short sIndex,
01808             /* [in] */ float __RPC_FAR *newVal);
01809
01810         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetT )(
01811             IRbtlkVariable __RPC_FAR * This,
01812             /* [in] */ short sIC,
01813             /* [in] */ short sIndex,
01814             /* [out] */ float __RPC_FAR *pVal);
01815
01816         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetT )(
01817             IRbtlkVariable __RPC_FAR * This,
01818             /* [in] */ short sIC,
01819             /* [in] */ short sIndex,
01820             /* [in] */ float __RPC_FAR *newVal);
01821
01822         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetTabLen )(
01823             IRbtlkVariable __RPC_FAR * This,
01824             /* [in] */ short sPrgIC,
01825             /* [in] */ short sTypeIC,
01826             /* [out] */ short __RPC_FAR *pVal);
01827
01828         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetDefIO )(
01829             IRbtlkVariable __RPC_FAR * This,
01830             /* [in] */ short sPort,
01831             /* [in] */ short sType,
01832             /* [in] */ long lMask,
01833             /* [out] */ long __RPC_FAR *pVal);
01834
01835         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetDefIO )(
01836             IRbtlkVariable __RPC_FAR * This,
01837             /* [in] */ short sPort,
01838             /* [in] */ short sType,
01839             /* [in] */ long lMask,
01840             /* [in] */ long lVal);
01841
01842         END_INTERFACE
01843     } IRbtlkVariableVtbl;
01844
01845     interface IRbtlkVariable
01846     {
01847         CONST_VTBL struct IRbtlkVariableVtbl __RPC_FAR *lpVtbl;
01848     };
01849
01850
01851
01852 #ifdef COBJMACROS
01853
01854
01855 #define IRbtlkVariable_QueryInterface(This,riid,ppvObject)  \
01856     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
01857
01858 #define IRbtlkVariable_AddRef(This) \
01859     (This)->lpVtbl -> AddRef(This)
01860
01861 #define IRbtlkVariable_Release(This)    \
01862     (This)->lpVtbl -> Release(This)
01863
01864
01865 #define IRbtlkVariable_cmdGetI(This,sIC,sIndex,pVal)    \
01866     (This)->lpVtbl -> cmdGetI(This,sIC,sIndex,pVal)
01867
01868 #define IRbtlkVariable_cmdLetI(This,sIC,sIndex,newVal)  \
01869     (This)->lpVtbl -> cmdLetI(This,sIC,sIndex,newVal)
01870
01871 #define IRbtlkVariable_cmdGetF(This,sIC,sIndex,pVal)    \
01872     (This)->lpVtbl -> cmdGetF(This,sIC,sIndex,pVal)
01873
01874 #define IRbtlkVariable_cmdLetF(This,sIC,sIndex,newVal)  \
01875     (This)->lpVtbl -> cmdLetF(This,sIC,sIndex,newVal)
01876
01877 #define IRbtlkVariable_cmdGetP(This,sIC,sIndex,pVal)    \
01878     (This)->lpVtbl -> cmdGetP(This,sIC,sIndex,pVal)
01879
01880 #define IRbtlkVariable_cmdLetP(This,sIC,sIndex,newVal)  \
01881     (This)->lpVtbl -> cmdLetP(This,sIC,sIndex,newVal)
01882
01883 #define IRbtlkVariable_cmdGetJ(This,sIC,sIndex,pVal)    \
01884     (This)->lpVtbl -> cmdGetJ(This,sIC,sIndex,pVal)
01885
01886 #define IRbtlkVariable_cmdLetJ(This,sIC,sIndex,newVal)  \
01887     (This)->lpVtbl -> cmdLetJ(This,sIC,sIndex,newVal)
01888
01889 #define IRbtlkVariable_cmdGetD(This,sIC,sIndex,pVal)    \
01890     (This)->lpVtbl -> cmdGetD(This,sIC,sIndex,pVal)
01891
01892 #define IRbtlkVariable_cmdLetD(This,sIC,sIndex,newVal)  \
01893     (This)->lpVtbl -> cmdLetD(This,sIC,sIndex,newVal)
01894
01895 #define IRbtlkVariable_cmdGetS(This,sIC,sIndex,pVal)    \
01896     (This)->lpVtbl -> cmdGetS(This,sIC,sIndex,pVal)
01897
01898 #define IRbtlkVariable_cmdLetS(This,sIC,sIndex,newVal)  \
01899     (This)->lpVtbl -> cmdLetS(This,sIC,sIndex,newVal)
01900
01901 #define IRbtlkVariable_cmdGetV(This,sIC,sIndex,pVal)    \
01902     (This)->lpVtbl -> cmdGetV(This,sIC,sIndex,pVal)
01903
01904 #define IRbtlkVariable_cmdLetV(This,sIC,sIndex,newVal)  \
01905     (This)->lpVtbl -> cmdLetV(This,sIC,sIndex,newVal)
01906
01907 #define IRbtlkVariable_cmdGetT(This,sIC,sIndex,pVal)    \
01908     (This)->lpVtbl -> cmdGetT(This,sIC,sIndex,pVal)
01909
01910 #define IRbtlkVariable_cmdLetT(This,sIC,sIndex,newVal)  \
01911     (This)->lpVtbl -> cmdLetT(This,sIC,sIndex,newVal)
01912
01913 #define IRbtlkVariable_cmdGetTabLen(This,sPrgIC,sTypeIC,pVal)   \
01914     (This)->lpVtbl -> cmdGetTabLen(This,sPrgIC,sTypeIC,pVal)
01915
01916 #define IRbtlkVariable_cmdGetDefIO(This,sPort,sType,lMask,pVal) \
01917     (This)->lpVtbl -> cmdGetDefIO(This,sPort,sType,lMask,pVal)
01918
01919 #define IRbtlkVariable_cmdLetDefIO(This,sPort,sType,lMask,lVal) \
01920     (This)->lpVtbl -> cmdLetDefIO(This,sPort,sType,lMask,lVal)
01921
01922 #endif /* COBJMACROS */
01923
01924
01925 #endif  /* C style interface */
01926
01927
01928
01929 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetI_Proxy(
01930     IRbtlkVariable __RPC_FAR * This,
01931     /* [in] */ short sIC,
01932     /* [in] */ short sIndex,
01933     /* [out] */ long __RPC_FAR *pVal);
01934
01935
01936 void __RPC_STUB IRbtlkVariable_cmdGetI_Stub(
01937     IRpcStubBuffer *This,
01938     IRpcChannelBuffer *_pRpcChannelBuffer,
01939     PRPC_MESSAGE _pRpcMessage,
01940     DWORD *_pdwStubPhase);
01941
01942
01943 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetI_Proxy(
01944     IRbtlkVariable __RPC_FAR * This,
01945     /* [in] */ short sIC,
01946     /* [in] */ short sIndex,
01947     /* [in] */ long newVal);
01948
01949
01950 void __RPC_STUB IRbtlkVariable_cmdLetI_Stub(
01951     IRpcStubBuffer *This,
01952     IRpcChannelBuffer *_pRpcChannelBuffer,
01953     PRPC_MESSAGE _pRpcMessage,
01954     DWORD *_pdwStubPhase);
01955
01956
01957 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetF_Proxy(
01958     IRbtlkVariable __RPC_FAR * This,
01959     /* [in] */ short sIC,
01960     /* [in] */ short sIndex,
01961     /* [out] */ float __RPC_FAR *pVal);
01962
01963
01964 void __RPC_STUB IRbtlkVariable_cmdGetF_Stub(
01965     IRpcStubBuffer *This,
01966     IRpcChannelBuffer *_pRpcChannelBuffer,
01967     PRPC_MESSAGE _pRpcMessage,
01968     DWORD *_pdwStubPhase);
01969
01970
01971 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetF_Proxy(
01972     IRbtlkVariable __RPC_FAR * This,
01973     /* [in] */ short sIC,
01974     /* [in] */ short sIndex,
01975     /* [in] */ float newVal);
01976
01977
01978 void __RPC_STUB IRbtlkVariable_cmdLetF_Stub(
01979     IRpcStubBuffer *This,
01980     IRpcChannelBuffer *_pRpcChannelBuffer,
01981     PRPC_MESSAGE _pRpcMessage,
01982     DWORD *_pdwStubPhase);
01983
01984
01985 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetP_Proxy(
01986     IRbtlkVariable __RPC_FAR * This,
01987     /* [in] */ short sIC,
01988     /* [in] */ short sIndex,
01989     /* [out] */ float __RPC_FAR *pVal);
01990
01991
01992 void __RPC_STUB IRbtlkVariable_cmdGetP_Stub(
01993     IRpcStubBuffer *This,
01994     IRpcChannelBuffer *_pRpcChannelBuffer,
01995     PRPC_MESSAGE _pRpcMessage,
01996     DWORD *_pdwStubPhase);
01997
01998
01999 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetP_Proxy(
02000     IRbtlkVariable __RPC_FAR * This,
02001     /* [in] */ short sIC,
02002     /* [in] */ short sIndex,
02003     /* [in] */ float __RPC_FAR *newVal);
02004
02005
02006 void __RPC_STUB IRbtlkVariable_cmdLetP_Stub(
02007     IRpcStubBuffer *This,
02008     IRpcChannelBuffer *_pRpcChannelBuffer,
02009     PRPC_MESSAGE _pRpcMessage,
02010     DWORD *_pdwStubPhase);
02011
02012
02013 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetJ_Proxy(
02014     IRbtlkVariable __RPC_FAR * This,
02015     /* [in] */ short sIC,
02016     /* [in] */ short sIndex,
02017     /* [out] */ float __RPC_FAR *pVal);
02018
02019
02020 void __RPC_STUB IRbtlkVariable_cmdGetJ_Stub(
02021     IRpcStubBuffer *This,
02022     IRpcChannelBuffer *_pRpcChannelBuffer,
02023     PRPC_MESSAGE _pRpcMessage,
02024     DWORD *_pdwStubPhase);
02025
02026
02027 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetJ_Proxy(
02028     IRbtlkVariable __RPC_FAR * This,
02029     /* [in] */ short sIC,
02030     /* [in] */ short sIndex,
02031     /* [in] */ float __RPC_FAR *newVal);
02032
02033
02034 void __RPC_STUB IRbtlkVariable_cmdLetJ_Stub(
02035     IRpcStubBuffer *This,
02036     IRpcChannelBuffer *_pRpcChannelBuffer,
02037     PRPC_MESSAGE _pRpcMessage,
02038     DWORD *_pdwStubPhase);
02039
02040
02041 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetD_Proxy(
02042     IRbtlkVariable __RPC_FAR * This,
02043     /* [in] */ short sIC,
02044     /* [in] */ short sIndex,
02045     /* [out] */ double __RPC_FAR *pVal);
02046
02047
02048 void __RPC_STUB IRbtlkVariable_cmdGetD_Stub(
02049     IRpcStubBuffer *This,
02050     IRpcChannelBuffer *_pRpcChannelBuffer,
02051     PRPC_MESSAGE _pRpcMessage,
02052     DWORD *_pdwStubPhase);
02053
02054
02055 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetD_Proxy(
02056     IRbtlkVariable __RPC_FAR * This,
02057     /* [in] */ short sIC,
02058     /* [in] */ short sIndex,
02059     /* [in] */ double newVal);
02060
02061
02062 void __RPC_STUB IRbtlkVariable_cmdLetD_Stub(
02063     IRpcStubBuffer *This,
02064     IRpcChannelBuffer *_pRpcChannelBuffer,
02065     PRPC_MESSAGE _pRpcMessage,
02066     DWORD *_pdwStubPhase);
02067
02068
02069 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetS_Proxy(
02070     IRbtlkVariable __RPC_FAR * This,
02071     /* [in] */ short sIC,
02072     /* [in] */ short sIndex,
02073     /* [out] */ CHAR __RPC_FAR *pVal);
02074
02075
02076 void __RPC_STUB IRbtlkVariable_cmdGetS_Stub(
02077     IRpcStubBuffer *This,
02078     IRpcChannelBuffer *_pRpcChannelBuffer,
02079     PRPC_MESSAGE _pRpcMessage,
02080     DWORD *_pdwStubPhase);
02081
02082
02083 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetS_Proxy(
02084     IRbtlkVariable __RPC_FAR * This,
02085     /* [in] */ short sIC,
02086     /* [in] */ short sIndex,
02087     /* [in] */ CHAR __RPC_FAR *newVal);
02088
02089
02090 void __RPC_STUB IRbtlkVariable_cmdLetS_Stub(
02091     IRpcStubBuffer *This,
02092     IRpcChannelBuffer *_pRpcChannelBuffer,
02093     PRPC_MESSAGE _pRpcMessage,
02094     DWORD *_pdwStubPhase);
02095
02096
02097 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetV_Proxy(
02098     IRbtlkVariable __RPC_FAR * This,
02099     /* [in] */ short sIC,
02100     /* [in] */ short sIndex,
02101     /* [out] */ float __RPC_FAR *pVal);
02102
02103
02104 void __RPC_STUB IRbtlkVariable_cmdGetV_Stub(
02105     IRpcStubBuffer *This,
02106     IRpcChannelBuffer *_pRpcChannelBuffer,
02107     PRPC_MESSAGE _pRpcMessage,
02108     DWORD *_pdwStubPhase);
02109
02110
02111 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetV_Proxy(
02112     IRbtlkVariable __RPC_FAR * This,
02113     /* [in] */ short sIC,
02114     /* [in] */ short sIndex,
02115     /* [in] */ float __RPC_FAR *newVal);
02116
02117
02118 void __RPC_STUB IRbtlkVariable_cmdLetV_Stub(
02119     IRpcStubBuffer *This,
02120     IRpcChannelBuffer *_pRpcChannelBuffer,
02121     PRPC_MESSAGE _pRpcMessage,
02122     DWORD *_pdwStubPhase);
02123
02124
02125 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetT_Proxy(
02126     IRbtlkVariable __RPC_FAR * This,
02127     /* [in] */ short sIC,
02128     /* [in] */ short sIndex,
02129     /* [out] */ float __RPC_FAR *pVal);
02130
02131
02132 void __RPC_STUB IRbtlkVariable_cmdGetT_Stub(
02133     IRpcStubBuffer *This,
02134     IRpcChannelBuffer *_pRpcChannelBuffer,
02135     PRPC_MESSAGE _pRpcMessage,
02136     DWORD *_pdwStubPhase);
02137
02138
02139 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetT_Proxy(
02140     IRbtlkVariable __RPC_FAR * This,
02141     /* [in] */ short sIC,
02142     /* [in] */ short sIndex,
02143     /* [in] */ float __RPC_FAR *newVal);
02144
02145
02146 void __RPC_STUB IRbtlkVariable_cmdLetT_Stub(
02147     IRpcStubBuffer *This,
02148     IRpcChannelBuffer *_pRpcChannelBuffer,
02149     PRPC_MESSAGE _pRpcMessage,
02150     DWORD *_pdwStubPhase);
02151
02152
02153 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetTabLen_Proxy(
02154     IRbtlkVariable __RPC_FAR * This,
02155     /* [in] */ short sPrgIC,
02156     /* [in] */ short sTypeIC,
02157     /* [out] */ short __RPC_FAR *pVal);
02158
02159
02160 void __RPC_STUB IRbtlkVariable_cmdGetTabLen_Stub(
02161     IRpcStubBuffer *This,
02162     IRpcChannelBuffer *_pRpcChannelBuffer,
02163     PRPC_MESSAGE _pRpcMessage,
02164     DWORD *_pdwStubPhase);
02165
02166
02167 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdGetDefIO_Proxy(
02168     IRbtlkVariable __RPC_FAR * This,
02169     /* [in] */ short sPort,
02170     /* [in] */ short sType,
02171     /* [in] */ long lMask,
02172     /* [out] */ long __RPC_FAR *pVal);
02173
02174
02175 void __RPC_STUB IRbtlkVariable_cmdGetDefIO_Stub(
02176     IRpcStubBuffer *This,
02177     IRpcChannelBuffer *_pRpcChannelBuffer,
02178     PRPC_MESSAGE _pRpcMessage,
02179     DWORD *_pdwStubPhase);
02180
02181
02182 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkVariable_cmdLetDefIO_Proxy(
02183     IRbtlkVariable __RPC_FAR * This,
02184     /* [in] */ short sPort,
02185     /* [in] */ short sType,
02186     /* [in] */ long lMask,
02187     /* [in] */ long lVal);
02188
02189
02190 void __RPC_STUB IRbtlkVariable_cmdLetDefIO_Stub(
02191     IRpcStubBuffer *This,
02192     IRpcChannelBuffer *_pRpcChannelBuffer,
02193     PRPC_MESSAGE _pRpcMessage,
02194     DWORD *_pdwStubPhase);
02195
02196
02197
02198 #endif  /* __IRbtlkVariable_INTERFACE_DEFINED__ */
02199
02200
02201 #ifndef __IRbtlkIO_INTERFACE_DEFINED__
02202 #define __IRbtlkIO_INTERFACE_DEFINED__
02203
02204 /* interface IRbtlkIO */
02205 /* [unique][helpstring][uuid][object] */
02206
02207
02208 EXTERN_C const IID IID_IRbtlkIO;
02209
02210 #if defined(__cplusplus) && !defined(CINTERFACE)
02211
02212     MIDL_INTERFACE("B8937F48-2FB7-4807-8D2D-2200683801FA")
02213     IRbtlkIO : public IUnknown
02214     {
02215     public:
02216         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdDin(
02217             /* [in] */ short sIndex,
02218             /* [out] */ BOOL __RPC_FAR *pVal) = 0;
02219
02220         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdDout(
02221             /* [in] */ short sIndex,
02222             /* [in] */ BOOL newVal) = 0;
02223
02224         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdDummy(
02225             /* [in] */ short sIndex,
02226             /* [in] */ short newVal) = 0;
02227
02228         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdDin8(
02229             /* [in] */ short sIndex,
02230             /* [out] */ short __RPC_FAR *pVal) = 0;
02231
02232         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdDout8(
02233             /* [in] */ short sIndex,
02234             /* [in] */ short newVal) = 0;
02235
02236         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdDin16(
02237             /* [in] */ short sIndex,
02238             /* [out] */ short __RPC_FAR *pVal) = 0;
02239
02240         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdDout16(
02241             /* [in] */ short sIndex,
02242             /* [in] */ short newVal) = 0;
02243
02244         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdChangeLabel(
02245             /* [in] */ short sPlateNo,
02246             /* [in] */ short sButtonNo,
02247             /* [in] */ CHAR __RPC_FAR *newVal) = 0;
02248
02249     };
02250
02251 #else   /* C style interface */
02252
02253     typedef struct IRbtlkIOVtbl
02254     {
02255         BEGIN_INTERFACE
02256
02257         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
02258             IRbtlkIO __RPC_FAR * This,
02259             /* [in] */ REFIID riid,
02260             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
02261
02262         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
02263             IRbtlkIO __RPC_FAR * This);
02264
02265         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
02266             IRbtlkIO __RPC_FAR * This);
02267
02268         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdDin )(
02269             IRbtlkIO __RPC_FAR * This,
02270             /* [in] */ short sIndex,
02271             /* [out] */ BOOL __RPC_FAR *pVal);
02272
02273         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdDout )(
02274             IRbtlkIO __RPC_FAR * This,
02275             /* [in] */ short sIndex,
02276             /* [in] */ BOOL newVal);
02277
02278         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdDummy )(
02279             IRbtlkIO __RPC_FAR * This,
02280             /* [in] */ short sIndex,
02281             /* [in] */ short newVal);
02282
02283         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdDin8 )(
02284             IRbtlkIO __RPC_FAR * This,
02285             /* [in] */ short sIndex,
02286             /* [out] */ short __RPC_FAR *pVal);
02287
02288         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdDout8 )(
02289             IRbtlkIO __RPC_FAR * This,
02290             /* [in] */ short sIndex,
02291             /* [in] */ short newVal);
02292
02293         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdDin16 )(
02294             IRbtlkIO __RPC_FAR * This,
02295             /* [in] */ short sIndex,
02296             /* [out] */ short __RPC_FAR *pVal);
02297
02298         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdDout16 )(
02299             IRbtlkIO __RPC_FAR * This,
02300             /* [in] */ short sIndex,
02301             /* [in] */ short newVal);
02302
02303         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdChangeLabel )(
02304             IRbtlkIO __RPC_FAR * This,
02305             /* [in] */ short sPlateNo,
02306             /* [in] */ short sButtonNo,
02307             /* [in] */ CHAR __RPC_FAR *newVal);
02308
02309         END_INTERFACE
02310     } IRbtlkIOVtbl;
02311
02312     interface IRbtlkIO
02313     {
02314         CONST_VTBL struct IRbtlkIOVtbl __RPC_FAR *lpVtbl;
02315     };
02316
02317
02318
02319 #ifdef COBJMACROS
02320
02321
02322 #define IRbtlkIO_QueryInterface(This,riid,ppvObject)    \
02323     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
02324
02325 #define IRbtlkIO_AddRef(This)   \
02326     (This)->lpVtbl -> AddRef(This)
02327
02328 #define IRbtlkIO_Release(This)  \
02329     (This)->lpVtbl -> Release(This)
02330
02331
02332 #define IRbtlkIO_cmdDin(This,sIndex,pVal)   \
02333     (This)->lpVtbl -> cmdDin(This,sIndex,pVal)
02334
02335 #define IRbtlkIO_cmdDout(This,sIndex,newVal)    \
02336     (This)->lpVtbl -> cmdDout(This,sIndex,newVal)
02337
02338 #define IRbtlkIO_cmdDummy(This,sIndex,newVal)   \
02339     (This)->lpVtbl -> cmdDummy(This,sIndex,newVal)
02340
02341 #define IRbtlkIO_cmdDin8(This,sIndex,pVal)  \
02342     (This)->lpVtbl -> cmdDin8(This,sIndex,pVal)
02343
02344 #define IRbtlkIO_cmdDout8(This,sIndex,newVal)   \
02345     (This)->lpVtbl -> cmdDout8(This,sIndex,newVal)
02346
02347 #define IRbtlkIO_cmdDin16(This,sIndex,pVal) \
02348     (This)->lpVtbl -> cmdDin16(This,sIndex,pVal)
02349
02350 #define IRbtlkIO_cmdDout16(This,sIndex,newVal)  \
02351     (This)->lpVtbl -> cmdDout16(This,sIndex,newVal)
02352
02353 #define IRbtlkIO_cmdChangeLabel(This,sPlateNo,sButtonNo,newVal) \
02354     (This)->lpVtbl -> cmdChangeLabel(This,sPlateNo,sButtonNo,newVal)
02355
02356 #endif /* COBJMACROS */
02357
02358
02359 #endif  /* C style interface */
02360
02361
02362
02363 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkIO_cmdDin_Proxy(
02364     IRbtlkIO __RPC_FAR * This,
02365     /* [in] */ short sIndex,
02366     /* [out] */ BOOL __RPC_FAR *pVal);
02367
02368
02369 void __RPC_STUB IRbtlkIO_cmdDin_Stub(
02370     IRpcStubBuffer *This,
02371     IRpcChannelBuffer *_pRpcChannelBuffer,
02372     PRPC_MESSAGE _pRpcMessage,
02373     DWORD *_pdwStubPhase);
02374
02375
02376 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkIO_cmdDout_Proxy(
02377     IRbtlkIO __RPC_FAR * This,
02378     /* [in] */ short sIndex,
02379     /* [in] */ BOOL newVal);
02380
02381
02382 void __RPC_STUB IRbtlkIO_cmdDout_Stub(
02383     IRpcStubBuffer *This,
02384     IRpcChannelBuffer *_pRpcChannelBuffer,
02385     PRPC_MESSAGE _pRpcMessage,
02386     DWORD *_pdwStubPhase);
02387
02388
02389 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkIO_cmdDummy_Proxy(
02390     IRbtlkIO __RPC_FAR * This,
02391     /* [in] */ short sIndex,
02392     /* [in] */ short newVal);
02393
02394
02395 void __RPC_STUB IRbtlkIO_cmdDummy_Stub(
02396     IRpcStubBuffer *This,
02397     IRpcChannelBuffer *_pRpcChannelBuffer,
02398     PRPC_MESSAGE _pRpcMessage,
02399     DWORD *_pdwStubPhase);
02400
02401
02402 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkIO_cmdDin8_Proxy(
02403     IRbtlkIO __RPC_FAR * This,
02404     /* [in] */ short sIndex,
02405     /* [out] */ short __RPC_FAR *pVal);
02406
02407
02408 void __RPC_STUB IRbtlkIO_cmdDin8_Stub(
02409     IRpcStubBuffer *This,
02410     IRpcChannelBuffer *_pRpcChannelBuffer,
02411     PRPC_MESSAGE _pRpcMessage,
02412     DWORD *_pdwStubPhase);
02413
02414
02415 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkIO_cmdDout8_Proxy(
02416     IRbtlkIO __RPC_FAR * This,
02417     /* [in] */ short sIndex,
02418     /* [in] */ short newVal);
02419
02420
02421 void __RPC_STUB IRbtlkIO_cmdDout8_Stub(
02422     IRpcStubBuffer *This,
02423     IRpcChannelBuffer *_pRpcChannelBuffer,
02424     PRPC_MESSAGE _pRpcMessage,
02425     DWORD *_pdwStubPhase);
02426
02427
02428 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkIO_cmdDin16_Proxy(
02429     IRbtlkIO __RPC_FAR * This,
02430     /* [in] */ short sIndex,
02431     /* [out] */ short __RPC_FAR *pVal);
02432
02433
02434 void __RPC_STUB IRbtlkIO_cmdDin16_Stub(
02435     IRpcStubBuffer *This,
02436     IRpcChannelBuffer *_pRpcChannelBuffer,
02437     PRPC_MESSAGE _pRpcMessage,
02438     DWORD *_pdwStubPhase);
02439
02440
02441 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkIO_cmdDout16_Proxy(
02442     IRbtlkIO __RPC_FAR * This,
02443     /* [in] */ short sIndex,
02444     /* [in] */ short newVal);
02445
02446
02447 void __RPC_STUB IRbtlkIO_cmdDout16_Stub(
02448     IRpcStubBuffer *This,
02449     IRpcChannelBuffer *_pRpcChannelBuffer,
02450     PRPC_MESSAGE _pRpcMessage,
02451     DWORD *_pdwStubPhase);
02452
02453
02454 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkIO_cmdChangeLabel_Proxy(
02455     IRbtlkIO __RPC_FAR * This,
02456     /* [in] */ short sPlateNo,
02457     /* [in] */ short sButtonNo,
02458     /* [in] */ CHAR __RPC_FAR *newVal);
02459
02460
02461 void __RPC_STUB IRbtlkIO_cmdChangeLabel_Stub(
02462     IRpcStubBuffer *This,
02463     IRpcChannelBuffer *_pRpcChannelBuffer,
02464     PRPC_MESSAGE _pRpcMessage,
02465     DWORD *_pdwStubPhase);
02466
02467
02468
02469 #endif  /* __IRbtlkIO_INTERFACE_DEFINED__ */
02470
02471
02472 #ifndef __IRbtlkArm_INTERFACE_DEFINED__
02473 #define __IRbtlkArm_INTERFACE_DEFINED__
02474
02475 /* interface IRbtlkArm */
02476 /* [unique][helpstring][uuid][object] */
02477
02478 typedef /* [public] */
02479 enum __MIDL_IRbtlkArm_0001
02480     {   RTK_AST_SERVO   = 16,
02481     RTK_AST_MODE    = 17,
02482     RTK_AST_CALEND  = 18
02483     }   RTK_ARM_STATUS;
02484
02485
02486 EXTERN_C const IID IID_IRbtlkArm;
02487
02488 #if defined(__cplusplus) && !defined(CINTERFACE)
02489
02490     MIDL_INTERFACE("E59220A9-344B-4aa6-8E8B-4555A3A42DFF")
02491     IRbtlkArm : public IUnknown
02492     {
02493     public:
02494         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdHere(
02495             /* [out] */ float __RPC_FAR *pVal) = 0;
02496
02497         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdJHere(
02498             /* [out] */ float __RPC_FAR *pVal) = 0;
02499
02500         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetTool(
02501             /* [in] */ short sNo,
02502             /* [out] */ float __RPC_FAR *pf) = 0;
02503
02504         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetTool(
02505             /* [in] */ short sNo,
02506             /* [in] */ float __RPC_FAR *pf) = 0;
02507
02508         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetWork(
02509             /* [in] */ short sNo,
02510             /* [out] */ float __RPC_FAR *pf) = 0;
02511
02512         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetWork(
02513             /* [in] */ short sNo,
02514             /* [in] */ float __RPC_FAR *pf) = 0;
02515
02516         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetArea(
02517             /* [in] */ short sNo,
02518             /* [out] */ float __RPC_FAR *pf,
02519             /* [out] */ short __RPC_FAR *psIO,
02520             /* [out] */ short __RPC_FAR *psPos) = 0;
02521
02522         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetArea(
02523             /* [in] */ short sNo,
02524             /* [in] */ float __RPC_FAR *pf,
02525             /* [in] */ short sIO,
02526             /* [in] */ short sPos) = 0;
02527
02528         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetAreaEx(
02529             /* [in] */ short sNo,
02530             /* [out] */ float __RPC_FAR *pf,
02531             /* [out] */ short __RPC_FAR *psIO,
02532             /* [out] */ short __RPC_FAR *psPos,
02533             /* [out] */ short __RPC_FAR *psErr,
02534             /* [out] */ short __RPC_FAR *psEnable) = 0;
02535
02536         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetAreaEx(
02537             /* [in] */ short sNo,
02538             /* [in] */ float __RPC_FAR *pf,
02539             /* [in] */ short sIO,
02540             /* [in] */ short sPos,
02541             /* [in] */ short sErr,
02542             /* [in] */ short sEnable) = 0;
02543
02544         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetToolIndex(
02545             /* [out] */ short __RPC_FAR *pVal) = 0;
02546
02547         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetWorkIndex(
02548             /* [out] */ short __RPC_FAR *pVal) = 0;
02549
02550         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdThere(
02551             /* [out] */ float __RPC_FAR *pVal) = 0;
02552
02553         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdEnableArea(
02554             /* [in] */ short sNo) = 0;
02555
02556         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdDisableArea(
02557             /* [in] */ short sNo) = 0;
02558
02559     };
02560
02561 #else   /* C style interface */
02562
02563     typedef struct IRbtlkArmVtbl
02564     {
02565         BEGIN_INTERFACE
02566
02567         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
02568             IRbtlkArm __RPC_FAR * This,
02569             /* [in] */ REFIID riid,
02570             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
02571
02572         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
02573             IRbtlkArm __RPC_FAR * This);
02574
02575         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
02576             IRbtlkArm __RPC_FAR * This);
02577
02578         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdHere )(
02579             IRbtlkArm __RPC_FAR * This,
02580             /* [out] */ float __RPC_FAR *pVal);
02581
02582         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdJHere )(
02583             IRbtlkArm __RPC_FAR * This,
02584             /* [out] */ float __RPC_FAR *pVal);
02585
02586         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetTool )(
02587             IRbtlkArm __RPC_FAR * This,
02588             /* [in] */ short sNo,
02589             /* [out] */ float __RPC_FAR *pf);
02590
02591         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetTool )(
02592             IRbtlkArm __RPC_FAR * This,
02593             /* [in] */ short sNo,
02594             /* [in] */ float __RPC_FAR *pf);
02595
02596         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetWork )(
02597             IRbtlkArm __RPC_FAR * This,
02598             /* [in] */ short sNo,
02599             /* [out] */ float __RPC_FAR *pf);
02600
02601         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetWork )(
02602             IRbtlkArm __RPC_FAR * This,
02603             /* [in] */ short sNo,
02604             /* [in] */ float __RPC_FAR *pf);
02605
02606         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetArea )(
02607             IRbtlkArm __RPC_FAR * This,
02608             /* [in] */ short sNo,
02609             /* [out] */ float __RPC_FAR *pf,
02610             /* [out] */ short __RPC_FAR *psIO,
02611             /* [out] */ short __RPC_FAR *psPos);
02612
02613         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetArea )(
02614             IRbtlkArm __RPC_FAR * This,
02615             /* [in] */ short sNo,
02616             /* [in] */ float __RPC_FAR *pf,
02617             /* [in] */ short sIO,
02618             /* [in] */ short sPos);
02619
02620         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetAreaEx )(
02621             IRbtlkArm __RPC_FAR * This,
02622             /* [in] */ short sNo,
02623             /* [out] */ float __RPC_FAR *pf,
02624             /* [out] */ short __RPC_FAR *psIO,
02625             /* [out] */ short __RPC_FAR *psPos,
02626             /* [out] */ short __RPC_FAR *psErr,
02627             /* [out] */ short __RPC_FAR *psEnable);
02628
02629         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetAreaEx )(
02630             IRbtlkArm __RPC_FAR * This,
02631             /* [in] */ short sNo,
02632             /* [in] */ float __RPC_FAR *pf,
02633             /* [in] */ short sIO,
02634             /* [in] */ short sPos,
02635             /* [in] */ short sErr,
02636             /* [in] */ short sEnable);
02637
02638         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetToolIndex )(
02639             IRbtlkArm __RPC_FAR * This,
02640             /* [out] */ short __RPC_FAR *pVal);
02641
02642         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetWorkIndex )(
02643             IRbtlkArm __RPC_FAR * This,
02644             /* [out] */ short __RPC_FAR *pVal);
02645
02646         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdThere )(
02647             IRbtlkArm __RPC_FAR * This,
02648             /* [out] */ float __RPC_FAR *pVal);
02649
02650         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdEnableArea )(
02651             IRbtlkArm __RPC_FAR * This,
02652             /* [in] */ short sNo);
02653
02654         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdDisableArea )(
02655             IRbtlkArm __RPC_FAR * This,
02656             /* [in] */ short sNo);
02657
02658         END_INTERFACE
02659     } IRbtlkArmVtbl;
02660
02661     interface IRbtlkArm
02662     {
02663         CONST_VTBL struct IRbtlkArmVtbl __RPC_FAR *lpVtbl;
02664     };
02665
02666
02667
02668 #ifdef COBJMACROS
02669
02670
02671 #define IRbtlkArm_QueryInterface(This,riid,ppvObject)   \
02672     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
02673
02674 #define IRbtlkArm_AddRef(This)  \
02675     (This)->lpVtbl -> AddRef(This)
02676
02677 #define IRbtlkArm_Release(This) \
02678     (This)->lpVtbl -> Release(This)
02679
02680
02681 #define IRbtlkArm_cmdHere(This,pVal)    \
02682     (This)->lpVtbl -> cmdHere(This,pVal)
02683
02684 #define IRbtlkArm_cmdJHere(This,pVal)   \
02685     (This)->lpVtbl -> cmdJHere(This,pVal)
02686
02687 #define IRbtlkArm_cmdGetTool(This,sNo,pf)   \
02688     (This)->lpVtbl -> cmdGetTool(This,sNo,pf)
02689
02690 #define IRbtlkArm_cmdLetTool(This,sNo,pf)   \
02691     (This)->lpVtbl -> cmdLetTool(This,sNo,pf)
02692
02693 #define IRbtlkArm_cmdGetWork(This,sNo,pf)   \
02694     (This)->lpVtbl -> cmdGetWork(This,sNo,pf)
02695
02696 #define IRbtlkArm_cmdLetWork(This,sNo,pf)   \
02697     (This)->lpVtbl -> cmdLetWork(This,sNo,pf)
02698
02699 #define IRbtlkArm_cmdGetArea(This,sNo,pf,psIO,psPos)    \
02700     (This)->lpVtbl -> cmdGetArea(This,sNo,pf,psIO,psPos)
02701
02702 #define IRbtlkArm_cmdLetArea(This,sNo,pf,sIO,sPos)  \
02703     (This)->lpVtbl -> cmdLetArea(This,sNo,pf,sIO,sPos)
02704
02705 #define IRbtlkArm_cmdGetAreaEx(This,sNo,pf,psIO,psPos,psErr,psEnable)   \
02706     (This)->lpVtbl -> cmdGetAreaEx(This,sNo,pf,psIO,psPos,psErr,psEnable)
02707
02708 #define IRbtlkArm_cmdLetAreaEx(This,sNo,pf,sIO,sPos,sErr,sEnable)   \
02709     (This)->lpVtbl -> cmdLetAreaEx(This,sNo,pf,sIO,sPos,sErr,sEnable)
02710
02711 #define IRbtlkArm_cmdGetToolIndex(This,pVal)    \
02712     (This)->lpVtbl -> cmdGetToolIndex(This,pVal)
02713
02714 #define IRbtlkArm_cmdGetWorkIndex(This,pVal)    \
02715     (This)->lpVtbl -> cmdGetWorkIndex(This,pVal)
02716
02717 #define IRbtlkArm_cmdThere(This,pVal)   \
02718     (This)->lpVtbl -> cmdThere(This,pVal)
02719
02720 #define IRbtlkArm_cmdEnableArea(This,sNo)   \
02721     (This)->lpVtbl -> cmdEnableArea(This,sNo)
02722
02723 #define IRbtlkArm_cmdDisableArea(This,sNo)  \
02724     (This)->lpVtbl -> cmdDisableArea(This,sNo)
02725
02726 #endif /* COBJMACROS */
02727
02728
02729 #endif  /* C style interface */
02730
02731
02732
02733 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdHere_Proxy(
02734     IRbtlkArm __RPC_FAR * This,
02735     /* [out] */ float __RPC_FAR *pVal);
02736
02737
02738 void __RPC_STUB IRbtlkArm_cmdHere_Stub(
02739     IRpcStubBuffer *This,
02740     IRpcChannelBuffer *_pRpcChannelBuffer,
02741     PRPC_MESSAGE _pRpcMessage,
02742     DWORD *_pdwStubPhase);
02743
02744
02745 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdJHere_Proxy(
02746     IRbtlkArm __RPC_FAR * This,
02747     /* [out] */ float __RPC_FAR *pVal);
02748
02749
02750 void __RPC_STUB IRbtlkArm_cmdJHere_Stub(
02751     IRpcStubBuffer *This,
02752     IRpcChannelBuffer *_pRpcChannelBuffer,
02753     PRPC_MESSAGE _pRpcMessage,
02754     DWORD *_pdwStubPhase);
02755
02756
02757 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdGetTool_Proxy(
02758     IRbtlkArm __RPC_FAR * This,
02759     /* [in] */ short sNo,
02760     /* [out] */ float __RPC_FAR *pf);
02761
02762
02763 void __RPC_STUB IRbtlkArm_cmdGetTool_Stub(
02764     IRpcStubBuffer *This,
02765     IRpcChannelBuffer *_pRpcChannelBuffer,
02766     PRPC_MESSAGE _pRpcMessage,
02767     DWORD *_pdwStubPhase);
02768
02769
02770 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdLetTool_Proxy(
02771     IRbtlkArm __RPC_FAR * This,
02772     /* [in] */ short sNo,
02773     /* [in] */ float __RPC_FAR *pf);
02774
02775
02776 void __RPC_STUB IRbtlkArm_cmdLetTool_Stub(
02777     IRpcStubBuffer *This,
02778     IRpcChannelBuffer *_pRpcChannelBuffer,
02779     PRPC_MESSAGE _pRpcMessage,
02780     DWORD *_pdwStubPhase);
02781
02782
02783 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdGetWork_Proxy(
02784     IRbtlkArm __RPC_FAR * This,
02785     /* [in] */ short sNo,
02786     /* [out] */ float __RPC_FAR *pf);
02787
02788
02789 void __RPC_STUB IRbtlkArm_cmdGetWork_Stub(
02790     IRpcStubBuffer *This,
02791     IRpcChannelBuffer *_pRpcChannelBuffer,
02792     PRPC_MESSAGE _pRpcMessage,
02793     DWORD *_pdwStubPhase);
02794
02795
02796 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdLetWork_Proxy(
02797     IRbtlkArm __RPC_FAR * This,
02798     /* [in] */ short sNo,
02799     /* [in] */ float __RPC_FAR *pf);
02800
02801
02802 void __RPC_STUB IRbtlkArm_cmdLetWork_Stub(
02803     IRpcStubBuffer *This,
02804     IRpcChannelBuffer *_pRpcChannelBuffer,
02805     PRPC_MESSAGE _pRpcMessage,
02806     DWORD *_pdwStubPhase);
02807
02808
02809 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdGetArea_Proxy(
02810     IRbtlkArm __RPC_FAR * This,
02811     /* [in] */ short sNo,
02812     /* [out] */ float __RPC_FAR *pf,
02813     /* [out] */ short __RPC_FAR *psIO,
02814     /* [out] */ short __RPC_FAR *psPos);
02815
02816
02817 void __RPC_STUB IRbtlkArm_cmdGetArea_Stub(
02818     IRpcStubBuffer *This,
02819     IRpcChannelBuffer *_pRpcChannelBuffer,
02820     PRPC_MESSAGE _pRpcMessage,
02821     DWORD *_pdwStubPhase);
02822
02823
02824 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdLetArea_Proxy(
02825     IRbtlkArm __RPC_FAR * This,
02826     /* [in] */ short sNo,
02827     /* [in] */ float __RPC_FAR *pf,
02828     /* [in] */ short sIO,
02829     /* [in] */ short sPos);
02830
02831
02832 void __RPC_STUB IRbtlkArm_cmdLetArea_Stub(
02833     IRpcStubBuffer *This,
02834     IRpcChannelBuffer *_pRpcChannelBuffer,
02835     PRPC_MESSAGE _pRpcMessage,
02836     DWORD *_pdwStubPhase);
02837
02838
02839 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdGetAreaEx_Proxy(
02840     IRbtlkArm __RPC_FAR * This,
02841     /* [in] */ short sNo,
02842     /* [out] */ float __RPC_FAR *pf,
02843     /* [out] */ short __RPC_FAR *psIO,
02844     /* [out] */ short __RPC_FAR *psPos,
02845     /* [out] */ short __RPC_FAR *psErr,
02846     /* [out] */ short __RPC_FAR *psEnable);
02847
02848
02849 void __RPC_STUB IRbtlkArm_cmdGetAreaEx_Stub(
02850     IRpcStubBuffer *This,
02851     IRpcChannelBuffer *_pRpcChannelBuffer,
02852     PRPC_MESSAGE _pRpcMessage,
02853     DWORD *_pdwStubPhase);
02854
02855
02856 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdLetAreaEx_Proxy(
02857     IRbtlkArm __RPC_FAR * This,
02858     /* [in] */ short sNo,
02859     /* [in] */ float __RPC_FAR *pf,
02860     /* [in] */ short sIO,
02861     /* [in] */ short sPos,
02862     /* [in] */ short sErr,
02863     /* [in] */ short sEnable);
02864
02865
02866 void __RPC_STUB IRbtlkArm_cmdLetAreaEx_Stub(
02867     IRpcStubBuffer *This,
02868     IRpcChannelBuffer *_pRpcChannelBuffer,
02869     PRPC_MESSAGE _pRpcMessage,
02870     DWORD *_pdwStubPhase);
02871
02872
02873 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdGetToolIndex_Proxy(
02874     IRbtlkArm __RPC_FAR * This,
02875     /* [out] */ short __RPC_FAR *pVal);
02876
02877
02878 void __RPC_STUB IRbtlkArm_cmdGetToolIndex_Stub(
02879     IRpcStubBuffer *This,
02880     IRpcChannelBuffer *_pRpcChannelBuffer,
02881     PRPC_MESSAGE _pRpcMessage,
02882     DWORD *_pdwStubPhase);
02883
02884
02885 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdGetWorkIndex_Proxy(
02886     IRbtlkArm __RPC_FAR * This,
02887     /* [out] */ short __RPC_FAR *pVal);
02888
02889
02890 void __RPC_STUB IRbtlkArm_cmdGetWorkIndex_Stub(
02891     IRpcStubBuffer *This,
02892     IRpcChannelBuffer *_pRpcChannelBuffer,
02893     PRPC_MESSAGE _pRpcMessage,
02894     DWORD *_pdwStubPhase);
02895
02896
02897 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdThere_Proxy(
02898     IRbtlkArm __RPC_FAR * This,
02899     /* [out] */ float __RPC_FAR *pVal);
02900
02901
02902 void __RPC_STUB IRbtlkArm_cmdThere_Stub(
02903     IRpcStubBuffer *This,
02904     IRpcChannelBuffer *_pRpcChannelBuffer,
02905     PRPC_MESSAGE _pRpcMessage,
02906     DWORD *_pdwStubPhase);
02907
02908
02909 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdEnableArea_Proxy(
02910     IRbtlkArm __RPC_FAR * This,
02911     /* [in] */ short sNo);
02912
02913
02914 void __RPC_STUB IRbtlkArm_cmdEnableArea_Stub(
02915     IRpcStubBuffer *This,
02916     IRpcChannelBuffer *_pRpcChannelBuffer,
02917     PRPC_MESSAGE _pRpcMessage,
02918     DWORD *_pdwStubPhase);
02919
02920
02921 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkArm_cmdDisableArea_Proxy(
02922     IRbtlkArm __RPC_FAR * This,
02923     /* [in] */ short sNo);
02924
02925
02926 void __RPC_STUB IRbtlkArm_cmdDisableArea_Stub(
02927     IRpcStubBuffer *This,
02928     IRpcChannelBuffer *_pRpcChannelBuffer,
02929     PRPC_MESSAGE _pRpcMessage,
02930     DWORD *_pdwStubPhase);
02931
02932
02933
02934 #endif  /* __IRbtlkArm_INTERFACE_DEFINED__ */
02935
02936
02937 #ifndef __IRbtlkTask_INTERFACE_DEFINED__
02938 #define __IRbtlkTask_INTERFACE_DEFINED__
02939
02940 /* interface IRbtlkTask */
02941 /* [unique][helpstring][uuid][object] */
02942
02943 typedef /* [public] */
02944 enum __MIDL_IRbtlkTask_0001
02945     {   RTK_PC_LANG_MODE    = 18,
02946     RTK_PC_ROBOTTYPE    = 19
02947     }   RTK_PAC_CONF;
02948
02949 typedef /* [public] */
02950 enum __MIDL_IRbtlkTask_0002
02951     {   RTK_IP_TASKNUM  = 1,
02952     RTK_IP_RSTKSIZE = 2
02953     }   RTK_ITP_CONF;
02954
02955
02956 EXTERN_C const IID IID_IRbtlkTask;
02957
02958 #if defined(__cplusplus) && !defined(CINTERFACE)
02959
02960     MIDL_INTERFACE("2E97DAF4-77AC-4d04-B9B0-1C33991A78F0")
02961     IRbtlkTask : public IUnknown
02962     {
02963     public:
02964         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetPrgListLen(
02965             /* [out] */ short __RPC_FAR *newVal) = 0;
02966
02967         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetPrgList(
02968             /* [in] */ short sIndex,
02969             /* [out] */ short __RPC_FAR *newVal,
02970             /* [out] */ CHAR __RPC_FAR *szName) = 0;
02971
02972         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetTaskStatus(
02973             /* [in] */ short sPrgIC,
02974             /* [out] */ short __RPC_FAR *pStatus) = 0;
02975
02976         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdContPrgStatus(
02977             /* [in] */ short sPrgIC,
02978             /* [out] */ short __RPC_FAR *pStatus,
02979             /* [out] */ short __RPC_FAR *pPriority,
02980             /* [out] */ short __RPC_FAR *pInterval,
02981             /* [out] */ short __RPC_FAR *pLineNo,
02982             /* [out] */ short __RPC_FAR *pIOBlock,
02983             /* [out] */ short __RPC_FAR *pMode,
02984             /* [out] */ long __RPC_FAR *pCT) = 0;
02985
02986     };
02987
02988 #else   /* C style interface */
02989
02990     typedef struct IRbtlkTaskVtbl
02991     {
02992         BEGIN_INTERFACE
02993
02994         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
02995             IRbtlkTask __RPC_FAR * This,
02996             /* [in] */ REFIID riid,
02997             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
02998
02999         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
03000             IRbtlkTask __RPC_FAR * This);
03001
03002         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
03003             IRbtlkTask __RPC_FAR * This);
03004
03005         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetPrgListLen )(
03006             IRbtlkTask __RPC_FAR * This,
03007             /* [out] */ short __RPC_FAR *newVal);
03008
03009         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetPrgList )(
03010             IRbtlkTask __RPC_FAR * This,
03011             /* [in] */ short sIndex,
03012             /* [out] */ short __RPC_FAR *newVal,
03013             /* [out] */ CHAR __RPC_FAR *szName);
03014
03015         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetTaskStatus )(
03016             IRbtlkTask __RPC_FAR * This,
03017             /* [in] */ short sPrgIC,
03018             /* [out] */ short __RPC_FAR *pStatus);
03019
03020         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdContPrgStatus )(
03021             IRbtlkTask __RPC_FAR * This,
03022             /* [in] */ short sPrgIC,
03023             /* [out] */ short __RPC_FAR *pStatus,
03024             /* [out] */ short __RPC_FAR *pPriority,
03025             /* [out] */ short __RPC_FAR *pInterval,
03026             /* [out] */ short __RPC_FAR *pLineNo,
03027             /* [out] */ short __RPC_FAR *pIOBlock,
03028             /* [out] */ short __RPC_FAR *pMode,
03029             /* [out] */ long __RPC_FAR *pCT);
03030
03031         END_INTERFACE
03032     } IRbtlkTaskVtbl;
03033
03034     interface IRbtlkTask
03035     {
03036         CONST_VTBL struct IRbtlkTaskVtbl __RPC_FAR *lpVtbl;
03037     };
03038
03039
03040
03041 #ifdef COBJMACROS
03042
03043
03044 #define IRbtlkTask_QueryInterface(This,riid,ppvObject)  \
03045     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
03046
03047 #define IRbtlkTask_AddRef(This) \
03048     (This)->lpVtbl -> AddRef(This)
03049
03050 #define IRbtlkTask_Release(This)    \
03051     (This)->lpVtbl -> Release(This)
03052
03053
03054 #define IRbtlkTask_cmdGetPrgListLen(This,newVal)    \
03055     (This)->lpVtbl -> cmdGetPrgListLen(This,newVal)
03056
03057 #define IRbtlkTask_cmdGetPrgList(This,sIndex,newVal,szName) \
03058     (This)->lpVtbl -> cmdGetPrgList(This,sIndex,newVal,szName)
03059
03060 #define IRbtlkTask_cmdGetTaskStatus(This,sPrgIC,pStatus)    \
03061     (This)->lpVtbl -> cmdGetTaskStatus(This,sPrgIC,pStatus)
03062
03063 #define IRbtlkTask_cmdContPrgStatus(This,sPrgIC,pStatus,pPriority,pInterval,pLineNo,pIOBlock,pMode,pCT) \
03064     (This)->lpVtbl -> cmdContPrgStatus(This,sPrgIC,pStatus,pPriority,pInterval,pLineNo,pIOBlock,pMode,pCT)
03065
03066 #endif /* COBJMACROS */
03067
03068
03069 #endif  /* C style interface */
03070
03071
03072
03073 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkTask_cmdGetPrgListLen_Proxy(
03074     IRbtlkTask __RPC_FAR * This,
03075     /* [out] */ short __RPC_FAR *newVal);
03076
03077
03078 void __RPC_STUB IRbtlkTask_cmdGetPrgListLen_Stub(
03079     IRpcStubBuffer *This,
03080     IRpcChannelBuffer *_pRpcChannelBuffer,
03081     PRPC_MESSAGE _pRpcMessage,
03082     DWORD *_pdwStubPhase);
03083
03084
03085 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkTask_cmdGetPrgList_Proxy(
03086     IRbtlkTask __RPC_FAR * This,
03087     /* [in] */ short sIndex,
03088     /* [out] */ short __RPC_FAR *newVal,
03089     /* [out] */ CHAR __RPC_FAR *szName);
03090
03091
03092 void __RPC_STUB IRbtlkTask_cmdGetPrgList_Stub(
03093     IRpcStubBuffer *This,
03094     IRpcChannelBuffer *_pRpcChannelBuffer,
03095     PRPC_MESSAGE _pRpcMessage,
03096     DWORD *_pdwStubPhase);
03097
03098
03099 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkTask_cmdGetTaskStatus_Proxy(
03100     IRbtlkTask __RPC_FAR * This,
03101     /* [in] */ short sPrgIC,
03102     /* [out] */ short __RPC_FAR *pStatus);
03103
03104
03105 void __RPC_STUB IRbtlkTask_cmdGetTaskStatus_Stub(
03106     IRpcStubBuffer *This,
03107     IRpcChannelBuffer *_pRpcChannelBuffer,
03108     PRPC_MESSAGE _pRpcMessage,
03109     DWORD *_pdwStubPhase);
03110
03111
03112 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkTask_cmdContPrgStatus_Proxy(
03113     IRbtlkTask __RPC_FAR * This,
03114     /* [in] */ short sPrgIC,
03115     /* [out] */ short __RPC_FAR *pStatus,
03116     /* [out] */ short __RPC_FAR *pPriority,
03117     /* [out] */ short __RPC_FAR *pInterval,
03118     /* [out] */ short __RPC_FAR *pLineNo,
03119     /* [out] */ short __RPC_FAR *pIOBlock,
03120     /* [out] */ short __RPC_FAR *pMode,
03121     /* [out] */ long __RPC_FAR *pCT);
03122
03123
03124 void __RPC_STUB IRbtlkTask_cmdContPrgStatus_Stub(
03125     IRpcStubBuffer *This,
03126     IRpcChannelBuffer *_pRpcChannelBuffer,
03127     PRPC_MESSAGE _pRpcMessage,
03128     DWORD *_pdwStubPhase);
03129
03130
03131
03132 #endif  /* __IRbtlkTask_INTERFACE_DEFINED__ */
03133
03134
03135 #ifndef __IRbtlkFile_INTERFACE_DEFINED__
03136 #define __IRbtlkFile_INTERFACE_DEFINED__
03137
03138 /* interface IRbtlkFile */
03139 /* [unique][helpstring][uuid][object] */
03140
03141
03142 EXTERN_C const IID IID_IRbtlkFile;
03143
03144 #if defined(__cplusplus) && !defined(CINTERFACE)
03145
03146     MIDL_INTERFACE("0CF06FBD-2D74-4b39-B299-EA20F6CA84AC")
03147     IRbtlkFile : public IUnknown
03148     {
03149     public:
03150         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdFileUploadStart( void) = 0;
03151
03152         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdFileUploadEnd( void) = 0;
03153
03154         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdRequestUpload(
03155             /* [in] */ short sBlocks,
03156             /* [in] */ long lSize,
03157             /* [in] */ short sFileProp,
03158             /* [in] */ short sFileFlag,
03159             /* [in] */ CHAR __RPC_FAR *szName,
03160             /* [out] */ short __RPC_FAR *psFileID) = 0;
03161
03162         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdRequestDownload(
03163             /* [in] */ short sFileFlag,
03164             /* [in] */ CHAR __RPC_FAR *szName,
03165             /* [out] */ short __RPC_FAR *psFileID,
03166             /* [out] */ short __RPC_FAR *psBlocks,
03167             /* [out] */ short __RPC_FAR *sFileProp,
03168             /* [out] */ long __RPC_FAR *plSize) = 0;
03169
03170         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdUpload(
03171             /* [in] */ short sFileID,
03172             /* [in] */ short sBlockNo,
03173             /* [in] */ BSTR bstrData) = 0;
03174
03175         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdDownload(
03176             /* [in] */ short sFileID,
03177             /* [out] */ short __RPC_FAR *psFileID,
03178             /* [out] */ short __RPC_FAR *psBlockNo,
03179             /* [out] */ BSTR __RPC_FAR *pbstrData) = 0;
03180
03181         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdCancelUpload(
03182             /* [in] */ short sFileID) = 0;
03183
03184         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdCancelDownload(
03185             /* [in] */ short sFileID) = 0;
03186
03187         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdDeleteFile(
03188             /* [in] */ CHAR __RPC_FAR *szName) = 0;
03189
03190         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetFileCnt(
03191             /* [in] */ CHAR __RPC_FAR *szName,
03192             /* [out] */ short __RPC_FAR *psFiles) = 0;
03193
03194         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdCopyFile(
03195             /* [in] */ CHAR __RPC_FAR *szFrom,
03196             /* [in] */ CHAR __RPC_FAR *szTo) = 0;
03197
03198         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdMoveFile(
03199             /* [in] */ CHAR __RPC_FAR *szFrom,
03200             /* [in] */ CHAR __RPC_FAR *szTo) = 0;
03201
03202         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetFileName(
03203             /* [in] */ short sIndex,
03204             /* [in] */ CHAR __RPC_FAR *szDirName,
03205             /* [out] */ CHAR __RPC_FAR *pVal) = 0;
03206
03207         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetAttributes(
03208             /* [in] */ short iSystem,
03209             /* [in] */ CHAR __RPC_FAR *szName,
03210             /* [out] */ long __RPC_FAR *pVal) = 0;
03211
03212         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetDataCreated(
03213             /* [in] */ short iSystem,
03214             /* [in] */ CHAR __RPC_FAR *szName,
03215             /* [out] */ short __RPC_FAR *pDateTime) = 0;
03216
03217         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetLastModified(
03218             /* [in] */ short iSystem,
03219             /* [in] */ CHAR __RPC_FAR *szName,
03220             /* [out] */ short __RPC_FAR *pDateTime) = 0;
03221
03222         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetLastAccessed(
03223             /* [in] */ short iSystem,
03224             /* [in] */ CHAR __RPC_FAR *szName,
03225             /* [out] */ short __RPC_FAR *pDateTime) = 0;
03226
03227         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetSize(
03228             /* [in] */ short iSystem,
03229             /* [in] */ CHAR __RPC_FAR *szName,
03230             /* [out] */ long __RPC_FAR *pVal) = 0;
03231
03232         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdStartPrg(
03233             /* [in] */ short iProgIC,
03234             /* [in] */ short iStartMode) = 0;
03235
03236         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdStopPrg(
03237             /* [in] */ short iProgIC,
03238             /* [in] */ short iStopMode) = 0;
03239
03240         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetProgramIC(
03241             /* [in] */ CHAR __RPC_FAR *szName,
03242             /* [out] */ short __RPC_FAR *pVal) = 0;
03243
03244         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdStepForward(
03245             /* [in] */ short iProgIC) = 0;
03246
03247         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdStepBackward(
03248             /* [in] */ short iProgIC) = 0;
03249
03250         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLetStartLine(
03251             /* [in] */ short iLineNo,
03252             /* [in] */ short iProgIC,
03253             /* [out] */ short __RPC_FAR *pVal) = 0;
03254
03255         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdKillProg(
03256             /* [in] */ short iActMode,
03257             /* [in] */ short iProgIC) = 0;
03258
03259         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdLoadNic(
03260             /* [out] */ long __RPC_FAR *pID) = 0;
03261
03262         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdRequestUpload0(
03263             /* [in] */ short sBlocks,
03264             /* [in] */ long lSize,
03265             /* [in] */ CHAR __RPC_FAR *szName,
03266             /* [in] */ CHAR __RPC_FAR *szAttribute,
03267             /* [in] */ CHAR __RPC_FAR *szUsage,
03268             /* [out] */ short __RPC_FAR *psFileID) = 0;
03269
03270         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdRequestDownload0(
03271             /* [in] */ CHAR __RPC_FAR *szName,
03272             /* [out] */ short __RPC_FAR *psFileID,
03273             /* [out] */ short __RPC_FAR *psBlocks,
03274             /* [out] */ long __RPC_FAR *plSize,
03275             /* [out] */ CHAR __RPC_FAR *szAttribute,
03276             /* [out] */ CHAR __RPC_FAR *szUsage) = 0;
03277
03278         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdUpload0(
03279             /* [in] */ short sFileID,
03280             /* [in] */ short sBlockNo,
03281             /* [in] */ BSTR bstrData) = 0;
03282
03283         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdDownload0(
03284             /* [in] */ short sFileID,
03285             /* [out] */ short __RPC_FAR *psFileID,
03286             /* [out] */ short __RPC_FAR *psBlockNo,
03287             /* [out] */ BSTR __RPC_FAR *pbstrData) = 0;
03288
03289         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdCancelUpload0(
03290             /* [in] */ short sFileID) = 0;
03291
03292         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdCancelDownload0(
03293             /* [in] */ short sFileID) = 0;
03294
03295         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetProgramIndex(
03296             /* [in] */ CHAR __RPC_FAR *szName,
03297             /* [out] */ short __RPC_FAR *pVal) = 0;
03298
03299         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdDeleteFile0(
03300             /* [in] */ CHAR __RPC_FAR *szName) = 0;
03301
03302         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetFileCnt0(
03303             /* [out] */ short __RPC_FAR *psFiles) = 0;
03304
03305         virtual /* [helpstring] */ HRESULT STDMETHODCALLTYPE cmdGetFileName0(
03306             /* [in] */ short sIndex,
03307             /* [out] */ CHAR __RPC_FAR *pVal) = 0;
03308
03309     };
03310
03311 #else   /* C style interface */
03312
03313     typedef struct IRbtlkFileVtbl
03314     {
03315         BEGIN_INTERFACE
03316
03317         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
03318             IRbtlkFile __RPC_FAR * This,
03319             /* [in] */ REFIID riid,
03320             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
03321
03322         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
03323             IRbtlkFile __RPC_FAR * This);
03324
03325         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
03326             IRbtlkFile __RPC_FAR * This);
03327
03328         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdFileUploadStart )(
03329             IRbtlkFile __RPC_FAR * This);
03330
03331         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdFileUploadEnd )(
03332             IRbtlkFile __RPC_FAR * This);
03333
03334         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdRequestUpload )(
03335             IRbtlkFile __RPC_FAR * This,
03336             /* [in] */ short sBlocks,
03337             /* [in] */ long lSize,
03338             /* [in] */ short sFileProp,
03339             /* [in] */ short sFileFlag,
03340             /* [in] */ CHAR __RPC_FAR *szName,
03341             /* [out] */ short __RPC_FAR *psFileID);
03342
03343         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdRequestDownload )(
03344             IRbtlkFile __RPC_FAR * This,
03345             /* [in] */ short sFileFlag,
03346             /* [in] */ CHAR __RPC_FAR *szName,
03347             /* [out] */ short __RPC_FAR *psFileID,
03348             /* [out] */ short __RPC_FAR *psBlocks,
03349             /* [out] */ short __RPC_FAR *sFileProp,
03350             /* [out] */ long __RPC_FAR *plSize);
03351
03352         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdUpload )(
03353             IRbtlkFile __RPC_FAR * This,
03354             /* [in] */ short sFileID,
03355             /* [in] */ short sBlockNo,
03356             /* [in] */ BSTR bstrData);
03357
03358         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdDownload )(
03359             IRbtlkFile __RPC_FAR * This,
03360             /* [in] */ short sFileID,
03361             /* [out] */ short __RPC_FAR *psFileID,
03362             /* [out] */ short __RPC_FAR *psBlockNo,
03363             /* [out] */ BSTR __RPC_FAR *pbstrData);
03364
03365         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdCancelUpload )(
03366             IRbtlkFile __RPC_FAR * This,
03367             /* [in] */ short sFileID);
03368
03369         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdCancelDownload )(
03370             IRbtlkFile __RPC_FAR * This,
03371             /* [in] */ short sFileID);
03372
03373         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdDeleteFile )(
03374             IRbtlkFile __RPC_FAR * This,
03375             /* [in] */ CHAR __RPC_FAR *szName);
03376
03377         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetFileCnt )(
03378             IRbtlkFile __RPC_FAR * This,
03379             /* [in] */ CHAR __RPC_FAR *szName,
03380             /* [out] */ short __RPC_FAR *psFiles);
03381
03382         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdCopyFile )(
03383             IRbtlkFile __RPC_FAR * This,
03384             /* [in] */ CHAR __RPC_FAR *szFrom,
03385             /* [in] */ CHAR __RPC_FAR *szTo);
03386
03387         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdMoveFile )(
03388             IRbtlkFile __RPC_FAR * This,
03389             /* [in] */ CHAR __RPC_FAR *szFrom,
03390             /* [in] */ CHAR __RPC_FAR *szTo);
03391
03392         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetFileName )(
03393             IRbtlkFile __RPC_FAR * This,
03394             /* [in] */ short sIndex,
03395             /* [in] */ CHAR __RPC_FAR *szDirName,
03396             /* [out] */ CHAR __RPC_FAR *pVal);
03397
03398         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetAttributes )(
03399             IRbtlkFile __RPC_FAR * This,
03400             /* [in] */ short iSystem,
03401             /* [in] */ CHAR __RPC_FAR *szName,
03402             /* [out] */ long __RPC_FAR *pVal);
03403
03404         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetDataCreated )(
03405             IRbtlkFile __RPC_FAR * This,
03406             /* [in] */ short iSystem,
03407             /* [in] */ CHAR __RPC_FAR *szName,
03408             /* [out] */ short __RPC_FAR *pDateTime);
03409
03410         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetLastModified )(
03411             IRbtlkFile __RPC_FAR * This,
03412             /* [in] */ short iSystem,
03413             /* [in] */ CHAR __RPC_FAR *szName,
03414             /* [out] */ short __RPC_FAR *pDateTime);
03415
03416         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetLastAccessed )(
03417             IRbtlkFile __RPC_FAR * This,
03418             /* [in] */ short iSystem,
03419             /* [in] */ CHAR __RPC_FAR *szName,
03420             /* [out] */ short __RPC_FAR *pDateTime);
03421
03422         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetSize )(
03423             IRbtlkFile __RPC_FAR * This,
03424             /* [in] */ short iSystem,
03425             /* [in] */ CHAR __RPC_FAR *szName,
03426             /* [out] */ long __RPC_FAR *pVal);
03427
03428         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdStartPrg )(
03429             IRbtlkFile __RPC_FAR * This,
03430             /* [in] */ short iProgIC,
03431             /* [in] */ short iStartMode);
03432
03433         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdStopPrg )(
03434             IRbtlkFile __RPC_FAR * This,
03435             /* [in] */ short iProgIC,
03436             /* [in] */ short iStopMode);
03437
03438         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetProgramIC )(
03439             IRbtlkFile __RPC_FAR * This,
03440             /* [in] */ CHAR __RPC_FAR *szName,
03441             /* [out] */ short __RPC_FAR *pVal);
03442
03443         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdStepForward )(
03444             IRbtlkFile __RPC_FAR * This,
03445             /* [in] */ short iProgIC);
03446
03447         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdStepBackward )(
03448             IRbtlkFile __RPC_FAR * This,
03449             /* [in] */ short iProgIC);
03450
03451         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLetStartLine )(
03452             IRbtlkFile __RPC_FAR * This,
03453             /* [in] */ short iLineNo,
03454             /* [in] */ short iProgIC,
03455             /* [out] */ short __RPC_FAR *pVal);
03456
03457         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdKillProg )(
03458             IRbtlkFile __RPC_FAR * This,
03459             /* [in] */ short iActMode,
03460             /* [in] */ short iProgIC);
03461
03462         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdLoadNic )(
03463             IRbtlkFile __RPC_FAR * This,
03464             /* [out] */ long __RPC_FAR *pID);
03465
03466         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdRequestUpload0 )(
03467             IRbtlkFile __RPC_FAR * This,
03468             /* [in] */ short sBlocks,
03469             /* [in] */ long lSize,
03470             /* [in] */ CHAR __RPC_FAR *szName,
03471             /* [in] */ CHAR __RPC_FAR *szAttribute,
03472             /* [in] */ CHAR __RPC_FAR *szUsage,
03473             /* [out] */ short __RPC_FAR *psFileID);
03474
03475         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdRequestDownload0 )(
03476             IRbtlkFile __RPC_FAR * This,
03477             /* [in] */ CHAR __RPC_FAR *szName,
03478             /* [out] */ short __RPC_FAR *psFileID,
03479             /* [out] */ short __RPC_FAR *psBlocks,
03480             /* [out] */ long __RPC_FAR *plSize,
03481             /* [out] */ CHAR __RPC_FAR *szAttribute,
03482             /* [out] */ CHAR __RPC_FAR *szUsage);
03483
03484         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdUpload0 )(
03485             IRbtlkFile __RPC_FAR * This,
03486             /* [in] */ short sFileID,
03487             /* [in] */ short sBlockNo,
03488             /* [in] */ BSTR bstrData);
03489
03490         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdDownload0 )(
03491             IRbtlkFile __RPC_FAR * This,
03492             /* [in] */ short sFileID,
03493             /* [out] */ short __RPC_FAR *psFileID,
03494             /* [out] */ short __RPC_FAR *psBlockNo,
03495             /* [out] */ BSTR __RPC_FAR *pbstrData);
03496
03497         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdCancelUpload0 )(
03498             IRbtlkFile __RPC_FAR * This,
03499             /* [in] */ short sFileID);
03500
03501         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdCancelDownload0 )(
03502             IRbtlkFile __RPC_FAR * This,
03503             /* [in] */ short sFileID);
03504
03505         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetProgramIndex )(
03506             IRbtlkFile __RPC_FAR * This,
03507             /* [in] */ CHAR __RPC_FAR *szName,
03508             /* [out] */ short __RPC_FAR *pVal);
03509
03510         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdDeleteFile0 )(
03511             IRbtlkFile __RPC_FAR * This,
03512             /* [in] */ CHAR __RPC_FAR *szName);
03513
03514         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetFileCnt0 )(
03515             IRbtlkFile __RPC_FAR * This,
03516             /* [out] */ short __RPC_FAR *psFiles);
03517
03518         /* [helpstring] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *cmdGetFileName0 )(
03519             IRbtlkFile __RPC_FAR * This,
03520             /* [in] */ short sIndex,
03521             /* [out] */ CHAR __RPC_FAR *pVal);
03522
03523         END_INTERFACE
03524     } IRbtlkFileVtbl;
03525
03526     interface IRbtlkFile
03527     {
03528         CONST_VTBL struct IRbtlkFileVtbl __RPC_FAR *lpVtbl;
03529     };
03530
03531
03532
03533 #ifdef COBJMACROS
03534
03535
03536 #define IRbtlkFile_QueryInterface(This,riid,ppvObject)  \
03537     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
03538
03539 #define IRbtlkFile_AddRef(This) \
03540     (This)->lpVtbl -> AddRef(This)
03541
03542 #define IRbtlkFile_Release(This)    \
03543     (This)->lpVtbl -> Release(This)
03544
03545
03546 #define IRbtlkFile_cmdFileUploadStart(This) \
03547     (This)->lpVtbl -> cmdFileUploadStart(This)
03548
03549 #define IRbtlkFile_cmdFileUploadEnd(This)   \
03550     (This)->lpVtbl -> cmdFileUploadEnd(This)
03551
03552 #define IRbtlkFile_cmdRequestUpload(This,sBlocks,lSize,sFileProp,sFileFlag,szName,psFileID) \
03553     (This)->lpVtbl -> cmdRequestUpload(This,sBlocks,lSize,sFileProp,sFileFlag,szName,psFileID)
03554
03555 #define IRbtlkFile_cmdRequestDownload(This,sFileFlag,szName,psFileID,psBlocks,sFileProp,plSize) \
03556     (This)->lpVtbl -> cmdRequestDownload(This,sFileFlag,szName,psFileID,psBlocks,sFileProp,plSize)
03557
03558 #define IRbtlkFile_cmdUpload(This,sFileID,sBlockNo,bstrData)    \
03559     (This)->lpVtbl -> cmdUpload(This,sFileID,sBlockNo,bstrData)
03560
03561 #define IRbtlkFile_cmdDownload(This,sFileID,psFileID,psBlockNo,pbstrData)   \
03562     (This)->lpVtbl -> cmdDownload(This,sFileID,psFileID,psBlockNo,pbstrData)
03563
03564 #define IRbtlkFile_cmdCancelUpload(This,sFileID)    \
03565     (This)->lpVtbl -> cmdCancelUpload(This,sFileID)
03566
03567 #define IRbtlkFile_cmdCancelDownload(This,sFileID)  \
03568     (This)->lpVtbl -> cmdCancelDownload(This,sFileID)
03569
03570 #define IRbtlkFile_cmdDeleteFile(This,szName)   \
03571     (This)->lpVtbl -> cmdDeleteFile(This,szName)
03572
03573 #define IRbtlkFile_cmdGetFileCnt(This,szName,psFiles)   \
03574     (This)->lpVtbl -> cmdGetFileCnt(This,szName,psFiles)
03575
03576 #define IRbtlkFile_cmdCopyFile(This,szFrom,szTo)    \
03577     (This)->lpVtbl -> cmdCopyFile(This,szFrom,szTo)
03578
03579 #define IRbtlkFile_cmdMoveFile(This,szFrom,szTo)    \
03580     (This)->lpVtbl -> cmdMoveFile(This,szFrom,szTo)
03581
03582 #define IRbtlkFile_cmdGetFileName(This,sIndex,szDirName,pVal)   \
03583     (This)->lpVtbl -> cmdGetFileName(This,sIndex,szDirName,pVal)
03584
03585 #define IRbtlkFile_cmdGetAttributes(This,iSystem,szName,pVal)   \
03586     (This)->lpVtbl -> cmdGetAttributes(This,iSystem,szName,pVal)
03587
03588 #define IRbtlkFile_cmdGetDataCreated(This,iSystem,szName,pDateTime) \
03589     (This)->lpVtbl -> cmdGetDataCreated(This,iSystem,szName,pDateTime)
03590
03591 #define IRbtlkFile_cmdGetLastModified(This,iSystem,szName,pDateTime)    \
03592     (This)->lpVtbl -> cmdGetLastModified(This,iSystem,szName,pDateTime)
03593
03594 #define IRbtlkFile_cmdGetLastAccessed(This,iSystem,szName,pDateTime)    \
03595     (This)->lpVtbl -> cmdGetLastAccessed(This,iSystem,szName,pDateTime)
03596
03597 #define IRbtlkFile_cmdGetSize(This,iSystem,szName,pVal) \
03598     (This)->lpVtbl -> cmdGetSize(This,iSystem,szName,pVal)
03599
03600 #define IRbtlkFile_cmdStartPrg(This,iProgIC,iStartMode) \
03601     (This)->lpVtbl -> cmdStartPrg(This,iProgIC,iStartMode)
03602
03603 #define IRbtlkFile_cmdStopPrg(This,iProgIC,iStopMode)   \
03604     (This)->lpVtbl -> cmdStopPrg(This,iProgIC,iStopMode)
03605
03606 #define IRbtlkFile_cmdGetProgramIC(This,szName,pVal)    \
03607     (This)->lpVtbl -> cmdGetProgramIC(This,szName,pVal)
03608
03609 #define IRbtlkFile_cmdStepForward(This,iProgIC) \
03610     (This)->lpVtbl -> cmdStepForward(This,iProgIC)
03611
03612 #define IRbtlkFile_cmdStepBackward(This,iProgIC)    \
03613     (This)->lpVtbl -> cmdStepBackward(This,iProgIC)
03614
03615 #define IRbtlkFile_cmdLetStartLine(This,iLineNo,iProgIC,pVal)   \
03616     (This)->lpVtbl -> cmdLetStartLine(This,iLineNo,iProgIC,pVal)
03617
03618 #define IRbtlkFile_cmdKillProg(This,iActMode,iProgIC)   \
03619     (This)->lpVtbl -> cmdKillProg(This,iActMode,iProgIC)
03620
03621 #define IRbtlkFile_cmdLoadNic(This,pID) \
03622     (This)->lpVtbl -> cmdLoadNic(This,pID)
03623
03624 #define IRbtlkFile_cmdRequestUpload0(This,sBlocks,lSize,szName,szAttribute,szUsage,psFileID)    \
03625     (This)->lpVtbl -> cmdRequestUpload0(This,sBlocks,lSize,szName,szAttribute,szUsage,psFileID)
03626
03627 #define IRbtlkFile_cmdRequestDownload0(This,szName,psFileID,psBlocks,plSize,szAttribute,szUsage)    \
03628     (This)->lpVtbl -> cmdRequestDownload0(This,szName,psFileID,psBlocks,plSize,szAttribute,szUsage)
03629
03630 #define IRbtlkFile_cmdUpload0(This,sFileID,sBlockNo,bstrData)   \
03631     (This)->lpVtbl -> cmdUpload0(This,sFileID,sBlockNo,bstrData)
03632
03633 #define IRbtlkFile_cmdDownload0(This,sFileID,psFileID,psBlockNo,pbstrData)  \
03634     (This)->lpVtbl -> cmdDownload0(This,sFileID,psFileID,psBlockNo,pbstrData)
03635
03636 #define IRbtlkFile_cmdCancelUpload0(This,sFileID)   \
03637     (This)->lpVtbl -> cmdCancelUpload0(This,sFileID)
03638
03639 #define IRbtlkFile_cmdCancelDownload0(This,sFileID) \
03640     (This)->lpVtbl -> cmdCancelDownload0(This,sFileID)
03641
03642 #define IRbtlkFile_cmdGetProgramIndex(This,szName,pVal) \
03643     (This)->lpVtbl -> cmdGetProgramIndex(This,szName,pVal)
03644
03645 #define IRbtlkFile_cmdDeleteFile0(This,szName)  \
03646     (This)->lpVtbl -> cmdDeleteFile0(This,szName)
03647
03648 #define IRbtlkFile_cmdGetFileCnt0(This,psFiles) \
03649     (This)->lpVtbl -> cmdGetFileCnt0(This,psFiles)
03650
03651 #define IRbtlkFile_cmdGetFileName0(This,sIndex,pVal)    \
03652     (This)->lpVtbl -> cmdGetFileName0(This,sIndex,pVal)
03653
03654 #endif /* COBJMACROS */
03655
03656
03657 #endif  /* C style interface */
03658
03659
03660
03661 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdFileUploadStart_Proxy(
03662     IRbtlkFile __RPC_FAR * This);
03663
03664
03665 void __RPC_STUB IRbtlkFile_cmdFileUploadStart_Stub(
03666     IRpcStubBuffer *This,
03667     IRpcChannelBuffer *_pRpcChannelBuffer,
03668     PRPC_MESSAGE _pRpcMessage,
03669     DWORD *_pdwStubPhase);
03670
03671
03672 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdFileUploadEnd_Proxy(
03673     IRbtlkFile __RPC_FAR * This);
03674
03675
03676 void __RPC_STUB IRbtlkFile_cmdFileUploadEnd_Stub(
03677     IRpcStubBuffer *This,
03678     IRpcChannelBuffer *_pRpcChannelBuffer,
03679     PRPC_MESSAGE _pRpcMessage,
03680     DWORD *_pdwStubPhase);
03681
03682
03683 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdRequestUpload_Proxy(
03684     IRbtlkFile __RPC_FAR * This,
03685     /* [in] */ short sBlocks,
03686     /* [in] */ long lSize,
03687     /* [in] */ short sFileProp,
03688     /* [in] */ short sFileFlag,
03689     /* [in] */ CHAR __RPC_FAR *szName,
03690     /* [out] */ short __RPC_FAR *psFileID);
03691
03692
03693 void __RPC_STUB IRbtlkFile_cmdRequestUpload_Stub(
03694     IRpcStubBuffer *This,
03695     IRpcChannelBuffer *_pRpcChannelBuffer,
03696     PRPC_MESSAGE _pRpcMessage,
03697     DWORD *_pdwStubPhase);
03698
03699
03700 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdRequestDownload_Proxy(
03701     IRbtlkFile __RPC_FAR * This,
03702     /* [in] */ short sFileFlag,
03703     /* [in] */ CHAR __RPC_FAR *szName,
03704     /* [out] */ short __RPC_FAR *psFileID,
03705     /* [out] */ short __RPC_FAR *psBlocks,
03706     /* [out] */ short __RPC_FAR *sFileProp,
03707     /* [out] */ long __RPC_FAR *plSize);
03708
03709
03710 void __RPC_STUB IRbtlkFile_cmdRequestDownload_Stub(
03711     IRpcStubBuffer *This,
03712     IRpcChannelBuffer *_pRpcChannelBuffer,
03713     PRPC_MESSAGE _pRpcMessage,
03714     DWORD *_pdwStubPhase);
03715
03716
03717 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdUpload_Proxy(
03718     IRbtlkFile __RPC_FAR * This,
03719     /* [in] */ short sFileID,
03720     /* [in] */ short sBlockNo,
03721     /* [in] */ BSTR bstrData);
03722
03723
03724 void __RPC_STUB IRbtlkFile_cmdUpload_Stub(
03725     IRpcStubBuffer *This,
03726     IRpcChannelBuffer *_pRpcChannelBuffer,
03727     PRPC_MESSAGE _pRpcMessage,
03728     DWORD *_pdwStubPhase);
03729
03730
03731 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdDownload_Proxy(
03732     IRbtlkFile __RPC_FAR * This,
03733     /* [in] */ short sFileID,
03734     /* [out] */ short __RPC_FAR *psFileID,
03735     /* [out] */ short __RPC_FAR *psBlockNo,
03736     /* [out] */ BSTR __RPC_FAR *pbstrData);
03737
03738
03739 void __RPC_STUB IRbtlkFile_cmdDownload_Stub(
03740     IRpcStubBuffer *This,
03741     IRpcChannelBuffer *_pRpcChannelBuffer,
03742     PRPC_MESSAGE _pRpcMessage,
03743     DWORD *_pdwStubPhase);
03744
03745
03746 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdCancelUpload_Proxy(
03747     IRbtlkFile __RPC_FAR * This,
03748     /* [in] */ short sFileID);
03749
03750
03751 void __RPC_STUB IRbtlkFile_cmdCancelUpload_Stub(
03752     IRpcStubBuffer *This,
03753     IRpcChannelBuffer *_pRpcChannelBuffer,
03754     PRPC_MESSAGE _pRpcMessage,
03755     DWORD *_pdwStubPhase);
03756
03757
03758 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdCancelDownload_Proxy(
03759     IRbtlkFile __RPC_FAR * This,
03760     /* [in] */ short sFileID);
03761
03762
03763 void __RPC_STUB IRbtlkFile_cmdCancelDownload_Stub(
03764     IRpcStubBuffer *This,
03765     IRpcChannelBuffer *_pRpcChannelBuffer,
03766     PRPC_MESSAGE _pRpcMessage,
03767     DWORD *_pdwStubPhase);
03768
03769
03770 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdDeleteFile_Proxy(
03771     IRbtlkFile __RPC_FAR * This,
03772     /* [in] */ CHAR __RPC_FAR *szName);
03773
03774
03775 void __RPC_STUB IRbtlkFile_cmdDeleteFile_Stub(
03776     IRpcStubBuffer *This,
03777     IRpcChannelBuffer *_pRpcChannelBuffer,
03778     PRPC_MESSAGE _pRpcMessage,
03779     DWORD *_pdwStubPhase);
03780
03781
03782 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetFileCnt_Proxy(
03783     IRbtlkFile __RPC_FAR * This,
03784     /* [in] */ CHAR __RPC_FAR *szName,
03785     /* [out] */ short __RPC_FAR *psFiles);
03786
03787
03788 void __RPC_STUB IRbtlkFile_cmdGetFileCnt_Stub(
03789     IRpcStubBuffer *This,
03790     IRpcChannelBuffer *_pRpcChannelBuffer,
03791     PRPC_MESSAGE _pRpcMessage,
03792     DWORD *_pdwStubPhase);
03793
03794
03795 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdCopyFile_Proxy(
03796     IRbtlkFile __RPC_FAR * This,
03797     /* [in] */ CHAR __RPC_FAR *szFrom,
03798     /* [in] */ CHAR __RPC_FAR *szTo);
03799
03800
03801 void __RPC_STUB IRbtlkFile_cmdCopyFile_Stub(
03802     IRpcStubBuffer *This,
03803     IRpcChannelBuffer *_pRpcChannelBuffer,
03804     PRPC_MESSAGE _pRpcMessage,
03805     DWORD *_pdwStubPhase);
03806
03807
03808 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdMoveFile_Proxy(
03809     IRbtlkFile __RPC_FAR * This,
03810     /* [in] */ CHAR __RPC_FAR *szFrom,
03811     /* [in] */ CHAR __RPC_FAR *szTo);
03812
03813
03814 void __RPC_STUB IRbtlkFile_cmdMoveFile_Stub(
03815     IRpcStubBuffer *This,
03816     IRpcChannelBuffer *_pRpcChannelBuffer,
03817     PRPC_MESSAGE _pRpcMessage,
03818     DWORD *_pdwStubPhase);
03819
03820
03821 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetFileName_Proxy(
03822     IRbtlkFile __RPC_FAR * This,
03823     /* [in] */ short sIndex,
03824     /* [in] */ CHAR __RPC_FAR *szDirName,
03825     /* [out] */ CHAR __RPC_FAR *pVal);
03826
03827
03828 void __RPC_STUB IRbtlkFile_cmdGetFileName_Stub(
03829     IRpcStubBuffer *This,
03830     IRpcChannelBuffer *_pRpcChannelBuffer,
03831     PRPC_MESSAGE _pRpcMessage,
03832     DWORD *_pdwStubPhase);
03833
03834
03835 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetAttributes_Proxy(
03836     IRbtlkFile __RPC_FAR * This,
03837     /* [in] */ short iSystem,
03838     /* [in] */ CHAR __RPC_FAR *szName,
03839     /* [out] */ long __RPC_FAR *pVal);
03840
03841
03842 void __RPC_STUB IRbtlkFile_cmdGetAttributes_Stub(
03843     IRpcStubBuffer *This,
03844     IRpcChannelBuffer *_pRpcChannelBuffer,
03845     PRPC_MESSAGE _pRpcMessage,
03846     DWORD *_pdwStubPhase);
03847
03848
03849 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetDataCreated_Proxy(
03850     IRbtlkFile __RPC_FAR * This,
03851     /* [in] */ short iSystem,
03852     /* [in] */ CHAR __RPC_FAR *szName,
03853     /* [out] */ short __RPC_FAR *pDateTime);
03854
03855
03856 void __RPC_STUB IRbtlkFile_cmdGetDataCreated_Stub(
03857     IRpcStubBuffer *This,
03858     IRpcChannelBuffer *_pRpcChannelBuffer,
03859     PRPC_MESSAGE _pRpcMessage,
03860     DWORD *_pdwStubPhase);
03861
03862
03863 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetLastModified_Proxy(
03864     IRbtlkFile __RPC_FAR * This,
03865     /* [in] */ short iSystem,
03866     /* [in] */ CHAR __RPC_FAR *szName,
03867     /* [out] */ short __RPC_FAR *pDateTime);
03868
03869
03870 void __RPC_STUB IRbtlkFile_cmdGetLastModified_Stub(
03871     IRpcStubBuffer *This,
03872     IRpcChannelBuffer *_pRpcChannelBuffer,
03873     PRPC_MESSAGE _pRpcMessage,
03874     DWORD *_pdwStubPhase);
03875
03876
03877 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetLastAccessed_Proxy(
03878     IRbtlkFile __RPC_FAR * This,
03879     /* [in] */ short iSystem,
03880     /* [in] */ CHAR __RPC_FAR *szName,
03881     /* [out] */ short __RPC_FAR *pDateTime);
03882
03883
03884 void __RPC_STUB IRbtlkFile_cmdGetLastAccessed_Stub(
03885     IRpcStubBuffer *This,
03886     IRpcChannelBuffer *_pRpcChannelBuffer,
03887     PRPC_MESSAGE _pRpcMessage,
03888     DWORD *_pdwStubPhase);
03889
03890
03891 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetSize_Proxy(
03892     IRbtlkFile __RPC_FAR * This,
03893     /* [in] */ short iSystem,
03894     /* [in] */ CHAR __RPC_FAR *szName,
03895     /* [out] */ long __RPC_FAR *pVal);
03896
03897
03898 void __RPC_STUB IRbtlkFile_cmdGetSize_Stub(
03899     IRpcStubBuffer *This,
03900     IRpcChannelBuffer *_pRpcChannelBuffer,
03901     PRPC_MESSAGE _pRpcMessage,
03902     DWORD *_pdwStubPhase);
03903
03904
03905 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdStartPrg_Proxy(
03906     IRbtlkFile __RPC_FAR * This,
03907     /* [in] */ short iProgIC,
03908     /* [in] */ short iStartMode);
03909
03910
03911 void __RPC_STUB IRbtlkFile_cmdStartPrg_Stub(
03912     IRpcStubBuffer *This,
03913     IRpcChannelBuffer *_pRpcChannelBuffer,
03914     PRPC_MESSAGE _pRpcMessage,
03915     DWORD *_pdwStubPhase);
03916
03917
03918 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdStopPrg_Proxy(
03919     IRbtlkFile __RPC_FAR * This,
03920     /* [in] */ short iProgIC,
03921     /* [in] */ short iStopMode);
03922
03923
03924 void __RPC_STUB IRbtlkFile_cmdStopPrg_Stub(
03925     IRpcStubBuffer *This,
03926     IRpcChannelBuffer *_pRpcChannelBuffer,
03927     PRPC_MESSAGE _pRpcMessage,
03928     DWORD *_pdwStubPhase);
03929
03930
03931 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetProgramIC_Proxy(
03932     IRbtlkFile __RPC_FAR * This,
03933     /* [in] */ CHAR __RPC_FAR *szName,
03934     /* [out] */ short __RPC_FAR *pVal);
03935
03936
03937 void __RPC_STUB IRbtlkFile_cmdGetProgramIC_Stub(
03938     IRpcStubBuffer *This,
03939     IRpcChannelBuffer *_pRpcChannelBuffer,
03940     PRPC_MESSAGE _pRpcMessage,
03941     DWORD *_pdwStubPhase);
03942
03943
03944 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdStepForward_Proxy(
03945     IRbtlkFile __RPC_FAR * This,
03946     /* [in] */ short iProgIC);
03947
03948
03949 void __RPC_STUB IRbtlkFile_cmdStepForward_Stub(
03950     IRpcStubBuffer *This,
03951     IRpcChannelBuffer *_pRpcChannelBuffer,
03952     PRPC_MESSAGE _pRpcMessage,
03953     DWORD *_pdwStubPhase);
03954
03955
03956 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdStepBackward_Proxy(
03957     IRbtlkFile __RPC_FAR * This,
03958     /* [in] */ short iProgIC);
03959
03960
03961 void __RPC_STUB IRbtlkFile_cmdStepBackward_Stub(
03962     IRpcStubBuffer *This,
03963     IRpcChannelBuffer *_pRpcChannelBuffer,
03964     PRPC_MESSAGE _pRpcMessage,
03965     DWORD *_pdwStubPhase);
03966
03967
03968 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdLetStartLine_Proxy(
03969     IRbtlkFile __RPC_FAR * This,
03970     /* [in] */ short iLineNo,
03971     /* [in] */ short iProgIC,
03972     /* [out] */ short __RPC_FAR *pVal);
03973
03974
03975 void __RPC_STUB IRbtlkFile_cmdLetStartLine_Stub(
03976     IRpcStubBuffer *This,
03977     IRpcChannelBuffer *_pRpcChannelBuffer,
03978     PRPC_MESSAGE _pRpcMessage,
03979     DWORD *_pdwStubPhase);
03980
03981
03982 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdKillProg_Proxy(
03983     IRbtlkFile __RPC_FAR * This,
03984     /* [in] */ short iActMode,
03985     /* [in] */ short iProgIC);
03986
03987
03988 void __RPC_STUB IRbtlkFile_cmdKillProg_Stub(
03989     IRpcStubBuffer *This,
03990     IRpcChannelBuffer *_pRpcChannelBuffer,
03991     PRPC_MESSAGE _pRpcMessage,
03992     DWORD *_pdwStubPhase);
03993
03994
03995 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdLoadNic_Proxy(
03996     IRbtlkFile __RPC_FAR * This,
03997     /* [out] */ long __RPC_FAR *pID);
03998
03999
04000 void __RPC_STUB IRbtlkFile_cmdLoadNic_Stub(
04001     IRpcStubBuffer *This,
04002     IRpcChannelBuffer *_pRpcChannelBuffer,
04003     PRPC_MESSAGE _pRpcMessage,
04004     DWORD *_pdwStubPhase);
04005
04006
04007 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdRequestUpload0_Proxy(
04008     IRbtlkFile __RPC_FAR * This,
04009     /* [in] */ short sBlocks,
04010     /* [in] */ long lSize,
04011     /* [in] */ CHAR __RPC_FAR *szName,
04012     /* [in] */ CHAR __RPC_FAR *szAttribute,
04013     /* [in] */ CHAR __RPC_FAR *szUsage,
04014     /* [out] */ short __RPC_FAR *psFileID);
04015
04016
04017 void __RPC_STUB IRbtlkFile_cmdRequestUpload0_Stub(
04018     IRpcStubBuffer *This,
04019     IRpcChannelBuffer *_pRpcChannelBuffer,
04020     PRPC_MESSAGE _pRpcMessage,
04021     DWORD *_pdwStubPhase);
04022
04023
04024 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdRequestDownload0_Proxy(
04025     IRbtlkFile __RPC_FAR * This,
04026     /* [in] */ CHAR __RPC_FAR *szName,
04027     /* [out] */ short __RPC_FAR *psFileID,
04028     /* [out] */ short __RPC_FAR *psBlocks,
04029     /* [out] */ long __RPC_FAR *plSize,
04030     /* [out] */ CHAR __RPC_FAR *szAttribute,
04031     /* [out] */ CHAR __RPC_FAR *szUsage);
04032
04033
04034 void __RPC_STUB IRbtlkFile_cmdRequestDownload0_Stub(
04035     IRpcStubBuffer *This,
04036     IRpcChannelBuffer *_pRpcChannelBuffer,
04037     PRPC_MESSAGE _pRpcMessage,
04038     DWORD *_pdwStubPhase);
04039
04040
04041 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdUpload0_Proxy(
04042     IRbtlkFile __RPC_FAR * This,
04043     /* [in] */ short sFileID,
04044     /* [in] */ short sBlockNo,
04045     /* [in] */ BSTR bstrData);
04046
04047
04048 void __RPC_STUB IRbtlkFile_cmdUpload0_Stub(
04049     IRpcStubBuffer *This,
04050     IRpcChannelBuffer *_pRpcChannelBuffer,
04051     PRPC_MESSAGE _pRpcMessage,
04052     DWORD *_pdwStubPhase);
04053
04054
04055 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdDownload0_Proxy(
04056     IRbtlkFile __RPC_FAR * This,
04057     /* [in] */ short sFileID,
04058     /* [out] */ short __RPC_FAR *psFileID,
04059     /* [out] */ short __RPC_FAR *psBlockNo,
04060     /* [out] */ BSTR __RPC_FAR *pbstrData);
04061
04062
04063 void __RPC_STUB IRbtlkFile_cmdDownload0_Stub(
04064     IRpcStubBuffer *This,
04065     IRpcChannelBuffer *_pRpcChannelBuffer,
04066     PRPC_MESSAGE _pRpcMessage,
04067     DWORD *_pdwStubPhase);
04068
04069
04070 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdCancelUpload0_Proxy(
04071     IRbtlkFile __RPC_FAR * This,
04072     /* [in] */ short sFileID);
04073
04074
04075 void __RPC_STUB IRbtlkFile_cmdCancelUpload0_Stub(
04076     IRpcStubBuffer *This,
04077     IRpcChannelBuffer *_pRpcChannelBuffer,
04078     PRPC_MESSAGE _pRpcMessage,
04079     DWORD *_pdwStubPhase);
04080
04081
04082 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdCancelDownload0_Proxy(
04083     IRbtlkFile __RPC_FAR * This,
04084     /* [in] */ short sFileID);
04085
04086
04087 void __RPC_STUB IRbtlkFile_cmdCancelDownload0_Stub(
04088     IRpcStubBuffer *This,
04089     IRpcChannelBuffer *_pRpcChannelBuffer,
04090     PRPC_MESSAGE _pRpcMessage,
04091     DWORD *_pdwStubPhase);
04092
04093
04094 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetProgramIndex_Proxy(
04095     IRbtlkFile __RPC_FAR * This,
04096     /* [in] */ CHAR __RPC_FAR *szName,
04097     /* [out] */ short __RPC_FAR *pVal);
04098
04099
04100 void __RPC_STUB IRbtlkFile_cmdGetProgramIndex_Stub(
04101     IRpcStubBuffer *This,
04102     IRpcChannelBuffer *_pRpcChannelBuffer,
04103     PRPC_MESSAGE _pRpcMessage,
04104     DWORD *_pdwStubPhase);
04105
04106
04107 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdDeleteFile0_Proxy(
04108     IRbtlkFile __RPC_FAR * This,
04109     /* [in] */ CHAR __RPC_FAR *szName);
04110
04111
04112 void __RPC_STUB IRbtlkFile_cmdDeleteFile0_Stub(
04113     IRpcStubBuffer *This,
04114     IRpcChannelBuffer *_pRpcChannelBuffer,
04115     PRPC_MESSAGE _pRpcMessage,
04116     DWORD *_pdwStubPhase);
04117
04118
04119 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetFileCnt0_Proxy(
04120     IRbtlkFile __RPC_FAR * This,
04121     /* [out] */ short __RPC_FAR *psFiles);
04122
04123
04124 void __RPC_STUB IRbtlkFile_cmdGetFileCnt0_Stub(
04125     IRpcStubBuffer *This,
04126     IRpcChannelBuffer *_pRpcChannelBuffer,
04127     PRPC_MESSAGE _pRpcMessage,
04128     DWORD *_pdwStubPhase);
04129
04130
04131 /* [helpstring] */ HRESULT STDMETHODCALLTYPE IRbtlkFile_cmdGetFileName0_Proxy(
04132     IRbtlkFile __RPC_FAR * This,
04133     /* [in] */ short sIndex,
04134     /* [out] */ CHAR __RPC_FAR *pVal);
04135
04136
04137 void __RPC_STUB IRbtlkFile_cmdGetFileName0_Stub(
04138     IRpcStubBuffer *This,
04139     IRpcChannelBuffer *_pRpcChannelBuffer,
04140     PRPC_MESSAGE _pRpcMessage,
04141     DWORD *_pdwStubPhase);
04142
04143
04144
04145 #endif  /* __IRbtlkFile_INTERFACE_DEFINED__ */
04146
04147
04148
04149 #ifndef __ROBOTALKLib_LIBRARY_DEFINED__
04150 #define __ROBOTALKLib_LIBRARY_DEFINED__
04151
04152 /* library ROBOTALKLib */
04153 /* [helpstring][version][uuid] */
04154
04155
04156 EXTERN_C const IID LIBID_ROBOTALKLib;
04157
04158 EXTERN_C const CLSID CLSID_RbtlkEngine;
04159
04160 #ifdef __cplusplus
04161
04162 class DECLSPEC_UUID("2567A726-828B-4D30-8E2E-E661F9921D99")
04163 RbtlkEngine;
04164 #endif
04165
04166 EXTERN_C const CLSID CLSID_RbtlkController;
04167
04168 #ifdef __cplusplus
04169
04170 class DECLSPEC_UUID("E218CEA4-EA72-4ab3-A5E5-6AE4B2835995")
04171 RbtlkController;
04172 #endif
04173
04174 EXTERN_C const CLSID CLSID_RbtlkVariable;
04175
04176 #ifdef __cplusplus
04177
04178 class DECLSPEC_UUID("8D476744-65EC-456e-A6C7-641D07520C13")
04179 RbtlkVariable;
04180 #endif
04181
04182 EXTERN_C const CLSID CLSID_RbtlkIO;
04183
04184 #ifdef __cplusplus
04185
04186 class DECLSPEC_UUID("BA8055B8-4ED2-4d3e-ADFD-8A8DB628EF39")
04187 RbtlkIO;
04188 #endif
04189
04190 EXTERN_C const CLSID CLSID_RbtlkArm;
04191
04192 #ifdef __cplusplus
04193
04194 class DECLSPEC_UUID("8403C89E-8C66-4d0b-BBB4-8A170A767F6F")
04195 RbtlkArm;
04196 #endif
04197
04198 EXTERN_C const CLSID CLSID_RbtlkTask;
04199
04200 #ifdef __cplusplus
04201
04202 class DECLSPEC_UUID("2A783DB8-5443-4950-B460-43FA8E7E0BF2")
04203 RbtlkTask;
04204 #endif
04205
04206 EXTERN_C const CLSID CLSID_RbtlkFile;
04207
04208 #ifdef __cplusplus
04209
04210 class DECLSPEC_UUID("448B9ED4-44D4-4a29-A30C-953CA7A2910B")
04211 RbtlkFile;
04212 #endif
04213 #endif /* __ROBOTALKLib_LIBRARY_DEFINED__ */
04214
04215 /* Additional Prototypes for ALL interfaces */
04216
04217 unsigned long             __RPC_USER  BSTR_UserSize(     unsigned long __RPC_FAR *, unsigned long            , BSTR __RPC_FAR * );
04218 unsigned char __RPC_FAR * __RPC_USER  BSTR_UserMarshal(  unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR * );
04219 unsigned char __RPC_FAR * __RPC_USER  BSTR_UserUnmarshal(unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR * );
04220 void                      __RPC_USER  BSTR_UserFree(     unsigned long __RPC_FAR *, BSTR __RPC_FAR * );
04221
04222 /* end of Additional Prototypes */
04223
04224 #ifdef __cplusplus
04225 }
04226 #endif
04227
04228 #endif
Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


ROBOTalk.idl Source File

ROBOTalk.idl

解説を見る。
00001 // ROBOTalk.idl : ROBOTalk.dll 用の IDL ソース ファイル
00002 //
00003
00004 // このファイルはタイプ ライブラリ (ROBOTalk.tlb) を作成するために
00005 // タイプ ライブラリ作成ツール MIDL によって処理されます。
00006
00007 import "oaidl.idl";
00008 import "ocidl.idl";
00009
00010 interface IRbtlkController;
00011 interface IRbtlkVariable;
00012 interface IRbtlkIO;
00013 interface IRbtlkArm;
00014 interface IRbtlkTask;
00015 interface IRbtlkFile;
00016
00017     [
00018         object,
00019         uuid(F7D1E6C8-C6D4-4696-BD58-282134D40134),
00020
00021         helpstring("IRbtlkEngine Interface"),
00022         pointer_default(unique)
00023     ]
00024     interface IRbtlkEngine : IUnknown
00025     {
00026         // ========== PAC-NIC 大域変数の内部コード ==========
00027         typedef enum {
00028             NIC_GV_INT = (short)0x1018,
00029             NIC_GV_SNG = (short)0x1019,
00030             NIC_GV_DBL = (short)0x101A,
00031             NIC_GV_VEC = (short)0x101C,
00032             NIC_GV_POS = (short)0x1015,
00033             NIC_GV_JNT = (short)0x101E,
00034             NIC_GV_TRN = (short)0x101D,
00035             NIC_GV_STR = (short)0x101B,
00036             NIC_GV_IO  = (short)0xFFFF
00037         } NIC_GVAR_IC;
00038
00039         // ========== ROBOTalk パケット構造 ==========
00040         typedef struct
00041         {
00042 //          char    bEnabled;                   // (注) 実際のパケットには入っていない．
00043             BYTE    bEnq;                       //
00044             BYTE    bLength;                    //
00045             WORD    wCommand;                   //
00046             BYTE    bID1;                       //
00047             BYTE    bID2;                       //
00048             BYTE    bData[248];             // = RTK_DATA_MAXLEN
00049             BYTE    bCDH;                       //
00050             BYTE    bCDL;                       //
00051         } RTK_PACKET;
00052
00053         // ========== GetStatus Items ==========
00054         typedef enum {
00055             RTK_CST_ERROR       = 2,        // ロボット異常 (0:OFF, 1:ON)
00056             RTK_CST_RUNNING     = 3,        // ロボット運転中 (0:OFF, 1:ON)
00057             RTK_CST_EMGSTOP     = 4         // 非常停止 (0:OFF, 1:ON)
00058         } RTK_CTRL_STATUS;
00059
00060         [helpstring("ﾒｿｯﾄﾞ ConnectServer")] HRESULT ConnectServer([in] CHAR *szPara);
00061         [helpstring("ﾒｿｯﾄﾞ DisconnectServer")] HRESULT DisconnectServer();
00062
00063         [helpstring("ﾒｿｯﾄﾞ Cancel")] HRESULT Cancel();
00064         [helpstring("ﾒｿｯﾄﾞ GetVerInfo")] HRESULT GetVarInfo([in] CHAR *szVar, [out] short *sType, [out] short *sIndex );
00065
00066         [propget, helpstring("ﾌﾟﾛﾊﾟﾃｨ RbtlkController")] HRESULT RbtlkController([out, retval] IRbtlkController **ppVal);
00067         [propget, helpstring("ﾌﾟﾛﾊﾟﾃｨ RbtlkVariable")] HRESULT RbtlkVariable([out, retval] IRbtlkVariable **ppVal);
00068         [propget, helpstring("ﾌﾟﾛﾊﾟﾃｨ RbtlkArm")] HRESULT RbtlkArm([out, retval] IRbtlkArm **ppVal);
00069         [propget, helpstring("ﾌﾟﾛﾊﾟﾃｨ RbtlkIO")] HRESULT RbtlkIO([out, retval] IRbtlkIO **ppVal);
00070         [propget, helpstring("ﾌﾟﾛﾊﾟﾃｨ RbtlkTask")] HRESULT RbtlkTask([out, retval] IRbtlkTask **ppVal);
00071         [propget, helpstring("ﾌﾟﾛﾊﾟﾃｨ RbtlkFile")] HRESULT RbtlkFile([out, retval] IRbtlkFile **ppVal);
00072         [propget, helpstring("ﾌﾟﾛﾊﾟﾃｨ TimeOut")] HRESULT TimeOut([out, retval] long *pVal);
00073         [propput, helpstring("ﾌﾟﾛﾊﾟﾃｨ TimeOut")] HRESULT TimeOut([in] long newVal);
00074         [propget, helpstring("ﾌﾟﾛﾊﾟﾃｨ TimeOutRetry")] HRESULT TimeOutRetry([out, retval] long *pVal);
00075         [propput, helpstring("ﾌﾟﾛﾊﾟﾃｨ TimeOutRetry")] HRESULT TimeOutRetry([in] long newVal);
00076         [propget, helpstring("ﾌﾟﾛﾊﾟﾃｨ NakRetry")] HRESULT NakRetry([out, retval] long *pVal);
00077         [propput, helpstring("ﾌﾟﾛﾊﾟﾃｨ NakRetry")] HRESULT NakRetry([in] long newVal);
00078         [propget, helpstring("ﾌﾟﾛﾊﾟﾃｨ LastError")] HRESULT LastError([out, retval] long *pVal);
00079         [propget, helpstring("ﾌﾟﾛﾊﾟﾃｨ Version")] HRESULT Version([out, retval] double *pVal);
00080     };
00081
00082     // IRbtlkController
00083     [
00084         object,
00085         uuid(C85F8BB2-EFF4-485e-BB44-F5DED29F2701),
00086         helpstring("IRbtlkController Interface"),
00087         pointer_default(unique)
00088     ]
00089     interface IRbtlkController : IUnknown
00090     {
00091         [helpstring("ﾒｿｯﾄﾞ cmdGetVersions")] HRESULT cmdGetVersions([in] short sIndex, [out] CHAR *pVal);
00092         [helpstring("ﾒｿｯﾄﾞ cmdGetDateTime")] HRESULT cmdGetDateTime([out] short *psDateTime);
00093         [helpstring("ﾒｿｯﾄﾞ cmdLetDateTime")] HRESULT cmdLetDateTime([in] short *psDateTime);
00094         [helpstring("ﾒｿｯﾄﾞ cmdClearCtrlLog")] HRESULT cmdClearCtrlLog();
00095         [helpstring("ﾒｿｯﾄﾞ cmdStartCtrlLog")] HRESULT cmdStartCtrlLog();
00096         [helpstring("ﾒｿｯﾄﾞ cmdStopCtrlLog")] HRESULT cmdStopCtrlLog();
00097         [helpstring("ﾒｿｯﾄﾞ cmdGetParamCtrlLog")] HRESULT cmdGetParamCtrlLog([out] long *pSmpCnt, [out] long *pSmpRate);
00098         [helpstring("ﾒｿｯﾄﾞ cmdSwitchCtrlLog")] HRESULT cmdSwitchCtrlLog([in] short sMode);
00099         [helpstring("ﾒｿｯﾄﾞ cmdCancelCtrlLog")] HRESULT cmdCancelCtrlLog();
00100         [helpstring("ﾒｿｯﾄﾞ cmdGetMode")] HRESULT cmdGetMode([out] short* pVal );
00101         [helpstring("ﾒｿｯﾄﾞ cmdSetMode")] HRESULT cmdSetMode([in] short iMode );
00102         [helpstring("ﾒｿｯﾄﾞ cmdGetFreeMemory")] HRESULT cmdGetFreeMemory([out] long* pVal);
00103         [helpstring("ﾒｿｯﾄﾞ cmdGetRobotType")] HRESULT cmdGetRobotType([out] long* pVal);
00104         [helpstring("ﾒｿｯﾄﾞ cmdGetJointInfo")] HRESULT cmdGetJointInfo([in] short sMode, [out] short* pVal);
00105         [helpstring("ﾒｿｯﾄﾞ cmdGetJobStatus")] HRESULT cmdGetJobStatus([in] long JobID, [out] short* pStatus);
00106         [helpstring("ﾒｿｯﾄﾞ cmdLetJobStatus")] HRESULT cmdLetJobStatus([in] long JobID, [in] short sStatus);
00107         [helpstring("ﾒｿｯﾄﾞ cmdRequestFileSave")] HRESULT cmdRequestFileSave([out] short *pTransMode, [out] long *pTaskID);
00108         [helpstring("ﾒｿｯﾄﾞ cmdGetTransMode")] HRESULT cmdGetTransMode([out] short *pTransMode);
00109         [helpstring("ﾒｿｯﾄﾞ cmdRequestRomUpdate")] HRESULT cmdRequestRomUpdate();
00110         [helpstring("ﾒｿｯﾄﾞ cmdNoticeRomVersion")] HRESULT cmdNoticeRomVersion([in] short sVer);
00111         [helpstring("ﾒｿｯﾄﾞ cmdDoSignal")] HRESULT cmdDoSignal([in] short sMode, [in] short sAction);
00112         [helpstring("ﾒｿｯﾄﾞ cmdSrvJointParam")] HRESULT cmdSrvJointParam([out] short *pJoint, [out] short *pInterval, [out] short *pCounts, [out] short *pData1, [out] short *pData2);
00113         [helpstring("ﾒｿｯﾄﾞ cmdSrvJointData")] HRESULT cmdSrvJointData([in] short sOffset, [in] short sCounts, [out] float **pData1, [out] float **pData2);
00114         [helpstring("ﾒｿｯﾄﾞ cmdSrvJointCancel")] HRESULT cmdSrvJointCancel();
00115         [helpstring("ﾒｿｯﾄﾞ cmdGetErrorCode")] HRESULT cmdGetErrorCode([out] long *pVal);
00116         [helpstring("ﾒｿｯﾄﾞ cmdClearError")] HRESULT cmdClearError([in] long lErrCode, [out] short *pVal);
00117         [helpstring("ﾒｿｯﾄﾞ cmdGetOperationLog")] HRESULT cmdGetOperationLog([in] short sIndex, [out] short *pCode, [out] CHAR *szDate, [out] CHAR *szTime, [out] CHAR *szModule, [out] CHAR *szMsg);
00118         [helpstring("ﾒｿｯﾄﾞ cmdGetErrorLog")] HRESULT cmdGetErrorLog([in] short sIndex, [out] short *pCode, [out] short *pLevel, [out] CHAR *szDate, [out] CHAR *szTime, [out] CHAR *szModule, [out] CHAR *szMsg);
00119         [helpstring("ﾒｿｯﾄﾞ cmdGetControlLog")] HRESULT cmdGetControlLog([in] short sIndex, [out] float pData[8][4], [out] float *pReg, [out] short *pProgNo, [out] short *pLineNo);
00120         [helpstring("ﾒｿｯﾄﾞ cmdSetOption")] HRESULT cmdSetOption([in] short sMode, [in] long lKey, [out] CHAR *pVal);
00121         [helpstring("ﾒｿｯﾄﾞ cmdChangeConfig")] HRESULT cmdChangeConfig([in] short sMode);
00122         [helpstring("ﾒｿｯﾄﾞ cmdLetConfig")] HRESULT cmdLetConfig([in] short sMode, [in] short sIndex, [in] long newVal);
00123         [helpstring("ﾒｿｯﾄﾞ cmdGetConfig")] HRESULT cmdGetConfig([in] short sMode, [in] short sIndex, [out] long *pVal);
00124         [helpstring("ﾒｿｯﾄﾞ cmdGetStatus")] HRESULT cmdGetStatus([in] short sModule, [in] short sIndex, [out] short *pVal);
00125
00126     };
00127
00128     // IRbtlkVariable
00129     [
00130         object,
00131         uuid(9C5AD78B-2D87-4bc0-95CC-A0CD897CEEF0),
00132         helpstring("IRbtlkVariable Interface"),
00133         pointer_default(unique)
00134     ]
00135     interface IRbtlkVariable : IUnknown
00136     {
00137         [helpstring("ﾒｿｯﾄﾞ cmdGetI")] HRESULT cmdGetI([in] short sIC, [in] short sIndex, [out] long *pVal);
00138         [helpstring("ﾒｿｯﾄﾞ cmdLetI")] HRESULT cmdLetI([in] short sIC, [in] short sIndex, [in] long newVal);
00139         [helpstring("ﾒｿｯﾄﾞ cmdGetF")] HRESULT cmdGetF([in] short sIC ,[in] short sIndex, [out] float *pVal);
00140         [helpstring("ﾒｿｯﾄﾞ cmdLetF")] HRESULT cmdLetF([in] short sIC ,[in] short sIndex, [in] float newVal);
00141         [helpstring("ﾒｿｯﾄﾞ cmdGetP")] HRESULT cmdGetP([in] short sIC, [in] short sIndex, [out] float *pVal);
00142         [helpstring("ﾒｿｯﾄﾞ cmdLetP")] HRESULT cmdLetP([in] short sIC, [in] short sIndex, [in] float *newVal);
00143         [helpstring("ﾒｿｯﾄﾞ cmdGetJ")] HRESULT cmdGetJ([in] short sIC, [in] short sIndex, [out] float *pVal);
00144         [helpstring("ﾒｿｯﾄﾞ cmdLetJ")] HRESULT cmdLetJ([in] short sIC, [in] short sIndex, [in] float *newVal);
00145         [helpstring("ﾒｿｯﾄﾞ cmdGetD")] HRESULT cmdGetD([in] short sIC, [in] short sIndex, [out] double *pVal);
00146         [helpstring("ﾒｿｯﾄﾞ cmdLetD")] HRESULT cmdLetD([in] short sIC, [in] short sIndex, [in] double newVal);
00147         [helpstring("ﾒｿｯﾄﾞ cmdGetS")] HRESULT cmdGetS([in] short sIC, [in] short sIndex, [out] CHAR *pVal);
00148         [helpstring("ﾒｿｯﾄﾞ cmdLetS")] HRESULT cmdLetS([in] short sIC, [in] short sIndex, [in] CHAR *newVal);
00149         [helpstring("ﾒｿｯﾄﾞ cmdGetV")] HRESULT cmdGetV([in] short sIC, [in] short sIndex, [out] float *pVal);
00150         [helpstring("ﾒｿｯﾄﾞ cmdLetV")] HRESULT cmdLetV([in] short sIC, [in] short sIndex, [in] float *newVal);
00151         [helpstring("ﾒｿｯﾄﾞ cmdGetT")] HRESULT cmdGetT([in] short sIC, [in] short sIndex, [out] float *pVal);
00152         [helpstring("ﾒｿｯﾄﾞ cmdLetT")] HRESULT cmdLetT([in] short sIC, [in] short sIndex, [in] float *newVal);
00153         [helpstring("ﾒｿｯﾄﾞ cmdGetTabLen")] HRESULT cmdGetTabLen([in] short sPrgIC, [in] short sTypeIC, [out] short *pVal);
00154         [helpstring("ﾒｿｯﾄﾞ cmdGetDefIO")] HRESULT cmdGetDefIO([in] short sPort, [in] short sType, [in] long lMask, [out] long *pVal);
00155         [helpstring("ﾒｿｯﾄﾞ cmdLetDefIO")] HRESULT cmdLetDefIO([in] short sPort, [in] short sType, [in] long lMask, [in] long lVal);
00156     };
00157
00158     // IRbtlkIO
00159     [
00160         object,
00161         uuid(B8937F48-2FB7-4807-8D2D-2200683801FA),
00162         helpstring("IRbtlkIO Interface"),
00163         pointer_default(unique)
00164     ]
00165     interface IRbtlkIO : IUnknown
00166     {
00167         [helpstring("ﾒｿｯﾄﾞ cmdDin")] HRESULT cmdDin([in] short sIndex, [out] BOOL *pVal);
00168         [helpstring("ﾒｿｯﾄﾞ cmdDout")] HRESULT cmdDout([in] short sIndex, [in] BOOL newVal);
00169         [helpstring("ﾒｿｯﾄﾞ cmdDummy")] HRESULT cmdDummy([in] short sIndex, [in] short newVal);
00170         [helpstring("ﾒｿｯﾄﾞ cmdDin8")] HRESULT cmdDin8([in] short sIndex, [out] short *pVal);
00171         [helpstring("ﾒｿｯﾄﾞ cmdDout8")] HRESULT cmdDout8([in] short sIndex, [in] short newVal);
00172         [helpstring("ﾒｿｯﾄﾞ cmdDin16")] HRESULT cmdDin16([in] short sIndex, [out] short *pVal);
00173         [helpstring("ﾒｿｯﾄﾞ cmdDout16")] HRESULT cmdDout16([in] short sIndex, [in] short newVal);
00174         [helpstring("ﾒｿｯﾄﾞ cmdChangeLabel")] HRESULT cmdChangeLabel([in] short sPlateNo, [in] short sButtonNo, [in] CHAR *newVal);
00175
00176     };
00177
00178     // IRbtlkArm
00179     [
00180         object,
00181         uuid(E59220A9-344B-4aa6-8E8B-4555A3A42DFF),
00182         helpstring("IRbtlkArm Interface"),
00183         pointer_default(unique)
00184     ]
00185     interface IRbtlkArm : IUnknown
00186     {
00187         // ========== GetStatus Items ==========
00188         typedef enum {
00189             RTK_AST_SERVO       = 16,       // サーボ (0:OFF, 1:ON)
00190             RTK_AST_MODE        = 17,       // モード (0:手動, 1:自動，2:TC)
00191             RTK_AST_CALEND      = 18        // CAL完了済み (0:NO, 1:YES)
00192         } RTK_ARM_STATUS;
00193
00194         [helpstring("ﾒｿｯﾄﾞ cmdHere")] HRESULT cmdHere([out] float *pVal);
00195         [helpstring("ﾒｿｯﾄﾞ cmdJHere")] HRESULT cmdJHere([out] float *pVal);
00196         [helpstring("ﾒｿｯﾄﾞ cmdGetTool")] HRESULT cmdGetTool([in] short sNo, [out] float *pf);
00197         [helpstring("ﾒｿｯﾄﾞ cmdLetTool")] HRESULT cmdLetTool([in] short sNo, [in] float *pf);
00198         [helpstring("ﾒｿｯﾄﾞ cmdGetWork")] HRESULT cmdGetWork([in] short sNo, [out] float *pf);
00199         [helpstring("ﾒｿｯﾄﾞ cmdLetWork")] HRESULT cmdLetWork([in] short sNo, [in] float *pf);
00200         [helpstring("ﾒｿｯﾄﾞ cmdGetArea")] HRESULT cmdGetArea([in] short sNo, [out] float *pf, [out] short *psIO, [out] short *psPos);
00201         [helpstring("ﾒｿｯﾄﾞ cmdLetArea")] HRESULT cmdLetArea([in] short sNo, [in] float *pf, [in] short sIO, [in] short sPos);
00202         [helpstring("ﾒｿｯﾄﾞ cmdGetAreaEx")] HRESULT cmdGetAreaEx([in] short sNo, [out] float *pf, [out] short *psIO, [out] short *psPos, [out] short *psErr, [out] short *psEnable);
00203         [helpstring("ﾒｿｯﾄﾞ cmdLetAreaEx")] HRESULT cmdLetAreaEx([in] short sNo, [in] float *pf, [in] short sIO, [in] short sPos, [in] short sErr, [in] short sEnable);
00204         [helpstring("ﾒｿｯﾄﾞ cmdGetToolIndex")] HRESULT cmdGetToolIndex([out] short *pVal);
00205         [helpstring("ﾒｿｯﾄﾞ cmdGetWorkIndex")] HRESULT cmdGetWorkIndex([out] short *pVal);
00206         [helpstring("ﾒｿｯﾄﾞ cmdThere")] HRESULT cmdThere([out] float *pVal);
00207         [helpstring("ﾒｿｯﾄﾞ cmdEnableArea")] HRESULT cmdEnableArea([in] short sNo);
00208         [helpstring("ﾒｿｯﾄﾞ cmdDisableArea")] HRESULT cmdDisableArea([in] short sNo);
00209
00210     };
00211     [
00212         object,
00213         uuid(2E97DAF4-77AC-4d04-B9B0-1C33991A78F0),
00214         helpstring("IRbtlkTask Interface"),
00215         pointer_default(unique)
00216     ]
00217     interface IRbtlkTask : IUnknown
00218     {
00219         // ========== PAC_CNF / ITP_CNF ==========
00220         // (注) RTK_ 以降はPacCnfマクロ名をそのまま使う．
00221         typedef enum {
00222             RTK_PC_LANG_MODE = 18,
00223             RTK_PC_ROBOTTYPE = 19
00224         } RTK_PAC_CONF;
00225
00226         typedef enum {
00227             RTK_IP_TASKNUM = 1,
00228             RTK_IP_RSTKSIZE = 2
00229         } RTK_ITP_CONF;
00230
00231         [helpstring("ﾒｿｯﾄﾞ cmdGetPrgListLen")] HRESULT cmdGetPrgListLen([out] short* newVal);
00232         [helpstring("ﾒｿｯﾄﾞ cmdGetPrgList")] HRESULT cmdGetPrgList([in] short sIndex, [out] short* newVal, [out] CHAR* szName);
00233         [helpstring("ﾒｿｯﾄﾞ cmdGetTaskStatus")] HRESULT cmdGetTaskStatus([in] short sPrgIC, [out] short* pStatus );
00234         [helpstring("ﾒｿｯﾄﾞ cmdContPrgStatus")] HRESULT cmdContPrgStatus([in] short sPrgIC, [out] short* pStatus, [out] short* pPriority, [out] short* pInterval, [out] short* pLineNo, [out] short* pIOBlock, [out] short* pMode, [out] long* pCT );
00235
00236     };
00237     [
00238         object,
00239         uuid(0CF06FBD-2D74-4b39-B299-EA20F6CA84AC),
00240         helpstring("IRbtlkFile Interface"),
00241         pointer_default(unique)
00242     ]
00243     interface IRbtlkFile : IUnknown
00244     {
00245
00246         [helpstring("ﾒｿｯﾄﾞ cmdFileUploadStart")] HRESULT cmdFileUploadStart();
00247         [helpstring("ﾒｿｯﾄﾞ cmdFileUploadEnd")] HRESULT cmdFileUploadEnd();
00248
00249         [helpstring("ﾒｿｯﾄﾞ cmdRequestUpload")] HRESULT cmdRequestUpload([in] short sBlocks, [in] long lSize, [in] short sFileProp, [in] short sFileFlag, [in] CHAR *szName, [out] short *psFileID);
00250         [helpstring("ﾒｿｯﾄﾞ cmdRequestDownload")] HRESULT cmdRequestDownload([in] short sFileFlag, [in] CHAR *szName, [out] short *psFileID, [out] short *psBlocks, [out] short* sFileProp, [out] long *plSize);
00251         [helpstring("ﾒｿｯﾄﾞ cmdUpload")] HRESULT cmdUpload([in] short sFileID, [in] short sBlockNo, [in] BSTR bstrData );
00252         [helpstring("ﾒｿｯﾄﾞ cmdDownload")] HRESULT cmdDownload([in] short sFileID, [out] short* psFileID, [out] short* psBlockNo, [out] BSTR* pbstrData);
00253         [helpstring("ﾒｿｯﾄﾞ cmdCancelUpload")] HRESULT cmdCancelUpload([in] short sFileID);
00254         [helpstring("ﾒｿｯﾄﾞ cmdCancelDownload")] HRESULT cmdCancelDownload([in] short sFileID);
00255         [helpstring("ﾒｿｯﾄﾞ cmdDeleteFile")] HRESULT cmdDeleteFile([in] CHAR *szName);
00256         [helpstring("ﾒｿｯﾄﾞ cmdGetFileCnt")] HRESULT cmdGetFileCnt([in] CHAR *szName, [out] short* psFiles);
00257         [helpstring("ﾒｿｯﾄﾞ cmdCopyFile")] HRESULT cmdCopyFile([in] CHAR *szFrom, [in] CHAR *szTo );
00258         [helpstring("ﾒｿｯﾄﾞ cmdMoveFile")] HRESULT cmdMoveFile([in] CHAR *szFrom, [in] CHAR *szTo );
00259         [helpstring("ﾒｿｯﾄﾞ cmdGetFileName")] HRESULT cmdGetFileName([in] short sIndex, [in] CHAR *szDirName, [out] CHAR *pVal);
00260         [helpstring("ﾒｿｯﾄﾞ cmdGetAttributes")] HRESULT cmdGetAttributes([in] short iSystem, [in] CHAR *szName, [out] long* pVal);
00261         [helpstring("ﾒｿｯﾄﾞ cmdGetDataCreated")] HRESULT cmdGetDataCreated([in] short iSystem, [in] CHAR *szName, [out] short* pDateTime);
00262         [helpstring("ﾒｿｯﾄﾞ cmdGetLastModified")] HRESULT cmdGetLastModified([in] short iSystem, [in] CHAR *szName, [out] short* pDateTime);
00263         [helpstring("ﾒｿｯﾄﾞ cmdGetLastAccessed")] HRESULT cmdGetLastAccessed([in] short iSystem, [in] CHAR *szName, [out] short* pDateTime);
00264         [helpstring("ﾒｿｯﾄﾞ cmdGetSize")] HRESULT cmdGetSize([in] short iSystem, [in] CHAR *szName, [out] long* pVal);
00265         [helpstring("ﾒｿｯﾄﾞ cmdStartPrg")] HRESULT cmdStartPrg([in] short iProgIC, [in] short iStartMode );
00266         [helpstring("ﾒｿｯﾄﾞ cmdStopPrg")] HRESULT cmdStopPrg([in] short iProgIC, [in] short iStopMode );
00267         [helpstring("ﾒｿｯﾄﾞ cmdGetProgramIC")] HRESULT cmdGetProgramIC([in] CHAR *szName, [out] short* pVal );
00268         [helpstring("ﾒｿｯﾄﾞ cmdStepForward")] HRESULT cmdStepForward([in] short iProgIC );
00269         [helpstring("ﾒｿｯﾄﾞ cmdStepBackward")] HRESULT cmdStepBackward([in] short iProgIC );
00270         [helpstring("ﾒｿｯﾄﾞ cmdLetStartLine")] HRESULT cmdLetStartLine([in] short iLineNo, [in] short iProgIC, [out] short* pVal );
00271         [helpstring("ﾒｿｯﾄﾞ cmdKillProg")] HRESULT cmdKillProg([in] short iActMode, [in] short iProgIC );
00272         [helpstring("ﾒｿｯﾄﾞ cmdLoadNic")] HRESULT cmdLoadNic([out] long *pID);
00273         [helpstring("ﾒｿｯﾄﾞ cmdRequestUpload0")] HRESULT cmdRequestUpload0([in] short sBlocks, [in] long lSize, [in] CHAR *szName, [in] CHAR *szAttribute, [in] CHAR *szUsage, [out] short *psFileID);
00274         [helpstring("ﾒｿｯﾄﾞ cmdRequestDownload0")] HRESULT cmdRequestDownload0([in] CHAR *szName, [out] short *psFileID, [out] short *psBlocks, [out] long *plSize, [out] CHAR *szAttribute, [out] CHAR *szUsage);
00275         [helpstring("ﾒｿｯﾄﾞ cmdUpload0")] HRESULT cmdUpload0([in] short sFileID, [in] short sBlockNo, [in] BSTR bstrData );
00276         [helpstring("ﾒｿｯﾄﾞ cmdDownload0")] HRESULT cmdDownload0([in] short sFileID, [out] short* psFileID, [out] short* psBlockNo, [out] BSTR* pbstrData);
00277         [helpstring("ﾒｿｯﾄﾞ cmdCancelUpload0")] HRESULT cmdCancelUpload0([in] short sFileID);
00278         [helpstring("ﾒｿｯﾄﾞ cmdCancelDownload0")] HRESULT cmdCancelDownload0([in] short sFileID);
00279         [helpstring("ﾒｿｯﾄﾞ cmdGetProgramIndex")] HRESULT cmdGetProgramIndex([in] CHAR *szName, [out] short* pVal );
00280         [helpstring("ﾒｿｯﾄﾞ cmdDeleteFile0")] HRESULT cmdDeleteFile0([in] CHAR *szName);
00281         [helpstring("ﾒｿｯﾄﾞ cmdGetFileCnt0")] HRESULT cmdGetFileCnt0([out] short* psFiles);
00282         [helpstring("ﾒｿｯﾄﾞ cmdGetFileName0")] HRESULT cmdGetFileName0([in] short sIndex, [out] CHAR* pVal);
00283
00284     };
00285 /* --------------------------- */
00286 /* ROBOTalk Object Definitions */
00287 /* --------------------------- */
00288 [
00289     uuid(90A12141-BF93-4D03-9D76-6E70A83FEC10),
00290     version(1.0),
00291     helpstring("ROBOTalk 1.0 ﾀｲﾌﾟ ﾗｲﾌﾞﾗﾘ")
00292 ]
00293 library ROBOTALKLib
00294 {
00295     importlib("stdole32.tlb");
00296     importlib("stdole2.tlb");
00297
00298     // RbtlkEngine
00299     [
00300         uuid(2567A726-828B-4D30-8E2E-E661F9921D99),
00301         helpstring("RbtlkEngine Class")
00302     ]
00303     coclass RbtlkEngine
00304     {
00305         [default] interface IRbtlkEngine;
00306     };
00307
00308     // RbtlkController
00309     [
00310         uuid(E218CEA4-EA72-4ab3-A5E5-6AE4B2835995),
00311         helpstring("RbtlkController Class")
00312     ]
00313     coclass RbtlkController
00314     {
00315         [default] interface IRbtlkController;
00316     };
00317
00318     // RbtlkVariable
00319     [
00320         uuid(8D476744-65EC-456e-A6C7-641D07520C13),
00321         helpstring("RbtlkVariable Class")
00322     ]
00323     coclass RbtlkVariable
00324     {
00325         [default] interface IRbtlkVariable;
00326     };
00327
00328     // RbtlkIO
00329     [
00330         uuid(BA8055B8-4ED2-4d3e-ADFD-8A8DB628EF39),
00331         helpstring("RbtlkIO Class")
00332     ]
00333     coclass RbtlkIO
00334     {
00335         [default] interface IRbtlkIO;
00336     };
00337
00338     // RbtlkArm
00339     [
00340         uuid(8403C89E-8C66-4d0b-BBB4-8A170A767F6F),
00341         helpstring("RbtlkArm Class")
00342     ]
00343     coclass RbtlkArm
00344     {
00345         [default] interface IRbtlkArm;
00346     };
00347
00348     // RbtlkTask
00349     [
00350         uuid(2A783DB8-5443-4950-B460-43FA8E7E0BF2),
00351         helpstring("RbtlkTask Class")
00352     ]
00353     coclass RbtlkTask
00354     {
00355         [default] interface IRbtlkTask;
00356     };
00357
00358     // RbtlkFile
00359     [
00360         uuid(448B9ED4-44D4-4a29-A30C-953CA7A2910B),
00361         helpstring("RbtlkFile Class")
00362     ]
00363     coclass RbtlkFile
00364     {
00365         [default] interface IRbtlkFile;
00366     };
00367 };
Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


Serial.h Source File

Serial.h

解説を見る。
00001
00011 #if !defined(AFX_SERIAL_H__DEDDC022_9FCD_43A7_A7DD_A620C7D69DCA__INCLUDED_)
00012 #define AFX_SERIAL_H__DEDDC022_9FCD_43A7_A7DD_A620C7D69DCA__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00018 #include "Device.h"
00019 #include <stdio.h>
00020
00021 #define SERIAL_PORT_MAX     256         // 対応通信ポートの最大値 "COM256"
00022 #define SERIAL_BASE_TIMEOUT 50          // 基準タイムアウト時間
00023
00030 class CSerial : public CDevice
00031 {
00032 // データメンバ
00033 private:
00034     DWORD m_dwPortNo;
00035
00036 protected:
00038     HANDLE m_hComHandle;
00040     DWORD m_dwReceiveRetry;
00041
00042 public:
00044 //  SerialParam m_Param;
00045
00046 // メソッド
00047 public:
00048 // コンストラクタ
00049     CSerial();
00050 // デストラクタ
00051     virtual ~CSerial();
00052
00053 // 接続
00054     virtual HRESULT Connect(CDevice** ppNewDevice = NULL);
00055 // 切断
00056     virtual HRESULT Disconnect(void);
00057 // バッファクリア
00058     virtual HRESULT Flush(void);
00059 // タイムアウト時間の更新
00060     virtual HRESULT SetTimeOut(DWORD dwTimeout);
00061 // 受信個数
00062     virtual DWORD GetReceivedCount(void);
00063
00064 // GetCommState
00065     HRESULT GetState(DCB* pDCB);
00066 // SetCommState
00067     HRESULT SetState(DCB* pDCB);
00068
00069 // 初期化処理
00070     virtual HRESULT Initialize(PVOID pArgs[]);
00071
00072 private:
00073 // 送信 (dwSendLen = 0 のとき NULL終端まで出力)
00074     virtual HRESULT SendData(LPCSTR lpszData, DWORD dwSendLen = 0);
00075 // 受信
00076     virtual HRESULT ReceiveData(LPSTR lpszData, DWORD dwBufSize, DWORD *pdwReceivedLen, int nTermCount = 1);
00077 };
00078
00079 #endif // !defined(AFX_SERIAL_H__DEDDC022_9FCD_43A7_A7DD_A620C7D69DCA__INCLUDED_)
Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


StdAfx.h Source File

StdAfx.h

解説を見る。
00001 // stdafx.h : 標準のシステム インクルード ファイル、
00002 //            または参照回数が多く、かつあまり変更されない
00003 //            プロジェクト専用のインクルード ファイルを記述します。
00004
00005 #if !defined(AFX_STDAFX_H__CC0FF5A6_2B7E_440F_90F4_45B40D643078__INCLUDED_)
00006 #define AFX_STDAFX_H__CC0FF5A6_2B7E_440F_90F4_45B40D643078__INCLUDED_
00007
00008 #if _MSC_VER > 1000
00009 #pragma once
00010 #endif // _MSC_VER > 1000
00011
00012 #define STRICT
00013 #ifndef _WIN32_WINNT
00014 #define _WIN32_WINNT 0x0400
00015 #endif
00016 #define _ATL_APARTMENT_THREADED
00017
00018 #include <atlbase.h>
00019 // CComModule クラスから派生したクラスを使用して、オーバーライドする場合
00020 // _Module の名前は変更しないでください。
00021 extern CComModule _Module;
00022
00023 #include <atlcom.h>
00024
00025 #include "RbtlkHeader.h"
00026 #include <map>
00027 extern std::map<BYTE, PVOID> g_mapID;
00028
00029
00031 struct EtherParam {
00033     DWORD dwIPAdr;
00035     DWORD dwPortNo;
00036 };
00037
00039 struct SerialParam {
00041     DWORD dwPortNo;
00046     DWORD dwBaudRate;
00051     DWORD dwParity;
00053     DWORD dwDataBits;
00058     DWORD dwStopBits;
00060     CComBSTR    bstrATCmd;
00061 };
00062
00063 //{{AFX_INSERT_LOCATION}}
00064 // Microsoft Visual C++ は前行の直前に追加の宣言を挿入します。
00065
00066 #endif // !defined(AFX_STDAFX_H__CC0FF5A6_2B7E_440F_90F4_45B40D643078__INCLUDED)
Generated on Wed Sep 29 10:57:34 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

__MIDL_IRbtlkEngine_0002 メンバ一覧

これは全メンバの一覧です。__MIDL_IRbtlkEngine_0002継承メンバも含んでいます。
bCDH | __MIDL_IRbtlkEngine_0002
bCDL | __MIDL_IRbtlkEngine_0002
bData | __MIDL_IRbtlkEngine_0002
bEnq | __MIDL_IRbtlkEngine_0002
bID1 | __MIDL_IRbtlkEngine_0002
bID2 | __MIDL_IRbtlkEngine_0002
bLength | __MIDL_IRbtlkEngine_0002
wCommand | __MIDL_IRbtlkEngine_0002
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_IID メンバ一覧

これは全メンバの一覧です。_IID継承メンバも含んでいます。
c | _IID
s1 | _IID
s2 | _IID
x | _IID
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_MIDL_PROC_FORMAT_STRING メンバ一覧

これは全メンバの一覧です。_MIDL_PROC_FORMAT_STRING継承メンバも含んでいます。
Format | _MIDL_PROC_FORMAT_STRING
Pad | _MIDL_PROC_FORMAT_STRING
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_MIDL_TYPE_FORMAT_STRING メンバ一覧

これは全メンバの一覧です。_MIDL_TYPE_FORMAT_STRING継承メンバも含んでいます。
Format | _MIDL_TYPE_FORMAT_STRING
Pad | _MIDL_TYPE_FORMAT_STRING
Generated on Wed Sep 29 10:57:43 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

EtherParam メンバ一覧

これは全メンバの一覧です。EtherParam継承メンバも含んでいます。
dwIPAdr | EtherParam
dwPortNo | EtherParam
Generated on Wed Sep 29 10:57:44 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

IRbtlkEngine::RTK_PACKET メンバ一覧

これは全メンバの一覧です。IRbtlkEngine::RTK_PACKET継承メンバも含んでいます。
bCDH | IRbtlkEngine::RTK_PACKET
bCDL | IRbtlkEngine::RTK_PACKET
bData | IRbtlkEngine::RTK_PACKET
bEnq | IRbtlkEngine::RTK_PACKET
bID1 | IRbtlkEngine::RTK_PACKET
bID2 | IRbtlkEngine::RTK_PACKET
bLength | IRbtlkEngine::RTK_PACKET
wCommand | IRbtlkEngine::RTK_PACKET
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

SerialParam メンバ一覧

これは全メンバの一覧です。SerialParam継承メンバも含んでいます。
bstrATCmd | SerialParam
dwBaudRate | SerialParam
dwDataBits | SerialParam
dwParity | SerialParam
dwPortNo | SerialParam
dwStopBits | SerialParam
Generated on Wed Sep 29 10:57:45 2004 for DENSO WAVE ROBOTalk Project by doxygen 1.2.18, © 1997-2001