メインページ

CRDMapper Project ドキュメント

1.0

Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


File Index

CRDMapper Project ファイル一覧

これはファイル一覧です。
_CCRDNodeTemplate.h [コード] | CCRDNode クラスのインターフェイス
CRD.h [コード] |
CRDCommand.cpp |
CRDCommand.h [コード] |
CRDController.cpp |
CRDController.h [コード] |
CRDEngine.cpp | CCRDEngine のインプリメンテーション
CRDEngine.h [コード] |
CRDExtension.cpp |
CRDExtension.h [コード] |
CRDFile.cpp |
CRDFile.h [コード] |
CRDMapper.cpp |
CRDMapper.h [コード] |
CRDMapper.idl [コード] |
CRDMapper_i.c |
CRDMapper_p.c |
CRDMessage.cpp |
CRDMessage.h [コード] |
CRDRobot.cpp |
CRDRobot.h [コード] |
CRDTask.cpp |
CRDTask.h [コード] |
CRDUtility.h [コード] |
CRDVariable.cpp |
CRDVariable.h [コード] |
dlldata.c |
resource.h [コード] |
StdAfx.cpp |
StdAfx.h [コード] |
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


_CCRDNodeTemplate.h File Reference

_CCRDNodeTemplate.h の解説

CCRDNode クラスのインターフェイス. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | _CCRDNodeTemplate
CRDMapperの共通クラス. [詳細]

マクロ定義

#define | AFX_CRDNODE_H__48D0C551_35F0_47C0_A616_5A199A2D49D0__INCLUDED_

解説

CCRDNode クラスのインターフェイス.

バージョン:
1.0
日付:
2003/10/19
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CRDNODE_H__48D0C551_35F0_47C0_A616_5A199A2D49D0__INCLUDED_

Generated on Thu Jan 27 18:50:00 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRD.h File Reference

CRD.h の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

マクロ定義

#define | MAX_BUFFER 1025
#define | XML_VARIDATION VARIANT_TRUE
#define | XML_LOAD_ASYNC VARIANT_FALSE
#define | TYPE_NODE_ELEMENT 1
#define | TYPE_NODE_ATTRIBUTE 2
#define | TYPE_NODE_TEXT 3
#define | XML_ELEM_PROCESS L"xml"
#define | XML_NODE_DATA L"version=\"1.0\" encoding=\"Shift_JIS\""
#define | CRD_ELEM_ROOT L"CRD"
#define | XSI_ATTR_NS L"xmlns:xsi"
#define | XML_SCHEMA_INSTANCE L"http://www.w3.org/2001/XMLSchema-instance"
#define | CRD_ATTR_LOCATION L"xsi:schemaLocation"
#define | CRD_SCHEMA_LOCATION L"http://www.orin.jp/CRD/CRDSchema"
#define | CRD_SCHEMA_FILE L"CRDSchema.xsd"
#define | XPATH_DOC_PROPERTY L"SelectionNamespaces"
#define | XPATH_CRD_NAMESPACE L"xmlns:crd='http://www.orin.jp/CRD/CRDSchema'"
#define | XPATH_NAMED_NODE L"crd:%ls[@name='%ls']"
#define | XPATH_NUMBER_NODE L"crd:%ls[@number='%li']"
#define | XPATH_PREFIX_NODE L"crd:%ls"
#define | CRD_ELEM_CONTROLLER L"Controller"
#define | CRD_ELEM_EXTENSION L"Extension"
#define | CRD_ELEM_FILE L"File"
#define | CRD_ELEM_ROBOT L"Robot"
#define | CRD_ELEM_TASK L"Task"
#define | CRD_ELEM_VARIABLE L"Variable"
#define | CRD_ELEM_COMMAND L"Command"
#define | CRD_ELEM_MESSAGE L"Message"
#define | CRD_ELEM_ATTRIBUTE L"Attribute"
#define | CRD_ELEM_HELP L"Help"
#define | CRD_ELEM_ID L"ID"
#define | CRD_ELEM_VERSION L"Version"
#define | CRD_ELEM_DATE_CREATED L"DateCreated"
#define | CRD_ELEM_DATE_LAST_ACCESSED L"DateLastAccessed"
#define | CRD_ELEM_DATE_LAST_MODIFIED L"DateLastModified"
#define | CRD_ELEM_PATH L"Path"
#define | CRD_ELEM_SIZE L"Size"
#define | CRD_ELEM_TYPE L"Type"
#define | CRD_ELEM_ACCEL L"Acceleration"
#define | CRD_ELEM_DECEL L"Deceleration"
#define | CRD_ELEM_JSPEED L"JointSpeed"
#define | CRD_ELEM_SPEED L"Speed"
#define | CRD_ELEM_FILENAME L"FileName"
#define | CRD_ELEM_DATETIME L"DateTime"
#define | CRD_ELEM_MICROSECOND L"Microsecond"
#define | CRD_ELEM_STATE L"State"
#define | CRD_ELEM_TIMEOUT L"Timeout"
#define | CRD_ELEM_PARAMETERS L"Parameters"
#define | CRD_ELEM_DESCRIPTION L"Description"
#define | CRD_ELEM_DESTINATIOM L"Destination"
#define | CRD_ELEM_SOURCE L"Source"
#define | CRD_ELEM_VALUE L"Value"
#define | CRD_ATTR_NAME L"name"
#define | CRD_ATTR_NUMBER L"number"
#define | CRD_ELEM_VALUE L"Value"
#define | CRD_ATTR_TYPE L"type"
#define | CRD_ELEM_DIMENSION L"dimension"
#define | CRD_ELEM_ARRAYBOUND L"arrayBound"
#define | CRD_ELEM_LBOUND L"lBound"
#define | CRD_ELEM_ELEMENTS L"elements"
#define | CRD_ELEM_ARRAYDATA L"arrayData"
#define | CRD_ELEM_BOOL L"boolVal"
#define | CRD_ELEM_I1 L"cVal"
#define | CRD_ELEM_UI1 L"bVal"
#define | CRD_ELEM_I2 L"iVal"
#define | CRD_ELEM_UI2 L"uiVal"
#define | CRD_ELEM_I4 L"lVal"
#define | CRD_ELEM_UI4 L"ulVal"
#define | CRD_ELEM_R4 L"fltVal"
#define | CRD_ELEM_R8 L"dblVal"
#define | CRD_ELEM_DATE L"date"
#define | CRD_ELEM_BSTR L"bstrVal"
#define | CRD_ELEM_VARIANT L"varVal"
#define | CRD_ELEM_ARRAY L"array"
#define | CRD_TYPE_BOOL L"VT_BOOL"
#define | CRD_TYPE_I1 L"VT_I1"
#define | CRD_TYPE_UI1 L"VT_UI1"
#define | CRD_TYPE_I2 L"VT_I2"
#define | CRD_TYPE_UI2 L"VT_UI2"
#define | CRD_TYPE_I4 L"VT_I4"
#define | CRD_TYPE_UI4 L"VT_UI4"
#define | CRD_TYPE_R4 L"VT_R4"
#define | CRD_TYPE_R8 L"VT_R8"
#define | CRD_TYPE_DATE L"VT_DATE"
#define | CRD_TYPE_BSTR L"VT_BSTR"
#define | CRD_TYPE_VARIANT L"VT_VARIANT"
#define | CRD_TYPE_ARRAY L"VT_ARRAY"

マクロ定義の解説

#define CRD_ATTR_LOCATION L"xsi:schemaLocation"

#define CRD_ATTR_NAME L"name"

#define CRD_ATTR_NUMBER L"number"

#define CRD_ATTR_TYPE L"type"

#define CRD_ELEM_ACCEL L"Acceleration"

#define CRD_ELEM_ARRAY L"array"

#define CRD_ELEM_ARRAYBOUND L"arrayBound"

#define CRD_ELEM_ARRAYDATA L"arrayData"

#define CRD_ELEM_ATTRIBUTE L"Attribute"

#define CRD_ELEM_BOOL L"boolVal"

#define CRD_ELEM_BSTR L"bstrVal"

#define CRD_ELEM_COMMAND L"Command"

#define CRD_ELEM_CONTROLLER L"Controller"

#define CRD_ELEM_DATE L"date"

#define CRD_ELEM_DATE_CREATED L"DateCreated"

#define CRD_ELEM_DATE_LAST_ACCESSED L"DateLastAccessed"

#define CRD_ELEM_DATE_LAST_MODIFIED L"DateLastModified"

#define CRD_ELEM_DATETIME L"DateTime"

#define CRD_ELEM_DECEL L"Deceleration"

#define CRD_ELEM_DESCRIPTION L"Description"

#define CRD_ELEM_DESTINATIOM L"Destination"

#define CRD_ELEM_DIMENSION L"dimension"

#define CRD_ELEM_ELEMENTS L"elements"

#define CRD_ELEM_EXTENSION L"Extension"

#define CRD_ELEM_FILE L"File"

#define CRD_ELEM_FILENAME L"FileName"

#define CRD_ELEM_HELP L"Help"

#define CRD_ELEM_I1 L"cVal"

#define CRD_ELEM_I2 L"iVal"

#define CRD_ELEM_I4 L"lVal"

#define CRD_ELEM_ID L"ID"

#define CRD_ELEM_JSPEED L"JointSpeed"

#define CRD_ELEM_LBOUND L"lBound"

#define CRD_ELEM_MESSAGE L"Message"

#define CRD_ELEM_MICROSECOND L"Microsecond"

#define CRD_ELEM_PARAMETERS L"Parameters"

#define CRD_ELEM_PATH L"Path"

#define CRD_ELEM_R4 L"fltVal"

#define CRD_ELEM_R8 L"dblVal"

#define CRD_ELEM_ROBOT L"Robot"

#define CRD_ELEM_ROOT L"CRD"

#define CRD_ELEM_SIZE L"Size"

#define CRD_ELEM_SOURCE L"Source"

#define CRD_ELEM_SPEED L"Speed"

#define CRD_ELEM_STATE L"State"

#define CRD_ELEM_TASK L"Task"

#define CRD_ELEM_TIMEOUT L"Timeout"

#define CRD_ELEM_TYPE L"Type"

#define CRD_ELEM_UI1 L"bVal"

#define CRD_ELEM_UI2 L"uiVal"

#define CRD_ELEM_UI4 L"ulVal"

#define CRD_ELEM_VALUE L"Value"

#define CRD_ELEM_VALUE L"Value"

#define CRD_ELEM_VARIABLE L"Variable"

#define CRD_ELEM_VARIANT L"varVal"

#define CRD_ELEM_VERSION L"Version"

#define CRD_SCHEMA_FILE L"CRDSchema.xsd"

#define CRD_SCHEMA_LOCATION L"http://www.orin.jp/CRD/CRDSchema"

#define CRD_TYPE_ARRAY L"VT_ARRAY"

#define CRD_TYPE_BOOL L"VT_BOOL"

#define CRD_TYPE_BSTR L"VT_BSTR"

#define CRD_TYPE_DATE L"VT_DATE"

#define CRD_TYPE_I1 L"VT_I1"

#define CRD_TYPE_I2 L"VT_I2"

#define CRD_TYPE_I4 L"VT_I4"

#define CRD_TYPE_R4 L"VT_R4"

#define CRD_TYPE_R8 L"VT_R8"

#define CRD_TYPE_UI1 L"VT_UI1"

#define CRD_TYPE_UI2 L"VT_UI2"

#define CRD_TYPE_UI4 L"VT_UI4"

#define CRD_TYPE_VARIANT L"VT_VARIANT"

#define MAX_BUFFER 1025

#define TYPE_NODE_ATTRIBUTE 2

#define TYPE_NODE_ELEMENT 1

#define TYPE_NODE_TEXT 3

#define XML_ELEM_PROCESS L"xml"

#define XML_LOAD_ASYNC VARIANT_FALSE

#define XML_NODE_DATA L"version=\"1.0\" encoding=\"Shift_JIS\""

#define XML_SCHEMA_INSTANCE L"http://www.w3.org/2001/XMLSchema-instance"

#define XML_VARIDATION VARIANT_TRUE

#define XPATH_CRD_NAMESPACE L"xmlns:crd='http://www.orin.jp/CRD/CRDSchema'"

#define XPATH_DOC_PROPERTY L"SelectionNamespaces"

#define XPATH_NAMED_NODE L"crd:%ls[@name='%ls']"

#define XPATH_NUMBER_NODE L"crd:%ls[@number='%li']"

#define XPATH_PREFIX_NODE L"crd:%ls"

#define XSI_ATTR_NS L"xmlns:xsi"

Generated on Thu Jan 27 18:50:00 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDCommand.cpp File Reference

CRDCommand.cpp の解説

#include "stdafx.h"
#include "CRDMapper.h"
#include "CRDCommand.h"

CRDCommand.cppのインクルード依存関係図

Include dependency graph
Generated on Thu Jan 27 18:50:00 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDCommand.h File Reference

CRDCommand.h の解説

#include "resource.h"
#include "_CCRDNodeTemplate.h"

CRDCommand.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCRDCommand
CRDMapperのCommandクラス. [詳細]

Generated on Thu Jan 27 18:50:00 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDController.cpp File Reference

CRDController.cpp の解説

#include "stdafx.h"
#include "CRDMapper.h"
#include "CRDController.h"

CRDController.cppのインクルード依存関係図

Include dependency graph
Generated on Thu Jan 27 18:50:00 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDController.h File Reference

CRDController.h の解説

#include "resource.h"
#include "_CCRDNodeTemplate.h"
#include "CRDExtension.h"
#include "CRDFile.h"
#include "CRDRobot.h"
#include "CRDTask.h"
#include "CRDVariable.h"
#include "CRDCommand.h"
#include "CRDMessage.h"

CRDController.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCRDController
CRDMapperのControllerクラス. [詳細]

Generated on Thu Jan 27 18:50:01 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDEngine.cpp File Reference

CRDEngine.cpp の解説

CCRDEngine のインプリメンテーション. [詳細]

#include "stdafx.h"
#include "CRDMapper.h"
#include "CRDEngine.h"

CRDEngine.cppのインクルード依存関係図

Include dependency graph

解説

CCRDEngine のインプリメンテーション.

バージョン:
1.0
日付:
2003/10/19
作者:
DENSO WAVE
Generated on Thu Jan 27 18:50:01 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDEngine.h File Reference

CRDEngine.h の解説

#include "resource.h"
#include "CRDController.h"

CRDEngine.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCRDEngine
CRDMapperのEngineクラス. [詳細]

Generated on Thu Jan 27 18:50:01 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDExtension.cpp File Reference

CRDExtension.cpp の解説

#include "stdafx.h"
#include "CRDMapper.h"
#include "CRDExtension.h"

CRDExtension.cppのインクルード依存関係図

Include dependency graph
Generated on Thu Jan 27 18:50:02 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDExtension.h File Reference

CRDExtension.h の解説

#include "resource.h"
#include "_CCRDNodeTemplate.h"
#include "CRDVariable.h"

CRDExtension.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCRDExtension
CRDMapperのExtensionクラス. [詳細]

Generated on Thu Jan 27 18:50:02 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDFile.cpp File Reference

CRDFile.cpp の解説

#include "stdafx.h"
#include "CRDMapper.h"
#include "CRDFile.h"

CRDFile.cppのインクルード依存関係図

Include dependency graph
Generated on Thu Jan 27 18:50:02 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDFile.h File Reference

CRDFile.h の解説

#include "resource.h"
#include "_CCRDNodeTemplate.h"
#include "CRDFile.h"
#include "CRDVariable.h"

CRDFile.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCRDFile
CRDMapperのFileクラス. [詳細]

Generated on Thu Jan 27 18:50:02 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMapper.cpp File Reference

CRDMapper.cpp の解説

#include "stdafx.h"
#include "resource.h"
#include <initguid.h>
#include "CRDMapper.h"
#include "CRDMapper_i.c"
#include "CRDEngine.h"
#include "CRDController.h"
#include "CRDExtension.h"
#include "CRDFile.h"
#include "CRDRobot.h"
#include "CRDTask.h"
#include "CRDVariable.h"

CRDMapper.cppのインクルード依存関係図

Include dependency graph

関数

BOOL WINAPI | DllMain (HINSTANCE hInstance, DWORD dwReason, LPVOID)
STDAPI | DllCanUnloadNow (void)
STDAPI | DllGetClassObject (REFCLSID rclsid, REFIID riid, LPVOID *ppv)
STDAPI | DllRegisterServer (void)
STDAPI | DllUnregisterServer (void)

変数

CComModule | _Module

関数の解説

STDAPI DllCanUnloadNow ( void )

STDAPI DllGetClassObject | ( | REFCLSID | rclsid,
 |  | REFIID | riid,
 |  | LPVOID * | ppv
 | ) |

BOOL WINAPI DllMain | ( | HINSTANCE | hInstance,
 |  | DWORD | dwReason,
 |  | LPVOID |
 | ) |

STDAPI DllRegisterServer ( void )

STDAPI DllUnregisterServer ( void )

変数の解説

CComModule _Module

Generated on Thu Jan 27 18:50:03 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMapper.h File Reference

CRDMapper.h の解説

#include "rpc.h"
#include "rpcndr.h"
#include "windows.h"
#include "ole2.h"
#include "oaidl.h"
#include "ocidl.h"

CRDMapper.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

マクロ定義

#define | __REQUIRED_RPCNDR_H_VERSION__ 440

Typedef

typedef interface ICRDEngine | ICRDEngine
typedef interface ICRDController | ICRDController
typedef interface ICRDExtension | ICRDExtension
typedef interface ICRDFile | ICRDFile
typedef interface ICRDRobot | ICRDRobot
typedef interface ICRDTask | ICRDTask
typedef interface ICRDVariable | ICRDVariable
typedef interface ICRDCommand | ICRDCommand
typedef interface ICRDMessage | ICRDMessage
typedef CRDEngine | CRDEngine
typedef CRDController | CRDController
typedef CRDExtension | CRDExtension
typedef CRDFile | CRDFile
typedef CRDRobot | CRDRobot
typedef CRDTask | CRDTask
typedef CRDVariable | CRDVariable
typedef CRDCommand | CRDCommand
typedef CRDMessage | CRDMessage

関数

void __RPC_FAR *__RPC_USER | MIDL_user_allocate (size_t)
void __RPC_USER | MIDL_user_free (void __RPC_FAR *)
virtual HRESULT STDMETHODCALLTYPE | load (BSTR bstrFileName)=0
virtual HRESULT STDMETHODCALLTYPE | save (void)=0
virtual HRESULT STDMETHODCALLTYPE | saveAs (BSTR bstrFileName=L"")=0
virtual HRESULT STDMETHODCALLTYPE | createController (BSTR bstrName, ICRDController __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | removeController (BSTR bstrName)=0
virtual HRESULT STDMETHODCALLTYPE | appendController (ICRDController __RPC_FAR *newCtrl)=0
virtual HRESULT STDMETHODCALLTYPE | get_ControllerNames (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Controller (BSTR bstrName, ICRDController __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Help (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Help (BSTR newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Version (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Version (BSTR newVal)=0
HRESULT STDMETHODCALLTYPE | ICRDEngine_CreateDocument_Proxy (ICRDEngine __RPC_FAR *This)
void __RPC_STUB | ICRDEngine_CreateDocument_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDEngine_load_Proxy (ICRDEngine __RPC_FAR *This, BSTR bstrFileName)
void __RPC_STUB | ICRDEngine_load_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDEngine_save_Proxy (ICRDEngine __RPC_FAR *This)
void __RPC_STUB | ICRDEngine_save_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDEngine_saveAs_Proxy (ICRDEngine __RPC_FAR *This, BSTR bstrFileName)
void __RPC_STUB | ICRDEngine_saveAs_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDEngine_createController_Proxy (ICRDEngine __RPC_FAR *This, BSTR bstrName, ICRDController __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDEngine_createController_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDEngine_removeController_Proxy (ICRDEngine __RPC_FAR *This, BSTR bstrName)
void __RPC_STUB | ICRDEngine_removeController_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDEngine_appendController_Proxy (ICRDEngine __RPC_FAR *This, ICRDController __RPC_FAR *newCtrl)
void __RPC_STUB | ICRDEngine_appendController_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDEngine_get_ControllerNames_Proxy (ICRDEngine __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDEngine_get_ControllerNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDEngine_get_Controller_Proxy (ICRDEngine __RPC_FAR *This, BSTR bstrName, ICRDController __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDEngine_get_Controller_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDEngine_get_Help_Proxy (ICRDEngine __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDEngine_get_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDEngine_put_Help_Proxy (ICRDEngine __RPC_FAR *This, BSTR newVal)
void __RPC_STUB | ICRDEngine_put_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDEngine_get_Version_Proxy (ICRDEngine __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDEngine_get_Version_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDEngine_put_Version_Proxy (ICRDEngine __RPC_FAR *This, BSTR newVal)
void __RPC_STUB | ICRDEngine_put_Version_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | get_Attribute (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Attribute (long newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_ID (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_ID (VARIANT newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_XMLNode (IUnknown __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | createExtension (BSTR bstrName, ICRDExtension __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | removeExtension (BSTR bstrName)=0
virtual HRESULT STDMETHODCALLTYPE | appendExtension (ICRDExtension __RPC_FAR *newExt)=0
virtual HRESULT STDMETHODCALLTYPE | get_ExtensionNames (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Extension (BSTR bstrName, ICRDExtension __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | createFile (BSTR bstrName, ICRDFile __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | removeFile (BSTR bstrName)=0
virtual HRESULT STDMETHODCALLTYPE | appendFile (ICRDFile __RPC_FAR *newFile)=0
virtual HRESULT STDMETHODCALLTYPE | get_FileNames (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_File (BSTR bstrName, ICRDFile __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | createRobot (BSTR bstrName, ICRDRobot __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | removeRobot (BSTR bstrName)=0
virtual HRESULT STDMETHODCALLTYPE | appendRobot (ICRDRobot __RPC_FAR *newRobot)=0
virtual HRESULT STDMETHODCALLTYPE | get_RobotNames (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Robot (BSTR bstrName, ICRDRobot __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | createTask (BSTR bstrName, ICRDTask __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | removeTask (BSTR bstrName)=0
virtual HRESULT STDMETHODCALLTYPE | appendTask (ICRDTask __RPC_FAR *newTask)=0
virtual HRESULT STDMETHODCALLTYPE | get_TaskNames (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Task (BSTR bstrName, ICRDTask __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | createVariable (BSTR bstrName, ICRDVariable __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | removeVariable (BSTR bstrName)=0
virtual HRESULT STDMETHODCALLTYPE | appendVariable (ICRDVariable __RPC_FAR *newVar)=0
virtual HRESULT STDMETHODCALLTYPE | get_VariableNames (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Variable (BSTR bstrName, ICRDVariable __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | createCommand (BSTR bstrName, ICRDCommand __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | removeCommand (BSTR bstrName)=0
virtual HRESULT STDMETHODCALLTYPE | appendCommand (ICRDCommand __RPC_FAR *newCmd)=0
virtual HRESULT STDMETHODCALLTYPE | get_CommandNames (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Command (BSTR bstrName, ICRDCommand __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | createMessage (long lNumber, ICRDMessage __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | removeMessage (long lNumber)=0
virtual HRESULT STDMETHODCALLTYPE | appendMessage (ICRDMessage __RPC_FAR *newMsg)=0
virtual HRESULT STDMETHODCALLTYPE | get_MessageNumbers (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Message (long lNumber, ICRDMessage __RPC_FAR *__RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | clone (BSTR bstrDestName, ICRDController __RPC_FAR *__RPC_FAR *pVal)=0
HRESULT STDMETHODCALLTYPE | ICRDController_get_Name_Proxy (ICRDController __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_Attribute_Proxy (ICRDController __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_put_Attribute_Proxy (ICRDController __RPC_FAR *This, long newVal)
void __RPC_STUB | ICRDController_put_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_Help_Proxy (ICRDController __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_put_Help_Proxy (ICRDController __RPC_FAR *This, BSTR newVal)
void __RPC_STUB | ICRDController_put_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_ID_Proxy (ICRDController __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_put_ID_Proxy (ICRDController __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDController_put_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_XMLNode_Proxy (ICRDController __RPC_FAR *This, IUnknown __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_XMLNode_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_createExtension_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName, ICRDExtension __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDController_createExtension_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_removeExtension_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName)
void __RPC_STUB | ICRDController_removeExtension_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_appendExtension_Proxy (ICRDController __RPC_FAR *This, ICRDExtension __RPC_FAR *newExt)
void __RPC_STUB | ICRDController_appendExtension_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_ExtensionNames_Proxy (ICRDController __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_ExtensionNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_Extension_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName, ICRDExtension __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_Extension_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_createFile_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName, ICRDFile __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDController_createFile_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_removeFile_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName)
void __RPC_STUB | ICRDController_removeFile_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_appendFile_Proxy (ICRDController __RPC_FAR *This, ICRDFile __RPC_FAR *newFile)
void __RPC_STUB | ICRDController_appendFile_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_FileNames_Proxy (ICRDController __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_FileNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_File_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName, ICRDFile __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_File_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_createRobot_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName, ICRDRobot __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDController_createRobot_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_removeRobot_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName)
void __RPC_STUB | ICRDController_removeRobot_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_appendRobot_Proxy (ICRDController __RPC_FAR *This, ICRDRobot __RPC_FAR *newRobot)
void __RPC_STUB | ICRDController_appendRobot_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_RobotNames_Proxy (ICRDController __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_RobotNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_Robot_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName, ICRDRobot __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_Robot_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_createTask_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName, ICRDTask __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDController_createTask_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_removeTask_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName)
void __RPC_STUB | ICRDController_removeTask_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_appendTask_Proxy (ICRDController __RPC_FAR *This, ICRDTask __RPC_FAR *newTask)
void __RPC_STUB | ICRDController_appendTask_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_TaskNames_Proxy (ICRDController __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_TaskNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_Task_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName, ICRDTask __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_Task_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_createVariable_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName, ICRDVariable __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDController_createVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_removeVariable_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName)
void __RPC_STUB | ICRDController_removeVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_appendVariable_Proxy (ICRDController __RPC_FAR *This, ICRDVariable __RPC_FAR *newVar)
void __RPC_STUB | ICRDController_appendVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_VariableNames_Proxy (ICRDController __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_VariableNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_Variable_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName, ICRDVariable __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_Variable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_createCommand_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName, ICRDCommand __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDController_createCommand_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_removeCommand_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName)
void __RPC_STUB | ICRDController_removeCommand_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_appendCommand_Proxy (ICRDController __RPC_FAR *This, ICRDCommand __RPC_FAR *newCmd)
void __RPC_STUB | ICRDController_appendCommand_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_CommandNames_Proxy (ICRDController __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_CommandNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_Command_Proxy (ICRDController __RPC_FAR *This, BSTR bstrName, ICRDCommand __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_Command_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_createMessage_Proxy (ICRDController __RPC_FAR *This, long lNumber, ICRDMessage __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDController_createMessage_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_removeMessage_Proxy (ICRDController __RPC_FAR *This, long lNumber)
void __RPC_STUB | ICRDController_removeMessage_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_appendMessage_Proxy (ICRDController __RPC_FAR *This, ICRDMessage __RPC_FAR *newMsg)
void __RPC_STUB | ICRDController_appendMessage_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_MessageNumbers_Proxy (ICRDController __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_MessageNumbers_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_get_Message_Proxy (ICRDController __RPC_FAR *This, long lNumber, ICRDMessage __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDController_get_Message_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDController_clone_Proxy (ICRDController __RPC_FAR *This, BSTR bstrDestName, ICRDController __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDController_clone_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | clone (BSTR bstrDestName, ICRDExtension __RPC_FAR *__RPC_FAR *pVal)=0
HRESULT STDMETHODCALLTYPE | ICRDExtension_get_Name_Proxy (ICRDExtension __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDExtension_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDExtension_get_Attribute_Proxy (ICRDExtension __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICRDExtension_get_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDExtension_put_Attribute_Proxy (ICRDExtension __RPC_FAR *This, long newVal)
void __RPC_STUB | ICRDExtension_put_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDExtension_get_Help_Proxy (ICRDExtension __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDExtension_get_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDExtension_put_Help_Proxy (ICRDExtension __RPC_FAR *This, BSTR newVal)
void __RPC_STUB | ICRDExtension_put_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDExtension_get_ID_Proxy (ICRDExtension __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDExtension_get_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDExtension_put_ID_Proxy (ICRDExtension __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDExtension_put_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDExtension_get_XMLNode_Proxy (ICRDExtension __RPC_FAR *This, IUnknown __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDExtension_get_XMLNode_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDExtension_createVariable_Proxy (ICRDExtension __RPC_FAR *This, BSTR bstrName, ICRDVariable __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDExtension_createVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDExtension_removeVariable_Proxy (ICRDExtension __RPC_FAR *This, BSTR bstrName)
void __RPC_STUB | ICRDExtension_removeVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDExtension_appendVariable_Proxy (ICRDExtension __RPC_FAR *This, ICRDVariable __RPC_FAR *newVar)
void __RPC_STUB | ICRDExtension_appendVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDExtension_get_VariableNames_Proxy (ICRDExtension __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDExtension_get_VariableNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDExtension_get_Variable_Proxy (ICRDExtension __RPC_FAR *This, BSTR bstrName, ICRDVariable __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDExtension_get_Variable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDExtension_clone_Proxy (ICRDExtension __RPC_FAR *This, BSTR bstrDestName, ICRDExtension __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDExtension_clone_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | get_DateCreated (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_DateCreated (VARIANT newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_DateLastAccessed (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_DateLastAccessed (VARIANT newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_DateLastModified (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_DateLastModified (VARIANT newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Path (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Path (BSTR newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Size (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Size (long newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Type (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Type (BSTR newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Value (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Value (VARIANT newVal)=0
virtual HRESULT STDMETHODCALLTYPE | clone (BSTR bstrDestName, ICRDFile __RPC_FAR *__RPC_FAR *pVal)=0
HRESULT STDMETHODCALLTYPE | ICRDFile_get_Name_Proxy (ICRDFile __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_get_Attribute_Proxy (ICRDFile __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_get_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_put_Attribute_Proxy (ICRDFile __RPC_FAR *This, long newVal)
void __RPC_STUB | ICRDFile_put_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_get_Help_Proxy (ICRDFile __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_get_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_put_Help_Proxy (ICRDFile __RPC_FAR *This, BSTR newVal)
void __RPC_STUB | ICRDFile_put_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_get_DateCreated_Proxy (ICRDFile __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_get_DateCreated_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_put_DateCreated_Proxy (ICRDFile __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDFile_put_DateCreated_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_get_DateLastAccessed_Proxy (ICRDFile __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_get_DateLastAccessed_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_put_DateLastAccessed_Proxy (ICRDFile __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDFile_put_DateLastAccessed_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_get_DateLastModified_Proxy (ICRDFile __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_get_DateLastModified_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_put_DateLastModified_Proxy (ICRDFile __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDFile_put_DateLastModified_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_get_Path_Proxy (ICRDFile __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_get_Path_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_put_Path_Proxy (ICRDFile __RPC_FAR *This, BSTR newVal)
void __RPC_STUB | ICRDFile_put_Path_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_get_Size_Proxy (ICRDFile __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_get_Size_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_put_Size_Proxy (ICRDFile __RPC_FAR *This, long newVal)
void __RPC_STUB | ICRDFile_put_Size_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_get_Type_Proxy (ICRDFile __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_get_Type_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_put_Type_Proxy (ICRDFile __RPC_FAR *This, BSTR newVal)
void __RPC_STUB | ICRDFile_put_Type_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_get_Value_Proxy (ICRDFile __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_get_Value_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_put_Value_Proxy (ICRDFile __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDFile_put_Value_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_get_ID_Proxy (ICRDFile __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_get_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_put_ID_Proxy (ICRDFile __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDFile_put_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_get_XMLNode_Proxy (ICRDFile __RPC_FAR *This, IUnknown __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_get_XMLNode_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_createFile_Proxy (ICRDFile __RPC_FAR *This, BSTR bstrName, ICRDFile __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_createFile_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_removeFile_Proxy (ICRDFile __RPC_FAR *This, BSTR bstrName)
void __RPC_STUB | ICRDFile_removeFile_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_appendFile_Proxy (ICRDFile __RPC_FAR *This, ICRDFile __RPC_FAR *newFile)
void __RPC_STUB | ICRDFile_appendFile_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_get_FileNames_Proxy (ICRDFile __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_get_FileNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_get_File_Proxy (ICRDFile __RPC_FAR *This, BSTR bstrName, ICRDFile __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_get_File_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_createVariable_Proxy (ICRDFile __RPC_FAR *This, BSTR bstrName, ICRDVariable __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_createVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_removeVariable_Proxy (ICRDFile __RPC_FAR *This, BSTR bstrName)
void __RPC_STUB | ICRDFile_removeVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_appendVariable_Proxy (ICRDFile __RPC_FAR *This, ICRDVariable __RPC_FAR *newVar)
void __RPC_STUB | ICRDFile_appendVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_get_VariableNames_Proxy (ICRDFile __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_get_VariableNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_get_Variable_Proxy (ICRDFile __RPC_FAR *This, BSTR bstrName, ICRDVariable __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_get_Variable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDFile_clone_Proxy (ICRDFile __RPC_FAR *This, BSTR bstrDestName, ICRDFile __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDFile_clone_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | clone (BSTR bstrDestName, ICRDRobot __RPC_FAR *__RPC_FAR *pVal)=0
HRESULT STDMETHODCALLTYPE | ICRDRobot_get_Name_Proxy (ICRDRobot __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDRobot_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDRobot_get_Attribute_Proxy (ICRDRobot __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICRDRobot_get_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDRobot_put_Attribute_Proxy (ICRDRobot __RPC_FAR *This, long newVal)
void __RPC_STUB | ICRDRobot_put_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDRobot_get_Help_Proxy (ICRDRobot __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDRobot_get_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDRobot_put_Help_Proxy (ICRDRobot __RPC_FAR *This, BSTR newVal)
void __RPC_STUB | ICRDRobot_put_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDRobot_get_ID_Proxy (ICRDRobot __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDRobot_get_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDRobot_put_ID_Proxy (ICRDRobot __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDRobot_put_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDRobot_get_XMLNode_Proxy (ICRDRobot __RPC_FAR *This, IUnknown __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDRobot_get_XMLNode_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDRobot_createVariable_Proxy (ICRDRobot __RPC_FAR *This, BSTR bstrName, ICRDVariable __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDRobot_createVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDRobot_removeVariable_Proxy (ICRDRobot __RPC_FAR *This, BSTR bstrName)
void __RPC_STUB | ICRDRobot_removeVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDRobot_appendVariable_Proxy (ICRDRobot __RPC_FAR *This, ICRDVariable __RPC_FAR *newVar)
void __RPC_STUB | ICRDRobot_appendVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDRobot_get_VariableNames_Proxy (ICRDRobot __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDRobot_get_VariableNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDRobot_get_Variable_Proxy (ICRDRobot __RPC_FAR *This, BSTR bstrName, ICRDVariable __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDRobot_get_Variable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDRobot_clone_Proxy (ICRDRobot __RPC_FAR *This, BSTR bstrDestName, ICRDRobot __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDRobot_clone_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | get_FileName (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_FileName (BSTR newVal)=0
virtual HRESULT STDMETHODCALLTYPE | clone (BSTR bstrDestName, ICRDTask __RPC_FAR *__RPC_FAR *pVal)=0
HRESULT STDMETHODCALLTYPE | ICRDTask_get_Name_Proxy (ICRDTask __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDTask_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDTask_get_Attribute_Proxy (ICRDTask __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICRDTask_get_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDTask_put_Attribute_Proxy (ICRDTask __RPC_FAR *This, long newVal)
void __RPC_STUB | ICRDTask_put_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDTask_get_Help_Proxy (ICRDTask __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDTask_get_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDTask_put_Help_Proxy (ICRDTask __RPC_FAR *This, BSTR newVal)
void __RPC_STUB | ICRDTask_put_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDTask_get_FileName_Proxy (ICRDTask __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDTask_get_FileName_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDTask_put_FileName_Proxy (ICRDTask __RPC_FAR *This, BSTR newVal)
void __RPC_STUB | ICRDTask_put_FileName_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDTask_get_ID_Proxy (ICRDTask __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDTask_get_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDTask_put_ID_Proxy (ICRDTask __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDTask_put_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDTask_get_XMLNode_Proxy (ICRDTask __RPC_FAR *This, IUnknown __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDTask_get_XMLNode_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDTask_createVariable_Proxy (ICRDTask __RPC_FAR *This, BSTR bstrName, ICRDVariable __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDTask_createVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDTask_removeVariable_Proxy (ICRDTask __RPC_FAR *This, BSTR bstrName)
void __RPC_STUB | ICRDTask_removeVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDTask_appendVariable_Proxy (ICRDTask __RPC_FAR *This, ICRDVariable __RPC_FAR *newVar)
void __RPC_STUB | ICRDTask_appendVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDTask_get_VariableNames_Proxy (ICRDTask __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDTask_get_VariableNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDTask_get_Variable_Proxy (ICRDTask __RPC_FAR *This, BSTR bstrName, ICRDVariable __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDTask_get_Variable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDTask_clone_Proxy (ICRDTask __RPC_FAR *This, BSTR bstrDestName, ICRDTask __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDTask_clone_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | get_DateTime (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_DateTime (VARIANT newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Microsecond (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Microsecond (long newVal)=0
virtual HRESULT STDMETHODCALLTYPE | clone (BSTR bstrDestName, ICRDVariable __RPC_FAR *__RPC_FAR *pVal)=0
HRESULT STDMETHODCALLTYPE | ICRDVariable_get_Name_Proxy (ICRDVariable __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDVariable_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDVariable_get_Attribute_Proxy (ICRDVariable __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICRDVariable_get_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDVariable_put_Attribute_Proxy (ICRDVariable __RPC_FAR *This, long newVal)
void __RPC_STUB | ICRDVariable_put_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDVariable_get_Help_Proxy (ICRDVariable __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDVariable_get_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDVariable_put_Help_Proxy (ICRDVariable __RPC_FAR *This, BSTR newVal)
void __RPC_STUB | ICRDVariable_put_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDVariable_get_DateTime_Proxy (ICRDVariable __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDVariable_get_DateTime_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDVariable_put_DateTime_Proxy (ICRDVariable __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDVariable_put_DateTime_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDVariable_get_Value_Proxy (ICRDVariable __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDVariable_get_Value_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDVariable_put_Value_Proxy (ICRDVariable __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDVariable_put_Value_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDVariable_get_ID_Proxy (ICRDVariable __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDVariable_get_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDVariable_put_ID_Proxy (ICRDVariable __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDVariable_put_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDVariable_get_Microsecond_Proxy (ICRDVariable __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICRDVariable_get_Microsecond_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDVariable_put_Microsecond_Proxy (ICRDVariable __RPC_FAR *This, long newVal)
void __RPC_STUB | ICRDVariable_put_Microsecond_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDVariable_get_XMLNode_Proxy (ICRDVariable __RPC_FAR *This, IUnknown __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDVariable_get_XMLNode_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDVariable_clone_Proxy (ICRDVariable __RPC_FAR *This, BSTR bstrDestName, ICRDVariable __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDVariable_clone_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | get_State (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_State (long newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Timeout (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Timeout (long newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Parameters (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Parameters (VARIANT newVal)=0
virtual HRESULT STDMETHODCALLTYPE | clone (BSTR bstrDestName, ICRDCommand __RPC_FAR *__RPC_FAR *pVal)=0
HRESULT STDMETHODCALLTYPE | ICRDCommand_get_Name_Proxy (ICRDCommand __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDCommand_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDCommand_get_Attribute_Proxy (ICRDCommand __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICRDCommand_get_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDCommand_put_Attribute_Proxy (ICRDCommand __RPC_FAR *This, long newVal)
void __RPC_STUB | ICRDCommand_put_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDCommand_get_Help_Proxy (ICRDCommand __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDCommand_get_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDCommand_put_Help_Proxy (ICRDCommand __RPC_FAR *This, BSTR newVal)
void __RPC_STUB | ICRDCommand_put_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDCommand_get_State_Proxy (ICRDCommand __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICRDCommand_get_State_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDCommand_put_State_Proxy (ICRDCommand __RPC_FAR *This, long newVal)
void __RPC_STUB | ICRDCommand_put_State_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDCommand_get_Timeout_Proxy (ICRDCommand __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICRDCommand_get_Timeout_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDCommand_put_Timeout_Proxy (ICRDCommand __RPC_FAR *This, long newVal)
void __RPC_STUB | ICRDCommand_put_Timeout_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDCommand_get_Parameters_Proxy (ICRDCommand __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDCommand_get_Parameters_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDCommand_put_Parameters_Proxy (ICRDCommand __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDCommand_put_Parameters_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDCommand_get_ID_Proxy (ICRDCommand __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDCommand_get_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDCommand_put_ID_Proxy (ICRDCommand __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDCommand_put_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDCommand_get_XMLNode_Proxy (ICRDCommand __RPC_FAR *This, IUnknown __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDCommand_get_XMLNode_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDCommand_clone_Proxy (ICRDCommand __RPC_FAR *This, BSTR bstrDestName, ICRDCommand __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDCommand_clone_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | get_Description (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Description (BSTR newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Destination (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Destination (BSTR newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Source (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Source (BSTR newVal)=0
virtual HRESULT STDMETHODCALLTYPE | clone (long lNumber, ICRDMessage __RPC_FAR *__RPC_FAR *pVal)=0
HRESULT STDMETHODCALLTYPE | ICRDMessage_get_Number_Proxy (ICRDMessage __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICRDMessage_get_Number_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDMessage_get_DateTime_Proxy (ICRDMessage __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDMessage_get_DateTime_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDMessage_put_DateTime_Proxy (ICRDMessage __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDMessage_put_DateTime_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDMessage_get_Description_Proxy (ICRDMessage __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDMessage_get_Description_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDMessage_put_Description_Proxy (ICRDMessage __RPC_FAR *This, BSTR newVal)
void __RPC_STUB | ICRDMessage_put_Description_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDMessage_get_Destination_Proxy (ICRDMessage __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDMessage_get_Destination_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDMessage_put_Destination_Proxy (ICRDMessage __RPC_FAR *This, BSTR newVal)
void __RPC_STUB | ICRDMessage_put_Destination_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDMessage_get_Source_Proxy (ICRDMessage __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICRDMessage_get_Source_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDMessage_put_Source_Proxy (ICRDMessage __RPC_FAR *This, BSTR newVal)
void __RPC_STUB | ICRDMessage_put_Source_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDMessage_get_Value_Proxy (ICRDMessage __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDMessage_get_Value_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDMessage_put_Value_Proxy (ICRDMessage __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDMessage_put_Value_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDMessage_get_ID_Proxy (ICRDMessage __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICRDMessage_get_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDMessage_put_ID_Proxy (ICRDMessage __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICRDMessage_put_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDMessage_get_XMLNode_Proxy (ICRDMessage __RPC_FAR *This, IUnknown __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDMessage_get_XMLNode_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICRDMessage_clone_Proxy (ICRDMessage __RPC_FAR *This, long lNumber, ICRDMessage __RPC_FAR *__RPC_FAR *pVal)
void __RPC_STUB | ICRDMessage_clone_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
class | DECLSPEC_UUID ("1A075796-21FA-4CE6-9CDB-B1683C4B0442") CRDEngine
class | DECLSPEC_UUID ("2D971601-9F26-4F70-AF6C-A6CE07683CB9") CRDController
class | DECLSPEC_UUID ("E8DE945C-B604-4567-9DD5-D6B6D52A18CC") CRDExtension
class | DECLSPEC_UUID ("523F3578-4ACE-4447-9D40-EC9BBC38AE0F") CRDFile
class | DECLSPEC_UUID ("2B010177-FD27-436B-BEFF-A3A302BEFCA8") CRDRobot
class | DECLSPEC_UUID ("952CCDAB-6AA8-4007-8225-9C9B704C8C90") CRDTask
class | DECLSPEC_UUID ("C39D19C0-3458-4623-9A55-02E5BEB27CD3") CRDVariable
class | DECLSPEC_UUID ("853BCF88-9A3C-4604-B95C-AB48AF47A33C") CRDCommand
class | DECLSPEC_UUID ("A8D27938-26D1-4af3-9599-23CF97285A7C") CRDMessage
unsigned long __RPC_USER | BSTR_UserSize (unsigned long __RPC_FAR *, unsigned long, BSTR __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | BSTR_UserMarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | BSTR_UserUnmarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR *)
void __RPC_USER | BSTR_UserFree (unsigned long __RPC_FAR *, BSTR __RPC_FAR *)
unsigned long __RPC_USER | VARIANT_UserSize (unsigned long __RPC_FAR *, unsigned long, VARIANT __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | VARIANT_UserMarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, VARIANT __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | VARIANT_UserUnmarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, VARIANT __RPC_FAR *)
void __RPC_USER | VARIANT_UserFree (unsigned long __RPC_FAR *, VARIANT __RPC_FAR *)

変数

RPC_IF_HANDLE | __MIDL_itf_CRDMapper_0000_v0_0_c_ifspec
RPC_IF_HANDLE | __MIDL_itf_CRDMapper_0000_v0_0_s_ifspec
EXTERN_C const IID | IID_ICRDEngine
ICRDEngine __pad0__
EXTERN_C const IID | IID_ICRDController
ICRDController __pad1__
EXTERN_C const IID | IID_ICRDExtension
ICRDExtension __pad2__
EXTERN_C const IID | IID_ICRDFile
ICRDFile __pad3__
EXTERN_C const IID | IID_ICRDRobot
ICRDRobot __pad4__
EXTERN_C const IID | IID_ICRDTask
ICRDTask __pad5__
EXTERN_C const IID | IID_ICRDVariable
ICRDVariable __pad6__
EXTERN_C const IID | IID_ICRDCommand
ICRDCommand __pad7__
EXTERN_C const IID | IID_ICRDMessage
ICRDMessage __pad8__
EXTERN_C const IID | LIBID_CRDMAPPERLib
EXTERN_C const CLSID | CLSID_CRDEngine
EXTERN_C const CLSID | CLSID_CRDController
EXTERN_C const CLSID | CLSID_CRDExtension
EXTERN_C const CLSID | CLSID_CRDFile
EXTERN_C const CLSID | CLSID_CRDRobot
EXTERN_C const CLSID | CLSID_CRDTask
EXTERN_C const CLSID | CLSID_CRDVariable
EXTERN_C const CLSID | CLSID_CRDCommand
EXTERN_C const CLSID | CLSID_CRDMessage

マクロ定義の解説

#define __REQUIRED_RPCNDR_H_VERSION__ 440

Typedef の解説

typedef class CRDCommand CRDCommand

typedef class CRDController CRDController

typedef class CRDEngine CRDEngine

typedef class CRDExtension CRDExtension

typedef class CRDFile CRDFile

typedef class CRDMessage CRDMessage

typedef class CRDRobot CRDRobot

typedef class CRDTask CRDTask

typedef class CRDVariable CRDVariable

typedef interface ICRDCommand ICRDCommand

typedef interface ICRDController ICRDController

typedef interface ICRDEngine ICRDEngine

typedef interface ICRDExtension ICRDExtension

typedef interface ICRDFile ICRDFile

typedef interface ICRDMessage ICRDMessage

typedef interface ICRDRobot ICRDRobot

typedef interface ICRDTask ICRDTask

typedef interface ICRDVariable ICRDVariable

関数の解説

virtual HRESULT STDMETHODCALLTYPE appendCommand ( ICRDCommand __RPC_FAR * newCmd ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE appendController ( ICRDController __RPC_FAR * newCtrl ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE appendExtension ( ICRDExtension __RPC_FAR * newExt ) [pure virtual]

HRESULT STDMETHODCALLTYPE appendFile ( ICRDFile __RPC_FAR * newFile ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE appendMessage ( ICRDMessage __RPC_FAR * newMsg ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE appendRobot ( ICRDRobot __RPC_FAR * newRobot ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE appendTask ( ICRDTask __RPC_FAR * newTask ) [pure virtual]

HRESULT STDMETHODCALLTYPE appendVariable ( ICRDVariable __RPC_FAR * newVar ) [pure virtual]

void __RPC_USER BSTR_UserFree | ( | unsigned long __RPC_FAR * | ,
 |  | BSTR __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER BSTR_UserMarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | BSTR __RPC_FAR * |
 | ) |

unsigned long __RPC_USER BSTR_UserSize | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned | long,
 |  | BSTR __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER BSTR_UserUnmarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | BSTR __RPC_FAR * |
 | ) |

virtual HRESULT STDMETHODCALLTYPE clone | ( | long | lNumber,
 |  | ICRDMessage __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE clone | ( | BSTR | bstrDestName,
 |  | ICRDCommand __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE clone | ( | BSTR | bstrDestName,
 |  | ICRDVariable __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE clone | ( | BSTR | bstrDestName,
 |  | ICRDTask __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE clone | ( | BSTR | bstrDestName,
 |  | ICRDRobot __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE clone | ( | BSTR | bstrDestName,
 |  | ICRDFile __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE clone | ( | BSTR | bstrDestName,
 |  | ICRDExtension __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE clone | ( | BSTR | bstrDestName,
 |  | ICRDController __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE createCommand | ( | BSTR | bstrName,
 |  | ICRDCommand __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE createController | ( | BSTR | bstrName,
 |  | ICRDController __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE createExtension | ( | BSTR | bstrName,
 |  | ICRDExtension __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

HRESULT STDMETHODCALLTYPE createFile | ( | BSTR | bstrName,
 |  | ICRDFile __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE createMessage | ( | long | lNumber,
 |  | ICRDMessage __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE createRobot | ( | BSTR | bstrName,
 |  | ICRDRobot __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE createTask | ( | BSTR | bstrName,
 |  | ICRDTask __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

HRESULT STDMETHODCALLTYPE createVariable | ( | BSTR | bstrName,
 |  | ICRDVariable __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

class DECLSPEC_UUID ( "A8D27938-26D1-4af3-9599-23CF97285A7C" )

class DECLSPEC_UUID ( "853BCF88-9A3C-4604-B95C-AB48AF47A33C" )

class DECLSPEC_UUID ( "C39D19C0-3458-4623-9A55-02E5BEB27CD3" )

class DECLSPEC_UUID ( "952CCDAB-6AA8-4007-8225-9C9B704C8C90" )

class DECLSPEC_UUID ( "2B010177-FD27-436B-BEFF-A3A302BEFCA8" )

class DECLSPEC_UUID ( "523F3578-4ACE-4447-9D40-EC9BBC38AE0F" )

class DECLSPEC_UUID ( "E8DE945C-B604-4567-9DD5-D6B6D52A18CC" )

class DECLSPEC_UUID ( "2D971601-9F26-4F70-AF6C-A6CE07683CB9" )

class DECLSPEC_UUID ( "1A075796-21FA-4CE6-9CDB-B1683C4B0442" )

HRESULT STDMETHODCALLTYPE get_Attribute ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Command | ( | BSTR | bstrName,
 |  | ICRDCommand __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_CommandNames ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Controller | ( | BSTR | bstrName,
 |  | ICRDController __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_ControllerNames ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_DateCreated ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_DateLastAccessed ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_DateLastModified ( VARIANT __RPC_FAR * pVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_DateTime ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Description ( BSTR __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Destination ( BSTR __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Extension | ( | BSTR | bstrName,
 |  | ICRDExtension __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_ExtensionNames ( VARIANT __RPC_FAR * pVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_File | ( | BSTR | bstrName,
 |  | ICRDFile __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_FileName ( BSTR __RPC_FAR * pVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_FileNames ( VARIANT __RPC_FAR * pVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_Help ( BSTR __RPC_FAR * pVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_ID ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Message | ( | long | lNumber,
 |  | ICRDMessage __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_MessageNumbers ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Microsecond ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Parameters ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Path ( BSTR __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Robot | ( | BSTR | bstrName,
 |  | ICRDRobot __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_RobotNames ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Size ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Source ( BSTR __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_State ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Task | ( | BSTR | bstrName,
 |  | ICRDTask __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_TaskNames ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Timeout ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Type ( BSTR __RPC_FAR * pVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_Value ( VARIANT __RPC_FAR * pVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_Variable | ( | BSTR | bstrName,
 |  | ICRDVariable __RPC_FAR *__RPC_FAR * | pVal
 | ) | [pure virtual]

HRESULT STDMETHODCALLTYPE get_VariableNames ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Version ( BSTR __RPC_FAR * pVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_XMLNode ( IUnknown __RPC_FAR *__RPC_FAR * pVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE ICRDCommand_clone_Proxy | ( | ICRDCommand __RPC_FAR * | This,
 |  | BSTR | bstrDestName,
 |  | ICRDCommand __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDCommand_clone_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDCommand_get_Attribute_Proxy | ( | ICRDCommand __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDCommand_get_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDCommand_get_Help_Proxy | ( | ICRDCommand __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDCommand_get_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDCommand_get_ID_Proxy | ( | ICRDCommand __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDCommand_get_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDCommand_get_Name_Proxy | ( | ICRDCommand __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDCommand_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDCommand_get_Parameters_Proxy | ( | ICRDCommand __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDCommand_get_Parameters_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDCommand_get_State_Proxy | ( | ICRDCommand __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDCommand_get_State_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDCommand_get_Timeout_Proxy | ( | ICRDCommand __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDCommand_get_Timeout_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDCommand_get_XMLNode_Proxy | ( | ICRDCommand __RPC_FAR * | This,
 |  | IUnknown __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDCommand_get_XMLNode_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDCommand_put_Attribute_Proxy | ( | ICRDCommand __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICRDCommand_put_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDCommand_put_Help_Proxy | ( | ICRDCommand __RPC_FAR * | This,
 |  | BSTR | newVal
 | ) |

void __RPC_STUB ICRDCommand_put_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDCommand_put_ID_Proxy | ( | ICRDCommand __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDCommand_put_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDCommand_put_Parameters_Proxy | ( | ICRDCommand __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDCommand_put_Parameters_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDCommand_put_State_Proxy | ( | ICRDCommand __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICRDCommand_put_State_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDCommand_put_Timeout_Proxy | ( | ICRDCommand __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICRDCommand_put_Timeout_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_appendCommand_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | ICRDCommand __RPC_FAR * | newCmd
 | ) |

void __RPC_STUB ICRDController_appendCommand_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_appendExtension_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | ICRDExtension __RPC_FAR * | newExt
 | ) |

void __RPC_STUB ICRDController_appendExtension_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_appendFile_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | ICRDFile __RPC_FAR * | newFile
 | ) |

void __RPC_STUB ICRDController_appendFile_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_appendMessage_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | ICRDMessage __RPC_FAR * | newMsg
 | ) |

void __RPC_STUB ICRDController_appendMessage_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_appendRobot_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | ICRDRobot __RPC_FAR * | newRobot
 | ) |

void __RPC_STUB ICRDController_appendRobot_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_appendTask_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | ICRDTask __RPC_FAR * | newTask
 | ) |

void __RPC_STUB ICRDController_appendTask_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_appendVariable_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | ICRDVariable __RPC_FAR * | newVar
 | ) |

void __RPC_STUB ICRDController_appendVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_clone_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrDestName,
 |  | ICRDController __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_clone_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_createCommand_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDCommand __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_createCommand_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_createExtension_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDExtension __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_createExtension_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_createFile_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDFile __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_createFile_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_createMessage_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | long | lNumber,
 |  | ICRDMessage __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_createMessage_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_createRobot_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDRobot __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_createRobot_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_createTask_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDTask __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_createTask_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_createVariable_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDVariable __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_createVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_Attribute_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_Command_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDCommand __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_Command_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_CommandNames_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_CommandNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_Extension_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDExtension __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_Extension_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_ExtensionNames_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_ExtensionNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_File_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDFile __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_File_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_FileNames_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_FileNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_Help_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_ID_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_Message_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | long | lNumber,
 |  | ICRDMessage __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_Message_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_MessageNumbers_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_MessageNumbers_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_Name_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_Robot_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDRobot __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_Robot_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_RobotNames_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_RobotNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_Task_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDTask __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_Task_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_TaskNames_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_TaskNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_Variable_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDVariable __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_Variable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_VariableNames_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_VariableNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_get_XMLNode_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | IUnknown __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDController_get_XMLNode_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_put_Attribute_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICRDController_put_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_put_Help_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | newVal
 | ) |

void __RPC_STUB ICRDController_put_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_put_ID_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDController_put_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_removeCommand_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName
 | ) |

void __RPC_STUB ICRDController_removeCommand_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_removeExtension_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName
 | ) |

void __RPC_STUB ICRDController_removeExtension_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_removeFile_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName
 | ) |

void __RPC_STUB ICRDController_removeFile_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_removeMessage_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | long | lNumber
 | ) |

void __RPC_STUB ICRDController_removeMessage_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_removeRobot_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName
 | ) |

void __RPC_STUB ICRDController_removeRobot_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_removeTask_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName
 | ) |

void __RPC_STUB ICRDController_removeTask_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDController_removeVariable_Proxy | ( | ICRDController __RPC_FAR * | This,
 |  | BSTR | bstrName
 | ) |

void __RPC_STUB ICRDController_removeVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDEngine_appendController_Proxy | ( | ICRDEngine __RPC_FAR * | This,
 |  | ICRDController __RPC_FAR * | newCtrl
 | ) |

void __RPC_STUB ICRDEngine_appendController_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDEngine_createController_Proxy | ( | ICRDEngine __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDController __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDEngine_createController_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDEngine_CreateDocument_Proxy ( ICRDEngine __RPC_FAR * This )

void __RPC_STUB ICRDEngine_CreateDocument_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDEngine_get_Controller_Proxy | ( | ICRDEngine __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDController __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDEngine_get_Controller_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDEngine_get_ControllerNames_Proxy | ( | ICRDEngine __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDEngine_get_ControllerNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDEngine_get_Help_Proxy | ( | ICRDEngine __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDEngine_get_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDEngine_get_Version_Proxy | ( | ICRDEngine __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDEngine_get_Version_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDEngine_load_Proxy | ( | ICRDEngine __RPC_FAR * | This,
 |  | BSTR | bstrFileName
 | ) |

void __RPC_STUB ICRDEngine_load_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDEngine_put_Help_Proxy | ( | ICRDEngine __RPC_FAR * | This,
 |  | BSTR | newVal
 | ) |

void __RPC_STUB ICRDEngine_put_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDEngine_put_Version_Proxy | ( | ICRDEngine __RPC_FAR * | This,
 |  | BSTR | newVal
 | ) |

void __RPC_STUB ICRDEngine_put_Version_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDEngine_removeController_Proxy | ( | ICRDEngine __RPC_FAR * | This,
 |  | BSTR | bstrName
 | ) |

void __RPC_STUB ICRDEngine_removeController_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDEngine_save_Proxy ( ICRDEngine __RPC_FAR * This )

void __RPC_STUB ICRDEngine_save_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDEngine_saveAs_Proxy | ( | ICRDEngine __RPC_FAR * | This,
 |  | BSTR | bstrFileName
 | ) |

void __RPC_STUB ICRDEngine_saveAs_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDExtension_appendVariable_Proxy | ( | ICRDExtension __RPC_FAR * | This,
 |  | ICRDVariable __RPC_FAR * | newVar
 | ) |

void __RPC_STUB ICRDExtension_appendVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDExtension_clone_Proxy | ( | ICRDExtension __RPC_FAR * | This,
 |  | BSTR | bstrDestName,
 |  | ICRDExtension __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDExtension_clone_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDExtension_createVariable_Proxy | ( | ICRDExtension __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDVariable __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDExtension_createVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDExtension_get_Attribute_Proxy | ( | ICRDExtension __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDExtension_get_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDExtension_get_Help_Proxy | ( | ICRDExtension __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDExtension_get_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDExtension_get_ID_Proxy | ( | ICRDExtension __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDExtension_get_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDExtension_get_Name_Proxy | ( | ICRDExtension __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDExtension_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDExtension_get_Variable_Proxy | ( | ICRDExtension __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDVariable __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDExtension_get_Variable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDExtension_get_VariableNames_Proxy | ( | ICRDExtension __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDExtension_get_VariableNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDExtension_get_XMLNode_Proxy | ( | ICRDExtension __RPC_FAR * | This,
 |  | IUnknown __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDExtension_get_XMLNode_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDExtension_put_Attribute_Proxy | ( | ICRDExtension __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICRDExtension_put_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDExtension_put_Help_Proxy | ( | ICRDExtension __RPC_FAR * | This,
 |  | BSTR | newVal
 | ) |

void __RPC_STUB ICRDExtension_put_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDExtension_put_ID_Proxy | ( | ICRDExtension __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDExtension_put_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDExtension_removeVariable_Proxy | ( | ICRDExtension __RPC_FAR * | This,
 |  | BSTR | bstrName
 | ) |

void __RPC_STUB ICRDExtension_removeVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_appendFile_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | ICRDFile __RPC_FAR * | newFile
 | ) |

void __RPC_STUB ICRDFile_appendFile_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_appendVariable_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | ICRDVariable __RPC_FAR * | newVar
 | ) |

void __RPC_STUB ICRDFile_appendVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_clone_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | BSTR | bstrDestName,
 |  | ICRDFile __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_clone_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_createFile_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDFile __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_createFile_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_createVariable_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDVariable __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_createVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_get_Attribute_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_get_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_get_DateCreated_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_get_DateCreated_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_get_DateLastAccessed_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_get_DateLastAccessed_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_get_DateLastModified_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_get_DateLastModified_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_get_File_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDFile __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_get_File_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_get_FileNames_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_get_FileNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_get_Help_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_get_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_get_ID_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_get_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_get_Name_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_get_Path_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_get_Path_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_get_Size_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_get_Size_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_get_Type_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_get_Type_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_get_Value_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_get_Value_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_get_Variable_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDVariable __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_get_Variable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_get_VariableNames_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_get_VariableNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_get_XMLNode_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | IUnknown __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDFile_get_XMLNode_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_put_Attribute_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICRDFile_put_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_put_DateCreated_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDFile_put_DateCreated_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_put_DateLastAccessed_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDFile_put_DateLastAccessed_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_put_DateLastModified_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDFile_put_DateLastModified_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_put_Help_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | BSTR | newVal
 | ) |

void __RPC_STUB ICRDFile_put_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_put_ID_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDFile_put_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_put_Path_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | BSTR | newVal
 | ) |

void __RPC_STUB ICRDFile_put_Path_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_put_Size_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICRDFile_put_Size_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_put_Type_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | BSTR | newVal
 | ) |

void __RPC_STUB ICRDFile_put_Type_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_put_Value_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDFile_put_Value_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_removeFile_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | BSTR | bstrName
 | ) |

void __RPC_STUB ICRDFile_removeFile_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDFile_removeVariable_Proxy | ( | ICRDFile __RPC_FAR * | This,
 |  | BSTR | bstrName
 | ) |

void __RPC_STUB ICRDFile_removeVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDMessage_clone_Proxy | ( | ICRDMessage __RPC_FAR * | This,
 |  | long | lNumber,
 |  | ICRDMessage __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDMessage_clone_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDMessage_get_DateTime_Proxy | ( | ICRDMessage __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDMessage_get_DateTime_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDMessage_get_Description_Proxy | ( | ICRDMessage __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDMessage_get_Description_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDMessage_get_Destination_Proxy | ( | ICRDMessage __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDMessage_get_Destination_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDMessage_get_ID_Proxy | ( | ICRDMessage __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDMessage_get_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDMessage_get_Number_Proxy | ( | ICRDMessage __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDMessage_get_Number_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDMessage_get_Source_Proxy | ( | ICRDMessage __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDMessage_get_Source_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDMessage_get_Value_Proxy | ( | ICRDMessage __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDMessage_get_Value_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDMessage_get_XMLNode_Proxy | ( | ICRDMessage __RPC_FAR * | This,
 |  | IUnknown __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDMessage_get_XMLNode_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDMessage_put_DateTime_Proxy | ( | ICRDMessage __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDMessage_put_DateTime_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDMessage_put_Description_Proxy | ( | ICRDMessage __RPC_FAR * | This,
 |  | BSTR | newVal
 | ) |

void __RPC_STUB ICRDMessage_put_Description_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDMessage_put_Destination_Proxy | ( | ICRDMessage __RPC_FAR * | This,
 |  | BSTR | newVal
 | ) |

void __RPC_STUB ICRDMessage_put_Destination_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDMessage_put_ID_Proxy | ( | ICRDMessage __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDMessage_put_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDMessage_put_Source_Proxy | ( | ICRDMessage __RPC_FAR * | This,
 |  | BSTR | newVal
 | ) |

void __RPC_STUB ICRDMessage_put_Source_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDMessage_put_Value_Proxy | ( | ICRDMessage __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDMessage_put_Value_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDRobot_appendVariable_Proxy | ( | ICRDRobot __RPC_FAR * | This,
 |  | ICRDVariable __RPC_FAR * | newVar
 | ) |

void __RPC_STUB ICRDRobot_appendVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDRobot_clone_Proxy | ( | ICRDRobot __RPC_FAR * | This,
 |  | BSTR | bstrDestName,
 |  | ICRDRobot __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDRobot_clone_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDRobot_createVariable_Proxy | ( | ICRDRobot __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDVariable __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDRobot_createVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDRobot_get_Attribute_Proxy | ( | ICRDRobot __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDRobot_get_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDRobot_get_Help_Proxy | ( | ICRDRobot __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDRobot_get_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDRobot_get_ID_Proxy | ( | ICRDRobot __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDRobot_get_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDRobot_get_Name_Proxy | ( | ICRDRobot __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDRobot_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDRobot_get_Variable_Proxy | ( | ICRDRobot __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDVariable __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDRobot_get_Variable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDRobot_get_VariableNames_Proxy | ( | ICRDRobot __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDRobot_get_VariableNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDRobot_get_XMLNode_Proxy | ( | ICRDRobot __RPC_FAR * | This,
 |  | IUnknown __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDRobot_get_XMLNode_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDRobot_put_Attribute_Proxy | ( | ICRDRobot __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICRDRobot_put_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDRobot_put_Help_Proxy | ( | ICRDRobot __RPC_FAR * | This,
 |  | BSTR | newVal
 | ) |

void __RPC_STUB ICRDRobot_put_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDRobot_put_ID_Proxy | ( | ICRDRobot __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDRobot_put_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDRobot_removeVariable_Proxy | ( | ICRDRobot __RPC_FAR * | This,
 |  | BSTR | bstrName
 | ) |

void __RPC_STUB ICRDRobot_removeVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDTask_appendVariable_Proxy | ( | ICRDTask __RPC_FAR * | This,
 |  | ICRDVariable __RPC_FAR * | newVar
 | ) |

void __RPC_STUB ICRDTask_appendVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDTask_clone_Proxy | ( | ICRDTask __RPC_FAR * | This,
 |  | BSTR | bstrDestName,
 |  | ICRDTask __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDTask_clone_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDTask_createVariable_Proxy | ( | ICRDTask __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDVariable __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDTask_createVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDTask_get_Attribute_Proxy | ( | ICRDTask __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDTask_get_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDTask_get_FileName_Proxy | ( | ICRDTask __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDTask_get_FileName_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDTask_get_Help_Proxy | ( | ICRDTask __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDTask_get_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDTask_get_ID_Proxy | ( | ICRDTask __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDTask_get_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDTask_get_Name_Proxy | ( | ICRDTask __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDTask_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDTask_get_Variable_Proxy | ( | ICRDTask __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | ICRDVariable __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDTask_get_Variable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDTask_get_VariableNames_Proxy | ( | ICRDTask __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDTask_get_VariableNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDTask_get_XMLNode_Proxy | ( | ICRDTask __RPC_FAR * | This,
 |  | IUnknown __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDTask_get_XMLNode_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDTask_put_Attribute_Proxy | ( | ICRDTask __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICRDTask_put_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDTask_put_FileName_Proxy | ( | ICRDTask __RPC_FAR * | This,
 |  | BSTR | newVal
 | ) |

void __RPC_STUB ICRDTask_put_FileName_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDTask_put_Help_Proxy | ( | ICRDTask __RPC_FAR * | This,
 |  | BSTR | newVal
 | ) |

void __RPC_STUB ICRDTask_put_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDTask_put_ID_Proxy | ( | ICRDTask __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDTask_put_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDTask_removeVariable_Proxy | ( | ICRDTask __RPC_FAR * | This,
 |  | BSTR | bstrName
 | ) |

void __RPC_STUB ICRDTask_removeVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDVariable_clone_Proxy | ( | ICRDVariable __RPC_FAR * | This,
 |  | BSTR | bstrDestName,
 |  | ICRDVariable __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDVariable_clone_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDVariable_get_Attribute_Proxy | ( | ICRDVariable __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDVariable_get_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDVariable_get_DateTime_Proxy | ( | ICRDVariable __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDVariable_get_DateTime_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDVariable_get_Help_Proxy | ( | ICRDVariable __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDVariable_get_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDVariable_get_ID_Proxy | ( | ICRDVariable __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDVariable_get_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDVariable_get_Microsecond_Proxy | ( | ICRDVariable __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDVariable_get_Microsecond_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDVariable_get_Name_Proxy | ( | ICRDVariable __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDVariable_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDVariable_get_Value_Proxy | ( | ICRDVariable __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDVariable_get_Value_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDVariable_get_XMLNode_Proxy | ( | ICRDVariable __RPC_FAR * | This,
 |  | IUnknown __RPC_FAR *__RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICRDVariable_get_XMLNode_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDVariable_put_Attribute_Proxy | ( | ICRDVariable __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICRDVariable_put_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDVariable_put_DateTime_Proxy | ( | ICRDVariable __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDVariable_put_DateTime_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDVariable_put_Help_Proxy | ( | ICRDVariable __RPC_FAR * | This,
 |  | BSTR | newVal
 | ) |

void __RPC_STUB ICRDVariable_put_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDVariable_put_ID_Proxy | ( | ICRDVariable __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDVariable_put_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDVariable_put_Microsecond_Proxy | ( | ICRDVariable __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICRDVariable_put_Microsecond_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICRDVariable_put_Value_Proxy | ( | ICRDVariable __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICRDVariable_put_Value_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

virtual HRESULT STDMETHODCALLTYPE load ( BSTR bstrFileName ) [pure virtual]

void __RPC_FAR* __RPC_USER MIDL_user_allocate ( size_t )

void __RPC_USER MIDL_user_free ( void __RPC_FAR * )

HRESULT STDMETHODCALLTYPE put_Attribute ( long newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_DateCreated ( VARIANT newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_DateLastAccessed ( VARIANT newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_DateLastModified ( VARIANT newVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE put_DateTime ( VARIANT newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_Description ( BSTR newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_Destination ( BSTR newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_FileName ( BSTR newVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE put_Help ( BSTR newVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE put_ID ( VARIANT newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_Microsecond ( long newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_Parameters ( VARIANT newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_Path ( BSTR newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_Size ( long newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_Source ( BSTR newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_State ( long newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_Timeout ( long newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_Type ( BSTR newVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE put_Value ( VARIANT newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_Version ( BSTR newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE removeCommand ( BSTR bstrName ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE removeController ( BSTR bstrName ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE removeExtension ( BSTR bstrName ) [pure virtual]

HRESULT STDMETHODCALLTYPE removeFile ( BSTR bstrName ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE removeMessage ( long lNumber ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE removeRobot ( BSTR bstrName ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE removeTask ( BSTR bstrName ) [pure virtual]

HRESULT STDMETHODCALLTYPE removeVariable ( BSTR bstrName ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE save ( void ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE saveAs ( BSTR bstrFileName = L"" ) [pure virtual]

void __RPC_USER VARIANT_UserFree | ( | unsigned long __RPC_FAR * | ,
 |  | VARIANT __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER VARIANT_UserMarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | VARIANT __RPC_FAR * |
 | ) |

unsigned long __RPC_USER VARIANT_UserSize | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned | long,
 |  | VARIANT __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER VARIANT_UserUnmarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | VARIANT __RPC_FAR * |
 | ) |

変数の解説

RPC_IF_HANDLE __MIDL_itf_CRDMapper_0000_v0_0_c_ifspec

RPC_IF_HANDLE __MIDL_itf_CRDMapper_0000_v0_0_s_ifspec

ICRDEngine __pad0__

ICRDController __pad1__

ICRDExtension __pad2__

ICRDFile __pad3__

ICRDRobot __pad4__

ICRDTask __pad5__

ICRDVariable __pad6__

ICRDCommand __pad7__

ICRDMessage __pad8__

EXTERN_C const CLSID CLSID_CRDCommand

EXTERN_C const CLSID CLSID_CRDController

EXTERN_C const CLSID CLSID_CRDEngine

EXTERN_C const CLSID CLSID_CRDExtension

EXTERN_C const CLSID CLSID_CRDFile

EXTERN_C const CLSID CLSID_CRDMessage

EXTERN_C const CLSID CLSID_CRDRobot

EXTERN_C const CLSID CLSID_CRDTask

EXTERN_C const CLSID CLSID_CRDVariable

EXTERN_C const IID IID_ICRDCommand

EXTERN_C const IID IID_ICRDController

EXTERN_C const IID IID_ICRDEngine

EXTERN_C const IID IID_ICRDExtension

EXTERN_C const IID IID_ICRDFile

EXTERN_C const IID IID_ICRDMessage

EXTERN_C const IID IID_ICRDRobot

EXTERN_C const IID IID_ICRDTask

EXTERN_C const IID IID_ICRDVariable

EXTERN_C const IID LIBID_CRDMAPPERLib

Generated on Thu Jan 27 18:50:05 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMapper.idl File Reference

CRDMapper.idl の解説

ソースコードを見る。

名前空間

namespace | CRDMAPPERLib

構成

interface | ICRDCommand
interface | ICRDController
interface | ICRDEngine
interface | ICRDExtension
interface | ICRDFile
interface | ICRDMessage
interface | ICRDRobot
interface | ICRDTask
interface | ICRDVariable

Generated on Thu Jan 27 18:50:05 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMapper_i.c File Reference

CRDMapper_i.c の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

構成

struct | _IID

Typedef

typedef _IID | IID
typedef IID | CLSID

変数

const IID | IID_ICRDEngine = {0xC6A53FD0,0xB13D,0x48EA,{0x86,0x2E,0x07,0x10,0x46,0x0C,0x14,0x60}}
const IID | IID_ICRDController = {0x9044FA0D,0x1B4D,0x42C4,{0x9D,0xBC,0x1F,0x6E,0x45,0x53,0xE3,0x1C}}
const IID | IID_ICRDExtension = {0x5DFD134B,0x65F4,0x44ED,{0xB2,0xB2,0xF7,0x03,0x78,0xBF,0x8E,0x13}}
const IID | IID_ICRDFile = {0x087D5BDD,0x4D9E,0x4EC5,{0x8C,0xDA,0x85,0x0F,0x48,0x6D,0xC8,0x3C}}
const IID | IID_ICRDRobot = {0x5E3CDB5B,0x0638,0x4285,{0xB1,0xCB,0xC1,0x49,0xB5,0x9A,0x1A,0xD2}}
const IID | IID_ICRDTask = {0x66E7EE84,0xCAA7,0x437F,{0xAF,0x52,0xA9,0x49,0x73,0xD8,0xA8,0xD7}}
const IID | IID_ICRDVariable = {0x29DD8E3A,0x87CB,0x4C35,{0x84,0xC5,0x57,0x96,0xC6,0xD4,0xEF,0xB2}}
const IID | IID_ICRDCommand = {0xA422E6C8,0xAD76,0x46a2,{0xBA,0x95,0x6A,0xA8,0xD0,0x73,0xA5,0x81}}
const IID | IID_ICRDMessage = {0x904C2E9D,0x085D,0x478f,{0x9E,0x8F,0x22,0x4F,0x5E,0x11,0x30,0xD4}}
const IID | LIBID_CRDMAPPERLib = {0xC7C2D3B2,0x52ED,0x45F7,{0x96,0xA5,0xD8,0xF3,0x41,0xE6,0x96,0xCF}}
const CLSID | CLSID_CRDEngine = {0x1A075796,0x21FA,0x4CE6,{0x9C,0xDB,0xB1,0x68,0x3C,0x4B,0x04,0x42}}
const CLSID | CLSID_CRDController = {0x2D971601,0x9F26,0x4F70,{0xAF,0x6C,0xA6,0xCE,0x07,0x68,0x3C,0xB9}}
const CLSID | CLSID_CRDExtension = {0xE8DE945C,0xB604,0x4567,{0x9D,0xD5,0xD6,0xB6,0xD5,0x2A,0x18,0xCC}}
const CLSID | CLSID_CRDFile = {0x523F3578,0x4ACE,0x4447,{0x9D,0x40,0xEC,0x9B,0xBC,0x38,0xAE,0x0F}}
const CLSID | CLSID_CRDRobot = {0x2B010177,0xFD27,0x436B,{0xBE,0xFF,0xA3,0xA3,0x02,0xBE,0xFC,0xA8}}
const CLSID | CLSID_CRDTask = {0x952CCDAB,0x6AA8,0x4007,{0x82,0x25,0x9C,0x9B,0x70,0x4C,0x8C,0x90}}
const CLSID | CLSID_CRDVariable = {0xC39D19C0,0x3458,0x4623,{0x9A,0x55,0x02,0xE5,0xBE,0xB2,0x7C,0xD3}}
const CLSID | CLSID_CRDCommand = {0x853BCF88,0x9A3C,0x4604,{0xB9,0x5C,0xAB,0x48,0xAF,0x47,0xA3,0x3C}}
const CLSID | CLSID_CRDMessage = {0xA8D27938,0x26D1,0x4af3,{0x95,0x99,0x23,0xCF,0x97,0x28,0x5A,0x7C}}

Typedef の解説

typedef IID CLSID

typedef struct _IID IID

変数の解説

const CLSID CLSID_CRDCommand = {0x853BCF88,0x9A3C,0x4604,{0xB9,0x5C,0xAB,0x48,0xAF,0x47,0xA3,0x3C}}

const CLSID CLSID_CRDController = {0x2D971601,0x9F26,0x4F70,{0xAF,0x6C,0xA6,0xCE,0x07,0x68,0x3C,0xB9}}

const CLSID CLSID_CRDEngine = {0x1A075796,0x21FA,0x4CE6,{0x9C,0xDB,0xB1,0x68,0x3C,0x4B,0x04,0x42}}

const CLSID CLSID_CRDExtension = {0xE8DE945C,0xB604,0x4567,{0x9D,0xD5,0xD6,0xB6,0xD5,0x2A,0x18,0xCC}}

const CLSID CLSID_CRDFile = {0x523F3578,0x4ACE,0x4447,{0x9D,0x40,0xEC,0x9B,0xBC,0x38,0xAE,0x0F}}

const CLSID CLSID_CRDMessage = {0xA8D27938,0x26D1,0x4af3,{0x95,0x99,0x23,0xCF,0x97,0x28,0x5A,0x7C}}

const CLSID CLSID_CRDRobot = {0x2B010177,0xFD27,0x436B,{0xBE,0xFF,0xA3,0xA3,0x02,0xBE,0xFC,0xA8}}

const CLSID CLSID_CRDTask = {0x952CCDAB,0x6AA8,0x4007,{0x82,0x25,0x9C,0x9B,0x70,0x4C,0x8C,0x90}}

const CLSID CLSID_CRDVariable = {0xC39D19C0,0x3458,0x4623,{0x9A,0x55,0x02,0xE5,0xBE,0xB2,0x7C,0xD3}}

const IID IID_ICRDCommand = {0xA422E6C8,0xAD76,0x46a2,{0xBA,0x95,0x6A,0xA8,0xD0,0x73,0xA5,0x81}}

const IID IID_ICRDController = {0x9044FA0D,0x1B4D,0x42C4,{0x9D,0xBC,0x1F,0x6E,0x45,0x53,0xE3,0x1C}}

const IID IID_ICRDEngine = {0xC6A53FD0,0xB13D,0x48EA,{0x86,0x2E,0x07,0x10,0x46,0x0C,0x14,0x60}}

const IID IID_ICRDExtension = {0x5DFD134B,0x65F4,0x44ED,{0xB2,0xB2,0xF7,0x03,0x78,0xBF,0x8E,0x13}}

const IID IID_ICRDFile = {0x087D5BDD,0x4D9E,0x4EC5,{0x8C,0xDA,0x85,0x0F,0x48,0x6D,0xC8,0x3C}}

const IID IID_ICRDMessage = {0x904C2E9D,0x085D,0x478f,{0x9E,0x8F,0x22,0x4F,0x5E,0x11,0x30,0xD4}}

const IID IID_ICRDRobot = {0x5E3CDB5B,0x0638,0x4285,{0xB1,0xCB,0xC1,0x49,0xB5,0x9A,0x1A,0xD2}}

const IID IID_ICRDTask = {0x66E7EE84,0xCAA7,0x437F,{0xAF,0x52,0xA9,0x49,0x73,0xD8,0xA8,0xD7}}

const IID IID_ICRDVariable = {0x29DD8E3A,0x87CB,0x4C35,{0x84,0xC5,0x57,0x96,0xC6,0xD4,0xEF,0xB2}}

const IID LIBID_CRDMAPPERLib = {0xC7C2D3B2,0x52ED,0x45F7,{0x96,0xA5,0xD8,0xF3,0x41,0xE6,0x96,0xCF}}

Generated on Thu Jan 27 18:50:05 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMapper_p.c File Reference

CRDMapper_p.c の解説

#include "rpcproxy.h"
#include "CRDMapper.h"

CRDMapper_p.cのインクルード依存関係図

Include dependency graph

構成

struct | _MIDL_PROC_FORMAT_STRING
struct | _MIDL_TYPE_FORMAT_STRING

マクロ定義

#define | USE_STUBLESS_PROXY
#define | __REQUIRED_RPCPROXY_H_VERSION__ 440
#define | TYPE_FORMAT_STRING_SIZE 1267
#define | PROC_FORMAT_STRING_SIZE 3227

Typedef

typedef _MIDL_TYPE_FORMAT_STRING | MIDL_TYPE_FORMAT_STRING
typedef _MIDL_PROC_FORMAT_STRING | MIDL_PROC_FORMAT_STRING

関数

CINTERFACE_PROXY_VTABLE (20) _ICRDEngineProxyVtbl=

変数

const MIDL_TYPE_FORMAT_STRING | __MIDL_TypeFormatString
const MIDL_PROC_FORMAT_STRING | __MIDL_ProcFormatString
const MIDL_STUB_DESC | Object_StubDesc
const MIDL_SERVER_INFO | ICRDEngine_ServerInfo
const unsigned short | ICRDEngine_FormatStringOffsetTable []
const MIDL_STUBLESS_PROXY_INFO | ICRDEngine_ProxyInfo

マクロ定義の解説

#define __REQUIRED_RPCPROXY_H_VERSION__ 440

#define PROC_FORMAT_STRING_SIZE 3227

#define TYPE_FORMAT_STRING_SIZE 1267

#define USE_STUBLESS_PROXY

Typedef の解説

typedef struct _MIDL_PROC_FORMAT_STRING MIDL_PROC_FORMAT_STRING

typedef struct _MIDL_TYPE_FORMAT_STRING MIDL_TYPE_FORMAT_STRING

関数の解説

CINTERFACE_PROXY_VTABLE ( 20 )

変数の解説

const MIDL_PROC_FORMAT_STRING __MIDL_ProcFormatString

const MIDL_TYPE_FORMAT_STRING __MIDL_TypeFormatString

const unsigned short ICRDEngine_FormatStringOffsetTable[] [static]

初期値:

    {
    (unsigned short) -1,
    (unsigned short) -1,
    (unsigned short) -1,
    (unsigned short) -1,
    0,
    22,
    50,
    72,
    100,
    134,
    162,
    190,
    218,
    252,
    280,
    308,
    336
    }

const MIDL_STUBLESS_PROXY_INFO ICRDEngine_ProxyInfo [static]

初期値:

    {
    &Object_StubDesc,
    __MIDL_ProcFormatString.Format,
    &ICRDEngine_FormatStringOffsetTable[-3],
    0,
    0,
    0
    }

const MIDL_SERVER_INFO ICRDEngine_ServerInfo

初期値:

    {
    &Object_StubDesc,
    0,
    __MIDL_ProcFormatString.Format,
    &ICRDEngine_FormatStringOffsetTable[-3],
    0,
    0,
    0,
    0
    }

const MIDL_STUB_DESC Object_StubDesc

Generated on Thu Jan 27 18:50:05 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMessage.cpp File Reference

CRDMessage.cpp の解説

#include "stdafx.h"
#include "CRDMapper.h"
#include "CRDMessage.h"

CRDMessage.cppのインクルード依存関係図

Include dependency graph
Generated on Thu Jan 27 18:50:05 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMessage.h File Reference

CRDMessage.h の解説

#include "resource.h"
#include "_CCRDNodeTemplate.h"

CRDMessage.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCRDMessage
CRDMapperのMessageクラス. [詳細]

Generated on Thu Jan 27 18:50:05 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDRobot.cpp File Reference

CRDRobot.cpp の解説

#include "stdafx.h"
#include "CRDMapper.h"
#include "CRDRobot.h"

CRDRobot.cppのインクルード依存関係図

Include dependency graph
Generated on Thu Jan 27 18:50:06 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDRobot.h File Reference

CRDRobot.h の解説

#include "resource.h"
#include "_CCRDNodeTemplate.h"
#include "CRDVariable.h"

CRDRobot.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCRDRobot
CRDMapperのRobotクラス. [詳細]

Generated on Thu Jan 27 18:50:06 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDTask.cpp File Reference

CRDTask.cpp の解説

#include "stdafx.h"
#include "CRDMapper.h"
#include "CRDTask.h"

CRDTask.cppのインクルード依存関係図

Include dependency graph
Generated on Thu Jan 27 18:50:06 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDTask.h File Reference

CRDTask.h の解説

#include "resource.h"
#include "_CCRDNodeTemplate.h"
#include "CRDVariable.h"

CRDTask.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCRDTask
CRDMapperのTaskクラス. [詳細]

Generated on Thu Jan 27 18:50:06 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDUtility.h File Reference

CRDUtility.h の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCRDUtility
CRDMapperのUtilityクラス. [詳細]

マクロ定義

#define | AFX_CRDUTILITY_H__E2594B17_3537_4843_87B1_520624BBBF77__INCLUDED_

マクロ定義の解説

#define AFX_CRDUTILITY_H__E2594B17_3537_4843_87B1_520624BBBF77__INCLUDED_

Generated on Thu Jan 27 18:50:06 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDVariable.cpp File Reference

CRDVariable.cpp の解説

#include "stdafx.h"
#include "CRDMapper.h"
#include "CRDVariable.h"

CRDVariable.cppのインクルード依存関係図

Include dependency graph
Generated on Thu Jan 27 18:50:07 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDVariable.h File Reference

CRDVariable.h の解説

#include "resource.h"
#include "_CCRDNodeTemplate.h"

CRDVariable.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCRDVariable
CRDMapperのVariableクラス. [詳細]

Generated on Thu Jan 27 18:50:07 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


dlldata.c File Reference

dlldata.c の解説

#include <rpcproxy.h>

dlldata.cのインクルード依存関係図

Include dependency graph

マクロ定義

#define | PROXY_DELEGATION

関数

PROXYFILE_LIST_START | REFERENCE_PROXY_FILE (CRDMapper)

マクロ定義の解説

#define PROXY_DELEGATION

関数の解説

PROXYFILE_LIST_START REFERENCE_PROXY_FILE ( CRDMapper )

Generated on Thu Jan 27 18:50:07 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


resource.h File Reference

resource.h の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

マクロ定義

#define | IDS_PROJNAME 100
#define | IDR_CRDENGINE 101
#define | IDR_CRDCONTROLLER 102
#define | IDR_CRDEXTENSION 104
#define | IDR_CRDFILE 106
#define | IDR_CRDROBOT 107
#define | IDR_CRDTASK 108
#define | IDR_CRDVARIABLE 109

マクロ定義の解説

#define IDR_CRDCONTROLLER 102

#define IDR_CRDENGINE 101

#define IDR_CRDEXTENSION 104

#define IDR_CRDFILE 106

#define IDR_CRDROBOT 107

#define IDR_CRDTASK 108

#define IDR_CRDVARIABLE 109

#define IDS_PROJNAME 100

Generated on Thu Jan 27 18:50:07 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


StdAfx.cpp File Reference

StdAfx.cpp の解説

#include "stdafx.h"
#include <atlimpl.cpp>

StdAfx.cppのインクルード依存関係図

Include dependency graph
Generated on Thu Jan 27 18:50:08 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


StdAfx.h File Reference

StdAfx.h の解説

#include <atlbase.h>
#include <atlcom.h>
#include <stdio.h>
#include "CRD.h"
#include "CRDUtility.h"

StdAfx.hのインクルード依存関係図

Include dependency graph

ソースコードを見る。

名前空間

namespace | MSXML2

マクロ定義

#define | AFX_STDAFX_H__1D245D43_9AC1_4B7B_82FC_36A4742EA6D8__INCLUDED_
#define | STRICT
#define | _WIN32_WINNT 0x0400
#define | _ATL_APARTMENT_THREADED

変数

CComModule | _Module

マクロ定義の解説

#define _ATL_APARTMENT_THREADED

#define _WIN32_WINNT 0x0400

#define AFX_STDAFX_H__1D245D43_9AC1_4B7B_82FC_36A4742EA6D8__INCLUDED_

#define STRICT

変数の解説

CComModule _Module

Generated on Thu Jan 27 18:50:08 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


Annotated Index

CRDMapper Project 構成

クラス、構造体、共用体、インタフェースの解説です。
_CCRDNodeTemplate< T, pclsid, T1, piid > | CRDMapperの共通クラス
_IID |
_MIDL_PROC_FORMAT_STRING |
_MIDL_TYPE_FORMAT_STRING |
CComCoClass |
CComObjectRootEx |
CCRDCommand | CRDMapperのCommandクラス
CCRDController | CRDMapperのControllerクラス
CCRDEngine | CRDMapperのEngineクラス
CCRDExtension | CRDMapperのExtensionクラス
CCRDFile | CRDMapperのFileクラス
CCRDMessage | CRDMapperのMessageクラス
CCRDRobot | CRDMapperのRobotクラス
CCRDTask | CRDMapperのTaskクラス
CCRDUtility | CRDMapperのUtilityクラス
CCRDVariable | CRDMapperのVariableクラス
CRDMAPPERLib::CRDCommand |
CRDMAPPERLib::CRDController |
CRDMAPPERLib::CRDEngine |
CRDMAPPERLib::CRDExtension |
CRDMAPPERLib::CRDFile |
CRDMAPPERLib::CRDMessage |
CRDMAPPERLib::CRDRobot |
CRDMAPPERLib::CRDTask |
CRDMAPPERLib::CRDVariable |
ICRDCommand |
ICRDController |
ICRDEngine |
ICRDExtension |
ICRDFile |
ICRDMessage |
ICRDRobot |
ICRDTask |
ICRDVariable |
IDispatchImpl |
ISupportErrorInfo |
Generated on Thu Jan 27 18:50:08 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


Template_CCRDNodeTemplate< T, pclsid, T1, piid > class Reference

クラス テンプレート_CCRDNodeTemplate< T, pclsid, T1, piid > の解説

CRDMapperの共通クラス. [詳細]

#include <_CCRDNodeTemplate.h>

_CCRDNodeTemplate< T, pclsid, T1, piid >に対する継承グラフ

[凡例]
_CCRDNodeTemplate< T, pclsid, T1, piid >のコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

_CCRDNodeTemplate ()
STDMETHODIMP | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | _Initialize (IXMLDOMNode *pINode)
オブジェクトの初期化

STDMETHODIMP | get_Name (BSTR *pVal)
オブジェクト名の取得

STDMETHODIMP | get_Attribute (long *pVal)
属性の取得

STDMETHODIMP | put_Attribute (long newVal)
属性の設定

STDMETHODIMP | get_Help (BSTR *pVal)
ヘルプの取得

STDMETHODIMP | put_Help (BSTR newVal)
ヘルプの設定

STDMETHODIMP | get_ID (VARIANT *pVal)
IDの取得.

STDMETHODIMP | put_ID (VARIANT newVal)
IDの設定.

STDMETHODIMP | get_XMLNode (IUnknown **pVal)
ノードオブジェクトの取得

Protected 変数

IXMLDOMNodePtr | m_pINode

解説

template<class T, const CLSID * pclsid, class T1, const IID * piid>
class _CCRDNodeTemplate< T, pclsid, T1, piid >

CRDMapperの共通クラス.

  CRDMapperの各クラスに共通のメソッドを提供する．

コンストラクタとデストラクタの解説

template<class T, const CLSID * pclsid, class T1, const IID * piid>
_CCRDNodeTemplate< T, pclsid, T1, piid >::_CCRDNodeTemplate ( ) [inline]

メソッドの解説

template<class T, const CLSID * pclsid, class T1, const IID * piid>
HRESULT _CCRDNodeTemplate< T, pclsid, T1, piid >::_Initialize ( IXMLDOMNode * pINode ) [inline]

オブジェクトの初期化

オブジェクトの初期化をする．
CRDNode テンプレートを継承するクラスはXMLノードを保持する．

引数:
pINode [in] XMLノードオブジェクト
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid>
STDMETHODIMP _CCRDNodeTemplate< T, pclsid, T1, piid >::get_Attribute ( long * pVal ) [inline]

属性の取得

CRDNode オブジェクトの属性情報を取得する．
CRDNode ノード以下の<Attribute>タグを探す．

引数:
pVal [out] 属性情報
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid>
STDMETHODIMP _CCRDNodeTemplate< T, pclsid, T1, piid >::get_Help ( BSTR * pVal ) [inline]

ヘルプの取得

CRDNode オブジェクトのヘルプ情報を取得する．
CRDNode ノード以下の<Help>タグを探す．

引数:
pVal [out]ヘルプ情報を格納するBSTRへのポインタ
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid>
STDMETHODIMP _CCRDNodeTemplate< T, pclsid, T1, piid >::get_ID ( VARIANT * pVal ) [inline]

IDの取得.

CRDNode オブジェクトのヘルプ情報を取得する．
CRDNode ノード以下の<ID>タグを探す．

引数:
pVal [out]ヘルプ情報を格納するBSTRへのポインタ
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid>
STDMETHODIMP _CCRDNodeTemplate< T, pclsid, T1, piid >::get_Name ( BSTR * pVal ) [inline]

オブジェクト名の取得

CRDNode オブジェクトの名前を取得する．

<Controller name="ctrl_name" >... という CRDNode であれば，"ctrl_name"を返す．

引数:
pVal [out] ノードの名前を格納するBSTRへのポインタ
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid>
STDMETHODIMP _CCRDNodeTemplate< T, pclsid, T1, piid >::get_XMLNode ( IUnknown ** pVal ) [inline]

ノードオブジェクトの取得

CRDNode のノード位置を示すオブジェクトを取得する．
このメソッドは外部から実行することを推奨ない．[restricted]

引数:
pVal [out]ノードオブジェクト
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid>
STDMETHODIMP _CCRDNodeTemplate< T, pclsid, T1, piid >::InterfaceSupportsErrorInfo ( REFIID riid ) [inline]

オートメーションIFのエラーオブジェクトのサポート判定

riid に指定されたインターフェイスが IErrorInfo インターフェース をサポートするかどうかを示す．

引数:
riid [in] インタフェース
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid>
STDMETHODIMP _CCRDNodeTemplate< T, pclsid, T1, piid >::put_Attribute ( long newVal ) [inline]

属性の設定

CRDNode オブジェクトの属性情報を設定する．
CRDNode ノード以下の<Attribute>タグに値をセットする．
もしノード以下に<Attribute>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out]ヘルプ情報
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid>
STDMETHODIMP _CCRDNodeTemplate< T, pclsid, T1, piid >::put_Help ( BSTR newVal ) [inline]

ヘルプの設定

CRDNode オブジェクトのヘルプ情報を設定する．
CRDNode ノード以下の<Help>タグに値をセットする．
もしノード以下に<Help>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out]ヘルプ情報
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid>
STDMETHODIMP _CCRDNodeTemplate< T, pclsid, T1, piid >::put_ID ( VARIANT newVal ) [inline]

IDの設定.

CRDNode オブジェクトのヘルプ情報を設定する．
CRDNode ノード以下の<ID>タグに値をセットする．
もしノード以下に<Help>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out]ヘルプ情報
戻り値:
HRESULT

変数の解説

template<class T, const CLSID * pclsid, class T1, const IID * piid>
IXMLDOMNodePtr _CCRDNodeTemplate< T, pclsid, T1, piid >::m_pINode [protected]

このクラスの解説は次のファイルから生成されました:
  • _CCRDNodeTemplate.h
Generated on Thu Jan 27 18:50:09 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


_IID struct Reference

構造体 _IID の解説

すべてのメンバ一覧

Public 変数

unsigned long | x
unsigned short | s1
unsigned short | s2
unsigned char | c [8]

変数の解説

unsigned char _IID::c[8]

unsigned short _IID::s1

unsigned short _IID::s2

unsigned long _IID::x

この構造体の解説は次のファイルから生成されました:
  • CRDMapper_i.c
Generated on Thu Jan 27 18:50:09 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


_MIDL_PROC_FORMAT_STRING struct Reference

構造体 _MIDL_PROC_FORMAT_STRING の解説

すべてのメンバ一覧

Public 変数

short | Pad
unsigned char | Format [PROC_FORMAT_STRING_SIZE]

変数の解説

unsigned char _MIDL_PROC_FORMAT_STRING::Format[ PROC_FORMAT_STRING_SIZE ]

short _MIDL_PROC_FORMAT_STRING::Pad

この構造体の解説は次のファイルから生成されました:
  • CRDMapper_p.c
Generated on Thu Jan 27 18:50:09 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


_MIDL_TYPE_FORMAT_STRING struct Reference

構造体 _MIDL_TYPE_FORMAT_STRING の解説

すべてのメンバ一覧

Public 変数

short | Pad
unsigned char | Format [TYPE_FORMAT_STRING_SIZE]

変数の解説

unsigned char _MIDL_TYPE_FORMAT_STRING::Format[ TYPE_FORMAT_STRING_SIZE ]

short _MIDL_TYPE_FORMAT_STRING::Pad

この構造体の解説は次のファイルから生成されました:
  • CRDMapper_p.c
Generated on Thu Jan 27 18:50:09 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CComCoClass class Reference

クラス CComCoClass の解説

CComCoClassに対する継承グラフ

[凡例]
このクラスの解説は次のファイルから生成されました:
  • _CCRDNodeTemplate.h
Generated on Thu Jan 27 18:50:09 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CComObjectRootEx class Reference

クラス CComObjectRootEx の解説

CComObjectRootExに対する継承グラフ

[凡例]
このクラスの解説は次のファイルから生成されました:
  • _CCRDNodeTemplate.h
Generated on Thu Jan 27 18:50:10 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CCRDCommand class Reference

クラス CCRDCommand の解説

CRDMapperのCommandクラス. [詳細]

#include <CRDCommand.h>

CCRDCommandに対する継承グラフ

[凡例]
CCRDCommandのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

HRESULT | get_Timeout (long *pVal)
タイムアウト値の取得

HRESULT | put_Timeout (long newVal)
タイムアウト値の設定

HRESULT | get_State (long *pVal)
状態情報の取得

HRESULT | put_State (long newVal)
状態情報の設定

HRESULT | get_Parameters (VARIANT *pVal)
パラメータの取得

HRESULT | put_Parameters (VARIANT newVal)
パラメータの設定

HRESULT | clone (BSTR bstrDestName, ICRDCommand **pVal)
コマンドのコピー

解説

CRDMapperのCommandクラス.

  デュアルインターフェースを持つCOMのクラス．詳細はICRDCommandを参照．
  CRDEngineクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  XMLファイルの<Command>タグに対応する．

メソッドの解説

STDMETHODIMP CCRDCommand::clone | ( | BSTR | bstrDestName,
 |  | ICRDCommand ** | pVal
 | ) |

コマンドのコピー

コマンドオブジェクトの複製を生成する．
ノードは新規に構成され，複製した時点ではドキュメントに追加されない．
CRDController::appencCommand を使用し，適宜ドキュメントに追加すること．
ノードオブジェクトは，複製元のノードオブジェクトをディープコピーする．

引数:
bstrDestName | [in]複製オブジェクトのコマンド名
pVal | [out]複製されたコマンドオブジェクト

STDMETHODIMP CCRDCommand::get_Parameters ( VARIANT * pVal )

パラメータの取得

CRDCommand オブジェクトの変数値情報を取得する．
CRDCommand ノード以下の<Parameter>タグを探す．

引数:
pVal [out] 変数値情報を格納するVARIANTへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDCommand::get_State ( long * pVal )

状態情報の取得

CRDCommand オブジェクトの状態情報を取得する．
CRDCommand ノード以下の<State>タグを探す．

引数:
pVal [out] 状態情報
戻り値:
HRESULT

STDMETHODIMP CCRDCommand::get_Timeout ( long * pVal )

タイムアウト値の取得

CRDCommand タイムアウト設定値を取得する．
CRDCommand ノード以下の<Timeout>タグを探す．

引数:
pVal [out] タイムアウト設定値
戻り値:
HRESULT

STDMETHODIMP CCRDCommand::put_Parameters ( VARIANT newVal )

パラメータの設定

CRDCommand オブジェクトの変数値情報を設定する．
CRDCommand ノード以下の<Parameters>タグに値をセットする．
もしノード以下に<Parameters>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] 変数値
戻り値:
HRESULT

STDMETHODIMP CCRDCommand::put_State ( long newVal )

状態情報の設定

CRDCommand オブジェクトの状態情報を設定する．
CRDCommand ノード以下の<State>タグに値をセットする．
もしノード以下に<State>タグが無い場合は新規に作成し，セットする．

引数:
newVal [in] 状態情報
戻り値:
HRESULT

STDMETHODIMP CCRDCommand::put_Timeout ( long newVal )

タイムアウト値の設定

CRDCommand タイムアウト設定値を設定する．
CRDCommand ノード以下の<Timeout>タグに値をセットする．
もしノード以下に<Timeout>タグが無い場合は新規に作成し，セットする．

引数:
newVal [in] タイムアウト設定値
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CRDCommand.h
  • CRDCommand.cpp
Generated on Thu Jan 27 18:50:11 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CCRDController class Reference

クラス CCRDController の解説

CRDMapperのControllerクラス. [詳細]

#include <CRDController.h>

CCRDControllerに対する継承グラフ

[凡例]
CCRDControllerのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

HRESULT | createExtension (BSTR bstrName, ICRDExtension **pVal)
拡張ボードの作成

HRESULT | removeExtension (BSTR bstrName)
拡張ボードの削除

HRESULT | appendExtension (ICRDExtension *newExt)
拡張ボードの追加

HRESULT | get_ExtensionNames (VARIANT *pVal)
拡張ボード名リストの取得

HRESULT | get_Extension (BSTR bstrName, ICRDExtension **pVal)
拡張ボードの取得

HRESULT | createFile (BSTR bstrName, ICRDFile **pVal)
ファイルの作成

HRESULT | removeFile (BSTR bstrName)
ファイルの削除

HRESULT | appendFile (ICRDFile *newFile)
ファイルの追加

HRESULT | get_FileNames (VARIANT *pVal)
ファイル名リストの取得

HRESULT | get_File (BSTR bstrName, ICRDFile **pVal)
ファイルの取得

HRESULT | createRobot (BSTR bstrName, ICRDRobot **pVal)
ロボットの作成

HRESULT | removeRobot (BSTR bstrName)
ロボットの削除

HRESULT | appendRobot (ICRDRobot *newRobot)
ロボットの追加

HRESULT | get_RobotNames (VARIANT *pVal)
ロボット名リストの取得

HRESULT | get_Robot (BSTR bstrName, ICRDRobot **pVal)
ロボットの取得

HRESULT | createTask (BSTR bstrName, ICRDTask **pVal)
タスクの作成

HRESULT | removeTask (BSTR bstrName)
タスクの削除

HRESULT | appendTask (ICRDTask *newTask)
タスクの追加

HRESULT | get_TaskNames (VARIANT *pVal)
タスク名リストの取得

HRESULT | get_Task (BSTR bstrName, ICRDTask **pVal)
タスクの取得

HRESULT | createVariable (BSTR bstrName, ICRDVariable **pVal)
変数の作成

HRESULT | removeVariable (BSTR bstrName)
変数の削除

HRESULT | appendVariable (ICRDVariable *newVar)
変数の追加

HRESULT | get_VariableNames (VARIANT *pVal)
変数名リストの取得

HRESULT | get_Variable (BSTR bstrName, ICRDVariable **pVal)
変数の取得

HRESULT | createCommand (BSTR bstrName, ICRDCommand **pVal)
コマンドの作成

HRESULT | removeCommand (BSTR bstrName)
コマンドの削除

HRESULT | appendCommand (ICRDCommand *newVar)
コマンドの追加

HRESULT | get_CommandNames (VARIANT *pVal)
コマンド名リストの取得

HRESULT | get_Command (BSTR bstrName, ICRDCommand **pVal)
コマンドの取得

HRESULT | createMessage (long lNumber, ICRDMessage **pVal)
メッセージの作成

HRESULT | removeMessage (long lNumber)
メッセージの削除

HRESULT | appendMessage (ICRDMessage *newVar)
メッセージの追加

HRESULT | get_MessageNumbers (VARIANT *pVal)
メッセージ番号リストの取得

HRESULT | get_Message (long lNumber, ICRDMessage **pVal)
メッセージの取得

HRESULT | clone (BSTR bstrDestName, ICRDController **pVal)
コントローラのコピー

解説

CRDMapperのControllerクラス.

  デュアルインターフェースを持つCOMのクラス．詳細はICRDControllerを参照．
  CRDEngineクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  XMLファイルの<Controller>タグに対応する．

メソッドの解説

STDMETHODIMP CCRDController::appendCommand ( ICRDCommand * newVar )

コマンドの追加

指定したコマンドのノードを追加する．

引数:
newVar [in] 追加するコマンドオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDController::appendExtension ( ICRDExtension * newExt )

拡張ボードの追加

指定した拡張ボードのノードを追加する．

引数:
newExt [in] 追加する拡張ボードオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDController::appendFile ( ICRDFile * newFile )

ファイルの追加

指定したファイルのノードを追加する．

引数:
newFile [in] 追加するファイルオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDController::appendMessage ( ICRDMessage * newVar )

メッセージの追加

指定したメッセージのノードを追加する．

引数:
newVar [in] 追加するコマンドオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDController::appendRobot ( ICRDRobot * newRobot )

ロボットの追加

指定したロボットのノードを追加する．

引数:
newRobot [in] 追加するロボットオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDController::appendTask ( ICRDTask * newTask )

タスクの追加

指定したタスクのノードを追加する．

引数:
newTask [in] 追加するタスクオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDController::appendVariable ( ICRDVariable * newVar )

変数の追加

指定した変数のノードを追加する．

引数:
newVar [in] 追加する変数オブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDController::clone | ( | BSTR | bstrDestName,
 |  | ICRDController ** | pVal
 | ) |

コントローラのコピー

コントローラオブジェクトの複製を生成する．
ノードは新規に構成され，複製した時点ではドキュメントに追加されない．
CRDEngine::appencController を使用し，適宜ドキュメントに追加すること．
ノードオブジェクトは，複製元のノードオブジェクトをディープコピーする．

引数:
bstrDestName | [in]複製オブジェクトのコントローラ名
pVal | [out]複製されたコントローラオブジェクト

STDMETHODIMP CCRDController::createCommand | ( | BSTR | bstrName,
 |  | ICRDCommand ** | pVal
 | ) |

コマンドの作成

指定した名前のコマンドノードを追加する．
以下のようなノードを構成する．

<Command name=[command_name]/>

引数:
bstrName | [in] コマンド名
pVal | [out] 新しく生成したCRDCommandオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDController::createExtension | ( | BSTR | bstrName,
 |  | ICRDExtension ** | pVal
 | ) |

拡張ボードの作成

指定した名前の拡張ボードノードを作成・追加する．
以下のようなノードを構成する．

<Extension name=[extension_name]/>

引数:
bstrName | [in] 拡張ボード名
pVal | [out] 新しく生成したCRDExtensionオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDController::createFile | ( | BSTR | bstrName,
 |  | ICRDFile ** | pVal
 | ) |

ファイルの作成

指定した名前のファイルノードを作成・追加する．
以下のようなノードを構成する．

<File name=[extension_name]/>

引数:
bstrName | [in] ファイル名
pVal | [out] 新しく生成したCRDFileオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDController::createMessage | ( | long | lNumber,
 |  | ICRDMessage ** | pVal
 | ) |

メッセージの作成

指定した名前のコマンドノードを追加する．
以下のようなノードを構成する．

<Message number=[Message_number]/>

引数:
bstrName | [in] コマンド名
pVal | [out] 新しく生成したCRDMessageオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDController::createRobot | ( | BSTR | bstrName,
 |  | ICRDRobot ** | pVal
 | ) |

ロボットの作成

指定した名前のロボットノードを作成・追加する．
以下のようなノードを構成する．

<Robot name=[robot_name]/>

引数:
bstrName | [in] ロボット名
pVal | [out] 新しく生成したCRDRobotオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDController::createTask | ( | BSTR | bstrName,
 |  | ICRDTask ** | pVal
 | ) |

タスクの作成

指定した名前のタスクノードを作成・追加する．
以下のようなノードを構成する．

<Task name=[task_name]/>

引数:
bstrName | [in] タスク名
pVal | [out] 新しく生成したCRDTaskオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDController::createVariable | ( | BSTR | bstrName,
 |  | ICRDVariable ** | pVal
 | ) |

変数の作成

指定した名前の変数ノードを追加する．
以下のようなノードを構成する．

<Variable name=[variable_name]/>

引数:
bstrName | [in] 変数名
pVal | [out] 新しく生成したCRDVariableオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDController::get_Command | ( | BSTR | bstrName,
 |  | ICRDCommand ** | pVal
 | ) |

コマンドの取得

指定した名前のコマンドノードを取得する．
ICRDCommand オブジェクトを返す．

引数:
bstrName | [in] コマンド名
pVal | [out] ICRDCommand IFポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDController::get_CommandNames ( VARIANT * pVal )

コマンド名リストの取得

コマンドノードの名前一覧を取得する．

引数:
pVal [out] 名前の一覧(VT_ARRAY|VT_BSTR)
戻り値:
HRESULT

STDMETHODIMP CCRDController::get_Extension | ( | BSTR | bstrName,
 |  | ICRDExtension ** | pVal
 | ) |

拡張ボードの取得

指定した名前の拡張ボードノードを取得する．
ICRDExtension オブジェクトを返す．

引数:
bstrName | [in] 拡張ボード名
pVal | [out] ICRDExtension IFポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDController::get_ExtensionNames ( VARIANT * pVal )

拡張ボード名リストの取得

拡張ボードノードの名前一覧を取得する．

引数:
pVal [out] 名前の一覧(VT_ARRAY|VT_BSTR)
戻り値:
HRESULT

STDMETHODIMP CCRDController::get_File | ( | BSTR | bstrName,
 |  | ICRDFile ** | pVal
 | ) |

ファイルの取得

指定した名前のファイルノードを取得する．
ICRDFile オブジェクトを返す．

引数:
bstrName | [in] ファイル名
pVal | [out] ICRDFile IFポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDController::get_FileNames ( VARIANT * pVal )

ファイル名リストの取得

ファイルノードの名前一覧を取得する．

引数:
pVal [out] 名前の一覧(VT_ARRAY|VT_BSTR)
戻り値:
HRESULT

STDMETHODIMP CCRDController::get_Message | ( | long | lNumber,
 |  | ICRDMessage ** | pVal
 | ) |

メッセージの取得

指定した名前のメッセージノードを取得する．
ICRDMessage オブジェクトを返す．

引数:
bstrName | [in] コマンド名
pVal | [out] ICRDCommand IFポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDController::get_MessageNumbers ( VARIANT * pVal )

メッセージ番号リストの取得

コマンドノードの名前一覧を取得する．

引数:
pVal [out] 名前の一覧(VT_ARRAY|VT_I4)
戻り値:
HRESULT

STDMETHODIMP CCRDController::get_Robot | ( | BSTR | bstrName,
 |  | ICRDRobot ** | pVal
 | ) |

ロボットの取得

指定した名前のロボットノードを取得する．
ICRDRobot オブジェクトを返す．

引数:
bstrName | [in] ロボット名
pVal | [out] ICRDRobot IFポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDController::get_RobotNames ( VARIANT * pVal )

ロボット名リストの取得

ロボットノードの名前一覧を取得する．

引数:
pVal [out] 名前の一覧(VT_ARRAY|VT_BSTR)
戻り値:
HRESULT

STDMETHODIMP CCRDController::get_Task | ( | BSTR | bstrName,
 |  | ICRDTask ** | pVal
 | ) |

タスクの取得

指定した名前のタスクノードを取得する．
ICRDTask オブジェクトを返す．

引数:
bstrName | [in] タスク名
pVal | [out] ICRDTask IFポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDController::get_TaskNames ( VARIANT * pVal )

タスク名リストの取得

タスクノードの名前一覧を取得する．

引数:
pVal [out] 名前の一覧(VT_ARRAY|VT_BSTR)
戻り値:
HRESULT

STDMETHODIMP CCRDController::get_Variable | ( | BSTR | bstrName,
 |  | ICRDVariable ** | pVal
 | ) |

変数の取得

指定した名前の変数ノードを取得する．
ICRDVariable オブジェクトを返す．

引数:
bstrName | [in] 変数名
pVal | [out] ICRDVariable IFポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDController::get_VariableNames ( VARIANT * pVal )

変数名リストの取得

変数ノードの名前一覧を取得する．

引数:
pVal [out] 名前の一覧(VT_ARRAY|VT_BSTR)
戻り値:
HRESULT

STDMETHODIMP CCRDController::removeCommand ( BSTR bstrName )

コマンドの削除

指定した名前のコマンドノードを削除する．
インスタンスは削除されますが，saveメソッドを実行するまでディスクには 反映されない．

引数:
bstrName [in] コマンド名
戻り値:
HRESULT

STDMETHODIMP CCRDController::removeExtension ( BSTR bstrName )

拡張ボードの削除

指定した名前の拡張ボードノードを削除する．
インスタンスは削除されますが，saveメソッドを実行するまでディスクには 反映されない．

引数:
bstrName [in] 拡張ボード名
戻り値:
HRESULT

STDMETHODIMP CCRDController::removeFile ( BSTR bstrName )

ファイルの削除

指定した名前のファイルノードを削除する．
インスタンスは削除されますが，saveメソッドを実行するまでディスクには 反映されない．

引数:
bstrName [in] ファイル名
戻り値:
HRESULT

STDMETHODIMP CCRDController::removeMessage ( long lNumber )

メッセージの削除

指定した番号のメッセージノードを削除する．
インスタンスは削除されますが，saveメソッドを実行するまでディスクには 反映されない．

引数:
lNumber [in] メッセージ番号
戻り値:
HRESULT

STDMETHODIMP CCRDController::removeRobot ( BSTR bstrName )

ロボットの削除

指定した名前のロボットノードを削除する．
インスタンスは削除されますが，saveメソッドを実行するまでディスクには 反映されない．

引数:
bstrName [in] ロボット名
戻り値:
HRESULT

STDMETHODIMP CCRDController::removeTask ( BSTR bstrName )

タスクの削除

指定した名前のタスクノードを削除する．
インスタンスは削除されますが，saveメソッドを実行するまでディスクには 反映されない．

引数:
bstrName [in] タスク名
戻り値:
HRESULT

STDMETHODIMP CCRDController::removeVariable ( BSTR bstrName )

変数の削除

指定した名前の変数ノードを削除する．
インスタンスは削除されますが，saveメソッドを実行するまでディスクには 反映されない．

引数:
bstrName [in] 変数名
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CRDController.h
  • CRDController.cpp
Generated on Thu Jan 27 18:50:11 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CCRDEngine class Reference

クラス CCRDEngine の解説

CRDMapperのEngineクラス. [詳細]

#include <CRDEngine.h>

CCRDEngineに対する継承グラフ

[凡例]
CCRDEngineのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCRDEngine ()
HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | CreateDocument ()
CRDファイルの新規作成.

HRESULT | save ()
CRDファイルの上書き保存.

HRESULT | saveAs (BSTR bstrFileName)
CRDファイルの名前をつけて保存.

HRESULT | load (BSTR bstrFileName)
CRDファイルの読込み.

HRESULT | removeController (BSTR bstrName)
コントローラの削除

HRESULT | createController (BSTR bstrName, ICRDController **pVal)
コントローラの作成

HRESULT | appendController (ICRDController *newCtrl)
コントローラの追加

HRESULT | get_Controller (BSTR bstrName, ICRDController **pVal)
コントローラの取得

HRESULT | get_ControllerNames (VARIANT *pVal)
コントローラ名リストの取得

HRESULT | get_Help (BSTR *pVal)
ヘルプの取得

HRESULT | put_Help (BSTR newVal)
ヘルプの設定

HRESULT | get_Version (BSTR *pVal)
バージョンの取得

HRESULT | put_Version (BSTR newVal)
バージョンの設定

解説

CRDMapperのEngineクラス.

  デュアルインターフェースを持つCOMのクラス．詳細はICaoEngineを参照．
  CRDMapperにおいてCOMクライアントが唯一インスタンス作成可能なクラス．
  XMLファイルにアクセスする．
  XMLファイルの<CRD>タグに対応する．

コンストラクタとデストラクタの解説

CCRDEngine::CCRDEngine ( ) [inline]

メソッドの解説

STDMETHODIMP CCRDEngine::appendController ( ICRDController * newCtrl )

コントローラの追加

指定したコントローラのノードを追加する．

引数:
newCtrl [in]追加するコントローラオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDEngine::createController | ( | BSTR | bstrName,
 |  | ICRDController ** | pVal
 | ) |

コントローラの作成

指定した名前のコントローラノードを作成・追加する．
以下のようなノードを構成する．

<Controller name=[controller_name]/>

引数:
bstrName | [in]コントローラ名
pVal | [out]新しく生成したCRDControllerオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDEngine::CreateDocument ( )

CRDファイルの新規作成.

CRD(XML)DOMDocを作成する．
saveメソッドを実行するまで実際のファイルは作成されない．

戻り値:
HRESULT

STDMETHODIMP CCRDEngine::get_Controller | ( | BSTR | bstrName,
 |  | ICRDController ** | pVal
 | ) |

コントローラの取得

指定した名前のコントローラノードを取得する．
ICRDController オブジェクトを返す．

引数:
bstrName | [in]コントローラ名
pVal | [out]ICRDController IFポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDEngine::get_ControllerNames ( VARIANT * pVal )

コントローラ名リストの取得

コントローラノードの名前一覧を取得する．

引数:
pVal [out]名前の一覧(VT_ARRAY|VT_BSTR)
戻り値:
HRESULT

STDMETHODIMP CCRDEngine::get_Help ( BSTR * pVal )

ヘルプの取得

CRDEngine オブジェクトのヘルプ情報を取得する．
CRDEngine ノード以下の<Help>タグを探す．

引数:
pVal [out]ヘルプ情報を格納するBSTRへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDEngine::get_Version ( BSTR * pVal )

バージョンの取得

CRDEngine オブジェクトの属性情報を取得する．
CRDEngine ノード以下の<Version>タグを探す．

引数:
pVal [out] バージョン
戻り値:
HRESULT

STDMETHODIMP CCRDEngine::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid [in] インタフェースID
戻り値:
HRESULT

STDMETHODIMP CCRDEngine::load ( BSTR bstrFileName )

CRDファイルの読込み.

CRD(XML)ファイルをロードする．

引数:
bstrFileName [in]ロードするファイル名
戻り値:
HRESULT

STDMETHODIMP CCRDEngine::put_Help ( BSTR newVal )

ヘルプの設定

CRDEngine オブジェクトのヘルプ情報を設定する．
CRDEngine ノード以下の<Help>タグに値をセットする．
もしノード以下に<Help>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out]ヘルプ情報
戻り値:
HRESULT

STDMETHODIMP CCRDEngine::put_Version ( BSTR newVal )

バージョンの設定

CRDEngine オブジェクトの属性情報を設定する．
CRDEngine ノード以下の<Version>タグに値をセットする．
もしノード以下に<Version>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out]ヘルプ情報
戻り値:
HRESULT

STDMETHODIMP CCRDEngine::removeController ( BSTR bstrName )

コントローラの削除

指定した名前のコントローラノードを削除する．
インスタンスは削除されますが，saveメソッドを実行するまでディスクには 反映されない．

引数:
bstrName [in]コントローラ名
戻り値:
HRESULT

STDMETHODIMP CCRDEngine::save ( )

CRDファイルの上書き保存.

CRD(XML)ファイルをセーブする．
セーブされるファイルは最後に実行したload()又はsaveAs()で指定したファイル名になる．
全ての変更はこのメソッド又はsaveAs()メソッドを実行しないと，ファイルには反映されない．
デフォルトファイル名を引数で指定したファイル名に変更する．

戻り値:
HRESULT

STDMETHODIMP CCRDEngine::saveAs ( BSTR bstrFileName )

CRDファイルの名前をつけて保存.

CRD(XML)ファイルをセーブする．
セーブされるファイルは引数で指定する．
全ての変更はこのメソッド又はsave()メソッドを実行しないと，ファイルには反映されない．
デフォルトファイル名を引数で指定したファイル名に変更する．

引数:
bstrFileName [in]セーブするファイル名
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CRDEngine.h
  • CRDEngine.cpp
Generated on Thu Jan 27 18:50:11 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CCRDExtension class Reference

クラス CCRDExtension の解説

CRDMapperのExtensionクラス. [詳細]

#include <CRDExtension.h>

CCRDExtensionに対する継承グラフ

[凡例]
CCRDExtensionのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

HRESULT | createVariable (BSTR bstrName, ICRDVariable **pVal)
変数の作成

HRESULT | removeVariable (BSTR bstrName)
変数の削除

HRESULT | appendVariable (ICRDVariable *newVar)
変数の追加

HRESULT | get_VariableNames (VARIANT *pVal)
変数名リストの取得

HRESULT | get_Variable (BSTR bstrName, ICRDVariable **pVal)
変数の取得

HRESULT | clone (BSTR bstrDestName, ICRDExtension **pVal)
変数のコピー

解説

CRDMapperのExtensionクラス.

  デュアルインターフェースを持つCOMのクラス．詳細はICRDExtensionを参照．
  CRDEngineクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  XMLファイルの<Extension>タグに対応する．

メソッドの解説

STDMETHODIMP CCRDExtension::appendVariable ( ICRDVariable * newVar )

変数の追加

指定した変数のノードを追加する．

引数:
newVar [in] 追加する変数オブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDExtension::clone | ( | BSTR | bstrDestName,
 |  | ICRDExtension ** | pVal
 | ) |

変数のコピー

拡張ボードオブジェクトの複製を生成する．
ノードは新規に構成され，複製した時点ではドキュメントに追加されない．
CRDEngine::appencController を使用し，適宜ドキュメントに追加すること．
ノードオブジェクトは，複製元のノードオブジェクトをディープコピーする．

引数:
bstrDestName | [in]複製オブジェクトの拡張ボード名
pVal | [out]複製された拡張ボードオブジェクト

STDMETHODIMP CCRDExtension::createVariable | ( | BSTR | bstrName,
 |  | ICRDVariable ** | pVal
 | ) |

変数の作成

指定した名前の変数ノードを追加する．
以下のようなノードを構成する．

<Variable name=[variable_name]/>

引数:
bstrName | [in] 変数名
pVal | [out] 新しく生成したCRDVariableオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDExtension::get_Variable | ( | BSTR | bstrName,
 |  | ICRDVariable ** | pVal
 | ) |

変数の取得

指定した名前の変数ノードを取得する．
ICRDVariable オブジェクトを返す．

引数:
bstrName | [in]変数名
pVal | [out]ICRDVariable IFポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDExtension::get_VariableNames ( VARIANT * pVal )

変数名リストの取得

変数ノードの名前一覧を取得する．

引数:
pVal [out]名前の一覧(VT_ARRAY|VT_BSTR)
戻り値:
HRESULT

STDMETHODIMP CCRDExtension::removeVariable ( BSTR bstrName )

変数の削除

指定した名前の変数ノードを削除する．
インスタンスは削除されますが，saveメソッドを実行するまでディスクには 反映されない．

引数:
bstrName [in] 変数名
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CRDExtension.h
  • CRDExtension.cpp
Generated on Thu Jan 27 18:50:12 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CCRDFile class Reference

クラス CCRDFile の解説

CRDMapperのFileクラス. [詳細]

#include <CRDFile.h>

CCRDFileに対する継承グラフ

[凡例]
CCRDFileのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

HRESULT | get_DateCreated (VARIANT *pVal)
作成日時の取得

HRESULT | put_DateCreated (VARIANT newVal)
作成日時の設定

HRESULT | get_DateLastAccessed (VARIANT *pVal)
最終アクセス日時の取得

HRESULT | put_DateLastAccessed (VARIANT newVal)
最終アクセス日時の設定

HRESULT | get_DateLastModified (VARIANT *pVal)
最終更新日時の取得

HRESULT | put_DateLastModified (VARIANT newVal)
最終更新日時の設定

HRESULT | get_Path (BSTR *pVal)
パスの取得

HRESULT | put_Path (BSTR newVal)
パスの設定

HRESULT | get_Size (long *pVal)
サイズの取得

HRESULT | put_Size (long newVal)
サイズの設定

HRESULT | get_Type (BSTR *pVal)
タイプの取得

HRESULT | put_Type (BSTR newVal)
タイプの設定

HRESULT | get_Value (VARIANT *pVal)
ファイル内容の取得

HRESULT | put_Value (VARIANT newVal)
ファイルの設定

HRESULT | createFile (BSTR bstrName, ICRDFile **pVal)
ファイルの作成

HRESULT | removeFile (BSTR bstrName)
ファイルの削除

HRESULT | appendFile (ICRDFile *newFile)
ファイルの追加

HRESULT | get_FileNames (VARIANT *pVal)
ファイル名リストの取得

HRESULT | get_File (BSTR bstrName, ICRDFile **pVal)
ファイルの取得

HRESULT | createVariable (BSTR bstrName, ICRDVariable **pVal)
変数の作成

HRESULT | removeVariable (BSTR bstrName)
変数の削除

HRESULT | appendVariable (ICRDVariable *newVar)
変数の追加

HRESULT | get_VariableNames (VARIANT *pVal)
変数名リストの取得

HRESULT | get_Variable (BSTR bstrName, ICRDVariable **pVal)
変数の取得

HRESULT | clone (BSTR bstrDestName, ICRDFile **pVal)
ファイルのコピー

解説

CRDMapperのFileクラス.

  デュアルインターフェースを持つCOMのクラス．詳細はICRDFileを参照．
  CRDEngineクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  XMLファイルの<File>タグに対応する．

メソッドの解説

STDMETHODIMP CCRDFile::appendFile ( ICRDFile * newFile )

ファイルの追加

指定したファイルのノードを追加する．

引数:
newFile [in] 追加するファイルオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDFile::appendVariable ( ICRDVariable * newVar )

変数の追加

指定した変数のノードを追加する．

引数:
newVar [in] 追加する変数オブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDFile::clone | ( | BSTR | bstrDestName,
 |  | ICRDFile ** | pVal
 | ) |

ファイルのコピー

ファイルオブジェクトの複製を生成する．
ノードは新規に構成され，複製した時点ではドキュメントに追加されない．
CRDController::appencFile を使用し，適宜ドキュメントに追加すること．
ノードオブジェクトは，複製元のノードオブジェクトをディープコピーする．

引数:
bstrDestName | [in]複製オブジェクトのファイル名
pVal | [out]複製されたファイルオブジェクト

STDMETHODIMP CCRDFile::createFile | ( | BSTR | bstrName,
 |  | ICRDFile ** | pVal
 | ) |

ファイルの作成

指定した名前のファイルノードを追加する．
以下のようなノードを構成する．

<File name=[extension_name]/>

引数:
bstrName | [in] ファイル名
pVal | [out]新しく生成したCRDFileオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDFile::createVariable | ( | BSTR | bstrName,
 |  | ICRDVariable ** | pVal
 | ) |

変数の作成

指定した名前の変数ノードを追加する．
以下のようなノードを構成する．

<Variable name=[variable_name]/>

引数:
bstrName | [in] 変数名
pVal | [out]新しく生成したCRDVariableオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDFile::get_DateCreated ( VARIANT * pVal )

作成日時の取得

CRDFile オブジェクトの作成日時情報を取得する．
CRDFile ノード以下の<DataCreated>タグを探す．

引数:
pVal [out] 作成日時情報を格納するVARIANTへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDFile::get_DateLastAccessed ( VARIANT * pVal )

最終アクセス日時の取得

CRDFile オブジェクトの最終アクセス日時情報を取得する．
CRDFile ノード以下の<DateLastAccessed>タグを探す．

引数:
pVal [out] 最終アクセス日時を格納するVARIANTへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDFile::get_DateLastModified ( VARIANT * pVal )

最終更新日時の取得

CRDFile オブジェクトの最終更新日時情報を取得する．
CRDFile ノード以下の<DateLastModified>タグを探す．

引数:
pVal [out] 最終更新日時を格納するVARIANTへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDFile::get_File | ( | BSTR | bstrName,
 |  | ICRDFile ** | pVal
 | ) |

ファイルの取得

指定した名前のファイルノードを取得する．
ICRDFile オブジェクトを返す．

引数:
bstrName | [in]ファイル名
pVal | [out]ICRDFile IFポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDFile::get_FileNames ( VARIANT * pVal )

ファイル名リストの取得

ファイルノードの名前一覧を取得する．

引数:
pVal [out]名前の一覧(VT_ARRAY|VT_BSTR)
戻り値:
HRESULT

STDMETHODIMP CCRDFile::get_Path ( BSTR * pVal )

パスの取得

CRDFile オブジェクトのパス情報を取得する．
CRDFile ノード以下の<Path>タグを探す．

引数:
pVal [out] パスを格納するBSTRへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDFile::get_Size ( long * pVal )

サイズの取得

CRDFile オブジェクトのファイルサイズ情報を取得する．
CRDFile ノード以下の<Size>タグを探す．

引数:
pVal [out] ファイルサイズを格納するlongへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDFile::get_Type ( BSTR * pVal )

タイプの取得

CRDFile オブジェクトのファイルタイプ情報を取得する．
CRDFile ノード以下の<Type>タグを探す．

引数:
pVal [out] ファイルタイプを格納するBSTRへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDFile::get_Value ( VARIANT * pVal )

ファイル内容の取得

CRDFile オブジェクトのファイル内容情報を取得する．
CRDFile ノード以下の<Value>タグを探す．

引数:
pVal [out] 変数値情報を格納するVARIANTへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDFile::get_Variable | ( | BSTR | bstrName,
 |  | ICRDVariable ** | pVal
 | ) |

変数の取得

指定した名前の変数ノードを取得する．
ICRDVariable オブジェクトを返す．

引数:
bstrName | [in]変数名
pVal | [out]ICRDVariable IFポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDFile::get_VariableNames ( VARIANT * pVal )

変数名リストの取得

変数ノードの名前一覧を取得する．

引数:
pVal [out]名前の一覧(VT_ARRAY|VT_BSTR)
戻り値:
HRESULT

STDMETHODIMP CCRDFile::put_DateCreated ( VARIANT newVal )

作成日時の設定

CRDFile オブジェクトの作成日時情報を設定する．
CRDFile ノード以下の<DataCreated>タグに値をセットする．
もしノード以下に<DataCreated>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] 作成日時
戻り値:
HRESULT

STDMETHODIMP CCRDFile::put_DateLastAccessed ( VARIANT newVal )

最終アクセス日時の設定

CRDFile オブジェクトの最終アクセス日時情報を設定する．
CRDFile ノード以下の<DateLastAccessed>タグに値をセットする．
もしノード以下に<DateLastAccessed>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] 最終アクセス日時
戻り値:
HRESULT

STDMETHODIMP CCRDFile::put_DateLastModified ( VARIANT newVal )

最終更新日時の設定

CRDFile オブジェクトの最終更新日時情報を設定する．
CRDFile ノード以下の<DateLastModified>タグに値をセットする．
もしノード以下に<DateLastModified>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] 最終更新日時
戻り値:
HRESULT

STDMETHODIMP CCRDFile::put_Path ( BSTR newVal )

パスの設定

CRDFile オブジェクトのパス名を設定する．
CRDFile ノード以下の<Path>タグに値をセットする．
もしノード以下に<Path>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] パス
戻り値:
HRESULT

STDMETHODIMP CCRDFile::put_Size ( long newVal )

サイズの設定

CRDFile オブジェクトのファイルサイズ情報を設定する．
CRDFile ノード以下の<Size>タグに値をセットする．
もしノード以下に<Size>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] ファイルサイズ
戻り値:
HRESULT

STDMETHODIMP CCRDFile::put_Type ( BSTR newVal )

タイプの設定

CRDFile オブジェクトのファイルタイプ情報を設定する．
CRDFile ノード以下の<Type>タグに値をセットする．
もしノード以下に<Type>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] ファイルタイプ
戻り値:
HRESULT

STDMETHODIMP CCRDFile::put_Value ( VARIANT newVal )

ファイルの設定

CRDFile オブジェクトのファイル内容情報を設定する．
CRDFile ノード以下の<Value>タグに値をセットする．
もしノード以下に<Value>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] 変数値
戻り値:
HRESULT

STDMETHODIMP CCRDFile::removeFile ( BSTR bstrName )

ファイルの削除

指定した名前のファイルノードを削除する．
インスタンスは削除されますが，saveメソッドを実行するまでディスクには 反映されない．

引数:
bstrName [in] ファイル名
戻り値:
HRESULT

STDMETHODIMP CCRDFile::removeVariable ( BSTR bstrName )

変数の削除

指定した名前の変数ノードを削除する．
インスタンスは削除されますが，saveメソッドを実行するまでディスクには 反映されない．

引数:
bstrName [in] 変数名
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CRDFile.h
  • CRDFile.cpp
Generated on Thu Jan 27 18:50:12 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CCRDMessage class Reference

クラス CCRDMessage の解説

CRDMapperのMessageクラス. [詳細]

#include <CRDMessage.h>

CCRDMessageに対する継承グラフ

[凡例]
CCRDMessageのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | get_Number (long *pVal)
HRESULT | get_DateTime (VARIANT *pVal)
タイムスタンプの取得

HRESULT | put_DateTime (VARIANT newVal)
タイムスタンプの設定

HRESULT | get_Description (BSTR *pVal)
説明文の取得

HRESULT | put_Description (BSTR newVal)
説明文の設定

HRESULT | get_Destination (BSTR *pVal)
送り先の取得

HRESULT | put_Destination (BSTR newVal)
送り先の設定

HRESULT | get_Source (BSTR *pVal)
送り元の取得

HRESULT | put_Source (BSTR newVal)
送り元の設定

HRESULT | get_Value (VARIANT *pVal)
変数値の取得

HRESULT | put_Value (VARIANT newVal)
変数値の設定

HRESULT | get_ID (VARIANT *pVal)
IDの取得.

HRESULT | put_ID (VARIANT newVal)
IDの設定.

HRESULT | get_XMLNode (IUnknown **pVal)
ノードオブジェクトの取得

HRESULT | clone (long lNumber, ICRDMessage **pVal)
メッセージのコピー

HRESULT | _Initialize (IXMLDOMNode *pINode)
オブジェクトの初期化

解説

CRDMapperのMessageクラス.

  デュアルインターフェースを持つCOMのクラス．詳細はICRDMessageを参照．
  CRDEngineクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  XMLファイルの<Message>タグに対応する．

メソッドの解説

HRESULT CCRDMessage::_Initialize ( IXMLDOMNode * pINode )

オブジェクトの初期化

オブジェクトの初期化をする．
CRDNode テンプレートを継承するクラスはXMLノードを保持する．

引数:
pINode [in] XMLノードオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDMessage::clone | ( | long | lNumber,
 |  | ICRDMessage ** | pVal
 | ) |

メッセージのコピー

メッセージオブジェクトの複製を生成する．
ノードは新規に構成され，複製した時点ではドキュメントに追加されない． 各クラスのappencMessage を使用し，適宜ドキュメントに追加すること．
ノードオブジェクトは，複製元のノードオブジェクトをディープコピーする．

引数:
bstrDestName | [in]複製オブジェクトのメッセージ名
pVal | [out]複製されたメッセージオブジェクト

STDMETHODIMP CCRDMessage::get_DateTime ( VARIANT * pVal )

タイムスタンプの取得

CRDMessage オブジェクトの時刻データ情報を取得する．
CRDMessage ノード以下の<DateTime>タグを探する．

引数:
pVal [out] 時刻データ情報を格納するVARIANTへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDMessage::get_Description ( BSTR * pVal )

説明文の取得

CRDMessage オブジェクトの説明文を取得する．
CRDMessage ノード以下の<Description>タグを探する．

引数:
pVal [out] 説明文情報を格納するVARIANTへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDMessage::get_Destination ( BSTR * pVal )

送り先の取得

CRDMessage オブジェクトの送り先を取得する．
CRDMessage ノード以下の<Destination>タグを探する．

引数:
pVal [out] 送り先情報を格納するVARIANTへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDMessage::get_ID ( VARIANT * pVal )

IDの取得.

CRDMessage オブジェクトのID情報を取得する．
CRDMessage ノード以下の<ID>タグを探す．

引数:
pVal [out] ID情報を格納するVARIANTへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDMessage::get_Number ( long * pVal )

STDMETHODIMP CCRDMessage::get_Source ( BSTR * pVal )

送り元の取得

CRDMessage オブジェクトの送り元を取得する．
CRDMessage ノード以下の<Source>タグを探する．

引数:
pVal [out] 送り元情報を格納するVARIANTへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDMessage::get_Value ( VARIANT * pVal )

変数値の取得

CRDMessage オブジェクトの変数値情報を取得する．
CRDMessage ノード以下の<Value>タグを探す．

引数:
pVal [out] 変数値情報を格納するVARIANTへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDMessage::get_XMLNode ( IUnknown ** pVal )

ノードオブジェクトの取得

CRDNode のノード位置を示すオブジェクトを取得する．
このメソッドは外部から実行することを推奨ない．[restricted]

引数:
pVal [out]ノードオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDMessage::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

riid に指定されたインターフェイスが IErrorInfo インターフェース をサポートするかどうかを示す．

引数:
riid [in] インタフェース
戻り値:
HRESULT

STDMETHODIMP CCRDMessage::put_DateTime ( VARIANT newVal )

タイムスタンプの設定

CRDMessage オブジェクトの時刻データ情報を設定する．
CRDMessage ノード以下の<DateTime>タグに値をセットする．
もしノード以下に<DateTime>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] 時刻データ
戻り値:
HRESULT

STDMETHODIMP CCRDMessage::put_Description ( BSTR newVal )

説明文の設定

CRDMessage オブジェクトの説明文を設定する．
CRDMessage ノード以下の<Description>タグに値をセットする．
もしノード以下に<Description>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] 説明文
戻り値:
HRESULT

STDMETHODIMP CCRDMessage::put_Destination ( BSTR newVal )

送り先の設定

CRDMessage オブジェクトの送り先を設定する．
CRDMessage ノード以下の<Destination>タグに値をセットする．
もしノード以下に<Destination>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] 送り先
戻り値:
HRESULT

STDMETHODIMP CCRDMessage::put_ID ( VARIANT newVal )

IDの設定.

CRDMessage オブジェクトのID情報を設定する．
CRDMessage ノード以下の<ID>タグに値をセットする．
もしノード以下に<ID>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] ID
戻り値:
HRESULT

STDMETHODIMP CCRDMessage::put_Source ( BSTR newVal )

送り元の設定

CRDMessage オブジェクトの送り元を設定する．
CRDMessage ノード以下の<Source>タグに値をセットする．
もしノード以下に<Source>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] 送り元
戻り値:
HRESULT

STDMETHODIMP CCRDMessage::put_Value ( VARIANT newVal )

変数値の設定

CRDMessage オブジェクトの変数値情報を設定する．
CRDMessage ノード以下の<Value>タグに値をセットする．
もしノード以下に<Value>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] 変数値
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CRDMessage.h
  • CRDMessage.cpp
Generated on Thu Jan 27 18:50:12 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CCRDRobot class Reference

クラス CCRDRobot の解説

CRDMapperのRobotクラス. [詳細]

#include <CRDRobot.h>

CCRDRobotに対する継承グラフ

[凡例]
CCRDRobotのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

HRESULT | createVariable (BSTR bstrName, ICRDVariable **pVal)
変数の作成

HRESULT | removeVariable (BSTR bstrName)
変数の削除

HRESULT | appendVariable (ICRDVariable *newVar)
変数の追加

HRESULT | get_VariableNames (VARIANT *pVal)
変数名リストの取得

HRESULT | get_Variable (BSTR bstrName, ICRDVariable **pVal)
変数の取得

HRESULT | clone (BSTR bstrDestName, ICRDRobot **pVal)
ロボットのコピー

解説

CRDMapperのRobotクラス.

  デュアルインターフェースを持つCOMのクラス．詳細はICRDRobotを参照．
  CRDEngineクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  XMLファイルの<Robot>タグに対応する．

メソッドの解説

STDMETHODIMP CCRDRobot::appendVariable ( ICRDVariable * newVar )

変数の追加

指定した変数のノードを追加する．

引数:
newVar [in] 追加する変数オブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDRobot::clone | ( | BSTR | bstrDestName,
 |  | ICRDRobot ** | pVal
 | ) |

ロボットのコピー

ロボットオブジェクトの複製を生成する．
ノードは新規に構成され，複製した時点ではドキュメントに追加されない．
CRDController::appencRobot を使用し，適宜ドキュメントに追加すること．
ノードオブジェクトは，複製元のノードオブジェクトをディープコピーする．

引数:
bstrDestName | [in]複製オブジェクトのロボット名
pVal | [out]複製されたロボットオブジェクト

STDMETHODIMP CCRDRobot::createVariable | ( | BSTR | bstrName,
 |  | ICRDVariable ** | pVal
 | ) |

変数の作成

指定した名前の変数ノードを追加する．
以下のようなノードを構成する．

<Variable name=[variable_name]/>

引数:
bstrName | [in] 変数名
pVal | [out]新しく生成したCRDVariableオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDRobot::get_Variable | ( | BSTR | bstrName,
 |  | ICRDVariable ** | pVal
 | ) |

変数の取得

指定した名前の変数ノードを取得する．
ICRDVariable オブジェクトを返す．

引数:
bstrName | [in]変数名
pVal | [out]ICRDVariable IFポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDRobot::get_VariableNames ( VARIANT * pVal )

変数名リストの取得

変数ノードの名前一覧を取得する．

引数:
pVal [out]名前の一覧(VT_ARRAY|VT_BSTR)
戻り値:
HRESULT

STDMETHODIMP CCRDRobot::removeVariable ( BSTR bstrName )

変数の削除

指定した名前の変数ノードを削除する．
インスタンスは削除されますが，saveメソッドを実行するまでディスクには 反映されない．

引数:
bstrName [in] 変数名
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CRDRobot.h
  • CRDRobot.cpp
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CCRDTask class Reference

クラス CCRDTask の解説

CRDMapperのTaskクラス. [詳細]

#include <CRDTask.h>

CCRDTaskに対する継承グラフ

[凡例]
CCRDTaskのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

HRESULT | get_FileName (BSTR *pVal)
対応ファイル名の取得

HRESULT | put_FileName (BSTR newVal)
対応ファイル名の設定

HRESULT | createVariable (BSTR bstrName, ICRDVariable **pVal)
変数の作成

HRESULT | removeVariable (BSTR bstrName)
変数の削除

HRESULT | appendVariable (ICRDVariable *newVar)
変数の追加

HRESULT | get_VariableNames (VARIANT *pVal)
変数名リストの取得

HRESULT | get_Variable (BSTR bstrName, ICRDVariable **pVal)
変数の取得

HRESULT | clone (BSTR bstrDestName, ICRDTask **pVal)
タスクのコピー

解説

CRDMapperのTaskクラス.

  デュアルインターフェースを持つCOMのクラス．詳細はICRDTaskを参照．
  CRDEngineクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  XMLファイルの<Task>タグに対応する．

メソッドの解説

STDMETHODIMP CCRDTask::appendVariable ( ICRDVariable * newVar )

変数の追加

指定した変数のノードを追加する．

引数:
newVar [in] 追加する変数オブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDTask::clone | ( | BSTR | bstrDestName,
 |  | ICRDTask ** | pVal
 | ) |

タスクのコピー

タスクオブジェクトの複製を生成する．
ノードは新規に構成され，複製した時点ではドキュメントに追加されない．
CRDController::appencTask を使用し，適宜ドキュメントに追加すること．
ノードオブジェクトは，複製元のノードオブジェクトをディープコピーする．

引数:
bstrDestName | [in]複製オブジェクトのタスク名
pVal | [out]複製されたタスクオブジェクト

STDMETHODIMP CCRDTask::createVariable | ( | BSTR | bstrName,
 |  | ICRDVariable ** | pVal
 | ) |

変数の作成

指定した名前の変数ノードを追加する．
以下のようなノードを構成する．

<Variable name=[variable_name]/>

引数:
bstrName | [in] 変数名
pVal | [out]新しく生成したCRDVariableオブジェクト
戻り値:
HRESULT

STDMETHODIMP CCRDTask::get_FileName ( BSTR * pVal )

対応ファイル名の取得

CRDTask オブジェクトの対応ファイル名情報を取得する．
CRDTask ノード以下の<FileName>タグを探す．

引数:
pVal [out] 対応ファイル名情報を格納するVARIANTへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDTask::get_Variable | ( | BSTR | bstrName,
 |  | ICRDVariable ** | pVal
 | ) |

変数の取得

指定した名前の変数ノードを取得する．
ICRDVariable オブジェクトを返する．

引数:
bstrName | [in]変数名
pVal | [out]ICRDVariable IFポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDTask::get_VariableNames ( VARIANT * pVal )

変数名リストの取得

変数ノードの名前一覧を取得する．

引数:
pVal [out]名前の一覧(VT_ARRAY|VT_BSTR)
戻り値:
HRESULT

STDMETHODIMP CCRDTask::put_FileName ( BSTR newVal )

対応ファイル名の設定

CRDTask オブジェクトの対応ファイル名情報を設定する．
CRDTask ノード以下の<FileName>タグに値をセットする．
もしノード以下に<FileName>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] 対応ファイル名
戻り値:
HRESULT

STDMETHODIMP CCRDTask::removeVariable ( BSTR bstrName )

変数の削除

指定した名前の変数ノードを削除する．
インスタンスは削除されますが，saveメソッドを実行するまでディスクには 反映されない．

引数:
bstrName [in] 変数名
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CRDTask.h
  • CRDTask.cpp
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CCRDUtility class Reference

クラス CCRDUtility の解説

CRDMapperのUtilityクラス. [詳細]

#include <CRDUtility.h>

すべてのメンバ一覧

Public メソッド

CCRDUtility ()
virtual | ~CCRDUtility ()

Static Public メソッド

HRESULT | GetNodeAttribute (BSTR bstrName, IXMLDOMNode *pINode, VARTYPE Type, VARIANT *pVal)
属性値の取得

HRESULT | GetNodeValue (BSTR bstrName, IXMLDOMNode *pINode, VARTYPE Type, VARIANT *pVal)
ノードの値の取得

HRESULT | SetNodeValue (BSTR bstrName, IXMLDOMNode *pINode, VARIANT newVal)
ノードの値の設定

HRESULT | GetNodeVariant (BSTR bstrName, IXMLDOMNode *pINode, VARIANT *pVal)
VARIANT型ノードの値の取得.

HRESULT | CreateVariantNode (BSTR bstrName, VARIANT vntVal, IXMLDOMNode *pINode, IXMLDOMElement **pVal)
VARIANT型ノードの作成.

HRESULT | GetNamedNodeList (BSTR bstrElementName, IXMLDOMNode *pINode, VARIANT *pVal)
ノードの名前リストの取得

HRESULT | GetNumberNodeList (BSTR bstrElementName, IXMLDOMNode *pINode, VARIANT *pVal)
ノードの名前リストの取得

HRESULT | CreateElement (BSTR bstrElementName, IXMLDOMNode *pINode, IXMLDOMElement **pVal)
エレメントの作成

HRESULT | CreateElementWithNameAttr (BSTR bstrTagName, BSTR bstrName, IXMLDOMNode *pINode, IXMLDOMElement **ppVal)
名前属性つきエレメントの作成

HRESULT | CreateElementWithNumberAttr (BSTR bstrTagName, long lNumber, IXMLDOMNode *pINode, IXMLDOMElement **ppVal)
番号属性つきエレメントの作成

HRESULT | AddIndent (IXMLDOMNode *ElementNode, long lLevel, IXMLDOMDocument *pIXMLDoc)
インデントの追加

HRESULT | RemoveIndent (IXMLDOMNode *ElementNode)
インデントの削除

HRESULT | VariantTimeToISO8601 (DATE vntDate, BSTR *pVal)
日付の変換（DATE型→ISO8601）

解説

CRDMapperのUtilityクラス.

  CRDMapperで使用するメソッドを提供するクラスである．

コンストラクタとデストラクタの解説

CCRDUtility::CCRDUtility ( )

virtual CCRDUtility::~CCRDUtility ( ) [virtual]

メソッドの解説

HRESULT CCRDUtility::AddIndent | ( | IXMLDOMNode * | ElementNode,
 |  | long | lLevel,
 |  | IXMLDOMDocument * | pIXMLDoc
 | ) | [inline, static]

インデントの追加

指定したエレメントにインデントをつける．
子ノードの間に改行とタブのテキストノードを追加する．
タブの数はlLevel引数で決定する．

引数:
ElementNode | [in] 整形するエレメント
lLevel | [in] 指定したエレメントのネストレベル
pIXMLDoc | [in] 生成するドキュメントオブジェクト
戻り値:
HRESULT

HRESULT CCRDUtility::CreateElement | ( | BSTR | bstrElementName,
 |  | IXMLDOMNode * | pINode,
 |  | IXMLDOMElement ** | pVal
 | ) | [inline, static]

エレメントの作成

指定した名前のエレメントを生成する．
エレメントの生成に必要な IXMLDOMDocument を取得し，エレメントを生成する．

引数:
bstrElementName | [in] 生成したいエレメント名
pINode | [in] 同じドキュメントのノードオブジェクト
pVal | [out] 生成したエレメントオブジェクト
戻り値:
HRESULT

HRESULT CCRDUtility::CreateElementWithNameAttr | ( | BSTR | bstrTagName,
 |  | BSTR | bstrName,
 |  | IXMLDOMNode * | pINode,
 |  | IXMLDOMElement ** | ppVal
 | ) | [inline, static]

名前属性つきエレメントの作成

名前属性つきエレメントを生成する．
以下のようなノードを構成する．

<[TagName] name=[controller_name]/>

引数:
bstrTagName | [in] タグ名
bstrName | [in] Name属性値
pIXMLDoc | [in] 生成するドキュメントオブジェクト
pVal | [out] 生成した名前属性付きエレメント
戻り値:
HRESULT

HRESULT CCRDUtility::CreateElementWithNumberAttr | ( | BSTR | bstrTagName,
 |  | long | lNumber,
 |  | IXMLDOMNode * | pINode,
 |  | IXMLDOMElement ** | ppVal
 | ) | [inline, static]

番号属性つきエレメントの作成

名前属性つきエレメントを生成する．
以下のようなノードを構成する．

<[TagName] number=[controller_number]/>

引数:
bstrTagName | [in] タグ名
lNumber | [in] number属性値
pIXMLDoc | [in] 生成するドキュメントオブジェクト
pVal | [out] 生成した名前属性付きエレメント
戻り値:
HRESULT

HRESULT CCRDUtility::CreateVariantNode | ( | BSTR | bstrName,
 |  | VARIANT | vntVal,
 |  | IXMLDOMNode * | pINode,
 |  | IXMLDOMElement ** | pVal
 | ) | [inline, static]

VARIANT型ノードの作成.

名前のノードを作成して，値を設定する．
ノードの構造はVariant型である．

引数:
bstrName | [in] ノード名
vntVal | [in] ノードに入れる値
pINode | [in] 親ノードオブジェクト
pVal | [out] 作成したVariantのノード
戻り値:
HRESULT

HRESULT CCRDUtility::GetNamedNodeList | ( | BSTR | bstrElementName,
 |  | IXMLDOMNode * | pINode,
 |  | VARIANT * | pVal
 | ) | [inline, static]

ノードの名前リストの取得

指定したエレメントが持つ"name"属性の一覧を返する．

引数:
bstrElementName | [in]対象となるノードエレメント名
pINode | [in]検索対象となる親ノード
pVal | [out]名前一覧を返す．(VT_ARRAY|VT_BSTR)
戻り値:
HRESULT

HRESULT CCRDUtility::GetNodeAttribute | ( | BSTR | bstrName,
 |  | IXMLDOMNode * | pINode,
 |  | VARTYPE | Type,
 |  | VARIANT * | pVal
 | ) | [inline, static]

属性値の取得

指定したノードの指定した属性値を取得する．

引数:
bstrName | [in]属性名
pINode | [in]属性を調べるノード
Type | [in]取得するデータ型
pVal | [out]Variableの値
戻り値:
HRESULT

HRESULT CCRDUtility::GetNodeValue | ( | BSTR | bstrName,
 |  | IXMLDOMNode * | pINode,
 |  | VARTYPE | Type,
 |  | VARIANT * | pVal
 | ) | [inline, static]

ノードの値の取得

名前から適合するノードの値を取得する．
同条件のノードが複数ある場合IXMLDOMNode::selectSingleNodeにより適合する最初 のノードから値を取得する．

引数:
bstrName | [in] 値を取得するノード名
pINode | [in] 親ノード
Type | [in] データ型
pVal | [out] 値
戻り値:
HRESULT

HRESULT CCRDUtility::GetNodeVariant | ( | BSTR | bstrName,
 |  | IXMLDOMNode * | pINode,
 |  | VARIANT * | pVal
 | ) | [inline, static]

VARIANT型ノードの値の取得.

指定したノードの値を取得する．
ノードの型がVARIANTの構造であることを前提としてチェックする．
同条件のノードが複数ある場合IXMLDOMNode::selectSingleNodeにより適合する最初 のノードから値を取得する．

引数:
bstrName | [in] ノード名
pINode | [in] 親ノード
pVal | [out] 値
戻り値:
HRESULT

HRESULT CCRDUtility::GetNumberNodeList | ( | BSTR | bstrElementName,
 |  | IXMLDOMNode * | pINode,
 |  | VARIANT * | pVal
 | ) | [inline, static]

ノードの名前リストの取得

指定したエレメントが持つ"Number"属性の一覧を返する．

引数:
bstrElementName | [in]対象となるノードエレメント名
pINode | [in]検索対象となる親ノード
pVal | [out]名前一覧を返す．(VT_ARRAY|VT_I4)
戻り値:
HRESULT

HRESULT CCRDUtility::RemoveIndent ( IXMLDOMNode * ElementNode ) [inline, static]

インデントの削除

指定したエレメントにインデントを解除する．
子ノードの間にある改行とタブのテキストノードを削除する．
タブの数はlLevel引数で決定する．

引数:
ElementNode [in] 整形するエレメント
戻り値:
HRESULT

HRESULT CCRDUtility::SetNodeValue | ( | BSTR | bstrName,
 |  | IXMLDOMNode * | pINode,
 |  | VARIANT | newVal
 | ) | [inline, static]

ノードの値の設定

名前から適合するノードに値を設定する．
同条件のノードが複数ある場合IXMLDOMNode::selectSingleNodeにより適合する最初 のノードから値を取得する．

引数:
bstrName | [in] 値を取得するノード名
pINode | [in] 親ノード
newVal | [in] 設定値
戻り値:
HRESULT

HRESULT CCRDUtility::VariantTimeToISO8601 | ( | DATE | vntDate,
 |  | BSTR * | pVal
 | ) | [inline, static]

日付の変換（DATE型→ISO8601）

Variantの日付型をISO8601形式の日付文字列に変換する．

引数:
vntDate | [in] DATE型の日付
pVal | [out] ISO8601の日付
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CRDUtility.h
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CCRDVariable class Reference

クラス CCRDVariable の解説

CRDMapperのVariableクラス. [詳細]

#include <CRDVariable.h>

CCRDVariableに対する継承グラフ

[凡例]
CCRDVariableのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

HRESULT | get_DateTime (VARIANT *pVal)
タイムスタンプの取得

HRESULT | put_DateTime (VARIANT newVal)
タイムスタンプの設定

HRESULT | get_Value (VARIANT *pVal)
変数値の取得

HRESULT | put_Value (VARIANT newVal)
変数値の設定

HRESULT | get_Microsecond (long *pVal)
サイズの取得

HRESULT | put_Microsecond (long newVal)
サイズの設定

HRESULT | clone (BSTR bstrDestName, ICRDVariable **pVal)
変数のコピー

解説

CRDMapperのVariableクラス.

  デュアルインターフェースを持つCOMのクラス．詳細はICRDVariableを参照．
  CRDEngineクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  XMLファイルの<Variable>タグに対応する．

メソッドの解説

STDMETHODIMP CCRDVariable::clone | ( | BSTR | bstrDestName,
 |  | ICRDVariable ** | pVal
 | ) |

変数のコピー

変数オブジェクトの複製を生成する．
ノードは新規に構成され，複製した時点ではドキュメントに追加されない． 各クラスのappencVariable を使用し，適宜ドキュメントに追加すること．
ノードオブジェクトは，複製元のノードオブジェクトをディープコピーする．

引数:
bstrDestName | [in]複製オブジェクトの変数名
pVal | [out]複製された変数オブジェクト

STDMETHODIMP CCRDVariable::get_DateTime ( VARIANT * pVal )

タイムスタンプの取得

CRDVariable オブジェクトの時刻データ情報を取得する．
CRDVariable ノード以下の<DateTime>タグを探する．

引数:
pVal [out] 時刻データ情報を格納するVARIANTへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDVariable::get_Microsecond ( long * pVal )

サイズの取得

CRDVariable オブジェクトのマイクロ秒タイムスタンプ情報を取得する．
CRDVariable ノード以下の<Microsecond>タグを探す．

引数:
pVal [out] マイクロ秒タイムスタンプを格納するlongへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDVariable::get_Value ( VARIANT * pVal )

変数値の取得

CRDVariable オブジェクトの変数値情報を取得する．
CRDVariable ノード以下の<Value>タグを探す．

引数:
pVal [out] 変数値情報を格納するVARIANTへのポインタ
戻り値:
HRESULT

STDMETHODIMP CCRDVariable::put_DateTime ( VARIANT newVal )

タイムスタンプの設定

CRDVariable オブジェクトの時刻データ情報を設定する．
CRDVariable ノード以下の<DateTime>タグに値をセットする．
もしノード以下に<DateTime>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] 時刻データ
戻り値:
HRESULT

STDMETHODIMP CCRDVariable::put_Microsecond ( long newVal )

サイズの設定

CRDFile オブジェクトのファイルサイズ情報を設定する．
CRDFile ノード以下の<Size>タグに値をセットする．
もしノード以下に<Size>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] ファイルサイズ
戻り値:
HRESULT

STDMETHODIMP CCRDVariable::put_Value ( VARIANT newVal )

変数値の設定

CRDVariable オブジェクトの変数値情報を設定する．
CRDVariable ノード以下の<Value>タグに値をセットする．
もしノード以下に<Value>タグが無い場合は新規に作成し，セットする．

引数:
newVal [out] 変数値
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CRDVariable.h
  • CRDVariable.cpp
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMAPPERLib::CRDCommand class Reference

クラス CRDMAPPERLib::CRDCommand の解説

import "CRDMapper.idl";

このクラスの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:15 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMAPPERLib::CRDController class Reference

クラス CRDMAPPERLib::CRDController の解説

import "CRDMapper.idl";

このクラスの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:15 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMAPPERLib::CRDEngine class Reference

クラス CRDMAPPERLib::CRDEngine の解説

import "CRDMapper.idl";

このクラスの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:15 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMAPPERLib::CRDExtension class Reference

クラス CRDMAPPERLib::CRDExtension の解説

import "CRDMapper.idl";

このクラスの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:15 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMAPPERLib::CRDFile class Reference

クラス CRDMAPPERLib::CRDFile の解説

import "CRDMapper.idl";

このクラスの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:15 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMAPPERLib::CRDMessage class Reference

クラス CRDMAPPERLib::CRDMessage の解説

import "CRDMapper.idl";

このクラスの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:15 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMAPPERLib::CRDRobot class Reference

クラス CRDMAPPERLib::CRDRobot の解説

import "CRDMapper.idl";

このクラスの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:15 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMAPPERLib::CRDTask class Reference

クラス CRDMAPPERLib::CRDTask の解説

import "CRDMapper.idl";

このクラスの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:15 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMAPPERLib::CRDVariable class Reference

クラス CRDMAPPERLib::CRDVariable の解説

import "CRDMapper.idl";

このクラスの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:15 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


ICRDCommand interface Reference

インタフェースICRDCommand の解説

import "CRDMapper.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | Name ([out, retval] BSTR *pVal)
HRESULT | Attribute ([out, retval] long *pVal)
HRESULT | Attribute ([in] long newVal)
HRESULT | Help ([out, retval] BSTR *pVal)
HRESULT | Help ([in] BSTR newVal)
HRESULT | State ([out, retval] long *pVal)
HRESULT | State ([in] long newVal)
HRESULT | Timeout ([out, retval] long *pVal)
HRESULT | Timeout ([in] long newVal)
HRESULT | Parameters ([out, retval] VARIANT *pVal)
HRESULT | Parameters ([in] VARIANT newVal)
HRESULT | ID ([out, retval] VARIANT *pVal)
HRESULT | ID ([in] VARIANT newVal)
HRESULT | XMLNode ([out, retval] IUnknown **pVal)
HRESULT | clone ([in] BSTR bstrDestName,[out, retval] ICRDCommand **pVal)

メソッドの解説

HRESULT ICRDCommand::Attribute ( [in] long newVal )

HRESULT ICRDCommand::Attribute ( [out, retval] long * pVal )

HRESULT ICRDCommand::clone | ( | [in] BSTR | bstrDestName,
 |  | [out, retval] ICRDCommand ** | pVal
 | ) |

HRESULT ICRDCommand::Help ( [in] BSTR newVal )

HRESULT ICRDCommand::Help ( [out, retval] BSTR * pVal )

HRESULT ICRDCommand::ID ( [in] VARIANT newVal )

HRESULT ICRDCommand::ID ( [out, retval] VARIANT * pVal )

HRESULT ICRDCommand::Name ( [out, retval] BSTR * pVal )

HRESULT ICRDCommand::Parameters ( [in] VARIANT newVal )

HRESULT ICRDCommand::Parameters ( [out, retval] VARIANT * pVal )

HRESULT ICRDCommand::State ( [in] long newVal )

HRESULT ICRDCommand::State ( [out, retval] long * pVal )

HRESULT ICRDCommand::Timeout ( [in] long newVal )

HRESULT ICRDCommand::Timeout ( [out, retval] long * pVal )

HRESULT ICRDCommand::XMLNode ( [out, retval] IUnknown ** pVal )

このインタフェースの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


ICRDController interface Reference

インタフェースICRDController の解説

import "CRDMapper.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | Name ([out, retval] BSTR *pVal)
HRESULT | Attribute ([out, retval] long *pVal)
HRESULT | Attribute ([in] long newVal)
HRESULT | Help ([out, retval] BSTR *pVal)
HRESULT | Help ([in] BSTR newVal)
HRESULT | ID ([out, retval] VARIANT *pVal)
HRESULT | ID ([in] VARIANT newVal)
HRESULT | XMLNode ([out, retval] IUnknown **pVal)
HRESULT | createExtension ([in] BSTR bstrName,[out, retval] ICRDExtension **pVal)
HRESULT | removeExtension ([in] BSTR bstrName)
HRESULT | appendExtension ([in] ICRDExtension *newExt)
HRESULT | ExtensionNames ([out, retval] VARIANT *pVal)
HRESULT | Extension (BSTR bstrName,[out, retval] ICRDExtension **pVal)
HRESULT | createFile ([in] BSTR bstrName,[out, retval] ICRDFile **pVal)
HRESULT | removeFile ([in] BSTR bstrName)
HRESULT | appendFile ([in] ICRDFile *newFile)
HRESULT | FileNames ([out, retval] VARIANT *pVal)
HRESULT | File (BSTR bstrName,[out, retval] ICRDFile **pVal)
HRESULT | createRobot ([in] BSTR bstrName,[out, retval] ICRDRobot **pVal)
HRESULT | removeRobot ([in] BSTR bstrName)
HRESULT | appendRobot ([in] ICRDRobot *newRobot)
HRESULT | RobotNames ([out, retval] VARIANT *pVal)
HRESULT | Robot (BSTR bstrName,[out, retval] ICRDRobot **pVal)
HRESULT | createTask ([in] BSTR bstrName,[out, retval] ICRDTask **pVal)
HRESULT | removeTask ([in] BSTR bstrName)
HRESULT | appendTask ([in] ICRDTask *newTask)
HRESULT | TaskNames ([out, retval] VARIANT *pVal)
HRESULT | Task (BSTR bstrName,[out, retval] ICRDTask **pVal)
HRESULT | createVariable ([in] BSTR bstrName,[out, retval] ICRDVariable **pVal)
HRESULT | removeVariable ([in] BSTR bstrName)
HRESULT | appendVariable ([in] ICRDVariable *newVar)
HRESULT | VariableNames ([out, retval] VARIANT *pVal)
HRESULT | Variable (BSTR bstrName,[out, retval] ICRDVariable **pVal)
HRESULT | createCommand ([in] BSTR bstrName,[out, retval] ICRDCommand **pVal)
HRESULT | removeCommand ([in] BSTR bstrName)
HRESULT | appendCommand ([in] ICRDCommand *newCmd)
HRESULT | CommandNames ([out, retval] VARIANT *pVal)
HRESULT | Command (BSTR bstrName,[out, retval] ICRDCommand **pVal)
HRESULT | createMessage ([in] long lNumber,[out, retval] ICRDMessage **pVal)
HRESULT | removeMessage ([in] long lNumber)
HRESULT | appendMessage ([in] ICRDMessage *newMsg)
HRESULT | MessageNumbers ([out, retval] VARIANT *pVal)
HRESULT | Message (long lNumber,[out, retval] ICRDMessage **pVal)
HRESULT | clone ([in] BSTR bstrDestName,[out, retval] ICRDController **pVal)

メソッドの解説

HRESULT ICRDController::appendCommand ( [in] ICRDCommand * newCmd )

HRESULT ICRDController::appendExtension ( [in] ICRDExtension * newExt )

HRESULT ICRDController::appendFile ( [in] ICRDFile * newFile )

HRESULT ICRDController::appendMessage ( [in] ICRDMessage * newMsg )

HRESULT ICRDController::appendRobot ( [in] ICRDRobot * newRobot )

HRESULT ICRDController::appendTask ( [in] ICRDTask * newTask )

HRESULT ICRDController::appendVariable ( [in] ICRDVariable * newVar )

HRESULT ICRDController::Attribute ( [in] long newVal )

HRESULT ICRDController::Attribute ( [out, retval] long * pVal )

HRESULT ICRDController::clone | ( | [in] BSTR | bstrDestName,
 |  | [out, retval] ICRDController ** | pVal
 | ) |

HRESULT ICRDController::Command | ( | BSTR | bstrName,
 |  | [out, retval] ICRDCommand ** | pVal
 | ) |

HRESULT ICRDController::CommandNames ( [out, retval] VARIANT * pVal )

HRESULT ICRDController::createCommand | ( | [in] BSTR | bstrName,
 |  | [out, retval] ICRDCommand ** | pVal
 | ) |

HRESULT ICRDController::createExtension | ( | [in] BSTR | bstrName,
 |  | [out, retval] ICRDExtension ** | pVal
 | ) |

HRESULT ICRDController::createFile | ( | [in] BSTR | bstrName,
 |  | [out, retval] ICRDFile ** | pVal
 | ) |

HRESULT ICRDController::createMessage | ( | [in] long | lNumber,
 |  | [out, retval] ICRDMessage ** | pVal
 | ) |

HRESULT ICRDController::createRobot | ( | [in] BSTR | bstrName,
 |  | [out, retval] ICRDRobot ** | pVal
 | ) |

HRESULT ICRDController::createTask | ( | [in] BSTR | bstrName,
 |  | [out, retval] ICRDTask ** | pVal
 | ) |

HRESULT ICRDController::createVariable | ( | [in] BSTR | bstrName,
 |  | [out, retval] ICRDVariable ** | pVal
 | ) |

HRESULT ICRDController::Extension | ( | BSTR | bstrName,
 |  | [out, retval] ICRDExtension ** | pVal
 | ) |

HRESULT ICRDController::ExtensionNames ( [out, retval] VARIANT * pVal )

HRESULT ICRDController::File | ( | BSTR | bstrName,
 |  | [out, retval] ICRDFile ** | pVal
 | ) |

HRESULT ICRDController::FileNames ( [out, retval] VARIANT * pVal )

HRESULT ICRDController::Help ( [in] BSTR newVal )

HRESULT ICRDController::Help ( [out, retval] BSTR * pVal )

HRESULT ICRDController::ID ( [in] VARIANT newVal )

HRESULT ICRDController::ID ( [out, retval] VARIANT * pVal )

HRESULT ICRDController::Message | ( | long | lNumber,
 |  | [out, retval] ICRDMessage ** | pVal
 | ) |

HRESULT ICRDController::MessageNumbers ( [out, retval] VARIANT * pVal )

HRESULT ICRDController::Name ( [out, retval] BSTR * pVal )

HRESULT ICRDController::removeCommand ( [in] BSTR bstrName )

HRESULT ICRDController::removeExtension ( [in] BSTR bstrName )

HRESULT ICRDController::removeFile ( [in] BSTR bstrName )

HRESULT ICRDController::removeMessage ( [in] long lNumber )

HRESULT ICRDController::removeRobot ( [in] BSTR bstrName )

HRESULT ICRDController::removeTask ( [in] BSTR bstrName )

HRESULT ICRDController::removeVariable ( [in] BSTR bstrName )

HRESULT ICRDController::Robot | ( | BSTR | bstrName,
 |  | [out, retval] ICRDRobot ** | pVal
 | ) |

HRESULT ICRDController::RobotNames ( [out, retval] VARIANT * pVal )

HRESULT ICRDController::Task | ( | BSTR | bstrName,
 |  | [out, retval] ICRDTask ** | pVal
 | ) |

HRESULT ICRDController::TaskNames ( [out, retval] VARIANT * pVal )

HRESULT ICRDController::Variable | ( | BSTR | bstrName,
 |  | [out, retval] ICRDVariable ** | pVal
 | ) |

HRESULT ICRDController::VariableNames ( [out, retval] VARIANT * pVal )

HRESULT ICRDController::XMLNode ( [out, retval] IUnknown ** pVal )

このインタフェースの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


ICRDEngine interface Reference

インタフェースICRDEngine の解説

import "CRDMapper.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | CreateDocument ()
HRESULT | load ([in] BSTR bstrFileName)
HRESULT | save ()
HRESULT | saveAs ([in, defaultvalue("")] BSTR bstrFileName)
HRESULT | createController ([in] BSTR bstrName,[out, retval] ICRDController **pVal)
HRESULT | removeController ([in] BSTR bstrName)
HRESULT | appendController ([in] ICRDController *newCtrl)
HRESULT | ControllerNames ([out, retval] VARIANT *pVal)
HRESULT | Controller ([in] BSTR bstrName,[out, retval] ICRDController **pVal)
HRESULT | Help ([out, retval] BSTR *pVal)
HRESULT | Help ([in] BSTR newVal)
HRESULT | Version ([out, retval] BSTR *pVal)
HRESULT | Version ([in] BSTR newVal)

メソッドの解説

HRESULT ICRDEngine::appendController ( [in] ICRDController * newCtrl )

HRESULT ICRDEngine::Controller | ( | [in] BSTR | bstrName,
 |  | [out, retval] ICRDController ** | pVal
 | ) |

HRESULT ICRDEngine::ControllerNames ( [out, retval] VARIANT * pVal )

HRESULT ICRDEngine::createController | ( | [in] BSTR | bstrName,
 |  | [out, retval] ICRDController ** | pVal
 | ) |

HRESULT ICRDEngine::CreateDocument ( )

HRESULT ICRDEngine::Help ( [in] BSTR newVal )

HRESULT ICRDEngine::Help ( [out, retval] BSTR * pVal )

HRESULT ICRDEngine::load ( [in] BSTR bstrFileName )

HRESULT ICRDEngine::removeController ( [in] BSTR bstrName )

HRESULT ICRDEngine::save ( )

HRESULT ICRDEngine::saveAs ( [in, defaultvalue("")] BSTR bstrFileName )

HRESULT ICRDEngine::Version ( [in] BSTR newVal )

HRESULT ICRDEngine::Version ( [out, retval] BSTR * pVal )

このインタフェースの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


ICRDExtension interface Reference

インタフェースICRDExtension の解説

import "CRDMapper.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | Name ([out, retval] BSTR *pVal)
HRESULT | Attribute ([out, retval] long *pVal)
HRESULT | Attribute ([in] long newVal)
HRESULT | Help ([out, retval] BSTR *pVal)
HRESULT | Help ([in] BSTR newVal)
HRESULT | ID ([out, retval] VARIANT *pVal)
HRESULT | ID ([in] VARIANT newVal)
HRESULT | XMLNode ([out, retval] IUnknown **pVal)
HRESULT | createVariable ([in] BSTR bstrName,[out, retval] ICRDVariable **pVal)
HRESULT | removeVariable ([in] BSTR bstrName)
HRESULT | appendVariable ([in] ICRDVariable *newVar)
HRESULT | VariableNames ([out, retval] VARIANT *pVal)
HRESULT | Variable (BSTR bstrName,[out, retval] ICRDVariable **pVal)
HRESULT | clone ([in] BSTR bstrDestName,[out, retval] ICRDExtension **pVal)

メソッドの解説

HRESULT ICRDExtension::appendVariable ( [in] ICRDVariable * newVar )

HRESULT ICRDExtension::Attribute ( [in] long newVal )

HRESULT ICRDExtension::Attribute ( [out, retval] long * pVal )

HRESULT ICRDExtension::clone | ( | [in] BSTR | bstrDestName,
 |  | [out, retval] ICRDExtension ** | pVal
 | ) |

HRESULT ICRDExtension::createVariable | ( | [in] BSTR | bstrName,
 |  | [out, retval] ICRDVariable ** | pVal
 | ) |

HRESULT ICRDExtension::Help ( [in] BSTR newVal )

HRESULT ICRDExtension::Help ( [out, retval] BSTR * pVal )

HRESULT ICRDExtension::ID ( [in] VARIANT newVal )

HRESULT ICRDExtension::ID ( [out, retval] VARIANT * pVal )

HRESULT ICRDExtension::Name ( [out, retval] BSTR * pVal )

HRESULT ICRDExtension::removeVariable ( [in] BSTR bstrName )

HRESULT ICRDExtension::Variable | ( | BSTR | bstrName,
 |  | [out, retval] ICRDVariable ** | pVal
 | ) |

HRESULT ICRDExtension::VariableNames ( [out, retval] VARIANT * pVal )

HRESULT ICRDExtension::XMLNode ( [out, retval] IUnknown ** pVal )

このインタフェースの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


ICRDFile interface Reference

インタフェースICRDFile の解説

import "CRDMapper.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | Name ([out, retval] BSTR *pVal)
HRESULT | Attribute ([out, retval] long *pVal)
HRESULT | Attribute ([in] long newVal)
HRESULT | Help ([out, retval] BSTR *pVal)
HRESULT | Help ([in] BSTR newVal)
HRESULT | DateCreated ([out, retval] VARIANT *pVal)
HRESULT | DateCreated ([in] VARIANT newVal)
HRESULT | DateLastAccessed ([out, retval] VARIANT *pVal)
HRESULT | DateLastAccessed ([in] VARIANT newVal)
HRESULT | DateLastModified ([out, retval] VARIANT *pVal)
HRESULT | DateLastModified ([in] VARIANT newVal)
HRESULT | Path ([out, retval] BSTR *pVal)
HRESULT | Path ([in] BSTR newVal)
HRESULT | Size ([out, retval] long *pVal)
HRESULT | Size ([in] long newVal)
HRESULT | Type ([out, retval] BSTR *pVal)
HRESULT | Type ([in] BSTR newVal)
HRESULT | Value ([out, retval] VARIANT *pVal)
HRESULT | Value ([in] VARIANT newVal)
HRESULT | ID ([out, retval] VARIANT *pVal)
HRESULT | ID ([in] VARIANT newVal)
HRESULT | XMLNode ([out, retval] IUnknown **pVal)
HRESULT | createFile ([in] BSTR bstrName,[out, retval] ICRDFile **pVal)
HRESULT | removeFile ([in] BSTR bstrName)
HRESULT | appendFile ([in] ICRDFile *newFile)
HRESULT | FileNames ([out, retval] VARIANT *pVal)
HRESULT | File (BSTR bstrName,[out, retval] ICRDFile **pVal)
HRESULT | createVariable ([in] BSTR bstrName,[out, retval] ICRDVariable **pVal)
HRESULT | removeVariable ([in] BSTR bstrName)
HRESULT | appendVariable ([in] ICRDVariable *newVar)
HRESULT | VariableNames ([out, retval] VARIANT *pVal)
HRESULT | Variable (BSTR bstrName,[out, retval] ICRDVariable **pVal)
HRESULT | clone ([in] BSTR bstrDestName,[out, retval] ICRDFile **pVal)

メソッドの解説

HRESULT ICRDFile::appendFile ( [in] ICRDFile * newFile )

HRESULT ICRDFile::appendVariable ( [in] ICRDVariable * newVar )

HRESULT ICRDFile::Attribute ( [in] long newVal )

HRESULT ICRDFile::Attribute ( [out, retval] long * pVal )

HRESULT ICRDFile::clone | ( | [in] BSTR | bstrDestName,
 |  | [out, retval] ICRDFile ** | pVal
 | ) |

HRESULT ICRDFile::createFile | ( | [in] BSTR | bstrName,
 |  | [out, retval] ICRDFile ** | pVal
 | ) |

HRESULT ICRDFile::createVariable | ( | [in] BSTR | bstrName,
 |  | [out, retval] ICRDVariable ** | pVal
 | ) |

HRESULT ICRDFile::DateCreated ( [in] VARIANT newVal )

HRESULT ICRDFile::DateCreated ( [out, retval] VARIANT * pVal )

HRESULT ICRDFile::DateLastAccessed ( [in] VARIANT newVal )

HRESULT ICRDFile::DateLastAccessed ( [out, retval] VARIANT * pVal )

HRESULT ICRDFile::DateLastModified ( [in] VARIANT newVal )

HRESULT ICRDFile::DateLastModified ( [out, retval] VARIANT * pVal )

HRESULT ICRDFile::File | ( | BSTR | bstrName,
 |  | [out, retval] ICRDFile ** | pVal
 | ) |

HRESULT ICRDFile::FileNames ( [out, retval] VARIANT * pVal )

HRESULT ICRDFile::Help ( [in] BSTR newVal )

HRESULT ICRDFile::Help ( [out, retval] BSTR * pVal )

HRESULT ICRDFile::ID ( [in] VARIANT newVal )

HRESULT ICRDFile::ID ( [out, retval] VARIANT * pVal )

HRESULT ICRDFile::Name ( [out, retval] BSTR * pVal )

HRESULT ICRDFile::Path ( [in] BSTR newVal )

HRESULT ICRDFile::Path ( [out, retval] BSTR * pVal )

HRESULT ICRDFile::removeFile ( [in] BSTR bstrName )

HRESULT ICRDFile::removeVariable ( [in] BSTR bstrName )

HRESULT ICRDFile::Size ( [in] long newVal )

HRESULT ICRDFile::Size ( [out, retval] long * pVal )

HRESULT ICRDFile::Type ( [in] BSTR newVal )

HRESULT ICRDFile::Type ( [out, retval] BSTR * pVal )

HRESULT ICRDFile::Value ( [in] VARIANT newVal )

HRESULT ICRDFile::Value ( [out, retval] VARIANT * pVal )

HRESULT ICRDFile::Variable | ( | BSTR | bstrName,
 |  | [out, retval] ICRDVariable ** | pVal
 | ) |

HRESULT ICRDFile::VariableNames ( [out, retval] VARIANT * pVal )

HRESULT ICRDFile::XMLNode ( [out, retval] IUnknown ** pVal )

このインタフェースの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


ICRDMessage interface Reference

インタフェースICRDMessage の解説

import "CRDMapper.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | Number ([out, retval] long *pVal)
HRESULT | DateTime ([out, retval] VARIANT *pVal)
HRESULT | DateTime ([in] VARIANT newVal)
HRESULT | Description ([out, retval] BSTR *pVal)
HRESULT | Description ([in] BSTR newVal)
HRESULT | Destination ([out, retval] BSTR *pVal)
HRESULT | Destination ([in] BSTR newVal)
HRESULT | Source ([out, retval] BSTR *pVal)
HRESULT | Source ([in] BSTR newVal)
HRESULT | Value ([out, retval] VARIANT *pVal)
HRESULT | Value ([in] VARIANT newVal)
HRESULT | ID ([out, retval] VARIANT *pVal)
HRESULT | ID ([in] VARIANT newVal)
HRESULT | XMLNode ([out, retval] IUnknown **pVal)
HRESULT | clone ([in] long lNumber,[out, retval] ICRDMessage **pVal)

メソッドの解説

HRESULT ICRDMessage::clone | ( | [in] long | lNumber,
 |  | [out, retval] ICRDMessage ** | pVal
 | ) |

HRESULT ICRDMessage::DateTime ( [in] VARIANT newVal )

HRESULT ICRDMessage::DateTime ( [out, retval] VARIANT * pVal )

HRESULT ICRDMessage::Description ( [in] BSTR newVal )

HRESULT ICRDMessage::Description ( [out, retval] BSTR * pVal )

HRESULT ICRDMessage::Destination ( [in] BSTR newVal )

HRESULT ICRDMessage::Destination ( [out, retval] BSTR * pVal )

HRESULT ICRDMessage::ID ( [in] VARIANT newVal )

HRESULT ICRDMessage::ID ( [out, retval] VARIANT * pVal )

HRESULT ICRDMessage::Number ( [out, retval] long * pVal )

HRESULT ICRDMessage::Source ( [in] BSTR newVal )

HRESULT ICRDMessage::Source ( [out, retval] BSTR * pVal )

HRESULT ICRDMessage::Value ( [in] VARIANT newVal )

HRESULT ICRDMessage::Value ( [out, retval] VARIANT * pVal )

HRESULT ICRDMessage::XMLNode ( [out, retval] IUnknown ** pVal )

このインタフェースの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:14 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


ICRDRobot interface Reference

インタフェースICRDRobot の解説

import "CRDMapper.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | Name ([out, retval] BSTR *pVal)
HRESULT | Attribute ([out, retval] long *pVal)
HRESULT | Attribute ([in] long newVal)
HRESULT | Help ([out, retval] BSTR *pVal)
HRESULT | Help ([in] BSTR newVal)
HRESULT | ID ([out, retval] VARIANT *pVal)
HRESULT | ID ([in] VARIANT newVal)
HRESULT | XMLNode ([out, retval] IUnknown **pVal)
HRESULT | createVariable ([in] BSTR bstrName,[out, retval] ICRDVariable **pVal)
HRESULT | removeVariable ([in] BSTR bstrName)
HRESULT | appendVariable ([in] ICRDVariable *newVar)
HRESULT | VariableNames ([out, retval] VARIANT *pVal)
HRESULT | Variable (BSTR bstrName,[out, retval] ICRDVariable **pVal)
HRESULT | clone ([in] BSTR bstrDestName,[out, retval] ICRDRobot **pVal)

メソッドの解説

HRESULT ICRDRobot::appendVariable ( [in] ICRDVariable * newVar )

HRESULT ICRDRobot::Attribute ( [in] long newVal )

HRESULT ICRDRobot::Attribute ( [out, retval] long * pVal )

HRESULT ICRDRobot::clone | ( | [in] BSTR | bstrDestName,
 |  | [out, retval] ICRDRobot ** | pVal
 | ) |

HRESULT ICRDRobot::createVariable | ( | [in] BSTR | bstrName,
 |  | [out, retval] ICRDVariable ** | pVal
 | ) |

HRESULT ICRDRobot::Help ( [in] BSTR newVal )

HRESULT ICRDRobot::Help ( [out, retval] BSTR * pVal )

HRESULT ICRDRobot::ID ( [in] VARIANT newVal )

HRESULT ICRDRobot::ID ( [out, retval] VARIANT * pVal )

HRESULT ICRDRobot::Name ( [out, retval] BSTR * pVal )

HRESULT ICRDRobot::removeVariable ( [in] BSTR bstrName )

HRESULT ICRDRobot::Variable | ( | BSTR | bstrName,
 |  | [out, retval] ICRDVariable ** | pVal
 | ) |

HRESULT ICRDRobot::VariableNames ( [out, retval] VARIANT * pVal )

HRESULT ICRDRobot::XMLNode ( [out, retval] IUnknown ** pVal )

このインタフェースの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:14 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


ICRDTask interface Reference

インタフェースICRDTask の解説

import "CRDMapper.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | Name ([out, retval] BSTR *pVal)
HRESULT | Attribute ([out, retval] long *pVal)
HRESULT | Attribute ([in] long newVal)
HRESULT | Help ([out, retval] BSTR *pVal)
HRESULT | Help ([in] BSTR newVal)
HRESULT | FileName ([out, retval] BSTR *pVal)
HRESULT | FileName ([in] BSTR newVal)
HRESULT | ID ([out, retval] VARIANT *pVal)
HRESULT | ID ([in] VARIANT newVal)
HRESULT | XMLNode ([out, retval] IUnknown **pVal)
HRESULT | createVariable ([in] BSTR bstrName,[out, retval] ICRDVariable **pVal)
HRESULT | removeVariable ([in] BSTR bstrName)
HRESULT | appendVariable ([in] ICRDVariable *newVar)
HRESULT | VariableNames ([out, retval] VARIANT *pVal)
HRESULT | Variable (BSTR bstrName,[out, retval] ICRDVariable **pVal)
HRESULT | clone ([in] BSTR bstrDestName,[out, retval] ICRDTask **pVal)

メソッドの解説

HRESULT ICRDTask::appendVariable ( [in] ICRDVariable * newVar )

HRESULT ICRDTask::Attribute ( [in] long newVal )

HRESULT ICRDTask::Attribute ( [out, retval] long * pVal )

HRESULT ICRDTask::clone | ( | [in] BSTR | bstrDestName,
 |  | [out, retval] ICRDTask ** | pVal
 | ) |

HRESULT ICRDTask::createVariable | ( | [in] BSTR | bstrName,
 |  | [out, retval] ICRDVariable ** | pVal
 | ) |

HRESULT ICRDTask::FileName ( [in] BSTR newVal )

HRESULT ICRDTask::FileName ( [out, retval] BSTR * pVal )

HRESULT ICRDTask::Help ( [in] BSTR newVal )

HRESULT ICRDTask::Help ( [out, retval] BSTR * pVal )

HRESULT ICRDTask::ID ( [in] VARIANT newVal )

HRESULT ICRDTask::ID ( [out, retval] VARIANT * pVal )

HRESULT ICRDTask::Name ( [out, retval] BSTR * pVal )

HRESULT ICRDTask::removeVariable ( [in] BSTR bstrName )

HRESULT ICRDTask::Variable | ( | BSTR | bstrName,
 |  | [out, retval] ICRDVariable ** | pVal
 | ) |

HRESULT ICRDTask::VariableNames ( [out, retval] VARIANT * pVal )

HRESULT ICRDTask::XMLNode ( [out, retval] IUnknown ** pVal )

このインタフェースの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:14 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


ICRDVariable interface Reference

インタフェースICRDVariable の解説

import "CRDMapper.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | Name ([out, retval] BSTR *pVal)
HRESULT | Attribute ([out, retval] long *pVal)
HRESULT | Attribute ([in] long newVal)
HRESULT | Help ([out, retval] BSTR *pVal)
HRESULT | Help ([in] BSTR newVal)
HRESULT | DateTime ([out, retval] VARIANT *pVal)
HRESULT | DateTime ([in] VARIANT newVal)
HRESULT | Value ([out, retval] VARIANT *pVal)
HRESULT | Value ([in] VARIANT newVal)
HRESULT | ID ([out, retval] VARIANT *pVal)
HRESULT | ID ([in] VARIANT newVal)
HRESULT | Microsecond ([out, retval] long *pVal)
HRESULT | Microsecond ([in] long newVal)
HRESULT | XMLNode ([out, retval] IUnknown **pVal)
HRESULT | clone ([in] BSTR bstrDestName,[out, retval] ICRDVariable **pVal)

メソッドの解説

HRESULT ICRDVariable::Attribute ( [in] long newVal )

HRESULT ICRDVariable::Attribute ( [out, retval] long * pVal )

HRESULT ICRDVariable::clone | ( | [in] BSTR | bstrDestName,
 |  | [out, retval] ICRDVariable ** | pVal
 | ) |

HRESULT ICRDVariable::DateTime ( [in] VARIANT newVal )

HRESULT ICRDVariable::DateTime ( [out, retval] VARIANT * pVal )

HRESULT ICRDVariable::Help ( [in] BSTR newVal )

HRESULT ICRDVariable::Help ( [out, retval] BSTR * pVal )

HRESULT ICRDVariable::ID ( [in] VARIANT newVal )

HRESULT ICRDVariable::ID ( [out, retval] VARIANT * pVal )

HRESULT ICRDVariable::Microsecond ( [in] long newVal )

HRESULT ICRDVariable::Microsecond ( [out, retval] long * pVal )

HRESULT ICRDVariable::Name ( [out, retval] BSTR * pVal )

HRESULT ICRDVariable::Value ( [in] VARIANT newVal )

HRESULT ICRDVariable::Value ( [out, retval] VARIANT * pVal )

HRESULT ICRDVariable::XMLNode ( [out, retval] IUnknown ** pVal )

このインタフェースの解説は次のファイルから生成されました:
  • CRDMapper.idl
Generated on Thu Jan 27 18:50:14 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


IDispatchImpl class Reference

クラス IDispatchImpl の解説

IDispatchImplに対する継承グラフ

[凡例]
このクラスの解説は次のファイルから生成されました:
  • _CCRDNodeTemplate.h
Generated on Thu Jan 27 18:50:15 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


ISupportErrorInfo class Reference

クラス ISupportErrorInfo の解説

ISupportErrorInfoに対する継承グラフ

[凡例]
このクラスの解説は次のファイルから生成されました:
  • _CCRDNodeTemplate.h
Generated on Thu Jan 27 18:50:15 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


Hierarchical Index

CRDMapper Project クラス階層

クラス階層図を見る。

この継承一覧はおおまかにはソートされていますが、完全にアルファベット順でソートされてはいません。

  • _IID
  • _MIDL_PROC_FORMAT_STRING
  • _MIDL_TYPE_FORMAT_STRING
  • CComCoClass
    • _CCRDNodeTemplate< T, pclsid, T1, piid >
    • _CCRDNodeTemplate< CCRDCommand,&CLSID_CRDCommand, ICRDCommand,&IID_ICRDCommand >
      • CCRDCommand
    • _CCRDNodeTemplate< CCRDController,&CLSID_CRDController, ICRDController,&IID_ICRDController >
      • CCRDController
    • _CCRDNodeTemplate< CCRDExtension,&CLSID_CRDExtension, ICRDExtension,&IID_ICRDExtension >
      • CCRDExtension
    • _CCRDNodeTemplate< CCRDFile,&CLSID_CRDFile, ICRDFile,&IID_ICRDFile >
      • CCRDFile
    • _CCRDNodeTemplate< CCRDRobot,&CLSID_CRDRobot, ICRDRobot,&IID_ICRDRobot >
      • CCRDRobot
    • _CCRDNodeTemplate< CCRDTask,&CLSID_CRDTask, ICRDTask,&IID_ICRDTask >
      • CCRDTask
    • _CCRDNodeTemplate< CCRDVariable,&CLSID_CRDVariable, ICRDVariable,&IID_ICRDVariable >
      • CCRDVariable
    • CCRDEngine
    • CCRDMessage
  • CComObjectRootEx
    • _CCRDNodeTemplate< T, pclsid, T1, piid >
    • _CCRDNodeTemplate< CCRDCommand,&CLSID_CRDCommand, ICRDCommand,&IID_ICRDCommand >
    • _CCRDNodeTemplate< CCRDController,&CLSID_CRDController, ICRDController,&IID_ICRDController >
    • _CCRDNodeTemplate< CCRDExtension,&CLSID_CRDExtension, ICRDExtension,&IID_ICRDExtension >
    • _CCRDNodeTemplate< CCRDFile,&CLSID_CRDFile, ICRDFile,&IID_ICRDFile >
    • _CCRDNodeTemplate< CCRDRobot,&CLSID_CRDRobot, ICRDRobot,&IID_ICRDRobot >
    • _CCRDNodeTemplate< CCRDTask,&CLSID_CRDTask, ICRDTask,&IID_ICRDTask >
    • _CCRDNodeTemplate< CCRDVariable,&CLSID_CRDVariable, ICRDVariable,&IID_ICRDVariable >
    • CCRDEngine
    • CCRDMessage
  • CCRDUtility
  • CRDMAPPERLib::CRDCommand
  • CRDMAPPERLib::CRDController
  • CRDMAPPERLib::CRDEngine
  • CRDMAPPERLib::CRDExtension
  • CRDMAPPERLib::CRDFile
  • CRDMAPPERLib::CRDMessage
  • CRDMAPPERLib::CRDRobot
  • CRDMAPPERLib::CRDTask
  • CRDMAPPERLib::CRDVariable
  • ICRDCommand
  • ICRDController
  • ICRDEngine
  • ICRDExtension
  • ICRDFile
  • ICRDMessage
  • ICRDRobot
  • ICRDTask
  • ICRDVariable
  • IDispatchImpl
    • _CCRDNodeTemplate< T, pclsid, T1, piid >
    • _CCRDNodeTemplate< CCRDCommand,&CLSID_CRDCommand, ICRDCommand,&IID_ICRDCommand >
    • _CCRDNodeTemplate< CCRDController,&CLSID_CRDController, ICRDController,&IID_ICRDController >
    • _CCRDNodeTemplate< CCRDExtension,&CLSID_CRDExtension, ICRDExtension,&IID_ICRDExtension >
    • _CCRDNodeTemplate< CCRDFile,&CLSID_CRDFile, ICRDFile,&IID_ICRDFile >
    • _CCRDNodeTemplate< CCRDRobot,&CLSID_CRDRobot, ICRDRobot,&IID_ICRDRobot >
    • _CCRDNodeTemplate< CCRDTask,&CLSID_CRDTask, ICRDTask,&IID_ICRDTask >
    • _CCRDNodeTemplate< CCRDVariable,&CLSID_CRDVariable, ICRDVariable,&IID_ICRDVariable >
    • CCRDEngine
    • CCRDMessage
  • ISupportErrorInfo
    • _CCRDNodeTemplate< T, pclsid, T1, piid >
    • _CCRDNodeTemplate< CCRDCommand,&CLSID_CRDCommand, ICRDCommand,&IID_ICRDCommand >
    • _CCRDNodeTemplate< CCRDController,&CLSID_CRDController, ICRDController,&IID_ICRDController >
    • _CCRDNodeTemplate< CCRDExtension,&CLSID_CRDExtension, ICRDExtension,&IID_ICRDExtension >
    • _CCRDNodeTemplate< CCRDFile,&CLSID_CRDFile, ICRDFile,&IID_ICRDFile >
    • _CCRDNodeTemplate< CCRDRobot,&CLSID_CRDRobot, ICRDRobot,&IID_ICRDRobot >
    • _CCRDNodeTemplate< CCRDTask,&CLSID_CRDTask, ICRDTask,&IID_ICRDTask >
    • _CCRDNodeTemplate< CCRDVariable,&CLSID_CRDVariable, ICRDVariable,&IID_ICRDVariable >
    • CCRDEngine
    • CCRDMessage
Generated on Thu Jan 27 18:50:08 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


Compound Member Index

CRDMapper Project 構成メンバ

_ | a | c | d | e | f | g | h | i | l | m | n | p | r | s | t | v | x | ~

これはクラスメンバの一覧で、それぞれが属しているクラスの解説へリンクしています。

- _ -

  • _CCRDNodeTemplate() : _CCRDNodeTemplate< T, pclsid, T1, piid >
  • _Initialize() : CCRDMessage, _CCRDNodeTemplate< T, pclsid, T1, piid >

- a -

  • AddIndent() : CCRDUtility
  • appendCommand() : ICRDController, CCRDController
  • appendController() : ICRDEngine, CCRDEngine
  • appendExtension() : ICRDController, CCRDController
  • appendFile() : ICRDFile, ICRDController, CCRDFile, CCRDController
  • appendMessage() : ICRDController, CCRDController
  • appendRobot() : ICRDController, CCRDController
  • appendTask() : ICRDController, CCRDController
  • appendVariable() : CCRDTask, CCRDRobot, ICRDTask, ICRDRobot, ICRDFile, ICRDExtension, ICRDController, CCRDFile, CCRDExtension, CCRDController
  • Attribute() : ICRDCommand, ICRDVariable, ICRDTask, ICRDRobot, ICRDFile, ICRDExtension, ICRDController

- c -

  • c : _IID
  • CCRDEngine() : CCRDEngine
  • CCRDUtility() : CCRDUtility
  • clone() : CCRDVariable, CCRDTask, CCRDRobot, CCRDMessage, ICRDMessage, ICRDCommand, ICRDVariable, ICRDTask, ICRDRobot, ICRDFile, ICRDExtension, ICRDController, CCRDFile, CCRDExtension, CCRDController, CCRDCommand
  • Command() : ICRDController
  • CommandNames() : ICRDController
  • Controller() : ICRDEngine
  • ControllerNames() : ICRDEngine
  • createCommand() : ICRDController, CCRDController
  • createController() : ICRDEngine, CCRDEngine
  • CreateDocument() : ICRDEngine, CCRDEngine
  • CreateElement() : CCRDUtility
  • CreateElementWithNameAttr() : CCRDUtility
  • CreateElementWithNumberAttr() : CCRDUtility
  • createExtension() : ICRDController, CCRDController
  • createFile() : ICRDFile, ICRDController, CCRDFile, CCRDController
  • createMessage() : ICRDController, CCRDController
  • createRobot() : ICRDController, CCRDController
  • createTask() : ICRDController, CCRDController
  • createVariable() : CCRDTask, CCRDRobot, ICRDTask, ICRDRobot, ICRDFile, ICRDExtension, ICRDController, CCRDFile, CCRDExtension, CCRDController
  • CreateVariantNode() : CCRDUtility

- d -

  • DateCreated() : ICRDFile
  • DateLastAccessed() : ICRDFile
  • DateLastModified() : ICRDFile
  • DateTime() : ICRDMessage, ICRDVariable
  • Description() : ICRDMessage
  • Destination() : ICRDMessage

- e -

  • Extension() : ICRDController
  • ExtensionNames() : ICRDController

- f -

  • File() : ICRDFile, ICRDController
  • FileName() : ICRDTask
  • FileNames() : ICRDFile, ICRDController
  • Format : _MIDL_PROC_FORMAT_STRING, _MIDL_TYPE_FORMAT_STRING

- g -

  • get_Attribute() : _CCRDNodeTemplate< T, pclsid, T1, piid >
  • get_Command() : CCRDController
  • get_CommandNames() : CCRDController
  • get_Controller() : CCRDEngine
  • get_ControllerNames() : CCRDEngine
  • get_DateCreated() : CCRDFile
  • get_DateLastAccessed() : CCRDFile
  • get_DateLastModified() : CCRDFile
  • get_DateTime() : CCRDVariable, CCRDMessage
  • get_Description() : CCRDMessage
  • get_Destination() : CCRDMessage
  • get_Extension() : CCRDController
  • get_ExtensionNames() : CCRDController
  • get_File() : CCRDFile, CCRDController
  • get_FileName() : CCRDTask
  • get_FileNames() : CCRDFile, CCRDController
  • get_Help() : CCRDEngine, _CCRDNodeTemplate< T, pclsid, T1, piid >
  • get_ID() : CCRDMessage, _CCRDNodeTemplate< T, pclsid, T1, piid >
  • get_Message() : CCRDController
  • get_MessageNumbers() : CCRDController
  • get_Microsecond() : CCRDVariable
  • get_Name() : _CCRDNodeTemplate< T, pclsid, T1, piid >
  • get_Number() : CCRDMessage
  • get_Parameters() : CCRDCommand
  • get_Path() : CCRDFile
  • get_Robot() : CCRDController
  • get_RobotNames() : CCRDController
  • get_Size() : CCRDFile
  • get_Source() : CCRDMessage
  • get_State() : CCRDCommand
  • get_Task() : CCRDController
  • get_TaskNames() : CCRDController
  • get_Timeout() : CCRDCommand
  • get_Type() : CCRDFile
  • get_Value() : CCRDVariable, CCRDMessage, CCRDFile
  • get_Variable() : CCRDTask, CCRDRobot, CCRDFile, CCRDExtension, CCRDController
  • get_VariableNames() : CCRDTask, CCRDRobot, CCRDFile, CCRDExtension, CCRDController
  • get_Version() : CCRDEngine
  • get_XMLNode() : CCRDMessage, _CCRDNodeTemplate< T, pclsid, T1, piid >
  • GetNamedNodeList() : CCRDUtility
  • GetNodeAttribute() : CCRDUtility
  • GetNodeValue() : CCRDUtility
  • GetNodeVariant() : CCRDUtility
  • GetNumberNodeList() : CCRDUtility

- h -

  • Help() : ICRDCommand, ICRDVariable, ICRDTask, ICRDRobot, ICRDFile, ICRDExtension, ICRDController, ICRDEngine

- i -

  • ID() : ICRDMessage, ICRDCommand, ICRDVariable, ICRDTask, ICRDRobot, ICRDFile, ICRDExtension, ICRDController
  • InterfaceSupportsErrorInfo() : CCRDMessage, CCRDEngine, _CCRDNodeTemplate< T, pclsid, T1, piid >

- l -

  • load() : ICRDEngine, CCRDEngine

- m -

  • m_pINode : _CCRDNodeTemplate< T, pclsid, T1, piid >
  • Message() : ICRDController
  • MessageNumbers() : ICRDController
  • Microsecond() : ICRDVariable

- n -

  • Name() : ICRDCommand, ICRDVariable, ICRDTask, ICRDRobot, ICRDFile, ICRDExtension, ICRDController
  • Number() : ICRDMessage

- p -

  • Pad : _MIDL_PROC_FORMAT_STRING, _MIDL_TYPE_FORMAT_STRING
  • Parameters() : ICRDCommand
  • Path() : ICRDFile
  • put_Attribute() : _CCRDNodeTemplate< T, pclsid, T1, piid >
  • put_DateCreated() : CCRDFile
  • put_DateLastAccessed() : CCRDFile
  • put_DateLastModified() : CCRDFile
  • put_DateTime() : CCRDVariable, CCRDMessage
  • put_Description() : CCRDMessage
  • put_Destination() : CCRDMessage
  • put_FileName() : CCRDTask
  • put_Help() : CCRDEngine, _CCRDNodeTemplate< T, pclsid, T1, piid >
  • put_ID() : CCRDMessage, _CCRDNodeTemplate< T, pclsid, T1, piid >
  • put_Microsecond() : CCRDVariable
  • put_Parameters() : CCRDCommand
  • put_Path() : CCRDFile
  • put_Size() : CCRDFile
  • put_Source() : CCRDMessage
  • put_State() : CCRDCommand
  • put_Timeout() : CCRDCommand
  • put_Type() : CCRDFile
  • put_Value() : CCRDVariable, CCRDMessage, CCRDFile
  • put_Version() : CCRDEngine

- r -

  • removeCommand() : ICRDController, CCRDController
  • removeController() : ICRDEngine, CCRDEngine
  • removeExtension() : ICRDController, CCRDController
  • removeFile() : ICRDFile, ICRDController, CCRDFile, CCRDController
  • RemoveIndent() : CCRDUtility
  • removeMessage() : ICRDController, CCRDController
  • removeRobot() : ICRDController, CCRDController
  • removeTask() : ICRDController, CCRDController
  • removeVariable() : CCRDTask, CCRDRobot, ICRDTask, ICRDRobot, ICRDFile, ICRDExtension, ICRDController, CCRDFile, CCRDExtension, CCRDController
  • Robot() : ICRDController
  • RobotNames() : ICRDController

- s -

  • s1 : _IID
  • s2 : _IID
  • save() : ICRDEngine, CCRDEngine
  • saveAs() : ICRDEngine, CCRDEngine
  • SetNodeValue() : CCRDUtility
  • Size() : ICRDFile
  • Source() : ICRDMessage
  • State() : ICRDCommand

- t -

  • Task() : ICRDController
  • TaskNames() : ICRDController
  • Timeout() : ICRDCommand
  • Type() : ICRDFile

- v -

  • Value() : ICRDMessage, ICRDVariable, ICRDFile
  • Variable() : ICRDTask, ICRDRobot, ICRDFile, ICRDExtension, ICRDController
  • VariableNames() : ICRDTask, ICRDRobot, ICRDFile, ICRDExtension, ICRDController
  • VariantTimeToISO8601() : CCRDUtility
  • Version() : ICRDEngine

- x -

  • x : _IID
  • XMLNode() : ICRDMessage, ICRDCommand, ICRDVariable, ICRDTask, ICRDRobot, ICRDFile, ICRDExtension, ICRDController

- ~ -

  • ~CCRDUtility() : CCRDUtility
Generated on Thu Jan 27 18:50:08 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


Namespace Index

CRDMapper Project 名前空間一覧

名前空間の一覧です。
CRDMAPPERLib
MSXML2
Generated on Thu Jan 27 18:50:15 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMAPPERLib Namespace Reference

名前空間 CRDMAPPERLib の解説

構成

class | CRDCommand
class | CRDController
class | CRDEngine
class | CRDExtension
class | CRDFile
class | CRDMessage
class | CRDRobot
class | CRDTask
class | CRDVariable

関数

importlib ("stdole32.tlb")
importlib ("stdole2.tlb")

関数の解説

importlib ( "stdole2.tlb" )

importlib ( "stdole32.tlb" )

Generated on Thu Jan 27 18:50:15 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


MSXML2 Namespace Reference

名前空間 MSXML2 の解説

Generated on Thu Jan 27 18:50:15 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


File Member Index

CRDMapper Project ファイルメンバ

_ | a | b | c | d | g | i | l | m | o | p | r | s | t | u | v | x

これはファイルメンバの一覧です。それぞれが属しているファイルの解説へリンクしています。

- _ -

  • __MIDL_itf_CRDMapper_0000_v0_0_c_ifspec : CRDMapper.h
  • __MIDL_itf_CRDMapper_0000_v0_0_s_ifspec : CRDMapper.h
  • __MIDL_ProcFormatString : CRDMapper_p.c
  • __MIDL_TypeFormatString : CRDMapper_p.c
  • __pad0__ : CRDMapper.h
  • __pad1__ : CRDMapper.h
  • __pad2__ : CRDMapper.h
  • __pad3__ : CRDMapper.h
  • __pad4__ : CRDMapper.h
  • __pad5__ : CRDMapper.h
  • __pad6__ : CRDMapper.h
  • __pad7__ : CRDMapper.h
  • __pad8__ : CRDMapper.h
  • __REQUIRED_RPCNDR_H_VERSION__ : CRDMapper.h
  • __REQUIRED_RPCPROXY_H_VERSION__ : CRDMapper_p.c
  • _ATL_APARTMENT_THREADED : StdAfx.h
  • _Module : StdAfx.h, CRDMapper.cpp
  • _WIN32_WINNT : StdAfx.h

- a -

  • AFX_CRDNODE_H__48D0C551_35F0_47C0_A616_5A199A2D49D0__INCLUDED_ : _CCRDNodeTemplate.h
  • AFX_CRDUTILITY_H__E2594B17_3537_4843_87B1_520624BBBF77__INCLUDED_ : CRDUtility.h
  • AFX_STDAFX_H__1D245D43_9AC1_4B7B_82FC_36A4742EA6D8__INCLUDED_ : StdAfx.h
  • appendCommand() : CRDMapper.h
  • appendController() : CRDMapper.h
  • appendExtension() : CRDMapper.h
  • appendFile() : CRDMapper.h
  • appendMessage() : CRDMapper.h
  • appendRobot() : CRDMapper.h
  • appendTask() : CRDMapper.h
  • appendVariable() : CRDMapper.h

- b -

  • BSTR_UserFree() : CRDMapper.h
  • BSTR_UserMarshal() : CRDMapper.h
  • BSTR_UserSize() : CRDMapper.h
  • BSTR_UserUnmarshal() : CRDMapper.h

- c -

  • CINTERFACE_PROXY_VTABLE() : CRDMapper_p.c
  • clone() : CRDMapper.h
  • CLSID : CRDMapper_i.c
  • CLSID_CRDCommand : CRDMapper_i.c, CRDMapper.h
  • CLSID_CRDController : CRDMapper_i.c, CRDMapper.h
  • CLSID_CRDEngine : CRDMapper_i.c, CRDMapper.h
  • CLSID_CRDExtension : CRDMapper_i.c, CRDMapper.h
  • CLSID_CRDFile : CRDMapper_i.c, CRDMapper.h
  • CLSID_CRDMessage : CRDMapper_i.c, CRDMapper.h
  • CLSID_CRDRobot : CRDMapper_i.c, CRDMapper.h
  • CLSID_CRDTask : CRDMapper_i.c, CRDMapper.h
  • CLSID_CRDVariable : CRDMapper_i.c, CRDMapper.h
  • CRD_ATTR_LOCATION : CRD.h
  • CRD_ATTR_NAME : CRD.h
  • CRD_ATTR_NUMBER : CRD.h
  • CRD_ATTR_TYPE : CRD.h
  • CRD_ELEM_ACCEL : CRD.h
  • CRD_ELEM_ARRAY : CRD.h
  • CRD_ELEM_ARRAYBOUND : CRD.h
  • CRD_ELEM_ARRAYDATA : CRD.h
  • CRD_ELEM_ATTRIBUTE : CRD.h
  • CRD_ELEM_BOOL : CRD.h
  • CRD_ELEM_BSTR : CRD.h
  • CRD_ELEM_COMMAND : CRD.h
  • CRD_ELEM_CONTROLLER : CRD.h
  • CRD_ELEM_DATE : CRD.h
  • CRD_ELEM_DATE_CREATED : CRD.h
  • CRD_ELEM_DATE_LAST_ACCESSED : CRD.h
  • CRD_ELEM_DATE_LAST_MODIFIED : CRD.h
  • CRD_ELEM_DATETIME : CRD.h
  • CRD_ELEM_DECEL : CRD.h
  • CRD_ELEM_DESCRIPTION : CRD.h
  • CRD_ELEM_DESTINATIOM : CRD.h
  • CRD_ELEM_DIMENSION : CRD.h
  • CRD_ELEM_ELEMENTS : CRD.h
  • CRD_ELEM_EXTENSION : CRD.h
  • CRD_ELEM_FILE : CRD.h
  • CRD_ELEM_FILENAME : CRD.h
  • CRD_ELEM_HELP : CRD.h
  • CRD_ELEM_I1 : CRD.h
  • CRD_ELEM_I2 : CRD.h
  • CRD_ELEM_I4 : CRD.h
  • CRD_ELEM_ID : CRD.h
  • CRD_ELEM_JSPEED : CRD.h
  • CRD_ELEM_LBOUND : CRD.h
  • CRD_ELEM_MESSAGE : CRD.h
  • CRD_ELEM_MICROSECOND : CRD.h
  • CRD_ELEM_PARAMETERS : CRD.h
  • CRD_ELEM_PATH : CRD.h
  • CRD_ELEM_R4 : CRD.h
  • CRD_ELEM_R8 : CRD.h
  • CRD_ELEM_ROBOT : CRD.h
  • CRD_ELEM_ROOT : CRD.h
  • CRD_ELEM_SIZE : CRD.h
  • CRD_ELEM_SOURCE : CRD.h
  • CRD_ELEM_SPEED : CRD.h
  • CRD_ELEM_STATE : CRD.h
  • CRD_ELEM_TASK : CRD.h
  • CRD_ELEM_TIMEOUT : CRD.h
  • CRD_ELEM_TYPE : CRD.h
  • CRD_ELEM_UI1 : CRD.h
  • CRD_ELEM_UI2 : CRD.h
  • CRD_ELEM_UI4 : CRD.h
  • CRD_ELEM_VALUE : CRD.h
  • CRD_ELEM_VARIABLE : CRD.h
  • CRD_ELEM_VARIANT : CRD.h
  • CRD_ELEM_VERSION : CRD.h
  • CRD_SCHEMA_FILE : CRD.h
  • CRD_SCHEMA_LOCATION : CRD.h
  • CRD_TYPE_ARRAY : CRD.h
  • CRD_TYPE_BOOL : CRD.h
  • CRD_TYPE_BSTR : CRD.h
  • CRD_TYPE_DATE : CRD.h
  • CRD_TYPE_I1 : CRD.h
  • CRD_TYPE_I2 : CRD.h
  • CRD_TYPE_I4 : CRD.h
  • CRD_TYPE_R4 : CRD.h
  • CRD_TYPE_R8 : CRD.h
  • CRD_TYPE_UI1 : CRD.h
  • CRD_TYPE_UI2 : CRD.h
  • CRD_TYPE_UI4 : CRD.h
  • CRD_TYPE_VARIANT : CRD.h
  • CRDCommand : CRDMapper.h
  • CRDController : CRDMapper.h
  • CRDEngine : CRDMapper.h
  • CRDExtension : CRDMapper.h
  • CRDFile : CRDMapper.h
  • CRDMessage : CRDMapper.h
  • CRDRobot : CRDMapper.h
  • CRDTask : CRDMapper.h
  • CRDVariable : CRDMapper.h
  • createCommand() : CRDMapper.h
  • createController() : CRDMapper.h
  • createExtension() : CRDMapper.h
  • createFile() : CRDMapper.h
  • createMessage() : CRDMapper.h
  • createRobot() : CRDMapper.h
  • createTask() : CRDMapper.h
  • createVariable() : CRDMapper.h

- d -

  • DECLSPEC_UUID() : CRDMapper.h
  • DllCanUnloadNow() : CRDMapper.cpp
  • DllGetClassObject() : CRDMapper.cpp
  • DllMain() : CRDMapper.cpp
  • DllRegisterServer() : CRDMapper.cpp
  • DllUnregisterServer() : CRDMapper.cpp

- g -

  • get_Attribute() : CRDMapper.h
  • get_Command() : CRDMapper.h
  • get_CommandNames() : CRDMapper.h
  • get_Controller() : CRDMapper.h
  • get_ControllerNames() : CRDMapper.h
  • get_DateCreated() : CRDMapper.h
  • get_DateLastAccessed() : CRDMapper.h
  • get_DateLastModified() : CRDMapper.h
  • get_DateTime() : CRDMapper.h
  • get_Description() : CRDMapper.h
  • get_Destination() : CRDMapper.h
  • get_Extension() : CRDMapper.h
  • get_ExtensionNames() : CRDMapper.h
  • get_File() : CRDMapper.h
  • get_FileName() : CRDMapper.h
  • get_FileNames() : CRDMapper.h
  • get_Help() : CRDMapper.h
  • get_ID() : CRDMapper.h
  • get_Message() : CRDMapper.h
  • get_MessageNumbers() : CRDMapper.h
  • get_Microsecond() : CRDMapper.h
  • get_Parameters() : CRDMapper.h
  • get_Path() : CRDMapper.h
  • get_Robot() : CRDMapper.h
  • get_RobotNames() : CRDMapper.h
  • get_Size() : CRDMapper.h
  • get_Source() : CRDMapper.h
  • get_State() : CRDMapper.h
  • get_Task() : CRDMapper.h
  • get_TaskNames() : CRDMapper.h
  • get_Timeout() : CRDMapper.h
  • get_Type() : CRDMapper.h
  • get_Value() : CRDMapper.h
  • get_Variable() : CRDMapper.h
  • get_VariableNames() : CRDMapper.h
  • get_Version() : CRDMapper.h
  • get_XMLNode() : CRDMapper.h

- i -

  • ICRDCommand : CRDMapper.h
  • ICRDCommand_clone_Proxy() : CRDMapper.h
  • ICRDCommand_clone_Stub() : CRDMapper.h
  • ICRDCommand_get_Attribute_Proxy() : CRDMapper.h
  • ICRDCommand_get_Attribute_Stub() : CRDMapper.h
  • ICRDCommand_get_Help_Proxy() : CRDMapper.h
  • ICRDCommand_get_Help_Stub() : CRDMapper.h
  • ICRDCommand_get_ID_Proxy() : CRDMapper.h
  • ICRDCommand_get_ID_Stub() : CRDMapper.h
  • ICRDCommand_get_Name_Proxy() : CRDMapper.h
  • ICRDCommand_get_Name_Stub() : CRDMapper.h
  • ICRDCommand_get_Parameters_Proxy() : CRDMapper.h
  • ICRDCommand_get_Parameters_Stub() : CRDMapper.h
  • ICRDCommand_get_State_Proxy() : CRDMapper.h
  • ICRDCommand_get_State_Stub() : CRDMapper.h
  • ICRDCommand_get_Timeout_Proxy() : CRDMapper.h
  • ICRDCommand_get_Timeout_Stub() : CRDMapper.h
  • ICRDCommand_get_XMLNode_Proxy() : CRDMapper.h
  • ICRDCommand_get_XMLNode_Stub() : CRDMapper.h
  • ICRDCommand_put_Attribute_Proxy() : CRDMapper.h
  • ICRDCommand_put_Attribute_Stub() : CRDMapper.h
  • ICRDCommand_put_Help_Proxy() : CRDMapper.h
  • ICRDCommand_put_Help_Stub() : CRDMapper.h
  • ICRDCommand_put_ID_Proxy() : CRDMapper.h
  • ICRDCommand_put_ID_Stub() : CRDMapper.h
  • ICRDCommand_put_Parameters_Proxy() : CRDMapper.h
  • ICRDCommand_put_Parameters_Stub() : CRDMapper.h
  • ICRDCommand_put_State_Proxy() : CRDMapper.h
  • ICRDCommand_put_State_Stub() : CRDMapper.h
  • ICRDCommand_put_Timeout_Proxy() : CRDMapper.h
  • ICRDCommand_put_Timeout_Stub() : CRDMapper.h
  • ICRDController : CRDMapper.h
  • ICRDController_appendCommand_Proxy() : CRDMapper.h
  • ICRDController_appendCommand_Stub() : CRDMapper.h
  • ICRDController_appendExtension_Proxy() : CRDMapper.h
  • ICRDController_appendExtension_Stub() : CRDMapper.h
  • ICRDController_appendFile_Proxy() : CRDMapper.h
  • ICRDController_appendFile_Stub() : CRDMapper.h
  • ICRDController_appendMessage_Proxy() : CRDMapper.h
  • ICRDController_appendMessage_Stub() : CRDMapper.h
  • ICRDController_appendRobot_Proxy() : CRDMapper.h
  • ICRDController_appendRobot_Stub() : CRDMapper.h
  • ICRDController_appendTask_Proxy() : CRDMapper.h
  • ICRDController_appendTask_Stub() : CRDMapper.h
  • ICRDController_appendVariable_Proxy() : CRDMapper.h
  • ICRDController_appendVariable_Stub() : CRDMapper.h
  • ICRDController_clone_Proxy() : CRDMapper.h
  • ICRDController_clone_Stub() : CRDMapper.h
  • ICRDController_createCommand_Proxy() : CRDMapper.h
  • ICRDController_createCommand_Stub() : CRDMapper.h
  • ICRDController_createExtension_Proxy() : CRDMapper.h
  • ICRDController_createExtension_Stub() : CRDMapper.h
  • ICRDController_createFile_Proxy() : CRDMapper.h
  • ICRDController_createFile_Stub() : CRDMapper.h
  • ICRDController_createMessage_Proxy() : CRDMapper.h
  • ICRDController_createMessage_Stub() : CRDMapper.h
  • ICRDController_createRobot_Proxy() : CRDMapper.h
  • ICRDController_createRobot_Stub() : CRDMapper.h
  • ICRDController_createTask_Proxy() : CRDMapper.h
  • ICRDController_createTask_Stub() : CRDMapper.h
  • ICRDController_createVariable_Proxy() : CRDMapper.h
  • ICRDController_createVariable_Stub() : CRDMapper.h
  • ICRDController_get_Attribute_Proxy() : CRDMapper.h
  • ICRDController_get_Attribute_Stub() : CRDMapper.h
  • ICRDController_get_Command_Proxy() : CRDMapper.h
  • ICRDController_get_Command_Stub() : CRDMapper.h
  • ICRDController_get_CommandNames_Proxy() : CRDMapper.h
  • ICRDController_get_CommandNames_Stub() : CRDMapper.h
  • ICRDController_get_Extension_Proxy() : CRDMapper.h
  • ICRDController_get_Extension_Stub() : CRDMapper.h
  • ICRDController_get_ExtensionNames_Proxy() : CRDMapper.h
  • ICRDController_get_ExtensionNames_Stub() : CRDMapper.h
  • ICRDController_get_File_Proxy() : CRDMapper.h
  • ICRDController_get_File_Stub() : CRDMapper.h
  • ICRDController_get_FileNames_Proxy() : CRDMapper.h
  • ICRDController_get_FileNames_Stub() : CRDMapper.h
  • ICRDController_get_Help_Proxy() : CRDMapper.h
  • ICRDController_get_Help_Stub() : CRDMapper.h
  • ICRDController_get_ID_Proxy() : CRDMapper.h
  • ICRDController_get_ID_Stub() : CRDMapper.h
  • ICRDController_get_Message_Proxy() : CRDMapper.h
  • ICRDController_get_Message_Stub() : CRDMapper.h
  • ICRDController_get_MessageNumbers_Proxy() : CRDMapper.h
  • ICRDController_get_MessageNumbers_Stub() : CRDMapper.h
  • ICRDController_get_Name_Proxy() : CRDMapper.h
  • ICRDController_get_Name_Stub() : CRDMapper.h
  • ICRDController_get_Robot_Proxy() : CRDMapper.h
  • ICRDController_get_Robot_Stub() : CRDMapper.h
  • ICRDController_get_RobotNames_Proxy() : CRDMapper.h
  • ICRDController_get_RobotNames_Stub() : CRDMapper.h
  • ICRDController_get_Task_Proxy() : CRDMapper.h
  • ICRDController_get_Task_Stub() : CRDMapper.h
  • ICRDController_get_TaskNames_Proxy() : CRDMapper.h
  • ICRDController_get_TaskNames_Stub() : CRDMapper.h
  • ICRDController_get_Variable_Proxy() : CRDMapper.h
  • ICRDController_get_Variable_Stub() : CRDMapper.h
  • ICRDController_get_VariableNames_Proxy() : CRDMapper.h
  • ICRDController_get_VariableNames_Stub() : CRDMapper.h
  • ICRDController_get_XMLNode_Proxy() : CRDMapper.h
  • ICRDController_get_XMLNode_Stub() : CRDMapper.h
  • ICRDController_put_Attribute_Proxy() : CRDMapper.h
  • ICRDController_put_Attribute_Stub() : CRDMapper.h
  • ICRDController_put_Help_Proxy() : CRDMapper.h
  • ICRDController_put_Help_Stub() : CRDMapper.h
  • ICRDController_put_ID_Proxy() : CRDMapper.h
  • ICRDController_put_ID_Stub() : CRDMapper.h
  • ICRDController_removeCommand_Proxy() : CRDMapper.h
  • ICRDController_removeCommand_Stub() : CRDMapper.h
  • ICRDController_removeExtension_Proxy() : CRDMapper.h
  • ICRDController_removeExtension_Stub() : CRDMapper.h
  • ICRDController_removeFile_Proxy() : CRDMapper.h
  • ICRDController_removeFile_Stub() : CRDMapper.h
  • ICRDController_removeMessage_Proxy() : CRDMapper.h
  • ICRDController_removeMessage_Stub() : CRDMapper.h
  • ICRDController_removeRobot_Proxy() : CRDMapper.h
  • ICRDController_removeRobot_Stub() : CRDMapper.h
  • ICRDController_removeTask_Proxy() : CRDMapper.h
  • ICRDController_removeTask_Stub() : CRDMapper.h
  • ICRDController_removeVariable_Proxy() : CRDMapper.h
  • ICRDController_removeVariable_Stub() : CRDMapper.h
  • ICRDEngine : CRDMapper.h
  • ICRDEngine_appendController_Proxy() : CRDMapper.h
  • ICRDEngine_appendController_Stub() : CRDMapper.h
  • ICRDEngine_createController_Proxy() : CRDMapper.h
  • ICRDEngine_createController_Stub() : CRDMapper.h
  • ICRDEngine_CreateDocument_Proxy() : CRDMapper.h
  • ICRDEngine_CreateDocument_Stub() : CRDMapper.h
  • ICRDEngine_FormatStringOffsetTable : CRDMapper_p.c
  • ICRDEngine_get_Controller_Proxy() : CRDMapper.h
  • ICRDEngine_get_Controller_Stub() : CRDMapper.h
  • ICRDEngine_get_ControllerNames_Proxy() : CRDMapper.h
  • ICRDEngine_get_ControllerNames_Stub() : CRDMapper.h
  • ICRDEngine_get_Help_Proxy() : CRDMapper.h
  • ICRDEngine_get_Help_Stub() : CRDMapper.h
  • ICRDEngine_get_Version_Proxy() : CRDMapper.h
  • ICRDEngine_get_Version_Stub() : CRDMapper.h
  • ICRDEngine_load_Proxy() : CRDMapper.h
  • ICRDEngine_load_Stub() : CRDMapper.h
  • ICRDEngine_ProxyInfo : CRDMapper_p.c
  • ICRDEngine_put_Help_Proxy() : CRDMapper.h
  • ICRDEngine_put_Help_Stub() : CRDMapper.h
  • ICRDEngine_put_Version_Proxy() : CRDMapper.h
  • ICRDEngine_put_Version_Stub() : CRDMapper.h
  • ICRDEngine_removeController_Proxy() : CRDMapper.h
  • ICRDEngine_removeController_Stub() : CRDMapper.h
  • ICRDEngine_save_Proxy() : CRDMapper.h
  • ICRDEngine_save_Stub() : CRDMapper.h
  • ICRDEngine_saveAs_Proxy() : CRDMapper.h
  • ICRDEngine_saveAs_Stub() : CRDMapper.h
  • ICRDEngine_ServerInfo : CRDMapper_p.c
  • ICRDExtension : CRDMapper.h
  • ICRDExtension_appendVariable_Proxy() : CRDMapper.h
  • ICRDExtension_appendVariable_Stub() : CRDMapper.h
  • ICRDExtension_clone_Proxy() : CRDMapper.h
  • ICRDExtension_clone_Stub() : CRDMapper.h
  • ICRDExtension_createVariable_Proxy() : CRDMapper.h
  • ICRDExtension_createVariable_Stub() : CRDMapper.h
  • ICRDExtension_get_Attribute_Proxy() : CRDMapper.h
  • ICRDExtension_get_Attribute_Stub() : CRDMapper.h
  • ICRDExtension_get_Help_Proxy() : CRDMapper.h
  • ICRDExtension_get_Help_Stub() : CRDMapper.h
  • ICRDExtension_get_ID_Proxy() : CRDMapper.h
  • ICRDExtension_get_ID_Stub() : CRDMapper.h
  • ICRDExtension_get_Name_Proxy() : CRDMapper.h
  • ICRDExtension_get_Name_Stub() : CRDMapper.h
  • ICRDExtension_get_Variable_Proxy() : CRDMapper.h
  • ICRDExtension_get_Variable_Stub() : CRDMapper.h
  • ICRDExtension_get_VariableNames_Proxy() : CRDMapper.h
  • ICRDExtension_get_VariableNames_Stub() : CRDMapper.h
  • ICRDExtension_get_XMLNode_Proxy() : CRDMapper.h
  • ICRDExtension_get_XMLNode_Stub() : CRDMapper.h
  • ICRDExtension_put_Attribute_Proxy() : CRDMapper.h
  • ICRDExtension_put_Attribute_Stub() : CRDMapper.h
  • ICRDExtension_put_Help_Proxy() : CRDMapper.h
  • ICRDExtension_put_Help_Stub() : CRDMapper.h
  • ICRDExtension_put_ID_Proxy() : CRDMapper.h
  • ICRDExtension_put_ID_Stub() : CRDMapper.h
  • ICRDExtension_removeVariable_Proxy() : CRDMapper.h
  • ICRDExtension_removeVariable_Stub() : CRDMapper.h
  • ICRDFile : CRDMapper.h
  • ICRDFile_appendFile_Proxy() : CRDMapper.h
  • ICRDFile_appendFile_Stub() : CRDMapper.h
  • ICRDFile_appendVariable_Proxy() : CRDMapper.h
  • ICRDFile_appendVariable_Stub() : CRDMapper.h
  • ICRDFile_clone_Proxy() : CRDMapper.h
  • ICRDFile_clone_Stub() : CRDMapper.h
  • ICRDFile_createFile_Proxy() : CRDMapper.h
  • ICRDFile_createFile_Stub() : CRDMapper.h
  • ICRDFile_createVariable_Proxy() : CRDMapper.h
  • ICRDFile_createVariable_Stub() : CRDMapper.h
  • ICRDFile_get_Attribute_Proxy() : CRDMapper.h
  • ICRDFile_get_Attribute_Stub() : CRDMapper.h
  • ICRDFile_get_DateCreated_Proxy() : CRDMapper.h
  • ICRDFile_get_DateCreated_Stub() : CRDMapper.h
  • ICRDFile_get_DateLastAccessed_Proxy() : CRDMapper.h
  • ICRDFile_get_DateLastAccessed_Stub() : CRDMapper.h
  • ICRDFile_get_DateLastModified_Proxy() : CRDMapper.h
  • ICRDFile_get_DateLastModified_Stub() : CRDMapper.h
  • ICRDFile_get_File_Proxy() : CRDMapper.h
  • ICRDFile_get_File_Stub() : CRDMapper.h
  • ICRDFile_get_FileNames_Proxy() : CRDMapper.h
  • ICRDFile_get_FileNames_Stub() : CRDMapper.h
  • ICRDFile_get_Help_Proxy() : CRDMapper.h
  • ICRDFile_get_Help_Stub() : CRDMapper.h
  • ICRDFile_get_ID_Proxy() : CRDMapper.h
  • ICRDFile_get_ID_Stub() : CRDMapper.h
  • ICRDFile_get_Name_Proxy() : CRDMapper.h
  • ICRDFile_get_Name_Stub() : CRDMapper.h
  • ICRDFile_get_Path_Proxy() : CRDMapper.h
  • ICRDFile_get_Path_Stub() : CRDMapper.h
  • ICRDFile_get_Size_Proxy() : CRDMapper.h
  • ICRDFile_get_Size_Stub() : CRDMapper.h
  • ICRDFile_get_Type_Proxy() : CRDMapper.h
  • ICRDFile_get_Type_Stub() : CRDMapper.h
  • ICRDFile_get_Value_Proxy() : CRDMapper.h
  • ICRDFile_get_Value_Stub() : CRDMapper.h
  • ICRDFile_get_Variable_Proxy() : CRDMapper.h
  • ICRDFile_get_Variable_Stub() : CRDMapper.h
  • ICRDFile_get_VariableNames_Proxy() : CRDMapper.h
  • ICRDFile_get_VariableNames_Stub() : CRDMapper.h
  • ICRDFile_get_XMLNode_Proxy() : CRDMapper.h
  • ICRDFile_get_XMLNode_Stub() : CRDMapper.h
  • ICRDFile_put_Attribute_Proxy() : CRDMapper.h
  • ICRDFile_put_Attribute_Stub() : CRDMapper.h
  • ICRDFile_put_DateCreated_Proxy() : CRDMapper.h
  • ICRDFile_put_DateCreated_Stub() : CRDMapper.h
  • ICRDFile_put_DateLastAccessed_Proxy() : CRDMapper.h
  • ICRDFile_put_DateLastAccessed_Stub() : CRDMapper.h
  • ICRDFile_put_DateLastModified_Proxy() : CRDMapper.h
  • ICRDFile_put_DateLastModified_Stub() : CRDMapper.h
  • ICRDFile_put_Help_Proxy() : CRDMapper.h
  • ICRDFile_put_Help_Stub() : CRDMapper.h
  • ICRDFile_put_ID_Proxy() : CRDMapper.h
  • ICRDFile_put_ID_Stub() : CRDMapper.h
  • ICRDFile_put_Path_Proxy() : CRDMapper.h
  • ICRDFile_put_Path_Stub() : CRDMapper.h
  • ICRDFile_put_Size_Proxy() : CRDMapper.h
  • ICRDFile_put_Size_Stub() : CRDMapper.h
  • ICRDFile_put_Type_Proxy() : CRDMapper.h
  • ICRDFile_put_Type_Stub() : CRDMapper.h
  • ICRDFile_put_Value_Proxy() : CRDMapper.h
  • ICRDFile_put_Value_Stub() : CRDMapper.h
  • ICRDFile_removeFile_Proxy() : CRDMapper.h
  • ICRDFile_removeFile_Stub() : CRDMapper.h
  • ICRDFile_removeVariable_Proxy() : CRDMapper.h
  • ICRDFile_removeVariable_Stub() : CRDMapper.h
  • ICRDMessage : CRDMapper.h
  • ICRDMessage_clone_Proxy() : CRDMapper.h
  • ICRDMessage_clone_Stub() : CRDMapper.h
  • ICRDMessage_get_DateTime_Proxy() : CRDMapper.h
  • ICRDMessage_get_DateTime_Stub() : CRDMapper.h
  • ICRDMessage_get_Description_Proxy() : CRDMapper.h
  • ICRDMessage_get_Description_Stub() : CRDMapper.h
  • ICRDMessage_get_Destination_Proxy() : CRDMapper.h
  • ICRDMessage_get_Destination_Stub() : CRDMapper.h
  • ICRDMessage_get_ID_Proxy() : CRDMapper.h
  • ICRDMessage_get_ID_Stub() : CRDMapper.h
  • ICRDMessage_get_Number_Proxy() : CRDMapper.h
  • ICRDMessage_get_Number_Stub() : CRDMapper.h
  • ICRDMessage_get_Source_Proxy() : CRDMapper.h
  • ICRDMessage_get_Source_Stub() : CRDMapper.h
  • ICRDMessage_get_Value_Proxy() : CRDMapper.h
  • ICRDMessage_get_Value_Stub() : CRDMapper.h
  • ICRDMessage_get_XMLNode_Proxy() : CRDMapper.h
  • ICRDMessage_get_XMLNode_Stub() : CRDMapper.h
  • ICRDMessage_put_DateTime_Proxy() : CRDMapper.h
  • ICRDMessage_put_DateTime_Stub() : CRDMapper.h
  • ICRDMessage_put_Description_Proxy() : CRDMapper.h
  • ICRDMessage_put_Description_Stub() : CRDMapper.h
  • ICRDMessage_put_Destination_Proxy() : CRDMapper.h
  • ICRDMessage_put_Destination_Stub() : CRDMapper.h
  • ICRDMessage_put_ID_Proxy() : CRDMapper.h
  • ICRDMessage_put_ID_Stub() : CRDMapper.h
  • ICRDMessage_put_Source_Proxy() : CRDMapper.h
  • ICRDMessage_put_Source_Stub() : CRDMapper.h
  • ICRDMessage_put_Value_Proxy() : CRDMapper.h
  • ICRDMessage_put_Value_Stub() : CRDMapper.h
  • ICRDRobot : CRDMapper.h
  • ICRDRobot_appendVariable_Proxy() : CRDMapper.h
  • ICRDRobot_appendVariable_Stub() : CRDMapper.h
  • ICRDRobot_clone_Proxy() : CRDMapper.h
  • ICRDRobot_clone_Stub() : CRDMapper.h
  • ICRDRobot_createVariable_Proxy() : CRDMapper.h
  • ICRDRobot_createVariable_Stub() : CRDMapper.h
  • ICRDRobot_get_Attribute_Proxy() : CRDMapper.h
  • ICRDRobot_get_Attribute_Stub() : CRDMapper.h
  • ICRDRobot_get_Help_Proxy() : CRDMapper.h
  • ICRDRobot_get_Help_Stub() : CRDMapper.h
  • ICRDRobot_get_ID_Proxy() : CRDMapper.h
  • ICRDRobot_get_ID_Stub() : CRDMapper.h
  • ICRDRobot_get_Name_Proxy() : CRDMapper.h
  • ICRDRobot_get_Name_Stub() : CRDMapper.h
  • ICRDRobot_get_Variable_Proxy() : CRDMapper.h
  • ICRDRobot_get_Variable_Stub() : CRDMapper.h
  • ICRDRobot_get_VariableNames_Proxy() : CRDMapper.h
  • ICRDRobot_get_VariableNames_Stub() : CRDMapper.h
  • ICRDRobot_get_XMLNode_Proxy() : CRDMapper.h
  • ICRDRobot_get_XMLNode_Stub() : CRDMapper.h
  • ICRDRobot_put_Attribute_Proxy() : CRDMapper.h
  • ICRDRobot_put_Attribute_Stub() : CRDMapper.h
  • ICRDRobot_put_Help_Proxy() : CRDMapper.h
  • ICRDRobot_put_Help_Stub() : CRDMapper.h
  • ICRDRobot_put_ID_Proxy() : CRDMapper.h
  • ICRDRobot_put_ID_Stub() : CRDMapper.h
  • ICRDRobot_removeVariable_Proxy() : CRDMapper.h
  • ICRDRobot_removeVariable_Stub() : CRDMapper.h
  • ICRDTask : CRDMapper.h
  • ICRDTask_appendVariable_Proxy() : CRDMapper.h
  • ICRDTask_appendVariable_Stub() : CRDMapper.h
  • ICRDTask_clone_Proxy() : CRDMapper.h
  • ICRDTask_clone_Stub() : CRDMapper.h
  • ICRDTask_createVariable_Proxy() : CRDMapper.h
  • ICRDTask_createVariable_Stub() : CRDMapper.h
  • ICRDTask_get_Attribute_Proxy() : CRDMapper.h
  • ICRDTask_get_Attribute_Stub() : CRDMapper.h
  • ICRDTask_get_FileName_Proxy() : CRDMapper.h
  • ICRDTask_get_FileName_Stub() : CRDMapper.h
  • ICRDTask_get_Help_Proxy() : CRDMapper.h
  • ICRDTask_get_Help_Stub() : CRDMapper.h
  • ICRDTask_get_ID_Proxy() : CRDMapper.h
  • ICRDTask_get_ID_Stub() : CRDMapper.h
  • ICRDTask_get_Name_Proxy() : CRDMapper.h
  • ICRDTask_get_Name_Stub() : CRDMapper.h
  • ICRDTask_get_Variable_Proxy() : CRDMapper.h
  • ICRDTask_get_Variable_Stub() : CRDMapper.h
  • ICRDTask_get_VariableNames_Proxy() : CRDMapper.h
  • ICRDTask_get_VariableNames_Stub() : CRDMapper.h
  • ICRDTask_get_XMLNode_Proxy() : CRDMapper.h
  • ICRDTask_get_XMLNode_Stub() : CRDMapper.h
  • ICRDTask_put_Attribute_Proxy() : CRDMapper.h
  • ICRDTask_put_Attribute_Stub() : CRDMapper.h
  • ICRDTask_put_FileName_Proxy() : CRDMapper.h
  • ICRDTask_put_FileName_Stub() : CRDMapper.h
  • ICRDTask_put_Help_Proxy() : CRDMapper.h
  • ICRDTask_put_Help_Stub() : CRDMapper.h
  • ICRDTask_put_ID_Proxy() : CRDMapper.h
  • ICRDTask_put_ID_Stub() : CRDMapper.h
  • ICRDTask_removeVariable_Proxy() : CRDMapper.h
  • ICRDTask_removeVariable_Stub() : CRDMapper.h
  • ICRDVariable : CRDMapper.h
  • ICRDVariable_clone_Proxy() : CRDMapper.h
  • ICRDVariable_clone_Stub() : CRDMapper.h
  • ICRDVariable_get_Attribute_Proxy() : CRDMapper.h
  • ICRDVariable_get_Attribute_Stub() : CRDMapper.h
  • ICRDVariable_get_DateTime_Proxy() : CRDMapper.h
  • ICRDVariable_get_DateTime_Stub() : CRDMapper.h
  • ICRDVariable_get_Help_Proxy() : CRDMapper.h
  • ICRDVariable_get_Help_Stub() : CRDMapper.h
  • ICRDVariable_get_ID_Proxy() : CRDMapper.h
  • ICRDVariable_get_ID_Stub() : CRDMapper.h
  • ICRDVariable_get_Microsecond_Proxy() : CRDMapper.h
  • ICRDVariable_get_Microsecond_Stub() : CRDMapper.h
  • ICRDVariable_get_Name_Proxy() : CRDMapper.h
  • ICRDVariable_get_Name_Stub() : CRDMapper.h
  • ICRDVariable_get_Value_Proxy() : CRDMapper.h
  • ICRDVariable_get_Value_Stub() : CRDMapper.h
  • ICRDVariable_get_XMLNode_Proxy() : CRDMapper.h
  • ICRDVariable_get_XMLNode_Stub() : CRDMapper.h
  • ICRDVariable_put_Attribute_Proxy() : CRDMapper.h
  • ICRDVariable_put_Attribute_Stub() : CRDMapper.h
  • ICRDVariable_put_DateTime_Proxy() : CRDMapper.h
  • ICRDVariable_put_DateTime_Stub() : CRDMapper.h
  • ICRDVariable_put_Help_Proxy() : CRDMapper.h
  • ICRDVariable_put_Help_Stub() : CRDMapper.h
  • ICRDVariable_put_ID_Proxy() : CRDMapper.h
  • ICRDVariable_put_ID_Stub() : CRDMapper.h
  • ICRDVariable_put_Microsecond_Proxy() : CRDMapper.h
  • ICRDVariable_put_Microsecond_Stub() : CRDMapper.h
  • ICRDVariable_put_Value_Proxy() : CRDMapper.h
  • ICRDVariable_put_Value_Stub() : CRDMapper.h
  • IDR_CRDCONTROLLER : resource.h
  • IDR_CRDENGINE : resource.h
  • IDR_CRDEXTENSION : resource.h
  • IDR_CRDFILE : resource.h
  • IDR_CRDROBOT : resource.h
  • IDR_CRDTASK : resource.h
  • IDR_CRDVARIABLE : resource.h
  • IDS_PROJNAME : resource.h
  • IID : CRDMapper_i.c
  • IID_ICRDCommand : CRDMapper_i.c, CRDMapper.h
  • IID_ICRDController : CRDMapper_i.c, CRDMapper.h
  • IID_ICRDEngine : CRDMapper_i.c, CRDMapper.h
  • IID_ICRDExtension : CRDMapper_i.c, CRDMapper.h
  • IID_ICRDFile : CRDMapper_i.c, CRDMapper.h
  • IID_ICRDMessage : CRDMapper_i.c, CRDMapper.h
  • IID_ICRDRobot : CRDMapper_i.c, CRDMapper.h
  • IID_ICRDTask : CRDMapper_i.c, CRDMapper.h
  • IID_ICRDVariable : CRDMapper_i.c, CRDMapper.h

- l -

  • LIBID_CRDMAPPERLib : CRDMapper_i.c, CRDMapper.h
  • load() : CRDMapper.h

- m -

  • MAX_BUFFER : CRD.h
  • MIDL_PROC_FORMAT_STRING : CRDMapper_p.c
  • MIDL_TYPE_FORMAT_STRING : CRDMapper_p.c
  • MIDL_user_allocate() : CRDMapper.h
  • MIDL_user_free() : CRDMapper.h

- o -

  • Object_StubDesc : CRDMapper_p.c

- p -

  • PROC_FORMAT_STRING_SIZE : CRDMapper_p.c
  • PROXY_DELEGATION : dlldata.c
  • put_Attribute() : CRDMapper.h
  • put_DateCreated() : CRDMapper.h
  • put_DateLastAccessed() : CRDMapper.h
  • put_DateLastModified() : CRDMapper.h
  • put_DateTime() : CRDMapper.h
  • put_Description() : CRDMapper.h
  • put_Destination() : CRDMapper.h
  • put_FileName() : CRDMapper.h
  • put_Help() : CRDMapper.h
  • put_ID() : CRDMapper.h
  • put_Microsecond() : CRDMapper.h
  • put_Parameters() : CRDMapper.h
  • put_Path() : CRDMapper.h
  • put_Size() : CRDMapper.h
  • put_Source() : CRDMapper.h
  • put_State() : CRDMapper.h
  • put_Timeout() : CRDMapper.h
  • put_Type() : CRDMapper.h
  • put_Value() : CRDMapper.h
  • put_Version() : CRDMapper.h

- r -

  • REFERENCE_PROXY_FILE() : dlldata.c
  • removeCommand() : CRDMapper.h
  • removeController() : CRDMapper.h
  • removeExtension() : CRDMapper.h
  • removeFile() : CRDMapper.h
  • removeMessage() : CRDMapper.h
  • removeRobot() : CRDMapper.h
  • removeTask() : CRDMapper.h
  • removeVariable() : CRDMapper.h

- s -

  • save() : CRDMapper.h
  • saveAs() : CRDMapper.h
  • STRICT : StdAfx.h

- t -

  • TYPE_FORMAT_STRING_SIZE : CRDMapper_p.c
  • TYPE_NODE_ATTRIBUTE : CRD.h
  • TYPE_NODE_ELEMENT : CRD.h
  • TYPE_NODE_TEXT : CRD.h

- u -

  • USE_STUBLESS_PROXY : CRDMapper_p.c

- v -

  • VARIANT_UserFree() : CRDMapper.h
  • VARIANT_UserMarshal() : CRDMapper.h
  • VARIANT_UserSize() : CRDMapper.h
  • VARIANT_UserUnmarshal() : CRDMapper.h

- x -

  • XML_ELEM_PROCESS : CRD.h
  • XML_LOAD_ASYNC : CRD.h
  • XML_NODE_DATA : CRD.h
  • XML_SCHEMA_INSTANCE : CRD.h
  • XML_VARIDATION : CRD.h
  • XPATH_CRD_NAMESPACE : CRD.h
  • XPATH_DOC_PROPERTY : CRD.h
  • XPATH_NAMED_NODE : CRD.h
  • XPATH_NUMBER_NODE : CRD.h
  • XPATH_PREFIX_NODE : CRD.h
  • XSI_ATTR_NS : CRD.h
Generated on Thu Jan 27 18:50:16 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


Namespace Member Index

CRDMapper Project 名前空間メンバ

i

これは名前空間の一覧です。それぞれの名前空間の解説へリンクしています。

- i -

  • importlib() : CRDMAPPERLib
Generated on Thu Jan 27 18:50:16 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


Graphical Class Hierarchy

CRDMapper Project クラス階層図

クラス階層図を見る。

Generated on Thu Jan 27 18:50:17 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


_CCRDNodeTemplate.h Source File

_CCRDNodeTemplate.h

解説を見る。
00001
00010 #if !defined(AFX_CRDNODE_H__48D0C551_35F0_47C0_A616_5A199A2D49D0__INCLUDED_)
00011 #define AFX_CRDNODE_H__48D0C551_35F0_47C0_A616_5A199A2D49D0__INCLUDED_
00012
00013 #if _MSC_VER > 1000
00014 #pragma once
00015 #endif // _MSC_VER > 1000
00016
00022 template <class T, const CLSID* pclsid, class T1, const IID* piid>
00023 class ATL_NO_VTABLE _CCRDNodeTemplate :
00024     public CComObjectRootEx<CComMultiThreadModel>,
00025     public CComCoClass<T, pclsid>,
00026     public ISupportErrorInfo,
00027     public IDispatchImpl<T1, piid, &LIBID_CRDMAPPERLib>
00028 {
00029 public:
00030     _CCRDNodeTemplate()
00031     {
00032     };
00033
00034 //DECLARE_REGISTRY_RESOURCEID(IDR_CRDCONTROLLER)
00035
00036 DECLARE_PROTECT_FINAL_CONSTRUCT()
00037
00038 BEGIN_COM_MAP(T)
00039     COM_INTERFACE_ENTRY(T1)
00040     COM_INTERFACE_ENTRY(IDispatch)
00041     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00042 END_COM_MAP()
00043
00044
00045
00053     STDMETHODIMP InterfaceSupportsErrorInfo(REFIID riid)
00054     {
00055         static const IID* arr[] =
00056         {
00057             piid
00058         };
00059         for (int i=0; i < sizeof(arr) / sizeof(arr[0]); i++) {
00060             if (InlineIsEqualGUID(*arr[i],riid)) {
00061                 return S_OK;
00062             }
00063         }
00064         return S_FALSE;
00065     }
00066
00075     HRESULT _Initialize(IXMLDOMNode* pINode)
00076     {
00077         if (pINode == NULL) {
00078             return E_INVALIDARG;
00079         }
00080
00081         m_pINode = pINode;
00082
00083         return S_OK;
00084     }
00085
00095     STDMETHODIMP get_Name(BSTR *pVal)
00096     {
00097         _variant_t vntVal;
00098         HRESULT hr = CCRDUtility::GetNodeAttribute(CRD_ATTR_NAME, m_pINode, VT_BSTR, &vntVal);
00099         if (SUCCEEDED(hr)) {
00100             if (vntVal.vt == VT_BSTR) {
00101                 *pVal = SysAllocString(vntVal.bstrVal);
00102             } else {
00103                 return E_UNEXPECTED;
00104             }
00105         }
00106
00107         return hr;
00108     }
00109
00118     STDMETHODIMP get_Attribute(long *pVal)
00119     {
00120         _variant_t vntVal;
00121         HRESULT hr = CCRDUtility::GetNodeValue(CRD_ELEM_ATTRIBUTE, m_pINode, VT_I4, &vntVal);
00122         if (SUCCEEDED(hr)) {
00123             if (vntVal.vt == VT_I4) {
00124                 *pVal = vntVal.lVal;
00125             } else {
00126                 hr = E_FAIL;
00127             }
00128         }
00129
00130         return hr;
00131     }
00132
00142     STDMETHODIMP put_Attribute(long newVal)
00143     {
00144         HRESULT hr = CCRDUtility::SetNodeValue(CRD_ELEM_ATTRIBUTE, m_pINode, _variant_t(newVal));
00145         if (hr == S_FALSE) {
00146             // Append blank Attribute element
00147             IXMLDOMElementPtr attrElement;
00148             hr = CCRDUtility::CreateElement(CRD_ELEM_ATTRIBUTE, m_pINode, &attrElement);
00149             if (FAILED(hr)) {
00150                 return hr;
00151             }
00152
00153             hr = attrElement->put_nodeTypedValue(_variant_t(newVal));
00154             if (FAILED(hr)) {
00155                 return hr;
00156             }
00157
00158             // 子ノードの先頭に追加
00159             IXMLDOMNodePtr pFirstChild;
00160             hr = m_pINode->get_firstChild(&pFirstChild);
00161             if (FAILED(hr)) {
00162                 return hr;
00163             }
00164             if (hr == S_OK) {
00165                 hr = m_pINode->insertBefore(attrElement, _variant_t(pFirstChild.GetInterfacePtr()), NULL);
00166             } else {
00167                 hr = m_pINode->appendChild(attrElement, NULL);
00168             }
00169         }
00170
00171         return hr;
00172     }
00173
00182     STDMETHODIMP get_Help(BSTR *pVal)
00183     {
00184         _variant_t vntVal;
00185         HRESULT hr = CCRDUtility::GetNodeValue(CRD_ELEM_HELP, m_pINode, VT_BSTR, &vntVal);
00186         if (SUCCEEDED(hr)) {
00187             if (vntVal.vt == VT_BSTR) {
00188                 *pVal = SysAllocString(vntVal.bstrVal);
00189             } else {
00190                 hr = E_FAIL;
00191             }
00192         }
00193
00194         return hr;
00195     }
00196
00206     STDMETHODIMP put_Help(BSTR newVal)
00207     {
00208
00209         HRESULT hr = CCRDUtility::SetNodeValue(CRD_ELEM_HELP, m_pINode, _variant_t(newVal));
00210         if (hr == S_FALSE) {
00211             // Append blank Help element
00212             IXMLDOMElementPtr helpElement;
00213             hr = CCRDUtility::CreateElement(CRD_ELEM_HELP, m_pINode, &helpElement);
00214             if (FAILED(hr)) {
00215                 return hr;
00216             }
00217
00218             hr = helpElement->put_nodeTypedValue(_variant_t(newVal));
00219             if (FAILED(hr)) {
00220                 return hr;
00221             }
00222
00223             // Attributeノードの後ろに追加する．
00224             IXMLDOMNodeListPtr pChildNodes;
00225             IXMLDOMNodePtr pIChildNode;
00226             hr = m_pINode->get_childNodes(&pChildNodes);
00227             if(FAILED(hr)) {
00228                 return hr;
00229             }
00230             // 先頭の子ノードを取得
00231             hr = pChildNodes->get_item(0, &pIChildNode);
00232             if(FAILED(hr)) {
00233                 return hr;
00234             } else if (hr == S_OK) {    // 子ノードがあるとき
00235                 CComBSTR bstrNodeName;
00236                 hr = pIChildNode->get_nodeName(&bstrNodeName);
00237                 if(FAILED(hr)) {
00238                     return hr;
00239                 }
00240                 // 先頭の子ノードがAttributeのときは，次の子ノードに移動する．
00241                 if (bstrNodeName == CRD_ELEM_ATTRIBUTE) {
00242                     hr = pChildNodes->get_item(1, &pIChildNode);
00243                     if(FAILED(hr)) {
00244                         return hr;
00245                     }
00246                 }
00247             }
00248             if (hr == S_OK) {
00249                 // 取得した子ノードの前にHelpノードを追加
00250                 hr = m_pINode->insertBefore(helpElement, _variant_t(pIChildNode.GetInterfacePtr()), NULL);
00251             } else {    // ノードがないとき
00252                 hr = m_pINode->appendChild(helpElement, NULL);
00253             }
00254         }
00255
00256         return hr;
00257     }
00258
00267     STDMETHODIMP get_ID(VARIANT *pVal)
00268     {
00269         return CCRDUtility::GetNodeVariant(CRD_ELEM_ID, m_pINode, pVal);
00270     }
00271
00281     STDMETHODIMP put_ID(VARIANT newVal)
00282     {
00283
00284         // Valueエレメントの作成
00285         IXMLDOMElementPtr addElement;
00286         HRESULT hr = CCRDUtility::CreateVariantNode(CRD_ELEM_ID, newVal, m_pINode, &addElement);
00287         if (FAILED(hr)) {
00288             return hr;
00289         }
00290
00291         // Helpノードの後ろに追加する．
00292         IXMLDOMNodeListPtr pChildNodes;
00293         IXMLDOMNodePtr pIChildNode;
00294         hr = m_pINode->get_childNodes(&pChildNodes);
00295         if(FAILED(hr)) {
00296             return hr;
00297         }
00298
00299         // 追加位置のサーチ
00300         CComBSTR bstrNodeName;
00301         long lCnt = 0;
00302         while (hr == S_OK) {
00303             hr = pChildNodes->get_item(lCnt, &pIChildNode);
00304             if (FAILED(hr)) {
00305                 return hr;
00306             } else if (hr == S_FALSE) {
00307                 continue;
00308             }
00309
00310             hr = pIChildNode->get_nodeName(&bstrNodeName);
00311             if(FAILED(hr)) {
00312                 break;
00313             }
00314             // 後ろにあるタグを見つけたら検索終了
00315             if (!(bstrNodeName == CRD_ELEM_ATTRIBUTE || bstrNodeName == CRD_ELEM_HELP)) {
00316                 break;
00317             }
00318             lCnt++;
00319         }
00320
00321         if (hr == S_OK) {
00322             // 取得した子ノードの前にIDノードを追加
00323             hr = m_pINode->insertBefore(addElement, _variant_t(pIChildNode.GetInterfacePtr()), NULL);
00324         } else {    // ノードがないとき
00325             hr = m_pINode->appendChild(addElement, NULL);
00326         }
00327
00328         return hr;
00329     }
00330
00339     STDMETHODIMP get_XMLNode(IUnknown **pVal)
00340     {
00341         *pVal = m_pINode;
00342         m_pINode.AddRef();
00343         return S_OK;
00344     }
00345
00346 protected:
00347     IXMLDOMNodePtr m_pINode;        //< <code>CRDNode</code> のノード位置を示すオブジェクト
00348
00349 };
00350
00351 #endif // !defined(AFX_CRDNODE_H__48D0C551_35F0_47C0_A616_5A199A2D49D0__INCLUDED_)
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_CCRDNodeTemplate< T, pclsid, T1, piid > メンバ一覧

これは全メンバの一覧です。_CCRDNodeTemplate< T, pclsid, T1, piid >継承メンバも含んでいます。
_CCRDNodeTemplate() | _CCRDNodeTemplate< T, pclsid, T1, piid > | [inline]
_Initialize(IXMLDOMNode *pINode) | _CCRDNodeTemplate< T, pclsid, T1, piid > | [inline]
get_Attribute(long *pVal) | _CCRDNodeTemplate< T, pclsid, T1, piid > | [inline]
get_Help(BSTR *pVal) | _CCRDNodeTemplate< T, pclsid, T1, piid > | [inline]
get_ID(VARIANT *pVal) | _CCRDNodeTemplate< T, pclsid, T1, piid > | [inline]
get_Name(BSTR *pVal) | _CCRDNodeTemplate< T, pclsid, T1, piid > | [inline]
get_XMLNode(IUnknown **pVal) | _CCRDNodeTemplate< T, pclsid, T1, piid > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCRDNodeTemplate< T, pclsid, T1, piid > | [inline]
m_pINode | _CCRDNodeTemplate< T, pclsid, T1, piid > | [protected]
put_Attribute(long newVal) | _CCRDNodeTemplate< T, pclsid, T1, piid > | [inline]
put_Help(BSTR newVal) | _CCRDNodeTemplate< T, pclsid, T1, piid > | [inline]
put_ID(VARIANT newVal) | _CCRDNodeTemplate< T, pclsid, T1, piid > | [inline]
Generated on Thu Jan 27 18:50:09 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCRDCommand メンバ一覧

これは全メンバの一覧です。CCRDCommand継承メンバも含んでいます。
_CCRDNodeTemplate() | _CCRDNodeTemplate< CCRDCommand,&CLSID_CRDCommand, ICRDCommand,&IID_ICRDCommand > | [inline]
_Initialize(IXMLDOMNode *pINode) | _CCRDNodeTemplate< CCRDCommand,&CLSID_CRDCommand, ICRDCommand,&IID_ICRDCommand > | [inline]
clone(BSTR bstrDestName, ICRDCommand **pVal) | CCRDCommand |
get_Attribute(long *pVal) | _CCRDNodeTemplate< CCRDCommand,&CLSID_CRDCommand, ICRDCommand,&IID_ICRDCommand > | [inline]
get_Help(BSTR *pVal) | _CCRDNodeTemplate< CCRDCommand,&CLSID_CRDCommand, ICRDCommand,&IID_ICRDCommand > | [inline]
get_ID(VARIANT *pVal) | _CCRDNodeTemplate< CCRDCommand,&CLSID_CRDCommand, ICRDCommand,&IID_ICRDCommand > | [inline]
get_Name(BSTR *pVal) | _CCRDNodeTemplate< CCRDCommand,&CLSID_CRDCommand, ICRDCommand,&IID_ICRDCommand > | [inline]
get_Parameters(VARIANT *pVal) | CCRDCommand |
get_State(long *pVal) | CCRDCommand |
get_Timeout(long *pVal) | CCRDCommand |
get_XMLNode(IUnknown **pVal) | _CCRDNodeTemplate< CCRDCommand,&CLSID_CRDCommand, ICRDCommand,&IID_ICRDCommand > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCRDNodeTemplate< CCRDCommand,&CLSID_CRDCommand, ICRDCommand,&IID_ICRDCommand > | [inline]
m_pINode | _CCRDNodeTemplate< CCRDCommand,&CLSID_CRDCommand, ICRDCommand,&IID_ICRDCommand > | [protected]
put_Attribute(long newVal) | _CCRDNodeTemplate< CCRDCommand,&CLSID_CRDCommand, ICRDCommand,&IID_ICRDCommand > | [inline]
put_Help(BSTR newVal) | _CCRDNodeTemplate< CCRDCommand,&CLSID_CRDCommand, ICRDCommand,&IID_ICRDCommand > | [inline]
put_ID(VARIANT newVal) | _CCRDNodeTemplate< CCRDCommand,&CLSID_CRDCommand, ICRDCommand,&IID_ICRDCommand > | [inline]
put_Parameters(VARIANT newVal) | CCRDCommand |
put_State(long newVal) | CCRDCommand |
put_Timeout(long newVal) | CCRDCommand |
Generated on Thu Jan 27 18:50:11 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCRDController メンバ一覧

これは全メンバの一覧です。CCRDController継承メンバも含んでいます。
_CCRDNodeTemplate() | _CCRDNodeTemplate< CCRDController,&CLSID_CRDController, ICRDController,&IID_ICRDController > | [inline]
_Initialize(IXMLDOMNode *pINode) | _CCRDNodeTemplate< CCRDController,&CLSID_CRDController, ICRDController,&IID_ICRDController > | [inline]
appendCommand(ICRDCommand *newVar) | CCRDController |
appendExtension(ICRDExtension *newExt) | CCRDController |
appendFile(ICRDFile *newFile) | CCRDController |
appendMessage(ICRDMessage *newVar) | CCRDController |
appendRobot(ICRDRobot *newRobot) | CCRDController |
appendTask(ICRDTask *newTask) | CCRDController |
appendVariable(ICRDVariable *newVar) | CCRDController |
clone(BSTR bstrDestName, ICRDController **pVal) | CCRDController |
createCommand(BSTR bstrName, ICRDCommand **pVal) | CCRDController |
createExtension(BSTR bstrName, ICRDExtension **pVal) | CCRDController |
createFile(BSTR bstrName, ICRDFile **pVal) | CCRDController |
createMessage(long lNumber, ICRDMessage **pVal) | CCRDController |
createRobot(BSTR bstrName, ICRDRobot **pVal) | CCRDController |
createTask(BSTR bstrName, ICRDTask **pVal) | CCRDController |
createVariable(BSTR bstrName, ICRDVariable **pVal) | CCRDController |
get_Attribute(long *pVal) | _CCRDNodeTemplate< CCRDController,&CLSID_CRDController, ICRDController,&IID_ICRDController > | [inline]
get_Command(BSTR bstrName, ICRDCommand **pVal) | CCRDController |
get_CommandNames(VARIANT *pVal) | CCRDController |
get_Extension(BSTR bstrName, ICRDExtension **pVal) | CCRDController |
get_ExtensionNames(VARIANT *pVal) | CCRDController |
get_File(BSTR bstrName, ICRDFile **pVal) | CCRDController |
get_FileNames(VARIANT *pVal) | CCRDController |
get_Help(BSTR *pVal) | _CCRDNodeTemplate< CCRDController,&CLSID_CRDController, ICRDController,&IID_ICRDController > | [inline]
get_ID(VARIANT *pVal) | _CCRDNodeTemplate< CCRDController,&CLSID_CRDController, ICRDController,&IID_ICRDController > | [inline]
get_Message(long lNumber, ICRDMessage **pVal) | CCRDController |
get_MessageNumbers(VARIANT *pVal) | CCRDController |
get_Name(BSTR *pVal) | _CCRDNodeTemplate< CCRDController,&CLSID_CRDController, ICRDController,&IID_ICRDController > | [inline]
get_Robot(BSTR bstrName, ICRDRobot **pVal) | CCRDController |
get_RobotNames(VARIANT *pVal) | CCRDController |
get_Task(BSTR bstrName, ICRDTask **pVal) | CCRDController |
get_TaskNames(VARIANT *pVal) | CCRDController |
get_Variable(BSTR bstrName, ICRDVariable **pVal) | CCRDController |
get_VariableNames(VARIANT *pVal) | CCRDController |
get_XMLNode(IUnknown **pVal) | _CCRDNodeTemplate< CCRDController,&CLSID_CRDController, ICRDController,&IID_ICRDController > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCRDNodeTemplate< CCRDController,&CLSID_CRDController, ICRDController,&IID_ICRDController > | [inline]
m_pINode | _CCRDNodeTemplate< CCRDController,&CLSID_CRDController, ICRDController,&IID_ICRDController > | [protected]
put_Attribute(long newVal) | _CCRDNodeTemplate< CCRDController,&CLSID_CRDController, ICRDController,&IID_ICRDController > | [inline]
put_Help(BSTR newVal) | _CCRDNodeTemplate< CCRDController,&CLSID_CRDController, ICRDController,&IID_ICRDController > | [inline]
put_ID(VARIANT newVal) | _CCRDNodeTemplate< CCRDController,&CLSID_CRDController, ICRDController,&IID_ICRDController > | [inline]
removeCommand(BSTR bstrName) | CCRDController |
removeExtension(BSTR bstrName) | CCRDController |
removeFile(BSTR bstrName) | CCRDController |
removeMessage(long lNumber) | CCRDController |
removeRobot(BSTR bstrName) | CCRDController |
removeTask(BSTR bstrName) | CCRDController |
removeVariable(BSTR bstrName) | CCRDController |
Generated on Thu Jan 27 18:50:11 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCRDEngine メンバ一覧

これは全メンバの一覧です。CCRDEngine継承メンバも含んでいます。
appendController(ICRDController *newCtrl) | CCRDEngine |
CCRDEngine() | CCRDEngine | [inline]
createController(BSTR bstrName, ICRDController **pVal) | CCRDEngine |
CreateDocument() | CCRDEngine |
get_Controller(BSTR bstrName, ICRDController **pVal) | CCRDEngine |
get_ControllerNames(VARIANT *pVal) | CCRDEngine |
get_Help(BSTR *pVal) | CCRDEngine |
get_Version(BSTR *pVal) | CCRDEngine |
InterfaceSupportsErrorInfo(REFIID riid) | CCRDEngine |
load(BSTR bstrFileName) | CCRDEngine |
put_Help(BSTR newVal) | CCRDEngine |
put_Version(BSTR newVal) | CCRDEngine |
removeController(BSTR bstrName) | CCRDEngine |
save() | CCRDEngine |
saveAs(BSTR bstrFileName) | CCRDEngine |
Generated on Thu Jan 27 18:50:11 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCRDExtension メンバ一覧

これは全メンバの一覧です。CCRDExtension継承メンバも含んでいます。
_CCRDNodeTemplate() | _CCRDNodeTemplate< CCRDExtension,&CLSID_CRDExtension, ICRDExtension,&IID_ICRDExtension > | [inline]
_Initialize(IXMLDOMNode *pINode) | _CCRDNodeTemplate< CCRDExtension,&CLSID_CRDExtension, ICRDExtension,&IID_ICRDExtension > | [inline]
appendVariable(ICRDVariable *newVar) | CCRDExtension |
clone(BSTR bstrDestName, ICRDExtension **pVal) | CCRDExtension |
createVariable(BSTR bstrName, ICRDVariable **pVal) | CCRDExtension |
get_Attribute(long *pVal) | _CCRDNodeTemplate< CCRDExtension,&CLSID_CRDExtension, ICRDExtension,&IID_ICRDExtension > | [inline]
get_Help(BSTR *pVal) | _CCRDNodeTemplate< CCRDExtension,&CLSID_CRDExtension, ICRDExtension,&IID_ICRDExtension > | [inline]
get_ID(VARIANT *pVal) | _CCRDNodeTemplate< CCRDExtension,&CLSID_CRDExtension, ICRDExtension,&IID_ICRDExtension > | [inline]
get_Name(BSTR *pVal) | _CCRDNodeTemplate< CCRDExtension,&CLSID_CRDExtension, ICRDExtension,&IID_ICRDExtension > | [inline]
get_Variable(BSTR bstrName, ICRDVariable **pVal) | CCRDExtension |
get_VariableNames(VARIANT *pVal) | CCRDExtension |
get_XMLNode(IUnknown **pVal) | _CCRDNodeTemplate< CCRDExtension,&CLSID_CRDExtension, ICRDExtension,&IID_ICRDExtension > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCRDNodeTemplate< CCRDExtension,&CLSID_CRDExtension, ICRDExtension,&IID_ICRDExtension > | [inline]
m_pINode | _CCRDNodeTemplate< CCRDExtension,&CLSID_CRDExtension, ICRDExtension,&IID_ICRDExtension > | [protected]
put_Attribute(long newVal) | _CCRDNodeTemplate< CCRDExtension,&CLSID_CRDExtension, ICRDExtension,&IID_ICRDExtension > | [inline]
put_Help(BSTR newVal) | _CCRDNodeTemplate< CCRDExtension,&CLSID_CRDExtension, ICRDExtension,&IID_ICRDExtension > | [inline]
put_ID(VARIANT newVal) | _CCRDNodeTemplate< CCRDExtension,&CLSID_CRDExtension, ICRDExtension,&IID_ICRDExtension > | [inline]
removeVariable(BSTR bstrName) | CCRDExtension |
Generated on Thu Jan 27 18:50:12 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCRDFile メンバ一覧

これは全メンバの一覧です。CCRDFile継承メンバも含んでいます。
_CCRDNodeTemplate() | _CCRDNodeTemplate< CCRDFile,&CLSID_CRDFile, ICRDFile,&IID_ICRDFile > | [inline]
_Initialize(IXMLDOMNode *pINode) | _CCRDNodeTemplate< CCRDFile,&CLSID_CRDFile, ICRDFile,&IID_ICRDFile > | [inline]
appendFile(ICRDFile *newFile) | CCRDFile |
appendVariable(ICRDVariable *newVar) | CCRDFile |
clone(BSTR bstrDestName, ICRDFile **pVal) | CCRDFile |
createFile(BSTR bstrName, ICRDFile **pVal) | CCRDFile |
createVariable(BSTR bstrName, ICRDVariable **pVal) | CCRDFile |
get_Attribute(long *pVal) | _CCRDNodeTemplate< CCRDFile,&CLSID_CRDFile, ICRDFile,&IID_ICRDFile > | [inline]
get_DateCreated(VARIANT *pVal) | CCRDFile |
get_DateLastAccessed(VARIANT *pVal) | CCRDFile |
get_DateLastModified(VARIANT *pVal) | CCRDFile |
get_File(BSTR bstrName, ICRDFile **pVal) | CCRDFile |
get_FileNames(VARIANT *pVal) | CCRDFile |
get_Help(BSTR *pVal) | _CCRDNodeTemplate< CCRDFile,&CLSID_CRDFile, ICRDFile,&IID_ICRDFile > | [inline]
get_ID(VARIANT *pVal) | _CCRDNodeTemplate< CCRDFile,&CLSID_CRDFile, ICRDFile,&IID_ICRDFile > | [inline]
get_Name(BSTR *pVal) | _CCRDNodeTemplate< CCRDFile,&CLSID_CRDFile, ICRDFile,&IID_ICRDFile > | [inline]
get_Path(BSTR *pVal) | CCRDFile |
get_Size(long *pVal) | CCRDFile |
get_Type(BSTR *pVal) | CCRDFile |
get_Value(VARIANT *pVal) | CCRDFile |
get_Variable(BSTR bstrName, ICRDVariable **pVal) | CCRDFile |
get_VariableNames(VARIANT *pVal) | CCRDFile |
get_XMLNode(IUnknown **pVal) | _CCRDNodeTemplate< CCRDFile,&CLSID_CRDFile, ICRDFile,&IID_ICRDFile > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCRDNodeTemplate< CCRDFile,&CLSID_CRDFile, ICRDFile,&IID_ICRDFile > | [inline]
m_pINode | _CCRDNodeTemplate< CCRDFile,&CLSID_CRDFile, ICRDFile,&IID_ICRDFile > | [protected]
put_Attribute(long newVal) | _CCRDNodeTemplate< CCRDFile,&CLSID_CRDFile, ICRDFile,&IID_ICRDFile > | [inline]
put_DateCreated(VARIANT newVal) | CCRDFile |
put_DateLastAccessed(VARIANT newVal) | CCRDFile |
put_DateLastModified(VARIANT newVal) | CCRDFile |
put_Help(BSTR newVal) | _CCRDNodeTemplate< CCRDFile,&CLSID_CRDFile, ICRDFile,&IID_ICRDFile > | [inline]
put_ID(VARIANT newVal) | _CCRDNodeTemplate< CCRDFile,&CLSID_CRDFile, ICRDFile,&IID_ICRDFile > | [inline]
put_Path(BSTR newVal) | CCRDFile |
put_Size(long newVal) | CCRDFile |
put_Type(BSTR newVal) | CCRDFile |
put_Value(VARIANT newVal) | CCRDFile |
removeFile(BSTR bstrName) | CCRDFile |
removeVariable(BSTR bstrName) | CCRDFile |
Generated on Thu Jan 27 18:50:12 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCRDMessage メンバ一覧

これは全メンバの一覧です。CCRDMessage継承メンバも含んでいます。
_Initialize(IXMLDOMNode *pINode) | CCRDMessage
clone(long lNumber, ICRDMessage **pVal) | CCRDMessage
get_DateTime(VARIANT *pVal) | CCRDMessage
get_Description(BSTR *pVal) | CCRDMessage
get_Destination(BSTR *pVal) | CCRDMessage
get_ID(VARIANT *pVal) | CCRDMessage
get_Number(long *pVal) | CCRDMessage
get_Source(BSTR *pVal) | CCRDMessage
get_Value(VARIANT *pVal) | CCRDMessage
get_XMLNode(IUnknown **pVal) | CCRDMessage
InterfaceSupportsErrorInfo(REFIID riid) | CCRDMessage
put_DateTime(VARIANT newVal) | CCRDMessage
put_Description(BSTR newVal) | CCRDMessage
put_Destination(BSTR newVal) | CCRDMessage
put_ID(VARIANT newVal) | CCRDMessage
put_Source(BSTR newVal) | CCRDMessage
put_Value(VARIANT newVal) | CCRDMessage
Generated on Thu Jan 27 18:50:12 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCRDRobot メンバ一覧

これは全メンバの一覧です。CCRDRobot継承メンバも含んでいます。
_CCRDNodeTemplate() | _CCRDNodeTemplate< CCRDRobot,&CLSID_CRDRobot, ICRDRobot,&IID_ICRDRobot > | [inline]
_Initialize(IXMLDOMNode *pINode) | _CCRDNodeTemplate< CCRDRobot,&CLSID_CRDRobot, ICRDRobot,&IID_ICRDRobot > | [inline]
appendVariable(ICRDVariable *newVar) | CCRDRobot |
clone(BSTR bstrDestName, ICRDRobot **pVal) | CCRDRobot |
createVariable(BSTR bstrName, ICRDVariable **pVal) | CCRDRobot |
get_Attribute(long *pVal) | _CCRDNodeTemplate< CCRDRobot,&CLSID_CRDRobot, ICRDRobot,&IID_ICRDRobot > | [inline]
get_Help(BSTR *pVal) | _CCRDNodeTemplate< CCRDRobot,&CLSID_CRDRobot, ICRDRobot,&IID_ICRDRobot > | [inline]
get_ID(VARIANT *pVal) | _CCRDNodeTemplate< CCRDRobot,&CLSID_CRDRobot, ICRDRobot,&IID_ICRDRobot > | [inline]
get_Name(BSTR *pVal) | _CCRDNodeTemplate< CCRDRobot,&CLSID_CRDRobot, ICRDRobot,&IID_ICRDRobot > | [inline]
get_Variable(BSTR bstrName, ICRDVariable **pVal) | CCRDRobot |
get_VariableNames(VARIANT *pVal) | CCRDRobot |
get_XMLNode(IUnknown **pVal) | _CCRDNodeTemplate< CCRDRobot,&CLSID_CRDRobot, ICRDRobot,&IID_ICRDRobot > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCRDNodeTemplate< CCRDRobot,&CLSID_CRDRobot, ICRDRobot,&IID_ICRDRobot > | [inline]
m_pINode | _CCRDNodeTemplate< CCRDRobot,&CLSID_CRDRobot, ICRDRobot,&IID_ICRDRobot > | [protected]
put_Attribute(long newVal) | _CCRDNodeTemplate< CCRDRobot,&CLSID_CRDRobot, ICRDRobot,&IID_ICRDRobot > | [inline]
put_Help(BSTR newVal) | _CCRDNodeTemplate< CCRDRobot,&CLSID_CRDRobot, ICRDRobot,&IID_ICRDRobot > | [inline]
put_ID(VARIANT newVal) | _CCRDNodeTemplate< CCRDRobot,&CLSID_CRDRobot, ICRDRobot,&IID_ICRDRobot > | [inline]
removeVariable(BSTR bstrName) | CCRDRobot |
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCRDTask メンバ一覧

これは全メンバの一覧です。CCRDTask継承メンバも含んでいます。
_CCRDNodeTemplate() | _CCRDNodeTemplate< CCRDTask,&CLSID_CRDTask, ICRDTask,&IID_ICRDTask > | [inline]
_Initialize(IXMLDOMNode *pINode) | _CCRDNodeTemplate< CCRDTask,&CLSID_CRDTask, ICRDTask,&IID_ICRDTask > | [inline]
appendVariable(ICRDVariable *newVar) | CCRDTask |
clone(BSTR bstrDestName, ICRDTask **pVal) | CCRDTask |
createVariable(BSTR bstrName, ICRDVariable **pVal) | CCRDTask |
get_Attribute(long *pVal) | _CCRDNodeTemplate< CCRDTask,&CLSID_CRDTask, ICRDTask,&IID_ICRDTask > | [inline]
get_FileName(BSTR *pVal) | CCRDTask |
get_Help(BSTR *pVal) | _CCRDNodeTemplate< CCRDTask,&CLSID_CRDTask, ICRDTask,&IID_ICRDTask > | [inline]
get_ID(VARIANT *pVal) | _CCRDNodeTemplate< CCRDTask,&CLSID_CRDTask, ICRDTask,&IID_ICRDTask > | [inline]
get_Name(BSTR *pVal) | _CCRDNodeTemplate< CCRDTask,&CLSID_CRDTask, ICRDTask,&IID_ICRDTask > | [inline]
get_Variable(BSTR bstrName, ICRDVariable **pVal) | CCRDTask |
get_VariableNames(VARIANT *pVal) | CCRDTask |
get_XMLNode(IUnknown **pVal) | _CCRDNodeTemplate< CCRDTask,&CLSID_CRDTask, ICRDTask,&IID_ICRDTask > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCRDNodeTemplate< CCRDTask,&CLSID_CRDTask, ICRDTask,&IID_ICRDTask > | [inline]
m_pINode | _CCRDNodeTemplate< CCRDTask,&CLSID_CRDTask, ICRDTask,&IID_ICRDTask > | [protected]
put_Attribute(long newVal) | _CCRDNodeTemplate< CCRDTask,&CLSID_CRDTask, ICRDTask,&IID_ICRDTask > | [inline]
put_FileName(BSTR newVal) | CCRDTask |
put_Help(BSTR newVal) | _CCRDNodeTemplate< CCRDTask,&CLSID_CRDTask, ICRDTask,&IID_ICRDTask > | [inline]
put_ID(VARIANT newVal) | _CCRDNodeTemplate< CCRDTask,&CLSID_CRDTask, ICRDTask,&IID_ICRDTask > | [inline]
removeVariable(BSTR bstrName) | CCRDTask |
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCRDUtility メンバ一覧

これは全メンバの一覧です。CCRDUtility継承メンバも含んでいます。
AddIndent(IXMLDOMNode *ElementNode, long lLevel, IXMLDOMDocument *pIXMLDoc) | CCRDUtility | [inline, static]
CCRDUtility() | CCRDUtility |
CreateElement(BSTR bstrElementName, IXMLDOMNode *pINode, IXMLDOMElement **pVal) | CCRDUtility | [inline, static]
CreateElementWithNameAttr(BSTR bstrTagName, BSTR bstrName, IXMLDOMNode *pINode, IXMLDOMElement **ppVal) | CCRDUtility | [inline, static]
CreateElementWithNumberAttr(BSTR bstrTagName, long lNumber, IXMLDOMNode *pINode, IXMLDOMElement **ppVal) | CCRDUtility | [inline, static]
CreateVariantNode(BSTR bstrName, VARIANT vntVal, IXMLDOMNode *pINode, IXMLDOMElement **pVal) | CCRDUtility | [inline, static]
GetNamedNodeList(BSTR bstrElementName, IXMLDOMNode *pINode, VARIANT *pVal) | CCRDUtility | [inline, static]
GetNodeAttribute(BSTR bstrName, IXMLDOMNode *pINode, VARTYPE Type, VARIANT *pVal) | CCRDUtility | [inline, static]
GetNodeValue(BSTR bstrName, IXMLDOMNode *pINode, VARTYPE Type, VARIANT *pVal) | CCRDUtility | [inline, static]
GetNodeVariant(BSTR bstrName, IXMLDOMNode *pINode, VARIANT *pVal) | CCRDUtility | [inline, static]
GetNumberNodeList(BSTR bstrElementName, IXMLDOMNode *pINode, VARIANT *pVal) | CCRDUtility | [inline, static]
RemoveIndent(IXMLDOMNode *ElementNode) | CCRDUtility | [inline, static]
SetNodeValue(BSTR bstrName, IXMLDOMNode *pINode, VARIANT newVal) | CCRDUtility | [inline, static]
VariantTimeToISO8601(DATE vntDate, BSTR *pVal) | CCRDUtility | [inline, static]
~CCRDUtility() | CCRDUtility | [virtual]
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCRDVariable メンバ一覧

これは全メンバの一覧です。CCRDVariable継承メンバも含んでいます。
_CCRDNodeTemplate() | _CCRDNodeTemplate< CCRDVariable,&CLSID_CRDVariable, ICRDVariable,&IID_ICRDVariable > | [inline]
_Initialize(IXMLDOMNode *pINode) | _CCRDNodeTemplate< CCRDVariable,&CLSID_CRDVariable, ICRDVariable,&IID_ICRDVariable > | [inline]
clone(BSTR bstrDestName, ICRDVariable **pVal) | CCRDVariable |
get_Attribute(long *pVal) | _CCRDNodeTemplate< CCRDVariable,&CLSID_CRDVariable, ICRDVariable,&IID_ICRDVariable > | [inline]
get_DateTime(VARIANT *pVal) | CCRDVariable |
get_Help(BSTR *pVal) | _CCRDNodeTemplate< CCRDVariable,&CLSID_CRDVariable, ICRDVariable,&IID_ICRDVariable > | [inline]
get_ID(VARIANT *pVal) | _CCRDNodeTemplate< CCRDVariable,&CLSID_CRDVariable, ICRDVariable,&IID_ICRDVariable > | [inline]
get_Microsecond(long *pVal) | CCRDVariable |
get_Name(BSTR *pVal) | _CCRDNodeTemplate< CCRDVariable,&CLSID_CRDVariable, ICRDVariable,&IID_ICRDVariable > | [inline]
get_Value(VARIANT *pVal) | CCRDVariable |
get_XMLNode(IUnknown **pVal) | _CCRDNodeTemplate< CCRDVariable,&CLSID_CRDVariable, ICRDVariable,&IID_ICRDVariable > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCRDNodeTemplate< CCRDVariable,&CLSID_CRDVariable, ICRDVariable,&IID_ICRDVariable > | [inline]
m_pINode | _CCRDNodeTemplate< CCRDVariable,&CLSID_CRDVariable, ICRDVariable,&IID_ICRDVariable > | [protected]
put_Attribute(long newVal) | _CCRDNodeTemplate< CCRDVariable,&CLSID_CRDVariable, ICRDVariable,&IID_ICRDVariable > | [inline]
put_DateTime(VARIANT newVal) | CCRDVariable |
put_Help(BSTR newVal) | _CCRDNodeTemplate< CCRDVariable,&CLSID_CRDVariable, ICRDVariable,&IID_ICRDVariable > | [inline]
put_ID(VARIANT newVal) | _CCRDNodeTemplate< CCRDVariable,&CLSID_CRDVariable, ICRDVariable,&IID_ICRDVariable > | [inline]
put_Microsecond(long newVal) | CCRDVariable |
put_Value(VARIANT newVal) | CCRDVariable |
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRD.h Source File

CRD.h

解説を見る。
00001
00002 // Common
00003 #define     MAX_BUFFER          1025
00004
00005 // XMLDOMDocument
00006 #define     XML_VARIDATION      VARIANT_TRUE
00007 #define     XML_LOAD_ASYNC      VARIANT_FALSE
00008
00009 #define     TYPE_NODE_ELEMENT       1
00010 #define     TYPE_NODE_ATTRIBUTE     2
00011 #define     TYPE_NODE_TEXT          3
00012
00013 // XML
00014 #define     XML_ELEM_PROCESS        L"xml"
00015 #define     XML_NODE_DATA           L"version=\"1.0\" encoding=\"Shift_JIS\""
00016
00017 #define     CRD_ELEM_ROOT           L"CRD"
00018 #define     XSI_ATTR_NS             L"xmlns:xsi"
00019 #define     XML_SCHEMA_INSTANCE     L"http://www.w3.org/2001/XMLSchema-instance"
00020 #define     CRD_ATTR_LOCATION       L"xsi:schemaLocation"
00021 #define     CRD_SCHEMA_LOCATION     L"http://www.orin.jp/CRD/CRDSchema"
00022 #define     CRD_SCHEMA_FILE         L"CRDSchema.xsd"
00023
00024 // XPath
00025 #define     XPATH_DOC_PROPERTY          L"SelectionNamespaces"
00026 #define     XPATH_CRD_NAMESPACE         L"xmlns:crd='http://www.orin.jp/CRD/CRDSchema'"
00027 #define     XPATH_NAMED_NODE            L"crd:%ls[@name='%ls']"
00028 #define     XPATH_NUMBER_NODE           L"crd:%ls[@number='%li']"
00029 #define     XPATH_PREFIX_NODE           L"crd:%ls"
00030
00031 // ObjectTag
00032 #define     CRD_ELEM_CONTROLLER         L"Controller"
00033 #define     CRD_ELEM_EXTENSION          L"Extension"
00034 #define     CRD_ELEM_FILE               L"File"
00035 #define     CRD_ELEM_ROBOT              L"Robot"
00036 #define     CRD_ELEM_TASK               L"Task"
00037 #define     CRD_ELEM_VARIABLE           L"Variable"
00038 #define     CRD_ELEM_COMMAND            L"Command"
00039 #define     CRD_ELEM_MESSAGE            L"Message"
00040
00041 // CommonChild
00042 #define     CRD_ELEM_ATTRIBUTE          L"Attribute"
00043 #define     CRD_ELEM_HELP               L"Help"
00044 #define     CRD_ELEM_ID                 L"ID"
00045
00046 // RootTag
00047 #define     CRD_ELEM_VERSION            L"Version"
00048
00049 // FileTag
00050 #define     CRD_ELEM_DATE_CREATED       L"DateCreated"
00051 #define     CRD_ELEM_DATE_LAST_ACCESSED L"DateLastAccessed"
00052 #define     CRD_ELEM_DATE_LAST_MODIFIED L"DateLastModified"
00053 #define     CRD_ELEM_PATH               L"Path"
00054 #define     CRD_ELEM_SIZE               L"Size"
00055 #define     CRD_ELEM_TYPE               L"Type"
00056
00057 // RobotTag
00058 #define     CRD_ELEM_ACCEL              L"Acceleration"
00059 #define     CRD_ELEM_DECEL              L"Deceleration"
00060 #define     CRD_ELEM_JSPEED             L"JointSpeed"
00061 #define     CRD_ELEM_SPEED              L"Speed"
00062
00063 // TaskTag
00064 #define     CRD_ELEM_FILENAME           L"FileName"
00065
00066 // VariableTag
00067 #define     CRD_ELEM_DATETIME           L"DateTime"
00068 #define     CRD_ELEM_MICROSECOND        L"Microsecond"
00069
00070 // CommandTag
00071 #define     CRD_ELEM_STATE              L"State"
00072 #define     CRD_ELEM_TIMEOUT            L"Timeout"
00073 #define     CRD_ELEM_PARAMETERS         L"Parameters"
00074
00075 // MessageTag
00076 #define     CRD_ELEM_DESCRIPTION        L"Description"
00077 #define     CRD_ELEM_DESTINATIOM        L"Destination"
00078 #define     CRD_ELEM_SOURCE             L"Source"
00079 #define     CRD_ELEM_VALUE              L"Value"
00080
00081 // Attribute
00082 #define     CRD_ATTR_NAME               L"name"
00083 #define     CRD_ATTR_NUMBER             L"number"
00084
00085 // Variant Tag
00086 #define     CRD_ELEM_VALUE              L"Value"
00087 #define     CRD_ATTR_TYPE               L"type"
00088
00089 // ArrayTag
00090 #define     CRD_ELEM_DIMENSION          L"dimension"
00091 #define     CRD_ELEM_ARRAYBOUND         L"arrayBound"
00092 #define     CRD_ELEM_LBOUND             L"lBound"
00093 #define     CRD_ELEM_ELEMENTS           L"elements"
00094 #define     CRD_ELEM_ARRAYDATA          L"arrayData"
00095
00096 // Variable and Array Data
00097 #define     CRD_ELEM_BOOL               L"boolVal"
00098 #define     CRD_ELEM_I1                 L"cVal"
00099 #define     CRD_ELEM_UI1                L"bVal"
00100 #define     CRD_ELEM_I2                 L"iVal"
00101 #define     CRD_ELEM_UI2                L"uiVal"
00102 #define     CRD_ELEM_I4                 L"lVal"
00103 #define     CRD_ELEM_UI4                L"ulVal"
00104 #define     CRD_ELEM_R4                 L"fltVal"
00105 #define     CRD_ELEM_R8                 L"dblVal"
00106 #define     CRD_ELEM_DATE               L"date"
00107 #define     CRD_ELEM_BSTR               L"bstrVal"
00108 #define     CRD_ELEM_VARIANT            L"varVal"
00109 #define     CRD_ELEM_ARRAY              L"array"
00110
00111 // Variable and Array Type
00112 #define     CRD_TYPE_BOOL               L"VT_BOOL"
00113 #define     CRD_TYPE_I1                 L"VT_I1"
00114 #define     CRD_TYPE_UI1                L"VT_UI1"
00115 #define     CRD_TYPE_I2                 L"VT_I2"
00116 #define     CRD_TYPE_UI2                L"VT_UI2"
00117 #define     CRD_TYPE_I4                 L"VT_I4"
00118 #define     CRD_TYPE_UI4                L"VT_UI4"
00119 #define     CRD_TYPE_R4                 L"VT_R4"
00120 #define     CRD_TYPE_R8                 L"VT_R8"
00121 #define     CRD_TYPE_DATE               L"VT_DATE"
00122 #define     CRD_TYPE_BSTR               L"VT_BSTR"
00123 #define     CRD_TYPE_VARIANT            L"VT_VARIANT"
00124 #define     CRD_TYPE_ARRAY              L"VT_ARRAY"
00125
00126
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDCommand.h Source File

CRDCommand.h

解説を見る。
00001 // CRDCommand.h : CCRDCommand の宣言
00002
00003 #ifndef __CRDCOMMAND_H_
00004 #define __CRDCOMMAND_H_
00005
00006 #include "resource.h"       // メイン シンボル
00007 #include "_CCRDNodeTemplate.h"
00008
00016 class ATL_NO_VTABLE CCRDCommand :
00017     public _CCRDNodeTemplate<CCRDCommand, &CLSID_CRDCommand, ICRDCommand, &IID_ICRDCommand>
00018 {
00019 // ICRDCommand
00020 public:
00021     STDMETHOD(get_Timeout)(/*[out, retval]*/ long *pVal);
00022     STDMETHOD(put_Timeout)(/*[in]*/ long newVal);
00023     STDMETHOD(get_State)(/*[out, retval]*/ long *pVal);
00024     STDMETHOD(put_State)(/*[in]*/ long newVal);
00025     STDMETHOD(get_Parameters)(/*[out, retval]*/ VARIANT *pVal);
00026     STDMETHOD(put_Parameters)(/*[in]*/ VARIANT newVal);
00027
00028     STDMETHOD(clone)(/*[in]*/ BSTR bstrDestName, /*[out, retval]*/ ICRDCommand** pVal);
00029 };
00030
00031 #endif //__CRDCOMMAND_H_
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDController.h Source File

CRDController.h

解説を見る。
00001 // CRDController.h : CCRDController の宣言
00002
00003 #ifndef __CRDCONTROLLER_H_
00004 #define __CRDCONTROLLER_H_
00005
00006 #include "resource.h"       // メイン シンボル
00007 #include "_CCRDNodeTemplate.h"
00008 #include "CRDExtension.h"
00009 #include "CRDFile.h"
00010 #include "CRDRobot.h"
00011 #include "CRDTask.h"
00012 #include "CRDVariable.h"
00013 #include "CRDCommand.h"
00014 #include "CRDMessage.h"
00015
00023 class ATL_NO_VTABLE CCRDController :
00024     public _CCRDNodeTemplate<CCRDController, &CLSID_CRDController, ICRDController, &IID_ICRDController>
00025 {
00026
00027 // ICRDController
00028 public:
00029     STDMETHOD(createExtension)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDExtension** pVal);
00030     STDMETHOD(removeExtension)(/*[in]*/ BSTR bstrName);
00031     STDMETHOD(appendExtension)(/*[in]*/ ICRDExtension* newExt);
00032     STDMETHOD(get_ExtensionNames)(/*[out, retval]*/ VARIANT *pVal);
00033     STDMETHOD(get_Extension)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDExtension **pVal);
00034
00035     STDMETHOD(createFile)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDFile** pVal);
00036     STDMETHOD(removeFile)(/*[in]*/ BSTR bstrName);
00037     STDMETHOD(appendFile)(/*[in]*/ ICRDFile* newFile);
00038     STDMETHOD(get_FileNames)(/*[out, retval]*/ VARIANT *pVal);
00039     STDMETHOD(get_File)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDFile **pVal);
00040
00041     STDMETHOD(createRobot)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDRobot** pVal);
00042     STDMETHOD(removeRobot)(/*[in]*/ BSTR bstrName);
00043     STDMETHOD(appendRobot)(/*[in]*/ ICRDRobot* newRobot);
00044     STDMETHOD(get_RobotNames)(/*[out, retval]*/ VARIANT *pVal);
00045     STDMETHOD(get_Robot)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDRobot **pVal);
00046
00047     STDMETHOD(createTask)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDTask** pVal);
00048     STDMETHOD(removeTask)(/*[in]*/ BSTR bstrName);
00049     STDMETHOD(appendTask)(/*[in]*/ ICRDTask* newTask);
00050     STDMETHOD(get_TaskNames)(/*[out, retval]*/ VARIANT *pVal);
00051     STDMETHOD(get_Task)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDTask **pVal);
00052
00053     STDMETHOD(createVariable)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDVariable** pVal);
00054     STDMETHOD(removeVariable)(/*[in]*/ BSTR bstrName);
00055     STDMETHOD(appendVariable)(/*[in]*/ ICRDVariable* newVar);
00056     STDMETHOD(get_VariableNames)(/*[out, retval]*/ VARIANT *pVal);
00057     STDMETHOD(get_Variable)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDVariable **pVal);
00058
00059     STDMETHOD(createCommand)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDCommand** pVal);
00060     STDMETHOD(removeCommand)(/*[in]*/ BSTR bstrName);
00061     STDMETHOD(appendCommand)(/*[in]*/ ICRDCommand* newVar);
00062     STDMETHOD(get_CommandNames)(/*[out, retval]*/ VARIANT *pVal);
00063     STDMETHOD(get_Command)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDCommand **pVal);
00064
00065     STDMETHOD(createMessage)(/*[in]*/ long lNumber, /*[out, retval]*/ ICRDMessage** pVal);
00066     STDMETHOD(removeMessage)(/*[in]*/ long lNumber);
00067     STDMETHOD(appendMessage)(/*[in]*/ ICRDMessage* newVar);
00068     STDMETHOD(get_MessageNumbers)(/*[out, retval]*/ VARIANT *pVal);
00069     STDMETHOD(get_Message)(/*[in]*/ long lNumber, /*[out, retval]*/ ICRDMessage **pVal);
00070
00071     STDMETHOD(clone)(/*[in]*/ BSTR bstrDestName, /*[out, retval]*/ ICRDController** pVal);
00072
00073
00074 };
00075
00076 #endif //__CRDCONTROLLER_H_
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDEngine.h Source File

CRDEngine.h

解説を見る。
00001 // CRDEngine.h : CCRDEngine の宣言
00002
00003 #ifndef __CRDENGINE_H_
00004 #define __CRDENGINE_H_
00005
00006 #include "resource.h"       // メイン シンボル
00007 #include "CRDController.h"
00008
00009
00018 class ATL_NO_VTABLE CCRDEngine :
00019     public CComObjectRootEx<CComMultiThreadModel>,
00020     public CComCoClass<CCRDEngine, &CLSID_CRDEngine>,
00021     public ISupportErrorInfo,
00022     public IDispatchImpl<ICRDEngine, &IID_ICRDEngine, &LIBID_CRDMAPPERLib>
00023 {
00024 public:
00025     CCRDEngine()
00026     {
00027         m_bstrName = NULL;
00028     }
00029
00030 DECLARE_REGISTRY_RESOURCEID(IDR_CRDENGINE)
00031
00032 DECLARE_PROTECT_FINAL_CONSTRUCT()
00033
00034 BEGIN_COM_MAP(CCRDEngine)
00035     COM_INTERFACE_ENTRY(ICRDEngine)
00036     COM_INTERFACE_ENTRY(IDispatch)
00037     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00038 END_COM_MAP()
00039
00040 // ISupportsErrorInfo
00041     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00042
00043 // ICRDEngine
00044 public:
00045     STDMETHOD(CreateDocument)();
00046     STDMETHOD(save)();
00047     STDMETHOD(saveAs)(BSTR bstrFileName);
00048     STDMETHOD(load)(BSTR bstrFileName);
00049     STDMETHOD(removeController)(/*[in]*/ BSTR bstrName);
00050     STDMETHOD(createController)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDController** pVal);
00051     STDMETHOD(appendController)(/*[in]*/ ICRDController* newCtrl);
00052     STDMETHOD(get_Controller)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDController **pVal);
00053     STDMETHOD(get_ControllerNames)(/*[out, retval]*/ VARIANT *pVal);
00054
00055     STDMETHOD(get_Help)(/*[out, retval]*/ BSTR *pVal);
00056     STDMETHOD(put_Help)(/*[in]*/ BSTR newVal);
00057     STDMETHOD(get_Version)(/*[out, retval]*/ BSTR *pVal);
00058     STDMETHOD(put_Version)(/*[in]*/ BSTR newVal);
00059
00060 private:
00061     IXMLDOMDocument2Ptr m_pIXMLDoc;
00062     IXMLDOMElementPtr m_pIXMLRootElement;
00063
00064     BSTR m_bstrName;
00065
00066 };
00067
00068 #endif //__CRDENGINE_H_
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDExtension.h Source File

CRDExtension.h

解説を見る。
00001
00002 // CRDExtension.h : CCRDExtension の宣言
00003
00004 #ifndef __CRDEXTENSION_H_
00005 #define __CRDEXTENSION_H_
00006
00007 #include "resource.h"       // メイン シンボル
00008 #include "_CCRDNodeTemplate.h"
00009 #include "CRDVariable.h"
00010
00018 class ATL_NO_VTABLE CCRDExtension :
00019     public _CCRDNodeTemplate<CCRDExtension, &CLSID_CRDExtension, ICRDExtension, &IID_ICRDExtension>
00020 {
00021 // ICRDExtension
00022 public:
00023     STDMETHOD(createVariable)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDVariable** pVal);
00024     STDMETHOD(removeVariable)(/*[in]*/ BSTR bstrName);
00025     STDMETHOD(appendVariable)(/*[in]*/ ICRDVariable* newVar);
00026     STDMETHOD(get_VariableNames)(/*[out, retval]*/ VARIANT *pVal);
00027     STDMETHOD(get_Variable)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDVariable **pVal);
00028
00029     STDMETHOD(clone)(/*[in]*/ BSTR bstrDestName, /*[out, retval]*/ ICRDExtension** pVal);
00030
00031 };
00032
00033 #endif //__CRDEXTENSION_H_
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDFile.h Source File

CRDFile.h

解説を見る。
00001 // CRDFile.h : CCRDFile の宣言
00002
00003 #ifndef __CRDFILE_H_
00004 #define __CRDFILE_H_
00005
00006 #include "resource.h"       // メイン シンボル
00007 #include "_CCRDNodeTemplate.h"
00008 #include "CRDFile.h"
00009 #include "CRDVariable.h"
00010
00018 class ATL_NO_VTABLE CCRDFile :
00019     public _CCRDNodeTemplate<CCRDFile, &CLSID_CRDFile, ICRDFile, &IID_ICRDFile>
00020 {
00021 // ICRDFile
00022 public:
00023     STDMETHOD(get_DateCreated)(/*[out, retval]*/ VARIANT *pVal);
00024     STDMETHOD(put_DateCreated)(/*[in]*/ VARIANT newVal);
00025     STDMETHOD(get_DateLastAccessed)(/*[out, retval]*/ VARIANT *pVal);
00026     STDMETHOD(put_DateLastAccessed)(/*[in]*/ VARIANT newVal);
00027     STDMETHOD(get_DateLastModified)(/*[out, retval]*/ VARIANT *pVal);
00028     STDMETHOD(put_DateLastModified)(/*[in]*/ VARIANT newVal);
00029     STDMETHOD(get_Path)(/*[out, retval]*/ BSTR *pVal);
00030     STDMETHOD(put_Path)(/*[in]*/ BSTR newVal);
00031     STDMETHOD(get_Size)(/*[out, retval]*/ long *pVal);
00032     STDMETHOD(put_Size)(/*[in]*/ long newVal);
00033     STDMETHOD(get_Type)(/*[out, retval]*/ BSTR *pVal);
00034     STDMETHOD(put_Type)(/*[in]*/ BSTR newVal);
00035     STDMETHOD(get_Value)(/*[out, retval]*/ VARIANT *pVal);
00036     STDMETHOD(put_Value)(/*[in]*/ VARIANT newVal);
00037
00038     STDMETHOD(createFile)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDFile** pVal);
00039     STDMETHOD(removeFile)(/*[in]*/ BSTR bstrName);
00040     STDMETHOD(appendFile)(/*[in]*/ ICRDFile* newFile);
00041     STDMETHOD(get_FileNames)(/*[out, retval]*/ VARIANT *pVal);
00042     STDMETHOD(get_File)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDFile **pVal);
00043
00044     STDMETHOD(createVariable)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDVariable** pVal);
00045     STDMETHOD(removeVariable)(/*[in]*/ BSTR bstrName);
00046     STDMETHOD(appendVariable)(/*[in]*/ ICRDVariable* newVar);
00047     STDMETHOD(get_VariableNames)(/*[out, retval]*/ VARIANT *pVal);
00048     STDMETHOD(get_Variable)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDVariable **pVal);
00049
00050     STDMETHOD(clone)(/*[in]*/ BSTR bstrDestName, /*[out, retval]*/ ICRDFile** pVal);
00051 };
00052
00053 #endif //__CRDFILE_H_
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMapper.h Source File

CRDMapper.h

解説を見る。
00001 /* this ALWAYS GENERATED file contains the definitions for the interfaces */
00002
00003
00004 /* File created by MIDL compiler version 5.01.0164 */
00005 /* at Thu Jan 27 18:21:55 2005
00006  */
00007 /* Compiler settings for D:\ORiN2\CAO\ProviderLib\CRD\CRDMapper\Src\CRDMapper.idl:
00008     Oicf (OptLev=i2), W1, Zp8, env=Win32, ms_ext, c_ext
00009     error checks: allocation ref bounds_check enum stub_data
00010 */
00011 //@@MIDL_FILE_HEADING(  )
00012
00013
00014 /* verify that the <rpcndr.h> version is high enough to compile this file*/
00015 #ifndef __REQUIRED_RPCNDR_H_VERSION__
00016 #define __REQUIRED_RPCNDR_H_VERSION__ 440
00017 #endif
00018
00019 #include "rpc.h"
00020 #include "rpcndr.h"
00021
00022 #ifndef __RPCNDR_H_VERSION__
00023 #error this stub requires an updated version of <rpcndr.h>
00024 #endif // __RPCNDR_H_VERSION__
00025
00026 #ifndef COM_NO_WINDOWS_H
00027 #include "windows.h"
00028 #include "ole2.h"
00029 #endif /*COM_NO_WINDOWS_H*/
00030
00031 #ifndef __CRDMapper_h__
00032 #define __CRDMapper_h__
00033
00034 #ifdef __cplusplus
00035 extern "C"{
00036 #endif
00037
00038 /* Forward Declarations */
00039
00040 #ifndef __ICRDEngine_FWD_DEFINED__
00041 #define __ICRDEngine_FWD_DEFINED__
00042 typedef interface ICRDEngine ICRDEngine;
00043 #endif  /* __ICRDEngine_FWD_DEFINED__ */
00044
00045
00046 #ifndef __ICRDController_FWD_DEFINED__
00047 #define __ICRDController_FWD_DEFINED__
00048 typedef interface ICRDController ICRDController;
00049 #endif  /* __ICRDController_FWD_DEFINED__ */
00050
00051
00052 #ifndef __ICRDExtension_FWD_DEFINED__
00053 #define __ICRDExtension_FWD_DEFINED__
00054 typedef interface ICRDExtension ICRDExtension;
00055 #endif  /* __ICRDExtension_FWD_DEFINED__ */
00056
00057
00058 #ifndef __ICRDFile_FWD_DEFINED__
00059 #define __ICRDFile_FWD_DEFINED__
00060 typedef interface ICRDFile ICRDFile;
00061 #endif  /* __ICRDFile_FWD_DEFINED__ */
00062
00063
00064 #ifndef __ICRDRobot_FWD_DEFINED__
00065 #define __ICRDRobot_FWD_DEFINED__
00066 typedef interface ICRDRobot ICRDRobot;
00067 #endif  /* __ICRDRobot_FWD_DEFINED__ */
00068
00069
00070 #ifndef __ICRDTask_FWD_DEFINED__
00071 #define __ICRDTask_FWD_DEFINED__
00072 typedef interface ICRDTask ICRDTask;
00073 #endif  /* __ICRDTask_FWD_DEFINED__ */
00074
00075
00076 #ifndef __ICRDVariable_FWD_DEFINED__
00077 #define __ICRDVariable_FWD_DEFINED__
00078 typedef interface ICRDVariable ICRDVariable;
00079 #endif  /* __ICRDVariable_FWD_DEFINED__ */
00080
00081
00082 #ifndef __ICRDCommand_FWD_DEFINED__
00083 #define __ICRDCommand_FWD_DEFINED__
00084 typedef interface ICRDCommand ICRDCommand;
00085 #endif  /* __ICRDCommand_FWD_DEFINED__ */
00086
00087
00088 #ifndef __ICRDMessage_FWD_DEFINED__
00089 #define __ICRDMessage_FWD_DEFINED__
00090 typedef interface ICRDMessage ICRDMessage;
00091 #endif  /* __ICRDMessage_FWD_DEFINED__ */
00092
00093
00094 #ifndef __CRDEngine_FWD_DEFINED__
00095 #define __CRDEngine_FWD_DEFINED__
00096
00097 #ifdef __cplusplus
00098 typedef class CRDEngine CRDEngine;
00099 #else
00100 typedef struct CRDEngine CRDEngine;
00101 #endif /* __cplusplus */
00102
00103 #endif  /* __CRDEngine_FWD_DEFINED__ */
00104
00105
00106 #ifndef __CRDController_FWD_DEFINED__
00107 #define __CRDController_FWD_DEFINED__
00108
00109 #ifdef __cplusplus
00110 typedef class CRDController CRDController;
00111 #else
00112 typedef struct CRDController CRDController;
00113 #endif /* __cplusplus */
00114
00115 #endif  /* __CRDController_FWD_DEFINED__ */
00116
00117
00118 #ifndef __CRDExtension_FWD_DEFINED__
00119 #define __CRDExtension_FWD_DEFINED__
00120
00121 #ifdef __cplusplus
00122 typedef class CRDExtension CRDExtension;
00123 #else
00124 typedef struct CRDExtension CRDExtension;
00125 #endif /* __cplusplus */
00126
00127 #endif  /* __CRDExtension_FWD_DEFINED__ */
00128
00129
00130 #ifndef __CRDFile_FWD_DEFINED__
00131 #define __CRDFile_FWD_DEFINED__
00132
00133 #ifdef __cplusplus
00134 typedef class CRDFile CRDFile;
00135 #else
00136 typedef struct CRDFile CRDFile;
00137 #endif /* __cplusplus */
00138
00139 #endif  /* __CRDFile_FWD_DEFINED__ */
00140
00141
00142 #ifndef __CRDRobot_FWD_DEFINED__
00143 #define __CRDRobot_FWD_DEFINED__
00144
00145 #ifdef __cplusplus
00146 typedef class CRDRobot CRDRobot;
00147 #else
00148 typedef struct CRDRobot CRDRobot;
00149 #endif /* __cplusplus */
00150
00151 #endif  /* __CRDRobot_FWD_DEFINED__ */
00152
00153
00154 #ifndef __CRDTask_FWD_DEFINED__
00155 #define __CRDTask_FWD_DEFINED__
00156
00157 #ifdef __cplusplus
00158 typedef class CRDTask CRDTask;
00159 #else
00160 typedef struct CRDTask CRDTask;
00161 #endif /* __cplusplus */
00162
00163 #endif  /* __CRDTask_FWD_DEFINED__ */
00164
00165
00166 #ifndef __CRDVariable_FWD_DEFINED__
00167 #define __CRDVariable_FWD_DEFINED__
00168
00169 #ifdef __cplusplus
00170 typedef class CRDVariable CRDVariable;
00171 #else
00172 typedef struct CRDVariable CRDVariable;
00173 #endif /* __cplusplus */
00174
00175 #endif  /* __CRDVariable_FWD_DEFINED__ */
00176
00177
00178 #ifndef __CRDCommand_FWD_DEFINED__
00179 #define __CRDCommand_FWD_DEFINED__
00180
00181 #ifdef __cplusplus
00182 typedef class CRDCommand CRDCommand;
00183 #else
00184 typedef struct CRDCommand CRDCommand;
00185 #endif /* __cplusplus */
00186
00187 #endif  /* __CRDCommand_FWD_DEFINED__ */
00188
00189
00190 #ifndef __CRDMessage_FWD_DEFINED__
00191 #define __CRDMessage_FWD_DEFINED__
00192
00193 #ifdef __cplusplus
00194 typedef class CRDMessage CRDMessage;
00195 #else
00196 typedef struct CRDMessage CRDMessage;
00197 #endif /* __cplusplus */
00198
00199 #endif  /* __CRDMessage_FWD_DEFINED__ */
00200
00201
00202 /* header files for imported files */
00203 #include "oaidl.h"
00204 #include "ocidl.h"
00205
00206 void __RPC_FAR * __RPC_USER MIDL_user_allocate(size_t);
00207 void __RPC_USER MIDL_user_free( void __RPC_FAR * );
00208
00209 /* interface __MIDL_itf_CRDMapper_0000 */
00210 /* [local] */
00211
00212
00213
00214
00215
00216
00217
00218
00219
00220
00221
00222
00223 extern RPC_IF_HANDLE __MIDL_itf_CRDMapper_0000_v0_0_c_ifspec;
00224 extern RPC_IF_HANDLE __MIDL_itf_CRDMapper_0000_v0_0_s_ifspec;
00225
00226 #ifndef __ICRDEngine_INTERFACE_DEFINED__
00227 #define __ICRDEngine_INTERFACE_DEFINED__
00228
00229 /* interface ICRDEngine */
00230 /* [unique][helpstring][dual][uuid][object] */
00231
00232
00233 EXTERN_C const IID IID_ICRDEngine;
00234
00235 #if defined(__cplusplus) && !defined(CINTERFACE)
00236
00237     MIDL_INTERFACE("C6A53FD0-B13D-48EA-862E-0710460C1460")
00238     ICRDEngine : public IDispatch
00239     {
00240     public:
00241         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE CreateDocument( void) = 0;
00242
00243         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE load(
00244             /* [in] */ BSTR bstrFileName) = 0;
00245
00246         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE save( void) = 0;
00247
00248         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE saveAs(
00249             /* [defaultvalue][in] */ BSTR bstrFileName = L"") = 0;
00250
00251         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE createController(
00252             /* [in] */ BSTR bstrName,
00253             /* [retval][out] */ ICRDController __RPC_FAR *__RPC_FAR *pVal) = 0;
00254
00255         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE removeController(
00256             /* [in] */ BSTR bstrName) = 0;
00257
00258         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE appendController(
00259             /* [in] */ ICRDController __RPC_FAR *newCtrl) = 0;
00260
00261         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ControllerNames(
00262             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
00263
00264         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Controller(
00265             /* [in] */ BSTR bstrName,
00266             /* [retval][out] */ ICRDController __RPC_FAR *__RPC_FAR *pVal) = 0;
00267
00268         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Help(
00269             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
00270
00271         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Help(
00272             /* [in] */ BSTR newVal) = 0;
00273
00274         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Version(
00275             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
00276
00277         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Version(
00278             /* [in] */ BSTR newVal) = 0;
00279
00280     };
00281
00282 #else   /* C style interface */
00283
00284     typedef struct ICRDEngineVtbl
00285     {
00286         BEGIN_INTERFACE
00287
00288         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
00289             ICRDEngine __RPC_FAR * This,
00290             /* [in] */ REFIID riid,
00291             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
00292
00293         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
00294             ICRDEngine __RPC_FAR * This);
00295
00296         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
00297             ICRDEngine __RPC_FAR * This);
00298
00299         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
00300             ICRDEngine __RPC_FAR * This,
00301             /* [out] */ UINT __RPC_FAR *pctinfo);
00302
00303         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
00304             ICRDEngine __RPC_FAR * This,
00305             /* [in] */ UINT iTInfo,
00306             /* [in] */ LCID lcid,
00307             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
00308
00309         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
00310             ICRDEngine __RPC_FAR * This,
00311             /* [in] */ REFIID riid,
00312             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
00313             /* [in] */ UINT cNames,
00314             /* [in] */ LCID lcid,
00315             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
00316
00317         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
00318             ICRDEngine __RPC_FAR * This,
00319             /* [in] */ DISPID dispIdMember,
00320             /* [in] */ REFIID riid,
00321             /* [in] */ LCID lcid,
00322             /* [in] */ WORD wFlags,
00323             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
00324             /* [out] */ VARIANT __RPC_FAR *pVarResult,
00325             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
00326             /* [out] */ UINT __RPC_FAR *puArgErr);
00327
00328         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *CreateDocument )(
00329             ICRDEngine __RPC_FAR * This);
00330
00331         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *load )(
00332             ICRDEngine __RPC_FAR * This,
00333             /* [in] */ BSTR bstrFileName);
00334
00335         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *save )(
00336             ICRDEngine __RPC_FAR * This);
00337
00338         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *saveAs )(
00339             ICRDEngine __RPC_FAR * This,
00340             /* [defaultvalue][in] */ BSTR bstrFileName);
00341
00342         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *createController )(
00343             ICRDEngine __RPC_FAR * This,
00344             /* [in] */ BSTR bstrName,
00345             /* [retval][out] */ ICRDController __RPC_FAR *__RPC_FAR *pVal);
00346
00347         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *removeController )(
00348             ICRDEngine __RPC_FAR * This,
00349             /* [in] */ BSTR bstrName);
00350
00351         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *appendController )(
00352             ICRDEngine __RPC_FAR * This,
00353             /* [in] */ ICRDController __RPC_FAR *newCtrl);
00354
00355         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ControllerNames )(
00356             ICRDEngine __RPC_FAR * This,
00357             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
00358
00359         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Controller )(
00360             ICRDEngine __RPC_FAR * This,
00361             /* [in] */ BSTR bstrName,
00362             /* [retval][out] */ ICRDController __RPC_FAR *__RPC_FAR *pVal);
00363
00364         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Help )(
00365             ICRDEngine __RPC_FAR * This,
00366             /* [retval][out] */ BSTR __RPC_FAR *pVal);
00367
00368         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Help )(
00369             ICRDEngine __RPC_FAR * This,
00370             /* [in] */ BSTR newVal);
00371
00372         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Version )(
00373             ICRDEngine __RPC_FAR * This,
00374             /* [retval][out] */ BSTR __RPC_FAR *pVal);
00375
00376         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Version )(
00377             ICRDEngine __RPC_FAR * This,
00378             /* [in] */ BSTR newVal);
00379
00380         END_INTERFACE
00381     } ICRDEngineVtbl;
00382
00383     interface ICRDEngine
00384     {
00385         CONST_VTBL struct ICRDEngineVtbl __RPC_FAR *lpVtbl;
00386     };
00387
00388
00389
00390 #ifdef COBJMACROS
00391
00392
00393 #define ICRDEngine_QueryInterface(This,riid,ppvObject)  \
00394     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
00395
00396 #define ICRDEngine_AddRef(This) \
00397     (This)->lpVtbl -> AddRef(This)
00398
00399 #define ICRDEngine_Release(This)    \
00400     (This)->lpVtbl -> Release(This)
00401
00402
00403 #define ICRDEngine_GetTypeInfoCount(This,pctinfo)   \
00404     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
00405
00406 #define ICRDEngine_GetTypeInfo(This,iTInfo,lcid,ppTInfo)    \
00407     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
00408
00409 #define ICRDEngine_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)  \
00410     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
00411
00412 #define ICRDEngine_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)    \
00413     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
00414
00415
00416 #define ICRDEngine_CreateDocument(This) \
00417     (This)->lpVtbl -> CreateDocument(This)
00418
00419 #define ICRDEngine_load(This,bstrFileName)  \
00420     (This)->lpVtbl -> load(This,bstrFileName)
00421
00422 #define ICRDEngine_save(This)   \
00423     (This)->lpVtbl -> save(This)
00424
00425 #define ICRDEngine_saveAs(This,bstrFileName)    \
00426     (This)->lpVtbl -> saveAs(This,bstrFileName)
00427
00428 #define ICRDEngine_createController(This,bstrName,pVal) \
00429     (This)->lpVtbl -> createController(This,bstrName,pVal)
00430
00431 #define ICRDEngine_removeController(This,bstrName)  \
00432     (This)->lpVtbl -> removeController(This,bstrName)
00433
00434 #define ICRDEngine_appendController(This,newCtrl)   \
00435     (This)->lpVtbl -> appendController(This,newCtrl)
00436
00437 #define ICRDEngine_get_ControllerNames(This,pVal)   \
00438     (This)->lpVtbl -> get_ControllerNames(This,pVal)
00439
00440 #define ICRDEngine_get_Controller(This,bstrName,pVal)   \
00441     (This)->lpVtbl -> get_Controller(This,bstrName,pVal)
00442
00443 #define ICRDEngine_get_Help(This,pVal)  \
00444     (This)->lpVtbl -> get_Help(This,pVal)
00445
00446 #define ICRDEngine_put_Help(This,newVal)    \
00447     (This)->lpVtbl -> put_Help(This,newVal)
00448
00449 #define ICRDEngine_get_Version(This,pVal)   \
00450     (This)->lpVtbl -> get_Version(This,pVal)
00451
00452 #define ICRDEngine_put_Version(This,newVal) \
00453     (This)->lpVtbl -> put_Version(This,newVal)
00454
00455 #endif /* COBJMACROS */
00456
00457
00458 #endif  /* C style interface */
00459
00460
00461
00462 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDEngine_CreateDocument_Proxy(
00463     ICRDEngine __RPC_FAR * This);
00464
00465
00466 void __RPC_STUB ICRDEngine_CreateDocument_Stub(
00467     IRpcStubBuffer *This,
00468     IRpcChannelBuffer *_pRpcChannelBuffer,
00469     PRPC_MESSAGE _pRpcMessage,
00470     DWORD *_pdwStubPhase);
00471
00472
00473 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDEngine_load_Proxy(
00474     ICRDEngine __RPC_FAR * This,
00475     /* [in] */ BSTR bstrFileName);
00476
00477
00478 void __RPC_STUB ICRDEngine_load_Stub(
00479     IRpcStubBuffer *This,
00480     IRpcChannelBuffer *_pRpcChannelBuffer,
00481     PRPC_MESSAGE _pRpcMessage,
00482     DWORD *_pdwStubPhase);
00483
00484
00485 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDEngine_save_Proxy(
00486     ICRDEngine __RPC_FAR * This);
00487
00488
00489 void __RPC_STUB ICRDEngine_save_Stub(
00490     IRpcStubBuffer *This,
00491     IRpcChannelBuffer *_pRpcChannelBuffer,
00492     PRPC_MESSAGE _pRpcMessage,
00493     DWORD *_pdwStubPhase);
00494
00495
00496 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDEngine_saveAs_Proxy(
00497     ICRDEngine __RPC_FAR * This,
00498     /* [defaultvalue][in] */ BSTR bstrFileName);
00499
00500
00501 void __RPC_STUB ICRDEngine_saveAs_Stub(
00502     IRpcStubBuffer *This,
00503     IRpcChannelBuffer *_pRpcChannelBuffer,
00504     PRPC_MESSAGE _pRpcMessage,
00505     DWORD *_pdwStubPhase);
00506
00507
00508 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDEngine_createController_Proxy(
00509     ICRDEngine __RPC_FAR * This,
00510     /* [in] */ BSTR bstrName,
00511     /* [retval][out] */ ICRDController __RPC_FAR *__RPC_FAR *pVal);
00512
00513
00514 void __RPC_STUB ICRDEngine_createController_Stub(
00515     IRpcStubBuffer *This,
00516     IRpcChannelBuffer *_pRpcChannelBuffer,
00517     PRPC_MESSAGE _pRpcMessage,
00518     DWORD *_pdwStubPhase);
00519
00520
00521 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDEngine_removeController_Proxy(
00522     ICRDEngine __RPC_FAR * This,
00523     /* [in] */ BSTR bstrName);
00524
00525
00526 void __RPC_STUB ICRDEngine_removeController_Stub(
00527     IRpcStubBuffer *This,
00528     IRpcChannelBuffer *_pRpcChannelBuffer,
00529     PRPC_MESSAGE _pRpcMessage,
00530     DWORD *_pdwStubPhase);
00531
00532
00533 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDEngine_appendController_Proxy(
00534     ICRDEngine __RPC_FAR * This,
00535     /* [in] */ ICRDController __RPC_FAR *newCtrl);
00536
00537
00538 void __RPC_STUB ICRDEngine_appendController_Stub(
00539     IRpcStubBuffer *This,
00540     IRpcChannelBuffer *_pRpcChannelBuffer,
00541     PRPC_MESSAGE _pRpcMessage,
00542     DWORD *_pdwStubPhase);
00543
00544
00545 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDEngine_get_ControllerNames_Proxy(
00546     ICRDEngine __RPC_FAR * This,
00547     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
00548
00549
00550 void __RPC_STUB ICRDEngine_get_ControllerNames_Stub(
00551     IRpcStubBuffer *This,
00552     IRpcChannelBuffer *_pRpcChannelBuffer,
00553     PRPC_MESSAGE _pRpcMessage,
00554     DWORD *_pdwStubPhase);
00555
00556
00557 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDEngine_get_Controller_Proxy(
00558     ICRDEngine __RPC_FAR * This,
00559     /* [in] */ BSTR bstrName,
00560     /* [retval][out] */ ICRDController __RPC_FAR *__RPC_FAR *pVal);
00561
00562
00563 void __RPC_STUB ICRDEngine_get_Controller_Stub(
00564     IRpcStubBuffer *This,
00565     IRpcChannelBuffer *_pRpcChannelBuffer,
00566     PRPC_MESSAGE _pRpcMessage,
00567     DWORD *_pdwStubPhase);
00568
00569
00570 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDEngine_get_Help_Proxy(
00571     ICRDEngine __RPC_FAR * This,
00572     /* [retval][out] */ BSTR __RPC_FAR *pVal);
00573
00574
00575 void __RPC_STUB ICRDEngine_get_Help_Stub(
00576     IRpcStubBuffer *This,
00577     IRpcChannelBuffer *_pRpcChannelBuffer,
00578     PRPC_MESSAGE _pRpcMessage,
00579     DWORD *_pdwStubPhase);
00580
00581
00582 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDEngine_put_Help_Proxy(
00583     ICRDEngine __RPC_FAR * This,
00584     /* [in] */ BSTR newVal);
00585
00586
00587 void __RPC_STUB ICRDEngine_put_Help_Stub(
00588     IRpcStubBuffer *This,
00589     IRpcChannelBuffer *_pRpcChannelBuffer,
00590     PRPC_MESSAGE _pRpcMessage,
00591     DWORD *_pdwStubPhase);
00592
00593
00594 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDEngine_get_Version_Proxy(
00595     ICRDEngine __RPC_FAR * This,
00596     /* [retval][out] */ BSTR __RPC_FAR *pVal);
00597
00598
00599 void __RPC_STUB ICRDEngine_get_Version_Stub(
00600     IRpcStubBuffer *This,
00601     IRpcChannelBuffer *_pRpcChannelBuffer,
00602     PRPC_MESSAGE _pRpcMessage,
00603     DWORD *_pdwStubPhase);
00604
00605
00606 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDEngine_put_Version_Proxy(
00607     ICRDEngine __RPC_FAR * This,
00608     /* [in] */ BSTR newVal);
00609
00610
00611 void __RPC_STUB ICRDEngine_put_Version_Stub(
00612     IRpcStubBuffer *This,
00613     IRpcChannelBuffer *_pRpcChannelBuffer,
00614     PRPC_MESSAGE _pRpcMessage,
00615     DWORD *_pdwStubPhase);
00616
00617
00618
00619 #endif  /* __ICRDEngine_INTERFACE_DEFINED__ */
00620
00621
00622 #ifndef __ICRDController_INTERFACE_DEFINED__
00623 #define __ICRDController_INTERFACE_DEFINED__
00624
00625 /* interface ICRDController */
00626 /* [unique][helpstring][dual][uuid][object] */
00627
00628
00629 EXTERN_C const IID IID_ICRDController;
00630
00631 #if defined(__cplusplus) && !defined(CINTERFACE)
00632
00633     MIDL_INTERFACE("9044FA0D-1B4D-42C4-9DBC-1F6E4553E31C")
00634     ICRDController : public IDispatch
00635     {
00636     public:
00637         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
00638             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
00639
00640         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Attribute(
00641             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
00642
00643         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Attribute(
00644             /* [in] */ long newVal) = 0;
00645
00646         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Help(
00647             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
00648
00649         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Help(
00650             /* [in] */ BSTR newVal) = 0;
00651
00652         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ID(
00653             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
00654
00655         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ID(
00656             /* [in] */ VARIANT newVal) = 0;
00657
00658         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_XMLNode(
00659             /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal) = 0;
00660
00661         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE createExtension(
00662             /* [in] */ BSTR bstrName,
00663             /* [retval][out] */ ICRDExtension __RPC_FAR *__RPC_FAR *pVal) = 0;
00664
00665         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE removeExtension(
00666             /* [in] */ BSTR bstrName) = 0;
00667
00668         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE appendExtension(
00669             /* [in] */ ICRDExtension __RPC_FAR *newExt) = 0;
00670
00671         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ExtensionNames(
00672             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
00673
00674         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Extension(
00675             BSTR bstrName,
00676             /* [retval][out] */ ICRDExtension __RPC_FAR *__RPC_FAR *pVal) = 0;
00677
00678         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE createFile(
00679             /* [in] */ BSTR bstrName,
00680             /* [retval][out] */ ICRDFile __RPC_FAR *__RPC_FAR *pVal) = 0;
00681
00682         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE removeFile(
00683             /* [in] */ BSTR bstrName) = 0;
00684
00685         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE appendFile(
00686             /* [in] */ ICRDFile __RPC_FAR *newFile) = 0;
00687
00688         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_FileNames(
00689             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
00690
00691         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_File(
00692             BSTR bstrName,
00693             /* [retval][out] */ ICRDFile __RPC_FAR *__RPC_FAR *pVal) = 0;
00694
00695         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE createRobot(
00696             /* [in] */ BSTR bstrName,
00697             /* [retval][out] */ ICRDRobot __RPC_FAR *__RPC_FAR *pVal) = 0;
00698
00699         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE removeRobot(
00700             /* [in] */ BSTR bstrName) = 0;
00701
00702         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE appendRobot(
00703             /* [in] */ ICRDRobot __RPC_FAR *newRobot) = 0;
00704
00705         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_RobotNames(
00706             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
00707
00708         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Robot(
00709             BSTR bstrName,
00710             /* [retval][out] */ ICRDRobot __RPC_FAR *__RPC_FAR *pVal) = 0;
00711
00712         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE createTask(
00713             /* [in] */ BSTR bstrName,
00714             /* [retval][out] */ ICRDTask __RPC_FAR *__RPC_FAR *pVal) = 0;
00715
00716         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE removeTask(
00717             /* [in] */ BSTR bstrName) = 0;
00718
00719         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE appendTask(
00720             /* [in] */ ICRDTask __RPC_FAR *newTask) = 0;
00721
00722         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_TaskNames(
00723             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
00724
00725         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Task(
00726             BSTR bstrName,
00727             /* [retval][out] */ ICRDTask __RPC_FAR *__RPC_FAR *pVal) = 0;
00728
00729         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE createVariable(
00730             /* [in] */ BSTR bstrName,
00731             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal) = 0;
00732
00733         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE removeVariable(
00734             /* [in] */ BSTR bstrName) = 0;
00735
00736         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE appendVariable(
00737             /* [in] */ ICRDVariable __RPC_FAR *newVar) = 0;
00738
00739         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_VariableNames(
00740             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
00741
00742         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Variable(
00743             BSTR bstrName,
00744             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal) = 0;
00745
00746         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE createCommand(
00747             /* [in] */ BSTR bstrName,
00748             /* [retval][out] */ ICRDCommand __RPC_FAR *__RPC_FAR *pVal) = 0;
00749
00750         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE removeCommand(
00751             /* [in] */ BSTR bstrName) = 0;
00752
00753         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE appendCommand(
00754             /* [in] */ ICRDCommand __RPC_FAR *newCmd) = 0;
00755
00756         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_CommandNames(
00757             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
00758
00759         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Command(
00760             BSTR bstrName,
00761             /* [retval][out] */ ICRDCommand __RPC_FAR *__RPC_FAR *pVal) = 0;
00762
00763         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE createMessage(
00764             /* [in] */ long lNumber,
00765             /* [retval][out] */ ICRDMessage __RPC_FAR *__RPC_FAR *pVal) = 0;
00766
00767         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE removeMessage(
00768             /* [in] */ long lNumber) = 0;
00769
00770         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE appendMessage(
00771             /* [in] */ ICRDMessage __RPC_FAR *newMsg) = 0;
00772
00773         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_MessageNumbers(
00774             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
00775
00776         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Message(
00777             long lNumber,
00778             /* [retval][out] */ ICRDMessage __RPC_FAR *__RPC_FAR *pVal) = 0;
00779
00780         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE clone(
00781             /* [in] */ BSTR bstrDestName,
00782             /* [retval][out] */ ICRDController __RPC_FAR *__RPC_FAR *pVal) = 0;
00783
00784     };
00785
00786 #else   /* C style interface */
00787
00788     typedef struct ICRDControllerVtbl
00789     {
00790         BEGIN_INTERFACE
00791
00792         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
00793             ICRDController __RPC_FAR * This,
00794             /* [in] */ REFIID riid,
00795             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
00796
00797         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
00798             ICRDController __RPC_FAR * This);
00799
00800         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
00801             ICRDController __RPC_FAR * This);
00802
00803         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
00804             ICRDController __RPC_FAR * This,
00805             /* [out] */ UINT __RPC_FAR *pctinfo);
00806
00807         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
00808             ICRDController __RPC_FAR * This,
00809             /* [in] */ UINT iTInfo,
00810             /* [in] */ LCID lcid,
00811             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
00812
00813         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
00814             ICRDController __RPC_FAR * This,
00815             /* [in] */ REFIID riid,
00816             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
00817             /* [in] */ UINT cNames,
00818             /* [in] */ LCID lcid,
00819             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
00820
00821         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
00822             ICRDController __RPC_FAR * This,
00823             /* [in] */ DISPID dispIdMember,
00824             /* [in] */ REFIID riid,
00825             /* [in] */ LCID lcid,
00826             /* [in] */ WORD wFlags,
00827             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
00828             /* [out] */ VARIANT __RPC_FAR *pVarResult,
00829             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
00830             /* [out] */ UINT __RPC_FAR *puArgErr);
00831
00832         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
00833             ICRDController __RPC_FAR * This,
00834             /* [retval][out] */ BSTR __RPC_FAR *pVal);
00835
00836         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Attribute )(
00837             ICRDController __RPC_FAR * This,
00838             /* [retval][out] */ long __RPC_FAR *pVal);
00839
00840         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Attribute )(
00841             ICRDController __RPC_FAR * This,
00842             /* [in] */ long newVal);
00843
00844         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Help )(
00845             ICRDController __RPC_FAR * This,
00846             /* [retval][out] */ BSTR __RPC_FAR *pVal);
00847
00848         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Help )(
00849             ICRDController __RPC_FAR * This,
00850             /* [in] */ BSTR newVal);
00851
00852         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ID )(
00853             ICRDController __RPC_FAR * This,
00854             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
00855
00856         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ID )(
00857             ICRDController __RPC_FAR * This,
00858             /* [in] */ VARIANT newVal);
00859
00860         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_XMLNode )(
00861             ICRDController __RPC_FAR * This,
00862             /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal);
00863
00864         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *createExtension )(
00865             ICRDController __RPC_FAR * This,
00866             /* [in] */ BSTR bstrName,
00867             /* [retval][out] */ ICRDExtension __RPC_FAR *__RPC_FAR *pVal);
00868
00869         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *removeExtension )(
00870             ICRDController __RPC_FAR * This,
00871             /* [in] */ BSTR bstrName);
00872
00873         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *appendExtension )(
00874             ICRDController __RPC_FAR * This,
00875             /* [in] */ ICRDExtension __RPC_FAR *newExt);
00876
00877         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ExtensionNames )(
00878             ICRDController __RPC_FAR * This,
00879             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
00880
00881         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Extension )(
00882             ICRDController __RPC_FAR * This,
00883             BSTR bstrName,
00884             /* [retval][out] */ ICRDExtension __RPC_FAR *__RPC_FAR *pVal);
00885
00886         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *createFile )(
00887             ICRDController __RPC_FAR * This,
00888             /* [in] */ BSTR bstrName,
00889             /* [retval][out] */ ICRDFile __RPC_FAR *__RPC_FAR *pVal);
00890
00891         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *removeFile )(
00892             ICRDController __RPC_FAR * This,
00893             /* [in] */ BSTR bstrName);
00894
00895         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *appendFile )(
00896             ICRDController __RPC_FAR * This,
00897             /* [in] */ ICRDFile __RPC_FAR *newFile);
00898
00899         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_FileNames )(
00900             ICRDController __RPC_FAR * This,
00901             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
00902
00903         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_File )(
00904             ICRDController __RPC_FAR * This,
00905             BSTR bstrName,
00906             /* [retval][out] */ ICRDFile __RPC_FAR *__RPC_FAR *pVal);
00907
00908         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *createRobot )(
00909             ICRDController __RPC_FAR * This,
00910             /* [in] */ BSTR bstrName,
00911             /* [retval][out] */ ICRDRobot __RPC_FAR *__RPC_FAR *pVal);
00912
00913         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *removeRobot )(
00914             ICRDController __RPC_FAR * This,
00915             /* [in] */ BSTR bstrName);
00916
00917         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *appendRobot )(
00918             ICRDController __RPC_FAR * This,
00919             /* [in] */ ICRDRobot __RPC_FAR *newRobot);
00920
00921         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_RobotNames )(
00922             ICRDController __RPC_FAR * This,
00923             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
00924
00925         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Robot )(
00926             ICRDController __RPC_FAR * This,
00927             BSTR bstrName,
00928             /* [retval][out] */ ICRDRobot __RPC_FAR *__RPC_FAR *pVal);
00929
00930         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *createTask )(
00931             ICRDController __RPC_FAR * This,
00932             /* [in] */ BSTR bstrName,
00933             /* [retval][out] */ ICRDTask __RPC_FAR *__RPC_FAR *pVal);
00934
00935         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *removeTask )(
00936             ICRDController __RPC_FAR * This,
00937             /* [in] */ BSTR bstrName);
00938
00939         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *appendTask )(
00940             ICRDController __RPC_FAR * This,
00941             /* [in] */ ICRDTask __RPC_FAR *newTask);
00942
00943         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_TaskNames )(
00944             ICRDController __RPC_FAR * This,
00945             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
00946
00947         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Task )(
00948             ICRDController __RPC_FAR * This,
00949             BSTR bstrName,
00950             /* [retval][out] */ ICRDTask __RPC_FAR *__RPC_FAR *pVal);
00951
00952         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *createVariable )(
00953             ICRDController __RPC_FAR * This,
00954             /* [in] */ BSTR bstrName,
00955             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
00956
00957         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *removeVariable )(
00958             ICRDController __RPC_FAR * This,
00959             /* [in] */ BSTR bstrName);
00960
00961         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *appendVariable )(
00962             ICRDController __RPC_FAR * This,
00963             /* [in] */ ICRDVariable __RPC_FAR *newVar);
00964
00965         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_VariableNames )(
00966             ICRDController __RPC_FAR * This,
00967             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
00968
00969         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Variable )(
00970             ICRDController __RPC_FAR * This,
00971             BSTR bstrName,
00972             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
00973
00974         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *createCommand )(
00975             ICRDController __RPC_FAR * This,
00976             /* [in] */ BSTR bstrName,
00977             /* [retval][out] */ ICRDCommand __RPC_FAR *__RPC_FAR *pVal);
00978
00979         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *removeCommand )(
00980             ICRDController __RPC_FAR * This,
00981             /* [in] */ BSTR bstrName);
00982
00983         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *appendCommand )(
00984             ICRDController __RPC_FAR * This,
00985             /* [in] */ ICRDCommand __RPC_FAR *newCmd);
00986
00987         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_CommandNames )(
00988             ICRDController __RPC_FAR * This,
00989             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
00990
00991         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Command )(
00992             ICRDController __RPC_FAR * This,
00993             BSTR bstrName,
00994             /* [retval][out] */ ICRDCommand __RPC_FAR *__RPC_FAR *pVal);
00995
00996         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *createMessage )(
00997             ICRDController __RPC_FAR * This,
00998             /* [in] */ long lNumber,
00999             /* [retval][out] */ ICRDMessage __RPC_FAR *__RPC_FAR *pVal);
01000
01001         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *removeMessage )(
01002             ICRDController __RPC_FAR * This,
01003             /* [in] */ long lNumber);
01004
01005         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *appendMessage )(
01006             ICRDController __RPC_FAR * This,
01007             /* [in] */ ICRDMessage __RPC_FAR *newMsg);
01008
01009         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_MessageNumbers )(
01010             ICRDController __RPC_FAR * This,
01011             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01012
01013         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Message )(
01014             ICRDController __RPC_FAR * This,
01015             long lNumber,
01016             /* [retval][out] */ ICRDMessage __RPC_FAR *__RPC_FAR *pVal);
01017
01018         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *clone )(
01019             ICRDController __RPC_FAR * This,
01020             /* [in] */ BSTR bstrDestName,
01021             /* [retval][out] */ ICRDController __RPC_FAR *__RPC_FAR *pVal);
01022
01023         END_INTERFACE
01024     } ICRDControllerVtbl;
01025
01026     interface ICRDController
01027     {
01028         CONST_VTBL struct ICRDControllerVtbl __RPC_FAR *lpVtbl;
01029     };
01030
01031
01032
01033 #ifdef COBJMACROS
01034
01035
01036 #define ICRDController_QueryInterface(This,riid,ppvObject)  \
01037     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
01038
01039 #define ICRDController_AddRef(This) \
01040     (This)->lpVtbl -> AddRef(This)
01041
01042 #define ICRDController_Release(This)    \
01043     (This)->lpVtbl -> Release(This)
01044
01045
01046 #define ICRDController_GetTypeInfoCount(This,pctinfo)   \
01047     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
01048
01049 #define ICRDController_GetTypeInfo(This,iTInfo,lcid,ppTInfo)    \
01050     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
01051
01052 #define ICRDController_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)  \
01053     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
01054
01055 #define ICRDController_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)    \
01056     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
01057
01058
01059 #define ICRDController_get_Name(This,pVal)  \
01060     (This)->lpVtbl -> get_Name(This,pVal)
01061
01062 #define ICRDController_get_Attribute(This,pVal) \
01063     (This)->lpVtbl -> get_Attribute(This,pVal)
01064
01065 #define ICRDController_put_Attribute(This,newVal)   \
01066     (This)->lpVtbl -> put_Attribute(This,newVal)
01067
01068 #define ICRDController_get_Help(This,pVal)  \
01069     (This)->lpVtbl -> get_Help(This,pVal)
01070
01071 #define ICRDController_put_Help(This,newVal)    \
01072     (This)->lpVtbl -> put_Help(This,newVal)
01073
01074 #define ICRDController_get_ID(This,pVal)    \
01075     (This)->lpVtbl -> get_ID(This,pVal)
01076
01077 #define ICRDController_put_ID(This,newVal)  \
01078     (This)->lpVtbl -> put_ID(This,newVal)
01079
01080 #define ICRDController_get_XMLNode(This,pVal)   \
01081     (This)->lpVtbl -> get_XMLNode(This,pVal)
01082
01083 #define ICRDController_createExtension(This,bstrName,pVal)  \
01084     (This)->lpVtbl -> createExtension(This,bstrName,pVal)
01085
01086 #define ICRDController_removeExtension(This,bstrName)   \
01087     (This)->lpVtbl -> removeExtension(This,bstrName)
01088
01089 #define ICRDController_appendExtension(This,newExt) \
01090     (This)->lpVtbl -> appendExtension(This,newExt)
01091
01092 #define ICRDController_get_ExtensionNames(This,pVal)    \
01093     (This)->lpVtbl -> get_ExtensionNames(This,pVal)
01094
01095 #define ICRDController_get_Extension(This,bstrName,pVal)    \
01096     (This)->lpVtbl -> get_Extension(This,bstrName,pVal)
01097
01098 #define ICRDController_createFile(This,bstrName,pVal)   \
01099     (This)->lpVtbl -> createFile(This,bstrName,pVal)
01100
01101 #define ICRDController_removeFile(This,bstrName)    \
01102     (This)->lpVtbl -> removeFile(This,bstrName)
01103
01104 #define ICRDController_appendFile(This,newFile) \
01105     (This)->lpVtbl -> appendFile(This,newFile)
01106
01107 #define ICRDController_get_FileNames(This,pVal) \
01108     (This)->lpVtbl -> get_FileNames(This,pVal)
01109
01110 #define ICRDController_get_File(This,bstrName,pVal) \
01111     (This)->lpVtbl -> get_File(This,bstrName,pVal)
01112
01113 #define ICRDController_createRobot(This,bstrName,pVal)  \
01114     (This)->lpVtbl -> createRobot(This,bstrName,pVal)
01115
01116 #define ICRDController_removeRobot(This,bstrName)   \
01117     (This)->lpVtbl -> removeRobot(This,bstrName)
01118
01119 #define ICRDController_appendRobot(This,newRobot)   \
01120     (This)->lpVtbl -> appendRobot(This,newRobot)
01121
01122 #define ICRDController_get_RobotNames(This,pVal)    \
01123     (This)->lpVtbl -> get_RobotNames(This,pVal)
01124
01125 #define ICRDController_get_Robot(This,bstrName,pVal)    \
01126     (This)->lpVtbl -> get_Robot(This,bstrName,pVal)
01127
01128 #define ICRDController_createTask(This,bstrName,pVal)   \
01129     (This)->lpVtbl -> createTask(This,bstrName,pVal)
01130
01131 #define ICRDController_removeTask(This,bstrName)    \
01132     (This)->lpVtbl -> removeTask(This,bstrName)
01133
01134 #define ICRDController_appendTask(This,newTask) \
01135     (This)->lpVtbl -> appendTask(This,newTask)
01136
01137 #define ICRDController_get_TaskNames(This,pVal) \
01138     (This)->lpVtbl -> get_TaskNames(This,pVal)
01139
01140 #define ICRDController_get_Task(This,bstrName,pVal) \
01141     (This)->lpVtbl -> get_Task(This,bstrName,pVal)
01142
01143 #define ICRDController_createVariable(This,bstrName,pVal)   \
01144     (This)->lpVtbl -> createVariable(This,bstrName,pVal)
01145
01146 #define ICRDController_removeVariable(This,bstrName)    \
01147     (This)->lpVtbl -> removeVariable(This,bstrName)
01148
01149 #define ICRDController_appendVariable(This,newVar)  \
01150     (This)->lpVtbl -> appendVariable(This,newVar)
01151
01152 #define ICRDController_get_VariableNames(This,pVal) \
01153     (This)->lpVtbl -> get_VariableNames(This,pVal)
01154
01155 #define ICRDController_get_Variable(This,bstrName,pVal) \
01156     (This)->lpVtbl -> get_Variable(This,bstrName,pVal)
01157
01158 #define ICRDController_createCommand(This,bstrName,pVal)    \
01159     (This)->lpVtbl -> createCommand(This,bstrName,pVal)
01160
01161 #define ICRDController_removeCommand(This,bstrName) \
01162     (This)->lpVtbl -> removeCommand(This,bstrName)
01163
01164 #define ICRDController_appendCommand(This,newCmd)   \
01165     (This)->lpVtbl -> appendCommand(This,newCmd)
01166
01167 #define ICRDController_get_CommandNames(This,pVal)  \
01168     (This)->lpVtbl -> get_CommandNames(This,pVal)
01169
01170 #define ICRDController_get_Command(This,bstrName,pVal)  \
01171     (This)->lpVtbl -> get_Command(This,bstrName,pVal)
01172
01173 #define ICRDController_createMessage(This,lNumber,pVal) \
01174     (This)->lpVtbl -> createMessage(This,lNumber,pVal)
01175
01176 #define ICRDController_removeMessage(This,lNumber)  \
01177     (This)->lpVtbl -> removeMessage(This,lNumber)
01178
01179 #define ICRDController_appendMessage(This,newMsg)   \
01180     (This)->lpVtbl -> appendMessage(This,newMsg)
01181
01182 #define ICRDController_get_MessageNumbers(This,pVal)    \
01183     (This)->lpVtbl -> get_MessageNumbers(This,pVal)
01184
01185 #define ICRDController_get_Message(This,lNumber,pVal)   \
01186     (This)->lpVtbl -> get_Message(This,lNumber,pVal)
01187
01188 #define ICRDController_clone(This,bstrDestName,pVal)    \
01189     (This)->lpVtbl -> clone(This,bstrDestName,pVal)
01190
01191 #endif /* COBJMACROS */
01192
01193
01194 #endif  /* C style interface */
01195
01196
01197
01198 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_Name_Proxy(
01199     ICRDController __RPC_FAR * This,
01200     /* [retval][out] */ BSTR __RPC_FAR *pVal);
01201
01202
01203 void __RPC_STUB ICRDController_get_Name_Stub(
01204     IRpcStubBuffer *This,
01205     IRpcChannelBuffer *_pRpcChannelBuffer,
01206     PRPC_MESSAGE _pRpcMessage,
01207     DWORD *_pdwStubPhase);
01208
01209
01210 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_Attribute_Proxy(
01211     ICRDController __RPC_FAR * This,
01212     /* [retval][out] */ long __RPC_FAR *pVal);
01213
01214
01215 void __RPC_STUB ICRDController_get_Attribute_Stub(
01216     IRpcStubBuffer *This,
01217     IRpcChannelBuffer *_pRpcChannelBuffer,
01218     PRPC_MESSAGE _pRpcMessage,
01219     DWORD *_pdwStubPhase);
01220
01221
01222 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDController_put_Attribute_Proxy(
01223     ICRDController __RPC_FAR * This,
01224     /* [in] */ long newVal);
01225
01226
01227 void __RPC_STUB ICRDController_put_Attribute_Stub(
01228     IRpcStubBuffer *This,
01229     IRpcChannelBuffer *_pRpcChannelBuffer,
01230     PRPC_MESSAGE _pRpcMessage,
01231     DWORD *_pdwStubPhase);
01232
01233
01234 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_Help_Proxy(
01235     ICRDController __RPC_FAR * This,
01236     /* [retval][out] */ BSTR __RPC_FAR *pVal);
01237
01238
01239 void __RPC_STUB ICRDController_get_Help_Stub(
01240     IRpcStubBuffer *This,
01241     IRpcChannelBuffer *_pRpcChannelBuffer,
01242     PRPC_MESSAGE _pRpcMessage,
01243     DWORD *_pdwStubPhase);
01244
01245
01246 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDController_put_Help_Proxy(
01247     ICRDController __RPC_FAR * This,
01248     /* [in] */ BSTR newVal);
01249
01250
01251 void __RPC_STUB ICRDController_put_Help_Stub(
01252     IRpcStubBuffer *This,
01253     IRpcChannelBuffer *_pRpcChannelBuffer,
01254     PRPC_MESSAGE _pRpcMessage,
01255     DWORD *_pdwStubPhase);
01256
01257
01258 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_ID_Proxy(
01259     ICRDController __RPC_FAR * This,
01260     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01261
01262
01263 void __RPC_STUB ICRDController_get_ID_Stub(
01264     IRpcStubBuffer *This,
01265     IRpcChannelBuffer *_pRpcChannelBuffer,
01266     PRPC_MESSAGE _pRpcMessage,
01267     DWORD *_pdwStubPhase);
01268
01269
01270 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDController_put_ID_Proxy(
01271     ICRDController __RPC_FAR * This,
01272     /* [in] */ VARIANT newVal);
01273
01274
01275 void __RPC_STUB ICRDController_put_ID_Stub(
01276     IRpcStubBuffer *This,
01277     IRpcChannelBuffer *_pRpcChannelBuffer,
01278     PRPC_MESSAGE _pRpcMessage,
01279     DWORD *_pdwStubPhase);
01280
01281
01282 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_XMLNode_Proxy(
01283     ICRDController __RPC_FAR * This,
01284     /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal);
01285
01286
01287 void __RPC_STUB ICRDController_get_XMLNode_Stub(
01288     IRpcStubBuffer *This,
01289     IRpcChannelBuffer *_pRpcChannelBuffer,
01290     PRPC_MESSAGE _pRpcMessage,
01291     DWORD *_pdwStubPhase);
01292
01293
01294 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_createExtension_Proxy(
01295     ICRDController __RPC_FAR * This,
01296     /* [in] */ BSTR bstrName,
01297     /* [retval][out] */ ICRDExtension __RPC_FAR *__RPC_FAR *pVal);
01298
01299
01300 void __RPC_STUB ICRDController_createExtension_Stub(
01301     IRpcStubBuffer *This,
01302     IRpcChannelBuffer *_pRpcChannelBuffer,
01303     PRPC_MESSAGE _pRpcMessage,
01304     DWORD *_pdwStubPhase);
01305
01306
01307 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_removeExtension_Proxy(
01308     ICRDController __RPC_FAR * This,
01309     /* [in] */ BSTR bstrName);
01310
01311
01312 void __RPC_STUB ICRDController_removeExtension_Stub(
01313     IRpcStubBuffer *This,
01314     IRpcChannelBuffer *_pRpcChannelBuffer,
01315     PRPC_MESSAGE _pRpcMessage,
01316     DWORD *_pdwStubPhase);
01317
01318
01319 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_appendExtension_Proxy(
01320     ICRDController __RPC_FAR * This,
01321     /* [in] */ ICRDExtension __RPC_FAR *newExt);
01322
01323
01324 void __RPC_STUB ICRDController_appendExtension_Stub(
01325     IRpcStubBuffer *This,
01326     IRpcChannelBuffer *_pRpcChannelBuffer,
01327     PRPC_MESSAGE _pRpcMessage,
01328     DWORD *_pdwStubPhase);
01329
01330
01331 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_ExtensionNames_Proxy(
01332     ICRDController __RPC_FAR * This,
01333     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01334
01335
01336 void __RPC_STUB ICRDController_get_ExtensionNames_Stub(
01337     IRpcStubBuffer *This,
01338     IRpcChannelBuffer *_pRpcChannelBuffer,
01339     PRPC_MESSAGE _pRpcMessage,
01340     DWORD *_pdwStubPhase);
01341
01342
01343 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_Extension_Proxy(
01344     ICRDController __RPC_FAR * This,
01345     BSTR bstrName,
01346     /* [retval][out] */ ICRDExtension __RPC_FAR *__RPC_FAR *pVal);
01347
01348
01349 void __RPC_STUB ICRDController_get_Extension_Stub(
01350     IRpcStubBuffer *This,
01351     IRpcChannelBuffer *_pRpcChannelBuffer,
01352     PRPC_MESSAGE _pRpcMessage,
01353     DWORD *_pdwStubPhase);
01354
01355
01356 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_createFile_Proxy(
01357     ICRDController __RPC_FAR * This,
01358     /* [in] */ BSTR bstrName,
01359     /* [retval][out] */ ICRDFile __RPC_FAR *__RPC_FAR *pVal);
01360
01361
01362 void __RPC_STUB ICRDController_createFile_Stub(
01363     IRpcStubBuffer *This,
01364     IRpcChannelBuffer *_pRpcChannelBuffer,
01365     PRPC_MESSAGE _pRpcMessage,
01366     DWORD *_pdwStubPhase);
01367
01368
01369 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_removeFile_Proxy(
01370     ICRDController __RPC_FAR * This,
01371     /* [in] */ BSTR bstrName);
01372
01373
01374 void __RPC_STUB ICRDController_removeFile_Stub(
01375     IRpcStubBuffer *This,
01376     IRpcChannelBuffer *_pRpcChannelBuffer,
01377     PRPC_MESSAGE _pRpcMessage,
01378     DWORD *_pdwStubPhase);
01379
01380
01381 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_appendFile_Proxy(
01382     ICRDController __RPC_FAR * This,
01383     /* [in] */ ICRDFile __RPC_FAR *newFile);
01384
01385
01386 void __RPC_STUB ICRDController_appendFile_Stub(
01387     IRpcStubBuffer *This,
01388     IRpcChannelBuffer *_pRpcChannelBuffer,
01389     PRPC_MESSAGE _pRpcMessage,
01390     DWORD *_pdwStubPhase);
01391
01392
01393 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_FileNames_Proxy(
01394     ICRDController __RPC_FAR * This,
01395     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01396
01397
01398 void __RPC_STUB ICRDController_get_FileNames_Stub(
01399     IRpcStubBuffer *This,
01400     IRpcChannelBuffer *_pRpcChannelBuffer,
01401     PRPC_MESSAGE _pRpcMessage,
01402     DWORD *_pdwStubPhase);
01403
01404
01405 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_File_Proxy(
01406     ICRDController __RPC_FAR * This,
01407     BSTR bstrName,
01408     /* [retval][out] */ ICRDFile __RPC_FAR *__RPC_FAR *pVal);
01409
01410
01411 void __RPC_STUB ICRDController_get_File_Stub(
01412     IRpcStubBuffer *This,
01413     IRpcChannelBuffer *_pRpcChannelBuffer,
01414     PRPC_MESSAGE _pRpcMessage,
01415     DWORD *_pdwStubPhase);
01416
01417
01418 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_createRobot_Proxy(
01419     ICRDController __RPC_FAR * This,
01420     /* [in] */ BSTR bstrName,
01421     /* [retval][out] */ ICRDRobot __RPC_FAR *__RPC_FAR *pVal);
01422
01423
01424 void __RPC_STUB ICRDController_createRobot_Stub(
01425     IRpcStubBuffer *This,
01426     IRpcChannelBuffer *_pRpcChannelBuffer,
01427     PRPC_MESSAGE _pRpcMessage,
01428     DWORD *_pdwStubPhase);
01429
01430
01431 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_removeRobot_Proxy(
01432     ICRDController __RPC_FAR * This,
01433     /* [in] */ BSTR bstrName);
01434
01435
01436 void __RPC_STUB ICRDController_removeRobot_Stub(
01437     IRpcStubBuffer *This,
01438     IRpcChannelBuffer *_pRpcChannelBuffer,
01439     PRPC_MESSAGE _pRpcMessage,
01440     DWORD *_pdwStubPhase);
01441
01442
01443 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_appendRobot_Proxy(
01444     ICRDController __RPC_FAR * This,
01445     /* [in] */ ICRDRobot __RPC_FAR *newRobot);
01446
01447
01448 void __RPC_STUB ICRDController_appendRobot_Stub(
01449     IRpcStubBuffer *This,
01450     IRpcChannelBuffer *_pRpcChannelBuffer,
01451     PRPC_MESSAGE _pRpcMessage,
01452     DWORD *_pdwStubPhase);
01453
01454
01455 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_RobotNames_Proxy(
01456     ICRDController __RPC_FAR * This,
01457     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01458
01459
01460 void __RPC_STUB ICRDController_get_RobotNames_Stub(
01461     IRpcStubBuffer *This,
01462     IRpcChannelBuffer *_pRpcChannelBuffer,
01463     PRPC_MESSAGE _pRpcMessage,
01464     DWORD *_pdwStubPhase);
01465
01466
01467 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_Robot_Proxy(
01468     ICRDController __RPC_FAR * This,
01469     BSTR bstrName,
01470     /* [retval][out] */ ICRDRobot __RPC_FAR *__RPC_FAR *pVal);
01471
01472
01473 void __RPC_STUB ICRDController_get_Robot_Stub(
01474     IRpcStubBuffer *This,
01475     IRpcChannelBuffer *_pRpcChannelBuffer,
01476     PRPC_MESSAGE _pRpcMessage,
01477     DWORD *_pdwStubPhase);
01478
01479
01480 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_createTask_Proxy(
01481     ICRDController __RPC_FAR * This,
01482     /* [in] */ BSTR bstrName,
01483     /* [retval][out] */ ICRDTask __RPC_FAR *__RPC_FAR *pVal);
01484
01485
01486 void __RPC_STUB ICRDController_createTask_Stub(
01487     IRpcStubBuffer *This,
01488     IRpcChannelBuffer *_pRpcChannelBuffer,
01489     PRPC_MESSAGE _pRpcMessage,
01490     DWORD *_pdwStubPhase);
01491
01492
01493 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_removeTask_Proxy(
01494     ICRDController __RPC_FAR * This,
01495     /* [in] */ BSTR bstrName);
01496
01497
01498 void __RPC_STUB ICRDController_removeTask_Stub(
01499     IRpcStubBuffer *This,
01500     IRpcChannelBuffer *_pRpcChannelBuffer,
01501     PRPC_MESSAGE _pRpcMessage,
01502     DWORD *_pdwStubPhase);
01503
01504
01505 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_appendTask_Proxy(
01506     ICRDController __RPC_FAR * This,
01507     /* [in] */ ICRDTask __RPC_FAR *newTask);
01508
01509
01510 void __RPC_STUB ICRDController_appendTask_Stub(
01511     IRpcStubBuffer *This,
01512     IRpcChannelBuffer *_pRpcChannelBuffer,
01513     PRPC_MESSAGE _pRpcMessage,
01514     DWORD *_pdwStubPhase);
01515
01516
01517 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_TaskNames_Proxy(
01518     ICRDController __RPC_FAR * This,
01519     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01520
01521
01522 void __RPC_STUB ICRDController_get_TaskNames_Stub(
01523     IRpcStubBuffer *This,
01524     IRpcChannelBuffer *_pRpcChannelBuffer,
01525     PRPC_MESSAGE _pRpcMessage,
01526     DWORD *_pdwStubPhase);
01527
01528
01529 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_Task_Proxy(
01530     ICRDController __RPC_FAR * This,
01531     BSTR bstrName,
01532     /* [retval][out] */ ICRDTask __RPC_FAR *__RPC_FAR *pVal);
01533
01534
01535 void __RPC_STUB ICRDController_get_Task_Stub(
01536     IRpcStubBuffer *This,
01537     IRpcChannelBuffer *_pRpcChannelBuffer,
01538     PRPC_MESSAGE _pRpcMessage,
01539     DWORD *_pdwStubPhase);
01540
01541
01542 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_createVariable_Proxy(
01543     ICRDController __RPC_FAR * This,
01544     /* [in] */ BSTR bstrName,
01545     /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
01546
01547
01548 void __RPC_STUB ICRDController_createVariable_Stub(
01549     IRpcStubBuffer *This,
01550     IRpcChannelBuffer *_pRpcChannelBuffer,
01551     PRPC_MESSAGE _pRpcMessage,
01552     DWORD *_pdwStubPhase);
01553
01554
01555 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_removeVariable_Proxy(
01556     ICRDController __RPC_FAR * This,
01557     /* [in] */ BSTR bstrName);
01558
01559
01560 void __RPC_STUB ICRDController_removeVariable_Stub(
01561     IRpcStubBuffer *This,
01562     IRpcChannelBuffer *_pRpcChannelBuffer,
01563     PRPC_MESSAGE _pRpcMessage,
01564     DWORD *_pdwStubPhase);
01565
01566
01567 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_appendVariable_Proxy(
01568     ICRDController __RPC_FAR * This,
01569     /* [in] */ ICRDVariable __RPC_FAR *newVar);
01570
01571
01572 void __RPC_STUB ICRDController_appendVariable_Stub(
01573     IRpcStubBuffer *This,
01574     IRpcChannelBuffer *_pRpcChannelBuffer,
01575     PRPC_MESSAGE _pRpcMessage,
01576     DWORD *_pdwStubPhase);
01577
01578
01579 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_VariableNames_Proxy(
01580     ICRDController __RPC_FAR * This,
01581     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01582
01583
01584 void __RPC_STUB ICRDController_get_VariableNames_Stub(
01585     IRpcStubBuffer *This,
01586     IRpcChannelBuffer *_pRpcChannelBuffer,
01587     PRPC_MESSAGE _pRpcMessage,
01588     DWORD *_pdwStubPhase);
01589
01590
01591 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_Variable_Proxy(
01592     ICRDController __RPC_FAR * This,
01593     BSTR bstrName,
01594     /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
01595
01596
01597 void __RPC_STUB ICRDController_get_Variable_Stub(
01598     IRpcStubBuffer *This,
01599     IRpcChannelBuffer *_pRpcChannelBuffer,
01600     PRPC_MESSAGE _pRpcMessage,
01601     DWORD *_pdwStubPhase);
01602
01603
01604 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_createCommand_Proxy(
01605     ICRDController __RPC_FAR * This,
01606     /* [in] */ BSTR bstrName,
01607     /* [retval][out] */ ICRDCommand __RPC_FAR *__RPC_FAR *pVal);
01608
01609
01610 void __RPC_STUB ICRDController_createCommand_Stub(
01611     IRpcStubBuffer *This,
01612     IRpcChannelBuffer *_pRpcChannelBuffer,
01613     PRPC_MESSAGE _pRpcMessage,
01614     DWORD *_pdwStubPhase);
01615
01616
01617 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_removeCommand_Proxy(
01618     ICRDController __RPC_FAR * This,
01619     /* [in] */ BSTR bstrName);
01620
01621
01622 void __RPC_STUB ICRDController_removeCommand_Stub(
01623     IRpcStubBuffer *This,
01624     IRpcChannelBuffer *_pRpcChannelBuffer,
01625     PRPC_MESSAGE _pRpcMessage,
01626     DWORD *_pdwStubPhase);
01627
01628
01629 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_appendCommand_Proxy(
01630     ICRDController __RPC_FAR * This,
01631     /* [in] */ ICRDCommand __RPC_FAR *newCmd);
01632
01633
01634 void __RPC_STUB ICRDController_appendCommand_Stub(
01635     IRpcStubBuffer *This,
01636     IRpcChannelBuffer *_pRpcChannelBuffer,
01637     PRPC_MESSAGE _pRpcMessage,
01638     DWORD *_pdwStubPhase);
01639
01640
01641 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_CommandNames_Proxy(
01642     ICRDController __RPC_FAR * This,
01643     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01644
01645
01646 void __RPC_STUB ICRDController_get_CommandNames_Stub(
01647     IRpcStubBuffer *This,
01648     IRpcChannelBuffer *_pRpcChannelBuffer,
01649     PRPC_MESSAGE _pRpcMessage,
01650     DWORD *_pdwStubPhase);
01651
01652
01653 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_Command_Proxy(
01654     ICRDController __RPC_FAR * This,
01655     BSTR bstrName,
01656     /* [retval][out] */ ICRDCommand __RPC_FAR *__RPC_FAR *pVal);
01657
01658
01659 void __RPC_STUB ICRDController_get_Command_Stub(
01660     IRpcStubBuffer *This,
01661     IRpcChannelBuffer *_pRpcChannelBuffer,
01662     PRPC_MESSAGE _pRpcMessage,
01663     DWORD *_pdwStubPhase);
01664
01665
01666 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_createMessage_Proxy(
01667     ICRDController __RPC_FAR * This,
01668     /* [in] */ long lNumber,
01669     /* [retval][out] */ ICRDMessage __RPC_FAR *__RPC_FAR *pVal);
01670
01671
01672 void __RPC_STUB ICRDController_createMessage_Stub(
01673     IRpcStubBuffer *This,
01674     IRpcChannelBuffer *_pRpcChannelBuffer,
01675     PRPC_MESSAGE _pRpcMessage,
01676     DWORD *_pdwStubPhase);
01677
01678
01679 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_removeMessage_Proxy(
01680     ICRDController __RPC_FAR * This,
01681     /* [in] */ long lNumber);
01682
01683
01684 void __RPC_STUB ICRDController_removeMessage_Stub(
01685     IRpcStubBuffer *This,
01686     IRpcChannelBuffer *_pRpcChannelBuffer,
01687     PRPC_MESSAGE _pRpcMessage,
01688     DWORD *_pdwStubPhase);
01689
01690
01691 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_appendMessage_Proxy(
01692     ICRDController __RPC_FAR * This,
01693     /* [in] */ ICRDMessage __RPC_FAR *newMsg);
01694
01695
01696 void __RPC_STUB ICRDController_appendMessage_Stub(
01697     IRpcStubBuffer *This,
01698     IRpcChannelBuffer *_pRpcChannelBuffer,
01699     PRPC_MESSAGE _pRpcMessage,
01700     DWORD *_pdwStubPhase);
01701
01702
01703 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_MessageNumbers_Proxy(
01704     ICRDController __RPC_FAR * This,
01705     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01706
01707
01708 void __RPC_STUB ICRDController_get_MessageNumbers_Stub(
01709     IRpcStubBuffer *This,
01710     IRpcChannelBuffer *_pRpcChannelBuffer,
01711     PRPC_MESSAGE _pRpcMessage,
01712     DWORD *_pdwStubPhase);
01713
01714
01715 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDController_get_Message_Proxy(
01716     ICRDController __RPC_FAR * This,
01717     long lNumber,
01718     /* [retval][out] */ ICRDMessage __RPC_FAR *__RPC_FAR *pVal);
01719
01720
01721 void __RPC_STUB ICRDController_get_Message_Stub(
01722     IRpcStubBuffer *This,
01723     IRpcChannelBuffer *_pRpcChannelBuffer,
01724     PRPC_MESSAGE _pRpcMessage,
01725     DWORD *_pdwStubPhase);
01726
01727
01728 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDController_clone_Proxy(
01729     ICRDController __RPC_FAR * This,
01730     /* [in] */ BSTR bstrDestName,
01731     /* [retval][out] */ ICRDController __RPC_FAR *__RPC_FAR *pVal);
01732
01733
01734 void __RPC_STUB ICRDController_clone_Stub(
01735     IRpcStubBuffer *This,
01736     IRpcChannelBuffer *_pRpcChannelBuffer,
01737     PRPC_MESSAGE _pRpcMessage,
01738     DWORD *_pdwStubPhase);
01739
01740
01741
01742 #endif  /* __ICRDController_INTERFACE_DEFINED__ */
01743
01744
01745 #ifndef __ICRDExtension_INTERFACE_DEFINED__
01746 #define __ICRDExtension_INTERFACE_DEFINED__
01747
01748 /* interface ICRDExtension */
01749 /* [unique][helpstring][dual][uuid][object] */
01750
01751
01752 EXTERN_C const IID IID_ICRDExtension;
01753
01754 #if defined(__cplusplus) && !defined(CINTERFACE)
01755
01756     MIDL_INTERFACE("5DFD134B-65F4-44ED-B2B2-F70378BF8E13")
01757     ICRDExtension : public IDispatch
01758     {
01759     public:
01760         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
01761             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
01762
01763         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Attribute(
01764             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
01765
01766         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Attribute(
01767             /* [in] */ long newVal) = 0;
01768
01769         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Help(
01770             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
01771
01772         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Help(
01773             /* [in] */ BSTR newVal) = 0;
01774
01775         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ID(
01776             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
01777
01778         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ID(
01779             /* [in] */ VARIANT newVal) = 0;
01780
01781         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_XMLNode(
01782             /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal) = 0;
01783
01784         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE createVariable(
01785             /* [in] */ BSTR bstrName,
01786             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal) = 0;
01787
01788         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE removeVariable(
01789             /* [in] */ BSTR bstrName) = 0;
01790
01791         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE appendVariable(
01792             /* [in] */ ICRDVariable __RPC_FAR *newVar) = 0;
01793
01794         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_VariableNames(
01795             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
01796
01797         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Variable(
01798             BSTR bstrName,
01799             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal) = 0;
01800
01801         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE clone(
01802             /* [in] */ BSTR bstrDestName,
01803             /* [retval][out] */ ICRDExtension __RPC_FAR *__RPC_FAR *pVal) = 0;
01804
01805     };
01806
01807 #else   /* C style interface */
01808
01809     typedef struct ICRDExtensionVtbl
01810     {
01811         BEGIN_INTERFACE
01812
01813         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
01814             ICRDExtension __RPC_FAR * This,
01815             /* [in] */ REFIID riid,
01816             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
01817
01818         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
01819             ICRDExtension __RPC_FAR * This);
01820
01821         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
01822             ICRDExtension __RPC_FAR * This);
01823
01824         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
01825             ICRDExtension __RPC_FAR * This,
01826             /* [out] */ UINT __RPC_FAR *pctinfo);
01827
01828         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
01829             ICRDExtension __RPC_FAR * This,
01830             /* [in] */ UINT iTInfo,
01831             /* [in] */ LCID lcid,
01832             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
01833
01834         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
01835             ICRDExtension __RPC_FAR * This,
01836             /* [in] */ REFIID riid,
01837             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
01838             /* [in] */ UINT cNames,
01839             /* [in] */ LCID lcid,
01840             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
01841
01842         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
01843             ICRDExtension __RPC_FAR * This,
01844             /* [in] */ DISPID dispIdMember,
01845             /* [in] */ REFIID riid,
01846             /* [in] */ LCID lcid,
01847             /* [in] */ WORD wFlags,
01848             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
01849             /* [out] */ VARIANT __RPC_FAR *pVarResult,
01850             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
01851             /* [out] */ UINT __RPC_FAR *puArgErr);
01852
01853         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
01854             ICRDExtension __RPC_FAR * This,
01855             /* [retval][out] */ BSTR __RPC_FAR *pVal);
01856
01857         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Attribute )(
01858             ICRDExtension __RPC_FAR * This,
01859             /* [retval][out] */ long __RPC_FAR *pVal);
01860
01861         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Attribute )(
01862             ICRDExtension __RPC_FAR * This,
01863             /* [in] */ long newVal);
01864
01865         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Help )(
01866             ICRDExtension __RPC_FAR * This,
01867             /* [retval][out] */ BSTR __RPC_FAR *pVal);
01868
01869         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Help )(
01870             ICRDExtension __RPC_FAR * This,
01871             /* [in] */ BSTR newVal);
01872
01873         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ID )(
01874             ICRDExtension __RPC_FAR * This,
01875             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01876
01877         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ID )(
01878             ICRDExtension __RPC_FAR * This,
01879             /* [in] */ VARIANT newVal);
01880
01881         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_XMLNode )(
01882             ICRDExtension __RPC_FAR * This,
01883             /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal);
01884
01885         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *createVariable )(
01886             ICRDExtension __RPC_FAR * This,
01887             /* [in] */ BSTR bstrName,
01888             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
01889
01890         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *removeVariable )(
01891             ICRDExtension __RPC_FAR * This,
01892             /* [in] */ BSTR bstrName);
01893
01894         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *appendVariable )(
01895             ICRDExtension __RPC_FAR * This,
01896             /* [in] */ ICRDVariable __RPC_FAR *newVar);
01897
01898         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_VariableNames )(
01899             ICRDExtension __RPC_FAR * This,
01900             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01901
01902         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Variable )(
01903             ICRDExtension __RPC_FAR * This,
01904             BSTR bstrName,
01905             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
01906
01907         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *clone )(
01908             ICRDExtension __RPC_FAR * This,
01909             /* [in] */ BSTR bstrDestName,
01910             /* [retval][out] */ ICRDExtension __RPC_FAR *__RPC_FAR *pVal);
01911
01912         END_INTERFACE
01913     } ICRDExtensionVtbl;
01914
01915     interface ICRDExtension
01916     {
01917         CONST_VTBL struct ICRDExtensionVtbl __RPC_FAR *lpVtbl;
01918     };
01919
01920
01921
01922 #ifdef COBJMACROS
01923
01924
01925 #define ICRDExtension_QueryInterface(This,riid,ppvObject)   \
01926     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
01927
01928 #define ICRDExtension_AddRef(This)  \
01929     (This)->lpVtbl -> AddRef(This)
01930
01931 #define ICRDExtension_Release(This) \
01932     (This)->lpVtbl -> Release(This)
01933
01934
01935 #define ICRDExtension_GetTypeInfoCount(This,pctinfo)    \
01936     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
01937
01938 #define ICRDExtension_GetTypeInfo(This,iTInfo,lcid,ppTInfo) \
01939     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
01940
01941 #define ICRDExtension_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)   \
01942     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
01943
01944 #define ICRDExtension_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr) \
01945     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
01946
01947
01948 #define ICRDExtension_get_Name(This,pVal)   \
01949     (This)->lpVtbl -> get_Name(This,pVal)
01950
01951 #define ICRDExtension_get_Attribute(This,pVal)  \
01952     (This)->lpVtbl -> get_Attribute(This,pVal)
01953
01954 #define ICRDExtension_put_Attribute(This,newVal)    \
01955     (This)->lpVtbl -> put_Attribute(This,newVal)
01956
01957 #define ICRDExtension_get_Help(This,pVal)   \
01958     (This)->lpVtbl -> get_Help(This,pVal)
01959
01960 #define ICRDExtension_put_Help(This,newVal) \
01961     (This)->lpVtbl -> put_Help(This,newVal)
01962
01963 #define ICRDExtension_get_ID(This,pVal) \
01964     (This)->lpVtbl -> get_ID(This,pVal)
01965
01966 #define ICRDExtension_put_ID(This,newVal)   \
01967     (This)->lpVtbl -> put_ID(This,newVal)
01968
01969 #define ICRDExtension_get_XMLNode(This,pVal)    \
01970     (This)->lpVtbl -> get_XMLNode(This,pVal)
01971
01972 #define ICRDExtension_createVariable(This,bstrName,pVal)    \
01973     (This)->lpVtbl -> createVariable(This,bstrName,pVal)
01974
01975 #define ICRDExtension_removeVariable(This,bstrName) \
01976     (This)->lpVtbl -> removeVariable(This,bstrName)
01977
01978 #define ICRDExtension_appendVariable(This,newVar)   \
01979     (This)->lpVtbl -> appendVariable(This,newVar)
01980
01981 #define ICRDExtension_get_VariableNames(This,pVal)  \
01982     (This)->lpVtbl -> get_VariableNames(This,pVal)
01983
01984 #define ICRDExtension_get_Variable(This,bstrName,pVal)  \
01985     (This)->lpVtbl -> get_Variable(This,bstrName,pVal)
01986
01987 #define ICRDExtension_clone(This,bstrDestName,pVal) \
01988     (This)->lpVtbl -> clone(This,bstrDestName,pVal)
01989
01990 #endif /* COBJMACROS */
01991
01992
01993 #endif  /* C style interface */
01994
01995
01996
01997 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDExtension_get_Name_Proxy(
01998     ICRDExtension __RPC_FAR * This,
01999     /* [retval][out] */ BSTR __RPC_FAR *pVal);
02000
02001
02002 void __RPC_STUB ICRDExtension_get_Name_Stub(
02003     IRpcStubBuffer *This,
02004     IRpcChannelBuffer *_pRpcChannelBuffer,
02005     PRPC_MESSAGE _pRpcMessage,
02006     DWORD *_pdwStubPhase);
02007
02008
02009 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDExtension_get_Attribute_Proxy(
02010     ICRDExtension __RPC_FAR * This,
02011     /* [retval][out] */ long __RPC_FAR *pVal);
02012
02013
02014 void __RPC_STUB ICRDExtension_get_Attribute_Stub(
02015     IRpcStubBuffer *This,
02016     IRpcChannelBuffer *_pRpcChannelBuffer,
02017     PRPC_MESSAGE _pRpcMessage,
02018     DWORD *_pdwStubPhase);
02019
02020
02021 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDExtension_put_Attribute_Proxy(
02022     ICRDExtension __RPC_FAR * This,
02023     /* [in] */ long newVal);
02024
02025
02026 void __RPC_STUB ICRDExtension_put_Attribute_Stub(
02027     IRpcStubBuffer *This,
02028     IRpcChannelBuffer *_pRpcChannelBuffer,
02029     PRPC_MESSAGE _pRpcMessage,
02030     DWORD *_pdwStubPhase);
02031
02032
02033 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDExtension_get_Help_Proxy(
02034     ICRDExtension __RPC_FAR * This,
02035     /* [retval][out] */ BSTR __RPC_FAR *pVal);
02036
02037
02038 void __RPC_STUB ICRDExtension_get_Help_Stub(
02039     IRpcStubBuffer *This,
02040     IRpcChannelBuffer *_pRpcChannelBuffer,
02041     PRPC_MESSAGE _pRpcMessage,
02042     DWORD *_pdwStubPhase);
02043
02044
02045 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDExtension_put_Help_Proxy(
02046     ICRDExtension __RPC_FAR * This,
02047     /* [in] */ BSTR newVal);
02048
02049
02050 void __RPC_STUB ICRDExtension_put_Help_Stub(
02051     IRpcStubBuffer *This,
02052     IRpcChannelBuffer *_pRpcChannelBuffer,
02053     PRPC_MESSAGE _pRpcMessage,
02054     DWORD *_pdwStubPhase);
02055
02056
02057 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDExtension_get_ID_Proxy(
02058     ICRDExtension __RPC_FAR * This,
02059     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02060
02061
02062 void __RPC_STUB ICRDExtension_get_ID_Stub(
02063     IRpcStubBuffer *This,
02064     IRpcChannelBuffer *_pRpcChannelBuffer,
02065     PRPC_MESSAGE _pRpcMessage,
02066     DWORD *_pdwStubPhase);
02067
02068
02069 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDExtension_put_ID_Proxy(
02070     ICRDExtension __RPC_FAR * This,
02071     /* [in] */ VARIANT newVal);
02072
02073
02074 void __RPC_STUB ICRDExtension_put_ID_Stub(
02075     IRpcStubBuffer *This,
02076     IRpcChannelBuffer *_pRpcChannelBuffer,
02077     PRPC_MESSAGE _pRpcMessage,
02078     DWORD *_pdwStubPhase);
02079
02080
02081 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDExtension_get_XMLNode_Proxy(
02082     ICRDExtension __RPC_FAR * This,
02083     /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal);
02084
02085
02086 void __RPC_STUB ICRDExtension_get_XMLNode_Stub(
02087     IRpcStubBuffer *This,
02088     IRpcChannelBuffer *_pRpcChannelBuffer,
02089     PRPC_MESSAGE _pRpcMessage,
02090     DWORD *_pdwStubPhase);
02091
02092
02093 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDExtension_createVariable_Proxy(
02094     ICRDExtension __RPC_FAR * This,
02095     /* [in] */ BSTR bstrName,
02096     /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
02097
02098
02099 void __RPC_STUB ICRDExtension_createVariable_Stub(
02100     IRpcStubBuffer *This,
02101     IRpcChannelBuffer *_pRpcChannelBuffer,
02102     PRPC_MESSAGE _pRpcMessage,
02103     DWORD *_pdwStubPhase);
02104
02105
02106 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDExtension_removeVariable_Proxy(
02107     ICRDExtension __RPC_FAR * This,
02108     /* [in] */ BSTR bstrName);
02109
02110
02111 void __RPC_STUB ICRDExtension_removeVariable_Stub(
02112     IRpcStubBuffer *This,
02113     IRpcChannelBuffer *_pRpcChannelBuffer,
02114     PRPC_MESSAGE _pRpcMessage,
02115     DWORD *_pdwStubPhase);
02116
02117
02118 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDExtension_appendVariable_Proxy(
02119     ICRDExtension __RPC_FAR * This,
02120     /* [in] */ ICRDVariable __RPC_FAR *newVar);
02121
02122
02123 void __RPC_STUB ICRDExtension_appendVariable_Stub(
02124     IRpcStubBuffer *This,
02125     IRpcChannelBuffer *_pRpcChannelBuffer,
02126     PRPC_MESSAGE _pRpcMessage,
02127     DWORD *_pdwStubPhase);
02128
02129
02130 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDExtension_get_VariableNames_Proxy(
02131     ICRDExtension __RPC_FAR * This,
02132     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02133
02134
02135 void __RPC_STUB ICRDExtension_get_VariableNames_Stub(
02136     IRpcStubBuffer *This,
02137     IRpcChannelBuffer *_pRpcChannelBuffer,
02138     PRPC_MESSAGE _pRpcMessage,
02139     DWORD *_pdwStubPhase);
02140
02141
02142 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDExtension_get_Variable_Proxy(
02143     ICRDExtension __RPC_FAR * This,
02144     BSTR bstrName,
02145     /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
02146
02147
02148 void __RPC_STUB ICRDExtension_get_Variable_Stub(
02149     IRpcStubBuffer *This,
02150     IRpcChannelBuffer *_pRpcChannelBuffer,
02151     PRPC_MESSAGE _pRpcMessage,
02152     DWORD *_pdwStubPhase);
02153
02154
02155 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDExtension_clone_Proxy(
02156     ICRDExtension __RPC_FAR * This,
02157     /* [in] */ BSTR bstrDestName,
02158     /* [retval][out] */ ICRDExtension __RPC_FAR *__RPC_FAR *pVal);
02159
02160
02161 void __RPC_STUB ICRDExtension_clone_Stub(
02162     IRpcStubBuffer *This,
02163     IRpcChannelBuffer *_pRpcChannelBuffer,
02164     PRPC_MESSAGE _pRpcMessage,
02165     DWORD *_pdwStubPhase);
02166
02167
02168
02169 #endif  /* __ICRDExtension_INTERFACE_DEFINED__ */
02170
02171
02172 #ifndef __ICRDFile_INTERFACE_DEFINED__
02173 #define __ICRDFile_INTERFACE_DEFINED__
02174
02175 /* interface ICRDFile */
02176 /* [unique][helpstring][dual][uuid][object] */
02177
02178
02179 EXTERN_C const IID IID_ICRDFile;
02180
02181 #if defined(__cplusplus) && !defined(CINTERFACE)
02182
02183     MIDL_INTERFACE("087D5BDD-4D9E-4EC5-8CDA-850F486DC83C")
02184     ICRDFile : public IDispatch
02185     {
02186     public:
02187         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
02188             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
02189
02190         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Attribute(
02191             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
02192
02193         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Attribute(
02194             /* [in] */ long newVal) = 0;
02195
02196         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Help(
02197             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
02198
02199         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Help(
02200             /* [in] */ BSTR newVal) = 0;
02201
02202         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_DateCreated(
02203             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
02204
02205         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_DateCreated(
02206             /* [in] */ VARIANT newVal) = 0;
02207
02208         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_DateLastAccessed(
02209             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
02210
02211         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_DateLastAccessed(
02212             /* [in] */ VARIANT newVal) = 0;
02213
02214         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_DateLastModified(
02215             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
02216
02217         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_DateLastModified(
02218             /* [in] */ VARIANT newVal) = 0;
02219
02220         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Path(
02221             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
02222
02223         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Path(
02224             /* [in] */ BSTR newVal) = 0;
02225
02226         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Size(
02227             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
02228
02229         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Size(
02230             /* [in] */ long newVal) = 0;
02231
02232         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Type(
02233             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
02234
02235         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Type(
02236             /* [in] */ BSTR newVal) = 0;
02237
02238         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Value(
02239             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
02240
02241         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Value(
02242             /* [in] */ VARIANT newVal) = 0;
02243
02244         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ID(
02245             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
02246
02247         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ID(
02248             /* [in] */ VARIANT newVal) = 0;
02249
02250         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_XMLNode(
02251             /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal) = 0;
02252
02253         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE createFile(
02254             /* [in] */ BSTR bstrName,
02255             /* [retval][out] */ ICRDFile __RPC_FAR *__RPC_FAR *pVal) = 0;
02256
02257         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE removeFile(
02258             /* [in] */ BSTR bstrName) = 0;
02259
02260         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE appendFile(
02261             /* [in] */ ICRDFile __RPC_FAR *newFile) = 0;
02262
02263         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_FileNames(
02264             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
02265
02266         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_File(
02267             BSTR bstrName,
02268             /* [retval][out] */ ICRDFile __RPC_FAR *__RPC_FAR *pVal) = 0;
02269
02270         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE createVariable(
02271             /* [in] */ BSTR bstrName,
02272             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal) = 0;
02273
02274         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE removeVariable(
02275             /* [in] */ BSTR bstrName) = 0;
02276
02277         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE appendVariable(
02278             /* [in] */ ICRDVariable __RPC_FAR *newVar) = 0;
02279
02280         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_VariableNames(
02281             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
02282
02283         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Variable(
02284             BSTR bstrName,
02285             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal) = 0;
02286
02287         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE clone(
02288             /* [in] */ BSTR bstrDestName,
02289             /* [retval][out] */ ICRDFile __RPC_FAR *__RPC_FAR *pVal) = 0;
02290
02291     };
02292
02293 #else   /* C style interface */
02294
02295     typedef struct ICRDFileVtbl
02296     {
02297         BEGIN_INTERFACE
02298
02299         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
02300             ICRDFile __RPC_FAR * This,
02301             /* [in] */ REFIID riid,
02302             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
02303
02304         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
02305             ICRDFile __RPC_FAR * This);
02306
02307         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
02308             ICRDFile __RPC_FAR * This);
02309
02310         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
02311             ICRDFile __RPC_FAR * This,
02312             /* [out] */ UINT __RPC_FAR *pctinfo);
02313
02314         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
02315             ICRDFile __RPC_FAR * This,
02316             /* [in] */ UINT iTInfo,
02317             /* [in] */ LCID lcid,
02318             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
02319
02320         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
02321             ICRDFile __RPC_FAR * This,
02322             /* [in] */ REFIID riid,
02323             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
02324             /* [in] */ UINT cNames,
02325             /* [in] */ LCID lcid,
02326             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
02327
02328         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
02329             ICRDFile __RPC_FAR * This,
02330             /* [in] */ DISPID dispIdMember,
02331             /* [in] */ REFIID riid,
02332             /* [in] */ LCID lcid,
02333             /* [in] */ WORD wFlags,
02334             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
02335             /* [out] */ VARIANT __RPC_FAR *pVarResult,
02336             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
02337             /* [out] */ UINT __RPC_FAR *puArgErr);
02338
02339         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
02340             ICRDFile __RPC_FAR * This,
02341             /* [retval][out] */ BSTR __RPC_FAR *pVal);
02342
02343         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Attribute )(
02344             ICRDFile __RPC_FAR * This,
02345             /* [retval][out] */ long __RPC_FAR *pVal);
02346
02347         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Attribute )(
02348             ICRDFile __RPC_FAR * This,
02349             /* [in] */ long newVal);
02350
02351         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Help )(
02352             ICRDFile __RPC_FAR * This,
02353             /* [retval][out] */ BSTR __RPC_FAR *pVal);
02354
02355         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Help )(
02356             ICRDFile __RPC_FAR * This,
02357             /* [in] */ BSTR newVal);
02358
02359         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_DateCreated )(
02360             ICRDFile __RPC_FAR * This,
02361             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02362
02363         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_DateCreated )(
02364             ICRDFile __RPC_FAR * This,
02365             /* [in] */ VARIANT newVal);
02366
02367         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_DateLastAccessed )(
02368             ICRDFile __RPC_FAR * This,
02369             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02370
02371         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_DateLastAccessed )(
02372             ICRDFile __RPC_FAR * This,
02373             /* [in] */ VARIANT newVal);
02374
02375         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_DateLastModified )(
02376             ICRDFile __RPC_FAR * This,
02377             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02378
02379         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_DateLastModified )(
02380             ICRDFile __RPC_FAR * This,
02381             /* [in] */ VARIANT newVal);
02382
02383         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Path )(
02384             ICRDFile __RPC_FAR * This,
02385             /* [retval][out] */ BSTR __RPC_FAR *pVal);
02386
02387         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Path )(
02388             ICRDFile __RPC_FAR * This,
02389             /* [in] */ BSTR newVal);
02390
02391         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Size )(
02392             ICRDFile __RPC_FAR * This,
02393             /* [retval][out] */ long __RPC_FAR *pVal);
02394
02395         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Size )(
02396             ICRDFile __RPC_FAR * This,
02397             /* [in] */ long newVal);
02398
02399         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Type )(
02400             ICRDFile __RPC_FAR * This,
02401             /* [retval][out] */ BSTR __RPC_FAR *pVal);
02402
02403         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Type )(
02404             ICRDFile __RPC_FAR * This,
02405             /* [in] */ BSTR newVal);
02406
02407         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Value )(
02408             ICRDFile __RPC_FAR * This,
02409             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02410
02411         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Value )(
02412             ICRDFile __RPC_FAR * This,
02413             /* [in] */ VARIANT newVal);
02414
02415         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ID )(
02416             ICRDFile __RPC_FAR * This,
02417             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02418
02419         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ID )(
02420             ICRDFile __RPC_FAR * This,
02421             /* [in] */ VARIANT newVal);
02422
02423         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_XMLNode )(
02424             ICRDFile __RPC_FAR * This,
02425             /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal);
02426
02427         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *createFile )(
02428             ICRDFile __RPC_FAR * This,
02429             /* [in] */ BSTR bstrName,
02430             /* [retval][out] */ ICRDFile __RPC_FAR *__RPC_FAR *pVal);
02431
02432         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *removeFile )(
02433             ICRDFile __RPC_FAR * This,
02434             /* [in] */ BSTR bstrName);
02435
02436         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *appendFile )(
02437             ICRDFile __RPC_FAR * This,
02438             /* [in] */ ICRDFile __RPC_FAR *newFile);
02439
02440         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_FileNames )(
02441             ICRDFile __RPC_FAR * This,
02442             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02443
02444         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_File )(
02445             ICRDFile __RPC_FAR * This,
02446             BSTR bstrName,
02447             /* [retval][out] */ ICRDFile __RPC_FAR *__RPC_FAR *pVal);
02448
02449         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *createVariable )(
02450             ICRDFile __RPC_FAR * This,
02451             /* [in] */ BSTR bstrName,
02452             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
02453
02454         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *removeVariable )(
02455             ICRDFile __RPC_FAR * This,
02456             /* [in] */ BSTR bstrName);
02457
02458         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *appendVariable )(
02459             ICRDFile __RPC_FAR * This,
02460             /* [in] */ ICRDVariable __RPC_FAR *newVar);
02461
02462         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_VariableNames )(
02463             ICRDFile __RPC_FAR * This,
02464             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02465
02466         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Variable )(
02467             ICRDFile __RPC_FAR * This,
02468             BSTR bstrName,
02469             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
02470
02471         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *clone )(
02472             ICRDFile __RPC_FAR * This,
02473             /* [in] */ BSTR bstrDestName,
02474             /* [retval][out] */ ICRDFile __RPC_FAR *__RPC_FAR *pVal);
02475
02476         END_INTERFACE
02477     } ICRDFileVtbl;
02478
02479     interface ICRDFile
02480     {
02481         CONST_VTBL struct ICRDFileVtbl __RPC_FAR *lpVtbl;
02482     };
02483
02484
02485
02486 #ifdef COBJMACROS
02487
02488
02489 #define ICRDFile_QueryInterface(This,riid,ppvObject)    \
02490     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
02491
02492 #define ICRDFile_AddRef(This)   \
02493     (This)->lpVtbl -> AddRef(This)
02494
02495 #define ICRDFile_Release(This)  \
02496     (This)->lpVtbl -> Release(This)
02497
02498
02499 #define ICRDFile_GetTypeInfoCount(This,pctinfo) \
02500     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
02501
02502 #define ICRDFile_GetTypeInfo(This,iTInfo,lcid,ppTInfo)  \
02503     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
02504
02505 #define ICRDFile_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)    \
02506     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
02507
02508 #define ICRDFile_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)  \
02509     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
02510
02511
02512 #define ICRDFile_get_Name(This,pVal)    \
02513     (This)->lpVtbl -> get_Name(This,pVal)
02514
02515 #define ICRDFile_get_Attribute(This,pVal)   \
02516     (This)->lpVtbl -> get_Attribute(This,pVal)
02517
02518 #define ICRDFile_put_Attribute(This,newVal) \
02519     (This)->lpVtbl -> put_Attribute(This,newVal)
02520
02521 #define ICRDFile_get_Help(This,pVal)    \
02522     (This)->lpVtbl -> get_Help(This,pVal)
02523
02524 #define ICRDFile_put_Help(This,newVal)  \
02525     (This)->lpVtbl -> put_Help(This,newVal)
02526
02527 #define ICRDFile_get_DateCreated(This,pVal) \
02528     (This)->lpVtbl -> get_DateCreated(This,pVal)
02529
02530 #define ICRDFile_put_DateCreated(This,newVal)   \
02531     (This)->lpVtbl -> put_DateCreated(This,newVal)
02532
02533 #define ICRDFile_get_DateLastAccessed(This,pVal)    \
02534     (This)->lpVtbl -> get_DateLastAccessed(This,pVal)
02535
02536 #define ICRDFile_put_DateLastAccessed(This,newVal)  \
02537     (This)->lpVtbl -> put_DateLastAccessed(This,newVal)
02538
02539 #define ICRDFile_get_DateLastModified(This,pVal)    \
02540     (This)->lpVtbl -> get_DateLastModified(This,pVal)
02541
02542 #define ICRDFile_put_DateLastModified(This,newVal)  \
02543     (This)->lpVtbl -> put_DateLastModified(This,newVal)
02544
02545 #define ICRDFile_get_Path(This,pVal)    \
02546     (This)->lpVtbl -> get_Path(This,pVal)
02547
02548 #define ICRDFile_put_Path(This,newVal)  \
02549     (This)->lpVtbl -> put_Path(This,newVal)
02550
02551 #define ICRDFile_get_Size(This,pVal)    \
02552     (This)->lpVtbl -> get_Size(This,pVal)
02553
02554 #define ICRDFile_put_Size(This,newVal)  \
02555     (This)->lpVtbl -> put_Size(This,newVal)
02556
02557 #define ICRDFile_get_Type(This,pVal)    \
02558     (This)->lpVtbl -> get_Type(This,pVal)
02559
02560 #define ICRDFile_put_Type(This,newVal)  \
02561     (This)->lpVtbl -> put_Type(This,newVal)
02562
02563 #define ICRDFile_get_Value(This,pVal)   \
02564     (This)->lpVtbl -> get_Value(This,pVal)
02565
02566 #define ICRDFile_put_Value(This,newVal) \
02567     (This)->lpVtbl -> put_Value(This,newVal)
02568
02569 #define ICRDFile_get_ID(This,pVal)  \
02570     (This)->lpVtbl -> get_ID(This,pVal)
02571
02572 #define ICRDFile_put_ID(This,newVal)    \
02573     (This)->lpVtbl -> put_ID(This,newVal)
02574
02575 #define ICRDFile_get_XMLNode(This,pVal) \
02576     (This)->lpVtbl -> get_XMLNode(This,pVal)
02577
02578 #define ICRDFile_createFile(This,bstrName,pVal) \
02579     (This)->lpVtbl -> createFile(This,bstrName,pVal)
02580
02581 #define ICRDFile_removeFile(This,bstrName)  \
02582     (This)->lpVtbl -> removeFile(This,bstrName)
02583
02584 #define ICRDFile_appendFile(This,newFile)   \
02585     (This)->lpVtbl -> appendFile(This,newFile)
02586
02587 #define ICRDFile_get_FileNames(This,pVal)   \
02588     (This)->lpVtbl -> get_FileNames(This,pVal)
02589
02590 #define ICRDFile_get_File(This,bstrName,pVal)   \
02591     (This)->lpVtbl -> get_File(This,bstrName,pVal)
02592
02593 #define ICRDFile_createVariable(This,bstrName,pVal) \
02594     (This)->lpVtbl -> createVariable(This,bstrName,pVal)
02595
02596 #define ICRDFile_removeVariable(This,bstrName)  \
02597     (This)->lpVtbl -> removeVariable(This,bstrName)
02598
02599 #define ICRDFile_appendVariable(This,newVar)    \
02600     (This)->lpVtbl -> appendVariable(This,newVar)
02601
02602 #define ICRDFile_get_VariableNames(This,pVal)   \
02603     (This)->lpVtbl -> get_VariableNames(This,pVal)
02604
02605 #define ICRDFile_get_Variable(This,bstrName,pVal)   \
02606     (This)->lpVtbl -> get_Variable(This,bstrName,pVal)
02607
02608 #define ICRDFile_clone(This,bstrDestName,pVal)  \
02609     (This)->lpVtbl -> clone(This,bstrDestName,pVal)
02610
02611 #endif /* COBJMACROS */
02612
02613
02614 #endif  /* C style interface */
02615
02616
02617
02618 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDFile_get_Name_Proxy(
02619     ICRDFile __RPC_FAR * This,
02620     /* [retval][out] */ BSTR __RPC_FAR *pVal);
02621
02622
02623 void __RPC_STUB ICRDFile_get_Name_Stub(
02624     IRpcStubBuffer *This,
02625     IRpcChannelBuffer *_pRpcChannelBuffer,
02626     PRPC_MESSAGE _pRpcMessage,
02627     DWORD *_pdwStubPhase);
02628
02629
02630 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDFile_get_Attribute_Proxy(
02631     ICRDFile __RPC_FAR * This,
02632     /* [retval][out] */ long __RPC_FAR *pVal);
02633
02634
02635 void __RPC_STUB ICRDFile_get_Attribute_Stub(
02636     IRpcStubBuffer *This,
02637     IRpcChannelBuffer *_pRpcChannelBuffer,
02638     PRPC_MESSAGE _pRpcMessage,
02639     DWORD *_pdwStubPhase);
02640
02641
02642 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDFile_put_Attribute_Proxy(
02643     ICRDFile __RPC_FAR * This,
02644     /* [in] */ long newVal);
02645
02646
02647 void __RPC_STUB ICRDFile_put_Attribute_Stub(
02648     IRpcStubBuffer *This,
02649     IRpcChannelBuffer *_pRpcChannelBuffer,
02650     PRPC_MESSAGE _pRpcMessage,
02651     DWORD *_pdwStubPhase);
02652
02653
02654 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDFile_get_Help_Proxy(
02655     ICRDFile __RPC_FAR * This,
02656     /* [retval][out] */ BSTR __RPC_FAR *pVal);
02657
02658
02659 void __RPC_STUB ICRDFile_get_Help_Stub(
02660     IRpcStubBuffer *This,
02661     IRpcChannelBuffer *_pRpcChannelBuffer,
02662     PRPC_MESSAGE _pRpcMessage,
02663     DWORD *_pdwStubPhase);
02664
02665
02666 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDFile_put_Help_Proxy(
02667     ICRDFile __RPC_FAR * This,
02668     /* [in] */ BSTR newVal);
02669
02670
02671 void __RPC_STUB ICRDFile_put_Help_Stub(
02672     IRpcStubBuffer *This,
02673     IRpcChannelBuffer *_pRpcChannelBuffer,
02674     PRPC_MESSAGE _pRpcMessage,
02675     DWORD *_pdwStubPhase);
02676
02677
02678 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDFile_get_DateCreated_Proxy(
02679     ICRDFile __RPC_FAR * This,
02680     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02681
02682
02683 void __RPC_STUB ICRDFile_get_DateCreated_Stub(
02684     IRpcStubBuffer *This,
02685     IRpcChannelBuffer *_pRpcChannelBuffer,
02686     PRPC_MESSAGE _pRpcMessage,
02687     DWORD *_pdwStubPhase);
02688
02689
02690 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDFile_put_DateCreated_Proxy(
02691     ICRDFile __RPC_FAR * This,
02692     /* [in] */ VARIANT newVal);
02693
02694
02695 void __RPC_STUB ICRDFile_put_DateCreated_Stub(
02696     IRpcStubBuffer *This,
02697     IRpcChannelBuffer *_pRpcChannelBuffer,
02698     PRPC_MESSAGE _pRpcMessage,
02699     DWORD *_pdwStubPhase);
02700
02701
02702 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDFile_get_DateLastAccessed_Proxy(
02703     ICRDFile __RPC_FAR * This,
02704     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02705
02706
02707 void __RPC_STUB ICRDFile_get_DateLastAccessed_Stub(
02708     IRpcStubBuffer *This,
02709     IRpcChannelBuffer *_pRpcChannelBuffer,
02710     PRPC_MESSAGE _pRpcMessage,
02711     DWORD *_pdwStubPhase);
02712
02713
02714 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDFile_put_DateLastAccessed_Proxy(
02715     ICRDFile __RPC_FAR * This,
02716     /* [in] */ VARIANT newVal);
02717
02718
02719 void __RPC_STUB ICRDFile_put_DateLastAccessed_Stub(
02720     IRpcStubBuffer *This,
02721     IRpcChannelBuffer *_pRpcChannelBuffer,
02722     PRPC_MESSAGE _pRpcMessage,
02723     DWORD *_pdwStubPhase);
02724
02725
02726 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDFile_get_DateLastModified_Proxy(
02727     ICRDFile __RPC_FAR * This,
02728     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02729
02730
02731 void __RPC_STUB ICRDFile_get_DateLastModified_Stub(
02732     IRpcStubBuffer *This,
02733     IRpcChannelBuffer *_pRpcChannelBuffer,
02734     PRPC_MESSAGE _pRpcMessage,
02735     DWORD *_pdwStubPhase);
02736
02737
02738 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDFile_put_DateLastModified_Proxy(
02739     ICRDFile __RPC_FAR * This,
02740     /* [in] */ VARIANT newVal);
02741
02742
02743 void __RPC_STUB ICRDFile_put_DateLastModified_Stub(
02744     IRpcStubBuffer *This,
02745     IRpcChannelBuffer *_pRpcChannelBuffer,
02746     PRPC_MESSAGE _pRpcMessage,
02747     DWORD *_pdwStubPhase);
02748
02749
02750 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDFile_get_Path_Proxy(
02751     ICRDFile __RPC_FAR * This,
02752     /* [retval][out] */ BSTR __RPC_FAR *pVal);
02753
02754
02755 void __RPC_STUB ICRDFile_get_Path_Stub(
02756     IRpcStubBuffer *This,
02757     IRpcChannelBuffer *_pRpcChannelBuffer,
02758     PRPC_MESSAGE _pRpcMessage,
02759     DWORD *_pdwStubPhase);
02760
02761
02762 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDFile_put_Path_Proxy(
02763     ICRDFile __RPC_FAR * This,
02764     /* [in] */ BSTR newVal);
02765
02766
02767 void __RPC_STUB ICRDFile_put_Path_Stub(
02768     IRpcStubBuffer *This,
02769     IRpcChannelBuffer *_pRpcChannelBuffer,
02770     PRPC_MESSAGE _pRpcMessage,
02771     DWORD *_pdwStubPhase);
02772
02773
02774 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDFile_get_Size_Proxy(
02775     ICRDFile __RPC_FAR * This,
02776     /* [retval][out] */ long __RPC_FAR *pVal);
02777
02778
02779 void __RPC_STUB ICRDFile_get_Size_Stub(
02780     IRpcStubBuffer *This,
02781     IRpcChannelBuffer *_pRpcChannelBuffer,
02782     PRPC_MESSAGE _pRpcMessage,
02783     DWORD *_pdwStubPhase);
02784
02785
02786 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDFile_put_Size_Proxy(
02787     ICRDFile __RPC_FAR * This,
02788     /* [in] */ long newVal);
02789
02790
02791 void __RPC_STUB ICRDFile_put_Size_Stub(
02792     IRpcStubBuffer *This,
02793     IRpcChannelBuffer *_pRpcChannelBuffer,
02794     PRPC_MESSAGE _pRpcMessage,
02795     DWORD *_pdwStubPhase);
02796
02797
02798 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDFile_get_Type_Proxy(
02799     ICRDFile __RPC_FAR * This,
02800     /* [retval][out] */ BSTR __RPC_FAR *pVal);
02801
02802
02803 void __RPC_STUB ICRDFile_get_Type_Stub(
02804     IRpcStubBuffer *This,
02805     IRpcChannelBuffer *_pRpcChannelBuffer,
02806     PRPC_MESSAGE _pRpcMessage,
02807     DWORD *_pdwStubPhase);
02808
02809
02810 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDFile_put_Type_Proxy(
02811     ICRDFile __RPC_FAR * This,
02812     /* [in] */ BSTR newVal);
02813
02814
02815 void __RPC_STUB ICRDFile_put_Type_Stub(
02816     IRpcStubBuffer *This,
02817     IRpcChannelBuffer *_pRpcChannelBuffer,
02818     PRPC_MESSAGE _pRpcMessage,
02819     DWORD *_pdwStubPhase);
02820
02821
02822 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDFile_get_Value_Proxy(
02823     ICRDFile __RPC_FAR * This,
02824     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02825
02826
02827 void __RPC_STUB ICRDFile_get_Value_Stub(
02828     IRpcStubBuffer *This,
02829     IRpcChannelBuffer *_pRpcChannelBuffer,
02830     PRPC_MESSAGE _pRpcMessage,
02831     DWORD *_pdwStubPhase);
02832
02833
02834 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDFile_put_Value_Proxy(
02835     ICRDFile __RPC_FAR * This,
02836     /* [in] */ VARIANT newVal);
02837
02838
02839 void __RPC_STUB ICRDFile_put_Value_Stub(
02840     IRpcStubBuffer *This,
02841     IRpcChannelBuffer *_pRpcChannelBuffer,
02842     PRPC_MESSAGE _pRpcMessage,
02843     DWORD *_pdwStubPhase);
02844
02845
02846 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDFile_get_ID_Proxy(
02847     ICRDFile __RPC_FAR * This,
02848     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02849
02850
02851 void __RPC_STUB ICRDFile_get_ID_Stub(
02852     IRpcStubBuffer *This,
02853     IRpcChannelBuffer *_pRpcChannelBuffer,
02854     PRPC_MESSAGE _pRpcMessage,
02855     DWORD *_pdwStubPhase);
02856
02857
02858 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDFile_put_ID_Proxy(
02859     ICRDFile __RPC_FAR * This,
02860     /* [in] */ VARIANT newVal);
02861
02862
02863 void __RPC_STUB ICRDFile_put_ID_Stub(
02864     IRpcStubBuffer *This,
02865     IRpcChannelBuffer *_pRpcChannelBuffer,
02866     PRPC_MESSAGE _pRpcMessage,
02867     DWORD *_pdwStubPhase);
02868
02869
02870 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDFile_get_XMLNode_Proxy(
02871     ICRDFile __RPC_FAR * This,
02872     /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal);
02873
02874
02875 void __RPC_STUB ICRDFile_get_XMLNode_Stub(
02876     IRpcStubBuffer *This,
02877     IRpcChannelBuffer *_pRpcChannelBuffer,
02878     PRPC_MESSAGE _pRpcMessage,
02879     DWORD *_pdwStubPhase);
02880
02881
02882 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDFile_createFile_Proxy(
02883     ICRDFile __RPC_FAR * This,
02884     /* [in] */ BSTR bstrName,
02885     /* [retval][out] */ ICRDFile __RPC_FAR *__RPC_FAR *pVal);
02886
02887
02888 void __RPC_STUB ICRDFile_createFile_Stub(
02889     IRpcStubBuffer *This,
02890     IRpcChannelBuffer *_pRpcChannelBuffer,
02891     PRPC_MESSAGE _pRpcMessage,
02892     DWORD *_pdwStubPhase);
02893
02894
02895 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDFile_removeFile_Proxy(
02896     ICRDFile __RPC_FAR * This,
02897     /* [in] */ BSTR bstrName);
02898
02899
02900 void __RPC_STUB ICRDFile_removeFile_Stub(
02901     IRpcStubBuffer *This,
02902     IRpcChannelBuffer *_pRpcChannelBuffer,
02903     PRPC_MESSAGE _pRpcMessage,
02904     DWORD *_pdwStubPhase);
02905
02906
02907 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDFile_appendFile_Proxy(
02908     ICRDFile __RPC_FAR * This,
02909     /* [in] */ ICRDFile __RPC_FAR *newFile);
02910
02911
02912 void __RPC_STUB ICRDFile_appendFile_Stub(
02913     IRpcStubBuffer *This,
02914     IRpcChannelBuffer *_pRpcChannelBuffer,
02915     PRPC_MESSAGE _pRpcMessage,
02916     DWORD *_pdwStubPhase);
02917
02918
02919 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDFile_get_FileNames_Proxy(
02920     ICRDFile __RPC_FAR * This,
02921     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02922
02923
02924 void __RPC_STUB ICRDFile_get_FileNames_Stub(
02925     IRpcStubBuffer *This,
02926     IRpcChannelBuffer *_pRpcChannelBuffer,
02927     PRPC_MESSAGE _pRpcMessage,
02928     DWORD *_pdwStubPhase);
02929
02930
02931 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDFile_get_File_Proxy(
02932     ICRDFile __RPC_FAR * This,
02933     BSTR bstrName,
02934     /* [retval][out] */ ICRDFile __RPC_FAR *__RPC_FAR *pVal);
02935
02936
02937 void __RPC_STUB ICRDFile_get_File_Stub(
02938     IRpcStubBuffer *This,
02939     IRpcChannelBuffer *_pRpcChannelBuffer,
02940     PRPC_MESSAGE _pRpcMessage,
02941     DWORD *_pdwStubPhase);
02942
02943
02944 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDFile_createVariable_Proxy(
02945     ICRDFile __RPC_FAR * This,
02946     /* [in] */ BSTR bstrName,
02947     /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
02948
02949
02950 void __RPC_STUB ICRDFile_createVariable_Stub(
02951     IRpcStubBuffer *This,
02952     IRpcChannelBuffer *_pRpcChannelBuffer,
02953     PRPC_MESSAGE _pRpcMessage,
02954     DWORD *_pdwStubPhase);
02955
02956
02957 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDFile_removeVariable_Proxy(
02958     ICRDFile __RPC_FAR * This,
02959     /* [in] */ BSTR bstrName);
02960
02961
02962 void __RPC_STUB ICRDFile_removeVariable_Stub(
02963     IRpcStubBuffer *This,
02964     IRpcChannelBuffer *_pRpcChannelBuffer,
02965     PRPC_MESSAGE _pRpcMessage,
02966     DWORD *_pdwStubPhase);
02967
02968
02969 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDFile_appendVariable_Proxy(
02970     ICRDFile __RPC_FAR * This,
02971     /* [in] */ ICRDVariable __RPC_FAR *newVar);
02972
02973
02974 void __RPC_STUB ICRDFile_appendVariable_Stub(
02975     IRpcStubBuffer *This,
02976     IRpcChannelBuffer *_pRpcChannelBuffer,
02977     PRPC_MESSAGE _pRpcMessage,
02978     DWORD *_pdwStubPhase);
02979
02980
02981 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDFile_get_VariableNames_Proxy(
02982     ICRDFile __RPC_FAR * This,
02983     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02984
02985
02986 void __RPC_STUB ICRDFile_get_VariableNames_Stub(
02987     IRpcStubBuffer *This,
02988     IRpcChannelBuffer *_pRpcChannelBuffer,
02989     PRPC_MESSAGE _pRpcMessage,
02990     DWORD *_pdwStubPhase);
02991
02992
02993 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDFile_get_Variable_Proxy(
02994     ICRDFile __RPC_FAR * This,
02995     BSTR bstrName,
02996     /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
02997
02998
02999 void __RPC_STUB ICRDFile_get_Variable_Stub(
03000     IRpcStubBuffer *This,
03001     IRpcChannelBuffer *_pRpcChannelBuffer,
03002     PRPC_MESSAGE _pRpcMessage,
03003     DWORD *_pdwStubPhase);
03004
03005
03006 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDFile_clone_Proxy(
03007     ICRDFile __RPC_FAR * This,
03008     /* [in] */ BSTR bstrDestName,
03009     /* [retval][out] */ ICRDFile __RPC_FAR *__RPC_FAR *pVal);
03010
03011
03012 void __RPC_STUB ICRDFile_clone_Stub(
03013     IRpcStubBuffer *This,
03014     IRpcChannelBuffer *_pRpcChannelBuffer,
03015     PRPC_MESSAGE _pRpcMessage,
03016     DWORD *_pdwStubPhase);
03017
03018
03019
03020 #endif  /* __ICRDFile_INTERFACE_DEFINED__ */
03021
03022
03023 #ifndef __ICRDRobot_INTERFACE_DEFINED__
03024 #define __ICRDRobot_INTERFACE_DEFINED__
03025
03026 /* interface ICRDRobot */
03027 /* [unique][helpstring][dual][uuid][object] */
03028
03029
03030 EXTERN_C const IID IID_ICRDRobot;
03031
03032 #if defined(__cplusplus) && !defined(CINTERFACE)
03033
03034     MIDL_INTERFACE("5E3CDB5B-0638-4285-B1CB-C149B59A1AD2")
03035     ICRDRobot : public IDispatch
03036     {
03037     public:
03038         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
03039             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
03040
03041         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Attribute(
03042             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
03043
03044         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Attribute(
03045             /* [in] */ long newVal) = 0;
03046
03047         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Help(
03048             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
03049
03050         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Help(
03051             /* [in] */ BSTR newVal) = 0;
03052
03053         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ID(
03054             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
03055
03056         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ID(
03057             /* [in] */ VARIANT newVal) = 0;
03058
03059         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_XMLNode(
03060             /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal) = 0;
03061
03062         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE createVariable(
03063             /* [in] */ BSTR bstrName,
03064             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal) = 0;
03065
03066         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE removeVariable(
03067             /* [in] */ BSTR bstrName) = 0;
03068
03069         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE appendVariable(
03070             /* [in] */ ICRDVariable __RPC_FAR *newVar) = 0;
03071
03072         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_VariableNames(
03073             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
03074
03075         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Variable(
03076             BSTR bstrName,
03077             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal) = 0;
03078
03079         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE clone(
03080             /* [in] */ BSTR bstrDestName,
03081             /* [retval][out] */ ICRDRobot __RPC_FAR *__RPC_FAR *pVal) = 0;
03082
03083     };
03084
03085 #else   /* C style interface */
03086
03087     typedef struct ICRDRobotVtbl
03088     {
03089         BEGIN_INTERFACE
03090
03091         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
03092             ICRDRobot __RPC_FAR * This,
03093             /* [in] */ REFIID riid,
03094             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
03095
03096         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
03097             ICRDRobot __RPC_FAR * This);
03098
03099         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
03100             ICRDRobot __RPC_FAR * This);
03101
03102         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
03103             ICRDRobot __RPC_FAR * This,
03104             /* [out] */ UINT __RPC_FAR *pctinfo);
03105
03106         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
03107             ICRDRobot __RPC_FAR * This,
03108             /* [in] */ UINT iTInfo,
03109             /* [in] */ LCID lcid,
03110             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
03111
03112         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
03113             ICRDRobot __RPC_FAR * This,
03114             /* [in] */ REFIID riid,
03115             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
03116             /* [in] */ UINT cNames,
03117             /* [in] */ LCID lcid,
03118             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
03119
03120         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
03121             ICRDRobot __RPC_FAR * This,
03122             /* [in] */ DISPID dispIdMember,
03123             /* [in] */ REFIID riid,
03124             /* [in] */ LCID lcid,
03125             /* [in] */ WORD wFlags,
03126             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
03127             /* [out] */ VARIANT __RPC_FAR *pVarResult,
03128             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
03129             /* [out] */ UINT __RPC_FAR *puArgErr);
03130
03131         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
03132             ICRDRobot __RPC_FAR * This,
03133             /* [retval][out] */ BSTR __RPC_FAR *pVal);
03134
03135         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Attribute )(
03136             ICRDRobot __RPC_FAR * This,
03137             /* [retval][out] */ long __RPC_FAR *pVal);
03138
03139         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Attribute )(
03140             ICRDRobot __RPC_FAR * This,
03141             /* [in] */ long newVal);
03142
03143         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Help )(
03144             ICRDRobot __RPC_FAR * This,
03145             /* [retval][out] */ BSTR __RPC_FAR *pVal);
03146
03147         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Help )(
03148             ICRDRobot __RPC_FAR * This,
03149             /* [in] */ BSTR newVal);
03150
03151         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ID )(
03152             ICRDRobot __RPC_FAR * This,
03153             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03154
03155         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ID )(
03156             ICRDRobot __RPC_FAR * This,
03157             /* [in] */ VARIANT newVal);
03158
03159         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_XMLNode )(
03160             ICRDRobot __RPC_FAR * This,
03161             /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal);
03162
03163         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *createVariable )(
03164             ICRDRobot __RPC_FAR * This,
03165             /* [in] */ BSTR bstrName,
03166             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
03167
03168         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *removeVariable )(
03169             ICRDRobot __RPC_FAR * This,
03170             /* [in] */ BSTR bstrName);
03171
03172         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *appendVariable )(
03173             ICRDRobot __RPC_FAR * This,
03174             /* [in] */ ICRDVariable __RPC_FAR *newVar);
03175
03176         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_VariableNames )(
03177             ICRDRobot __RPC_FAR * This,
03178             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03179
03180         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Variable )(
03181             ICRDRobot __RPC_FAR * This,
03182             BSTR bstrName,
03183             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
03184
03185         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *clone )(
03186             ICRDRobot __RPC_FAR * This,
03187             /* [in] */ BSTR bstrDestName,
03188             /* [retval][out] */ ICRDRobot __RPC_FAR *__RPC_FAR *pVal);
03189
03190         END_INTERFACE
03191     } ICRDRobotVtbl;
03192
03193     interface ICRDRobot
03194     {
03195         CONST_VTBL struct ICRDRobotVtbl __RPC_FAR *lpVtbl;
03196     };
03197
03198
03199
03200 #ifdef COBJMACROS
03201
03202
03203 #define ICRDRobot_QueryInterface(This,riid,ppvObject)   \
03204     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
03205
03206 #define ICRDRobot_AddRef(This)  \
03207     (This)->lpVtbl -> AddRef(This)
03208
03209 #define ICRDRobot_Release(This) \
03210     (This)->lpVtbl -> Release(This)
03211
03212
03213 #define ICRDRobot_GetTypeInfoCount(This,pctinfo)    \
03214     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
03215
03216 #define ICRDRobot_GetTypeInfo(This,iTInfo,lcid,ppTInfo) \
03217     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
03218
03219 #define ICRDRobot_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)   \
03220     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
03221
03222 #define ICRDRobot_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr) \
03223     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
03224
03225
03226 #define ICRDRobot_get_Name(This,pVal)   \
03227     (This)->lpVtbl -> get_Name(This,pVal)
03228
03229 #define ICRDRobot_get_Attribute(This,pVal)  \
03230     (This)->lpVtbl -> get_Attribute(This,pVal)
03231
03232 #define ICRDRobot_put_Attribute(This,newVal)    \
03233     (This)->lpVtbl -> put_Attribute(This,newVal)
03234
03235 #define ICRDRobot_get_Help(This,pVal)   \
03236     (This)->lpVtbl -> get_Help(This,pVal)
03237
03238 #define ICRDRobot_put_Help(This,newVal) \
03239     (This)->lpVtbl -> put_Help(This,newVal)
03240
03241 #define ICRDRobot_get_ID(This,pVal) \
03242     (This)->lpVtbl -> get_ID(This,pVal)
03243
03244 #define ICRDRobot_put_ID(This,newVal)   \
03245     (This)->lpVtbl -> put_ID(This,newVal)
03246
03247 #define ICRDRobot_get_XMLNode(This,pVal)    \
03248     (This)->lpVtbl -> get_XMLNode(This,pVal)
03249
03250 #define ICRDRobot_createVariable(This,bstrName,pVal)    \
03251     (This)->lpVtbl -> createVariable(This,bstrName,pVal)
03252
03253 #define ICRDRobot_removeVariable(This,bstrName) \
03254     (This)->lpVtbl -> removeVariable(This,bstrName)
03255
03256 #define ICRDRobot_appendVariable(This,newVar)   \
03257     (This)->lpVtbl -> appendVariable(This,newVar)
03258
03259 #define ICRDRobot_get_VariableNames(This,pVal)  \
03260     (This)->lpVtbl -> get_VariableNames(This,pVal)
03261
03262 #define ICRDRobot_get_Variable(This,bstrName,pVal)  \
03263     (This)->lpVtbl -> get_Variable(This,bstrName,pVal)
03264
03265 #define ICRDRobot_clone(This,bstrDestName,pVal) \
03266     (This)->lpVtbl -> clone(This,bstrDestName,pVal)
03267
03268 #endif /* COBJMACROS */
03269
03270
03271 #endif  /* C style interface */
03272
03273
03274
03275 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDRobot_get_Name_Proxy(
03276     ICRDRobot __RPC_FAR * This,
03277     /* [retval][out] */ BSTR __RPC_FAR *pVal);
03278
03279
03280 void __RPC_STUB ICRDRobot_get_Name_Stub(
03281     IRpcStubBuffer *This,
03282     IRpcChannelBuffer *_pRpcChannelBuffer,
03283     PRPC_MESSAGE _pRpcMessage,
03284     DWORD *_pdwStubPhase);
03285
03286
03287 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDRobot_get_Attribute_Proxy(
03288     ICRDRobot __RPC_FAR * This,
03289     /* [retval][out] */ long __RPC_FAR *pVal);
03290
03291
03292 void __RPC_STUB ICRDRobot_get_Attribute_Stub(
03293     IRpcStubBuffer *This,
03294     IRpcChannelBuffer *_pRpcChannelBuffer,
03295     PRPC_MESSAGE _pRpcMessage,
03296     DWORD *_pdwStubPhase);
03297
03298
03299 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDRobot_put_Attribute_Proxy(
03300     ICRDRobot __RPC_FAR * This,
03301     /* [in] */ long newVal);
03302
03303
03304 void __RPC_STUB ICRDRobot_put_Attribute_Stub(
03305     IRpcStubBuffer *This,
03306     IRpcChannelBuffer *_pRpcChannelBuffer,
03307     PRPC_MESSAGE _pRpcMessage,
03308     DWORD *_pdwStubPhase);
03309
03310
03311 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDRobot_get_Help_Proxy(
03312     ICRDRobot __RPC_FAR * This,
03313     /* [retval][out] */ BSTR __RPC_FAR *pVal);
03314
03315
03316 void __RPC_STUB ICRDRobot_get_Help_Stub(
03317     IRpcStubBuffer *This,
03318     IRpcChannelBuffer *_pRpcChannelBuffer,
03319     PRPC_MESSAGE _pRpcMessage,
03320     DWORD *_pdwStubPhase);
03321
03322
03323 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDRobot_put_Help_Proxy(
03324     ICRDRobot __RPC_FAR * This,
03325     /* [in] */ BSTR newVal);
03326
03327
03328 void __RPC_STUB ICRDRobot_put_Help_Stub(
03329     IRpcStubBuffer *This,
03330     IRpcChannelBuffer *_pRpcChannelBuffer,
03331     PRPC_MESSAGE _pRpcMessage,
03332     DWORD *_pdwStubPhase);
03333
03334
03335 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDRobot_get_ID_Proxy(
03336     ICRDRobot __RPC_FAR * This,
03337     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03338
03339
03340 void __RPC_STUB ICRDRobot_get_ID_Stub(
03341     IRpcStubBuffer *This,
03342     IRpcChannelBuffer *_pRpcChannelBuffer,
03343     PRPC_MESSAGE _pRpcMessage,
03344     DWORD *_pdwStubPhase);
03345
03346
03347 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDRobot_put_ID_Proxy(
03348     ICRDRobot __RPC_FAR * This,
03349     /* [in] */ VARIANT newVal);
03350
03351
03352 void __RPC_STUB ICRDRobot_put_ID_Stub(
03353     IRpcStubBuffer *This,
03354     IRpcChannelBuffer *_pRpcChannelBuffer,
03355     PRPC_MESSAGE _pRpcMessage,
03356     DWORD *_pdwStubPhase);
03357
03358
03359 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDRobot_get_XMLNode_Proxy(
03360     ICRDRobot __RPC_FAR * This,
03361     /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal);
03362
03363
03364 void __RPC_STUB ICRDRobot_get_XMLNode_Stub(
03365     IRpcStubBuffer *This,
03366     IRpcChannelBuffer *_pRpcChannelBuffer,
03367     PRPC_MESSAGE _pRpcMessage,
03368     DWORD *_pdwStubPhase);
03369
03370
03371 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDRobot_createVariable_Proxy(
03372     ICRDRobot __RPC_FAR * This,
03373     /* [in] */ BSTR bstrName,
03374     /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
03375
03376
03377 void __RPC_STUB ICRDRobot_createVariable_Stub(
03378     IRpcStubBuffer *This,
03379     IRpcChannelBuffer *_pRpcChannelBuffer,
03380     PRPC_MESSAGE _pRpcMessage,
03381     DWORD *_pdwStubPhase);
03382
03383
03384 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDRobot_removeVariable_Proxy(
03385     ICRDRobot __RPC_FAR * This,
03386     /* [in] */ BSTR bstrName);
03387
03388
03389 void __RPC_STUB ICRDRobot_removeVariable_Stub(
03390     IRpcStubBuffer *This,
03391     IRpcChannelBuffer *_pRpcChannelBuffer,
03392     PRPC_MESSAGE _pRpcMessage,
03393     DWORD *_pdwStubPhase);
03394
03395
03396 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDRobot_appendVariable_Proxy(
03397     ICRDRobot __RPC_FAR * This,
03398     /* [in] */ ICRDVariable __RPC_FAR *newVar);
03399
03400
03401 void __RPC_STUB ICRDRobot_appendVariable_Stub(
03402     IRpcStubBuffer *This,
03403     IRpcChannelBuffer *_pRpcChannelBuffer,
03404     PRPC_MESSAGE _pRpcMessage,
03405     DWORD *_pdwStubPhase);
03406
03407
03408 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDRobot_get_VariableNames_Proxy(
03409     ICRDRobot __RPC_FAR * This,
03410     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03411
03412
03413 void __RPC_STUB ICRDRobot_get_VariableNames_Stub(
03414     IRpcStubBuffer *This,
03415     IRpcChannelBuffer *_pRpcChannelBuffer,
03416     PRPC_MESSAGE _pRpcMessage,
03417     DWORD *_pdwStubPhase);
03418
03419
03420 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDRobot_get_Variable_Proxy(
03421     ICRDRobot __RPC_FAR * This,
03422     BSTR bstrName,
03423     /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
03424
03425
03426 void __RPC_STUB ICRDRobot_get_Variable_Stub(
03427     IRpcStubBuffer *This,
03428     IRpcChannelBuffer *_pRpcChannelBuffer,
03429     PRPC_MESSAGE _pRpcMessage,
03430     DWORD *_pdwStubPhase);
03431
03432
03433 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDRobot_clone_Proxy(
03434     ICRDRobot __RPC_FAR * This,
03435     /* [in] */ BSTR bstrDestName,
03436     /* [retval][out] */ ICRDRobot __RPC_FAR *__RPC_FAR *pVal);
03437
03438
03439 void __RPC_STUB ICRDRobot_clone_Stub(
03440     IRpcStubBuffer *This,
03441     IRpcChannelBuffer *_pRpcChannelBuffer,
03442     PRPC_MESSAGE _pRpcMessage,
03443     DWORD *_pdwStubPhase);
03444
03445
03446
03447 #endif  /* __ICRDRobot_INTERFACE_DEFINED__ */
03448
03449
03450 #ifndef __ICRDTask_INTERFACE_DEFINED__
03451 #define __ICRDTask_INTERFACE_DEFINED__
03452
03453 /* interface ICRDTask */
03454 /* [unique][helpstring][dual][uuid][object] */
03455
03456
03457 EXTERN_C const IID IID_ICRDTask;
03458
03459 #if defined(__cplusplus) && !defined(CINTERFACE)
03460
03461     MIDL_INTERFACE("66E7EE84-CAA7-437F-AF52-A94973D8A8D7")
03462     ICRDTask : public IDispatch
03463     {
03464     public:
03465         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
03466             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
03467
03468         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Attribute(
03469             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
03470
03471         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Attribute(
03472             /* [in] */ long newVal) = 0;
03473
03474         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Help(
03475             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
03476
03477         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Help(
03478             /* [in] */ BSTR newVal) = 0;
03479
03480         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_FileName(
03481             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
03482
03483         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_FileName(
03484             /* [in] */ BSTR newVal) = 0;
03485
03486         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ID(
03487             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
03488
03489         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ID(
03490             /* [in] */ VARIANT newVal) = 0;
03491
03492         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_XMLNode(
03493             /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal) = 0;
03494
03495         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE createVariable(
03496             /* [in] */ BSTR bstrName,
03497             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal) = 0;
03498
03499         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE removeVariable(
03500             /* [in] */ BSTR bstrName) = 0;
03501
03502         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE appendVariable(
03503             /* [in] */ ICRDVariable __RPC_FAR *newVar) = 0;
03504
03505         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_VariableNames(
03506             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
03507
03508         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Variable(
03509             BSTR bstrName,
03510             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal) = 0;
03511
03512         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE clone(
03513             /* [in] */ BSTR bstrDestName,
03514             /* [retval][out] */ ICRDTask __RPC_FAR *__RPC_FAR *pVal) = 0;
03515
03516     };
03517
03518 #else   /* C style interface */
03519
03520     typedef struct ICRDTaskVtbl
03521     {
03522         BEGIN_INTERFACE
03523
03524         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
03525             ICRDTask __RPC_FAR * This,
03526             /* [in] */ REFIID riid,
03527             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
03528
03529         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
03530             ICRDTask __RPC_FAR * This);
03531
03532         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
03533             ICRDTask __RPC_FAR * This);
03534
03535         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
03536             ICRDTask __RPC_FAR * This,
03537             /* [out] */ UINT __RPC_FAR *pctinfo);
03538
03539         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
03540             ICRDTask __RPC_FAR * This,
03541             /* [in] */ UINT iTInfo,
03542             /* [in] */ LCID lcid,
03543             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
03544
03545         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
03546             ICRDTask __RPC_FAR * This,
03547             /* [in] */ REFIID riid,
03548             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
03549             /* [in] */ UINT cNames,
03550             /* [in] */ LCID lcid,
03551             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
03552
03553         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
03554             ICRDTask __RPC_FAR * This,
03555             /* [in] */ DISPID dispIdMember,
03556             /* [in] */ REFIID riid,
03557             /* [in] */ LCID lcid,
03558             /* [in] */ WORD wFlags,
03559             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
03560             /* [out] */ VARIANT __RPC_FAR *pVarResult,
03561             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
03562             /* [out] */ UINT __RPC_FAR *puArgErr);
03563
03564         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
03565             ICRDTask __RPC_FAR * This,
03566             /* [retval][out] */ BSTR __RPC_FAR *pVal);
03567
03568         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Attribute )(
03569             ICRDTask __RPC_FAR * This,
03570             /* [retval][out] */ long __RPC_FAR *pVal);
03571
03572         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Attribute )(
03573             ICRDTask __RPC_FAR * This,
03574             /* [in] */ long newVal);
03575
03576         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Help )(
03577             ICRDTask __RPC_FAR * This,
03578             /* [retval][out] */ BSTR __RPC_FAR *pVal);
03579
03580         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Help )(
03581             ICRDTask __RPC_FAR * This,
03582             /* [in] */ BSTR newVal);
03583
03584         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_FileName )(
03585             ICRDTask __RPC_FAR * This,
03586             /* [retval][out] */ BSTR __RPC_FAR *pVal);
03587
03588         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_FileName )(
03589             ICRDTask __RPC_FAR * This,
03590             /* [in] */ BSTR newVal);
03591
03592         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ID )(
03593             ICRDTask __RPC_FAR * This,
03594             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03595
03596         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ID )(
03597             ICRDTask __RPC_FAR * This,
03598             /* [in] */ VARIANT newVal);
03599
03600         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_XMLNode )(
03601             ICRDTask __RPC_FAR * This,
03602             /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal);
03603
03604         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *createVariable )(
03605             ICRDTask __RPC_FAR * This,
03606             /* [in] */ BSTR bstrName,
03607             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
03608
03609         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *removeVariable )(
03610             ICRDTask __RPC_FAR * This,
03611             /* [in] */ BSTR bstrName);
03612
03613         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *appendVariable )(
03614             ICRDTask __RPC_FAR * This,
03615             /* [in] */ ICRDVariable __RPC_FAR *newVar);
03616
03617         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_VariableNames )(
03618             ICRDTask __RPC_FAR * This,
03619             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03620
03621         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Variable )(
03622             ICRDTask __RPC_FAR * This,
03623             BSTR bstrName,
03624             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
03625
03626         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *clone )(
03627             ICRDTask __RPC_FAR * This,
03628             /* [in] */ BSTR bstrDestName,
03629             /* [retval][out] */ ICRDTask __RPC_FAR *__RPC_FAR *pVal);
03630
03631         END_INTERFACE
03632     } ICRDTaskVtbl;
03633
03634     interface ICRDTask
03635     {
03636         CONST_VTBL struct ICRDTaskVtbl __RPC_FAR *lpVtbl;
03637     };
03638
03639
03640
03641 #ifdef COBJMACROS
03642
03643
03644 #define ICRDTask_QueryInterface(This,riid,ppvObject)    \
03645     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
03646
03647 #define ICRDTask_AddRef(This)   \
03648     (This)->lpVtbl -> AddRef(This)
03649
03650 #define ICRDTask_Release(This)  \
03651     (This)->lpVtbl -> Release(This)
03652
03653
03654 #define ICRDTask_GetTypeInfoCount(This,pctinfo) \
03655     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
03656
03657 #define ICRDTask_GetTypeInfo(This,iTInfo,lcid,ppTInfo)  \
03658     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
03659
03660 #define ICRDTask_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)    \
03661     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
03662
03663 #define ICRDTask_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)  \
03664     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
03665
03666
03667 #define ICRDTask_get_Name(This,pVal)    \
03668     (This)->lpVtbl -> get_Name(This,pVal)
03669
03670 #define ICRDTask_get_Attribute(This,pVal)   \
03671     (This)->lpVtbl -> get_Attribute(This,pVal)
03672
03673 #define ICRDTask_put_Attribute(This,newVal) \
03674     (This)->lpVtbl -> put_Attribute(This,newVal)
03675
03676 #define ICRDTask_get_Help(This,pVal)    \
03677     (This)->lpVtbl -> get_Help(This,pVal)
03678
03679 #define ICRDTask_put_Help(This,newVal)  \
03680     (This)->lpVtbl -> put_Help(This,newVal)
03681
03682 #define ICRDTask_get_FileName(This,pVal)    \
03683     (This)->lpVtbl -> get_FileName(This,pVal)
03684
03685 #define ICRDTask_put_FileName(This,newVal)  \
03686     (This)->lpVtbl -> put_FileName(This,newVal)
03687
03688 #define ICRDTask_get_ID(This,pVal)  \
03689     (This)->lpVtbl -> get_ID(This,pVal)
03690
03691 #define ICRDTask_put_ID(This,newVal)    \
03692     (This)->lpVtbl -> put_ID(This,newVal)
03693
03694 #define ICRDTask_get_XMLNode(This,pVal) \
03695     (This)->lpVtbl -> get_XMLNode(This,pVal)
03696
03697 #define ICRDTask_createVariable(This,bstrName,pVal) \
03698     (This)->lpVtbl -> createVariable(This,bstrName,pVal)
03699
03700 #define ICRDTask_removeVariable(This,bstrName)  \
03701     (This)->lpVtbl -> removeVariable(This,bstrName)
03702
03703 #define ICRDTask_appendVariable(This,newVar)    \
03704     (This)->lpVtbl -> appendVariable(This,newVar)
03705
03706 #define ICRDTask_get_VariableNames(This,pVal)   \
03707     (This)->lpVtbl -> get_VariableNames(This,pVal)
03708
03709 #define ICRDTask_get_Variable(This,bstrName,pVal)   \
03710     (This)->lpVtbl -> get_Variable(This,bstrName,pVal)
03711
03712 #define ICRDTask_clone(This,bstrDestName,pVal)  \
03713     (This)->lpVtbl -> clone(This,bstrDestName,pVal)
03714
03715 #endif /* COBJMACROS */
03716
03717
03718 #endif  /* C style interface */
03719
03720
03721
03722 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDTask_get_Name_Proxy(
03723     ICRDTask __RPC_FAR * This,
03724     /* [retval][out] */ BSTR __RPC_FAR *pVal);
03725
03726
03727 void __RPC_STUB ICRDTask_get_Name_Stub(
03728     IRpcStubBuffer *This,
03729     IRpcChannelBuffer *_pRpcChannelBuffer,
03730     PRPC_MESSAGE _pRpcMessage,
03731     DWORD *_pdwStubPhase);
03732
03733
03734 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDTask_get_Attribute_Proxy(
03735     ICRDTask __RPC_FAR * This,
03736     /* [retval][out] */ long __RPC_FAR *pVal);
03737
03738
03739 void __RPC_STUB ICRDTask_get_Attribute_Stub(
03740     IRpcStubBuffer *This,
03741     IRpcChannelBuffer *_pRpcChannelBuffer,
03742     PRPC_MESSAGE _pRpcMessage,
03743     DWORD *_pdwStubPhase);
03744
03745
03746 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDTask_put_Attribute_Proxy(
03747     ICRDTask __RPC_FAR * This,
03748     /* [in] */ long newVal);
03749
03750
03751 void __RPC_STUB ICRDTask_put_Attribute_Stub(
03752     IRpcStubBuffer *This,
03753     IRpcChannelBuffer *_pRpcChannelBuffer,
03754     PRPC_MESSAGE _pRpcMessage,
03755     DWORD *_pdwStubPhase);
03756
03757
03758 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDTask_get_Help_Proxy(
03759     ICRDTask __RPC_FAR * This,
03760     /* [retval][out] */ BSTR __RPC_FAR *pVal);
03761
03762
03763 void __RPC_STUB ICRDTask_get_Help_Stub(
03764     IRpcStubBuffer *This,
03765     IRpcChannelBuffer *_pRpcChannelBuffer,
03766     PRPC_MESSAGE _pRpcMessage,
03767     DWORD *_pdwStubPhase);
03768
03769
03770 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDTask_put_Help_Proxy(
03771     ICRDTask __RPC_FAR * This,
03772     /* [in] */ BSTR newVal);
03773
03774
03775 void __RPC_STUB ICRDTask_put_Help_Stub(
03776     IRpcStubBuffer *This,
03777     IRpcChannelBuffer *_pRpcChannelBuffer,
03778     PRPC_MESSAGE _pRpcMessage,
03779     DWORD *_pdwStubPhase);
03780
03781
03782 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDTask_get_FileName_Proxy(
03783     ICRDTask __RPC_FAR * This,
03784     /* [retval][out] */ BSTR __RPC_FAR *pVal);
03785
03786
03787 void __RPC_STUB ICRDTask_get_FileName_Stub(
03788     IRpcStubBuffer *This,
03789     IRpcChannelBuffer *_pRpcChannelBuffer,
03790     PRPC_MESSAGE _pRpcMessage,
03791     DWORD *_pdwStubPhase);
03792
03793
03794 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDTask_put_FileName_Proxy(
03795     ICRDTask __RPC_FAR * This,
03796     /* [in] */ BSTR newVal);
03797
03798
03799 void __RPC_STUB ICRDTask_put_FileName_Stub(
03800     IRpcStubBuffer *This,
03801     IRpcChannelBuffer *_pRpcChannelBuffer,
03802     PRPC_MESSAGE _pRpcMessage,
03803     DWORD *_pdwStubPhase);
03804
03805
03806 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDTask_get_ID_Proxy(
03807     ICRDTask __RPC_FAR * This,
03808     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03809
03810
03811 void __RPC_STUB ICRDTask_get_ID_Stub(
03812     IRpcStubBuffer *This,
03813     IRpcChannelBuffer *_pRpcChannelBuffer,
03814     PRPC_MESSAGE _pRpcMessage,
03815     DWORD *_pdwStubPhase);
03816
03817
03818 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDTask_put_ID_Proxy(
03819     ICRDTask __RPC_FAR * This,
03820     /* [in] */ VARIANT newVal);
03821
03822
03823 void __RPC_STUB ICRDTask_put_ID_Stub(
03824     IRpcStubBuffer *This,
03825     IRpcChannelBuffer *_pRpcChannelBuffer,
03826     PRPC_MESSAGE _pRpcMessage,
03827     DWORD *_pdwStubPhase);
03828
03829
03830 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDTask_get_XMLNode_Proxy(
03831     ICRDTask __RPC_FAR * This,
03832     /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal);
03833
03834
03835 void __RPC_STUB ICRDTask_get_XMLNode_Stub(
03836     IRpcStubBuffer *This,
03837     IRpcChannelBuffer *_pRpcChannelBuffer,
03838     PRPC_MESSAGE _pRpcMessage,
03839     DWORD *_pdwStubPhase);
03840
03841
03842 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDTask_createVariable_Proxy(
03843     ICRDTask __RPC_FAR * This,
03844     /* [in] */ BSTR bstrName,
03845     /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
03846
03847
03848 void __RPC_STUB ICRDTask_createVariable_Stub(
03849     IRpcStubBuffer *This,
03850     IRpcChannelBuffer *_pRpcChannelBuffer,
03851     PRPC_MESSAGE _pRpcMessage,
03852     DWORD *_pdwStubPhase);
03853
03854
03855 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDTask_removeVariable_Proxy(
03856     ICRDTask __RPC_FAR * This,
03857     /* [in] */ BSTR bstrName);
03858
03859
03860 void __RPC_STUB ICRDTask_removeVariable_Stub(
03861     IRpcStubBuffer *This,
03862     IRpcChannelBuffer *_pRpcChannelBuffer,
03863     PRPC_MESSAGE _pRpcMessage,
03864     DWORD *_pdwStubPhase);
03865
03866
03867 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDTask_appendVariable_Proxy(
03868     ICRDTask __RPC_FAR * This,
03869     /* [in] */ ICRDVariable __RPC_FAR *newVar);
03870
03871
03872 void __RPC_STUB ICRDTask_appendVariable_Stub(
03873     IRpcStubBuffer *This,
03874     IRpcChannelBuffer *_pRpcChannelBuffer,
03875     PRPC_MESSAGE _pRpcMessage,
03876     DWORD *_pdwStubPhase);
03877
03878
03879 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDTask_get_VariableNames_Proxy(
03880     ICRDTask __RPC_FAR * This,
03881     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03882
03883
03884 void __RPC_STUB ICRDTask_get_VariableNames_Stub(
03885     IRpcStubBuffer *This,
03886     IRpcChannelBuffer *_pRpcChannelBuffer,
03887     PRPC_MESSAGE _pRpcMessage,
03888     DWORD *_pdwStubPhase);
03889
03890
03891 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDTask_get_Variable_Proxy(
03892     ICRDTask __RPC_FAR * This,
03893     BSTR bstrName,
03894     /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
03895
03896
03897 void __RPC_STUB ICRDTask_get_Variable_Stub(
03898     IRpcStubBuffer *This,
03899     IRpcChannelBuffer *_pRpcChannelBuffer,
03900     PRPC_MESSAGE _pRpcMessage,
03901     DWORD *_pdwStubPhase);
03902
03903
03904 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDTask_clone_Proxy(
03905     ICRDTask __RPC_FAR * This,
03906     /* [in] */ BSTR bstrDestName,
03907     /* [retval][out] */ ICRDTask __RPC_FAR *__RPC_FAR *pVal);
03908
03909
03910 void __RPC_STUB ICRDTask_clone_Stub(
03911     IRpcStubBuffer *This,
03912     IRpcChannelBuffer *_pRpcChannelBuffer,
03913     PRPC_MESSAGE _pRpcMessage,
03914     DWORD *_pdwStubPhase);
03915
03916
03917
03918 #endif  /* __ICRDTask_INTERFACE_DEFINED__ */
03919
03920
03921 #ifndef __ICRDVariable_INTERFACE_DEFINED__
03922 #define __ICRDVariable_INTERFACE_DEFINED__
03923
03924 /* interface ICRDVariable */
03925 /* [unique][helpstring][dual][uuid][object] */
03926
03927
03928 EXTERN_C const IID IID_ICRDVariable;
03929
03930 #if defined(__cplusplus) && !defined(CINTERFACE)
03931
03932     MIDL_INTERFACE("29DD8E3A-87CB-4C35-84C5-5796C6D4EFB2")
03933     ICRDVariable : public IDispatch
03934     {
03935     public:
03936         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
03937             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
03938
03939         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Attribute(
03940             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
03941
03942         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Attribute(
03943             /* [in] */ long newVal) = 0;
03944
03945         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Help(
03946             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
03947
03948         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Help(
03949             /* [in] */ BSTR newVal) = 0;
03950
03951         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_DateTime(
03952             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
03953
03954         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_DateTime(
03955             /* [in] */ VARIANT newVal) = 0;
03956
03957         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Value(
03958             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
03959
03960         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Value(
03961             /* [in] */ VARIANT newVal) = 0;
03962
03963         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ID(
03964             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
03965
03966         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ID(
03967             /* [in] */ VARIANT newVal) = 0;
03968
03969         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Microsecond(
03970             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
03971
03972         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Microsecond(
03973             /* [in] */ long newVal) = 0;
03974
03975         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_XMLNode(
03976             /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal) = 0;
03977
03978         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE clone(
03979             /* [in] */ BSTR bstrDestName,
03980             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal) = 0;
03981
03982     };
03983
03984 #else   /* C style interface */
03985
03986     typedef struct ICRDVariableVtbl
03987     {
03988         BEGIN_INTERFACE
03989
03990         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
03991             ICRDVariable __RPC_FAR * This,
03992             /* [in] */ REFIID riid,
03993             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
03994
03995         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
03996             ICRDVariable __RPC_FAR * This);
03997
03998         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
03999             ICRDVariable __RPC_FAR * This);
04000
04001         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
04002             ICRDVariable __RPC_FAR * This,
04003             /* [out] */ UINT __RPC_FAR *pctinfo);
04004
04005         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
04006             ICRDVariable __RPC_FAR * This,
04007             /* [in] */ UINT iTInfo,
04008             /* [in] */ LCID lcid,
04009             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
04010
04011         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
04012             ICRDVariable __RPC_FAR * This,
04013             /* [in] */ REFIID riid,
04014             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
04015             /* [in] */ UINT cNames,
04016             /* [in] */ LCID lcid,
04017             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
04018
04019         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
04020             ICRDVariable __RPC_FAR * This,
04021             /* [in] */ DISPID dispIdMember,
04022             /* [in] */ REFIID riid,
04023             /* [in] */ LCID lcid,
04024             /* [in] */ WORD wFlags,
04025             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
04026             /* [out] */ VARIANT __RPC_FAR *pVarResult,
04027             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
04028             /* [out] */ UINT __RPC_FAR *puArgErr);
04029
04030         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
04031             ICRDVariable __RPC_FAR * This,
04032             /* [retval][out] */ BSTR __RPC_FAR *pVal);
04033
04034         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Attribute )(
04035             ICRDVariable __RPC_FAR * This,
04036             /* [retval][out] */ long __RPC_FAR *pVal);
04037
04038         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Attribute )(
04039             ICRDVariable __RPC_FAR * This,
04040             /* [in] */ long newVal);
04041
04042         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Help )(
04043             ICRDVariable __RPC_FAR * This,
04044             /* [retval][out] */ BSTR __RPC_FAR *pVal);
04045
04046         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Help )(
04047             ICRDVariable __RPC_FAR * This,
04048             /* [in] */ BSTR newVal);
04049
04050         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_DateTime )(
04051             ICRDVariable __RPC_FAR * This,
04052             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04053
04054         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_DateTime )(
04055             ICRDVariable __RPC_FAR * This,
04056             /* [in] */ VARIANT newVal);
04057
04058         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Value )(
04059             ICRDVariable __RPC_FAR * This,
04060             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04061
04062         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Value )(
04063             ICRDVariable __RPC_FAR * This,
04064             /* [in] */ VARIANT newVal);
04065
04066         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ID )(
04067             ICRDVariable __RPC_FAR * This,
04068             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04069
04070         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ID )(
04071             ICRDVariable __RPC_FAR * This,
04072             /* [in] */ VARIANT newVal);
04073
04074         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Microsecond )(
04075             ICRDVariable __RPC_FAR * This,
04076             /* [retval][out] */ long __RPC_FAR *pVal);
04077
04078         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Microsecond )(
04079             ICRDVariable __RPC_FAR * This,
04080             /* [in] */ long newVal);
04081
04082         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_XMLNode )(
04083             ICRDVariable __RPC_FAR * This,
04084             /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal);
04085
04086         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *clone )(
04087             ICRDVariable __RPC_FAR * This,
04088             /* [in] */ BSTR bstrDestName,
04089             /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
04090
04091         END_INTERFACE
04092     } ICRDVariableVtbl;
04093
04094     interface ICRDVariable
04095     {
04096         CONST_VTBL struct ICRDVariableVtbl __RPC_FAR *lpVtbl;
04097     };
04098
04099
04100
04101 #ifdef COBJMACROS
04102
04103
04104 #define ICRDVariable_QueryInterface(This,riid,ppvObject)    \
04105     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
04106
04107 #define ICRDVariable_AddRef(This)   \
04108     (This)->lpVtbl -> AddRef(This)
04109
04110 #define ICRDVariable_Release(This)  \
04111     (This)->lpVtbl -> Release(This)
04112
04113
04114 #define ICRDVariable_GetTypeInfoCount(This,pctinfo) \
04115     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
04116
04117 #define ICRDVariable_GetTypeInfo(This,iTInfo,lcid,ppTInfo)  \
04118     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
04119
04120 #define ICRDVariable_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)    \
04121     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
04122
04123 #define ICRDVariable_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)  \
04124     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
04125
04126
04127 #define ICRDVariable_get_Name(This,pVal)    \
04128     (This)->lpVtbl -> get_Name(This,pVal)
04129
04130 #define ICRDVariable_get_Attribute(This,pVal)   \
04131     (This)->lpVtbl -> get_Attribute(This,pVal)
04132
04133 #define ICRDVariable_put_Attribute(This,newVal) \
04134     (This)->lpVtbl -> put_Attribute(This,newVal)
04135
04136 #define ICRDVariable_get_Help(This,pVal)    \
04137     (This)->lpVtbl -> get_Help(This,pVal)
04138
04139 #define ICRDVariable_put_Help(This,newVal)  \
04140     (This)->lpVtbl -> put_Help(This,newVal)
04141
04142 #define ICRDVariable_get_DateTime(This,pVal)    \
04143     (This)->lpVtbl -> get_DateTime(This,pVal)
04144
04145 #define ICRDVariable_put_DateTime(This,newVal)  \
04146     (This)->lpVtbl -> put_DateTime(This,newVal)
04147
04148 #define ICRDVariable_get_Value(This,pVal)   \
04149     (This)->lpVtbl -> get_Value(This,pVal)
04150
04151 #define ICRDVariable_put_Value(This,newVal) \
04152     (This)->lpVtbl -> put_Value(This,newVal)
04153
04154 #define ICRDVariable_get_ID(This,pVal)  \
04155     (This)->lpVtbl -> get_ID(This,pVal)
04156
04157 #define ICRDVariable_put_ID(This,newVal)    \
04158     (This)->lpVtbl -> put_ID(This,newVal)
04159
04160 #define ICRDVariable_get_Microsecond(This,pVal) \
04161     (This)->lpVtbl -> get_Microsecond(This,pVal)
04162
04163 #define ICRDVariable_put_Microsecond(This,newVal)   \
04164     (This)->lpVtbl -> put_Microsecond(This,newVal)
04165
04166 #define ICRDVariable_get_XMLNode(This,pVal) \
04167     (This)->lpVtbl -> get_XMLNode(This,pVal)
04168
04169 #define ICRDVariable_clone(This,bstrDestName,pVal)  \
04170     (This)->lpVtbl -> clone(This,bstrDestName,pVal)
04171
04172 #endif /* COBJMACROS */
04173
04174
04175 #endif  /* C style interface */
04176
04177
04178
04179 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDVariable_get_Name_Proxy(
04180     ICRDVariable __RPC_FAR * This,
04181     /* [retval][out] */ BSTR __RPC_FAR *pVal);
04182
04183
04184 void __RPC_STUB ICRDVariable_get_Name_Stub(
04185     IRpcStubBuffer *This,
04186     IRpcChannelBuffer *_pRpcChannelBuffer,
04187     PRPC_MESSAGE _pRpcMessage,
04188     DWORD *_pdwStubPhase);
04189
04190
04191 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDVariable_get_Attribute_Proxy(
04192     ICRDVariable __RPC_FAR * This,
04193     /* [retval][out] */ long __RPC_FAR *pVal);
04194
04195
04196 void __RPC_STUB ICRDVariable_get_Attribute_Stub(
04197     IRpcStubBuffer *This,
04198     IRpcChannelBuffer *_pRpcChannelBuffer,
04199     PRPC_MESSAGE _pRpcMessage,
04200     DWORD *_pdwStubPhase);
04201
04202
04203 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDVariable_put_Attribute_Proxy(
04204     ICRDVariable __RPC_FAR * This,
04205     /* [in] */ long newVal);
04206
04207
04208 void __RPC_STUB ICRDVariable_put_Attribute_Stub(
04209     IRpcStubBuffer *This,
04210     IRpcChannelBuffer *_pRpcChannelBuffer,
04211     PRPC_MESSAGE _pRpcMessage,
04212     DWORD *_pdwStubPhase);
04213
04214
04215 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDVariable_get_Help_Proxy(
04216     ICRDVariable __RPC_FAR * This,
04217     /* [retval][out] */ BSTR __RPC_FAR *pVal);
04218
04219
04220 void __RPC_STUB ICRDVariable_get_Help_Stub(
04221     IRpcStubBuffer *This,
04222     IRpcChannelBuffer *_pRpcChannelBuffer,
04223     PRPC_MESSAGE _pRpcMessage,
04224     DWORD *_pdwStubPhase);
04225
04226
04227 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDVariable_put_Help_Proxy(
04228     ICRDVariable __RPC_FAR * This,
04229     /* [in] */ BSTR newVal);
04230
04231
04232 void __RPC_STUB ICRDVariable_put_Help_Stub(
04233     IRpcStubBuffer *This,
04234     IRpcChannelBuffer *_pRpcChannelBuffer,
04235     PRPC_MESSAGE _pRpcMessage,
04236     DWORD *_pdwStubPhase);
04237
04238
04239 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDVariable_get_DateTime_Proxy(
04240     ICRDVariable __RPC_FAR * This,
04241     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04242
04243
04244 void __RPC_STUB ICRDVariable_get_DateTime_Stub(
04245     IRpcStubBuffer *This,
04246     IRpcChannelBuffer *_pRpcChannelBuffer,
04247     PRPC_MESSAGE _pRpcMessage,
04248     DWORD *_pdwStubPhase);
04249
04250
04251 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDVariable_put_DateTime_Proxy(
04252     ICRDVariable __RPC_FAR * This,
04253     /* [in] */ VARIANT newVal);
04254
04255
04256 void __RPC_STUB ICRDVariable_put_DateTime_Stub(
04257     IRpcStubBuffer *This,
04258     IRpcChannelBuffer *_pRpcChannelBuffer,
04259     PRPC_MESSAGE _pRpcMessage,
04260     DWORD *_pdwStubPhase);
04261
04262
04263 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDVariable_get_Value_Proxy(
04264     ICRDVariable __RPC_FAR * This,
04265     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04266
04267
04268 void __RPC_STUB ICRDVariable_get_Value_Stub(
04269     IRpcStubBuffer *This,
04270     IRpcChannelBuffer *_pRpcChannelBuffer,
04271     PRPC_MESSAGE _pRpcMessage,
04272     DWORD *_pdwStubPhase);
04273
04274
04275 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDVariable_put_Value_Proxy(
04276     ICRDVariable __RPC_FAR * This,
04277     /* [in] */ VARIANT newVal);
04278
04279
04280 void __RPC_STUB ICRDVariable_put_Value_Stub(
04281     IRpcStubBuffer *This,
04282     IRpcChannelBuffer *_pRpcChannelBuffer,
04283     PRPC_MESSAGE _pRpcMessage,
04284     DWORD *_pdwStubPhase);
04285
04286
04287 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDVariable_get_ID_Proxy(
04288     ICRDVariable __RPC_FAR * This,
04289     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04290
04291
04292 void __RPC_STUB ICRDVariable_get_ID_Stub(
04293     IRpcStubBuffer *This,
04294     IRpcChannelBuffer *_pRpcChannelBuffer,
04295     PRPC_MESSAGE _pRpcMessage,
04296     DWORD *_pdwStubPhase);
04297
04298
04299 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDVariable_put_ID_Proxy(
04300     ICRDVariable __RPC_FAR * This,
04301     /* [in] */ VARIANT newVal);
04302
04303
04304 void __RPC_STUB ICRDVariable_put_ID_Stub(
04305     IRpcStubBuffer *This,
04306     IRpcChannelBuffer *_pRpcChannelBuffer,
04307     PRPC_MESSAGE _pRpcMessage,
04308     DWORD *_pdwStubPhase);
04309
04310
04311 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDVariable_get_Microsecond_Proxy(
04312     ICRDVariable __RPC_FAR * This,
04313     /* [retval][out] */ long __RPC_FAR *pVal);
04314
04315
04316 void __RPC_STUB ICRDVariable_get_Microsecond_Stub(
04317     IRpcStubBuffer *This,
04318     IRpcChannelBuffer *_pRpcChannelBuffer,
04319     PRPC_MESSAGE _pRpcMessage,
04320     DWORD *_pdwStubPhase);
04321
04322
04323 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDVariable_put_Microsecond_Proxy(
04324     ICRDVariable __RPC_FAR * This,
04325     /* [in] */ long newVal);
04326
04327
04328 void __RPC_STUB ICRDVariable_put_Microsecond_Stub(
04329     IRpcStubBuffer *This,
04330     IRpcChannelBuffer *_pRpcChannelBuffer,
04331     PRPC_MESSAGE _pRpcMessage,
04332     DWORD *_pdwStubPhase);
04333
04334
04335 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDVariable_get_XMLNode_Proxy(
04336     ICRDVariable __RPC_FAR * This,
04337     /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal);
04338
04339
04340 void __RPC_STUB ICRDVariable_get_XMLNode_Stub(
04341     IRpcStubBuffer *This,
04342     IRpcChannelBuffer *_pRpcChannelBuffer,
04343     PRPC_MESSAGE _pRpcMessage,
04344     DWORD *_pdwStubPhase);
04345
04346
04347 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDVariable_clone_Proxy(
04348     ICRDVariable __RPC_FAR * This,
04349     /* [in] */ BSTR bstrDestName,
04350     /* [retval][out] */ ICRDVariable __RPC_FAR *__RPC_FAR *pVal);
04351
04352
04353 void __RPC_STUB ICRDVariable_clone_Stub(
04354     IRpcStubBuffer *This,
04355     IRpcChannelBuffer *_pRpcChannelBuffer,
04356     PRPC_MESSAGE _pRpcMessage,
04357     DWORD *_pdwStubPhase);
04358
04359
04360
04361 #endif  /* __ICRDVariable_INTERFACE_DEFINED__ */
04362
04363
04364 #ifndef __ICRDCommand_INTERFACE_DEFINED__
04365 #define __ICRDCommand_INTERFACE_DEFINED__
04366
04367 /* interface ICRDCommand */
04368 /* [unique][helpstring][dual][uuid][object] */
04369
04370
04371 EXTERN_C const IID IID_ICRDCommand;
04372
04373 #if defined(__cplusplus) && !defined(CINTERFACE)
04374
04375     MIDL_INTERFACE("A422E6C8-AD76-46a2-BA95-6AA8D073A581")
04376     ICRDCommand : public IDispatch
04377     {
04378     public:
04379         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
04380             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
04381
04382         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Attribute(
04383             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
04384
04385         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Attribute(
04386             /* [in] */ long newVal) = 0;
04387
04388         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Help(
04389             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
04390
04391         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Help(
04392             /* [in] */ BSTR newVal) = 0;
04393
04394         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_State(
04395             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
04396
04397         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_State(
04398             /* [in] */ long newVal) = 0;
04399
04400         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Timeout(
04401             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
04402
04403         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Timeout(
04404             /* [in] */ long newVal) = 0;
04405
04406         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Parameters(
04407             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
04408
04409         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Parameters(
04410             /* [in] */ VARIANT newVal) = 0;
04411
04412         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ID(
04413             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
04414
04415         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ID(
04416             /* [in] */ VARIANT newVal) = 0;
04417
04418         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_XMLNode(
04419             /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal) = 0;
04420
04421         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE clone(
04422             /* [in] */ BSTR bstrDestName,
04423             /* [retval][out] */ ICRDCommand __RPC_FAR *__RPC_FAR *pVal) = 0;
04424
04425     };
04426
04427 #else   /* C style interface */
04428
04429     typedef struct ICRDCommandVtbl
04430     {
04431         BEGIN_INTERFACE
04432
04433         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
04434             ICRDCommand __RPC_FAR * This,
04435             /* [in] */ REFIID riid,
04436             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
04437
04438         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
04439             ICRDCommand __RPC_FAR * This);
04440
04441         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
04442             ICRDCommand __RPC_FAR * This);
04443
04444         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
04445             ICRDCommand __RPC_FAR * This,
04446             /* [out] */ UINT __RPC_FAR *pctinfo);
04447
04448         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
04449             ICRDCommand __RPC_FAR * This,
04450             /* [in] */ UINT iTInfo,
04451             /* [in] */ LCID lcid,
04452             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
04453
04454         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
04455             ICRDCommand __RPC_FAR * This,
04456             /* [in] */ REFIID riid,
04457             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
04458             /* [in] */ UINT cNames,
04459             /* [in] */ LCID lcid,
04460             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
04461
04462         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
04463             ICRDCommand __RPC_FAR * This,
04464             /* [in] */ DISPID dispIdMember,
04465             /* [in] */ REFIID riid,
04466             /* [in] */ LCID lcid,
04467             /* [in] */ WORD wFlags,
04468             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
04469             /* [out] */ VARIANT __RPC_FAR *pVarResult,
04470             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
04471             /* [out] */ UINT __RPC_FAR *puArgErr);
04472
04473         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
04474             ICRDCommand __RPC_FAR * This,
04475             /* [retval][out] */ BSTR __RPC_FAR *pVal);
04476
04477         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Attribute )(
04478             ICRDCommand __RPC_FAR * This,
04479             /* [retval][out] */ long __RPC_FAR *pVal);
04480
04481         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Attribute )(
04482             ICRDCommand __RPC_FAR * This,
04483             /* [in] */ long newVal);
04484
04485         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Help )(
04486             ICRDCommand __RPC_FAR * This,
04487             /* [retval][out] */ BSTR __RPC_FAR *pVal);
04488
04489         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Help )(
04490             ICRDCommand __RPC_FAR * This,
04491             /* [in] */ BSTR newVal);
04492
04493         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_State )(
04494             ICRDCommand __RPC_FAR * This,
04495             /* [retval][out] */ long __RPC_FAR *pVal);
04496
04497         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_State )(
04498             ICRDCommand __RPC_FAR * This,
04499             /* [in] */ long newVal);
04500
04501         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Timeout )(
04502             ICRDCommand __RPC_FAR * This,
04503             /* [retval][out] */ long __RPC_FAR *pVal);
04504
04505         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Timeout )(
04506             ICRDCommand __RPC_FAR * This,
04507             /* [in] */ long newVal);
04508
04509         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Parameters )(
04510             ICRDCommand __RPC_FAR * This,
04511             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04512
04513         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Parameters )(
04514             ICRDCommand __RPC_FAR * This,
04515             /* [in] */ VARIANT newVal);
04516
04517         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ID )(
04518             ICRDCommand __RPC_FAR * This,
04519             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04520
04521         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ID )(
04522             ICRDCommand __RPC_FAR * This,
04523             /* [in] */ VARIANT newVal);
04524
04525         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_XMLNode )(
04526             ICRDCommand __RPC_FAR * This,
04527             /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal);
04528
04529         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *clone )(
04530             ICRDCommand __RPC_FAR * This,
04531             /* [in] */ BSTR bstrDestName,
04532             /* [retval][out] */ ICRDCommand __RPC_FAR *__RPC_FAR *pVal);
04533
04534         END_INTERFACE
04535     } ICRDCommandVtbl;
04536
04537     interface ICRDCommand
04538     {
04539         CONST_VTBL struct ICRDCommandVtbl __RPC_FAR *lpVtbl;
04540     };
04541
04542
04543
04544 #ifdef COBJMACROS
04545
04546
04547 #define ICRDCommand_QueryInterface(This,riid,ppvObject) \
04548     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
04549
04550 #define ICRDCommand_AddRef(This)    \
04551     (This)->lpVtbl -> AddRef(This)
04552
04553 #define ICRDCommand_Release(This)   \
04554     (This)->lpVtbl -> Release(This)
04555
04556
04557 #define ICRDCommand_GetTypeInfoCount(This,pctinfo)  \
04558     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
04559
04560 #define ICRDCommand_GetTypeInfo(This,iTInfo,lcid,ppTInfo)   \
04561     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
04562
04563 #define ICRDCommand_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId) \
04564     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
04565
04566 #define ICRDCommand_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)   \
04567     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
04568
04569
04570 #define ICRDCommand_get_Name(This,pVal) \
04571     (This)->lpVtbl -> get_Name(This,pVal)
04572
04573 #define ICRDCommand_get_Attribute(This,pVal)    \
04574     (This)->lpVtbl -> get_Attribute(This,pVal)
04575
04576 #define ICRDCommand_put_Attribute(This,newVal)  \
04577     (This)->lpVtbl -> put_Attribute(This,newVal)
04578
04579 #define ICRDCommand_get_Help(This,pVal) \
04580     (This)->lpVtbl -> get_Help(This,pVal)
04581
04582 #define ICRDCommand_put_Help(This,newVal)   \
04583     (This)->lpVtbl -> put_Help(This,newVal)
04584
04585 #define ICRDCommand_get_State(This,pVal)    \
04586     (This)->lpVtbl -> get_State(This,pVal)
04587
04588 #define ICRDCommand_put_State(This,newVal)  \
04589     (This)->lpVtbl -> put_State(This,newVal)
04590
04591 #define ICRDCommand_get_Timeout(This,pVal)  \
04592     (This)->lpVtbl -> get_Timeout(This,pVal)
04593
04594 #define ICRDCommand_put_Timeout(This,newVal)    \
04595     (This)->lpVtbl -> put_Timeout(This,newVal)
04596
04597 #define ICRDCommand_get_Parameters(This,pVal)   \
04598     (This)->lpVtbl -> get_Parameters(This,pVal)
04599
04600 #define ICRDCommand_put_Parameters(This,newVal) \
04601     (This)->lpVtbl -> put_Parameters(This,newVal)
04602
04603 #define ICRDCommand_get_ID(This,pVal)   \
04604     (This)->lpVtbl -> get_ID(This,pVal)
04605
04606 #define ICRDCommand_put_ID(This,newVal) \
04607     (This)->lpVtbl -> put_ID(This,newVal)
04608
04609 #define ICRDCommand_get_XMLNode(This,pVal)  \
04610     (This)->lpVtbl -> get_XMLNode(This,pVal)
04611
04612 #define ICRDCommand_clone(This,bstrDestName,pVal)   \
04613     (This)->lpVtbl -> clone(This,bstrDestName,pVal)
04614
04615 #endif /* COBJMACROS */
04616
04617
04618 #endif  /* C style interface */
04619
04620
04621
04622 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDCommand_get_Name_Proxy(
04623     ICRDCommand __RPC_FAR * This,
04624     /* [retval][out] */ BSTR __RPC_FAR *pVal);
04625
04626
04627 void __RPC_STUB ICRDCommand_get_Name_Stub(
04628     IRpcStubBuffer *This,
04629     IRpcChannelBuffer *_pRpcChannelBuffer,
04630     PRPC_MESSAGE _pRpcMessage,
04631     DWORD *_pdwStubPhase);
04632
04633
04634 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDCommand_get_Attribute_Proxy(
04635     ICRDCommand __RPC_FAR * This,
04636     /* [retval][out] */ long __RPC_FAR *pVal);
04637
04638
04639 void __RPC_STUB ICRDCommand_get_Attribute_Stub(
04640     IRpcStubBuffer *This,
04641     IRpcChannelBuffer *_pRpcChannelBuffer,
04642     PRPC_MESSAGE _pRpcMessage,
04643     DWORD *_pdwStubPhase);
04644
04645
04646 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDCommand_put_Attribute_Proxy(
04647     ICRDCommand __RPC_FAR * This,
04648     /* [in] */ long newVal);
04649
04650
04651 void __RPC_STUB ICRDCommand_put_Attribute_Stub(
04652     IRpcStubBuffer *This,
04653     IRpcChannelBuffer *_pRpcChannelBuffer,
04654     PRPC_MESSAGE _pRpcMessage,
04655     DWORD *_pdwStubPhase);
04656
04657
04658 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDCommand_get_Help_Proxy(
04659     ICRDCommand __RPC_FAR * This,
04660     /* [retval][out] */ BSTR __RPC_FAR *pVal);
04661
04662
04663 void __RPC_STUB ICRDCommand_get_Help_Stub(
04664     IRpcStubBuffer *This,
04665     IRpcChannelBuffer *_pRpcChannelBuffer,
04666     PRPC_MESSAGE _pRpcMessage,
04667     DWORD *_pdwStubPhase);
04668
04669
04670 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDCommand_put_Help_Proxy(
04671     ICRDCommand __RPC_FAR * This,
04672     /* [in] */ BSTR newVal);
04673
04674
04675 void __RPC_STUB ICRDCommand_put_Help_Stub(
04676     IRpcStubBuffer *This,
04677     IRpcChannelBuffer *_pRpcChannelBuffer,
04678     PRPC_MESSAGE _pRpcMessage,
04679     DWORD *_pdwStubPhase);
04680
04681
04682 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDCommand_get_State_Proxy(
04683     ICRDCommand __RPC_FAR * This,
04684     /* [retval][out] */ long __RPC_FAR *pVal);
04685
04686
04687 void __RPC_STUB ICRDCommand_get_State_Stub(
04688     IRpcStubBuffer *This,
04689     IRpcChannelBuffer *_pRpcChannelBuffer,
04690     PRPC_MESSAGE _pRpcMessage,
04691     DWORD *_pdwStubPhase);
04692
04693
04694 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDCommand_put_State_Proxy(
04695     ICRDCommand __RPC_FAR * This,
04696     /* [in] */ long newVal);
04697
04698
04699 void __RPC_STUB ICRDCommand_put_State_Stub(
04700     IRpcStubBuffer *This,
04701     IRpcChannelBuffer *_pRpcChannelBuffer,
04702     PRPC_MESSAGE _pRpcMessage,
04703     DWORD *_pdwStubPhase);
04704
04705
04706 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDCommand_get_Timeout_Proxy(
04707     ICRDCommand __RPC_FAR * This,
04708     /* [retval][out] */ long __RPC_FAR *pVal);
04709
04710
04711 void __RPC_STUB ICRDCommand_get_Timeout_Stub(
04712     IRpcStubBuffer *This,
04713     IRpcChannelBuffer *_pRpcChannelBuffer,
04714     PRPC_MESSAGE _pRpcMessage,
04715     DWORD *_pdwStubPhase);
04716
04717
04718 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDCommand_put_Timeout_Proxy(
04719     ICRDCommand __RPC_FAR * This,
04720     /* [in] */ long newVal);
04721
04722
04723 void __RPC_STUB ICRDCommand_put_Timeout_Stub(
04724     IRpcStubBuffer *This,
04725     IRpcChannelBuffer *_pRpcChannelBuffer,
04726     PRPC_MESSAGE _pRpcMessage,
04727     DWORD *_pdwStubPhase);
04728
04729
04730 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDCommand_get_Parameters_Proxy(
04731     ICRDCommand __RPC_FAR * This,
04732     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04733
04734
04735 void __RPC_STUB ICRDCommand_get_Parameters_Stub(
04736     IRpcStubBuffer *This,
04737     IRpcChannelBuffer *_pRpcChannelBuffer,
04738     PRPC_MESSAGE _pRpcMessage,
04739     DWORD *_pdwStubPhase);
04740
04741
04742 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDCommand_put_Parameters_Proxy(
04743     ICRDCommand __RPC_FAR * This,
04744     /* [in] */ VARIANT newVal);
04745
04746
04747 void __RPC_STUB ICRDCommand_put_Parameters_Stub(
04748     IRpcStubBuffer *This,
04749     IRpcChannelBuffer *_pRpcChannelBuffer,
04750     PRPC_MESSAGE _pRpcMessage,
04751     DWORD *_pdwStubPhase);
04752
04753
04754 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDCommand_get_ID_Proxy(
04755     ICRDCommand __RPC_FAR * This,
04756     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04757
04758
04759 void __RPC_STUB ICRDCommand_get_ID_Stub(
04760     IRpcStubBuffer *This,
04761     IRpcChannelBuffer *_pRpcChannelBuffer,
04762     PRPC_MESSAGE _pRpcMessage,
04763     DWORD *_pdwStubPhase);
04764
04765
04766 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDCommand_put_ID_Proxy(
04767     ICRDCommand __RPC_FAR * This,
04768     /* [in] */ VARIANT newVal);
04769
04770
04771 void __RPC_STUB ICRDCommand_put_ID_Stub(
04772     IRpcStubBuffer *This,
04773     IRpcChannelBuffer *_pRpcChannelBuffer,
04774     PRPC_MESSAGE _pRpcMessage,
04775     DWORD *_pdwStubPhase);
04776
04777
04778 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDCommand_get_XMLNode_Proxy(
04779     ICRDCommand __RPC_FAR * This,
04780     /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal);
04781
04782
04783 void __RPC_STUB ICRDCommand_get_XMLNode_Stub(
04784     IRpcStubBuffer *This,
04785     IRpcChannelBuffer *_pRpcChannelBuffer,
04786     PRPC_MESSAGE _pRpcMessage,
04787     DWORD *_pdwStubPhase);
04788
04789
04790 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDCommand_clone_Proxy(
04791     ICRDCommand __RPC_FAR * This,
04792     /* [in] */ BSTR bstrDestName,
04793     /* [retval][out] */ ICRDCommand __RPC_FAR *__RPC_FAR *pVal);
04794
04795
04796 void __RPC_STUB ICRDCommand_clone_Stub(
04797     IRpcStubBuffer *This,
04798     IRpcChannelBuffer *_pRpcChannelBuffer,
04799     PRPC_MESSAGE _pRpcMessage,
04800     DWORD *_pdwStubPhase);
04801
04802
04803
04804 #endif  /* __ICRDCommand_INTERFACE_DEFINED__ */
04805
04806
04807 #ifndef __ICRDMessage_INTERFACE_DEFINED__
04808 #define __ICRDMessage_INTERFACE_DEFINED__
04809
04810 /* interface ICRDMessage */
04811 /* [unique][helpstring][dual][uuid][object] */
04812
04813
04814 EXTERN_C const IID IID_ICRDMessage;
04815
04816 #if defined(__cplusplus) && !defined(CINTERFACE)
04817
04818     MIDL_INTERFACE("904C2E9D-085D-478f-9E8F-224F5E1130D4")
04819     ICRDMessage : public IDispatch
04820     {
04821     public:
04822         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Number(
04823             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
04824
04825         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_DateTime(
04826             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
04827
04828         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_DateTime(
04829             /* [in] */ VARIANT newVal) = 0;
04830
04831         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Description(
04832             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
04833
04834         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Description(
04835             /* [in] */ BSTR newVal) = 0;
04836
04837         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Destination(
04838             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
04839
04840         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Destination(
04841             /* [in] */ BSTR newVal) = 0;
04842
04843         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Source(
04844             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
04845
04846         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Source(
04847             /* [in] */ BSTR newVal) = 0;
04848
04849         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Value(
04850             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
04851
04852         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Value(
04853             /* [in] */ VARIANT newVal) = 0;
04854
04855         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ID(
04856             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
04857
04858         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ID(
04859             /* [in] */ VARIANT newVal) = 0;
04860
04861         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_XMLNode(
04862             /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal) = 0;
04863
04864         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE clone(
04865             /* [in] */ long lNumber,
04866             /* [retval][out] */ ICRDMessage __RPC_FAR *__RPC_FAR *pVal) = 0;
04867
04868     };
04869
04870 #else   /* C style interface */
04871
04872     typedef struct ICRDMessageVtbl
04873     {
04874         BEGIN_INTERFACE
04875
04876         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
04877             ICRDMessage __RPC_FAR * This,
04878             /* [in] */ REFIID riid,
04879             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
04880
04881         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
04882             ICRDMessage __RPC_FAR * This);
04883
04884         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
04885             ICRDMessage __RPC_FAR * This);
04886
04887         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
04888             ICRDMessage __RPC_FAR * This,
04889             /* [out] */ UINT __RPC_FAR *pctinfo);
04890
04891         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
04892             ICRDMessage __RPC_FAR * This,
04893             /* [in] */ UINT iTInfo,
04894             /* [in] */ LCID lcid,
04895             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
04896
04897         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
04898             ICRDMessage __RPC_FAR * This,
04899             /* [in] */ REFIID riid,
04900             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
04901             /* [in] */ UINT cNames,
04902             /* [in] */ LCID lcid,
04903             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
04904
04905         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
04906             ICRDMessage __RPC_FAR * This,
04907             /* [in] */ DISPID dispIdMember,
04908             /* [in] */ REFIID riid,
04909             /* [in] */ LCID lcid,
04910             /* [in] */ WORD wFlags,
04911             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
04912             /* [out] */ VARIANT __RPC_FAR *pVarResult,
04913             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
04914             /* [out] */ UINT __RPC_FAR *puArgErr);
04915
04916         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Number )(
04917             ICRDMessage __RPC_FAR * This,
04918             /* [retval][out] */ long __RPC_FAR *pVal);
04919
04920         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_DateTime )(
04921             ICRDMessage __RPC_FAR * This,
04922             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04923
04924         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_DateTime )(
04925             ICRDMessage __RPC_FAR * This,
04926             /* [in] */ VARIANT newVal);
04927
04928         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Description )(
04929             ICRDMessage __RPC_FAR * This,
04930             /* [retval][out] */ BSTR __RPC_FAR *pVal);
04931
04932         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Description )(
04933             ICRDMessage __RPC_FAR * This,
04934             /* [in] */ BSTR newVal);
04935
04936         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Destination )(
04937             ICRDMessage __RPC_FAR * This,
04938             /* [retval][out] */ BSTR __RPC_FAR *pVal);
04939
04940         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Destination )(
04941             ICRDMessage __RPC_FAR * This,
04942             /* [in] */ BSTR newVal);
04943
04944         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Source )(
04945             ICRDMessage __RPC_FAR * This,
04946             /* [retval][out] */ BSTR __RPC_FAR *pVal);
04947
04948         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Source )(
04949             ICRDMessage __RPC_FAR * This,
04950             /* [in] */ BSTR newVal);
04951
04952         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Value )(
04953             ICRDMessage __RPC_FAR * This,
04954             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04955
04956         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Value )(
04957             ICRDMessage __RPC_FAR * This,
04958             /* [in] */ VARIANT newVal);
04959
04960         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ID )(
04961             ICRDMessage __RPC_FAR * This,
04962             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04963
04964         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ID )(
04965             ICRDMessage __RPC_FAR * This,
04966             /* [in] */ VARIANT newVal);
04967
04968         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_XMLNode )(
04969             ICRDMessage __RPC_FAR * This,
04970             /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal);
04971
04972         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *clone )(
04973             ICRDMessage __RPC_FAR * This,
04974             /* [in] */ long lNumber,
04975             /* [retval][out] */ ICRDMessage __RPC_FAR *__RPC_FAR *pVal);
04976
04977         END_INTERFACE
04978     } ICRDMessageVtbl;
04979
04980     interface ICRDMessage
04981     {
04982         CONST_VTBL struct ICRDMessageVtbl __RPC_FAR *lpVtbl;
04983     };
04984
04985
04986
04987 #ifdef COBJMACROS
04988
04989
04990 #define ICRDMessage_QueryInterface(This,riid,ppvObject) \
04991     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
04992
04993 #define ICRDMessage_AddRef(This)    \
04994     (This)->lpVtbl -> AddRef(This)
04995
04996 #define ICRDMessage_Release(This)   \
04997     (This)->lpVtbl -> Release(This)
04998
04999
05000 #define ICRDMessage_GetTypeInfoCount(This,pctinfo)  \
05001     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
05002
05003 #define ICRDMessage_GetTypeInfo(This,iTInfo,lcid,ppTInfo)   \
05004     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
05005
05006 #define ICRDMessage_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId) \
05007     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
05008
05009 #define ICRDMessage_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)   \
05010     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
05011
05012
05013 #define ICRDMessage_get_Number(This,pVal)   \
05014     (This)->lpVtbl -> get_Number(This,pVal)
05015
05016 #define ICRDMessage_get_DateTime(This,pVal) \
05017     (This)->lpVtbl -> get_DateTime(This,pVal)
05018
05019 #define ICRDMessage_put_DateTime(This,newVal)   \
05020     (This)->lpVtbl -> put_DateTime(This,newVal)
05021
05022 #define ICRDMessage_get_Description(This,pVal)  \
05023     (This)->lpVtbl -> get_Description(This,pVal)
05024
05025 #define ICRDMessage_put_Description(This,newVal)    \
05026     (This)->lpVtbl -> put_Description(This,newVal)
05027
05028 #define ICRDMessage_get_Destination(This,pVal)  \
05029     (This)->lpVtbl -> get_Destination(This,pVal)
05030
05031 #define ICRDMessage_put_Destination(This,newVal)    \
05032     (This)->lpVtbl -> put_Destination(This,newVal)
05033
05034 #define ICRDMessage_get_Source(This,pVal)   \
05035     (This)->lpVtbl -> get_Source(This,pVal)
05036
05037 #define ICRDMessage_put_Source(This,newVal) \
05038     (This)->lpVtbl -> put_Source(This,newVal)
05039
05040 #define ICRDMessage_get_Value(This,pVal)    \
05041     (This)->lpVtbl -> get_Value(This,pVal)
05042
05043 #define ICRDMessage_put_Value(This,newVal)  \
05044     (This)->lpVtbl -> put_Value(This,newVal)
05045
05046 #define ICRDMessage_get_ID(This,pVal)   \
05047     (This)->lpVtbl -> get_ID(This,pVal)
05048
05049 #define ICRDMessage_put_ID(This,newVal) \
05050     (This)->lpVtbl -> put_ID(This,newVal)
05051
05052 #define ICRDMessage_get_XMLNode(This,pVal)  \
05053     (This)->lpVtbl -> get_XMLNode(This,pVal)
05054
05055 #define ICRDMessage_clone(This,lNumber,pVal)    \
05056     (This)->lpVtbl -> clone(This,lNumber,pVal)
05057
05058 #endif /* COBJMACROS */
05059
05060
05061 #endif  /* C style interface */
05062
05063
05064
05065 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDMessage_get_Number_Proxy(
05066     ICRDMessage __RPC_FAR * This,
05067     /* [retval][out] */ long __RPC_FAR *pVal);
05068
05069
05070 void __RPC_STUB ICRDMessage_get_Number_Stub(
05071     IRpcStubBuffer *This,
05072     IRpcChannelBuffer *_pRpcChannelBuffer,
05073     PRPC_MESSAGE _pRpcMessage,
05074     DWORD *_pdwStubPhase);
05075
05076
05077 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDMessage_get_DateTime_Proxy(
05078     ICRDMessage __RPC_FAR * This,
05079     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
05080
05081
05082 void __RPC_STUB ICRDMessage_get_DateTime_Stub(
05083     IRpcStubBuffer *This,
05084     IRpcChannelBuffer *_pRpcChannelBuffer,
05085     PRPC_MESSAGE _pRpcMessage,
05086     DWORD *_pdwStubPhase);
05087
05088
05089 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDMessage_put_DateTime_Proxy(
05090     ICRDMessage __RPC_FAR * This,
05091     /* [in] */ VARIANT newVal);
05092
05093
05094 void __RPC_STUB ICRDMessage_put_DateTime_Stub(
05095     IRpcStubBuffer *This,
05096     IRpcChannelBuffer *_pRpcChannelBuffer,
05097     PRPC_MESSAGE _pRpcMessage,
05098     DWORD *_pdwStubPhase);
05099
05100
05101 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDMessage_get_Description_Proxy(
05102     ICRDMessage __RPC_FAR * This,
05103     /* [retval][out] */ BSTR __RPC_FAR *pVal);
05104
05105
05106 void __RPC_STUB ICRDMessage_get_Description_Stub(
05107     IRpcStubBuffer *This,
05108     IRpcChannelBuffer *_pRpcChannelBuffer,
05109     PRPC_MESSAGE _pRpcMessage,
05110     DWORD *_pdwStubPhase);
05111
05112
05113 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDMessage_put_Description_Proxy(
05114     ICRDMessage __RPC_FAR * This,
05115     /* [in] */ BSTR newVal);
05116
05117
05118 void __RPC_STUB ICRDMessage_put_Description_Stub(
05119     IRpcStubBuffer *This,
05120     IRpcChannelBuffer *_pRpcChannelBuffer,
05121     PRPC_MESSAGE _pRpcMessage,
05122     DWORD *_pdwStubPhase);
05123
05124
05125 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDMessage_get_Destination_Proxy(
05126     ICRDMessage __RPC_FAR * This,
05127     /* [retval][out] */ BSTR __RPC_FAR *pVal);
05128
05129
05130 void __RPC_STUB ICRDMessage_get_Destination_Stub(
05131     IRpcStubBuffer *This,
05132     IRpcChannelBuffer *_pRpcChannelBuffer,
05133     PRPC_MESSAGE _pRpcMessage,
05134     DWORD *_pdwStubPhase);
05135
05136
05137 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDMessage_put_Destination_Proxy(
05138     ICRDMessage __RPC_FAR * This,
05139     /* [in] */ BSTR newVal);
05140
05141
05142 void __RPC_STUB ICRDMessage_put_Destination_Stub(
05143     IRpcStubBuffer *This,
05144     IRpcChannelBuffer *_pRpcChannelBuffer,
05145     PRPC_MESSAGE _pRpcMessage,
05146     DWORD *_pdwStubPhase);
05147
05148
05149 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDMessage_get_Source_Proxy(
05150     ICRDMessage __RPC_FAR * This,
05151     /* [retval][out] */ BSTR __RPC_FAR *pVal);
05152
05153
05154 void __RPC_STUB ICRDMessage_get_Source_Stub(
05155     IRpcStubBuffer *This,
05156     IRpcChannelBuffer *_pRpcChannelBuffer,
05157     PRPC_MESSAGE _pRpcMessage,
05158     DWORD *_pdwStubPhase);
05159
05160
05161 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDMessage_put_Source_Proxy(
05162     ICRDMessage __RPC_FAR * This,
05163     /* [in] */ BSTR newVal);
05164
05165
05166 void __RPC_STUB ICRDMessage_put_Source_Stub(
05167     IRpcStubBuffer *This,
05168     IRpcChannelBuffer *_pRpcChannelBuffer,
05169     PRPC_MESSAGE _pRpcMessage,
05170     DWORD *_pdwStubPhase);
05171
05172
05173 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDMessage_get_Value_Proxy(
05174     ICRDMessage __RPC_FAR * This,
05175     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
05176
05177
05178 void __RPC_STUB ICRDMessage_get_Value_Stub(
05179     IRpcStubBuffer *This,
05180     IRpcChannelBuffer *_pRpcChannelBuffer,
05181     PRPC_MESSAGE _pRpcMessage,
05182     DWORD *_pdwStubPhase);
05183
05184
05185 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDMessage_put_Value_Proxy(
05186     ICRDMessage __RPC_FAR * This,
05187     /* [in] */ VARIANT newVal);
05188
05189
05190 void __RPC_STUB ICRDMessage_put_Value_Stub(
05191     IRpcStubBuffer *This,
05192     IRpcChannelBuffer *_pRpcChannelBuffer,
05193     PRPC_MESSAGE _pRpcMessage,
05194     DWORD *_pdwStubPhase);
05195
05196
05197 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDMessage_get_ID_Proxy(
05198     ICRDMessage __RPC_FAR * This,
05199     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
05200
05201
05202 void __RPC_STUB ICRDMessage_get_ID_Stub(
05203     IRpcStubBuffer *This,
05204     IRpcChannelBuffer *_pRpcChannelBuffer,
05205     PRPC_MESSAGE _pRpcMessage,
05206     DWORD *_pdwStubPhase);
05207
05208
05209 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICRDMessage_put_ID_Proxy(
05210     ICRDMessage __RPC_FAR * This,
05211     /* [in] */ VARIANT newVal);
05212
05213
05214 void __RPC_STUB ICRDMessage_put_ID_Stub(
05215     IRpcStubBuffer *This,
05216     IRpcChannelBuffer *_pRpcChannelBuffer,
05217     PRPC_MESSAGE _pRpcMessage,
05218     DWORD *_pdwStubPhase);
05219
05220
05221 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICRDMessage_get_XMLNode_Proxy(
05222     ICRDMessage __RPC_FAR * This,
05223     /* [retval][out] */ IUnknown __RPC_FAR *__RPC_FAR *pVal);
05224
05225
05226 void __RPC_STUB ICRDMessage_get_XMLNode_Stub(
05227     IRpcStubBuffer *This,
05228     IRpcChannelBuffer *_pRpcChannelBuffer,
05229     PRPC_MESSAGE _pRpcMessage,
05230     DWORD *_pdwStubPhase);
05231
05232
05233 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICRDMessage_clone_Proxy(
05234     ICRDMessage __RPC_FAR * This,
05235     /* [in] */ long lNumber,
05236     /* [retval][out] */ ICRDMessage __RPC_FAR *__RPC_FAR *pVal);
05237
05238
05239 void __RPC_STUB ICRDMessage_clone_Stub(
05240     IRpcStubBuffer *This,
05241     IRpcChannelBuffer *_pRpcChannelBuffer,
05242     PRPC_MESSAGE _pRpcMessage,
05243     DWORD *_pdwStubPhase);
05244
05245
05246
05247 #endif  /* __ICRDMessage_INTERFACE_DEFINED__ */
05248
05249
05250
05251 #ifndef __CRDMAPPERLib_LIBRARY_DEFINED__
05252 #define __CRDMAPPERLib_LIBRARY_DEFINED__
05253
05254 /* library CRDMAPPERLib */
05255 /* [helpstring][version][uuid] */
05256
05257
05258 EXTERN_C const IID LIBID_CRDMAPPERLib;
05259
05260 EXTERN_C const CLSID CLSID_CRDEngine;
05261
05262 #ifdef __cplusplus
05263
05264 class DECLSPEC_UUID("1A075796-21FA-4CE6-9CDB-B1683C4B0442")
05265 CRDEngine;
05266 #endif
05267
05268 EXTERN_C const CLSID CLSID_CRDController;
05269
05270 #ifdef __cplusplus
05271
05272 class DECLSPEC_UUID("2D971601-9F26-4F70-AF6C-A6CE07683CB9")
05273 CRDController;
05274 #endif
05275
05276 EXTERN_C const CLSID CLSID_CRDExtension;
05277
05278 #ifdef __cplusplus
05279
05280 class DECLSPEC_UUID("E8DE945C-B604-4567-9DD5-D6B6D52A18CC")
05281 CRDExtension;
05282 #endif
05283
05284 EXTERN_C const CLSID CLSID_CRDFile;
05285
05286 #ifdef __cplusplus
05287
05288 class DECLSPEC_UUID("523F3578-4ACE-4447-9D40-EC9BBC38AE0F")
05289 CRDFile;
05290 #endif
05291
05292 EXTERN_C const CLSID CLSID_CRDRobot;
05293
05294 #ifdef __cplusplus
05295
05296 class DECLSPEC_UUID("2B010177-FD27-436B-BEFF-A3A302BEFCA8")
05297 CRDRobot;
05298 #endif
05299
05300 EXTERN_C const CLSID CLSID_CRDTask;
05301
05302 #ifdef __cplusplus
05303
05304 class DECLSPEC_UUID("952CCDAB-6AA8-4007-8225-9C9B704C8C90")
05305 CRDTask;
05306 #endif
05307
05308 EXTERN_C const CLSID CLSID_CRDVariable;
05309
05310 #ifdef __cplusplus
05311
05312 class DECLSPEC_UUID("C39D19C0-3458-4623-9A55-02E5BEB27CD3")
05313 CRDVariable;
05314 #endif
05315
05316 EXTERN_C const CLSID CLSID_CRDCommand;
05317
05318 #ifdef __cplusplus
05319
05320 class DECLSPEC_UUID("853BCF88-9A3C-4604-B95C-AB48AF47A33C")
05321 CRDCommand;
05322 #endif
05323
05324 EXTERN_C const CLSID CLSID_CRDMessage;
05325
05326 #ifdef __cplusplus
05327
05328 class DECLSPEC_UUID("A8D27938-26D1-4af3-9599-23CF97285A7C")
05329 CRDMessage;
05330 #endif
05331 #endif /* __CRDMAPPERLib_LIBRARY_DEFINED__ */
05332
05333 /* Additional Prototypes for ALL interfaces */
05334
05335 unsigned long             __RPC_USER  BSTR_UserSize(     unsigned long __RPC_FAR *, unsigned long            , BSTR __RPC_FAR * );
05336 unsigned char __RPC_FAR * __RPC_USER  BSTR_UserMarshal(  unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR * );
05337 unsigned char __RPC_FAR * __RPC_USER  BSTR_UserUnmarshal(unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR * );
05338 void                      __RPC_USER  BSTR_UserFree(     unsigned long __RPC_FAR *, BSTR __RPC_FAR * );
05339
05340 unsigned long             __RPC_USER  VARIANT_UserSize(     unsigned long __RPC_FAR *, unsigned long            , VARIANT __RPC_FAR * );
05341 unsigned char __RPC_FAR * __RPC_USER  VARIANT_UserMarshal(  unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, VARIANT __RPC_FAR * );
05342 unsigned char __RPC_FAR * __RPC_USER  VARIANT_UserUnmarshal(unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, VARIANT __RPC_FAR * );
05343 void                      __RPC_USER  VARIANT_UserFree(     unsigned long __RPC_FAR *, VARIANT __RPC_FAR * );
05344
05345 /* end of Additional Prototypes */
05346
05347 #ifdef __cplusplus
05348 }
05349 #endif
05350
05351 #endif
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMapper.idl Source File

CRDMapper.idl

解説を見る。
00001 // CRDMapper.idl : CRDMapper.dll 用の IDL ソース ファイル
00002 //
00003
00004 // このファイルはタイプ ライブラリ (CRDMapper.tlb) を作成するために
00005 // タイプ ライブラリ作成ツール MIDL によって処理されます。
00006
00007 import "oaidl.idl";
00008 import "ocidl.idl";
00009
00010 interface ICRDEngine;
00011 interface ICRDController;
00012 interface ICRDExtension;
00013 interface ICRDFile;
00014 interface ICRDRobot;
00015 interface ICRDTask;
00016 interface ICRDVariable;
00017 interface ICRDCommand;
00018 interface ICRDMessage;
00019
00020     [
00021         object,
00022         uuid(C6A53FD0-B13D-48EA-862E-0710460C1460),
00023         dual,
00024         helpstring("ICRDEngine Interface"),
00025         pointer_default(unique)
00026     ]
00027     interface ICRDEngine : IDispatch
00028     {
00029         [id(1), helpstring("ﾒｿｯﾄﾞ CreateDocument")] HRESULT CreateDocument();
00030         [id(2), helpstring("ﾒｿｯﾄﾞ load")] HRESULT load([in] BSTR bstrFileName);
00031         [id(3), helpstring("ﾒｿｯﾄﾞ save")] HRESULT save();
00032         [id(4), helpstring("ﾒｿｯﾄﾞ saveAs")] HRESULT saveAs([in, defaultvalue("")] BSTR bstrFileName);
00033
00034         [id(5), helpstring("ﾒｿｯﾄﾞ createController")] HRESULT createController([in] BSTR bstrName, [out, retval] ICRDController** pVal);
00035         [id(6), helpstring("ﾒｿｯﾄﾞ removeController")] HRESULT removeController([in] BSTR bstrName);
00036         [id(7), helpstring("ﾒｿｯﾄﾞ appendController")] HRESULT appendController([in] ICRDController* newCtrl);
00037         [propget, id(8), helpstring("ﾌﾟﾛﾊﾟﾃｨ ControllerNames")] HRESULT ControllerNames([out, retval] VARIANT *pVal);
00038         [propget, id(9), helpstring("ﾌﾟﾛﾊﾟﾃｨ Controller")] HRESULT Controller([in] BSTR bstrName, [out, retval] ICRDController **pVal);
00039
00040         [propget, id(10), helpstring("ﾌﾟﾛﾊﾟﾃｨ Help")] HRESULT Help([out, retval] BSTR *pVal);
00041         [propput, id(10), helpstring("ﾌﾟﾛﾊﾟﾃｨ Help")] HRESULT Help([in] BSTR newVal);
00042         [propget, id(11), helpstring("ﾌﾟﾛﾊﾟﾃｨ Version")] HRESULT Version([out, retval] BSTR *pVal);
00043         [propput, id(11), helpstring("ﾌﾟﾛﾊﾟﾃｨ Version")] HRESULT Version([in] BSTR newVal);
00044     };
00045     [
00046         object,
00047         uuid(9044FA0D-1B4D-42C4-9DBC-1F6E4553E31C),
00048         dual,
00049         helpstring("ICRDController Interface"),
00050         pointer_default(unique)
00051     ]
00052     interface ICRDController : IDispatch
00053     {
00054         [propget, id(1), helpstring("ﾌﾟﾛﾊﾟﾃｨ Name")] HRESULT Name([out, retval] BSTR *pVal);
00055         [propget, id(2), helpstring("ﾌﾟﾛﾊﾟﾃｨ Attribute")] HRESULT Attribute([out, retval] long *pVal);
00056         [propput, id(2), helpstring("ﾌﾟﾛﾊﾟﾃｨ Attribute")] HRESULT Attribute([in] long newVal);
00057         [propget, id(3), helpstring("ﾌﾟﾛﾊﾟﾃｨ Help")] HRESULT Help([out, retval] BSTR *pVal);
00058         [propput, id(3), helpstring("ﾌﾟﾛﾊﾟﾃｨ Help")] HRESULT Help([in] BSTR newVal);
00059         [propget, id(4), helpstring("ﾌﾟﾛﾊﾟﾃｨ ID")] HRESULT ID([out, retval] VARIANT *pVal);
00060         [propput, id(4), helpstring("ﾌﾟﾛﾊﾟﾃｨ ID")] HRESULT ID([in] VARIANT newVal);
00061         [propget, id(5), helpstring("ﾌﾟﾛﾊﾟﾃｨ XMLNode"), restricted] HRESULT XMLNode([out, retval] IUnknown **pVal);
00062
00063         [id(10), helpstring("ﾒｿｯﾄﾞ createExtension")] HRESULT createExtension([in] BSTR bstrName, [out, retval] ICRDExtension** pVal);
00064         [id(11), helpstring("ﾒｿｯﾄﾞ removeExtension")] HRESULT removeExtension([in] BSTR bstrName);
00065         [id(12), helpstring("ﾒｿｯﾄﾞ appendExtension")] HRESULT appendExtension([in] ICRDExtension* newExt);
00066         [propget, id(13), helpstring("ﾌﾟﾛﾊﾟﾃｨ ExtensionNames")] HRESULT ExtensionNames([out, retval] VARIANT *pVal);
00067         [propget, id(14), helpstring("ﾌﾟﾛﾊﾟﾃｨ Extension")] HRESULT Extension(BSTR bstrName, [out, retval] ICRDExtension **pVal);
00068
00069         [id(20), helpstring("ﾒｿｯﾄﾞ createFile")] HRESULT createFile([in] BSTR bstrName, [out, retval] ICRDFile** pVal);
00070         [id(21), helpstring("ﾒｿｯﾄﾞ removeFile")] HRESULT removeFile([in] BSTR bstrName);
00071         [id(22), helpstring("ﾒｿｯﾄﾞ appendFile")] HRESULT appendFile([in] ICRDFile* newFile);
00072         [propget, id(23), helpstring("ﾌﾟﾛﾊﾟﾃｨ FileNames")] HRESULT FileNames([out, retval] VARIANT *pVal);
00073         [propget, id(24), helpstring("ﾌﾟﾛﾊﾟﾃｨ File")] HRESULT File(BSTR bstrName, [out, retval] ICRDFile **pVal);
00074
00075         [id(30), helpstring("ﾒｿｯﾄﾞ createRobot")] HRESULT createRobot([in] BSTR bstrName, [out, retval] ICRDRobot** pVal);
00076         [id(31), helpstring("ﾒｿｯﾄﾞ removeRobot")] HRESULT removeRobot([in] BSTR bstrName);
00077         [id(32), helpstring("ﾒｿｯﾄﾞ appendRobot")] HRESULT appendRobot([in] ICRDRobot* newRobot);
00078         [propget, id(33), helpstring("ﾌﾟﾛﾊﾟﾃｨ RobotNames")] HRESULT RobotNames([out, retval] VARIANT *pVal);
00079         [propget, id(34), helpstring("ﾌﾟﾛﾊﾟﾃｨ Robot")] HRESULT Robot(BSTR bstrName, [out, retval] ICRDRobot **pVal);
00080
00081         [id(40), helpstring("ﾒｿｯﾄﾞ createTask")] HRESULT createTask([in] BSTR bstrName, [out, retval] ICRDTask** pVal);
00082         [id(41), helpstring("ﾒｿｯﾄﾞ removeTask")] HRESULT removeTask([in] BSTR bstrName);
00083         [id(42), helpstring("ﾒｿｯﾄﾞ appendTask")] HRESULT appendTask([in] ICRDTask* newTask);
00084         [propget, id(43), helpstring("ﾌﾟﾛﾊﾟﾃｨ TaskNames")] HRESULT TaskNames([out, retval] VARIANT *pVal);
00085         [propget, id(44), helpstring("ﾌﾟﾛﾊﾟﾃｨ Task")] HRESULT Task(BSTR bstrName, [out, retval] ICRDTask **pVal);
00086
00087         [id(50), helpstring("ﾒｿｯﾄﾞ createVariable")] HRESULT createVariable([in] BSTR bstrName, [out, retval] ICRDVariable** pVal);
00088         [id(51), helpstring("ﾒｿｯﾄﾞ removeVariable")] HRESULT removeVariable([in] BSTR bstrName);
00089         [id(52), helpstring("ﾒｿｯﾄﾞ appendVariable")] HRESULT appendVariable([in] ICRDVariable* newVar);
00090         [propget, id(53), helpstring("ﾌﾟﾛﾊﾟﾃｨ VariableNames")] HRESULT VariableNames([out, retval] VARIANT *pVal);
00091         [propget, id(54), helpstring("ﾌﾟﾛﾊﾟﾃｨ Variable")] HRESULT Variable(BSTR bstrName, [out, retval] ICRDVariable **pVal);
00092
00093         [id(60), helpstring("ﾒｿｯﾄﾞ createCommand")] HRESULT createCommand([in] BSTR bstrName, [out, retval] ICRDCommand** pVal);
00094         [id(61), helpstring("ﾒｿｯﾄﾞ removeCommand")] HRESULT removeCommand([in] BSTR bstrName);
00095         [id(62), helpstring("ﾒｿｯﾄﾞ appendCommand")] HRESULT appendCommand([in] ICRDCommand* newCmd);
00096         [propget, id(63), helpstring("ﾌﾟﾛﾊﾟﾃｨ CommandNames")] HRESULT CommandNames([out, retval] VARIANT *pVal);
00097         [propget, id(64), helpstring("ﾌﾟﾛﾊﾟﾃｨ Command")] HRESULT Command(BSTR bstrName, [out, retval] ICRDCommand **pVal);
00098
00099         [id(70), helpstring("ﾒｿｯﾄﾞ createMessage")] HRESULT createMessage([in] long lNumber, [out, retval] ICRDMessage** pVal);
00100         [id(71), helpstring("ﾒｿｯﾄﾞ removeMessage")] HRESULT removeMessage([in] long lNumber);
00101         [id(72), helpstring("ﾒｿｯﾄﾞ appendMessage")] HRESULT appendMessage([in] ICRDMessage* newMsg);
00102         [propget, id(73), helpstring("ﾌﾟﾛﾊﾟﾃｨ MessageNames")] HRESULT MessageNumbers([out, retval] VARIANT *pVal);
00103         [propget, id(74), helpstring("ﾌﾟﾛﾊﾟﾃｨ Message")] HRESULT Message(long lNumber, [out, retval] ICRDMessage **pVal);
00104
00105         [id(80), helpstring("ﾒｿｯﾄﾞ clone")] HRESULT clone([in] BSTR bstrDestName, [out, retval] ICRDController** pVal);
00106
00107     };
00108     [
00109         object,
00110         uuid(5DFD134B-65F4-44ED-B2B2-F70378BF8E13),
00111         dual,
00112         helpstring("ICRDExtension Interface"),
00113         pointer_default(unique)
00114     ]
00115     interface ICRDExtension : IDispatch
00116     {
00117         [propget, id(1), helpstring("ﾌﾟﾛﾊﾟﾃｨ Name")] HRESULT Name([out, retval] BSTR *pVal);
00118         [propget, id(2), helpstring("ﾌﾟﾛﾊﾟﾃｨ Attribute")] HRESULT Attribute([out, retval] long *pVal);
00119         [propput, id(2), helpstring("ﾌﾟﾛﾊﾟﾃｨ Attribute")] HRESULT Attribute([in] long newVal);
00120         [propget, id(3), helpstring("ﾌﾟﾛﾊﾟﾃｨ Help")] HRESULT Help([out, retval] BSTR *pVal);
00121         [propput, id(3), helpstring("ﾌﾟﾛﾊﾟﾃｨ Help")] HRESULT Help([in] BSTR newVal);
00122         [propget, id(4), helpstring("ﾌﾟﾛﾊﾟﾃｨ ID")] HRESULT ID([out, retval] VARIANT *pVal);
00123         [propput, id(4), helpstring("ﾌﾟﾛﾊﾟﾃｨ ID")] HRESULT ID([in] VARIANT newVal);
00124         [propget, id(5), helpstring("ﾌﾟﾛﾊﾟﾃｨ XMLNode"), restricted] HRESULT XMLNode([out, retval] IUnknown **pVal);
00125
00126         [id(50), helpstring("ﾒｿｯﾄﾞ createVariable")] HRESULT createVariable([in] BSTR bstrName, [out, retval] ICRDVariable** pVal);
00127         [id(51), helpstring("ﾒｿｯﾄﾞ removeVariable")] HRESULT removeVariable([in] BSTR bstrName);
00128         [id(52), helpstring("ﾒｿｯﾄﾞ appendVariable")] HRESULT appendVariable([in] ICRDVariable* newVar);
00129         [propget, id(53), helpstring("ﾌﾟﾛﾊﾟﾃｨ VariableNames")] HRESULT VariableNames([out, retval] VARIANT *pVal);
00130         [propget, id(54), helpstring("ﾌﾟﾛﾊﾟﾃｨ Variable")] HRESULT Variable(BSTR bstrName, [out, retval] ICRDVariable **pVal);
00131
00132         [id(60), helpstring("ﾒｿｯﾄﾞ clone")] HRESULT clone([in] BSTR bstrDestName, [out, retval] ICRDExtension** pVal);
00133     };
00134     [
00135         object,
00136         uuid(087D5BDD-4D9E-4EC5-8CDA-850F486DC83C),
00137         dual,
00138         helpstring("ICRDFile Interface"),
00139         pointer_default(unique)
00140     ]
00141     interface ICRDFile : IDispatch
00142     {
00143         [propget, id(1), helpstring("ﾌﾟﾛﾊﾟﾃｨ Name")] HRESULT Name([out, retval] BSTR *pVal);
00144         [propget, id(2), helpstring("ﾌﾟﾛﾊﾟﾃｨ Attribute")] HRESULT Attribute([out, retval] long *pVal);
00145         [propput, id(2), helpstring("ﾌﾟﾛﾊﾟﾃｨ Attribute")] HRESULT Attribute([in] long newVal);
00146         [propget, id(3), helpstring("ﾌﾟﾛﾊﾟﾃｨ Help")] HRESULT Help([out, retval] BSTR *pVal);
00147         [propput, id(3), helpstring("ﾌﾟﾛﾊﾟﾃｨ Help")] HRESULT Help([in] BSTR newVal);
00148         [propget, id(4), helpstring("ﾌﾟﾛﾊﾟﾃｨ DateCreated")] HRESULT DateCreated([out, retval] VARIANT *pVal);
00149         [propput, id(4), helpstring("ﾌﾟﾛﾊﾟﾃｨ DateCreated")] HRESULT DateCreated([in] VARIANT newVal);
00150         [propget, id(5), helpstring("ﾌﾟﾛﾊﾟﾃｨ DateLastAccessed")] HRESULT DateLastAccessed([out, retval] VARIANT *pVal);
00151         [propput, id(5), helpstring("ﾌﾟﾛﾊﾟﾃｨ DateLastAccessed")] HRESULT DateLastAccessed([in] VARIANT newVal);
00152         [propget, id(6), helpstring("ﾌﾟﾛﾊﾟﾃｨ DateLastModified")] HRESULT DateLastModified([out, retval] VARIANT *pVal);
00153         [propput, id(6), helpstring("ﾌﾟﾛﾊﾟﾃｨ DateLastModified")] HRESULT DateLastModified([in] VARIANT newVal);
00154         [propget, id(7), helpstring("ﾌﾟﾛﾊﾟﾃｨ Path")] HRESULT Path([out, retval] BSTR *pVal);
00155         [propput, id(7), helpstring("ﾌﾟﾛﾊﾟﾃｨ Path")] HRESULT Path([in] BSTR newVal);
00156         [propget, id(8), helpstring("ﾌﾟﾛﾊﾟﾃｨ Size")] HRESULT Size([out, retval] long *pVal);
00157         [propput, id(8), helpstring("ﾌﾟﾛﾊﾟﾃｨ Size")] HRESULT Size([in] long newVal);
00158         [propget, id(9), helpstring("ﾌﾟﾛﾊﾟﾃｨ Type")] HRESULT Type([out, retval] BSTR *pVal);
00159         [propput, id(9), helpstring("ﾌﾟﾛﾊﾟﾃｨ Type")] HRESULT Type([in] BSTR newVal);
00160         [propget, id(10), helpstring("ﾌﾟﾛﾊﾟﾃｨ Value")] HRESULT Value([out, retval] VARIANT *pVal);
00161         [propput, id(10), helpstring("ﾌﾟﾛﾊﾟﾃｨ Value")] HRESULT Value([in] VARIANT newVal);
00162         [propget, id(11), helpstring("ﾌﾟﾛﾊﾟﾃｨ ID")] HRESULT ID([out, retval] VARIANT *pVal);
00163         [propput, id(11), helpstring("ﾌﾟﾛﾊﾟﾃｨ ID")] HRESULT ID([in] VARIANT newVal);
00164         [propget, id(12), helpstring("ﾌﾟﾛﾊﾟﾃｨ XMLNode"), restricted] HRESULT XMLNode([out, retval] IUnknown **pVal);
00165
00166         [id(20), helpstring("ﾒｿｯﾄﾞ createFile")] HRESULT createFile([in] BSTR bstrName, [out, retval] ICRDFile** pVal);
00167         [id(21), helpstring("ﾒｿｯﾄﾞ removeFile")] HRESULT removeFile([in] BSTR bstrName);
00168         [id(22), helpstring("ﾒｿｯﾄﾞ appendFile")] HRESULT appendFile([in] ICRDFile* newFile);
00169         [propget, id(23), helpstring("ﾌﾟﾛﾊﾟﾃｨ FileNames")] HRESULT FileNames([out, retval] VARIANT *pVal);
00170         [propget, id(24), helpstring("ﾌﾟﾛﾊﾟﾃｨ File")] HRESULT File(BSTR bstrName, [out, retval] ICRDFile **pVal);
00171
00172         [id(50), helpstring("ﾒｿｯﾄﾞ createVariable")] HRESULT createVariable([in] BSTR bstrName, [out, retval] ICRDVariable** pVal);
00173         [id(51), helpstring("ﾒｿｯﾄﾞ removeVariable")] HRESULT removeVariable([in] BSTR bstrName);
00174         [id(52), helpstring("ﾒｿｯﾄﾞ appendVariable")] HRESULT appendVariable([in] ICRDVariable* newVar);
00175         [propget, id(53), helpstring("ﾌﾟﾛﾊﾟﾃｨ VariableNames")] HRESULT VariableNames([out, retval] VARIANT *pVal);
00176         [propget, id(54), helpstring("ﾌﾟﾛﾊﾟﾃｨ Variable")] HRESULT Variable(BSTR bstrName, [out, retval] ICRDVariable **pVal);
00177
00178         [id(60), helpstring("ﾒｿｯﾄﾞ clone")] HRESULT clone([in] BSTR bstrDestName, [out, retval] ICRDFile** pVal);
00179     };
00180     [
00181         object,
00182         uuid(5E3CDB5B-0638-4285-B1CB-C149B59A1AD2),
00183         dual,
00184         helpstring("ICRDRobot Interface"),
00185         pointer_default(unique)
00186     ]
00187     interface ICRDRobot : IDispatch
00188     {
00189         [propget, id(1), helpstring("ﾌﾟﾛﾊﾟﾃｨ Name")] HRESULT Name([out, retval] BSTR *pVal);
00190         [propget, id(2), helpstring("ﾌﾟﾛﾊﾟﾃｨ Attribute")] HRESULT Attribute([out, retval] long *pVal);
00191         [propput, id(2), helpstring("ﾌﾟﾛﾊﾟﾃｨ Attribute")] HRESULT Attribute([in] long newVal);
00192         [propget, id(3), helpstring("ﾌﾟﾛﾊﾟﾃｨ Help")] HRESULT Help([out, retval] BSTR *pVal);
00193         [propput, id(3), helpstring("ﾌﾟﾛﾊﾟﾃｨ Help")] HRESULT Help([in] BSTR newVal);
00194         [propget, id(4), helpstring("ﾌﾟﾛﾊﾟﾃｨ ID")] HRESULT ID([out, retval] VARIANT *pVal);
00195         [propput, id(4), helpstring("ﾌﾟﾛﾊﾟﾃｨ ID")] HRESULT ID([in] VARIANT newVal);
00196         [propget, id(5), helpstring("ﾌﾟﾛﾊﾟﾃｨ XMLNode"), restricted] HRESULT XMLNode([out, retval] IUnknown **pVal);
00197
00198         [id(50), helpstring("ﾒｿｯﾄﾞ createVariable")] HRESULT createVariable([in] BSTR bstrName, [out, retval] ICRDVariable** pVal);
00199         [id(51), helpstring("ﾒｿｯﾄﾞ removeVariable")] HRESULT removeVariable([in] BSTR bstrName);
00200         [id(52), helpstring("ﾒｿｯﾄﾞ appendVariable")] HRESULT appendVariable([in] ICRDVariable* newVar);
00201         [propget, id(53), helpstring("ﾌﾟﾛﾊﾟﾃｨ VariableNames")] HRESULT VariableNames([out, retval] VARIANT *pVal);
00202         [propget, id(54), helpstring("ﾌﾟﾛﾊﾟﾃｨ Variable")] HRESULT Variable(BSTR bstrName, [out, retval] ICRDVariable **pVal);
00203
00204         [id(60), helpstring("ﾒｿｯﾄﾞ clone")] HRESULT clone([in] BSTR bstrDestName, [out, retval] ICRDRobot** pVal);
00205     };
00206     [
00207         object,
00208         uuid(66E7EE84-CAA7-437F-AF52-A94973D8A8D7),
00209         dual,
00210         helpstring("ICRDTask Interface"),
00211         pointer_default(unique)
00212     ]
00213     interface ICRDTask : IDispatch
00214     {
00215         [propget, id(1), helpstring("ﾌﾟﾛﾊﾟﾃｨ Name")] HRESULT Name([out, retval] BSTR *pVal);
00216         [propget, id(2), helpstring("ﾌﾟﾛﾊﾟﾃｨ Attribute")] HRESULT Attribute([out, retval] long *pVal);
00217         [propput, id(2), helpstring("ﾌﾟﾛﾊﾟﾃｨ Attribute")] HRESULT Attribute([in] long newVal);
00218         [propget, id(3), helpstring("ﾌﾟﾛﾊﾟﾃｨ Help")] HRESULT Help([out, retval] BSTR *pVal);
00219         [propput, id(3), helpstring("ﾌﾟﾛﾊﾟﾃｨ Help")] HRESULT Help([in] BSTR newVal);
00220         [propget, id(4), helpstring("ﾌﾟﾛﾊﾟﾃｨ FileName")] HRESULT FileName([out, retval] BSTR *pVal);
00221         [propput, id(4), helpstring("ﾌﾟﾛﾊﾟﾃｨ FileName")] HRESULT FileName([in] BSTR newVal);
00222         [propget, id(5), helpstring("ﾌﾟﾛﾊﾟﾃｨ ID")] HRESULT ID([out, retval] VARIANT *pVal);
00223         [propput, id(5), helpstring("ﾌﾟﾛﾊﾟﾃｨ ID")] HRESULT ID([in] VARIANT newVal);
00224         [propget, id(20), helpstring("ﾌﾟﾛﾊﾟﾃｨ XMLNode"), restricted] HRESULT XMLNode([out, retval] IUnknown **pVal);
00225
00226         [id(50), helpstring("ﾒｿｯﾄﾞ createVariable")] HRESULT createVariable([in] BSTR bstrName, [out, retval] ICRDVariable** pVal);
00227         [id(51), helpstring("ﾒｿｯﾄﾞ removeVariable")] HRESULT removeVariable([in] BSTR bstrName);
00228         [id(52), helpstring("ﾒｿｯﾄﾞ appendVariable")] HRESULT appendVariable([in] ICRDVariable* newVar);
00229         [propget, id(53), helpstring("ﾌﾟﾛﾊﾟﾃｨ VariableNames")] HRESULT VariableNames([out, retval] VARIANT *pVal);
00230         [propget, id(54), helpstring("ﾌﾟﾛﾊﾟﾃｨ Variable")] HRESULT Variable(BSTR bstrName, [out, retval] ICRDVariable **pVal);
00231
00232         [id(60), helpstring("ﾒｿｯﾄﾞ clone")] HRESULT clone([in] BSTR bstrDestName, [out, retval] ICRDTask** pVal);
00233     };
00234
00235     [
00236         object,
00237         uuid(29DD8E3A-87CB-4C35-84C5-5796C6D4EFB2),
00238         dual,
00239         helpstring("ICRDVariable Interface"),
00240         pointer_default(unique)
00241     ]
00242     interface ICRDVariable : IDispatch
00243     {
00244         [propget, id(1), helpstring("ﾌﾟﾛﾊﾟﾃｨ Name")] HRESULT Name([out, retval] BSTR *pVal);
00245         [propget, id(2), helpstring("ﾌﾟﾛﾊﾟﾃｨ Attribute")] HRESULT Attribute([out, retval] long *pVal);
00246         [propput, id(2), helpstring("ﾌﾟﾛﾊﾟﾃｨ Attribute")] HRESULT Attribute([in] long newVal);
00247         [propget, id(3), helpstring("ﾌﾟﾛﾊﾟﾃｨ Help")] HRESULT Help([out, retval] BSTR *pVal);
00248         [propput, id(3), helpstring("ﾌﾟﾛﾊﾟﾃｨ Help")] HRESULT Help([in] BSTR newVal);
00249         [propget, id(4), helpstring("ﾌﾟﾛﾊﾟﾃｨ DateTime")] HRESULT DateTime([out, retval] VARIANT *pVal);
00250         [propput, id(4), helpstring("ﾌﾟﾛﾊﾟﾃｨ DateTime")] HRESULT DateTime([in] VARIANT newVal);
00251         [propget, id(5), helpstring("ﾌﾟﾛﾊﾟﾃｨ Value")] HRESULT Value([out, retval] VARIANT *pVal);
00252         [propput, id(5), helpstring("ﾌﾟﾛﾊﾟﾃｨ Value")] HRESULT Value([in] VARIANT newVal);
00253         [propget, id(6), helpstring("ﾌﾟﾛﾊﾟﾃｨ ID")] HRESULT ID([out, retval] VARIANT *pVal);
00254         [propput, id(6), helpstring("ﾌﾟﾛﾊﾟﾃｨ ID")] HRESULT ID([in] VARIANT newVal);
00255         [propget, id(7), helpstring("ﾌﾟﾛﾊﾟﾃｨ Microsecond")] HRESULT Microsecond([out, retval] long *pVal);
00256         [propput, id(7), helpstring("ﾌﾟﾛﾊﾟﾃｨ Microsecond")] HRESULT Microsecond([in] long newVal);
00257         [propget, id(20), helpstring("ﾌﾟﾛﾊﾟﾃｨ XMLNode"), restricted] HRESULT XMLNode([out, retval] IUnknown **pVal);
00258
00259         [id(60), helpstring("ﾒｿｯﾄﾞ clone")] HRESULT clone([in] BSTR bstrDestName, [out, retval] ICRDVariable** pVal);
00260     };
00261     [
00262         object,
00263         uuid(A422E6C8-AD76-46a2-BA95-6AA8D073A581),
00264         dual,
00265         helpstring("ICRDCommand Interface"),
00266         pointer_default(unique)
00267     ]
00268
00269     interface ICRDCommand : IDispatch
00270     {
00271         [propget, id(1), helpstring("ﾌﾟﾛﾊﾟﾃｨ Name")] HRESULT Name([out, retval] BSTR *pVal);
00272         [propget, id(2), helpstring("ﾌﾟﾛﾊﾟﾃｨ Attribute")] HRESULT Attribute([out, retval] long *pVal);
00273         [propput, id(2), helpstring("ﾌﾟﾛﾊﾟﾃｨ Attribute")] HRESULT Attribute([in] long newVal);
00274         [propget, id(3), helpstring("ﾌﾟﾛﾊﾟﾃｨ Help")] HRESULT Help([out, retval] BSTR *pVal);
00275         [propput, id(3), helpstring("ﾌﾟﾛﾊﾟﾃｨ Help")] HRESULT Help([in] BSTR newVal);
00276         [propget, id(4), helpstring("ﾌﾟﾛﾊﾟﾃｨ State")] HRESULT State([out, retval] long *pVal);
00277         [propput, id(4), helpstring("ﾌﾟﾛﾊﾟﾃｨ State")] HRESULT State([in] long newVal);
00278         [propget, id(5), helpstring("ﾌﾟﾛﾊﾟﾃｨ Timeout")] HRESULT Timeout([out, retval] long *pVal);
00279         [propput, id(5), helpstring("ﾌﾟﾛﾊﾟﾃｨ Timeout")] HRESULT Timeout([in] long newVal);
00280         [propget, id(6), helpstring("ﾌﾟﾛﾊﾟﾃｨ Parameters")] HRESULT Parameters([out, retval] VARIANT *pVal);
00281         [propput, id(6), helpstring("ﾌﾟﾛﾊﾟﾃｨ Parameters")] HRESULT Parameters([in] VARIANT newVal);
00282         [propget, id(7), helpstring("ﾌﾟﾛﾊﾟﾃｨ ID")] HRESULT ID([out, retval] VARIANT *pVal);
00283         [propput, id(7), helpstring("ﾌﾟﾛﾊﾟﾃｨ ID")] HRESULT ID([in] VARIANT newVal);
00284         [propget, id(20), helpstring("ﾌﾟﾛﾊﾟﾃｨ XMLNode"), restricted] HRESULT XMLNode([out, retval] IUnknown **pVal);
00285
00286         [id(60), helpstring("ﾒｿｯﾄﾞ clone")] HRESULT clone([in] BSTR bstrDestName, [out, retval] ICRDCommand** pVal);
00287     };
00288
00289     [
00290         object,
00291         uuid(904C2E9D-085D-478f-9E8F-224F5E1130D4),
00292         dual,
00293         helpstring("ICRDMessage Interface"),
00294         pointer_default(unique)
00295     ]
00296     interface ICRDMessage : IDispatch
00297     {
00298         [propget, id(1), helpstring("ﾌﾟﾛﾊﾟﾃｨ Number")] HRESULT Number([out, retval] long *pVal);
00299         [propget, id(2), helpstring("ﾌﾟﾛﾊﾟﾃｨ DateTime")] HRESULT DateTime([out, retval] VARIANT *pVal);
00300         [propput, id(2), helpstring("ﾌﾟﾛﾊﾟﾃｨ DateTime")] HRESULT DateTime([in] VARIANT newVal);
00301         [propget, id(3), helpstring("ﾌﾟﾛﾊﾟﾃｨ Description")] HRESULT Description([out, retval] BSTR *pVal);
00302         [propput, id(3), helpstring("ﾌﾟﾛﾊﾟﾃｨ Description")] HRESULT Description([in] BSTR newVal);
00303         [propget, id(4), helpstring("ﾌﾟﾛﾊﾟﾃｨ Destination")] HRESULT Destination([out, retval] BSTR *pVal);
00304         [propput, id(4), helpstring("ﾌﾟﾛﾊﾟﾃｨ Destination")] HRESULT Destination([in] BSTR newVal);
00305         [propget, id(5), helpstring("ﾌﾟﾛﾊﾟﾃｨ Source")] HRESULT Source([out, retval] BSTR *pVal);
00306         [propput, id(5), helpstring("ﾌﾟﾛﾊﾟﾃｨ Source")] HRESULT Source([in] BSTR newVal);
00307         [propget, id(6), helpstring("ﾌﾟﾛﾊﾟﾃｨ Value")] HRESULT Value([out, retval] VARIANT *pVal);
00308         [propput, id(6), helpstring("ﾌﾟﾛﾊﾟﾃｨ Value")] HRESULT Value([in] VARIANT newVal);
00309         [propget, id(7), helpstring("ﾌﾟﾛﾊﾟﾃｨ ID")] HRESULT ID([out, retval] VARIANT *pVal);
00310         [propput, id(7), helpstring("ﾌﾟﾛﾊﾟﾃｨ ID")] HRESULT ID([in] VARIANT newVal);
00311         [propget, id(20), helpstring("ﾌﾟﾛﾊﾟﾃｨ XMLNode"), restricted] HRESULT XMLNode([out, retval] IUnknown **pVal);
00312
00313         [id(60), helpstring("ﾒｿｯﾄﾞ clone")] HRESULT clone([in] long lNumber, [out, retval] ICRDMessage** pVal);
00314     };
00315
00316 [
00317     uuid(C7C2D3B2-52ED-45F7-96A5-D8F341E696CF),
00318     version(1.0),
00319     helpstring("CRDMapper 1.0 ﾀｲﾌﾟ ﾗｲﾌﾞﾗﾘ")
00320 ]
00321 library CRDMAPPERLib
00322 {
00323     importlib("stdole32.tlb");
00324     importlib("stdole2.tlb");
00325
00326     [
00327         uuid(1A075796-21FA-4CE6-9CDB-B1683C4B0442),
00328         helpstring("CRDEngine Class")
00329     ]
00330     coclass CRDEngine
00331     {
00332         [default] interface ICRDEngine;
00333     };
00334     [
00335         uuid(2D971601-9F26-4F70-AF6C-A6CE07683CB9),
00336         helpstring("CRDController Class")
00337     ]
00338     coclass CRDController
00339     {
00340         [default] interface ICRDController;
00341     };
00342     [
00343         uuid(E8DE945C-B604-4567-9DD5-D6B6D52A18CC),
00344         helpstring("CRDExtension Class")
00345     ]
00346     coclass CRDExtension
00347     {
00348         [default] interface ICRDExtension;
00349     };
00350     [
00351         uuid(523F3578-4ACE-4447-9D40-EC9BBC38AE0F),
00352         helpstring("CRDFile Class")
00353     ]
00354     coclass CRDFile
00355     {
00356         [default] interface ICRDFile;
00357     };
00358     [
00359         uuid(2B010177-FD27-436B-BEFF-A3A302BEFCA8),
00360         helpstring("CRDRobot Class")
00361     ]
00362     coclass CRDRobot
00363     {
00364         [default] interface ICRDRobot;
00365     };
00366     [
00367         uuid(952CCDAB-6AA8-4007-8225-9C9B704C8C90),
00368         helpstring("CRDTask Class")
00369     ]
00370     coclass CRDTask
00371     {
00372         [default] interface ICRDTask;
00373     };
00374     [
00375         uuid(C39D19C0-3458-4623-9A55-02E5BEB27CD3),
00376         helpstring("CRDVariable Class")
00377     ]
00378     coclass CRDVariable
00379     {
00380         [default] interface ICRDVariable;
00381     };
00382     [
00383         uuid(853BCF88-9A3C-4604-B95C-AB48AF47A33C),
00384         helpstring("CRDCommand Class")
00385     ]
00386     coclass CRDCommand
00387     {
00388         [default] interface ICRDCommand;
00389     };
00390     [
00391         uuid(A8D27938-26D1-4af3-9599-23CF97285A7C),
00392         helpstring("CRDMessage Class")
00393     ]
00394     coclass CRDMessage
00395     {
00396         [default] interface ICRDMessage;
00397     };
00398 };
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDMessage.h Source File

CRDMessage.h

解説を見る。
00001 // CRDMessage.h : CCRDMessage の宣言
00002
00003 #ifndef __CRDMESSAGE_H_
00004 #define __CRDMESSAGE_H_
00005
00006 #include "resource.h"       // メイン シンボル
00007 #include "_CCRDNodeTemplate.h"
00008
00016 class ATL_NO_VTABLE CCRDMessage :
00017     public CComObjectRootEx<CComMultiThreadModel>,
00018     public CComCoClass<CCRDMessage, &CLSID_CRDMessage>,
00019     public ISupportErrorInfo,
00020     public IDispatchImpl<ICRDMessage, &IID_ICRDMessage, &LIBID_CRDMAPPERLib>
00021 {
00022 public:
00023 //DECLARE_REGISTRY_RESOURCEID(IDR_CRDCONTROLLER)
00024
00025 DECLARE_PROTECT_FINAL_CONSTRUCT()
00026
00027 BEGIN_COM_MAP(CCRDMessage)
00028     COM_INTERFACE_ENTRY(ICRDMessage)
00029     COM_INTERFACE_ENTRY(IDispatch)
00030     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00031 END_COM_MAP()
00032
00033 // ISupportsErrorInfo
00034     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00035
00036 // ICRDMessage
00037     STDMETHOD(get_Number)(/*[out, retval]*/ long *pVal);
00038     STDMETHOD(get_DateTime)(/*[out, retval]*/ VARIANT *pVal);
00039     STDMETHOD(put_DateTime)(/*[in]*/ VARIANT newVal);
00040     STDMETHOD(get_Description)(/*[out, retval]*/BSTR *pVal);
00041     STDMETHOD(put_Description)(/*[in]*/BSTR newVal);
00042     STDMETHOD(get_Destination)(/*[out, retval]*/BSTR *pVal);
00043     STDMETHOD(put_Destination)(/*[in]*/BSTR newVal);
00044     STDMETHOD(get_Source)(/*[out, retval]*/BSTR *pVal);
00045     STDMETHOD(put_Source)(/*[in]*/BSTR newVal);
00046     STDMETHOD(get_Value)(/*[out, retval]*/ VARIANT *pVal);
00047     STDMETHOD(put_Value)(/*[in]*/ VARIANT newVal);
00048     STDMETHOD(get_ID)(/*[out, retval]*/ VARIANT *pVal);
00049     STDMETHOD(put_ID)(/*[in]*/ VARIANT newVal);
00050     STDMETHOD(get_XMLNode)(/*[out, retval]*/IUnknown **pVal);
00051     STDMETHOD(clone)(/*[in]*/ long lNumber, /*[out, retval]*/ ICRDMessage** pVal);
00052     HRESULT _Initialize(IXMLDOMNode* pINode);
00053
00054 private:
00055     IXMLDOMNodePtr m_pINode;        //< <code>CRDNode</code> のノード位置を示すオブジェクト
00056
00057 };
00058
00059 #endif //__CRDMESSAGE_H_
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDRobot.h Source File

CRDRobot.h

解説を見る。
00001 // CRDRobot.h : CCRDRobot の宣言
00002
00003 #ifndef __CRDROBOT_H_
00004 #define __CRDROBOT_H_
00005
00006 #include "resource.h"       // メイン シンボル
00007 #include "_CCRDNodeTemplate.h"
00008 #include "CRDVariable.h"
00009
00017 class ATL_NO_VTABLE CCRDRobot :
00018     public _CCRDNodeTemplate<CCRDRobot, &CLSID_CRDRobot, ICRDRobot, &IID_ICRDRobot>
00019 {
00020 // ICRDRobot
00021 public:
00022     STDMETHOD(createVariable)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDVariable** pVal);
00023     STDMETHOD(removeVariable)(/*[in]*/ BSTR bstrName);
00024     STDMETHOD(appendVariable)(/*[in]*/ ICRDVariable* newVar);
00025     STDMETHOD(get_VariableNames)(/*[out, retval]*/ VARIANT *pVal);
00026     STDMETHOD(get_Variable)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDVariable **pVal);
00027
00028     STDMETHOD(clone)(/*[in]*/ BSTR bstrDestName, /*[out, retval]*/ ICRDRobot** pVal);
00029 };
00030
00031 #endif //__CRDROBOT_H_
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDTask.h Source File

CRDTask.h

解説を見る。
00001 // CRDTask.h : CCRDTask の宣言
00002
00003 #ifndef __CRDTASK_H_
00004 #define __CRDTASK_H_
00005
00006 #include "resource.h"       // メイン シンボル
00007 #include "_CCRDNodeTemplate.h"
00008 #include "CRDVariable.h"
00009
00017 class ATL_NO_VTABLE CCRDTask :
00018     public _CCRDNodeTemplate<CCRDTask, &CLSID_CRDTask, ICRDTask, &IID_ICRDTask>
00019 {
00020 // ICRDTask
00021 public:
00022     STDMETHOD(get_FileName)(/*[out, retval]*/ BSTR *pVal);
00023     STDMETHOD(put_FileName)(/*[in]*/ BSTR newVal);
00024
00025     STDMETHOD(createVariable)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDVariable** pVal);
00026     STDMETHOD(removeVariable)(/*[in]*/ BSTR bstrName);
00027     STDMETHOD(appendVariable)(/*[in]*/ ICRDVariable* newVar);
00028     STDMETHOD(get_VariableNames)(/*[out, retval]*/ VARIANT *pVal);
00029     STDMETHOD(get_Variable)(/*[in]*/ BSTR bstrName, /*[out, retval]*/ ICRDVariable **pVal);
00030
00031     STDMETHOD(clone)(/*[in]*/ BSTR bstrDestName, /*[out, retval]*/ ICRDTask** pVal);
00032 };
00033
00034 #endif //__CRDTASK_H_
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDUtility.h Source File

CRDUtility.h

解説を見る。
00001 // CRDUtility.h: CCRDUtility クラスのインターフェイス
00002 //
00004
00005 #if !defined(AFX_CRDUTILITY_H__E2594B17_3537_4843_87B1_520624BBBF77__INCLUDED_)
00006 #define AFX_CRDUTILITY_H__E2594B17_3537_4843_87B1_520624BBBF77__INCLUDED_
00007
00008 #if _MSC_VER > 1000
00009 #pragma once
00010 #endif // _MSC_VER > 1000
00011
00017 class CCRDUtility
00018 {
00019 public:
00020     CCRDUtility();
00021     virtual ~CCRDUtility();
00022
00033     static HRESULT GetNodeAttribute(BSTR bstrName, IXMLDOMNode* pINode, VARTYPE Type, VARIANT* pVal)
00034     {
00035         IXMLDOMNamedNodeMapPtr pINodeMap;
00036
00037         // ノードの持つ属性のリストを取得
00038         HRESULT hr = pINode->get_attributes(&pINodeMap);
00039         if (hr != S_OK) {                   // S_FALSE有り
00040             return E_FAIL;
00041         }
00042
00043         // 指定した名前の属性を取得
00044         IXMLDOMNodePtr pIAttrNode;
00045         hr = pINodeMap->getNamedItem(bstrName, &pIAttrNode);
00046         if (hr != S_OK) {                   // S_FALSE有り
00047             return E_FAIL;
00048         }
00049
00050         return GetSelectTypeValue(pIAttrNode, Type, pVal);
00051     };
00052
00065     static HRESULT GetNodeValue(BSTR bstrName, IXMLDOMNode* pINode, VARTYPE Type, VARIANT* pVal)
00066     {
00067         IXMLDOMNodePtr pIChildNode;
00068         HRESULT hr = GetCRDNode(bstrName, pINode, &pIChildNode);
00069         if(hr == S_FALSE) {     // ノードが見つからないときはエラーを返す．
00070             hr = E_INVALIDARG;
00071         }
00072         if(FAILED(hr)){
00073             return hr;
00074         }
00075
00076         return GetSelectTypeValue(pIChildNode, Type, pVal);
00077
00078     }
00079
00091     static HRESULT SetNodeValue(BSTR bstrName, IXMLDOMNode* pINode, VARIANT newVal)
00092     {
00093         IXMLDOMNodePtr pIChildNode;
00094         HRESULT hr = GetCRDNode(bstrName, pINode, &pIChildNode);
00095         if(hr != S_OK) {
00096             return hr;
00097         }
00098
00099         return pIChildNode->put_nodeTypedValue(newVal);
00100     }
00101
00114     static HRESULT GetNodeVariant(BSTR bstrName, IXMLDOMNode* pINode, VARIANT* pVal)
00115     {
00116         IXMLDOMNodePtr pIChildNode;
00117         HRESULT hr = GetCRDNode(bstrName, pINode, &pIChildNode);
00118         if(FAILED(hr)) {
00119             return hr;
00120         }
00121
00122         return GetVariantNodeValue(pIChildNode, pVal);
00123     }
00124
00136     static HRESULT CreateVariantNode(BSTR bstrName, VARIANT vntVal, IXMLDOMNode* pINode, IXMLDOMElement** pVal)
00137     {
00138         HRESULT hr;
00139
00140
00141         // Variantのルートタグの作成
00142         hr = CreateElement(bstrName, pINode, pVal);
00143         if (FAILED(hr)) {
00144             return hr;
00145         }
00146
00147         // type属性の追加
00148         CComVariant vntType;
00149         hr = VarTypeToTypeAttribute(vntVal.vt, &vntType.bstrVal);
00150         if (FAILED(hr)) {
00151             return hr;
00152         }
00153         vntType.vt = VT_BSTR;
00154
00155         hr = (*pVal)->setAttribute(CRD_ATTR_TYPE, vntType);
00156         if (FAILED(hr)) {
00157             return hr;
00158         }
00159
00160         // Variantのデータ部の作成
00161         IXMLDOMElementPtr pIDataNode;
00162         if (vntVal.vt & VT_ARRAY) {     // 配列のとき
00163             hr = CreateArrayNode(vntVal.parray, *pVal, &pIDataNode);
00164
00165         } else {    // 配列以外のとき
00166             CComBSTR bstrTagName;
00167             hr = VarTypeToTagName(vntVal.vt, &bstrTagName);
00168             if (FAILED(hr)) {
00169                 return hr;
00170             }
00171
00172             // VARIANT型の時は再帰呼び出しをする．
00173             if (vntVal.vt == (VT_VARIANT | VT_BYREF)) {
00174                 hr = CreateVariantNode(bstrTagName, *vntVal.pvarVal, *pVal, &pIDataNode);
00175
00176             // その他のデータ型は値を入れる
00177             } else {
00178                 hr = CreateElement(bstrTagName, *pVal, &pIDataNode);
00179                 if (FAILED(hr)) {
00180                     return hr;
00181                 }
00182                 // データが日付型のときはISO8601形式に変換する．
00183                 if (vntVal.vt == VT_DATE) {
00184                     CComVariant vntDate;
00185                     hr = VariantTimeToISO8601(vntVal.date, &vntDate.bstrVal);
00186                     if (FAILED(hr)) {
00187                         return hr;
00188                     }
00189                     vntDate.vt = VT_BSTR;
00190
00191                     hr = pIDataNode->put_nodeTypedValue(vntDate);
00192
00193                 // BOOL型のときは文字列に変換
00194                 } else if (vntVal.vt == VT_BOOL) {
00195                     CComVariant vntBool;
00196                     vntBool = (vntVal.boolVal == VARIANT_TRUE ? L"true": L"false");
00197                     hr = pIDataNode->put_nodeTypedValue(vntBool);
00198
00199                 } else {
00200                     hr = pIDataNode->put_nodeTypedValue(vntVal);
00201                 }
00202             }
00203         }
00204         if (FAILED(hr)) {
00205             return hr;
00206         }
00207         return (*pVal)->appendChild(pIDataNode, NULL);
00208     }
00209
00219     static HRESULT GetNamedNodeList(BSTR bstrElementName, IXMLDOMNode* pINode, VARIANT* pVal)
00220     {
00221         WCHAR wcsData[MAX_BUFFER];
00222         swprintf(wcsData, XPATH_PREFIX_NODE, bstrElementName);
00223
00224         IXMLDOMNodeListPtr pINodeList;
00225         HRESULT hr = pINode->selectNodes(wcsData, &pINodeList);
00226         if (FAILED(hr)) {
00227             return hr;
00228         }
00229
00230         // 取得できたノード数をチェック
00231         long lLen;
00232         hr = pINodeList->get_length(&lLen);
00233         if (FAILED(hr)) {
00234             return hr;
00235         }
00236
00237         SAFEARRAY* pSa;
00238         SAFEARRAYBOUND bound = {lLen, 0};
00239         pSa = SafeArrayCreate(VT_BSTR, 1, &bound);
00240
00241         BSTR* pbstrArray;
00242         SafeArrayAccessData(pSa, (void **)&pbstrArray);
00243         for (long i= 0; i< lLen; i++ ) {
00244
00245             IXMLDOMNodePtr pIChildNode;
00246             hr = pINodeList->get_item(i, &pIChildNode);
00247             if (FAILED(hr)) {
00248                 SafeArrayDestroy(pSa);
00249                 return hr;
00250             }
00251
00252             // ノードの名前属性を取得
00253             VARIANT vntName;
00254             hr = CCRDUtility::GetNodeAttribute(CRD_ATTR_NAME, pIChildNode, VT_BSTR, &vntName);
00255             if (FAILED(hr)) {
00256                 SafeArrayDestroy(pSa);
00257                 return hr;
00258             }
00259
00260             pbstrArray[i] = SysAllocString(vntName.bstrVal);
00261         }
00262         SafeArrayUnaccessData(pSa);
00263
00264         pVal->vt = VT_ARRAY | VT_BSTR;
00265         pVal->parray = pSa;
00266
00267         return S_OK;
00268
00269     }
00270
00280     static HRESULT GetNumberNodeList(BSTR bstrElementName, IXMLDOMNode* pINode, VARIANT* pVal)
00281     {
00282         WCHAR wcsData[MAX_BUFFER];
00283         swprintf(wcsData, XPATH_PREFIX_NODE, bstrElementName);
00284
00285         IXMLDOMNodeListPtr pINodeList;
00286         HRESULT hr = pINode->selectNodes(wcsData, &pINodeList);
00287         if (FAILED(hr)) {
00288             return hr;
00289         }
00290
00291         // 取得できたノード数をチェック
00292         long lLen;
00293         hr = pINodeList->get_length(&lLen);
00294         if (FAILED(hr)) {
00295             return hr;
00296         }
00297
00298         SAFEARRAY* pSa;
00299         SAFEARRAYBOUND bound = {lLen, 0};
00300         pSa = SafeArrayCreate(VT_I4, 1, &bound);
00301
00302         long* plArray;
00303         SafeArrayAccessData(pSa, (void **)&plArray);
00304         for (long i= 0; i< lLen; i++ ) {
00305
00306             IXMLDOMNodePtr pIChildNode;
00307             hr = pINodeList->get_item(i, &pIChildNode);
00308             if (FAILED(hr)) {
00309                 SafeArrayUnaccessData(pSa);
00310                 SafeArrayDestroy(pSa);
00311                 return hr;
00312             }
00313
00314             // ノードの名前属性を取得
00315             VARIANT vntName;
00316             hr = CCRDUtility::GetNodeAttribute(CRD_ATTR_NUMBER, pIChildNode, VT_I4, &vntName);
00317             if (FAILED(hr)) {
00318                 SafeArrayUnaccessData(pSa);
00319                 SafeArrayDestroy(pSa);
00320                 return hr;
00321             }
00322
00323             plArray[i] = vntName.lVal;
00324         }
00325         SafeArrayUnaccessData(pSa);
00326
00327         pVal->vt = VT_ARRAY | VT_BSTR;
00328         pVal->parray = pSa;
00329
00330         return S_OK;
00331
00332     }
00333
00344     static HRESULT CreateElement(BSTR bstrElementName, IXMLDOMNode* pINode, IXMLDOMElement** pVal)
00345     {
00346         IXMLDOMDocumentPtr pIXMLDoc;
00347         HRESULT hr = pINode->get_ownerDocument(&pIXMLDoc);
00348         if (FAILED(hr)) {
00349             return hr;
00350         }
00351
00352         IXMLDOMNodePtr pIElemNode;
00353         CComVariant vntNodeType(TYPE_NODE_ELEMENT);
00354         hr = pIXMLDoc->createNode(vntNodeType, bstrElementName, CRD_SCHEMA_LOCATION, &pIElemNode);
00355         if (FAILED(hr)) {
00356             return hr;
00357         }
00358
00359         return pIElemNode->QueryInterface(__uuidof(IXMLDOMElement), (void **)(pVal));
00360
00361     }
00362
00377     static HRESULT CreateElementWithNameAttr(BSTR bstrTagName, BSTR bstrName, IXMLDOMNode* pINode, IXMLDOMElement** ppVal)
00378     {
00379         // 名前がないときはエラー
00380         if ((bstrName == NULL) || (SysStringLen(bstrName) <= 0)) {
00381             return E_INVALIDARG;
00382         }
00383 /*
00384         CComVariant vntNodeType;
00385         vntNodeType = TYPE_NODE_ELEMENT;
00386
00387         // Create Controller element
00388         IXMLDOMNodePtr temp;
00389         HRESULT hr = pIXMLDoc->createNode(vntNodeType, bstrTagName, CRD_SCHEMA_LOCATION, &temp);
00390         if (FAILED(hr)) {
00391             return hr;
00392         }
00393         hr = temp->QueryInterface(__uuidof(IXMLDOMElement), (void **)(pVal));
00394         if (FAILED(hr)) {
00395             return hr;
00396         }
00397 */
00398         HRESULT hr = CreateElement(bstrTagName, pINode, ppVal);
00399         // Append name attribute
00400         hr = (*ppVal)->setAttribute(CRD_ATTR_NAME, _variant_t(bstrName));
00401         if (FAILED(hr)) {
00402             return hr;
00403         }
00404
00405         return hr;
00406     }
00407
00422     static HRESULT CreateElementWithNumberAttr(BSTR bstrTagName, long lNumber, IXMLDOMNode* pINode, IXMLDOMElement** ppVal)
00423     {
00424         HRESULT hr = CreateElement(bstrTagName, pINode, ppVal);
00425         if (FAILED(hr)) {
00426             return hr;
00427         }
00428
00429         // Append name attribute
00430         hr = (*ppVal)->setAttribute(CRD_ATTR_NUMBER, _variant_t(lNumber));
00431         if (FAILED(hr)) {
00432             return hr;
00433         }
00434
00435         return hr;
00436     }
00437
00450     static HRESULT AddIndent(IXMLDOMNode* ElementNode, long lLevel, IXMLDOMDocument* pIXMLDoc)
00451     {
00452         HRESULT hr;
00453         long lCnt;
00454         IXMLDOMNodeListPtr pChildNodes;
00455         CComBSTR bstrText;
00456         int i;
00457
00458         if (!ElementNode) {
00459             return E_INVALIDARG;
00460         }
00461
00462         // テキストノードの文字列の作成
00463         bstrText = "\n";
00464         for (i = 0; i <= lLevel; i++) {
00465             bstrText += "\t";
00466         }
00467
00468         // 子ノードリストの取得
00469         hr = ElementNode->get_childNodes(&pChildNodes);
00470         if(FAILED(hr)) {
00471             return hr;
00472         }
00473
00474         // 子ノードの数を取得
00475         hr = pChildNodes->get_length(&lCnt);
00476         if(FAILED(hr)) {
00477             return hr;
00478         }
00479
00480         // 子ノードがない又はテキストノード一つだけのときは終了
00481         if (!lCnt) {
00482             return S_OK;
00483         }
00484
00485         IXMLDOMNodePtr pIDomNode;
00486         IXMLDOMTextPtr pIDomText;
00487         DOMNodeType NowNodeType;
00488         DOMNodeType BeforeNodeType;
00489         // 子ノードを順番に整形する．
00490         for (i = 0; i < lCnt; i++) {
00491             // 子ノードの取得
00492             hr = pChildNodes->get_item(i, &pIDomNode);
00493             if(FAILED(hr)) {
00494                 return hr;
00495             }
00496
00497             // 子ノードがエレメントかどうかチェック
00498             hr = pIDomNode->get_nodeType(&NowNodeType);
00499             if(FAILED(hr)) {
00500                 return hr;
00501             }
00502             if (NowNodeType == TYPE_NODE_ELEMENT) {
00503                 // エレメントの直前にテキストノードがないときは追加
00504                 if (BeforeNodeType != TYPE_NODE_TEXT) {
00505                     hr = pIXMLDoc->createTextNode(bstrText, &pIDomText);
00506                     if(FAILED(hr)) {
00507                         return hr;
00508                     }
00509                     CComVariant temp;
00510                     hr = pIDomNode->get_nodeName(&temp.bstrVal);
00511                     if(FAILED(hr)) {
00512                         return hr;
00513                     }
00514                     temp.vt = VT_BSTR;
00515
00516                     hr = ElementNode->insertBefore(pIDomText, _variant_t(pIDomNode.GetInterfacePtr()), NULL);
00517                     if(FAILED(hr)) {
00518                         return hr;
00519                     }
00520                     lCnt++;
00521                     i++;
00522                 }
00523                 // エレメントの子ノードを整形する．
00524                 hr = AddIndent(pIDomNode, lLevel+1, pIXMLDoc);
00525                 if(FAILED(hr)) {
00526                     return hr;
00527                 }
00528             // テキストのノードは整形する．
00529             } else if (NowNodeType == TYPE_NODE_TEXT) {
00530                 // 唯一の子ノードがテキストの時は即終了（データの場所だから）
00531                 if (lCnt == 1) {
00532                     return S_OK;
00533                 }
00534
00535                 hr = pIDomNode->put_text(bstrText);
00536                 if(FAILED(hr)) {
00537                     return hr;
00538                 }
00539             }
00540
00541             BeforeNodeType = NowNodeType;
00542         }
00543
00544         // 最後尾用のテキストノード文字列作成
00545         bstrText = "\n";
00546         for (i = 0; i < lLevel; i++) {
00547             bstrText += "\t";
00548         }
00549
00550         // 最後尾のテキストノードを上書き
00551         if (NowNodeType == TYPE_NODE_TEXT) {
00552             hr = pIDomNode->put_text(bstrText);
00553             if(FAILED(hr)) {
00554                 return hr;
00555             }
00556
00557         // ノードリストの最後がテキストでなければ追加する．
00558         } else {
00559             hr = pIXMLDoc->createTextNode(bstrText, &pIDomText);
00560             if(FAILED(hr)) {
00561                 return hr;
00562             }
00563             hr = ElementNode->appendChild(pIDomText, NULL);
00564             if(FAILED(hr)) {
00565                 return hr;
00566             }
00567         }
00568
00569         return S_OK;
00570     }
00571
00582     static HRESULT RemoveIndent(IXMLDOMNode* ElementNode)
00583     {
00584         HRESULT hr;
00585         long lCnt;
00586         IXMLDOMNodeListPtr pChildNodes;
00587
00588         if (!ElementNode) {
00589             return E_INVALIDARG;
00590         }
00591
00592         // 子ノードリストの取得
00593         hr = ElementNode->get_childNodes(&pChildNodes);
00594         if(FAILED(hr)) {
00595             return hr;
00596         }
00597
00598         // 子ノードの数を取得
00599         hr = pChildNodes->get_length(&lCnt);
00600         if(FAILED(hr)) {
00601             return hr;
00602         }
00603
00604         // 子ノードがないときは終了
00605         if (!lCnt) {
00606             return S_OK;
00607         }
00608
00609         IXMLDOMNodePtr pIDomNode;
00610         DOMNodeType NodeType;
00611         // 子ノードを順番に整形する．
00612         for (int i = 0; i < lCnt; i++) {
00613             // 子ノードの取得
00614             hr = pChildNodes->get_item(i, &pIDomNode);
00615             if(FAILED(hr)) {
00616                 return hr;
00617             }
00618
00619             // 子ノードがノードタイプのチェック
00620             hr = pIDomNode->get_nodeType(&NodeType);
00621             if(FAILED(hr)) {
00622                 return hr;
00623             }
00624             // エレメントのとき
00625             if (NodeType == TYPE_NODE_ELEMENT) {
00626                 RemoveIndent(pIDomNode);
00627
00628             // テキストのとき
00629             } else if (NodeType == TYPE_NODE_TEXT) {
00630                 // 唯一の子ノードがテキストの時は即終了（データの場所だから）
00631                 if (lCnt == 1) {
00632                     return S_OK;
00633                 }
00634
00635                 hr = ElementNode->removeChild(pIDomNode, NULL);
00636                 if(FAILED(hr)) {
00637                     return hr;
00638                 }
00639                 lCnt--;
00640                 i--;
00641             }
00642         }
00643
00644         return S_OK;
00645     }
00646
00656     static HRESULT VariantTimeToISO8601(DATE vntDate, BSTR* pVal)
00657     {
00658         SYSTEMTIME stTime;
00659         if(!VariantTimeToSystemTime(vntDate, &stTime)){
00660             return E_FAIL;
00661         }
00662
00663         WCHAR wcsData[MAX_BUFFER];
00664         swprintf(wcsData, L"%04hu-%02hu-%02huT%02hu:%02hu:%02hu", stTime.wYear, stTime.wMonth, stTime.wDay, stTime.wHour, stTime.wMinute, stTime.wSecond);
00665
00666         *pVal = SysAllocString(wcsData);
00667         return S_OK;
00668
00669     }
00670
00671 private:
00681     static HRESULT GetValueWithSelectType(BSTR bstrType, IXMLDOMNode* pINode, VARIANT* pVal )
00682     {
00683         CComBSTR bstrElemName;
00684         VARTYPE vt;
00685         CComPtr<IXMLDOMNode> pIValNode;
00686         HRESULT hr = S_OK;
00687         if (!wcscmp(bstrType, CRD_TYPE_BOOL)) {
00688             bstrElemName = CRD_ELEM_BOOL;
00689             vt = VT_BOOL;
00690         } else if(!wcscmp(bstrType, CRD_TYPE_I1)) {
00691             bstrElemName = CRD_ELEM_I1;
00692             vt = VT_I1;
00693         } else if(!wcscmp(bstrType, CRD_TYPE_UI1)) {
00694             bstrElemName = CRD_ELEM_UI1;
00695             vt = VT_UI1;
00696         } else if(!wcscmp(bstrType, CRD_TYPE_I2)) {
00697             bstrElemName = CRD_ELEM_I2;
00698             vt = VT_I2;
00699         } else if(!wcscmp(bstrType, CRD_TYPE_UI2)) {
00700             bstrElemName = CRD_ELEM_UI2;
00701             vt = VT_UI2;
00702         } else if(!wcscmp(bstrType, CRD_TYPE_I4)) {
00703             bstrElemName = CRD_ELEM_I4;
00704             vt = VT_I4;
00705         } else if(!wcscmp(bstrType, CRD_TYPE_UI4)) {
00706             bstrElemName = CRD_ELEM_UI4;
00707             vt = VT_UI4;
00708         } else if(!wcscmp(bstrType, CRD_TYPE_R4)) {
00709             bstrElemName = CRD_ELEM_R4;
00710             vt = VT_R4;
00711         } else if(!wcscmp(bstrType, CRD_TYPE_R8)) {
00712             bstrElemName = CRD_ELEM_R8;
00713             vt = VT_R8;
00714         } else if(!wcscmp(bstrType, CRD_TYPE_DATE)) {
00715             bstrElemName = CRD_ELEM_DATE;
00716             vt = VT_DATE;
00717         } else if(!wcscmp(bstrType, CRD_TYPE_BSTR)) {
00718             bstrElemName = CRD_ELEM_BSTR;
00719             vt = VT_BSTR;
00720         } else if(!wcscmp(bstrType, CRD_TYPE_VARIANT)) {
00721             pVal->vt = VT_VARIANT | VT_BYREF ;
00722             pVal->pvarVal = new VARIANT;
00723             return GetNodeVariant(CRD_ELEM_VARIANT, pINode, pVal->pvarVal);
00724
00725         } else {
00726             return E_INVALIDARG;
00727         }
00728
00729         return GetNodeValue(bstrElemName, pINode, vt, pVal);
00730
00731     }
00732
00741     static HRESULT GetArrayValue(IXMLDOMNode* pINode, VARIANT* pVal)
00742     {
00743         VARTYPE vt;
00744         CComPtr<IXMLDOMNode> pIValNode;
00745         HRESULT hr = S_OK;
00746         long lCnt;
00747         CComVariant vntVal;
00748
00749         // arrayタグの取得
00750         WCHAR wcsData[MAX_BUFFER];
00751         swprintf(wcsData, XPATH_PREFIX_NODE, CRD_ELEM_ARRAY);
00752         IXMLDOMNodePtr pIElemArray;
00753         hr = pINode->selectSingleNode(wcsData, &pIElemArray);
00754         if (hr != S_OK) {                   // S_FALSE有り
00755             return E_FAIL;
00756         }
00757
00758         // type属性をVARTYPEに変換
00759         CComVariant vntType;
00760         hr = GetNodeAttribute(CRD_ATTR_TYPE, pIElemArray, VT_BSTR, &vntType);
00761         if (FAILED(hr)) {
00762             return hr;
00763         }
00764         hr = TypeAttributeToVarType(vntType.bstrVal, &vt);
00765         if (FAILED(hr)) {
00766             return hr;
00767         }
00768
00769         // 配列の次元数の取得
00770         CComVariant vntDimm;
00771         hr = GetNodeValue(CRD_ELEM_DIMENSION, pIElemArray, VT_I4, &vntDimm);
00772         if (FAILED(hr)) {                   // S_FALSE有り
00773             return hr;
00774         }
00775
00776         // Arrayboundの取得
00777         swprintf(wcsData, XPATH_PREFIX_NODE, CRD_ELEM_ARRAYBOUND);
00778         IXMLDOMNodeListPtr pINodeList;
00779         hr = pIElemArray->selectNodes(wcsData, &pINodeList);
00780         if (FAILED(hr)) {
00781             return hr;
00782         }
00783
00784         // Arrayboundの個数のチェック
00785         hr = pINodeList->get_length(&lCnt);
00786         if (FAILED(hr)) {
00787             return hr;
00788         }
00789         if (lCnt > vntDimm.lVal) {
00790             return E_FAIL;
00791         }
00792
00793         // 配列情報の取得
00794         IXMLDOMNodePtr pIDomNode;
00795         SAFEARRAYBOUND *bounds = new SAFEARRAYBOUND[vntDimm.lVal];
00796         if (bounds == NULL) {
00797             return E_OUTOFMEMORY;
00798         }
00799         for (lCnt = 0; lCnt < vntDimm.lVal; lCnt++) {
00800             hr = pINodeList->get_item(lCnt, &pIDomNode);
00801             if (FAILED(hr)) {
00802                 return hr;
00803             }
00804             // Arrayboundタグがないときはデフォルト値を入れる．
00805             if (hr == S_FALSE){
00806                 bounds[lCnt].lLbound = 0;
00807                 bounds[lCnt].cElements = 1;
00808             } else {
00809                 hr = GetNodeValue(CRD_ELEM_LBOUND, pIDomNode, VT_I4, &vntVal);
00810                 if (FAILED(hr)) {
00811                     return hr;
00812                 }
00813                 bounds[lCnt].lLbound = vntVal.lVal;
00814
00815                 hr = GetNodeValue(CRD_ELEM_ELEMENTS, pIDomNode, VT_UI4, &vntVal);
00816                 if (FAILED(hr)) {
00817                     return hr;
00818                 }
00819                 bounds[lCnt].cElements = vntVal.ulVal;
00820             }
00821         }
00822
00823         // ArrayDataの取得
00824         swprintf(wcsData, XPATH_PREFIX_NODE, CRD_ELEM_ARRAYDATA);
00825         IXMLDOMNodePtr pIArrayData;
00826         hr = pIElemArray->selectSingleNode(wcsData, &pIArrayData);
00827         if (hr != S_OK) {                   // S_FALSE有り
00828             return E_FAIL;
00829         }
00830
00831         // SAFEARRAYの作成
00832         SAFEARRAY *psa;
00833         psa = SafeArrayCreate(vt, vntDimm.lVal, bounds);
00834         long *lIndexs = new long [vntDimm.lVal];
00835         if (lIndexs == NULL) {
00836             return E_OUTOFMEMORY;
00837         }
00838
00839         hr = MakeSafeArray(1, lIndexs, pIArrayData, psa);
00840         if (FAILED(hr)) {
00841             return hr;
00842         }
00843
00844         pVal->vt = vt | VT_ARRAY;
00845         pVal->parray = psa;
00846
00847         delete [] lIndexs;
00848         return S_OK;
00849
00850     }
00851
00860     static HRESULT MakeSafeArray(long lDim, long *indexs, IXMLDOMNode* pINode, SAFEARRAY *psa)
00861     {
00862         HRESULT hr;
00863
00864         // 次元数のチェック
00865         int iMaxDim = SafeArrayGetDim(psa);
00866         if (lDim > iMaxDim) {
00867             return E_INVALIDARG;
00868         }
00869
00870         // ノードが無しのときはS_FALSE(SAFEARRAYのデフォルト値）
00871         if (!pINode) {
00872             return S_FALSE;
00873         }
00874
00875         // データタグリストの取得
00876         CComBSTR bstrTagName;
00877         VARTYPE vt;
00878         // 一番下の次元以外は"arrayData"タグ
00879         if (lDim < iMaxDim) {
00880             bstrTagName = CRD_ELEM_ARRAYDATA;
00881         } else {
00882             hr = SafeArrayGetVartype(psa, &vt);
00883             if (FAILED(hr)) {
00884                 return hr;
00885             }
00886             hr = VarTypeToTagName(vt, &bstrTagName);
00887             if (FAILED(hr)) {
00888                 return hr;
00889             }
00890         }
00891         WCHAR wcsData[MAX_BUFFER];
00892         swprintf(wcsData, XPATH_PREFIX_NODE, bstrTagName);
00893         IXMLDOMNodeListPtr pINodeList;
00894         hr = pINode->selectNodes(wcsData, &pINodeList);
00895         if (FAILED(hr)) {
00896             return hr;
00897         }
00898
00899         // 要素数のチェック
00900         long lCnt;
00901         long lLBound;
00902         long lUBound;
00903         hr = pINodeList->get_length(&lCnt);
00904         if (FAILED(hr)) {
00905             return hr;
00906         }
00907         hr = SafeArrayGetLBound(psa, lDim, &lLBound);
00908         if (FAILED(hr)) {
00909             return hr;
00910         }
00911         hr = SafeArrayGetUBound(psa, lDim, &lUBound);
00912         if (FAILED(hr)) {
00913             return hr;
00914         }
00915
00916         if (lCnt > (lUBound - lLBound +1)) {
00917             return E_INVALIDARG;
00918         }
00919
00920         // 子ノードの種類をチェック
00921         // 目的のノードリストが取得した時は除外
00922         if (lCnt == 0) {
00923             IXMLDOMNodePtr pIChild;
00924             hr = pINode->get_firstChild(&pIChild);
00925             if (FAILED(hr)) {
00926                 return hr;
00927             }
00928             // S_OKの時は対象外の子ノードが存在するとする．
00929             if (hr == S_OK) {
00930                 return E_INVALIDARG;
00931             }
00932         }
00933
00934         // データの取得
00935         lCnt = 0;
00936         IXMLDOMNodePtr pIData;
00937         for (long lPos = lLBound; lPos <= lUBound; lPos++) {
00938             hr = pINodeList->get_item(lCnt, &pIData);
00939             if (FAILED(hr)) {
00940                 return hr;
00941             }
00942             // ノードがないときは何もしない．
00943             if (hr == S_FALSE) {
00944                 continue;
00945             }
00946
00947             indexs[lDim-1] = lPos;
00948
00949             // 直下がデータじゃないときは再帰呼び出し
00950             if (!wcscmp(bstrTagName, CRD_ELEM_ARRAYDATA)) {
00951                 hr = MakeSafeArray(lDim+1, indexs, pIData, psa);
00952             } else {
00953                 CComVariant vntValue;
00954                 if (vt == VT_VARIANT) {
00955                     hr = GetVariantNodeValue(pIData, &vntValue);
00956                     if (FAILED(hr)){
00957                         return hr;
00958                     }
00959                     hr = SafeArrayPutElement(psa, indexs, &vntValue);
00960                 } else {
00961                     hr = GetSelectTypeValue(pIData, vt, &vntValue);
00962                     switch (vt) {
00963                     case VT_BOOL:
00964                         hr = SafeArrayPutElement(psa, indexs, &vntValue.boolVal);
00965                         break;
00966
00967                     case VT_I1:
00968                         hr = SafeArrayPutElement(psa, indexs, &vntValue.cVal);
00969                         break;
00970
00971                     case VT_UI1:
00972                         hr = SafeArrayPutElement(psa, indexs, &vntValue.bVal);
00973                         break;
00974
00975                     case VT_I2:
00976                         hr = SafeArrayPutElement(psa, indexs, &vntValue.iVal);
00977                         break;
00978
00979                     case VT_UI2:
00980                         hr = SafeArrayPutElement(psa, indexs, &vntValue.uiVal);
00981                         break;
00982
00983                     case VT_I4:
00984                         hr = SafeArrayPutElement(psa, indexs, &vntValue.lVal);
00985                         break;
00986
00987                     case VT_UI4:
00988                         hr = SafeArrayPutElement(psa, indexs, &vntValue.ulVal);
00989                         break;
00990
00991                     case VT_R4:
00992                         hr = SafeArrayPutElement(psa, indexs, &vntValue.fltVal);
00993                         break;
00994
00995                     case VT_R8:
00996                         hr = SafeArrayPutElement(psa, indexs, &vntValue.dblVal);
00997                         break;
00998
00999                     case VT_DATE:
01000                         hr = SafeArrayPutElement(psa, indexs, &vntValue.date);
01001                         break;
01002
01003                     case VT_BSTR:
01004                         hr = SafeArrayPutElement(psa, indexs, vntValue.bstrVal);
01005                         break;
01006
01007                     default:
01008                         return E_INVALIDARG;
01009                     }
01010                 }
01011             }
01012             lCnt++;
01013         }
01014
01015         return hr;
01016     }
01017
01028     static HRESULT VarTypeToTagName(VARTYPE vt, BSTR* pVal)
01029     {
01030         if (vt & VT_ARRAY) {
01031             *pVal = CRD_ELEM_ARRAY;
01032         } else {
01033             // VT_BYREFを消す．
01034             vt = vt & (~VT_BYREF);
01035             switch (vt) {
01036             case VT_BOOL:
01037                 *pVal = CRD_ELEM_BOOL;
01038                 break;
01039
01040             case VT_I1:
01041                 *pVal = CRD_ELEM_I1;
01042                 break;
01043
01044             case VT_UI1:
01045                 *pVal = CRD_ELEM_UI1;
01046                 break;
01047
01048             case VT_I2:
01049                 *pVal = CRD_ELEM_I2;
01050                 break;
01051
01052             case VT_UI2:
01053                 *pVal = CRD_ELEM_UI2;
01054                 break;
01055
01056             case VT_I4:
01057                 *pVal = CRD_ELEM_I4;
01058                 break;
01059
01060             case VT_UI4:
01061                 *pVal = CRD_ELEM_UI4;
01062                 break;
01063
01064             case VT_R4:
01065                 *pVal = CRD_ELEM_R4;
01066                 break;
01067
01068             case VT_R8:
01069                 *pVal = CRD_ELEM_R8;
01070                 break;
01071
01072             case VT_DATE:
01073                 *pVal = CRD_ELEM_DATE;
01074                 break;
01075
01076             case VT_BSTR:
01077                 *pVal = CRD_ELEM_BSTR;
01078                 break;
01079
01080             case VT_VARIANT:
01081                 *pVal = CRD_ELEM_VARIANT;
01082                 break;
01083
01084             default:
01085                 return E_INVALIDARG;
01086             }
01087         }
01088         return S_OK;
01089     }
01090
01101     static HRESULT TypeAttributeToVarType(BSTR TypeAttr, VARTYPE *vt)
01102     {
01103         if (!wcscmp(TypeAttr, CRD_TYPE_BOOL)) {
01104             *vt = VT_BOOL;
01105         } else if(!wcscmp(TypeAttr, CRD_TYPE_I1)) {
01106             *vt = VT_I1;
01107         } else if(!wcscmp(TypeAttr, CRD_TYPE_UI1)) {
01108             *vt = VT_UI1;
01109         } else if(!wcscmp(TypeAttr, CRD_TYPE_I2)) {
01110             *vt = VT_I2;
01111         } else if(!wcscmp(TypeAttr, CRD_TYPE_UI2)) {
01112             *vt = VT_UI2;
01113         } else if(!wcscmp(TypeAttr, CRD_TYPE_I4)) {
01114             *vt = VT_I4;
01115         } else if(!wcscmp(TypeAttr, CRD_TYPE_UI4)) {
01116             *vt = VT_UI4;
01117         } else if(!wcscmp(TypeAttr, CRD_TYPE_R4)) {
01118             *vt = VT_R4;
01119         } else if(!wcscmp(TypeAttr, CRD_TYPE_R8)) {
01120             *vt = VT_R8;
01121         } else if(!wcscmp(TypeAttr, CRD_TYPE_DATE)) {
01122             *vt = VT_DATE;
01123         } else if(!wcscmp(TypeAttr, CRD_TYPE_BSTR)) {
01124             *vt = VT_BSTR;
01125         } else if(!wcscmp(TypeAttr, CRD_TYPE_VARIANT)) {
01126             *vt = VT_VARIANT;
01127         } else {
01128             return E_INVALIDARG;
01129         }
01130         return S_OK;
01131     }
01132
01143     static HRESULT VarTypeToTypeAttribute(VARTYPE vt, BSTR *pVal)
01144     {
01145         if (vt & VT_ARRAY) {
01146             *pVal = SysAllocString(CRD_TYPE_ARRAY);
01147         } else {
01148             // VT_BYREFを消す．
01149             vt = vt & (~VT_BYREF);
01150             switch (vt) {
01151             case VT_BOOL:
01152                 *pVal = SysAllocString(CRD_TYPE_BOOL);
01153                 break;
01154
01155             case VT_I1:
01156                 *pVal = SysAllocString(CRD_TYPE_I1);
01157                 break;
01158
01159             case VT_UI1:
01160                 *pVal = SysAllocString(CRD_TYPE_UI1);
01161                 break;
01162
01163             case VT_I2:
01164                 *pVal = SysAllocString(CRD_TYPE_I2);
01165                 break;
01166
01167             case VT_UI2:
01168                 *pVal = SysAllocString(CRD_TYPE_UI2);
01169                 break;
01170
01171             case VT_I4:
01172                 *pVal = SysAllocString(CRD_TYPE_I4);
01173                 break;
01174
01175             case VT_UI4:
01176                 *pVal = SysAllocString(CRD_TYPE_UI4);
01177                 break;
01178
01179             case VT_R4:
01180                 *pVal = SysAllocString(CRD_TYPE_R4);
01181                 break;
01182
01183             case VT_R8:
01184                 *pVal = SysAllocString(CRD_TYPE_R8);
01185                 break;
01186
01187             case VT_DATE:
01188                 *pVal = SysAllocString(CRD_TYPE_DATE);
01189                 break;
01190
01191             case VT_BSTR:
01192                 *pVal = SysAllocString(CRD_TYPE_BSTR);
01193                 break;
01194
01195             case VT_VARIANT:
01196                 *pVal = SysAllocString(CRD_TYPE_VARIANT);
01197                 break;
01198
01199             default:
01200                 return E_INVALIDARG;
01201             }
01202         }
01203
01204         return S_OK;
01205     }
01206
01218     static HRESULT GetCRDNode(BSTR bstrName, IXMLDOMNode* pINode, IXMLDOMNode** pVal)
01219     {
01220         WCHAR wcsData[MAX_BUFFER];
01221         swprintf(wcsData, XPATH_PREFIX_NODE, bstrName);
01222         return pINode->selectSingleNode(wcsData, pVal);
01223     }
01224
01234     static HRESULT GetSelectTypeValue(IXMLDOMNode* pINode, VARTYPE Type, VARIANT* pVal)
01235     {
01236         HRESULT hr = S_OK;
01237         CComVariant vntVal;
01238         switch (Type) {
01239         case VT_I1:
01240             hr = pINode->put_dataType(L"i1");
01241             break;
01242
01243         case VT_UI1:
01244             hr = pINode->put_dataType(L"ui1");
01245             break;
01246
01247         case VT_I2:
01248             hr = pINode->put_dataType(L"i2");
01249             break;
01250
01251         case VT_UI2:
01252             hr = pINode->put_dataType(L"ui2");
01253             break;
01254
01255         case VT_I4:
01256             hr = pINode->put_dataType(L"i4");
01257             break;
01258
01259         case VT_UI4:
01260             hr = pINode->put_dataType(L"ui4");
01261             break;
01262
01263         case VT_R4:
01264             hr = pINode->put_dataType(L"r4");
01265             break;
01266
01267         case VT_R8:
01268             hr = pINode->put_dataType(L"r8");
01269             break;
01270
01271         case VT_DATE:
01272             hr = pINode->put_dataType(L"dateTime");
01273             break;
01274
01275         case VT_BSTR:
01276             hr = pINode->put_dataType(L"string");
01277             break;
01278
01279         case VT_BOOL:
01280             // BOOL型だけは直接値を判別します．
01281             hr = pINode->get_nodeTypedValue(&vntVal);
01282             if (FAILED(hr)) {
01283                 return hr;
01284             }
01285             if (vntVal == _variant_t("true") || vntVal == _variant_t("1")){
01286                 pVal->vt = VT_BOOL;
01287                 pVal->boolVal = VARIANT_TRUE;
01288             } else if (vntVal == _variant_t("false") || vntVal == _variant_t("0")) {
01289                 pVal->vt = VT_BOOL;
01290                 pVal->boolVal = VARIANT_FALSE;
01291             } else {
01292                 hr = E_INVALIDARG;
01293             }
01294             return hr;
01295             break;
01296
01297         default:
01298             hr = E_INVALIDARG;
01299         }
01300         if (FAILED(hr)) {
01301             return hr;
01302         }
01303
01304         hr = pINode->get_nodeTypedValue(pVal);
01305         pINode->put_dataType(L"");
01306
01307         return hr;
01308     }
01309
01318     static HRESULT GetVariantNodeValue(IXMLDOMNode* pINode, VARIANT* pVal)
01319     {
01320         CComVariant vntType;
01321         HRESULT hr = GetNodeAttribute(CRD_ATTR_TYPE, pINode, VT_BSTR, &vntType);
01322         if (FAILED(hr)) {
01323             return hr;
01324         }
01325
01326         if (wcscmp(vntType.bstrVal, L"VT_ARRAY")) {
01327             // 配列以外のとき
01328             return GetValueWithSelectType(vntType.bstrVal, pINode, pVal);
01329
01330         } else {
01331             // 配列のとき
01332             return GetArrayValue(pINode, pVal);
01333         }
01334     }
01335
01345     static HRESULT CreateArrayNode(SAFEARRAY* psa, IXMLDOMNode* pINode, IXMLDOMElement** pVal)
01346     {
01347         // arrayタグの作成
01348         HRESULT hr = CreateElement(CRD_ELEM_ARRAY, pINode, pVal);
01349         if (FAILED(hr)) {
01350             return hr;
01351         }
01352
01353         // type属性の作成
01354         VARTYPE vt;
01355         hr = SafeArrayGetVartype(psa, &vt);
01356         if (FAILED(hr)) {
01357             return hr;
01358         }
01359         CComBSTR bstrType;
01360         hr = VarTypeToTypeAttribute(vt, &bstrType);
01361         if (FAILED(hr)) {
01362             return hr;
01363         }
01364         hr = (*pVal)->setAttribute(CRD_ATTR_TYPE, _variant_t(bstrType));
01365         if (FAILED(hr)) {
01366             return hr;
01367         }
01368
01369         // dimentionタグの作成
01370         IXMLDOMElementPtr pIDimension;
01371         hr = CreateElement(CRD_ELEM_DIMENSION, *pVal, &pIDimension);
01372         if (FAILED(hr)) {
01373             return hr;
01374         }
01375         long lDim = SafeArrayGetDim(psa);
01376         hr = pIDimension->put_nodeTypedValue(_variant_t(lDim));
01377         if (FAILED(hr)) {
01378             return hr;
01379         }
01380         hr = (*pVal)->appendChild(pIDimension, NULL);
01381         if (FAILED(hr)) {
01382             return hr;
01383         }
01384
01385         // arrayBoundタグの作成
01386         long lCnt;
01387         IXMLDOMElementPtr pIArrayBound;
01388         IXMLDOMElementPtr pILBount;
01389         IXMLDOMElementPtr pIElements;
01390         for (lCnt = 1; lCnt <= lDim; lCnt++) {
01391             hr = CreateElement(CRD_ELEM_ARRAYBOUND, *pVal, &pIArrayBound);
01392             if (FAILED(hr)) {
01393                 return hr;
01394             }
01395             hr = CreateElement(CRD_ELEM_LBOUND, pIArrayBound, &pILBount);
01396             if (FAILED(hr)) {
01397                 return hr;
01398             }
01399             hr = CreateElement(CRD_ELEM_ELEMENTS, pIArrayBound, &pIElements);
01400             if (FAILED(hr)) {
01401                 return hr;
01402             }
01403
01404             // 配列情報の設定
01405             long lLbound;
01406             long lUbound;
01407             long lElements;
01408             hr = SafeArrayGetLBound(psa, lCnt, &lLbound);
01409             if (FAILED(hr)) {
01410                 return hr;
01411             }
01412             hr = SafeArrayGetUBound(psa, lCnt, &lUbound);
01413             if (FAILED(hr)) {
01414                 return hr;
01415             }
01416             hr = pILBount->put_nodeTypedValue(_variant_t(lLbound));
01417             if (FAILED(hr)) {
01418                 return hr;
01419             }
01420
01421             lElements = lUbound - lLbound +1;
01422             hr = pIElements->put_nodeTypedValue(_variant_t(lElements));
01423             if (FAILED(hr)) {
01424                 return hr;
01425             }
01426             hr = (*pVal)->appendChild(pIArrayBound, NULL);
01427             if (FAILED(hr)) {
01428                 return hr;
01429             }
01430             hr = pIArrayBound->appendChild(pILBount, NULL);
01431             if (FAILED(hr)) {
01432                 return hr;
01433             }
01434             hr = pIArrayBound->appendChild(pIElements, NULL);
01435             if (FAILED(hr)) {
01436                 return hr;
01437             }
01438         }
01439
01440         // arrayDataタグの作成
01441         IXMLDOMElementPtr pIData;
01442         long* lIndexs = new long [lDim];
01443         if (lIndexs == NULL) {
01444             return E_OUTOFMEMORY;
01445         }
01446         hr = CreateArrayDataNode(1, lIndexs, psa, *pVal, &pIData);
01447         if (FAILED(hr)) {
01448             return hr;
01449         }
01450
01451         delete [] lIndexs;
01452         return (*pVal)->appendChild(pIData, NULL);
01453
01454     }
01455
01467     static HRESULT CreateArrayDataNode(long lDim, long *indexs, SAFEARRAY* psa, IXMLDOMNode* pINode, IXMLDOMElement** pVal)
01468     {
01469         // 次元の要素情報の取得
01470         long lLbound;
01471         long lUbound;
01472         HRESULT hr = SafeArrayGetLBound(psa, lDim, &lLbound);
01473         if (FAILED(hr)) {
01474             return hr;
01475         }
01476         hr = SafeArrayGetUBound(psa, lDim, &lUbound);
01477         if (FAILED(hr)) {
01478             return hr;
01479         }
01480
01481         // 配列の最大次元の取得
01482         long lMaxDim = SafeArrayGetDim(psa);
01483
01484         // arrayDataタグの作成
01485         hr = CreateElement(CRD_ELEM_ARRAYDATA, pINode, pVal);
01486         if (FAILED(hr)) {
01487             return hr;
01488         }
01489
01490         IXMLDOMElementPtr pIDataNode;
01491         for (long lCnt = lLbound; lCnt <= lUbound; lCnt++) {
01492             indexs[lDim-1] = lCnt;
01493             // 一番上の次元ならデータの取得
01494             if (lDim == lMaxDim) {
01495                 VARTYPE vt;
01496                 hr = SafeArrayGetVartype(psa, &vt);
01497                 if (FAILED(hr)) {
01498                     return hr;
01499                 }
01500
01501                 CComVariant vntVal;
01502                 switch (vt) {
01503                 case VT_BOOL:
01504                     hr = SafeArrayGetElement(psa, indexs, &vntVal.boolVal);
01505                     break;
01506
01507                 case VT_I1:
01508                     hr = SafeArrayGetElement(psa, indexs, &vntVal.cVal);
01509                     break;
01510
01511                 case VT_UI1:
01512                     hr = SafeArrayGetElement(psa, indexs, &vntVal.bVal);
01513                     break;
01514
01515                 case VT_I2:
01516                     hr = SafeArrayGetElement(psa, indexs, &vntVal.iVal);
01517                     break;
01518
01519                 case VT_UI2:
01520                     hr = SafeArrayGetElement(psa, indexs, &vntVal.uiVal);
01521                     break;
01522
01523                 case VT_I4:
01524                     hr = SafeArrayGetElement(psa, indexs, &vntVal.lVal);
01525                     break;
01526
01527                 case VT_UI4:
01528                     hr = SafeArrayGetElement(psa, indexs, &vntVal.ulVal);
01529                     break;
01530
01531                 case VT_R4:
01532                     hr = SafeArrayGetElement(psa, indexs, &vntVal.fltVal);
01533                     break;
01534
01535                 case VT_R8:
01536                     hr = SafeArrayGetElement(psa, indexs, &vntVal.dblVal);
01537                     break;
01538
01539                 case VT_DATE:
01540                     hr = SafeArrayGetElement(psa, indexs, &vntVal.date);
01541                     break;
01542
01543                 case VT_BSTR:
01544                     hr = SafeArrayGetElement(psa, indexs, &vntVal.bstrVal);
01545                     break;
01546
01547                 case VT_VARIANT:
01548                     hr = SafeArrayGetElement(psa, indexs, &vntVal);
01549                     break;
01550
01551                 default:
01552                     return E_INVALIDARG;
01553                 }
01554                 if (FAILED(hr)) {
01555                     return hr;
01556                 }
01557                 vntVal.vt = vt;
01558
01559                 // データ部のノード作成
01560                 if (vt == VT_VARIANT) {
01561                     hr = CreateVariantNode(CRD_ELEM_VARIANT, vntVal, *pVal, &pIDataNode);
01562                 } else {
01563                     CComBSTR bstrTagName;
01564                     hr = VarTypeToTagName(vt, &bstrTagName);
01565                     if (FAILED(hr)) {
01566                         return hr;
01567                     }
01568                     hr = CreateElement(bstrTagName, pINode, &pIDataNode);
01569                     if (FAILED(hr)) {
01570                         return hr;
01571                     }
01572
01573                     // 日付型のときは変換する．
01574                     if (vt == VT_DATE) {
01575                         CComVariant vntDate;
01576                         vntDate.vt = VT_BSTR;
01577                         hr = VariantTimeToISO8601(vntVal.date, &vntDate.bstrVal);
01578                         if (FAILED(hr)) {
01579                             return hr;
01580                         }
01581                         hr = pIDataNode->put_nodeTypedValue(vntDate);
01582                     } else if (vt == VT_BOOL) {
01583                         CComVariant vntBool;
01584                         vntBool = (vntVal.boolVal == VARIANT_TRUE ? L"true": L"false");
01585                         hr = pIDataNode->put_nodeTypedValue(vntBool);
01586                     } else {
01587                         hr = pIDataNode->put_nodeTypedValue(vntVal);
01588                     }
01589                 }
01590
01591             // 一番上の次元でないなら次のarrayDataを作成する．
01592             } else {
01593                 hr = CreateArrayDataNode(lDim+1, indexs, psa, *pVal, &pIDataNode);
01594             }
01595             if (FAILED(hr)) {
01596                 return hr;
01597             }
01598             hr = (*pVal)->appendChild(pIDataNode, NULL);
01599             if (FAILED(hr)) {
01600                 return hr;
01601             }
01602         }
01603         return hr;
01604     }
01605 };
01606
01607 #endif // !defined(AFX_CRDUTILITY_H__E2594B17_3537_4843_87B1_520624BBBF77__INCLUDED_)
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


CRDVariable.h Source File

CRDVariable.h

解説を見る。
00001 // CRDVariable.h : CCRDVariable の宣言
00002
00003 #ifndef __CRDVARIABLE_H_
00004 #define __CRDVARIABLE_H_
00005
00006 #include "resource.h"       // メイン シンボル
00007 #include "_CCRDNodeTemplate.h"
00008
00016 class ATL_NO_VTABLE CCRDVariable :
00017     public _CCRDNodeTemplate<CCRDVariable, &CLSID_CRDVariable, ICRDVariable, &IID_ICRDVariable>
00018 {
00019 // ICRDVariable
00020 public:
00021     STDMETHOD(get_DateTime)(/*[out, retval]*/ VARIANT *pVal);
00022     STDMETHOD(put_DateTime)(/*[in]*/ VARIANT newVal);
00023     STDMETHOD(get_Value)(/*[out, retval]*/ VARIANT *pVal);
00024     STDMETHOD(put_Value)(/*[in]*/ VARIANT newVal);
00025     STDMETHOD(get_Microsecond)(/*[out, retval]*/ long *pVal);
00026     STDMETHOD(put_Microsecond)(/*[out, retval]*/ long newVal);
00027
00028     STDMETHOD(clone)(/*[in]*/ BSTR bstrDestName, /*[out, retval]*/ ICRDVariable** pVal);
00029 };
00030
00031 #endif //__CRDVARIABLE_H_
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


Graph Legend

グラフの凡例

このページでは、doxygen で生成されたグラフをどのようにみたらよいかを説明します。

次の例を考えてみます。

/*! 省略されて見えないクラス */
class Invisible { };

/*! 省略されたクラス(継承関係は隠されている) */
class Truncated : public Invisible { };

/* doxygen コメントによるドキュメントがないクラス */
class Undocumented { };

/*! public で継承されたクラス */
class PublicBase : public Truncated { };

/*! protected で継承されたクラス */
class ProtectedBase { };

/*! private で継承されたクラス */
class PrivateBase { };

/*! 継承されたクラスで使われているクラス */
class Used { };

/*! 複数のクラスを継承している上位クラス */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
{
  private:
    Used *m_usedClass;
};
設定ファイル中で、タグ MAX_DOT_GRAPH_HEIGHT が 200 にセットされた場合、次のようなグラフとなります。

上のグラフ内のボックスには次のような意味があります。

  • 黒く塗りつぶされたボックスは、このグラフに対応する構造体やクラスを表します。
  • 黒枠のボックスはドキュメントがある構造体やクラスを表します。
  • 灰色の枠のボックスはドキュメントがない構造体やクラスを表します。
  • 赤枠のボックスはドキュメントがある構造体やクラスを表しますが、指定されたサイズに収まらないために継承・包含関係をすべて図示することができなかったことを示します。
矢印には次のような意味があります。
  • 青い矢印は二つのクラス間の public 継承関係を示します。
  • 緑の矢印は protected 継承関係を示します。
  • 赤の矢印は private 継承関係を示します。
  • 紫の破線矢印は、そのクラスが他のクラスに含まれていたり、利用されていることを示します。また、矢印が指しているクラスや構造体をどの変数でアクセスできるかを矢印のラベルとして示しています。
Generated on Thu Jan 27 18:50:16 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICRDCommand メンバ一覧

これは全メンバの一覧です。ICRDCommand継承メンバも含んでいます。
Attribute([out, retval] long *pVal) | ICRDCommand
Attribute([in] long newVal) | ICRDCommand
clone([in] BSTR bstrDestName,[out, retval] ICRDCommand **pVal) | ICRDCommand
Help([out, retval] BSTR *pVal) | ICRDCommand
Help([in] BSTR newVal) | ICRDCommand
ID([out, retval] VARIANT *pVal) | ICRDCommand
ID([in] VARIANT newVal) | ICRDCommand
Name([out, retval] BSTR *pVal) | ICRDCommand
Parameters([out, retval] VARIANT *pVal) | ICRDCommand
Parameters([in] VARIANT newVal) | ICRDCommand
State([out, retval] long *pVal) | ICRDCommand
State([in] long newVal) | ICRDCommand
Timeout([out, retval] long *pVal) | ICRDCommand
Timeout([in] long newVal) | ICRDCommand
XMLNode([out, retval] IUnknown **pVal) | ICRDCommand
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICRDController メンバ一覧

これは全メンバの一覧です。ICRDController継承メンバも含んでいます。
appendCommand([in] ICRDCommand *newCmd) | ICRDController
appendExtension([in] ICRDExtension *newExt) | ICRDController
appendFile([in] ICRDFile *newFile) | ICRDController
appendMessage([in] ICRDMessage *newMsg) | ICRDController
appendRobot([in] ICRDRobot *newRobot) | ICRDController
appendTask([in] ICRDTask *newTask) | ICRDController
appendVariable([in] ICRDVariable *newVar) | ICRDController
Attribute([out, retval] long *pVal) | ICRDController
Attribute([in] long newVal) | ICRDController
clone([in] BSTR bstrDestName,[out, retval] ICRDController **pVal) | ICRDController
Command(BSTR bstrName,[out, retval] ICRDCommand **pVal) | ICRDController
CommandNames([out, retval] VARIANT *pVal) | ICRDController
createCommand([in] BSTR bstrName,[out, retval] ICRDCommand **pVal) | ICRDController
createExtension([in] BSTR bstrName,[out, retval] ICRDExtension **pVal) | ICRDController
createFile([in] BSTR bstrName,[out, retval] ICRDFile **pVal) | ICRDController
createMessage([in] long lNumber,[out, retval] ICRDMessage **pVal) | ICRDController
createRobot([in] BSTR bstrName,[out, retval] ICRDRobot **pVal) | ICRDController
createTask([in] BSTR bstrName,[out, retval] ICRDTask **pVal) | ICRDController
createVariable([in] BSTR bstrName,[out, retval] ICRDVariable **pVal) | ICRDController
Extension(BSTR bstrName,[out, retval] ICRDExtension **pVal) | ICRDController
ExtensionNames([out, retval] VARIANT *pVal) | ICRDController
File(BSTR bstrName,[out, retval] ICRDFile **pVal) | ICRDController
FileNames([out, retval] VARIANT *pVal) | ICRDController
Help([out, retval] BSTR *pVal) | ICRDController
Help([in] BSTR newVal) | ICRDController
ID([out, retval] VARIANT *pVal) | ICRDController
ID([in] VARIANT newVal) | ICRDController
Message(long lNumber,[out, retval] ICRDMessage **pVal) | ICRDController
MessageNumbers([out, retval] VARIANT *pVal) | ICRDController
Name([out, retval] BSTR *pVal) | ICRDController
removeCommand([in] BSTR bstrName) | ICRDController
removeExtension([in] BSTR bstrName) | ICRDController
removeFile([in] BSTR bstrName) | ICRDController
removeMessage([in] long lNumber) | ICRDController
removeRobot([in] BSTR bstrName) | ICRDController
removeTask([in] BSTR bstrName) | ICRDController
removeVariable([in] BSTR bstrName) | ICRDController
Robot(BSTR bstrName,[out, retval] ICRDRobot **pVal) | ICRDController
RobotNames([out, retval] VARIANT *pVal) | ICRDController
Task(BSTR bstrName,[out, retval] ICRDTask **pVal) | ICRDController
TaskNames([out, retval] VARIANT *pVal) | ICRDController
Variable(BSTR bstrName,[out, retval] ICRDVariable **pVal) | ICRDController
VariableNames([out, retval] VARIANT *pVal) | ICRDController
XMLNode([out, retval] IUnknown **pVal) | ICRDController
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICRDEngine メンバ一覧

これは全メンバの一覧です。ICRDEngine継承メンバも含んでいます。
appendController([in] ICRDController *newCtrl) | ICRDEngine
Controller([in] BSTR bstrName,[out, retval] ICRDController **pVal) | ICRDEngine
ControllerNames([out, retval] VARIANT *pVal) | ICRDEngine
createController([in] BSTR bstrName,[out, retval] ICRDController **pVal) | ICRDEngine
CreateDocument() | ICRDEngine
Help([out, retval] BSTR *pVal) | ICRDEngine
Help([in] BSTR newVal) | ICRDEngine
load([in] BSTR bstrFileName) | ICRDEngine
removeController([in] BSTR bstrName) | ICRDEngine
save() | ICRDEngine
saveAs([in, defaultvalue("")] BSTR bstrFileName) | ICRDEngine
Version([out, retval] BSTR *pVal) | ICRDEngine
Version([in] BSTR newVal) | ICRDEngine
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICRDExtension メンバ一覧

これは全メンバの一覧です。ICRDExtension継承メンバも含んでいます。
appendVariable([in] ICRDVariable *newVar) | ICRDExtension
Attribute([out, retval] long *pVal) | ICRDExtension
Attribute([in] long newVal) | ICRDExtension
clone([in] BSTR bstrDestName,[out, retval] ICRDExtension **pVal) | ICRDExtension
createVariable([in] BSTR bstrName,[out, retval] ICRDVariable **pVal) | ICRDExtension
Help([out, retval] BSTR *pVal) | ICRDExtension
Help([in] BSTR newVal) | ICRDExtension
ID([out, retval] VARIANT *pVal) | ICRDExtension
ID([in] VARIANT newVal) | ICRDExtension
Name([out, retval] BSTR *pVal) | ICRDExtension
removeVariable([in] BSTR bstrName) | ICRDExtension
Variable(BSTR bstrName,[out, retval] ICRDVariable **pVal) | ICRDExtension
VariableNames([out, retval] VARIANT *pVal) | ICRDExtension
XMLNode([out, retval] IUnknown **pVal) | ICRDExtension
Generated on Thu Jan 27 18:50:13 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICRDFile メンバ一覧

これは全メンバの一覧です。ICRDFile継承メンバも含んでいます。
appendFile([in] ICRDFile *newFile) | ICRDFile
appendVariable([in] ICRDVariable *newVar) | ICRDFile
Attribute([out, retval] long *pVal) | ICRDFile
Attribute([in] long newVal) | ICRDFile
clone([in] BSTR bstrDestName,[out, retval] ICRDFile **pVal) | ICRDFile
createFile([in] BSTR bstrName,[out, retval] ICRDFile **pVal) | ICRDFile
createVariable([in] BSTR bstrName,[out, retval] ICRDVariable **pVal) | ICRDFile
DateCreated([out, retval] VARIANT *pVal) | ICRDFile
DateCreated([in] VARIANT newVal) | ICRDFile
DateLastAccessed([out, retval] VARIANT *pVal) | ICRDFile
DateLastAccessed([in] VARIANT newVal) | ICRDFile
DateLastModified([out, retval] VARIANT *pVal) | ICRDFile
DateLastModified([in] VARIANT newVal) | ICRDFile
File(BSTR bstrName,[out, retval] ICRDFile **pVal) | ICRDFile
FileNames([out, retval] VARIANT *pVal) | ICRDFile
Help([out, retval] BSTR *pVal) | ICRDFile
Help([in] BSTR newVal) | ICRDFile
ID([out, retval] VARIANT *pVal) | ICRDFile
ID([in] VARIANT newVal) | ICRDFile
Name([out, retval] BSTR *pVal) | ICRDFile
Path([out, retval] BSTR *pVal) | ICRDFile
Path([in] BSTR newVal) | ICRDFile
removeFile([in] BSTR bstrName) | ICRDFile
removeVariable([in] BSTR bstrName) | ICRDFile
Size([out, retval] long *pVal) | ICRDFile
Size([in] long newVal) | ICRDFile
Type([out, retval] BSTR *pVal) | ICRDFile
Type([in] BSTR newVal) | ICRDFile
Value([out, retval] VARIANT *pVal) | ICRDFile
Value([in] VARIANT newVal) | ICRDFile
Variable(BSTR bstrName,[out, retval] ICRDVariable **pVal) | ICRDFile
VariableNames([out, retval] VARIANT *pVal) | ICRDFile
XMLNode([out, retval] IUnknown **pVal) | ICRDFile
Generated on Thu Jan 27 18:50:14 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICRDMessage メンバ一覧

これは全メンバの一覧です。ICRDMessage継承メンバも含んでいます。
clone([in] long lNumber,[out, retval] ICRDMessage **pVal) | ICRDMessage
DateTime([out, retval] VARIANT *pVal) | ICRDMessage
DateTime([in] VARIANT newVal) | ICRDMessage
Description([out, retval] BSTR *pVal) | ICRDMessage
Description([in] BSTR newVal) | ICRDMessage
Destination([out, retval] BSTR *pVal) | ICRDMessage
Destination([in] BSTR newVal) | ICRDMessage
ID([out, retval] VARIANT *pVal) | ICRDMessage
ID([in] VARIANT newVal) | ICRDMessage
Number([out, retval] long *pVal) | ICRDMessage
Source([out, retval] BSTR *pVal) | ICRDMessage
Source([in] BSTR newVal) | ICRDMessage
Value([out, retval] VARIANT *pVal) | ICRDMessage
Value([in] VARIANT newVal) | ICRDMessage
XMLNode([out, retval] IUnknown **pVal) | ICRDMessage
Generated on Thu Jan 27 18:50:14 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICRDRobot メンバ一覧

これは全メンバの一覧です。ICRDRobot継承メンバも含んでいます。
appendVariable([in] ICRDVariable *newVar) | ICRDRobot
Attribute([out, retval] long *pVal) | ICRDRobot
Attribute([in] long newVal) | ICRDRobot
clone([in] BSTR bstrDestName,[out, retval] ICRDRobot **pVal) | ICRDRobot
createVariable([in] BSTR bstrName,[out, retval] ICRDVariable **pVal) | ICRDRobot
Help([out, retval] BSTR *pVal) | ICRDRobot
Help([in] BSTR newVal) | ICRDRobot
ID([out, retval] VARIANT *pVal) | ICRDRobot
ID([in] VARIANT newVal) | ICRDRobot
Name([out, retval] BSTR *pVal) | ICRDRobot
removeVariable([in] BSTR bstrName) | ICRDRobot
Variable(BSTR bstrName,[out, retval] ICRDVariable **pVal) | ICRDRobot
VariableNames([out, retval] VARIANT *pVal) | ICRDRobot
XMLNode([out, retval] IUnknown **pVal) | ICRDRobot
Generated on Thu Jan 27 18:50:14 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICRDTask メンバ一覧

これは全メンバの一覧です。ICRDTask継承メンバも含んでいます。
appendVariable([in] ICRDVariable *newVar) | ICRDTask
Attribute([out, retval] long *pVal) | ICRDTask
Attribute([in] long newVal) | ICRDTask
clone([in] BSTR bstrDestName,[out, retval] ICRDTask **pVal) | ICRDTask
createVariable([in] BSTR bstrName,[out, retval] ICRDVariable **pVal) | ICRDTask
FileName([out, retval] BSTR *pVal) | ICRDTask
FileName([in] BSTR newVal) | ICRDTask
Help([out, retval] BSTR *pVal) | ICRDTask
Help([in] BSTR newVal) | ICRDTask
ID([out, retval] VARIANT *pVal) | ICRDTask
ID([in] VARIANT newVal) | ICRDTask
Name([out, retval] BSTR *pVal) | ICRDTask
removeVariable([in] BSTR bstrName) | ICRDTask
Variable(BSTR bstrName,[out, retval] ICRDVariable **pVal) | ICRDTask
VariableNames([out, retval] VARIANT *pVal) | ICRDTask
XMLNode([out, retval] IUnknown **pVal) | ICRDTask
Generated on Thu Jan 27 18:50:14 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICRDVariable メンバ一覧

これは全メンバの一覧です。ICRDVariable継承メンバも含んでいます。
Attribute([out, retval] long *pVal) | ICRDVariable
Attribute([in] long newVal) | ICRDVariable
clone([in] BSTR bstrDestName,[out, retval] ICRDVariable **pVal) | ICRDVariable
DateTime([out, retval] VARIANT *pVal) | ICRDVariable
DateTime([in] VARIANT newVal) | ICRDVariable
Help([out, retval] BSTR *pVal) | ICRDVariable
Help([in] BSTR newVal) | ICRDVariable
ID([out, retval] VARIANT *pVal) | ICRDVariable
ID([in] VARIANT newVal) | ICRDVariable
Microsecond([out, retval] long *pVal) | ICRDVariable
Microsecond([in] long newVal) | ICRDVariable
Name([out, retval] BSTR *pVal) | ICRDVariable
Value([out, retval] VARIANT *pVal) | ICRDVariable
Value([in] VARIANT newVal) | ICRDVariable
XMLNode([out, retval] IUnknown **pVal) | ICRDVariable
Generated on Thu Jan 27 18:50:14 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


resource.h Source File

resource.h

解説を見る。
00001 //{{NO_DEPENDENCIES}}
00002 // Microsoft Developer Studio generated include file.
00003 // Used by CRDMapper.rc
00004 //
00005 #define IDS_PROJNAME                    100
00006 #define IDR_CRDENGINE                   101
00007 #define IDR_CRDCONTROLLER               102
00008 #define IDR_CRDEXTENSION                104
00009 #define IDR_CRDFILE                     106
00010 #define IDR_CRDROBOT                    107
00011 #define IDR_CRDTASK                     108
00012 #define IDR_CRDVARIABLE                 109
00013
00014 // Next default values for new objects
00015 //
00016 #ifdef APSTUDIO_INVOKED
00017 #ifndef APSTUDIO_READONLY_SYMBOLS
00018 #define _APS_NEXT_RESOURCE_VALUE        201
00019 #define _APS_NEXT_COMMAND_VALUE         32768
00020 #define _APS_NEXT_CONTROL_VALUE         201
00021 #define _APS_NEXT_SYMED_VALUE           110
00022 #endif
00023 #endif
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


StdAfx.h Source File

StdAfx.h

解説を見る。
00001 // stdafx.h : 標準のシステム インクルード ファイル、
00002 //            または参照回数が多く、かつあまり変更されない
00003 //            プロジェクト専用のインクルード ファイルを記述します。
00004
00005 #if !defined(AFX_STDAFX_H__1D245D43_9AC1_4B7B_82FC_36A4742EA6D8__INCLUDED_)
00006 #define AFX_STDAFX_H__1D245D43_9AC1_4B7B_82FC_36A4742EA6D8__INCLUDED_
00007
00008 #if _MSC_VER > 1000
00009 #pragma once
00010 #endif // _MSC_VER > 1000
00011
00012 #define STRICT
00013 #ifndef _WIN32_WINNT
00014 #define _WIN32_WINNT 0x0400
00015 #endif
00016 #define _ATL_APARTMENT_THREADED
00017
00018 #include <atlbase.h>
00019 // CComModule クラスから派生したクラスを使用して、オーバーライドする場合
00020 // _Module の名前は変更しないでください。
00021 extern CComModule _Module;
00022 #include <atlcom.h>
00023
00024 #import <msxml4.dll> named_guids raw_interfaces_only
00025 //#include "msxml2.h"
00026 using namespace MSXML2;
00027
00028 #include <stdio.h>
00029 #include "CRD.h"
00030 #include "CRDUtility.h"
00031
00032 //{{AFX_INSERT_LOCATION}}
00033 // Microsoft Visual C++ は前行の直前に追加の宣言を挿入します。
00034
00035 #endif // !defined(AFX_STDAFX_H__1D245D43_9AC1_4B7B_82FC_36A4742EA6D8__INCLUDED)
Generated on Thu Jan 27 18:49:59 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_IID メンバ一覧

これは全メンバの一覧です。_IID継承メンバも含んでいます。
c | _IID
s1 | _IID
s2 | _IID
x | _IID
Generated on Thu Jan 27 18:50:09 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_MIDL_PROC_FORMAT_STRING メンバ一覧

これは全メンバの一覧です。_MIDL_PROC_FORMAT_STRING継承メンバも含んでいます。
Format | _MIDL_PROC_FORMAT_STRING
Pad | _MIDL_PROC_FORMAT_STRING
Generated on Thu Jan 27 18:50:09 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_MIDL_TYPE_FORMAT_STRING メンバ一覧

これは全メンバの一覧です。_MIDL_TYPE_FORMAT_STRING継承メンバも含んでいます。
Format | _MIDL_TYPE_FORMAT_STRING
Pad | _MIDL_TYPE_FORMAT_STRING
Generated on Thu Jan 27 18:50:09 2005 for CRDMapper Project by doxygen 1.2.18, © 1997-2001