メインページ

GwCaopCorba Project ドキュメント

1.0

Generated on Mon Oct 25 19:42:48 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


File Index

GwCaopCorba Project ファイル一覧

これはファイル一覧です。
CaopCorCommand.cpp | CaopCorCommandクラスの実装
CaopCorCommand.h [コード] | CaopCorCommandクラスの宣言
CaopCorController.cpp |
CaopCorController.h [コード] | CaopCorControllerクラスの宣言
CaopCorExtension.cpp |
CaopCorExtension.h [コード] | CaopCorExtensionクラスの宣言
CaopCorFile.cpp |
CaopCorFile.h [コード] | CaopCorFileクラスの宣言
CaopCorMessage.cpp |
CaopCorMessage.h [コード] | CaopCorMessageクラスの宣言
CaopCorRobot.cpp |
CaopCorRobot.h [コード] | CaopCorRobotクラスの宣言
CaopCorTask.cpp |
CaopCorTask.h [コード] | CaopCorTaskクラスの宣言
CaopCorVariable.cpp |
CaopCorVariable.h [コード] | CaopCorVariableクラスの宣言
CaoProvCorba.idl [コード] | CORBA用CAO Provider インタフェース定義ファイル
CorbaServer.cpp |
CorbaServer.h [コード] | CorbaServerクラスの宣言
dlldata.c |
EventSink.cpp |
EventSink.h [コード] | EventSinkクラスの宣言
GwCaopCorba.cpp |
GwCaopCorba.h [コード] |
GwCaopCorba.idl [コード] |
GwCaopCorba_i.c |
GwCaopCorba_p.c |
resource.h [コード] |
StdAfx.cpp |
StdAfx.h [コード] |
Generated on Mon Oct 25 19:42:48 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorCommand.cpp File Reference

CaopCorCommand.cpp の解説

CaopCorCommandクラスの実装. [詳細]

#include "stdafx.h"
#include "CaopCorCommand.h"

CaopCorCommand.cppのインクルード依存関係図

Include dependency graph

解説

CaopCorCommandクラスの実装.

バージョン:
1.0
日付:
2003/10/25
作者:
DENSO WAVE
Generated on Mon Oct 25 19:42:49 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorCommand.h File Reference

CaopCorCommand.h の解説

CaopCorCommandクラスの宣言. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaopCorCommand
GwCaopCorbaのCommandクラス. [詳細]

マクロ定義

#define | AFX_CAOPCORCOMMAND_H__44DBF0D9_5C2F_47DC_B061_6E04F69BF643__INCLUDED_

解説

CaopCorCommandクラスの宣言.

バージョン:
1.0
日付:
2003/10/25
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CAOPCORCOMMAND_H__44DBF0D9_5C2F_47DC_B061_6E04F69BF643__INCLUDED_

Generated on Mon Oct 25 19:42:49 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorController.cpp File Reference

CaopCorController.cpp の解説

#include "stdafx.h"
#include "CaopCorController.h"
#include "CaopCorExtension.h"
#include "CaopCorFile.h"
#include "CaopCorTask.h"
#include "CaopCorRobot.h"
#include "CaopCorVariable.h"
#include "CaopCorCommand.h"

CaopCorController.cppのインクルード依存関係図

Include dependency graph
Generated on Mon Oct 25 19:42:50 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorController.h File Reference

CaopCorController.h の解説

CaopCorControllerクラスの宣言. [詳細]

#include "EventSink.h"

CaopCorController.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaopCorController
GwCaopCorbaのControllerクラス. [詳細]

マクロ定義

#define | AFX_CAOPCORCONTROLLER_H__7181812F_E80C_4E60_B640_82A6BF49AC48__INCLUDED_

解説

CaopCorControllerクラスの宣言.

バージョン:
1.0
日付:
2003/10/25
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CAOPCORCONTROLLER_H__7181812F_E80C_4E60_B640_82A6BF49AC48__INCLUDED_

Generated on Mon Oct 25 19:42:50 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorExtension.cpp File Reference

CaopCorExtension.cpp の解説

#include "stdafx.h"
#include "CaopCorExtension.h"
#include "CaopCorVariable.h"

CaopCorExtension.cppのインクルード依存関係図

Include dependency graph
Generated on Mon Oct 25 19:42:51 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorExtension.h File Reference

CaopCorExtension.h の解説

CaopCorExtensionクラスの宣言. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaopCorExtension
GwCaopCorbaのExtensionクラス. [詳細]

マクロ定義

#define | AFX_CAOPCOREXTENSION_H__1D732A34_6570_4E2D_B417_CB280DBF4F60__INCLUDED_

解説

CaopCorExtensionクラスの宣言.

バージョン:
1.0
日付:
2003/10/25
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CAOPCOREXTENSION_H__1D732A34_6570_4E2D_B417_CB280DBF4F60__INCLUDED_

Generated on Mon Oct 25 19:42:51 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorFile.cpp File Reference

CaopCorFile.cpp の解説

#include "stdafx.h"
#include "CaopCorFile.h"
#include "CaopCorVariable.h"

CaopCorFile.cppのインクルード依存関係図

Include dependency graph
Generated on Mon Oct 25 19:42:51 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorFile.h File Reference

CaopCorFile.h の解説

CaopCorFileクラスの宣言. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaopCorFile
GwCaopCorbaのFileクラス. [詳細]

マクロ定義

#define | AFX_CAOPCORFILE_H__7BBD0652_BD7E_46F5_9BEE_11DFE9E2CAAF__INCLUDED_

解説

CaopCorFileクラスの宣言.

バージョン:
1.0
日付:
2003/10/25
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CAOPCORFILE_H__7BBD0652_BD7E_46F5_9BEE_11DFE9E2CAAF__INCLUDED_

Generated on Mon Oct 25 19:42:51 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorMessage.cpp File Reference

CaopCorMessage.cpp の解説

#include "stdafx.h"
#include "CaopCorMessage.h"

CaopCorMessage.cppのインクルード依存関係図

Include dependency graph
Generated on Mon Oct 25 19:42:52 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorMessage.h File Reference

CaopCorMessage.h の解説

CaopCorMessageクラスの宣言. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaopCorMessage
GwCaopCorbaのMessageクラス. [詳細]

マクロ定義

#define | AFX_CAOPCORMESSAGE_H__10B17A7C_7A2C_474E_8B85_27C0C6FFC175__INCLUDED_

解説

CaopCorMessageクラスの宣言.

バージョン:
1.0
日付:
2003/10/25
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CAOPCORMESSAGE_H__10B17A7C_7A2C_474E_8B85_27C0C6FFC175__INCLUDED_

Generated on Mon Oct 25 19:42:52 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorRobot.cpp File Reference

CaopCorRobot.cpp の解説

#include "stdafx.h"
#include "CaopCorRobot.h"
#include "CaopCorVariable.h"

CaopCorRobot.cppのインクルード依存関係図

Include dependency graph
Generated on Mon Oct 25 19:42:52 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorRobot.h File Reference

CaopCorRobot.h の解説

CaopCorRobotクラスの宣言. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaopCorRobot
GwCaopCorbaのRobotクラス. [詳細]

マクロ定義

#define | AFX_CAOPCORROBOT_H__73C329C8_5F88_4022_B346_DF415612E5CE__INCLUDED_

解説

CaopCorRobotクラスの宣言.

バージョン:
1.0
日付:
2003/10/25
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CAOPCORROBOT_H__73C329C8_5F88_4022_B346_DF415612E5CE__INCLUDED_

Generated on Mon Oct 25 19:42:52 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorTask.cpp File Reference

CaopCorTask.cpp の解説

#include "stdafx.h"
#include "CaopCorTask.h"
#include "CaopCorVariable.h"

CaopCorTask.cppのインクルード依存関係図

Include dependency graph
Generated on Mon Oct 25 19:42:52 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorTask.h File Reference

CaopCorTask.h の解説

CaopCorTaskクラスの宣言. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaopCorTask
GwCaopCorbaのTaskクラス. [詳細]

マクロ定義

#define | AFX_CAOPCORTASK_H__43C215C0_B349_4369_BB80_19A673E35E73__INCLUDED_

解説

CaopCorTaskクラスの宣言.

バージョン:
1.0
日付:
2003/10/25
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CAOPCORTASK_H__43C215C0_B349_4369_BB80_19A673E35E73__INCLUDED_

Generated on Mon Oct 25 19:42:53 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorVariable.cpp File Reference

CaopCorVariable.cpp の解説

#include "stdafx.h"
#include "CaopCorVariable.h"

CaopCorVariable.cppのインクルード依存関係図

Include dependency graph
Generated on Mon Oct 25 19:42:53 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorVariable.h File Reference

CaopCorVariable.h の解説

CaopCorVariableクラスの宣言. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaopCorVariable
GwCaopCorbaのVariableクラス. [詳細]

マクロ定義

#define | AFX_CAOPCORVARIABLE_H__426A6316_14DF_4453_A94A_673E2CA65B8F__INCLUDED_

解説

CaopCorVariableクラスの宣言.

バージョン:
1.0
日付:
2003/10/25
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CAOPCORVARIABLE_H__426A6316_14DF_4453_A94A_673E2CA65B8F__INCLUDED_

Generated on Mon Oct 25 19:42:53 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaoProvCorba.idl File Reference

CaoProvCorba.idl の解説

CORBA用CAO Provider インタフェース定義ファイル. [詳細]

ソースコードを見る。

名前空間

namespace CaoProv

解説

CORBA用CAO Provider インタフェース定義ファイル.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Mon Oct 25 19:42:53 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CorbaServer.cpp File Reference

CorbaServer.cpp の解説

#include "stdafx.h"
#include "CorbaServer.h"
#include "CaopCorController.h"
#include <process.h>

CorbaServer.cppのインクルード依存関係図

Include dependency graph
Generated on Mon Oct 25 19:42:54 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CorbaServer.h File Reference

CorbaServer.h の解説

CorbaServerクラスの宣言. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCorbaServer
GwCaopCorbaのCorbaServerクラス. [詳細]

マクロ定義

#define | AFX_CORBASERVER_H__993BCE13_EC11_4A0B_8877_5B4A4E6085A6__INCLUDED_
#define | CORBA_NAME_SIZE 256

解説

CorbaServerクラスの宣言.

バージョン:
1.0
日付:
2003/10/25
作者:
DENSO WAVE

マクロ定義の解説

#define AFX_CORBASERVER_H__993BCE13_EC11_4A0B_8877_5B4A4E6085A6__INCLUDED_

#define CORBA_NAME_SIZE 256

Generated on Mon Oct 25 19:42:54 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


dlldata.c File Reference

dlldata.c の解説

#include <rpcproxy.h>

dlldata.cのインクルード依存関係図

Include dependency graph

マクロ定義

#define | PROXY_DELEGATION

関数

PROXYFILE_LIST_START | REFERENCE_PROXY_FILE (GwCaopCorba)

マクロ定義の解説

#define PROXY_DELEGATION

関数の解説

PROXYFILE_LIST_START REFERENCE_PROXY_FILE ( GwCaopCorba )

Generated on Mon Oct 25 19:42:54 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


EventSink.cpp File Reference

EventSink.cpp の解説

#include "stdafx.h"
#include "GwCaopCorba.h"
#include "EventSink.h"
#include "caoprovif_i.c"
#include "CaopCorMessage.h"

EventSink.cppのインクルード依存関係図

Include dependency graph
Generated on Mon Oct 25 19:42:55 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


EventSink.h File Reference

EventSink.h の解説

EventSinkクラスの宣言. [詳細]

#include "resource.h"
#include "GwCaopCorba.h"

EventSink.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CEventSink
CAOのイベントシンククラス. [詳細]

解説

EventSinkクラスの宣言.

バージョン:
1.0
日付:
2003/10/25
作者:
DENSO WAVE
Generated on Mon Oct 25 19:42:55 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


GwCaopCorba.cpp File Reference

GwCaopCorba.cpp の解説

#include "stdafx.h"
#include "resource.h"
#include <initguid.h>
#include "GwCaopCorba.h"
#include "GwCaopCorba_i.c"
#include <stdio.h>
#include "EventSink.h"

GwCaopCorba.cppのインクルード依存関係図

Include dependency graph

関数

LPCTSTR | FindOneOf (LPCTSTR p1, LPCTSTR p2)
int WINAPI | _tWinMain (HINSTANCE hInstance, HINSTANCE, LPTSTR lpCmdLine, int)

変数

CServiceModule _Module

関数の解説

int WINAPI _tWinMain | ( | HINSTANCE | hInstance,
 |  | HINSTANCE | ,
 |  | LPTSTR | lpCmdLine,
 |  | int |
 | ) |

LPCTSTR FindOneOf | ( | LPCTSTR | p1,
 |  | LPCTSTR | p2
 | ) |

変数の解説

CServiceModule _Module

Generated on Mon Oct 25 19:42:56 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


GwCaopCorba.h File Reference

GwCaopCorba.h の解説

#include "rpc.h"
#include "rpcndr.h"
#include "windows.h"
#include "ole2.h"
#include "oaidl.h"
#include "ocidl.h"

GwCaopCorba.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

マクロ定義

#define | __REQUIRED_RPCNDR_H_VERSION__ 440

Typedef

typedef interface IEventSink | IEventSink
typedef EventSink | EventSink

関数

void __RPC_FAR *__RPC_USER | MIDL_user_allocate (size_t)
void __RPC_USER | MIDL_user_free (void __RPC_FAR *)
HRESULT STDMETHODCALLTYPE | IEventSink_OnMessage_Proxy (IEventSink __RPC_FAR *This, IUnknown __RPC_FAR *pVal)
void __RPC_STUB | IEventSink_OnMessage_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
class | DECLSPEC_UUID ("9BB72A60-3579-42CB-A019-4527AB424BF8") EventSink

変数

EXTERN_C const IID | IID_IEventSink
IEventSink __pad0__
EXTERN_C const IID | LIBID_GWCAOPCORBALib
EXTERN_C const CLSID | CLSID_EventSink

マクロ定義の解説

#define __REQUIRED_RPCNDR_H_VERSION__ 440

Typedef の解説

typedef class EventSink EventSink

typedef interface IEventSink IEventSink

関数の解説

class DECLSPEC_UUID ( "9BB72A60-3579-42CB-A019-4527AB424BF8" )

HRESULT STDMETHODCALLTYPE IEventSink_OnMessage_Proxy | ( | IEventSink __RPC_FAR * | This,
 |  | IUnknown __RPC_FAR * | pVal
 | ) |

void __RPC_STUB IEventSink_OnMessage_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

void __RPC_FAR* __RPC_USER MIDL_user_allocate ( size_t )

void __RPC_USER MIDL_user_free ( void __RPC_FAR * )

変数の解説

IEventSink __pad0__

EXTERN_C const CLSID CLSID_EventSink

EXTERN_C const IID IID_IEventSink

EXTERN_C const IID LIBID_GWCAOPCORBALib

Generated on Mon Oct 25 19:42:56 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


GwCaopCorba.idl File Reference

GwCaopCorba.idl の解説

ソースコードを見る。

名前空間

namespace | GWCAOPCORBALib

構成

interface | IEventSink

Generated on Mon Oct 25 19:42:56 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


GwCaopCorba_i.c File Reference

GwCaopCorba_i.c の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

構成

struct | _IID

Typedef

typedef _IID | IID
typedef IID | CLSID

変数

const IID | IID_IEventSink = {0x9D51383D,0xD9F8,0x490E,{0x84,0xFB,0xED,0xFC,0xBF,0x36,0xAD,0x48}}
const IID | LIBID_GWCAOPCORBALib = {0x9F6E5130,0x5125,0x4003,{0x80,0x29,0xD1,0x3E,0x39,0x3F,0x20,0x02}}
const CLSID | CLSID_EventSink = {0x9BB72A60,0x3579,0x42CB,{0xA0,0x19,0x45,0x27,0xAB,0x42,0x4B,0xF8}}

Typedef の解説

typedef IID CLSID

typedef struct _IID IID

変数の解説

const CLSID CLSID_EventSink = {0x9BB72A60,0x3579,0x42CB,{0xA0,0x19,0x45,0x27,0xAB,0x42,0x4B,0xF8}}

const IID IID_IEventSink = {0x9D51383D,0xD9F8,0x490E,{0x84,0xFB,0xED,0xFC,0xBF,0x36,0xAD,0x48}}

const IID LIBID_GWCAOPCORBALib = {0x9F6E5130,0x5125,0x4003,{0x80,0x29,0xD1,0x3E,0x39,0x3F,0x20,0x02}}

Generated on Mon Oct 25 19:42:56 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


GwCaopCorba_p.c File Reference

GwCaopCorba_p.c の解説

#include "rpcproxy.h"
#include "GwCaopCorba.h"

GwCaopCorba_p.cのインクルード依存関係図

Include dependency graph

構成

struct | _MIDL_PROC_FORMAT_STRING
struct | _MIDL_TYPE_FORMAT_STRING

マクロ定義

#define | USE_STUBLESS_PROXY
#define | __REQUIRED_RPCPROXY_H_VERSION__ 440
#define | TYPE_FORMAT_STRING_SIZE 21
#define | PROC_FORMAT_STRING_SIZE 29

Typedef

typedef _MIDL_TYPE_FORMAT_STRING | MIDL_TYPE_FORMAT_STRING
typedef _MIDL_PROC_FORMAT_STRING | MIDL_PROC_FORMAT_STRING

関数

CINTERFACE_PROXY_VTABLE (8) _IEventSinkProxyVtbl=

変数

const MIDL_TYPE_FORMAT_STRING | __MIDL_TypeFormatString
const MIDL_PROC_FORMAT_STRING | __MIDL_ProcFormatString
const MIDL_STUB_DESC | Object_StubDesc
const MIDL_SERVER_INFO | IEventSink_ServerInfo
const unsigned short | IEventSink_FormatStringOffsetTable []
const MIDL_STUBLESS_PROXY_INFO | IEventSink_ProxyInfo

マクロ定義の解説

#define __REQUIRED_RPCPROXY_H_VERSION__ 440

#define PROC_FORMAT_STRING_SIZE 29

#define TYPE_FORMAT_STRING_SIZE 21

#define USE_STUBLESS_PROXY

Typedef の解説

typedef struct _MIDL_PROC_FORMAT_STRING MIDL_PROC_FORMAT_STRING

typedef struct _MIDL_TYPE_FORMAT_STRING MIDL_TYPE_FORMAT_STRING

関数の解説

CINTERFACE_PROXY_VTABLE ( 8 )

変数の解説

const MIDL_PROC_FORMAT_STRING __MIDL_ProcFormatString

const MIDL_TYPE_FORMAT_STRING __MIDL_TypeFormatString

const unsigned short IEventSink_FormatStringOffsetTable[] [static]

初期値:

    {
    (unsigned short) -1,
    (unsigned short) -1,
    (unsigned short) -1,
    (unsigned short) -1,
    0
    }

const MIDL_STUBLESS_PROXY_INFO IEventSink_ProxyInfo [static]

初期値:

    {
    &Object_StubDesc,
    __MIDL_ProcFormatString.Format,
    &IEventSink_FormatStringOffsetTable[-3],
    0,
    0,
    0
    }

const MIDL_SERVER_INFO IEventSink_ServerInfo

初期値:

    {
    &Object_StubDesc,
    0,
    __MIDL_ProcFormatString.Format,
    &IEventSink_FormatStringOffsetTable[-3],
    0,
    0,
    0,
    0
    }

const MIDL_STUB_DESC Object_StubDesc

初期値:

    {
    0,
    NdrOleAllocate,
    NdrOleFree,
    0,
    0,
    0,
    0,
    0,
    __MIDL_TypeFormatString.Format,
    1,
    0x20000,
    0,
    0x50100a4,
    0,
    0,
    0,
    1,
    0,
    0,
    0
    }

Generated on Mon Oct 25 19:42:57 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


resource.h File Reference

resource.h の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

マクロ定義

#define | IDS_SERVICENAME 100
#define | IDR_GwCaopCorba 100
#define | IDR_EVENTSINK 101

マクロ定義の解説

#define IDR_EVENTSINK 101

#define IDR_GwCaopCorba 100

#define IDS_SERVICENAME 100

Generated on Mon Oct 25 19:42:57 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


StdAfx.cpp File Reference

StdAfx.cpp の解説

#include "stdafx.h"
#include <atlimpl.cpp>

StdAfx.cppのインクルード依存関係図

Include dependency graph
Generated on Mon Oct 25 19:42:57 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


StdAfx.h File Reference

StdAfx.h の解説

#include <atlbase.h>
#include "CaoProvCorba.h"
#include "CorbaServer.h"
#include <atlcom.h>
#include "caoprovif.h"

StdAfx.hのインクルード依存関係図

Include dependency graph

ソースコードを見る。

構成

class | CServiceModule

マクロ定義

#define | AFX_STDAFX_H__503EE5DC_08C2_490C_BAC3_4196D94D05A6__INCLUDED_
#define | STRICT
#define | _WIN32_WINNT 0x0400
#define | _ATL_APARTMENT_THREADED
#define | MAX_STR_LEN 256
#define | SAFE_RELEASE(p) { if(p) { (p)->Release(); (p)=NULL; } }
#define | SAFE_DELETE(p) { if(p) { delete (p); (p)=NULL; } }
#define | SAFE_CLOSE(p) { if(p) { CloseHandle(p); (p)=NULL; } }
#define | THROW_HRESULT(p) { throw CORBA::BAD_OPERATION(hr, CORBA::COMPLETED_NO); }

関数

LPCTSTR | FindOneOf (LPCTSTR p1, LPCTSTR p2)

変数

CServiceModule _Module

マクロ定義の解説

#define _ATL_APARTMENT_THREADED

#define _WIN32_WINNT 0x0400

#define AFX_STDAFX_H__503EE5DC_08C2_490C_BAC3_4196D94D05A6__INCLUDED_

#define MAX_STR_LEN 256

#define SAFE_CLOSE ( p ) { if(p) { CloseHandle(p); (p)=NULL; } }

#define SAFE_DELETE ( p ) { if(p) { delete (p); (p)=NULL; } }

#define SAFE_RELEASE ( p ) { if(p) { (p)->Release(); (p)=NULL; } }

#define STRICT

#define THROW_HRESULT ( p ) { throw CORBA::BAD_OPERATION(hr, CORBA::COMPLETED_NO); }

関数の解説

LPCTSTR FindOneOf | ( | LPCTSTR | p1,
 |  | LPCTSTR | p2
 | ) |

変数の解説

CServiceModule _Module

Generated on Mon Oct 25 19:42:57 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


Annotated Index

GwCaopCorba Project 構成

クラス、構造体、共用体、インタフェースの解説です。
_IID |
_MIDL_PROC_FORMAT_STRING |
_MIDL_TYPE_FORMAT_STRING |
CCaopCorCommand | GwCaopCorbaのCommandクラス
CCaopCorController | GwCaopCorbaのControllerクラス
CCaopCorExtension | GwCaopCorbaのExtensionクラス
CCaopCorFile | GwCaopCorbaのFileクラス
CCaopCorMessage | GwCaopCorbaのMessageクラス
CCaopCorRobot | GwCaopCorbaのRobotクラス
CCaopCorTask | GwCaopCorbaのTaskクラス
CCaopCorVariable | GwCaopCorbaのVariableクラス
CCorbaServer | GwCaopCorbaのCorbaServerクラス
CEventSink | CAOのイベントシンククラス
CaoProv::Command |
CaoProv::Controller |
CaoProv::ControllerEvents |
CaoProv::CORBA_VARIANT |
CServiceModule |
GWCAOPCORBALib::EventSink |
CaoProv::Extension |
CaoProv::File |
IEventSink |
CaoProv::Message |
CaoProv::Robot |
CaoProv::Task |
CaoProv::Variable |
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


_IID struct Reference

構造体 _IID の解説

すべてのメンバ一覧

Public 変数

unsigned long | x
unsigned short | s1
unsigned short | s2
unsigned char | c [8]

変数の解説

unsigned char _IID::c[8]

unsigned short _IID::s1

unsigned short _IID::s2

unsigned long _IID::x

この構造体の解説は次のファイルから生成されました:
  • GwCaopCorba_i.c
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


_MIDL_PROC_FORMAT_STRING struct Reference

構造体 _MIDL_PROC_FORMAT_STRING の解説

すべてのメンバ一覧

Public 変数

short | Pad
unsigned char | Format [PROC_FORMAT_STRING_SIZE]

変数の解説

unsigned char _MIDL_PROC_FORMAT_STRING::Format[ PROC_FORMAT_STRING_SIZE ]

short _MIDL_PROC_FORMAT_STRING::Pad

この構造体の解説は次のファイルから生成されました:
  • GwCaopCorba_p.c
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


_MIDL_TYPE_FORMAT_STRING struct Reference

構造体 _MIDL_TYPE_FORMAT_STRING の解説

すべてのメンバ一覧

Public 変数

short | Pad
unsigned char | Format [TYPE_FORMAT_STRING_SIZE]

変数の解説

unsigned char _MIDL_TYPE_FORMAT_STRING::Format[ TYPE_FORMAT_STRING_SIZE ]

short _MIDL_TYPE_FORMAT_STRING::Pad

この構造体の解説は次のファイルから生成されました:
  • GwCaopCorba_p.c
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CCaopCorCommand class Reference

クラス CCaopCorCommand の解説

GwCaopCorbaのCommandクラス. [詳細]

#include <CaopCorCommand.h>

すべてのメンバ一覧

Public メソッド

CCaopCorCommand ()
コンストラクタ

virtual | ~CCaopCorCommand ()
デストラクタ

HRESULT | initialize (PVOID pArg)
初期化処理

virtual CORBA_VARIANT * | execute (long lOption)
コマンドの実行

virtual void | cancel ()
実行中コマンドのキャンセル

virtual WCHAR * | name ()
コマンド名の取得

virtual long | type ()
属性の取得

virtual WCHAR * | help ()
ヘルプ文字列の取得

virtual long | state ()
パラメータの取得

virtual CORBA_VARIANT * | parameters ()
パラメータの取得

virtual void | parameters (const CORBA_VARIANT &_v)
パラメータの設定

virtual long | timeout ()
パラメータの取得

virtual void | timeout (long _v)
パラメータの設定

解説

GwCaopCorbaのCommandクラス.

CORBAサーバのCommandクラス。CaoProv::Commandインターフェースを実装する。
  CAOプロバイダのコマンドクラスと1対1に対応する。

コンストラクタとデストラクタの解説

CCaopCorCommand::CCaopCorCommand ( )

コンストラクタ

CCaopCorCommand::~CCaopCorCommand ( ) [virtual]

デストラクタ

メソッドの解説

void CCaopCorCommand::cancel ( ) [virtual]

実行中コマンドのキャンセル

  CAOプロバイダのICaopCommand::Execute()を実行する．

CORBA_VARIANT * CCaopCorCommand::execute ( long lOption ) [virtual]

コマンドの実行

  CAOプロバイダのICaopCommand::Execute()を実行する．

引数:
lOption : [in] モード
戻り値:
CORBA_VARIANT ： 実行結果

WCHAR * CCaopCorCommand::help ( ) [virtual]

ヘルプ文字列の取得

  CAOプロバイダのICaopCommand::get_Help()を実行する．

戻り値:
WCHAR * : ヘルプ文字列

HRESULT CCaopCorCommand::initialize ( PVOID pArgs )

初期化処理

引数:
pArgs : [in] CAOプロバイダのコマンドIF 　retval HRESULT

WCHAR * CCaopCorCommand::name ( ) [virtual]

コマンド名の取得

  CAOプロバイダのICaopCommand::get_Name()を実行する．

戻り値:
WCHAR * ： コマンド名

void CCaopCorCommand::parameters ( const CORBA_VARIANT & _v ) [virtual]

パラメータの設定

  CAOプロバイダのICaopCommand::put_Parameters()を実行する．

引数:
_v : [in] パラメータ配列

CORBA_VARIANT * CCaopCorCommand::parameters ( ) [virtual]

パラメータの取得

  CAOプロバイダのICaopCommand::get_Parameters()を実行する．

戻り値:
CORBA_VARIANT : パラメータ配列

long CCaopCorCommand::state ( ) [virtual]

パラメータの取得

  CAOプロバイダのICaopCommand::get_State()を実行する．

戻り値:
long : 状態値

void CCaopCorCommand::timeout ( long _v ) [virtual]

パラメータの設定

  CAOプロバイダのICaopCommand::put_Timeout()を実行する．

引数:
_v : [in] タイムアウト値

long CCaopCorCommand::timeout ( ) [virtual]

パラメータの取得

  CAOプロバイダのICaopCommand::get_Timeout()を実行する．

戻り値:
long : タイムアウト値

long CCaopCorCommand::type ( ) [virtual]

属性の取得

  CAOプロバイダのICaopCommand::get_Attribute()を実行する．

戻り値:
long ： 属性値

このクラスの解説は次のファイルから生成されました:
  • CaopCorCommand.h
  • CaopCorCommand.cpp
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CCaopCorController class Reference

クラス CCaopCorController の解説

GwCaopCorbaのControllerクラス. [詳細]

#include <CaopCorController.h>

すべてのメンバ一覧

Public メソッド

CCaopCorController ()
コンストラクタ

virtual | ~CCaopCorController ()
デストラクタ

HRESULT | initialize (PVOID pArg)
初期化処理

virtual void | connect (const WCHAR *wszName, const WCHAR *wszOption, ControllerEvents_ptr pCaoEvent)
接続処理

virtual void | disconnect ()
接続処理

virtual Extension_ptr | getExtension (const WCHAR *wszName, const WCHAR *wszOption)
拡張ボードオブジェクトの取得

virtual File_ptr | getFile (const WCHAR *wszName, const WCHAR *wszOption)
ファイルオブジェクトの取得

virtual Robot_ptr | getRobot (const WCHAR *wszName, const WCHAR *wszOption)
ロボットオブジェクトの取得

virtual Task_ptr | getTask (const WCHAR *wszName, const WCHAR *wszOption)
タスクオブジェクトの取得

virtual Variable_ptr | getVariable (const WCHAR *wszName, const WCHAR *wszOption)
変数オブジェクトの取得

virtual Command_ptr | getCommand (const WCHAR *wszName, const WCHAR *wszOption)
コマンドオブジェクトの取得

virtual CORBA_VARIANT * | execute (const CORBA_VARIANT &Command)
拡張コマンドの実行

virtual WCHAR * | name ()
コントローラ名の取得

virtual long | type ()
属性の取得

virtual WCHAR * | help ()
ヘルプ文字列の取得

virtual CORBA_VARIANT * | getExtensionNames (const WCHAR *wszOption)
拡張ボードリストの取得

virtual CORBA_VARIANT * | getFileNames (const WCHAR *wszOption)
ファイルリストの取得

virtual CORBA_VARIANT * | getRobotNames (const WCHAR *wszOption)
ロボットリストの取得

virtual CORBA_VARIANT * | getTaskNames (const WCHAR *wszOption)
タスクリストの取得

virtual CORBA_VARIANT * | getVariableNames (const WCHAR *wszOption)
変数リストの取得

virtual CORBA_VARIANT * | getCommandNames (const WCHAR *wszOption)
コマンドリストの取得

解説

GwCaopCorbaのControllerクラス.

CORBAサーバのControllerクラス。CaoProv::Controllerインターフェースを実装する。
  CAOプロバイダのコントローラクラスと1対1に対応する。

コンストラクタとデストラクタの解説

CCaopCorController::CCaopCorController ( )

コンストラクタ

CCaopCorController::~CCaopCorController ( ) [virtual]

デストラクタ

メソッドの解説

void CCaopCorController::connect | ( | const WCHAR * | wszName,
 |  | const WCHAR * | wszOption,
 |  | ControllerEvents_ptr | pCaoEvent
 | ) | [virtual]

接続処理

  CAOプロバイダののコントローラオブジェクトを生成する。
  コントローラオブジェクト生成後、ICaopCommand::Connect()を実行する．

引数:
wszName | : [in] コントローラ名
wszOption | : [in] オプション文字列
pCaoEvent | : [in] クライアント側イベントオブジェクト

void CCaopCorController::disconnect ( ) [virtual]

接続処理

  ICaopCommand::Disconnect()を実行する． 　Disconnect()実行後、CAOプロバイダののコントローラオブジェクトを削除する。

CORBA_VARIANT * CCaopCorController::execute ( const CORBA_VARIANT & Command ) [virtual]

拡張コマンドの実行

  CAOプロバイダのICaopController::Execute()を実行する．

引数:
Command : [in] コマンド
戻り値:
CORBA_VARIANT ： 実行結果

Command_ptr CCaopCorController::getCommand | ( | const WCHAR * | wszName,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

コマンドオブジェクトの取得

  CAOプロバイダのICaopController::GetCommand()を実行する． 取得したCAOプロバイダオブジェクトはCaoProv::Commandオブジェクトでラップして返します。

引数:
wszName | : [in] コマンド名
wszOption | : [in] オプション
戻り値:
Command_ptr ： CaoProv::Commandのポインタ

CORBA_VARIANT * CCaopCorController::getCommandNames ( const WCHAR * wszOption ) [virtual]

コマンドリストの取得

  CAOプロバイダのICaopController::get_CommandNames()を実行する．

引数:
wszOption : [in] オプション
戻り値:
CORBA_VARIANT ： コマンドリスト

Extension_ptr CCaopCorController::getExtension | ( | const WCHAR * | wszName,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

拡張ボードオブジェクトの取得

  CAOプロバイダのICaopController::GetExtension()を実行する． 取得したCAOプロバイダオブジェクトはCaoProv::Extensionオブジェクトでラップして返します。

引数:
wszName | : [in] 拡張ボード名
wszOption | : [in] オプション
戻り値:
Extension_ptr ： CaoProv::Extensionのポインタ

CORBA_VARIANT * CCaopCorController::getExtensionNames ( const WCHAR * wszOption ) [virtual]

拡張ボードリストの取得

  CAOプロバイダのICaopController::get_ExtensionNames()を実行する．

引数:
wszOption : [in] オプション
戻り値:
CORBA_VARIANT ： 拡張ボード名リスト

File_ptr CCaopCorController::getFile | ( | const WCHAR * | wszName,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

ファイルオブジェクトの取得

  CAOプロバイダのICaopController::GetFile()を実行する． 取得したCAOプロバイダオブジェクトはCaoProv::Fileオブジェクトでラップして返します。

引数:
wszName | : [in] ファイル名
wszOption | : [in] オプション
戻り値:
File_ptr ： CaoProv::Fileのポインタ

CORBA_VARIANT * CCaopCorController::getFileNames ( const WCHAR * wszOption ) [virtual]

ファイルリストの取得

  CAOプロバイダのICaopController::get_FileNames()を実行する．

引数:
wszOption : [in] オプション
戻り値:
CORBA_VARIANT ： ファイル名リスト

Robot_ptr CCaopCorController::getRobot | ( | const WCHAR * | wszName,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

ロボットオブジェクトの取得

  CAOプロバイダのICaopController::GetRobot()を実行する． 取得したCAOプロバイダオブジェクトはCaoProv::Robotオブジェクトでラップして返します。

引数:
wszName | : [in] ロボット名
wszOption | : [in] オプション
戻り値:
Robot_ptr ： CaoProv::Robotのポインタ

CORBA_VARIANT * CCaopCorController::getRobotNames ( const WCHAR * wszOption ) [virtual]

ロボットリストの取得

  CAOプロバイダのICaopController::get_RobotNames()を実行する．

引数:
wszOption : [in] オプション
戻り値:
CORBA_VARIANT ： ロボット名リスト

Task_ptr CCaopCorController::getTask | ( | const WCHAR * | wszName,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

タスクオブジェクトの取得

  CAOプロバイダのICaopController::GetTask()を実行する． 取得したCAOプロバイダオブジェクトはCaoProv::Taskオブジェクトでラップして返します。

引数:
wszName | : [in] タスク名
wszOption | : [in] オプション
戻り値:
Task_ptr ： CaoProv::Taskのポインタ

CORBA_VARIANT * CCaopCorController::getTaskNames ( const WCHAR * wszOption ) [virtual]

タスクリストの取得

  CAOプロバイダのICaopController::get_TaskNames()を実行する．

引数:
wszOption : [in] オプション
戻り値:
CORBA_VARIANT ： タスク名リスト

Variable_ptr CCaopCorController::getVariable | ( | const WCHAR * | wszName,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

変数オブジェクトの取得

  CAOプロバイダのICaopController::GetVariable()を実行する． 取得したCAOプロバイダオブジェクトはCaoProv::Variableオブジェクトでラップして返します。

引数:
wszName | : [in] 変数名
wszOption | : [in] オプション
戻り値:
Variable_ptr ： CaoProv::Variableのポインタ

CORBA_VARIANT * CCaopCorController::getVariableNames ( const WCHAR * wszOption ) [virtual]

変数リストの取得

  CAOプロバイダのICaopController::get_VariableNames()を実行する．

引数:
wszOption : [in] オプション
戻り値:
CORBA_VARIANT ： 変数名リスト

WCHAR * CCaopCorController::help ( ) [virtual]

ヘルプ文字列の取得

  CAOプロバイダのICaopController::get_Help()を実行する．

戻り値:
WCHAR * : ヘルプ文字列

HRESULT CCaopCorController::initialize ( PVOID pArgs )

初期化処理

引数:
pArgs [] : [in]pArgs[0] - コントローラ名
pArgs[1] - プロバイダ名
  retval HRESULT

WCHAR * CCaopCorController::name ( ) [virtual]

コントローラ名の取得

  CAOプロバイダのICaopController::get_Name()を実行する．

戻り値:
WCHAR * ： コントローラ名

long CCaopCorController::type ( ) [virtual]

属性の取得

  CAOプロバイダのICaopController::get_Attribute()を実行する．

戻り値:
long ： 属性値

このクラスの解説は次のファイルから生成されました:
  • CaopCorController.h
  • CaopCorController.cpp
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CCaopCorExtension class Reference

クラス CCaopCorExtension の解説

GwCaopCorbaのExtensionクラス. [詳細]

#include <CaopCorExtension.h>

すべてのメンバ一覧

Public メソッド

CCaopCorExtension ()
コンストラクタ

virtual | ~CCaopCorExtension ()
デストラクタ

HRESULT | initialize (PVOID pArg)
初期化処理

virtual Variable_ptr | getVariable (const WCHAR *wszName, const WCHAR *wszOption)
変数オブジェクトの取得

virtual CORBA_VARIANT * | execute (const CORBA_VARIANT &Command)
拡張コマンドの実行

virtual CORBA_VARIANT * | getVariableNames (const WCHAR *wszOption)
変数リストの取得

virtual WCHAR * | name ()
拡張ボード名の取得

virtual long | type ()
属性の取得

virtual WCHAR * | help ()
ヘルプ文字列の取得

解説

GwCaopCorbaのExtensionクラス.

CORBAサーバのExtensionクラス。CaoProv::Extensionインターフェースを実装する。
  CAOプロバイダの拡張ボードクラスと1対1に対応する。

コンストラクタとデストラクタの解説

CCaopCorExtension::CCaopCorExtension ( )

コンストラクタ

CCaopCorExtension::~CCaopCorExtension ( ) [virtual]

デストラクタ

メソッドの解説

CORBA_VARIANT * CCaopCorExtension::execute ( const CORBA_VARIANT & Command ) [virtual]

拡張コマンドの実行

  CAOプロバイダのICaopExtension::Execute()を実行する．

引数:
Command : [in] コマンド
戻り値:
CORBA_VARIANT ： 実行結果

Variable_ptr CCaopCorExtension::getVariable | ( | const WCHAR * | wszName,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

変数オブジェクトの取得

  CAOプロバイダのICaopExtension::GetVariable()を実行する． 取得したCAOプロバイダオブジェクトはCaoProv::Variableオブジェクトでラップして返します。

引数:
wszName | : [in] 変数名
wszOption | : [in] オプション
戻り値:
Variable_ptr ： CaoProv::Variableのポインタ

CORBA_VARIANT * CCaopCorExtension::getVariableNames ( const WCHAR * wszOption ) [virtual]

変数リストの取得

  CAOプロバイダのICaopExtension::get_VariableNames()を実行する．

引数:
wszOption : [in] オプション
戻り値:
CORBA_VARIANT ： 変数名リスト

WCHAR * CCaopCorExtension::help ( ) [virtual]

ヘルプ文字列の取得

  CAOプロバイダのICaopExtension::get_Help()を実行する．

戻り値:
WCHAR * : ヘルプ文字列

HRESULT CCaopCorExtension::initialize ( PVOID pArgs )

初期化処理

引数:
pArgs : [in] CAOプロバイダの拡張ボードIF 　retval HRESULT

WCHAR * CCaopCorExtension::name ( ) [virtual]

拡張ボード名の取得

  CAOプロバイダのICaopExtension::get_Name()を実行する．

戻り値:
WCHAR * ： 拡張ボード名

long CCaopCorExtension::type ( ) [virtual]

属性の取得

  CAOプロバイダのICaopExtension::get_Attribute()を実行する．

戻り値:
long ： 属性値

このクラスの解説は次のファイルから生成されました:
  • CaopCorExtension.h
  • CaopCorExtension.cpp
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CCaopCorFile class Reference

クラス CCaopCorFile の解説

GwCaopCorbaのFileクラス. [詳細]

#include <CaopCorFile.h>

すべてのメンバ一覧

Public メソッド

CCaopCorFile ()
コンストラクタ

virtual | ~CCaopCorFile ()
デストラクタ

HRESULT | initialize (PVOID pArg)
初期化処理

virtual File_ptr | getFile (const WCHAR *wszName, const WCHAR *wszOption)
ファイルオブジェクトの取得

virtual Variable_ptr | getVariable (const WCHAR *wszName, const WCHAR *wszOption)
変数オブジェクトの取得

virtual CORBA_VARIANT * | execute (const CORBA_VARIANT &Command)
拡張コマンドの実行

virtual void | copy (const WCHAR *wszName, const WCHAR *wszOption)
ファイルの複写

virtual void | deleteFile (const WCHAR *wszOption)
ファイルの削除

virtual void | move (const WCHAR *wszName, const WCHAR *wszOption)
ファイルの移動

virtual WCHAR * | run (const WCHAR *wszOption)
タスクの生成

virtual CORBA_VARIANT * | getFileNames (const WCHAR *wszOption)
ファイルリストの取得

virtual CORBA_VARIANT * | getVariableNames (const WCHAR *wszOption)
変数リストの取得

virtual WCHAR * | name ()
ファイル名の取得

virtual long | type ()
属性の取得

virtual WCHAR * | help ()
ヘルプ文字列の取得

virtual CORBA_VARIANT * | dateCreated ()
ファイル作成日時の取得

virtual CORBA_VARIANT * | dateLastAccessed ()
フォルダ最終アクセス日時の取得

virtual CORBA_VARIANT * | dateLastModified ()
ファイル更新日時

virtual WCHAR * | path ()
パスの取得

virtual long | size ()
サイズの取得

virtual WCHAR * | fileType ()
タイプ（拡張子）の取得

virtual CORBA_VARIANT * | value ()
ファイルの内容の取得

virtual void | value (const CORBA_VARIANT &_v)
ファイルの内容の設定

解説

GwCaopCorbaのFileクラス.

CORBAサーバのFileクラス。CaoProv::Fileインターフェースを実装する。
  CAOプロバイダのファイルクラスと1対1に対応する。

コンストラクタとデストラクタの解説

CCaopCorFile::CCaopCorFile ( )

コンストラクタ

CCaopCorFile::~CCaopCorFile ( ) [virtual]

デストラクタ

メソッドの解説

void CCaopCorFile::copy | ( | const WCHAR * | wszName,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

ファイルの複写

  CAOプロバイダのICaopFile::Copy()を実行する．

引数:
wszName | : [in] 複写先パス（複写先ファイル）名（文字列）
wszOption | : [in] オプション

CORBA_VARIANT * CCaopCorFile::dateCreated ( ) [virtual]

ファイル作成日時の取得

  CAOプロバイダのICaopFile::get_DateCreated()を実行する．

戻り値:
CORBA_VARIANT ： ファイル作成日時

CORBA_VARIANT * CCaopCorFile::dateLastAccessed ( ) [virtual]

フォルダ最終アクセス日時の取得

  CAOプロバイダのICaopFile::get_DateLastAccessed()を実行する．

戻り値:
CORBA_VARIANT ： フォルダ最終アクセス日時

CORBA_VARIANT * CCaopCorFile::dateLastModified ( ) [virtual]

ファイル更新日時

  CAOプロバイダのICaopFile::get_DateLastModified()を実行する．

戻り値:
CORBA_VARIANT ： ファイル更新日時

void CCaopCorFile::deleteFile ( const WCHAR * wszOption ) [virtual]

ファイルの削除

  CAOプロバイダのICaopFile::Copy()を実行する．

引数:
wszOption : [in] オプション

CORBA_VARIANT * CCaopCorFile::execute ( const CORBA_VARIANT & Command ) [virtual]

拡張コマンドの実行

  CAOプロバイダのICaopFile::Execute()を実行する．

引数:
Command : [in] コマンド
戻り値:
CORBA_VARIANT ： 実行結果

WCHAR * CCaopCorFile::fileType ( ) [virtual]

タイプ（拡張子）の取得

  CAOプロバイダのICaopFile::get_Type()を実行する．

戻り値:
WCHAR * : タイプ（拡張子）

File_ptr CCaopCorFile::getFile | ( | const WCHAR * | wszName,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

ファイルオブジェクトの取得

  CAOプロバイダのICaopFile::GetFile()を実行する． 取得したCAOプロバイダオブジェクトはCaoProv::Fileオブジェクトでラップして返します。

引数:
wszName | : [in] ファイル名
wszOption | : [in] オプション
戻り値:
File_ptr ： CaoProv::Fileのポインタ

CORBA_VARIANT * CCaopCorFile::getFileNames ( const WCHAR * wszOption ) [virtual]

ファイルリストの取得

  CAOプロバイダのICaopFile::get_FileNames()を実行する．

引数:
wszOption : [in] オプション
戻り値:
CORBA_VARIANT ： ファイル名リスト

Variable_ptr CCaopCorFile::getVariable | ( | const WCHAR * | wszName,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

変数オブジェクトの取得

  CAOプロバイダのICaopFile::GetVariable()を実行する． 取得したCAOプロバイダオブジェクトはCaoProv::Variableオブジェクトでラップして返します。

引数:
wszName | : [in] 変数名
wszOption | : [in] オプション
戻り値:
Variable_ptr ： CaoProv::Variableのポインタ

CORBA_VARIANT * CCaopCorFile::getVariableNames ( const WCHAR * wszOption ) [virtual]

変数リストの取得

  CAOプロバイダのICaopFile::get_VariableNames()を実行する．

引数:
wszOption : [in] オプション
戻り値:
CORBA_VARIANT ： 変数名リスト

WCHAR * CCaopCorFile::help ( ) [virtual]

ヘルプ文字列の取得

  CAOプロバイダのICaopFile::get_Help()を実行する．

戻り値:
WCHAR * : ヘルプ文字列

HRESULT CCaopCorFile::initialize ( PVOID pArgs )

初期化処理

引数:
pArgs : [in] CAOプロバイダのファイルIF 　retval HRESULT

void CCaopCorFile::move | ( | const WCHAR * | wszName,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

ファイルの移動

  CAOプロバイダのICaopFile::Move()を実行する．

引数:
wszName | : [in] 移動先パス（移動先ファイル）名（文字列）
wszOption | : [in] オプション

WCHAR * CCaopCorFile::name ( ) [virtual]

ファイル名の取得

  CAOプロバイダのICaopFile::get_Name()を実行する．

戻り値:
WCHAR * ： ファイル名

WCHAR * CCaopCorFile::path ( ) [virtual]

パスの取得

  CAOプロバイダのICaopFile::get_Path()を実行する．

戻り値:
WCHAR * : ファイルのフルパス名

WCHAR * CCaopCorFile::run ( const WCHAR * wszOption ) [virtual]

タスクの生成

  CAOプロバイダのICaopFile::Run()を実行する．

引数:
wszOption : [in] オプション
戻り値:
WCHAR * ： タスク名

long CCaopCorFile::size ( ) [virtual]

サイズの取得

  CAOプロバイダのICaopFile::get_Size()を実行する．

戻り値:
long : サイズ（バイト数）

long CCaopCorFile::type ( ) [virtual]

属性の取得

  CAOプロバイダのICaopFile::get_Attribute()を実行する．

戻り値:
long ： 属性値

void CCaopCorFile::value ( const CORBA_VARIANT & _v ) [virtual]

ファイルの内容の設定

  CAOプロバイダのICaopFile::put_Value()を実行する．

引数:
_v : [in] ファイルの内容

CORBA_VARIANT * CCaopCorFile::value ( ) [virtual]

ファイルの内容の取得

  CAOプロバイダのICaopFile::get_Value()を実行する．

戻り値:
CORBA_VARIANT : ファイルの内容

このクラスの解説は次のファイルから生成されました:
  • CaopCorFile.h
  • CaopCorFile.cpp
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CCaopCorMessage class Reference

クラス CCaopCorMessage の解説

GwCaopCorbaのMessageクラス. [詳細]

#include <CaopCorMessage.h>

すべてのメンバ一覧

Public メソッド

CCaopCorMessage ()
コンストラクタ

virtual | ~CCaopCorMessage ()
デストラクタ

HRESULT | initialize (PVOID pArg)
初期化処理

virtual CORBA_VARIANT * | dateTime ()
メッセージ作成日時の取得

virtual WCHAR * | description ()
メッセージの説明の取得

virtual WCHAR * | destination ()
送り先の取得

virtual long | number ()
メッセージ番号の取得

virtual long | option ()
メッセージオプションの取得

virtual WCHAR * | source ()
送り元の取得

virtual CORBA_VARIANT * | value ()
メッセージ本文の取得

virtual void | clear ()
メッセージのクリア

virtual void | reply (const CORBA_VARIANT &vntData)
メッセージの返信

解説

GwCaopCorbaのMessageクラス.

CORBAサーバのMessageクラス。CaoProv::Messageインターフェースを実装する。
  CAOプロバイダのメッセージクラスと1対1に対応する。

コンストラクタとデストラクタの解説

CCaopCorMessage::CCaopCorMessage ( )

コンストラクタ

CCaopCorMessage::~CCaopCorMessage ( ) [virtual]

デストラクタ

メソッドの解説

void CCaopCorMessage::clear ( ) [virtual]

メッセージのクリア

  CAOプロバイダのICaopMessage::Clear()を実行する．

CORBA_VARIANT * CCaopCorMessage::dateTime ( ) [virtual]

メッセージ作成日時の取得

  CAOプロバイダのICaopMessage::get_DateTime()を実行する．

戻り値:
CORBA_VARIANT : 作成日時

WCHAR * CCaopCorMessage::description ( ) [virtual]

メッセージの説明の取得

  CAOプロバイダのICaopMessage::get_Description()を実行する．

戻り値:
WCHAR * : 説明

WCHAR * CCaopCorMessage::destination ( ) [virtual]

送り先の取得

  CAOプロバイダのICaopMessage::get_Destination()を実行する．

戻り値:
WCHAR * : 送り先

HRESULT CCaopCorMessage::initialize ( PVOID pArgs )

初期化処理

引数:
pArgs : [in] CAOプロバイダのメッセージIF 　retval HRESULT

long CCaopCorMessage::number ( ) [virtual]

メッセージ番号の取得

  CAOプロバイダのICaopMessage::get_Number()を実行する．

戻り値:
long : メッセージ番号

long CCaopCorMessage::option ( ) [virtual]

メッセージオプションの取得

  CAOプロバイダのICaopMessage::get_Option()を実行する．

戻り値:
long : メッセージオプション

void CCaopCorMessage::reply ( const CORBA_VARIANT & _v ) [virtual]

メッセージの返信

  CAOプロバイダのICaopMessage::Reply()を実行する．

引数:
_v : [in] CAOプロバイダのメッセージIF

WCHAR * CCaopCorMessage::source ( ) [virtual]

送り元の取得

  CAOプロバイダのICaopMessage::get_Source()を実行する．

戻り値:
WCHAR * : 送り元

CORBA_VARIANT * CCaopCorMessage::value ( ) [virtual]

メッセージ本文の取得

  CAOプロバイダのICaopMessage::get_Value()を実行する．

戻り値:
WCHAR * : メッセージ本文

このクラスの解説は次のファイルから生成されました:
  • CaopCorMessage.h
  • CaopCorMessage.cpp
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CCaopCorRobot class Reference

クラス CCaopCorRobot の解説

GwCaopCorbaのRobotクラス. [詳細]

#include <CaopCorRobot.h>

すべてのメンバ一覧

Public メソッド

CCaopCorRobot ()
コンストラクタ

virtual | ~CCaopCorRobot ()
デストラクタ

HRESULT | initialize (PVOID pArg)
初期化処理

virtual Variable_ptr | getVariable (const WCHAR *wszName, const WCHAR *wszOption)
変数オブジェクトの取得

virtual CORBA_VARIANT * | execute (const CORBA_VARIANT &Command)
拡張コマンドの実行

virtual void | accelerate (long lAxis, float fAccel, float fDecel)
ACCEL文の実行.

virtual void | cancel ()
実行中制御メソッドのキャンセル

virtual void | change (const WCHAR *wszName)
CHANGE文の実行.

virtual void | chuck (const WCHAR *wszOption)
GRASP文の実行.

virtual void | drive (long lNo, float fMov, const WCHAR *wszOption)
DRIVE文の実行.

virtual void | goHome ()
GOHOME文の実行.

virtual void | move (long lComp, long lPrec, const CORBA_VARIANT &vntPose, const WCHAR *wszOption)
MOVE文の実行.

virtual void | rotate (const CORBA_VARIANT &vntRotSuf, float fDeg, const CORBA_VARIANT &vntPivot, const WCHAR *wszOption)
ROTATE文の実行.

virtual void | speed (long lAxis, float fSpeed)
SPEED/JSPEED文の実行.

virtual void | unchuck (const WCHAR *wszOption)
RELEASE文の実行.

virtual WCHAR * | name ()
ロボット名の取得

virtual long | type ()
属性の取得

virtual WCHAR * | help ()
ヘルプ文字列の取得

virtual CORBA_VARIANT * | getVariableNames (const WCHAR *wszOption)
変数リストの取得

解説

GwCaopCorbaのRobotクラス.

CORBAサーバのRobotクラス。CaoProv::Robotインターフェースを実装する。
  CAOプロバイダのロボットクラスと1対1に対応する。

コンストラクタとデストラクタの解説

CCaopCorRobot::CCaopCorRobot ( )

コンストラクタ

CCaopCorRobot::~CCaopCorRobot ( ) [virtual]

デストラクタ

メソッドの解説

void CCaopCorRobot::accelerate | ( | long | lAxis,
 |  | float | fAccel,
 |  | float | fDecel
 | ) | [virtual]

ACCEL文の実行.

  CAOプロバイダのICaopRobot::Accelerate()を実行する．

引数:
lAxis | : [in] 軸番号
fAccel | : [in] 加速度
fDecel | : [in] 減速度

void CCaopCorRobot::cancel ( ) [virtual]

実行中制御メソッドのキャンセル

  CAOプロバイダのICaopRobot::Cancel()を実行する．

void CCaopCorRobot::change ( const WCHAR * wszName ) [virtual]

CHANGE文の実行.

  CAOプロバイダのICaopRobot::Change()を実行する．

引数:
wszName : [in] ハンド名

void CCaopCorRobot::chuck ( const WCHAR * wszOption ) [virtual]

GRASP文の実行.

  CAOプロバイダのICaopRobot::Chuck()を実行する．

引数:
wszOption : [in] オプション

void CCaopCorRobot::drive | ( | long | lNo,
 |  | float | fMov,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

DRIVE文の実行.

  CAOプロバイダのICaopRobot::Drive()を実行する．

引数:
lNo | : [in] 軸番号
fMov | : [in] 移動量
wszOption | : [in] 動作オプション

CORBA_VARIANT * CCaopCorRobot::execute ( const CORBA_VARIANT & Command ) [virtual]

拡張コマンドの実行

  CAOプロバイダのICaopRobot::Execute()を実行する．

引数:
Command : [in] コマンド
戻り値:
CORBA_VARIANT ： 実行結果

Variable_ptr CCaopCorRobot::getVariable | ( | const WCHAR * | wszName,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

変数オブジェクトの取得

  CAOプロバイダのICaopRobot::GetVariable()を実行する． 取得したCAOプロバイダオブジェクトはCaoProv::Variableオブジェクトでラップして返します。

引数:
wszName | : [in] 変数名
wszOption | : [in] オプション
戻り値:
Variable_ptr ： CaoProv::Variableのポインタ

CORBA_VARIANT * CCaopCorRobot::getVariableNames ( const WCHAR * wszOption ) [virtual]

変数リストの取得

  CAOプロバイダのICaopRobot::get_VariableNames()を実行する．

引数:
wszOption : [in] オプション
戻り値:
CORBA_VARIANT ： 変数名リスト

void CCaopCorRobot::goHome ( ) [virtual]

GOHOME文の実行.

  CAOプロバイダのICaopRobot::GoHome()を実行する．

WCHAR * CCaopCorRobot::help ( ) [virtual]

ヘルプ文字列の取得

  CAOプロバイダのICaopRobot::get_Help()を実行する．

戻り値:
WCHAR * : ヘルプ文字列

HRESULT CCaopCorRobot::initialize ( PVOID pArgs )

初期化処理

引数:
pArgs : [in] CAOプロバイダのロボットIF 　retval HRESULT

void CCaopCorRobot::move | ( | long | lComp,
 |  | long | lPrec,
 |  | const CORBA_VARIANT & | vntPose,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

MOVE文の実行.

  CAOプロバイダのICaopRobot::Move()を実行する．

引数:
lComp | : [in] 補完指定
lPrec | : [in] 位置決め精度
vntPose | : [in] ポーズ列
wszOption | : [in] 動作オプション

WCHAR * CCaopCorRobot::name ( ) [virtual]

ロボット名の取得

  CAOプロバイダのICaopRobot::get_Name()を実行する．

戻り値:
WCHAR * ： ロボット名

void CCaopCorRobot::rotate | ( | const CORBA_VARIANT & | vntRotSuf,
 |  | float | fDeg,
 |  | const CORBA_VARIANT & | vntPivot,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

ROTATE文の実行.

  CAOプロバイダのICaopRobot::Rotate()を実行する．

引数:
vntRotSuf | : [in] 回転面
fDeg | : [in] 角度
vntPivot | : [in] 回転中心
wszOption | : [in] 動作オプション

void CCaopCorRobot::speed | ( | long | lAxis,
 |  | float | fSpeed
 | ) | [virtual]

SPEED/JSPEED文の実行.

  CAOプロバイダのICaopRobot::Speed()を実行する．

引数:
lAxis | : [in] 軸番号
fSpeed | : [in] 速度

long CCaopCorRobot::type ( ) [virtual]

属性の取得

  CAOプロバイダのICaopRobot::get_Attribute()を実行する．

戻り値:
long ： 属性値

void CCaopCorRobot::unchuck ( const WCHAR * wszOption ) [virtual]

RELEASE文の実行.

  CAOプロバイダのICaopRobot::Unchuck()を実行する．

引数:
wszOption : [in] オプション

このクラスの解説は次のファイルから生成されました:
  • CaopCorRobot.h
  • CaopCorRobot.cpp
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CCaopCorTask class Reference

クラス CCaopCorTask の解説

GwCaopCorbaのTaskクラス. [詳細]

#include <CaopCorTask.h>

すべてのメンバ一覧

Public メソッド

CCaopCorTask ()
コンストラクタ

virtual | ~CCaopCorTask ()
デストラクタ

HRESULT | initialize (PVOID pArg)
初期化処理

virtual Variable_ptr | getVariable (const WCHAR *wszName, const WCHAR *wszOption)
変数オブジェクトの取得

virtual CORBA_VARIANT * | execute (const CORBA_VARIANT &Command)
拡張コマンドの実行

virtual void | start (long lMode, const WCHAR *wszOption)
タスク（プログラム）の開始

virtual void | stop (long lMode, const WCHAR *wszOption)
タスク（プログラム）の停止

virtual void | deleteTask (const WCHAR *wszOption)
ファイルの削除

virtual WCHAR * | name ()
拡張ボード名の取得

virtual long | type ()
属性の取得

virtual WCHAR * | help ()
ヘルプ文字列の取得

virtual WCHAR * | fileName ()
対応ファイル名の取得

virtual CORBA_VARIANT * | getVariableNames (const WCHAR *wszOption)
変数リストの取得

解説

GwCaopCorbaのTaskクラス.

CORBAサーバのTaskクラス。CaoProv::Taskインターフェースを実装する。
  CAOプロバイダのタスククラスと1対1に対応する。

コンストラクタとデストラクタの解説

CCaopCorTask::CCaopCorTask ( )

コンストラクタ

CCaopCorTask::~CCaopCorTask ( ) [virtual]

デストラクタ

メソッドの解説

void CCaopCorTask::deleteTask ( const WCHAR * wszOption ) [virtual]

ファイルの削除

  CAOプロバイダのICaopTask::Delete()を実行する．

引数:
wszOption : [in] オプション

CORBA_VARIANT * CCaopCorTask::execute ( const CORBA_VARIANT & Command ) [virtual]

拡張コマンドの実行

  CAOプロバイダのICaopTask::Execute()を実行する．

引数:
Command : [in] コマンド
戻り値:
CORBA_VARIANT ： 実行結果

WCHAR * CCaopCorTask::fileName ( ) [virtual]

対応ファイル名の取得

  CAOプロバイダのICaopTask::get_Help()を実行する．

戻り値:
WCHAR * : ファイル名

Variable_ptr CCaopCorTask::getVariable | ( | const WCHAR * | wszName,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

変数オブジェクトの取得

  CAOプロバイダのICaopTask::GetVariable()を実行する． 取得したCAOプロバイダオブジェクトはCaoProv::Variableオブジェクトでラップして返します。

引数:
wszName | : [in] 変数名
wszOption | : [in] オプション
戻り値:
Variable_ptr ： CaoProv::Variableのポインタ

CORBA_VARIANT * CCaopCorTask::getVariableNames ( const WCHAR * wszOption ) [virtual]

変数リストの取得

  CAOプロバイダのICaopTask::get_VariableNames()を実行する．

引数:
wszOption : [in] オプション
戻り値:
CORBA_VARIANT ： 変数名リスト

WCHAR * CCaopCorTask::help ( ) [virtual]

ヘルプ文字列の取得

  CAOプロバイダのICaopTask::get_Help()を実行する．

戻り値:
WCHAR * : ヘルプ文字列

HRESULT CCaopCorTask::initialize ( PVOID pArgs )

初期化処理

引数:
pArgs : [in] CAOプロバイダのタスクIF 　retval HRESULT

WCHAR * CCaopCorTask::name ( ) [virtual]

拡張ボード名の取得

  CAOプロバイダのICaopTask::get_Name()を実行する．

戻り値:
WCHAR * ： 拡張ボード名

void CCaopCorTask::start | ( | long | lMode,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

タスク（プログラム）の開始

  CAOプロバイダのICaopTask::Start()を実行する．

引数:
lMode | : [in] 開始モード
wszOption | : [in] オプション

void CCaopCorTask::stop | ( | long | lMode,
 |  | const WCHAR * | wszOption
 | ) | [virtual]

タスク（プログラム）の停止

  CAOプロバイダのICaopTask::Stop()を実行する．

引数:
lMode | : [in] 停止モード
wszOption | : [in] オプション

long CCaopCorTask::type ( ) [virtual]

属性の取得

  CAOプロバイダのICaopTask::get_Attribute()を実行する．

戻り値:
long ： 属性値

このクラスの解説は次のファイルから生成されました:
  • CaopCorTask.h
  • CaopCorTask.cpp
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CCaopCorVariable class Reference

クラス CCaopCorVariable の解説

GwCaopCorbaのVariableクラス. [詳細]

#include <CaopCorVariable.h>

すべてのメンバ一覧

Public メソッド

CCaopCorVariable ()
コンストラクタ

virtual | ~CCaopCorVariable ()
デストラクタ

HRESULT | initialize (PVOID pArg)
初期化処理

virtual WCHAR * | name ()
変数名の取得

virtual long | type ()
属性の取得

virtual WCHAR * | help ()
ヘルプ文字列の取得

virtual CORBA_VARIANT * | dateTime ()
値のタイムスタンプの取得

virtual CORBA_VARIANT * | value ()
変数値の取得

virtual void | value (const CORBA_VARIANT &_v)
変数の値の変更

解説

GwCaopCorbaのVariableクラス.

CORBAサーバのVariableクラス。CaoProv::Variableインターフェースを実装する。
  CAOプロバイダの変数クラスと1対1に対応する。

コンストラクタとデストラクタの解説

CCaopCorVariable::CCaopCorVariable ( )

コンストラクタ

CCaopCorVariable::~CCaopCorVariable ( ) [virtual]

デストラクタ

メソッドの解説

CORBA_VARIANT * CCaopCorVariable::dateTime ( ) [virtual]

値のタイムスタンプの取得

  CAOプロバイダのICaopVariable::get_DateTime()を実行する．

戻り値:
CORBA_VARIANT ： タイムスタンプ

WCHAR * CCaopCorVariable::help ( ) [virtual]

ヘルプ文字列の取得

  CAOプロバイダのICaopVariable::get_Help()を実行する．

戻り値:
WCHAR * : ヘルプ文字列

HRESULT CCaopCorVariable::initialize ( PVOID pArgs )

初期化処理

引数:
pArgs : [in] CAOプロバイダの変数IF 　retval HRESULT

WCHAR * CCaopCorVariable::name ( ) [virtual]

変数名の取得

  CAOプロバイダのICaopVariable::get_Name()を実行する．

戻り値:
WCHAR * ： 変数名

long CCaopCorVariable::type ( ) [virtual]

属性の取得

  CAOプロバイダのICaopVariable::get_Attribute()を実行する．

戻り値:
long ： 属性値

void CCaopCorVariable::value ( const CORBA_VARIANT & _v ) [virtual]

変数の値の変更

  CAOプロバイダのICaopVariable::put_Value()を実行する．

引数:
_v : [in] 変数値

CORBA_VARIANT * CCaopCorVariable::value ( ) [virtual]

変数値の取得

  CAOプロバイダのICaopVariable::get_Value()を実行する．

戻り値:
CORBA_VARIANT : 変数値

このクラスの解説は次のファイルから生成されました:
  • CaopCorVariable.h
  • CaopCorVariable.cpp
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CCorbaServer class Reference

クラス CCorbaServer の解説

GwCaopCorbaのCorbaServerクラス. [詳細]

#include <CorbaServer.h>

すべてのメンバ一覧

Public メソッド

CCorbaServer ()
コンストラクタ

virtual | ~CCorbaServer ()
デストラクタ

HRESULT | Start ()
CORBAサーバスレッドの開始.

HRESULT | Stop ()
CORBAサーバスレッドの停止.

HRESULT | UnregName (const char *szCtrlName)
ネームサービスの登録削除

Static Public メソッド

void __cdecl | ServerThread (void *pSub)
CORBAサーバスレッド.

解説

GwCaopCorbaのCorbaServerクラス.

CORBAサーバの起動クラス。CORBAのメソッド受付をするスレッドの起動・停止を行います。
  スレッドでは、CaoProv::Controllerオブジェクトを作成し、ネームサービスに登録します。
ネームサービスからの削除メソッドも実装しています。
  スレッド起動中にネームサービスから削除すると正しく動作しなくなるので注意すること。

コンストラクタとデストラクタの解説

CCorbaServer::CCorbaServer ( )

コンストラクタ

CCorbaServer::~CCorbaServer ( ) [virtual]

デストラクタ

メソッドの解説

void __cdecl CCorbaServer::ServerThread ( void * pSub ) [static]

CORBAサーバスレッド.

  CaoProv::Controllerオブジェクトを作成し、ネームサービスに登録します。
  その後、メソッドの呼び出し待ちになります。
ネームサービスに同名のものが登録されていた場合は、このスレッドは直ちに終了します。

引数:
pSub : [in] スレッドの実行開始アドレス

HRESULT CCorbaServer::Start ( )

CORBAサーバスレッドの開始.

戻り値:
HRESULT

HRESULT CCorbaServer::Stop ( )

CORBAサーバスレッドの停止.

戻り値:
HRESULT

HRESULT CCorbaServer::UnregName ( const char * szCtrlName )

ネームサービスの登録削除

引数:
szCtrlName : [in] 削除コントローラ名
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CorbaServer.h
  • CorbaServer.cpp
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CEventSink class Reference

クラス CEventSink の解説

CAOのイベントシンククラス. [詳細]

#include <EventSink.h>

すべてのメンバ一覧

Public メソッド

CEventSink ()
コンストラクタ

~CEventSink ()
デストラクタ

HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | _Initialize (PVOID pArgs[])
初期化処理

HRESULT | _Terminate ()
後処理

HRESULT | OnMessage (IUnknown *pVal)
OnMessageのイベント処理.

解説

CAOのイベントシンククラス.

シンクインターフェースを持つCOMのクラス．
CaopCorbaControllerクラスで作成されるクラス．外部からインスタンスの作成は不可能．
  プロバイダからのOnMessageイベントを受け取る．

コンストラクタとデストラクタの解説

CEventSink::CEventSink ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CEventSink::~CEventSink ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CEventSink::_Initialize ( PVOID pArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
pArgs [] : [in]　vntArgs[0] - CaoProvControllerのIFポインタ
          vntArgs[1] - RaoProvControllerのIFポインタ
戻り値:
HRESULT

STDMETHODIMP CEventSink::_Terminate ( )

後処理

  オブジェクト消滅時の後処理は FinalRelease() を使うこと．

戻り値:
HRESULT

HRESULT CEventSink::FinalConstruct ( )

ファイナルコンストラクタ

  オブジェクト生成時に一度だけ呼ばれます．

void CEventSink::FinalRelease ( )

ファイナルデストラクタ

  オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CEventSink::InterfaceSupportsErrorInfo ( REFIID riid )

STDMETHODIMP CEventSink::OnMessage ( IUnknown * pVal )

OnMessageのイベント処理.

  CaoProviderで発生したOnMessageイベントを処理する．

引数:
pVal : [in]　CaoPropMessageのIFポインタ
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • EventSink.h
  • EventSink.cpp
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaoProv::Command interface Reference

インタフェースCaoProv::Command の解説

import "CaoProvCorba.idl";

CaoProv::Commandのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CORBA_VARIANT | execute (in long lOption)
void | cancel ()

Public 変数

readonly attribute wstring | name
readonly attribute long | type
readonly attribute wstring | help
readonly attribute long | state
attribute CORBA_VARIANT | parameters
attribute long | timeout

メソッドの解説

void CaoProv::Command::cancel ( )

CORBA_VARIANT CaoProv::Command::execute ( in long lOption )

変数の解説

readonly attribute wstring CaoProv::Command::help

readonly attribute wstring CaoProv::Command::name

attribute CORBA_VARIANT CaoProv::Command::parameters

readonly attribute long CaoProv::Command::state

attribute long CaoProv::Command::timeout

readonly attribute long CaoProv::Command::type

このインタフェースの解説は次のファイルから生成されました:
  • CaoProvCorba.idl
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaoProv::Controller interface Reference

インタフェースCaoProv::Controller の解説

import "CaoProvCorba.idl";

すべてのメンバ一覧

Public メソッド

CORBA_VARIANT | getExtensionNames (in wstring wszOption)
CORBA_VARIANT | getFileNames (in wstring wszOption)
CORBA_VARIANT | getRobotNames (in wstring wszOption)
CORBA_VARIANT | getTaskNames (in wstring wszOption)
CORBA_VARIANT | getVariableNames (in wstring wszOption)
CORBA_VARIANT | getCommandNames (in wstring wszOption)
void | connect (in wstring wszName, in wstring wszOption, in ControllerEvents pCaoEvent)
void | disconnect ()
Extension | getExtension (in wstring wszName, in wstring wszOption)
File | getFile (in wstring wszName, in wstring wszOption)
Robot | getRobot (in wstring wszName, in wstring wszOption)
Task | getTask (in wstring wszName, in wstring wszOption)
Variable | getVariable (in wstring wszName, in wstring wszOption)
Command | getCommand (in wstring wszName, in wstring wszOption)
CORBA_VARIANT | execute (in CORBA_VARIANT Command)

Public 変数

readonly attribute wstring | name
readonly attribute long | type
readonly attribute wstring | help

メソッドの解説

void CaoProv::Controller::connect | ( | in wstring | wszName,
 |  | in wstring | wszOption,
 |  | in ControllerEvents | pCaoEvent
 | ) |

void CaoProv::Controller::disconnect ( )

CORBA_VARIANT CaoProv::Controller::execute ( in CORBA_VARIANT Command )

Command CaoProv::Controller::getCommand | ( | in wstring | wszName,
 |  | in wstring | wszOption
 | ) |

CORBA_VARIANT CaoProv::Controller::getCommandNames ( in wstring wszOption )

Extension CaoProv::Controller::getExtension | ( | in wstring | wszName,
 |  | in wstring | wszOption
 | ) |

CORBA_VARIANT CaoProv::Controller::getExtensionNames ( in wstring wszOption )

File CaoProv::Controller::getFile | ( | in wstring | wszName,
 |  | in wstring | wszOption
 | ) |

CORBA_VARIANT CaoProv::Controller::getFileNames ( in wstring wszOption )

Robot CaoProv::Controller::getRobot | ( | in wstring | wszName,
 |  | in wstring | wszOption
 | ) |

CORBA_VARIANT CaoProv::Controller::getRobotNames ( in wstring wszOption )

Task CaoProv::Controller::getTask | ( | in wstring | wszName,
 |  | in wstring | wszOption
 | ) |

CORBA_VARIANT CaoProv::Controller::getTaskNames ( in wstring wszOption )

Variable CaoProv::Controller::getVariable | ( | in wstring | wszName,
 |  | in wstring | wszOption
 | ) |

CORBA_VARIANT CaoProv::Controller::getVariableNames ( in wstring wszOption )

変数の解説

readonly attribute wstring CaoProv::Controller::help

readonly attribute wstring CaoProv::Controller::name

readonly attribute long CaoProv::Controller::type

このインタフェースの解説は次のファイルから生成されました:
  • CaoProvCorba.idl
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaoProv::ControllerEvents interface Reference

インタフェースCaoProv::ControllerEvents の解説

import "CaoProvCorba.idl";

すべてのメンバ一覧

Public メソッド

void onMessage (in Message CaopMessage)

メソッドの解説

void CaoProv::ControllerEvents::onMessage ( in Message CaopMessage )

このインタフェースの解説は次のファイルから生成されました:
  • CaoProvCorba.idl
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaoProv::CORBA_VARIANT struct Reference

構造体 CaoProv::CORBA_VARIANT の解説

import "CaoProvCorba.idl";

すべてのメンバ一覧

Public 変数

unsigned short | vt
any | val
CORBA_SAFEARRAY sa

変数の解説

CORBA_SAFEARRAY CaoProv::CORBA_VARIANT::sa

any CaoProv::CORBA_VARIANT::val

unsigned short CaoProv::CORBA_VARIANT::vt

この構造体の解説は次のファイルから生成されました:
  • CaoProvCorba.idl
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CServiceModule class Reference

クラス CServiceModule の解説

#include <StdAfx.h>

CServiceModuleのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

HRESULT | RegisterServer (BOOL bRegTypeLib, BOOL bService)
HRESULT | UnregisterServer ()
void | Init (_ATL_OBJMAP_ENTRY *p, HINSTANCE h, UINT nServiceNameID, const GUID *plibid=NULL)
void | Start ()
void | ServiceMain (DWORD dwArgc, LPTSTR *lpszArgv)
void | Handler (DWORD dwOpcode)
void | Run ()
BOOL | IsInstalled ()
BOOL | Install ()
BOOL | Uninstall ()
LONG | Unlock ()
void | LogEvent (LPCTSTR pszFormat,...)
void | SetServiceStatus (DWORD dwState)
void | SetupAsLocalServer ()
HRESULT | VntToCorbaVnt (VARIANT vntSrc, CORBA_VARIANT *pvntRet)
VARIANT→CORBA_VARIANT変換.

HRESULT | CorbaVntToVnt (CORBA_VARIANT vntSrc, VARIANT *pvntRet)
CORBA_VARIANT→VARIANT変換.

Public 変数

TCHAR | m_szServiceName [256]
SERVICE_STATUS_HANDLE | m_hServiceStatus
SERVICE_STATUS | m_status
DWORD | dwThreadID
BOOL | m_bService
CCorbaServer m_CorbaSvr
int | m_argc
char * | m_argv [20]

メソッドの解説

HRESULT CServiceModule::CorbaVntToVnt | ( | CORBA_VARIANT | vntSrc,
 |  | VARIANT * | pvntRet
 | ) |

CORBA_VARIANT→VARIANT変換.

  CaoProvCorba.idlで定義された擬似VARIANT型をVARIANT型へ変換します。

引数:
vntSrc | : [in]　変換前データ
pvntRet | : [out]　変換後データ
戻り値:
HRESULT

void CServiceModule::Handler ( DWORD dwOpcode ) [inline]

void CServiceModule::Init | ( | _ATL_OBJMAP_ENTRY * | p,
 |  | HINSTANCE | h,
 |  | UINT | nServiceNameID,
 |  | const GUID * | plibid = NULL
 | ) | [inline]

BOOL CServiceModule::Install ( ) [inline]

BOOL CServiceModule::IsInstalled ( )

void CServiceModule::LogEvent | ( | LPCTSTR | pszFormat,
 |  | ... |
 | ) |

HRESULT CServiceModule::RegisterServer | ( | BOOL | bRegTypeLib,
 |  | BOOL | bService
 | ) | [inline]

void CServiceModule::Run ( )

void CServiceModule::ServiceMain | ( | DWORD | dwArgc,
 |  | LPTSTR * | lpszArgv
 | ) | [inline]

void CServiceModule::SetServiceStatus ( DWORD dwState )

void CServiceModule::SetupAsLocalServer ( )

void CServiceModule::Start ( ) [inline]

BOOL CServiceModule::Uninstall ( ) [inline]

LONG CServiceModule::Unlock ( )

HRESULT CServiceModule::UnregisterServer ( ) [inline]

HRESULT CServiceModule::VntToCorbaVnt | ( | VARIANT | vntSrc,
 |  | CORBA_VARIANT * | pvntRet
 | ) |

VARIANT→CORBA_VARIANT変換.

  VARIANT型をCaoProvCorba.idlで定義された擬似VARIANT型へ変換します。

引数:
vntSrc | : [in]　変換前データ
pvntRet | : [out]　変換後データ
戻り値:
HRESULT

変数の解説

DWORD CServiceModule::dwThreadID

int CServiceModule::m_argc

char* CServiceModule::m_argv[20]

BOOL CServiceModule::m_bService

CCorbaServer CServiceModule::m_CorbaSvr

SERVICE_STATUS_HANDLE CServiceModule::m_hServiceStatus

SERVICE_STATUS CServiceModule::m_status

TCHAR CServiceModule::m_szServiceName[256]

このクラスの解説は次のファイルから生成されました:
  • StdAfx.h
  • GwCaopCorba.cpp
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


GWCAOPCORBALib::EventSink class Reference

クラス GWCAOPCORBALib::EventSink の解説

import "GwCaopCorba.idl";

このクラスの解説は次のファイルから生成されました:
  • GwCaopCorba.idl
Generated on Mon Oct 25 19:43:00 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaoProv::Extension interface Reference

インタフェースCaoProv::Extension の解説

import "CaoProvCorba.idl";

すべてのメンバ一覧

Public メソッド

CORBA_VARIANT | getVariableNames (in wstring wszOption)
Variable | getVariable (in wstring wszName, in wstring wszOption)
CORBA_VARIANT | execute (in CORBA_VARIANT Command)

Public 変数

readonly attribute wstring | name
readonly attribute long | type
readonly attribute wstring | help

メソッドの解説

CORBA_VARIANT CaoProv::Extension::execute ( in CORBA_VARIANT Command )

Variable CaoProv::Extension::getVariable | ( | in wstring | wszName,
 |  | in wstring | wszOption
 | ) |

CORBA_VARIANT CaoProv::Extension::getVariableNames ( in wstring wszOption )

変数の解説

readonly attribute wstring CaoProv::Extension::help

readonly attribute wstring CaoProv::Extension::name

readonly attribute long CaoProv::Extension::type

このインタフェースの解説は次のファイルから生成されました:
  • CaoProvCorba.idl
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaoProv::File interface Reference

インタフェースCaoProv::File の解説

import "CaoProvCorba.idl";

CaoProv::Fileのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CORBA_VARIANT | getFileNames (in wstring wszOption)
CORBA_VARIANT | getVariableNames (in wstring wszOption)
File | getFile (in wstring wszName, in wstring wszOption)
Variable | getVariable (in wstring wszName, in wstring wszOption)
void | copy (in wstring wszName, in wstring wszOption)
void | deleteFile (in wstring wszOption)
CORBA_VARIANT | execute (in CORBA_VARIANT Command)
void | move (in wstring wszName, in wstring wszOption)
wstring | run (in wstring wszOption)

Public 変数

readonly attribute wstring | name
readonly attribute long | type
readonly attribute wstring | help
readonly attribute CORBA_VARIANT | dateCreated
readonly attribute CORBA_VARIANT | dateLastAccessed
readonly attribute CORBA_VARIANT | dateLastModified
readonly attribute wstring | path
readonly attribute long | size
readonly attribute wstring | fileType
attribute CORBA_VARIANT | value

メソッドの解説

void CaoProv::File::copy | ( | in wstring | wszName,
 |  | in wstring | wszOption
 | ) |

void CaoProv::File::deleteFile ( in wstring wszOption )

CORBA_VARIANT CaoProv::File::execute ( in CORBA_VARIANT Command )

File CaoProv::File::getFile | ( | in wstring | wszName,
 |  | in wstring | wszOption
 | ) |

CORBA_VARIANT CaoProv::File::getFileNames ( in wstring wszOption )

Variable CaoProv::File::getVariable | ( | in wstring | wszName,
 |  | in wstring | wszOption
 | ) |

CORBA_VARIANT CaoProv::File::getVariableNames ( in wstring wszOption )

void CaoProv::File::move | ( | in wstring | wszName,
 |  | in wstring | wszOption
 | ) |

wstring CaoProv::File::run ( in wstring wszOption )

変数の解説

readonly attribute CORBA_VARIANT CaoProv::File::dateCreated

readonly attribute CORBA_VARIANT CaoProv::File::dateLastAccessed

readonly attribute CORBA_VARIANT CaoProv::File::dateLastModified

readonly attribute wstring CaoProv::File::fileType

readonly attribute wstring CaoProv::File::help

readonly attribute wstring CaoProv::File::name

readonly attribute wstring CaoProv::File::path

readonly attribute long CaoProv::File::size

readonly attribute long CaoProv::File::type

attribute CORBA_VARIANT CaoProv::File::value

このインタフェースの解説は次のファイルから生成されました:
  • CaoProvCorba.idl
Generated on Mon Oct 25 19:43:00 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


IEventSink interface Reference

インタフェースIEventSink の解説

import "GwCaopCorba.idl";

すべてのメンバ一覧

Public メソッド

HRESULT OnMessage ([in] IUnknown *pVal)

メソッドの解説

HRESULT IEventSink::OnMessage ( [in] IUnknown * pVal )

このインタフェースの解説は次のファイルから生成されました:
  • GwCaopCorba.idl
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaoProv::Message interface Reference

インタフェースCaoProv::Message の解説

import "CaoProvCorba.idl";

CaoProv::Messageのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

void | clear ()
void | reply (in CORBA_VARIANT vntData)

Public 変数

readonly attribute CORBA_VARIANT | dateTime
readonly attribute wstring | description
readonly attribute wstring | destination
readonly attribute long | number
readonly attribute long | option
readonly attribute wstring | source
readonly attribute CORBA_VARIANT | value

メソッドの解説

void CaoProv::Message::clear ( )

void CaoProv::Message::reply ( in CORBA_VARIANT vntData )

変数の解説

readonly attribute CORBA_VARIANT CaoProv::Message::dateTime

readonly attribute wstring CaoProv::Message::description

readonly attribute wstring CaoProv::Message::destination

readonly attribute long CaoProv::Message::number

readonly attribute long CaoProv::Message::option

readonly attribute wstring CaoProv::Message::source

readonly attribute CORBA_VARIANT CaoProv::Message::value

このインタフェースの解説は次のファイルから生成されました:
  • CaoProvCorba.idl
Generated on Mon Oct 25 19:43:00 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaoProv::Robot interface Reference

インタフェースCaoProv::Robot の解説

import "CaoProvCorba.idl";

すべてのメンバ一覧

Public メソッド

CORBA_VARIANT | getVariableNames (in wstring wszOption)
Variable | getVariable (in wstring wszName, in wstring wszOption)
CORBA_VARIANT | execute (in CORBA_VARIANT Command)
void | accelerate (in long lAxis, in float fAccel, in float fDecel)
void | cancel ()
void | change (in wstring wszName)
void | chuck (in wstring wszOption)
void | drive (in long lNo, in float fMov, in wstring wszOption)
void | goHome ()
void | move (in long lComp, in long lPrec, in CORBA_VARIANT vntPose, in wstring wszOption)
void | rotate (in CORBA_VARIANT vntRotSuf, in float fDeg, in CORBA_VARIANT vntPivot, in wstring wszOption)
void | speed (in long lAxis, in float fSpeed)
void | unchuck (in wstring wszOption)

Public 変数

readonly attribute wstring | name
readonly attribute long | type
readonly attribute wstring | help

メソッドの解説

void CaoProv::Robot::accelerate | ( | in long | lAxis,
 |  | in float | fAccel,
 |  | in float | fDecel
 | ) |

void CaoProv::Robot::cancel ( )

void CaoProv::Robot::change ( in wstring wszName )

void CaoProv::Robot::chuck ( in wstring wszOption )

void CaoProv::Robot::drive | ( | in long | lNo,
 |  | in float | fMov,
 |  | in wstring | wszOption
 | ) |

CORBA_VARIANT CaoProv::Robot::execute ( in CORBA_VARIANT Command )

Variable CaoProv::Robot::getVariable | ( | in wstring | wszName,
 |  | in wstring | wszOption
 | ) |

CORBA_VARIANT CaoProv::Robot::getVariableNames ( in wstring wszOption )

void CaoProv::Robot::goHome ( )

void CaoProv::Robot::move | ( | in long | lComp,
 |  | in long | lPrec,
 |  | in CORBA_VARIANT | vntPose,
 |  | in wstring | wszOption
 | ) |

void CaoProv::Robot::rotate | ( | in CORBA_VARIANT | vntRotSuf,
 |  | in float | fDeg,
 |  | in CORBA_VARIANT | vntPivot,
 |  | in wstring | wszOption
 | ) |

void CaoProv::Robot::speed | ( | in long | lAxis,
 |  | in float | fSpeed
 | ) |

void CaoProv::Robot::unchuck ( in wstring wszOption )

変数の解説

readonly attribute wstring CaoProv::Robot::help

readonly attribute wstring CaoProv::Robot::name

readonly attribute long CaoProv::Robot::type

このインタフェースの解説は次のファイルから生成されました:
  • CaoProvCorba.idl
Generated on Mon Oct 25 19:43:00 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaoProv::Task interface Reference

インタフェースCaoProv::Task の解説

import "CaoProvCorba.idl";

すべてのメンバ一覧

Public メソッド

CORBA_VARIANT | getVariableNames (in wstring wszOption)
Variable | getVariable (in wstring wszName, in wstring wszOption)
CORBA_VARIANT | execute (in CORBA_VARIANT Command)
void | deleteTask (in wstring wszOption)
void | start (in long lMode, in wstring wszOption)
void | stop (in long lMode, in wstring wszOption)

Public 変数

readonly attribute wstring | name
readonly attribute long | type
readonly attribute wstring | help
readonly attribute wstring | fileName

メソッドの解説

void CaoProv::Task::deleteTask ( in wstring wszOption )

CORBA_VARIANT CaoProv::Task::execute ( in CORBA_VARIANT Command )

Variable CaoProv::Task::getVariable | ( | in wstring | wszName,
 |  | in wstring | wszOption
 | ) |

CORBA_VARIANT CaoProv::Task::getVariableNames ( in wstring wszOption )

void CaoProv::Task::start | ( | in long | lMode,
 |  | in wstring | wszOption
 | ) |

void CaoProv::Task::stop | ( | in long | lMode,
 |  | in wstring | wszOption
 | ) |

変数の解説

readonly attribute wstring CaoProv::Task::fileName

readonly attribute wstring CaoProv::Task::help

readonly attribute wstring CaoProv::Task::name

readonly attribute long CaoProv::Task::type

このインタフェースの解説は次のファイルから生成されました:
  • CaoProvCorba.idl
Generated on Mon Oct 25 19:43:00 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaoProv::Variable interface Reference

インタフェースCaoProv::Variable の解説

import "CaoProvCorba.idl";

CaoProv::Variableのコラボレーション図

[凡例]
すべてのメンバ一覧

Public 変数

readonly attribute wstring | name
readonly attribute long | type
readonly attribute wstring | help
readonly attribute CORBA_VARIANT | dateTime
attribute CORBA_VARIANT | value

変数の解説

readonly attribute CORBA_VARIANT CaoProv::Variable::dateTime

readonly attribute wstring CaoProv::Variable::help

readonly attribute wstring CaoProv::Variable::name

readonly attribute long CaoProv::Variable::type

attribute CORBA_VARIANT CaoProv::Variable::value

このインタフェースの解説は次のファイルから生成されました:
  • CaoProvCorba.idl
Generated on Mon Oct 25 19:43:00 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


Compound Member Index

GwCaopCorba Project 構成メンバ

_ | a | c | d | e | f | g | h | i | l | m | n | o | p | r | s | t | u | v | x | ~

これはクラスメンバの一覧で、それぞれが属しているクラスの解説へリンクしています。

- _ -

  • _Initialize() : CEventSink
  • _Terminate() : CEventSink

- a -

  • accelerate() : CaoProv::Robot, CCaopCorRobot

- c -

  • c : _IID
  • cancel() : CaoProv::Command, CaoProv::Robot, CCaopCorRobot, CCaopCorCommand
  • CCaopCorCommand() : CCaopCorCommand
  • CCaopCorController() : CCaopCorController
  • CCaopCorExtension() : CCaopCorExtension
  • CCaopCorFile() : CCaopCorFile
  • CCaopCorMessage() : CCaopCorMessage
  • CCaopCorRobot() : CCaopCorRobot
  • CCaopCorTask() : CCaopCorTask
  • CCaopCorVariable() : CCaopCorVariable
  • CCorbaServer() : CCorbaServer
  • CEventSink() : CEventSink
  • change() : CaoProv::Robot, CCaopCorRobot
  • chuck() : CaoProv::Robot, CCaopCorRobot
  • clear() : CaoProv::Message, CCaopCorMessage
  • connect() : CaoProv::Controller, CCaopCorController
  • copy() : CaoProv::File, CCaopCorFile
  • CorbaVntToVnt() : CServiceModule

- d -

  • dateCreated : CCaopCorFile, CaoProv::File
  • dateLastAccessed : CCaopCorFile, CaoProv::File
  • dateLastModified : CCaopCorFile, CaoProv::File
  • dateTime : CCaopCorVariable, CCaopCorMessage, CaoProv::Message, CaoProv::Variable
  • deleteFile() : CaoProv::File, CCaopCorFile
  • deleteTask() : CaoProv::Task, CCaopCorTask
  • description : CCaopCorMessage, CaoProv::Message
  • destination : CCaopCorMessage, CaoProv::Message
  • disconnect() : CaoProv::Controller, CCaopCorController
  • drive() : CaoProv::Robot, CCaopCorRobot
  • dwThreadID : CServiceModule

- e -

  • execute() : CaoProv::Command, CaoProv::Task, CaoProv::Robot, CaoProv::File, CaoProv::Extension, CaoProv::Controller, CCaopCorTask, CCaopCorRobot, CCaopCorFile, CCaopCorExtension, CCaopCorController, CCaopCorCommand

- f -

  • fileName : CCaopCorTask, CaoProv::Task
  • fileType : CCaopCorFile, CaoProv::File
  • FinalConstruct() : CEventSink
  • FinalRelease() : CEventSink
  • Format : _MIDL_PROC_FORMAT_STRING, _MIDL_TYPE_FORMAT_STRING

- g -

  • getCommand() : CaoProv::Controller, CCaopCorController
  • getCommandNames() : CaoProv::Controller, CCaopCorController
  • getExtension() : CaoProv::Controller, CCaopCorController
  • getExtensionNames() : CaoProv::Controller, CCaopCorController
  • getFile() : CaoProv::File, CaoProv::Controller, CCaopCorFile, CCaopCorController
  • getFileNames() : CaoProv::File, CaoProv::Controller, CCaopCorFile, CCaopCorController
  • getRobot() : CaoProv::Controller, CCaopCorController
  • getRobotNames() : CaoProv::Controller, CCaopCorController
  • getTask() : CaoProv::Controller, CCaopCorController
  • getTaskNames() : CaoProv::Controller, CCaopCorController
  • getVariable() : CaoProv::Task, CaoProv::Robot, CaoProv::File, CaoProv::Extension, CaoProv::Controller, CCaopCorTask, CCaopCorRobot, CCaopCorFile, CCaopCorExtension, CCaopCorController
  • getVariableNames() : CaoProv::Task, CaoProv::Robot, CaoProv::File, CaoProv::Extension, CaoProv::Controller, CCaopCorTask, CCaopCorRobot, CCaopCorFile, CCaopCorExtension, CCaopCorController
  • goHome() : CaoProv::Robot, CCaopCorRobot

- h -

  • Handler() : CServiceModule
  • help : CCaopCorVariable, CCaopCorTask, CCaopCorRobot, CCaopCorFile, CCaopCorExtension, CCaopCorController, CCaopCorCommand, CaoProv::Command, CaoProv::Variable, CaoProv::Task, CaoProv::Robot, CaoProv::File, CaoProv::Extension, CaoProv::Controller

- i -

  • Init() : CServiceModule
  • initialize() : CCaopCorVariable, CCaopCorTask, CCaopCorRobot, CCaopCorMessage, CCaopCorFile, CCaopCorExtension, CCaopCorController, CCaopCorCommand
  • Install() : CServiceModule
  • InterfaceSupportsErrorInfo() : CEventSink
  • IsInstalled() : CServiceModule

- l -

  • LogEvent() : CServiceModule

- m -

  • m_argc : CServiceModule
  • m_argv : CServiceModule
  • m_bService : CServiceModule
  • m_CorbaSvr : CServiceModule
  • m_hServiceStatus : CServiceModule
  • m_status : CServiceModule
  • m_szServiceName : CServiceModule
  • move() : CaoProv::Robot, CaoProv::File, CCaopCorRobot, CCaopCorFile

- n -

  • name : CCaopCorVariable, CCaopCorTask, CCaopCorRobot, CCaopCorFile, CCaopCorExtension, CCaopCorController, CCaopCorCommand, CaoProv::Command, CaoProv::Variable, CaoProv::Task, CaoProv::Robot, CaoProv::File, CaoProv::Extension, CaoProv::Controller
  • number : CCaopCorMessage, CaoProv::Message

- o -

  • onMessage() : CaoProv::ControllerEvents
  • OnMessage() : IEventSink, CEventSink
  • option : CCaopCorMessage, CaoProv::Message

- p -

  • Pad : _MIDL_PROC_FORMAT_STRING, _MIDL_TYPE_FORMAT_STRING
  • parameters : CCaopCorCommand, CaoProv::Command
  • path : CCaopCorFile, CaoProv::File

- r -

  • RegisterServer() : CServiceModule
  • reply() : CaoProv::Message, CCaopCorMessage
  • rotate() : CaoProv::Robot, CCaopCorRobot
  • Run() : CServiceModule
  • run() : CaoProv::File, CCaopCorFile

- s -

  • s1 : _IID
  • s2 : _IID
  • sa : CaoProv::CORBA_VARIANT
  • ServerThread() : CCorbaServer
  • ServiceMain() : CServiceModule
  • SetServiceStatus() : CServiceModule
  • SetupAsLocalServer() : CServiceModule
  • size : CCaopCorFile, CaoProv::File
  • source : CCaopCorMessage, CaoProv::Message
  • speed() : CaoProv::Robot, CCaopCorRobot
  • start() : CaoProv::Task, CCaopCorTask
  • Start() : CServiceModule, CCorbaServer
  • state : CCaopCorCommand, CaoProv::Command
  • stop() : CaoProv::Task, CCaopCorTask
  • Stop() : CCorbaServer

- t -

  • timeout : CCaopCorCommand, CaoProv::Command
  • type : CCaopCorVariable, CCaopCorTask, CCaopCorRobot, CCaopCorFile, CCaopCorExtension, CCaopCorController, CCaopCorCommand, CaoProv::Command, CaoProv::Variable, CaoProv::Task, CaoProv::Robot, CaoProv::File, CaoProv::Extension, CaoProv::Controller

- u -

  • unchuck() : CaoProv::Robot, CCaopCorRobot
  • Uninstall() : CServiceModule
  • Unlock() : CServiceModule
  • UnregisterServer() : CServiceModule
  • UnregName() : CCorbaServer

- v -

  • val : CaoProv::CORBA_VARIANT
  • value : CCaopCorVariable, CCaopCorMessage, CCaopCorFile, CaoProv::Message, CaoProv::Variable, CaoProv::File
  • VntToCorbaVnt() : CServiceModule
  • vt : CaoProv::CORBA_VARIANT

- x -

  • x : _IID

- ~ -

  • ~CCaopCorCommand() : CCaopCorCommand
  • ~CCaopCorController() : CCaopCorController
  • ~CCaopCorExtension() : CCaopCorExtension
  • ~CCaopCorFile() : CCaopCorFile
  • ~CCaopCorMessage() : CCaopCorMessage
  • ~CCaopCorRobot() : CCaopCorRobot
  • ~CCaopCorTask() : CCaopCorTask
  • ~CCaopCorVariable() : CCaopCorVariable
  • ~CCorbaServer() : CCorbaServer
  • ~CEventSink() : CEventSink
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


Namespace Index

GwCaopCorba Project 名前空間一覧

名前空間の一覧です。
CaoProv
GWCAOPCORBALib
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaoProv Namespace Reference

名前空間 CaoProv の解説

構成

interface | Command
interface | Controller
interface | ControllerEvents
struct | CORBA_VARIANT
interface | Extension
interface | File
interface | Message
interface | Robot
interface | Task
interface | Variable

Typedef

typedef sequence< CORBA_VARIANT > | CORBA_SAFEARRAY

Typedef の解説

typedef sequence<CORBA_VARIANT> CaoProv::CORBA_SAFEARRAY

Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


GWCAOPCORBALib Namespace Reference

名前空間 GWCAOPCORBALib の解説

構成

class EventSink

関数

importlib ("stdole32.tlb")
importlib ("stdole2.tlb")

関数の解説

importlib ( "stdole2.tlb" )

importlib ( "stdole32.tlb" )

Generated on Mon Oct 25 19:43:00 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


File Member Index

GwCaopCorba Project ファイルメンバ

_ | a | c | d | e | f | i | l | m | o | p | r | s | t | u

これはファイルメンバの一覧です。それぞれが属しているファイルの解説へリンクしています。

- _ -

  • __MIDL_ProcFormatString : GwCaopCorba_p.c
  • __MIDL_TypeFormatString : GwCaopCorba_p.c
  • __pad0__ : GwCaopCorba.h
  • __REQUIRED_RPCNDR_H_VERSION__ : GwCaopCorba.h
  • __REQUIRED_RPCPROXY_H_VERSION__ : GwCaopCorba_p.c
  • _ATL_APARTMENT_THREADED : StdAfx.h
  • _Module : StdAfx.h, GwCaopCorba.cpp
  • _tWinMain() : GwCaopCorba.cpp
  • _WIN32_WINNT : StdAfx.h

- a -

  • AFX_CAOPCORCOMMAND_H__44DBF0D9_5C2F_47DC_B061_6E04F69BF643__INCLUDED_ : CaopCorCommand.h
  • AFX_CAOPCORCONTROLLER_H__7181812F_E80C_4E60_B640_82A6BF49AC48__INCLUDED_ : CaopCorController.h
  • AFX_CAOPCOREXTENSION_H__1D732A34_6570_4E2D_B417_CB280DBF4F60__INCLUDED_ : CaopCorExtension.h
  • AFX_CAOPCORFILE_H__7BBD0652_BD7E_46F5_9BEE_11DFE9E2CAAF__INCLUDED_ : CaopCorFile.h
  • AFX_CAOPCORMESSAGE_H__10B17A7C_7A2C_474E_8B85_27C0C6FFC175__INCLUDED_ : CaopCorMessage.h
  • AFX_CAOPCORROBOT_H__73C329C8_5F88_4022_B346_DF415612E5CE__INCLUDED_ : CaopCorRobot.h
  • AFX_CAOPCORTASK_H__43C215C0_B349_4369_BB80_19A673E35E73__INCLUDED_ : CaopCorTask.h
  • AFX_CAOPCORVARIABLE_H__426A6316_14DF_4453_A94A_673E2CA65B8F__INCLUDED_ : CaopCorVariable.h
  • AFX_CORBASERVER_H__993BCE13_EC11_4A0B_8877_5B4A4E6085A6__INCLUDED_ : CorbaServer.h
  • AFX_STDAFX_H__503EE5DC_08C2_490C_BAC3_4196D94D05A6__INCLUDED_ : StdAfx.h

- c -

  • CINTERFACE_PROXY_VTABLE() : GwCaopCorba_p.c
  • CLSID : GwCaopCorba_i.c
  • CLSID_EventSink : GwCaopCorba_i.c, GwCaopCorba.h
  • CORBA_NAME_SIZE : CorbaServer.h

- d -

  • DECLSPEC_UUID() : GwCaopCorba.h

- e -

  • EventSink : GwCaopCorba.h

- f -

  • FindOneOf() : StdAfx.h, GwCaopCorba.cpp

- i -

  • IDR_EVENTSINK : resource.h
  • IDR_GwCaopCorba : resource.h
  • IDS_SERVICENAME : resource.h
  • IEventSink : GwCaopCorba.h
  • IEventSink_FormatStringOffsetTable : GwCaopCorba_p.c
  • IEventSink_OnMessage_Proxy() : GwCaopCorba.h
  • IEventSink_OnMessage_Stub() : GwCaopCorba.h
  • IEventSink_ProxyInfo : GwCaopCorba_p.c
  • IEventSink_ServerInfo : GwCaopCorba_p.c
  • IID : GwCaopCorba_i.c
  • IID_IEventSink : GwCaopCorba_i.c, GwCaopCorba.h

- l -

  • LIBID_GWCAOPCORBALib : GwCaopCorba_i.c, GwCaopCorba.h

- m -

  • MAX_STR_LEN : StdAfx.h
  • MIDL_PROC_FORMAT_STRING : GwCaopCorba_p.c
  • MIDL_TYPE_FORMAT_STRING : GwCaopCorba_p.c
  • MIDL_user_allocate() : GwCaopCorba.h
  • MIDL_user_free() : GwCaopCorba.h

- o -

  • Object_StubDesc : GwCaopCorba_p.c

- p -

  • PROC_FORMAT_STRING_SIZE : GwCaopCorba_p.c
  • PROXY_DELEGATION : dlldata.c

- r -

  • REFERENCE_PROXY_FILE() : dlldata.c

- s -

  • SAFE_CLOSE : StdAfx.h
  • SAFE_DELETE : StdAfx.h
  • SAFE_RELEASE : StdAfx.h
  • STRICT : StdAfx.h

- t -

  • THROW_HRESULT : StdAfx.h
  • TYPE_FORMAT_STRING_SIZE : GwCaopCorba_p.c

- u -

  • USE_STUBLESS_PROXY : GwCaopCorba_p.c
Generated on Mon Oct 25 19:43:00 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


Namespace Member Index

GwCaopCorba Project 名前空間メンバ

c | i

これは名前空間の一覧です。それぞれの名前空間の解説へリンクしています。

- c -

  • CORBA_SAFEARRAY : CaoProv

- i -

  • importlib() : GWCAOPCORBALib
Generated on Mon Oct 25 19:43:00 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorCommand.h Source File

CaopCorCommand.h

解説を見る。
00001
00011 #if !defined(AFX_CAOPCORCOMMAND_H__44DBF0D9_5C2F_47DC_B061_6E04F69BF643__INCLUDED_)
00012 #define AFX_CAOPCORCOMMAND_H__44DBF0D9_5C2F_47DC_B061_6E04F69BF643__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00024 class CCaopCorCommand :
00025     public POA_CaoProv::Command,
00026     public PortableServer::RefCountServantBase
00027 {
00028 public:
00029     CCaopCorCommand();
00030     virtual ~CCaopCorCommand();
00031
00032     HRESULT initialize(PVOID pArg);
00033
00034     virtual CORBA_VARIANT* execute(long lOption);
00035     virtual void cancel();
00036     virtual WCHAR* name();
00037     virtual long type();
00038     virtual WCHAR* help();
00039     virtual long state();
00040     virtual CORBA_VARIANT* parameters();
00041     virtual void parameters(const CORBA_VARIANT& _v);
00042     virtual long timeout();
00043     virtual void timeout(long _v);
00044
00045 private:
00046     ICaoProvCommand* m_pICaopCmd;       // CAOプロバイダのコマンドクラスIF
00047
00048 };
00049
00050 #endif // !defined(AFX_CAOPCORCOMMAND_H__44DBF0D9_5C2F_47DC_B061_6E04F69BF643__INCLUDED_)
Generated on Mon Oct 25 19:42:48 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorController.h Source File

CaopCorController.h

解説を見る。
00001
00011 #if !defined(AFX_CAOPCORCONTROLLER_H__7181812F_E80C_4E60_B640_82A6BF49AC48__INCLUDED_)
00012 #define AFX_CAOPCORCONTROLLER_H__7181812F_E80C_4E60_B640_82A6BF49AC48__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00018 #include "EventSink.h"
00019
00026 class CCaopCorController :
00027     public POA_CaoProv::Controller,
00028     public PortableServer::RefCountServantBase
00029 {
00030 public:
00031     CCaopCorController();
00032     virtual ~CCaopCorController();
00033
00034     HRESULT initialize(PVOID pArg);
00035
00036     virtual void connect(const WCHAR* wszName, const WCHAR* wszOption, ControllerEvents_ptr pCaoEvent);
00037     virtual void disconnect();
00038     virtual Extension_ptr getExtension(const WCHAR* wszName, const WCHAR* wszOption);
00039     virtual File_ptr getFile(const WCHAR* wszName, const WCHAR* wszOption);
00040     virtual Robot_ptr getRobot(const WCHAR* wszName, const WCHAR* wszOption);
00041     virtual Task_ptr getTask(const WCHAR* wszName, const WCHAR* wszOption);
00042     virtual Variable_ptr getVariable(const WCHAR* wszName, const WCHAR* wszOption);
00043     virtual Command_ptr getCommand(const WCHAR* wszName, const WCHAR* wszOption);
00044     virtual CORBA_VARIANT* execute(const CORBA_VARIANT& Command);
00045
00046     virtual WCHAR* name();
00047     virtual long type();
00048     virtual WCHAR* help();
00049     virtual CORBA_VARIANT* getExtensionNames(const WCHAR* wszOption);
00050     virtual CORBA_VARIANT* getFileNames(const WCHAR* wszOption);
00051     virtual CORBA_VARIANT* getRobotNames(const WCHAR* wszOption);
00052     virtual CORBA_VARIANT* getTaskNames(const WCHAR* wszOption);
00053     virtual CORBA_VARIANT* getVariableNames(const WCHAR* wszOption);
00054     virtual CORBA_VARIANT* getCommandNames(const WCHAR* wszOption);
00055
00056 private:
00057     ICaoProvController* m_pICaopCtrl;           // CAOプロバイダのコマンドクラスIF
00058     char m_szProvName[MAX_STR_LEN];             // プロバイダ名
00059     char m_szCtrlName[MAX_STR_LEN];             // コントローラ名
00060
00061     CComObject<CEventSink>* m_pEventSink;       // CaoProvController へ Advise するイベントシンク
00062 };
00063
00064 #endif // !defined(AFX_CAOPCORCONTROLLER_H__7181812F_E80C_4E60_B640_82A6BF49AC48__INCLUDED_)
Generated on Mon Oct 25 19:42:48 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorExtension.h Source File

CaopCorExtension.h

解説を見る。
00001
00011 #if !defined(AFX_CAOPCOREXTENSION_H__1D732A34_6570_4E2D_B417_CB280DBF4F60__INCLUDED_)
00012 #define AFX_CAOPCOREXTENSION_H__1D732A34_6570_4E2D_B417_CB280DBF4F60__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00024 class CCaopCorExtension :
00025     public POA_CaoProv::Extension,
00026     public PortableServer::RefCountServantBase
00027 {
00028 public:
00029     CCaopCorExtension();
00030     virtual ~CCaopCorExtension();
00031
00032     HRESULT initialize(PVOID pArg);
00033
00034     virtual Variable_ptr getVariable(const WCHAR* wszName, const WCHAR* wszOption);
00035     virtual CORBA_VARIANT* execute(const CORBA_VARIANT& Command);
00036     virtual CORBA_VARIANT* getVariableNames(const WCHAR* wszOption);
00037
00038     virtual WCHAR* name();
00039     virtual long type();
00040     virtual WCHAR* help();
00041
00042 private:
00043     ICaoProvExtension* m_pICaopExt;         // CAOプロバイダのコマンドクラスIF
00044 };
00045
00046 #endif // !defined(AFX_CAOPCOREXTENSION_H__1D732A34_6570_4E2D_B417_CB280DBF4F60__INCLUDED_)
Generated on Mon Oct 25 19:42:48 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorFile.h Source File

CaopCorFile.h

解説を見る。
00001
00011 #if !defined(AFX_CAOPCORFILE_H__7BBD0652_BD7E_46F5_9BEE_11DFE9E2CAAF__INCLUDED_)
00012 #define AFX_CAOPCORFILE_H__7BBD0652_BD7E_46F5_9BEE_11DFE9E2CAAF__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00024 class CCaopCorFile :
00025     public POA_CaoProv::File,
00026     public PortableServer::RefCountServantBase
00027 {
00028 public:
00029     CCaopCorFile();
00030     virtual ~CCaopCorFile();
00031
00032     HRESULT initialize(PVOID pArg);
00033
00034     virtual File_ptr getFile(const WCHAR* wszName, const WCHAR* wszOption);
00035     virtual Variable_ptr getVariable(const WCHAR* wszName, const WCHAR* wszOption);
00036     virtual CORBA_VARIANT* execute(const CORBA_VARIANT& Command);
00037     virtual void copy(const WCHAR* wszName, const WCHAR* wszOption);
00038     virtual void deleteFile(const WCHAR* wszOption);
00039     virtual void move(const WCHAR* wszName, const WCHAR* wszOption);
00040     virtual WCHAR* run(const WCHAR* wszOption);
00041
00042     virtual CORBA_VARIANT* getFileNames(const WCHAR* wszOption);
00043     virtual CORBA_VARIANT* getVariableNames(const WCHAR* wszOption);
00044     virtual WCHAR* name();
00045     virtual long type();
00046     virtual WCHAR* help();
00047     virtual CORBA_VARIANT* dateCreated();
00048     virtual CORBA_VARIANT* dateLastAccessed();
00049     virtual CORBA_VARIANT* dateLastModified();
00050     virtual WCHAR* path();
00051     virtual long size();
00052     virtual WCHAR* fileType();
00053     virtual CORBA_VARIANT* value();
00054     virtual void value(const CORBA_VARIANT& _v);
00055
00056 private:
00057     ICaoProvFile* m_pICaopFile;     // CAOプロバイダのファイルクラスIF
00058
00059 };
00060
00061 #endif // !defined(AFX_CAOPCORFILE_H__7BBD0652_BD7E_46F5_9BEE_11DFE9E2CAAF__INCLUDED_)
Generated on Mon Oct 25 19:42:48 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorMessage.h Source File

CaopCorMessage.h

解説を見る。
00001
00011 #if !defined(AFX_CAOPCORMESSAGE_H__10B17A7C_7A2C_474E_8B85_27C0C6FFC175__INCLUDED_)
00012 #define AFX_CAOPCORMESSAGE_H__10B17A7C_7A2C_474E_8B85_27C0C6FFC175__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00024 class CCaopCorMessage :
00025     public POA_CaoProv::Message,
00026     public PortableServer::RefCountServantBase
00027 {
00028 public:
00029     CCaopCorMessage();
00030     virtual ~CCaopCorMessage();
00031
00032     HRESULT initialize(PVOID pArg);
00033
00034     virtual CORBA_VARIANT* dateTime();
00035     virtual WCHAR* description();
00036     virtual WCHAR* destination();
00037     virtual long number();
00038     virtual long option();
00039     virtual WCHAR* source();
00040     virtual CORBA_VARIANT* value();
00041     virtual void clear();
00042     virtual void reply(const CORBA_VARIANT& vntData);
00043
00044 private:
00045     ICaoProvMessage* m_pICaopMsg;       // CAOプロバイダのメッセージクラスIF
00046
00047 };
00048
00049 #endif // !defined(AFX_CAOPCORMESSAGE_H__10B17A7C_7A2C_474E_8B85_27C0C6FFC175__INCLUDED_)
Generated on Mon Oct 25 19:42:48 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorRobot.h Source File

CaopCorRobot.h

解説を見る。
00001
00011 #if !defined(AFX_CAOPCORROBOT_H__73C329C8_5F88_4022_B346_DF415612E5CE__INCLUDED_)
00012 #define AFX_CAOPCORROBOT_H__73C329C8_5F88_4022_B346_DF415612E5CE__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00024 class CCaopCorRobot :
00025     public POA_CaoProv::Robot,
00026     public PortableServer::RefCountServantBase
00027 {
00028 public:
00029     CCaopCorRobot();
00030     virtual ~CCaopCorRobot();
00031
00032     HRESULT initialize(PVOID pArg);
00033
00034     virtual Variable_ptr getVariable(const WCHAR* wszName, const WCHAR* wszOption);
00035     virtual CORBA_VARIANT* execute(const CORBA_VARIANT& Command);
00036
00037     virtual void accelerate(long lAxis, float fAccel, float fDecel);
00038     virtual void cancel();
00039     virtual void change(const WCHAR* wszName);
00040     virtual void chuck(const WCHAR* wszOption);
00041     virtual void drive(long lNo, float fMov, const WCHAR* wszOption);
00042     virtual void goHome();
00043     virtual void move(long lComp, long lPrec, const CORBA_VARIANT& vntPose, const WCHAR* wszOption);
00044     virtual void rotate(const CORBA_VARIANT& vntRotSuf, float fDeg, const CORBA_VARIANT& vntPivot, const WCHAR* wszOption);
00045     virtual void speed(long lAxis, float fSpeed);
00046     virtual void unchuck(const WCHAR* wszOption);
00047     virtual WCHAR* name();
00048     virtual long type();
00049     virtual WCHAR* help();
00050     virtual CORBA_VARIANT* getVariableNames(const WCHAR* wszOption);
00051
00052 private:
00053     ICaoProvRobot* m_pICaopRobot;       // CAOプロバイダのロボットクラスIF
00054
00055 };
00056
00057 #endif // !defined(AFX_CAOPCORROBOT_H__73C329C8_5F88_4022_B346_DF415612E5CE__INCLUDED_)
Generated on Mon Oct 25 19:42:48 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorTask.h Source File

CaopCorTask.h

解説を見る。
00001
00011 #if !defined(AFX_CAOPCORTASK_H__43C215C0_B349_4369_BB80_19A673E35E73__INCLUDED_)
00012 #define AFX_CAOPCORTASK_H__43C215C0_B349_4369_BB80_19A673E35E73__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00024 class CCaopCorTask :
00025     public POA_CaoProv::Task,
00026     public PortableServer::RefCountServantBase
00027 {
00028 public:
00029     CCaopCorTask();
00030     virtual ~CCaopCorTask();
00031
00032     HRESULT initialize(PVOID pArg);
00033
00034     virtual Variable_ptr getVariable(const WCHAR* wszName, const WCHAR* wszOption);
00035     virtual CORBA_VARIANT* execute(const CORBA_VARIANT& Command);
00036     virtual void start(long lMode, const WCHAR* wszOption);
00037     virtual void stop(long lMode, const WCHAR* wszOption);
00038     virtual void deleteTask(const WCHAR* wszOption);
00039
00040     virtual WCHAR* name();
00041     virtual long type();
00042     virtual WCHAR* help();
00043     virtual WCHAR* fileName();
00044     virtual CORBA_VARIANT* getVariableNames(const WCHAR* wszOption);
00045
00046 private:
00047     ICaoProvTask* m_pICaopTask;     // CAOプロバイダのタスククラスIF
00048
00049 };
00050
00051 #endif // !defined(AFX_CAOPCORTASK_H__43C215C0_B349_4369_BB80_19A673E35E73__INCLUDED_)
Generated on Mon Oct 25 19:42:48 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaopCorVariable.h Source File

CaopCorVariable.h

解説を見る。
00001
00011 #if !defined(AFX_CAOPCORVARIABLE_H__426A6316_14DF_4453_A94A_673E2CA65B8F__INCLUDED_)
00012 #define AFX_CAOPCORVARIABLE_H__426A6316_14DF_4453_A94A_673E2CA65B8F__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00024 class CCaopCorVariable :
00025     public POA_CaoProv::Variable,
00026     public PortableServer::RefCountServantBase
00027 {
00028 public:
00029     CCaopCorVariable();
00030     virtual ~CCaopCorVariable();
00031
00032     HRESULT initialize(PVOID pArg);
00033
00034     virtual WCHAR* name();
00035     virtual long type();
00036     virtual WCHAR* help();
00037     virtual CORBA_VARIANT* dateTime();
00038     virtual CORBA_VARIANT* value();
00039     virtual void value(const CORBA_VARIANT& _v);
00040
00041 private:
00042     ICaoProvVariable* m_pICaopVar;      // CAOプロバイダの変数クラスIF
00043
00044 };
00045
00046 #endif // !defined(AFX_CAOPCORVARIABLE_H__426A6316_14DF_4453_A94A_673E2CA65B8F__INCLUDED_)
Generated on Mon Oct 25 19:42:48 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CaoProvCorba.idl Source File

CaoProvCorba.idl

解説を見る。
00001
00011 // >>>>>>>>>> このファイルは編集しないで下さい．<<<<<<<<<<
00012 #ifndef __CAOCORBA_IDL__
00013 #define __CAOCORBA_IDL__
00014
00015 module CaoProv {
00016
00017     interface Controller;
00018     interface Extension;
00019     interface File;
00020     interface Robot;
00021     interface Task;
00022     interface Variable;
00023     interface Message;
00024     interface Command;
00025     interface ControllerEvents;
00026
00027     struct CORBA_VARIANT;
00028
00029     typedef sequence <CORBA_VARIANT> CORBA_SAFEARRAY;
00030
00031     struct CORBA_VARIANT {
00032         unsigned short  vt;
00033         any val;
00034         CORBA_SAFEARRAY sa;
00035     };
00036
00037     // Controller Interface
00038     interface Controller {
00039         readonly attribute wstring name;
00040         readonly attribute long type;
00041         readonly attribute wstring help;
00042
00043         CORBA_VARIANT getExtensionNames(in wstring wszOption);
00044         CORBA_VARIANT getFileNames(in wstring wszOption);
00045         CORBA_VARIANT getRobotNames(in wstring wszOption);
00046         CORBA_VARIANT getTaskNames(in wstring wszOption);
00047         CORBA_VARIANT getVariableNames(in wstring wszOption);
00048         CORBA_VARIANT getCommandNames(in wstring wszOption);
00049
00050         void connect(in wstring wszName, in wstring wszOption, in ControllerEvents pCaoEvent);
00051         void disconnect();
00052         Extension getExtension(in wstring wszName, in wstring wszOption);
00053         File getFile(in wstring wszName, in wstring wszOption);
00054         Robot getRobot(in wstring wszName, in wstring wszOption);
00055         Task getTask(in wstring wszName, in wstring wszOption);
00056         Variable getVariable(in wstring wszName, in wstring wszOption);
00057         Command getCommand(in wstring wszName, in wstring wszOption);
00058         CORBA_VARIANT execute(in CORBA_VARIANT Command);
00059     };
00060
00061     // Extension Interface
00062     interface Extension {
00063         readonly attribute wstring name;
00064         readonly attribute long type;
00065         readonly attribute wstring help;
00066
00067         CORBA_VARIANT getVariableNames(in wstring wszOption);
00068         Variable getVariable(in wstring wszName, in wstring wszOption);
00069         CORBA_VARIANT execute(in CORBA_VARIANT Command);
00070     };
00071
00072     // IFile Interface
00073     interface File {
00074         readonly attribute wstring name;
00075         readonly attribute long type;
00076         readonly attribute wstring help;
00077         readonly attribute CORBA_VARIANT dateCreated;
00078         readonly attribute CORBA_VARIANT dateLastAccessed;
00079         readonly attribute CORBA_VARIANT dateLastModified;
00080         readonly attribute wstring path;
00081         readonly attribute long size;
00082         readonly attribute wstring fileType;
00083         attribute CORBA_VARIANT value;
00084
00085         CORBA_VARIANT getFileNames(in wstring wszOption);
00086         CORBA_VARIANT getVariableNames(in wstring wszOption);
00087
00088         File getFile(in wstring wszName, in wstring wszOption);
00089         Variable getVariable(in wstring wszName, in wstring wszOption);
00090         void copy(in wstring wszName, in wstring wszOption);
00091         void deleteFile(in wstring wszOption);
00092         CORBA_VARIANT execute(in CORBA_VARIANT Command);
00093         void move(in wstring wszName, in wstring wszOption);
00094         wstring run(in wstring wszOption);
00095     };
00096
00097     // IRobot Interface
00098     interface Robot {
00099         readonly attribute wstring name;
00100         readonly attribute long type;
00101         readonly attribute wstring help;
00102
00103         CORBA_VARIANT getVariableNames(in wstring wszOption);
00104         Variable getVariable(in wstring wszName, in wstring wszOption);
00105         CORBA_VARIANT execute(in CORBA_VARIANT Command);
00106
00107         void accelerate(in long lAxis, in float fAccel, in float fDecel);
00108         void cancel();
00109         void change(in wstring wszName);
00110         void chuck(in wstring wszOption);
00111         void drive(in long lNo, in float fMov, in wstring wszOption);
00112         void goHome();
00113         void move(in long lComp, in long lPrec, in CORBA_VARIANT vntPose, in wstring wszOption);
00114         void rotate(in CORBA_VARIANT vntRotSuf, in float fDeg, in CORBA_VARIANT vntPivot, in wstring wszOption);
00115         void speed(in long lAxis, in float fSpeed);
00116         void unchuck(in wstring wszOption);
00117     };
00118
00119     // ITask Interface
00120     interface Task {
00121         readonly attribute wstring name;
00122         readonly attribute long type;
00123         readonly attribute wstring help;
00124         readonly attribute wstring fileName;
00125
00126         CORBA_VARIANT getVariableNames(in wstring wszOption);
00127         Variable getVariable(in wstring wszName, in wstring wszOption);
00128         CORBA_VARIANT execute(in CORBA_VARIANT Command);
00129
00130         void deleteTask(in wstring wszOption);
00131         void start(in long lMode, in wstring wszOption);
00132         void stop(in long lMode, in wstring wszOption);
00133     };
00134
00135     // IVariable Interface
00136     interface Variable {
00137         readonly attribute wstring name;
00138         readonly attribute long type;
00139         readonly attribute wstring help;
00140         readonly attribute CORBA_VARIANT dateTime;
00141         attribute CORBA_VARIANT value;
00142     };
00143
00144     // ICommand Interface
00145     interface Command {
00146         readonly attribute wstring name;
00147         readonly attribute long type;
00148         readonly attribute wstring help;
00149         readonly attribute long state;
00150         attribute CORBA_VARIANT parameters;
00151         attribute long timeout;
00152
00153         CORBA_VARIANT execute(in long lOption);
00154         void cancel();
00155     };
00156
00157     // IMessage Interface
00158     interface Message {
00159         readonly attribute CORBA_VARIANT dateTime;
00160         readonly attribute wstring description;
00161         readonly attribute wstring destination;
00162         readonly attribute long number;
00163         readonly attribute long option;
00164         readonly attribute wstring source;
00165         readonly attribute CORBA_VARIANT value;
00166
00167         void clear();
00168         void reply(in CORBA_VARIANT vntData);
00169     };
00170
00171     interface ControllerEvents {
00172         void onMessage(in Message CaopMessage);
00173     };
00174 };
00175
00176 #endif
00177
Generated on Mon Oct 25 19:42:48 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaopCorCommand メンバ一覧

これは全メンバの一覧です。CCaopCorCommand継承メンバも含んでいます。
cancel() | CCaopCorCommand | [virtual]
CCaopCorCommand() | CCaopCorCommand |
execute(long lOption) | CCaopCorCommand | [virtual]
help() | CCaopCorCommand | [virtual]
initialize(PVOID pArg) | CCaopCorCommand |
name() | CCaopCorCommand | [virtual]
parameters() | CCaopCorCommand | [virtual]
parameters(const CORBA_VARIANT &_v) | CCaopCorCommand | [virtual]
state() | CCaopCorCommand | [virtual]
timeout() | CCaopCorCommand | [virtual]
timeout(long _v) | CCaopCorCommand | [virtual]
type() | CCaopCorCommand | [virtual]
~CCaopCorCommand() | CCaopCorCommand | [virtual]
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaopCorController メンバ一覧

これは全メンバの一覧です。CCaopCorController継承メンバも含んでいます。
CCaopCorController() | CCaopCorController |
connect(const WCHAR *wszName, const WCHAR *wszOption, ControllerEvents_ptr pCaoEvent) | CCaopCorController | [virtual]
disconnect() | CCaopCorController | [virtual]
execute(const CORBA_VARIANT &Command) | CCaopCorController | [virtual]
getCommand(const WCHAR *wszName, const WCHAR *wszOption) | CCaopCorController | [virtual]
getCommandNames(const WCHAR *wszOption) | CCaopCorController | [virtual]
getExtension(const WCHAR *wszName, const WCHAR *wszOption) | CCaopCorController | [virtual]
getExtensionNames(const WCHAR *wszOption) | CCaopCorController | [virtual]
getFile(const WCHAR *wszName, const WCHAR *wszOption) | CCaopCorController | [virtual]
getFileNames(const WCHAR *wszOption) | CCaopCorController | [virtual]
getRobot(const WCHAR *wszName, const WCHAR *wszOption) | CCaopCorController | [virtual]
getRobotNames(const WCHAR *wszOption) | CCaopCorController | [virtual]
getTask(const WCHAR *wszName, const WCHAR *wszOption) | CCaopCorController | [virtual]
getTaskNames(const WCHAR *wszOption) | CCaopCorController | [virtual]
getVariable(const WCHAR *wszName, const WCHAR *wszOption) | CCaopCorController | [virtual]
getVariableNames(const WCHAR *wszOption) | CCaopCorController | [virtual]
help() | CCaopCorController | [virtual]
initialize(PVOID pArg) | CCaopCorController |
name() | CCaopCorController | [virtual]
type() | CCaopCorController | [virtual]
~CCaopCorController() | CCaopCorController | [virtual]
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaopCorExtension メンバ一覧

これは全メンバの一覧です。CCaopCorExtension継承メンバも含んでいます。
CCaopCorExtension() | CCaopCorExtension |
execute(const CORBA_VARIANT &Command) | CCaopCorExtension | [virtual]
getVariable(const WCHAR *wszName, const WCHAR *wszOption) | CCaopCorExtension | [virtual]
getVariableNames(const WCHAR *wszOption) | CCaopCorExtension | [virtual]
help() | CCaopCorExtension | [virtual]
initialize(PVOID pArg) | CCaopCorExtension |
name() | CCaopCorExtension | [virtual]
type() | CCaopCorExtension | [virtual]
~CCaopCorExtension() | CCaopCorExtension | [virtual]
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaopCorFile メンバ一覧

これは全メンバの一覧です。CCaopCorFile継承メンバも含んでいます。
CCaopCorFile() | CCaopCorFile |
copy(const WCHAR *wszName, const WCHAR *wszOption) | CCaopCorFile | [virtual]
dateCreated() | CCaopCorFile | [virtual]
dateLastAccessed() | CCaopCorFile | [virtual]
dateLastModified() | CCaopCorFile | [virtual]
deleteFile(const WCHAR *wszOption) | CCaopCorFile | [virtual]
execute(const CORBA_VARIANT &Command) | CCaopCorFile | [virtual]
fileType() | CCaopCorFile | [virtual]
getFile(const WCHAR *wszName, const WCHAR *wszOption) | CCaopCorFile | [virtual]
getFileNames(const WCHAR *wszOption) | CCaopCorFile | [virtual]
getVariable(const WCHAR *wszName, const WCHAR *wszOption) | CCaopCorFile | [virtual]
getVariableNames(const WCHAR *wszOption) | CCaopCorFile | [virtual]
help() | CCaopCorFile | [virtual]
initialize(PVOID pArg) | CCaopCorFile |
move(const WCHAR *wszName, const WCHAR *wszOption) | CCaopCorFile | [virtual]
name() | CCaopCorFile | [virtual]
path() | CCaopCorFile | [virtual]
run(const WCHAR *wszOption) | CCaopCorFile | [virtual]
size() | CCaopCorFile | [virtual]
type() | CCaopCorFile | [virtual]
value() | CCaopCorFile | [virtual]
value(const CORBA_VARIANT &_v) | CCaopCorFile | [virtual]
~CCaopCorFile() | CCaopCorFile | [virtual]
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaopCorMessage メンバ一覧

これは全メンバの一覧です。CCaopCorMessage継承メンバも含んでいます。
CCaopCorMessage() | CCaopCorMessage |
clear() | CCaopCorMessage | [virtual]
dateTime() | CCaopCorMessage | [virtual]
description() | CCaopCorMessage | [virtual]
destination() | CCaopCorMessage | [virtual]
initialize(PVOID pArg) | CCaopCorMessage |
number() | CCaopCorMessage | [virtual]
option() | CCaopCorMessage | [virtual]
reply(const CORBA_VARIANT &vntData) | CCaopCorMessage | [virtual]
source() | CCaopCorMessage | [virtual]
value() | CCaopCorMessage | [virtual]
~CCaopCorMessage() | CCaopCorMessage | [virtual]
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaopCorRobot メンバ一覧

これは全メンバの一覧です。CCaopCorRobot継承メンバも含んでいます。
accelerate(long lAxis, float fAccel, float fDecel) | CCaopCorRobot | [virtual]
cancel() | CCaopCorRobot | [virtual]
CCaopCorRobot() | CCaopCorRobot |
change(const WCHAR *wszName) | CCaopCorRobot | [virtual]
chuck(const WCHAR *wszOption) | CCaopCorRobot | [virtual]
drive(long lNo, float fMov, const WCHAR *wszOption) | CCaopCorRobot | [virtual]
execute(const CORBA_VARIANT &Command) | CCaopCorRobot | [virtual]
getVariable(const WCHAR *wszName, const WCHAR *wszOption) | CCaopCorRobot | [virtual]
getVariableNames(const WCHAR *wszOption) | CCaopCorRobot | [virtual]
goHome() | CCaopCorRobot | [virtual]
help() | CCaopCorRobot | [virtual]
initialize(PVOID pArg) | CCaopCorRobot |
move(long lComp, long lPrec, const CORBA_VARIANT &vntPose, const WCHAR *wszOption) | CCaopCorRobot | [virtual]
name() | CCaopCorRobot | [virtual]
rotate(const CORBA_VARIANT &vntRotSuf, float fDeg, const CORBA_VARIANT &vntPivot, const WCHAR *wszOption) | CCaopCorRobot | [virtual]
speed(long lAxis, float fSpeed) | CCaopCorRobot | [virtual]
type() | CCaopCorRobot | [virtual]
unchuck(const WCHAR *wszOption) | CCaopCorRobot | [virtual]
~CCaopCorRobot() | CCaopCorRobot | [virtual]
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaopCorTask メンバ一覧

これは全メンバの一覧です。CCaopCorTask継承メンバも含んでいます。
CCaopCorTask() | CCaopCorTask |
deleteTask(const WCHAR *wszOption) | CCaopCorTask | [virtual]
execute(const CORBA_VARIANT &Command) | CCaopCorTask | [virtual]
fileName() | CCaopCorTask | [virtual]
getVariable(const WCHAR *wszName, const WCHAR *wszOption) | CCaopCorTask | [virtual]
getVariableNames(const WCHAR *wszOption) | CCaopCorTask | [virtual]
help() | CCaopCorTask | [virtual]
initialize(PVOID pArg) | CCaopCorTask |
name() | CCaopCorTask | [virtual]
start(long lMode, const WCHAR *wszOption) | CCaopCorTask | [virtual]
stop(long lMode, const WCHAR *wszOption) | CCaopCorTask | [virtual]
type() | CCaopCorTask | [virtual]
~CCaopCorTask() | CCaopCorTask | [virtual]
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaopCorVariable メンバ一覧

これは全メンバの一覧です。CCaopCorVariable継承メンバも含んでいます。
CCaopCorVariable() | CCaopCorVariable |
dateTime() | CCaopCorVariable | [virtual]
help() | CCaopCorVariable | [virtual]
initialize(PVOID pArg) | CCaopCorVariable |
name() | CCaopCorVariable | [virtual]
type() | CCaopCorVariable | [virtual]
value() | CCaopCorVariable | [virtual]
value(const CORBA_VARIANT &_v) | CCaopCorVariable | [virtual]
~CCaopCorVariable() | CCaopCorVariable | [virtual]
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCorbaServer メンバ一覧

これは全メンバの一覧です。CCorbaServer継承メンバも含んでいます。
CCorbaServer() | CCorbaServer |
ServerThread(void *pSub) | CCorbaServer | [static]
Start() | CCorbaServer |
Stop() | CCorbaServer |
UnregName(const char *szCtrlName) | CCorbaServer |
~CCorbaServer() | CCorbaServer | [virtual]
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CEventSink メンバ一覧

これは全メンバの一覧です。CEventSink継承メンバも含んでいます。
_Initialize(PVOID pArgs[]) | CEventSink |
_Terminate() | CEventSink |
CEventSink() | CEventSink | [inline]
FinalConstruct() | CEventSink |
FinalRelease() | CEventSink |
InterfaceSupportsErrorInfo(REFIID riid) | CEventSink |
OnMessage(IUnknown *pVal) | CEventSink |
~CEventSink() | CEventSink | [inline]
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CServiceModule メンバ一覧

これは全メンバの一覧です。CServiceModule継承メンバも含んでいます。
CorbaVntToVnt(CORBA_VARIANT vntSrc, VARIANT *pvntRet) | CServiceModule |
dwThreadID | CServiceModule |
Handler(DWORD dwOpcode) | CServiceModule | [inline]
Init(_ATL_OBJMAP_ENTRY *p, HINSTANCE h, UINT nServiceNameID, const GUID *plibid=NULL) | CServiceModule | [inline]
Install() | CServiceModule | [inline]
IsInstalled() | CServiceModule |
LogEvent(LPCTSTR pszFormat,...) | CServiceModule |
m_argc | CServiceModule |
m_argv | CServiceModule |
m_bService | CServiceModule |
m_CorbaSvr | CServiceModule |
m_hServiceStatus | CServiceModule |
m_status | CServiceModule |
m_szServiceName | CServiceModule |
RegisterServer(BOOL bRegTypeLib, BOOL bService) | CServiceModule | [inline]
Run() | CServiceModule |
ServiceMain(DWORD dwArgc, LPTSTR *lpszArgv) | CServiceModule | [inline]
SetServiceStatus(DWORD dwState) | CServiceModule |
SetupAsLocalServer() | CServiceModule |
Start() | CServiceModule | [inline]
Uninstall() | CServiceModule | [inline]
Unlock() | CServiceModule |
UnregisterServer() | CServiceModule | [inline]
VntToCorbaVnt(VARIANT vntSrc, CORBA_VARIANT *pvntRet) | CServiceModule |
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


CorbaServer.h Source File

CorbaServer.h

解説を見る。
00001
00011 #if !defined(AFX_CORBASERVER_H__993BCE13_EC11_4A0B_8877_5B4A4E6085A6__INCLUDED_)
00012 #define AFX_CORBASERVER_H__993BCE13_EC11_4A0B_8877_5B4A4E6085A6__INCLUDED_
00013
00014 #if _MSC_VER > 1000
00015 #pragma once
00016 #endif // _MSC_VER > 1000
00017
00018 #define CORBA_NAME_SIZE 256
00019
00028 class CCorbaServer
00029 {
00030 public:
00031     CCorbaServer();
00032     virtual ~CCorbaServer();
00033
00034     HRESULT Start();
00035     HRESULT Stop();
00036
00037     HRESULT UnregName(const char* szCtrlName);
00038
00039     static void __cdecl ServerThread(void *pSub);
00040
00041 private:
00042     char    m_szName[CORBA_NAME_SIZE];
00043     BOOL    m_bConnect;
00044
00045     CORBA::ORB_var m_orb;
00046 };
00047
00048 #endif // !defined(AFX_CORBASERVER_H__993BCE13_EC11_4A0B_8877_5B4A4E6085A6__INCLUDED_)
Generated on Mon Oct 25 19:42:49 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


EventSink.h Source File

EventSink.h

解説を見る。
00001
00011 #ifndef __EVENTSINK_H_
00012 #define __EVENTSINK_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include "GwCaopCorba.h"
00016
00024 class ATL_NO_VTABLE CEventSink :
00025     public CComObjectRootEx<CComMultiThreadModel>,
00026     public CComCoClass<CEventSink, &CLSID_EventSink>,
00027     public ISupportErrorInfo,
00028     public IDispatchImpl<IEventSink, &IID_IEventSink, &LIBID_GWCAOPCORBALib>
00029 {
00030 public:
00036     CEventSink() : m_dwCookie(0)
00037     {
00038         m_pICaopCtrl = NULL;
00039         m_pCaoEvent = NULL;
00040     }
00041
00047     ~CEventSink()
00048     {
00049     }
00050
00051 DECLARE_REGISTRY_RESOURCEID(IDR_EVENTSINK)
00052
00053 DECLARE_PROTECT_FINAL_CONSTRUCT()
00054
00055 BEGIN_COM_MAP(CEventSink)
00056     COM_INTERFACE_ENTRY(IEventSink)
00057     COM_INTERFACE_ENTRY(IDispatch)
00058     COM_INTERFACE_ENTRY_IID(__uuidof(_ICaoProvControllerEvents), IDispatch)
00059     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00060 END_COM_MAP()
00061
00062 // ISupportsErrorInfo
00063     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00064
00065 // FinalConstruct / FinalRelease
00066     HRESULT FinalConstruct();
00067     void FinalRelease();
00068
00069 // IEventSink
00070     STDMETHOD(_Initialize)(PVOID pArgs[]);
00071     STDMETHOD(_Terminate)();
00072
00073     STDMETHOD(OnMessage)(/*[in]*/ IUnknown *pVal);
00074
00075 private:
00076     ICaoProvController* m_pICaopCtrl;       // CaoProvCtrl インターフェイスへのポインタ
00077     DWORD m_dwCookie;                       // 接続を一意に識別するクッキー
00078
00079     ControllerEvents_ptr m_pCaoEvent;
00080 };
00081
00082 #endif //__EVENTSINK_H_
Generated on Mon Oct 25 19:42:49 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


Graph Legend

グラフの凡例

このページでは、doxygen で生成されたグラフをどのようにみたらよいかを説明します。

次の例を考えてみます。

/*! 省略されて見えないクラス */
class Invisible { };

/*! 省略されたクラス(継承関係は隠されている) */
class Truncated : public Invisible { };

/* doxygen コメントによるドキュメントがないクラス */
class Undocumented { };

/*! public で継承されたクラス */
class PublicBase : public Truncated { };

/*! protected で継承されたクラス */
class ProtectedBase { };

/*! private で継承されたクラス */
class PrivateBase { };

/*! 継承されたクラスで使われているクラス */
class Used { };

/*! 複数のクラスを継承している上位クラス */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
{
  private:
    Used *m_usedClass;
};
設定ファイル中で、タグ MAX_DOT_GRAPH_HEIGHT が 200 にセットされた場合、次のようなグラフとなります。

上のグラフ内のボックスには次のような意味があります。

  • 黒く塗りつぶされたボックスは、このグラフに対応する構造体やクラスを表します。
  • 黒枠のボックスはドキュメントがある構造体やクラスを表します。
  • 灰色の枠のボックスはドキュメントがない構造体やクラスを表します。
  • 赤枠のボックスはドキュメントがある構造体やクラスを表しますが、指定されたサイズに収まらないために継承・包含関係をすべて図示することができなかったことを示します。
矢印には次のような意味があります。
  • 青い矢印は二つのクラス間の public 継承関係を示します。
  • 緑の矢印は protected 継承関係を示します。
  • 赤の矢印は private 継承関係を示します。
  • 紫の破線矢印は、そのクラスが他のクラスに含まれていたり、利用されていることを示します。また、矢印が指しているクラスや構造体をどの変数でアクセスできるかを矢印のラベルとして示しています。
Generated on Mon Oct 25 19:43:01 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


GwCaopCorba.h Source File

GwCaopCorba.h

解説を見る。
00001 /* this ALWAYS GENERATED file contains the definitions for the interfaces */
00002
00003
00004 /* File created by MIDL compiler version 5.01.0164 */
00005 /* at Fri Oct 22 17:22:56 2004
00006  */
00007 /* Compiler settings for D:\work\Robot\ORiN2\WorkingCopy\ORiN2\CAO\ProviderLib\CORBA\GwCaopCorba\Src\GwCaopCorba.idl:
00008     Oicf (OptLev=i2), W1, Zp8, env=Win32, ms_ext, c_ext
00009     error checks: allocation ref bounds_check enum stub_data
00010 */
00011 //@@MIDL_FILE_HEADING(  )
00012
00013
00014 /* verify that the <rpcndr.h> version is high enough to compile this file*/
00015 #ifndef __REQUIRED_RPCNDR_H_VERSION__
00016 #define __REQUIRED_RPCNDR_H_VERSION__ 440
00017 #endif
00018
00019 #include "rpc.h"
00020 #include "rpcndr.h"
00021
00022 #ifndef __RPCNDR_H_VERSION__
00023 #error this stub requires an updated version of <rpcndr.h>
00024 #endif // __RPCNDR_H_VERSION__
00025
00026 #ifndef COM_NO_WINDOWS_H
00027 #include "windows.h"
00028 #include "ole2.h"
00029 #endif /*COM_NO_WINDOWS_H*/
00030
00031 #ifndef __GwCaopCorba_h__
00032 #define __GwCaopCorba_h__
00033
00034 #ifdef __cplusplus
00035 extern "C"{
00036 #endif
00037
00038 /* Forward Declarations */
00039
00040 #ifndef __IEventSink_FWD_DEFINED__
00041 #define __IEventSink_FWD_DEFINED__
00042 typedef interface IEventSink IEventSink;
00043 #endif  /* __IEventSink_FWD_DEFINED__ */
00044
00045
00046 #ifndef __EventSink_FWD_DEFINED__
00047 #define __EventSink_FWD_DEFINED__
00048
00049 #ifdef __cplusplus
00050 typedef class EventSink EventSink;
00051 #else
00052 typedef struct EventSink EventSink;
00053 #endif /* __cplusplus */
00054
00055 #endif  /* __EventSink_FWD_DEFINED__ */
00056
00057
00058 /* header files for imported files */
00059 #include "oaidl.h"
00060 #include "ocidl.h"
00061
00062 void __RPC_FAR * __RPC_USER MIDL_user_allocate(size_t);
00063 void __RPC_USER MIDL_user_free( void __RPC_FAR * );
00064
00065 #ifndef __IEventSink_INTERFACE_DEFINED__
00066 #define __IEventSink_INTERFACE_DEFINED__
00067
00068 /* interface IEventSink */
00069 /* [unique][helpstring][dual][uuid][object] */
00070
00071
00072 EXTERN_C const IID IID_IEventSink;
00073
00074 #if defined(__cplusplus) && !defined(CINTERFACE)
00075
00076     MIDL_INTERFACE("9D51383D-D9F8-490E-84FB-EDFCBF36AD48")
00077     IEventSink : public IDispatch
00078     {
00079     public:
00080         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE OnMessage(
00081             /* [in] */ IUnknown __RPC_FAR *pVal) = 0;
00082
00083     };
00084
00085 #else   /* C style interface */
00086
00087     typedef struct IEventSinkVtbl
00088     {
00089         BEGIN_INTERFACE
00090
00091         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
00092             IEventSink __RPC_FAR * This,
00093             /* [in] */ REFIID riid,
00094             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
00095
00096         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
00097             IEventSink __RPC_FAR * This);
00098
00099         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
00100             IEventSink __RPC_FAR * This);
00101
00102         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
00103             IEventSink __RPC_FAR * This,
00104             /* [out] */ UINT __RPC_FAR *pctinfo);
00105
00106         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
00107             IEventSink __RPC_FAR * This,
00108             /* [in] */ UINT iTInfo,
00109             /* [in] */ LCID lcid,
00110             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
00111
00112         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
00113             IEventSink __RPC_FAR * This,
00114             /* [in] */ REFIID riid,
00115             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
00116             /* [in] */ UINT cNames,
00117             /* [in] */ LCID lcid,
00118             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
00119
00120         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
00121             IEventSink __RPC_FAR * This,
00122             /* [in] */ DISPID dispIdMember,
00123             /* [in] */ REFIID riid,
00124             /* [in] */ LCID lcid,
00125             /* [in] */ WORD wFlags,
00126             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
00127             /* [out] */ VARIANT __RPC_FAR *pVarResult,
00128             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
00129             /* [out] */ UINT __RPC_FAR *puArgErr);
00130
00131         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *OnMessage )(
00132             IEventSink __RPC_FAR * This,
00133             /* [in] */ IUnknown __RPC_FAR *pVal);
00134
00135         END_INTERFACE
00136     } IEventSinkVtbl;
00137
00138     interface IEventSink
00139     {
00140         CONST_VTBL struct IEventSinkVtbl __RPC_FAR *lpVtbl;
00141     };
00142
00143
00144
00145 #ifdef COBJMACROS
00146
00147
00148 #define IEventSink_QueryInterface(This,riid,ppvObject)  \
00149     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
00150
00151 #define IEventSink_AddRef(This) \
00152     (This)->lpVtbl -> AddRef(This)
00153
00154 #define IEventSink_Release(This)    \
00155     (This)->lpVtbl -> Release(This)
00156
00157
00158 #define IEventSink_GetTypeInfoCount(This,pctinfo)   \
00159     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
00160
00161 #define IEventSink_GetTypeInfo(This,iTInfo,lcid,ppTInfo)    \
00162     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
00163
00164 #define IEventSink_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)  \
00165     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
00166
00167 #define IEventSink_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)    \
00168     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
00169
00170
00171 #define IEventSink_OnMessage(This,pVal) \
00172     (This)->lpVtbl -> OnMessage(This,pVal)
00173
00174 #endif /* COBJMACROS */
00175
00176
00177 #endif  /* C style interface */
00178
00179
00180
00181 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE IEventSink_OnMessage_Proxy(
00182     IEventSink __RPC_FAR * This,
00183     /* [in] */ IUnknown __RPC_FAR *pVal);
00184
00185
00186 void __RPC_STUB IEventSink_OnMessage_Stub(
00187     IRpcStubBuffer *This,
00188     IRpcChannelBuffer *_pRpcChannelBuffer,
00189     PRPC_MESSAGE _pRpcMessage,
00190     DWORD *_pdwStubPhase);
00191
00192
00193
00194 #endif  /* __IEventSink_INTERFACE_DEFINED__ */
00195
00196
00197
00198 #ifndef __GWCAOPCORBALib_LIBRARY_DEFINED__
00199 #define __GWCAOPCORBALib_LIBRARY_DEFINED__
00200
00201 /* library GWCAOPCORBALib */
00202 /* [helpstring][version][uuid] */
00203
00204
00205 EXTERN_C const IID LIBID_GWCAOPCORBALib;
00206
00207 EXTERN_C const CLSID CLSID_EventSink;
00208
00209 #ifdef __cplusplus
00210
00211 class DECLSPEC_UUID("9BB72A60-3579-42CB-A019-4527AB424BF8")
00212 EventSink;
00213 #endif
00214 #endif /* __GWCAOPCORBALib_LIBRARY_DEFINED__ */
00215
00216 /* Additional Prototypes for ALL interfaces */
00217
00218 /* end of Additional Prototypes */
00219
00220 #ifdef __cplusplus
00221 }
00222 #endif
00223
00224 #endif
Generated on Mon Oct 25 19:42:49 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


GwCaopCorba.idl Source File

GwCaopCorba.idl

解説を見る。
00001 // GwCaopCorba.idl : GwCaopCorba.dll 用の IDL ソース ファイル
00002 //
00003
00004 // このファイルはタイプ ライブラリ (GwCaopCorba.tlb) を作成するために
00005 // タイプ ライブラリ作成ツール MIDL によって処理されます。
00006
00007 import "oaidl.idl";
00008 import "ocidl.idl";
00009     [
00010         object,
00011         uuid(9D51383D-D9F8-490E-84FB-EDFCBF36AD48),
00012         dual,
00013         helpstring("IEventSink Interface"),
00014         pointer_default(unique)
00015     ]
00016     interface IEventSink : IDispatch
00017     {
00018         [id(1), helpstring("ﾒｿｯﾄﾞ OnMessage")] HRESULT OnMessage([in] IUnknown *pVal);
00019     };
00020
00021 [
00022     uuid(9F6E5130-5125-4003-8029-D13E393F2002),
00023     version(1.0),
00024     helpstring("GwCaopCorba 1.0 ﾀｲﾌﾟ ﾗｲﾌﾞﾗﾘ")
00025 ]
00026 library GWCAOPCORBALib
00027 {
00028     importlib("stdole32.tlb");
00029     importlib("stdole2.tlb");
00030
00031     [
00032         uuid(9BB72A60-3579-42CB-A019-4527AB424BF8),
00033         helpstring("EventSink Class")
00034     ]
00035     coclass EventSink
00036     {
00037         [default] interface IEventSink;
00038     };
00039 };
Generated on Mon Oct 25 19:42:49 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CaoProv::Command メンバ一覧

これは全メンバの一覧です。CaoProv::Command継承メンバも含んでいます。
cancel() | CaoProv::Command
execute(in long lOption) | CaoProv::Command
help | CaoProv::Command
name | CaoProv::Command
parameters | CaoProv::Command
state | CaoProv::Command
timeout | CaoProv::Command
type | CaoProv::Command
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CaoProv::Controller メンバ一覧

これは全メンバの一覧です。CaoProv::Controller継承メンバも含んでいます。
connect(in wstring wszName, in wstring wszOption, in ControllerEvents pCaoEvent) | CaoProv::Controller
disconnect() | CaoProv::Controller
execute(in CORBA_VARIANT Command) | CaoProv::Controller
getCommand(in wstring wszName, in wstring wszOption) | CaoProv::Controller
getCommandNames(in wstring wszOption) | CaoProv::Controller
getExtension(in wstring wszName, in wstring wszOption) | CaoProv::Controller
getExtensionNames(in wstring wszOption) | CaoProv::Controller
getFile(in wstring wszName, in wstring wszOption) | CaoProv::Controller
getFileNames(in wstring wszOption) | CaoProv::Controller
getRobot(in wstring wszName, in wstring wszOption) | CaoProv::Controller
getRobotNames(in wstring wszOption) | CaoProv::Controller
getTask(in wstring wszName, in wstring wszOption) | CaoProv::Controller
getTaskNames(in wstring wszOption) | CaoProv::Controller
getVariable(in wstring wszName, in wstring wszOption) | CaoProv::Controller
getVariableNames(in wstring wszOption) | CaoProv::Controller
help | CaoProv::Controller
name | CaoProv::Controller
type | CaoProv::Controller
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CaoProv::ControllerEvents メンバ一覧

これは全メンバの一覧です。CaoProv::ControllerEvents継承メンバも含んでいます。
onMessage(in Message CaopMessage) CaoProv::ControllerEvents
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CaoProv::Extension メンバ一覧

これは全メンバの一覧です。CaoProv::Extension継承メンバも含んでいます。
execute(in CORBA_VARIANT Command) | CaoProv::Extension
getVariable(in wstring wszName, in wstring wszOption) | CaoProv::Extension
getVariableNames(in wstring wszOption) | CaoProv::Extension
help | CaoProv::Extension
name | CaoProv::Extension
type | CaoProv::Extension
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CaoProv::File メンバ一覧

これは全メンバの一覧です。CaoProv::File継承メンバも含んでいます。
copy(in wstring wszName, in wstring wszOption) | CaoProv::File
dateCreated | CaoProv::File
dateLastAccessed | CaoProv::File
dateLastModified | CaoProv::File
deleteFile(in wstring wszOption) | CaoProv::File
execute(in CORBA_VARIANT Command) | CaoProv::File
fileType | CaoProv::File
getFile(in wstring wszName, in wstring wszOption) | CaoProv::File
getFileNames(in wstring wszOption) | CaoProv::File
getVariable(in wstring wszName, in wstring wszOption) | CaoProv::File
getVariableNames(in wstring wszOption) | CaoProv::File
help | CaoProv::File
move(in wstring wszName, in wstring wszOption) | CaoProv::File
name | CaoProv::File
path | CaoProv::File
run(in wstring wszOption) | CaoProv::File
size | CaoProv::File
type | CaoProv::File
value | CaoProv::File
Generated on Mon Oct 25 19:43:00 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CaoProv::Message メンバ一覧

これは全メンバの一覧です。CaoProv::Message継承メンバも含んでいます。
clear() | CaoProv::Message
dateTime | CaoProv::Message
description | CaoProv::Message
destination | CaoProv::Message
number | CaoProv::Message
option | CaoProv::Message
reply(in CORBA_VARIANT vntData) | CaoProv::Message
source | CaoProv::Message
value | CaoProv::Message
Generated on Mon Oct 25 19:43:00 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CaoProv::Robot メンバ一覧

これは全メンバの一覧です。CaoProv::Robot継承メンバも含んでいます。
accelerate(in long lAxis, in float fAccel, in float fDecel) | CaoProv::Robot
cancel() | CaoProv::Robot
change(in wstring wszName) | CaoProv::Robot
chuck(in wstring wszOption) | CaoProv::Robot
drive(in long lNo, in float fMov, in wstring wszOption) | CaoProv::Robot
execute(in CORBA_VARIANT Command) | CaoProv::Robot
getVariable(in wstring wszName, in wstring wszOption) | CaoProv::Robot
getVariableNames(in wstring wszOption) | CaoProv::Robot
goHome() | CaoProv::Robot
help | CaoProv::Robot
move(in long lComp, in long lPrec, in CORBA_VARIANT vntPose, in wstring wszOption) | CaoProv::Robot
name | CaoProv::Robot
rotate(in CORBA_VARIANT vntRotSuf, in float fDeg, in CORBA_VARIANT vntPivot, in wstring wszOption) | CaoProv::Robot
speed(in long lAxis, in float fSpeed) | CaoProv::Robot
type | CaoProv::Robot
unchuck(in wstring wszOption) | CaoProv::Robot
Generated on Mon Oct 25 19:43:00 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CaoProv::Task メンバ一覧

これは全メンバの一覧です。CaoProv::Task継承メンバも含んでいます。
deleteTask(in wstring wszOption) | CaoProv::Task
execute(in CORBA_VARIANT Command) | CaoProv::Task
fileName | CaoProv::Task
getVariable(in wstring wszName, in wstring wszOption) | CaoProv::Task
getVariableNames(in wstring wszOption) | CaoProv::Task
help | CaoProv::Task
name | CaoProv::Task
start(in long lMode, in wstring wszOption) | CaoProv::Task
stop(in long lMode, in wstring wszOption) | CaoProv::Task
type | CaoProv::Task
Generated on Mon Oct 25 19:43:00 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CaoProv::Variable メンバ一覧

これは全メンバの一覧です。CaoProv::Variable継承メンバも含んでいます。
dateTime | CaoProv::Variable
help | CaoProv::Variable
name | CaoProv::Variable
type | CaoProv::Variable
value | CaoProv::Variable
Generated on Mon Oct 25 19:43:00 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

IEventSink メンバ一覧

これは全メンバの一覧です。IEventSink継承メンバも含んでいます。
OnMessage([in] IUnknown *pVal) IEventSink
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


resource.h Source File

resource.h

解説を見る。
00001 //{{NO_DEPENDENCIES}}
00002 // Microsoft Developer Studio generated include file.
00003 // Used by GwCaopCorba.rc
00004 //
00005 #define IDS_SERVICENAME                 100
00006 #define IDR_GwCaopCorba                 100
00007 #define IDR_EVENTSINK                   101
00008
00009 // Next default values for new objects
00010 //
00011 #ifdef APSTUDIO_INVOKED
00012 #ifndef APSTUDIO_READONLY_SYMBOLS
00013 #define _APS_NEXT_RESOURCE_VALUE        201
00014 #define _APS_NEXT_COMMAND_VALUE         32768
00015 #define _APS_NEXT_CONTROL_VALUE         201
00016 #define _APS_NEXT_SYMED_VALUE           102
00017 #endif
00018 #endif
Generated on Mon Oct 25 19:42:49 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


StdAfx.h Source File

StdAfx.h

解説を見る。
00001 // stdafx.h : 標準のシステム インクルード ファイル、
00002 //            または参照回数が多く、かつあまり変更されない
00003 //            プロジェクト専用のインクルード ファイルを記述します。
00004
00005 #if !defined(AFX_STDAFX_H__503EE5DC_08C2_490C_BAC3_4196D94D05A6__INCLUDED_)
00006 #define AFX_STDAFX_H__503EE5DC_08C2_490C_BAC3_4196D94D05A6__INCLUDED_
00007
00008 #if _MSC_VER > 1000
00009 #pragma once
00010 #endif // _MSC_VER > 1000
00011
00012 #define STRICT
00013 #ifndef _WIN32_WINNT
00014 #define _WIN32_WINNT 0x0400
00015 #endif
00016 #define _ATL_APARTMENT_THREADED
00017
00018 #include <atlbase.h>
00019 #include "CaoProvCorba.h"
00020 #include "CorbaServer.h"
00021
00022 using namespace CaoProv;
00023
00024 #define MAX_STR_LEN 256
00025
00026 #define SAFE_RELEASE(p) { if(p) { (p)->Release(); (p)=NULL; } }
00027 #define SAFE_DELETE(p) { if(p) { delete (p); (p)=NULL; } }
00028 #define SAFE_CLOSE(p) { if(p) { CloseHandle(p); (p)=NULL; } }
00029
00030 #define THROW_HRESULT(p) { throw CORBA::BAD_OPERATION(hr, CORBA::COMPLETED_NO); }
00031
00032 // CComModule クラスから派生したクラスを使用して、オーバーライドする場合
00033 // _Module の名前は変更しないでください。
00034
00035 class CServiceModule : public CComModule
00036 {
00037 public:
00038     HRESULT RegisterServer(BOOL bRegTypeLib, BOOL bService);
00039     HRESULT UnregisterServer();
00040     void Init(_ATL_OBJMAP_ENTRY* p, HINSTANCE h, UINT nServiceNameID, const GUID* plibid = NULL);
00041     void Start();
00042     void ServiceMain(DWORD dwArgc, LPTSTR* lpszArgv);
00043     void Handler(DWORD dwOpcode);
00044     void Run();
00045     BOOL IsInstalled();
00046     BOOL Install();
00047     BOOL Uninstall();
00048     LONG Unlock();
00049     void LogEvent(LPCTSTR pszFormat, ...);
00050     void SetServiceStatus(DWORD dwState);
00051     void SetupAsLocalServer();
00052
00053     HRESULT VntToCorbaVnt(VARIANT vntSrc, CORBA_VARIANT *pvntRet);
00054     HRESULT CorbaVntToVnt(CORBA_VARIANT vntSrc, VARIANT *pvntRet);
00055
00056 // インプリメンテーション
00057 private:
00058     static void WINAPI _ServiceMain(DWORD dwArgc, LPTSTR* lpszArgv);
00059     static void WINAPI _Handler(DWORD dwOpcode);
00060
00061
00062 // データ メンバ
00063 public:
00064     TCHAR m_szServiceName[256];
00065     SERVICE_STATUS_HANDLE m_hServiceStatus;
00066     SERVICE_STATUS m_status;
00067     DWORD dwThreadID;
00068     BOOL m_bService;
00069
00070     CCorbaServer m_CorbaSvr;
00071     int m_argc;
00072     char* m_argv[20];
00073 };
00074
00075 extern CServiceModule _Module;
00076 #include <atlcom.h>
00077
00078 #include "caoprovif.h"
00079
00080 LPCTSTR FindOneOf(LPCTSTR p1, LPCTSTR p2);
00081
00082 //{{AFX_INSERT_LOCATION}}
00083
00084 // Microsoft Visual C++ は前行の直前に追加の宣言を挿入します。
00085
00086 #endif // !defined(AFX_STDAFX_H__503EE5DC_08C2_490C_BAC3_4196D94D05A6__INCLUDED)
Generated on Mon Oct 25 19:42:49 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_IID メンバ一覧

これは全メンバの一覧です。_IID継承メンバも含んでいます。
c | _IID
s1 | _IID
s2 | _IID
x | _IID
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_MIDL_PROC_FORMAT_STRING メンバ一覧

これは全メンバの一覧です。_MIDL_PROC_FORMAT_STRING継承メンバも含んでいます。
Format | _MIDL_PROC_FORMAT_STRING
Pad | _MIDL_PROC_FORMAT_STRING
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_MIDL_TYPE_FORMAT_STRING メンバ一覧

これは全メンバの一覧です。_MIDL_TYPE_FORMAT_STRING継承メンバも含んでいます。
Format | _MIDL_TYPE_FORMAT_STRING
Pad | _MIDL_TYPE_FORMAT_STRING
Generated on Mon Oct 25 19:42:58 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CaoProv::CORBA_VARIANT メンバ一覧

これは全メンバの一覧です。CaoProv::CORBA_VARIANT継承メンバも含んでいます。
sa | CaoProv::CORBA_VARIANT
val | CaoProv::CORBA_VARIANT
vt | CaoProv::CORBA_VARIANT
Generated on Mon Oct 25 19:42:59 2004 for GwCaopCorba Project by doxygen 1.2.18, © 1997-2001