メインページ

DENSO WAVE CAO Project ドキュメント

1.0

Generated on Wed Dec 7 19:01:42 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


File Index

DENSO WAVE CAO Project ファイル一覧

これはファイル一覧です。
CAO.cpp | CServiceModule クラスの実装
CAO.h [コード] |
CAO.idl [コード] | CAO.dll 用の IDL ソース ファイル
CAO_i.c |
CAO_p.c |
CaoCollectionTmpl.h [コード] | CCaoCollectionTmplの定義
CaoCommand.cpp | CCaoCommandクラスの実装
CaoCommand.h [コード] | CCaoCommandの宣言
CaoCommands.cpp | CCaoCommandsクラスの実装
CaoCommands.h [コード] | CCaoCommandsの宣言
CaoController.cpp | CCaoController クラスの実装
CaoController.h [コード] | CCaoControllerの定義
CaoControllers.cpp | CCaoControllersの実装
CaoControllers.h [コード] | CCaoControllersの宣言
CAOCP.h [コード] | イベント通知テンプレートの宣言
CaoEngine.cpp | CCaoEngineクラスの実装
CaoEngine.h [コード] | CCaoEngineの宣言
CaoEngineStatus.cpp | CCaoEngineStatusクラスの実装
CaoEngineStatus.h [コード] | CCaoEngineStatusの宣言
CAOEventInfo.h [コード] |
CaoExtension.cpp | CCaoExtensionクラスの実装
CaoExtension.h [コード] | CCaoExtensionの宣言
CaoExtensions.cpp | CCaoExtensionsクラスの実装
CaoExtensions.h [コード] | CCaoExtensionsの宣言
CaoFile.cpp | CCaoFileクラスの実装
CaoFile.h [コード] | CCaoFileの宣言
CaoFiles.cpp | CCaoFilesクラスの実装
CaoFiles.h [コード] | CCaoFilesの宣言
CaoMessage.cpp | CCaoMessageの実装
CaoMessage.h [コード] | CCaoMessageの宣言
CaoObjectTmpl.h [コード] | CAOのオブジェクトのテンプレート宣言
CaoRobot.cpp | CCaoRobotクラスの実装
CaoRobot.h [コード] | CCaoRobotの宣言
CaoRobots.cpp | CCaoRobotsクラスの実装
CaoRobots.h [コード] | CCaoRobotsの宣言
CaoTask.cpp | CCaoTaskクラスの実装
CaoTask.h [コード] | CCaoTaskの宣言
CaoTasks.cpp | CCaoTasksクラスの実装
CaoTasks.h [コード] | CCaoTasksの宣言
CaoVariable.cpp | CCaoVariableクラスの実装
CaoVariable.h [コード] | CaoVariableの宣言
CaoVariables.cpp | CCaoVariablesクラスの実装
CaoVariables.h [コード] | CaoVariablesの宣言
CaoWorkspace.cpp | CCaoWorkspaceクラスの実装
CaoWorkspace.h [コード] | CCaoWorkspaceの宣言
CaoWorkspaces.cpp | CCaoWorkspacesクラスの実装
CaoWorkspaces.h [コード] | CCaoWorkspacesの宣言
dlldata.c |
EventSink.cpp | CEventSinkクラスの実装
EventSink.h [コード] | CEventSinkの宣言
Preload.h [コード] |
resource.h [コード] |
StdAfx.cpp | 標準インクルードファイルを含むソースファイル
StdAfx.h [コード] | 標準のシステムインクルードファイル
Generated on Wed Dec 7 19:01:42 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAO.cpp File Reference

CAO.cpp の解説

CServiceModule クラスの実装. [詳細]

#include "stdafx.h"
#include "resource.h"
#include <initguid.h>
#include "CAO.h"
#include "CAO_i.c"
#include "CaoEngine.h"
#include "CaoWorkspace.h"
#include "CaoWorkspaces.h"
#include "CaoController.h"
#include "CaoControllers.h"
#include "CaoExtension.h"
#include "CaoExtensions.h"
#include "CaoFile.h"
#include "CaoFiles.h"
#include "CaoRobot.h"
#include "CaoRobots.h"
#include "CaoTask.h"
#include "CaoTasks.h"
#include "CaoVariable.h"
#include "CaoVariables.h"
#include "CaoCommand.h"
#include "CaoCommands.h"
#include "CaoEngineStatus.h"
#include "EventSink.h"
#include "CaoEventInfo.h"

CAO.cppのインクルード依存関係図

Include dependency graph

関数

void | CoUninitializeEx ()
DCOM 開始.

LPCTSTR | FindOneOf (LPCTSTR p1, LPCTSTR p2)
トークンの切り出し

int WINAPI | _tWinMain (HINSTANCE hInstance, HINSTANCE, LPTSTR lpCmdLine, int)
エントリポイント

変数

CServiceModule _Module
int | PROCESS_PRIORITY [4]
レジストリオプション読み込み

解説

CServiceModule クラスの実装.

  メモ: Proxy/Stub 情報 　別々の proxy/stub DLL をビルドするためには，プロジェクトのディレクトリで 　nmake -f CAOps.mak を実行してください．

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE

関数の解説

int WINAPI _tWinMain | ( | HINSTANCE | hInstance,
 |  | HINSTANCE | ,
 |  | LPTSTR | lpCmdLine,
 |  | int |
 | ) |

エントリポイント

  MS-Windows のEXE形式のエントリポイント 　WinMain() はライブラリコードの中に埋め込まれている．

引数:
hInstance
lpCmdLine
戻り値:
int

void CoUninitializeEx ( )

DCOM 開始.

  DCOM 開始処理 と メッセージ取得を行う 　ケースID(問い合わせ番号) SRF000412690262

LPCTSTR FindOneOf | ( | LPCTSTR | p1,
 |  | LPCTSTR | p2
 | ) |

トークンの切り出し

  文字列から1つのトークンを切り出します．

引数:
p1 | : [in] 文字列
p2 | : [in] デリミタ
戻り値:
LPCTSTR : OK 時 文字列 ，NG 時 NULL

変数の解説

CServiceModule _Module

int PROCESS_PRIORITY[4]

初期値:

{
    IDLE_PRIORITY_CLASS,
    NORMAL_PRIORITY_CLASS,
    HIGH_PRIORITY_CLASS,
    REALTIME_PRIORITY_CLASS,
}
レジストリオプション読み込み

  Priority　:　IDLE_PRIORITY_CLASS 0x00000040 低
               NORMAL_PRIORITY_CLASS 0x00000020 中
               HIGH_PRIORITY_CLASS 0x00000080 高（デフォルト）
               REALTIME_PRIORITY_CLASS 0x00000100 リアルタイム
  LogType　:　0x00000000 Console
              0x00000001 Event Viewer（デフォルト）
              0x00000002 Debug Viewer - OutputDebugString
              0x00000003 RRD File
  LogLevel　:　0x00000001 システムメッセージ（デフォルト）
               0x00000002 Call Engine
               0x00000004 Call Provider

戻り値:
long

Generated on Wed Dec 7 19:01:44 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAO.h File Reference

CAO.h の解説

#include "rpc.h"
#include "rpcndr.h"
#include "windows.h"
#include "ole2.h"
#include "oaidl.h"
#include "ocidl.h"

CAO.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

マクロ定義

#define | __REQUIRED_RPCNDR_H_VERSION__ 440

Typedef

typedef interface ICaoEngine | ICaoEngine
typedef interface ICaoWorkspaces | ICaoWorkspaces
typedef interface ICaoWorkspace | ICaoWorkspace
typedef interface ICaoControllers | ICaoControllers
typedef interface ICaoController | ICaoController
typedef interface ICaoExtensions | ICaoExtensions
typedef interface ICaoExtension | ICaoExtension
typedef interface ICaoFiles | ICaoFiles
typedef interface ICaoFile | ICaoFile
typedef interface ICaoRobots | ICaoRobots
typedef interface ICaoRobot | ICaoRobot
typedef interface ICaoTasks | ICaoTasks
typedef interface ICaoTask | ICaoTask
typedef interface ICaoVariables | ICaoVariables
typedef interface ICaoVariable | ICaoVariable
typedef interface ICaoCommands | ICaoCommands
typedef interface ICaoCommand | ICaoCommand
typedef interface ICaoMessage | ICaoMessage
typedef interface ICaoEngineStatus | ICaoEngineStatus
typedef interface IEventSink | IEventSink
typedef interface _ICaoControllerEvents | _ICaoControllerEvents
typedef interface _ICaoCommandsEvents | _ICaoCommandsEvents
typedef CaoEngine | CaoEngine
typedef CaoWorkspaces | CaoWorkspaces
typedef CaoWorkspace | CaoWorkspace
typedef CaoControllers | CaoControllers
typedef CaoController | CaoController
typedef CaoExtensions | CaoExtensions
typedef CaoExtension | CaoExtension
typedef CaoFiles | CaoFiles
typedef CaoFile | CaoFile
typedef CaoRobots | CaoRobots
typedef CaoRobot | CaoRobot
typedef CaoTasks | CaoTasks
typedef CaoTask | CaoTask
typedef CaoVariables | CaoVariables
typedef CaoVariable | CaoVariable
typedef CaoCommands | CaoCommands
typedef CaoCommand | CaoCommand
typedef CaoMessage | CaoMessage
typedef CaoEngineStatus | CaoEngineStatus
typedef EventSink | EventSink

関数

void __RPC_FAR *__RPC_USER | MIDL_user_allocate (size_t)
void __RPC_USER | MIDL_user_free (void __RPC_FAR *)
virtual HRESULT STDMETHODCALLTYPE | get_Workspaces (ICaoWorkspaces __RPC_FAR *__RPC_FAR *ppICaoWSs)=0
virtual HRESULT STDMETHODCALLTYPE | AddWorkspace (BSTR bstrName, BSTR bstrOption, ICaoWorkspace __RPC_FAR *__RPC_FAR *ppICaoWS)=0
virtual HRESULT STDMETHODCALLTYPE | Execute (VARIANT vntCommand, VARIANT __RPC_FAR *pVal)=0
HRESULT STDMETHODCALLTYPE | ICaoEngine_get_EngineStatus_Proxy (ICaoEngine __RPC_FAR *This, ICaoEngineStatus __RPC_FAR *__RPC_FAR *ppICaoEngineStatus)
void __RPC_STUB | ICaoEngine_get_EngineStatus_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoEngine_get_Workspaces_Proxy (ICaoEngine __RPC_FAR *This, ICaoWorkspaces __RPC_FAR *__RPC_FAR *ppICaoWSs)
void __RPC_STUB | ICaoEngine_get_Workspaces_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoEngine_AddWorkspace_Proxy (ICaoEngine __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoWorkspace __RPC_FAR *__RPC_FAR *ppICaoWS)
void __RPC_STUB | ICaoEngine_AddWorkspace_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoEngine_Execute_Proxy (ICaoEngine __RPC_FAR *This, VARIANT vntCommand, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoEngine_Execute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | Item (VARIANT Index, ICaoWorkspace __RPC_FAR *__RPC_FAR *ppICaoWS)=0
virtual HRESULT STDMETHODCALLTYPE | get_Count (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | Add (BSTR bstrName, BSTR bstrOption, ICaoWorkspace __RPC_FAR *__RPC_FAR *ppICaoWS)=0
virtual HRESULT STDMETHODCALLTYPE | Remove (VARIANT Index)=0
virtual HRESULT STDMETHODCALLTYPE | Clear (void)=0
virtual HRESULT STDMETHODCALLTYPE | IsMember (VARIANT Index, VARIANT_BOOL __RPC_FAR *pVal)=0
HRESULT STDMETHODCALLTYPE | ICaoWorkspaces_get__NewEnum_Proxy (ICaoWorkspaces __RPC_FAR *This, LPUNKNOWN __RPC_FAR *pVal)
void __RPC_STUB | ICaoWorkspaces_get__NewEnum_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoWorkspaces_Item_Proxy (ICaoWorkspaces __RPC_FAR *This, VARIANT Index, ICaoWorkspace __RPC_FAR *__RPC_FAR *ppICaoWS)
void __RPC_STUB | ICaoWorkspaces_Item_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoWorkspaces_get_Count_Proxy (ICaoWorkspaces __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoWorkspaces_get_Count_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoWorkspaces_Add_Proxy (ICaoWorkspaces __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoWorkspace __RPC_FAR *__RPC_FAR *ppICaoWS)
void __RPC_STUB | ICaoWorkspaces_Add_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoWorkspaces_Remove_Proxy (ICaoWorkspaces __RPC_FAR *This, VARIANT Index)
void __RPC_STUB | ICaoWorkspaces_Remove_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoWorkspaces_Clear_Proxy (ICaoWorkspaces __RPC_FAR *This)
void __RPC_STUB | ICaoWorkspaces_Clear_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoWorkspaces_IsMember_Proxy (ICaoWorkspaces __RPC_FAR *This, VARIANT Index, VARIANT_BOOL __RPC_FAR *pVal)
void __RPC_STUB | ICaoWorkspaces_IsMember_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | get_Controllers (ICaoControllers __RPC_FAR *__RPC_FAR *ppICaoCtrls)=0
virtual HRESULT STDMETHODCALLTYPE | get_Index (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Name (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_ProviderNames (BSTR bstrOption, VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | AddController (BSTR bstrController, BSTR bstrProvider, BSTR bstrMachine, BSTR bstrOption, ICaoController __RPC_FAR *__RPC_FAR *ppICaoCtrl)=0
HRESULT STDMETHODCALLTYPE | ICaoWorkspace__PutIndex_Proxy (ICaoWorkspace __RPC_FAR *This, long newVal)
void __RPC_STUB | ICaoWorkspace__PutIndex_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoWorkspace_get_Controllers_Proxy (ICaoWorkspace __RPC_FAR *This, ICaoControllers __RPC_FAR *__RPC_FAR *ppICaoCtrls)
void __RPC_STUB | ICaoWorkspace_get_Controllers_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoWorkspace_get_Index_Proxy (ICaoWorkspace __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoWorkspace_get_Index_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoWorkspace_get_Name_Proxy (ICaoWorkspace __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoWorkspace_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoWorkspace_get_ProviderNames_Proxy (ICaoWorkspace __RPC_FAR *This, BSTR bstrOption, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoWorkspace_get_ProviderNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoWorkspace_AddController_Proxy (ICaoWorkspace __RPC_FAR *This, BSTR bstrController, BSTR bstrProvider, BSTR bstrMachine, BSTR bstrOption, ICaoController __RPC_FAR *__RPC_FAR *ppICaoCtrl)
void __RPC_STUB | ICaoWorkspace_AddController_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoWorkspace_Execute_Proxy (ICaoWorkspace __RPC_FAR *This, VARIANT vntCommand, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoWorkspace_Execute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | Item (VARIANT Index, ICaoController __RPC_FAR *__RPC_FAR *ppICaoCtrl)=0
virtual HRESULT STDMETHODCALLTYPE | Add (BSTR bstrController, BSTR bstrProvider, BSTR bstrMachine, BSTR bstrOption, ICaoController __RPC_FAR *__RPC_FAR *ppICaoCtrl)=0
HRESULT STDMETHODCALLTYPE | ICaoControllers_get__NewEnum_Proxy (ICaoControllers __RPC_FAR *This, LPUNKNOWN __RPC_FAR *pVal)
void __RPC_STUB | ICaoControllers_get__NewEnum_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoControllers_Item_Proxy (ICaoControllers __RPC_FAR *This, VARIANT Index, ICaoController __RPC_FAR *__RPC_FAR *ppICaoCtrl)
void __RPC_STUB | ICaoControllers_Item_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoControllers_get_Count_Proxy (ICaoControllers __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoControllers_get_Count_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoControllers_Add_Proxy (ICaoControllers __RPC_FAR *This, BSTR bstrController, BSTR bstrProvider, BSTR bstrMachine, BSTR bstrOption, ICaoController __RPC_FAR *__RPC_FAR *ppICaoCtrl)
void __RPC_STUB | ICaoControllers_Add_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoControllers_Remove_Proxy (ICaoControllers __RPC_FAR *This, VARIANT Index)
void __RPC_STUB | ICaoControllers_Remove_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoControllers_Clear_Proxy (ICaoControllers __RPC_FAR *This)
void __RPC_STUB | ICaoControllers_Clear_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoControllers_IsMember_Proxy (ICaoControllers __RPC_FAR *This, VARIANT Index, VARIANT_BOOL __RPC_FAR *pVal)
void __RPC_STUB | ICaoControllers_IsMember_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | get_Attribute (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_ExtensionNames (BSTR bstrOption, VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Extensions (ICaoExtensions __RPC_FAR *__RPC_FAR *ppICaoExtensions)=0
virtual HRESULT STDMETHODCALLTYPE | get_FileNames (BSTR bstrOption, VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Files (ICaoFiles __RPC_FAR *__RPC_FAR *ppICaoFiles)=0
virtual HRESULT STDMETHODCALLTYPE | get_Help (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_RobotNames (BSTR bstrOption, VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Robots (ICaoRobots __RPC_FAR *__RPC_FAR *ppICaoRobots)=0
virtual HRESULT STDMETHODCALLTYPE | get_Tag (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Tag (VARIANT newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_TaskNames (BSTR bstrOption, VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Tasks (ICaoTasks __RPC_FAR *__RPC_FAR *ppICaoTasks)=0
virtual HRESULT STDMETHODCALLTYPE | get_VariableNames (BSTR bstrOption, VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Variables (ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables)=0
virtual HRESULT STDMETHODCALLTYPE | get_CommandNames (BSTR bstrOption, VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Commands (ICaoCommands __RPC_FAR *__RPC_FAR *ppICaoCommands)=0
virtual HRESULT STDMETHODCALLTYPE | get_ID (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_ID (VARIANT newVal)=0
virtual HRESULT STDMETHODCALLTYPE | AddExtension (BSTR bstrName, BSTR bstrOption, ICaoExtension __RPC_FAR *__RPC_FAR *ppICaoExtension)=0
virtual HRESULT STDMETHODCALLTYPE | AddFile (BSTR bstrName, BSTR bstrOption, ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile)=0
virtual HRESULT STDMETHODCALLTYPE | AddRobot (BSTR bstrName, BSTR bstrOption, ICaoRobot __RPC_FAR *__RPC_FAR *ppICaoRobot)=0
virtual HRESULT STDMETHODCALLTYPE | AddTask (BSTR bstrName, BSTR bstrOption, ICaoTask __RPC_FAR *__RPC_FAR *ppICaoTask)=0
virtual HRESULT STDMETHODCALLTYPE | AddVariable (BSTR bstrName, BSTR bstrOption, ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar)=0
virtual HRESULT STDMETHODCALLTYPE | AddCommand (BSTR bstrName, BSTR bstrOption, ICaoCommand __RPC_FAR *__RPC_FAR *ppICaoCommand)=0
virtual HRESULT STDMETHODCALLTYPE | GetMessage (ICaoMessage __RPC_FAR *__RPC_FAR *ppICaoMessage)=0
HRESULT STDMETHODCALLTYPE | ICaoController__PutIndex_Proxy (ICaoController __RPC_FAR *This, long newVal)
void __RPC_STUB | ICaoController__PutIndex_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_Attribute_Proxy (ICaoController __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoController_get_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_ExtensionNames_Proxy (ICaoController __RPC_FAR *This, BSTR bstrOption, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoController_get_ExtensionNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_Extensions_Proxy (ICaoController __RPC_FAR *This, ICaoExtensions __RPC_FAR *__RPC_FAR *ppICaoExtensions)
void __RPC_STUB | ICaoController_get_Extensions_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_FileNames_Proxy (ICaoController __RPC_FAR *This, BSTR bstrOption, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoController_get_FileNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_Files_Proxy (ICaoController __RPC_FAR *This, ICaoFiles __RPC_FAR *__RPC_FAR *ppICaoFiles)
void __RPC_STUB | ICaoController_get_Files_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_Help_Proxy (ICaoController __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoController_get_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_Index_Proxy (ICaoController __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoController_get_Index_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_Name_Proxy (ICaoController __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoController_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_RobotNames_Proxy (ICaoController __RPC_FAR *This, BSTR bstrOption, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoController_get_RobotNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_Robots_Proxy (ICaoController __RPC_FAR *This, ICaoRobots __RPC_FAR *__RPC_FAR *ppICaoRobots)
void __RPC_STUB | ICaoController_get_Robots_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_Tag_Proxy (ICaoController __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoController_get_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_put_Tag_Proxy (ICaoController __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoController_put_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_TaskNames_Proxy (ICaoController __RPC_FAR *This, BSTR bstrOption, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoController_get_TaskNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_Tasks_Proxy (ICaoController __RPC_FAR *This, ICaoTasks __RPC_FAR *__RPC_FAR *ppICaoTasks)
void __RPC_STUB | ICaoController_get_Tasks_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_VariableNames_Proxy (ICaoController __RPC_FAR *This, BSTR bstrOption, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoController_get_VariableNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_Variables_Proxy (ICaoController __RPC_FAR *This, ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables)
void __RPC_STUB | ICaoController_get_Variables_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_CommandNames_Proxy (ICaoController __RPC_FAR *This, BSTR bstrOption, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoController_get_CommandNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_Commands_Proxy (ICaoController __RPC_FAR *This, ICaoCommands __RPC_FAR *__RPC_FAR *ppICaoCommands)
void __RPC_STUB | ICaoController_get_Commands_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_get_ID_Proxy (ICaoController __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoController_get_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_put_ID_Proxy (ICaoController __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoController_put_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_AddExtension_Proxy (ICaoController __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoExtension __RPC_FAR *__RPC_FAR *ppICaoExtension)
void __RPC_STUB | ICaoController_AddExtension_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_AddFile_Proxy (ICaoController __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile)
void __RPC_STUB | ICaoController_AddFile_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_AddRobot_Proxy (ICaoController __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoRobot __RPC_FAR *__RPC_FAR *ppICaoRobot)
void __RPC_STUB | ICaoController_AddRobot_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_AddTask_Proxy (ICaoController __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoTask __RPC_FAR *__RPC_FAR *ppICaoTask)
void __RPC_STUB | ICaoController_AddTask_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_AddVariable_Proxy (ICaoController __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar)
void __RPC_STUB | ICaoController_AddVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_AddCommand_Proxy (ICaoController __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoCommand __RPC_FAR *__RPC_FAR *ppICaoCommand)
void __RPC_STUB | ICaoController_AddCommand_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_Execute_Proxy (ICaoController __RPC_FAR *This, VARIANT vntCommand, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoController_Execute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoController_GetMessage_Proxy (ICaoController __RPC_FAR *This, ICaoMessage __RPC_FAR *__RPC_FAR *ppICaoMessage)
void __RPC_STUB | ICaoController_GetMessage_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | Item (VARIANT Index, ICaoExtension __RPC_FAR *__RPC_FAR *ppICaoExtension)=0
virtual HRESULT STDMETHODCALLTYPE | Add (BSTR bstrName, BSTR bstrOption, ICaoExtension __RPC_FAR *__RPC_FAR *ppICaoExtension)=0
HRESULT STDMETHODCALLTYPE | ICaoExtensions_get__NewEnum_Proxy (ICaoExtensions __RPC_FAR *This, LPUNKNOWN __RPC_FAR *pVal)
void __RPC_STUB | ICaoExtensions_get__NewEnum_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtensions_Item_Proxy (ICaoExtensions __RPC_FAR *This, VARIANT Index, ICaoExtension __RPC_FAR *__RPC_FAR *ppICaoExtension)
void __RPC_STUB | ICaoExtensions_Item_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtensions_get_Count_Proxy (ICaoExtensions __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoExtensions_get_Count_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtensions_Add_Proxy (ICaoExtensions __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoExtension __RPC_FAR *__RPC_FAR *ppICaoExtension)
void __RPC_STUB | ICaoExtensions_Add_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtensions_Remove_Proxy (ICaoExtensions __RPC_FAR *This, VARIANT Index)
void __RPC_STUB | ICaoExtensions_Remove_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtensions_Clear_Proxy (ICaoExtensions __RPC_FAR *This)
void __RPC_STUB | ICaoExtensions_Clear_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtensions_IsMember_Proxy (ICaoExtensions __RPC_FAR *This, VARIANT Index, VARIANT_BOOL __RPC_FAR *pVal)
void __RPC_STUB | ICaoExtensions_IsMember_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtension__PutIndex_Proxy (ICaoExtension __RPC_FAR *This, long newVal)
void __RPC_STUB | ICaoExtension__PutIndex_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtension_get_Attribute_Proxy (ICaoExtension __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoExtension_get_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtension_get_Help_Proxy (ICaoExtension __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoExtension_get_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtension_get_Index_Proxy (ICaoExtension __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoExtension_get_Index_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtension_get_Name_Proxy (ICaoExtension __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoExtension_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtension_get_Tag_Proxy (ICaoExtension __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoExtension_get_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtension_put_Tag_Proxy (ICaoExtension __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoExtension_put_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtension_get_VariableNames_Proxy (ICaoExtension __RPC_FAR *This, BSTR bstrOption, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoExtension_get_VariableNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtension_get_Variables_Proxy (ICaoExtension __RPC_FAR *This, ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables)
void __RPC_STUB | ICaoExtension_get_Variables_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtension_get_ID_Proxy (ICaoExtension __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoExtension_get_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtension_put_ID_Proxy (ICaoExtension __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoExtension_put_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtension_AddVariable_Proxy (ICaoExtension __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar)
void __RPC_STUB | ICaoExtension_AddVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoExtension_Execute_Proxy (ICaoExtension __RPC_FAR *This, VARIANT vntCommand, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoExtension_Execute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | Item (VARIANT Index, ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile)=0
virtual HRESULT STDMETHODCALLTYPE | Add (BSTR bstrName, BSTR bstrOption, ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile)=0
HRESULT STDMETHODCALLTYPE | ICaoFiles_get__NewEnum_Proxy (ICaoFiles __RPC_FAR *This, LPUNKNOWN __RPC_FAR *pVal)
void __RPC_STUB | ICaoFiles_get__NewEnum_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFiles_Item_Proxy (ICaoFiles __RPC_FAR *This, VARIANT Index, ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile)
void __RPC_STUB | ICaoFiles_Item_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFiles_get_Count_Proxy (ICaoFiles __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoFiles_get_Count_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFiles_Add_Proxy (ICaoFiles __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile)
void __RPC_STUB | ICaoFiles_Add_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFiles_Remove_Proxy (ICaoFiles __RPC_FAR *This, VARIANT Index)
void __RPC_STUB | ICaoFiles_Remove_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFiles_Clear_Proxy (ICaoFiles __RPC_FAR *This)
void __RPC_STUB | ICaoFiles_Clear_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFiles_IsMember_Proxy (ICaoFiles __RPC_FAR *This, VARIANT Index, VARIANT_BOOL __RPC_FAR *pVal)
void __RPC_STUB | ICaoFiles_IsMember_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | put_Value (VARIANT newVal)=0
virtual HRESULT STDMETHODCALLTYPE | _PutIndex (long newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_DateCreated (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_DateLastAccessed (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_DateLastModified (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Path (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Size (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Type (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | Copy (BSTR bstrName, BSTR bstrOption=L"")=0
virtual HRESULT STDMETHODCALLTYPE | Delete (BSTR bstrOption=L"")=0
virtual HRESULT STDMETHODCALLTYPE | Move (BSTR bstrName, BSTR bstrOption=L"")=0
virtual HRESULT STDMETHODCALLTYPE | Run (BSTR bstrOption, BSTR __RPC_FAR *bstrName)=0
HRESULT STDMETHODCALLTYPE | ICaoFile_get_Value_Proxy (ICaoFile __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoFile_get_Value_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_put_Value_Proxy (ICaoFile __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoFile_put_Value_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile__PutIndex_Proxy (ICaoFile __RPC_FAR *This, long newVal)
void __RPC_STUB | ICaoFile__PutIndex_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_get_Attribute_Proxy (ICaoFile __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoFile_get_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_get_DateCreated_Proxy (ICaoFile __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoFile_get_DateCreated_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_get_DateLastAccessed_Proxy (ICaoFile __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoFile_get_DateLastAccessed_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_get_DateLastModified_Proxy (ICaoFile __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoFile_get_DateLastModified_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_get_FileNames_Proxy (ICaoFile __RPC_FAR *This, BSTR bstrOption, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoFile_get_FileNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_get_Files_Proxy (ICaoFile __RPC_FAR *This, ICaoFiles __RPC_FAR *__RPC_FAR *ppICaoFiles)
void __RPC_STUB | ICaoFile_get_Files_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_get_Help_Proxy (ICaoFile __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoFile_get_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_get_Index_Proxy (ICaoFile __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoFile_get_Index_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_get_Name_Proxy (ICaoFile __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoFile_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_get_Path_Proxy (ICaoFile __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoFile_get_Path_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_get_Size_Proxy (ICaoFile __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoFile_get_Size_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_get_Tag_Proxy (ICaoFile __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoFile_get_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_put_Tag_Proxy (ICaoFile __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoFile_put_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_get_Type_Proxy (ICaoFile __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoFile_get_Type_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_get_VariableNames_Proxy (ICaoFile __RPC_FAR *This, BSTR bstrOption, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoFile_get_VariableNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_get_Variables_Proxy (ICaoFile __RPC_FAR *This, ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables)
void __RPC_STUB | ICaoFile_get_Variables_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_get_ID_Proxy (ICaoFile __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoFile_get_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_put_ID_Proxy (ICaoFile __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoFile_put_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_AddFile_Proxy (ICaoFile __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile)
void __RPC_STUB | ICaoFile_AddFile_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_AddVariable_Proxy (ICaoFile __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar)
void __RPC_STUB | ICaoFile_AddVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_Copy_Proxy (ICaoFile __RPC_FAR *This, BSTR bstrName, BSTR bstrOption)
void __RPC_STUB | ICaoFile_Copy_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_Delete_Proxy (ICaoFile __RPC_FAR *This, BSTR bstrOption)
void __RPC_STUB | ICaoFile_Delete_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_Execute_Proxy (ICaoFile __RPC_FAR *This, VARIANT vntCommand, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoFile_Execute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_Move_Proxy (ICaoFile __RPC_FAR *This, BSTR bstrName, BSTR bstrOption)
void __RPC_STUB | ICaoFile_Move_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoFile_Run_Proxy (ICaoFile __RPC_FAR *This, BSTR bstrOption, BSTR __RPC_FAR *bstrName)
void __RPC_STUB | ICaoFile_Run_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | Item (VARIANT Index, ICaoRobot __RPC_FAR *__RPC_FAR *ppICaoRobot)=0
virtual HRESULT STDMETHODCALLTYPE | Add (BSTR bstrName, BSTR bstrOption, ICaoRobot __RPC_FAR *__RPC_FAR *ppICaoRobot)=0
HRESULT STDMETHODCALLTYPE | ICaoRobots_get__NewEnum_Proxy (ICaoRobots __RPC_FAR *This, LPUNKNOWN __RPC_FAR *pVal)
void __RPC_STUB | ICaoRobots_get__NewEnum_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobots_Item_Proxy (ICaoRobots __RPC_FAR *This, VARIANT Index, ICaoRobot __RPC_FAR *__RPC_FAR *ppICaoRobot)
void __RPC_STUB | ICaoRobots_Item_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobots_get_Count_Proxy (ICaoRobots __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoRobots_get_Count_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobots_Add_Proxy (ICaoRobots __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoRobot __RPC_FAR *__RPC_FAR *ppICaoRobot)
void __RPC_STUB | ICaoRobots_Add_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobots_Remove_Proxy (ICaoRobots __RPC_FAR *This, VARIANT Index)
void __RPC_STUB | ICaoRobots_Remove_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobots_Clear_Proxy (ICaoRobots __RPC_FAR *This)
void __RPC_STUB | ICaoRobots_Clear_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobots_IsMember_Proxy (ICaoRobots __RPC_FAR *This, VARIANT Index, VARIANT_BOOL __RPC_FAR *pVal)
void __RPC_STUB | ICaoRobots_IsMember_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | Accelerate (long lAxis, float fAccel, float fDecel=0)=0
virtual HRESULT STDMETHODCALLTYPE | Change (BSTR bstrName)=0
virtual HRESULT STDMETHODCALLTYPE | Chuck (BSTR bstrOption=L"")=0
virtual HRESULT STDMETHODCALLTYPE | Drive (long lNo, float fMov, BSTR bstrOpt=L"")=0
virtual HRESULT STDMETHODCALLTYPE | GoHome (void)=0
virtual HRESULT STDMETHODCALLTYPE | Halt (BSTR bstrOption=L"")=0
virtual HRESULT STDMETHODCALLTYPE | Hold (BSTR bstrOption=L"")=0
virtual HRESULT STDMETHODCALLTYPE | Move (long lComp, VARIANT vntPose, BSTR bstrOpt=L"")=0
virtual HRESULT STDMETHODCALLTYPE | Rotate (VARIANT vntRotSuf, float fDeg, VARIANT vntPivot, BSTR bstrOpt=L"")=0
virtual HRESULT STDMETHODCALLTYPE | Speed (long lAxis, float fSpeed)=0
virtual HRESULT STDMETHODCALLTYPE | Unchuck (BSTR bstrOption=L"")=0
virtual HRESULT STDMETHODCALLTYPE | Unhold (BSTR bstrOption=L"")=0
HRESULT STDMETHODCALLTYPE | ICaoRobot__PutIndex_Proxy (ICaoRobot __RPC_FAR *This, long newVal)
void __RPC_STUB | ICaoRobot__PutIndex_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_get_Attribute_Proxy (ICaoRobot __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoRobot_get_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_get_Help_Proxy (ICaoRobot __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoRobot_get_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_get_Index_Proxy (ICaoRobot __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoRobot_get_Index_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_get_Name_Proxy (ICaoRobot __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoRobot_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_get_Tag_Proxy (ICaoRobot __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoRobot_get_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_put_Tag_Proxy (ICaoRobot __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoRobot_put_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_get_VariableNames_Proxy (ICaoRobot __RPC_FAR *This, BSTR bstrOption, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoRobot_get_VariableNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_get_Variables_Proxy (ICaoRobot __RPC_FAR *This, ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables)
void __RPC_STUB | ICaoRobot_get_Variables_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_get_ID_Proxy (ICaoRobot __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoRobot_get_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_put_ID_Proxy (ICaoRobot __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoRobot_put_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_Accelerate_Proxy (ICaoRobot __RPC_FAR *This, long lAxis, float fAccel, float fDecel)
void __RPC_STUB | ICaoRobot_Accelerate_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_AddVariable_Proxy (ICaoRobot __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar)
void __RPC_STUB | ICaoRobot_AddVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_Change_Proxy (ICaoRobot __RPC_FAR *This, BSTR bstrName)
void __RPC_STUB | ICaoRobot_Change_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_Chuck_Proxy (ICaoRobot __RPC_FAR *This, BSTR bstrOption)
void __RPC_STUB | ICaoRobot_Chuck_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_Drive_Proxy (ICaoRobot __RPC_FAR *This, long lNo, float fMov, BSTR bstrOpt)
void __RPC_STUB | ICaoRobot_Drive_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_Execute_Proxy (ICaoRobot __RPC_FAR *This, VARIANT vntCommand, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoRobot_Execute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_GoHome_Proxy (ICaoRobot __RPC_FAR *This)
void __RPC_STUB | ICaoRobot_GoHome_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_Halt_Proxy (ICaoRobot __RPC_FAR *This, BSTR bstrOption)
void __RPC_STUB | ICaoRobot_Halt_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_Hold_Proxy (ICaoRobot __RPC_FAR *This, BSTR bstrOption)
void __RPC_STUB | ICaoRobot_Hold_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_Move_Proxy (ICaoRobot __RPC_FAR *This, long lComp, VARIANT vntPose, BSTR bstrOpt)
void __RPC_STUB | ICaoRobot_Move_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_Rotate_Proxy (ICaoRobot __RPC_FAR *This, VARIANT vntRotSuf, float fDeg, VARIANT vntPivot, BSTR bstrOpt)
void __RPC_STUB | ICaoRobot_Rotate_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_Speed_Proxy (ICaoRobot __RPC_FAR *This, long lAxis, float fSpeed)
void __RPC_STUB | ICaoRobot_Speed_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_Unchuck_Proxy (ICaoRobot __RPC_FAR *This, BSTR bstrOption)
void __RPC_STUB | ICaoRobot_Unchuck_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoRobot_Unhold_Proxy (ICaoRobot __RPC_FAR *This, BSTR bstrOption)
void __RPC_STUB | ICaoRobot_Unhold_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | Item (VARIANT Index, ICaoTask __RPC_FAR *__RPC_FAR *ppICaoTask)=0
virtual HRESULT STDMETHODCALLTYPE | Add (BSTR bstrName, BSTR bstrOption, ICaoTask __RPC_FAR *__RPC_FAR *ppICaoTask)=0
HRESULT STDMETHODCALLTYPE | ICaoTasks_get__NewEnum_Proxy (ICaoTasks __RPC_FAR *This, LPUNKNOWN __RPC_FAR *pVal)
void __RPC_STUB | ICaoTasks_get__NewEnum_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTasks_Item_Proxy (ICaoTasks __RPC_FAR *This, VARIANT Index, ICaoTask __RPC_FAR *__RPC_FAR *ppICaoTask)
void __RPC_STUB | ICaoTasks_Item_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTasks_get_Count_Proxy (ICaoTasks __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoTasks_get_Count_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTasks_Add_Proxy (ICaoTasks __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoTask __RPC_FAR *__RPC_FAR *ppICaoTask)
void __RPC_STUB | ICaoTasks_Add_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTasks_Remove_Proxy (ICaoTasks __RPC_FAR *This, VARIANT Index)
void __RPC_STUB | ICaoTasks_Remove_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTasks_Clear_Proxy (ICaoTasks __RPC_FAR *This)
void __RPC_STUB | ICaoTasks_Clear_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTasks_IsMember_Proxy (ICaoTasks __RPC_FAR *This, VARIANT Index, VARIANT_BOOL __RPC_FAR *pVal)
void __RPC_STUB | ICaoTasks_IsMember_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | get_FileName (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | Start (long lMode=0, BSTR bstrOption=L"")=0
virtual HRESULT STDMETHODCALLTYPE | Stop (long lMode=0, BSTR bstrOption=L"")=0
HRESULT STDMETHODCALLTYPE | ICaoTask__PutIndex_Proxy (ICaoTask __RPC_FAR *This, long newVal)
void __RPC_STUB | ICaoTask__PutIndex_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTask_get_Attribute_Proxy (ICaoTask __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoTask_get_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTask_get_FileName_Proxy (ICaoTask __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoTask_get_FileName_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTask_get_Help_Proxy (ICaoTask __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoTask_get_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTask_get_Index_Proxy (ICaoTask __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoTask_get_Index_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTask_get_Name_Proxy (ICaoTask __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoTask_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTask_get_Tag_Proxy (ICaoTask __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoTask_get_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTask_put_Tag_Proxy (ICaoTask __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoTask_put_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTask_get_VariableNames_Proxy (ICaoTask __RPC_FAR *This, BSTR bstrOption, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoTask_get_VariableNames_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTask_get_Variables_Proxy (ICaoTask __RPC_FAR *This, ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables)
void __RPC_STUB | ICaoTask_get_Variables_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTask_get_ID_Proxy (ICaoTask __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoTask_get_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTask_put_ID_Proxy (ICaoTask __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoTask_put_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTask_AddVariable_Proxy (ICaoTask __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar)
void __RPC_STUB | ICaoTask_AddVariable_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTask_Delete_Proxy (ICaoTask __RPC_FAR *This, BSTR bstrOption)
void __RPC_STUB | ICaoTask_Delete_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTask_Execute_Proxy (ICaoTask __RPC_FAR *This, VARIANT vntCommand, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoTask_Execute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTask_Start_Proxy (ICaoTask __RPC_FAR *This, long lMode, BSTR bstrOption)
void __RPC_STUB | ICaoTask_Start_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoTask_Stop_Proxy (ICaoTask __RPC_FAR *This, long lMode, BSTR bstrOption)
void __RPC_STUB | ICaoTask_Stop_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | Item (VARIANT Index, ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar)=0
virtual HRESULT STDMETHODCALLTYPE | Add (BSTR bstrName, BSTR bstrOption, ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar)=0
HRESULT STDMETHODCALLTYPE | ICaoVariables_get__NewEnum_Proxy (ICaoVariables __RPC_FAR *This, LPUNKNOWN __RPC_FAR *pVal)
void __RPC_STUB | ICaoVariables_get__NewEnum_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariables_Item_Proxy (ICaoVariables __RPC_FAR *This, VARIANT Index, ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar)
void __RPC_STUB | ICaoVariables_Item_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariables_get_Count_Proxy (ICaoVariables __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoVariables_get_Count_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariables_Add_Proxy (ICaoVariables __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar)
void __RPC_STUB | ICaoVariables_Add_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariables_Remove_Proxy (ICaoVariables __RPC_FAR *This, VARIANT Index)
void __RPC_STUB | ICaoVariables_Remove_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariables_Clear_Proxy (ICaoVariables __RPC_FAR *This)
void __RPC_STUB | ICaoVariables_Clear_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariables_IsMember_Proxy (ICaoVariables __RPC_FAR *This, VARIANT Index, VARIANT_BOOL __RPC_FAR *pVal)
void __RPC_STUB | ICaoVariables_IsMember_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | get_DateTime (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Microsecond (long __RPC_FAR *pVal)=0
HRESULT STDMETHODCALLTYPE | ICaoVariable_get_Value_Proxy (ICaoVariable __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoVariable_get_Value_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariable_put_Value_Proxy (ICaoVariable __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoVariable_put_Value_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariable__PutIndex_Proxy (ICaoVariable __RPC_FAR *This, long newVal)
void __RPC_STUB | ICaoVariable__PutIndex_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariable_get_Attribute_Proxy (ICaoVariable __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoVariable_get_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariable_get_DateTime_Proxy (ICaoVariable __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoVariable_get_DateTime_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariable_get_Help_Proxy (ICaoVariable __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoVariable_get_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariable_get_Index_Proxy (ICaoVariable __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoVariable_get_Index_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariable_get_Name_Proxy (ICaoVariable __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoVariable_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariable_get_Tag_Proxy (ICaoVariable __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoVariable_get_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariable_put_Tag_Proxy (ICaoVariable __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoVariable_put_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariable_get_ID_Proxy (ICaoVariable __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoVariable_get_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariable_put_ID_Proxy (ICaoVariable __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoVariable_put_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoVariable_get_Microsecond_Proxy (ICaoVariable __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoVariable_get_Microsecond_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | Item (VARIANT Index, ICaoCommand __RPC_FAR *__RPC_FAR *ppICaoCommand)=0
virtual HRESULT STDMETHODCALLTYPE | Add (BSTR bstrName, BSTR bstrOption, ICaoCommand __RPC_FAR *__RPC_FAR *ppICaoCommand)=0
HRESULT STDMETHODCALLTYPE | ICaoCommands_get__NewEnum_Proxy (ICaoCommands __RPC_FAR *This, LPUNKNOWN __RPC_FAR *pVal)
void __RPC_STUB | ICaoCommands_get__NewEnum_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommands_Item_Proxy (ICaoCommands __RPC_FAR *This, VARIANT Index, ICaoCommand __RPC_FAR *__RPC_FAR *ppICaoCommand)
void __RPC_STUB | ICaoCommands_Item_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommands_get_Count_Proxy (ICaoCommands __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoCommands_get_Count_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommands_Add_Proxy (ICaoCommands __RPC_FAR *This, BSTR bstrName, BSTR bstrOption, ICaoCommand __RPC_FAR *__RPC_FAR *ppICaoCommand)
void __RPC_STUB | ICaoCommands_Add_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommands_Remove_Proxy (ICaoCommands __RPC_FAR *This, VARIANT Index)
void __RPC_STUB | ICaoCommands_Remove_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommands_Clear_Proxy (ICaoCommands __RPC_FAR *This)
void __RPC_STUB | ICaoCommands_Clear_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommands_IsMember_Proxy (ICaoCommands __RPC_FAR *This, VARIANT Index, VARIANT_BOOL __RPC_FAR *pVal)
void __RPC_STUB | ICaoCommands_IsMember_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | get_Parameters (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Parameters (VARIANT newVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Result (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_State (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Timeout (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | put_Timeout (long newVal)=0
virtual HRESULT STDMETHODCALLTYPE | Cancel (void)=0
virtual HRESULT STDMETHODCALLTYPE | Execute (long lMode=0)=0
HRESULT STDMETHODCALLTYPE | ICaoCommand__PutIndex_Proxy (ICaoCommand __RPC_FAR *This, long newVal)
void __RPC_STUB | ICaoCommand__PutIndex_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommand_get_Attribute_Proxy (ICaoCommand __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoCommand_get_Attribute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommand_get_Help_Proxy (ICaoCommand __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoCommand_get_Help_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommand_get_Index_Proxy (ICaoCommand __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoCommand_get_Index_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommand_get_Name_Proxy (ICaoCommand __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoCommand_get_Name_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommand_get_Parameters_Proxy (ICaoCommand __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoCommand_get_Parameters_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommand_put_Parameters_Proxy (ICaoCommand __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoCommand_put_Parameters_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommand_get_Result_Proxy (ICaoCommand __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoCommand_get_Result_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommand_get_State_Proxy (ICaoCommand __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoCommand_get_State_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommand_get_Tag_Proxy (ICaoCommand __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoCommand_get_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommand_put_Tag_Proxy (ICaoCommand __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoCommand_put_Tag_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommand_get_Timeout_Proxy (ICaoCommand __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoCommand_get_Timeout_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommand_put_Timeout_Proxy (ICaoCommand __RPC_FAR *This, long newVal)
void __RPC_STUB | ICaoCommand_put_Timeout_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommand_get_ID_Proxy (ICaoCommand __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoCommand_get_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommand_put_ID_Proxy (ICaoCommand __RPC_FAR *This, VARIANT newVal)
void __RPC_STUB | ICaoCommand_put_ID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommand_Cancel_Proxy (ICaoCommand __RPC_FAR *This)
void __RPC_STUB | ICaoCommand_Cancel_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoCommand_Execute_Proxy (ICaoCommand __RPC_FAR *This, long lMode)
void __RPC_STUB | ICaoCommand_Execute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | get_Description (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Destination (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Number (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_SerialNumber (long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Source (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Value (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | Reply (VARIANT vntData)=0
HRESULT STDMETHODCALLTYPE | ICaoMessage_get_DateTime_Proxy (ICaoMessage __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoMessage_get_DateTime_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoMessage_get_Description_Proxy (ICaoMessage __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoMessage_get_Description_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoMessage_get_Destination_Proxy (ICaoMessage __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoMessage_get_Destination_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoMessage_get_Number_Proxy (ICaoMessage __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoMessage_get_Number_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoMessage_get_SerialNumber_Proxy (ICaoMessage __RPC_FAR *This, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoMessage_get_SerialNumber_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoMessage_get_Source_Proxy (ICaoMessage __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoMessage_get_Source_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoMessage_get_Value_Proxy (ICaoMessage __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoMessage_get_Value_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoMessage_Clear_Proxy (ICaoMessage __RPC_FAR *This)
void __RPC_STUB | ICaoMessage_Clear_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoMessage_Reply_Proxy (ICaoMessage __RPC_FAR *This, VARIANT vntData)
void __RPC_STUB | ICaoMessage_Reply_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | get_ComputerName (BSTR __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_ObjectCounts (VARIANT vntName, long __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_StartDateTime (VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Values (VARIANT vntName, VARIANT __RPC_FAR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_Version (BSTR __RPC_FAR *pVal)=0
HRESULT STDMETHODCALLTYPE | ICaoEngineStatus_get_CurrentDateTime_Proxy (ICaoEngineStatus __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoEngineStatus_get_CurrentDateTime_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoEngineStatus_get_ComputerName_Proxy (ICaoEngineStatus __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoEngineStatus_get_ComputerName_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoEngineStatus_get_ObjectCounts_Proxy (ICaoEngineStatus __RPC_FAR *This, VARIANT vntName, long __RPC_FAR *pVal)
void __RPC_STUB | ICaoEngineStatus_get_ObjectCounts_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoEngineStatus_get_StartDateTime_Proxy (ICaoEngineStatus __RPC_FAR *This, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoEngineStatus_get_StartDateTime_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoEngineStatus_get_Values_Proxy (ICaoEngineStatus __RPC_FAR *This, VARIANT vntName, VARIANT __RPC_FAR *pVal)
void __RPC_STUB | ICaoEngineStatus_get_Values_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | ICaoEngineStatus_get_Version_Proxy (ICaoEngineStatus __RPC_FAR *This, BSTR __RPC_FAR *pVal)
void __RPC_STUB | ICaoEngineStatus_get_Version_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IEventSink_OnMessage_Proxy (IEventSink __RPC_FAR *This, IUnknown __RPC_FAR *pVal, long lOption)
void __RPC_STUB | IEventSink_OnMessage_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
class | DECLSPEC_UUID ("60555f1b-e473-4250-bb43-933990fbeced") CaoEngine
class | DECLSPEC_UUID ("f7430785-4ec2-4193-8552-f5cb2d6be732") CaoWorkspaces
class | DECLSPEC_UUID ("22fc99b8-9c3a-48c9-9f4d-8eee16ed365a") CaoWorkspace
class | DECLSPEC_UUID ("41c404be-bfd1-40ce-8454-2f47e04a09b1") CaoControllers
class | DECLSPEC_UUID ("d1baa44e-9ca9-4075-8ad1-481aa21434a8") CaoController
class | DECLSPEC_UUID ("0AF9CEC7-4F11-4EA4-8033-142CF4E45512") CaoExtensions
class | DECLSPEC_UUID ("FE266A3E-9435-4F25-85E2-B4350A378B81") CaoExtension
class | DECLSPEC_UUID ("2d662501-91ce-49e0-bafa-453a2d610b50") CaoFiles
class | DECLSPEC_UUID ("b7466915-2234-4382-b9e7-da74a34acaff") CaoFile
class | DECLSPEC_UUID ("f6981128-7e0f-4159-86b0-7397eb1596a3") CaoRobots
class | DECLSPEC_UUID ("c486acdd-451e-4fb5-a20b-3cc747f8cc2e") CaoRobot
class | DECLSPEC_UUID ("eb5211bb-dd98-4e91-b84f-a619f636de30") CaoTasks
class | DECLSPEC_UUID ("1ab45162-d81d-475c-a73f-3f9bbc0f0768") CaoTask
class | DECLSPEC_UUID ("5691304f-610a-4645-8d58-64138e059824") CaoVariables
class | DECLSPEC_UUID ("2c9b6656-32d1-425c-ad61-536c5a07c773") CaoVariable
class | DECLSPEC_UUID ("887FFEAF-3E41-4d54-A558-DE75E7E11B44") CaoCommands
class | DECLSPEC_UUID ("9289DBE4-ADEC-4001-9CF0-C58C756B2E79") CaoCommand
class | DECLSPEC_UUID ("4f2f3700-71c8-452a-81ac-5a8539b8a5c6") CaoMessage
class | DECLSPEC_UUID ("f5e9b29c-e1d6-4f78-ac18-a85ae49dbbb2") CaoEngineStatus
class | DECLSPEC_UUID ("12654e13-f7bc-4f1a-831d-a7a93e733cb7") EventSink
unsigned long __RPC_USER | BSTR_UserSize (unsigned long __RPC_FAR *, unsigned long, BSTR __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | BSTR_UserMarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | BSTR_UserUnmarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR *)
void __RPC_USER | BSTR_UserFree (unsigned long __RPC_FAR *, BSTR __RPC_FAR *)
unsigned long __RPC_USER | VARIANT_UserSize (unsigned long __RPC_FAR *, unsigned long, VARIANT __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | VARIANT_UserMarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, VARIANT __RPC_FAR *)
unsigned char __RPC_FAR *__RPC_USER | VARIANT_UserUnmarshal (unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, VARIANT __RPC_FAR *)
void __RPC_USER | VARIANT_UserFree (unsigned long __RPC_FAR *, VARIANT __RPC_FAR *)

変数

RPC_IF_HANDLE | __MIDL_itf_CAO_0000_v0_0_c_ifspec
RPC_IF_HANDLE | __MIDL_itf_CAO_0000_v0_0_s_ifspec
EXTERN_C const IID | IID_ICaoEngine
ICaoEngine __pad0__
EXTERN_C const IID | IID_ICaoWorkspaces
ICaoWorkspaces __pad1__
EXTERN_C const IID | IID_ICaoWorkspace
ICaoWorkspace __pad2__
EXTERN_C const IID | IID_ICaoControllers
ICaoControllers __pad3__
EXTERN_C const IID | IID_ICaoController
ICaoController __pad4__
EXTERN_C const IID | IID_ICaoExtensions
ICaoExtensions __pad5__
EXTERN_C const IID | IID_ICaoExtension
ICaoExtension __pad6__
EXTERN_C const IID | IID_ICaoFiles
ICaoFiles __pad7__
EXTERN_C const IID | IID_ICaoFile
ICaoFile __pad8__
EXTERN_C const IID | IID_ICaoRobots
ICaoRobots __pad9__
EXTERN_C const IID | IID_ICaoRobot
ICaoRobot __pad10__
EXTERN_C const IID | IID_ICaoTasks
ICaoTasks __pad11__
EXTERN_C const IID | IID_ICaoTask
ICaoTask __pad12__
EXTERN_C const IID | IID_ICaoVariables
ICaoVariables __pad13__
EXTERN_C const IID | IID_ICaoVariable
ICaoVariable __pad14__
EXTERN_C const IID | IID_ICaoCommands
ICaoCommands __pad15__
EXTERN_C const IID | IID_ICaoCommand
ICaoCommand __pad16__
EXTERN_C const IID | IID_ICaoMessage
ICaoMessage __pad17__
EXTERN_C const IID | IID_ICaoEngineStatus
ICaoEngineStatus __pad18__
EXTERN_C const IID | IID_IEventSink
IEventSink __pad19__
IEventSink long | lOption = 0) = 0
EXTERN_C const IID | LIBID_CAOLib
EXTERN_C const IID | DIID__ICaoControllerEvents
_ICaoControllerEvents __pad20__
EXTERN_C const IID | DIID__ICaoCommandsEvents
_ICaoCommandsEvents __pad21__
EXTERN_C const CLSID | CLSID_CaoEngine
EXTERN_C const CLSID | CLSID_CaoWorkspaces
EXTERN_C const CLSID | CLSID_CaoWorkspace
EXTERN_C const CLSID | CLSID_CaoControllers
EXTERN_C const CLSID | CLSID_CaoController
EXTERN_C const CLSID | CLSID_CaoExtensions
EXTERN_C const CLSID | CLSID_CaoExtension
EXTERN_C const CLSID | CLSID_CaoFiles
EXTERN_C const CLSID | CLSID_CaoFile
EXTERN_C const CLSID | CLSID_CaoRobots
EXTERN_C const CLSID | CLSID_CaoRobot
EXTERN_C const CLSID | CLSID_CaoTasks
EXTERN_C const CLSID | CLSID_CaoTask
EXTERN_C const CLSID | CLSID_CaoVariables
EXTERN_C const CLSID | CLSID_CaoVariable
EXTERN_C const CLSID | CLSID_CaoCommands
EXTERN_C const CLSID | CLSID_CaoCommand
EXTERN_C const CLSID | CLSID_CaoMessage
EXTERN_C const CLSID | CLSID_CaoEngineStatus
EXTERN_C const CLSID | CLSID_EventSink

マクロ定義の解説

#define __REQUIRED_RPCNDR_H_VERSION__ 440

Typedef の解説

typedef interface _ICaoCommandsEvents _ICaoCommandsEvents

typedef interface _ICaoControllerEvents _ICaoControllerEvents

typedef class CaoCommand CaoCommand

typedef class CaoCommands CaoCommands

typedef class CaoController CaoController

typedef class CaoControllers CaoControllers

typedef class CaoEngine CaoEngine

typedef class CaoEngineStatus CaoEngineStatus

typedef class CaoExtension CaoExtension

typedef class CaoExtensions CaoExtensions

typedef class CaoFile CaoFile

typedef class CaoFiles CaoFiles

typedef class CaoMessage CaoMessage

typedef class CaoRobot CaoRobot

typedef class CaoRobots CaoRobots

typedef class CaoTask CaoTask

typedef class CaoTasks CaoTasks

typedef class CaoVariable CaoVariable

typedef class CaoVariables CaoVariables

typedef class CaoWorkspace CaoWorkspace

typedef class CaoWorkspaces CaoWorkspaces

typedef class EventSink EventSink

typedef interface ICaoCommand ICaoCommand

typedef interface ICaoCommands ICaoCommands

typedef interface ICaoController ICaoController

typedef interface ICaoControllers ICaoControllers

typedef interface ICaoEngine ICaoEngine

typedef interface ICaoEngineStatus ICaoEngineStatus

typedef interface ICaoExtension ICaoExtension

typedef interface ICaoExtensions ICaoExtensions

typedef interface ICaoFile ICaoFile

typedef interface ICaoFiles ICaoFiles

typedef interface ICaoMessage ICaoMessage

typedef interface ICaoRobot ICaoRobot

typedef interface ICaoRobots ICaoRobots

typedef interface ICaoTask ICaoTask

typedef interface ICaoTasks ICaoTasks

typedef interface ICaoVariable ICaoVariable

typedef interface ICaoVariables ICaoVariables

typedef interface ICaoWorkspace ICaoWorkspace

typedef interface ICaoWorkspaces ICaoWorkspaces

typedef interface IEventSink IEventSink

関数の解説

HRESULT STDMETHODCALLTYPE _PutIndex ( long newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Accelerate | ( | long | lAxis,
 |  | float | fAccel,
 |  | float | fDecel = 0
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Add | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoCommand __RPC_FAR *__RPC_FAR * | ppICaoCommand
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Add | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoVariable __RPC_FAR *__RPC_FAR * | ppICaoVar
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Add | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoTask __RPC_FAR *__RPC_FAR * | ppICaoTask
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Add | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoRobot __RPC_FAR *__RPC_FAR * | ppICaoRobot
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Add | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoFile __RPC_FAR *__RPC_FAR * | ppICaoFile
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Add | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoExtension __RPC_FAR *__RPC_FAR * | ppICaoExtension
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Add | ( | BSTR | bstrController,
 |  | BSTR | bstrProvider,
 |  | BSTR | bstrMachine,
 |  | BSTR | bstrOption,
 |  | ICaoController __RPC_FAR *__RPC_FAR * | ppICaoCtrl
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Add | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoWorkspace __RPC_FAR *__RPC_FAR * | ppICaoWS
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE AddCommand | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoCommand __RPC_FAR *__RPC_FAR * | ppICaoCommand
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE AddController | ( | BSTR | bstrController,
 |  | BSTR | bstrProvider,
 |  | BSTR | bstrMachine,
 |  | BSTR | bstrOption,
 |  | ICaoController __RPC_FAR *__RPC_FAR * | ppICaoCtrl
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE AddExtension | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoExtension __RPC_FAR *__RPC_FAR * | ppICaoExtension
 | ) | [pure virtual]

HRESULT STDMETHODCALLTYPE AddFile | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoFile __RPC_FAR *__RPC_FAR * | ppICaoFile
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE AddRobot | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoRobot __RPC_FAR *__RPC_FAR * | ppICaoRobot
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE AddTask | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoTask __RPC_FAR *__RPC_FAR * | ppICaoTask
 | ) | [pure virtual]

HRESULT STDMETHODCALLTYPE AddVariable | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoVariable __RPC_FAR *__RPC_FAR * | ppICaoVar
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE AddWorkspace | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoWorkspace __RPC_FAR *__RPC_FAR * | ppICaoWS
 | ) | [pure virtual]

void __RPC_USER BSTR_UserFree | ( | unsigned long __RPC_FAR * | ,
 |  | BSTR __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER BSTR_UserMarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | BSTR __RPC_FAR * |
 | ) |

unsigned long __RPC_USER BSTR_UserSize | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned | long,
 |  | BSTR __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER BSTR_UserUnmarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | BSTR __RPC_FAR * |
 | ) |

virtual HRESULT STDMETHODCALLTYPE Cancel ( void ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Change ( BSTR bstrName ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Chuck ( BSTR bstrOption = L"" ) [pure virtual]

HRESULT STDMETHODCALLTYPE Clear ( void ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Copy | ( | BSTR | bstrName,
 |  | BSTR | bstrOption = L""
 | ) | [pure virtual]

class DECLSPEC_UUID ( "12654e13-f7bc-4f1a-831d-a7a93e733cb7" )

class DECLSPEC_UUID ( "f5e9b29c-e1d6-4f78-ac18-a85ae49dbbb2" )

class DECLSPEC_UUID ( "4f2f3700-71c8-452a-81ac-5a8539b8a5c6" )

class DECLSPEC_UUID ( "9289DBE4-ADEC-4001-9CF0-C58C756B2E79" )

class DECLSPEC_UUID ( "887FFEAF-3E41-4d54-A558-DE75E7E11B44" )

class DECLSPEC_UUID ( "2c9b6656-32d1-425c-ad61-536c5a07c773" )

class DECLSPEC_UUID ( "5691304f-610a-4645-8d58-64138e059824" )

class DECLSPEC_UUID ( "1ab45162-d81d-475c-a73f-3f9bbc0f0768" )

class DECLSPEC_UUID ( "eb5211bb-dd98-4e91-b84f-a619f636de30" )

class DECLSPEC_UUID ( "c486acdd-451e-4fb5-a20b-3cc747f8cc2e" )

class DECLSPEC_UUID ( "f6981128-7e0f-4159-86b0-7397eb1596a3" )

class DECLSPEC_UUID ( "b7466915-2234-4382-b9e7-da74a34acaff" )

class DECLSPEC_UUID ( "2d662501-91ce-49e0-bafa-453a2d610b50" )

class DECLSPEC_UUID ( "FE266A3E-9435-4F25-85E2-B4350A378B81" )

class DECLSPEC_UUID ( "0AF9CEC7-4F11-4EA4-8033-142CF4E45512" )

class DECLSPEC_UUID ( "d1baa44e-9ca9-4075-8ad1-481aa21434a8" )

class DECLSPEC_UUID ( "41c404be-bfd1-40ce-8454-2f47e04a09b1" )

class DECLSPEC_UUID ( "22fc99b8-9c3a-48c9-9f4d-8eee16ed365a" )

class DECLSPEC_UUID ( "f7430785-4ec2-4193-8552-f5cb2d6be732" )

class DECLSPEC_UUID ( "60555f1b-e473-4250-bb43-933990fbeced" )

HRESULT STDMETHODCALLTYPE Delete ( BSTR bstrOption = L"" ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Drive | ( | long | lNo,
 |  | float | fMov,
 |  | BSTR | bstrOpt = L""
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Execute ( long lMode = 0 ) [pure virtual]

HRESULT STDMETHODCALLTYPE Execute | ( | VARIANT | vntCommand,
 |  | VARIANT __RPC_FAR * | pVal
 | ) | [pure virtual]

HRESULT STDMETHODCALLTYPE get_Attribute ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_CommandNames | ( | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Commands ( ICaoCommands __RPC_FAR *__RPC_FAR * ppICaoCommands ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_ComputerName ( BSTR __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Controllers ( ICaoControllers __RPC_FAR *__RPC_FAR * ppICaoCtrls ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_Count ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_DateCreated ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_DateLastAccessed ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_DateLastModified ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_DateTime ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Description ( BSTR __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Destination ( BSTR __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_ExtensionNames | ( | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Extensions ( ICaoExtensions __RPC_FAR *__RPC_FAR * ppICaoExtensions ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_FileName ( BSTR __RPC_FAR * pVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_FileNames | ( | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) | [pure virtual]

HRESULT STDMETHODCALLTYPE get_Files ( ICaoFiles __RPC_FAR *__RPC_FAR * ppICaoFiles ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_Help ( BSTR __RPC_FAR * pVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_ID ( VARIANT __RPC_FAR * pVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_Index ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Microsecond ( long __RPC_FAR * pVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_Name ( BSTR __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Number ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_ObjectCounts | ( | VARIANT | vntName,
 |  | long __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Parameters ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Path ( BSTR __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_ProviderNames | ( | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Result ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_RobotNames | ( | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Robots ( ICaoRobots __RPC_FAR *__RPC_FAR * ppICaoRobots ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_SerialNumber ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Size ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Source ( BSTR __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_StartDateTime ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_State ( long __RPC_FAR * pVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE get_Tag ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_TaskNames | ( | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Tasks ( ICaoTasks __RPC_FAR *__RPC_FAR * ppICaoTasks ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Timeout ( long __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Type ( BSTR __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Value ( VARIANT __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Values | ( | VARIANT | vntName,
 |  | VARIANT __RPC_FAR * | pVal
 | ) | [pure virtual]

HRESULT STDMETHODCALLTYPE get_VariableNames | ( | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) | [pure virtual]

HRESULT STDMETHODCALLTYPE get_Variables ( ICaoVariables __RPC_FAR *__RPC_FAR * ppICaoVariables ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Version ( BSTR __RPC_FAR * pVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE get_Workspaces ( ICaoWorkspaces __RPC_FAR *__RPC_FAR * ppICaoWSs ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE GetMessage ( ICaoMessage __RPC_FAR *__RPC_FAR * ppICaoMessage ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE GoHome ( void ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Halt ( BSTR bstrOption = L"" ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Hold ( BSTR bstrOption = L"" ) [pure virtual]

HRESULT STDMETHODCALLTYPE ICaoCommand__PutIndex_Proxy | ( | ICaoCommand __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICaoCommand__PutIndex_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommand_Cancel_Proxy ( ICaoCommand __RPC_FAR * This )

void __RPC_STUB ICaoCommand_Cancel_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommand_Execute_Proxy | ( | ICaoCommand __RPC_FAR * | This,
 |  | long | lMode
 | ) |

void __RPC_STUB ICaoCommand_Execute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommand_get_Attribute_Proxy | ( | ICaoCommand __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoCommand_get_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommand_get_Help_Proxy | ( | ICaoCommand __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoCommand_get_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommand_get_ID_Proxy | ( | ICaoCommand __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoCommand_get_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommand_get_Index_Proxy | ( | ICaoCommand __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoCommand_get_Index_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommand_get_Name_Proxy | ( | ICaoCommand __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoCommand_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommand_get_Parameters_Proxy | ( | ICaoCommand __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoCommand_get_Parameters_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommand_get_Result_Proxy | ( | ICaoCommand __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoCommand_get_Result_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommand_get_State_Proxy | ( | ICaoCommand __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoCommand_get_State_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommand_get_Tag_Proxy | ( | ICaoCommand __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoCommand_get_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommand_get_Timeout_Proxy | ( | ICaoCommand __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoCommand_get_Timeout_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommand_put_ID_Proxy | ( | ICaoCommand __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoCommand_put_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommand_put_Parameters_Proxy | ( | ICaoCommand __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoCommand_put_Parameters_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommand_put_Tag_Proxy | ( | ICaoCommand __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoCommand_put_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommand_put_Timeout_Proxy | ( | ICaoCommand __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICaoCommand_put_Timeout_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommands_Add_Proxy | ( | ICaoCommands __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoCommand __RPC_FAR *__RPC_FAR * | ppICaoCommand
 | ) |

void __RPC_STUB ICaoCommands_Add_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommands_Clear_Proxy ( ICaoCommands __RPC_FAR * This )

void __RPC_STUB ICaoCommands_Clear_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommands_get__NewEnum_Proxy | ( | ICaoCommands __RPC_FAR * | This,
 |  | LPUNKNOWN __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoCommands_get__NewEnum_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommands_get_Count_Proxy | ( | ICaoCommands __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoCommands_get_Count_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommands_IsMember_Proxy | ( | ICaoCommands __RPC_FAR * | This,
 |  | VARIANT | Index,
 |  | VARIANT_BOOL __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoCommands_IsMember_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommands_Item_Proxy | ( | ICaoCommands __RPC_FAR * | This,
 |  | VARIANT | Index,
 |  | ICaoCommand __RPC_FAR *__RPC_FAR * | ppICaoCommand
 | ) |

void __RPC_STUB ICaoCommands_Item_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoCommands_Remove_Proxy | ( | ICaoCommands __RPC_FAR * | This,
 |  | VARIANT | Index
 | ) |

void __RPC_STUB ICaoCommands_Remove_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController__PutIndex_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICaoController__PutIndex_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_AddCommand_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoCommand __RPC_FAR *__RPC_FAR * | ppICaoCommand
 | ) |

void __RPC_STUB ICaoController_AddCommand_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_AddExtension_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoExtension __RPC_FAR *__RPC_FAR * | ppICaoExtension
 | ) |

void __RPC_STUB ICaoController_AddExtension_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_AddFile_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoFile __RPC_FAR *__RPC_FAR * | ppICaoFile
 | ) |

void __RPC_STUB ICaoController_AddFile_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_AddRobot_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoRobot __RPC_FAR *__RPC_FAR * | ppICaoRobot
 | ) |

void __RPC_STUB ICaoController_AddRobot_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_AddTask_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoTask __RPC_FAR *__RPC_FAR * | ppICaoTask
 | ) |

void __RPC_STUB ICaoController_AddTask_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_AddVariable_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoVariable __RPC_FAR *__RPC_FAR * | ppICaoVar
 | ) |

void __RPC_STUB ICaoController_AddVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_Execute_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | VARIANT | vntCommand,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoController_Execute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_Attribute_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoController_get_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_CommandNames_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoController_get_CommandNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_Commands_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | ICaoCommands __RPC_FAR *__RPC_FAR * | ppICaoCommands
 | ) |

void __RPC_STUB ICaoController_get_Commands_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_ExtensionNames_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoController_get_ExtensionNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_Extensions_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | ICaoExtensions __RPC_FAR *__RPC_FAR * | ppICaoExtensions
 | ) |

void __RPC_STUB ICaoController_get_Extensions_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_FileNames_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoController_get_FileNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_Files_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | ICaoFiles __RPC_FAR *__RPC_FAR * | ppICaoFiles
 | ) |

void __RPC_STUB ICaoController_get_Files_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_Help_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoController_get_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_ID_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoController_get_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_Index_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoController_get_Index_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_Name_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoController_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_RobotNames_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoController_get_RobotNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_Robots_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | ICaoRobots __RPC_FAR *__RPC_FAR * | ppICaoRobots
 | ) |

void __RPC_STUB ICaoController_get_Robots_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_Tag_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoController_get_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_TaskNames_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoController_get_TaskNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_Tasks_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | ICaoTasks __RPC_FAR *__RPC_FAR * | ppICaoTasks
 | ) |

void __RPC_STUB ICaoController_get_Tasks_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_VariableNames_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoController_get_VariableNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_get_Variables_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | ICaoVariables __RPC_FAR *__RPC_FAR * | ppICaoVariables
 | ) |

void __RPC_STUB ICaoController_get_Variables_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_GetMessage_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | ICaoMessage __RPC_FAR *__RPC_FAR * | ppICaoMessage
 | ) |

void __RPC_STUB ICaoController_GetMessage_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_put_ID_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoController_put_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoController_put_Tag_Proxy | ( | ICaoController __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoController_put_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoControllers_Add_Proxy | ( | ICaoControllers __RPC_FAR * | This,
 |  | BSTR | bstrController,
 |  | BSTR | bstrProvider,
 |  | BSTR | bstrMachine,
 |  | BSTR | bstrOption,
 |  | ICaoController __RPC_FAR *__RPC_FAR * | ppICaoCtrl
 | ) |

void __RPC_STUB ICaoControllers_Add_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoControllers_Clear_Proxy ( ICaoControllers __RPC_FAR * This )

void __RPC_STUB ICaoControllers_Clear_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoControllers_get__NewEnum_Proxy | ( | ICaoControllers __RPC_FAR * | This,
 |  | LPUNKNOWN __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoControllers_get__NewEnum_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoControllers_get_Count_Proxy | ( | ICaoControllers __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoControllers_get_Count_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoControllers_IsMember_Proxy | ( | ICaoControllers __RPC_FAR * | This,
 |  | VARIANT | Index,
 |  | VARIANT_BOOL __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoControllers_IsMember_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoControllers_Item_Proxy | ( | ICaoControllers __RPC_FAR * | This,
 |  | VARIANT | Index,
 |  | ICaoController __RPC_FAR *__RPC_FAR * | ppICaoCtrl
 | ) |

void __RPC_STUB ICaoControllers_Item_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoControllers_Remove_Proxy | ( | ICaoControllers __RPC_FAR * | This,
 |  | VARIANT | Index
 | ) |

void __RPC_STUB ICaoControllers_Remove_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoEngine_AddWorkspace_Proxy | ( | ICaoEngine __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoWorkspace __RPC_FAR *__RPC_FAR * | ppICaoWS
 | ) |

void __RPC_STUB ICaoEngine_AddWorkspace_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoEngine_Execute_Proxy | ( | ICaoEngine __RPC_FAR * | This,
 |  | VARIANT | vntCommand,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoEngine_Execute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoEngine_get_EngineStatus_Proxy | ( | ICaoEngine __RPC_FAR * | This,
 |  | ICaoEngineStatus __RPC_FAR *__RPC_FAR * | ppICaoEngineStatus
 | ) |

void __RPC_STUB ICaoEngine_get_EngineStatus_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoEngine_get_Workspaces_Proxy | ( | ICaoEngine __RPC_FAR * | This,
 |  | ICaoWorkspaces __RPC_FAR *__RPC_FAR * | ppICaoWSs
 | ) |

void __RPC_STUB ICaoEngine_get_Workspaces_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoEngineStatus_get_ComputerName_Proxy | ( | ICaoEngineStatus __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoEngineStatus_get_ComputerName_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoEngineStatus_get_CurrentDateTime_Proxy | ( | ICaoEngineStatus __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoEngineStatus_get_CurrentDateTime_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoEngineStatus_get_ObjectCounts_Proxy | ( | ICaoEngineStatus __RPC_FAR * | This,
 |  | VARIANT | vntName,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoEngineStatus_get_ObjectCounts_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoEngineStatus_get_StartDateTime_Proxy | ( | ICaoEngineStatus __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoEngineStatus_get_StartDateTime_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoEngineStatus_get_Values_Proxy | ( | ICaoEngineStatus __RPC_FAR * | This,
 |  | VARIANT | vntName,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoEngineStatus_get_Values_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoEngineStatus_get_Version_Proxy | ( | ICaoEngineStatus __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoEngineStatus_get_Version_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtension__PutIndex_Proxy | ( | ICaoExtension __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICaoExtension__PutIndex_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtension_AddVariable_Proxy | ( | ICaoExtension __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoVariable __RPC_FAR *__RPC_FAR * | ppICaoVar
 | ) |

void __RPC_STUB ICaoExtension_AddVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtension_Execute_Proxy | ( | ICaoExtension __RPC_FAR * | This,
 |  | VARIANT | vntCommand,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoExtension_Execute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtension_get_Attribute_Proxy | ( | ICaoExtension __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoExtension_get_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtension_get_Help_Proxy | ( | ICaoExtension __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoExtension_get_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtension_get_ID_Proxy | ( | ICaoExtension __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoExtension_get_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtension_get_Index_Proxy | ( | ICaoExtension __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoExtension_get_Index_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtension_get_Name_Proxy | ( | ICaoExtension __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoExtension_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtension_get_Tag_Proxy | ( | ICaoExtension __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoExtension_get_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtension_get_VariableNames_Proxy | ( | ICaoExtension __RPC_FAR * | This,
 |  | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoExtension_get_VariableNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtension_get_Variables_Proxy | ( | ICaoExtension __RPC_FAR * | This,
 |  | ICaoVariables __RPC_FAR *__RPC_FAR * | ppICaoVariables
 | ) |

void __RPC_STUB ICaoExtension_get_Variables_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtension_put_ID_Proxy | ( | ICaoExtension __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoExtension_put_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtension_put_Tag_Proxy | ( | ICaoExtension __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoExtension_put_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtensions_Add_Proxy | ( | ICaoExtensions __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoExtension __RPC_FAR *__RPC_FAR * | ppICaoExtension
 | ) |

void __RPC_STUB ICaoExtensions_Add_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtensions_Clear_Proxy ( ICaoExtensions __RPC_FAR * This )

void __RPC_STUB ICaoExtensions_Clear_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtensions_get__NewEnum_Proxy | ( | ICaoExtensions __RPC_FAR * | This,
 |  | LPUNKNOWN __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoExtensions_get__NewEnum_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtensions_get_Count_Proxy | ( | ICaoExtensions __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoExtensions_get_Count_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtensions_IsMember_Proxy | ( | ICaoExtensions __RPC_FAR * | This,
 |  | VARIANT | Index,
 |  | VARIANT_BOOL __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoExtensions_IsMember_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtensions_Item_Proxy | ( | ICaoExtensions __RPC_FAR * | This,
 |  | VARIANT | Index,
 |  | ICaoExtension __RPC_FAR *__RPC_FAR * | ppICaoExtension
 | ) |

void __RPC_STUB ICaoExtensions_Item_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoExtensions_Remove_Proxy | ( | ICaoExtensions __RPC_FAR * | This,
 |  | VARIANT | Index
 | ) |

void __RPC_STUB ICaoExtensions_Remove_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile__PutIndex_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICaoFile__PutIndex_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_AddFile_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoFile __RPC_FAR *__RPC_FAR * | ppICaoFile
 | ) |

void __RPC_STUB ICaoFile_AddFile_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_AddVariable_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoVariable __RPC_FAR *__RPC_FAR * | ppICaoVar
 | ) |

void __RPC_STUB ICaoFile_AddVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_Copy_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption
 | ) |

void __RPC_STUB ICaoFile_Copy_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_Delete_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | BSTR | bstrOption
 | ) |

void __RPC_STUB ICaoFile_Delete_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_Execute_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | VARIANT | vntCommand,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFile_Execute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_Attribute_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFile_get_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_DateCreated_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFile_get_DateCreated_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_DateLastAccessed_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFile_get_DateLastAccessed_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_DateLastModified_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFile_get_DateLastModified_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_FileNames_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFile_get_FileNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_Files_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | ICaoFiles __RPC_FAR *__RPC_FAR * | ppICaoFiles
 | ) |

void __RPC_STUB ICaoFile_get_Files_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_Help_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFile_get_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_ID_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFile_get_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_Index_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFile_get_Index_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_Name_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFile_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_Path_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFile_get_Path_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_Size_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFile_get_Size_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_Tag_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFile_get_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_Type_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFile_get_Type_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_Value_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFile_get_Value_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_VariableNames_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFile_get_VariableNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_get_Variables_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | ICaoVariables __RPC_FAR *__RPC_FAR * | ppICaoVariables
 | ) |

void __RPC_STUB ICaoFile_get_Variables_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_Move_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption
 | ) |

void __RPC_STUB ICaoFile_Move_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_put_ID_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoFile_put_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_put_Tag_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoFile_put_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_put_Value_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoFile_put_Value_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFile_Run_Proxy | ( | ICaoFile __RPC_FAR * | This,
 |  | BSTR | bstrOption,
 |  | BSTR __RPC_FAR * | bstrName
 | ) |

void __RPC_STUB ICaoFile_Run_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFiles_Add_Proxy | ( | ICaoFiles __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoFile __RPC_FAR *__RPC_FAR * | ppICaoFile
 | ) |

void __RPC_STUB ICaoFiles_Add_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFiles_Clear_Proxy ( ICaoFiles __RPC_FAR * This )

void __RPC_STUB ICaoFiles_Clear_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFiles_get__NewEnum_Proxy | ( | ICaoFiles __RPC_FAR * | This,
 |  | LPUNKNOWN __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFiles_get__NewEnum_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFiles_get_Count_Proxy | ( | ICaoFiles __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFiles_get_Count_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFiles_IsMember_Proxy | ( | ICaoFiles __RPC_FAR * | This,
 |  | VARIANT | Index,
 |  | VARIANT_BOOL __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoFiles_IsMember_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFiles_Item_Proxy | ( | ICaoFiles __RPC_FAR * | This,
 |  | VARIANT | Index,
 |  | ICaoFile __RPC_FAR *__RPC_FAR * | ppICaoFile
 | ) |

void __RPC_STUB ICaoFiles_Item_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoFiles_Remove_Proxy | ( | ICaoFiles __RPC_FAR * | This,
 |  | VARIANT | Index
 | ) |

void __RPC_STUB ICaoFiles_Remove_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoMessage_Clear_Proxy ( ICaoMessage __RPC_FAR * This )

void __RPC_STUB ICaoMessage_Clear_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoMessage_get_DateTime_Proxy | ( | ICaoMessage __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoMessage_get_DateTime_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoMessage_get_Description_Proxy | ( | ICaoMessage __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoMessage_get_Description_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoMessage_get_Destination_Proxy | ( | ICaoMessage __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoMessage_get_Destination_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoMessage_get_Number_Proxy | ( | ICaoMessage __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoMessage_get_Number_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoMessage_get_SerialNumber_Proxy | ( | ICaoMessage __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoMessage_get_SerialNumber_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoMessage_get_Source_Proxy | ( | ICaoMessage __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoMessage_get_Source_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoMessage_get_Value_Proxy | ( | ICaoMessage __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoMessage_get_Value_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoMessage_Reply_Proxy | ( | ICaoMessage __RPC_FAR * | This,
 |  | VARIANT | vntData
 | ) |

void __RPC_STUB ICaoMessage_Reply_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot__PutIndex_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICaoRobot__PutIndex_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_Accelerate_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | long | lAxis,
 |  | float | fAccel,
 |  | float | fDecel
 | ) |

void __RPC_STUB ICaoRobot_Accelerate_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_AddVariable_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoVariable __RPC_FAR *__RPC_FAR * | ppICaoVar
 | ) |

void __RPC_STUB ICaoRobot_AddVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_Change_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | BSTR | bstrName
 | ) |

void __RPC_STUB ICaoRobot_Change_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_Chuck_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | BSTR | bstrOption
 | ) |

void __RPC_STUB ICaoRobot_Chuck_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_Drive_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | long | lNo,
 |  | float | fMov,
 |  | BSTR | bstrOpt
 | ) |

void __RPC_STUB ICaoRobot_Drive_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_Execute_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | VARIANT | vntCommand,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoRobot_Execute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_get_Attribute_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoRobot_get_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_get_Help_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoRobot_get_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_get_ID_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoRobot_get_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_get_Index_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoRobot_get_Index_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_get_Name_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoRobot_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_get_Tag_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoRobot_get_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_get_VariableNames_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoRobot_get_VariableNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_get_Variables_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | ICaoVariables __RPC_FAR *__RPC_FAR * | ppICaoVariables
 | ) |

void __RPC_STUB ICaoRobot_get_Variables_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_GoHome_Proxy ( ICaoRobot __RPC_FAR * This )

void __RPC_STUB ICaoRobot_GoHome_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_Halt_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | BSTR | bstrOption
 | ) |

void __RPC_STUB ICaoRobot_Halt_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_Hold_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | BSTR | bstrOption
 | ) |

void __RPC_STUB ICaoRobot_Hold_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_Move_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | long | lComp,
 |  | VARIANT | vntPose,
 |  | BSTR | bstrOpt
 | ) |

void __RPC_STUB ICaoRobot_Move_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_put_ID_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoRobot_put_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_put_Tag_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoRobot_put_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_Rotate_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | VARIANT | vntRotSuf,
 |  | float | fDeg,
 |  | VARIANT | vntPivot,
 |  | BSTR | bstrOpt
 | ) |

void __RPC_STUB ICaoRobot_Rotate_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_Speed_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | long | lAxis,
 |  | float | fSpeed
 | ) |

void __RPC_STUB ICaoRobot_Speed_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_Unchuck_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | BSTR | bstrOption
 | ) |

void __RPC_STUB ICaoRobot_Unchuck_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobot_Unhold_Proxy | ( | ICaoRobot __RPC_FAR * | This,
 |  | BSTR | bstrOption
 | ) |

void __RPC_STUB ICaoRobot_Unhold_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobots_Add_Proxy | ( | ICaoRobots __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoRobot __RPC_FAR *__RPC_FAR * | ppICaoRobot
 | ) |

void __RPC_STUB ICaoRobots_Add_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobots_Clear_Proxy ( ICaoRobots __RPC_FAR * This )

void __RPC_STUB ICaoRobots_Clear_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobots_get__NewEnum_Proxy | ( | ICaoRobots __RPC_FAR * | This,
 |  | LPUNKNOWN __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoRobots_get__NewEnum_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobots_get_Count_Proxy | ( | ICaoRobots __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoRobots_get_Count_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobots_IsMember_Proxy | ( | ICaoRobots __RPC_FAR * | This,
 |  | VARIANT | Index,
 |  | VARIANT_BOOL __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoRobots_IsMember_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobots_Item_Proxy | ( | ICaoRobots __RPC_FAR * | This,
 |  | VARIANT | Index,
 |  | ICaoRobot __RPC_FAR *__RPC_FAR * | ppICaoRobot
 | ) |

void __RPC_STUB ICaoRobots_Item_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoRobots_Remove_Proxy | ( | ICaoRobots __RPC_FAR * | This,
 |  | VARIANT | Index
 | ) |

void __RPC_STUB ICaoRobots_Remove_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask__PutIndex_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICaoTask__PutIndex_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask_AddVariable_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoVariable __RPC_FAR *__RPC_FAR * | ppICaoVar
 | ) |

void __RPC_STUB ICaoTask_AddVariable_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask_Delete_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | BSTR | bstrOption
 | ) |

void __RPC_STUB ICaoTask_Delete_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask_Execute_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | VARIANT | vntCommand,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoTask_Execute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask_get_Attribute_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoTask_get_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask_get_FileName_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoTask_get_FileName_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask_get_Help_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoTask_get_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask_get_ID_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoTask_get_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask_get_Index_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoTask_get_Index_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask_get_Name_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoTask_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask_get_Tag_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoTask_get_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask_get_VariableNames_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoTask_get_VariableNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask_get_Variables_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | ICaoVariables __RPC_FAR *__RPC_FAR * | ppICaoVariables
 | ) |

void __RPC_STUB ICaoTask_get_Variables_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask_put_ID_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoTask_put_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask_put_Tag_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoTask_put_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask_Start_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | long | lMode,
 |  | BSTR | bstrOption
 | ) |

void __RPC_STUB ICaoTask_Start_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTask_Stop_Proxy | ( | ICaoTask __RPC_FAR * | This,
 |  | long | lMode,
 |  | BSTR | bstrOption
 | ) |

void __RPC_STUB ICaoTask_Stop_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTasks_Add_Proxy | ( | ICaoTasks __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoTask __RPC_FAR *__RPC_FAR * | ppICaoTask
 | ) |

void __RPC_STUB ICaoTasks_Add_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTasks_Clear_Proxy ( ICaoTasks __RPC_FAR * This )

void __RPC_STUB ICaoTasks_Clear_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTasks_get__NewEnum_Proxy | ( | ICaoTasks __RPC_FAR * | This,
 |  | LPUNKNOWN __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoTasks_get__NewEnum_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTasks_get_Count_Proxy | ( | ICaoTasks __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoTasks_get_Count_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTasks_IsMember_Proxy | ( | ICaoTasks __RPC_FAR * | This,
 |  | VARIANT | Index,
 |  | VARIANT_BOOL __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoTasks_IsMember_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTasks_Item_Proxy | ( | ICaoTasks __RPC_FAR * | This,
 |  | VARIANT | Index,
 |  | ICaoTask __RPC_FAR *__RPC_FAR * | ppICaoTask
 | ) |

void __RPC_STUB ICaoTasks_Item_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoTasks_Remove_Proxy | ( | ICaoTasks __RPC_FAR * | This,
 |  | VARIANT | Index
 | ) |

void __RPC_STUB ICaoTasks_Remove_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariable__PutIndex_Proxy | ( | ICaoVariable __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICaoVariable__PutIndex_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariable_get_Attribute_Proxy | ( | ICaoVariable __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoVariable_get_Attribute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariable_get_DateTime_Proxy | ( | ICaoVariable __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoVariable_get_DateTime_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariable_get_Help_Proxy | ( | ICaoVariable __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoVariable_get_Help_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariable_get_ID_Proxy | ( | ICaoVariable __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoVariable_get_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariable_get_Index_Proxy | ( | ICaoVariable __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoVariable_get_Index_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariable_get_Microsecond_Proxy | ( | ICaoVariable __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoVariable_get_Microsecond_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariable_get_Name_Proxy | ( | ICaoVariable __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoVariable_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariable_get_Tag_Proxy | ( | ICaoVariable __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoVariable_get_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariable_get_Value_Proxy | ( | ICaoVariable __RPC_FAR * | This,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoVariable_get_Value_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariable_put_ID_Proxy | ( | ICaoVariable __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoVariable_put_ID_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariable_put_Tag_Proxy | ( | ICaoVariable __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoVariable_put_Tag_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariable_put_Value_Proxy | ( | ICaoVariable __RPC_FAR * | This,
 |  | VARIANT | newVal
 | ) |

void __RPC_STUB ICaoVariable_put_Value_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariables_Add_Proxy | ( | ICaoVariables __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoVariable __RPC_FAR *__RPC_FAR * | ppICaoVar
 | ) |

void __RPC_STUB ICaoVariables_Add_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariables_Clear_Proxy ( ICaoVariables __RPC_FAR * This )

void __RPC_STUB ICaoVariables_Clear_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariables_get__NewEnum_Proxy | ( | ICaoVariables __RPC_FAR * | This,
 |  | LPUNKNOWN __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoVariables_get__NewEnum_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariables_get_Count_Proxy | ( | ICaoVariables __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoVariables_get_Count_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariables_IsMember_Proxy | ( | ICaoVariables __RPC_FAR * | This,
 |  | VARIANT | Index,
 |  | VARIANT_BOOL __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoVariables_IsMember_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariables_Item_Proxy | ( | ICaoVariables __RPC_FAR * | This,
 |  | VARIANT | Index,
 |  | ICaoVariable __RPC_FAR *__RPC_FAR * | ppICaoVar
 | ) |

void __RPC_STUB ICaoVariables_Item_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoVariables_Remove_Proxy | ( | ICaoVariables __RPC_FAR * | This,
 |  | VARIANT | Index
 | ) |

void __RPC_STUB ICaoVariables_Remove_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoWorkspace__PutIndex_Proxy | ( | ICaoWorkspace __RPC_FAR * | This,
 |  | long | newVal
 | ) |

void __RPC_STUB ICaoWorkspace__PutIndex_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoWorkspace_AddController_Proxy | ( | ICaoWorkspace __RPC_FAR * | This,
 |  | BSTR | bstrController,
 |  | BSTR | bstrProvider,
 |  | BSTR | bstrMachine,
 |  | BSTR | bstrOption,
 |  | ICaoController __RPC_FAR *__RPC_FAR * | ppICaoCtrl
 | ) |

void __RPC_STUB ICaoWorkspace_AddController_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoWorkspace_Execute_Proxy | ( | ICaoWorkspace __RPC_FAR * | This,
 |  | VARIANT | vntCommand,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoWorkspace_Execute_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoWorkspace_get_Controllers_Proxy | ( | ICaoWorkspace __RPC_FAR * | This,
 |  | ICaoControllers __RPC_FAR *__RPC_FAR * | ppICaoCtrls
 | ) |

void __RPC_STUB ICaoWorkspace_get_Controllers_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoWorkspace_get_Index_Proxy | ( | ICaoWorkspace __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoWorkspace_get_Index_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoWorkspace_get_Name_Proxy | ( | ICaoWorkspace __RPC_FAR * | This,
 |  | BSTR __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoWorkspace_get_Name_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoWorkspace_get_ProviderNames_Proxy | ( | ICaoWorkspace __RPC_FAR * | This,
 |  | BSTR | bstrOption,
 |  | VARIANT __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoWorkspace_get_ProviderNames_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoWorkspaces_Add_Proxy | ( | ICaoWorkspaces __RPC_FAR * | This,
 |  | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoWorkspace __RPC_FAR *__RPC_FAR * | ppICaoWS
 | ) |

void __RPC_STUB ICaoWorkspaces_Add_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoWorkspaces_Clear_Proxy ( ICaoWorkspaces __RPC_FAR * This )

void __RPC_STUB ICaoWorkspaces_Clear_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoWorkspaces_get__NewEnum_Proxy | ( | ICaoWorkspaces __RPC_FAR * | This,
 |  | LPUNKNOWN __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoWorkspaces_get__NewEnum_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoWorkspaces_get_Count_Proxy | ( | ICaoWorkspaces __RPC_FAR * | This,
 |  | long __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoWorkspaces_get_Count_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoWorkspaces_IsMember_Proxy | ( | ICaoWorkspaces __RPC_FAR * | This,
 |  | VARIANT | Index,
 |  | VARIANT_BOOL __RPC_FAR * | pVal
 | ) |

void __RPC_STUB ICaoWorkspaces_IsMember_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoWorkspaces_Item_Proxy | ( | ICaoWorkspaces __RPC_FAR * | This,
 |  | VARIANT | Index,
 |  | ICaoWorkspace __RPC_FAR *__RPC_FAR * | ppICaoWS
 | ) |

void __RPC_STUB ICaoWorkspaces_Item_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE ICaoWorkspaces_Remove_Proxy | ( | ICaoWorkspaces __RPC_FAR * | This,
 |  | VARIANT | Index
 | ) |

void __RPC_STUB ICaoWorkspaces_Remove_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IEventSink_OnMessage_Proxy | ( | IEventSink __RPC_FAR * | This,
 |  | IUnknown __RPC_FAR * | pVal,
 |  | long | lOption
 | ) |

void __RPC_STUB IEventSink_OnMessage_Stub | ( | IRpcStubBuffer * | This,
 |  | IRpcChannelBuffer * | _pRpcChannelBuffer,
 |  | PRPC_MESSAGE | _pRpcMessage,
 |  | DWORD * | _pdwStubPhase
 | ) |

HRESULT STDMETHODCALLTYPE IsMember | ( | VARIANT | Index,
 |  | VARIANT_BOOL __RPC_FAR * | pVal
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Item | ( | VARIANT | Index,
 |  | ICaoCommand __RPC_FAR *__RPC_FAR * | ppICaoCommand
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Item | ( | VARIANT | Index,
 |  | ICaoVariable __RPC_FAR *__RPC_FAR * | ppICaoVar
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Item | ( | VARIANT | Index,
 |  | ICaoTask __RPC_FAR *__RPC_FAR * | ppICaoTask
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Item | ( | VARIANT | Index,
 |  | ICaoRobot __RPC_FAR *__RPC_FAR * | ppICaoRobot
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Item | ( | VARIANT | Index,
 |  | ICaoFile __RPC_FAR *__RPC_FAR * | ppICaoFile
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Item | ( | VARIANT | Index,
 |  | ICaoExtension __RPC_FAR *__RPC_FAR * | ppICaoExtension
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Item | ( | VARIANT | Index,
 |  | ICaoController __RPC_FAR *__RPC_FAR * | ppICaoCtrl
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Item | ( | VARIANT | Index,
 |  | ICaoWorkspace __RPC_FAR *__RPC_FAR * | ppICaoWS
 | ) | [pure virtual]

void __RPC_FAR* __RPC_USER MIDL_user_allocate ( size_t )

void __RPC_USER MIDL_user_free ( void __RPC_FAR * )

virtual HRESULT STDMETHODCALLTYPE Move | ( | long | lComp,
 |  | VARIANT | vntPose,
 |  | BSTR | bstrOpt = L""
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Move | ( | BSTR | bstrName,
 |  | BSTR | bstrOption = L""
 | ) | [pure virtual]

HRESULT STDMETHODCALLTYPE put_ID ( VARIANT newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_Parameters ( VARIANT newVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE put_Tag ( VARIANT newVal ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE put_Timeout ( long newVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE put_Value ( VARIANT newVal ) [pure virtual]

HRESULT STDMETHODCALLTYPE Remove ( VARIANT Index ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Reply ( VARIANT vntData ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Rotate | ( | VARIANT | vntRotSuf,
 |  | float | fDeg,
 |  | VARIANT | vntPivot,
 |  | BSTR | bstrOpt = L""
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Run | ( | BSTR | bstrOption,
 |  | BSTR __RPC_FAR * | bstrName
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Speed | ( | long | lAxis,
 |  | float | fSpeed
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Start | ( | long | lMode = 0,
 |  | BSTR | bstrOption = L""
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Stop | ( | long | lMode = 0,
 |  | BSTR | bstrOption = L""
 | ) | [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Unchuck ( BSTR bstrOption = L"" ) [pure virtual]

virtual HRESULT STDMETHODCALLTYPE Unhold ( BSTR bstrOption = L"" ) [pure virtual]

void __RPC_USER VARIANT_UserFree | ( | unsigned long __RPC_FAR * | ,
 |  | VARIANT __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER VARIANT_UserMarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | VARIANT __RPC_FAR * |
 | ) |

unsigned long __RPC_USER VARIANT_UserSize | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned | long,
 |  | VARIANT __RPC_FAR * |
 | ) |

unsigned char __RPC_FAR* __RPC_USER VARIANT_UserUnmarshal | ( | unsigned long __RPC_FAR * | ,
 |  | unsigned char __RPC_FAR * | ,
 |  | VARIANT __RPC_FAR * |
 | ) |

変数の解説

RPC_IF_HANDLE __MIDL_itf_CAO_0000_v0_0_c_ifspec

RPC_IF_HANDLE __MIDL_itf_CAO_0000_v0_0_s_ifspec

ICaoEngine __pad0__

ICaoRobot __pad10__

ICaoTasks __pad11__

ICaoTask __pad12__

ICaoVariables __pad13__

ICaoVariable __pad14__

ICaoCommands __pad15__

ICaoCommand __pad16__

ICaoMessage __pad17__

ICaoEngineStatus __pad18__

IEventSink __pad19__

ICaoWorkspaces __pad1__

_ICaoControllerEvents __pad20__

_ICaoCommandsEvents __pad21__

ICaoWorkspace __pad2__

ICaoControllers __pad3__

ICaoController __pad4__

ICaoExtensions __pad5__

ICaoExtension __pad6__

ICaoFiles __pad7__

ICaoFile __pad8__

ICaoRobots __pad9__

EXTERN_C const CLSID CLSID_CaoCommand

EXTERN_C const CLSID CLSID_CaoCommands

EXTERN_C const CLSID CLSID_CaoController

EXTERN_C const CLSID CLSID_CaoControllers

EXTERN_C const CLSID CLSID_CaoEngine

EXTERN_C const CLSID CLSID_CaoEngineStatus

EXTERN_C const CLSID CLSID_CaoExtension

EXTERN_C const CLSID CLSID_CaoExtensions

EXTERN_C const CLSID CLSID_CaoFile

EXTERN_C const CLSID CLSID_CaoFiles

EXTERN_C const CLSID CLSID_CaoMessage

EXTERN_C const CLSID CLSID_CaoRobot

EXTERN_C const CLSID CLSID_CaoRobots

EXTERN_C const CLSID CLSID_CaoTask

EXTERN_C const CLSID CLSID_CaoTasks

EXTERN_C const CLSID CLSID_CaoVariable

EXTERN_C const CLSID CLSID_CaoVariables

EXTERN_C const CLSID CLSID_CaoWorkspace

EXTERN_C const CLSID CLSID_CaoWorkspaces

EXTERN_C const CLSID CLSID_EventSink

EXTERN_C const IID DIID__ICaoCommandsEvents

EXTERN_C const IID DIID__ICaoControllerEvents

EXTERN_C const IID IID_ICaoCommand

EXTERN_C const IID IID_ICaoCommands

EXTERN_C const IID IID_ICaoController

EXTERN_C const IID IID_ICaoControllers

EXTERN_C const IID IID_ICaoEngine

EXTERN_C const IID IID_ICaoEngineStatus

EXTERN_C const IID IID_ICaoExtension

EXTERN_C const IID IID_ICaoExtensions

EXTERN_C const IID IID_ICaoFile

EXTERN_C const IID IID_ICaoFiles

EXTERN_C const IID IID_ICaoMessage

EXTERN_C const IID IID_ICaoRobot

EXTERN_C const IID IID_ICaoRobots

EXTERN_C const IID IID_ICaoTask

EXTERN_C const IID IID_ICaoTasks

EXTERN_C const IID IID_ICaoVariable

EXTERN_C const IID IID_ICaoVariables

EXTERN_C const IID IID_ICaoWorkspace

EXTERN_C const IID IID_ICaoWorkspaces

EXTERN_C const IID IID_IEventSink

EXTERN_C const IID LIBID_CAOLib

IEventSink long lOption = 0) = 0

Generated on Wed Dec 7 19:01:46 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAO.h Source File

CAO.h

解説を見る。
00001 /* this ALWAYS GENERATED file contains the definitions for the interfaces */
00002
00003
00004 /* File created by MIDL compiler version 5.01.0164 */
00005 /* at Wed Dec 07 14:20:51 2005
00006  */
00007 /* Compiler settings for D:\ORiN2\CAO\Engine\Src\CAO.idl:
00008     Oicf (OptLev=i2), W1, Zp8, env=Win32, ms_ext, c_ext
00009     error checks: allocation ref bounds_check enum stub_data
00010 */
00011 //@@MIDL_FILE_HEADING(  )
00012
00013
00014 /* verify that the <rpcndr.h> version is high enough to compile this file*/
00015 #ifndef __REQUIRED_RPCNDR_H_VERSION__
00016 #define __REQUIRED_RPCNDR_H_VERSION__ 440
00017 #endif
00018
00019 #include "rpc.h"
00020 #include "rpcndr.h"
00021
00022 #ifndef __RPCNDR_H_VERSION__
00023 #error this stub requires an updated version of <rpcndr.h>
00024 #endif // __RPCNDR_H_VERSION__
00025
00026 #ifndef COM_NO_WINDOWS_H
00027 #include "windows.h"
00028 #include "ole2.h"
00029 #endif /*COM_NO_WINDOWS_H*/
00030
00031 #ifndef __CAO_h__
00032 #define __CAO_h__
00033
00034 #ifdef __cplusplus
00035 extern "C"{
00036 #endif
00037
00038 /* Forward Declarations */
00039
00040 #ifndef __ICaoEngine_FWD_DEFINED__
00041 #define __ICaoEngine_FWD_DEFINED__
00042 typedef interface ICaoEngine ICaoEngine;
00043 #endif  /* __ICaoEngine_FWD_DEFINED__ */
00044
00045
00046 #ifndef __ICaoWorkspaces_FWD_DEFINED__
00047 #define __ICaoWorkspaces_FWD_DEFINED__
00048 typedef interface ICaoWorkspaces ICaoWorkspaces;
00049 #endif  /* __ICaoWorkspaces_FWD_DEFINED__ */
00050
00051
00052 #ifndef __ICaoWorkspace_FWD_DEFINED__
00053 #define __ICaoWorkspace_FWD_DEFINED__
00054 typedef interface ICaoWorkspace ICaoWorkspace;
00055 #endif  /* __ICaoWorkspace_FWD_DEFINED__ */
00056
00057
00058 #ifndef __ICaoControllers_FWD_DEFINED__
00059 #define __ICaoControllers_FWD_DEFINED__
00060 typedef interface ICaoControllers ICaoControllers;
00061 #endif  /* __ICaoControllers_FWD_DEFINED__ */
00062
00063
00064 #ifndef __ICaoController_FWD_DEFINED__
00065 #define __ICaoController_FWD_DEFINED__
00066 typedef interface ICaoController ICaoController;
00067 #endif  /* __ICaoController_FWD_DEFINED__ */
00068
00069
00070 #ifndef __ICaoExtensions_FWD_DEFINED__
00071 #define __ICaoExtensions_FWD_DEFINED__
00072 typedef interface ICaoExtensions ICaoExtensions;
00073 #endif  /* __ICaoExtensions_FWD_DEFINED__ */
00074
00075
00076 #ifndef __ICaoExtension_FWD_DEFINED__
00077 #define __ICaoExtension_FWD_DEFINED__
00078 typedef interface ICaoExtension ICaoExtension;
00079 #endif  /* __ICaoExtension_FWD_DEFINED__ */
00080
00081
00082 #ifndef __ICaoFiles_FWD_DEFINED__
00083 #define __ICaoFiles_FWD_DEFINED__
00084 typedef interface ICaoFiles ICaoFiles;
00085 #endif  /* __ICaoFiles_FWD_DEFINED__ */
00086
00087
00088 #ifndef __ICaoFile_FWD_DEFINED__
00089 #define __ICaoFile_FWD_DEFINED__
00090 typedef interface ICaoFile ICaoFile;
00091 #endif  /* __ICaoFile_FWD_DEFINED__ */
00092
00093
00094 #ifndef __ICaoRobots_FWD_DEFINED__
00095 #define __ICaoRobots_FWD_DEFINED__
00096 typedef interface ICaoRobots ICaoRobots;
00097 #endif  /* __ICaoRobots_FWD_DEFINED__ */
00098
00099
00100 #ifndef __ICaoRobot_FWD_DEFINED__
00101 #define __ICaoRobot_FWD_DEFINED__
00102 typedef interface ICaoRobot ICaoRobot;
00103 #endif  /* __ICaoRobot_FWD_DEFINED__ */
00104
00105
00106 #ifndef __ICaoTasks_FWD_DEFINED__
00107 #define __ICaoTasks_FWD_DEFINED__
00108 typedef interface ICaoTasks ICaoTasks;
00109 #endif  /* __ICaoTasks_FWD_DEFINED__ */
00110
00111
00112 #ifndef __ICaoTask_FWD_DEFINED__
00113 #define __ICaoTask_FWD_DEFINED__
00114 typedef interface ICaoTask ICaoTask;
00115 #endif  /* __ICaoTask_FWD_DEFINED__ */
00116
00117
00118 #ifndef __ICaoVariables_FWD_DEFINED__
00119 #define __ICaoVariables_FWD_DEFINED__
00120 typedef interface ICaoVariables ICaoVariables;
00121 #endif  /* __ICaoVariables_FWD_DEFINED__ */
00122
00123
00124 #ifndef __ICaoVariable_FWD_DEFINED__
00125 #define __ICaoVariable_FWD_DEFINED__
00126 typedef interface ICaoVariable ICaoVariable;
00127 #endif  /* __ICaoVariable_FWD_DEFINED__ */
00128
00129
00130 #ifndef __ICaoCommands_FWD_DEFINED__
00131 #define __ICaoCommands_FWD_DEFINED__
00132 typedef interface ICaoCommands ICaoCommands;
00133 #endif  /* __ICaoCommands_FWD_DEFINED__ */
00134
00135
00136 #ifndef __ICaoCommand_FWD_DEFINED__
00137 #define __ICaoCommand_FWD_DEFINED__
00138 typedef interface ICaoCommand ICaoCommand;
00139 #endif  /* __ICaoCommand_FWD_DEFINED__ */
00140
00141
00142 #ifndef __ICaoMessage_FWD_DEFINED__
00143 #define __ICaoMessage_FWD_DEFINED__
00144 typedef interface ICaoMessage ICaoMessage;
00145 #endif  /* __ICaoMessage_FWD_DEFINED__ */
00146
00147
00148 #ifndef __ICaoEngineStatus_FWD_DEFINED__
00149 #define __ICaoEngineStatus_FWD_DEFINED__
00150 typedef interface ICaoEngineStatus ICaoEngineStatus;
00151 #endif  /* __ICaoEngineStatus_FWD_DEFINED__ */
00152
00153
00154 #ifndef __IEventSink_FWD_DEFINED__
00155 #define __IEventSink_FWD_DEFINED__
00156 typedef interface IEventSink IEventSink;
00157 #endif  /* __IEventSink_FWD_DEFINED__ */
00158
00159
00160 #ifndef ___ICaoControllerEvents_FWD_DEFINED__
00161 #define ___ICaoControllerEvents_FWD_DEFINED__
00162 typedef interface _ICaoControllerEvents _ICaoControllerEvents;
00163 #endif  /* ___ICaoControllerEvents_FWD_DEFINED__ */
00164
00165
00166 #ifndef ___ICaoCommandsEvents_FWD_DEFINED__
00167 #define ___ICaoCommandsEvents_FWD_DEFINED__
00168 typedef interface _ICaoCommandsEvents _ICaoCommandsEvents;
00169 #endif  /* ___ICaoCommandsEvents_FWD_DEFINED__ */
00170
00171
00172 #ifndef __CaoEngine_FWD_DEFINED__
00173 #define __CaoEngine_FWD_DEFINED__
00174
00175 #ifdef __cplusplus
00176 typedef class CaoEngine CaoEngine;
00177 #else
00178 typedef struct CaoEngine CaoEngine;
00179 #endif /* __cplusplus */
00180
00181 #endif  /* __CaoEngine_FWD_DEFINED__ */
00182
00183
00184 #ifndef __CaoWorkspaces_FWD_DEFINED__
00185 #define __CaoWorkspaces_FWD_DEFINED__
00186
00187 #ifdef __cplusplus
00188 typedef class CaoWorkspaces CaoWorkspaces;
00189 #else
00190 typedef struct CaoWorkspaces CaoWorkspaces;
00191 #endif /* __cplusplus */
00192
00193 #endif  /* __CaoWorkspaces_FWD_DEFINED__ */
00194
00195
00196 #ifndef __CaoWorkspace_FWD_DEFINED__
00197 #define __CaoWorkspace_FWD_DEFINED__
00198
00199 #ifdef __cplusplus
00200 typedef class CaoWorkspace CaoWorkspace;
00201 #else
00202 typedef struct CaoWorkspace CaoWorkspace;
00203 #endif /* __cplusplus */
00204
00205 #endif  /* __CaoWorkspace_FWD_DEFINED__ */
00206
00207
00208 #ifndef __CaoControllers_FWD_DEFINED__
00209 #define __CaoControllers_FWD_DEFINED__
00210
00211 #ifdef __cplusplus
00212 typedef class CaoControllers CaoControllers;
00213 #else
00214 typedef struct CaoControllers CaoControllers;
00215 #endif /* __cplusplus */
00216
00217 #endif  /* __CaoControllers_FWD_DEFINED__ */
00218
00219
00220 #ifndef __CaoController_FWD_DEFINED__
00221 #define __CaoController_FWD_DEFINED__
00222
00223 #ifdef __cplusplus
00224 typedef class CaoController CaoController;
00225 #else
00226 typedef struct CaoController CaoController;
00227 #endif /* __cplusplus */
00228
00229 #endif  /* __CaoController_FWD_DEFINED__ */
00230
00231
00232 #ifndef __CaoExtensions_FWD_DEFINED__
00233 #define __CaoExtensions_FWD_DEFINED__
00234
00235 #ifdef __cplusplus
00236 typedef class CaoExtensions CaoExtensions;
00237 #else
00238 typedef struct CaoExtensions CaoExtensions;
00239 #endif /* __cplusplus */
00240
00241 #endif  /* __CaoExtensions_FWD_DEFINED__ */
00242
00243
00244 #ifndef __CaoExtension_FWD_DEFINED__
00245 #define __CaoExtension_FWD_DEFINED__
00246
00247 #ifdef __cplusplus
00248 typedef class CaoExtension CaoExtension;
00249 #else
00250 typedef struct CaoExtension CaoExtension;
00251 #endif /* __cplusplus */
00252
00253 #endif  /* __CaoExtension_FWD_DEFINED__ */
00254
00255
00256 #ifndef __CaoFiles_FWD_DEFINED__
00257 #define __CaoFiles_FWD_DEFINED__
00258
00259 #ifdef __cplusplus
00260 typedef class CaoFiles CaoFiles;
00261 #else
00262 typedef struct CaoFiles CaoFiles;
00263 #endif /* __cplusplus */
00264
00265 #endif  /* __CaoFiles_FWD_DEFINED__ */
00266
00267
00268 #ifndef __CaoFile_FWD_DEFINED__
00269 #define __CaoFile_FWD_DEFINED__
00270
00271 #ifdef __cplusplus
00272 typedef class CaoFile CaoFile;
00273 #else
00274 typedef struct CaoFile CaoFile;
00275 #endif /* __cplusplus */
00276
00277 #endif  /* __CaoFile_FWD_DEFINED__ */
00278
00279
00280 #ifndef __CaoRobots_FWD_DEFINED__
00281 #define __CaoRobots_FWD_DEFINED__
00282
00283 #ifdef __cplusplus
00284 typedef class CaoRobots CaoRobots;
00285 #else
00286 typedef struct CaoRobots CaoRobots;
00287 #endif /* __cplusplus */
00288
00289 #endif  /* __CaoRobots_FWD_DEFINED__ */
00290
00291
00292 #ifndef __CaoRobot_FWD_DEFINED__
00293 #define __CaoRobot_FWD_DEFINED__
00294
00295 #ifdef __cplusplus
00296 typedef class CaoRobot CaoRobot;
00297 #else
00298 typedef struct CaoRobot CaoRobot;
00299 #endif /* __cplusplus */
00300
00301 #endif  /* __CaoRobot_FWD_DEFINED__ */
00302
00303
00304 #ifndef __CaoTasks_FWD_DEFINED__
00305 #define __CaoTasks_FWD_DEFINED__
00306
00307 #ifdef __cplusplus
00308 typedef class CaoTasks CaoTasks;
00309 #else
00310 typedef struct CaoTasks CaoTasks;
00311 #endif /* __cplusplus */
00312
00313 #endif  /* __CaoTasks_FWD_DEFINED__ */
00314
00315
00316 #ifndef __CaoTask_FWD_DEFINED__
00317 #define __CaoTask_FWD_DEFINED__
00318
00319 #ifdef __cplusplus
00320 typedef class CaoTask CaoTask;
00321 #else
00322 typedef struct CaoTask CaoTask;
00323 #endif /* __cplusplus */
00324
00325 #endif  /* __CaoTask_FWD_DEFINED__ */
00326
00327
00328 #ifndef __CaoVariables_FWD_DEFINED__
00329 #define __CaoVariables_FWD_DEFINED__
00330
00331 #ifdef __cplusplus
00332 typedef class CaoVariables CaoVariables;
00333 #else
00334 typedef struct CaoVariables CaoVariables;
00335 #endif /* __cplusplus */
00336
00337 #endif  /* __CaoVariables_FWD_DEFINED__ */
00338
00339
00340 #ifndef __CaoVariable_FWD_DEFINED__
00341 #define __CaoVariable_FWD_DEFINED__
00342
00343 #ifdef __cplusplus
00344 typedef class CaoVariable CaoVariable;
00345 #else
00346 typedef struct CaoVariable CaoVariable;
00347 #endif /* __cplusplus */
00348
00349 #endif  /* __CaoVariable_FWD_DEFINED__ */
00350
00351
00352 #ifndef __CaoCommands_FWD_DEFINED__
00353 #define __CaoCommands_FWD_DEFINED__
00354
00355 #ifdef __cplusplus
00356 typedef class CaoCommands CaoCommands;
00357 #else
00358 typedef struct CaoCommands CaoCommands;
00359 #endif /* __cplusplus */
00360
00361 #endif  /* __CaoCommands_FWD_DEFINED__ */
00362
00363
00364 #ifndef __CaoCommand_FWD_DEFINED__
00365 #define __CaoCommand_FWD_DEFINED__
00366
00367 #ifdef __cplusplus
00368 typedef class CaoCommand CaoCommand;
00369 #else
00370 typedef struct CaoCommand CaoCommand;
00371 #endif /* __cplusplus */
00372
00373 #endif  /* __CaoCommand_FWD_DEFINED__ */
00374
00375
00376 #ifndef __CaoMessage_FWD_DEFINED__
00377 #define __CaoMessage_FWD_DEFINED__
00378
00379 #ifdef __cplusplus
00380 typedef class CaoMessage CaoMessage;
00381 #else
00382 typedef struct CaoMessage CaoMessage;
00383 #endif /* __cplusplus */
00384
00385 #endif  /* __CaoMessage_FWD_DEFINED__ */
00386
00387
00388 #ifndef __CaoEngineStatus_FWD_DEFINED__
00389 #define __CaoEngineStatus_FWD_DEFINED__
00390
00391 #ifdef __cplusplus
00392 typedef class CaoEngineStatus CaoEngineStatus;
00393 #else
00394 typedef struct CaoEngineStatus CaoEngineStatus;
00395 #endif /* __cplusplus */
00396
00397 #endif  /* __CaoEngineStatus_FWD_DEFINED__ */
00398
00399
00400 #ifndef __EventSink_FWD_DEFINED__
00401 #define __EventSink_FWD_DEFINED__
00402
00403 #ifdef __cplusplus
00404 typedef class EventSink EventSink;
00405 #else
00406 typedef struct EventSink EventSink;
00407 #endif /* __cplusplus */
00408
00409 #endif  /* __EventSink_FWD_DEFINED__ */
00410
00411
00412 /* header files for imported files */
00413 #include "oaidl.h"
00414 #include "ocidl.h"
00415
00416 void __RPC_FAR * __RPC_USER MIDL_user_allocate(size_t);
00417 void __RPC_USER MIDL_user_free( void __RPC_FAR * );
00418
00419 /* interface __MIDL_itf_CAO_0000 */
00420 /* [local] */
00421
00422
00423
00424
00425
00426
00427
00428
00429
00430
00431
00432
00433
00434
00435
00436
00437
00438
00439
00440
00441
00442 extern RPC_IF_HANDLE __MIDL_itf_CAO_0000_v0_0_c_ifspec;
00443 extern RPC_IF_HANDLE __MIDL_itf_CAO_0000_v0_0_s_ifspec;
00444
00445 #ifndef __ICaoEngine_INTERFACE_DEFINED__
00446 #define __ICaoEngine_INTERFACE_DEFINED__
00447
00448 /* interface ICaoEngine */
00449 /* [unique][helpstring][dual][uuid][object] */
00450
00451
00452 EXTERN_C const IID IID_ICaoEngine;
00453
00454 #if defined(__cplusplus) && !defined(CINTERFACE)
00455
00456     MIDL_INTERFACE("5acfd9fe-41f0-43f6-a0d6-c10c079315fc")
00457     ICaoEngine : public IDispatch
00458     {
00459     public:
00460         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_EngineStatus(
00461             /* [retval][out] */ ICaoEngineStatus __RPC_FAR *__RPC_FAR *ppICaoEngineStatus) = 0;
00462
00463         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Workspaces(
00464             /* [retval][out] */ ICaoWorkspaces __RPC_FAR *__RPC_FAR *ppICaoWSs) = 0;
00465
00466         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE AddWorkspace(
00467             /* [in] */ BSTR bstrName,
00468             /* [defaultvalue][in] */ BSTR bstrOption,
00469             /* [retval][out] */ ICaoWorkspace __RPC_FAR *__RPC_FAR *ppICaoWS) = 0;
00470
00471         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Execute(
00472             /* [in] */ VARIANT vntCommand,
00473             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
00474
00475     };
00476
00477 #else   /* C style interface */
00478
00479     typedef struct ICaoEngineVtbl
00480     {
00481         BEGIN_INTERFACE
00482
00483         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
00484             ICaoEngine __RPC_FAR * This,
00485             /* [in] */ REFIID riid,
00486             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
00487
00488         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
00489             ICaoEngine __RPC_FAR * This);
00490
00491         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
00492             ICaoEngine __RPC_FAR * This);
00493
00494         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
00495             ICaoEngine __RPC_FAR * This,
00496             /* [out] */ UINT __RPC_FAR *pctinfo);
00497
00498         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
00499             ICaoEngine __RPC_FAR * This,
00500             /* [in] */ UINT iTInfo,
00501             /* [in] */ LCID lcid,
00502             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
00503
00504         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
00505             ICaoEngine __RPC_FAR * This,
00506             /* [in] */ REFIID riid,
00507             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
00508             /* [in] */ UINT cNames,
00509             /* [in] */ LCID lcid,
00510             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
00511
00512         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
00513             ICaoEngine __RPC_FAR * This,
00514             /* [in] */ DISPID dispIdMember,
00515             /* [in] */ REFIID riid,
00516             /* [in] */ LCID lcid,
00517             /* [in] */ WORD wFlags,
00518             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
00519             /* [out] */ VARIANT __RPC_FAR *pVarResult,
00520             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
00521             /* [out] */ UINT __RPC_FAR *puArgErr);
00522
00523         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_EngineStatus )(
00524             ICaoEngine __RPC_FAR * This,
00525             /* [retval][out] */ ICaoEngineStatus __RPC_FAR *__RPC_FAR *ppICaoEngineStatus);
00526
00527         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Workspaces )(
00528             ICaoEngine __RPC_FAR * This,
00529             /* [retval][out] */ ICaoWorkspaces __RPC_FAR *__RPC_FAR *ppICaoWSs);
00530
00531         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *AddWorkspace )(
00532             ICaoEngine __RPC_FAR * This,
00533             /* [in] */ BSTR bstrName,
00534             /* [defaultvalue][in] */ BSTR bstrOption,
00535             /* [retval][out] */ ICaoWorkspace __RPC_FAR *__RPC_FAR *ppICaoWS);
00536
00537         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Execute )(
00538             ICaoEngine __RPC_FAR * This,
00539             /* [in] */ VARIANT vntCommand,
00540             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
00541
00542         END_INTERFACE
00543     } ICaoEngineVtbl;
00544
00545     interface ICaoEngine
00546     {
00547         CONST_VTBL struct ICaoEngineVtbl __RPC_FAR *lpVtbl;
00548     };
00549
00550
00551
00552 #ifdef COBJMACROS
00553
00554
00555 #define ICaoEngine_QueryInterface(This,riid,ppvObject)  \
00556     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
00557
00558 #define ICaoEngine_AddRef(This) \
00559     (This)->lpVtbl -> AddRef(This)
00560
00561 #define ICaoEngine_Release(This)    \
00562     (This)->lpVtbl -> Release(This)
00563
00564
00565 #define ICaoEngine_GetTypeInfoCount(This,pctinfo)   \
00566     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
00567
00568 #define ICaoEngine_GetTypeInfo(This,iTInfo,lcid,ppTInfo)    \
00569     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
00570
00571 #define ICaoEngine_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)  \
00572     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
00573
00574 #define ICaoEngine_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)    \
00575     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
00576
00577
00578 #define ICaoEngine_get_EngineStatus(This,ppICaoEngineStatus)    \
00579     (This)->lpVtbl -> get_EngineStatus(This,ppICaoEngineStatus)
00580
00581 #define ICaoEngine_get_Workspaces(This,ppICaoWSs)   \
00582     (This)->lpVtbl -> get_Workspaces(This,ppICaoWSs)
00583
00584 #define ICaoEngine_AddWorkspace(This,bstrName,bstrOption,ppICaoWS)  \
00585     (This)->lpVtbl -> AddWorkspace(This,bstrName,bstrOption,ppICaoWS)
00586
00587 #define ICaoEngine_Execute(This,vntCommand,pVal)    \
00588     (This)->lpVtbl -> Execute(This,vntCommand,pVal)
00589
00590 #endif /* COBJMACROS */
00591
00592
00593 #endif  /* C style interface */
00594
00595
00596
00597 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoEngine_get_EngineStatus_Proxy(
00598     ICaoEngine __RPC_FAR * This,
00599     /* [retval][out] */ ICaoEngineStatus __RPC_FAR *__RPC_FAR *ppICaoEngineStatus);
00600
00601
00602 void __RPC_STUB ICaoEngine_get_EngineStatus_Stub(
00603     IRpcStubBuffer *This,
00604     IRpcChannelBuffer *_pRpcChannelBuffer,
00605     PRPC_MESSAGE _pRpcMessage,
00606     DWORD *_pdwStubPhase);
00607
00608
00609 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoEngine_get_Workspaces_Proxy(
00610     ICaoEngine __RPC_FAR * This,
00611     /* [retval][out] */ ICaoWorkspaces __RPC_FAR *__RPC_FAR *ppICaoWSs);
00612
00613
00614 void __RPC_STUB ICaoEngine_get_Workspaces_Stub(
00615     IRpcStubBuffer *This,
00616     IRpcChannelBuffer *_pRpcChannelBuffer,
00617     PRPC_MESSAGE _pRpcMessage,
00618     DWORD *_pdwStubPhase);
00619
00620
00621 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoEngine_AddWorkspace_Proxy(
00622     ICaoEngine __RPC_FAR * This,
00623     /* [in] */ BSTR bstrName,
00624     /* [defaultvalue][in] */ BSTR bstrOption,
00625     /* [retval][out] */ ICaoWorkspace __RPC_FAR *__RPC_FAR *ppICaoWS);
00626
00627
00628 void __RPC_STUB ICaoEngine_AddWorkspace_Stub(
00629     IRpcStubBuffer *This,
00630     IRpcChannelBuffer *_pRpcChannelBuffer,
00631     PRPC_MESSAGE _pRpcMessage,
00632     DWORD *_pdwStubPhase);
00633
00634
00635 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoEngine_Execute_Proxy(
00636     ICaoEngine __RPC_FAR * This,
00637     /* [in] */ VARIANT vntCommand,
00638     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
00639
00640
00641 void __RPC_STUB ICaoEngine_Execute_Stub(
00642     IRpcStubBuffer *This,
00643     IRpcChannelBuffer *_pRpcChannelBuffer,
00644     PRPC_MESSAGE _pRpcMessage,
00645     DWORD *_pdwStubPhase);
00646
00647
00648
00649 #endif  /* __ICaoEngine_INTERFACE_DEFINED__ */
00650
00651
00652 #ifndef __ICaoWorkspaces_INTERFACE_DEFINED__
00653 #define __ICaoWorkspaces_INTERFACE_DEFINED__
00654
00655 /* interface ICaoWorkspaces */
00656 /* [unique][helpstring][dual][uuid][object] */
00657
00658
00659 EXTERN_C const IID IID_ICaoWorkspaces;
00660
00661 #if defined(__cplusplus) && !defined(CINTERFACE)
00662
00663     MIDL_INTERFACE("8dcdfb4e-cf07-47ca-895f-db1d5afa8f74")
00664     ICaoWorkspaces : public IDispatch
00665     {
00666     public:
00667         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get__NewEnum(
00668             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal) = 0;
00669
00670         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Item(
00671             /* [in] */ VARIANT Index,
00672             /* [retval][out] */ ICaoWorkspace __RPC_FAR *__RPC_FAR *ppICaoWS) = 0;
00673
00674         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Count(
00675             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
00676
00677         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Add(
00678             /* [in] */ BSTR bstrName,
00679             /* [defaultvalue][in] */ BSTR bstrOption,
00680             /* [retval][out] */ ICaoWorkspace __RPC_FAR *__RPC_FAR *ppICaoWS) = 0;
00681
00682         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Remove(
00683             /* [in] */ VARIANT Index) = 0;
00684
00685         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Clear( void) = 0;
00686
00687         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE IsMember(
00688             /* [in] */ VARIANT Index,
00689             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal) = 0;
00690
00691     };
00692
00693 #else   /* C style interface */
00694
00695     typedef struct ICaoWorkspacesVtbl
00696     {
00697         BEGIN_INTERFACE
00698
00699         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
00700             ICaoWorkspaces __RPC_FAR * This,
00701             /* [in] */ REFIID riid,
00702             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
00703
00704         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
00705             ICaoWorkspaces __RPC_FAR * This);
00706
00707         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
00708             ICaoWorkspaces __RPC_FAR * This);
00709
00710         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
00711             ICaoWorkspaces __RPC_FAR * This,
00712             /* [out] */ UINT __RPC_FAR *pctinfo);
00713
00714         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
00715             ICaoWorkspaces __RPC_FAR * This,
00716             /* [in] */ UINT iTInfo,
00717             /* [in] */ LCID lcid,
00718             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
00719
00720         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
00721             ICaoWorkspaces __RPC_FAR * This,
00722             /* [in] */ REFIID riid,
00723             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
00724             /* [in] */ UINT cNames,
00725             /* [in] */ LCID lcid,
00726             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
00727
00728         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
00729             ICaoWorkspaces __RPC_FAR * This,
00730             /* [in] */ DISPID dispIdMember,
00731             /* [in] */ REFIID riid,
00732             /* [in] */ LCID lcid,
00733             /* [in] */ WORD wFlags,
00734             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
00735             /* [out] */ VARIANT __RPC_FAR *pVarResult,
00736             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
00737             /* [out] */ UINT __RPC_FAR *puArgErr);
00738
00739         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get__NewEnum )(
00740             ICaoWorkspaces __RPC_FAR * This,
00741             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
00742
00743         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Item )(
00744             ICaoWorkspaces __RPC_FAR * This,
00745             /* [in] */ VARIANT Index,
00746             /* [retval][out] */ ICaoWorkspace __RPC_FAR *__RPC_FAR *ppICaoWS);
00747
00748         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Count )(
00749             ICaoWorkspaces __RPC_FAR * This,
00750             /* [retval][out] */ long __RPC_FAR *pVal);
00751
00752         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Add )(
00753             ICaoWorkspaces __RPC_FAR * This,
00754             /* [in] */ BSTR bstrName,
00755             /* [defaultvalue][in] */ BSTR bstrOption,
00756             /* [retval][out] */ ICaoWorkspace __RPC_FAR *__RPC_FAR *ppICaoWS);
00757
00758         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Remove )(
00759             ICaoWorkspaces __RPC_FAR * This,
00760             /* [in] */ VARIANT Index);
00761
00762         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Clear )(
00763             ICaoWorkspaces __RPC_FAR * This);
00764
00765         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *IsMember )(
00766             ICaoWorkspaces __RPC_FAR * This,
00767             /* [in] */ VARIANT Index,
00768             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal);
00769
00770         END_INTERFACE
00771     } ICaoWorkspacesVtbl;
00772
00773     interface ICaoWorkspaces
00774     {
00775         CONST_VTBL struct ICaoWorkspacesVtbl __RPC_FAR *lpVtbl;
00776     };
00777
00778
00779
00780 #ifdef COBJMACROS
00781
00782
00783 #define ICaoWorkspaces_QueryInterface(This,riid,ppvObject)  \
00784     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
00785
00786 #define ICaoWorkspaces_AddRef(This) \
00787     (This)->lpVtbl -> AddRef(This)
00788
00789 #define ICaoWorkspaces_Release(This)    \
00790     (This)->lpVtbl -> Release(This)
00791
00792
00793 #define ICaoWorkspaces_GetTypeInfoCount(This,pctinfo)   \
00794     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
00795
00796 #define ICaoWorkspaces_GetTypeInfo(This,iTInfo,lcid,ppTInfo)    \
00797     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
00798
00799 #define ICaoWorkspaces_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)  \
00800     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
00801
00802 #define ICaoWorkspaces_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)    \
00803     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
00804
00805
00806 #define ICaoWorkspaces_get__NewEnum(This,pVal)  \
00807     (This)->lpVtbl -> get__NewEnum(This,pVal)
00808
00809 #define ICaoWorkspaces_Item(This,Index,ppICaoWS)    \
00810     (This)->lpVtbl -> Item(This,Index,ppICaoWS)
00811
00812 #define ICaoWorkspaces_get_Count(This,pVal) \
00813     (This)->lpVtbl -> get_Count(This,pVal)
00814
00815 #define ICaoWorkspaces_Add(This,bstrName,bstrOption,ppICaoWS)   \
00816     (This)->lpVtbl -> Add(This,bstrName,bstrOption,ppICaoWS)
00817
00818 #define ICaoWorkspaces_Remove(This,Index)   \
00819     (This)->lpVtbl -> Remove(This,Index)
00820
00821 #define ICaoWorkspaces_Clear(This)  \
00822     (This)->lpVtbl -> Clear(This)
00823
00824 #define ICaoWorkspaces_IsMember(This,Index,pVal)    \
00825     (This)->lpVtbl -> IsMember(This,Index,pVal)
00826
00827 #endif /* COBJMACROS */
00828
00829
00830 #endif  /* C style interface */
00831
00832
00833
00834 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoWorkspaces_get__NewEnum_Proxy(
00835     ICaoWorkspaces __RPC_FAR * This,
00836     /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
00837
00838
00839 void __RPC_STUB ICaoWorkspaces_get__NewEnum_Stub(
00840     IRpcStubBuffer *This,
00841     IRpcChannelBuffer *_pRpcChannelBuffer,
00842     PRPC_MESSAGE _pRpcMessage,
00843     DWORD *_pdwStubPhase);
00844
00845
00846 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoWorkspaces_Item_Proxy(
00847     ICaoWorkspaces __RPC_FAR * This,
00848     /* [in] */ VARIANT Index,
00849     /* [retval][out] */ ICaoWorkspace __RPC_FAR *__RPC_FAR *ppICaoWS);
00850
00851
00852 void __RPC_STUB ICaoWorkspaces_Item_Stub(
00853     IRpcStubBuffer *This,
00854     IRpcChannelBuffer *_pRpcChannelBuffer,
00855     PRPC_MESSAGE _pRpcMessage,
00856     DWORD *_pdwStubPhase);
00857
00858
00859 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoWorkspaces_get_Count_Proxy(
00860     ICaoWorkspaces __RPC_FAR * This,
00861     /* [retval][out] */ long __RPC_FAR *pVal);
00862
00863
00864 void __RPC_STUB ICaoWorkspaces_get_Count_Stub(
00865     IRpcStubBuffer *This,
00866     IRpcChannelBuffer *_pRpcChannelBuffer,
00867     PRPC_MESSAGE _pRpcMessage,
00868     DWORD *_pdwStubPhase);
00869
00870
00871 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoWorkspaces_Add_Proxy(
00872     ICaoWorkspaces __RPC_FAR * This,
00873     /* [in] */ BSTR bstrName,
00874     /* [defaultvalue][in] */ BSTR bstrOption,
00875     /* [retval][out] */ ICaoWorkspace __RPC_FAR *__RPC_FAR *ppICaoWS);
00876
00877
00878 void __RPC_STUB ICaoWorkspaces_Add_Stub(
00879     IRpcStubBuffer *This,
00880     IRpcChannelBuffer *_pRpcChannelBuffer,
00881     PRPC_MESSAGE _pRpcMessage,
00882     DWORD *_pdwStubPhase);
00883
00884
00885 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoWorkspaces_Remove_Proxy(
00886     ICaoWorkspaces __RPC_FAR * This,
00887     /* [in] */ VARIANT Index);
00888
00889
00890 void __RPC_STUB ICaoWorkspaces_Remove_Stub(
00891     IRpcStubBuffer *This,
00892     IRpcChannelBuffer *_pRpcChannelBuffer,
00893     PRPC_MESSAGE _pRpcMessage,
00894     DWORD *_pdwStubPhase);
00895
00896
00897 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoWorkspaces_Clear_Proxy(
00898     ICaoWorkspaces __RPC_FAR * This);
00899
00900
00901 void __RPC_STUB ICaoWorkspaces_Clear_Stub(
00902     IRpcStubBuffer *This,
00903     IRpcChannelBuffer *_pRpcChannelBuffer,
00904     PRPC_MESSAGE _pRpcMessage,
00905     DWORD *_pdwStubPhase);
00906
00907
00908 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoWorkspaces_IsMember_Proxy(
00909     ICaoWorkspaces __RPC_FAR * This,
00910     /* [in] */ VARIANT Index,
00911     /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal);
00912
00913
00914 void __RPC_STUB ICaoWorkspaces_IsMember_Stub(
00915     IRpcStubBuffer *This,
00916     IRpcChannelBuffer *_pRpcChannelBuffer,
00917     PRPC_MESSAGE _pRpcMessage,
00918     DWORD *_pdwStubPhase);
00919
00920
00921
00922 #endif  /* __ICaoWorkspaces_INTERFACE_DEFINED__ */
00923
00924
00925 #ifndef __ICaoWorkspace_INTERFACE_DEFINED__
00926 #define __ICaoWorkspace_INTERFACE_DEFINED__
00927
00928 /* interface ICaoWorkspace */
00929 /* [unique][helpstring][dual][uuid][object] */
00930
00931
00932 EXTERN_C const IID IID_ICaoWorkspace;
00933
00934 #if defined(__cplusplus) && !defined(CINTERFACE)
00935
00936     MIDL_INTERFACE("0ed07c17-b078-40cf-9b0f-3a4974de55e5")
00937     ICaoWorkspace : public IDispatch
00938     {
00939     public:
00940         virtual /* [restricted][helpstring][id] */ HRESULT STDMETHODCALLTYPE _PutIndex(
00941             /* [in] */ long newVal) = 0;
00942
00943         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Controllers(
00944             /* [retval][out] */ ICaoControllers __RPC_FAR *__RPC_FAR *ppICaoCtrls) = 0;
00945
00946         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Index(
00947             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
00948
00949         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
00950             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
00951
00952         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ProviderNames(
00953             /* [defaultvalue][in] */ BSTR bstrOption,
00954             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
00955
00956         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE AddController(
00957             /* [in] */ BSTR bstrController,
00958             /* [in] */ BSTR bstrProvider,
00959             /* [defaultvalue][in] */ BSTR bstrMachine,
00960             /* [defaultvalue][in] */ BSTR bstrOption,
00961             /* [retval][out] */ ICaoController __RPC_FAR *__RPC_FAR *ppICaoCtrl) = 0;
00962
00963         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Execute(
00964             /* [in] */ VARIANT vntCommand,
00965             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
00966
00967     };
00968
00969 #else   /* C style interface */
00970
00971     typedef struct ICaoWorkspaceVtbl
00972     {
00973         BEGIN_INTERFACE
00974
00975         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
00976             ICaoWorkspace __RPC_FAR * This,
00977             /* [in] */ REFIID riid,
00978             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
00979
00980         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
00981             ICaoWorkspace __RPC_FAR * This);
00982
00983         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
00984             ICaoWorkspace __RPC_FAR * This);
00985
00986         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
00987             ICaoWorkspace __RPC_FAR * This,
00988             /* [out] */ UINT __RPC_FAR *pctinfo);
00989
00990         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
00991             ICaoWorkspace __RPC_FAR * This,
00992             /* [in] */ UINT iTInfo,
00993             /* [in] */ LCID lcid,
00994             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
00995
00996         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
00997             ICaoWorkspace __RPC_FAR * This,
00998             /* [in] */ REFIID riid,
00999             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
01000             /* [in] */ UINT cNames,
01001             /* [in] */ LCID lcid,
01002             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
01003
01004         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
01005             ICaoWorkspace __RPC_FAR * This,
01006             /* [in] */ DISPID dispIdMember,
01007             /* [in] */ REFIID riid,
01008             /* [in] */ LCID lcid,
01009             /* [in] */ WORD wFlags,
01010             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
01011             /* [out] */ VARIANT __RPC_FAR *pVarResult,
01012             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
01013             /* [out] */ UINT __RPC_FAR *puArgErr);
01014
01015         /* [restricted][helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *_PutIndex )(
01016             ICaoWorkspace __RPC_FAR * This,
01017             /* [in] */ long newVal);
01018
01019         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Controllers )(
01020             ICaoWorkspace __RPC_FAR * This,
01021             /* [retval][out] */ ICaoControllers __RPC_FAR *__RPC_FAR *ppICaoCtrls);
01022
01023         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Index )(
01024             ICaoWorkspace __RPC_FAR * This,
01025             /* [retval][out] */ long __RPC_FAR *pVal);
01026
01027         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
01028             ICaoWorkspace __RPC_FAR * This,
01029             /* [retval][out] */ BSTR __RPC_FAR *pVal);
01030
01031         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ProviderNames )(
01032             ICaoWorkspace __RPC_FAR * This,
01033             /* [defaultvalue][in] */ BSTR bstrOption,
01034             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01035
01036         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *AddController )(
01037             ICaoWorkspace __RPC_FAR * This,
01038             /* [in] */ BSTR bstrController,
01039             /* [in] */ BSTR bstrProvider,
01040             /* [defaultvalue][in] */ BSTR bstrMachine,
01041             /* [defaultvalue][in] */ BSTR bstrOption,
01042             /* [retval][out] */ ICaoController __RPC_FAR *__RPC_FAR *ppICaoCtrl);
01043
01044         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Execute )(
01045             ICaoWorkspace __RPC_FAR * This,
01046             /* [in] */ VARIANT vntCommand,
01047             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01048
01049         END_INTERFACE
01050     } ICaoWorkspaceVtbl;
01051
01052     interface ICaoWorkspace
01053     {
01054         CONST_VTBL struct ICaoWorkspaceVtbl __RPC_FAR *lpVtbl;
01055     };
01056
01057
01058
01059 #ifdef COBJMACROS
01060
01061
01062 #define ICaoWorkspace_QueryInterface(This,riid,ppvObject)   \
01063     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
01064
01065 #define ICaoWorkspace_AddRef(This)  \
01066     (This)->lpVtbl -> AddRef(This)
01067
01068 #define ICaoWorkspace_Release(This) \
01069     (This)->lpVtbl -> Release(This)
01070
01071
01072 #define ICaoWorkspace_GetTypeInfoCount(This,pctinfo)    \
01073     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
01074
01075 #define ICaoWorkspace_GetTypeInfo(This,iTInfo,lcid,ppTInfo) \
01076     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
01077
01078 #define ICaoWorkspace_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)   \
01079     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
01080
01081 #define ICaoWorkspace_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr) \
01082     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
01083
01084
01085 #define ICaoWorkspace__PutIndex(This,newVal)    \
01086     (This)->lpVtbl -> _PutIndex(This,newVal)
01087
01088 #define ICaoWorkspace_get_Controllers(This,ppICaoCtrls) \
01089     (This)->lpVtbl -> get_Controllers(This,ppICaoCtrls)
01090
01091 #define ICaoWorkspace_get_Index(This,pVal)  \
01092     (This)->lpVtbl -> get_Index(This,pVal)
01093
01094 #define ICaoWorkspace_get_Name(This,pVal)   \
01095     (This)->lpVtbl -> get_Name(This,pVal)
01096
01097 #define ICaoWorkspace_get_ProviderNames(This,bstrOption,pVal)   \
01098     (This)->lpVtbl -> get_ProviderNames(This,bstrOption,pVal)
01099
01100 #define ICaoWorkspace_AddController(This,bstrController,bstrProvider,bstrMachine,bstrOption,ppICaoCtrl) \
01101     (This)->lpVtbl -> AddController(This,bstrController,bstrProvider,bstrMachine,bstrOption,ppICaoCtrl)
01102
01103 #define ICaoWorkspace_Execute(This,vntCommand,pVal) \
01104     (This)->lpVtbl -> Execute(This,vntCommand,pVal)
01105
01106 #endif /* COBJMACROS */
01107
01108
01109 #endif  /* C style interface */
01110
01111
01112
01113 /* [restricted][helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoWorkspace__PutIndex_Proxy(
01114     ICaoWorkspace __RPC_FAR * This,
01115     /* [in] */ long newVal);
01116
01117
01118 void __RPC_STUB ICaoWorkspace__PutIndex_Stub(
01119     IRpcStubBuffer *This,
01120     IRpcChannelBuffer *_pRpcChannelBuffer,
01121     PRPC_MESSAGE _pRpcMessage,
01122     DWORD *_pdwStubPhase);
01123
01124
01125 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoWorkspace_get_Controllers_Proxy(
01126     ICaoWorkspace __RPC_FAR * This,
01127     /* [retval][out] */ ICaoControllers __RPC_FAR *__RPC_FAR *ppICaoCtrls);
01128
01129
01130 void __RPC_STUB ICaoWorkspace_get_Controllers_Stub(
01131     IRpcStubBuffer *This,
01132     IRpcChannelBuffer *_pRpcChannelBuffer,
01133     PRPC_MESSAGE _pRpcMessage,
01134     DWORD *_pdwStubPhase);
01135
01136
01137 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoWorkspace_get_Index_Proxy(
01138     ICaoWorkspace __RPC_FAR * This,
01139     /* [retval][out] */ long __RPC_FAR *pVal);
01140
01141
01142 void __RPC_STUB ICaoWorkspace_get_Index_Stub(
01143     IRpcStubBuffer *This,
01144     IRpcChannelBuffer *_pRpcChannelBuffer,
01145     PRPC_MESSAGE _pRpcMessage,
01146     DWORD *_pdwStubPhase);
01147
01148
01149 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoWorkspace_get_Name_Proxy(
01150     ICaoWorkspace __RPC_FAR * This,
01151     /* [retval][out] */ BSTR __RPC_FAR *pVal);
01152
01153
01154 void __RPC_STUB ICaoWorkspace_get_Name_Stub(
01155     IRpcStubBuffer *This,
01156     IRpcChannelBuffer *_pRpcChannelBuffer,
01157     PRPC_MESSAGE _pRpcMessage,
01158     DWORD *_pdwStubPhase);
01159
01160
01161 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoWorkspace_get_ProviderNames_Proxy(
01162     ICaoWorkspace __RPC_FAR * This,
01163     /* [defaultvalue][in] */ BSTR bstrOption,
01164     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01165
01166
01167 void __RPC_STUB ICaoWorkspace_get_ProviderNames_Stub(
01168     IRpcStubBuffer *This,
01169     IRpcChannelBuffer *_pRpcChannelBuffer,
01170     PRPC_MESSAGE _pRpcMessage,
01171     DWORD *_pdwStubPhase);
01172
01173
01174 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoWorkspace_AddController_Proxy(
01175     ICaoWorkspace __RPC_FAR * This,
01176     /* [in] */ BSTR bstrController,
01177     /* [in] */ BSTR bstrProvider,
01178     /* [defaultvalue][in] */ BSTR bstrMachine,
01179     /* [defaultvalue][in] */ BSTR bstrOption,
01180     /* [retval][out] */ ICaoController __RPC_FAR *__RPC_FAR *ppICaoCtrl);
01181
01182
01183 void __RPC_STUB ICaoWorkspace_AddController_Stub(
01184     IRpcStubBuffer *This,
01185     IRpcChannelBuffer *_pRpcChannelBuffer,
01186     PRPC_MESSAGE _pRpcMessage,
01187     DWORD *_pdwStubPhase);
01188
01189
01190 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoWorkspace_Execute_Proxy(
01191     ICaoWorkspace __RPC_FAR * This,
01192     /* [in] */ VARIANT vntCommand,
01193     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01194
01195
01196 void __RPC_STUB ICaoWorkspace_Execute_Stub(
01197     IRpcStubBuffer *This,
01198     IRpcChannelBuffer *_pRpcChannelBuffer,
01199     PRPC_MESSAGE _pRpcMessage,
01200     DWORD *_pdwStubPhase);
01201
01202
01203
01204 #endif  /* __ICaoWorkspace_INTERFACE_DEFINED__ */
01205
01206
01207 #ifndef __ICaoControllers_INTERFACE_DEFINED__
01208 #define __ICaoControllers_INTERFACE_DEFINED__
01209
01210 /* interface ICaoControllers */
01211 /* [unique][helpstring][dual][uuid][object] */
01212
01213
01214 EXTERN_C const IID IID_ICaoControllers;
01215
01216 #if defined(__cplusplus) && !defined(CINTERFACE)
01217
01218     MIDL_INTERFACE("474b2753-9f06-41e0-840b-1f26b1ac1c2c")
01219     ICaoControllers : public IDispatch
01220     {
01221     public:
01222         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get__NewEnum(
01223             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal) = 0;
01224
01225         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Item(
01226             /* [in] */ VARIANT Index,
01227             /* [retval][out] */ ICaoController __RPC_FAR *__RPC_FAR *ppICaoCtrl) = 0;
01228
01229         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Count(
01230             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
01231
01232         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Add(
01233             /* [in] */ BSTR bstrController,
01234             /* [in] */ BSTR bstrProvider,
01235             /* [defaultvalue][in] */ BSTR bstrMachine,
01236             /* [defaultvalue][in] */ BSTR bstrOption,
01237             /* [retval][out] */ ICaoController __RPC_FAR *__RPC_FAR *ppICaoCtrl) = 0;
01238
01239         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Remove(
01240             /* [in] */ VARIANT Index) = 0;
01241
01242         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Clear( void) = 0;
01243
01244         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE IsMember(
01245             /* [in] */ VARIANT Index,
01246             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal) = 0;
01247
01248     };
01249
01250 #else   /* C style interface */
01251
01252     typedef struct ICaoControllersVtbl
01253     {
01254         BEGIN_INTERFACE
01255
01256         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
01257             ICaoControllers __RPC_FAR * This,
01258             /* [in] */ REFIID riid,
01259             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
01260
01261         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
01262             ICaoControllers __RPC_FAR * This);
01263
01264         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
01265             ICaoControllers __RPC_FAR * This);
01266
01267         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
01268             ICaoControllers __RPC_FAR * This,
01269             /* [out] */ UINT __RPC_FAR *pctinfo);
01270
01271         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
01272             ICaoControllers __RPC_FAR * This,
01273             /* [in] */ UINT iTInfo,
01274             /* [in] */ LCID lcid,
01275             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
01276
01277         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
01278             ICaoControllers __RPC_FAR * This,
01279             /* [in] */ REFIID riid,
01280             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
01281             /* [in] */ UINT cNames,
01282             /* [in] */ LCID lcid,
01283             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
01284
01285         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
01286             ICaoControllers __RPC_FAR * This,
01287             /* [in] */ DISPID dispIdMember,
01288             /* [in] */ REFIID riid,
01289             /* [in] */ LCID lcid,
01290             /* [in] */ WORD wFlags,
01291             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
01292             /* [out] */ VARIANT __RPC_FAR *pVarResult,
01293             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
01294             /* [out] */ UINT __RPC_FAR *puArgErr);
01295
01296         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get__NewEnum )(
01297             ICaoControllers __RPC_FAR * This,
01298             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
01299
01300         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Item )(
01301             ICaoControllers __RPC_FAR * This,
01302             /* [in] */ VARIANT Index,
01303             /* [retval][out] */ ICaoController __RPC_FAR *__RPC_FAR *ppICaoCtrl);
01304
01305         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Count )(
01306             ICaoControllers __RPC_FAR * This,
01307             /* [retval][out] */ long __RPC_FAR *pVal);
01308
01309         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Add )(
01310             ICaoControllers __RPC_FAR * This,
01311             /* [in] */ BSTR bstrController,
01312             /* [in] */ BSTR bstrProvider,
01313             /* [defaultvalue][in] */ BSTR bstrMachine,
01314             /* [defaultvalue][in] */ BSTR bstrOption,
01315             /* [retval][out] */ ICaoController __RPC_FAR *__RPC_FAR *ppICaoCtrl);
01316
01317         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Remove )(
01318             ICaoControllers __RPC_FAR * This,
01319             /* [in] */ VARIANT Index);
01320
01321         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Clear )(
01322             ICaoControllers __RPC_FAR * This);
01323
01324         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *IsMember )(
01325             ICaoControllers __RPC_FAR * This,
01326             /* [in] */ VARIANT Index,
01327             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal);
01328
01329         END_INTERFACE
01330     } ICaoControllersVtbl;
01331
01332     interface ICaoControllers
01333     {
01334         CONST_VTBL struct ICaoControllersVtbl __RPC_FAR *lpVtbl;
01335     };
01336
01337
01338
01339 #ifdef COBJMACROS
01340
01341
01342 #define ICaoControllers_QueryInterface(This,riid,ppvObject) \
01343     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
01344
01345 #define ICaoControllers_AddRef(This)    \
01346     (This)->lpVtbl -> AddRef(This)
01347
01348 #define ICaoControllers_Release(This)   \
01349     (This)->lpVtbl -> Release(This)
01350
01351
01352 #define ICaoControllers_GetTypeInfoCount(This,pctinfo)  \
01353     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
01354
01355 #define ICaoControllers_GetTypeInfo(This,iTInfo,lcid,ppTInfo)   \
01356     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
01357
01358 #define ICaoControllers_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId) \
01359     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
01360
01361 #define ICaoControllers_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)   \
01362     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
01363
01364
01365 #define ICaoControllers_get__NewEnum(This,pVal) \
01366     (This)->lpVtbl -> get__NewEnum(This,pVal)
01367
01368 #define ICaoControllers_Item(This,Index,ppICaoCtrl) \
01369     (This)->lpVtbl -> Item(This,Index,ppICaoCtrl)
01370
01371 #define ICaoControllers_get_Count(This,pVal)    \
01372     (This)->lpVtbl -> get_Count(This,pVal)
01373
01374 #define ICaoControllers_Add(This,bstrController,bstrProvider,bstrMachine,bstrOption,ppICaoCtrl) \
01375     (This)->lpVtbl -> Add(This,bstrController,bstrProvider,bstrMachine,bstrOption,ppICaoCtrl)
01376
01377 #define ICaoControllers_Remove(This,Index)  \
01378     (This)->lpVtbl -> Remove(This,Index)
01379
01380 #define ICaoControllers_Clear(This) \
01381     (This)->lpVtbl -> Clear(This)
01382
01383 #define ICaoControllers_IsMember(This,Index,pVal)   \
01384     (This)->lpVtbl -> IsMember(This,Index,pVal)
01385
01386 #endif /* COBJMACROS */
01387
01388
01389 #endif  /* C style interface */
01390
01391
01392
01393 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoControllers_get__NewEnum_Proxy(
01394     ICaoControllers __RPC_FAR * This,
01395     /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
01396
01397
01398 void __RPC_STUB ICaoControllers_get__NewEnum_Stub(
01399     IRpcStubBuffer *This,
01400     IRpcChannelBuffer *_pRpcChannelBuffer,
01401     PRPC_MESSAGE _pRpcMessage,
01402     DWORD *_pdwStubPhase);
01403
01404
01405 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoControllers_Item_Proxy(
01406     ICaoControllers __RPC_FAR * This,
01407     /* [in] */ VARIANT Index,
01408     /* [retval][out] */ ICaoController __RPC_FAR *__RPC_FAR *ppICaoCtrl);
01409
01410
01411 void __RPC_STUB ICaoControllers_Item_Stub(
01412     IRpcStubBuffer *This,
01413     IRpcChannelBuffer *_pRpcChannelBuffer,
01414     PRPC_MESSAGE _pRpcMessage,
01415     DWORD *_pdwStubPhase);
01416
01417
01418 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoControllers_get_Count_Proxy(
01419     ICaoControllers __RPC_FAR * This,
01420     /* [retval][out] */ long __RPC_FAR *pVal);
01421
01422
01423 void __RPC_STUB ICaoControllers_get_Count_Stub(
01424     IRpcStubBuffer *This,
01425     IRpcChannelBuffer *_pRpcChannelBuffer,
01426     PRPC_MESSAGE _pRpcMessage,
01427     DWORD *_pdwStubPhase);
01428
01429
01430 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoControllers_Add_Proxy(
01431     ICaoControllers __RPC_FAR * This,
01432     /* [in] */ BSTR bstrController,
01433     /* [in] */ BSTR bstrProvider,
01434     /* [defaultvalue][in] */ BSTR bstrMachine,
01435     /* [defaultvalue][in] */ BSTR bstrOption,
01436     /* [retval][out] */ ICaoController __RPC_FAR *__RPC_FAR *ppICaoCtrl);
01437
01438
01439 void __RPC_STUB ICaoControllers_Add_Stub(
01440     IRpcStubBuffer *This,
01441     IRpcChannelBuffer *_pRpcChannelBuffer,
01442     PRPC_MESSAGE _pRpcMessage,
01443     DWORD *_pdwStubPhase);
01444
01445
01446 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoControllers_Remove_Proxy(
01447     ICaoControllers __RPC_FAR * This,
01448     /* [in] */ VARIANT Index);
01449
01450
01451 void __RPC_STUB ICaoControllers_Remove_Stub(
01452     IRpcStubBuffer *This,
01453     IRpcChannelBuffer *_pRpcChannelBuffer,
01454     PRPC_MESSAGE _pRpcMessage,
01455     DWORD *_pdwStubPhase);
01456
01457
01458 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoControllers_Clear_Proxy(
01459     ICaoControllers __RPC_FAR * This);
01460
01461
01462 void __RPC_STUB ICaoControllers_Clear_Stub(
01463     IRpcStubBuffer *This,
01464     IRpcChannelBuffer *_pRpcChannelBuffer,
01465     PRPC_MESSAGE _pRpcMessage,
01466     DWORD *_pdwStubPhase);
01467
01468
01469 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoControllers_IsMember_Proxy(
01470     ICaoControllers __RPC_FAR * This,
01471     /* [in] */ VARIANT Index,
01472     /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal);
01473
01474
01475 void __RPC_STUB ICaoControllers_IsMember_Stub(
01476     IRpcStubBuffer *This,
01477     IRpcChannelBuffer *_pRpcChannelBuffer,
01478     PRPC_MESSAGE _pRpcMessage,
01479     DWORD *_pdwStubPhase);
01480
01481
01482
01483 #endif  /* __ICaoControllers_INTERFACE_DEFINED__ */
01484
01485
01486 #ifndef __ICaoController_INTERFACE_DEFINED__
01487 #define __ICaoController_INTERFACE_DEFINED__
01488
01489 /* interface ICaoController */
01490 /* [unique][helpstring][dual][uuid][object] */
01491
01492
01493 EXTERN_C const IID IID_ICaoController;
01494
01495 #if defined(__cplusplus) && !defined(CINTERFACE)
01496
01497     MIDL_INTERFACE("c94e794f-ec5b-43f2-879f-777a49e7305b")
01498     ICaoController : public IDispatch
01499     {
01500     public:
01501         virtual /* [restricted][helpstring][id] */ HRESULT STDMETHODCALLTYPE _PutIndex(
01502             /* [in] */ long newVal) = 0;
01503
01504         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Attribute(
01505             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
01506
01507         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ExtensionNames(
01508             /* [defaultvalue][in] */ BSTR bstrOption,
01509             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
01510
01511         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Extensions(
01512             /* [retval][out] */ ICaoExtensions __RPC_FAR *__RPC_FAR *ppICaoExtensions) = 0;
01513
01514         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_FileNames(
01515             /* [defaultvalue][in] */ BSTR bstrOption,
01516             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
01517
01518         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Files(
01519             /* [retval][out] */ ICaoFiles __RPC_FAR *__RPC_FAR *ppICaoFiles) = 0;
01520
01521         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Help(
01522             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
01523
01524         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Index(
01525             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
01526
01527         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
01528             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
01529
01530         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_RobotNames(
01531             /* [defaultvalue][in] */ BSTR bstrOption,
01532             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
01533
01534         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Robots(
01535             /* [retval][out] */ ICaoRobots __RPC_FAR *__RPC_FAR *ppICaoRobots) = 0;
01536
01537         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Tag(
01538             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
01539
01540         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Tag(
01541             /* [in] */ VARIANT newVal) = 0;
01542
01543         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_TaskNames(
01544             /* [defaultvalue][in] */ BSTR bstrOption,
01545             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
01546
01547         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Tasks(
01548             /* [retval][out] */ ICaoTasks __RPC_FAR *__RPC_FAR *ppICaoTasks) = 0;
01549
01550         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_VariableNames(
01551             /* [defaultvalue][in] */ BSTR bstrOption,
01552             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
01553
01554         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Variables(
01555             /* [retval][out] */ ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables) = 0;
01556
01557         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_CommandNames(
01558             /* [defaultvalue][in] */ BSTR bstrOption,
01559             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
01560
01561         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Commands(
01562             /* [retval][out] */ ICaoCommands __RPC_FAR *__RPC_FAR *ppICaoCommands) = 0;
01563
01564         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ID(
01565             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
01566
01567         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ID(
01568             /* [in] */ VARIANT newVal) = 0;
01569
01570         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE AddExtension(
01571             /* [in] */ BSTR bstrName,
01572             /* [defaultvalue][in] */ BSTR bstrOption,
01573             /* [retval][out] */ ICaoExtension __RPC_FAR *__RPC_FAR *ppICaoExtension) = 0;
01574
01575         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE AddFile(
01576             /* [in] */ BSTR bstrName,
01577             /* [defaultvalue][in] */ BSTR bstrOption,
01578             /* [retval][out] */ ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile) = 0;
01579
01580         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE AddRobot(
01581             /* [in] */ BSTR bstrName,
01582             /* [defaultvalue][in] */ BSTR bstrOption,
01583             /* [retval][out] */ ICaoRobot __RPC_FAR *__RPC_FAR *ppICaoRobot) = 0;
01584
01585         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE AddTask(
01586             /* [in] */ BSTR bstrName,
01587             /* [defaultvalue][in] */ BSTR bstrOption,
01588             /* [retval][out] */ ICaoTask __RPC_FAR *__RPC_FAR *ppICaoTask) = 0;
01589
01590         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE AddVariable(
01591             /* [in] */ BSTR bstrName,
01592             /* [defaultvalue][in] */ BSTR bstrOption,
01593             /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar) = 0;
01594
01595         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE AddCommand(
01596             /* [in] */ BSTR bstrName,
01597             /* [defaultvalue][in] */ BSTR bstrOption,
01598             /* [retval][out] */ ICaoCommand __RPC_FAR *__RPC_FAR *ppICaoCommand) = 0;
01599
01600         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Execute(
01601             /* [in] */ VARIANT vntCommand,
01602             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
01603
01604         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE GetMessage(
01605             /* [retval][out] */ ICaoMessage __RPC_FAR *__RPC_FAR *ppICaoMessage) = 0;
01606
01607     };
01608
01609 #else   /* C style interface */
01610
01611     typedef struct ICaoControllerVtbl
01612     {
01613         BEGIN_INTERFACE
01614
01615         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
01616             ICaoController __RPC_FAR * This,
01617             /* [in] */ REFIID riid,
01618             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
01619
01620         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
01621             ICaoController __RPC_FAR * This);
01622
01623         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
01624             ICaoController __RPC_FAR * This);
01625
01626         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
01627             ICaoController __RPC_FAR * This,
01628             /* [out] */ UINT __RPC_FAR *pctinfo);
01629
01630         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
01631             ICaoController __RPC_FAR * This,
01632             /* [in] */ UINT iTInfo,
01633             /* [in] */ LCID lcid,
01634             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
01635
01636         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
01637             ICaoController __RPC_FAR * This,
01638             /* [in] */ REFIID riid,
01639             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
01640             /* [in] */ UINT cNames,
01641             /* [in] */ LCID lcid,
01642             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
01643
01644         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
01645             ICaoController __RPC_FAR * This,
01646             /* [in] */ DISPID dispIdMember,
01647             /* [in] */ REFIID riid,
01648             /* [in] */ LCID lcid,
01649             /* [in] */ WORD wFlags,
01650             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
01651             /* [out] */ VARIANT __RPC_FAR *pVarResult,
01652             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
01653             /* [out] */ UINT __RPC_FAR *puArgErr);
01654
01655         /* [restricted][helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *_PutIndex )(
01656             ICaoController __RPC_FAR * This,
01657             /* [in] */ long newVal);
01658
01659         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Attribute )(
01660             ICaoController __RPC_FAR * This,
01661             /* [retval][out] */ long __RPC_FAR *pVal);
01662
01663         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ExtensionNames )(
01664             ICaoController __RPC_FAR * This,
01665             /* [defaultvalue][in] */ BSTR bstrOption,
01666             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01667
01668         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Extensions )(
01669             ICaoController __RPC_FAR * This,
01670             /* [retval][out] */ ICaoExtensions __RPC_FAR *__RPC_FAR *ppICaoExtensions);
01671
01672         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_FileNames )(
01673             ICaoController __RPC_FAR * This,
01674             /* [defaultvalue][in] */ BSTR bstrOption,
01675             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01676
01677         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Files )(
01678             ICaoController __RPC_FAR * This,
01679             /* [retval][out] */ ICaoFiles __RPC_FAR *__RPC_FAR *ppICaoFiles);
01680
01681         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Help )(
01682             ICaoController __RPC_FAR * This,
01683             /* [retval][out] */ BSTR __RPC_FAR *pVal);
01684
01685         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Index )(
01686             ICaoController __RPC_FAR * This,
01687             /* [retval][out] */ long __RPC_FAR *pVal);
01688
01689         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
01690             ICaoController __RPC_FAR * This,
01691             /* [retval][out] */ BSTR __RPC_FAR *pVal);
01692
01693         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_RobotNames )(
01694             ICaoController __RPC_FAR * This,
01695             /* [defaultvalue][in] */ BSTR bstrOption,
01696             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01697
01698         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Robots )(
01699             ICaoController __RPC_FAR * This,
01700             /* [retval][out] */ ICaoRobots __RPC_FAR *__RPC_FAR *ppICaoRobots);
01701
01702         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Tag )(
01703             ICaoController __RPC_FAR * This,
01704             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01705
01706         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Tag )(
01707             ICaoController __RPC_FAR * This,
01708             /* [in] */ VARIANT newVal);
01709
01710         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_TaskNames )(
01711             ICaoController __RPC_FAR * This,
01712             /* [defaultvalue][in] */ BSTR bstrOption,
01713             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01714
01715         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Tasks )(
01716             ICaoController __RPC_FAR * This,
01717             /* [retval][out] */ ICaoTasks __RPC_FAR *__RPC_FAR *ppICaoTasks);
01718
01719         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_VariableNames )(
01720             ICaoController __RPC_FAR * This,
01721             /* [defaultvalue][in] */ BSTR bstrOption,
01722             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01723
01724         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Variables )(
01725             ICaoController __RPC_FAR * This,
01726             /* [retval][out] */ ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables);
01727
01728         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_CommandNames )(
01729             ICaoController __RPC_FAR * This,
01730             /* [defaultvalue][in] */ BSTR bstrOption,
01731             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01732
01733         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Commands )(
01734             ICaoController __RPC_FAR * This,
01735             /* [retval][out] */ ICaoCommands __RPC_FAR *__RPC_FAR *ppICaoCommands);
01736
01737         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ID )(
01738             ICaoController __RPC_FAR * This,
01739             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01740
01741         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ID )(
01742             ICaoController __RPC_FAR * This,
01743             /* [in] */ VARIANT newVal);
01744
01745         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *AddExtension )(
01746             ICaoController __RPC_FAR * This,
01747             /* [in] */ BSTR bstrName,
01748             /* [defaultvalue][in] */ BSTR bstrOption,
01749             /* [retval][out] */ ICaoExtension __RPC_FAR *__RPC_FAR *ppICaoExtension);
01750
01751         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *AddFile )(
01752             ICaoController __RPC_FAR * This,
01753             /* [in] */ BSTR bstrName,
01754             /* [defaultvalue][in] */ BSTR bstrOption,
01755             /* [retval][out] */ ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile);
01756
01757         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *AddRobot )(
01758             ICaoController __RPC_FAR * This,
01759             /* [in] */ BSTR bstrName,
01760             /* [defaultvalue][in] */ BSTR bstrOption,
01761             /* [retval][out] */ ICaoRobot __RPC_FAR *__RPC_FAR *ppICaoRobot);
01762
01763         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *AddTask )(
01764             ICaoController __RPC_FAR * This,
01765             /* [in] */ BSTR bstrName,
01766             /* [defaultvalue][in] */ BSTR bstrOption,
01767             /* [retval][out] */ ICaoTask __RPC_FAR *__RPC_FAR *ppICaoTask);
01768
01769         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *AddVariable )(
01770             ICaoController __RPC_FAR * This,
01771             /* [in] */ BSTR bstrName,
01772             /* [defaultvalue][in] */ BSTR bstrOption,
01773             /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar);
01774
01775         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *AddCommand )(
01776             ICaoController __RPC_FAR * This,
01777             /* [in] */ BSTR bstrName,
01778             /* [defaultvalue][in] */ BSTR bstrOption,
01779             /* [retval][out] */ ICaoCommand __RPC_FAR *__RPC_FAR *ppICaoCommand);
01780
01781         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Execute )(
01782             ICaoController __RPC_FAR * This,
01783             /* [in] */ VARIANT vntCommand,
01784             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01785
01786         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetMessage )(
01787             ICaoController __RPC_FAR * This,
01788             /* [retval][out] */ ICaoMessage __RPC_FAR *__RPC_FAR *ppICaoMessage);
01789
01790         END_INTERFACE
01791     } ICaoControllerVtbl;
01792
01793     interface ICaoController
01794     {
01795         CONST_VTBL struct ICaoControllerVtbl __RPC_FAR *lpVtbl;
01796     };
01797
01798
01799
01800 #ifdef COBJMACROS
01801
01802
01803 #define ICaoController_QueryInterface(This,riid,ppvObject)  \
01804     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
01805
01806 #define ICaoController_AddRef(This) \
01807     (This)->lpVtbl -> AddRef(This)
01808
01809 #define ICaoController_Release(This)    \
01810     (This)->lpVtbl -> Release(This)
01811
01812
01813 #define ICaoController_GetTypeInfoCount(This,pctinfo)   \
01814     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
01815
01816 #define ICaoController_GetTypeInfo(This,iTInfo,lcid,ppTInfo)    \
01817     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
01818
01819 #define ICaoController_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)  \
01820     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
01821
01822 #define ICaoController_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)    \
01823     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
01824
01825
01826 #define ICaoController__PutIndex(This,newVal)   \
01827     (This)->lpVtbl -> _PutIndex(This,newVal)
01828
01829 #define ICaoController_get_Attribute(This,pVal) \
01830     (This)->lpVtbl -> get_Attribute(This,pVal)
01831
01832 #define ICaoController_get_ExtensionNames(This,bstrOption,pVal) \
01833     (This)->lpVtbl -> get_ExtensionNames(This,bstrOption,pVal)
01834
01835 #define ICaoController_get_Extensions(This,ppICaoExtensions)    \
01836     (This)->lpVtbl -> get_Extensions(This,ppICaoExtensions)
01837
01838 #define ICaoController_get_FileNames(This,bstrOption,pVal)  \
01839     (This)->lpVtbl -> get_FileNames(This,bstrOption,pVal)
01840
01841 #define ICaoController_get_Files(This,ppICaoFiles)  \
01842     (This)->lpVtbl -> get_Files(This,ppICaoFiles)
01843
01844 #define ICaoController_get_Help(This,pVal)  \
01845     (This)->lpVtbl -> get_Help(This,pVal)
01846
01847 #define ICaoController_get_Index(This,pVal) \
01848     (This)->lpVtbl -> get_Index(This,pVal)
01849
01850 #define ICaoController_get_Name(This,pVal)  \
01851     (This)->lpVtbl -> get_Name(This,pVal)
01852
01853 #define ICaoController_get_RobotNames(This,bstrOption,pVal) \
01854     (This)->lpVtbl -> get_RobotNames(This,bstrOption,pVal)
01855
01856 #define ICaoController_get_Robots(This,ppICaoRobots)    \
01857     (This)->lpVtbl -> get_Robots(This,ppICaoRobots)
01858
01859 #define ICaoController_get_Tag(This,pVal)   \
01860     (This)->lpVtbl -> get_Tag(This,pVal)
01861
01862 #define ICaoController_put_Tag(This,newVal) \
01863     (This)->lpVtbl -> put_Tag(This,newVal)
01864
01865 #define ICaoController_get_TaskNames(This,bstrOption,pVal)  \
01866     (This)->lpVtbl -> get_TaskNames(This,bstrOption,pVal)
01867
01868 #define ICaoController_get_Tasks(This,ppICaoTasks)  \
01869     (This)->lpVtbl -> get_Tasks(This,ppICaoTasks)
01870
01871 #define ICaoController_get_VariableNames(This,bstrOption,pVal)  \
01872     (This)->lpVtbl -> get_VariableNames(This,bstrOption,pVal)
01873
01874 #define ICaoController_get_Variables(This,ppICaoVariables)  \
01875     (This)->lpVtbl -> get_Variables(This,ppICaoVariables)
01876
01877 #define ICaoController_get_CommandNames(This,bstrOption,pVal)   \
01878     (This)->lpVtbl -> get_CommandNames(This,bstrOption,pVal)
01879
01880 #define ICaoController_get_Commands(This,ppICaoCommands)    \
01881     (This)->lpVtbl -> get_Commands(This,ppICaoCommands)
01882
01883 #define ICaoController_get_ID(This,pVal)    \
01884     (This)->lpVtbl -> get_ID(This,pVal)
01885
01886 #define ICaoController_put_ID(This,newVal)  \
01887     (This)->lpVtbl -> put_ID(This,newVal)
01888
01889 #define ICaoController_AddExtension(This,bstrName,bstrOption,ppICaoExtension)   \
01890     (This)->lpVtbl -> AddExtension(This,bstrName,bstrOption,ppICaoExtension)
01891
01892 #define ICaoController_AddFile(This,bstrName,bstrOption,ppICaoFile) \
01893     (This)->lpVtbl -> AddFile(This,bstrName,bstrOption,ppICaoFile)
01894
01895 #define ICaoController_AddRobot(This,bstrName,bstrOption,ppICaoRobot)   \
01896     (This)->lpVtbl -> AddRobot(This,bstrName,bstrOption,ppICaoRobot)
01897
01898 #define ICaoController_AddTask(This,bstrName,bstrOption,ppICaoTask) \
01899     (This)->lpVtbl -> AddTask(This,bstrName,bstrOption,ppICaoTask)
01900
01901 #define ICaoController_AddVariable(This,bstrName,bstrOption,ppICaoVar)  \
01902     (This)->lpVtbl -> AddVariable(This,bstrName,bstrOption,ppICaoVar)
01903
01904 #define ICaoController_AddCommand(This,bstrName,bstrOption,ppICaoCommand)   \
01905     (This)->lpVtbl -> AddCommand(This,bstrName,bstrOption,ppICaoCommand)
01906
01907 #define ICaoController_Execute(This,vntCommand,pVal)    \
01908     (This)->lpVtbl -> Execute(This,vntCommand,pVal)
01909
01910 #define ICaoController_GetMessage(This,ppICaoMessage)   \
01911     (This)->lpVtbl -> GetMessage(This,ppICaoMessage)
01912
01913 #endif /* COBJMACROS */
01914
01915
01916 #endif  /* C style interface */
01917
01918
01919
01920 /* [restricted][helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoController__PutIndex_Proxy(
01921     ICaoController __RPC_FAR * This,
01922     /* [in] */ long newVal);
01923
01924
01925 void __RPC_STUB ICaoController__PutIndex_Stub(
01926     IRpcStubBuffer *This,
01927     IRpcChannelBuffer *_pRpcChannelBuffer,
01928     PRPC_MESSAGE _pRpcMessage,
01929     DWORD *_pdwStubPhase);
01930
01931
01932 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_Attribute_Proxy(
01933     ICaoController __RPC_FAR * This,
01934     /* [retval][out] */ long __RPC_FAR *pVal);
01935
01936
01937 void __RPC_STUB ICaoController_get_Attribute_Stub(
01938     IRpcStubBuffer *This,
01939     IRpcChannelBuffer *_pRpcChannelBuffer,
01940     PRPC_MESSAGE _pRpcMessage,
01941     DWORD *_pdwStubPhase);
01942
01943
01944 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_ExtensionNames_Proxy(
01945     ICaoController __RPC_FAR * This,
01946     /* [defaultvalue][in] */ BSTR bstrOption,
01947     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01948
01949
01950 void __RPC_STUB ICaoController_get_ExtensionNames_Stub(
01951     IRpcStubBuffer *This,
01952     IRpcChannelBuffer *_pRpcChannelBuffer,
01953     PRPC_MESSAGE _pRpcMessage,
01954     DWORD *_pdwStubPhase);
01955
01956
01957 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_Extensions_Proxy(
01958     ICaoController __RPC_FAR * This,
01959     /* [retval][out] */ ICaoExtensions __RPC_FAR *__RPC_FAR *ppICaoExtensions);
01960
01961
01962 void __RPC_STUB ICaoController_get_Extensions_Stub(
01963     IRpcStubBuffer *This,
01964     IRpcChannelBuffer *_pRpcChannelBuffer,
01965     PRPC_MESSAGE _pRpcMessage,
01966     DWORD *_pdwStubPhase);
01967
01968
01969 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_FileNames_Proxy(
01970     ICaoController __RPC_FAR * This,
01971     /* [defaultvalue][in] */ BSTR bstrOption,
01972     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
01973
01974
01975 void __RPC_STUB ICaoController_get_FileNames_Stub(
01976     IRpcStubBuffer *This,
01977     IRpcChannelBuffer *_pRpcChannelBuffer,
01978     PRPC_MESSAGE _pRpcMessage,
01979     DWORD *_pdwStubPhase);
01980
01981
01982 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_Files_Proxy(
01983     ICaoController __RPC_FAR * This,
01984     /* [retval][out] */ ICaoFiles __RPC_FAR *__RPC_FAR *ppICaoFiles);
01985
01986
01987 void __RPC_STUB ICaoController_get_Files_Stub(
01988     IRpcStubBuffer *This,
01989     IRpcChannelBuffer *_pRpcChannelBuffer,
01990     PRPC_MESSAGE _pRpcMessage,
01991     DWORD *_pdwStubPhase);
01992
01993
01994 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_Help_Proxy(
01995     ICaoController __RPC_FAR * This,
01996     /* [retval][out] */ BSTR __RPC_FAR *pVal);
01997
01998
01999 void __RPC_STUB ICaoController_get_Help_Stub(
02000     IRpcStubBuffer *This,
02001     IRpcChannelBuffer *_pRpcChannelBuffer,
02002     PRPC_MESSAGE _pRpcMessage,
02003     DWORD *_pdwStubPhase);
02004
02005
02006 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_Index_Proxy(
02007     ICaoController __RPC_FAR * This,
02008     /* [retval][out] */ long __RPC_FAR *pVal);
02009
02010
02011 void __RPC_STUB ICaoController_get_Index_Stub(
02012     IRpcStubBuffer *This,
02013     IRpcChannelBuffer *_pRpcChannelBuffer,
02014     PRPC_MESSAGE _pRpcMessage,
02015     DWORD *_pdwStubPhase);
02016
02017
02018 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_Name_Proxy(
02019     ICaoController __RPC_FAR * This,
02020     /* [retval][out] */ BSTR __RPC_FAR *pVal);
02021
02022
02023 void __RPC_STUB ICaoController_get_Name_Stub(
02024     IRpcStubBuffer *This,
02025     IRpcChannelBuffer *_pRpcChannelBuffer,
02026     PRPC_MESSAGE _pRpcMessage,
02027     DWORD *_pdwStubPhase);
02028
02029
02030 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_RobotNames_Proxy(
02031     ICaoController __RPC_FAR * This,
02032     /* [defaultvalue][in] */ BSTR bstrOption,
02033     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02034
02035
02036 void __RPC_STUB ICaoController_get_RobotNames_Stub(
02037     IRpcStubBuffer *This,
02038     IRpcChannelBuffer *_pRpcChannelBuffer,
02039     PRPC_MESSAGE _pRpcMessage,
02040     DWORD *_pdwStubPhase);
02041
02042
02043 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_Robots_Proxy(
02044     ICaoController __RPC_FAR * This,
02045     /* [retval][out] */ ICaoRobots __RPC_FAR *__RPC_FAR *ppICaoRobots);
02046
02047
02048 void __RPC_STUB ICaoController_get_Robots_Stub(
02049     IRpcStubBuffer *This,
02050     IRpcChannelBuffer *_pRpcChannelBuffer,
02051     PRPC_MESSAGE _pRpcMessage,
02052     DWORD *_pdwStubPhase);
02053
02054
02055 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_Tag_Proxy(
02056     ICaoController __RPC_FAR * This,
02057     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02058
02059
02060 void __RPC_STUB ICaoController_get_Tag_Stub(
02061     IRpcStubBuffer *This,
02062     IRpcChannelBuffer *_pRpcChannelBuffer,
02063     PRPC_MESSAGE _pRpcMessage,
02064     DWORD *_pdwStubPhase);
02065
02066
02067 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoController_put_Tag_Proxy(
02068     ICaoController __RPC_FAR * This,
02069     /* [in] */ VARIANT newVal);
02070
02071
02072 void __RPC_STUB ICaoController_put_Tag_Stub(
02073     IRpcStubBuffer *This,
02074     IRpcChannelBuffer *_pRpcChannelBuffer,
02075     PRPC_MESSAGE _pRpcMessage,
02076     DWORD *_pdwStubPhase);
02077
02078
02079 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_TaskNames_Proxy(
02080     ICaoController __RPC_FAR * This,
02081     /* [defaultvalue][in] */ BSTR bstrOption,
02082     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02083
02084
02085 void __RPC_STUB ICaoController_get_TaskNames_Stub(
02086     IRpcStubBuffer *This,
02087     IRpcChannelBuffer *_pRpcChannelBuffer,
02088     PRPC_MESSAGE _pRpcMessage,
02089     DWORD *_pdwStubPhase);
02090
02091
02092 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_Tasks_Proxy(
02093     ICaoController __RPC_FAR * This,
02094     /* [retval][out] */ ICaoTasks __RPC_FAR *__RPC_FAR *ppICaoTasks);
02095
02096
02097 void __RPC_STUB ICaoController_get_Tasks_Stub(
02098     IRpcStubBuffer *This,
02099     IRpcChannelBuffer *_pRpcChannelBuffer,
02100     PRPC_MESSAGE _pRpcMessage,
02101     DWORD *_pdwStubPhase);
02102
02103
02104 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_VariableNames_Proxy(
02105     ICaoController __RPC_FAR * This,
02106     /* [defaultvalue][in] */ BSTR bstrOption,
02107     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02108
02109
02110 void __RPC_STUB ICaoController_get_VariableNames_Stub(
02111     IRpcStubBuffer *This,
02112     IRpcChannelBuffer *_pRpcChannelBuffer,
02113     PRPC_MESSAGE _pRpcMessage,
02114     DWORD *_pdwStubPhase);
02115
02116
02117 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_Variables_Proxy(
02118     ICaoController __RPC_FAR * This,
02119     /* [retval][out] */ ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables);
02120
02121
02122 void __RPC_STUB ICaoController_get_Variables_Stub(
02123     IRpcStubBuffer *This,
02124     IRpcChannelBuffer *_pRpcChannelBuffer,
02125     PRPC_MESSAGE _pRpcMessage,
02126     DWORD *_pdwStubPhase);
02127
02128
02129 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_CommandNames_Proxy(
02130     ICaoController __RPC_FAR * This,
02131     /* [defaultvalue][in] */ BSTR bstrOption,
02132     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02133
02134
02135 void __RPC_STUB ICaoController_get_CommandNames_Stub(
02136     IRpcStubBuffer *This,
02137     IRpcChannelBuffer *_pRpcChannelBuffer,
02138     PRPC_MESSAGE _pRpcMessage,
02139     DWORD *_pdwStubPhase);
02140
02141
02142 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_Commands_Proxy(
02143     ICaoController __RPC_FAR * This,
02144     /* [retval][out] */ ICaoCommands __RPC_FAR *__RPC_FAR *ppICaoCommands);
02145
02146
02147 void __RPC_STUB ICaoController_get_Commands_Stub(
02148     IRpcStubBuffer *This,
02149     IRpcChannelBuffer *_pRpcChannelBuffer,
02150     PRPC_MESSAGE _pRpcMessage,
02151     DWORD *_pdwStubPhase);
02152
02153
02154 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoController_get_ID_Proxy(
02155     ICaoController __RPC_FAR * This,
02156     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02157
02158
02159 void __RPC_STUB ICaoController_get_ID_Stub(
02160     IRpcStubBuffer *This,
02161     IRpcChannelBuffer *_pRpcChannelBuffer,
02162     PRPC_MESSAGE _pRpcMessage,
02163     DWORD *_pdwStubPhase);
02164
02165
02166 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoController_put_ID_Proxy(
02167     ICaoController __RPC_FAR * This,
02168     /* [in] */ VARIANT newVal);
02169
02170
02171 void __RPC_STUB ICaoController_put_ID_Stub(
02172     IRpcStubBuffer *This,
02173     IRpcChannelBuffer *_pRpcChannelBuffer,
02174     PRPC_MESSAGE _pRpcMessage,
02175     DWORD *_pdwStubPhase);
02176
02177
02178 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoController_AddExtension_Proxy(
02179     ICaoController __RPC_FAR * This,
02180     /* [in] */ BSTR bstrName,
02181     /* [defaultvalue][in] */ BSTR bstrOption,
02182     /* [retval][out] */ ICaoExtension __RPC_FAR *__RPC_FAR *ppICaoExtension);
02183
02184
02185 void __RPC_STUB ICaoController_AddExtension_Stub(
02186     IRpcStubBuffer *This,
02187     IRpcChannelBuffer *_pRpcChannelBuffer,
02188     PRPC_MESSAGE _pRpcMessage,
02189     DWORD *_pdwStubPhase);
02190
02191
02192 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoController_AddFile_Proxy(
02193     ICaoController __RPC_FAR * This,
02194     /* [in] */ BSTR bstrName,
02195     /* [defaultvalue][in] */ BSTR bstrOption,
02196     /* [retval][out] */ ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile);
02197
02198
02199 void __RPC_STUB ICaoController_AddFile_Stub(
02200     IRpcStubBuffer *This,
02201     IRpcChannelBuffer *_pRpcChannelBuffer,
02202     PRPC_MESSAGE _pRpcMessage,
02203     DWORD *_pdwStubPhase);
02204
02205
02206 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoController_AddRobot_Proxy(
02207     ICaoController __RPC_FAR * This,
02208     /* [in] */ BSTR bstrName,
02209     /* [defaultvalue][in] */ BSTR bstrOption,
02210     /* [retval][out] */ ICaoRobot __RPC_FAR *__RPC_FAR *ppICaoRobot);
02211
02212
02213 void __RPC_STUB ICaoController_AddRobot_Stub(
02214     IRpcStubBuffer *This,
02215     IRpcChannelBuffer *_pRpcChannelBuffer,
02216     PRPC_MESSAGE _pRpcMessage,
02217     DWORD *_pdwStubPhase);
02218
02219
02220 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoController_AddTask_Proxy(
02221     ICaoController __RPC_FAR * This,
02222     /* [in] */ BSTR bstrName,
02223     /* [defaultvalue][in] */ BSTR bstrOption,
02224     /* [retval][out] */ ICaoTask __RPC_FAR *__RPC_FAR *ppICaoTask);
02225
02226
02227 void __RPC_STUB ICaoController_AddTask_Stub(
02228     IRpcStubBuffer *This,
02229     IRpcChannelBuffer *_pRpcChannelBuffer,
02230     PRPC_MESSAGE _pRpcMessage,
02231     DWORD *_pdwStubPhase);
02232
02233
02234 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoController_AddVariable_Proxy(
02235     ICaoController __RPC_FAR * This,
02236     /* [in] */ BSTR bstrName,
02237     /* [defaultvalue][in] */ BSTR bstrOption,
02238     /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar);
02239
02240
02241 void __RPC_STUB ICaoController_AddVariable_Stub(
02242     IRpcStubBuffer *This,
02243     IRpcChannelBuffer *_pRpcChannelBuffer,
02244     PRPC_MESSAGE _pRpcMessage,
02245     DWORD *_pdwStubPhase);
02246
02247
02248 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoController_AddCommand_Proxy(
02249     ICaoController __RPC_FAR * This,
02250     /* [in] */ BSTR bstrName,
02251     /* [defaultvalue][in] */ BSTR bstrOption,
02252     /* [retval][out] */ ICaoCommand __RPC_FAR *__RPC_FAR *ppICaoCommand);
02253
02254
02255 void __RPC_STUB ICaoController_AddCommand_Stub(
02256     IRpcStubBuffer *This,
02257     IRpcChannelBuffer *_pRpcChannelBuffer,
02258     PRPC_MESSAGE _pRpcMessage,
02259     DWORD *_pdwStubPhase);
02260
02261
02262 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoController_Execute_Proxy(
02263     ICaoController __RPC_FAR * This,
02264     /* [in] */ VARIANT vntCommand,
02265     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02266
02267
02268 void __RPC_STUB ICaoController_Execute_Stub(
02269     IRpcStubBuffer *This,
02270     IRpcChannelBuffer *_pRpcChannelBuffer,
02271     PRPC_MESSAGE _pRpcMessage,
02272     DWORD *_pdwStubPhase);
02273
02274
02275 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoController_GetMessage_Proxy(
02276     ICaoController __RPC_FAR * This,
02277     /* [retval][out] */ ICaoMessage __RPC_FAR *__RPC_FAR *ppICaoMessage);
02278
02279
02280 void __RPC_STUB ICaoController_GetMessage_Stub(
02281     IRpcStubBuffer *This,
02282     IRpcChannelBuffer *_pRpcChannelBuffer,
02283     PRPC_MESSAGE _pRpcMessage,
02284     DWORD *_pdwStubPhase);
02285
02286
02287
02288 #endif  /* __ICaoController_INTERFACE_DEFINED__ */
02289
02290
02291 #ifndef __ICaoExtensions_INTERFACE_DEFINED__
02292 #define __ICaoExtensions_INTERFACE_DEFINED__
02293
02294 /* interface ICaoExtensions */
02295 /* [unique][helpstring][dual][uuid][object] */
02296
02297
02298 EXTERN_C const IID IID_ICaoExtensions;
02299
02300 #if defined(__cplusplus) && !defined(CINTERFACE)
02301
02302     MIDL_INTERFACE("c5cd2d49-d7b9-4c6d-8d0d-56a566b78042")
02303     ICaoExtensions : public IDispatch
02304     {
02305     public:
02306         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get__NewEnum(
02307             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal) = 0;
02308
02309         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Item(
02310             /* [in] */ VARIANT Index,
02311             /* [retval][out] */ ICaoExtension __RPC_FAR *__RPC_FAR *ppICaoExtension) = 0;
02312
02313         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Count(
02314             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
02315
02316         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Add(
02317             /* [in] */ BSTR bstrName,
02318             /* [defaultvalue][in] */ BSTR bstrOption,
02319             /* [retval][out] */ ICaoExtension __RPC_FAR *__RPC_FAR *ppICaoExtension) = 0;
02320
02321         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Remove(
02322             /* [in] */ VARIANT Index) = 0;
02323
02324         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Clear( void) = 0;
02325
02326         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE IsMember(
02327             /* [in] */ VARIANT Index,
02328             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal) = 0;
02329
02330     };
02331
02332 #else   /* C style interface */
02333
02334     typedef struct ICaoExtensionsVtbl
02335     {
02336         BEGIN_INTERFACE
02337
02338         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
02339             ICaoExtensions __RPC_FAR * This,
02340             /* [in] */ REFIID riid,
02341             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
02342
02343         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
02344             ICaoExtensions __RPC_FAR * This);
02345
02346         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
02347             ICaoExtensions __RPC_FAR * This);
02348
02349         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
02350             ICaoExtensions __RPC_FAR * This,
02351             /* [out] */ UINT __RPC_FAR *pctinfo);
02352
02353         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
02354             ICaoExtensions __RPC_FAR * This,
02355             /* [in] */ UINT iTInfo,
02356             /* [in] */ LCID lcid,
02357             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
02358
02359         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
02360             ICaoExtensions __RPC_FAR * This,
02361             /* [in] */ REFIID riid,
02362             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
02363             /* [in] */ UINT cNames,
02364             /* [in] */ LCID lcid,
02365             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
02366
02367         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
02368             ICaoExtensions __RPC_FAR * This,
02369             /* [in] */ DISPID dispIdMember,
02370             /* [in] */ REFIID riid,
02371             /* [in] */ LCID lcid,
02372             /* [in] */ WORD wFlags,
02373             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
02374             /* [out] */ VARIANT __RPC_FAR *pVarResult,
02375             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
02376             /* [out] */ UINT __RPC_FAR *puArgErr);
02377
02378         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get__NewEnum )(
02379             ICaoExtensions __RPC_FAR * This,
02380             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
02381
02382         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Item )(
02383             ICaoExtensions __RPC_FAR * This,
02384             /* [in] */ VARIANT Index,
02385             /* [retval][out] */ ICaoExtension __RPC_FAR *__RPC_FAR *ppICaoExtension);
02386
02387         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Count )(
02388             ICaoExtensions __RPC_FAR * This,
02389             /* [retval][out] */ long __RPC_FAR *pVal);
02390
02391         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Add )(
02392             ICaoExtensions __RPC_FAR * This,
02393             /* [in] */ BSTR bstrName,
02394             /* [defaultvalue][in] */ BSTR bstrOption,
02395             /* [retval][out] */ ICaoExtension __RPC_FAR *__RPC_FAR *ppICaoExtension);
02396
02397         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Remove )(
02398             ICaoExtensions __RPC_FAR * This,
02399             /* [in] */ VARIANT Index);
02400
02401         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Clear )(
02402             ICaoExtensions __RPC_FAR * This);
02403
02404         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *IsMember )(
02405             ICaoExtensions __RPC_FAR * This,
02406             /* [in] */ VARIANT Index,
02407             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal);
02408
02409         END_INTERFACE
02410     } ICaoExtensionsVtbl;
02411
02412     interface ICaoExtensions
02413     {
02414         CONST_VTBL struct ICaoExtensionsVtbl __RPC_FAR *lpVtbl;
02415     };
02416
02417
02418
02419 #ifdef COBJMACROS
02420
02421
02422 #define ICaoExtensions_QueryInterface(This,riid,ppvObject)  \
02423     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
02424
02425 #define ICaoExtensions_AddRef(This) \
02426     (This)->lpVtbl -> AddRef(This)
02427
02428 #define ICaoExtensions_Release(This)    \
02429     (This)->lpVtbl -> Release(This)
02430
02431
02432 #define ICaoExtensions_GetTypeInfoCount(This,pctinfo)   \
02433     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
02434
02435 #define ICaoExtensions_GetTypeInfo(This,iTInfo,lcid,ppTInfo)    \
02436     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
02437
02438 #define ICaoExtensions_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)  \
02439     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
02440
02441 #define ICaoExtensions_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)    \
02442     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
02443
02444
02445 #define ICaoExtensions_get__NewEnum(This,pVal)  \
02446     (This)->lpVtbl -> get__NewEnum(This,pVal)
02447
02448 #define ICaoExtensions_Item(This,Index,ppICaoExtension) \
02449     (This)->lpVtbl -> Item(This,Index,ppICaoExtension)
02450
02451 #define ICaoExtensions_get_Count(This,pVal) \
02452     (This)->lpVtbl -> get_Count(This,pVal)
02453
02454 #define ICaoExtensions_Add(This,bstrName,bstrOption,ppICaoExtension)    \
02455     (This)->lpVtbl -> Add(This,bstrName,bstrOption,ppICaoExtension)
02456
02457 #define ICaoExtensions_Remove(This,Index)   \
02458     (This)->lpVtbl -> Remove(This,Index)
02459
02460 #define ICaoExtensions_Clear(This)  \
02461     (This)->lpVtbl -> Clear(This)
02462
02463 #define ICaoExtensions_IsMember(This,Index,pVal)    \
02464     (This)->lpVtbl -> IsMember(This,Index,pVal)
02465
02466 #endif /* COBJMACROS */
02467
02468
02469 #endif  /* C style interface */
02470
02471
02472
02473 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoExtensions_get__NewEnum_Proxy(
02474     ICaoExtensions __RPC_FAR * This,
02475     /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
02476
02477
02478 void __RPC_STUB ICaoExtensions_get__NewEnum_Stub(
02479     IRpcStubBuffer *This,
02480     IRpcChannelBuffer *_pRpcChannelBuffer,
02481     PRPC_MESSAGE _pRpcMessage,
02482     DWORD *_pdwStubPhase);
02483
02484
02485 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoExtensions_Item_Proxy(
02486     ICaoExtensions __RPC_FAR * This,
02487     /* [in] */ VARIANT Index,
02488     /* [retval][out] */ ICaoExtension __RPC_FAR *__RPC_FAR *ppICaoExtension);
02489
02490
02491 void __RPC_STUB ICaoExtensions_Item_Stub(
02492     IRpcStubBuffer *This,
02493     IRpcChannelBuffer *_pRpcChannelBuffer,
02494     PRPC_MESSAGE _pRpcMessage,
02495     DWORD *_pdwStubPhase);
02496
02497
02498 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoExtensions_get_Count_Proxy(
02499     ICaoExtensions __RPC_FAR * This,
02500     /* [retval][out] */ long __RPC_FAR *pVal);
02501
02502
02503 void __RPC_STUB ICaoExtensions_get_Count_Stub(
02504     IRpcStubBuffer *This,
02505     IRpcChannelBuffer *_pRpcChannelBuffer,
02506     PRPC_MESSAGE _pRpcMessage,
02507     DWORD *_pdwStubPhase);
02508
02509
02510 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoExtensions_Add_Proxy(
02511     ICaoExtensions __RPC_FAR * This,
02512     /* [in] */ BSTR bstrName,
02513     /* [defaultvalue][in] */ BSTR bstrOption,
02514     /* [retval][out] */ ICaoExtension __RPC_FAR *__RPC_FAR *ppICaoExtension);
02515
02516
02517 void __RPC_STUB ICaoExtensions_Add_Stub(
02518     IRpcStubBuffer *This,
02519     IRpcChannelBuffer *_pRpcChannelBuffer,
02520     PRPC_MESSAGE _pRpcMessage,
02521     DWORD *_pdwStubPhase);
02522
02523
02524 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoExtensions_Remove_Proxy(
02525     ICaoExtensions __RPC_FAR * This,
02526     /* [in] */ VARIANT Index);
02527
02528
02529 void __RPC_STUB ICaoExtensions_Remove_Stub(
02530     IRpcStubBuffer *This,
02531     IRpcChannelBuffer *_pRpcChannelBuffer,
02532     PRPC_MESSAGE _pRpcMessage,
02533     DWORD *_pdwStubPhase);
02534
02535
02536 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoExtensions_Clear_Proxy(
02537     ICaoExtensions __RPC_FAR * This);
02538
02539
02540 void __RPC_STUB ICaoExtensions_Clear_Stub(
02541     IRpcStubBuffer *This,
02542     IRpcChannelBuffer *_pRpcChannelBuffer,
02543     PRPC_MESSAGE _pRpcMessage,
02544     DWORD *_pdwStubPhase);
02545
02546
02547 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoExtensions_IsMember_Proxy(
02548     ICaoExtensions __RPC_FAR * This,
02549     /* [in] */ VARIANT Index,
02550     /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal);
02551
02552
02553 void __RPC_STUB ICaoExtensions_IsMember_Stub(
02554     IRpcStubBuffer *This,
02555     IRpcChannelBuffer *_pRpcChannelBuffer,
02556     PRPC_MESSAGE _pRpcMessage,
02557     DWORD *_pdwStubPhase);
02558
02559
02560
02561 #endif  /* __ICaoExtensions_INTERFACE_DEFINED__ */
02562
02563
02564 #ifndef __ICaoExtension_INTERFACE_DEFINED__
02565 #define __ICaoExtension_INTERFACE_DEFINED__
02566
02567 /* interface ICaoExtension */
02568 /* [unique][helpstring][dual][uuid][object] */
02569
02570
02571 EXTERN_C const IID IID_ICaoExtension;
02572
02573 #if defined(__cplusplus) && !defined(CINTERFACE)
02574
02575     MIDL_INTERFACE("a2e8ab44-325e-4fd8-8e92-55a91d213d19")
02576     ICaoExtension : public IDispatch
02577     {
02578     public:
02579         virtual /* [restricted][helpstring][id] */ HRESULT STDMETHODCALLTYPE _PutIndex(
02580             /* [in] */ long newVal) = 0;
02581
02582         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Attribute(
02583             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
02584
02585         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Help(
02586             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
02587
02588         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Index(
02589             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
02590
02591         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
02592             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
02593
02594         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Tag(
02595             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
02596
02597         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Tag(
02598             /* [in] */ VARIANT newVal) = 0;
02599
02600         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_VariableNames(
02601             /* [defaultvalue][in] */ BSTR bstrOption,
02602             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
02603
02604         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Variables(
02605             /* [retval][out] */ ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables) = 0;
02606
02607         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ID(
02608             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
02609
02610         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ID(
02611             /* [in] */ VARIANT newVal) = 0;
02612
02613         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE AddVariable(
02614             /* [in] */ BSTR bstrName,
02615             /* [defaultvalue][in] */ BSTR bstrOption,
02616             /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar) = 0;
02617
02618         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Execute(
02619             /* [in] */ VARIANT vntCommand,
02620             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
02621
02622     };
02623
02624 #else   /* C style interface */
02625
02626     typedef struct ICaoExtensionVtbl
02627     {
02628         BEGIN_INTERFACE
02629
02630         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
02631             ICaoExtension __RPC_FAR * This,
02632             /* [in] */ REFIID riid,
02633             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
02634
02635         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
02636             ICaoExtension __RPC_FAR * This);
02637
02638         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
02639             ICaoExtension __RPC_FAR * This);
02640
02641         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
02642             ICaoExtension __RPC_FAR * This,
02643             /* [out] */ UINT __RPC_FAR *pctinfo);
02644
02645         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
02646             ICaoExtension __RPC_FAR * This,
02647             /* [in] */ UINT iTInfo,
02648             /* [in] */ LCID lcid,
02649             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
02650
02651         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
02652             ICaoExtension __RPC_FAR * This,
02653             /* [in] */ REFIID riid,
02654             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
02655             /* [in] */ UINT cNames,
02656             /* [in] */ LCID lcid,
02657             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
02658
02659         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
02660             ICaoExtension __RPC_FAR * This,
02661             /* [in] */ DISPID dispIdMember,
02662             /* [in] */ REFIID riid,
02663             /* [in] */ LCID lcid,
02664             /* [in] */ WORD wFlags,
02665             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
02666             /* [out] */ VARIANT __RPC_FAR *pVarResult,
02667             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
02668             /* [out] */ UINT __RPC_FAR *puArgErr);
02669
02670         /* [restricted][helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *_PutIndex )(
02671             ICaoExtension __RPC_FAR * This,
02672             /* [in] */ long newVal);
02673
02674         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Attribute )(
02675             ICaoExtension __RPC_FAR * This,
02676             /* [retval][out] */ long __RPC_FAR *pVal);
02677
02678         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Help )(
02679             ICaoExtension __RPC_FAR * This,
02680             /* [retval][out] */ BSTR __RPC_FAR *pVal);
02681
02682         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Index )(
02683             ICaoExtension __RPC_FAR * This,
02684             /* [retval][out] */ long __RPC_FAR *pVal);
02685
02686         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
02687             ICaoExtension __RPC_FAR * This,
02688             /* [retval][out] */ BSTR __RPC_FAR *pVal);
02689
02690         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Tag )(
02691             ICaoExtension __RPC_FAR * This,
02692             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02693
02694         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Tag )(
02695             ICaoExtension __RPC_FAR * This,
02696             /* [in] */ VARIANT newVal);
02697
02698         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_VariableNames )(
02699             ICaoExtension __RPC_FAR * This,
02700             /* [defaultvalue][in] */ BSTR bstrOption,
02701             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02702
02703         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Variables )(
02704             ICaoExtension __RPC_FAR * This,
02705             /* [retval][out] */ ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables);
02706
02707         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ID )(
02708             ICaoExtension __RPC_FAR * This,
02709             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02710
02711         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ID )(
02712             ICaoExtension __RPC_FAR * This,
02713             /* [in] */ VARIANT newVal);
02714
02715         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *AddVariable )(
02716             ICaoExtension __RPC_FAR * This,
02717             /* [in] */ BSTR bstrName,
02718             /* [defaultvalue][in] */ BSTR bstrOption,
02719             /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar);
02720
02721         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Execute )(
02722             ICaoExtension __RPC_FAR * This,
02723             /* [in] */ VARIANT vntCommand,
02724             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02725
02726         END_INTERFACE
02727     } ICaoExtensionVtbl;
02728
02729     interface ICaoExtension
02730     {
02731         CONST_VTBL struct ICaoExtensionVtbl __RPC_FAR *lpVtbl;
02732     };
02733
02734
02735
02736 #ifdef COBJMACROS
02737
02738
02739 #define ICaoExtension_QueryInterface(This,riid,ppvObject)   \
02740     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
02741
02742 #define ICaoExtension_AddRef(This)  \
02743     (This)->lpVtbl -> AddRef(This)
02744
02745 #define ICaoExtension_Release(This) \
02746     (This)->lpVtbl -> Release(This)
02747
02748
02749 #define ICaoExtension_GetTypeInfoCount(This,pctinfo)    \
02750     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
02751
02752 #define ICaoExtension_GetTypeInfo(This,iTInfo,lcid,ppTInfo) \
02753     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
02754
02755 #define ICaoExtension_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)   \
02756     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
02757
02758 #define ICaoExtension_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr) \
02759     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
02760
02761
02762 #define ICaoExtension__PutIndex(This,newVal)    \
02763     (This)->lpVtbl -> _PutIndex(This,newVal)
02764
02765 #define ICaoExtension_get_Attribute(This,pVal)  \
02766     (This)->lpVtbl -> get_Attribute(This,pVal)
02767
02768 #define ICaoExtension_get_Help(This,pVal)   \
02769     (This)->lpVtbl -> get_Help(This,pVal)
02770
02771 #define ICaoExtension_get_Index(This,pVal)  \
02772     (This)->lpVtbl -> get_Index(This,pVal)
02773
02774 #define ICaoExtension_get_Name(This,pVal)   \
02775     (This)->lpVtbl -> get_Name(This,pVal)
02776
02777 #define ICaoExtension_get_Tag(This,pVal)    \
02778     (This)->lpVtbl -> get_Tag(This,pVal)
02779
02780 #define ICaoExtension_put_Tag(This,newVal)  \
02781     (This)->lpVtbl -> put_Tag(This,newVal)
02782
02783 #define ICaoExtension_get_VariableNames(This,bstrOption,pVal)   \
02784     (This)->lpVtbl -> get_VariableNames(This,bstrOption,pVal)
02785
02786 #define ICaoExtension_get_Variables(This,ppICaoVariables)   \
02787     (This)->lpVtbl -> get_Variables(This,ppICaoVariables)
02788
02789 #define ICaoExtension_get_ID(This,pVal) \
02790     (This)->lpVtbl -> get_ID(This,pVal)
02791
02792 #define ICaoExtension_put_ID(This,newVal)   \
02793     (This)->lpVtbl -> put_ID(This,newVal)
02794
02795 #define ICaoExtension_AddVariable(This,bstrName,bstrOption,ppICaoVar)   \
02796     (This)->lpVtbl -> AddVariable(This,bstrName,bstrOption,ppICaoVar)
02797
02798 #define ICaoExtension_Execute(This,vntCommand,pVal) \
02799     (This)->lpVtbl -> Execute(This,vntCommand,pVal)
02800
02801 #endif /* COBJMACROS */
02802
02803
02804 #endif  /* C style interface */
02805
02806
02807
02808 /* [restricted][helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoExtension__PutIndex_Proxy(
02809     ICaoExtension __RPC_FAR * This,
02810     /* [in] */ long newVal);
02811
02812
02813 void __RPC_STUB ICaoExtension__PutIndex_Stub(
02814     IRpcStubBuffer *This,
02815     IRpcChannelBuffer *_pRpcChannelBuffer,
02816     PRPC_MESSAGE _pRpcMessage,
02817     DWORD *_pdwStubPhase);
02818
02819
02820 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoExtension_get_Attribute_Proxy(
02821     ICaoExtension __RPC_FAR * This,
02822     /* [retval][out] */ long __RPC_FAR *pVal);
02823
02824
02825 void __RPC_STUB ICaoExtension_get_Attribute_Stub(
02826     IRpcStubBuffer *This,
02827     IRpcChannelBuffer *_pRpcChannelBuffer,
02828     PRPC_MESSAGE _pRpcMessage,
02829     DWORD *_pdwStubPhase);
02830
02831
02832 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoExtension_get_Help_Proxy(
02833     ICaoExtension __RPC_FAR * This,
02834     /* [retval][out] */ BSTR __RPC_FAR *pVal);
02835
02836
02837 void __RPC_STUB ICaoExtension_get_Help_Stub(
02838     IRpcStubBuffer *This,
02839     IRpcChannelBuffer *_pRpcChannelBuffer,
02840     PRPC_MESSAGE _pRpcMessage,
02841     DWORD *_pdwStubPhase);
02842
02843
02844 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoExtension_get_Index_Proxy(
02845     ICaoExtension __RPC_FAR * This,
02846     /* [retval][out] */ long __RPC_FAR *pVal);
02847
02848
02849 void __RPC_STUB ICaoExtension_get_Index_Stub(
02850     IRpcStubBuffer *This,
02851     IRpcChannelBuffer *_pRpcChannelBuffer,
02852     PRPC_MESSAGE _pRpcMessage,
02853     DWORD *_pdwStubPhase);
02854
02855
02856 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoExtension_get_Name_Proxy(
02857     ICaoExtension __RPC_FAR * This,
02858     /* [retval][out] */ BSTR __RPC_FAR *pVal);
02859
02860
02861 void __RPC_STUB ICaoExtension_get_Name_Stub(
02862     IRpcStubBuffer *This,
02863     IRpcChannelBuffer *_pRpcChannelBuffer,
02864     PRPC_MESSAGE _pRpcMessage,
02865     DWORD *_pdwStubPhase);
02866
02867
02868 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoExtension_get_Tag_Proxy(
02869     ICaoExtension __RPC_FAR * This,
02870     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02871
02872
02873 void __RPC_STUB ICaoExtension_get_Tag_Stub(
02874     IRpcStubBuffer *This,
02875     IRpcChannelBuffer *_pRpcChannelBuffer,
02876     PRPC_MESSAGE _pRpcMessage,
02877     DWORD *_pdwStubPhase);
02878
02879
02880 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoExtension_put_Tag_Proxy(
02881     ICaoExtension __RPC_FAR * This,
02882     /* [in] */ VARIANT newVal);
02883
02884
02885 void __RPC_STUB ICaoExtension_put_Tag_Stub(
02886     IRpcStubBuffer *This,
02887     IRpcChannelBuffer *_pRpcChannelBuffer,
02888     PRPC_MESSAGE _pRpcMessage,
02889     DWORD *_pdwStubPhase);
02890
02891
02892 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoExtension_get_VariableNames_Proxy(
02893     ICaoExtension __RPC_FAR * This,
02894     /* [defaultvalue][in] */ BSTR bstrOption,
02895     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02896
02897
02898 void __RPC_STUB ICaoExtension_get_VariableNames_Stub(
02899     IRpcStubBuffer *This,
02900     IRpcChannelBuffer *_pRpcChannelBuffer,
02901     PRPC_MESSAGE _pRpcMessage,
02902     DWORD *_pdwStubPhase);
02903
02904
02905 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoExtension_get_Variables_Proxy(
02906     ICaoExtension __RPC_FAR * This,
02907     /* [retval][out] */ ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables);
02908
02909
02910 void __RPC_STUB ICaoExtension_get_Variables_Stub(
02911     IRpcStubBuffer *This,
02912     IRpcChannelBuffer *_pRpcChannelBuffer,
02913     PRPC_MESSAGE _pRpcMessage,
02914     DWORD *_pdwStubPhase);
02915
02916
02917 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoExtension_get_ID_Proxy(
02918     ICaoExtension __RPC_FAR * This,
02919     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02920
02921
02922 void __RPC_STUB ICaoExtension_get_ID_Stub(
02923     IRpcStubBuffer *This,
02924     IRpcChannelBuffer *_pRpcChannelBuffer,
02925     PRPC_MESSAGE _pRpcMessage,
02926     DWORD *_pdwStubPhase);
02927
02928
02929 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoExtension_put_ID_Proxy(
02930     ICaoExtension __RPC_FAR * This,
02931     /* [in] */ VARIANT newVal);
02932
02933
02934 void __RPC_STUB ICaoExtension_put_ID_Stub(
02935     IRpcStubBuffer *This,
02936     IRpcChannelBuffer *_pRpcChannelBuffer,
02937     PRPC_MESSAGE _pRpcMessage,
02938     DWORD *_pdwStubPhase);
02939
02940
02941 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoExtension_AddVariable_Proxy(
02942     ICaoExtension __RPC_FAR * This,
02943     /* [in] */ BSTR bstrName,
02944     /* [defaultvalue][in] */ BSTR bstrOption,
02945     /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar);
02946
02947
02948 void __RPC_STUB ICaoExtension_AddVariable_Stub(
02949     IRpcStubBuffer *This,
02950     IRpcChannelBuffer *_pRpcChannelBuffer,
02951     PRPC_MESSAGE _pRpcMessage,
02952     DWORD *_pdwStubPhase);
02953
02954
02955 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoExtension_Execute_Proxy(
02956     ICaoExtension __RPC_FAR * This,
02957     /* [in] */ VARIANT vntCommand,
02958     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
02959
02960
02961 void __RPC_STUB ICaoExtension_Execute_Stub(
02962     IRpcStubBuffer *This,
02963     IRpcChannelBuffer *_pRpcChannelBuffer,
02964     PRPC_MESSAGE _pRpcMessage,
02965     DWORD *_pdwStubPhase);
02966
02967
02968
02969 #endif  /* __ICaoExtension_INTERFACE_DEFINED__ */
02970
02971
02972 #ifndef __ICaoFiles_INTERFACE_DEFINED__
02973 #define __ICaoFiles_INTERFACE_DEFINED__
02974
02975 /* interface ICaoFiles */
02976 /* [unique][helpstring][dual][uuid][object] */
02977
02978
02979 EXTERN_C const IID IID_ICaoFiles;
02980
02981 #if defined(__cplusplus) && !defined(CINTERFACE)
02982
02983     MIDL_INTERFACE("9f1e5eaf-4c53-4718-9d79-efc3f8758d02")
02984     ICaoFiles : public IDispatch
02985     {
02986     public:
02987         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get__NewEnum(
02988             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal) = 0;
02989
02990         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Item(
02991             /* [in] */ VARIANT Index,
02992             /* [retval][out] */ ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile) = 0;
02993
02994         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Count(
02995             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
02996
02997         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Add(
02998             /* [in] */ BSTR bstrName,
02999             /* [defaultvalue][in] */ BSTR bstrOption,
03000             /* [retval][out] */ ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile) = 0;
03001
03002         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Remove(
03003             /* [in] */ VARIANT Index) = 0;
03004
03005         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Clear( void) = 0;
03006
03007         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE IsMember(
03008             /* [in] */ VARIANT Index,
03009             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal) = 0;
03010
03011     };
03012
03013 #else   /* C style interface */
03014
03015     typedef struct ICaoFilesVtbl
03016     {
03017         BEGIN_INTERFACE
03018
03019         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
03020             ICaoFiles __RPC_FAR * This,
03021             /* [in] */ REFIID riid,
03022             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
03023
03024         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
03025             ICaoFiles __RPC_FAR * This);
03026
03027         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
03028             ICaoFiles __RPC_FAR * This);
03029
03030         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
03031             ICaoFiles __RPC_FAR * This,
03032             /* [out] */ UINT __RPC_FAR *pctinfo);
03033
03034         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
03035             ICaoFiles __RPC_FAR * This,
03036             /* [in] */ UINT iTInfo,
03037             /* [in] */ LCID lcid,
03038             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
03039
03040         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
03041             ICaoFiles __RPC_FAR * This,
03042             /* [in] */ REFIID riid,
03043             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
03044             /* [in] */ UINT cNames,
03045             /* [in] */ LCID lcid,
03046             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
03047
03048         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
03049             ICaoFiles __RPC_FAR * This,
03050             /* [in] */ DISPID dispIdMember,
03051             /* [in] */ REFIID riid,
03052             /* [in] */ LCID lcid,
03053             /* [in] */ WORD wFlags,
03054             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
03055             /* [out] */ VARIANT __RPC_FAR *pVarResult,
03056             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
03057             /* [out] */ UINT __RPC_FAR *puArgErr);
03058
03059         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get__NewEnum )(
03060             ICaoFiles __RPC_FAR * This,
03061             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
03062
03063         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Item )(
03064             ICaoFiles __RPC_FAR * This,
03065             /* [in] */ VARIANT Index,
03066             /* [retval][out] */ ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile);
03067
03068         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Count )(
03069             ICaoFiles __RPC_FAR * This,
03070             /* [retval][out] */ long __RPC_FAR *pVal);
03071
03072         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Add )(
03073             ICaoFiles __RPC_FAR * This,
03074             /* [in] */ BSTR bstrName,
03075             /* [defaultvalue][in] */ BSTR bstrOption,
03076             /* [retval][out] */ ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile);
03077
03078         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Remove )(
03079             ICaoFiles __RPC_FAR * This,
03080             /* [in] */ VARIANT Index);
03081
03082         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Clear )(
03083             ICaoFiles __RPC_FAR * This);
03084
03085         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *IsMember )(
03086             ICaoFiles __RPC_FAR * This,
03087             /* [in] */ VARIANT Index,
03088             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal);
03089
03090         END_INTERFACE
03091     } ICaoFilesVtbl;
03092
03093     interface ICaoFiles
03094     {
03095         CONST_VTBL struct ICaoFilesVtbl __RPC_FAR *lpVtbl;
03096     };
03097
03098
03099
03100 #ifdef COBJMACROS
03101
03102
03103 #define ICaoFiles_QueryInterface(This,riid,ppvObject)   \
03104     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
03105
03106 #define ICaoFiles_AddRef(This)  \
03107     (This)->lpVtbl -> AddRef(This)
03108
03109 #define ICaoFiles_Release(This) \
03110     (This)->lpVtbl -> Release(This)
03111
03112
03113 #define ICaoFiles_GetTypeInfoCount(This,pctinfo)    \
03114     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
03115
03116 #define ICaoFiles_GetTypeInfo(This,iTInfo,lcid,ppTInfo) \
03117     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
03118
03119 #define ICaoFiles_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)   \
03120     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
03121
03122 #define ICaoFiles_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr) \
03123     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
03124
03125
03126 #define ICaoFiles_get__NewEnum(This,pVal)   \
03127     (This)->lpVtbl -> get__NewEnum(This,pVal)
03128
03129 #define ICaoFiles_Item(This,Index,ppICaoFile)   \
03130     (This)->lpVtbl -> Item(This,Index,ppICaoFile)
03131
03132 #define ICaoFiles_get_Count(This,pVal)  \
03133     (This)->lpVtbl -> get_Count(This,pVal)
03134
03135 #define ICaoFiles_Add(This,bstrName,bstrOption,ppICaoFile)  \
03136     (This)->lpVtbl -> Add(This,bstrName,bstrOption,ppICaoFile)
03137
03138 #define ICaoFiles_Remove(This,Index)    \
03139     (This)->lpVtbl -> Remove(This,Index)
03140
03141 #define ICaoFiles_Clear(This)   \
03142     (This)->lpVtbl -> Clear(This)
03143
03144 #define ICaoFiles_IsMember(This,Index,pVal) \
03145     (This)->lpVtbl -> IsMember(This,Index,pVal)
03146
03147 #endif /* COBJMACROS */
03148
03149
03150 #endif  /* C style interface */
03151
03152
03153
03154 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFiles_get__NewEnum_Proxy(
03155     ICaoFiles __RPC_FAR * This,
03156     /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
03157
03158
03159 void __RPC_STUB ICaoFiles_get__NewEnum_Stub(
03160     IRpcStubBuffer *This,
03161     IRpcChannelBuffer *_pRpcChannelBuffer,
03162     PRPC_MESSAGE _pRpcMessage,
03163     DWORD *_pdwStubPhase);
03164
03165
03166 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoFiles_Item_Proxy(
03167     ICaoFiles __RPC_FAR * This,
03168     /* [in] */ VARIANT Index,
03169     /* [retval][out] */ ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile);
03170
03171
03172 void __RPC_STUB ICaoFiles_Item_Stub(
03173     IRpcStubBuffer *This,
03174     IRpcChannelBuffer *_pRpcChannelBuffer,
03175     PRPC_MESSAGE _pRpcMessage,
03176     DWORD *_pdwStubPhase);
03177
03178
03179 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFiles_get_Count_Proxy(
03180     ICaoFiles __RPC_FAR * This,
03181     /* [retval][out] */ long __RPC_FAR *pVal);
03182
03183
03184 void __RPC_STUB ICaoFiles_get_Count_Stub(
03185     IRpcStubBuffer *This,
03186     IRpcChannelBuffer *_pRpcChannelBuffer,
03187     PRPC_MESSAGE _pRpcMessage,
03188     DWORD *_pdwStubPhase);
03189
03190
03191 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoFiles_Add_Proxy(
03192     ICaoFiles __RPC_FAR * This,
03193     /* [in] */ BSTR bstrName,
03194     /* [defaultvalue][in] */ BSTR bstrOption,
03195     /* [retval][out] */ ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile);
03196
03197
03198 void __RPC_STUB ICaoFiles_Add_Stub(
03199     IRpcStubBuffer *This,
03200     IRpcChannelBuffer *_pRpcChannelBuffer,
03201     PRPC_MESSAGE _pRpcMessage,
03202     DWORD *_pdwStubPhase);
03203
03204
03205 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoFiles_Remove_Proxy(
03206     ICaoFiles __RPC_FAR * This,
03207     /* [in] */ VARIANT Index);
03208
03209
03210 void __RPC_STUB ICaoFiles_Remove_Stub(
03211     IRpcStubBuffer *This,
03212     IRpcChannelBuffer *_pRpcChannelBuffer,
03213     PRPC_MESSAGE _pRpcMessage,
03214     DWORD *_pdwStubPhase);
03215
03216
03217 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoFiles_Clear_Proxy(
03218     ICaoFiles __RPC_FAR * This);
03219
03220
03221 void __RPC_STUB ICaoFiles_Clear_Stub(
03222     IRpcStubBuffer *This,
03223     IRpcChannelBuffer *_pRpcChannelBuffer,
03224     PRPC_MESSAGE _pRpcMessage,
03225     DWORD *_pdwStubPhase);
03226
03227
03228 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoFiles_IsMember_Proxy(
03229     ICaoFiles __RPC_FAR * This,
03230     /* [in] */ VARIANT Index,
03231     /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal);
03232
03233
03234 void __RPC_STUB ICaoFiles_IsMember_Stub(
03235     IRpcStubBuffer *This,
03236     IRpcChannelBuffer *_pRpcChannelBuffer,
03237     PRPC_MESSAGE _pRpcMessage,
03238     DWORD *_pdwStubPhase);
03239
03240
03241
03242 #endif  /* __ICaoFiles_INTERFACE_DEFINED__ */
03243
03244
03245 #ifndef __ICaoFile_INTERFACE_DEFINED__
03246 #define __ICaoFile_INTERFACE_DEFINED__
03247
03248 /* interface ICaoFile */
03249 /* [unique][helpstring][dual][uuid][object] */
03250
03251
03252 EXTERN_C const IID IID_ICaoFile;
03253
03254 #if defined(__cplusplus) && !defined(CINTERFACE)
03255
03256     MIDL_INTERFACE("9a4617d6-3e02-499d-a1b9-3d33bca0569f")
03257     ICaoFile : public IDispatch
03258     {
03259     public:
03260         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Value(
03261             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
03262
03263         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Value(
03264             /* [in] */ VARIANT newVal) = 0;
03265
03266         virtual /* [restricted][helpstring][id] */ HRESULT STDMETHODCALLTYPE _PutIndex(
03267             /* [in] */ long newVal) = 0;
03268
03269         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Attribute(
03270             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
03271
03272         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_DateCreated(
03273             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
03274
03275         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_DateLastAccessed(
03276             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
03277
03278         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_DateLastModified(
03279             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
03280
03281         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_FileNames(
03282             /* [defaultvalue][in] */ BSTR bstrOption,
03283             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
03284
03285         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Files(
03286             /* [retval][out] */ ICaoFiles __RPC_FAR *__RPC_FAR *ppICaoFiles) = 0;
03287
03288         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Help(
03289             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
03290
03291         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Index(
03292             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
03293
03294         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
03295             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
03296
03297         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Path(
03298             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
03299
03300         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Size(
03301             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
03302
03303         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Tag(
03304             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
03305
03306         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Tag(
03307             /* [in] */ VARIANT newVal) = 0;
03308
03309         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Type(
03310             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
03311
03312         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_VariableNames(
03313             /* [defaultvalue][in] */ BSTR bstrOption,
03314             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
03315
03316         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Variables(
03317             /* [retval][out] */ ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables) = 0;
03318
03319         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ID(
03320             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
03321
03322         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ID(
03323             /* [in] */ VARIANT newVal) = 0;
03324
03325         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE AddFile(
03326             /* [in] */ BSTR bstrName,
03327             /* [defaultvalue][in] */ BSTR bstrOption,
03328             /* [retval][out] */ ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile) = 0;
03329
03330         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE AddVariable(
03331             /* [in] */ BSTR bstrName,
03332             /* [defaultvalue][in] */ BSTR bstrOption,
03333             /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar) = 0;
03334
03335         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Copy(
03336             /* [in] */ BSTR bstrName,
03337             /* [defaultvalue][in] */ BSTR bstrOption = L"") = 0;
03338
03339         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Delete(
03340             /* [defaultvalue][in] */ BSTR bstrOption = L"") = 0;
03341
03342         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Execute(
03343             /* [in] */ VARIANT vntCommand,
03344             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
03345
03346         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Move(
03347             /* [in] */ BSTR bstrName,
03348             /* [defaultvalue][in] */ BSTR bstrOption = L"") = 0;
03349
03350         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Run(
03351             /* [defaultvalue][in] */ BSTR bstrOption,
03352             /* [retval][out] */ BSTR __RPC_FAR *bstrName) = 0;
03353
03354     };
03355
03356 #else   /* C style interface */
03357
03358     typedef struct ICaoFileVtbl
03359     {
03360         BEGIN_INTERFACE
03361
03362         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
03363             ICaoFile __RPC_FAR * This,
03364             /* [in] */ REFIID riid,
03365             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
03366
03367         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
03368             ICaoFile __RPC_FAR * This);
03369
03370         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
03371             ICaoFile __RPC_FAR * This);
03372
03373         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
03374             ICaoFile __RPC_FAR * This,
03375             /* [out] */ UINT __RPC_FAR *pctinfo);
03376
03377         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
03378             ICaoFile __RPC_FAR * This,
03379             /* [in] */ UINT iTInfo,
03380             /* [in] */ LCID lcid,
03381             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
03382
03383         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
03384             ICaoFile __RPC_FAR * This,
03385             /* [in] */ REFIID riid,
03386             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
03387             /* [in] */ UINT cNames,
03388             /* [in] */ LCID lcid,
03389             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
03390
03391         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
03392             ICaoFile __RPC_FAR * This,
03393             /* [in] */ DISPID dispIdMember,
03394             /* [in] */ REFIID riid,
03395             /* [in] */ LCID lcid,
03396             /* [in] */ WORD wFlags,
03397             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
03398             /* [out] */ VARIANT __RPC_FAR *pVarResult,
03399             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
03400             /* [out] */ UINT __RPC_FAR *puArgErr);
03401
03402         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Value )(
03403             ICaoFile __RPC_FAR * This,
03404             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03405
03406         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Value )(
03407             ICaoFile __RPC_FAR * This,
03408             /* [in] */ VARIANT newVal);
03409
03410         /* [restricted][helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *_PutIndex )(
03411             ICaoFile __RPC_FAR * This,
03412             /* [in] */ long newVal);
03413
03414         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Attribute )(
03415             ICaoFile __RPC_FAR * This,
03416             /* [retval][out] */ long __RPC_FAR *pVal);
03417
03418         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_DateCreated )(
03419             ICaoFile __RPC_FAR * This,
03420             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03421
03422         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_DateLastAccessed )(
03423             ICaoFile __RPC_FAR * This,
03424             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03425
03426         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_DateLastModified )(
03427             ICaoFile __RPC_FAR * This,
03428             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03429
03430         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_FileNames )(
03431             ICaoFile __RPC_FAR * This,
03432             /* [defaultvalue][in] */ BSTR bstrOption,
03433             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03434
03435         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Files )(
03436             ICaoFile __RPC_FAR * This,
03437             /* [retval][out] */ ICaoFiles __RPC_FAR *__RPC_FAR *ppICaoFiles);
03438
03439         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Help )(
03440             ICaoFile __RPC_FAR * This,
03441             /* [retval][out] */ BSTR __RPC_FAR *pVal);
03442
03443         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Index )(
03444             ICaoFile __RPC_FAR * This,
03445             /* [retval][out] */ long __RPC_FAR *pVal);
03446
03447         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
03448             ICaoFile __RPC_FAR * This,
03449             /* [retval][out] */ BSTR __RPC_FAR *pVal);
03450
03451         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Path )(
03452             ICaoFile __RPC_FAR * This,
03453             /* [retval][out] */ BSTR __RPC_FAR *pVal);
03454
03455         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Size )(
03456             ICaoFile __RPC_FAR * This,
03457             /* [retval][out] */ long __RPC_FAR *pVal);
03458
03459         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Tag )(
03460             ICaoFile __RPC_FAR * This,
03461             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03462
03463         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Tag )(
03464             ICaoFile __RPC_FAR * This,
03465             /* [in] */ VARIANT newVal);
03466
03467         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Type )(
03468             ICaoFile __RPC_FAR * This,
03469             /* [retval][out] */ BSTR __RPC_FAR *pVal);
03470
03471         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_VariableNames )(
03472             ICaoFile __RPC_FAR * This,
03473             /* [defaultvalue][in] */ BSTR bstrOption,
03474             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03475
03476         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Variables )(
03477             ICaoFile __RPC_FAR * This,
03478             /* [retval][out] */ ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables);
03479
03480         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ID )(
03481             ICaoFile __RPC_FAR * This,
03482             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03483
03484         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ID )(
03485             ICaoFile __RPC_FAR * This,
03486             /* [in] */ VARIANT newVal);
03487
03488         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *AddFile )(
03489             ICaoFile __RPC_FAR * This,
03490             /* [in] */ BSTR bstrName,
03491             /* [defaultvalue][in] */ BSTR bstrOption,
03492             /* [retval][out] */ ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile);
03493
03494         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *AddVariable )(
03495             ICaoFile __RPC_FAR * This,
03496             /* [in] */ BSTR bstrName,
03497             /* [defaultvalue][in] */ BSTR bstrOption,
03498             /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar);
03499
03500         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Copy )(
03501             ICaoFile __RPC_FAR * This,
03502             /* [in] */ BSTR bstrName,
03503             /* [defaultvalue][in] */ BSTR bstrOption);
03504
03505         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Delete )(
03506             ICaoFile __RPC_FAR * This,
03507             /* [defaultvalue][in] */ BSTR bstrOption);
03508
03509         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Execute )(
03510             ICaoFile __RPC_FAR * This,
03511             /* [in] */ VARIANT vntCommand,
03512             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03513
03514         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Move )(
03515             ICaoFile __RPC_FAR * This,
03516             /* [in] */ BSTR bstrName,
03517             /* [defaultvalue][in] */ BSTR bstrOption);
03518
03519         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Run )(
03520             ICaoFile __RPC_FAR * This,
03521             /* [defaultvalue][in] */ BSTR bstrOption,
03522             /* [retval][out] */ BSTR __RPC_FAR *bstrName);
03523
03524         END_INTERFACE
03525     } ICaoFileVtbl;
03526
03527     interface ICaoFile
03528     {
03529         CONST_VTBL struct ICaoFileVtbl __RPC_FAR *lpVtbl;
03530     };
03531
03532
03533
03534 #ifdef COBJMACROS
03535
03536
03537 #define ICaoFile_QueryInterface(This,riid,ppvObject)    \
03538     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
03539
03540 #define ICaoFile_AddRef(This)   \
03541     (This)->lpVtbl -> AddRef(This)
03542
03543 #define ICaoFile_Release(This)  \
03544     (This)->lpVtbl -> Release(This)
03545
03546
03547 #define ICaoFile_GetTypeInfoCount(This,pctinfo) \
03548     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
03549
03550 #define ICaoFile_GetTypeInfo(This,iTInfo,lcid,ppTInfo)  \
03551     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
03552
03553 #define ICaoFile_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)    \
03554     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
03555
03556 #define ICaoFile_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)  \
03557     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
03558
03559
03560 #define ICaoFile_get_Value(This,pVal)   \
03561     (This)->lpVtbl -> get_Value(This,pVal)
03562
03563 #define ICaoFile_put_Value(This,newVal) \
03564     (This)->lpVtbl -> put_Value(This,newVal)
03565
03566 #define ICaoFile__PutIndex(This,newVal) \
03567     (This)->lpVtbl -> _PutIndex(This,newVal)
03568
03569 #define ICaoFile_get_Attribute(This,pVal)   \
03570     (This)->lpVtbl -> get_Attribute(This,pVal)
03571
03572 #define ICaoFile_get_DateCreated(This,pVal) \
03573     (This)->lpVtbl -> get_DateCreated(This,pVal)
03574
03575 #define ICaoFile_get_DateLastAccessed(This,pVal)    \
03576     (This)->lpVtbl -> get_DateLastAccessed(This,pVal)
03577
03578 #define ICaoFile_get_DateLastModified(This,pVal)    \
03579     (This)->lpVtbl -> get_DateLastModified(This,pVal)
03580
03581 #define ICaoFile_get_FileNames(This,bstrOption,pVal)    \
03582     (This)->lpVtbl -> get_FileNames(This,bstrOption,pVal)
03583
03584 #define ICaoFile_get_Files(This,ppICaoFiles)    \
03585     (This)->lpVtbl -> get_Files(This,ppICaoFiles)
03586
03587 #define ICaoFile_get_Help(This,pVal)    \
03588     (This)->lpVtbl -> get_Help(This,pVal)
03589
03590 #define ICaoFile_get_Index(This,pVal)   \
03591     (This)->lpVtbl -> get_Index(This,pVal)
03592
03593 #define ICaoFile_get_Name(This,pVal)    \
03594     (This)->lpVtbl -> get_Name(This,pVal)
03595
03596 #define ICaoFile_get_Path(This,pVal)    \
03597     (This)->lpVtbl -> get_Path(This,pVal)
03598
03599 #define ICaoFile_get_Size(This,pVal)    \
03600     (This)->lpVtbl -> get_Size(This,pVal)
03601
03602 #define ICaoFile_get_Tag(This,pVal) \
03603     (This)->lpVtbl -> get_Tag(This,pVal)
03604
03605 #define ICaoFile_put_Tag(This,newVal)   \
03606     (This)->lpVtbl -> put_Tag(This,newVal)
03607
03608 #define ICaoFile_get_Type(This,pVal)    \
03609     (This)->lpVtbl -> get_Type(This,pVal)
03610
03611 #define ICaoFile_get_VariableNames(This,bstrOption,pVal)    \
03612     (This)->lpVtbl -> get_VariableNames(This,bstrOption,pVal)
03613
03614 #define ICaoFile_get_Variables(This,ppICaoVariables)    \
03615     (This)->lpVtbl -> get_Variables(This,ppICaoVariables)
03616
03617 #define ICaoFile_get_ID(This,pVal)  \
03618     (This)->lpVtbl -> get_ID(This,pVal)
03619
03620 #define ICaoFile_put_ID(This,newVal)    \
03621     (This)->lpVtbl -> put_ID(This,newVal)
03622
03623 #define ICaoFile_AddFile(This,bstrName,bstrOption,ppICaoFile)   \
03624     (This)->lpVtbl -> AddFile(This,bstrName,bstrOption,ppICaoFile)
03625
03626 #define ICaoFile_AddVariable(This,bstrName,bstrOption,ppICaoVar)    \
03627     (This)->lpVtbl -> AddVariable(This,bstrName,bstrOption,ppICaoVar)
03628
03629 #define ICaoFile_Copy(This,bstrName,bstrOption) \
03630     (This)->lpVtbl -> Copy(This,bstrName,bstrOption)
03631
03632 #define ICaoFile_Delete(This,bstrOption)    \
03633     (This)->lpVtbl -> Delete(This,bstrOption)
03634
03635 #define ICaoFile_Execute(This,vntCommand,pVal)  \
03636     (This)->lpVtbl -> Execute(This,vntCommand,pVal)
03637
03638 #define ICaoFile_Move(This,bstrName,bstrOption) \
03639     (This)->lpVtbl -> Move(This,bstrName,bstrOption)
03640
03641 #define ICaoFile_Run(This,bstrOption,bstrName)  \
03642     (This)->lpVtbl -> Run(This,bstrOption,bstrName)
03643
03644 #endif /* COBJMACROS */
03645
03646
03647 #endif  /* C style interface */
03648
03649
03650
03651 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_Value_Proxy(
03652     ICaoFile __RPC_FAR * This,
03653     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03654
03655
03656 void __RPC_STUB ICaoFile_get_Value_Stub(
03657     IRpcStubBuffer *This,
03658     IRpcChannelBuffer *_pRpcChannelBuffer,
03659     PRPC_MESSAGE _pRpcMessage,
03660     DWORD *_pdwStubPhase);
03661
03662
03663 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoFile_put_Value_Proxy(
03664     ICaoFile __RPC_FAR * This,
03665     /* [in] */ VARIANT newVal);
03666
03667
03668 void __RPC_STUB ICaoFile_put_Value_Stub(
03669     IRpcStubBuffer *This,
03670     IRpcChannelBuffer *_pRpcChannelBuffer,
03671     PRPC_MESSAGE _pRpcMessage,
03672     DWORD *_pdwStubPhase);
03673
03674
03675 /* [restricted][helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoFile__PutIndex_Proxy(
03676     ICaoFile __RPC_FAR * This,
03677     /* [in] */ long newVal);
03678
03679
03680 void __RPC_STUB ICaoFile__PutIndex_Stub(
03681     IRpcStubBuffer *This,
03682     IRpcChannelBuffer *_pRpcChannelBuffer,
03683     PRPC_MESSAGE _pRpcMessage,
03684     DWORD *_pdwStubPhase);
03685
03686
03687 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_Attribute_Proxy(
03688     ICaoFile __RPC_FAR * This,
03689     /* [retval][out] */ long __RPC_FAR *pVal);
03690
03691
03692 void __RPC_STUB ICaoFile_get_Attribute_Stub(
03693     IRpcStubBuffer *This,
03694     IRpcChannelBuffer *_pRpcChannelBuffer,
03695     PRPC_MESSAGE _pRpcMessage,
03696     DWORD *_pdwStubPhase);
03697
03698
03699 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_DateCreated_Proxy(
03700     ICaoFile __RPC_FAR * This,
03701     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03702
03703
03704 void __RPC_STUB ICaoFile_get_DateCreated_Stub(
03705     IRpcStubBuffer *This,
03706     IRpcChannelBuffer *_pRpcChannelBuffer,
03707     PRPC_MESSAGE _pRpcMessage,
03708     DWORD *_pdwStubPhase);
03709
03710
03711 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_DateLastAccessed_Proxy(
03712     ICaoFile __RPC_FAR * This,
03713     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03714
03715
03716 void __RPC_STUB ICaoFile_get_DateLastAccessed_Stub(
03717     IRpcStubBuffer *This,
03718     IRpcChannelBuffer *_pRpcChannelBuffer,
03719     PRPC_MESSAGE _pRpcMessage,
03720     DWORD *_pdwStubPhase);
03721
03722
03723 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_DateLastModified_Proxy(
03724     ICaoFile __RPC_FAR * This,
03725     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03726
03727
03728 void __RPC_STUB ICaoFile_get_DateLastModified_Stub(
03729     IRpcStubBuffer *This,
03730     IRpcChannelBuffer *_pRpcChannelBuffer,
03731     PRPC_MESSAGE _pRpcMessage,
03732     DWORD *_pdwStubPhase);
03733
03734
03735 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_FileNames_Proxy(
03736     ICaoFile __RPC_FAR * This,
03737     /* [defaultvalue][in] */ BSTR bstrOption,
03738     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03739
03740
03741 void __RPC_STUB ICaoFile_get_FileNames_Stub(
03742     IRpcStubBuffer *This,
03743     IRpcChannelBuffer *_pRpcChannelBuffer,
03744     PRPC_MESSAGE _pRpcMessage,
03745     DWORD *_pdwStubPhase);
03746
03747
03748 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_Files_Proxy(
03749     ICaoFile __RPC_FAR * This,
03750     /* [retval][out] */ ICaoFiles __RPC_FAR *__RPC_FAR *ppICaoFiles);
03751
03752
03753 void __RPC_STUB ICaoFile_get_Files_Stub(
03754     IRpcStubBuffer *This,
03755     IRpcChannelBuffer *_pRpcChannelBuffer,
03756     PRPC_MESSAGE _pRpcMessage,
03757     DWORD *_pdwStubPhase);
03758
03759
03760 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_Help_Proxy(
03761     ICaoFile __RPC_FAR * This,
03762     /* [retval][out] */ BSTR __RPC_FAR *pVal);
03763
03764
03765 void __RPC_STUB ICaoFile_get_Help_Stub(
03766     IRpcStubBuffer *This,
03767     IRpcChannelBuffer *_pRpcChannelBuffer,
03768     PRPC_MESSAGE _pRpcMessage,
03769     DWORD *_pdwStubPhase);
03770
03771
03772 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_Index_Proxy(
03773     ICaoFile __RPC_FAR * This,
03774     /* [retval][out] */ long __RPC_FAR *pVal);
03775
03776
03777 void __RPC_STUB ICaoFile_get_Index_Stub(
03778     IRpcStubBuffer *This,
03779     IRpcChannelBuffer *_pRpcChannelBuffer,
03780     PRPC_MESSAGE _pRpcMessage,
03781     DWORD *_pdwStubPhase);
03782
03783
03784 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_Name_Proxy(
03785     ICaoFile __RPC_FAR * This,
03786     /* [retval][out] */ BSTR __RPC_FAR *pVal);
03787
03788
03789 void __RPC_STUB ICaoFile_get_Name_Stub(
03790     IRpcStubBuffer *This,
03791     IRpcChannelBuffer *_pRpcChannelBuffer,
03792     PRPC_MESSAGE _pRpcMessage,
03793     DWORD *_pdwStubPhase);
03794
03795
03796 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_Path_Proxy(
03797     ICaoFile __RPC_FAR * This,
03798     /* [retval][out] */ BSTR __RPC_FAR *pVal);
03799
03800
03801 void __RPC_STUB ICaoFile_get_Path_Stub(
03802     IRpcStubBuffer *This,
03803     IRpcChannelBuffer *_pRpcChannelBuffer,
03804     PRPC_MESSAGE _pRpcMessage,
03805     DWORD *_pdwStubPhase);
03806
03807
03808 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_Size_Proxy(
03809     ICaoFile __RPC_FAR * This,
03810     /* [retval][out] */ long __RPC_FAR *pVal);
03811
03812
03813 void __RPC_STUB ICaoFile_get_Size_Stub(
03814     IRpcStubBuffer *This,
03815     IRpcChannelBuffer *_pRpcChannelBuffer,
03816     PRPC_MESSAGE _pRpcMessage,
03817     DWORD *_pdwStubPhase);
03818
03819
03820 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_Tag_Proxy(
03821     ICaoFile __RPC_FAR * This,
03822     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03823
03824
03825 void __RPC_STUB ICaoFile_get_Tag_Stub(
03826     IRpcStubBuffer *This,
03827     IRpcChannelBuffer *_pRpcChannelBuffer,
03828     PRPC_MESSAGE _pRpcMessage,
03829     DWORD *_pdwStubPhase);
03830
03831
03832 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoFile_put_Tag_Proxy(
03833     ICaoFile __RPC_FAR * This,
03834     /* [in] */ VARIANT newVal);
03835
03836
03837 void __RPC_STUB ICaoFile_put_Tag_Stub(
03838     IRpcStubBuffer *This,
03839     IRpcChannelBuffer *_pRpcChannelBuffer,
03840     PRPC_MESSAGE _pRpcMessage,
03841     DWORD *_pdwStubPhase);
03842
03843
03844 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_Type_Proxy(
03845     ICaoFile __RPC_FAR * This,
03846     /* [retval][out] */ BSTR __RPC_FAR *pVal);
03847
03848
03849 void __RPC_STUB ICaoFile_get_Type_Stub(
03850     IRpcStubBuffer *This,
03851     IRpcChannelBuffer *_pRpcChannelBuffer,
03852     PRPC_MESSAGE _pRpcMessage,
03853     DWORD *_pdwStubPhase);
03854
03855
03856 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_VariableNames_Proxy(
03857     ICaoFile __RPC_FAR * This,
03858     /* [defaultvalue][in] */ BSTR bstrOption,
03859     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03860
03861
03862 void __RPC_STUB ICaoFile_get_VariableNames_Stub(
03863     IRpcStubBuffer *This,
03864     IRpcChannelBuffer *_pRpcChannelBuffer,
03865     PRPC_MESSAGE _pRpcMessage,
03866     DWORD *_pdwStubPhase);
03867
03868
03869 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_Variables_Proxy(
03870     ICaoFile __RPC_FAR * This,
03871     /* [retval][out] */ ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables);
03872
03873
03874 void __RPC_STUB ICaoFile_get_Variables_Stub(
03875     IRpcStubBuffer *This,
03876     IRpcChannelBuffer *_pRpcChannelBuffer,
03877     PRPC_MESSAGE _pRpcMessage,
03878     DWORD *_pdwStubPhase);
03879
03880
03881 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoFile_get_ID_Proxy(
03882     ICaoFile __RPC_FAR * This,
03883     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03884
03885
03886 void __RPC_STUB ICaoFile_get_ID_Stub(
03887     IRpcStubBuffer *This,
03888     IRpcChannelBuffer *_pRpcChannelBuffer,
03889     PRPC_MESSAGE _pRpcMessage,
03890     DWORD *_pdwStubPhase);
03891
03892
03893 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoFile_put_ID_Proxy(
03894     ICaoFile __RPC_FAR * This,
03895     /* [in] */ VARIANT newVal);
03896
03897
03898 void __RPC_STUB ICaoFile_put_ID_Stub(
03899     IRpcStubBuffer *This,
03900     IRpcChannelBuffer *_pRpcChannelBuffer,
03901     PRPC_MESSAGE _pRpcMessage,
03902     DWORD *_pdwStubPhase);
03903
03904
03905 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoFile_AddFile_Proxy(
03906     ICaoFile __RPC_FAR * This,
03907     /* [in] */ BSTR bstrName,
03908     /* [defaultvalue][in] */ BSTR bstrOption,
03909     /* [retval][out] */ ICaoFile __RPC_FAR *__RPC_FAR *ppICaoFile);
03910
03911
03912 void __RPC_STUB ICaoFile_AddFile_Stub(
03913     IRpcStubBuffer *This,
03914     IRpcChannelBuffer *_pRpcChannelBuffer,
03915     PRPC_MESSAGE _pRpcMessage,
03916     DWORD *_pdwStubPhase);
03917
03918
03919 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoFile_AddVariable_Proxy(
03920     ICaoFile __RPC_FAR * This,
03921     /* [in] */ BSTR bstrName,
03922     /* [defaultvalue][in] */ BSTR bstrOption,
03923     /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar);
03924
03925
03926 void __RPC_STUB ICaoFile_AddVariable_Stub(
03927     IRpcStubBuffer *This,
03928     IRpcChannelBuffer *_pRpcChannelBuffer,
03929     PRPC_MESSAGE _pRpcMessage,
03930     DWORD *_pdwStubPhase);
03931
03932
03933 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoFile_Copy_Proxy(
03934     ICaoFile __RPC_FAR * This,
03935     /* [in] */ BSTR bstrName,
03936     /* [defaultvalue][in] */ BSTR bstrOption);
03937
03938
03939 void __RPC_STUB ICaoFile_Copy_Stub(
03940     IRpcStubBuffer *This,
03941     IRpcChannelBuffer *_pRpcChannelBuffer,
03942     PRPC_MESSAGE _pRpcMessage,
03943     DWORD *_pdwStubPhase);
03944
03945
03946 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoFile_Delete_Proxy(
03947     ICaoFile __RPC_FAR * This,
03948     /* [defaultvalue][in] */ BSTR bstrOption);
03949
03950
03951 void __RPC_STUB ICaoFile_Delete_Stub(
03952     IRpcStubBuffer *This,
03953     IRpcChannelBuffer *_pRpcChannelBuffer,
03954     PRPC_MESSAGE _pRpcMessage,
03955     DWORD *_pdwStubPhase);
03956
03957
03958 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoFile_Execute_Proxy(
03959     ICaoFile __RPC_FAR * This,
03960     /* [in] */ VARIANT vntCommand,
03961     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
03962
03963
03964 void __RPC_STUB ICaoFile_Execute_Stub(
03965     IRpcStubBuffer *This,
03966     IRpcChannelBuffer *_pRpcChannelBuffer,
03967     PRPC_MESSAGE _pRpcMessage,
03968     DWORD *_pdwStubPhase);
03969
03970
03971 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoFile_Move_Proxy(
03972     ICaoFile __RPC_FAR * This,
03973     /* [in] */ BSTR bstrName,
03974     /* [defaultvalue][in] */ BSTR bstrOption);
03975
03976
03977 void __RPC_STUB ICaoFile_Move_Stub(
03978     IRpcStubBuffer *This,
03979     IRpcChannelBuffer *_pRpcChannelBuffer,
03980     PRPC_MESSAGE _pRpcMessage,
03981     DWORD *_pdwStubPhase);
03982
03983
03984 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoFile_Run_Proxy(
03985     ICaoFile __RPC_FAR * This,
03986     /* [defaultvalue][in] */ BSTR bstrOption,
03987     /* [retval][out] */ BSTR __RPC_FAR *bstrName);
03988
03989
03990 void __RPC_STUB ICaoFile_Run_Stub(
03991     IRpcStubBuffer *This,
03992     IRpcChannelBuffer *_pRpcChannelBuffer,
03993     PRPC_MESSAGE _pRpcMessage,
03994     DWORD *_pdwStubPhase);
03995
03996
03997
03998 #endif  /* __ICaoFile_INTERFACE_DEFINED__ */
03999
04000
04001 #ifndef __ICaoRobots_INTERFACE_DEFINED__
04002 #define __ICaoRobots_INTERFACE_DEFINED__
04003
04004 /* interface ICaoRobots */
04005 /* [unique][helpstring][dual][uuid][object] */
04006
04007
04008 EXTERN_C const IID IID_ICaoRobots;
04009
04010 #if defined(__cplusplus) && !defined(CINTERFACE)
04011
04012     MIDL_INTERFACE("76cddba4-09e9-4292-95ef-1a5a85dcbea9")
04013     ICaoRobots : public IDispatch
04014     {
04015     public:
04016         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get__NewEnum(
04017             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal) = 0;
04018
04019         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Item(
04020             /* [in] */ VARIANT Index,
04021             /* [retval][out] */ ICaoRobot __RPC_FAR *__RPC_FAR *ppICaoRobot) = 0;
04022
04023         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Count(
04024             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
04025
04026         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Add(
04027             /* [in] */ BSTR bstrName,
04028             /* [defaultvalue][in] */ BSTR bstrOption,
04029             /* [retval][out] */ ICaoRobot __RPC_FAR *__RPC_FAR *ppICaoRobot) = 0;
04030
04031         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Remove(
04032             /* [in] */ VARIANT Index) = 0;
04033
04034         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Clear( void) = 0;
04035
04036         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE IsMember(
04037             /* [in] */ VARIANT Index,
04038             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal) = 0;
04039
04040     };
04041
04042 #else   /* C style interface */
04043
04044     typedef struct ICaoRobotsVtbl
04045     {
04046         BEGIN_INTERFACE
04047
04048         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
04049             ICaoRobots __RPC_FAR * This,
04050             /* [in] */ REFIID riid,
04051             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
04052
04053         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
04054             ICaoRobots __RPC_FAR * This);
04055
04056         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
04057             ICaoRobots __RPC_FAR * This);
04058
04059         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
04060             ICaoRobots __RPC_FAR * This,
04061             /* [out] */ UINT __RPC_FAR *pctinfo);
04062
04063         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
04064             ICaoRobots __RPC_FAR * This,
04065             /* [in] */ UINT iTInfo,
04066             /* [in] */ LCID lcid,
04067             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
04068
04069         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
04070             ICaoRobots __RPC_FAR * This,
04071             /* [in] */ REFIID riid,
04072             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
04073             /* [in] */ UINT cNames,
04074             /* [in] */ LCID lcid,
04075             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
04076
04077         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
04078             ICaoRobots __RPC_FAR * This,
04079             /* [in] */ DISPID dispIdMember,
04080             /* [in] */ REFIID riid,
04081             /* [in] */ LCID lcid,
04082             /* [in] */ WORD wFlags,
04083             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
04084             /* [out] */ VARIANT __RPC_FAR *pVarResult,
04085             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
04086             /* [out] */ UINT __RPC_FAR *puArgErr);
04087
04088         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get__NewEnum )(
04089             ICaoRobots __RPC_FAR * This,
04090             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
04091
04092         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Item )(
04093             ICaoRobots __RPC_FAR * This,
04094             /* [in] */ VARIANT Index,
04095             /* [retval][out] */ ICaoRobot __RPC_FAR *__RPC_FAR *ppICaoRobot);
04096
04097         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Count )(
04098             ICaoRobots __RPC_FAR * This,
04099             /* [retval][out] */ long __RPC_FAR *pVal);
04100
04101         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Add )(
04102             ICaoRobots __RPC_FAR * This,
04103             /* [in] */ BSTR bstrName,
04104             /* [defaultvalue][in] */ BSTR bstrOption,
04105             /* [retval][out] */ ICaoRobot __RPC_FAR *__RPC_FAR *ppICaoRobot);
04106
04107         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Remove )(
04108             ICaoRobots __RPC_FAR * This,
04109             /* [in] */ VARIANT Index);
04110
04111         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Clear )(
04112             ICaoRobots __RPC_FAR * This);
04113
04114         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *IsMember )(
04115             ICaoRobots __RPC_FAR * This,
04116             /* [in] */ VARIANT Index,
04117             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal);
04118
04119         END_INTERFACE
04120     } ICaoRobotsVtbl;
04121
04122     interface ICaoRobots
04123     {
04124         CONST_VTBL struct ICaoRobotsVtbl __RPC_FAR *lpVtbl;
04125     };
04126
04127
04128
04129 #ifdef COBJMACROS
04130
04131
04132 #define ICaoRobots_QueryInterface(This,riid,ppvObject)  \
04133     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
04134
04135 #define ICaoRobots_AddRef(This) \
04136     (This)->lpVtbl -> AddRef(This)
04137
04138 #define ICaoRobots_Release(This)    \
04139     (This)->lpVtbl -> Release(This)
04140
04141
04142 #define ICaoRobots_GetTypeInfoCount(This,pctinfo)   \
04143     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
04144
04145 #define ICaoRobots_GetTypeInfo(This,iTInfo,lcid,ppTInfo)    \
04146     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
04147
04148 #define ICaoRobots_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)  \
04149     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
04150
04151 #define ICaoRobots_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)    \
04152     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
04153
04154
04155 #define ICaoRobots_get__NewEnum(This,pVal)  \
04156     (This)->lpVtbl -> get__NewEnum(This,pVal)
04157
04158 #define ICaoRobots_Item(This,Index,ppICaoRobot) \
04159     (This)->lpVtbl -> Item(This,Index,ppICaoRobot)
04160
04161 #define ICaoRobots_get_Count(This,pVal) \
04162     (This)->lpVtbl -> get_Count(This,pVal)
04163
04164 #define ICaoRobots_Add(This,bstrName,bstrOption,ppICaoRobot)    \
04165     (This)->lpVtbl -> Add(This,bstrName,bstrOption,ppICaoRobot)
04166
04167 #define ICaoRobots_Remove(This,Index)   \
04168     (This)->lpVtbl -> Remove(This,Index)
04169
04170 #define ICaoRobots_Clear(This)  \
04171     (This)->lpVtbl -> Clear(This)
04172
04173 #define ICaoRobots_IsMember(This,Index,pVal)    \
04174     (This)->lpVtbl -> IsMember(This,Index,pVal)
04175
04176 #endif /* COBJMACROS */
04177
04178
04179 #endif  /* C style interface */
04180
04181
04182
04183 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoRobots_get__NewEnum_Proxy(
04184     ICaoRobots __RPC_FAR * This,
04185     /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
04186
04187
04188 void __RPC_STUB ICaoRobots_get__NewEnum_Stub(
04189     IRpcStubBuffer *This,
04190     IRpcChannelBuffer *_pRpcChannelBuffer,
04191     PRPC_MESSAGE _pRpcMessage,
04192     DWORD *_pdwStubPhase);
04193
04194
04195 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobots_Item_Proxy(
04196     ICaoRobots __RPC_FAR * This,
04197     /* [in] */ VARIANT Index,
04198     /* [retval][out] */ ICaoRobot __RPC_FAR *__RPC_FAR *ppICaoRobot);
04199
04200
04201 void __RPC_STUB ICaoRobots_Item_Stub(
04202     IRpcStubBuffer *This,
04203     IRpcChannelBuffer *_pRpcChannelBuffer,
04204     PRPC_MESSAGE _pRpcMessage,
04205     DWORD *_pdwStubPhase);
04206
04207
04208 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoRobots_get_Count_Proxy(
04209     ICaoRobots __RPC_FAR * This,
04210     /* [retval][out] */ long __RPC_FAR *pVal);
04211
04212
04213 void __RPC_STUB ICaoRobots_get_Count_Stub(
04214     IRpcStubBuffer *This,
04215     IRpcChannelBuffer *_pRpcChannelBuffer,
04216     PRPC_MESSAGE _pRpcMessage,
04217     DWORD *_pdwStubPhase);
04218
04219
04220 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobots_Add_Proxy(
04221     ICaoRobots __RPC_FAR * This,
04222     /* [in] */ BSTR bstrName,
04223     /* [defaultvalue][in] */ BSTR bstrOption,
04224     /* [retval][out] */ ICaoRobot __RPC_FAR *__RPC_FAR *ppICaoRobot);
04225
04226
04227 void __RPC_STUB ICaoRobots_Add_Stub(
04228     IRpcStubBuffer *This,
04229     IRpcChannelBuffer *_pRpcChannelBuffer,
04230     PRPC_MESSAGE _pRpcMessage,
04231     DWORD *_pdwStubPhase);
04232
04233
04234 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobots_Remove_Proxy(
04235     ICaoRobots __RPC_FAR * This,
04236     /* [in] */ VARIANT Index);
04237
04238
04239 void __RPC_STUB ICaoRobots_Remove_Stub(
04240     IRpcStubBuffer *This,
04241     IRpcChannelBuffer *_pRpcChannelBuffer,
04242     PRPC_MESSAGE _pRpcMessage,
04243     DWORD *_pdwStubPhase);
04244
04245
04246 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobots_Clear_Proxy(
04247     ICaoRobots __RPC_FAR * This);
04248
04249
04250 void __RPC_STUB ICaoRobots_Clear_Stub(
04251     IRpcStubBuffer *This,
04252     IRpcChannelBuffer *_pRpcChannelBuffer,
04253     PRPC_MESSAGE _pRpcMessage,
04254     DWORD *_pdwStubPhase);
04255
04256
04257 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobots_IsMember_Proxy(
04258     ICaoRobots __RPC_FAR * This,
04259     /* [in] */ VARIANT Index,
04260     /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal);
04261
04262
04263 void __RPC_STUB ICaoRobots_IsMember_Stub(
04264     IRpcStubBuffer *This,
04265     IRpcChannelBuffer *_pRpcChannelBuffer,
04266     PRPC_MESSAGE _pRpcMessage,
04267     DWORD *_pdwStubPhase);
04268
04269
04270
04271 #endif  /* __ICaoRobots_INTERFACE_DEFINED__ */
04272
04273
04274 #ifndef __ICaoRobot_INTERFACE_DEFINED__
04275 #define __ICaoRobot_INTERFACE_DEFINED__
04276
04277 /* interface ICaoRobot */
04278 /* [unique][helpstring][dual][uuid][object] */
04279
04280
04281 EXTERN_C const IID IID_ICaoRobot;
04282
04283 #if defined(__cplusplus) && !defined(CINTERFACE)
04284
04285     MIDL_INTERFACE("02105032-6ae1-4251-a72f-9aadc04f6659")
04286     ICaoRobot : public IDispatch
04287     {
04288     public:
04289         virtual /* [restricted][helpstring][id] */ HRESULT STDMETHODCALLTYPE _PutIndex(
04290             /* [in] */ long newVal) = 0;
04291
04292         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Attribute(
04293             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
04294
04295         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Help(
04296             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
04297
04298         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Index(
04299             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
04300
04301         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
04302             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
04303
04304         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Tag(
04305             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
04306
04307         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Tag(
04308             /* [in] */ VARIANT newVal) = 0;
04309
04310         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_VariableNames(
04311             /* [defaultvalue][in] */ BSTR bstrOption,
04312             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
04313
04314         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Variables(
04315             /* [retval][out] */ ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables) = 0;
04316
04317         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ID(
04318             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
04319
04320         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ID(
04321             /* [in] */ VARIANT newVal) = 0;
04322
04323         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Accelerate(
04324             /* [in] */ long lAxis,
04325             /* [in] */ float fAccel,
04326             /* [defaultvalue][in] */ float fDecel = 0) = 0;
04327
04328         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE AddVariable(
04329             /* [in] */ BSTR bstrName,
04330             /* [defaultvalue][in] */ BSTR bstrOption,
04331             /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar) = 0;
04332
04333         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Change(
04334             /* [in] */ BSTR bstrName) = 0;
04335
04336         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Chuck(
04337             /* [defaultvalue][in] */ BSTR bstrOption = L"") = 0;
04338
04339         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Drive(
04340             /* [in] */ long lNo,
04341             /* [in] */ float fMov,
04342             /* [defaultvalue][in] */ BSTR bstrOpt = L"") = 0;
04343
04344         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Execute(
04345             /* [in] */ VARIANT vntCommand,
04346             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
04347
04348         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE GoHome( void) = 0;
04349
04350         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Halt(
04351             /* [defaultvalue][in] */ BSTR bstrOption = L"") = 0;
04352
04353         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Hold(
04354             /* [defaultvalue][in] */ BSTR bstrOption = L"") = 0;
04355
04356         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Move(
04357             /* [in] */ long lComp,
04358             /* [in] */ VARIANT vntPose,
04359             /* [defaultvalue][in] */ BSTR bstrOpt = L"") = 0;
04360
04361         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Rotate(
04362             /* [in] */ VARIANT vntRotSuf,
04363             /* [in] */ float fDeg,
04364             /* [in] */ VARIANT vntPivot,
04365             /* [defaultvalue][in] */ BSTR bstrOpt = L"") = 0;
04366
04367         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Speed(
04368             /* [in] */ long lAxis,
04369             /* [in] */ float fSpeed) = 0;
04370
04371         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Unchuck(
04372             /* [defaultvalue][in] */ BSTR bstrOption = L"") = 0;
04373
04374         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Unhold(
04375             /* [defaultvalue][in] */ BSTR bstrOption = L"") = 0;
04376
04377     };
04378
04379 #else   /* C style interface */
04380
04381     typedef struct ICaoRobotVtbl
04382     {
04383         BEGIN_INTERFACE
04384
04385         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
04386             ICaoRobot __RPC_FAR * This,
04387             /* [in] */ REFIID riid,
04388             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
04389
04390         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
04391             ICaoRobot __RPC_FAR * This);
04392
04393         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
04394             ICaoRobot __RPC_FAR * This);
04395
04396         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
04397             ICaoRobot __RPC_FAR * This,
04398             /* [out] */ UINT __RPC_FAR *pctinfo);
04399
04400         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
04401             ICaoRobot __RPC_FAR * This,
04402             /* [in] */ UINT iTInfo,
04403             /* [in] */ LCID lcid,
04404             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
04405
04406         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
04407             ICaoRobot __RPC_FAR * This,
04408             /* [in] */ REFIID riid,
04409             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
04410             /* [in] */ UINT cNames,
04411             /* [in] */ LCID lcid,
04412             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
04413
04414         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
04415             ICaoRobot __RPC_FAR * This,
04416             /* [in] */ DISPID dispIdMember,
04417             /* [in] */ REFIID riid,
04418             /* [in] */ LCID lcid,
04419             /* [in] */ WORD wFlags,
04420             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
04421             /* [out] */ VARIANT __RPC_FAR *pVarResult,
04422             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
04423             /* [out] */ UINT __RPC_FAR *puArgErr);
04424
04425         /* [restricted][helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *_PutIndex )(
04426             ICaoRobot __RPC_FAR * This,
04427             /* [in] */ long newVal);
04428
04429         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Attribute )(
04430             ICaoRobot __RPC_FAR * This,
04431             /* [retval][out] */ long __RPC_FAR *pVal);
04432
04433         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Help )(
04434             ICaoRobot __RPC_FAR * This,
04435             /* [retval][out] */ BSTR __RPC_FAR *pVal);
04436
04437         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Index )(
04438             ICaoRobot __RPC_FAR * This,
04439             /* [retval][out] */ long __RPC_FAR *pVal);
04440
04441         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
04442             ICaoRobot __RPC_FAR * This,
04443             /* [retval][out] */ BSTR __RPC_FAR *pVal);
04444
04445         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Tag )(
04446             ICaoRobot __RPC_FAR * This,
04447             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04448
04449         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Tag )(
04450             ICaoRobot __RPC_FAR * This,
04451             /* [in] */ VARIANT newVal);
04452
04453         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_VariableNames )(
04454             ICaoRobot __RPC_FAR * This,
04455             /* [defaultvalue][in] */ BSTR bstrOption,
04456             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04457
04458         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Variables )(
04459             ICaoRobot __RPC_FAR * This,
04460             /* [retval][out] */ ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables);
04461
04462         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ID )(
04463             ICaoRobot __RPC_FAR * This,
04464             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04465
04466         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ID )(
04467             ICaoRobot __RPC_FAR * This,
04468             /* [in] */ VARIANT newVal);
04469
04470         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Accelerate )(
04471             ICaoRobot __RPC_FAR * This,
04472             /* [in] */ long lAxis,
04473             /* [in] */ float fAccel,
04474             /* [defaultvalue][in] */ float fDecel);
04475
04476         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *AddVariable )(
04477             ICaoRobot __RPC_FAR * This,
04478             /* [in] */ BSTR bstrName,
04479             /* [defaultvalue][in] */ BSTR bstrOption,
04480             /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar);
04481
04482         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Change )(
04483             ICaoRobot __RPC_FAR * This,
04484             /* [in] */ BSTR bstrName);
04485
04486         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Chuck )(
04487             ICaoRobot __RPC_FAR * This,
04488             /* [defaultvalue][in] */ BSTR bstrOption);
04489
04490         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Drive )(
04491             ICaoRobot __RPC_FAR * This,
04492             /* [in] */ long lNo,
04493             /* [in] */ float fMov,
04494             /* [defaultvalue][in] */ BSTR bstrOpt);
04495
04496         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Execute )(
04497             ICaoRobot __RPC_FAR * This,
04498             /* [in] */ VARIANT vntCommand,
04499             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04500
04501         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GoHome )(
04502             ICaoRobot __RPC_FAR * This);
04503
04504         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Halt )(
04505             ICaoRobot __RPC_FAR * This,
04506             /* [defaultvalue][in] */ BSTR bstrOption);
04507
04508         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Hold )(
04509             ICaoRobot __RPC_FAR * This,
04510             /* [defaultvalue][in] */ BSTR bstrOption);
04511
04512         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Move )(
04513             ICaoRobot __RPC_FAR * This,
04514             /* [in] */ long lComp,
04515             /* [in] */ VARIANT vntPose,
04516             /* [defaultvalue][in] */ BSTR bstrOpt);
04517
04518         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Rotate )(
04519             ICaoRobot __RPC_FAR * This,
04520             /* [in] */ VARIANT vntRotSuf,
04521             /* [in] */ float fDeg,
04522             /* [in] */ VARIANT vntPivot,
04523             /* [defaultvalue][in] */ BSTR bstrOpt);
04524
04525         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Speed )(
04526             ICaoRobot __RPC_FAR * This,
04527             /* [in] */ long lAxis,
04528             /* [in] */ float fSpeed);
04529
04530         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Unchuck )(
04531             ICaoRobot __RPC_FAR * This,
04532             /* [defaultvalue][in] */ BSTR bstrOption);
04533
04534         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Unhold )(
04535             ICaoRobot __RPC_FAR * This,
04536             /* [defaultvalue][in] */ BSTR bstrOption);
04537
04538         END_INTERFACE
04539     } ICaoRobotVtbl;
04540
04541     interface ICaoRobot
04542     {
04543         CONST_VTBL struct ICaoRobotVtbl __RPC_FAR *lpVtbl;
04544     };
04545
04546
04547
04548 #ifdef COBJMACROS
04549
04550
04551 #define ICaoRobot_QueryInterface(This,riid,ppvObject)   \
04552     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
04553
04554 #define ICaoRobot_AddRef(This)  \
04555     (This)->lpVtbl -> AddRef(This)
04556
04557 #define ICaoRobot_Release(This) \
04558     (This)->lpVtbl -> Release(This)
04559
04560
04561 #define ICaoRobot_GetTypeInfoCount(This,pctinfo)    \
04562     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
04563
04564 #define ICaoRobot_GetTypeInfo(This,iTInfo,lcid,ppTInfo) \
04565     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
04566
04567 #define ICaoRobot_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)   \
04568     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
04569
04570 #define ICaoRobot_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr) \
04571     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
04572
04573
04574 #define ICaoRobot__PutIndex(This,newVal)    \
04575     (This)->lpVtbl -> _PutIndex(This,newVal)
04576
04577 #define ICaoRobot_get_Attribute(This,pVal)  \
04578     (This)->lpVtbl -> get_Attribute(This,pVal)
04579
04580 #define ICaoRobot_get_Help(This,pVal)   \
04581     (This)->lpVtbl -> get_Help(This,pVal)
04582
04583 #define ICaoRobot_get_Index(This,pVal)  \
04584     (This)->lpVtbl -> get_Index(This,pVal)
04585
04586 #define ICaoRobot_get_Name(This,pVal)   \
04587     (This)->lpVtbl -> get_Name(This,pVal)
04588
04589 #define ICaoRobot_get_Tag(This,pVal)    \
04590     (This)->lpVtbl -> get_Tag(This,pVal)
04591
04592 #define ICaoRobot_put_Tag(This,newVal)  \
04593     (This)->lpVtbl -> put_Tag(This,newVal)
04594
04595 #define ICaoRobot_get_VariableNames(This,bstrOption,pVal)   \
04596     (This)->lpVtbl -> get_VariableNames(This,bstrOption,pVal)
04597
04598 #define ICaoRobot_get_Variables(This,ppICaoVariables)   \
04599     (This)->lpVtbl -> get_Variables(This,ppICaoVariables)
04600
04601 #define ICaoRobot_get_ID(This,pVal) \
04602     (This)->lpVtbl -> get_ID(This,pVal)
04603
04604 #define ICaoRobot_put_ID(This,newVal)   \
04605     (This)->lpVtbl -> put_ID(This,newVal)
04606
04607 #define ICaoRobot_Accelerate(This,lAxis,fAccel,fDecel)  \
04608     (This)->lpVtbl -> Accelerate(This,lAxis,fAccel,fDecel)
04609
04610 #define ICaoRobot_AddVariable(This,bstrName,bstrOption,ppICaoVar)   \
04611     (This)->lpVtbl -> AddVariable(This,bstrName,bstrOption,ppICaoVar)
04612
04613 #define ICaoRobot_Change(This,bstrName) \
04614     (This)->lpVtbl -> Change(This,bstrName)
04615
04616 #define ICaoRobot_Chuck(This,bstrOption)    \
04617     (This)->lpVtbl -> Chuck(This,bstrOption)
04618
04619 #define ICaoRobot_Drive(This,lNo,fMov,bstrOpt)  \
04620     (This)->lpVtbl -> Drive(This,lNo,fMov,bstrOpt)
04621
04622 #define ICaoRobot_Execute(This,vntCommand,pVal) \
04623     (This)->lpVtbl -> Execute(This,vntCommand,pVal)
04624
04625 #define ICaoRobot_GoHome(This)  \
04626     (This)->lpVtbl -> GoHome(This)
04627
04628 #define ICaoRobot_Halt(This,bstrOption) \
04629     (This)->lpVtbl -> Halt(This,bstrOption)
04630
04631 #define ICaoRobot_Hold(This,bstrOption) \
04632     (This)->lpVtbl -> Hold(This,bstrOption)
04633
04634 #define ICaoRobot_Move(This,lComp,vntPose,bstrOpt)  \
04635     (This)->lpVtbl -> Move(This,lComp,vntPose,bstrOpt)
04636
04637 #define ICaoRobot_Rotate(This,vntRotSuf,fDeg,vntPivot,bstrOpt)  \
04638     (This)->lpVtbl -> Rotate(This,vntRotSuf,fDeg,vntPivot,bstrOpt)
04639
04640 #define ICaoRobot_Speed(This,lAxis,fSpeed)  \
04641     (This)->lpVtbl -> Speed(This,lAxis,fSpeed)
04642
04643 #define ICaoRobot_Unchuck(This,bstrOption)  \
04644     (This)->lpVtbl -> Unchuck(This,bstrOption)
04645
04646 #define ICaoRobot_Unhold(This,bstrOption)   \
04647     (This)->lpVtbl -> Unhold(This,bstrOption)
04648
04649 #endif /* COBJMACROS */
04650
04651
04652 #endif  /* C style interface */
04653
04654
04655
04656 /* [restricted][helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobot__PutIndex_Proxy(
04657     ICaoRobot __RPC_FAR * This,
04658     /* [in] */ long newVal);
04659
04660
04661 void __RPC_STUB ICaoRobot__PutIndex_Stub(
04662     IRpcStubBuffer *This,
04663     IRpcChannelBuffer *_pRpcChannelBuffer,
04664     PRPC_MESSAGE _pRpcMessage,
04665     DWORD *_pdwStubPhase);
04666
04667
04668 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoRobot_get_Attribute_Proxy(
04669     ICaoRobot __RPC_FAR * This,
04670     /* [retval][out] */ long __RPC_FAR *pVal);
04671
04672
04673 void __RPC_STUB ICaoRobot_get_Attribute_Stub(
04674     IRpcStubBuffer *This,
04675     IRpcChannelBuffer *_pRpcChannelBuffer,
04676     PRPC_MESSAGE _pRpcMessage,
04677     DWORD *_pdwStubPhase);
04678
04679
04680 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoRobot_get_Help_Proxy(
04681     ICaoRobot __RPC_FAR * This,
04682     /* [retval][out] */ BSTR __RPC_FAR *pVal);
04683
04684
04685 void __RPC_STUB ICaoRobot_get_Help_Stub(
04686     IRpcStubBuffer *This,
04687     IRpcChannelBuffer *_pRpcChannelBuffer,
04688     PRPC_MESSAGE _pRpcMessage,
04689     DWORD *_pdwStubPhase);
04690
04691
04692 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoRobot_get_Index_Proxy(
04693     ICaoRobot __RPC_FAR * This,
04694     /* [retval][out] */ long __RPC_FAR *pVal);
04695
04696
04697 void __RPC_STUB ICaoRobot_get_Index_Stub(
04698     IRpcStubBuffer *This,
04699     IRpcChannelBuffer *_pRpcChannelBuffer,
04700     PRPC_MESSAGE _pRpcMessage,
04701     DWORD *_pdwStubPhase);
04702
04703
04704 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoRobot_get_Name_Proxy(
04705     ICaoRobot __RPC_FAR * This,
04706     /* [retval][out] */ BSTR __RPC_FAR *pVal);
04707
04708
04709 void __RPC_STUB ICaoRobot_get_Name_Stub(
04710     IRpcStubBuffer *This,
04711     IRpcChannelBuffer *_pRpcChannelBuffer,
04712     PRPC_MESSAGE _pRpcMessage,
04713     DWORD *_pdwStubPhase);
04714
04715
04716 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoRobot_get_Tag_Proxy(
04717     ICaoRobot __RPC_FAR * This,
04718     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04719
04720
04721 void __RPC_STUB ICaoRobot_get_Tag_Stub(
04722     IRpcStubBuffer *This,
04723     IRpcChannelBuffer *_pRpcChannelBuffer,
04724     PRPC_MESSAGE _pRpcMessage,
04725     DWORD *_pdwStubPhase);
04726
04727
04728 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoRobot_put_Tag_Proxy(
04729     ICaoRobot __RPC_FAR * This,
04730     /* [in] */ VARIANT newVal);
04731
04732
04733 void __RPC_STUB ICaoRobot_put_Tag_Stub(
04734     IRpcStubBuffer *This,
04735     IRpcChannelBuffer *_pRpcChannelBuffer,
04736     PRPC_MESSAGE _pRpcMessage,
04737     DWORD *_pdwStubPhase);
04738
04739
04740 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoRobot_get_VariableNames_Proxy(
04741     ICaoRobot __RPC_FAR * This,
04742     /* [defaultvalue][in] */ BSTR bstrOption,
04743     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04744
04745
04746 void __RPC_STUB ICaoRobot_get_VariableNames_Stub(
04747     IRpcStubBuffer *This,
04748     IRpcChannelBuffer *_pRpcChannelBuffer,
04749     PRPC_MESSAGE _pRpcMessage,
04750     DWORD *_pdwStubPhase);
04751
04752
04753 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoRobot_get_Variables_Proxy(
04754     ICaoRobot __RPC_FAR * This,
04755     /* [retval][out] */ ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables);
04756
04757
04758 void __RPC_STUB ICaoRobot_get_Variables_Stub(
04759     IRpcStubBuffer *This,
04760     IRpcChannelBuffer *_pRpcChannelBuffer,
04761     PRPC_MESSAGE _pRpcMessage,
04762     DWORD *_pdwStubPhase);
04763
04764
04765 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoRobot_get_ID_Proxy(
04766     ICaoRobot __RPC_FAR * This,
04767     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04768
04769
04770 void __RPC_STUB ICaoRobot_get_ID_Stub(
04771     IRpcStubBuffer *This,
04772     IRpcChannelBuffer *_pRpcChannelBuffer,
04773     PRPC_MESSAGE _pRpcMessage,
04774     DWORD *_pdwStubPhase);
04775
04776
04777 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoRobot_put_ID_Proxy(
04778     ICaoRobot __RPC_FAR * This,
04779     /* [in] */ VARIANT newVal);
04780
04781
04782 void __RPC_STUB ICaoRobot_put_ID_Stub(
04783     IRpcStubBuffer *This,
04784     IRpcChannelBuffer *_pRpcChannelBuffer,
04785     PRPC_MESSAGE _pRpcMessage,
04786     DWORD *_pdwStubPhase);
04787
04788
04789 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobot_Accelerate_Proxy(
04790     ICaoRobot __RPC_FAR * This,
04791     /* [in] */ long lAxis,
04792     /* [in] */ float fAccel,
04793     /* [defaultvalue][in] */ float fDecel);
04794
04795
04796 void __RPC_STUB ICaoRobot_Accelerate_Stub(
04797     IRpcStubBuffer *This,
04798     IRpcChannelBuffer *_pRpcChannelBuffer,
04799     PRPC_MESSAGE _pRpcMessage,
04800     DWORD *_pdwStubPhase);
04801
04802
04803 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobot_AddVariable_Proxy(
04804     ICaoRobot __RPC_FAR * This,
04805     /* [in] */ BSTR bstrName,
04806     /* [defaultvalue][in] */ BSTR bstrOption,
04807     /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar);
04808
04809
04810 void __RPC_STUB ICaoRobot_AddVariable_Stub(
04811     IRpcStubBuffer *This,
04812     IRpcChannelBuffer *_pRpcChannelBuffer,
04813     PRPC_MESSAGE _pRpcMessage,
04814     DWORD *_pdwStubPhase);
04815
04816
04817 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobot_Change_Proxy(
04818     ICaoRobot __RPC_FAR * This,
04819     /* [in] */ BSTR bstrName);
04820
04821
04822 void __RPC_STUB ICaoRobot_Change_Stub(
04823     IRpcStubBuffer *This,
04824     IRpcChannelBuffer *_pRpcChannelBuffer,
04825     PRPC_MESSAGE _pRpcMessage,
04826     DWORD *_pdwStubPhase);
04827
04828
04829 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobot_Chuck_Proxy(
04830     ICaoRobot __RPC_FAR * This,
04831     /* [defaultvalue][in] */ BSTR bstrOption);
04832
04833
04834 void __RPC_STUB ICaoRobot_Chuck_Stub(
04835     IRpcStubBuffer *This,
04836     IRpcChannelBuffer *_pRpcChannelBuffer,
04837     PRPC_MESSAGE _pRpcMessage,
04838     DWORD *_pdwStubPhase);
04839
04840
04841 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobot_Drive_Proxy(
04842     ICaoRobot __RPC_FAR * This,
04843     /* [in] */ long lNo,
04844     /* [in] */ float fMov,
04845     /* [defaultvalue][in] */ BSTR bstrOpt);
04846
04847
04848 void __RPC_STUB ICaoRobot_Drive_Stub(
04849     IRpcStubBuffer *This,
04850     IRpcChannelBuffer *_pRpcChannelBuffer,
04851     PRPC_MESSAGE _pRpcMessage,
04852     DWORD *_pdwStubPhase);
04853
04854
04855 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobot_Execute_Proxy(
04856     ICaoRobot __RPC_FAR * This,
04857     /* [in] */ VARIANT vntCommand,
04858     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
04859
04860
04861 void __RPC_STUB ICaoRobot_Execute_Stub(
04862     IRpcStubBuffer *This,
04863     IRpcChannelBuffer *_pRpcChannelBuffer,
04864     PRPC_MESSAGE _pRpcMessage,
04865     DWORD *_pdwStubPhase);
04866
04867
04868 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobot_GoHome_Proxy(
04869     ICaoRobot __RPC_FAR * This);
04870
04871
04872 void __RPC_STUB ICaoRobot_GoHome_Stub(
04873     IRpcStubBuffer *This,
04874     IRpcChannelBuffer *_pRpcChannelBuffer,
04875     PRPC_MESSAGE _pRpcMessage,
04876     DWORD *_pdwStubPhase);
04877
04878
04879 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobot_Halt_Proxy(
04880     ICaoRobot __RPC_FAR * This,
04881     /* [defaultvalue][in] */ BSTR bstrOption);
04882
04883
04884 void __RPC_STUB ICaoRobot_Halt_Stub(
04885     IRpcStubBuffer *This,
04886     IRpcChannelBuffer *_pRpcChannelBuffer,
04887     PRPC_MESSAGE _pRpcMessage,
04888     DWORD *_pdwStubPhase);
04889
04890
04891 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobot_Hold_Proxy(
04892     ICaoRobot __RPC_FAR * This,
04893     /* [defaultvalue][in] */ BSTR bstrOption);
04894
04895
04896 void __RPC_STUB ICaoRobot_Hold_Stub(
04897     IRpcStubBuffer *This,
04898     IRpcChannelBuffer *_pRpcChannelBuffer,
04899     PRPC_MESSAGE _pRpcMessage,
04900     DWORD *_pdwStubPhase);
04901
04902
04903 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobot_Move_Proxy(
04904     ICaoRobot __RPC_FAR * This,
04905     /* [in] */ long lComp,
04906     /* [in] */ VARIANT vntPose,
04907     /* [defaultvalue][in] */ BSTR bstrOpt);
04908
04909
04910 void __RPC_STUB ICaoRobot_Move_Stub(
04911     IRpcStubBuffer *This,
04912     IRpcChannelBuffer *_pRpcChannelBuffer,
04913     PRPC_MESSAGE _pRpcMessage,
04914     DWORD *_pdwStubPhase);
04915
04916
04917 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobot_Rotate_Proxy(
04918     ICaoRobot __RPC_FAR * This,
04919     /* [in] */ VARIANT vntRotSuf,
04920     /* [in] */ float fDeg,
04921     /* [in] */ VARIANT vntPivot,
04922     /* [defaultvalue][in] */ BSTR bstrOpt);
04923
04924
04925 void __RPC_STUB ICaoRobot_Rotate_Stub(
04926     IRpcStubBuffer *This,
04927     IRpcChannelBuffer *_pRpcChannelBuffer,
04928     PRPC_MESSAGE _pRpcMessage,
04929     DWORD *_pdwStubPhase);
04930
04931
04932 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobot_Speed_Proxy(
04933     ICaoRobot __RPC_FAR * This,
04934     /* [in] */ long lAxis,
04935     /* [in] */ float fSpeed);
04936
04937
04938 void __RPC_STUB ICaoRobot_Speed_Stub(
04939     IRpcStubBuffer *This,
04940     IRpcChannelBuffer *_pRpcChannelBuffer,
04941     PRPC_MESSAGE _pRpcMessage,
04942     DWORD *_pdwStubPhase);
04943
04944
04945 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobot_Unchuck_Proxy(
04946     ICaoRobot __RPC_FAR * This,
04947     /* [defaultvalue][in] */ BSTR bstrOption);
04948
04949
04950 void __RPC_STUB ICaoRobot_Unchuck_Stub(
04951     IRpcStubBuffer *This,
04952     IRpcChannelBuffer *_pRpcChannelBuffer,
04953     PRPC_MESSAGE _pRpcMessage,
04954     DWORD *_pdwStubPhase);
04955
04956
04957 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoRobot_Unhold_Proxy(
04958     ICaoRobot __RPC_FAR * This,
04959     /* [defaultvalue][in] */ BSTR bstrOption);
04960
04961
04962 void __RPC_STUB ICaoRobot_Unhold_Stub(
04963     IRpcStubBuffer *This,
04964     IRpcChannelBuffer *_pRpcChannelBuffer,
04965     PRPC_MESSAGE _pRpcMessage,
04966     DWORD *_pdwStubPhase);
04967
04968
04969
04970 #endif  /* __ICaoRobot_INTERFACE_DEFINED__ */
04971
04972
04973 #ifndef __ICaoTasks_INTERFACE_DEFINED__
04974 #define __ICaoTasks_INTERFACE_DEFINED__
04975
04976 /* interface ICaoTasks */
04977 /* [unique][helpstring][dual][uuid][object] */
04978
04979
04980 EXTERN_C const IID IID_ICaoTasks;
04981
04982 #if defined(__cplusplus) && !defined(CINTERFACE)
04983
04984     MIDL_INTERFACE("a2a35844-148b-4762-8b41-68015bbc26f7")
04985     ICaoTasks : public IDispatch
04986     {
04987     public:
04988         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get__NewEnum(
04989             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal) = 0;
04990
04991         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Item(
04992             /* [in] */ VARIANT Index,
04993             /* [retval][out] */ ICaoTask __RPC_FAR *__RPC_FAR *ppICaoTask) = 0;
04994
04995         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Count(
04996             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
04997
04998         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Add(
04999             /* [in] */ BSTR bstrName,
05000             /* [defaultvalue][in] */ BSTR bstrOption,
05001             /* [retval][out] */ ICaoTask __RPC_FAR *__RPC_FAR *ppICaoTask) = 0;
05002
05003         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Remove(
05004             /* [in] */ VARIANT Index) = 0;
05005
05006         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Clear( void) = 0;
05007
05008         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE IsMember(
05009             /* [in] */ VARIANT Index,
05010             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal) = 0;
05011
05012     };
05013
05014 #else   /* C style interface */
05015
05016     typedef struct ICaoTasksVtbl
05017     {
05018         BEGIN_INTERFACE
05019
05020         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
05021             ICaoTasks __RPC_FAR * This,
05022             /* [in] */ REFIID riid,
05023             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
05024
05025         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
05026             ICaoTasks __RPC_FAR * This);
05027
05028         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
05029             ICaoTasks __RPC_FAR * This);
05030
05031         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
05032             ICaoTasks __RPC_FAR * This,
05033             /* [out] */ UINT __RPC_FAR *pctinfo);
05034
05035         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
05036             ICaoTasks __RPC_FAR * This,
05037             /* [in] */ UINT iTInfo,
05038             /* [in] */ LCID lcid,
05039             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
05040
05041         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
05042             ICaoTasks __RPC_FAR * This,
05043             /* [in] */ REFIID riid,
05044             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
05045             /* [in] */ UINT cNames,
05046             /* [in] */ LCID lcid,
05047             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
05048
05049         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
05050             ICaoTasks __RPC_FAR * This,
05051             /* [in] */ DISPID dispIdMember,
05052             /* [in] */ REFIID riid,
05053             /* [in] */ LCID lcid,
05054             /* [in] */ WORD wFlags,
05055             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
05056             /* [out] */ VARIANT __RPC_FAR *pVarResult,
05057             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
05058             /* [out] */ UINT __RPC_FAR *puArgErr);
05059
05060         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get__NewEnum )(
05061             ICaoTasks __RPC_FAR * This,
05062             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
05063
05064         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Item )(
05065             ICaoTasks __RPC_FAR * This,
05066             /* [in] */ VARIANT Index,
05067             /* [retval][out] */ ICaoTask __RPC_FAR *__RPC_FAR *ppICaoTask);
05068
05069         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Count )(
05070             ICaoTasks __RPC_FAR * This,
05071             /* [retval][out] */ long __RPC_FAR *pVal);
05072
05073         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Add )(
05074             ICaoTasks __RPC_FAR * This,
05075             /* [in] */ BSTR bstrName,
05076             /* [defaultvalue][in] */ BSTR bstrOption,
05077             /* [retval][out] */ ICaoTask __RPC_FAR *__RPC_FAR *ppICaoTask);
05078
05079         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Remove )(
05080             ICaoTasks __RPC_FAR * This,
05081             /* [in] */ VARIANT Index);
05082
05083         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Clear )(
05084             ICaoTasks __RPC_FAR * This);
05085
05086         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *IsMember )(
05087             ICaoTasks __RPC_FAR * This,
05088             /* [in] */ VARIANT Index,
05089             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal);
05090
05091         END_INTERFACE
05092     } ICaoTasksVtbl;
05093
05094     interface ICaoTasks
05095     {
05096         CONST_VTBL struct ICaoTasksVtbl __RPC_FAR *lpVtbl;
05097     };
05098
05099
05100
05101 #ifdef COBJMACROS
05102
05103
05104 #define ICaoTasks_QueryInterface(This,riid,ppvObject)   \
05105     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
05106
05107 #define ICaoTasks_AddRef(This)  \
05108     (This)->lpVtbl -> AddRef(This)
05109
05110 #define ICaoTasks_Release(This) \
05111     (This)->lpVtbl -> Release(This)
05112
05113
05114 #define ICaoTasks_GetTypeInfoCount(This,pctinfo)    \
05115     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
05116
05117 #define ICaoTasks_GetTypeInfo(This,iTInfo,lcid,ppTInfo) \
05118     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
05119
05120 #define ICaoTasks_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)   \
05121     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
05122
05123 #define ICaoTasks_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr) \
05124     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
05125
05126
05127 #define ICaoTasks_get__NewEnum(This,pVal)   \
05128     (This)->lpVtbl -> get__NewEnum(This,pVal)
05129
05130 #define ICaoTasks_Item(This,Index,ppICaoTask)   \
05131     (This)->lpVtbl -> Item(This,Index,ppICaoTask)
05132
05133 #define ICaoTasks_get_Count(This,pVal)  \
05134     (This)->lpVtbl -> get_Count(This,pVal)
05135
05136 #define ICaoTasks_Add(This,bstrName,bstrOption,ppICaoTask)  \
05137     (This)->lpVtbl -> Add(This,bstrName,bstrOption,ppICaoTask)
05138
05139 #define ICaoTasks_Remove(This,Index)    \
05140     (This)->lpVtbl -> Remove(This,Index)
05141
05142 #define ICaoTasks_Clear(This)   \
05143     (This)->lpVtbl -> Clear(This)
05144
05145 #define ICaoTasks_IsMember(This,Index,pVal) \
05146     (This)->lpVtbl -> IsMember(This,Index,pVal)
05147
05148 #endif /* COBJMACROS */
05149
05150
05151 #endif  /* C style interface */
05152
05153
05154
05155 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoTasks_get__NewEnum_Proxy(
05156     ICaoTasks __RPC_FAR * This,
05157     /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
05158
05159
05160 void __RPC_STUB ICaoTasks_get__NewEnum_Stub(
05161     IRpcStubBuffer *This,
05162     IRpcChannelBuffer *_pRpcChannelBuffer,
05163     PRPC_MESSAGE _pRpcMessage,
05164     DWORD *_pdwStubPhase);
05165
05166
05167 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoTasks_Item_Proxy(
05168     ICaoTasks __RPC_FAR * This,
05169     /* [in] */ VARIANT Index,
05170     /* [retval][out] */ ICaoTask __RPC_FAR *__RPC_FAR *ppICaoTask);
05171
05172
05173 void __RPC_STUB ICaoTasks_Item_Stub(
05174     IRpcStubBuffer *This,
05175     IRpcChannelBuffer *_pRpcChannelBuffer,
05176     PRPC_MESSAGE _pRpcMessage,
05177     DWORD *_pdwStubPhase);
05178
05179
05180 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoTasks_get_Count_Proxy(
05181     ICaoTasks __RPC_FAR * This,
05182     /* [retval][out] */ long __RPC_FAR *pVal);
05183
05184
05185 void __RPC_STUB ICaoTasks_get_Count_Stub(
05186     IRpcStubBuffer *This,
05187     IRpcChannelBuffer *_pRpcChannelBuffer,
05188     PRPC_MESSAGE _pRpcMessage,
05189     DWORD *_pdwStubPhase);
05190
05191
05192 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoTasks_Add_Proxy(
05193     ICaoTasks __RPC_FAR * This,
05194     /* [in] */ BSTR bstrName,
05195     /* [defaultvalue][in] */ BSTR bstrOption,
05196     /* [retval][out] */ ICaoTask __RPC_FAR *__RPC_FAR *ppICaoTask);
05197
05198
05199 void __RPC_STUB ICaoTasks_Add_Stub(
05200     IRpcStubBuffer *This,
05201     IRpcChannelBuffer *_pRpcChannelBuffer,
05202     PRPC_MESSAGE _pRpcMessage,
05203     DWORD *_pdwStubPhase);
05204
05205
05206 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoTasks_Remove_Proxy(
05207     ICaoTasks __RPC_FAR * This,
05208     /* [in] */ VARIANT Index);
05209
05210
05211 void __RPC_STUB ICaoTasks_Remove_Stub(
05212     IRpcStubBuffer *This,
05213     IRpcChannelBuffer *_pRpcChannelBuffer,
05214     PRPC_MESSAGE _pRpcMessage,
05215     DWORD *_pdwStubPhase);
05216
05217
05218 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoTasks_Clear_Proxy(
05219     ICaoTasks __RPC_FAR * This);
05220
05221
05222 void __RPC_STUB ICaoTasks_Clear_Stub(
05223     IRpcStubBuffer *This,
05224     IRpcChannelBuffer *_pRpcChannelBuffer,
05225     PRPC_MESSAGE _pRpcMessage,
05226     DWORD *_pdwStubPhase);
05227
05228
05229 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoTasks_IsMember_Proxy(
05230     ICaoTasks __RPC_FAR * This,
05231     /* [in] */ VARIANT Index,
05232     /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal);
05233
05234
05235 void __RPC_STUB ICaoTasks_IsMember_Stub(
05236     IRpcStubBuffer *This,
05237     IRpcChannelBuffer *_pRpcChannelBuffer,
05238     PRPC_MESSAGE _pRpcMessage,
05239     DWORD *_pdwStubPhase);
05240
05241
05242
05243 #endif  /* __ICaoTasks_INTERFACE_DEFINED__ */
05244
05245
05246 #ifndef __ICaoTask_INTERFACE_DEFINED__
05247 #define __ICaoTask_INTERFACE_DEFINED__
05248
05249 /* interface ICaoTask */
05250 /* [unique][helpstring][dual][uuid][object] */
05251
05252
05253 EXTERN_C const IID IID_ICaoTask;
05254
05255 #if defined(__cplusplus) && !defined(CINTERFACE)
05256
05257     MIDL_INTERFACE("cc23c152-1d58-4c70-bd1b-539fd0329ae2")
05258     ICaoTask : public IDispatch
05259     {
05260     public:
05261         virtual /* [restricted][helpstring][id] */ HRESULT STDMETHODCALLTYPE _PutIndex(
05262             /* [in] */ long newVal) = 0;
05263
05264         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Attribute(
05265             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
05266
05267         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_FileName(
05268             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
05269
05270         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Help(
05271             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
05272
05273         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Index(
05274             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
05275
05276         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
05277             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
05278
05279         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Tag(
05280             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
05281
05282         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Tag(
05283             /* [in] */ VARIANT newVal) = 0;
05284
05285         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_VariableNames(
05286             /* [defaultvalue][in] */ BSTR bstrOption,
05287             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
05288
05289         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Variables(
05290             /* [retval][out] */ ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables) = 0;
05291
05292         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ID(
05293             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
05294
05295         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ID(
05296             /* [in] */ VARIANT newVal) = 0;
05297
05298         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE AddVariable(
05299             /* [in] */ BSTR bstrName,
05300             /* [defaultvalue][in] */ BSTR bstrOption,
05301             /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar) = 0;
05302
05303         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Delete(
05304             /* [defaultvalue][in] */ BSTR bstrOption = L"") = 0;
05305
05306         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Execute(
05307             /* [in] */ VARIANT vntCommand,
05308             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
05309
05310         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Start(
05311             /* [defaultvalue][in] */ long lMode = 0,
05312             /* [defaultvalue][in] */ BSTR bstrOption = L"") = 0;
05313
05314         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Stop(
05315             /* [defaultvalue][in] */ long lMode = 0,
05316             /* [defaultvalue][in] */ BSTR bstrOption = L"") = 0;
05317
05318     };
05319
05320 #else   /* C style interface */
05321
05322     typedef struct ICaoTaskVtbl
05323     {
05324         BEGIN_INTERFACE
05325
05326         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
05327             ICaoTask __RPC_FAR * This,
05328             /* [in] */ REFIID riid,
05329             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
05330
05331         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
05332             ICaoTask __RPC_FAR * This);
05333
05334         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
05335             ICaoTask __RPC_FAR * This);
05336
05337         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
05338             ICaoTask __RPC_FAR * This,
05339             /* [out] */ UINT __RPC_FAR *pctinfo);
05340
05341         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
05342             ICaoTask __RPC_FAR * This,
05343             /* [in] */ UINT iTInfo,
05344             /* [in] */ LCID lcid,
05345             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
05346
05347         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
05348             ICaoTask __RPC_FAR * This,
05349             /* [in] */ REFIID riid,
05350             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
05351             /* [in] */ UINT cNames,
05352             /* [in] */ LCID lcid,
05353             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
05354
05355         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
05356             ICaoTask __RPC_FAR * This,
05357             /* [in] */ DISPID dispIdMember,
05358             /* [in] */ REFIID riid,
05359             /* [in] */ LCID lcid,
05360             /* [in] */ WORD wFlags,
05361             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
05362             /* [out] */ VARIANT __RPC_FAR *pVarResult,
05363             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
05364             /* [out] */ UINT __RPC_FAR *puArgErr);
05365
05366         /* [restricted][helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *_PutIndex )(
05367             ICaoTask __RPC_FAR * This,
05368             /* [in] */ long newVal);
05369
05370         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Attribute )(
05371             ICaoTask __RPC_FAR * This,
05372             /* [retval][out] */ long __RPC_FAR *pVal);
05373
05374         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_FileName )(
05375             ICaoTask __RPC_FAR * This,
05376             /* [retval][out] */ BSTR __RPC_FAR *pVal);
05377
05378         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Help )(
05379             ICaoTask __RPC_FAR * This,
05380             /* [retval][out] */ BSTR __RPC_FAR *pVal);
05381
05382         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Index )(
05383             ICaoTask __RPC_FAR * This,
05384             /* [retval][out] */ long __RPC_FAR *pVal);
05385
05386         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
05387             ICaoTask __RPC_FAR * This,
05388             /* [retval][out] */ BSTR __RPC_FAR *pVal);
05389
05390         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Tag )(
05391             ICaoTask __RPC_FAR * This,
05392             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
05393
05394         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Tag )(
05395             ICaoTask __RPC_FAR * This,
05396             /* [in] */ VARIANT newVal);
05397
05398         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_VariableNames )(
05399             ICaoTask __RPC_FAR * This,
05400             /* [defaultvalue][in] */ BSTR bstrOption,
05401             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
05402
05403         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Variables )(
05404             ICaoTask __RPC_FAR * This,
05405             /* [retval][out] */ ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables);
05406
05407         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ID )(
05408             ICaoTask __RPC_FAR * This,
05409             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
05410
05411         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ID )(
05412             ICaoTask __RPC_FAR * This,
05413             /* [in] */ VARIANT newVal);
05414
05415         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *AddVariable )(
05416             ICaoTask __RPC_FAR * This,
05417             /* [in] */ BSTR bstrName,
05418             /* [defaultvalue][in] */ BSTR bstrOption,
05419             /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar);
05420
05421         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Delete )(
05422             ICaoTask __RPC_FAR * This,
05423             /* [defaultvalue][in] */ BSTR bstrOption);
05424
05425         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Execute )(
05426             ICaoTask __RPC_FAR * This,
05427             /* [in] */ VARIANT vntCommand,
05428             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
05429
05430         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Start )(
05431             ICaoTask __RPC_FAR * This,
05432             /* [defaultvalue][in] */ long lMode,
05433             /* [defaultvalue][in] */ BSTR bstrOption);
05434
05435         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Stop )(
05436             ICaoTask __RPC_FAR * This,
05437             /* [defaultvalue][in] */ long lMode,
05438             /* [defaultvalue][in] */ BSTR bstrOption);
05439
05440         END_INTERFACE
05441     } ICaoTaskVtbl;
05442
05443     interface ICaoTask
05444     {
05445         CONST_VTBL struct ICaoTaskVtbl __RPC_FAR *lpVtbl;
05446     };
05447
05448
05449
05450 #ifdef COBJMACROS
05451
05452
05453 #define ICaoTask_QueryInterface(This,riid,ppvObject)    \
05454     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
05455
05456 #define ICaoTask_AddRef(This)   \
05457     (This)->lpVtbl -> AddRef(This)
05458
05459 #define ICaoTask_Release(This)  \
05460     (This)->lpVtbl -> Release(This)
05461
05462
05463 #define ICaoTask_GetTypeInfoCount(This,pctinfo) \
05464     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
05465
05466 #define ICaoTask_GetTypeInfo(This,iTInfo,lcid,ppTInfo)  \
05467     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
05468
05469 #define ICaoTask_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)    \
05470     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
05471
05472 #define ICaoTask_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)  \
05473     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
05474
05475
05476 #define ICaoTask__PutIndex(This,newVal) \
05477     (This)->lpVtbl -> _PutIndex(This,newVal)
05478
05479 #define ICaoTask_get_Attribute(This,pVal)   \
05480     (This)->lpVtbl -> get_Attribute(This,pVal)
05481
05482 #define ICaoTask_get_FileName(This,pVal)    \
05483     (This)->lpVtbl -> get_FileName(This,pVal)
05484
05485 #define ICaoTask_get_Help(This,pVal)    \
05486     (This)->lpVtbl -> get_Help(This,pVal)
05487
05488 #define ICaoTask_get_Index(This,pVal)   \
05489     (This)->lpVtbl -> get_Index(This,pVal)
05490
05491 #define ICaoTask_get_Name(This,pVal)    \
05492     (This)->lpVtbl -> get_Name(This,pVal)
05493
05494 #define ICaoTask_get_Tag(This,pVal) \
05495     (This)->lpVtbl -> get_Tag(This,pVal)
05496
05497 #define ICaoTask_put_Tag(This,newVal)   \
05498     (This)->lpVtbl -> put_Tag(This,newVal)
05499
05500 #define ICaoTask_get_VariableNames(This,bstrOption,pVal)    \
05501     (This)->lpVtbl -> get_VariableNames(This,bstrOption,pVal)
05502
05503 #define ICaoTask_get_Variables(This,ppICaoVariables)    \
05504     (This)->lpVtbl -> get_Variables(This,ppICaoVariables)
05505
05506 #define ICaoTask_get_ID(This,pVal)  \
05507     (This)->lpVtbl -> get_ID(This,pVal)
05508
05509 #define ICaoTask_put_ID(This,newVal)    \
05510     (This)->lpVtbl -> put_ID(This,newVal)
05511
05512 #define ICaoTask_AddVariable(This,bstrName,bstrOption,ppICaoVar)    \
05513     (This)->lpVtbl -> AddVariable(This,bstrName,bstrOption,ppICaoVar)
05514
05515 #define ICaoTask_Delete(This,bstrOption)    \
05516     (This)->lpVtbl -> Delete(This,bstrOption)
05517
05518 #define ICaoTask_Execute(This,vntCommand,pVal)  \
05519     (This)->lpVtbl -> Execute(This,vntCommand,pVal)
05520
05521 #define ICaoTask_Start(This,lMode,bstrOption)   \
05522     (This)->lpVtbl -> Start(This,lMode,bstrOption)
05523
05524 #define ICaoTask_Stop(This,lMode,bstrOption)    \
05525     (This)->lpVtbl -> Stop(This,lMode,bstrOption)
05526
05527 #endif /* COBJMACROS */
05528
05529
05530 #endif  /* C style interface */
05531
05532
05533
05534 /* [restricted][helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoTask__PutIndex_Proxy(
05535     ICaoTask __RPC_FAR * This,
05536     /* [in] */ long newVal);
05537
05538
05539 void __RPC_STUB ICaoTask__PutIndex_Stub(
05540     IRpcStubBuffer *This,
05541     IRpcChannelBuffer *_pRpcChannelBuffer,
05542     PRPC_MESSAGE _pRpcMessage,
05543     DWORD *_pdwStubPhase);
05544
05545
05546 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoTask_get_Attribute_Proxy(
05547     ICaoTask __RPC_FAR * This,
05548     /* [retval][out] */ long __RPC_FAR *pVal);
05549
05550
05551 void __RPC_STUB ICaoTask_get_Attribute_Stub(
05552     IRpcStubBuffer *This,
05553     IRpcChannelBuffer *_pRpcChannelBuffer,
05554     PRPC_MESSAGE _pRpcMessage,
05555     DWORD *_pdwStubPhase);
05556
05557
05558 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoTask_get_FileName_Proxy(
05559     ICaoTask __RPC_FAR * This,
05560     /* [retval][out] */ BSTR __RPC_FAR *pVal);
05561
05562
05563 void __RPC_STUB ICaoTask_get_FileName_Stub(
05564     IRpcStubBuffer *This,
05565     IRpcChannelBuffer *_pRpcChannelBuffer,
05566     PRPC_MESSAGE _pRpcMessage,
05567     DWORD *_pdwStubPhase);
05568
05569
05570 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoTask_get_Help_Proxy(
05571     ICaoTask __RPC_FAR * This,
05572     /* [retval][out] */ BSTR __RPC_FAR *pVal);
05573
05574
05575 void __RPC_STUB ICaoTask_get_Help_Stub(
05576     IRpcStubBuffer *This,
05577     IRpcChannelBuffer *_pRpcChannelBuffer,
05578     PRPC_MESSAGE _pRpcMessage,
05579     DWORD *_pdwStubPhase);
05580
05581
05582 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoTask_get_Index_Proxy(
05583     ICaoTask __RPC_FAR * This,
05584     /* [retval][out] */ long __RPC_FAR *pVal);
05585
05586
05587 void __RPC_STUB ICaoTask_get_Index_Stub(
05588     IRpcStubBuffer *This,
05589     IRpcChannelBuffer *_pRpcChannelBuffer,
05590     PRPC_MESSAGE _pRpcMessage,
05591     DWORD *_pdwStubPhase);
05592
05593
05594 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoTask_get_Name_Proxy(
05595     ICaoTask __RPC_FAR * This,
05596     /* [retval][out] */ BSTR __RPC_FAR *pVal);
05597
05598
05599 void __RPC_STUB ICaoTask_get_Name_Stub(
05600     IRpcStubBuffer *This,
05601     IRpcChannelBuffer *_pRpcChannelBuffer,
05602     PRPC_MESSAGE _pRpcMessage,
05603     DWORD *_pdwStubPhase);
05604
05605
05606 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoTask_get_Tag_Proxy(
05607     ICaoTask __RPC_FAR * This,
05608     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
05609
05610
05611 void __RPC_STUB ICaoTask_get_Tag_Stub(
05612     IRpcStubBuffer *This,
05613     IRpcChannelBuffer *_pRpcChannelBuffer,
05614     PRPC_MESSAGE _pRpcMessage,
05615     DWORD *_pdwStubPhase);
05616
05617
05618 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoTask_put_Tag_Proxy(
05619     ICaoTask __RPC_FAR * This,
05620     /* [in] */ VARIANT newVal);
05621
05622
05623 void __RPC_STUB ICaoTask_put_Tag_Stub(
05624     IRpcStubBuffer *This,
05625     IRpcChannelBuffer *_pRpcChannelBuffer,
05626     PRPC_MESSAGE _pRpcMessage,
05627     DWORD *_pdwStubPhase);
05628
05629
05630 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoTask_get_VariableNames_Proxy(
05631     ICaoTask __RPC_FAR * This,
05632     /* [defaultvalue][in] */ BSTR bstrOption,
05633     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
05634
05635
05636 void __RPC_STUB ICaoTask_get_VariableNames_Stub(
05637     IRpcStubBuffer *This,
05638     IRpcChannelBuffer *_pRpcChannelBuffer,
05639     PRPC_MESSAGE _pRpcMessage,
05640     DWORD *_pdwStubPhase);
05641
05642
05643 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoTask_get_Variables_Proxy(
05644     ICaoTask __RPC_FAR * This,
05645     /* [retval][out] */ ICaoVariables __RPC_FAR *__RPC_FAR *ppICaoVariables);
05646
05647
05648 void __RPC_STUB ICaoTask_get_Variables_Stub(
05649     IRpcStubBuffer *This,
05650     IRpcChannelBuffer *_pRpcChannelBuffer,
05651     PRPC_MESSAGE _pRpcMessage,
05652     DWORD *_pdwStubPhase);
05653
05654
05655 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoTask_get_ID_Proxy(
05656     ICaoTask __RPC_FAR * This,
05657     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
05658
05659
05660 void __RPC_STUB ICaoTask_get_ID_Stub(
05661     IRpcStubBuffer *This,
05662     IRpcChannelBuffer *_pRpcChannelBuffer,
05663     PRPC_MESSAGE _pRpcMessage,
05664     DWORD *_pdwStubPhase);
05665
05666
05667 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoTask_put_ID_Proxy(
05668     ICaoTask __RPC_FAR * This,
05669     /* [in] */ VARIANT newVal);
05670
05671
05672 void __RPC_STUB ICaoTask_put_ID_Stub(
05673     IRpcStubBuffer *This,
05674     IRpcChannelBuffer *_pRpcChannelBuffer,
05675     PRPC_MESSAGE _pRpcMessage,
05676     DWORD *_pdwStubPhase);
05677
05678
05679 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoTask_AddVariable_Proxy(
05680     ICaoTask __RPC_FAR * This,
05681     /* [in] */ BSTR bstrName,
05682     /* [defaultvalue][in] */ BSTR bstrOption,
05683     /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar);
05684
05685
05686 void __RPC_STUB ICaoTask_AddVariable_Stub(
05687     IRpcStubBuffer *This,
05688     IRpcChannelBuffer *_pRpcChannelBuffer,
05689     PRPC_MESSAGE _pRpcMessage,
05690     DWORD *_pdwStubPhase);
05691
05692
05693 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoTask_Delete_Proxy(
05694     ICaoTask __RPC_FAR * This,
05695     /* [defaultvalue][in] */ BSTR bstrOption);
05696
05697
05698 void __RPC_STUB ICaoTask_Delete_Stub(
05699     IRpcStubBuffer *This,
05700     IRpcChannelBuffer *_pRpcChannelBuffer,
05701     PRPC_MESSAGE _pRpcMessage,
05702     DWORD *_pdwStubPhase);
05703
05704
05705 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoTask_Execute_Proxy(
05706     ICaoTask __RPC_FAR * This,
05707     /* [in] */ VARIANT vntCommand,
05708     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
05709
05710
05711 void __RPC_STUB ICaoTask_Execute_Stub(
05712     IRpcStubBuffer *This,
05713     IRpcChannelBuffer *_pRpcChannelBuffer,
05714     PRPC_MESSAGE _pRpcMessage,
05715     DWORD *_pdwStubPhase);
05716
05717
05718 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoTask_Start_Proxy(
05719     ICaoTask __RPC_FAR * This,
05720     /* [defaultvalue][in] */ long lMode,
05721     /* [defaultvalue][in] */ BSTR bstrOption);
05722
05723
05724 void __RPC_STUB ICaoTask_Start_Stub(
05725     IRpcStubBuffer *This,
05726     IRpcChannelBuffer *_pRpcChannelBuffer,
05727     PRPC_MESSAGE _pRpcMessage,
05728     DWORD *_pdwStubPhase);
05729
05730
05731 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoTask_Stop_Proxy(
05732     ICaoTask __RPC_FAR * This,
05733     /* [defaultvalue][in] */ long lMode,
05734     /* [defaultvalue][in] */ BSTR bstrOption);
05735
05736
05737 void __RPC_STUB ICaoTask_Stop_Stub(
05738     IRpcStubBuffer *This,
05739     IRpcChannelBuffer *_pRpcChannelBuffer,
05740     PRPC_MESSAGE _pRpcMessage,
05741     DWORD *_pdwStubPhase);
05742
05743
05744
05745 #endif  /* __ICaoTask_INTERFACE_DEFINED__ */
05746
05747
05748 #ifndef __ICaoVariables_INTERFACE_DEFINED__
05749 #define __ICaoVariables_INTERFACE_DEFINED__
05750
05751 /* interface ICaoVariables */
05752 /* [unique][helpstring][dual][uuid][object] */
05753
05754
05755 EXTERN_C const IID IID_ICaoVariables;
05756
05757 #if defined(__cplusplus) && !defined(CINTERFACE)
05758
05759     MIDL_INTERFACE("8d392e7a-eb9e-46ef-86c6-8e7acd0eceab")
05760     ICaoVariables : public IDispatch
05761     {
05762     public:
05763         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get__NewEnum(
05764             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal) = 0;
05765
05766         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Item(
05767             /* [in] */ VARIANT Index,
05768             /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar) = 0;
05769
05770         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Count(
05771             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
05772
05773         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Add(
05774             /* [in] */ BSTR bstrName,
05775             /* [defaultvalue][in] */ BSTR bstrOption,
05776             /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar) = 0;
05777
05778         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Remove(
05779             /* [in] */ VARIANT Index) = 0;
05780
05781         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Clear( void) = 0;
05782
05783         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE IsMember(
05784             /* [in] */ VARIANT Index,
05785             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal) = 0;
05786
05787     };
05788
05789 #else   /* C style interface */
05790
05791     typedef struct ICaoVariablesVtbl
05792     {
05793         BEGIN_INTERFACE
05794
05795         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
05796             ICaoVariables __RPC_FAR * This,
05797             /* [in] */ REFIID riid,
05798             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
05799
05800         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
05801             ICaoVariables __RPC_FAR * This);
05802
05803         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
05804             ICaoVariables __RPC_FAR * This);
05805
05806         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
05807             ICaoVariables __RPC_FAR * This,
05808             /* [out] */ UINT __RPC_FAR *pctinfo);
05809
05810         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
05811             ICaoVariables __RPC_FAR * This,
05812             /* [in] */ UINT iTInfo,
05813             /* [in] */ LCID lcid,
05814             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
05815
05816         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
05817             ICaoVariables __RPC_FAR * This,
05818             /* [in] */ REFIID riid,
05819             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
05820             /* [in] */ UINT cNames,
05821             /* [in] */ LCID lcid,
05822             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
05823
05824         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
05825             ICaoVariables __RPC_FAR * This,
05826             /* [in] */ DISPID dispIdMember,
05827             /* [in] */ REFIID riid,
05828             /* [in] */ LCID lcid,
05829             /* [in] */ WORD wFlags,
05830             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
05831             /* [out] */ VARIANT __RPC_FAR *pVarResult,
05832             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
05833             /* [out] */ UINT __RPC_FAR *puArgErr);
05834
05835         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get__NewEnum )(
05836             ICaoVariables __RPC_FAR * This,
05837             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
05838
05839         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Item )(
05840             ICaoVariables __RPC_FAR * This,
05841             /* [in] */ VARIANT Index,
05842             /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar);
05843
05844         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Count )(
05845             ICaoVariables __RPC_FAR * This,
05846             /* [retval][out] */ long __RPC_FAR *pVal);
05847
05848         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Add )(
05849             ICaoVariables __RPC_FAR * This,
05850             /* [in] */ BSTR bstrName,
05851             /* [defaultvalue][in] */ BSTR bstrOption,
05852             /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar);
05853
05854         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Remove )(
05855             ICaoVariables __RPC_FAR * This,
05856             /* [in] */ VARIANT Index);
05857
05858         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Clear )(
05859             ICaoVariables __RPC_FAR * This);
05860
05861         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *IsMember )(
05862             ICaoVariables __RPC_FAR * This,
05863             /* [in] */ VARIANT Index,
05864             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal);
05865
05866         END_INTERFACE
05867     } ICaoVariablesVtbl;
05868
05869     interface ICaoVariables
05870     {
05871         CONST_VTBL struct ICaoVariablesVtbl __RPC_FAR *lpVtbl;
05872     };
05873
05874
05875
05876 #ifdef COBJMACROS
05877
05878
05879 #define ICaoVariables_QueryInterface(This,riid,ppvObject)   \
05880     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
05881
05882 #define ICaoVariables_AddRef(This)  \
05883     (This)->lpVtbl -> AddRef(This)
05884
05885 #define ICaoVariables_Release(This) \
05886     (This)->lpVtbl -> Release(This)
05887
05888
05889 #define ICaoVariables_GetTypeInfoCount(This,pctinfo)    \
05890     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
05891
05892 #define ICaoVariables_GetTypeInfo(This,iTInfo,lcid,ppTInfo) \
05893     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
05894
05895 #define ICaoVariables_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)   \
05896     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
05897
05898 #define ICaoVariables_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr) \
05899     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
05900
05901
05902 #define ICaoVariables_get__NewEnum(This,pVal)   \
05903     (This)->lpVtbl -> get__NewEnum(This,pVal)
05904
05905 #define ICaoVariables_Item(This,Index,ppICaoVar)    \
05906     (This)->lpVtbl -> Item(This,Index,ppICaoVar)
05907
05908 #define ICaoVariables_get_Count(This,pVal)  \
05909     (This)->lpVtbl -> get_Count(This,pVal)
05910
05911 #define ICaoVariables_Add(This,bstrName,bstrOption,ppICaoVar)   \
05912     (This)->lpVtbl -> Add(This,bstrName,bstrOption,ppICaoVar)
05913
05914 #define ICaoVariables_Remove(This,Index)    \
05915     (This)->lpVtbl -> Remove(This,Index)
05916
05917 #define ICaoVariables_Clear(This)   \
05918     (This)->lpVtbl -> Clear(This)
05919
05920 #define ICaoVariables_IsMember(This,Index,pVal) \
05921     (This)->lpVtbl -> IsMember(This,Index,pVal)
05922
05923 #endif /* COBJMACROS */
05924
05925
05926 #endif  /* C style interface */
05927
05928
05929
05930 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoVariables_get__NewEnum_Proxy(
05931     ICaoVariables __RPC_FAR * This,
05932     /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
05933
05934
05935 void __RPC_STUB ICaoVariables_get__NewEnum_Stub(
05936     IRpcStubBuffer *This,
05937     IRpcChannelBuffer *_pRpcChannelBuffer,
05938     PRPC_MESSAGE _pRpcMessage,
05939     DWORD *_pdwStubPhase);
05940
05941
05942 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoVariables_Item_Proxy(
05943     ICaoVariables __RPC_FAR * This,
05944     /* [in] */ VARIANT Index,
05945     /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar);
05946
05947
05948 void __RPC_STUB ICaoVariables_Item_Stub(
05949     IRpcStubBuffer *This,
05950     IRpcChannelBuffer *_pRpcChannelBuffer,
05951     PRPC_MESSAGE _pRpcMessage,
05952     DWORD *_pdwStubPhase);
05953
05954
05955 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoVariables_get_Count_Proxy(
05956     ICaoVariables __RPC_FAR * This,
05957     /* [retval][out] */ long __RPC_FAR *pVal);
05958
05959
05960 void __RPC_STUB ICaoVariables_get_Count_Stub(
05961     IRpcStubBuffer *This,
05962     IRpcChannelBuffer *_pRpcChannelBuffer,
05963     PRPC_MESSAGE _pRpcMessage,
05964     DWORD *_pdwStubPhase);
05965
05966
05967 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoVariables_Add_Proxy(
05968     ICaoVariables __RPC_FAR * This,
05969     /* [in] */ BSTR bstrName,
05970     /* [defaultvalue][in] */ BSTR bstrOption,
05971     /* [retval][out] */ ICaoVariable __RPC_FAR *__RPC_FAR *ppICaoVar);
05972
05973
05974 void __RPC_STUB ICaoVariables_Add_Stub(
05975     IRpcStubBuffer *This,
05976     IRpcChannelBuffer *_pRpcChannelBuffer,
05977     PRPC_MESSAGE _pRpcMessage,
05978     DWORD *_pdwStubPhase);
05979
05980
05981 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoVariables_Remove_Proxy(
05982     ICaoVariables __RPC_FAR * This,
05983     /* [in] */ VARIANT Index);
05984
05985
05986 void __RPC_STUB ICaoVariables_Remove_Stub(
05987     IRpcStubBuffer *This,
05988     IRpcChannelBuffer *_pRpcChannelBuffer,
05989     PRPC_MESSAGE _pRpcMessage,
05990     DWORD *_pdwStubPhase);
05991
05992
05993 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoVariables_Clear_Proxy(
05994     ICaoVariables __RPC_FAR * This);
05995
05996
05997 void __RPC_STUB ICaoVariables_Clear_Stub(
05998     IRpcStubBuffer *This,
05999     IRpcChannelBuffer *_pRpcChannelBuffer,
06000     PRPC_MESSAGE _pRpcMessage,
06001     DWORD *_pdwStubPhase);
06002
06003
06004 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoVariables_IsMember_Proxy(
06005     ICaoVariables __RPC_FAR * This,
06006     /* [in] */ VARIANT Index,
06007     /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal);
06008
06009
06010 void __RPC_STUB ICaoVariables_IsMember_Stub(
06011     IRpcStubBuffer *This,
06012     IRpcChannelBuffer *_pRpcChannelBuffer,
06013     PRPC_MESSAGE _pRpcMessage,
06014     DWORD *_pdwStubPhase);
06015
06016
06017
06018 #endif  /* __ICaoVariables_INTERFACE_DEFINED__ */
06019
06020
06021 #ifndef __ICaoVariable_INTERFACE_DEFINED__
06022 #define __ICaoVariable_INTERFACE_DEFINED__
06023
06024 /* interface ICaoVariable */
06025 /* [unique][helpstring][dual][uuid][object] */
06026
06027
06028 EXTERN_C const IID IID_ICaoVariable;
06029
06030 #if defined(__cplusplus) && !defined(CINTERFACE)
06031
06032     MIDL_INTERFACE("3dc12940-6c7b-43e4-b375-136c3e6e7e3a")
06033     ICaoVariable : public IDispatch
06034     {
06035     public:
06036         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Value(
06037             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
06038
06039         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Value(
06040             /* [in] */ VARIANT newVal) = 0;
06041
06042         virtual /* [restricted][helpstring][id] */ HRESULT STDMETHODCALLTYPE _PutIndex(
06043             /* [in] */ long newVal) = 0;
06044
06045         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Attribute(
06046             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
06047
06048         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_DateTime(
06049             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
06050
06051         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Help(
06052             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
06053
06054         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Index(
06055             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
06056
06057         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
06058             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
06059
06060         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Tag(
06061             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
06062
06063         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Tag(
06064             /* [in] */ VARIANT newVal) = 0;
06065
06066         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ID(
06067             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
06068
06069         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ID(
06070             /* [in] */ VARIANT newVal) = 0;
06071
06072         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Microsecond(
06073             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
06074
06075     };
06076
06077 #else   /* C style interface */
06078
06079     typedef struct ICaoVariableVtbl
06080     {
06081         BEGIN_INTERFACE
06082
06083         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
06084             ICaoVariable __RPC_FAR * This,
06085             /* [in] */ REFIID riid,
06086             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
06087
06088         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
06089             ICaoVariable __RPC_FAR * This);
06090
06091         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
06092             ICaoVariable __RPC_FAR * This);
06093
06094         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
06095             ICaoVariable __RPC_FAR * This,
06096             /* [out] */ UINT __RPC_FAR *pctinfo);
06097
06098         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
06099             ICaoVariable __RPC_FAR * This,
06100             /* [in] */ UINT iTInfo,
06101             /* [in] */ LCID lcid,
06102             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
06103
06104         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
06105             ICaoVariable __RPC_FAR * This,
06106             /* [in] */ REFIID riid,
06107             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
06108             /* [in] */ UINT cNames,
06109             /* [in] */ LCID lcid,
06110             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
06111
06112         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
06113             ICaoVariable __RPC_FAR * This,
06114             /* [in] */ DISPID dispIdMember,
06115             /* [in] */ REFIID riid,
06116             /* [in] */ LCID lcid,
06117             /* [in] */ WORD wFlags,
06118             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
06119             /* [out] */ VARIANT __RPC_FAR *pVarResult,
06120             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
06121             /* [out] */ UINT __RPC_FAR *puArgErr);
06122
06123         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Value )(
06124             ICaoVariable __RPC_FAR * This,
06125             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
06126
06127         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Value )(
06128             ICaoVariable __RPC_FAR * This,
06129             /* [in] */ VARIANT newVal);
06130
06131         /* [restricted][helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *_PutIndex )(
06132             ICaoVariable __RPC_FAR * This,
06133             /* [in] */ long newVal);
06134
06135         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Attribute )(
06136             ICaoVariable __RPC_FAR * This,
06137             /* [retval][out] */ long __RPC_FAR *pVal);
06138
06139         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_DateTime )(
06140             ICaoVariable __RPC_FAR * This,
06141             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
06142
06143         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Help )(
06144             ICaoVariable __RPC_FAR * This,
06145             /* [retval][out] */ BSTR __RPC_FAR *pVal);
06146
06147         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Index )(
06148             ICaoVariable __RPC_FAR * This,
06149             /* [retval][out] */ long __RPC_FAR *pVal);
06150
06151         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
06152             ICaoVariable __RPC_FAR * This,
06153             /* [retval][out] */ BSTR __RPC_FAR *pVal);
06154
06155         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Tag )(
06156             ICaoVariable __RPC_FAR * This,
06157             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
06158
06159         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Tag )(
06160             ICaoVariable __RPC_FAR * This,
06161             /* [in] */ VARIANT newVal);
06162
06163         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ID )(
06164             ICaoVariable __RPC_FAR * This,
06165             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
06166
06167         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ID )(
06168             ICaoVariable __RPC_FAR * This,
06169             /* [in] */ VARIANT newVal);
06170
06171         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Microsecond )(
06172             ICaoVariable __RPC_FAR * This,
06173             /* [retval][out] */ long __RPC_FAR *pVal);
06174
06175         END_INTERFACE
06176     } ICaoVariableVtbl;
06177
06178     interface ICaoVariable
06179     {
06180         CONST_VTBL struct ICaoVariableVtbl __RPC_FAR *lpVtbl;
06181     };
06182
06183
06184
06185 #ifdef COBJMACROS
06186
06187
06188 #define ICaoVariable_QueryInterface(This,riid,ppvObject)    \
06189     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
06190
06191 #define ICaoVariable_AddRef(This)   \
06192     (This)->lpVtbl -> AddRef(This)
06193
06194 #define ICaoVariable_Release(This)  \
06195     (This)->lpVtbl -> Release(This)
06196
06197
06198 #define ICaoVariable_GetTypeInfoCount(This,pctinfo) \
06199     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
06200
06201 #define ICaoVariable_GetTypeInfo(This,iTInfo,lcid,ppTInfo)  \
06202     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
06203
06204 #define ICaoVariable_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)    \
06205     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
06206
06207 #define ICaoVariable_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)  \
06208     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
06209
06210
06211 #define ICaoVariable_get_Value(This,pVal)   \
06212     (This)->lpVtbl -> get_Value(This,pVal)
06213
06214 #define ICaoVariable_put_Value(This,newVal) \
06215     (This)->lpVtbl -> put_Value(This,newVal)
06216
06217 #define ICaoVariable__PutIndex(This,newVal) \
06218     (This)->lpVtbl -> _PutIndex(This,newVal)
06219
06220 #define ICaoVariable_get_Attribute(This,pVal)   \
06221     (This)->lpVtbl -> get_Attribute(This,pVal)
06222
06223 #define ICaoVariable_get_DateTime(This,pVal)    \
06224     (This)->lpVtbl -> get_DateTime(This,pVal)
06225
06226 #define ICaoVariable_get_Help(This,pVal)    \
06227     (This)->lpVtbl -> get_Help(This,pVal)
06228
06229 #define ICaoVariable_get_Index(This,pVal)   \
06230     (This)->lpVtbl -> get_Index(This,pVal)
06231
06232 #define ICaoVariable_get_Name(This,pVal)    \
06233     (This)->lpVtbl -> get_Name(This,pVal)
06234
06235 #define ICaoVariable_get_Tag(This,pVal) \
06236     (This)->lpVtbl -> get_Tag(This,pVal)
06237
06238 #define ICaoVariable_put_Tag(This,newVal)   \
06239     (This)->lpVtbl -> put_Tag(This,newVal)
06240
06241 #define ICaoVariable_get_ID(This,pVal)  \
06242     (This)->lpVtbl -> get_ID(This,pVal)
06243
06244 #define ICaoVariable_put_ID(This,newVal)    \
06245     (This)->lpVtbl -> put_ID(This,newVal)
06246
06247 #define ICaoVariable_get_Microsecond(This,pVal) \
06248     (This)->lpVtbl -> get_Microsecond(This,pVal)
06249
06250 #endif /* COBJMACROS */
06251
06252
06253 #endif  /* C style interface */
06254
06255
06256
06257 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoVariable_get_Value_Proxy(
06258     ICaoVariable __RPC_FAR * This,
06259     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
06260
06261
06262 void __RPC_STUB ICaoVariable_get_Value_Stub(
06263     IRpcStubBuffer *This,
06264     IRpcChannelBuffer *_pRpcChannelBuffer,
06265     PRPC_MESSAGE _pRpcMessage,
06266     DWORD *_pdwStubPhase);
06267
06268
06269 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoVariable_put_Value_Proxy(
06270     ICaoVariable __RPC_FAR * This,
06271     /* [in] */ VARIANT newVal);
06272
06273
06274 void __RPC_STUB ICaoVariable_put_Value_Stub(
06275     IRpcStubBuffer *This,
06276     IRpcChannelBuffer *_pRpcChannelBuffer,
06277     PRPC_MESSAGE _pRpcMessage,
06278     DWORD *_pdwStubPhase);
06279
06280
06281 /* [restricted][helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoVariable__PutIndex_Proxy(
06282     ICaoVariable __RPC_FAR * This,
06283     /* [in] */ long newVal);
06284
06285
06286 void __RPC_STUB ICaoVariable__PutIndex_Stub(
06287     IRpcStubBuffer *This,
06288     IRpcChannelBuffer *_pRpcChannelBuffer,
06289     PRPC_MESSAGE _pRpcMessage,
06290     DWORD *_pdwStubPhase);
06291
06292
06293 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoVariable_get_Attribute_Proxy(
06294     ICaoVariable __RPC_FAR * This,
06295     /* [retval][out] */ long __RPC_FAR *pVal);
06296
06297
06298 void __RPC_STUB ICaoVariable_get_Attribute_Stub(
06299     IRpcStubBuffer *This,
06300     IRpcChannelBuffer *_pRpcChannelBuffer,
06301     PRPC_MESSAGE _pRpcMessage,
06302     DWORD *_pdwStubPhase);
06303
06304
06305 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoVariable_get_DateTime_Proxy(
06306     ICaoVariable __RPC_FAR * This,
06307     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
06308
06309
06310 void __RPC_STUB ICaoVariable_get_DateTime_Stub(
06311     IRpcStubBuffer *This,
06312     IRpcChannelBuffer *_pRpcChannelBuffer,
06313     PRPC_MESSAGE _pRpcMessage,
06314     DWORD *_pdwStubPhase);
06315
06316
06317 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoVariable_get_Help_Proxy(
06318     ICaoVariable __RPC_FAR * This,
06319     /* [retval][out] */ BSTR __RPC_FAR *pVal);
06320
06321
06322 void __RPC_STUB ICaoVariable_get_Help_Stub(
06323     IRpcStubBuffer *This,
06324     IRpcChannelBuffer *_pRpcChannelBuffer,
06325     PRPC_MESSAGE _pRpcMessage,
06326     DWORD *_pdwStubPhase);
06327
06328
06329 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoVariable_get_Index_Proxy(
06330     ICaoVariable __RPC_FAR * This,
06331     /* [retval][out] */ long __RPC_FAR *pVal);
06332
06333
06334 void __RPC_STUB ICaoVariable_get_Index_Stub(
06335     IRpcStubBuffer *This,
06336     IRpcChannelBuffer *_pRpcChannelBuffer,
06337     PRPC_MESSAGE _pRpcMessage,
06338     DWORD *_pdwStubPhase);
06339
06340
06341 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoVariable_get_Name_Proxy(
06342     ICaoVariable __RPC_FAR * This,
06343     /* [retval][out] */ BSTR __RPC_FAR *pVal);
06344
06345
06346 void __RPC_STUB ICaoVariable_get_Name_Stub(
06347     IRpcStubBuffer *This,
06348     IRpcChannelBuffer *_pRpcChannelBuffer,
06349     PRPC_MESSAGE _pRpcMessage,
06350     DWORD *_pdwStubPhase);
06351
06352
06353 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoVariable_get_Tag_Proxy(
06354     ICaoVariable __RPC_FAR * This,
06355     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
06356
06357
06358 void __RPC_STUB ICaoVariable_get_Tag_Stub(
06359     IRpcStubBuffer *This,
06360     IRpcChannelBuffer *_pRpcChannelBuffer,
06361     PRPC_MESSAGE _pRpcMessage,
06362     DWORD *_pdwStubPhase);
06363
06364
06365 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoVariable_put_Tag_Proxy(
06366     ICaoVariable __RPC_FAR * This,
06367     /* [in] */ VARIANT newVal);
06368
06369
06370 void __RPC_STUB ICaoVariable_put_Tag_Stub(
06371     IRpcStubBuffer *This,
06372     IRpcChannelBuffer *_pRpcChannelBuffer,
06373     PRPC_MESSAGE _pRpcMessage,
06374     DWORD *_pdwStubPhase);
06375
06376
06377 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoVariable_get_ID_Proxy(
06378     ICaoVariable __RPC_FAR * This,
06379     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
06380
06381
06382 void __RPC_STUB ICaoVariable_get_ID_Stub(
06383     IRpcStubBuffer *This,
06384     IRpcChannelBuffer *_pRpcChannelBuffer,
06385     PRPC_MESSAGE _pRpcMessage,
06386     DWORD *_pdwStubPhase);
06387
06388
06389 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoVariable_put_ID_Proxy(
06390     ICaoVariable __RPC_FAR * This,
06391     /* [in] */ VARIANT newVal);
06392
06393
06394 void __RPC_STUB ICaoVariable_put_ID_Stub(
06395     IRpcStubBuffer *This,
06396     IRpcChannelBuffer *_pRpcChannelBuffer,
06397     PRPC_MESSAGE _pRpcMessage,
06398     DWORD *_pdwStubPhase);
06399
06400
06401 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoVariable_get_Microsecond_Proxy(
06402     ICaoVariable __RPC_FAR * This,
06403     /* [retval][out] */ long __RPC_FAR *pVal);
06404
06405
06406 void __RPC_STUB ICaoVariable_get_Microsecond_Stub(
06407     IRpcStubBuffer *This,
06408     IRpcChannelBuffer *_pRpcChannelBuffer,
06409     PRPC_MESSAGE _pRpcMessage,
06410     DWORD *_pdwStubPhase);
06411
06412
06413
06414 #endif  /* __ICaoVariable_INTERFACE_DEFINED__ */
06415
06416
06417 #ifndef __ICaoCommands_INTERFACE_DEFINED__
06418 #define __ICaoCommands_INTERFACE_DEFINED__
06419
06420 /* interface ICaoCommands */
06421 /* [unique][helpstring][dual][uuid][object] */
06422
06423
06424 EXTERN_C const IID IID_ICaoCommands;
06425
06426 #if defined(__cplusplus) && !defined(CINTERFACE)
06427
06428     MIDL_INTERFACE("480CA4D6-ADCB-4cb4-812B-7E41BE891E03")
06429     ICaoCommands : public IDispatch
06430     {
06431     public:
06432         virtual /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get__NewEnum(
06433             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal) = 0;
06434
06435         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Item(
06436             /* [in] */ VARIANT Index,
06437             /* [retval][out] */ ICaoCommand __RPC_FAR *__RPC_FAR *ppICaoCommand) = 0;
06438
06439         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Count(
06440             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
06441
06442         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Add(
06443             /* [in] */ BSTR bstrName,
06444             /* [defaultvalue][in] */ BSTR bstrOption,
06445             /* [retval][out] */ ICaoCommand __RPC_FAR *__RPC_FAR *ppICaoCommand) = 0;
06446
06447         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Remove(
06448             /* [in] */ VARIANT Index) = 0;
06449
06450         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Clear( void) = 0;
06451
06452         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE IsMember(
06453             /* [in] */ VARIANT Index,
06454             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal) = 0;
06455
06456     };
06457
06458 #else   /* C style interface */
06459
06460     typedef struct ICaoCommandsVtbl
06461     {
06462         BEGIN_INTERFACE
06463
06464         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
06465             ICaoCommands __RPC_FAR * This,
06466             /* [in] */ REFIID riid,
06467             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
06468
06469         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
06470             ICaoCommands __RPC_FAR * This);
06471
06472         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
06473             ICaoCommands __RPC_FAR * This);
06474
06475         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
06476             ICaoCommands __RPC_FAR * This,
06477             /* [out] */ UINT __RPC_FAR *pctinfo);
06478
06479         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
06480             ICaoCommands __RPC_FAR * This,
06481             /* [in] */ UINT iTInfo,
06482             /* [in] */ LCID lcid,
06483             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
06484
06485         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
06486             ICaoCommands __RPC_FAR * This,
06487             /* [in] */ REFIID riid,
06488             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
06489             /* [in] */ UINT cNames,
06490             /* [in] */ LCID lcid,
06491             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
06492
06493         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
06494             ICaoCommands __RPC_FAR * This,
06495             /* [in] */ DISPID dispIdMember,
06496             /* [in] */ REFIID riid,
06497             /* [in] */ LCID lcid,
06498             /* [in] */ WORD wFlags,
06499             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
06500             /* [out] */ VARIANT __RPC_FAR *pVarResult,
06501             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
06502             /* [out] */ UINT __RPC_FAR *puArgErr);
06503
06504         /* [restricted][helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get__NewEnum )(
06505             ICaoCommands __RPC_FAR * This,
06506             /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
06507
06508         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Item )(
06509             ICaoCommands __RPC_FAR * This,
06510             /* [in] */ VARIANT Index,
06511             /* [retval][out] */ ICaoCommand __RPC_FAR *__RPC_FAR *ppICaoCommand);
06512
06513         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Count )(
06514             ICaoCommands __RPC_FAR * This,
06515             /* [retval][out] */ long __RPC_FAR *pVal);
06516
06517         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Add )(
06518             ICaoCommands __RPC_FAR * This,
06519             /* [in] */ BSTR bstrName,
06520             /* [defaultvalue][in] */ BSTR bstrOption,
06521             /* [retval][out] */ ICaoCommand __RPC_FAR *__RPC_FAR *ppICaoCommand);
06522
06523         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Remove )(
06524             ICaoCommands __RPC_FAR * This,
06525             /* [in] */ VARIANT Index);
06526
06527         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Clear )(
06528             ICaoCommands __RPC_FAR * This);
06529
06530         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *IsMember )(
06531             ICaoCommands __RPC_FAR * This,
06532             /* [in] */ VARIANT Index,
06533             /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal);
06534
06535         END_INTERFACE
06536     } ICaoCommandsVtbl;
06537
06538     interface ICaoCommands
06539     {
06540         CONST_VTBL struct ICaoCommandsVtbl __RPC_FAR *lpVtbl;
06541     };
06542
06543
06544
06545 #ifdef COBJMACROS
06546
06547
06548 #define ICaoCommands_QueryInterface(This,riid,ppvObject)    \
06549     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
06550
06551 #define ICaoCommands_AddRef(This)   \
06552     (This)->lpVtbl -> AddRef(This)
06553
06554 #define ICaoCommands_Release(This)  \
06555     (This)->lpVtbl -> Release(This)
06556
06557
06558 #define ICaoCommands_GetTypeInfoCount(This,pctinfo) \
06559     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
06560
06561 #define ICaoCommands_GetTypeInfo(This,iTInfo,lcid,ppTInfo)  \
06562     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
06563
06564 #define ICaoCommands_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)    \
06565     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
06566
06567 #define ICaoCommands_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)  \
06568     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
06569
06570
06571 #define ICaoCommands_get__NewEnum(This,pVal)    \
06572     (This)->lpVtbl -> get__NewEnum(This,pVal)
06573
06574 #define ICaoCommands_Item(This,Index,ppICaoCommand) \
06575     (This)->lpVtbl -> Item(This,Index,ppICaoCommand)
06576
06577 #define ICaoCommands_get_Count(This,pVal)   \
06578     (This)->lpVtbl -> get_Count(This,pVal)
06579
06580 #define ICaoCommands_Add(This,bstrName,bstrOption,ppICaoCommand)    \
06581     (This)->lpVtbl -> Add(This,bstrName,bstrOption,ppICaoCommand)
06582
06583 #define ICaoCommands_Remove(This,Index) \
06584     (This)->lpVtbl -> Remove(This,Index)
06585
06586 #define ICaoCommands_Clear(This)    \
06587     (This)->lpVtbl -> Clear(This)
06588
06589 #define ICaoCommands_IsMember(This,Index,pVal)  \
06590     (This)->lpVtbl -> IsMember(This,Index,pVal)
06591
06592 #endif /* COBJMACROS */
06593
06594
06595 #endif  /* C style interface */
06596
06597
06598
06599 /* [restricted][helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoCommands_get__NewEnum_Proxy(
06600     ICaoCommands __RPC_FAR * This,
06601     /* [retval][out] */ LPUNKNOWN __RPC_FAR *pVal);
06602
06603
06604 void __RPC_STUB ICaoCommands_get__NewEnum_Stub(
06605     IRpcStubBuffer *This,
06606     IRpcChannelBuffer *_pRpcChannelBuffer,
06607     PRPC_MESSAGE _pRpcMessage,
06608     DWORD *_pdwStubPhase);
06609
06610
06611 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoCommands_Item_Proxy(
06612     ICaoCommands __RPC_FAR * This,
06613     /* [in] */ VARIANT Index,
06614     /* [retval][out] */ ICaoCommand __RPC_FAR *__RPC_FAR *ppICaoCommand);
06615
06616
06617 void __RPC_STUB ICaoCommands_Item_Stub(
06618     IRpcStubBuffer *This,
06619     IRpcChannelBuffer *_pRpcChannelBuffer,
06620     PRPC_MESSAGE _pRpcMessage,
06621     DWORD *_pdwStubPhase);
06622
06623
06624 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoCommands_get_Count_Proxy(
06625     ICaoCommands __RPC_FAR * This,
06626     /* [retval][out] */ long __RPC_FAR *pVal);
06627
06628
06629 void __RPC_STUB ICaoCommands_get_Count_Stub(
06630     IRpcStubBuffer *This,
06631     IRpcChannelBuffer *_pRpcChannelBuffer,
06632     PRPC_MESSAGE _pRpcMessage,
06633     DWORD *_pdwStubPhase);
06634
06635
06636 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoCommands_Add_Proxy(
06637     ICaoCommands __RPC_FAR * This,
06638     /* [in] */ BSTR bstrName,
06639     /* [defaultvalue][in] */ BSTR bstrOption,
06640     /* [retval][out] */ ICaoCommand __RPC_FAR *__RPC_FAR *ppICaoCommand);
06641
06642
06643 void __RPC_STUB ICaoCommands_Add_Stub(
06644     IRpcStubBuffer *This,
06645     IRpcChannelBuffer *_pRpcChannelBuffer,
06646     PRPC_MESSAGE _pRpcMessage,
06647     DWORD *_pdwStubPhase);
06648
06649
06650 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoCommands_Remove_Proxy(
06651     ICaoCommands __RPC_FAR * This,
06652     /* [in] */ VARIANT Index);
06653
06654
06655 void __RPC_STUB ICaoCommands_Remove_Stub(
06656     IRpcStubBuffer *This,
06657     IRpcChannelBuffer *_pRpcChannelBuffer,
06658     PRPC_MESSAGE _pRpcMessage,
06659     DWORD *_pdwStubPhase);
06660
06661
06662 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoCommands_Clear_Proxy(
06663     ICaoCommands __RPC_FAR * This);
06664
06665
06666 void __RPC_STUB ICaoCommands_Clear_Stub(
06667     IRpcStubBuffer *This,
06668     IRpcChannelBuffer *_pRpcChannelBuffer,
06669     PRPC_MESSAGE _pRpcMessage,
06670     DWORD *_pdwStubPhase);
06671
06672
06673 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoCommands_IsMember_Proxy(
06674     ICaoCommands __RPC_FAR * This,
06675     /* [in] */ VARIANT Index,
06676     /* [retval][out] */ VARIANT_BOOL __RPC_FAR *pVal);
06677
06678
06679 void __RPC_STUB ICaoCommands_IsMember_Stub(
06680     IRpcStubBuffer *This,
06681     IRpcChannelBuffer *_pRpcChannelBuffer,
06682     PRPC_MESSAGE _pRpcMessage,
06683     DWORD *_pdwStubPhase);
06684
06685
06686
06687 #endif  /* __ICaoCommands_INTERFACE_DEFINED__ */
06688
06689
06690 #ifndef __ICaoCommand_INTERFACE_DEFINED__
06691 #define __ICaoCommand_INTERFACE_DEFINED__
06692
06693 /* interface ICaoCommand */
06694 /* [unique][helpstring][dual][uuid][object] */
06695
06696
06697 EXTERN_C const IID IID_ICaoCommand;
06698
06699 #if defined(__cplusplus) && !defined(CINTERFACE)
06700
06701     MIDL_INTERFACE("3DA3B42D-EA6A-468b-A57F-C375DEFD11E9")
06702     ICaoCommand : public IDispatch
06703     {
06704     public:
06705         virtual /* [restricted][helpstring][id] */ HRESULT STDMETHODCALLTYPE _PutIndex(
06706             /* [in] */ long newVal) = 0;
06707
06708         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Attribute(
06709             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
06710
06711         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Help(
06712             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
06713
06714         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Index(
06715             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
06716
06717         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Name(
06718             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
06719
06720         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Parameters(
06721             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
06722
06723         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Parameters(
06724             /* [in] */ VARIANT newVal) = 0;
06725
06726         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Result(
06727             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
06728
06729         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_State(
06730             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
06731
06732         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Tag(
06733             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
06734
06735         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Tag(
06736             /* [in] */ VARIANT newVal) = 0;
06737
06738         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Timeout(
06739             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
06740
06741         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_Timeout(
06742             /* [in] */ long newVal) = 0;
06743
06744         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ID(
06745             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
06746
06747         virtual /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE put_ID(
06748             /* [in] */ VARIANT newVal) = 0;
06749
06750         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Cancel( void) = 0;
06751
06752         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Execute(
06753             /* [defaultvalue][in] */ long lMode = 0) = 0;
06754
06755     };
06756
06757 #else   /* C style interface */
06758
06759     typedef struct ICaoCommandVtbl
06760     {
06761         BEGIN_INTERFACE
06762
06763         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
06764             ICaoCommand __RPC_FAR * This,
06765             /* [in] */ REFIID riid,
06766             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
06767
06768         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
06769             ICaoCommand __RPC_FAR * This);
06770
06771         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
06772             ICaoCommand __RPC_FAR * This);
06773
06774         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
06775             ICaoCommand __RPC_FAR * This,
06776             /* [out] */ UINT __RPC_FAR *pctinfo);
06777
06778         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
06779             ICaoCommand __RPC_FAR * This,
06780             /* [in] */ UINT iTInfo,
06781             /* [in] */ LCID lcid,
06782             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
06783
06784         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
06785             ICaoCommand __RPC_FAR * This,
06786             /* [in] */ REFIID riid,
06787             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
06788             /* [in] */ UINT cNames,
06789             /* [in] */ LCID lcid,
06790             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
06791
06792         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
06793             ICaoCommand __RPC_FAR * This,
06794             /* [in] */ DISPID dispIdMember,
06795             /* [in] */ REFIID riid,
06796             /* [in] */ LCID lcid,
06797             /* [in] */ WORD wFlags,
06798             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
06799             /* [out] */ VARIANT __RPC_FAR *pVarResult,
06800             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
06801             /* [out] */ UINT __RPC_FAR *puArgErr);
06802
06803         /* [restricted][helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *_PutIndex )(
06804             ICaoCommand __RPC_FAR * This,
06805             /* [in] */ long newVal);
06806
06807         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Attribute )(
06808             ICaoCommand __RPC_FAR * This,
06809             /* [retval][out] */ long __RPC_FAR *pVal);
06810
06811         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Help )(
06812             ICaoCommand __RPC_FAR * This,
06813             /* [retval][out] */ BSTR __RPC_FAR *pVal);
06814
06815         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Index )(
06816             ICaoCommand __RPC_FAR * This,
06817             /* [retval][out] */ long __RPC_FAR *pVal);
06818
06819         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Name )(
06820             ICaoCommand __RPC_FAR * This,
06821             /* [retval][out] */ BSTR __RPC_FAR *pVal);
06822
06823         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Parameters )(
06824             ICaoCommand __RPC_FAR * This,
06825             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
06826
06827         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Parameters )(
06828             ICaoCommand __RPC_FAR * This,
06829             /* [in] */ VARIANT newVal);
06830
06831         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Result )(
06832             ICaoCommand __RPC_FAR * This,
06833             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
06834
06835         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_State )(
06836             ICaoCommand __RPC_FAR * This,
06837             /* [retval][out] */ long __RPC_FAR *pVal);
06838
06839         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Tag )(
06840             ICaoCommand __RPC_FAR * This,
06841             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
06842
06843         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Tag )(
06844             ICaoCommand __RPC_FAR * This,
06845             /* [in] */ VARIANT newVal);
06846
06847         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Timeout )(
06848             ICaoCommand __RPC_FAR * This,
06849             /* [retval][out] */ long __RPC_FAR *pVal);
06850
06851         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_Timeout )(
06852             ICaoCommand __RPC_FAR * This,
06853             /* [in] */ long newVal);
06854
06855         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ID )(
06856             ICaoCommand __RPC_FAR * This,
06857             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
06858
06859         /* [helpstring][id][propput] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *put_ID )(
06860             ICaoCommand __RPC_FAR * This,
06861             /* [in] */ VARIANT newVal);
06862
06863         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Cancel )(
06864             ICaoCommand __RPC_FAR * This);
06865
06866         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Execute )(
06867             ICaoCommand __RPC_FAR * This,
06868             /* [defaultvalue][in] */ long lMode);
06869
06870         END_INTERFACE
06871     } ICaoCommandVtbl;
06872
06873     interface ICaoCommand
06874     {
06875         CONST_VTBL struct ICaoCommandVtbl __RPC_FAR *lpVtbl;
06876     };
06877
06878
06879
06880 #ifdef COBJMACROS
06881
06882
06883 #define ICaoCommand_QueryInterface(This,riid,ppvObject) \
06884     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
06885
06886 #define ICaoCommand_AddRef(This)    \
06887     (This)->lpVtbl -> AddRef(This)
06888
06889 #define ICaoCommand_Release(This)   \
06890     (This)->lpVtbl -> Release(This)
06891
06892
06893 #define ICaoCommand_GetTypeInfoCount(This,pctinfo)  \
06894     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
06895
06896 #define ICaoCommand_GetTypeInfo(This,iTInfo,lcid,ppTInfo)   \
06897     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
06898
06899 #define ICaoCommand_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId) \
06900     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
06901
06902 #define ICaoCommand_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)   \
06903     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
06904
06905
06906 #define ICaoCommand__PutIndex(This,newVal)  \
06907     (This)->lpVtbl -> _PutIndex(This,newVal)
06908
06909 #define ICaoCommand_get_Attribute(This,pVal)    \
06910     (This)->lpVtbl -> get_Attribute(This,pVal)
06911
06912 #define ICaoCommand_get_Help(This,pVal) \
06913     (This)->lpVtbl -> get_Help(This,pVal)
06914
06915 #define ICaoCommand_get_Index(This,pVal)    \
06916     (This)->lpVtbl -> get_Index(This,pVal)
06917
06918 #define ICaoCommand_get_Name(This,pVal) \
06919     (This)->lpVtbl -> get_Name(This,pVal)
06920
06921 #define ICaoCommand_get_Parameters(This,pVal)   \
06922     (This)->lpVtbl -> get_Parameters(This,pVal)
06923
06924 #define ICaoCommand_put_Parameters(This,newVal) \
06925     (This)->lpVtbl -> put_Parameters(This,newVal)
06926
06927 #define ICaoCommand_get_Result(This,pVal)   \
06928     (This)->lpVtbl -> get_Result(This,pVal)
06929
06930 #define ICaoCommand_get_State(This,pVal)    \
06931     (This)->lpVtbl -> get_State(This,pVal)
06932
06933 #define ICaoCommand_get_Tag(This,pVal)  \
06934     (This)->lpVtbl -> get_Tag(This,pVal)
06935
06936 #define ICaoCommand_put_Tag(This,newVal)    \
06937     (This)->lpVtbl -> put_Tag(This,newVal)
06938
06939 #define ICaoCommand_get_Timeout(This,pVal)  \
06940     (This)->lpVtbl -> get_Timeout(This,pVal)
06941
06942 #define ICaoCommand_put_Timeout(This,newVal)    \
06943     (This)->lpVtbl -> put_Timeout(This,newVal)
06944
06945 #define ICaoCommand_get_ID(This,pVal)   \
06946     (This)->lpVtbl -> get_ID(This,pVal)
06947
06948 #define ICaoCommand_put_ID(This,newVal) \
06949     (This)->lpVtbl -> put_ID(This,newVal)
06950
06951 #define ICaoCommand_Cancel(This)    \
06952     (This)->lpVtbl -> Cancel(This)
06953
06954 #define ICaoCommand_Execute(This,lMode) \
06955     (This)->lpVtbl -> Execute(This,lMode)
06956
06957 #endif /* COBJMACROS */
06958
06959
06960 #endif  /* C style interface */
06961
06962
06963
06964 /* [restricted][helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoCommand__PutIndex_Proxy(
06965     ICaoCommand __RPC_FAR * This,
06966     /* [in] */ long newVal);
06967
06968
06969 void __RPC_STUB ICaoCommand__PutIndex_Stub(
06970     IRpcStubBuffer *This,
06971     IRpcChannelBuffer *_pRpcChannelBuffer,
06972     PRPC_MESSAGE _pRpcMessage,
06973     DWORD *_pdwStubPhase);
06974
06975
06976 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoCommand_get_Attribute_Proxy(
06977     ICaoCommand __RPC_FAR * This,
06978     /* [retval][out] */ long __RPC_FAR *pVal);
06979
06980
06981 void __RPC_STUB ICaoCommand_get_Attribute_Stub(
06982     IRpcStubBuffer *This,
06983     IRpcChannelBuffer *_pRpcChannelBuffer,
06984     PRPC_MESSAGE _pRpcMessage,
06985     DWORD *_pdwStubPhase);
06986
06987
06988 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoCommand_get_Help_Proxy(
06989     ICaoCommand __RPC_FAR * This,
06990     /* [retval][out] */ BSTR __RPC_FAR *pVal);
06991
06992
06993 void __RPC_STUB ICaoCommand_get_Help_Stub(
06994     IRpcStubBuffer *This,
06995     IRpcChannelBuffer *_pRpcChannelBuffer,
06996     PRPC_MESSAGE _pRpcMessage,
06997     DWORD *_pdwStubPhase);
06998
06999
07000 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoCommand_get_Index_Proxy(
07001     ICaoCommand __RPC_FAR * This,
07002     /* [retval][out] */ long __RPC_FAR *pVal);
07003
07004
07005 void __RPC_STUB ICaoCommand_get_Index_Stub(
07006     IRpcStubBuffer *This,
07007     IRpcChannelBuffer *_pRpcChannelBuffer,
07008     PRPC_MESSAGE _pRpcMessage,
07009     DWORD *_pdwStubPhase);
07010
07011
07012 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoCommand_get_Name_Proxy(
07013     ICaoCommand __RPC_FAR * This,
07014     /* [retval][out] */ BSTR __RPC_FAR *pVal);
07015
07016
07017 void __RPC_STUB ICaoCommand_get_Name_Stub(
07018     IRpcStubBuffer *This,
07019     IRpcChannelBuffer *_pRpcChannelBuffer,
07020     PRPC_MESSAGE _pRpcMessage,
07021     DWORD *_pdwStubPhase);
07022
07023
07024 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoCommand_get_Parameters_Proxy(
07025     ICaoCommand __RPC_FAR * This,
07026     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
07027
07028
07029 void __RPC_STUB ICaoCommand_get_Parameters_Stub(
07030     IRpcStubBuffer *This,
07031     IRpcChannelBuffer *_pRpcChannelBuffer,
07032     PRPC_MESSAGE _pRpcMessage,
07033     DWORD *_pdwStubPhase);
07034
07035
07036 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoCommand_put_Parameters_Proxy(
07037     ICaoCommand __RPC_FAR * This,
07038     /* [in] */ VARIANT newVal);
07039
07040
07041 void __RPC_STUB ICaoCommand_put_Parameters_Stub(
07042     IRpcStubBuffer *This,
07043     IRpcChannelBuffer *_pRpcChannelBuffer,
07044     PRPC_MESSAGE _pRpcMessage,
07045     DWORD *_pdwStubPhase);
07046
07047
07048 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoCommand_get_Result_Proxy(
07049     ICaoCommand __RPC_FAR * This,
07050     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
07051
07052
07053 void __RPC_STUB ICaoCommand_get_Result_Stub(
07054     IRpcStubBuffer *This,
07055     IRpcChannelBuffer *_pRpcChannelBuffer,
07056     PRPC_MESSAGE _pRpcMessage,
07057     DWORD *_pdwStubPhase);
07058
07059
07060 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoCommand_get_State_Proxy(
07061     ICaoCommand __RPC_FAR * This,
07062     /* [retval][out] */ long __RPC_FAR *pVal);
07063
07064
07065 void __RPC_STUB ICaoCommand_get_State_Stub(
07066     IRpcStubBuffer *This,
07067     IRpcChannelBuffer *_pRpcChannelBuffer,
07068     PRPC_MESSAGE _pRpcMessage,
07069     DWORD *_pdwStubPhase);
07070
07071
07072 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoCommand_get_Tag_Proxy(
07073     ICaoCommand __RPC_FAR * This,
07074     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
07075
07076
07077 void __RPC_STUB ICaoCommand_get_Tag_Stub(
07078     IRpcStubBuffer *This,
07079     IRpcChannelBuffer *_pRpcChannelBuffer,
07080     PRPC_MESSAGE _pRpcMessage,
07081     DWORD *_pdwStubPhase);
07082
07083
07084 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoCommand_put_Tag_Proxy(
07085     ICaoCommand __RPC_FAR * This,
07086     /* [in] */ VARIANT newVal);
07087
07088
07089 void __RPC_STUB ICaoCommand_put_Tag_Stub(
07090     IRpcStubBuffer *This,
07091     IRpcChannelBuffer *_pRpcChannelBuffer,
07092     PRPC_MESSAGE _pRpcMessage,
07093     DWORD *_pdwStubPhase);
07094
07095
07096 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoCommand_get_Timeout_Proxy(
07097     ICaoCommand __RPC_FAR * This,
07098     /* [retval][out] */ long __RPC_FAR *pVal);
07099
07100
07101 void __RPC_STUB ICaoCommand_get_Timeout_Stub(
07102     IRpcStubBuffer *This,
07103     IRpcChannelBuffer *_pRpcChannelBuffer,
07104     PRPC_MESSAGE _pRpcMessage,
07105     DWORD *_pdwStubPhase);
07106
07107
07108 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoCommand_put_Timeout_Proxy(
07109     ICaoCommand __RPC_FAR * This,
07110     /* [in] */ long newVal);
07111
07112
07113 void __RPC_STUB ICaoCommand_put_Timeout_Stub(
07114     IRpcStubBuffer *This,
07115     IRpcChannelBuffer *_pRpcChannelBuffer,
07116     PRPC_MESSAGE _pRpcMessage,
07117     DWORD *_pdwStubPhase);
07118
07119
07120 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoCommand_get_ID_Proxy(
07121     ICaoCommand __RPC_FAR * This,
07122     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
07123
07124
07125 void __RPC_STUB ICaoCommand_get_ID_Stub(
07126     IRpcStubBuffer *This,
07127     IRpcChannelBuffer *_pRpcChannelBuffer,
07128     PRPC_MESSAGE _pRpcMessage,
07129     DWORD *_pdwStubPhase);
07130
07131
07132 /* [helpstring][id][propput] */ HRESULT STDMETHODCALLTYPE ICaoCommand_put_ID_Proxy(
07133     ICaoCommand __RPC_FAR * This,
07134     /* [in] */ VARIANT newVal);
07135
07136
07137 void __RPC_STUB ICaoCommand_put_ID_Stub(
07138     IRpcStubBuffer *This,
07139     IRpcChannelBuffer *_pRpcChannelBuffer,
07140     PRPC_MESSAGE _pRpcMessage,
07141     DWORD *_pdwStubPhase);
07142
07143
07144 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoCommand_Cancel_Proxy(
07145     ICaoCommand __RPC_FAR * This);
07146
07147
07148 void __RPC_STUB ICaoCommand_Cancel_Stub(
07149     IRpcStubBuffer *This,
07150     IRpcChannelBuffer *_pRpcChannelBuffer,
07151     PRPC_MESSAGE _pRpcMessage,
07152     DWORD *_pdwStubPhase);
07153
07154
07155 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoCommand_Execute_Proxy(
07156     ICaoCommand __RPC_FAR * This,
07157     /* [defaultvalue][in] */ long lMode);
07158
07159
07160 void __RPC_STUB ICaoCommand_Execute_Stub(
07161     IRpcStubBuffer *This,
07162     IRpcChannelBuffer *_pRpcChannelBuffer,
07163     PRPC_MESSAGE _pRpcMessage,
07164     DWORD *_pdwStubPhase);
07165
07166
07167
07168 #endif  /* __ICaoCommand_INTERFACE_DEFINED__ */
07169
07170
07171 #ifndef __ICaoMessage_INTERFACE_DEFINED__
07172 #define __ICaoMessage_INTERFACE_DEFINED__
07173
07174 /* interface ICaoMessage */
07175 /* [unique][helpstring][dual][uuid][object] */
07176
07177
07178 EXTERN_C const IID IID_ICaoMessage;
07179
07180 #if defined(__cplusplus) && !defined(CINTERFACE)
07181
07182     MIDL_INTERFACE("964497c9-a444-48e3-ad6c-78b1fa5be46f")
07183     ICaoMessage : public IDispatch
07184     {
07185     public:
07186         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_DateTime(
07187             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
07188
07189         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Description(
07190             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
07191
07192         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Destination(
07193             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
07194
07195         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Number(
07196             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
07197
07198         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_SerialNumber(
07199             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
07200
07201         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Source(
07202             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
07203
07204         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Value(
07205             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
07206
07207         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Clear( void) = 0;
07208
07209         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE Reply(
07210             VARIANT vntData) = 0;
07211
07212     };
07213
07214 #else   /* C style interface */
07215
07216     typedef struct ICaoMessageVtbl
07217     {
07218         BEGIN_INTERFACE
07219
07220         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
07221             ICaoMessage __RPC_FAR * This,
07222             /* [in] */ REFIID riid,
07223             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
07224
07225         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
07226             ICaoMessage __RPC_FAR * This);
07227
07228         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
07229             ICaoMessage __RPC_FAR * This);
07230
07231         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
07232             ICaoMessage __RPC_FAR * This,
07233             /* [out] */ UINT __RPC_FAR *pctinfo);
07234
07235         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
07236             ICaoMessage __RPC_FAR * This,
07237             /* [in] */ UINT iTInfo,
07238             /* [in] */ LCID lcid,
07239             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
07240
07241         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
07242             ICaoMessage __RPC_FAR * This,
07243             /* [in] */ REFIID riid,
07244             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
07245             /* [in] */ UINT cNames,
07246             /* [in] */ LCID lcid,
07247             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
07248
07249         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
07250             ICaoMessage __RPC_FAR * This,
07251             /* [in] */ DISPID dispIdMember,
07252             /* [in] */ REFIID riid,
07253             /* [in] */ LCID lcid,
07254             /* [in] */ WORD wFlags,
07255             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
07256             /* [out] */ VARIANT __RPC_FAR *pVarResult,
07257             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
07258             /* [out] */ UINT __RPC_FAR *puArgErr);
07259
07260         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_DateTime )(
07261             ICaoMessage __RPC_FAR * This,
07262             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
07263
07264         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Description )(
07265             ICaoMessage __RPC_FAR * This,
07266             /* [retval][out] */ BSTR __RPC_FAR *pVal);
07267
07268         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Destination )(
07269             ICaoMessage __RPC_FAR * This,
07270             /* [retval][out] */ BSTR __RPC_FAR *pVal);
07271
07272         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Number )(
07273             ICaoMessage __RPC_FAR * This,
07274             /* [retval][out] */ long __RPC_FAR *pVal);
07275
07276         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_SerialNumber )(
07277             ICaoMessage __RPC_FAR * This,
07278             /* [retval][out] */ long __RPC_FAR *pVal);
07279
07280         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Source )(
07281             ICaoMessage __RPC_FAR * This,
07282             /* [retval][out] */ BSTR __RPC_FAR *pVal);
07283
07284         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Value )(
07285             ICaoMessage __RPC_FAR * This,
07286             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
07287
07288         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Clear )(
07289             ICaoMessage __RPC_FAR * This);
07290
07291         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Reply )(
07292             ICaoMessage __RPC_FAR * This,
07293             VARIANT vntData);
07294
07295         END_INTERFACE
07296     } ICaoMessageVtbl;
07297
07298     interface ICaoMessage
07299     {
07300         CONST_VTBL struct ICaoMessageVtbl __RPC_FAR *lpVtbl;
07301     };
07302
07303
07304
07305 #ifdef COBJMACROS
07306
07307
07308 #define ICaoMessage_QueryInterface(This,riid,ppvObject) \
07309     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
07310
07311 #define ICaoMessage_AddRef(This)    \
07312     (This)->lpVtbl -> AddRef(This)
07313
07314 #define ICaoMessage_Release(This)   \
07315     (This)->lpVtbl -> Release(This)
07316
07317
07318 #define ICaoMessage_GetTypeInfoCount(This,pctinfo)  \
07319     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
07320
07321 #define ICaoMessage_GetTypeInfo(This,iTInfo,lcid,ppTInfo)   \
07322     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
07323
07324 #define ICaoMessage_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId) \
07325     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
07326
07327 #define ICaoMessage_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)   \
07328     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
07329
07330
07331 #define ICaoMessage_get_DateTime(This,pVal) \
07332     (This)->lpVtbl -> get_DateTime(This,pVal)
07333
07334 #define ICaoMessage_get_Description(This,pVal)  \
07335     (This)->lpVtbl -> get_Description(This,pVal)
07336
07337 #define ICaoMessage_get_Destination(This,pVal)  \
07338     (This)->lpVtbl -> get_Destination(This,pVal)
07339
07340 #define ICaoMessage_get_Number(This,pVal)   \
07341     (This)->lpVtbl -> get_Number(This,pVal)
07342
07343 #define ICaoMessage_get_SerialNumber(This,pVal) \
07344     (This)->lpVtbl -> get_SerialNumber(This,pVal)
07345
07346 #define ICaoMessage_get_Source(This,pVal)   \
07347     (This)->lpVtbl -> get_Source(This,pVal)
07348
07349 #define ICaoMessage_get_Value(This,pVal)    \
07350     (This)->lpVtbl -> get_Value(This,pVal)
07351
07352 #define ICaoMessage_Clear(This) \
07353     (This)->lpVtbl -> Clear(This)
07354
07355 #define ICaoMessage_Reply(This,vntData) \
07356     (This)->lpVtbl -> Reply(This,vntData)
07357
07358 #endif /* COBJMACROS */
07359
07360
07361 #endif  /* C style interface */
07362
07363
07364
07365 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoMessage_get_DateTime_Proxy(
07366     ICaoMessage __RPC_FAR * This,
07367     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
07368
07369
07370 void __RPC_STUB ICaoMessage_get_DateTime_Stub(
07371     IRpcStubBuffer *This,
07372     IRpcChannelBuffer *_pRpcChannelBuffer,
07373     PRPC_MESSAGE _pRpcMessage,
07374     DWORD *_pdwStubPhase);
07375
07376
07377 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoMessage_get_Description_Proxy(
07378     ICaoMessage __RPC_FAR * This,
07379     /* [retval][out] */ BSTR __RPC_FAR *pVal);
07380
07381
07382 void __RPC_STUB ICaoMessage_get_Description_Stub(
07383     IRpcStubBuffer *This,
07384     IRpcChannelBuffer *_pRpcChannelBuffer,
07385     PRPC_MESSAGE _pRpcMessage,
07386     DWORD *_pdwStubPhase);
07387
07388
07389 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoMessage_get_Destination_Proxy(
07390     ICaoMessage __RPC_FAR * This,
07391     /* [retval][out] */ BSTR __RPC_FAR *pVal);
07392
07393
07394 void __RPC_STUB ICaoMessage_get_Destination_Stub(
07395     IRpcStubBuffer *This,
07396     IRpcChannelBuffer *_pRpcChannelBuffer,
07397     PRPC_MESSAGE _pRpcMessage,
07398     DWORD *_pdwStubPhase);
07399
07400
07401 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoMessage_get_Number_Proxy(
07402     ICaoMessage __RPC_FAR * This,
07403     /* [retval][out] */ long __RPC_FAR *pVal);
07404
07405
07406 void __RPC_STUB ICaoMessage_get_Number_Stub(
07407     IRpcStubBuffer *This,
07408     IRpcChannelBuffer *_pRpcChannelBuffer,
07409     PRPC_MESSAGE _pRpcMessage,
07410     DWORD *_pdwStubPhase);
07411
07412
07413 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoMessage_get_SerialNumber_Proxy(
07414     ICaoMessage __RPC_FAR * This,
07415     /* [retval][out] */ long __RPC_FAR *pVal);
07416
07417
07418 void __RPC_STUB ICaoMessage_get_SerialNumber_Stub(
07419     IRpcStubBuffer *This,
07420     IRpcChannelBuffer *_pRpcChannelBuffer,
07421     PRPC_MESSAGE _pRpcMessage,
07422     DWORD *_pdwStubPhase);
07423
07424
07425 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoMessage_get_Source_Proxy(
07426     ICaoMessage __RPC_FAR * This,
07427     /* [retval][out] */ BSTR __RPC_FAR *pVal);
07428
07429
07430 void __RPC_STUB ICaoMessage_get_Source_Stub(
07431     IRpcStubBuffer *This,
07432     IRpcChannelBuffer *_pRpcChannelBuffer,
07433     PRPC_MESSAGE _pRpcMessage,
07434     DWORD *_pdwStubPhase);
07435
07436
07437 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoMessage_get_Value_Proxy(
07438     ICaoMessage __RPC_FAR * This,
07439     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
07440
07441
07442 void __RPC_STUB ICaoMessage_get_Value_Stub(
07443     IRpcStubBuffer *This,
07444     IRpcChannelBuffer *_pRpcChannelBuffer,
07445     PRPC_MESSAGE _pRpcMessage,
07446     DWORD *_pdwStubPhase);
07447
07448
07449 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoMessage_Clear_Proxy(
07450     ICaoMessage __RPC_FAR * This);
07451
07452
07453 void __RPC_STUB ICaoMessage_Clear_Stub(
07454     IRpcStubBuffer *This,
07455     IRpcChannelBuffer *_pRpcChannelBuffer,
07456     PRPC_MESSAGE _pRpcMessage,
07457     DWORD *_pdwStubPhase);
07458
07459
07460 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE ICaoMessage_Reply_Proxy(
07461     ICaoMessage __RPC_FAR * This,
07462     VARIANT vntData);
07463
07464
07465 void __RPC_STUB ICaoMessage_Reply_Stub(
07466     IRpcStubBuffer *This,
07467     IRpcChannelBuffer *_pRpcChannelBuffer,
07468     PRPC_MESSAGE _pRpcMessage,
07469     DWORD *_pdwStubPhase);
07470
07471
07472
07473 #endif  /* __ICaoMessage_INTERFACE_DEFINED__ */
07474
07475
07476 #ifndef __ICaoEngineStatus_INTERFACE_DEFINED__
07477 #define __ICaoEngineStatus_INTERFACE_DEFINED__
07478
07479 /* interface ICaoEngineStatus */
07480 /* [unique][helpstring][dual][uuid][object] */
07481
07482
07483 EXTERN_C const IID IID_ICaoEngineStatus;
07484
07485 #if defined(__cplusplus) && !defined(CINTERFACE)
07486
07487     MIDL_INTERFACE("9b77d6e0-b941-4513-8a63-08c59c992991")
07488     ICaoEngineStatus : public IDispatch
07489     {
07490     public:
07491         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_CurrentDateTime(
07492             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
07493
07494         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ComputerName(
07495             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
07496
07497         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_ObjectCounts(
07498             /* [in] */ VARIANT vntName,
07499             /* [retval][out] */ long __RPC_FAR *pVal) = 0;
07500
07501         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_StartDateTime(
07502             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
07503
07504         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Values(
07505             /* [in] */ VARIANT vntName,
07506             /* [retval][out] */ VARIANT __RPC_FAR *pVal) = 0;
07507
07508         virtual /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE get_Version(
07509             /* [retval][out] */ BSTR __RPC_FAR *pVal) = 0;
07510
07511     };
07512
07513 #else   /* C style interface */
07514
07515     typedef struct ICaoEngineStatusVtbl
07516     {
07517         BEGIN_INTERFACE
07518
07519         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
07520             ICaoEngineStatus __RPC_FAR * This,
07521             /* [in] */ REFIID riid,
07522             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
07523
07524         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
07525             ICaoEngineStatus __RPC_FAR * This);
07526
07527         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
07528             ICaoEngineStatus __RPC_FAR * This);
07529
07530         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
07531             ICaoEngineStatus __RPC_FAR * This,
07532             /* [out] */ UINT __RPC_FAR *pctinfo);
07533
07534         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
07535             ICaoEngineStatus __RPC_FAR * This,
07536             /* [in] */ UINT iTInfo,
07537             /* [in] */ LCID lcid,
07538             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
07539
07540         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
07541             ICaoEngineStatus __RPC_FAR * This,
07542             /* [in] */ REFIID riid,
07543             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
07544             /* [in] */ UINT cNames,
07545             /* [in] */ LCID lcid,
07546             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
07547
07548         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
07549             ICaoEngineStatus __RPC_FAR * This,
07550             /* [in] */ DISPID dispIdMember,
07551             /* [in] */ REFIID riid,
07552             /* [in] */ LCID lcid,
07553             /* [in] */ WORD wFlags,
07554             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
07555             /* [out] */ VARIANT __RPC_FAR *pVarResult,
07556             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
07557             /* [out] */ UINT __RPC_FAR *puArgErr);
07558
07559         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_CurrentDateTime )(
07560             ICaoEngineStatus __RPC_FAR * This,
07561             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
07562
07563         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ComputerName )(
07564             ICaoEngineStatus __RPC_FAR * This,
07565             /* [retval][out] */ BSTR __RPC_FAR *pVal);
07566
07567         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_ObjectCounts )(
07568             ICaoEngineStatus __RPC_FAR * This,
07569             /* [in] */ VARIANT vntName,
07570             /* [retval][out] */ long __RPC_FAR *pVal);
07571
07572         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_StartDateTime )(
07573             ICaoEngineStatus __RPC_FAR * This,
07574             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
07575
07576         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Values )(
07577             ICaoEngineStatus __RPC_FAR * This,
07578             /* [in] */ VARIANT vntName,
07579             /* [retval][out] */ VARIANT __RPC_FAR *pVal);
07580
07581         /* [helpstring][id][propget] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *get_Version )(
07582             ICaoEngineStatus __RPC_FAR * This,
07583             /* [retval][out] */ BSTR __RPC_FAR *pVal);
07584
07585         END_INTERFACE
07586     } ICaoEngineStatusVtbl;
07587
07588     interface ICaoEngineStatus
07589     {
07590         CONST_VTBL struct ICaoEngineStatusVtbl __RPC_FAR *lpVtbl;
07591     };
07592
07593
07594
07595 #ifdef COBJMACROS
07596
07597
07598 #define ICaoEngineStatus_QueryInterface(This,riid,ppvObject)    \
07599     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
07600
07601 #define ICaoEngineStatus_AddRef(This)   \
07602     (This)->lpVtbl -> AddRef(This)
07603
07604 #define ICaoEngineStatus_Release(This)  \
07605     (This)->lpVtbl -> Release(This)
07606
07607
07608 #define ICaoEngineStatus_GetTypeInfoCount(This,pctinfo) \
07609     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
07610
07611 #define ICaoEngineStatus_GetTypeInfo(This,iTInfo,lcid,ppTInfo)  \
07612     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
07613
07614 #define ICaoEngineStatus_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)    \
07615     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
07616
07617 #define ICaoEngineStatus_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)  \
07618     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
07619
07620
07621 #define ICaoEngineStatus_get_CurrentDateTime(This,pVal) \
07622     (This)->lpVtbl -> get_CurrentDateTime(This,pVal)
07623
07624 #define ICaoEngineStatus_get_ComputerName(This,pVal)    \
07625     (This)->lpVtbl -> get_ComputerName(This,pVal)
07626
07627 #define ICaoEngineStatus_get_ObjectCounts(This,vntName,pVal)    \
07628     (This)->lpVtbl -> get_ObjectCounts(This,vntName,pVal)
07629
07630 #define ICaoEngineStatus_get_StartDateTime(This,pVal)   \
07631     (This)->lpVtbl -> get_StartDateTime(This,pVal)
07632
07633 #define ICaoEngineStatus_get_Values(This,vntName,pVal)  \
07634     (This)->lpVtbl -> get_Values(This,vntName,pVal)
07635
07636 #define ICaoEngineStatus_get_Version(This,pVal) \
07637     (This)->lpVtbl -> get_Version(This,pVal)
07638
07639 #endif /* COBJMACROS */
07640
07641
07642 #endif  /* C style interface */
07643
07644
07645
07646 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoEngineStatus_get_CurrentDateTime_Proxy(
07647     ICaoEngineStatus __RPC_FAR * This,
07648     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
07649
07650
07651 void __RPC_STUB ICaoEngineStatus_get_CurrentDateTime_Stub(
07652     IRpcStubBuffer *This,
07653     IRpcChannelBuffer *_pRpcChannelBuffer,
07654     PRPC_MESSAGE _pRpcMessage,
07655     DWORD *_pdwStubPhase);
07656
07657
07658 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoEngineStatus_get_ComputerName_Proxy(
07659     ICaoEngineStatus __RPC_FAR * This,
07660     /* [retval][out] */ BSTR __RPC_FAR *pVal);
07661
07662
07663 void __RPC_STUB ICaoEngineStatus_get_ComputerName_Stub(
07664     IRpcStubBuffer *This,
07665     IRpcChannelBuffer *_pRpcChannelBuffer,
07666     PRPC_MESSAGE _pRpcMessage,
07667     DWORD *_pdwStubPhase);
07668
07669
07670 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoEngineStatus_get_ObjectCounts_Proxy(
07671     ICaoEngineStatus __RPC_FAR * This,
07672     /* [in] */ VARIANT vntName,
07673     /* [retval][out] */ long __RPC_FAR *pVal);
07674
07675
07676 void __RPC_STUB ICaoEngineStatus_get_ObjectCounts_Stub(
07677     IRpcStubBuffer *This,
07678     IRpcChannelBuffer *_pRpcChannelBuffer,
07679     PRPC_MESSAGE _pRpcMessage,
07680     DWORD *_pdwStubPhase);
07681
07682
07683 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoEngineStatus_get_StartDateTime_Proxy(
07684     ICaoEngineStatus __RPC_FAR * This,
07685     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
07686
07687
07688 void __RPC_STUB ICaoEngineStatus_get_StartDateTime_Stub(
07689     IRpcStubBuffer *This,
07690     IRpcChannelBuffer *_pRpcChannelBuffer,
07691     PRPC_MESSAGE _pRpcMessage,
07692     DWORD *_pdwStubPhase);
07693
07694
07695 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoEngineStatus_get_Values_Proxy(
07696     ICaoEngineStatus __RPC_FAR * This,
07697     /* [in] */ VARIANT vntName,
07698     /* [retval][out] */ VARIANT __RPC_FAR *pVal);
07699
07700
07701 void __RPC_STUB ICaoEngineStatus_get_Values_Stub(
07702     IRpcStubBuffer *This,
07703     IRpcChannelBuffer *_pRpcChannelBuffer,
07704     PRPC_MESSAGE _pRpcMessage,
07705     DWORD *_pdwStubPhase);
07706
07707
07708 /* [helpstring][id][propget] */ HRESULT STDMETHODCALLTYPE ICaoEngineStatus_get_Version_Proxy(
07709     ICaoEngineStatus __RPC_FAR * This,
07710     /* [retval][out] */ BSTR __RPC_FAR *pVal);
07711
07712
07713 void __RPC_STUB ICaoEngineStatus_get_Version_Stub(
07714     IRpcStubBuffer *This,
07715     IRpcChannelBuffer *_pRpcChannelBuffer,
07716     PRPC_MESSAGE _pRpcMessage,
07717     DWORD *_pdwStubPhase);
07718
07719
07720
07721 #endif  /* __ICaoEngineStatus_INTERFACE_DEFINED__ */
07722
07723
07724 #ifndef __IEventSink_INTERFACE_DEFINED__
07725 #define __IEventSink_INTERFACE_DEFINED__
07726
07727 /* interface IEventSink */
07728 /* [unique][helpstring][dual][uuid][object] */
07729
07730
07731 EXTERN_C const IID IID_IEventSink;
07732
07733 #if defined(__cplusplus) && !defined(CINTERFACE)
07734
07735     MIDL_INTERFACE("2b27bcbf-c3c2-45dd-ba66-8ac0fa898c1c")
07736     IEventSink : public IDispatch
07737     {
07738     public:
07739         virtual /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE OnMessage(
07740             /* [in] */ IUnknown __RPC_FAR *pVal,
07741             /* [defaultvalue][in] */ long lOption = 0) = 0;
07742
07743     };
07744
07745 #else   /* C style interface */
07746
07747     typedef struct IEventSinkVtbl
07748     {
07749         BEGIN_INTERFACE
07750
07751         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
07752             IEventSink __RPC_FAR * This,
07753             /* [in] */ REFIID riid,
07754             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
07755
07756         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
07757             IEventSink __RPC_FAR * This);
07758
07759         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
07760             IEventSink __RPC_FAR * This);
07761
07762         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
07763             IEventSink __RPC_FAR * This,
07764             /* [out] */ UINT __RPC_FAR *pctinfo);
07765
07766         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
07767             IEventSink __RPC_FAR * This,
07768             /* [in] */ UINT iTInfo,
07769             /* [in] */ LCID lcid,
07770             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
07771
07772         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
07773             IEventSink __RPC_FAR * This,
07774             /* [in] */ REFIID riid,
07775             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
07776             /* [in] */ UINT cNames,
07777             /* [in] */ LCID lcid,
07778             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
07779
07780         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
07781             IEventSink __RPC_FAR * This,
07782             /* [in] */ DISPID dispIdMember,
07783             /* [in] */ REFIID riid,
07784             /* [in] */ LCID lcid,
07785             /* [in] */ WORD wFlags,
07786             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
07787             /* [out] */ VARIANT __RPC_FAR *pVarResult,
07788             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
07789             /* [out] */ UINT __RPC_FAR *puArgErr);
07790
07791         /* [helpstring][id] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *OnMessage )(
07792             IEventSink __RPC_FAR * This,
07793             /* [in] */ IUnknown __RPC_FAR *pVal,
07794             /* [defaultvalue][in] */ long lOption);
07795
07796         END_INTERFACE
07797     } IEventSinkVtbl;
07798
07799     interface IEventSink
07800     {
07801         CONST_VTBL struct IEventSinkVtbl __RPC_FAR *lpVtbl;
07802     };
07803
07804
07805
07806 #ifdef COBJMACROS
07807
07808
07809 #define IEventSink_QueryInterface(This,riid,ppvObject)  \
07810     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
07811
07812 #define IEventSink_AddRef(This) \
07813     (This)->lpVtbl -> AddRef(This)
07814
07815 #define IEventSink_Release(This)    \
07816     (This)->lpVtbl -> Release(This)
07817
07818
07819 #define IEventSink_GetTypeInfoCount(This,pctinfo)   \
07820     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
07821
07822 #define IEventSink_GetTypeInfo(This,iTInfo,lcid,ppTInfo)    \
07823     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
07824
07825 #define IEventSink_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)  \
07826     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
07827
07828 #define IEventSink_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)    \
07829     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
07830
07831
07832 #define IEventSink_OnMessage(This,pVal,lOption) \
07833     (This)->lpVtbl -> OnMessage(This,pVal,lOption)
07834
07835 #endif /* COBJMACROS */
07836
07837
07838 #endif  /* C style interface */
07839
07840
07841
07842 /* [helpstring][id] */ HRESULT STDMETHODCALLTYPE IEventSink_OnMessage_Proxy(
07843     IEventSink __RPC_FAR * This,
07844     /* [in] */ IUnknown __RPC_FAR *pVal,
07845     /* [defaultvalue][in] */ long lOption);
07846
07847
07848 void __RPC_STUB IEventSink_OnMessage_Stub(
07849     IRpcStubBuffer *This,
07850     IRpcChannelBuffer *_pRpcChannelBuffer,
07851     PRPC_MESSAGE _pRpcMessage,
07852     DWORD *_pdwStubPhase);
07853
07854
07855
07856 #endif  /* __IEventSink_INTERFACE_DEFINED__ */
07857
07858
07859
07860 #ifndef __CAOLib_LIBRARY_DEFINED__
07861 #define __CAOLib_LIBRARY_DEFINED__
07862
07863 /* library CAOLib */
07864 /* [helpstring][version][uuid] */
07865
07866
07867 EXTERN_C const IID LIBID_CAOLib;
07868
07869 #ifndef ___ICaoControllerEvents_DISPINTERFACE_DEFINED__
07870 #define ___ICaoControllerEvents_DISPINTERFACE_DEFINED__
07871
07872 /* dispinterface _ICaoControllerEvents */
07873 /* [helpstring][uuid] */
07874
07875
07876 EXTERN_C const IID DIID__ICaoControllerEvents;
07877
07878 #if defined(__cplusplus) && !defined(CINTERFACE)
07879
07880     MIDL_INTERFACE("a7b43ef1-0215-4940-a6f6-21744b8cba52")
07881     _ICaoControllerEvents : public IDispatch
07882     {
07883     };
07884
07885 #else   /* C style interface */
07886
07887     typedef struct _ICaoControllerEventsVtbl
07888     {
07889         BEGIN_INTERFACE
07890
07891         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
07892             _ICaoControllerEvents __RPC_FAR * This,
07893             /* [in] */ REFIID riid,
07894             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
07895
07896         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
07897             _ICaoControllerEvents __RPC_FAR * This);
07898
07899         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
07900             _ICaoControllerEvents __RPC_FAR * This);
07901
07902         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
07903             _ICaoControllerEvents __RPC_FAR * This,
07904             /* [out] */ UINT __RPC_FAR *pctinfo);
07905
07906         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
07907             _ICaoControllerEvents __RPC_FAR * This,
07908             /* [in] */ UINT iTInfo,
07909             /* [in] */ LCID lcid,
07910             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
07911
07912         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
07913             _ICaoControllerEvents __RPC_FAR * This,
07914             /* [in] */ REFIID riid,
07915             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
07916             /* [in] */ UINT cNames,
07917             /* [in] */ LCID lcid,
07918             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
07919
07920         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
07921             _ICaoControllerEvents __RPC_FAR * This,
07922             /* [in] */ DISPID dispIdMember,
07923             /* [in] */ REFIID riid,
07924             /* [in] */ LCID lcid,
07925             /* [in] */ WORD wFlags,
07926             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
07927             /* [out] */ VARIANT __RPC_FAR *pVarResult,
07928             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
07929             /* [out] */ UINT __RPC_FAR *puArgErr);
07930
07931         END_INTERFACE
07932     } _ICaoControllerEventsVtbl;
07933
07934     interface _ICaoControllerEvents
07935     {
07936         CONST_VTBL struct _ICaoControllerEventsVtbl __RPC_FAR *lpVtbl;
07937     };
07938
07939
07940
07941 #ifdef COBJMACROS
07942
07943
07944 #define _ICaoControllerEvents_QueryInterface(This,riid,ppvObject)   \
07945     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
07946
07947 #define _ICaoControllerEvents_AddRef(This)  \
07948     (This)->lpVtbl -> AddRef(This)
07949
07950 #define _ICaoControllerEvents_Release(This) \
07951     (This)->lpVtbl -> Release(This)
07952
07953
07954 #define _ICaoControllerEvents_GetTypeInfoCount(This,pctinfo)    \
07955     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
07956
07957 #define _ICaoControllerEvents_GetTypeInfo(This,iTInfo,lcid,ppTInfo) \
07958     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
07959
07960 #define _ICaoControllerEvents_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)   \
07961     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
07962
07963 #define _ICaoControllerEvents_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr) \
07964     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
07965
07966 #endif /* COBJMACROS */
07967
07968
07969 #endif  /* C style interface */
07970
07971
07972 #endif  /* ___ICaoControllerEvents_DISPINTERFACE_DEFINED__ */
07973
07974
07975 #ifndef ___ICaoCommandsEvents_DISPINTERFACE_DEFINED__
07976 #define ___ICaoCommandsEvents_DISPINTERFACE_DEFINED__
07977
07978 /* dispinterface _ICaoCommandsEvents */
07979 /* [helpstring][uuid] */
07980
07981
07982 EXTERN_C const IID DIID__ICaoCommandsEvents;
07983
07984 #if defined(__cplusplus) && !defined(CINTERFACE)
07985
07986     MIDL_INTERFACE("DC17F478-F7B2-4ce7-819D-8EF34F70E351")
07987     _ICaoCommandsEvents : public IDispatch
07988     {
07989     };
07990
07991 #else   /* C style interface */
07992
07993     typedef struct _ICaoCommandsEventsVtbl
07994     {
07995         BEGIN_INTERFACE
07996
07997         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *QueryInterface )(
07998             _ICaoCommandsEvents __RPC_FAR * This,
07999             /* [in] */ REFIID riid,
08000             /* [iid_is][out] */ void __RPC_FAR *__RPC_FAR *ppvObject);
08001
08002         ULONG ( STDMETHODCALLTYPE __RPC_FAR *AddRef )(
08003             _ICaoCommandsEvents __RPC_FAR * This);
08004
08005         ULONG ( STDMETHODCALLTYPE __RPC_FAR *Release )(
08006             _ICaoCommandsEvents __RPC_FAR * This);
08007
08008         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfoCount )(
08009             _ICaoCommandsEvents __RPC_FAR * This,
08010             /* [out] */ UINT __RPC_FAR *pctinfo);
08011
08012         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetTypeInfo )(
08013             _ICaoCommandsEvents __RPC_FAR * This,
08014             /* [in] */ UINT iTInfo,
08015             /* [in] */ LCID lcid,
08016             /* [out] */ ITypeInfo __RPC_FAR *__RPC_FAR *ppTInfo);
08017
08018         HRESULT ( STDMETHODCALLTYPE __RPC_FAR *GetIDsOfNames )(
08019             _ICaoCommandsEvents __RPC_FAR * This,
08020             /* [in] */ REFIID riid,
08021             /* [size_is][in] */ LPOLESTR __RPC_FAR *rgszNames,
08022             /* [in] */ UINT cNames,
08023             /* [in] */ LCID lcid,
08024             /* [size_is][out] */ DISPID __RPC_FAR *rgDispId);
08025
08026         /* [local] */ HRESULT ( STDMETHODCALLTYPE __RPC_FAR *Invoke )(
08027             _ICaoCommandsEvents __RPC_FAR * This,
08028             /* [in] */ DISPID dispIdMember,
08029             /* [in] */ REFIID riid,
08030             /* [in] */ LCID lcid,
08031             /* [in] */ WORD wFlags,
08032             /* [out][in] */ DISPPARAMS __RPC_FAR *pDispParams,
08033             /* [out] */ VARIANT __RPC_FAR *pVarResult,
08034             /* [out] */ EXCEPINFO __RPC_FAR *pExcepInfo,
08035             /* [out] */ UINT __RPC_FAR *puArgErr);
08036
08037         END_INTERFACE
08038     } _ICaoCommandsEventsVtbl;
08039
08040     interface _ICaoCommandsEvents
08041     {
08042         CONST_VTBL struct _ICaoCommandsEventsVtbl __RPC_FAR *lpVtbl;
08043     };
08044
08045
08046
08047 #ifdef COBJMACROS
08048
08049
08050 #define _ICaoCommandsEvents_QueryInterface(This,riid,ppvObject) \
08051     (This)->lpVtbl -> QueryInterface(This,riid,ppvObject)
08052
08053 #define _ICaoCommandsEvents_AddRef(This)    \
08054     (This)->lpVtbl -> AddRef(This)
08055
08056 #define _ICaoCommandsEvents_Release(This)   \
08057     (This)->lpVtbl -> Release(This)
08058
08059
08060 #define _ICaoCommandsEvents_GetTypeInfoCount(This,pctinfo)  \
08061     (This)->lpVtbl -> GetTypeInfoCount(This,pctinfo)
08062
08063 #define _ICaoCommandsEvents_GetTypeInfo(This,iTInfo,lcid,ppTInfo)   \
08064     (This)->lpVtbl -> GetTypeInfo(This,iTInfo,lcid,ppTInfo)
08065
08066 #define _ICaoCommandsEvents_GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId) \
08067     (This)->lpVtbl -> GetIDsOfNames(This,riid,rgszNames,cNames,lcid,rgDispId)
08068
08069 #define _ICaoCommandsEvents_Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)   \
08070     (This)->lpVtbl -> Invoke(This,dispIdMember,riid,lcid,wFlags,pDispParams,pVarResult,pExcepInfo,puArgErr)
08071
08072 #endif /* COBJMACROS */
08073
08074
08075 #endif  /* C style interface */
08076
08077
08078 #endif  /* ___ICaoCommandsEvents_DISPINTERFACE_DEFINED__ */
08079
08080
08081 EXTERN_C const CLSID CLSID_CaoEngine;
08082
08083 #ifdef __cplusplus
08084
08085 class DECLSPEC_UUID("60555f1b-e473-4250-bb43-933990fbeced")
08086 CaoEngine;
08087 #endif
08088
08089 EXTERN_C const CLSID CLSID_CaoWorkspaces;
08090
08091 #ifdef __cplusplus
08092
08093 class DECLSPEC_UUID("f7430785-4ec2-4193-8552-f5cb2d6be732")
08094 CaoWorkspaces;
08095 #endif
08096
08097 EXTERN_C const CLSID CLSID_CaoWorkspace;
08098
08099 #ifdef __cplusplus
08100
08101 class DECLSPEC_UUID("22fc99b8-9c3a-48c9-9f4d-8eee16ed365a")
08102 CaoWorkspace;
08103 #endif
08104
08105 EXTERN_C const CLSID CLSID_CaoControllers;
08106
08107 #ifdef __cplusplus
08108
08109 class DECLSPEC_UUID("41c404be-bfd1-40ce-8454-2f47e04a09b1")
08110 CaoControllers;
08111 #endif
08112
08113 EXTERN_C const CLSID CLSID_CaoController;
08114
08115 #ifdef __cplusplus
08116
08117 class DECLSPEC_UUID("d1baa44e-9ca9-4075-8ad1-481aa21434a8")
08118 CaoController;
08119 #endif
08120
08121 EXTERN_C const CLSID CLSID_CaoExtensions;
08122
08123 #ifdef __cplusplus
08124
08125 class DECLSPEC_UUID("0AF9CEC7-4F11-4EA4-8033-142CF4E45512")
08126 CaoExtensions;
08127 #endif
08128
08129 EXTERN_C const CLSID CLSID_CaoExtension;
08130
08131 #ifdef __cplusplus
08132
08133 class DECLSPEC_UUID("FE266A3E-9435-4F25-85E2-B4350A378B81")
08134 CaoExtension;
08135 #endif
08136
08137 EXTERN_C const CLSID CLSID_CaoFiles;
08138
08139 #ifdef __cplusplus
08140
08141 class DECLSPEC_UUID("2d662501-91ce-49e0-bafa-453a2d610b50")
08142 CaoFiles;
08143 #endif
08144
08145 EXTERN_C const CLSID CLSID_CaoFile;
08146
08147 #ifdef __cplusplus
08148
08149 class DECLSPEC_UUID("b7466915-2234-4382-b9e7-da74a34acaff")
08150 CaoFile;
08151 #endif
08152
08153 EXTERN_C const CLSID CLSID_CaoRobots;
08154
08155 #ifdef __cplusplus
08156
08157 class DECLSPEC_UUID("f6981128-7e0f-4159-86b0-7397eb1596a3")
08158 CaoRobots;
08159 #endif
08160
08161 EXTERN_C const CLSID CLSID_CaoRobot;
08162
08163 #ifdef __cplusplus
08164
08165 class DECLSPEC_UUID("c486acdd-451e-4fb5-a20b-3cc747f8cc2e")
08166 CaoRobot;
08167 #endif
08168
08169 EXTERN_C const CLSID CLSID_CaoTasks;
08170
08171 #ifdef __cplusplus
08172
08173 class DECLSPEC_UUID("eb5211bb-dd98-4e91-b84f-a619f636de30")
08174 CaoTasks;
08175 #endif
08176
08177 EXTERN_C const CLSID CLSID_CaoTask;
08178
08179 #ifdef __cplusplus
08180
08181 class DECLSPEC_UUID("1ab45162-d81d-475c-a73f-3f9bbc0f0768")
08182 CaoTask;
08183 #endif
08184
08185 EXTERN_C const CLSID CLSID_CaoVariables;
08186
08187 #ifdef __cplusplus
08188
08189 class DECLSPEC_UUID("5691304f-610a-4645-8d58-64138e059824")
08190 CaoVariables;
08191 #endif
08192
08193 EXTERN_C const CLSID CLSID_CaoVariable;
08194
08195 #ifdef __cplusplus
08196
08197 class DECLSPEC_UUID("2c9b6656-32d1-425c-ad61-536c5a07c773")
08198 CaoVariable;
08199 #endif
08200
08201 EXTERN_C const CLSID CLSID_CaoCommands;
08202
08203 #ifdef __cplusplus
08204
08205 class DECLSPEC_UUID("887FFEAF-3E41-4d54-A558-DE75E7E11B44")
08206 CaoCommands;
08207 #endif
08208
08209 EXTERN_C const CLSID CLSID_CaoCommand;
08210
08211 #ifdef __cplusplus
08212
08213 class DECLSPEC_UUID("9289DBE4-ADEC-4001-9CF0-C58C756B2E79")
08214 CaoCommand;
08215 #endif
08216
08217 EXTERN_C const CLSID CLSID_CaoMessage;
08218
08219 #ifdef __cplusplus
08220
08221 class DECLSPEC_UUID("4f2f3700-71c8-452a-81ac-5a8539b8a5c6")
08222 CaoMessage;
08223 #endif
08224
08225 EXTERN_C const CLSID CLSID_CaoEngineStatus;
08226
08227 #ifdef __cplusplus
08228
08229 class DECLSPEC_UUID("f5e9b29c-e1d6-4f78-ac18-a85ae49dbbb2")
08230 CaoEngineStatus;
08231 #endif
08232
08233 EXTERN_C const CLSID CLSID_EventSink;
08234
08235 #ifdef __cplusplus
08236
08237 class DECLSPEC_UUID("12654e13-f7bc-4f1a-831d-a7a93e733cb7")
08238 EventSink;
08239 #endif
08240 #endif /* __CAOLib_LIBRARY_DEFINED__ */
08241
08242 /* Additional Prototypes for ALL interfaces */
08243
08244 unsigned long             __RPC_USER  BSTR_UserSize(     unsigned long __RPC_FAR *, unsigned long            , BSTR __RPC_FAR * );
08245 unsigned char __RPC_FAR * __RPC_USER  BSTR_UserMarshal(  unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR * );
08246 unsigned char __RPC_FAR * __RPC_USER  BSTR_UserUnmarshal(unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, BSTR __RPC_FAR * );
08247 void                      __RPC_USER  BSTR_UserFree(     unsigned long __RPC_FAR *, BSTR __RPC_FAR * );
08248
08249 unsigned long             __RPC_USER  VARIANT_UserSize(     unsigned long __RPC_FAR *, unsigned long            , VARIANT __RPC_FAR * );
08250 unsigned char __RPC_FAR * __RPC_USER  VARIANT_UserMarshal(  unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, VARIANT __RPC_FAR * );
08251 unsigned char __RPC_FAR * __RPC_USER  VARIANT_UserUnmarshal(unsigned long __RPC_FAR *, unsigned char __RPC_FAR *, VARIANT __RPC_FAR * );
08252 void                      __RPC_USER  VARIANT_UserFree(     unsigned long __RPC_FAR *, VARIANT __RPC_FAR * );
08253
08254 /* end of Additional Prototypes */
08255
08256 #ifdef __cplusplus
08257 }
08258 #endif
08259
08260 #endif
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAO.idl File Reference

CAO.idl の解説

CAO.dll 用の IDL ソース ファイル. [詳細]

ソースコードを見る。

名前空間

namespace | CAOLib

構成

interface | ICaoCommand
interface | ICaoCommands
interface | ICaoController
interface | ICaoControllers
interface | ICaoEngine
interface | ICaoEngineStatus
interface | ICaoExtension
interface | ICaoExtensions
interface | ICaoFile
interface | ICaoFiles
interface | ICaoMessage
interface | ICaoRobot
interface | ICaoRobots
interface | ICaoTask
interface | ICaoTasks
interface | ICaoVariable
interface | ICaoVariables
interface | ICaoWorkspace
interface | ICaoWorkspaces
interface | IEventSink

解説

CAO.dll 用の IDL ソース ファイル.

  このファイルはタイプ ライブラリ (CAO.tlb) を作成するために 　タイプ ライブラリ作成ツール MIDL によって処理されます．

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:46 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAO.idl Source File

CAO.idl

解説を見る。
00001
00014 import "oaidl.idl";
00015 import "ocidl.idl";
00016
00017 /* ------------------------- */
00018 /* CAO Interface Definitions */
00019 /* ------------------------- */
00020 interface ICaoWorkspaces;
00021 interface ICaoWorkspace;
00022 interface ICaoControllers;
00023 interface ICaoController;
00024 interface ICaoExtensions;
00025 interface ICaoExtension;
00026 interface ICaoFiles;
00027 interface ICaoFile;
00028 interface ICaoRobots;
00029 interface ICaoRobot;
00030 interface ICaoTasks;
00031 interface ICaoTask;
00032 interface ICaoVariables;
00033 interface ICaoVariable;
00034 interface ICaoCommands;
00035 interface ICaoCommand;
00036 interface ICaoMessage;
00037 interface ICaoEngineStatus;
00038
00039 // ICaoEngine Interface
00040 [
00041     object,
00042     uuid(5acfd9fe-41f0-43f6-a0d6-c10c079315fc),
00043     dual,
00044     helpstring("ICaoEngine Interface"),
00045     pointer_default(unique)
00046 ]
00047 interface ICaoEngine : IDispatch
00048 {
00049     [propget, id(1), helpstring("Property EngineStatus")] HRESULT EngineStatus([out, retval] ICaoEngineStatus **ppICaoEngineStatus);
00050     [propget, id(2), helpstring("Property Workspaces")] HRESULT Workspaces([out, retval]  ICaoWorkspaces **ppICaoWSs);
00051     [id(3), helpstring("Method AddWorkspace")] HRESULT AddWorkspace([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoWorkspace **ppICaoWS);
00052     [id(4), helpstring("Method Execute")] HRESULT Execute([in] VARIANT vntCommand, [out, retval] VARIANT *pVal);
00053 };
00054
00055 // ICaoWorkspaces Interface
00056 [
00057     object,
00058     uuid(8dcdfb4e-cf07-47ca-895f-db1d5afa8f74),
00059     dual,
00060     helpstring("ICaoWorkspaces Interface"),
00061     pointer_default(unique)
00062 ]
00063 interface ICaoWorkspaces : IDispatch
00064 {
00065     [propget, id(-4), helpstring("Property _NewEnum"), restricted] HRESULT _NewEnum([out, retval] LPUNKNOWN *pVal);
00066     [id(0), helpstring("Method Item")] HRESULT Item([in] VARIANT Index, [out, retval] ICaoWorkspace **ppICaoWS);
00067
00068     [propget, id(1), helpstring("Property Count")] HRESULT Count([out, retval] long *pVal);
00069
00070     [id(2), helpstring("Method Add")] HRESULT Add([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoWorkspace **ppICaoWS);
00071     [id(3), helpstring("Method Remove")] HRESULT Remove([in] VARIANT Index);
00072     [id(4), helpstring("Method Clear")] HRESULT Clear();
00073     [id(5), helpstring("Method IsMember")] HRESULT IsMember([in] VARIANT Index, [out, retval] VARIANT_BOOL *pVal);
00074 };
00075
00076 // ICaoWorkspace Interface
00077 [
00078     object,
00079     uuid(0ed07c17-b078-40cf-9b0f-3a4974de55e5),
00080     dual,
00081     helpstring("ICaoWorkspace Interface"),
00082     pointer_default(unique)
00083 ]
00084 interface ICaoWorkspace : IDispatch
00085 {
00086     [id(1), helpstring("Method _PutIndex"), restricted] HRESULT _PutIndex([in] long newVal);
00087
00088     [propget, id(2), helpstring("Property Controllers")] HRESULT Controllers([out, retval]  ICaoControllers **ppICaoCtrls);
00089     [propget, id(3), helpstring("Property Index")] HRESULT Index([out, retval] long *pVal);
00090     [propget, id(4), helpstring("Property Name")] HRESULT Name([out, retval] BSTR *pVal);
00091     [propget, id(5), helpstring("Property ProviderNames")] HRESULT ProviderNames([in, defaultvalue("")] BSTR bstrOption, [out, retval] VARIANT *pVal);
00092
00093     [id(6), helpstring("Method AddController")] HRESULT AddController([in] BSTR bstrController, [in] BSTR bstrProvider, [in, defaultvalue("")] BSTR bstrMachine, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoController **ppICaoCtrl);
00094     [id(7), helpstring("Method Execute")] HRESULT Execute([in] VARIANT vntCommand, [out, retval] VARIANT *pVal);
00095
00096 };
00097
00098 // ICaoControllers Interface
00099 [
00100     object,
00101     uuid(474b2753-9f06-41e0-840b-1f26b1ac1c2c),
00102     dual,
00103     helpstring("ICaoControllers Interface"),
00104     pointer_default(unique)
00105 ]
00106 interface ICaoControllers : IDispatch
00107 {
00108     [propget, id(-4), helpstring("Property _NewEnum"), restricted] HRESULT _NewEnum([out, retval] LPUNKNOWN *pVal);
00109     [id(0), helpstring("Method Item")] HRESULT Item([in] VARIANT Index, [out, retval]  ICaoController **ppICaoCtrl);
00110
00111     [propget, id(1), helpstring("Property Count")] HRESULT Count([out, retval] long *pVal);
00112
00113     [id(2), helpstring("Method Add")] HRESULT Add([in] BSTR bstrController, [in] BSTR bstrProvider, [in, defaultvalue("")] BSTR bstrMachine, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoController **ppICaoCtrl);
00114     [id(3), helpstring("Method Remove")] HRESULT Remove([in] VARIANT Index);
00115     [id(4), helpstring("Method Clear")] HRESULT Clear();
00116     [id(5), helpstring("Method IsMember")] HRESULT IsMember([in] VARIANT Index, [out, retval] VARIANT_BOOL *pVal);
00117 };
00118
00119 // ICaoController Interface
00120 [
00121     object,
00122     uuid(c94e794f-ec5b-43f2-879f-777a49e7305b),
00123     dual,
00124     helpstring("ICaoController Interface"),
00125     pointer_default(unique)
00126 ]
00127 interface ICaoController : IDispatch
00128 {
00129     [id(1), helpstring("Method _PutIndex"), restricted] HRESULT _PutIndex([in] long newVal);
00130
00131     [propget, id(2), helpstring("Property Attribute")] HRESULT Attribute([out, retval] long *pVal);
00132     [propget, id(3), helpstring("Property ExtensionNames")] HRESULT ExtensionNames([in, defaultvalue("")] BSTR bstrOption, [out, retval] VARIANT *pVal);
00133     [propget, id(4), helpstring("Property Extensions")] HRESULT Extensions([out, retval] ICaoExtensions **ppICaoExtensions);
00134     [propget, id(5), helpstring("Property FileNames")] HRESULT FileNames([in, defaultvalue("")] BSTR bstrOption, [out, retval] VARIANT *pVal);
00135     [propget, id(6), helpstring("Property Files")] HRESULT Files([out, retval]  ICaoFiles **ppICaoFiles);
00136     [propget, id(7), helpstring("Property Help")] HRESULT Help([out, retval] BSTR *pVal);
00137     [propget, id(8), helpstring("Property Index")] HRESULT Index([out, retval] long *pVal);
00138     [propget, id(9), helpstring("Property Name")] HRESULT Name([out, retval] BSTR *pVal);
00139     [propget, id(10), helpstring("Property RobotNames")] HRESULT RobotNames([in, defaultvalue("")] BSTR bstrOption, [out, retval] VARIANT *pVal);
00140     [propget, id(11), helpstring("Property Robots")] HRESULT Robots([out, retval]  ICaoRobots **ppICaoRobots);
00141     [propget, id(12), helpstring("Property Tag")] HRESULT Tag([out, retval] VARIANT *pVal);
00142     [propput, id(12), helpstring("Property Tag")] HRESULT Tag([in] VARIANT newVal);
00143     [propget, id(13), helpstring("Property TaskNames")] HRESULT TaskNames([in, defaultvalue("")] BSTR bstrOption, [out, retval] VARIANT *pVal);
00144     [propget, id(14), helpstring("Property Tasks")] HRESULT Tasks([out, retval]  ICaoTasks **ppICaoTasks);
00145     [propget, id(15), helpstring("Property VariableNames")] HRESULT VariableNames([in, defaultvalue("")] BSTR bstrOption, [out, retval] VARIANT *pVal);
00146     [propget, id(16), helpstring("Property Variables")] HRESULT Variables([out, retval] ICaoVariables **ppICaoVariables);
00147     [propget, id(17), helpstring("Property CommandNames")] HRESULT CommandNames([in, defaultvalue("")] BSTR bstrOption, [out, retval] VARIANT *pVal);
00148     [propget, id(18), helpstring("Property Commands")] HRESULT Commands([out, retval] ICaoCommands **ppICaoCommands);
00149     [propget, id(19), helpstring("Property ID")] HRESULT ID([out, retval] VARIANT *pVal);
00150     [propput, id(19), helpstring("Property ID")] HRESULT ID([in] VARIANT newVal);
00151
00152     [id(20), helpstring("Method AddExtension")] HRESULT AddExtension([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoExtension **ppICaoExtension);
00153     [id(21), helpstring("Method AddFile")] HRESULT AddFile([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoFile **ppICaoFile);
00154     [id(22), helpstring("Method AddRobot")] HRESULT AddRobot([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoRobot **ppICaoRobot);
00155     [id(23), helpstring("Method AddTask")] HRESULT AddTask([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoTask **ppICaoTask);
00156     [id(24), helpstring("Method AddVariable")] HRESULT AddVariable([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoVariable **ppICaoVar);
00157     [id(25), helpstring("Method AddCommand")] HRESULT AddCommand([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoCommand **ppICaoCommand);
00158     [id(26), helpstring("Method Execute")] HRESULT Execute([in] VARIANT vntCommand, [out, retval] VARIANT *pVal);
00159     [id(27), helpstring("Method GetMessage")] HRESULT GetMessage([out, retval] ICaoMessage **ppICaoMessage);
00160
00161 };
00162
00163 // ICaoExtensions Interface
00164 [
00165     object,
00166     uuid(c5cd2d49-d7b9-4c6d-8d0d-56a566b78042),
00167     dual,
00168     helpstring("ICaoExtensions Interface"),
00169     pointer_default(unique)
00170 ]
00171 interface ICaoExtensions : IDispatch
00172 {
00173     [propget, id(-4), helpstring("Property _NewEnum"), restricted] HRESULT _NewEnum([out, retval] LPUNKNOWN *pVal);
00174     [id(0), helpstring("Method Item")] HRESULT Item([in] VARIANT Index, [out, retval] ICaoExtension **ppICaoExtension);
00175
00176     [propget, id(1), helpstring("Property Count")] HRESULT Count([out, retval] long *pVal);
00177
00178     [id(2), helpstring("Method Add")] HRESULT Add([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoExtension **ppICaoExtension);
00179     [id(3), helpstring("Method Remove")] HRESULT Remove([in] VARIANT Index);
00180     [id(4), helpstring("Method Clear")] HRESULT Clear();
00181     [id(5), helpstring("Method IsMember")] HRESULT IsMember([in] VARIANT Index, [out, retval] VARIANT_BOOL *pVal);
00182
00183 };
00184
00185 // ICaoExtension Interface
00186 [
00187     object,
00188     uuid(a2e8ab44-325e-4fd8-8e92-55a91d213d19),
00189     dual,
00190     helpstring("ICaoExtension Interface"),
00191     pointer_default(unique)
00192 ]
00193 interface ICaoExtension : IDispatch
00194 {
00195     [id(1), helpstring("Method _PutIndex"), restricted] HRESULT _PutIndex([in] long newVal);
00196
00197     [propget, id(2), helpstring("Property Attribute")] HRESULT Attribute([out, retval] long *pVal);
00198     [propget, id(3), helpstring("Property Help")] HRESULT Help([out, retval] BSTR *pVal);
00199     [propget, id(4), helpstring("Property Index")] HRESULT Index([out, retval] long *pVal);
00200     [propget, id(5), helpstring("Property Name")] HRESULT Name([out, retval] BSTR *pVal);
00201     [propget, id(6), helpstring("Property Tag")] HRESULT Tag([out, retval] VARIANT *pVal);
00202     [propput, id(6), helpstring("Property Tag")] HRESULT Tag([in] VARIANT newVal);
00203     [propget, id(7), helpstring("Property VariableNames")] HRESULT VariableNames([in, defaultvalue("")] BSTR bstrOption, [out, retval] VARIANT *pVal);
00204     [propget, id(8), helpstring("Property Variables")] HRESULT Variables([out, retval] ICaoVariables **ppICaoVariables);
00205     [propget, id(9), helpstring("Property ID")] HRESULT ID([out, retval] VARIANT *pVal);
00206     [propput, id(9), helpstring("Property ID")] HRESULT ID([in] VARIANT newVal);
00207
00208     [id(10), helpstring("Method AddVariable")] HRESULT AddVariable([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoVariable **ppICaoVar);
00209     [id(11), helpstring("Method Execute")] HRESULT Execute([in] VARIANT vntCommand, [out, retval] VARIANT *pVal);
00210
00211 };
00212
00213 // ICaoFiles Interface
00214 [
00215     object,
00216     uuid(9f1e5eaf-4c53-4718-9d79-efc3f8758d02),
00217     dual,
00218     helpstring("ICaoFiles Interface"),
00219     pointer_default(unique)
00220 ]
00221 interface ICaoFiles : IDispatch
00222 {
00223     [propget, id(-4), helpstring("Property _NewEnum"), restricted] HRESULT _NewEnum([out, retval] LPUNKNOWN *pVal);
00224     [id(0), helpstring("Method Item")] HRESULT Item([in] VARIANT Index, [out, retval] ICaoFile **ppICaoFile);
00225
00226     [propget, id(1), helpstring("Property Count")] HRESULT Count([out, retval] long *pVal);
00227
00228     [id(2), helpstring("Method Add")] HRESULT Add([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoFile **ppICaoFile);
00229     [id(3), helpstring("Method Remove")] HRESULT Remove([in] VARIANT Index);
00230     [id(4), helpstring("Method Clear")] HRESULT Clear();
00231     [id(5), helpstring("Method IsMember")] HRESULT IsMember([in] VARIANT Index, [out, retval] VARIANT_BOOL *pVal);
00232 };
00233
00234 // ICaoFile Interface
00235 [
00236     object,
00237     uuid(9a4617d6-3e02-499d-a1b9-3d33bca0569f),
00238     dual,
00239     helpstring("ICaoFile Interface"),
00240     pointer_default(unique)
00241 ]
00242 interface ICaoFile : IDispatch
00243 {
00244     [propget, id(0), helpstring("Property Value")] HRESULT Value([out, retval] VARIANT *pVal);
00245     [propput, id(0), helpstring("Property Value")] HRESULT Value([in] VARIANT newVal);
00246
00247     [id(1), helpstring("Method _PutIndex"), restricted] HRESULT _PutIndex([in] long newVal);
00248
00249     [propget, id(2), helpstring("Property Attribute")] HRESULT Attribute([out, retval] long *pVal);
00250     [propget, id(3), helpstring("Property DateCreated")] HRESULT DateCreated([out, retval] VARIANT *pVal);
00251     [propget, id(4), helpstring("Property DateLastAccessed")] HRESULT DateLastAccessed([out, retval] VARIANT *pVal);
00252     [propget, id(5), helpstring("Property DateLastModified")] HRESULT DateLastModified([out, retval] VARIANT *pVal);
00253     [propget, id(6), helpstring("Property FileNames")] HRESULT FileNames([in, defaultvalue("")] BSTR bstrOption, [out, retval] VARIANT *pVal);
00254     [propget, id(7), helpstring("Property Files")] HRESULT Files([out, retval] ICaoFiles **ppICaoFiles);
00255     [propget, id(8), helpstring("Property Help")] HRESULT Help([out, retval] BSTR *pVal);
00256     [propget, id(9), helpstring("Property Index")] HRESULT Index([out, retval] long *pVal);
00257     [propget, id(10), helpstring("Property Name")] HRESULT Name([out, retval] BSTR *pVal);
00258     [propget, id(11), helpstring("Property Path")] HRESULT Path([out, retval] BSTR *pVal);
00259     [propget, id(12), helpstring("Property Size")] HRESULT Size([out, retval] long *pVal);
00260     [propget, id(13), helpstring("Property Tag")] HRESULT Tag([out, retval] VARIANT *pVal);
00261     [propput, id(13), helpstring("Property Tag")] HRESULT Tag([in] VARIANT newVal);
00262     [propget, id(14), helpstring("Property Type")] HRESULT Type([out, retval] BSTR *pVal);
00263     [propget, id(15), helpstring("Property VariableNames")] HRESULT VariableNames([in, defaultvalue("")] BSTR bstrOption, [out, retval] VARIANT *pVal);
00264     [propget, id(16), helpstring("Property Variables")] HRESULT Variables([out, retval] ICaoVariables **ppICaoVariables);
00265     [propget, id(17), helpstring("Property ID")] HRESULT ID([out, retval] VARIANT *pVal);
00266     [propput, id(17), helpstring("Property ID")] HRESULT ID([in] VARIANT newVal);
00267
00268     [id(18), helpstring("Method AddFile")] HRESULT AddFile([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoFile **ppICaoFile);
00269     [id(19), helpstring("Method AddVariable")] HRESULT AddVariable([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoVariable **ppICaoVar);
00270     [id(20), helpstring("Method Copy")] HRESULT Copy([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption);
00271     [id(21), helpstring("Method Delete")] HRESULT Delete([in, defaultvalue("")] BSTR bstrOption);
00272     [id(22), helpstring("Method Execute")] HRESULT Execute([in] VARIANT vntCommand, [out, retval] VARIANT *pVal);
00273     [id(23), helpstring("Method Move")] HRESULT Move([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption);
00274     [id(24), helpstring("Method Run")] HRESULT Run([in, defaultvalue("")] BSTR bstrOption, [out, retval] BSTR *bstrName);
00275
00276 };
00277
00278 // ICaoRobots Interface
00279 [
00280     object,
00281     uuid(76cddba4-09e9-4292-95ef-1a5a85dcbea9),
00282     dual,
00283     helpstring("ICaoRobots Interface"),
00284     pointer_default(unique)
00285 ]
00286 interface ICaoRobots : IDispatch
00287 {
00288     [propget, id(-4), helpstring("Property _NewEnum"), restricted] HRESULT _NewEnum([out, retval] LPUNKNOWN *pVal);
00289     [id(0), helpstring("Method Item")] HRESULT Item([in] VARIANT Index, [out, retval] ICaoRobot **ppICaoRobot);
00290
00291     [propget, id(1), helpstring("Property Count")] HRESULT Count([out, retval] long *pVal);
00292
00293     [id(2), helpstring("Method Add")] HRESULT Add([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoRobot **ppICaoRobot);
00294     [id(3), helpstring("Method Remove")] HRESULT Remove([in] VARIANT Index);
00295     [id(4), helpstring("Method Clear")] HRESULT Clear();
00296     [id(5), helpstring("Method IsMember")] HRESULT IsMember([in] VARIANT Index, [out, retval] VARIANT_BOOL *pVal);
00297 };
00298
00299 // ICaoRobot Interface
00300 [
00301     object,
00302     uuid(02105032-6ae1-4251-a72f-9aadc04f6659),
00303     dual,
00304     helpstring("ICaoRobot Interface"),
00305     pointer_default(unique)
00306 ]
00307 interface ICaoRobot : IDispatch
00308 {
00309     [id(1), helpstring("Method _PutIndex"), restricted] HRESULT _PutIndex([in] long newVal);
00310
00311     [propget, id(2), helpstring("Property Attribute")] HRESULT Attribute([out, retval] long *pVal);
00312     [propget, id(3), helpstring("Property Help")] HRESULT Help([out, retval] BSTR *pVal);
00313     [propget, id(4), helpstring("Property Index")] HRESULT Index([out, retval] long *pVal);
00314     [propget, id(5), helpstring("Property Name")] HRESULT Name([out, retval] BSTR *pVal);
00315     [propget, id(6), helpstring("Property Tag")] HRESULT Tag([out, retval] VARIANT *pVal);
00316     [propput, id(6), helpstring("Property Tag")] HRESULT Tag([in] VARIANT newVal);
00317     [propget, id(7), helpstring("Property VariableNames")] HRESULT VariableNames([in, defaultvalue("")] BSTR bstrOption, [out, retval] VARIANT *pVal);
00318     [propget, id(8), helpstring("Property Variables")] HRESULT Variables([out, retval] ICaoVariables **ppICaoVariables);
00319     [propget, id(9), helpstring("Property ID")] HRESULT ID([out, retval] VARIANT *pVal);
00320     [propput, id(9), helpstring("Property ID")] HRESULT ID([in] VARIANT newVal);
00321
00322     [id(10), helpstring("Method Accelerate")] HRESULT Accelerate([in] long lAxis, [in] float fAccel, [in, defaultvalue(0)] float fDecel);
00323     [id(11), helpstring("Method AddVariable")] HRESULT AddVariable([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoVariable **ppICaoVar);
00324     [id(12), helpstring("Method Change")] HRESULT Change([in] BSTR bstrName);
00325     [id(13), helpstring("Method Chuck")] HRESULT Chuck([in, defaultvalue("")] BSTR bstrOption);
00326     [id(14), helpstring("Method Drive")] HRESULT Drive([in] long lNo, [in] float fMov, [in, defaultvalue("")] BSTR bstrOpt );
00327     [id(15), helpstring("Method Execute")] HRESULT Execute([in] VARIANT vntCommand, [out, retval] VARIANT *pVal);
00328     [id(16), helpstring("Method GoHome")] HRESULT GoHome();
00329     [id(17), helpstring("Method Halt")] HRESULT Halt([in, defaultvalue("")] BSTR bstrOption);
00330     [id(18), helpstring("Method Hold")] HRESULT Hold([in, defaultvalue("")] BSTR bstrOption);
00331     [id(19), helpstring("Method Move")] HRESULT Move([in] long lComp, [in] VARIANT vntPose, [in, defaultvalue("")] BSTR bstrOpt );
00332     [id(20), helpstring("Method Rotate")] HRESULT Rotate([in] VARIANT vntRotSuf, [in] float fDeg, [in] VARIANT vntPivot, [in, defaultvalue("")] BSTR bstrOpt );
00333     [id(21), helpstring("Method Speed")] HRESULT Speed([in] long lAxis, [in] float fSpeed);
00334     [id(22), helpstring("Method Unchuck")] HRESULT Unchuck([in, defaultvalue("")] BSTR bstrOption);
00335     [id(23), helpstring("Method Unhold")] HRESULT Unhold([in, defaultvalue("")] BSTR bstrOption);
00336
00337 };
00338
00339 // ICaoTasks Interface
00340 [
00341     object,
00342     uuid(a2a35844-148b-4762-8b41-68015bbc26f7),
00343     dual,
00344     helpstring("ICaoTasks Interface"),
00345     pointer_default(unique)
00346 ]
00347 interface ICaoTasks : IDispatch
00348 {
00349     [propget, id(-4), helpstring("Property _NewEnum"), restricted] HRESULT _NewEnum([out, retval] LPUNKNOWN *pVal);
00350     [id(0), helpstring("Method Item")] HRESULT Item([in] VARIANT Index, [out, retval] ICaoTask **ppICaoTask);
00351
00352     [propget, id(1), helpstring("Property Count")] HRESULT Count([out, retval] long *pVal);
00353
00354     [id(2), helpstring("Method Add")] HRESULT Add([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoTask **ppICaoTask);
00355     [id(3), helpstring("Method Remove")] HRESULT Remove([in] VARIANT Index);
00356     [id(4), helpstring("Method Clear")] HRESULT Clear();
00357     [id(5), helpstring("Method IsMember")] HRESULT IsMember([in] VARIANT Index, [out, retval] VARIANT_BOOL *pVal);
00358 };
00359
00360 // ICaoTask Interface
00361 [
00362     object,
00363     uuid(cc23c152-1d58-4c70-bd1b-539fd0329ae2),
00364     dual,
00365     helpstring("ICaoTask Interface"),
00366     pointer_default(unique)
00367 ]
00368 interface ICaoTask : IDispatch
00369 {
00370     [id(1), helpstring("Method _PutIndex"), restricted] HRESULT _PutIndex([in] long newVal);
00371
00372     [propget, id(2), helpstring("Property Attribute")] HRESULT Attribute([out, retval] long *pVal);
00373     [propget, id(3), helpstring("Property FileName")] HRESULT FileName([out, retval] BSTR *pVal);
00374     [propget, id(4), helpstring("Property Help")] HRESULT Help([out, retval] BSTR *pVal);
00375     [propget, id(5), helpstring("Property Index")] HRESULT Index([out, retval] long *pVal);
00376     [propget, id(6), helpstring("Property Name")] HRESULT Name([out, retval] BSTR *pVal);
00377     [propget, id(7), helpstring("Property Tag")] HRESULT Tag([out, retval] VARIANT *pVal);
00378     [propput, id(7), helpstring("Property Tag")] HRESULT Tag([in] VARIANT newVal);
00379     [propget, id(8), helpstring("Property VariableNames")] HRESULT VariableNames([in, defaultvalue("")] BSTR bstrOption, [out, retval] VARIANT *pVal);
00380     [propget, id(9), helpstring("Property Variables")] HRESULT Variables([out, retval] ICaoVariables **ppICaoVariables);
00381     [propget, id(10), helpstring("Property ID")] HRESULT ID([out, retval] VARIANT *pVal);
00382     [propput, id(10), helpstring("Property ID")] HRESULT ID([in] VARIANT newVal);
00383
00384     [id(11), helpstring("Method AddVariable")] HRESULT AddVariable([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoVariable **ppICaoVar);
00385     [id(12), helpstring("Method Delete")] HRESULT Delete([in, defaultvalue("")] BSTR bstrOption);
00386     [id(13), helpstring("Method Execute")] HRESULT Execute([in] VARIANT vntCommand, [out, retval] VARIANT *pVal);
00387     [id(14), helpstring("Method Start")] HRESULT Start([in, defaultvalue(0)] long lMode, [in, defaultvalue("")] BSTR bstrOption);
00388     [id(15), helpstring("Method Stop")] HRESULT Stop([in, defaultvalue(0)] long lMode, [in, defaultvalue("")] BSTR bstrOption);
00389
00390 };
00391
00392 // ICaoVariables
00393 [
00394     object,
00395     uuid(8d392e7a-eb9e-46ef-86c6-8e7acd0eceab),
00396     dual,
00397     helpstring("ICaoVariables Interface"),
00398     pointer_default(unique)
00399 ]
00400 interface ICaoVariables : IDispatch
00401 {
00402     [propget, id(-4), helpstring("Property _NewEnum"), restricted] HRESULT _NewEnum([out, retval] LPUNKNOWN *pVal);
00403     [id(0), helpstring("Method Item")] HRESULT Item([in] VARIANT Index, [out, retval] ICaoVariable **ppICaoVar);
00404
00405     [propget, id(1), helpstring("Property Count")] HRESULT Count([out, retval] long *pVal);
00406
00407     [id(2), helpstring("Method Add")] HRESULT Add([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoVariable **ppICaoVar);
00408     [id(3), helpstring("Method Remove")] HRESULT Remove([in] VARIANT Index);
00409     [id(4), helpstring("Method Clear")] HRESULT Clear();
00410     [id(5), helpstring("Method IsMember")] HRESULT IsMember([in] VARIANT Index, [out, retval] VARIANT_BOOL *pVal);
00411 };
00412
00413 // ICaoVariable Interface
00414 [
00415     object,
00416     uuid(3dc12940-6c7b-43e4-b375-136c3e6e7e3a),
00417     dual,
00418     helpstring("ICaoVariable Interface"),
00419     pointer_default(unique)
00420 ]
00421 interface ICaoVariable : IDispatch
00422 {
00423     [propget, id(0), helpstring("Property Value")] HRESULT Value([out, retval] VARIANT *pVal);
00424     [propput, id(0), helpstring("Property Value")] HRESULT Value([in] VARIANT newVal);
00425
00426     [id(1), helpstring("Method _PutIndex"), restricted] HRESULT _PutIndex([in] long newVal);
00427
00428     [propget, id(2), helpstring("Property Attribute")] HRESULT Attribute([out, retval] long *pVal);
00429     [propget, id(3), helpstring("Property DateTime")] HRESULT DateTime([out, retval] VARIANT *pVal);
00430     [propget, id(4), helpstring("Property Help")] HRESULT Help([out, retval] BSTR *pVal);
00431     [propget, id(5), helpstring("Property Index")] HRESULT Index([out, retval] long *pVal);
00432     [propget, id(6), helpstring("Property Name")] HRESULT Name([out, retval] BSTR *pVal);
00433     [propget, id(7), helpstring("Property Tag")] HRESULT Tag([out, retval] VARIANT *pVal);
00434     [propput, id(7), helpstring("Property Tag")] HRESULT Tag([in] VARIANT newVal);
00435     [propget, id(8), helpstring("Property ID")] HRESULT ID([out, retval] VARIANT *pVal);
00436     [propput, id(8), helpstring("Property ID")] HRESULT ID([in] VARIANT newVal);
00437     [propget, id(9), helpstring("Property Microsecond")] HRESULT Microsecond([out, retval] long *pVal);
00438 };
00439
00440 // ICaoCommands Interface
00441 [
00442     object,
00443     uuid(480CA4D6-ADCB-4cb4-812B-7E41BE891E03),
00444
00445     dual,
00446     helpstring("ICaoCommands Interface"),
00447     pointer_default(unique)
00448 ]
00449 interface ICaoCommands : IDispatch
00450 {
00451     [propget, id(-4), helpstring("Property _NewEnum"), restricted] HRESULT _NewEnum([out, retval] LPUNKNOWN *pVal);
00452     [id(0), helpstring("Method Item")] HRESULT Item([in] VARIANT Index, [out, retval] ICaoCommand **ppICaoCommand);
00453
00454     [propget, id(1), helpstring("Property Count")] HRESULT Count([out, retval] long *pVal);
00455
00456     [id(2), helpstring("Method Add")] HRESULT Add([in] BSTR bstrName, [in, defaultvalue("")] BSTR bstrOption, [out, retval] ICaoCommand **ppICaoCommand);
00457     [id(3), helpstring("Method Remove")] HRESULT Remove([in] VARIANT Index);
00458     [id(4), helpstring("Method Clear")] HRESULT Clear();
00459     [id(5), helpstring("Method IsMember")] HRESULT IsMember([in] VARIANT Index, [out, retval] VARIANT_BOOL *pVal);
00460 };
00461
00462 // ICaoCommand Interface
00463 [
00464     object,
00465     uuid(3DA3B42D-EA6A-468b-A57F-C375DEFD11E9),
00466     dual,
00467     helpstring("ICaoCommand Interface"),
00468     pointer_default(unique)
00469 ]
00470 interface ICaoCommand : IDispatch
00471 {
00472     [id(1), helpstring("Method _PutIndex"), restricted] HRESULT _PutIndex([in] long newVal);
00473
00474     [propget, id(2), helpstring("Property Attribute")] HRESULT Attribute([out, retval] long *pVal);
00475     [propget, id(3), helpstring("Property Help")] HRESULT Help([out, retval] BSTR *pVal);
00476     [propget, id(4), helpstring("Property Index")] HRESULT Index([out, retval] long *pVal);
00477     [propget, id(5), helpstring("Property Name")] HRESULT Name([out, retval] BSTR *pVal);
00478     [propget, id(6), helpstring("Property Parameters")] HRESULT Parameters([out, retval] VARIANT *pVal);
00479     [propput, id(6), helpstring("Property Parameters")] HRESULT Parameters([in] VARIANT newVal);
00480     [propget, id(7), helpstring("Property Result")] HRESULT Result([out, retval] VARIANT *pVal);
00481     [propget, id(8), helpstring("Property State")] HRESULT State([out, retval] long *pVal);
00482     [propget, id(9), helpstring("Property Tag")] HRESULT Tag([out, retval] VARIANT *pVal);
00483     [propput, id(9), helpstring("Property Tag")] HRESULT Tag([in] VARIANT newVal);
00484     [propget, id(10), helpstring("Property Timeout")] HRESULT Timeout([out, retval] long *pVal);
00485     [propput, id(10), helpstring("Property Timeout")] HRESULT Timeout([in] long newVal);
00486     [propget, id(11), helpstring("Property ID")] HRESULT ID([out, retval] VARIANT *pVal);
00487     [propput, id(11), helpstring("Property ID")] HRESULT ID([in] VARIANT newVal);
00488
00489     [id(12), helpstring("Method Cancel")] HRESULT Cancel();
00490     [id(13), helpstring("Method Execute")] HRESULT Execute([in, defaultvalue(0)] long lMode);
00491
00492 };
00493
00494 // ICaoMessage Interface
00495 [
00496     object,
00497     uuid(964497c9-a444-48e3-ad6c-78b1fa5be46f),
00498     dual,
00499     helpstring("ICaoMessage Interface"),
00500     pointer_default(unique)
00501 ]
00502 interface ICaoMessage : IDispatch
00503 {
00504     [propget, id(1), helpstring("Property DateTime")] HRESULT DateTime([out, retval] VARIANT *pVal);
00505     [propget, id(2), helpstring("Property Description")] HRESULT Description([out, retval] BSTR *pVal);
00506     [propget, id(3), helpstring("Property Destination")] HRESULT Destination([out, retval] BSTR *pVal);
00507     [propget, id(4), helpstring("Property Number")] HRESULT Number([out, retval] long *pVal);
00508     [propget, id(5), helpstring("Property SerialNumber")] HRESULT SerialNumber([out, retval] long *pVal);
00509     [propget, id(6), helpstring("Property Source")] HRESULT Source([out, retval] BSTR *pVal);
00510     [propget, id(7), helpstring("Property Value")] HRESULT Value([out, retval] VARIANT *pVal);
00511
00512     [id(8), helpstring("Method Clear")] HRESULT Clear();
00513     [id(9), helpstring("Method Reply")] HRESULT Reply(VARIANT vntData);
00514
00515 };
00516
00517 // ICaoEngineStatus Interface
00518 [
00519     object,
00520     uuid(9b77d6e0-b941-4513-8a63-08c59c992991),
00521     dual,
00522     helpstring("ICaoEngineStatus Interface"),
00523     pointer_default(unique)
00524 ]
00525 interface ICaoEngineStatus : IDispatch
00526 {
00527     [propget, id(1), helpstring("Property CurrentDateTime")] HRESULT CurrentDateTime([out, retval] VARIANT *pVal);
00528     [propget, id(2), helpstring("Property ComputerName")] HRESULT ComputerName([out, retval] BSTR *pVal);
00529     [propget, id(3), helpstring("Property ObjectCounts")] HRESULT ObjectCounts([in] VARIANT vntName, [out, retval] long *pVal);
00530     [propget, id(4), helpstring("Property StartDateTime")] HRESULT StartDateTime([out, retval] VARIANT *pVal);
00531     [propget, id(5), helpstring("Property Values")] HRESULT Values([in] VARIANT vntName, [out, retval] VARIANT *pVal);
00532     [propget, id(6), helpstring("Property Version")] HRESULT Version([out, retval] BSTR *pVal);
00533
00534 };
00535
00536 // IEventSink Interface
00537 [
00538     object,
00539     uuid(2b27bcbf-c3c2-45dd-ba66-8ac0fa898c1c),
00540     dual,
00541     helpstring("IEventSink Interface"),
00542     pointer_default(unique)
00543 ]
00544 interface IEventSink : IDispatch
00545 {
00546     [id(1), helpstring("Method OnMessage")] HRESULT OnMessage([in] IUnknown *pVal, [in, defaultvalue(0)] long lOption);
00547
00548 };
00549
00550 /* ---------------------- */
00551 /* CAO Object Definitions */
00552 /* ---------------------- */
00553 [
00554     uuid(e2f77a83-3965-44e7-99a5-e75c6b07d59c),
00555     version(1.0),
00556     helpstring("CAO 1.0 ﾀｲﾌﾟ ﾗｲﾌﾞﾗﾘ")
00557 ]
00558 library CAOLib
00559 {
00560     importlib("stdole32.tlb");
00561     importlib("stdole2.tlb");
00562
00563     // _ICaoControllerEvents dispinterface
00564     [
00565         uuid(a7b43ef1-0215-4940-a6f6-21744b8cba52),
00566         helpstring("_ICaoControllerEvents Interface")
00567     ]
00568     dispinterface _ICaoControllerEvents
00569     {
00570         properties:
00571         methods:
00572         [id(1), helpstring("Method OnMessage")] HRESULT OnMessage([in] ICaoMessage* pICaoMess);
00573     };
00574
00575     // _ICaoommandEvents dispinterface
00576     [
00577         uuid(DC17F478-F7B2-4ce7-819D-8EF34F70E351),
00578         helpstring("_ICaoCommandsEvents Interface")
00579     ]
00580     dispinterface _ICaoCommandsEvents
00581     {
00582         properties:
00583         methods:
00584         [id(1), helpstring("Method ExecuteComplete")] HRESULT ExecuteComplete([in] long lID);
00585     };
00586
00587     // CaoEngine Class
00588     [
00589         uuid(60555f1b-e473-4250-bb43-933990fbeced),
00590         helpstring("CaoEngine Class")
00591     ]
00592     coclass CaoEngine
00593     {
00594         [default] interface ICaoEngine;
00595     };
00596
00597     // CaoWorkspaces Class
00598     [
00599         uuid(f7430785-4ec2-4193-8552-f5cb2d6be732),
00600         helpstring("CaoWorkspaces Class")
00601     ]
00602     coclass CaoWorkspaces
00603     {
00604         [default] interface ICaoWorkspaces;
00605     };
00606
00607     // CaoWorkspace Class
00608     [
00609         uuid(22fc99b8-9c3a-48c9-9f4d-8eee16ed365a),
00610         helpstring("CaoWorkspace Class")
00611     ]
00612     coclass CaoWorkspace
00613     {
00614         [default] interface ICaoWorkspace;
00615     };
00616
00617     // CaoControllers Class
00618     [
00619         uuid(41c404be-bfd1-40ce-8454-2f47e04a09b1),
00620         helpstring("CaoControllers Class")
00621     ]
00622     coclass CaoControllers
00623     {
00624         [default] interface ICaoControllers;
00625     };
00626
00627     // CaoController Class
00628     [
00629         uuid(d1baa44e-9ca9-4075-8ad1-481aa21434a8),
00630         helpstring("CaoController Class")
00631     ]
00632     coclass CaoController
00633     {
00634         [default] interface ICaoController;
00635         [default, source] dispinterface _ICaoControllerEvents;
00636     };
00637
00638     // CaoExtensions Class
00639     [
00640         uuid(0AF9CEC7-4F11-4EA4-8033-142CF4E45512),
00641         helpstring("CaoExtensions Class")
00642     ]
00643     coclass CaoExtensions
00644     {
00645         [default] interface ICaoExtensions;
00646     };
00647
00648     // CaoExtension Class
00649     [
00650         uuid(FE266A3E-9435-4F25-85E2-B4350A378B81),
00651         helpstring("CaoExtension Class")
00652     ]
00653     coclass CaoExtension
00654     {
00655         [default] interface ICaoExtension;
00656     };
00657
00658     // CaoFiles Class
00659     [
00660         uuid(2d662501-91ce-49e0-bafa-453a2d610b50),
00661         helpstring("CaoFiles Class")
00662     ]
00663     coclass CaoFiles
00664     {
00665         [default] interface ICaoFiles;
00666     };
00667
00668     // CaoFile Class
00669     [
00670         uuid(b7466915-2234-4382-b9e7-da74a34acaff),
00671         helpstring("CaoFile Class")
00672     ]
00673     coclass CaoFile
00674     {
00675         [default] interface ICaoFile;
00676     };
00677
00678     // CaoRobots Class
00679     [
00680         uuid(f6981128-7e0f-4159-86b0-7397eb1596a3),
00681         helpstring("CaoRobots Class")
00682     ]
00683     coclass CaoRobots
00684     {
00685         [default] interface ICaoRobots;
00686     };
00687
00688     // CaoRobot Class
00689     [
00690         uuid(c486acdd-451e-4fb5-a20b-3cc747f8cc2e),
00691         helpstring("CaoRobot Class")
00692     ]
00693     coclass CaoRobot
00694     {
00695         [default] interface ICaoRobot;
00696     };
00697
00698     // CaoTasks Class
00699     [
00700         uuid(eb5211bb-dd98-4e91-b84f-a619f636de30),
00701         helpstring("CaoTasks Class")
00702     ]
00703     coclass CaoTasks
00704     {
00705         [default] interface ICaoTasks;
00706     };
00707
00708     // CaoTask Class
00709     [
00710         uuid(1ab45162-d81d-475c-a73f-3f9bbc0f0768),
00711         helpstring("CaoTask Class")
00712     ]
00713     coclass CaoTask
00714     {
00715         [default] interface ICaoTask;
00716     };
00717
00718     // CaoVariables Class
00719     [
00720         uuid(5691304f-610a-4645-8d58-64138e059824),
00721         helpstring("CaoVariables Class")
00722     ]
00723     coclass CaoVariables
00724     {
00725         [default] interface ICaoVariables;
00726     };
00727
00728     // CaoVariable Class
00729     [
00730         uuid(2c9b6656-32d1-425c-ad61-536c5a07c773),
00731         helpstring("CaoVariable Class")
00732     ]
00733     coclass CaoVariable
00734     {
00735         [default] interface ICaoVariable;
00736     };
00737
00738     // CaoCommands Class
00739     [
00740         uuid(887FFEAF-3E41-4d54-A558-DE75E7E11B44),
00741         helpstring("CaoCommands Class")
00742     ]
00743     coclass CaoCommands
00744     {
00745         [default] interface ICaoCommands;
00746         [default, source] dispinterface _ICaoCommandsEvents;
00747     };
00748
00749     // CaoCommand Class
00750     [
00751         uuid(9289DBE4-ADEC-4001-9CF0-C58C756B2E79),
00752         helpstring("CaoCommand Class")
00753     ]
00754     coclass CaoCommand
00755     {
00756         [default] interface ICaoCommand;
00757     };
00758
00759     // CaoMessage Class
00760     [
00761         uuid(4f2f3700-71c8-452a-81ac-5a8539b8a5c6),
00762         helpstring("CaoMessage Class"),
00763     ]
00764     coclass CaoMessage
00765     {
00766         [default] interface ICaoMessage;
00767     };
00768
00769     // CaoEngineStatus Class
00770     [
00771         uuid(f5e9b29c-e1d6-4f78-ac18-a85ae49dbbb2),
00772         helpstring("CaoEngineStatus Class")
00773     ]
00774     coclass CaoEngineStatus
00775     {
00776         [default] interface ICaoEngineStatus;
00777     };
00778
00779     // EventSink Class
00780     [
00781         uuid(12654e13-f7bc-4f1a-831d-a7a93e733cb7),
00782         helpstring("EventSink Class")
00783     ]
00784     coclass EventSink
00785     {
00786         [default] interface IEventSink;
00787     };
00788
00789 };
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAO_i.c File Reference

CAO_i.c の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

構成

struct | _IID

Typedef

typedef _IID | IID
typedef IID | CLSID

変数

const IID | IID_ICaoEngine = {0x5acfd9fe,0x41f0,0x43f6,{0xa0,0xd6,0xc1,0x0c,0x07,0x93,0x15,0xfc}}
const IID | IID_ICaoWorkspaces = {0x8dcdfb4e,0xcf07,0x47ca,{0x89,0x5f,0xdb,0x1d,0x5a,0xfa,0x8f,0x74}}
const IID | IID_ICaoWorkspace = {0x0ed07c17,0xb078,0x40cf,{0x9b,0x0f,0x3a,0x49,0x74,0xde,0x55,0xe5}}
const IID | IID_ICaoControllers = {0x474b2753,0x9f06,0x41e0,{0x84,0x0b,0x1f,0x26,0xb1,0xac,0x1c,0x2c}}
const IID | IID_ICaoController = {0xc94e794f,0xec5b,0x43f2,{0x87,0x9f,0x77,0x7a,0x49,0xe7,0x30,0x5b}}
const IID | IID_ICaoExtensions = {0xc5cd2d49,0xd7b9,0x4c6d,{0x8d,0x0d,0x56,0xa5,0x66,0xb7,0x80,0x42}}
const IID | IID_ICaoExtension = {0xa2e8ab44,0x325e,0x4fd8,{0x8e,0x92,0x55,0xa9,0x1d,0x21,0x3d,0x19}}
const IID | IID_ICaoFiles = {0x9f1e5eaf,0x4c53,0x4718,{0x9d,0x79,0xef,0xc3,0xf8,0x75,0x8d,0x02}}
const IID | IID_ICaoFile = {0x9a4617d6,0x3e02,0x499d,{0xa1,0xb9,0x3d,0x33,0xbc,0xa0,0x56,0x9f}}
const IID | IID_ICaoRobots = {0x76cddba4,0x09e9,0x4292,{0x95,0xef,0x1a,0x5a,0x85,0xdc,0xbe,0xa9}}
const IID | IID_ICaoRobot = {0x02105032,0x6ae1,0x4251,{0xa7,0x2f,0x9a,0xad,0xc0,0x4f,0x66,0x59}}
const IID | IID_ICaoTasks = {0xa2a35844,0x148b,0x4762,{0x8b,0x41,0x68,0x01,0x5b,0xbc,0x26,0xf7}}
const IID | IID_ICaoTask = {0xcc23c152,0x1d58,0x4c70,{0xbd,0x1b,0x53,0x9f,0xd0,0x32,0x9a,0xe2}}
const IID | IID_ICaoVariables = {0x8d392e7a,0xeb9e,0x46ef,{0x86,0xc6,0x8e,0x7a,0xcd,0x0e,0xce,0xab}}
const IID | IID_ICaoVariable = {0x3dc12940,0x6c7b,0x43e4,{0xb3,0x75,0x13,0x6c,0x3e,0x6e,0x7e,0x3a}}
const IID | IID_ICaoCommands = {0x480CA4D6,0xADCB,0x4cb4,{0x81,0x2B,0x7E,0x41,0xBE,0x89,0x1E,0x03}}
const IID | IID_ICaoCommand = {0x3DA3B42D,0xEA6A,0x468b,{0xA5,0x7F,0xC3,0x75,0xDE,0xFD,0x11,0xE9}}
const IID | IID_ICaoMessage = {0x964497c9,0xa444,0x48e3,{0xad,0x6c,0x78,0xb1,0xfa,0x5b,0xe4,0x6f}}
const IID | IID_ICaoEngineStatus = {0x9b77d6e0,0xb941,0x4513,{0x8a,0x63,0x08,0xc5,0x9c,0x99,0x29,0x91}}
const IID | IID_IEventSink = {0x2b27bcbf,0xc3c2,0x45dd,{0xba,0x66,0x8a,0xc0,0xfa,0x89,0x8c,0x1c}}
const IID | LIBID_CAOLib = {0xe2f77a83,0x3965,0x44e7,{0x99,0xa5,0xe7,0x5c,0x6b,0x07,0xd5,0x9c}}
const IID | DIID__ICaoControllerEvents = {0xa7b43ef1,0x0215,0x4940,{0xa6,0xf6,0x21,0x74,0x4b,0x8c,0xba,0x52}}
const IID | DIID__ICaoCommandsEvents = {0xDC17F478,0xF7B2,0x4ce7,{0x81,0x9D,0x8E,0xF3,0x4F,0x70,0xE3,0x51}}
const CLSID | CLSID_CaoEngine = {0x60555f1b,0xe473,0x4250,{0xbb,0x43,0x93,0x39,0x90,0xfb,0xec,0xed}}
const CLSID | CLSID_CaoWorkspaces = {0xf7430785,0x4ec2,0x4193,{0x85,0x52,0xf5,0xcb,0x2d,0x6b,0xe7,0x32}}
const CLSID | CLSID_CaoWorkspace = {0x22fc99b8,0x9c3a,0x48c9,{0x9f,0x4d,0x8e,0xee,0x16,0xed,0x36,0x5a}}
const CLSID | CLSID_CaoControllers = {0x41c404be,0xbfd1,0x40ce,{0x84,0x54,0x2f,0x47,0xe0,0x4a,0x09,0xb1}}
const CLSID | CLSID_CaoController = {0xd1baa44e,0x9ca9,0x4075,{0x8a,0xd1,0x48,0x1a,0xa2,0x14,0x34,0xa8}}
const CLSID | CLSID_CaoExtensions = {0x0AF9CEC7,0x4F11,0x4EA4,{0x80,0x33,0x14,0x2C,0xF4,0xE4,0x55,0x12}}
const CLSID | CLSID_CaoExtension = {0xFE266A3E,0x9435,0x4F25,{0x85,0xE2,0xB4,0x35,0x0A,0x37,0x8B,0x81}}
const CLSID | CLSID_CaoFiles = {0x2d662501,0x91ce,0x49e0,{0xba,0xfa,0x45,0x3a,0x2d,0x61,0x0b,0x50}}
const CLSID | CLSID_CaoFile = {0xb7466915,0x2234,0x4382,{0xb9,0xe7,0xda,0x74,0xa3,0x4a,0xca,0xff}}
const CLSID | CLSID_CaoRobots = {0xf6981128,0x7e0f,0x4159,{0x86,0xb0,0x73,0x97,0xeb,0x15,0x96,0xa3}}
const CLSID | CLSID_CaoRobot = {0xc486acdd,0x451e,0x4fb5,{0xa2,0x0b,0x3c,0xc7,0x47,0xf8,0xcc,0x2e}}
const CLSID | CLSID_CaoTasks = {0xeb5211bb,0xdd98,0x4e91,{0xb8,0x4f,0xa6,0x19,0xf6,0x36,0xde,0x30}}
const CLSID | CLSID_CaoTask = {0x1ab45162,0xd81d,0x475c,{0xa7,0x3f,0x3f,0x9b,0xbc,0x0f,0x07,0x68}}
const CLSID | CLSID_CaoVariables = {0x5691304f,0x610a,0x4645,{0x8d,0x58,0x64,0x13,0x8e,0x05,0x98,0x24}}
const CLSID | CLSID_CaoVariable = {0x2c9b6656,0x32d1,0x425c,{0xad,0x61,0x53,0x6c,0x5a,0x07,0xc7,0x73}}
const CLSID | CLSID_CaoCommands = {0x887FFEAF,0x3E41,0x4d54,{0xA5,0x58,0xDE,0x75,0xE7,0xE1,0x1B,0x44}}
const CLSID | CLSID_CaoCommand = {0x9289DBE4,0xADEC,0x4001,{0x9C,0xF0,0xC5,0x8C,0x75,0x6B,0x2E,0x79}}
const CLSID | CLSID_CaoMessage = {0x4f2f3700,0x71c8,0x452a,{0x81,0xac,0x5a,0x85,0x39,0xb8,0xa5,0xc6}}
const CLSID | CLSID_CaoEngineStatus = {0xf5e9b29c,0xe1d6,0x4f78,{0xac,0x18,0xa8,0x5a,0xe4,0x9d,0xbb,0xb2}}
const CLSID | CLSID_EventSink = {0x12654e13,0xf7bc,0x4f1a,{0x83,0x1d,0xa7,0xa9,0x3e,0x73,0x3c,0xb7}}

Typedef の解説

typedef IID CLSID

typedef struct _IID IID

変数の解説

const CLSID CLSID_CaoCommand = {0x9289DBE4,0xADEC,0x4001,{0x9C,0xF0,0xC5,0x8C,0x75,0x6B,0x2E,0x79}}

const CLSID CLSID_CaoCommands = {0x887FFEAF,0x3E41,0x4d54,{0xA5,0x58,0xDE,0x75,0xE7,0xE1,0x1B,0x44}}

const CLSID CLSID_CaoController = {0xd1baa44e,0x9ca9,0x4075,{0x8a,0xd1,0x48,0x1a,0xa2,0x14,0x34,0xa8}}

const CLSID CLSID_CaoControllers = {0x41c404be,0xbfd1,0x40ce,{0x84,0x54,0x2f,0x47,0xe0,0x4a,0x09,0xb1}}

const CLSID CLSID_CaoEngine = {0x60555f1b,0xe473,0x4250,{0xbb,0x43,0x93,0x39,0x90,0xfb,0xec,0xed}}

const CLSID CLSID_CaoEngineStatus = {0xf5e9b29c,0xe1d6,0x4f78,{0xac,0x18,0xa8,0x5a,0xe4,0x9d,0xbb,0xb2}}

const CLSID CLSID_CaoExtension = {0xFE266A3E,0x9435,0x4F25,{0x85,0xE2,0xB4,0x35,0x0A,0x37,0x8B,0x81}}

const CLSID CLSID_CaoExtensions = {0x0AF9CEC7,0x4F11,0x4EA4,{0x80,0x33,0x14,0x2C,0xF4,0xE4,0x55,0x12}}

const CLSID CLSID_CaoFile = {0xb7466915,0x2234,0x4382,{0xb9,0xe7,0xda,0x74,0xa3,0x4a,0xca,0xff}}

const CLSID CLSID_CaoFiles = {0x2d662501,0x91ce,0x49e0,{0xba,0xfa,0x45,0x3a,0x2d,0x61,0x0b,0x50}}

const CLSID CLSID_CaoMessage = {0x4f2f3700,0x71c8,0x452a,{0x81,0xac,0x5a,0x85,0x39,0xb8,0xa5,0xc6}}

const CLSID CLSID_CaoRobot = {0xc486acdd,0x451e,0x4fb5,{0xa2,0x0b,0x3c,0xc7,0x47,0xf8,0xcc,0x2e}}

const CLSID CLSID_CaoRobots = {0xf6981128,0x7e0f,0x4159,{0x86,0xb0,0x73,0x97,0xeb,0x15,0x96,0xa3}}

const CLSID CLSID_CaoTask = {0x1ab45162,0xd81d,0x475c,{0xa7,0x3f,0x3f,0x9b,0xbc,0x0f,0x07,0x68}}

const CLSID CLSID_CaoTasks = {0xeb5211bb,0xdd98,0x4e91,{0xb8,0x4f,0xa6,0x19,0xf6,0x36,0xde,0x30}}

const CLSID CLSID_CaoVariable = {0x2c9b6656,0x32d1,0x425c,{0xad,0x61,0x53,0x6c,0x5a,0x07,0xc7,0x73}}

const CLSID CLSID_CaoVariables = {0x5691304f,0x610a,0x4645,{0x8d,0x58,0x64,0x13,0x8e,0x05,0x98,0x24}}

const CLSID CLSID_CaoWorkspace = {0x22fc99b8,0x9c3a,0x48c9,{0x9f,0x4d,0x8e,0xee,0x16,0xed,0x36,0x5a}}

const CLSID CLSID_CaoWorkspaces = {0xf7430785,0x4ec2,0x4193,{0x85,0x52,0xf5,0xcb,0x2d,0x6b,0xe7,0x32}}

const CLSID CLSID_EventSink = {0x12654e13,0xf7bc,0x4f1a,{0x83,0x1d,0xa7,0xa9,0x3e,0x73,0x3c,0xb7}}

const IID DIID__ICaoCommandsEvents = {0xDC17F478,0xF7B2,0x4ce7,{0x81,0x9D,0x8E,0xF3,0x4F,0x70,0xE3,0x51}}

const IID DIID__ICaoControllerEvents = {0xa7b43ef1,0x0215,0x4940,{0xa6,0xf6,0x21,0x74,0x4b,0x8c,0xba,0x52}}

const IID IID_ICaoCommand = {0x3DA3B42D,0xEA6A,0x468b,{0xA5,0x7F,0xC3,0x75,0xDE,0xFD,0x11,0xE9}}

const IID IID_ICaoCommands = {0x480CA4D6,0xADCB,0x4cb4,{0x81,0x2B,0x7E,0x41,0xBE,0x89,0x1E,0x03}}

const IID IID_ICaoController = {0xc94e794f,0xec5b,0x43f2,{0x87,0x9f,0x77,0x7a,0x49,0xe7,0x30,0x5b}}

const IID IID_ICaoControllers = {0x474b2753,0x9f06,0x41e0,{0x84,0x0b,0x1f,0x26,0xb1,0xac,0x1c,0x2c}}

const IID IID_ICaoEngine = {0x5acfd9fe,0x41f0,0x43f6,{0xa0,0xd6,0xc1,0x0c,0x07,0x93,0x15,0xfc}}

const IID IID_ICaoEngineStatus = {0x9b77d6e0,0xb941,0x4513,{0x8a,0x63,0x08,0xc5,0x9c,0x99,0x29,0x91}}

const IID IID_ICaoExtension = {0xa2e8ab44,0x325e,0x4fd8,{0x8e,0x92,0x55,0xa9,0x1d,0x21,0x3d,0x19}}

const IID IID_ICaoExtensions = {0xc5cd2d49,0xd7b9,0x4c6d,{0x8d,0x0d,0x56,0xa5,0x66,0xb7,0x80,0x42}}

const IID IID_ICaoFile = {0x9a4617d6,0x3e02,0x499d,{0xa1,0xb9,0x3d,0x33,0xbc,0xa0,0x56,0x9f}}

const IID IID_ICaoFiles = {0x9f1e5eaf,0x4c53,0x4718,{0x9d,0x79,0xef,0xc3,0xf8,0x75,0x8d,0x02}}

const IID IID_ICaoMessage = {0x964497c9,0xa444,0x48e3,{0xad,0x6c,0x78,0xb1,0xfa,0x5b,0xe4,0x6f}}

const IID IID_ICaoRobot = {0x02105032,0x6ae1,0x4251,{0xa7,0x2f,0x9a,0xad,0xc0,0x4f,0x66,0x59}}

const IID IID_ICaoRobots = {0x76cddba4,0x09e9,0x4292,{0x95,0xef,0x1a,0x5a,0x85,0xdc,0xbe,0xa9}}

const IID IID_ICaoTask = {0xcc23c152,0x1d58,0x4c70,{0xbd,0x1b,0x53,0x9f,0xd0,0x32,0x9a,0xe2}}

const IID IID_ICaoTasks = {0xa2a35844,0x148b,0x4762,{0x8b,0x41,0x68,0x01,0x5b,0xbc,0x26,0xf7}}

const IID IID_ICaoVariable = {0x3dc12940,0x6c7b,0x43e4,{0xb3,0x75,0x13,0x6c,0x3e,0x6e,0x7e,0x3a}}

const IID IID_ICaoVariables = {0x8d392e7a,0xeb9e,0x46ef,{0x86,0xc6,0x8e,0x7a,0xcd,0x0e,0xce,0xab}}

const IID IID_ICaoWorkspace = {0x0ed07c17,0xb078,0x40cf,{0x9b,0x0f,0x3a,0x49,0x74,0xde,0x55,0xe5}}

const IID IID_ICaoWorkspaces = {0x8dcdfb4e,0xcf07,0x47ca,{0x89,0x5f,0xdb,0x1d,0x5a,0xfa,0x8f,0x74}}

const IID IID_IEventSink = {0x2b27bcbf,0xc3c2,0x45dd,{0xba,0x66,0x8a,0xc0,0xfa,0x89,0x8c,0x1c}}

const IID LIBID_CAOLib = {0xe2f77a83,0x3965,0x44e7,{0x99,0xa5,0xe7,0x5c,0x6b,0x07,0xd5,0x9c}}

Generated on Wed Dec 7 19:01:46 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAO_p.c File Reference

CAO_p.c の解説

#include "rpcproxy.h"
#include "CAO.h"

CAO_p.cのインクルード依存関係図

Include dependency graph

構成

struct | _MIDL_PROC_FORMAT_STRING
struct | _MIDL_TYPE_FORMAT_STRING

マクロ定義

#define | USE_STUBLESS_PROXY
#define | __REQUIRED_RPCPROXY_H_VERSION__ 440
#define | TYPE_FORMAT_STRING_SIZE 1839
#define | PROC_FORMAT_STRING_SIZE 4453

Typedef

typedef _MIDL_TYPE_FORMAT_STRING | MIDL_TYPE_FORMAT_STRING
typedef _MIDL_PROC_FORMAT_STRING | MIDL_PROC_FORMAT_STRING

関数

CINTERFACE_PROXY_VTABLE (11) _ICaoEngineProxyVtbl=

変数

const MIDL_TYPE_FORMAT_STRING | __MIDL_TypeFormatString
const MIDL_PROC_FORMAT_STRING | __MIDL_ProcFormatString
const MIDL_STUB_DESC | Object_StubDesc
const MIDL_SERVER_INFO | ICaoEngine_ServerInfo
const unsigned short | ICaoEngine_FormatStringOffsetTable []
const MIDL_STUBLESS_PROXY_INFO | ICaoEngine_ProxyInfo

マクロ定義の解説

#define __REQUIRED_RPCPROXY_H_VERSION__ 440

#define PROC_FORMAT_STRING_SIZE 4453

#define TYPE_FORMAT_STRING_SIZE 1839

#define USE_STUBLESS_PROXY

Typedef の解説

typedef struct _MIDL_PROC_FORMAT_STRING MIDL_PROC_FORMAT_STRING

typedef struct _MIDL_TYPE_FORMAT_STRING MIDL_TYPE_FORMAT_STRING

関数の解説

CINTERFACE_PROXY_VTABLE ( 11 )

変数の解説

const MIDL_PROC_FORMAT_STRING __MIDL_ProcFormatString

const MIDL_TYPE_FORMAT_STRING __MIDL_TypeFormatString

const unsigned short ICaoEngine_FormatStringOffsetTable[] [static]

初期値:

    {
    (unsigned short) -1,
    (unsigned short) -1,
    (unsigned short) -1,
    (unsigned short) -1,
    0,
    28,
    56,
    96
    }

const MIDL_STUBLESS_PROXY_INFO ICaoEngine_ProxyInfo [static]

初期値:

    {
    &Object_StubDesc,
    __MIDL_ProcFormatString.Format,
    &ICaoEngine_FormatStringOffsetTable[-3],
    0,
    0,
    0
    }

const MIDL_SERVER_INFO ICaoEngine_ServerInfo

初期値:

    {
    &Object_StubDesc,
    0,
    __MIDL_ProcFormatString.Format,
    &ICaoEngine_FormatStringOffsetTable[-3],
    0,
    0,
    0,
    0
    }

const MIDL_STUB_DESC Object_StubDesc

Generated on Wed Dec 7 19:01:46 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoCollectionTmpl.h File Reference

CaoCollectionTmpl.h の解説

CCaoCollectionTmplの定義. [詳細]

#include "resource.h"
#include <map>

CaoCollectionTmpl.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class _CCaoCollectionTmpl
CAOのコレクションテンプレートクラス. [詳細]

解説

CCaoCollectionTmplの定義.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:46 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoCollectionTmpl.h Source File

CaoCollectionTmpl.h

解説を見る。
00001
00011 #ifndef _CAOCORRECTTMPL_H_
00012 #define _CAOCORRECTTMPL_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include <map>
00016
00017
00018 // <<<<<<<<<< CAO Collection Templates >>>>>>>>>>
00019
00025 template <class T, const CLSID* pclsid, class T1, const IID* piid, class TIChd>
00026 class ATL_NO_VTABLE _CCaoCollectionTmpl:
00027     public CComObjectRootEx<CComMultiThreadModel>,
00028     public CComCoClass<T, pclsid>,
00029     public ISupportErrorInfo,
00030     public IDispatchImpl<T1, piid, &LIBID_CAOLib>
00031 {
00032 public:
00038     _CCaoCollectionTmpl()
00039     {
00040     }
00041
00047     ~_CCaoCollectionTmpl()
00048     {
00049     }
00050
00051 DECLARE_PROTECT_FINAL_CONSTRUCT()
00052
00053 BEGIN_COM_MAP(T)
00054     COM_INTERFACE_ENTRY(T1)
00055     COM_INTERFACE_ENTRY(IDispatch)
00056     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00057 END_COM_MAP()
00058
00059 /* =================================================== */
00060 /*    CCaoCollectionTmpl Class Method Implementation   */
00061 /* =================================================== */
00062
00063
00071 STDMETHODIMP InterfaceSupportsErrorInfo(REFIID riid)
00072 {
00073     static const IID* arr[] =
00074     {
00075         piid
00076     };
00077     for (int i=0; i < sizeof(arr) / sizeof(arr[0]); i++) {
00078         if (InlineIsEqualGUID(*arr[i],riid)) {
00079             return S_OK;
00080         }
00081     }
00082     return S_FALSE;
00083 }
00084
00094 STDMETHODIMP Item(VARIANT Index, TIChd **ppItem){
00095     long lIndex;
00096
00097     HRESULT hr = GetIndex(Index, &lIndex);
00098     if (FAILED(hr)) {
00099         return hr;
00100     }
00101
00102     *ppItem = m_map[lIndex];
00103     (*ppItem)->AddRef();
00104
00105     return S_OK;
00106 }
00107
00108
00115 STDMETHODIMP Remove(VARIANT Index)
00116 {
00117     long lIndex;
00118
00119     HRESULT hr = GetIndex(Index, &lIndex);
00120     if (FAILED(hr)) {
00121         return hr;
00122     }
00123
00124     CComPtr<TIChd> pICaoObj;
00125     pICaoObj.Attach(m_map[lIndex]);
00126     pICaoObj->_PutIndex(CAO_OBJ_REMOVED);
00127     m_map.erase(lIndex);
00128
00129     return S_OK;
00130 }
00131
00137 STDMETHODIMP Clear()
00138 {
00139     std::map<long, TIChd*>::iterator it;
00140     for (it = m_map.begin(); it != m_map.end(); it++) {
00141         TIChd *pICaoObj;
00142         pICaoObj = it->second;
00143         pICaoObj->_PutIndex(CAO_OBJ_REMOVED);
00144         SAFE_RELEASE(pICaoObj);
00145     }
00146     m_map.clear();
00147
00148     return S_OK;
00149 }
00150
00158 STDMETHODIMP IsMember(VARIANT Index, VARIANT_BOOL *pVal)
00159 {
00160     long lIndex;
00161     HRESULT hr = GetIndex(Index, &lIndex);
00162     if (FAILED(hr)) {
00163         *pVal = VARIANT_FALSE;
00164     }
00165     else {
00166         *pVal = VARIANT_TRUE;
00167     }
00168
00169     return S_OK;
00170 }
00171
00172
00173 /* ====================================================== */
00174 /*    CCaoCollectionTmpl Class Property Implementation    */
00175 /* ====================================================== */
00176
00185 STDMETHODIMP get__NewEnum(LPUNKNOWN *pVal)
00186 {
00187     long lCount = m_map.size();
00188
00189     // オブジェクトを格納する為の一時的な配列
00190     VARIANT* vnt = new VARIANT[lCount];
00191     if (vnt == NULL) {
00192         return E_OUTOFMEMORY;
00193     }
00194
00195     std::map<long, TIChd*>::iterator it;
00196     int i = 0;
00197
00198     // 一時的な配列にオブジェクトを格納する．
00199     for (it = m_map.begin(); it != m_map.end(); it++, i++) {
00200         TIChd* pICaoObj = (*it).second;
00201         VariantInit(&vnt[i]);
00202         vnt[i].vt = VT_DISPATCH;
00203
00204         // VARIANTにIDispatchポインタを格納．
00205         pICaoObj->QueryInterface(IID_IDispatch, (void**)&(vnt[i].pdispVal));
00206     }
00207
00208     // オブジェクトの新しいインスタンスを生成
00209     typedef CComObject< CComEnum< IEnumVARIANT, &IID_IEnumVARIANT, VARIANT, _Copy<VARIANT> > > EnumVar;
00210     EnumVar* pVar = new EnumVar;
00211     if (pVar == NULL) {
00212         delete [] vnt;
00213         return E_OUTOFMEMORY;
00214     }
00215
00216     // オブジェクトとともに初期化．コピーを作成．
00217     pVar->Init(&vnt[0], &vnt[i], NULL, AtlFlagCopy);
00218
00219     // 一時的な配列に入っているオブジェクトを解放
00220     lCount--;
00221     while (lCount >= 0) {
00222         VariantClear(&vnt[lCount]);
00223         lCount--;
00224     }
00225     delete [] vnt;
00226
00227     // 列挙子のIUnknownを返す．(pValは削除しない．)
00228     pVar->QueryInterface(IID_IUnknown, (void**)pVal);
00229
00230     return S_OK;
00231 }
00232
00239 STDMETHODIMP get_Count(long *pVal)
00240 {
00241     // コレクションのエントリ数を取得する．
00242     *pVal = m_map.size();
00243     return S_OK;
00244 }
00245
00246 /* ============================================================== */
00247 /*    CCaoCollectionTmpl Class Private Function Implementation    */
00248 /* ============================================================== */
00249 protected:
00250
00259 HRESULT GenerateIndex(long *lVal)
00260 {
00261     long i;
00262
00263     // 使用されていないIDを探す
00264     std::map<long, TIChd*>::iterator it;
00265     for (i = 0; i < LONG_MAX ; ++i) {
00266         it = m_map.find(i);
00267         if (it == m_map.end()) {
00268             // 使用されていないIDを返す
00269             *lVal = i;
00270             return S_OK;
00271         }
00272     }
00273     return E_FAIL;
00274 }
00275
00276 public:
00284 STDMETHODIMP GetIndex(VARIANT vntIndex, long *lVal)
00285 {
00286     std::map<long, TIChd*>::iterator it;
00287
00288     VARIANT* pvntVal = (vntIndex.vt == (VT_VARIANT | VT_BYREF))? vntIndex.pvarVal: &vntIndex;
00289     switch (pvntVal->vt) {
00290     case VT_BSTR:
00291         // 文字列からNULL及び空文字のときはエラー
00292         if (!SysStringLen(pvntVal->bstrVal)) {
00293             Error(IDS_E_CAO_OBJECT_NOTFOUND, *piid, E_CAO_OBJECT_NOTFOUND);
00294             return E_CAO_OBJECT_NOTFOUND;
00295         }
00296
00297         // 項目を名前によって検索．
00298         for (it = m_map.begin(); it != m_map.end(); it++) {
00299             CComBSTR bstrName;
00300             (*it).second->get_Name(&bstrName);
00301             if (wcscmp(pvntVal->bstrVal, bstrName.m_str) == 0) {
00302                 // 見つかった場合：オブジェクトのキーを返す
00303                 *lVal = (*it).first;
00304                 return S_OK;
00305             }
00306         }
00307         Error(IDS_E_CAO_OBJECT_NOTFOUND, *piid, E_CAO_OBJECT_NOTFOUND);
00308         return E_CAO_OBJECT_NOTFOUND;
00309
00310     case VT_I2:
00311     case VT_I4:
00312         it = (pvntVal->vt == VT_I2)? m_map.find(pvntVal->iVal): m_map.find(pvntVal->lVal);
00313         if (it == m_map.end()) {
00314             // 見つからなかった場合：エラーを返す．
00315             Error(IDS_E_CAO_OBJECT_NOTFOUND, *piid, E_CAO_OBJECT_NOTFOUND);
00316             return E_CAO_OBJECT_NOTFOUND;
00317         }
00318         // 見つかった場合：インデックス番号をコピー．
00319         *lVal = (*it).first;
00320         return S_OK;
00321
00322     default:
00323         Error(IDS_E_CAO_VARIANT_TYPE_NOSUPPORT, *piid, E_CAO_VARIANT_TYPE_NOSUPPORT);
00324         return E_CAO_VARIANT_TYPE_NOSUPPORT;
00325     }
00326 }
00327
00328 // Data Members
00329 protected:
00330
00334     std::map<long, TIChd*> m_map;
00335
00336 };
00337
00338 #endif
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoCommand.cpp File Reference

CaoCommand.cpp の解説

CCaoCommandクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoCommand.h"

CaoCommand.cppのインクルード依存関係図

Include dependency graph

解説

CCaoCommandクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:46 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoCommand.h File Reference

CaoCommand.h の解説

CCaoCommandの宣言. [詳細]

#include "resource.h"
#include "CAOCP.h"
#include "CaoObjectTmpl.h"

CaoCommand.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoCommand
CAOのCommandクラス. [詳細]

解説

CCaoCommandの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:47 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoCommand.h Source File

CaoCommand.h

解説を見る。
00001
00011 #ifndef __CAOCOMMAND_H_
00012 #define __CAOCOMMAND_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include "CAOCP.h"
00016 #include "CaoObjectTmpl.h"
00017
00019 // CCaoCommand
00027 class ATL_NO_VTABLE CCaoCommand :
00028     public _CCaoProvConnectionObjTmpl<CCaoCommand, &CLSID_CaoCommand, ICaoCommand, &IID_ICaoCommand, ICaoProvCommand>
00029 {
00030 public:
00036     CCaoCommand()
00037     {
00038         m_lMode = 0;
00039         m_hResult = S_FALSE;
00040         VariantInit(&m_vntResult);
00041         m_phCmdSem = NULL;
00042         m_pcsCmd = NULL;
00043         m_pqueCmds = NULL;
00044         m_bExecute = FALSE;
00045     }
00046
00052     ~CCaoCommand()
00053     {
00054         VariantClear(&m_vntResult);
00055     }
00056
00057 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOCOMMAND)
00058
00059 // FinalConstruct / FinalRelease
00060     HRESULT FinalConstruct();
00061     void FinalRelease();
00062
00063 // ICaoCommand
00064 public:
00065     STDMETHOD(_GetICaopObj)(/*[out, retval]*/ IUnknown **ppICaopObj);
00066     STDMETHOD(_GetICRDObj)(/*[out, retval]*/ IUnknown **ppICRDObj);
00067     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00068     STDMETHOD(_Execute0)();
00069
00070     STDMETHOD(get_Parameters)(/*[out, retval]*/ VARIANT *pVal);
00071     STDMETHOD(put_Parameters)(/*[in]*/ VARIANT newVal);
00072     STDMETHOD(get_Result)(/*[out, retval]*/ VARIANT *pVal);
00073     STDMETHOD(get_State)(/*[out, retval]*/ long *pVal);
00074     STDMETHOD(get_Timeout)(/*[out, retval]*/ long *pVal);
00075     STDMETHOD(put_Timeout)(/*[in]*/ long newVal);
00076
00077     STDMETHOD(Execute)(/*[in]*/ long lMode);
00078     STDMETHOD(Cancel)();
00079
00080 // Data Members
00081 private:
00082     long m_lMode;                       // Execute実行時のモード
00083     HRESULT m_hResult;                  // Execute()の戻り値
00084     VARIANT m_vntResult;                // Execute()の結果
00085
00086     HANDLE *m_phCmdSem;                     // ワーカスレッド用のセマフォ
00087     CRITICAL_SECTION *m_pcsCmd;             // スレッド終了イベントハンドル
00088     std::queue<CCaoCommand*> *m_pqueCmds;   // 非同期コマンドキュー
00089     BOOL m_bExecute;                        // コマンド実行中フラグ
00090 };
00091
00092 #endif //__CAOCOMMAND_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoCommands.cpp File Reference

CaoCommands.cpp の解説

CCaoCommandsクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoCommands.h"
#include "CaoController.h"

CaoCommands.cppのインクルード依存関係図

Include dependency graph

解説

CCaoCommandsクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:47 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoCommands.h File Reference

CaoCommands.h の解説

CCaoCommandsの宣言. [詳細]

#include "resource.h"
#include <map>
#include "CaoCommand.h"
#include "CaoCollectionTmpl.h"

CaoCommands.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoCommands
CAOのCommandのコレクションクラス. [詳細]

解説

CCaoCommandsの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:47 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoCommands.h Source File

CaoCommands.h

解説を見る。
00001
00011 #ifndef __CAOCOMMANDS_H_
00012 #define __CAOCOMMANDS_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include <map>
00016 #include "CaoCommand.h"
00017 #include "CaoCollectionTmpl.h"
00018
00020 // CCaoCommands
00028 class ATL_NO_VTABLE CCaoCommands :
00029     public _CCaoCollectionTmpl<CCaoCommands, &CLSID_CaoCommands, ICaoCommands, &IID_ICaoCommands, ICaoCommand>,
00030     public IProvideClassInfo2Impl<&CLSID_CaoCommands, &DIID__ICaoCommandsEvents, &LIBID_CAOLib>,
00031     public IConnectionPointContainerImpl<CCaoCommands>,
00032     public CProxy_ICaoCommandsEvents<CCaoCommands>
00033 {
00034 public:
00040     CCaoCommands()
00041     {
00042         m_pParent = NULL;
00043         m_lParentType = -1;
00044         m_bWritable = VARIANT_FALSE;
00045         m_phCmdSem = NULL;
00046         m_pcsCmd = NULL;
00047         m_pqueCmds = NULL;
00048     }
00049
00055     ~CCaoCommands()
00056     {
00057     }
00058
00059 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOCOMMANDS)
00060
00061 BEGIN_COM_MAP(CCaoCommands)
00062     COM_INTERFACE_ENTRY(ICaoCommands)
00063     COM_INTERFACE_ENTRY(IDispatch)
00064     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00065     COM_INTERFACE_ENTRY(IConnectionPointContainer)
00066     COM_INTERFACE_ENTRY_IMPL(IConnectionPointContainer)
00067 END_COM_MAP()
00068
00069 BEGIN_CONNECTION_POINT_MAP(CCaoCommands)
00070     CONNECTION_POINT_ENTRY(DIID__ICaoCommandsEvents)
00071 END_CONNECTION_POINT_MAP()
00072
00073 // FinalConstruct / FinalRelease
00074     HRESULT FinalConstruct();
00075     void FinalRelease();
00076
00077 // ICaoCommands
00078     STDMETHOD(Add)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoCommand **ppICaoCommand);
00079
00080     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00081     STDMETHOD(_FireExecuteComplete)(long lIndex);
00082
00083 // Data Members
00084 private:
00085     PVOID m_pParent;                        // 親オブジェクトのIF
00086     long m_lParentType;                     // 親オブジェクトの種類
00087     VARIANT_BOOL m_bWritable;               // 書込み属性
00088
00089     HANDLE *m_phCmdSem;                     // ワーカスレッド用のセマフォ
00090     CRITICAL_SECTION *m_pcsCmd;             // スレッド終了イベントハンドル
00091     std::queue<CCaoCommand*> *m_pqueCmds;   // 非同期コマンドキュー
00092
00093 };
00094
00095 #endif //__CAOCOMMANDS_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoController.cpp File Reference

CaoController.cpp の解説

CCaoController クラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoController.h"

CaoController.cppのインクルード依存関係図

Include dependency graph

解説

CCaoController クラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:47 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoController.h File Reference

CaoController.h の解説

CCaoControllerの定義. [詳細]

#include "resource.h"
#include "CAOCP.h"
#include "CaoObjectTmpl.h"
#include "EventSink.h"
#include "CaoExtensions.h"
#include "CaoCommands.h"
#include "CaoFiles.h"
#include "CaoRobots.h"
#include "CaoTasks.h"
#include "CaoVariables.h"
#include "CaoMessage.h"

CaoController.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CCaoController
CAOのControllerクラス. [詳細]

struct | PROV_MESSAGE
メッセージ格納用構造体 [詳細]

解説

CCaoControllerの定義.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:48 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoController.h Source File

CaoController.h

解説を見る。
00001
00011 #ifndef __CAOCONTROLLER_H_
00012 #define __CAOCONTROLLER_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include "CAOCP.h"
00016 #include "CaoObjectTmpl.h"
00017 #include "EventSink.h"
00018 #include "CaoExtensions.h"
00019 #include "CaoCommands.h"
00020 #include "CaoFiles.h"
00021 #include "CaoRobots.h"
00022 #include "CaoTasks.h"
00023 #include "CaoVariables.h"
00024 #include "CaoMessage.h"
00025
00027 struct PROV_MESSAGE {
00029     ICaoProvMessage* pICaopMsg;
00031     long lOption;
00032 };
00033
00042 class ATL_NO_VTABLE CCaoController :
00043     public _CCaoProvConnectionObjTmpl<CCaoController, &CLSID_CaoController, ICaoController, &IID_ICaoController, ICaoProvController>,
00044     public IProvideClassInfo2Impl<&CLSID_CaoController, &DIID__ICaoControllerEvents, &LIBID_CAOLib>,
00045     public IConnectionPointContainerImpl<CCaoController>,
00046     public CProxy_ICaoControllerEvents<CCaoController>
00047 {
00048 public:
00054     CCaoController()
00055     {
00056         m_pCaoExps  = NULL;
00057         m_pCaoFiles = NULL;
00058         m_pCaoRobots = NULL;
00059         m_pCaoTasks = NULL;
00060         m_pCaoVals = NULL;
00061         m_pCaoCmds = NULL;
00062         m_bEventDisable = VARIANT_FALSE;
00063
00064         m_pEventSink = NULL;
00065         m_hMessThread = NULL;
00066         m_hEventSem = NULL;
00067         m_hTerminate = NULL;
00068         m_bWritable = VARIANT_FALSE;
00069
00070         m_hCmdThread = NULL;
00071         m_hCmdSem = NULL;
00072     }
00073
00079     ~CCaoController()
00080     {
00081     }
00082
00083 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOCONTROLLER)
00084
00085 DECLARE_PROTECT_FINAL_CONSTRUCT()
00086
00087 BEGIN_COM_MAP(CCaoController)
00088     COM_INTERFACE_ENTRY(ICaoController)
00089     COM_INTERFACE_ENTRY(IDispatch)
00090     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00091     COM_INTERFACE_ENTRY(IConnectionPointContainer)
00092     COM_INTERFACE_ENTRY_IMPL(IConnectionPointContainer)
00093 END_COM_MAP()
00094
00095 BEGIN_CONNECTION_POINT_MAP(CCaoController)
00096     CONNECTION_POINT_ENTRY(DIID__ICaoControllerEvents)
00097 END_CONNECTION_POINT_MAP()
00098
00099 // FinalConstruct / FinalRelease
00100     HRESULT FinalConstruct();
00101     void FinalRelease();
00102
00103 // ICaoController
00104     HRESULT _Initialize(VARIANT vntArgs[]);
00105     HRESULT _FireOnMessage(IUnknown *pVal, long lOption);
00106     HRESULT _GetICaopObj(IUnknown **ppICaopObj);
00107     HRESULT _GetICRDObj(IUnknown **ppICRDObj);
00108     HRESULT _Close();
00109
00110     STDMETHOD(get_ExtensionNames)(/*[in]*/ BSTR bstrOption, /*[out, retval]*/ VARIANT *pVal);
00111     STDMETHOD(get_Extensions)(/*[out, retval]*/ ICaoExtensions **ppICaoExtensions);
00112     STDMETHOD(get_FileNames)(/*[in]*/ BSTR bstrOption, /*[out, retval]*/ VARIANT *pVal);
00113     STDMETHOD(get_Files)(/*[out, retval]*/ ICaoFiles **ppICaoFiles);
00114     STDMETHOD(get_RobotNames)(/*[in]*/ BSTR bstrOption, /*[out, retval]*/ VARIANT *pVal);
00115     STDMETHOD(get_Robots)(/*[out, retval]*/ ICaoRobots **ppICaoRobots);
00116     STDMETHOD(get_TaskNames)(/*[in]*/ BSTR bstrOption, /*[out, retval]*/ VARIANT *pVal);
00117     STDMETHOD(get_Tasks)(/*[out, retval]*/ ICaoTasks **ppICaoTasks);
00118     STDMETHOD(get_VariableNames)(/*[in]*/ BSTR bstrOption, /*[out, retval]*/ VARIANT *pVal);
00119     STDMETHOD(get_Variables)(/*[out, retval]*/ ICaoVariables **ppICaoVariables);
00120     STDMETHOD(get_CommandNames)(/*[in]*/ BSTR bstrOption, /*[out, retval]*/ VARIANT *pVal);
00121     STDMETHOD(get_Commands)(/*[out, retval]*/ ICaoCommands **ppICaoCommands);
00122
00123     STDMETHOD(AddExtension)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoExtension **ppICaoExtension);
00124     STDMETHOD(AddFile)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoFile **ppICaoFile);
00125     STDMETHOD(AddRobot)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoRobot **ppICaoRobot);
00126     STDMETHOD(AddTask)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoTask **ppICaoTask);
00127     STDMETHOD(AddVariable)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoVariable **ppICaoVar);
00128     STDMETHOD(AddCommand)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoCommand **ppICaoCommand);
00129     STDMETHOD(Execute)(/*[in]*/ VARIANT vntCommand, /*[out, retval]*/ VARIANT *pVal);
00130     STDMETHOD(GetMessage)(/*[out, retval]*/ ICaoMessage **ppICaoMessage);
00131
00132     HRESULT CustomGetIDsOfNames(REFIID riid, LPOLESTR* rgszNames, UINT cNames, LCID lcid, DISPID* rgdispid);
00133     HRESULT CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS* pdispparams, VARIANT* pvarResult, EXCEPINFO* pexcepinfo, UINT* puArgErr);
00134
00135 private:
00136     static void __cdecl FireOnMessageAsync0(LPVOID pArglist);
00137     void FireOnMessageAsync();
00138
00139     static void __cdecl ExecuteAsync0(LPVOID pArglist);
00140     void ExecuteAsync();
00141
00142     HRESULT OutputLogMessage(ICaoProvMessage * pICaopMess, long lOption);
00143
00144     HRESULT CustomInvokeCmds(DISPID dispidMember, DISPPARAMS* pdispparams, VARIANT* pvarResult);
00145     HRESULT CustomInvokeExec(DISPPARAMS* pdispparams, VARIANT* pvarResult);
00146
00147 // Data Members
00148 private:
00149     CEventSink* m_pEventSink;               // CaoProvController へ Advise するイベントシンク
00150     CCaoExtensions* m_pCaoExps;             // CaoExtensionコレクション のIF
00151     CCaoFiles* m_pCaoFiles;                 // ICaoFileコレクション のIF
00152     CCaoRobots* m_pCaoRobots;               // ICaoRobotコレクション のIF
00153     CCaoTasks* m_pCaoTasks;                 // ICaoTaskコレクション のIF
00154     CCaoVariables* m_pCaoVals;              // ICaoVariableコレクション のIF
00155     CCaoCommands* m_pCaoCmds;               // ICaoCommandコレクション のIF
00156
00157     HANDLE m_hTerminate;                    // スレッド終了イベントハンドル
00158     VARIANT_BOOL m_bEventDisable;           // イベント機能の有効・無効フラグ
00159
00160     // メッセージイベント用
00161     HANDLE m_hMessThread;                   // イベント処理スレッドのハンドル
00162     HANDLE m_hEventSem;                     // イベント処理用のセマフォ
00163     std::queue<PROV_MESSAGE> m_queEvents;   // メッセージキュー
00164     CRITICAL_SECTION m_csMess;              // スレッド対応用のクリティカルセクション
00165     HRESULT m_hrLastOnMess;                 // メッセージイベントの最終結果
00166
00167     // 非同期コマンド用
00168     HANDLE m_hCmdThread;                    // イベント処理スレッドのハンドル
00169     HANDLE m_hCmdSem;                       // イベント処理用のセマフォ
00170     std::queue<CCaoCommand*> m_queCmds;     // 非同期コマンドキュー
00171     CRITICAL_SECTION m_csCmd;               // スレッド対応用のクリティカルセクション
00172
00173     VARIANT_BOOL m_bBindCmds;               // ダイナミックバインディング
00174     VARIANT_BOOL m_bBindExec;
00175     WCHAR m_wcsBindName[CAO_FUNCSTR_MAX];
00176 };
00177
00178 #endif //__CAOCONTROLLER_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoControllers.cpp File Reference

CaoControllers.cpp の解説

CCaoControllersの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoControllers.h"

CaoControllers.cppのインクルード依存関係図

Include dependency graph

解説

CCaoControllersの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:48 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoControllers.h File Reference

CaoControllers.h の解説

CCaoControllersの宣言. [詳細]

#include "resource.h"
#include <map>
#include "CaoController.h"
#include "CaoCollectionTmpl.h"

CaoControllers.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoControllers
CAOのControllerのコレクションクラス. [詳細]

解説

CCaoControllersの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:48 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoControllers.h Source File

CaoControllers.h

解説を見る。
00001
00011 #ifndef __CAOCONTROLLERS_H_
00012 #define __CAOCONTROLLERS_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include <map>
00016 #include "CaoController.h"
00017 #include "CaoCollectionTmpl.h"
00018
00020 // CCaoControllers
00028 class ATL_NO_VTABLE CCaoControllers :
00029     public _CCaoCollectionTmpl<CCaoControllers, &CLSID_CaoControllers, ICaoControllers, &IID_ICaoControllers, ICaoController>
00030
00031 {
00032 public:
00038     CCaoControllers()
00039     {
00040     }
00041
00047     ~CCaoControllers()
00048     {
00049     }
00050
00051 // FinalConstruct / FinalRelease
00052     HRESULT FinalConstruct();
00053     void FinalRelease();
00054
00055 // ICaoControllers
00056     STDMETHOD(Add)(/*[in]*/ BSTR bstrProvider, /*[in, defaultvalue("")]*/ BSTR bstrMachine, /*[in, defaultvalue("")]*/ BSTR bstrController, /*[in, defaultvalue("")]*/ BSTR bstrOption, /*[out, retval]*/ ICaoController **ppICaoCtrl);
00057     STDMETHOD(Remove)(/*[in]*/ VARIANT Index);
00058
00059 private:
00060     HRESULT ConnectServer(BSTR bstrController, BSTR bstrProvider, BSTR bstrMachine, BSTR bstrOption, ICaoController **ppICaoCtrl);
00061     HRESULT ConnectRemoteServer(BSTR bstrEngine, BSTR bstrProvider, BSTR bstrMachine, BSTR bstrController, BSTR bstrOption, ICaoController **ppICaoCtrl);
00062
00063 // Data Members
00064 private:
00065
00066 };
00067
00068 #endif //__CAOCONTROLLERS_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOCP.h File Reference

CAOCP.h の解説

イベント通知テンプレートの宣言 [詳細]

#include "CaoMessage.h"

CAOCP.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CProxy_ICaoCommandsEvents
CAOのコントローライベントプロキシテンプレートクラス. [詳細]

class | CProxy_ICaoControllerEvents
CAOのコントローライベントプロキシテンプレートクラス. [詳細]

class | CProxy_ICaoExecuteCompleteEvent
CAOのExecuteCompleteイベントテンプレートクラス. [詳細]

class | CProxy_ICaoOnMessageEvent
CAOのOnMessageイベントテンプレートクラス. [詳細]

解説

イベント通知テンプレートの宣言

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:49 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOCP.h Source File

CAOCP.h

解説を見る。
00001
00011 #ifndef _CAOCP_H_
00012 #define _CAOCP_H_
00013
00014 #include "CaoMessage.h"
00015 // <<<<<<<<<< CAO Event Templates >>>>>>>>>>
00016
00024 template <class T, DISPID dispid>
00025 class CProxy_ICaoOnMessageEvent
00026 {
00027 public:
00028     CProxy_ICaoOnMessageEvent()
00029     {
00030         m_lSerialNumber = 0;
00031     }
00032
00039     HRESULT Fire_OnMessage(IUnknown *pVal)
00040     {
00041         _Module.LogEvent(CAO_LOG_DEBUG, _T("CProxy_ICaoOnMessageEvent::Fire_OnMessage()\n"));
00042
00043         HRESULT hr;
00044         CComVariant vntResult;
00045         T* pT = static_cast<T*>(this);
00046         int nConnectionIndex;
00047         CComVariant pvnt;
00048
00049         // メッセージオブジェクトの作成
00050         CComPtr<ICaoMessage> pICaoMess;
00051         hr = CreateMessage((ICaoProvMessage*)pVal, (ICaoMessage**)(&pICaoMess));
00052         if (FAILED(hr)) {
00053             SAFE_RELEASE(pVal);
00054             return hr;
00055         }
00056
00057         int nConnections = pT->m_vec.GetSize();
00058
00059         for (nConnectionIndex = 0; nConnectionIndex < nConnections; nConnectionIndex++) {
00060             pT->Lock();
00061             CComPtr<IUnknown> sp = pT->m_vec.GetAt(nConnectionIndex);
00062             pT->Unlock();
00063             CComPtr<IDispatch> pDispatch = reinterpret_cast<IDispatch*>(sp.p);
00064             if (pDispatch != NULL) {
00065                 VariantClear(&vntResult);
00066
00067                 pvnt = pICaoMess;
00068
00069                 DISPPARAMS disp = { &pvnt, NULL, 1, 0 };
00070                 pDispatch->Invoke(dispid, IID_NULL, LOCALE_USER_DEFAULT, DISPATCH_METHOD, &disp, &vntResult, NULL, NULL);
00071             }
00072         }
00073         return vntResult.scode;
00074     }
00075
00083     HRESULT CreateMessage(ICaoProvMessage *pICaopMess, ICaoMessage **ppVal)
00084     {
00085         // CComObject<CCaoMessage>のインスタンス作成
00086         CComObject<CCaoMessage>* pCaoMessage;
00087         HRESULT hr = CComObject<CCaoMessage>::CreateInstance(&pCaoMessage);
00088         if (FAILED(hr)) {
00089             return hr;
00090         }
00091
00092         VARIANT vntArgs[2];
00093         vntArgs[0].punkVal = (IUnknown*)pICaopMess;
00094         vntArgs[1].lVal = m_lSerialNumber;
00095         hr = pCaoMessage->_Initialize(vntArgs);
00096         if (FAILED(hr)) {
00097             SAFE_DELETE(pCaoMessage);
00098             return hr;
00099         }
00100         hr = pCaoMessage->QueryInterface(IID_ICaoMessage, reinterpret_cast<void **>(ppVal));
00101         if (FAILED(hr)) {
00102             SAFE_DELETE(pCaoMessage);
00103         }
00104
00105         if(m_lSerialNumber == LONG_MAX) {
00106             m_lSerialNumber = 0;
00107         } else {
00108             ++m_lSerialNumber;
00109         }
00110         return hr;
00111     }
00112
00113
00114 private:
00115     long m_lSerialNumber;
00116 };
00117
00125 template <class T, DISPID dispid>
00126 class CProxy_ICaoExecuteCompleteEvent
00127 {
00128 public:
00129     HRESULT Fire_ExecuteComplete(long lIndex)
00130     {
00131         _Module.LogEvent(CAO_LOG_DEBUG, _T("CProxy_ICaoExecuteCompleteEvent::Fire_ExecuteComplete()\n"));
00132
00133         CComVariant vntResult;
00134         T* pT = static_cast<T*>(this);
00135         int nConnectionIndex;
00136         CComVariant pvnt;
00137
00138         int nConnections = pT->m_vec.GetSize();
00139
00140         for (nConnectionIndex = 0; nConnectionIndex < nConnections; nConnectionIndex++)
00141         {
00142             pT->Lock();
00143             CComPtr<IUnknown> sp = pT->m_vec.GetAt(nConnectionIndex);
00144             pT->Unlock();
00145             IDispatch* pDispatch = reinterpret_cast<IDispatch*>(sp.p);
00146             if (pDispatch != NULL)
00147             {
00148                 VariantClear(&vntResult);
00149                 pvnt.vt = VT_I4;
00150                 pvnt.lVal = lIndex;
00151                 DISPPARAMS disp = { &pvnt, NULL, 1, 0 };
00152                 pDispatch->Invoke(dispid, IID_NULL, LOCALE_USER_DEFAULT, DISPATCH_METHOD, &disp, &vntResult, NULL, NULL);
00153             }
00154         }
00155
00156         return vntResult.scode;
00157     }
00158 };
00159
00160 // <<<<<<<<<< CAO Event Definitions >>>>>>>>>>
00161
00162 /*-----------------------------------*/
00163 /* CProxy_ICaoControllerEvents Class */
00164 /*-----------------------------------*/
00165
00171 template <class T>
00172 class CProxy_ICaoControllerEvents :
00173     public IConnectionPointImpl<T, &DIID__ICaoControllerEvents, CComDynamicUnkArray>,
00174     public CProxy_ICaoOnMessageEvent<T, 0x1>
00175 {
00176 };
00177
00178 /*-----------------------------------*/
00179 /* CProxy_ICaoCommandsEvents Class   */
00180 /*-----------------------------------*/
00181
00187 template <class T>
00188 class CProxy_ICaoCommandsEvents :
00189     public IConnectionPointImpl<T, &DIID__ICaoCommandsEvents, CComDynamicUnkArray>,
00190     public CProxy_ICaoExecuteCompleteEvent<T, 0x1>
00191 {
00192 };
00193
00194 #endif
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoEngine.cpp File Reference

CaoEngine.cpp の解説

CCaoEngineクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoEngine.h"
#include "Preload.h"

CaoEngine.cppのインクルード依存関係図

Include dependency graph

解説

CCaoEngineクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:49 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoEngine.h File Reference

CaoEngine.h の解説

CCaoEngineの宣言. [詳細]

#include "resource.h"
#include "CaoWorkspaces.h"
#include "CaoWorkspace.h"
#include "CaoEngineStatus.h"

CaoEngine.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoEngine
CAOのEngineクラス. [詳細]

解説

CCaoEngineの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:49 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoEngine.h Source File

CaoEngine.h

解説を見る。
00001
00011 #ifndef __CAOENGINE_H_
00012 #define __CAOENGINE_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include "CaoWorkspaces.h"
00016 #include "CaoWorkspace.h"
00017 #include "CaoEngineStatus.h"
00018
00019
00021 // CCaoEngine
00028 class ATL_NO_VTABLE CCaoEngine :
00029     public CComObjectRootEx<CComMultiThreadModel>,
00030     public CComCoClass<CCaoEngine, &CLSID_CaoEngine>,
00031     public ISupportErrorInfo,
00032 //  public IDispatchImpl<ICaoEngine, &IID_ICaoEngine, &LIBID_CAOLib>
00033     public ICaoDispatchImpl<ICaoEngine, &IID_ICaoEngine, &LIBID_CAOLib>
00034 {
00035 public:
00041     CCaoEngine()
00042     {
00043         m_pCaoWSs = NULL;
00044         m_pCaoEngineStatus = NULL;
00045     }
00046
00052     ~CCaoEngine()
00053     {
00054     }
00055
00056 DECLARE_REGISTRY_RESOURCEID(IDR_CAOENGINE)
00057
00058 DECLARE_PROTECT_FINAL_CONSTRUCT()
00059
00060 BEGIN_COM_MAP(CCaoEngine)
00061     COM_INTERFACE_ENTRY(ICaoEngine)
00062     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00063     COM_INTERFACE_ENTRY(IDispatch)
00064 END_COM_MAP()
00065
00066 // FinalConstruct / FinalRelease
00067     HRESULT FinalConstruct();
00068     void FinalRelease();
00069
00070 // ISupportsErrorInfo
00071     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00072
00073 // ICaoEngine
00074     STDMETHOD(get_EngineStatus)(/*[out, retval]*/ ICaoEngineStatus **ppICaoStatus);
00075     STDMETHOD(get_Workspaces)(/*[out, retval]*/  ICaoWorkspaces **ppICaoWSs);
00076
00077     STDMETHOD(AddWorkspace)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoWorkspace **ppICaoWS);
00078     STDMETHOD(Execute)(/*[in]*/ VARIANT vntCommand, /*[out, retval]*/ VARIANT *pVal);
00079
00080 private:
00081 /*
00082     HRESULT PreloadObject(ICaoWorkspace *pICaoWS);
00083     HRESULT PreloadController(ICaoWorkspace *pICaoWS, ICRDEngine *pICRDEng);
00084     HRESULT PreloadCommand(ICaoController *pICaoCtrl, ICRDController *pICRDCtrl);
00085     template <class T1, class T2>HRESULT PreloadFile(T1 pICaoObj, T2 pICRDObj);
00086     HRESULT PreloadRobot(ICaoController *pICaoCtrl, ICRDController *pICRDCtrl);
00087     HRESULT PreloadTask(ICaoController *pICaoCtrl, ICRDController *pICRDCtrl);
00088     template <class T1, class T2>HRESULT PreloadVariable(T1 pICaoObj, T2 pICRDObj);
00089 */
00090
00091 // Data Members
00092 private:
00093     CCaoWorkspaces* m_pCaoWSs;                      // CaoWorkspaces オブジェクト
00094     CCaoEngineStatus* m_pCaoEngineStatus;           // CaoEngineStatus オブジェクト
00095
00096 };
00097
00098 #endif //__CAOENGINE_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoEngineStatus.cpp File Reference

CaoEngineStatus.cpp の解説

CCaoEngineStatusクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoEngineStatus.h"

CaoEngineStatus.cppのインクルード依存関係図

Include dependency graph

解説

CCaoEngineStatusクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:49 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoEngineStatus.h File Reference

CaoEngineStatus.h の解説

CCaoEngineStatusの宣言. [詳細]

#include "resource.h"

CaoEngineStatus.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoEngineStatus
CAOのEngineStatusクラス. [詳細]

解説

CCaoEngineStatusの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:49 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoEngineStatus.h Source File

CaoEngineStatus.h

解説を見る。
00001
00011 #ifndef __CAOENGINESTATUS_H_
00012 #define __CAOENGINESTATUS_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015
00017 // CCaoEngineStatus
00025 class ATL_NO_VTABLE CCaoEngineStatus :
00026     public CComObjectRootEx<CComSingleThreadModel>,
00027     public CComCoClass<CCaoEngineStatus, &CLSID_CaoEngineStatus>,
00028     public IDispatchImpl<ICaoEngineStatus, &IID_ICaoEngineStatus, &LIBID_CAOLib>
00029 {
00030 public:
00036     CCaoEngineStatus()
00037     {
00038         VariantInit(&m_vntStartTime);
00039     }
00040
00046     ~CCaoEngineStatus()
00047     {
00048         VariantClear(&m_vntStartTime);
00049     }
00050
00051 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOENGINESTATUS)
00052
00053 DECLARE_PROTECT_FINAL_CONSTRUCT()
00054
00055 BEGIN_COM_MAP(CCaoEngineStatus)
00056     COM_INTERFACE_ENTRY(ICaoEngineStatus)
00057     COM_INTERFACE_ENTRY(IDispatch)
00058 END_COM_MAP()
00059
00060 // FinalConstruct / FinalRelease
00061     HRESULT FinalConstruct();
00062     void FinalRelease();
00063
00064 // ICaoEngineStatus
00065 public:
00066     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00067
00068     STDMETHOD(get_Version)(/*[out, retval]*/ BSTR *pVal);
00069     STDMETHOD(get_Values)(/*[in]*/ VARIANT vntName, /*[out, retval]*/ VARIANT *pVal);
00070     STDMETHOD(get_StartDateTime)(/*[out, retval]*/ VARIANT *pVal);
00071     STDMETHOD(get_ObjectCounts)(/*[in]*/ VARIANT vntName, /*[out, retval]*/ long *pVal);
00072     STDMETHOD(get_ComputerName)(/*[out, retval]*/ BSTR *pVal);
00073     STDMETHOD(get_CurrentDateTime)(/*[out, retval]*/ VARIANT *pVal);
00074
00075 // Data Members
00076 private:
00077     VARIANT m_vntStartTime;
00078 };
00079
00080 #endif //__CAOENGINESTATUS_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOEventInfo.h File Reference

CAOEventInfo.h の解説

ソースコードを見る。

マクロ定義

#define | FACILITY_WARNING 0xF02
#define | FACILITY_INFORMATIONAL 0xF01
#define | FACILITY_ERROR 0xF03
#define | STATUS_SEVERITY_WARNING 0x2
#define | STATUS_SEVERITY_INFORMATIONAL 0x1
#define | STATUS_SEVERITY_ERROR 0x3
#define | MSG_CAO_LOG ((DWORD)0x4F010000L)

マクロ定義の解説

#define FACILITY_ERROR 0xF03

#define FACILITY_INFORMATIONAL 0xF01

#define FACILITY_WARNING 0xF02

#define MSG_CAO_LOG ((DWORD)0x4F010000L)

#define STATUS_SEVERITY_ERROR 0x3

#define STATUS_SEVERITY_INFORMATIONAL 0x1

#define STATUS_SEVERITY_WARNING 0x2

Generated on Wed Dec 7 19:01:50 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOEventInfo.h Source File

CAOEventInfo.h

解説を見る。
00001 #ifndef _CAOEVENTINFO_MC_
00002 #define _CAOEVENTINFO_MC_
00003 //
00004 //  Values are 32 bit values layed out as follows:
00005 //
00006 //   3 3 2 2 2 2 2 2 2 2 2 2 1 1 1 1 1 1 1 1 1 1
00007 //   1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0
00008 //  +---+-+-+-----------------------+-------------------------------+
00009 //  |Sev|C|R|     Facility          |               Code            |
00010 //  +---+-+-+-----------------------+-------------------------------+
00011 //
00012 //  where
00013 //
00014 //      Sev - is the severity code
00015 //
00016 //          00 - Success
00017 //          01 - Informational
00018 //          10 - Warning
00019 //          11 - Error
00020 //
00021 //      C - is the Customer code flag
00022 //
00023 //      R - is a reserved bit
00024 //
00025 //      Facility - is the facility code
00026 //
00027 //      Code - is the facility's status code
00028 //
00029 //
00030 // Define the facility codes
00031 //
00032 #define FACILITY_WARNING                 0xF02
00033 #define FACILITY_INFORMATIONAL           0xF01
00034 #define FACILITY_ERROR                   0xF03
00035
00036
00037 //
00038 // Define the severity codes
00039 //
00040 #define STATUS_SEVERITY_WARNING          0x2
00041 #define STATUS_SEVERITY_INFORMATIONAL    0x1
00042 #define STATUS_SEVERITY_ERROR            0x3
00043
00044
00045 //
00046 // MessageId: MSG_CAO_LOG
00047 //
00048 // MessageText:
00049 //
00050 //  %1
00051 //
00052 #define MSG_CAO_LOG                      ((DWORD)0x4F010000L)
00053
00054 #endif // _CAOINFO_MC_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoExtension.cpp File Reference

CaoExtension.cpp の解説

CCaoExtensionクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoExtension.h"

CaoExtension.cppのインクルード依存関係図

Include dependency graph

解説

CCaoExtensionクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:50 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoExtension.h File Reference

CaoExtension.h の解説

CCaoExtensionの宣言. [詳細]

#include "resource.h"
#include "CaoObjectTmpl.h"
#include "CaoVariables.h"

CaoExtension.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoExtension
CAOのExtensionクラス. [詳細]

解説

CCaoExtensionの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:50 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoExtension.h Source File

CaoExtension.h

解説を見る。
00001
00011 #ifndef __CAOEXTENSION_H_
00012 #define __CAOEXTENSION_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include "CaoObjectTmpl.h"
00016 #include "CaoVariables.h"
00017
00019 // CCaoExtension
00027 class ATL_NO_VTABLE CCaoExtension :
00028     public _CCaoProvConnectionObjTmpl<CCaoExtension, &CLSID_CaoExtension, ICaoExtension, &IID_ICaoExtension, ICaoProvExtension>
00029 {
00030 public:
00036     CCaoExtension()
00037     {
00038         m_pCaoVals = NULL;
00039     }
00040
00046     ~CCaoExtension()
00047     {
00048     }
00049
00050 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOEXTENSION)
00051
00052 // FinalConstruct / FinalRelease
00053     HRESULT FinalConstruct();
00054     void FinalRelease();
00055
00056 // ICaoExtension
00057     STDMETHOD(_GetICaopObj)(/*[out, retval]*/ IUnknown **ppICaopObj);
00058     STDMETHOD(_GetICRDObj)(/*[out, retval]*/ IUnknown **ppICRDObj);
00059
00060     STDMETHOD(get_VariableNames)(/*[in]*/ BSTR bstrOption, /*[out, retval]*/ VARIANT *pVal);
00061     STDMETHOD(get_Variables)(/*[out, retval]*/ ICaoVariables **ppICaoVariables);
00062
00063     STDMETHOD(AddVariable)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoVariable **ppICaoVar);
00064     STDMETHOD(Execute)(/*[in]*/ VARIANT vntCommand, /*[out, retval]*/ VARIANT *pVal);
00065
00066     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00067
00068     HRESULT CustomGetIDsOfNames(REFIID riid, LPOLESTR* rgszNames, UINT cNames, LCID lcid, DISPID* rgdispid);
00069     HRESULT CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS* pdispparams, VARIANT* pvarResult, EXCEPINFO* pexcepinfo, UINT* puArgErr);
00070
00071 private:
00072     HRESULT CustomInvokeExec(DISPPARAMS* pdispparams, VARIANT* pvarResult);
00073
00074 // Data Members
00075 private:
00076     CCaoVariables* m_pCaoVals;      // ICaoVariableコレクション のIF
00077     VARIANT_BOOL m_bBindExec;       // 動的Invoke
00078     WCHAR m_wcsBindName[CAO_FUNCSTR_MAX];
00079 };
00080
00081 #endif //__CAOEXTENSION_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoExtensions.cpp File Reference

CaoExtensions.cpp の解説

CCaoExtensionsクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoExtensions.h"
#include "CaoController.h"

CaoExtensions.cppのインクルード依存関係図

Include dependency graph

解説

CCaoExtensionsクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:50 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoExtensions.h File Reference

CaoExtensions.h の解説

CCaoExtensionsの宣言. [詳細]

#include "resource.h"
#include <map>
#include "CaoExtension.h"
#include "CaoCollectionTmpl.h"

CaoExtensions.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoExtensions
CAOのExtensionのコレクションクラス. [詳細]

解説

CCaoExtensionsの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:50 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoExtensions.h Source File

CaoExtensions.h

解説を見る。
00001
00011 #ifndef __CAOEXTENSIONS_H_
00012 #define __CAOEXTENSIONS_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include <map>
00016 #include "CaoExtension.h"
00017 #include "CaoCollectionTmpl.h"
00018
00020 // CCaoExtensions
00028 class ATL_NO_VTABLE CCaoExtensions :
00029     public _CCaoCollectionTmpl<CCaoExtensions, &CLSID_CaoExtensions, ICaoExtensions, &IID_ICaoExtensions, ICaoExtension>
00030 {
00031 public:
00037     CCaoExtensions()
00038     {
00039         m_pParent = NULL;
00040         m_lParentType = -1;
00041         m_bWritable = VARIANT_FALSE;
00042     }
00043
00049     ~CCaoExtensions()
00050     {
00051     }
00052
00053 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOEXTENSIONS)
00054
00055 // FinalConstruct / FinalRelease
00056     HRESULT FinalConstruct();
00057     void FinalRelease();
00058
00059 // ICaoExtensions
00060     STDMETHOD(Add)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoExtension **ppICaoExtension);
00061
00062     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00063
00064 // Data Members
00065 private:
00066     PVOID m_pParent;            // 親オブジェクトのIF
00067     long m_lParentType;         // 親オブジェクトの種類
00068     VARIANT_BOOL m_bWritable;   // 書込み属性
00069     VARIANT_BOOL m_bBindExec;   // 動的Invoke
00070
00071 };
00072
00073 #endif //__CAOEXTENSIONS_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoFile.cpp File Reference

CaoFile.cpp の解説

CCaoFileクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoFile.h"

CaoFile.cppのインクルード依存関係図

Include dependency graph

解説

CCaoFileクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:51 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoFile.h File Reference

CaoFile.h の解説

CCaoFileの宣言. [詳細]

#include "resource.h"
#include "CaoObjectTmpl.h"
#include "CaoFiles.h"
#include "CaoVariables.h"

CaoFile.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoFile
CAOのFileクラス. [詳細]

解説

CCaoFileの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:51 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoFile.h Source File

CaoFile.h

解説を見る。
00001
00011 #ifndef __CAOFILE_H_
00012 #define __CAOFILE_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include "CaoObjectTmpl.h"
00016 #include "CaoFiles.h"
00017 #include "CaoVariables.h"
00018
00019 class CCaoFiles;
00020
00022 // CCaoFile
00030 class ATL_NO_VTABLE CCaoFile :
00031     public _CCaoProvConnectionObjTmpl<CCaoFile, &CLSID_CaoFile, ICaoFile, &IID_ICaoFile, ICaoProvFile>
00032 {
00033 public:
00039     CCaoFile()
00040     {
00041         m_pCaoFiles = NULL;
00042         m_pCaoVals = NULL;
00043     }
00044
00050     ~CCaoFile()
00051     {
00052     }
00053
00054 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOFILE)
00055
00056 // FinalConstruct / FinalRelease
00057     HRESULT FinalConstruct();
00058     void FinalRelease();
00059
00060 // ICaoFile
00061     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00062     STDMETHOD(_GetICaopObj)(/*[out, retval]*/ IUnknown **ppICaopObj);
00063     STDMETHOD(_GetICRDObj)(/*[out, retval]*/ IUnknown **ppICRDObj);
00064
00065     STDMETHOD(get_DateCreated)(/*[out, retval]*/ VARIANT *pVal);
00066     STDMETHOD(get_DateLastAccessed)(/*[out, retval]*/ VARIANT *pVal);
00067     STDMETHOD(get_DateLastModified)(/*[out, retval]*/ VARIANT *pVal);
00068     STDMETHOD(get_FileNames)(/*[in]*/ BSTR bstrOption, /*[out, retval]*/ VARIANT *pVal);
00069     STDMETHOD(get_Files)(/*[out, retval]*/ ICaoFiles **ppICaoFiles);
00070     STDMETHOD(get_Path)(/*[out, retval]*/ BSTR *pVal);
00071     STDMETHOD(get_Size)(/*[out, retval]*/ long *pVal);
00072     STDMETHOD(get_Type)(/*[out, retval]*/ BSTR *pVal);
00073     STDMETHOD(get_Value)(/*[out, retval]*/ VARIANT *pVal);
00074     STDMETHOD(put_Value)(/*[in]*/ VARIANT newVal);
00075     STDMETHOD(get_VariableNames)(/*[in]*/ BSTR bstrOption, /*[out, retval]*/ VARIANT *pVal);
00076     STDMETHOD(get_Variables)(/*[out, retval]*/ ICaoVariables **ppICaoVariables);
00077     STDMETHOD(AddFile)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoFile **ppICaoFile);
00078     STDMETHOD(AddVariable)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoVariable **ppICaoVar);
00079     STDMETHOD(Copy)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption);
00080     STDMETHOD(Delete)(/*[in]*/ BSTR bstrOption);
00081     STDMETHOD(Execute)(/*[in]*/ VARIANT vntCommand, /*[out, retval]*/ VARIANT *pVal);
00082     STDMETHOD(Move)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption);
00083     STDMETHOD(Run)(/*[in]*/ BSTR bstrOption, /*[out, retval]*/ BSTR *bstrName);
00084
00085     HRESULT CustomGetIDsOfNames(REFIID riid, LPOLESTR* rgszNames, UINT cNames, LCID lcid, DISPID* rgdispid);
00086     HRESULT CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS* pdispparams, VARIANT* pvarResult, EXCEPINFO* pexcepinfo, UINT* puArgErr);
00087
00088 private:
00089     HRESULT CustomInvokeExec(DISPPARAMS* pdispparams, VARIANT* pvarResult);
00090
00091 // Data Members
00092 private:
00093     CCaoFiles* m_pCaoFiles;     // ICaoFileコレクション のIF
00094     CCaoVariables* m_pCaoVals;  // ICaoVariableコレクション のIF
00095     VARIANT_BOOL m_bBindExec;   // 動的Invoke
00096     WCHAR m_wcsBindName[CAO_FUNCSTR_MAX];
00097 };
00098
00099 #endif //__CAOFILE_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoFiles.cpp File Reference

CaoFiles.cpp の解説

CCaoFilesクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoFiles.h"
#include "CaoController.h"

CaoFiles.cppのインクルード依存関係図

Include dependency graph

解説

CCaoFilesクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:51 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoFiles.h File Reference

CaoFiles.h の解説

CCaoFilesの宣言. [詳細]

#include "resource.h"
#include <map>
#include "CaoFile.h"
#include "CaoCollectionTmpl.h"

CaoFiles.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoFiles
CAOのFileのコレクションクラス. [詳細]

解説

CCaoFilesの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:51 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoFiles.h Source File

CaoFiles.h

解説を見る。
00001
00011 #ifndef __CAOFILES_H_
00012 #define __CAOFILES_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include <map>
00016 #include "CaoFile.h"
00017 #include "CaoCollectionTmpl.h"
00018
00020 // CCaoFiles
00028 class ATL_NO_VTABLE CCaoFiles :
00029     public _CCaoCollectionTmpl<CCaoFiles, &CLSID_CaoFiles, ICaoFiles, &IID_ICaoFiles, ICaoFile>
00030 {
00031 public:
00037     CCaoFiles()
00038     {
00039         m_pParent = NULL;
00040         m_lParentType = -1;
00041         m_bWritable = VARIANT_FALSE;
00042     }
00043
00049     ~CCaoFiles()
00050     {
00051     }
00052
00053 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOFILES)
00054
00055 // FinalConstruct / FinalRelease
00056     HRESULT FinalConstruct();
00057     void FinalRelease();
00058
00059 // ICaoFiles
00060     STDMETHOD(Add)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoFile **ppICaoFile);
00061
00062     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00063
00064 // Data Members
00065 private:
00066     PVOID m_pParent;            // 親オブジェクトのIF
00067     long m_lParentType;         // 親オブジェクトの種類
00068     VARIANT_BOOL m_bWritable;   // 書込み属性
00069     VARIANT_BOOL m_bBindExec;   // 動的Invoke
00070 };
00071
00072 #endif //__CAOFILES_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoMessage.cpp File Reference

CaoMessage.cpp の解説

CCaoMessageの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoMessage.h"

CaoMessage.cppのインクルード依存関係図

Include dependency graph

解説

CCaoMessageの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:52 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoMessage.h File Reference

CaoMessage.h の解説

CCaoMessageの宣言. [詳細]

#include "resource.h"

CaoMessage.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoMessage
CAOのControllerクラス. [詳細]

解説

CCaoMessageの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:52 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoMessage.h Source File

CaoMessage.h

解説を見る。
00001
00011 #ifndef __CAOMESSAGE_H_
00012 #define __CAOMESSAGE_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015
00024 class ATL_NO_VTABLE CCaoMessage :
00025     public CComObjectRootEx<CComSingleThreadModel>,
00026     public CComCoClass<CCaoMessage, &CLSID_CaoMessage>,
00027     public ISupportErrorInfo,
00028     public IDispatchImpl<ICaoMessage, &IID_ICaoMessage, &LIBID_CAOLib>
00029 {
00030 public:
00036     CCaoMessage()
00037     {
00038         m_pICaopMessage = NULL;
00039         m_lSerialNumber = -1;
00040     }
00041
00047     ~CCaoMessage()
00048     {
00049     }
00050
00051 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOMESSAGE)
00052
00053 DECLARE_PROTECT_FINAL_CONSTRUCT()
00054
00055 BEGIN_COM_MAP(CCaoMessage)
00056     COM_INTERFACE_ENTRY(ICaoMessage)
00057     COM_INTERFACE_ENTRY(IDispatch)
00058     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00059 END_COM_MAP()
00060 // FinalConstruct / FinalRelease
00061     HRESULT FinalConstruct();
00062     void FinalRelease();
00063
00064 // ISupportsErrorInfo
00065     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00066
00067 // ICaoMessage
00068     STDMETHOD(get_DateTime)(/*[out, retval]*/ VARIANT *pVal);
00069     STDMETHOD(get_Description)(/*[out, retval]*/ BSTR *pVal);
00070     STDMETHOD(get_Destination)(/*[out, retval]*/ BSTR *pVal);
00071     STDMETHOD(get_Number)(/*[out, retval]*/ long *pVal);
00072     STDMETHOD(get_SerialNumber)(/*[out, retval]*/ long *pVal);
00073     STDMETHOD(get_Source)(/*[out, retval]*/ BSTR *pVal);
00074     STDMETHOD(get_Value)(/*[out, retval]*/ VARIANT *pVal);
00075
00076     STDMETHOD(Clear)(void);
00077     STDMETHOD(Reply)(VARIANT vntData);
00078
00079     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00080 // Data Members
00081 private:
00082     ICaoProvMessage* m_pICaopMessage;   // CaoProvMessage のIF
00083     long m_lSerialNumber;               // シリアルナンバー
00084 };
00085
00086 #endif //__CAOMESSAGE_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoObjectTmpl.h File Reference

CaoObjectTmpl.h の解説

CAOのオブジェクトのテンプレート宣言. [詳細]

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | _CCaoBaseTmpl
CAOのオブジェクトのテンプレートクラス. [詳細]

class | _CCaoProvConnectionObjTmpl
CAOのプロバイダと接続するクラスのテンプレート. [詳細]

class | ICaoDispatchImpl
CAOのカスタムDispatchインターフェース. [詳細]

解説

CAOのオブジェクトのテンプレート宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:52 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoObjectTmpl.h Source File

CaoObjectTmpl.h

解説を見る。
00001
00011 #ifndef _CAOOBJTMPL_H_
00012 #define _CAOOBJTMPL_H_
00013
00014 // <<<<<<<<<< CAO Object Templates >>>>>>>>>>
00015
00021 template <class T, const IID* piid, const GUID* plibid = &CComModule::m_libid, WORD wMajor = 1, WORD wMinor = 0, class tihclass = CComTypeInfoHolder>
00022 class ATL_NO_VTABLE ICaoDispatchImpl:
00023     public IDispatchImpl<T, piid, plibid, wMajor, wMinor, tihclass>
00024 {
00025 public:
00026     STDMETHOD(GetIDsOfNames)(REFIID riid, LPOLESTR* rgszNames, UINT cNames,
00027         LCID lcid, DISPID* rgdispid)
00028     {
00029         HRESULT hr;
00030         hr = _tih.GetIDsOfNames(riid, rgszNames, cNames, lcid, rgdispid);;
00031         if (hr == DISP_E_UNKNOWNNAME) {
00032             HRESULT hrTemp = CustomGetIDsOfNames(riid, rgszNames, cNames, lcid, rgdispid);
00033             if (hrTemp != E_NOTIMPL) {
00034                 hr = hrTemp;
00035             }
00036         }
00037         return hr;
00038     }
00039
00040     virtual HRESULT CustomGetIDsOfNames(REFIID riid, LPOLESTR* rgszNames, UINT cNames,
00041         LCID lcid, DISPID* rgdispid)
00042     {
00043         return E_NOTIMPL;
00044     }
00045
00046     STDMETHOD(Invoke)(DISPID dispidMember, REFIID riid,
00047         LCID lcid, WORD wFlags, DISPPARAMS* pdispparams, VARIANT* pvarResult,
00048         EXCEPINFO* pexcepinfo, UINT* puArgErr)
00049     {
00050         HRESULT hr;
00051
00052         if (dispidMember >= CAO_DISPID_EXEC) {
00053             hr = CustomInvoke(dispidMember, riid, lcid, wFlags, pdispparams, pvarResult, pexcepinfo, puArgErr);
00054         }
00055         else {
00056             hr = _tih.Invoke((IDispatch*)this, dispidMember, riid, lcid, wFlags, pdispparams, pvarResult, pexcepinfo, puArgErr);
00057         }
00058         return hr;
00059     }
00060
00061     virtual HRESULT CustomInvoke(DISPID dispidMember, REFIID riid,
00062         LCID lcid, WORD wFlags, DISPPARAMS* pdispparams, VARIANT* pvarResult,
00063         EXCEPINFO* pexcepinfo, UINT* puArgErr)
00064     {
00065         return E_NOTIMPL;
00066     }
00067 };
00068
00074 template <class T, const CLSID* pclsid, class T1, const IID* piid>
00075 class ATL_NO_VTABLE _CCaoBaseTmpl:
00076     public CComObjectRootEx<CComMultiThreadModel>,
00077     public CComCoClass<T, pclsid>,
00078     public ISupportErrorInfo,
00079 //  public IDispatchImpl<T1, piid, &LIBID_CAOLib>
00080     public ICaoDispatchImpl<T1, piid, &LIBID_CAOLib>
00081
00082 {
00083 public:
00089     _CCaoBaseTmpl()
00090     {
00091         m_bstrName = NULL;
00092         m_lIndex = -1;
00093         m_bWritable = VARIANT_TRUE;
00094     }
00095
00101     ~_CCaoBaseTmpl()
00102     {
00103         SysFreeString(m_bstrName);
00104     }
00105
00106 DECLARE_PROTECT_FINAL_CONSTRUCT()
00107
00108 BEGIN_COM_MAP(T)
00109     COM_INTERFACE_ENTRY(T1)
00110     COM_INTERFACE_ENTRY(IDispatch)
00111     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00112 END_COM_MAP()
00113
00114 /* ============================================= */
00115 /*    CCaoBaseTmpl Class Method Implementation   */
00116 /* ============================================= */
00117
00118
00126 STDMETHODIMP InterfaceSupportsErrorInfo(REFIID riid)
00127 {
00128     static const IID* arr[] =
00129     {
00130         &IID_ICaoWorkspace
00131     };
00132     for (int i=0; i < sizeof(arr) / sizeof(arr[0]); i++) {
00133         if (InlineIsEqualGUID(*arr[i],riid)) {
00134             return S_OK;
00135         }
00136     }
00137     return S_FALSE;
00138 }
00139
00146 STDMETHODIMP get_Index(long *pVal)
00147 {
00148     _Module.LogEvent(CAO_LOG_DEBUG, _T("_CCaoBaseTmpl::get_Index\n"));
00149
00150     *pVal = m_lIndex;
00151
00152     return S_OK;
00153 }
00154
00161 STDMETHODIMP _PutIndex(long lVal)
00162 {
00163     m_lIndex = lVal;
00164
00165     _Module.LogEvent(CAO_LOG_DEBUG, _T("_CCaoBaseTmpl::put_Index\n"));
00166     return S_OK;
00167 }
00168
00177 STDMETHODIMP get_Name(BSTR *pVal)
00178 {
00179     _Module.LogEvent(CAO_LOG_DEBUG, _T("_CCaoBaseTmpl::get_Name\n"));
00180
00181     // コレクション削除のチェック
00182     HRESULT hr = CheckAccess(CAO_CHK_REMOVED);
00183     if (FAILED(hr)) {
00184         return hr;
00185     }
00186
00187     // オブジェクトの名前を取得する
00188     *pVal = SysAllocString(m_bstrName);
00189
00190     _Module.LogEvent(CAO_LOG_DEBUG, _T("_CCaoBaseTmpl::get_Name\n"));
00191     return S_OK;
00192 }
00193
00194 /* =================================== */
00195 /*    CCaoBaseTmpl Class Data Members  */
00196 /* =================================== */
00197 protected:
00198
00207 HRESULT CheckAccess(DWORD dwChkList)
00208 {
00209     // コレクション削除チェック
00210     if (dwChkList & CAO_CHK_REMOVED) {
00211         if (m_lIndex == CAO_OBJ_REMOVED) {
00212             return E_ACCESSDENIED;
00213         }
00214     }
00215
00216     // 書込み禁止チェック
00217     if (dwChkList & CAO_CHK_WRITEABLE) {
00218         if (m_bWritable == VARIANT_FALSE) {
00219             Error(IDS_E_CAO_NOT_WRITABLE, *piid, E_CAO_NOT_WRITABLE);
00220             return E_CAO_NOT_WRITABLE;
00221         }
00222     }
00223
00224     return S_OK;
00225 }
00226
00228     BSTR m_bstrName;
00229
00231     long m_lIndex;
00232
00234     VARIANT_BOOL m_bWritable;
00235 };
00236
00237
00243  template <class T, const CLSID* pclsid, class T1, const IID* piid, class TProv>
00244 class ATL_NO_VTABLE _CCaoProvConnectionObjTmpl:
00245     public _CCaoBaseTmpl<T, pclsid, T1, piid>
00246 {
00247 public:
00253     _CCaoProvConnectionObjTmpl()
00254     {
00255         VariantInit(&m_vntTag);
00256         m_pICaopObj = NULL;
00257         m_pICRDObj = NULL;
00258     }
00259
00265     ~_CCaoProvConnectionObjTmpl()
00266     {
00267         VariantClear(&m_vntTag);
00268         SAFE_RELEASE(m_pICaopObj);
00269         SAFE_RELEASE(m_pICRDObj);
00270     }
00271
00272 /* ========================================================== */
00273 /*    CCaoProvConnectionObjTmpl Class Method Implementation   */
00274 /* ========================================================== */
00275
00282 STDMETHODIMP get_Attribute(long *pVal)
00283 {
00284     _Module.LogEvent(CAO_LOG_DEBUG, _T("_CCaoProvConnectionObjTmpl::get_Attribute\n"));
00285
00286     // コレクション削除のチェック
00287     HRESULT hr = CheckAccess(CAO_CHK_REMOVED);
00288     if (FAILED(hr)) {
00289         return hr;
00290     }
00291
00292     hr = m_pICaopObj->get_Attribute(pVal);
00293     if (hr == E_CRDIMPL && m_pICRDObj != NULL) {
00294         hr = m_pICRDObj->get_Attribute(pVal);
00295     }
00296     return hr;
00297 }
00298
00299
00308 STDMETHODIMP get_Tag(VARIANT *pVal)
00309 {
00310     _Module.LogEvent(CAO_LOG_DEBUG, _T("_CCaoProvConnectionObjTmpl::get_Tag\n"));
00311
00312     // コレクション削除のチェック
00313     HRESULT hr = CheckAccess(CAO_CHK_REMOVED);
00314     if (FAILED(hr)) {
00315         return hr;
00316     }
00317
00318     // タグ情報を取得する
00319     return VariantCopy(pVal, &m_vntTag);
00320 }
00321
00330 STDMETHODIMP put_Tag(VARIANT newVal)
00331 {
00332     _Module.LogEvent(CAO_LOG_DEBUG, _T("_CCaoProvConnectionObjTmpl::put_Tag\n"));
00333
00334     // 書き込み禁止、コレクション削除のチェック
00335     HRESULT hr = CheckAccess(CAO_CHK_REMOVED | CAO_CHK_WRITEABLE);
00336     if (FAILED(hr)) {
00337         return hr;
00338     }
00339
00340     // タグ情報を設定する
00341     return VariantCopy(&m_vntTag, &newVal);
00342 }
00343
00352 STDMETHODIMP get_Help(BSTR *pVal)
00353 {
00354     _Module.LogEvent(CAO_LOG_DEBUG, _T("_CCaoProvConnectionObjTmpl::get_Help\n"));
00355
00356     // コレクション削除のチェック
00357     HRESULT hr = CheckAccess(CAO_CHK_REMOVED);
00358     if (FAILED(hr)) {
00359         return hr;
00360     }
00361
00362     // ヘルプ文字列を取得する
00363     hr = m_pICaopObj->get_Help(pVal);
00364     if (hr == E_CRDIMPL && m_pICRDObj != NULL) {
00365         hr = m_pICRDObj->get_Help(pVal);
00366     }
00367     return hr;
00368 }
00369
00376 STDMETHODIMP get_ID(VARIANT *pVal)
00377 {
00378     _Module.LogEvent(CAO_LOG_DEBUG, _T("_CCaoProvConnectionObjTmpl::get_ID\n"));
00379
00380     // コレクション削除のチェック
00381     HRESULT hr = CheckAccess(CAO_CHK_REMOVED);
00382     if (FAILED(hr)) {
00383         return hr;
00384     }
00385
00386     // ヘルプ文字列を取得する
00387     hr = m_pICaopObj->get_ID(pVal);
00388     if (hr == E_CRDIMPL && m_pICRDObj != NULL) {
00389         hr = m_pICRDObj->get_ID(pVal);
00390     }
00391     return hr;
00392 }
00393
00400 STDMETHODIMP put_ID(VARIANT newVal)
00401 {
00402     _Module.LogEvent(CAO_LOG_DEBUG, _T("_CCaoProvConnectionObjTmpl::put_ID\n"));
00403
00404     // コレクション削除のチェック
00405     HRESULT hr = CheckAccess(CAO_CHK_REMOVED);
00406     if (FAILED(hr)) {
00407         return hr;
00408     }
00409
00410     // ヘルプ文字列を取得する
00411     hr = m_pICaopObj->put_ID(newVal);
00412     if (hr == E_CRDIMPL && m_pICRDObj != NULL) {
00413         hr = m_pICRDObj->put_ID(newVal);
00414     }
00415     return hr;
00416 }
00417
00418
00419 /* =================================== */
00420 /*    CCaoBaseTmpl Class Data Members  */
00421 /* =================================== */
00422 protected:
00424     TProv* m_pICaopObj;
00425
00427     TProv* m_pICRDObj;
00428
00430     VARIANT m_vntTag;
00431 };
00432 #endif
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoRobot.cpp File Reference

CaoRobot.cpp の解説

CCaoRobotクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoRobot.h"

CaoRobot.cppのインクルード依存関係図

Include dependency graph

解説

CCaoRobotクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:52 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoRobot.h File Reference

CaoRobot.h の解説

CCaoRobotの宣言. [詳細]

#include "resource.h"
#include "CaoObjectTmpl.h"
#include "CaoVariables.h"

CaoRobot.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoRobot
CAOのRobotクラス. [詳細]

解説

CCaoRobotの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:53 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoRobot.h Source File

CaoRobot.h

解説を見る。
00001
00011 #ifndef __CAOROBOT_H_
00012 #define __CAOROBOT_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include "CaoObjectTmpl.h"
00016 #include "CaoVariables.h"
00017
00019 // CCaoRobot
00027 class ATL_NO_VTABLE CCaoRobot :
00028     public _CCaoProvConnectionObjTmpl<CCaoRobot, &CLSID_CaoRobot, ICaoRobot, &IID_ICaoRobot, ICaoProvRobot>
00029 {
00030 public:
00036     CCaoRobot()
00037     {
00038         m_pCaoVals = NULL;
00039     }
00040
00046     ~CCaoRobot()
00047     {
00048     }
00049
00050 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOROBOT)
00051
00052 // FinalConstruct / FinalRelease
00053     HRESULT FinalConstruct();
00054     void FinalRelease();
00055
00056 // ICaoRobot
00057     STDMETHOD(_GetICaopObj)(/*[out, retval]*/ IUnknown **ppICaopObj);
00058     STDMETHOD(_GetICRDObj)(/*[out, retval]*/ IUnknown **ppICRDObj);
00059     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00060
00061     STDMETHOD(get_VariableNames)(/*[in]*/ BSTR bstrOption, /*[out, retval]*/ VARIANT *pVal);
00062     STDMETHOD(get_Variables)(/*[out, retval]*/ ICaoVariables **ppICaoVariables);
00063     STDMETHOD(Accelerate)(/*[in]*/ long lAxis, /*[in]*/ float fAccel, /*[in, defaultvalue(0)]*/ float fDecel);
00064     STDMETHOD(AddVariable)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoVariable **ppICaoVar);
00065     STDMETHOD(Change)(/*[in]*/ BSTR bstrName);
00066     STDMETHOD(Chuck)(/*[in, defaultvalue("")]*/ BSTR bstrOption);
00067     STDMETHOD(Drive)(/*[in]*/ long lNo, /*[in]*/ float fMov, /*[in]*/ BSTR bstrOpt);
00068     STDMETHOD(Execute)(/*[in]*/ VARIANT vntCommand, /*[out, retval]*/ VARIANT *pVal);
00069     STDMETHOD(GoHome)();
00070     STDMETHOD(Halt)(/*[in, defaultvalue("")]*/ BSTR bstrOption);
00071     STDMETHOD(Hold)(/*[in, defaultvalue("")]*/ BSTR bstrOption);
00072     STDMETHOD(Move)(/*[in]*/ long lComp, /*[in]*/ VARIANT vntPose, /*[in]*/ BSTR bstrOpt);
00073     STDMETHOD(Rotate)(/*[in]*/ VARIANT vntRotSuf, /*[in]*/ float fDeg, /*[in]*/ VARIANT vntPivot, /*[in]*/ BSTR bstrOpt);
00074     STDMETHOD(Speed)(/*[in]*/ long lAxis, /*[in]*/ float fSpeed);
00075     STDMETHOD(Unchuck)(/*[in, defaultvalue("")]*/ BSTR bstrOption);
00076     STDMETHOD(Unhold)(/*[in, defaultvalue("")]*/ BSTR bstrOption);
00077
00078     HRESULT CustomGetIDsOfNames(REFIID riid, LPOLESTR* rgszNames, UINT cNames, LCID lcid, DISPID* rgdispid);
00079     HRESULT CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS* pdispparams, VARIANT* pvarResult, EXCEPINFO* pexcepinfo, UINT* puArgErr);
00080
00081 private:
00082     HRESULT CustomInvokeExec(DISPPARAMS* pdispparams, VARIANT* pvarResult);
00083
00084 // Data Members
00085 private:
00086     CCaoVariables* m_pCaoVals;  // ICaoVariableコレクション のIF
00087     VARIANT_BOOL m_bBindExec;   // 動的Invoke
00088     WCHAR m_wcsBindName[CAO_FUNCSTR_MAX];
00089 };
00090
00091 #endif //__CAOROBOT_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoRobots.cpp File Reference

CaoRobots.cpp の解説

CCaoRobotsクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoRobots.h"
#include "CaoController.h"

CaoRobots.cppのインクルード依存関係図

Include dependency graph

解説

CCaoRobotsクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:53 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoRobots.h File Reference

CaoRobots.h の解説

CCaoRobotsの宣言. [詳細]

#include "resource.h"
#include <map>
#include "CaoRobot.h"
#include "CaoCollectionTmpl.h"

CaoRobots.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoRobots
CAOのRobotのコレクションクラス. [詳細]

解説

CCaoRobotsの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:53 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoRobots.h Source File

CaoRobots.h

解説を見る。
00001
00011 #ifndef __CAOROBOTS_H_
00012 #define __CAOROBOTS_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include <map>
00016 #include "CaoRobot.h"
00017 #include "CaoCollectionTmpl.h"
00018
00020 // CCaoRobots
00028 class ATL_NO_VTABLE CCaoRobots :
00029     public _CCaoCollectionTmpl<CCaoRobots, &CLSID_CaoRobots, ICaoRobots, &IID_ICaoRobots, ICaoRobot>
00030 {
00031 public:
00037     CCaoRobots()
00038     {
00039         m_lParentType = -1;
00040         m_pParent = NULL;
00041         m_bWritable = VARIANT_FALSE;
00042     }
00043
00049     ~CCaoRobots()
00050     {
00051     }
00052
00053 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOROBOTS)
00054
00055 // FinalConstruct / FinalRelease
00056     HRESULT FinalConstruct();
00057     void FinalRelease();
00058
00059 // ICaoRobots
00060     STDMETHOD(Add)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoRobot **ppICaoRobot);
00061     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00062
00063 private:
00064 //  HRESULT CreateProvObj(BSTR bstrName, BSTR bstrOption, IUnknown **ppICaoObj);
00065
00066 // Data Members
00067 private:
00068     PVOID m_pParent;            // 親オブジェクトのIF
00069     long m_lParentType;         // 親オブジェクトの種類
00070     VARIANT_BOOL m_bWritable;   // 書込み属性
00071     VARIANT_BOOL m_bBindExec;   // 動的Invoke
00072 };
00073
00074 #endif //__CAOROBOTS_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoTask.cpp File Reference

CaoTask.cpp の解説

CCaoTaskクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoTask.h"

CaoTask.cppのインクルード依存関係図

Include dependency graph

解説

CCaoTaskクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:53 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoTask.h File Reference

CaoTask.h の解説

CCaoTaskの宣言. [詳細]

#include "resource.h"
#include "CaoObjectTmpl.h"
#include "CaoVariables.h"

CaoTask.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoTask
CAOのTaskクラス. [詳細]

解説

CCaoTaskの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:54 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoTask.h Source File

CaoTask.h

解説を見る。
00001
00011 #ifndef __CAOTASK_H_
00012 #define __CAOTASK_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include "CaoObjectTmpl.h"
00016 #include "CaoVariables.h"
00017
00019 // CCaoTask
00027 class ATL_NO_VTABLE CCaoTask :
00028     public _CCaoProvConnectionObjTmpl<CCaoTask, &CLSID_CaoTask, ICaoTask, &IID_ICaoTask, ICaoProvTask>
00029 {
00030 public:
00036     CCaoTask()
00037     {
00038         m_pCaoVals = NULL;
00039     }
00040
00046     ~CCaoTask()
00047     {
00048     }
00049
00050 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOTASK)
00051
00052 // FinalConstruct / FinalRelease
00053     HRESULT FinalConstruct();
00054     void FinalRelease();
00055
00056
00057
00058 // ICaoTask
00059 public:
00060     STDMETHOD(_GetICaopObj)(/*[out, retval]*/ IUnknown **ppICaopObj);
00061     STDMETHOD(_GetICRDObj)(/*[out, retval]*/ IUnknown **ppICRDObj);
00062     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00063
00064     STDMETHOD(get_FileName)(/*[out, retval]*/ BSTR *pVal);
00065     STDMETHOD(get_VariableNames)(/*[in]*/ BSTR bstrOption, /*[out, retval]*/ VARIANT *pVal);
00066     STDMETHOD(get_Variables)(/*[out, retval]*/ ICaoVariables **ppICaoVariables);
00067
00068     STDMETHOD(AddVariable)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoVariable **ppICaoVar);
00069     STDMETHOD(Delete)(/*[in]*/ BSTR bstrOption);
00070     STDMETHOD(Execute)(/*[in]*/ VARIANT vntCommand, /*[out, retval]*/ VARIANT *pVal);
00071     STDMETHOD(Start)(/*[in]*/ long lMode, /*[in]*/ BSTR bstrOption);
00072     STDMETHOD(Stop)(/*[in]*/ long lMode, /*[in]*/ BSTR bstrOption);
00073
00074     HRESULT CustomGetIDsOfNames(REFIID riid, LPOLESTR* rgszNames, UINT cNames, LCID lcid, DISPID* rgdispid);
00075     HRESULT CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS* pdispparams, VARIANT* pvarResult, EXCEPINFO* pexcepinfo, UINT* puArgErr);
00076
00077 private:
00078     HRESULT CustomInvokeExec(DISPPARAMS* pdispparams, VARIANT* pvarResult);
00079
00080 // Data Members
00081 private:
00082     CCaoVariables* m_pCaoVals;  // ICaoVariableコレクション のIF
00083     VARIANT_BOOL m_bBindExec;   // 動的Invoke
00084     WCHAR m_wcsBindName[CAO_FUNCSTR_MAX];
00085 };
00086
00087 #endif //__CAOTASK_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoTasks.cpp File Reference

CaoTasks.cpp の解説

CCaoTasksクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoTasks.h"
#include "CaoController.h"

CaoTasks.cppのインクルード依存関係図

Include dependency graph

解説

CCaoTasksクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:54 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoTasks.h File Reference

CaoTasks.h の解説

CCaoTasksの宣言. [詳細]

#include "resource.h"
#include <map>
#include "CaoTask.h"
#include "CaoCollectionTmpl.h"

CaoTasks.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoTasks
CAOのTaskのコレクションクラス. [詳細]

解説

CCaoTasksの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:54 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoTasks.h Source File

CaoTasks.h

解説を見る。
00001
00011 #ifndef __CAOTASKS_H_
00012 #define __CAOTASKS_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include <map>
00016 #include "CaoTask.h"
00017 #include "CaoCollectionTmpl.h"
00018
00020 // CCaoTasks
00028 class ATL_NO_VTABLE CCaoTasks :
00029     public _CCaoCollectionTmpl<CCaoTasks, &CLSID_CaoTasks, ICaoTasks, &IID_ICaoTasks, ICaoTask>
00030 {
00031 public:
00037     CCaoTasks()
00038     {
00039         m_pParent = NULL;
00040         m_bWritable = VARIANT_FALSE;
00041         m_lParentType = -1;
00042     }
00043
00049     ~CCaoTasks()
00050     {
00051     }
00052
00053 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOTASKS)
00054
00055 // FinalConstruct / FinalRelease
00056     HRESULT FinalConstruct();
00057     void FinalRelease();
00058
00059 // ICaoTasks
00060     STDMETHOD(Add)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoTask **ppICaoTask);
00061
00062     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00063
00064 // Data Members
00065 private:
00066     PVOID m_pParent;            // 親オブジェクトのIF
00067     long m_lParentType;         // 親オブジェクトの種類
00068     VARIANT_BOOL m_bWritable;   // 書込み属性
00069     VARIANT_BOOL m_bBindExec;   // 動的Invoke
00070 };
00071
00072 #endif //__CAOTASKS_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoVariable.cpp File Reference

CaoVariable.cpp の解説

CCaoVariableクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoVariable.h"

CaoVariable.cppのインクルード依存関係図

Include dependency graph

解説

CCaoVariableクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:54 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoVariable.h File Reference

CaoVariable.h の解説

CaoVariableの宣言. [詳細]

#include "resource.h"
#include "CaoObjectTmpl.h"

CaoVariable.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoVariable
CAOのVariableクラス. [詳細]

解説

CaoVariableの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:55 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoVariable.h Source File

CaoVariable.h

解説を見る。
00001
00011 #ifndef __CAOVARIABLE_H_
00012 #define __CAOVARIABLE_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include "CaoObjectTmpl.h"
00016
00018 // CCaoVariable
00026 class ATL_NO_VTABLE CCaoVariable :
00027     public _CCaoProvConnectionObjTmpl<CCaoVariable, &CLSID_CaoVariable, ICaoVariable, &IID_ICaoVariable, ICaoProvVariable>
00028 {
00029 public:
00030     CCaoVariable()
00031     {
00032     }
00033
00039     ~CCaoVariable()
00040     {
00041     }
00042
00043 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOVARIABLE)
00044
00045 // FinalConstruct / FinalRelease
00046     HRESULT FinalConstruct();
00047     void FinalRelease();
00048
00049
00050
00051 // ICaoVariable
00052     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00053     STDMETHOD(get_DateTime)(/*[out, retval]*/ VARIANT *pVal);
00054     STDMETHOD(get_Value)(/*[out, retval]*/ VARIANT *pVal);
00055     STDMETHOD(put_Value)(/*[in]*/ VARIANT newVal);
00056     STDMETHOD(get_Microsecond)(/*[out, retval]*/ long *pVal);
00057
00058 // Data Members
00059 private:
00060
00061 };
00062
00063 #endif //__CAOVARIABLE_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoVariables.cpp File Reference

CaoVariables.cpp の解説

CCaoVariablesクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoVariables.h"
#include "CaoController.h"
#include "CaoExtension.h"
#include "CaoFile.h"
#include "CaoTask.h"
#include "CaoRobot.h"

CaoVariables.cppのインクルード依存関係図

Include dependency graph

解説

CCaoVariablesクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:55 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoVariables.h File Reference

CaoVariables.h の解説

CaoVariablesの宣言. [詳細]

#include "resource.h"
#include <map>
#include "CaoVariable.h"
#include "CaoCollectionTmpl.h"

CaoVariables.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoVariables
CAOのVariableのコレクションクラス. [詳細]

解説

CaoVariablesの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:55 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoVariables.h Source File

CaoVariables.h

解説を見る。
00001
00011 #ifndef __CAOVARIABLES_H_
00012 #define __CAOVARIABLES_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include <map>
00016 #include "CaoVariable.h"
00017 #include "CaoCollectionTmpl.h"
00018
00020 // CCaoVariables
00034 class ATL_NO_VTABLE CCaoVariables :
00035     public _CCaoCollectionTmpl<CCaoVariables, &CLSID_CaoVariables, ICaoVariables, &IID_ICaoVariables, ICaoVariable>
00036 {
00037 public:
00038     CCaoVariables()
00039     {
00040         m_pParent = NULL;
00041         m_bWritable = VARIANT_FALSE;
00042         m_lParentType = -1;
00043     }
00044
00050     ~CCaoVariables()
00051     {
00052     }
00053
00054 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOVARIABLES)
00055
00056 // FinalConstruct / FinalRelease
00057     HRESULT FinalConstruct();
00058     void FinalRelease();
00059
00060 // ICaoVariables
00061     STDMETHOD(Add)(/*[in]*/ BSTR bstrName, /*[in, defaultvalue("")]*/ BSTR bstrOption, /*[out, retval]*/ ICaoVariable **ppICaoVar);
00062
00063     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00064
00065 // Data Members
00066 private:
00067     PVOID m_pParent;                    // 親オブジェクトのIF
00068     long m_lParentType;                 // 親オブジェクトの種類
00069     VARIANT_BOOL m_bWritable;           // 書込み属性
00070 };
00071
00072 #endif //__CAOVARIABLES_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoWorkspace.cpp File Reference

CaoWorkspace.cpp の解説

CCaoWorkspaceクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoWorkspace.h"
#include "CaoController.h"

CaoWorkspace.cppのインクルード依存関係図

Include dependency graph

解説

CCaoWorkspaceクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:55 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoWorkspace.h File Reference

CaoWorkspace.h の解説

CCaoWorkspaceの宣言. [詳細]

#include "resource.h"
#include "CaoControllers.h"
#include "CaoObjectTmpl.h"

CaoWorkspace.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoWorkspace
CAOのWorkspaceクラス. [詳細]

解説

CCaoWorkspaceの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:56 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoWorkspace.h Source File

CaoWorkspace.h

解説を見る。
00001
00011 #ifndef __CAOWORKSPACE_H_
00012 #define __CAOWORKSPACE_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include "CaoControllers.h"
00016 #include "CaoObjectTmpl.h"
00017
00019 // CCaoWorkspace
00026 class ATL_NO_VTABLE CCaoWorkspace :
00027     public _CCaoBaseTmpl<CCaoWorkspace, &CLSID_CaoWorkspace, ICaoWorkspace, &IID_ICaoWorkspace>
00028 {
00029 public:
00035     CCaoWorkspace()
00036     {
00037         m_pCaoCtrls = NULL;
00038     }
00039
00045     ~CCaoWorkspace()
00046     {
00047     }
00048
00049 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOWORKSPACE)
00050
00051 // FinalConstruct / FinalRelease
00052     HRESULT FinalConstruct();
00053     void FinalRelease();
00054
00055 // ICaoWorkspace
00056
00057     STDMETHOD(get_Controllers)(/*[out, retval]*/ ICaoControllers **ppICaoCtrls);
00058     STDMETHOD(get_ProviderNames)(/*[in]*/ BSTR bstrOption, /*[out, retval]*/ VARIANT *pVal);
00059
00060     STDMETHOD(AddController)(/*[in]*/ BSTR bstrController, /*[in]*/ BSTR bstrProvider, /*[in, defaultvalue("")]*/ BSTR bstrMachine, /*[in, defaultvalue("")]*/ BSTR bstrOption, /*[out, retval]*/ ICaoController **ppICaoCtrl);
00061     STDMETHOD(Execute)(/*[in]*/ VARIANT vntCommand, /*[out, retval]*/ VARIANT *pVal);
00062
00063     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00064
00065 // Data Members
00066 private:
00067     CCaoControllers* m_pCaoCtrls;   // ControllerコレクションのIF
00068 };
00069
00070 #endif //__CAOWORKSPACE_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoWorkspaces.cpp File Reference

CaoWorkspaces.cpp の解説

CCaoWorkspacesクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "CaoWorkspaces.h"

CaoWorkspaces.cppのインクルード依存関係図

Include dependency graph

解説

CCaoWorkspacesクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:56 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoWorkspaces.h File Reference

CaoWorkspaces.h の解説

CCaoWorkspacesの宣言. [詳細]

#include "resource.h"
#include <map>
#include "CaoWorkspace.h"
#include "CaoCollectionTmpl.h"

CaoWorkspaces.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CCaoWorkspaces
CAOのWorkspaceのコレクションクラス. [詳細]

解説

CCaoWorkspacesの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:57 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CaoWorkspaces.h Source File

CaoWorkspaces.h

解説を見る。
00001
00011 #ifndef __CAOWORKSPACES_H_
00012 #define __CAOWORKSPACES_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include <map>
00016 #include "CaoWorkspace.h"
00017
00018 #include "CaoCollectionTmpl.h"
00019
00021 // CCaoWorkspaces
00029 class ATL_NO_VTABLE CCaoWorkspaces :
00030     public _CCaoCollectionTmpl<CCaoWorkspaces, &CLSID_CaoWorkspaces, ICaoWorkspaces, &IID_ICaoWorkspaces, ICaoWorkspace>
00031 {
00032 public:
00038     CCaoWorkspaces()
00039     {
00040     }
00041
00047     ~CCaoWorkspaces()
00048     {
00049     }
00050
00051 //DECLARE_REGISTRY_RESOURCEID(IDR_CAOWORKSPACES)
00052
00053 // FinalConstruct / FinalRelease
00054     HRESULT FinalConstruct();
00055     void FinalRelease();
00056
00057
00058 // ICaoWorkspaces
00059     STDMETHOD(Add)(/*[in]*/ BSTR bstrName, /*[in]*/ BSTR bstrOption, /*[out, retval]*/ ICaoWorkspace **ppICaoWS);
00060
00061
00062 // Data Members
00063 private:
00064
00065 };
00066
00067 #endif //__CAOWORKSPACES_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


dlldata.c File Reference

dlldata.c の解説

#include <rpcproxy.h>

dlldata.cのインクルード依存関係図

Include dependency graph

マクロ定義

#define | PROXY_DELEGATION

関数

PROXYFILE_LIST_START | REFERENCE_PROXY_FILE (CAO)

マクロ定義の解説

#define PROXY_DELEGATION

関数の解説

PROXYFILE_LIST_START REFERENCE_PROXY_FILE ( CAO )

Generated on Wed Dec 7 19:01:57 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


EventSink.cpp File Reference

EventSink.cpp の解説

CEventSinkクラスの実装. [詳細]

#include "stdafx.h"
#include "CAO.h"
#include "EventSink.h"
#include "CaoController.h"

EventSink.cppのインクルード依存関係図

Include dependency graph

解説

CEventSinkクラスの実装.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:57 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


EventSink.h File Reference

EventSink.h の解説

CEventSinkの宣言. [詳細]

#include "resource.h"
#include "CAOCP.h"

EventSink.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class CEventSink
CAOのイベントシンククラス. [詳細]

解説

CEventSinkの宣言.

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:57 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


EventSink.h Source File

EventSink.h

解説を見る。
00001
00011 #ifndef __EVENTSINK_H_
00012 #define __EVENTSINK_H_
00013
00014 #include "resource.h"       // メイン シンボル
00015 #include "CAOCP.h"
00016
00017 class CCaoController;
00018
00020 // CEventSink
00028 class ATL_NO_VTABLE CEventSink :
00029     public CComObjectRootEx<CComMultiThreadModel>,
00030     public CComCoClass<CEventSink, &CLSID_EventSink>,
00031     public ISupportErrorInfo,
00032     public IDispatchImpl<IEventSink, &IID_IEventSink, &LIBID_CAOLib>
00033 {
00034 public:
00040     CEventSink() : m_dwCookie(0)
00041     {
00042         m_pCaoCtrl = NULL;
00043         m_pICaopCtrl = NULL;
00044     }
00045
00051     ~CEventSink()
00052     {
00053     }
00054
00055 //DECLARE_REGISTRY_RESOURCEID(IDR_EVENTSINK)
00056
00057 DECLARE_PROTECT_FINAL_CONSTRUCT()
00058
00059 BEGIN_COM_MAP(CEventSink)
00060     COM_INTERFACE_ENTRY(IEventSink)
00061     COM_INTERFACE_ENTRY(IDispatch)
00062     COM_INTERFACE_ENTRY_IID(DIID__ICaoProvControllerEvents, IDispatch)
00063     COM_INTERFACE_ENTRY(ISupportErrorInfo)
00064 END_COM_MAP()
00065
00066 // ISupportsErrorInfo
00067     STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);
00068
00069 // FinalConstruct / FinalRelease
00070     HRESULT FinalConstruct();
00071     void FinalRelease();
00072
00073 // IEventSink
00074     STDMETHOD(_Initialize)(VARIANT vntArgs[]);
00075     STDMETHOD(_Terminate)();
00076
00077 //  STDMETHOD(OnMessage)(IUnknown *pVal);
00078     STDMETHOD(OnMessage)(IUnknown *pVal, long lOption);
00079
00080 private:
00081     CCaoController* m_pCaoCtrl;             // CaoCtrl インターフェイスへのポインタ
00082     ICaoProvController* m_pICaopCtrl;       // CaoProvCtrl インターフェイスへのポインタ
00083     DWORD m_dwCookie;                       // 接続を一意に識別するクッキー
00084
00085 };
00086
00087 #endif //__EVENTSINK_H_
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


Preload.h File Reference

Preload.h の解説

#include "stdafx.h"
#include "cao.h"
#include "..\..\ProviderLib\CRD\CRDMapper\Src\CRDMapper.h"
#include "..\..\ProviderLib\CRD\CRDMapper\Src\CRDMapper_i.c"

Preload.hのインクルード依存関係図

Include dependency graph

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

構成

class | CPreload
オブジェクト自動登録クラス 　 　指定したCaoWorkspaceにCRDファイルのオブジェクト構造を登録します。 [詳細]

マクロ定義

#define | AFX_PRELOAD_H__3181624D_10F6_4F8D_9A2E_35A67005CCE9__INCLUDED_

マクロ定義の解説

#define AFX_PRELOAD_H__3181624D_10F6_4F8D_9A2E_35A67005CCE9__INCLUDED_

Generated on Wed Dec 7 19:01:57 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


Preload.h Source File

Preload.h

解説を見る。
00001 // Preload.h: CPreload クラスのインターフェイス
00002 //
00004
00005 #if !defined(AFX_PRELOAD_H__3181624D_10F6_4F8D_9A2E_35A67005CCE9__INCLUDED_)
00006 #define AFX_PRELOAD_H__3181624D_10F6_4F8D_9A2E_35A67005CCE9__INCLUDED_
00007
00008 #if _MSC_VER > 1000
00009 #pragma once
00010 #endif // _MSC_VER > 1000
00011
00012 #include "stdafx.h"
00013 #include "cao.h"
00014
00015 #include "..\..\ProviderLib\CRD\CRDMapper\Src\CRDMapper.h"
00016 #include "..\..\ProviderLib\CRD\CRDMapper\Src\CRDMapper_i.c"
00017
00023 class CPreload
00024 {
00025 public:
00026     CPreload()
00027     {
00028     }
00029     virtual ~CPreload()
00030     {
00031     }
00032
00042     HRESULT PreloadObject(ICaoWorkspace *pICaoWS, BSTR bstrCRDFile)
00043     {
00044         HRESULT hr;
00045
00046         // PreLoad機能の可否の確認
00047         if (_Module.m_bPreload == FALSE) {
00048             return S_OK;
00049         }
00050
00051         // CRDMapperインスタンスの作成
00052         CComPtr<ICRDEngine> pICRDEng;
00053         hr = CoCreateInstance(CLSID_CRDEngine, NULL, CLSCTX_INPROC_SERVER, IID_ICRDEngine, (void **)&pICRDEng);
00054         if (FAILED(hr)){
00055             return hr;
00056         }
00057
00058         // CRDファイルのロード
00059         hr = pICRDEng->load(bstrCRDFile);
00060         if (FAILED(hr)){
00061             return hr;
00062         }
00063
00064         // コントローラの生成
00065         PreloadController(pICaoWS, pICRDEng);
00066
00067         return S_OK;
00068     }
00069
00070 private:
00080     HRESULT PreloadController(ICaoWorkspace *pICaoWS, ICRDEngine *pICRDEng)
00081     {
00082         HRESULT hr;
00083
00084         // コントローラ名リストの取得
00085         CComVariant vntNames;
00086         hr = pICRDEng->get_ControllerNames(&vntNames);
00087         if (FAILED(hr)){
00088             return hr;
00089         }
00090
00091         // コントローラの自動生成
00092         CComPtr<ICaoController> pICaoCtrl;
00093         CComPtr<ICRDController> pICRDCtrl;
00094         CComBSTR bstrName, bstrProvider, bstrMachine, bstrOption;
00095
00096         long lSize = vntNames.parray->rgsabound->cElements;
00097         for (long Cnt = 0; Cnt < lSize; Cnt++) {
00098             // 接続情報の初期化
00099             pICaoCtrl.Release();
00100             pICRDCtrl.Release();
00101             bstrName.Empty();
00102             bstrProvider.Empty();
00103             bstrMachine.Empty();
00104             bstrOption.Empty();
00105
00106             // コントローラ名の取得
00107             hr = SafeArrayGetElement(vntNames.parray, &Cnt, &bstrName);
00108             if (FAILED(hr)) {
00109                 continue;
00110             }
00111
00112             // コントローラ情報の取得
00113             hr = pICRDEng->get_Controller(bstrName, &pICRDCtrl);
00114             if (FAILED(hr)) {
00115                 continue;
00116             }
00117             pICRDCtrl->get_Provider(&bstrProvider);
00118             pICRDCtrl->get_Machine(&bstrMachine);
00119             pICRDCtrl->get_Option(&bstrOption);
00120
00121             // コントローラの追加
00122             hr = pICaoWS->AddController(bstrName, bstrProvider, bstrMachine, bstrOption, &pICaoCtrl);
00123             if (FAILED(hr)) {
00124                 _Module.LogEvent(CAO_LOG_WARN,_T("PreLoad Failed. CaoController : %S\n"), bstrName);
00125                 continue;
00126             }
00127             PreloadCommand(pICaoCtrl, pICRDCtrl);
00128             PreloadFile(pICaoCtrl, pICRDCtrl);
00129             PreloadRobot(pICaoCtrl, pICRDCtrl);
00130             PreloadTask(pICaoCtrl, pICRDCtrl);
00131             PreloadVariable(pICaoCtrl, pICRDCtrl);
00132         }
00133         return S_OK;
00134     }
00135
00145     HRESULT PreloadCommand(ICaoController *pICaoCtrl, ICRDController *pICRDCtrl)
00146     {
00147         HRESULT hr;
00148
00149         // コマンド名リストの取得
00150         CComVariant vntNames;
00151         hr = pICRDCtrl->get_CommandNames(&vntNames);
00152         if (FAILED(hr)){
00153             return hr;
00154         }
00155
00156         // コマンドの自動生成
00157         CComPtr<ICaoCommand> pICaoCmd;
00158         CComPtr<ICRDCommand> pICRDCmd;
00159         CComBSTR bstrName, bstrOption;
00160
00161         long lSize = vntNames.parray->rgsabound->cElements;
00162         for (long Cnt = 0; Cnt < lSize; Cnt++) {
00163             // 接続情報の初期化
00164             pICaoCmd.Release();
00165             pICRDCmd.Release();
00166             bstrName.Empty();
00167
00168             // コマンド名の取得
00169             hr = SafeArrayGetElement(vntNames.parray, &Cnt, &bstrName);
00170             if (FAILED(hr)) {
00171                 continue;
00172             }
00173
00174             // コマンド情報の取得
00175             hr = pICRDCtrl->get_Command(bstrName, &pICRDCmd);
00176             if (FAILED(hr)) {
00177                 continue;
00178             }
00179             pICRDCmd->get_Option(&bstrOption);
00180
00181             // コマンドの追加
00182             hr = pICaoCtrl->AddCommand(bstrName, bstrOption, &pICaoCmd);
00183             if (FAILED(hr)) {
00184                 _Module.LogEvent(CAO_LOG_WARN,_T("PreLoad Failed. CaoCommand : %S\n"), bstrName);
00185                 continue;
00186             }
00187         }
00188         return S_OK;
00189     }
00190
00200     template <class T1, class T2>
00201     HRESULT PreloadFile(T1 pICaoObj, T2 pICRDObj)
00202     {
00203         HRESULT hr;
00204
00205         // ファイル名リストの取得
00206         CComVariant vntNames;
00207         hr = pICRDObj->get_FileNames(&vntNames);
00208         if (FAILED(hr)){
00209             return hr;
00210         }
00211
00212         // ファイルの自動生成
00213         CComPtr<ICaoFile> pICaoFile;
00214         CComPtr<ICRDFile> pICRDFile;
00215         CComBSTR bstrName, bstrOption;
00216
00217         long lSize = vntNames.parray->rgsabound->cElements;
00218         for (long Cnt = 0; Cnt < lSize; Cnt++) {
00219             // 接続情報の初期化
00220             pICaoFile.Release();
00221             pICRDFile.Release();
00222             bstrName.Empty();
00223
00224             // ファイル名の取得
00225             hr = SafeArrayGetElement(vntNames.parray, &Cnt, &bstrName);
00226             if (FAILED(hr)) {
00227                 continue;
00228             }
00229
00230             // ファイル情報の取得
00231             hr = pICRDObj->get_File(bstrName, &pICRDFile);
00232             if (FAILED(hr)) {
00233                 continue;
00234             }
00235             pICRDFile->get_Option(&bstrOption);
00236
00237             // ファイルの追加
00238             hr = pICaoObj->AddFile(bstrName, bstrOption, &pICaoFile);
00239             if (FAILED(hr)) {
00240                 _Module.LogEvent(CAO_LOG_WARN,_T("PreLoad Failed. CaoFile : %S\n"), bstrName);
00241                 continue;
00242             }
00243
00244             PreloadFile(pICaoFile, pICRDFile);
00245             PreloadVariable(pICaoFile, pICRDFile);
00246
00247         }
00248         return S_OK;
00249     }
00250
00260     HRESULT PreloadRobot(ICaoController *pICaoCtrl, ICRDController *pICRDCtrl)
00261     {
00262         HRESULT hr;
00263
00264         // ロボット名リストの取得
00265         CComVariant vntNames;
00266         hr = pICRDCtrl->get_RobotNames(&vntNames);
00267         if (FAILED(hr)){
00268             return hr;
00269         }
00270
00271         // ロボットの自動生成
00272         CComPtr<ICaoRobot> pICaoRbt;
00273         CComPtr<ICRDRobot> pICRDRbt;
00274         CComBSTR bstrName, bstrOption;
00275
00276         long lSize = vntNames.parray->rgsabound->cElements;
00277         for (long Cnt = 0; Cnt < lSize; Cnt++) {
00278             // 接続情報の初期化
00279             pICaoRbt.Release();
00280             pICRDRbt.Release();
00281             bstrName.Empty();
00282
00283             // ロボット名の取得
00284             hr = SafeArrayGetElement(vntNames.parray, &Cnt, &bstrName);
00285             if (FAILED(hr)) {
00286                 continue;
00287             }
00288
00289             // ロボット情報の取得
00290             hr = pICRDCtrl->get_Robot(bstrName, &pICRDRbt);
00291             if (FAILED(hr)) {
00292                 continue;
00293             }
00294             pICRDRbt->get_Option(&bstrOption);
00295
00296             // ロボットの追加
00297             hr = pICaoCtrl->AddRobot(bstrName, bstrOption, &pICaoRbt);
00298             if (FAILED(hr)) {
00299                 _Module.LogEvent(CAO_LOG_WARN,_T("PreLoad Failed. CaoRobot : %S\n"), bstrName);
00300                 continue;
00301             }
00302
00303             PreloadVariable(pICaoRbt, pICRDRbt);
00304
00305         }
00306         return S_OK;
00307     }
00308
00318     HRESULT PreloadTask(ICaoController *pICaoCtrl, ICRDController *pICRDCtrl)
00319     {
00320         HRESULT hr;
00321
00322         // タスク名リストの取得
00323         CComVariant vntNames;
00324         hr = pICRDCtrl->get_TaskNames(&vntNames);
00325         if (FAILED(hr)){
00326             return hr;
00327         }
00328
00329         // タスクの自動生成
00330         CComPtr<ICaoTask> pICaoTsk;
00331         CComPtr<ICRDTask> pICRDTsk;
00332         CComBSTR bstrName, bstrOption;
00333
00334         long lSize = vntNames.parray->rgsabound->cElements;
00335         for (long Cnt = 0; Cnt < lSize; Cnt++) {
00336             // 接続情報の初期化
00337             pICaoTsk.Release();
00338             pICRDTsk.Release();
00339             bstrName.Empty();
00340
00341             // タスク名の取得
00342             hr = SafeArrayGetElement(vntNames.parray, &Cnt, &bstrName);
00343             if (FAILED(hr)) {
00344                 continue;
00345             }
00346
00347             // タスク情報の取得
00348             hr = pICRDCtrl->get_Task(bstrName, &pICRDTsk);
00349             if (FAILED(hr)) {
00350                 continue;
00351             }
00352             pICRDTsk->get_Option(&bstrOption);
00353
00354             // タスクの追加
00355             hr = pICaoCtrl->AddTask(bstrName, bstrOption, &pICaoTsk);
00356             if (FAILED(hr)) {
00357                 _Module.LogEvent(CAO_LOG_WARN,_T("PreLoad Failed. CaoTask : %S\n"), bstrName);
00358                 continue;
00359             }
00360
00361             PreloadVariable(pICaoTsk, pICRDTsk);
00362
00363         }
00364         return S_OK;
00365     }
00366
00376     template <class T1, class T2>
00377     HRESULT PreloadVariable(T1 pICaoObj, T2 pICRDObj)
00378     {
00379         HRESULT hr;
00380
00381         // 変数名リストの取得
00382         CComVariant vntNames;
00383         hr = pICRDObj->get_VariableNames(&vntNames);
00384         if (FAILED(hr)){
00385             return hr;
00386         }
00387
00388         // 変数の自動生成
00389         CComPtr<ICaoVariable> pICaoVar;
00390         CComPtr<ICRDVariable> pICRDVar;
00391         CComBSTR bstrName, bstrOption;
00392
00393         long lSize = vntNames.parray->rgsabound->cElements;
00394         for (long Cnt = 0; Cnt < lSize; Cnt++) {
00395             // 接続情報の初期化
00396             pICaoVar.Release();
00397             pICRDVar.Release();
00398             bstrName.Empty();
00399
00400             // 変数名の取得
00401             hr = SafeArrayGetElement(vntNames.parray, &Cnt, &bstrName);
00402             if (FAILED(hr)) {
00403                 continue;
00404             }
00405
00406             // 変数情報の取得
00407             hr = pICRDObj->get_Variable(bstrName, &pICRDVar);
00408             if (FAILED(hr)) {
00409                 continue;
00410             }
00411             pICRDVar->get_Option(&bstrOption);
00412
00413             // 変数の追加
00414             hr = pICaoObj->AddVariable(bstrName, bstrOption, &pICaoVar);
00415             if (FAILED(hr)) {
00416                 _Module.LogEvent(CAO_LOG_WARN,_T("PreLoad Failed. CaoVariable : %S\n"), bstrName);
00417                 continue;
00418             }
00419         }
00420         return S_OK;
00421     }
00422
00423
00424 };
00425
00426 #endif // !defined(AFX_PRELOAD_H__3181624D_10F6_4F8D_9A2E_35A67005CCE9__INCLUDED_)
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


resource.h File Reference

resource.h の解説

このグラフは、どのファイルから直接、間接的にインクルードされているかを示しています。

Included by dependency graph

ソースコードを見る。

マクロ定義

#define | IDS_SERVICENAME 100
#define | IDR_CAO 100
#define | IDR_CAOCONTROLLER 101
#define | IDR_CAOWORKSPACE 102
#define | IDR_CAOVARIABLE 105
#define | IDR_CAOSTATUS 108
#define | IDR_CAOCONTROLLERS 109
#define | IDR_CAOWORKSPACES 110
#define | IDR_CAOENGINE 113
#define | IDR_EVENTSINK 115
#define | IDR_CAOROBOT 116
#define | IDR_CAOVARIABLES 118
#define | IDR_CAOROBOTS 120
#define | IDR_CAOFILE 122
#define | IDR_CAOTASK 123
#define | IDR_CAOTASKS 124
#define | IDR_CAOFILES 126
#define | IDR_CAOERRORINFO 127
#define | IDI_CAO 201
#define | IDS_E_CAO_SEM_CREATE 512
#define | IDS_E_CAO_PROV_INVALID 513
#define | IDS_E_CAO_COMPUTER_NAME 514
#define | IDS_E_CAO_VARIANT_TYPE_NOSUPPORT 515
#define | IDS_E_CAO_OBJECT_NOTFOUND 516
#define | IDS_E_CAO_COLLECTION_REGISTERED 517
#define | IDS_E_CAO_SERVICE_PROCESS_NOSTART 518
#define | IDS_E_CAO_THREAD_CREATE 519
#define | IDS_E_CAO_REMOTE_ENGINE 520
#define | IDS_E_CAO_REMOTE_PROVIDER 521
#define | IDS_E_CAO_NOT_WRITABLE 522
#define | IDS_E_CRDIMPL 523
#define | IDS_E_CAO_CMD_EXECUTE 523

マクロ定義の解説

#define IDI_CAO 201

#define IDR_CAO 100

#define IDR_CAOCONTROLLER 101

#define IDR_CAOCONTROLLERS 109

#define IDR_CAOENGINE 113

#define IDR_CAOERRORINFO 127

#define IDR_CAOFILE 122

#define IDR_CAOFILES 126

#define IDR_CAOROBOT 116

#define IDR_CAOROBOTS 120

#define IDR_CAOSTATUS 108

#define IDR_CAOTASK 123

#define IDR_CAOTASKS 124

#define IDR_CAOVARIABLE 105

#define IDR_CAOVARIABLES 118

#define IDR_CAOWORKSPACE 102

#define IDR_CAOWORKSPACES 110

#define IDR_EVENTSINK 115

#define IDS_E_CAO_CMD_EXECUTE 523

#define IDS_E_CAO_COLLECTION_REGISTERED 517

#define IDS_E_CAO_COMPUTER_NAME 514

#define IDS_E_CAO_NOT_WRITABLE 522

#define IDS_E_CAO_OBJECT_NOTFOUND 516

#define IDS_E_CAO_PROV_INVALID 513

#define IDS_E_CAO_REMOTE_ENGINE 520

#define IDS_E_CAO_REMOTE_PROVIDER 521

#define IDS_E_CAO_SEM_CREATE 512

#define IDS_E_CAO_SERVICE_PROCESS_NOSTART 518

#define IDS_E_CAO_THREAD_CREATE 519

#define IDS_E_CAO_VARIANT_TYPE_NOSUPPORT 515

#define IDS_E_CRDIMPL 523

#define IDS_SERVICENAME 100

Generated on Wed Dec 7 19:01:58 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


resource.h Source File

resource.h

解説を見る。
00001 //{{NO_DEPENDENCIES}}
00002 // Microsoft Developer Studio generated include file.
00003 // Used by CAO.rc
00004 //
00005 #define IDS_SERVICENAME                 100
00006 #define IDR_CAO                         100
00007 #define IDR_CAOCONTROLLER               101
00008 #define IDR_CAOWORKSPACE                102
00009 #define IDR_CAOVARIABLE                 105
00010 #define IDR_CAOSTATUS                   108
00011 #define IDR_CAOCONTROLLERS              109
00012 #define IDR_CAOWORKSPACES               110
00013 #define IDR_CAOENGINE                   113
00014 #define IDR_EVENTSINK                   115
00015 #define IDR_CAOROBOT                    116
00016 #define IDR_CAOVARIABLES                118
00017 #define IDR_CAOROBOTS                   120
00018 #define IDR_CAOFILE                     122
00019 #define IDR_CAOTASK                     123
00020 #define IDR_CAOTASKS                    124
00021 #define IDR_CAOFILES                    126
00022 #define IDR_CAOERRORINFO                127
00023 #define IDI_CAO                         201
00024 #define IDS_E_CAO_SEM_CREATE            512
00025 #define IDS_E_CAO_PROV_INVALID          513
00026 #define IDS_E_CAO_COMPUTER_NAME         514
00027 #define IDS_E_CAO_VARIANT_TYPE_NOSUPPORT 515
00028 #define IDS_E_CAO_OBJECT_NOTFOUND       516
00029 #define IDS_E_CAO_COLLECTION_REGISTERED 517
00030 #define IDS_E_CAO_SERVICE_PROCESS_NOSTART 518
00031 #define IDS_E_CAO_THREAD_CREATE         519
00032 #define IDS_E_CAO_REMOTE_ENGINE         520
00033 #define IDS_E_CAO_REMOTE_PROVIDER       521
00034 #define IDS_E_CAO_NOT_WRITABLE          522
00035 #define IDS_E_CRDIMPL                   523
00036 #define IDS_E_CAO_CMD_EXECUTE           523
00037
00038 // Next default values for new objects
00039 //
00040 #ifdef APSTUDIO_INVOKED
00041 #ifndef APSTUDIO_READONLY_SYMBOLS
00042 #define _APS_NEXT_RESOURCE_VALUE        202
00043 #define _APS_NEXT_COMMAND_VALUE         32768
00044 #define _APS_NEXT_CONTROL_VALUE         201
00045 #define _APS_NEXT_SYMED_VALUE           128
00046 #endif
00047 #endif
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


StdAfx.cpp File Reference

StdAfx.cpp の解説

標準インクルードファイルを含むソースファイル [詳細]

#include "stdafx.h"
#include <atlimpl.cpp>

StdAfx.cppのインクルード依存関係図

Include dependency graph

解説

標準インクルードファイルを含むソースファイル

stdafx.pch 生成されるプリコンパイル済ヘッダー stdafx.obj 生成されるプリコンパイル済タイプ情報

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE
Generated on Wed Dec 7 19:01:58 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


StdAfx.h File Reference

StdAfx.h の解説

標準のシステムインクルードファイル [詳細]

#include "CAOSYSTEM.h"
#include <process.h>
#include <limits.h>
#include <atlbase.h>
#include <vector>
#include <queue>
#include "CaoProv_i.c"
#include "CaoProv.h"
#include "ORiNlm.h"
#include <atlcom.h>
#include <string>
#include "CAOERROR.h"

StdAfx.hのインクルード依存関係図

Include dependency graph

ソースコードを見る。

名前空間

namespace | std

構成

class | CServiceModule
CAOのサービスクラス. [詳細]

マクロ定義

#define | AFX_STDAFX_H__024E8F04_C596_11D2_A0DE_00C04FDB1900__INCLUDED_
#define | STRICT
#define | _WIN32_WINNT 0x0400
#define | _ATL_FREE_THREADED
#define | CAO_WORKT_MAX 1
#define | CAO_WORKT_TIMEOUT 500L
#define | CAO_EXECUTE_ASYNC 0x00000001
#define | CAO_OBJ_REMOVED -1
#define | CAO_DISPID_EXEC 0x100
#define | CAO_DISPID_CMDS 0x101
#define | CAO_WAIT_INTAVAL 10
#define | CAO_LOG_MSGBOX _T("\r\n\r\nClick [Cancel] to output a message into 'Debug Viewer' after this.")
#define | CAO_FUNCSTR_MAX 65
#define | CAO_CHK_REMOVED 0x00000001
#define | CAO_CHK_WRITEABLE 0x00000002
#define | LM_VER_ORIN_SDK 2
#define | LM_AAV_ORIN_SDK _T("SKD")
#define | LM_FUNC_CAO 0x4
#define | SIZEOFARRAY(array) (sizeof(array)/sizeof(array[0]))

変数

CServiceModule _Module

解説

標準のシステムインクルードファイル

参照回数が多く、かつあまり変更されない プロジェクト専用のインクルード ファイルを記述します．

バージョン:
1.0
日付:
2003/8/8
作者:
DENSO WAVE

マクロ定義の解説

#define _ATL_FREE_THREADED

#define _WIN32_WINNT 0x0400

#define AFX_STDAFX_H__024E8F04_C596_11D2_A0DE_00C04FDB1900__INCLUDED_

#define CAO_CHK_REMOVED 0x00000001

#define CAO_CHK_WRITEABLE 0x00000002

#define CAO_DISPID_CMDS 0x101

#define CAO_DISPID_EXEC 0x100

#define CAO_EXECUTE_ASYNC 0x00000001

#define CAO_FUNCSTR_MAX 65

#define CAO_LOG_MSGBOX _T("\r\n\r\nClick [Cancel] to output a message into 'Debug Viewer' after this.")

#define CAO_OBJ_REMOVED -1

#define CAO_WAIT_INTAVAL 10

#define CAO_WORKT_MAX 1

#define CAO_WORKT_TIMEOUT 500L

#define LM_AAV_ORIN_SDK _T("SKD")

#define LM_FUNC_CAO 0x4

#define LM_VER_ORIN_SDK 2

#define SIZEOFARRAY ( array ) (sizeof(array)/sizeof(array[0]))

#define STRICT

変数の解説

CServiceModule _Module

Generated on Wed Dec 7 19:01:58 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


StdAfx.h Source File

StdAfx.h

解説を見る。
00001
00014 #if !defined(AFX_STDAFX_H__024E8F04_C596_11D2_A0DE_00C04FDB1900__INCLUDED_)
00015 #define AFX_STDAFX_H__024E8F04_C596_11D2_A0DE_00C04FDB1900__INCLUDED_
00016
00017 #if _MSC_VER > 1000
00018 #pragma once
00019 #endif // _MSC_VER > 1000
00020
00021 #define STRICT
00022 #ifndef _WIN32_WINNT
00023 #define _WIN32_WINNT 0x0400
00024 //#define _WIN32_DCOM       // (注) CoInitializeEx(NULL, COINIT_MULTITHREADED)が失敗する．
00025 #endif
00026
00027 //#define _ATL_APARTMENT_THREADED
00028 #define _ATL_FREE_THREADED
00029
00030 #include "CAOSYSTEM.h"      // CAO Provider と共通の #DEFINE
00031 #include <process.h>
00032 #include <limits.h>
00033
00034 #include <atlbase.h>
00035 #include <vector>
00036 #include <queue>
00037
00038 #include "CaoProv_i.c"
00039 #include "CaoProv.h"
00040
00041 // >>>>>>>>>> これ以下は，CAOエンジンでのみ使う情報です．<<<<<<<<<<
00042 #define CAO_WORKT_MAX           1           // ワーカスレッドの最大数／オブジェクト (注)イベント発生順序の問題があるので当面は1にする．
00043 #define CAO_WORKT_TIMEOUT       500L        // ワーカスレッドの終了待ちタイムアウトのデフォルト値
00044 #define CAO_EXECUTE_ASYNC       0x00000001  // 非同期コマンド
00045 #define CAO_OBJ_REMOVED         -1          // コレクション削除済みのインデックス番号
00046 #define CAO_DISPID_EXEC         0x100       // ダイナミックバインディング(Execute)
00047 #define CAO_DISPID_CMDS         0x101       // ダイナミックバインディング(Commands)
00048 #define CAO_WAIT_INTAVAL        10          // イベントキューの確認間隔
00049 #define CAO_LOG_MSGBOX          _T("\r\n\r\nClick [Cancel] to output a message into 'Debug Viewer' after this.")
00050 #define CAO_FUNCSTR_MAX         65          // OLE関数名の最大長(64) + 1
00051 // CheckAccessフラグ
00052 #define CAO_CHK_REMOVED         0x00000001  // コレクション削除済み検査
00053 #define CAO_CHK_WRITEABLE       0x00000002  // 書込み禁止検査
00054 // typedef of ORiNlm.dll
00055 #include "ORiNlm.h"
00056 #define LM_VER_ORIN_SDK         2
00057 #define LM_AAV_ORIN_SDK         _T("SKD")
00058 #define LM_FUNC_CAO             0x4
00059
00060 // CComModule クラスから派生したクラスを使用して、オーバーライドする場合
00061 // _Module の名前は変更しないでください．
00062
00068 class CServiceModule : public CComModule
00069 {
00070 public:
00076     CServiceModule()
00077     {
00078         m_dwPriority = HIGH_PRIORITY_CLASS;
00079         m_dwLocaleID = LOCALE_USER_DEFAULT;
00080         m_dwLogType = 1L;
00081         m_dwLogLevel = CAO_LOG_INFO;
00082
00083         for (int i = 0; i < CLS_NO_MAX; i++) {
00084             m_lObjectCount[i] = 0;
00085         }
00086         memset(m_szLogFile, '\0', 256);
00087     }
00088
00094     ~CServiceModule()
00095     {
00096     }
00097
00098     HRESULT RegisterServer(BOOL bRegTypeLib, BOOL bService);
00099     HRESULT UnregisterServer();
00100     void Init(_ATL_OBJMAP_ENTRY* p, HINSTANCE h, UINT nServiceNameID, const GUID* plibid = NULL);
00101     void Start();
00102     void ServiceMain(DWORD dwArgc, LPTSTR* lpszArgv);
00103     void Handler(DWORD dwOpcode);
00104     void Run();
00105     BOOL IsInstalled();
00106     BOOL Install();
00107     BOOL Uninstall();
00108     LONG Unlock();
00109     void LogEvent(DWORD dwLevel, LPCTSTR pszFormat, ...);
00110     void SetServiceStatus(DWORD dwState);
00111     void SetupAsLocalServer();
00112
00113     // CAO
00114     long IncObjectCount(short iClsNo);
00115     long DecObjectCount(short iClsNo);
00116     HANDLE CreateWorkerSemaphore(long lInit = CAO_WORKT_MAX, long lMax = CAO_WORKT_MAX);
00117     void DeleteWorkerSemaphore(HANDLE hSemaphore);
00118     BOOL ReleaseWorkerSemaphore(HANDLE hSemaphore);
00119     HANDLE BeginWorkerThread(HANDLE hSemaphore, void( __cdecl *pFunc)(void *pThis), void *pArglist);
00120     void ExitWorkerThread();
00121     void DeleteWorkerThread(HANDLE hThread, HANDLE hTerminate);
00122     HRESULT ParseParameter(BSTR bsrCommand, WCHAR wc, VARIANT *pVal);
00123     HRESULT GetOptionValue(BSTR bstrOption, BSTR bstrKeyWord, VARTYPE Type, VARIANT *pVal);
00124     HRESULT CreateUniqueName(WORD wClsNo, PVOID pObject, BSTR *pbstrName);
00125     HRESULT CheckLicense();
00126
00127 // インプリメンテーション
00128 private:
00129     static void WINAPI _ServiceMain(DWORD dwArgc, LPTSTR* lpszArgv);
00130     static void WINAPI _Handler(DWORD dwOpcode);
00131
00132     HRESULT ReadRegInfo();
00133
00134 // データ メンバ
00135 public:
00136     TCHAR m_szServiceName[256];
00137     SERVICE_STATUS_HANDLE m_hServiceStatus;
00138     SERVICE_STATUS m_status;
00139     DWORD dwThreadID;
00140     BOOL m_bService;
00141
00142     DWORD m_dwPriority;                 // CAO
00143     DWORD m_dwLocaleID;                 // CAO
00144     DWORD m_dwLogType;                  // CAO
00145     DWORD m_dwLogLevel;                 // CAO
00146     long m_lObjectCount[CLS_NO_MAX];    // CAO
00147     TCHAR m_szLogFile[256];             // CAO
00148
00149     BOOL  m_bPreload;                   // CAO
00150     TCHAR m_szCRDFile[256];             // CAO
00151
00152
00153 private:
00154
00155 };
00156
00157 extern CServiceModule _Module;
00158
00159 #include <atlcom.h>
00160 #include <string>                       // CAO
00161 //#include <algorithm>
00162 using namespace std;                    // CAO
00163 #include "CAOERROR.h"                   // CAO
00164
00165 #define SIZEOFARRAY(array) (sizeof(array)/sizeof(array[0]))
00166
00167 //{{AFX_INSERT_LOCATION}}
00168 // Microsoft Visual C++ は前行の直前に追加の宣言を挿入します．
00169
00170 #endif // !defined(AFX_STDAFX_H__024E8F04_C596_11D2_A0DE_00C04FDB1900__INCLUDED)
Generated on Wed Dec 7 19:01:43 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


Annotated Index

DENSO WAVE CAO Project 構成

クラス、構造体、共用体、インタフェースの解説です。
_CCaoBaseTmpl< T, pclsid, T1, piid > | CAOのオブジェクトのテンプレートクラス
_CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd > | CAOのコレクションテンプレートクラス
_CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv > | CAOのプロバイダと接続するクラスのテンプレート
CAOLib::_ICaoCommandsEvents |
CAOLib::_ICaoControllerEvents |
_IID |
_MIDL_PROC_FORMAT_STRING |
_MIDL_TYPE_FORMAT_STRING |
CAOLib::CaoCommand |
CAOLib::CaoCommands |
CAOLib::CaoController |
CAOLib::CaoControllers |
CAOLib::CaoEngine |
CAOLib::CaoEngineStatus |
CAOLib::CaoExtension |
CAOLib::CaoExtensions |
CAOLib::CaoFile |
CAOLib::CaoFiles |
CAOLib::CaoMessage |
CAOLib::CaoRobot |
CAOLib::CaoRobots |
CAOLib::CaoTask |
CAOLib::CaoTasks |
CAOLib::CaoVariable |
CAOLib::CaoVariables |
CAOLib::CaoWorkspace |
CAOLib::CaoWorkspaces |
CCaoCommand | CAOのCommandクラス
CCaoCommands | CAOのCommandのコレクションクラス
CCaoController | CAOのControllerクラス
CCaoControllers | CAOのControllerのコレクションクラス
CCaoEngine | CAOのEngineクラス
CCaoEngineStatus | CAOのEngineStatusクラス
CCaoExtension | CAOのExtensionクラス
CCaoExtensions | CAOのExtensionのコレクションクラス
CCaoFile | CAOのFileクラス
CCaoFiles | CAOのFileのコレクションクラス
CCaoMessage | CAOのControllerクラス
CCaoRobot | CAOのRobotクラス
CCaoRobots | CAOのRobotのコレクションクラス
CCaoTask | CAOのTaskクラス
CCaoTasks | CAOのTaskのコレクションクラス
CCaoVariable | CAOのVariableクラス
CCaoVariables | CAOのVariableのコレクションクラス
CCaoWorkspace | CAOのWorkspaceクラス
CCaoWorkspaces | CAOのWorkspaceのコレクションクラス
CComCoClass |
CComObjectRootEx |
CEventSink | CAOのイベントシンククラス
CPreload | オブジェクト自動登録クラス 指定したCaoWorkspaceにCRDファイルのオブジェクト構造を登録します。
CProxy_ICaoCommandsEvents< T > | CAOのコントローライベントプロキシテンプレートクラス
CProxy_ICaoControllerEvents< T > | CAOのコントローライベントプロキシテンプレートクラス
CProxy_ICaoExecuteCompleteEvent< T, dispid > | CAOのExecuteCompleteイベントテンプレートクラス
CProxy_ICaoOnMessageEvent< T, dispid > | CAOのOnMessageイベントテンプレートクラス
CServiceModule | CAOのサービスクラス
CAOLib::EventSink |
ICaoCommand |
ICaoCommands |
ICaoController |
ICaoControllers |
ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass > | CAOのカスタムDispatchインターフェース
ICaoEngine |
ICaoEngineStatus |
ICaoExtension |
ICaoExtensions |
ICaoFile |
ICaoFiles |
ICaoMessage |
ICaoRobot |
ICaoRobots |
ICaoTask |
ICaoTasks |
ICaoVariable |
ICaoVariables |
ICaoWorkspace |
ICaoWorkspaces |
IConnectionPointImpl |
IDispatchImpl |
IEventSink |
ISupportErrorInfo |
PROV_MESSAGE | メッセージ格納用構造体
Generated on Wed Dec 7 19:01:58 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


Template_CCaoBaseTmpl< T, pclsid, T1, piid > class Reference

クラス テンプレート_CCaoBaseTmpl< T, pclsid, T1, piid > の解説

CAOのオブジェクトのテンプレートクラス. [詳細]

#include <CaoObjectTmpl.h>

_CCaoBaseTmpl< T, pclsid, T1, piid >に対する継承グラフ

[凡例]
_CCaoBaseTmpl< T, pclsid, T1, piid >のコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

_CCaoBaseTmpl ()
コンストラクタ

~_CCaoBaseTmpl ()
デストラクタ

STDMETHODIMP | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

STDMETHODIMP | get_Index (long *pVal)
コレクションのインデックス番号の取得

STDMETHODIMP | _PutIndex (long lVal)
コレクションのインデックス番号の設定

STDMETHODIMP | get_Name (BSTR *pVal)
名前の取得

Protected メソッド

HRESULT | CheckAccess (DWORD dwChkList)
アクセスチェック

Protected 変数

BSTR | m_bstrName
名前

long | m_lIndex
Index番号.

VARIANT_BOOL | m_bWritable
書込み属性

解説

template<class T, const CLSID * pclsid, class T1, const IID * piid>
class _CCaoBaseTmpl< T, pclsid, T1, piid >

CAOのオブジェクトのテンプレートクラス.

コレクションクラス以外のクラス共通のメソッドを持つテンプレートクラス．

コンストラクタとデストラクタの解説

template<class T, const CLSID * pclsid, class T1, const IID * piid>
_CCaoBaseTmpl< T, pclsid, T1, piid >::_CCaoBaseTmpl ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

template<class T, const CLSID * pclsid, class T1, const IID * piid>
_CCaoBaseTmpl< T, pclsid, T1, piid >::~_CCaoBaseTmpl ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

template<class T, const CLSID * pclsid, class T1, const IID * piid>
STDMETHODIMP _CCaoBaseTmpl< T, pclsid, T1, piid >::_PutIndex ( long lVal ) [inline]

コレクションのインデックス番号の設定

引数:
lVal : [in] コレクションのインデックス番号
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid>
HRESULT _CCaoBaseTmpl< T, pclsid, T1, piid >::CheckAccess ( DWORD dwChkList ) [inline, protected]

アクセスチェック

  コレクション削除、書込み禁止のチェックを行います。

引数:
dwChkList : [in] チェックフラグ
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid>
STDMETHODIMP _CCaoBaseTmpl< T, pclsid, T1, piid >::get_Index ( long * pVal ) [inline]

コレクションのインデックス番号の取得

引数:
pVal : [out] コレクションのインデックス番号
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid>
STDMETHODIMP _CCaoBaseTmpl< T, pclsid, T1, piid >::get_Name ( BSTR * pVal ) [inline]

名前の取得

  CCaoEngineオブジェクトのAddWorkspaceメソッドの第1引数で指定した値です．

引数:
pVal : [out] ワークスペース名
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid>
STDMETHODIMP _CCaoBaseTmpl< T, pclsid, T1, piid >::InterfaceSupportsErrorInfo ( REFIID riid ) [inline]

オートメーションIFのエラーオブジェクトのサポート判定

  riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : [in] インタフェース
戻り値:
HRESULT

変数の解説

template<class T, const CLSID * pclsid, class T1, const IID * piid>
BSTR _CCaoBaseTmpl< T, pclsid, T1, piid >::m_bstrName [protected]

名前

template<class T, const CLSID * pclsid, class T1, const IID * piid>
VARIANT_BOOL _CCaoBaseTmpl< T, pclsid, T1, piid >::m_bWritable [protected]

書込み属性

template<class T, const CLSID * pclsid, class T1, const IID * piid>
long _CCaoBaseTmpl< T, pclsid, T1, piid >::m_lIndex [protected]

Index番号.

このクラスの解説は次のファイルから生成されました:
  • CaoObjectTmpl.h
Generated on Wed Dec 7 19:01:59 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_CCaoBaseTmpl< T, pclsid, T1, piid > メンバ一覧

これは全メンバの一覧です。_CCaoBaseTmpl< T, pclsid, T1, piid >継承メンバも含んでいます。
_CCaoBaseTmpl() | _CCaoBaseTmpl< T, pclsid, T1, piid > | [inline]
_PutIndex(long lVal) | _CCaoBaseTmpl< T, pclsid, T1, piid > | [inline]
CheckAccess(DWORD dwChkList) | _CCaoBaseTmpl< T, pclsid, T1, piid > | [inline, protected]
CustomGetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< T1, piid,&LIBID_CAOLib > | [inline, virtual]
CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< T1, piid,&LIBID_CAOLib > | [inline, virtual]
get_Index(long *pVal) | _CCaoBaseTmpl< T, pclsid, T1, piid > | [inline]
get_Name(BSTR *pVal) | _CCaoBaseTmpl< T, pclsid, T1, piid > | [inline]
GetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< T1, piid,&LIBID_CAOLib > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoBaseTmpl< T, pclsid, T1, piid > | [inline]
Invoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< T1, piid,&LIBID_CAOLib > | [inline]
m_bstrName | _CCaoBaseTmpl< T, pclsid, T1, piid > | [protected]
m_bWritable | _CCaoBaseTmpl< T, pclsid, T1, piid > | [protected]
m_lIndex | _CCaoBaseTmpl< T, pclsid, T1, piid > | [protected]
~_CCaoBaseTmpl() | _CCaoBaseTmpl< T, pclsid, T1, piid > | [inline]
Generated on Wed Dec 7 19:01:59 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


Template_CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd > class Reference

クラス テンプレート_CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd > の解説

CAOのコレクションテンプレートクラス. [詳細]

#include <CaoCollectionTmpl.h>

_CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >に対する継承グラフ

[凡例]
_CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >のコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

_CCaoCollectionTmpl ()
コンストラクタ

~_CCaoCollectionTmpl ()
デストラクタ

STDMETHODIMP | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

STDMETHODIMP | Item (VARIANT Index, TIChd **ppItem)
コレクション内のオブジェクトの取得

STDMETHODIMP | Remove (VARIANT Index)
コレクションからオブジェクトの削除

STDMETHODIMP | Clear ()
コレクションからオブジェクトの削除

STDMETHODIMP | IsMember (VARIANT Index, VARIANT_BOOL *pVal)
コレクションメンバのチェック

STDMETHODIMP | get__NewEnum (LPUNKNOWN *pVal)
コレクション内の列挙子オブジェクトの取得

STDMETHODIMP | get_Count (long *pVal)
コレクション数の取得

STDMETHODIMP | GetIndex (VARIANT vntIndex, long *lVal)
コレクション内のオブジェクトのインデックス番号の取得

Protected メソッド

HRESULT | GenerateIndex (long *lVal)
ユニークIDの取得

Protected 変数

std::map< long, TIChd * > | m_map
  コレクションコンテナ

解説

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TIChd>
class _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >

CAOのコレクションテンプレートクラス.

コレクションクラス共通のメソッドを持つテンプレートクラス．

コンストラクタとデストラクタの解説

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TIChd>
_CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >::_CCaoCollectionTmpl ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TIChd>
_CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >::~_CCaoCollectionTmpl ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TIChd>
STDMETHODIMP _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >::Clear ( ) [inline]

コレクションからオブジェクトの削除

戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TIChd>
HRESULT _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >::GenerateIndex ( long * lVal ) [inline, protected]

ユニークIDの取得

  MAX値は，LONGです．

引数:
lVal : [out] ユニークID
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TIChd>
STDMETHODIMP _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >::get__NewEnum ( LPUNKNOWN * pVal ) [inline]

コレクション内の列挙子オブジェクトの取得

  スクリプトコードから直接アクセスは禁止されています(restricted)．

引数:
pVal : [out] 列挙子オブジェクト
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TIChd>
STDMETHODIMP _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >::get_Count ( long * pVal ) [inline]

コレクション数の取得

引数:
pVal : [out] コレクション数
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TIChd>
STDMETHODIMP _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >::GetIndex | ( | VARIANT | vntIndex,
 |  | long * | lVal
 | ) | [inline]

コレクション内のオブジェクトのインデックス番号の取得

引数:
vntIndex | : [in] 名前/インデックス番号
lVal | : [out] インデックス番号
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TIChd>
STDMETHODIMP _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >::InterfaceSupportsErrorInfo ( REFIID riid ) [inline]

オートメーションIFのエラーオブジェクトのサポート判定

riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : [in] インタフェース
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TIChd>
STDMETHODIMP _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >::IsMember | ( | VARIANT | Index,
 |  | VARIANT_BOOL * | pVal
 | ) | [inline]

コレクションメンバのチェック

引数:
Index | : [in] チェック対象メンバの名前/番号
pVal | : [in] 結果
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TIChd>
STDMETHODIMP _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >::Item | ( | VARIANT | Index,
 |  | TIChd ** | ppItem
 | ) | [inline]

コレクション内のオブジェクトの取得

コレクション内の指定されたオブジェクトを取得します．

引数:
Index | : [in] 取得対象オブジェクトの名前/番号
ppItem | : [out] 取得対象オブジェクトのIFポインタのアドレス
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TIChd>
STDMETHODIMP _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >::Remove ( VARIANT Index ) [inline]

コレクションからオブジェクトの削除

引数:
Index : [in] 削除対象オブジェクトの名前/番号
戻り値:
HRESULT

CCaoControllersで再定義されています。

変数の解説

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TIChd>
std::map<long, TIChd*> _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >::m_map [protected]

  コレクションコンテナ

このクラスの解説は次のファイルから生成されました:
  • CaoCollectionTmpl.h
Generated on Wed Dec 7 19:01:59 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd > メンバ一覧

これは全メンバの一覧です。_CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >継承メンバも含んでいます。
_CCaoCollectionTmpl() | _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd > | [inline]
Clear() | _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd > | [inline]
GenerateIndex(long *lVal) | _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd > | [inline, protected]
get__NewEnum(LPUNKNOWN *pVal) | _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd > | [inline]
get_Count(long *pVal) | _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd > | [inline]
GetIndex(VARIANT vntIndex, long *lVal) | _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd > | [inline]
IsMember(VARIANT Index, VARIANT_BOOL *pVal) | _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd > | [inline]
Item(VARIANT Index, TIChd **ppItem) | _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd > | [inline]
m_map | _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd > | [protected]
Remove(VARIANT Index) | _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd > | [inline]
~_CCaoCollectionTmpl() | _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd > | [inline]
Generated on Wed Dec 7 19:01:59 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


Template_CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv > class Reference

クラス テンプレート_CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv > の解説

CAOのプロバイダと接続するクラスのテンプレート. [詳細]

#include <CaoObjectTmpl.h>

_CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >に対する継承グラフ

[凡例]
_CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >のコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

_CCaoProvConnectionObjTmpl ()
コンストラクタ

~_CCaoProvConnectionObjTmpl ()
デストラクタ

STDMETHODIMP | get_Attribute (long *pVal)
属性の取得

STDMETHODIMP | get_Tag (VARIANT *pVal)
タグの取得

STDMETHODIMP | put_Tag (VARIANT newVal)
タグの設定

STDMETHODIMP | get_Help (BSTR *pVal)
ヘルプの取得

STDMETHODIMP | get_ID (VARIANT *pVal)
IDの取得.

STDMETHODIMP | put_ID (VARIANT newVal)
IDの設定.

Protected 変数

TProv * | m_pICaopObj
プロバイダのインターフェイスへのポインタ

TProv * | m_pICRDObj
CRDプロバイダのインターフェイスへのポインタ.

VARIANT | m_vntTag
多目的タグ

解説

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TProv>
class _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >

CAOのプロバイダと接続するクラスのテンプレート.

CAOプロバイダと接続するクラス共通のメソッドを持つテンプレートクラス．

コンストラクタとデストラクタの解説

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TProv>
_CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >::_CCaoProvConnectionObjTmpl ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TProv>
_CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >::~_CCaoProvConnectionObjTmpl ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TProv>
STDMETHODIMP _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >::get_Attribute ( long * pVal ) [inline]

属性の取得

引数:
pVal : [out] 属性
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TProv>
STDMETHODIMP _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >::get_Help ( BSTR * pVal ) [inline]

ヘルプの取得

  コメント等を格納しておく．

引数:
pVal : [out] ヘルプ文字列
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TProv>
STDMETHODIMP _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >::get_ID ( VARIANT * pVal ) [inline]

IDの取得.

引数:
pVal : [out] ID
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TProv>
STDMETHODIMP _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >::get_Tag ( VARIANT * pVal ) [inline]

タグの取得

  ユーザが自由に使える多目的変数．

引数:
pVal : [out] タグデータ
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TProv>
STDMETHODIMP _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >::put_ID ( VARIANT newVal ) [inline]

IDの設定.

引数:
newVal : [in] タグデータ
戻り値:
HRESULT

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TProv>
STDMETHODIMP _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >::put_Tag ( VARIANT newVal ) [inline]

タグの設定

  ユーザが自由に使える多目的変数．

引数:
newVal : [in] タグデータ
戻り値:
HRESULT

変数の解説

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TProv>
TProv* _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >::m_pICaopObj [protected]

プロバイダのインターフェイスへのポインタ

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TProv>
TProv* _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >::m_pICRDObj [protected]

CRDプロバイダのインターフェイスへのポインタ.

template<class T, const CLSID * pclsid, class T1, const IID * piid, class TProv>
VARIANT _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >::m_vntTag [protected]

多目的タグ

このクラスの解説は次のファイルから生成されました:
  • CaoObjectTmpl.h
Generated on Wed Dec 7 19:02:00 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv > メンバ一覧

これは全メンバの一覧です。_CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >継承メンバも含んでいます。
_CCaoBaseTmpl() | _CCaoBaseTmpl< T, pclsid, T1, piid > | [inline]
_CCaoProvConnectionObjTmpl() | _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv > | [inline]
_PutIndex(long lVal) | _CCaoBaseTmpl< T, pclsid, T1, piid > | [inline]
CheckAccess(DWORD dwChkList) | _CCaoBaseTmpl< T, pclsid, T1, piid > | [inline, protected]
CustomGetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< T1, piid,&LIBID_CAOLib > | [inline, virtual]
CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< T1, piid,&LIBID_CAOLib > | [inline, virtual]
get_Attribute(long *pVal) | _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv > | [inline]
get_Help(BSTR *pVal) | _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv > | [inline]
get_ID(VARIANT *pVal) | _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv > | [inline]
get_Index(long *pVal) | _CCaoBaseTmpl< T, pclsid, T1, piid > | [inline]
get_Name(BSTR *pVal) | _CCaoBaseTmpl< T, pclsid, T1, piid > | [inline]
get_Tag(VARIANT *pVal) | _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv > | [inline]
GetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< T1, piid,&LIBID_CAOLib > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoBaseTmpl< T, pclsid, T1, piid > | [inline]
Invoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< T1, piid,&LIBID_CAOLib > | [inline]
m_bstrName | _CCaoBaseTmpl< T, pclsid, T1, piid > | [protected]
m_bWritable | _CCaoBaseTmpl< T, pclsid, T1, piid > | [protected]
m_lIndex | _CCaoBaseTmpl< T, pclsid, T1, piid > | [protected]
m_pICaopObj | _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv > | [protected]
m_pICRDObj | _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv > | [protected]
m_vntTag | _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv > | [protected]
put_ID(VARIANT newVal) | _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv > | [inline]
put_Tag(VARIANT newVal) | _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv > | [inline]
~_CCaoBaseTmpl() | _CCaoBaseTmpl< T, pclsid, T1, piid > | [inline]
~_CCaoProvConnectionObjTmpl() | _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv > | [inline]
Generated on Wed Dec 7 19:02:00 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::_ICaoCommandsEvents interface Reference

インタフェースCAOLib::_ICaoCommandsEvents の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT ExecuteComplete ([in] long lID)

メソッドの解説

HRESULT CAOLib::_ICaoCommandsEvents::ExecuteComplete ( [in] long lID )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CAOLib::_ICaoCommandsEvents メンバ一覧

これは全メンバの一覧です。CAOLib::_ICaoCommandsEvents継承メンバも含んでいます。
ExecuteComplete([in] long lID) CAOLib::_ICaoCommandsEvents
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::_ICaoControllerEvents interface Reference

インタフェースCAOLib::_ICaoControllerEvents の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT OnMessage ([in] ICaoMessage *pICaoMess)

メソッドの解説

HRESULT CAOLib::_ICaoControllerEvents::OnMessage ( [in] ICaoMessage * pICaoMess )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CAOLib::_ICaoControllerEvents メンバ一覧

これは全メンバの一覧です。CAOLib::_ICaoControllerEvents継承メンバも含んでいます。
OnMessage([in] ICaoMessage *pICaoMess) CAOLib::_ICaoControllerEvents
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


_IID struct Reference

構造体 _IID の解説

すべてのメンバ一覧

Public 変数

unsigned long | x
unsigned short | s1
unsigned short | s2
unsigned char | c [8]

変数の解説

unsigned char _IID::c[8]

unsigned short _IID::s1

unsigned short _IID::s2

unsigned long _IID::x

この構造体の解説は次のファイルから生成されました:
  • CAO_i.c
Generated on Wed Dec 7 19:02:00 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_IID メンバ一覧

これは全メンバの一覧です。_IID継承メンバも含んでいます。
c | _IID
s1 | _IID
s2 | _IID
x | _IID
Generated on Wed Dec 7 19:02:00 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


_MIDL_PROC_FORMAT_STRING struct Reference

構造体 _MIDL_PROC_FORMAT_STRING の解説

すべてのメンバ一覧

Public 変数

short | Pad
unsigned char | Format [PROC_FORMAT_STRING_SIZE]

変数の解説

unsigned char _MIDL_PROC_FORMAT_STRING::Format[ PROC_FORMAT_STRING_SIZE ]

short _MIDL_PROC_FORMAT_STRING::Pad

この構造体の解説は次のファイルから生成されました:
  • CAO_p.c
Generated on Wed Dec 7 19:02:00 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_MIDL_PROC_FORMAT_STRING メンバ一覧

これは全メンバの一覧です。_MIDL_PROC_FORMAT_STRING継承メンバも含んでいます。
Format | _MIDL_PROC_FORMAT_STRING
Pad | _MIDL_PROC_FORMAT_STRING
Generated on Wed Dec 7 19:02:00 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


_MIDL_TYPE_FORMAT_STRING struct Reference

構造体 _MIDL_TYPE_FORMAT_STRING の解説

すべてのメンバ一覧

Public 変数

short | Pad
unsigned char | Format [TYPE_FORMAT_STRING_SIZE]

変数の解説

unsigned char _MIDL_TYPE_FORMAT_STRING::Format[ TYPE_FORMAT_STRING_SIZE ]

short _MIDL_TYPE_FORMAT_STRING::Pad

この構造体の解説は次のファイルから生成されました:
  • CAO_p.c
Generated on Wed Dec 7 19:02:00 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

_MIDL_TYPE_FORMAT_STRING メンバ一覧

これは全メンバの一覧です。_MIDL_TYPE_FORMAT_STRING継承メンバも含んでいます。
Format | _MIDL_TYPE_FORMAT_STRING
Pad | _MIDL_TYPE_FORMAT_STRING
Generated on Wed Dec 7 19:02:00 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoCommand class Reference

クラス CAOLib::CaoCommand の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoCommands class Reference

クラス CAOLib::CaoCommands の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoController class Reference

クラス CAOLib::CaoController の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoControllers class Reference

クラス CAOLib::CaoControllers の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoEngine class Reference

クラス CAOLib::CaoEngine の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoEngineStatus class Reference

クラス CAOLib::CaoEngineStatus の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoExtension class Reference

クラス CAOLib::CaoExtension の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoExtensions class Reference

クラス CAOLib::CaoExtensions の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoFile class Reference

クラス CAOLib::CaoFile の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoFiles class Reference

クラス CAOLib::CaoFiles の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoMessage class Reference

クラス CAOLib::CaoMessage の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoRobot class Reference

クラス CAOLib::CaoRobot の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoRobots class Reference

クラス CAOLib::CaoRobots の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoTask class Reference

クラス CAOLib::CaoTask の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoTasks class Reference

クラス CAOLib::CaoTasks の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoVariable class Reference

クラス CAOLib::CaoVariable の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoVariables class Reference

クラス CAOLib::CaoVariables の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoWorkspace class Reference

クラス CAOLib::CaoWorkspace の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::CaoWorkspaces class Reference

クラス CAOLib::CaoWorkspaces の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoCommand class Reference

クラス CCaoCommand の解説

CAOのCommandクラス. [詳細]

#include <CaoCommand.h>

CCaoCommandに対する継承グラフ

[凡例]
CCaoCommandのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoCommand ()
コンストラクタ

~CCaoCommand ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | _GetICaopObj (IUnknown **ppICaopObj)
ICaoProvCommandの取得.

HRESULT | _GetICRDObj (IUnknown **ppICRDObj)
CRDプロバイダのICaoProvCommandの取得.

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

HRESULT | _Execute0 ()
HRESULT | get_Parameters (VARIANT *pVal)
パラメータの取得

HRESULT | put_Parameters (VARIANT newVal)
パラメータの設定

HRESULT | get_Result (VARIANT *pVal)
Execute()実行結果の取得.

HRESULT | get_State (long *pVal)
状態の取得

HRESULT | get_Timeout (long *pVal)
タイムアウトの取得

HRESULT | put_Timeout (long newVal)
タイムアウトの設定

HRESULT | Execute (long lMode)
コマンドの実行

HRESULT | Cancel ()
実行中コマンドのキャンセル

解説

CAOのCommandクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoCommandを参照．
CaoCommandsクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  CaoプロバイダのCaoProvCommandオブジェクトと１対１に対応する．

コンストラクタとデストラクタの解説

CCaoCommand::CCaoCommand ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoCommand::~CCaoCommand ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoCommand::_Execute0 ( )

STDMETHODIMP CCaoCommand::_GetICaopObj ( IUnknown ** ppICaopObj )

ICaoProvCommandの取得.

  スクリプトコードから直接アクセスは禁止されています(restricted)

引数:
ppICaopObj : [out] CaoProvCommand IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoCommand::_GetICRDObj ( IUnknown ** ppICRDObj )

CRDプロバイダのICaoProvCommandの取得.

  スクリプトコードから直接アクセスは禁止されています(restricted)

引数:
ppICRDObj : [out] CRDプロバイダのCaoProvCommand IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoCommand::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in] vntArgs[0] - コマンド名
          vntArgs[1] - コマンド番号
          vntArgs[2] - CaoProvCommand IFポインタ
          vntArgs[3] - CRDプロバイダの CaoProvCommand IFポインタ
          vntArgs[4] - CaoCommands IFポインタ
          vntArgs[5] - 書き込み属性フラグ
          vntArgs[6] - 実行待ちキューへのポインタ
          vntArgs[7] - コマンド実行セマフォ
          vntArgs[8] - キューアクセス用クリティカルセクション
戻り値:
HRESULT

STDMETHODIMP CCaoCommand::Cancel ( )

実行中コマンドのキャンセル

戻り値:
HRESULT

STDMETHODIMP CCaoCommand::Execute ( long lMode )

コマンドの実行

引数:
lMode : [in] モード
戻り値:
HRESULT

HRESULT CCaoCommand::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoCommand::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoCommand::get_Parameters ( VARIANT * pVal )

パラメータの取得

引数:
pVal : [out] パラメータ配列
戻り値:
HRESULT

STDMETHODIMP CCaoCommand::get_Result ( VARIANT * pVal )

Execute()実行結果の取得.

引数:
pVal : [out] パラメータ配列
戻り値:
HRESULT

STDMETHODIMP CCaoCommand::get_State ( long * pVal )

状態の取得

引数:
pVal : [out] 状態
戻り値:
HRESULT

STDMETHODIMP CCaoCommand::get_Timeout ( long * pVal )

タイムアウトの取得

引数:
pVal : [out] タイムアウト時間
戻り値:
HRESULT

STDMETHODIMP CCaoCommand::put_Parameters ( VARIANT newVal )

パラメータの設定

引数:
newVal : [in] パラメータ配列
戻り値:
HRESULT

STDMETHODIMP CCaoCommand::put_Timeout ( long newVal )

タイムアウトの設定

引数:
newVal : [in] タイムアウト時間
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoCommand.h
  • CaoCommand.cpp
Generated on Wed Dec 7 19:02:00 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoCommand メンバ一覧

これは全メンバの一覧です。CCaoCommand継承メンバも含んでいます。
_CCaoBaseTmpl() | _CCaoBaseTmpl< CCaoCommand, pclsid, ICaoCommand, piid > | [inline]
_CCaoProvConnectionObjTmpl() | _CCaoProvConnectionObjTmpl< CCaoCommand,&CLSID_CaoCommand, ICaoCommand,&IID_ICaoCommand, ICaoProvCommand > | [inline]
_Execute0() | CCaoCommand |
_GetICaopObj(IUnknown **ppICaopObj) | CCaoCommand |
_GetICRDObj(IUnknown **ppICRDObj) | CCaoCommand |
_Initialize(VARIANT vntArgs[]) | CCaoCommand |
_PutIndex(long lVal) | _CCaoBaseTmpl< CCaoCommand, pclsid, ICaoCommand, piid > | [inline]
Cancel() | CCaoCommand |
CCaoCommand() | CCaoCommand | [inline]
CheckAccess(DWORD dwChkList) | _CCaoBaseTmpl< CCaoCommand, pclsid, ICaoCommand, piid > | [inline, protected]
CustomGetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< ICaoCommand, piid,&LIBID_CAOLib > | [inline, virtual]
CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< ICaoCommand, piid,&LIBID_CAOLib > | [inline, virtual]
Execute(long lMode) | CCaoCommand |
FinalConstruct() | CCaoCommand |
FinalRelease() | CCaoCommand |
get_Attribute(long *pVal) | _CCaoProvConnectionObjTmpl< CCaoCommand,&CLSID_CaoCommand, ICaoCommand,&IID_ICaoCommand, ICaoProvCommand > | [inline]
get_Help(BSTR *pVal) | _CCaoProvConnectionObjTmpl< CCaoCommand,&CLSID_CaoCommand, ICaoCommand,&IID_ICaoCommand, ICaoProvCommand > | [inline]
get_ID(VARIANT *pVal) | _CCaoProvConnectionObjTmpl< CCaoCommand,&CLSID_CaoCommand, ICaoCommand,&IID_ICaoCommand, ICaoProvCommand > | [inline]
get_Index(long *pVal) | _CCaoBaseTmpl< CCaoCommand, pclsid, ICaoCommand, piid > | [inline]
get_Name(BSTR *pVal) | _CCaoBaseTmpl< CCaoCommand, pclsid, ICaoCommand, piid > | [inline]
get_Parameters(VARIANT *pVal) | CCaoCommand |
get_Result(VARIANT *pVal) | CCaoCommand |
get_State(long *pVal) | CCaoCommand |
get_Tag(VARIANT *pVal) | _CCaoProvConnectionObjTmpl< CCaoCommand,&CLSID_CaoCommand, ICaoCommand,&IID_ICaoCommand, ICaoProvCommand > | [inline]
get_Timeout(long *pVal) | CCaoCommand |
GetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< ICaoCommand, piid,&LIBID_CAOLib > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoBaseTmpl< CCaoCommand, pclsid, ICaoCommand, piid > | [inline]
Invoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< ICaoCommand, piid,&LIBID_CAOLib > | [inline]
m_bstrName | _CCaoBaseTmpl< CCaoCommand, pclsid, ICaoCommand, piid > | [protected]
m_bWritable | _CCaoBaseTmpl< CCaoCommand, pclsid, ICaoCommand, piid > | [protected]
m_lIndex | _CCaoBaseTmpl< CCaoCommand, pclsid, ICaoCommand, piid > | [protected]
m_pICaopObj | _CCaoProvConnectionObjTmpl< CCaoCommand,&CLSID_CaoCommand, ICaoCommand,&IID_ICaoCommand, ICaoProvCommand > | [protected]
m_pICRDObj | _CCaoProvConnectionObjTmpl< CCaoCommand,&CLSID_CaoCommand, ICaoCommand,&IID_ICaoCommand, ICaoProvCommand > | [protected]
m_vntTag | _CCaoProvConnectionObjTmpl< CCaoCommand,&CLSID_CaoCommand, ICaoCommand,&IID_ICaoCommand, ICaoProvCommand > | [protected]
put_ID(VARIANT newVal) | _CCaoProvConnectionObjTmpl< CCaoCommand,&CLSID_CaoCommand, ICaoCommand,&IID_ICaoCommand, ICaoProvCommand > | [inline]
put_Parameters(VARIANT newVal) | CCaoCommand |
put_Tag(VARIANT newVal) | _CCaoProvConnectionObjTmpl< CCaoCommand,&CLSID_CaoCommand, ICaoCommand,&IID_ICaoCommand, ICaoProvCommand > | [inline]
put_Timeout(long newVal) | CCaoCommand |
~_CCaoBaseTmpl() | _CCaoBaseTmpl< CCaoCommand, pclsid, ICaoCommand, piid > | [inline]
~_CCaoProvConnectionObjTmpl() | _CCaoProvConnectionObjTmpl< CCaoCommand,&CLSID_CaoCommand, ICaoCommand,&IID_ICaoCommand, ICaoProvCommand > | [inline]
~CCaoCommand() | CCaoCommand | [inline]
Generated on Wed Dec 7 19:02:00 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoCommands class Reference

クラス CCaoCommands の解説

CAOのCommandのコレクションクラス. [詳細]

#include <CaoCommands.h>

CCaoCommandsに対する継承グラフ

[凡例]
CCaoCommandsのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoCommands ()
コンストラクタ

~CCaoCommands ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | Add (BSTR bstrName, BSTR bstrOption, ICaoCommand **ppICaoCommand)
コマンドオブジェクトの追加

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

HRESULT | _FireExecuteComplete (long lIndex)
ExecuteCompleteイベント処理.

解説

CAOのCommandのコレクションクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoCommandsを参照．
CaoControllerクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
CaoCommandクラスのコレクションクラスとなっている．

コンストラクタとデストラクタの解説

CCaoCommands::CCaoCommands ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoCommands::~CCaoCommands ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoCommands::_FireExecuteComplete ( long lIndex )

ExecuteCompleteイベント処理.

  ExecuteCompleteイベントを発生させる．

引数:
lIndex : [in] ICaoCommnad のコレクションインデックス番号
戻り値:
HRESULT

STDMETHODIMP CCaoCommands::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in]　vntArgs[0] - 親オブジェクトのIFポインタ
          vntArgs[1] - 書き込み属性フラグ
          vntArgs[2] - 親オブジェクトのクラスNo
戻り値:
HRESULT

STDMETHODIMP CCaoCommands::Add | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoCommand ** | ppICaoCommand
 | ) |

コマンドオブジェクトの追加

引数:
bstrName | : [in] コマンド名
bstrOption | : [in] オプション
ppICaoCommand | : [out] CaoCommand IFポインタのアドレス
戻り値:
HRESULT

HRESULT CCaoCommands::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoCommands::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

このクラスの解説は次のファイルから生成されました:
  • CaoCommands.h
  • CaoCommands.cpp
Generated on Wed Dec 7 19:02:01 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoCommands メンバ一覧

これは全メンバの一覧です。CCaoCommands継承メンバも含んでいます。
_CCaoCollectionTmpl() | _CCaoCollectionTmpl< CCaoCommands,&CLSID_CaoCommands, ICaoCommands,&IID_ICaoCommands, ICaoCommand > | [inline]
_FireExecuteComplete(long lIndex) | CCaoCommands |
_Initialize(VARIANT vntArgs[]) | CCaoCommands |
Add(BSTR bstrName, BSTR bstrOption, ICaoCommand **ppICaoCommand) | CCaoCommands |
CCaoCommands() | CCaoCommands | [inline]
Clear() | _CCaoCollectionTmpl< CCaoCommands,&CLSID_CaoCommands, ICaoCommands,&IID_ICaoCommands, ICaoCommand > | [inline]
FinalConstruct() | CCaoCommands |
FinalRelease() | CCaoCommands |
Fire_ExecuteComplete(long lIndex) | CProxy_ICaoExecuteCompleteEvent< CCaoCommands, 0x1 > | [inline]
GenerateIndex(long *lVal) | _CCaoCollectionTmpl< CCaoCommands,&CLSID_CaoCommands, ICaoCommands,&IID_ICaoCommands, ICaoCommand > | [inline, protected]
get__NewEnum(LPUNKNOWN *pVal) | _CCaoCollectionTmpl< CCaoCommands,&CLSID_CaoCommands, ICaoCommands,&IID_ICaoCommands, ICaoCommand > | [inline]
get_Count(long *pVal) | _CCaoCollectionTmpl< CCaoCommands,&CLSID_CaoCommands, ICaoCommands,&IID_ICaoCommands, ICaoCommand > | [inline]
GetIndex(VARIANT vntIndex, long *lVal) | _CCaoCollectionTmpl< CCaoCommands,&CLSID_CaoCommands, ICaoCommands,&IID_ICaoCommands, ICaoCommand > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoCollectionTmpl< CCaoCommands,&CLSID_CaoCommands, ICaoCommands,&IID_ICaoCommands, ICaoCommand > | [inline]
IsMember(VARIANT Index, VARIANT_BOOL *pVal) | _CCaoCollectionTmpl< CCaoCommands,&CLSID_CaoCommands, ICaoCommands,&IID_ICaoCommands, ICaoCommand > | [inline]
Item(VARIANT Index, ICaoCommand **ppItem) | _CCaoCollectionTmpl< CCaoCommands,&CLSID_CaoCommands, ICaoCommands,&IID_ICaoCommands, ICaoCommand > | [inline]
m_map | _CCaoCollectionTmpl< CCaoCommands,&CLSID_CaoCommands, ICaoCommands,&IID_ICaoCommands, ICaoCommand > | [protected]
Remove(VARIANT Index) | _CCaoCollectionTmpl< CCaoCommands,&CLSID_CaoCommands, ICaoCommands,&IID_ICaoCommands, ICaoCommand > | [inline]
~_CCaoCollectionTmpl() | _CCaoCollectionTmpl< CCaoCommands,&CLSID_CaoCommands, ICaoCommands,&IID_ICaoCommands, ICaoCommand > | [inline]
~CCaoCommands() | CCaoCommands | [inline]
Generated on Wed Dec 7 19:02:01 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoController class Reference

クラス CCaoController の解説

CAOのControllerクラス. [詳細]

#include <CaoController.h>

CCaoControllerに対する継承グラフ

[凡例]
CCaoControllerのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoController ()
コンストラクタ

~CCaoController ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

HRESULT | _FireOnMessage (IUnknown *pVal, long lOption)
OnMessageイベントの発生.

HRESULT | _GetICaopObj (IUnknown **ppICaopObj)
ICaoProvControllerの取得.

HRESULT | _GetICRDObj (IUnknown **ppICRDObj)
CRDプロバイダのICaoProvControllerの取得.

HRESULT | _Close ()
後処理

HRESULT | get_ExtensionNames (BSTR bstrOption, VARIANT *pVal)
拡張ボード名リストの取得

HRESULT | get_Extensions (ICaoExtensions **ppICaoExtensions)
拡張ボードコレクションの取得

HRESULT | get_FileNames (BSTR bstrOption, VARIANT *pVal)
ファイル名リストの取得

HRESULT | get_Files (ICaoFiles **ppICaoFiles)
ファイルコレクションの取得

HRESULT | get_RobotNames (BSTR bstrOption, VARIANT *pVal)
ロボット名リストの取得

HRESULT | get_Robots (ICaoRobots **ppICaoRobots)
ロボットコレクションの取得

HRESULT | get_TaskNames (BSTR bstrOption, VARIANT *pVal)
タスク名リストの取得

HRESULT | get_Tasks (ICaoTasks **ppICaoTasks)
タスクコレクションの取得

HRESULT | get_VariableNames (BSTR bstrOption, VARIANT *pVal)
変数名リストの取得

HRESULT | get_Variables (ICaoVariables **ppICaoVariables)
変数コレクションの取得

HRESULT | get_CommandNames (BSTR bstrOption, VARIANT *pVal)
コマンド名リストの取得

HRESULT | get_Commands (ICaoCommands **ppICaoCommands)
コマンドコレクションの取得

HRESULT | AddExtension (BSTR bstrName, BSTR bstrOption, ICaoExtension **ppICaoExtension)
拡張ボードオブジェクトの追加

HRESULT | AddFile (BSTR bstrName, BSTR bstrOption, ICaoFile **ppICaoFile)
ファイルオブジェクトの追加

HRESULT | AddRobot (BSTR bstrName, BSTR bstrOption, ICaoRobot **ppICaoRobot)
ロボットオブジェクトの追加

HRESULT | AddTask (BSTR bstrName, BSTR bstrOption, ICaoTask **ppICaoTask)
タスクオブジェクトの追加

HRESULT | AddVariable (BSTR bstrName, BSTR bstrOption, ICaoVariable **ppICaoVar)
変数オブジェクトの追加

HRESULT | AddCommand (BSTR bstrName, BSTR bstrOption, ICaoCommand **ppICaoCommand)
コマンドオブジェクトの追加

HRESULT | Execute (VARIANT vntCommand, VARIANT *pVal)
拡張コマンドの実行

HRESULT | GetMessage (ICaoMessage **ppICaoMessage)
メッセージの取得

HRESULT | CustomGetIDsOfNames (REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid)
IDispatch::GetIDsOfNames().

HRESULT | CustomInvoke (DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr)
IDispatch::Invoke().

解説

CAOのControllerクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoControllerを参照．
CaoControllersクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  CaoプロバイダのCaoProvControllerオブジェクトと１対１に対応する． 　OnMessageイベントを生起する唯一のクラス．

コンストラクタとデストラクタの解説

CCaoController::CCaoController ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoController::~CCaoController ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

HRESULT CCaoController::_Close ( )

後処理

  オブジェクト消滅時の後処理は FinalRelease() を使うこと．
  スクリプトコードから直接アクセスは禁止されています(restricted)．

戻り値:
HRESULT

HRESULT CCaoController::_FireOnMessage | ( | IUnknown * | pVal,
 |  | long | lOption
 | ) |

OnMessageイベントの発生.

  このオブジェクトを参照しているクライアントへOnMessageイベントを通知する．

引数:
pVal | : [in] IFポインタ
lOption | : [in] メッセージオプション
戻り値:
HRESULT

HRESULT CCaoController::_GetICaopObj ( IUnknown ** ppICaopObj )

ICaoProvControllerの取得.

  スクリプトコードから直接アクセスは禁止されています(restricted)

引数:
ppICaopObj : [out] CaoProvController IFポインタのアドレス
戻り値:
HRESULT

HRESULT CCaoController::_GetICRDObj ( IUnknown ** ppICRDObj )

CRDプロバイダのICaoProvControllerの取得.

  スクリプトコードから直接アクセスは禁止されています(restricted)

引数:
ppICRDObj : [out] CRDプロバイダのCaoProvController IFポインタのアドレス
戻り値:
HRESULT

HRESULT CCaoController::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in]　vntArgs[0] - CaoProvController IFポインタ
          vntArgs[1] - コントローラ名
          vntArgs[2] - 書き込み属性
          vntArgs[3] - イベント許可フラグ
          vntArgs[4] - CRDプロバイダの CaoProvController IFポインタ
戻り値:
HRESULT

STDMETHODIMP CCaoController::AddCommand | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoCommand ** | ppICaoCommand
 | ) |

コマンドオブジェクトの追加

CaoVariables::Add()と同じ機能です．

引数:
bstrName | : [in] コマンド名
bstrOption | : [in] オプション
ppICaoCommand | : [out] CaoCommand IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoController::AddExtension | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoExtension ** | ppICaoExtension
 | ) |

拡張ボードオブジェクトの追加

CaoExtensions::Add()と同じ機能です．

引数:
bstrName | : [in] 拡張ボード名
bstrOption | : [in] オプション
ppICaoExtension | : [out] CaoExtension IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoController::AddFile | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoFile ** | ppICaoFile
 | ) |

ファイルオブジェクトの追加

CaoFiles::Add()と同じ機能です．

引数:
bstrName | : [in] ファイル名
bstrOption | : [in] オプション
ppICaoFile | : [out] CaoFile IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoController::AddRobot | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoRobot ** | ppICaoRobot
 | ) |

ロボットオブジェクトの追加

CaoRobots::Add()と同じ機能です．

引数:
bstrName | : [in] ロボット名
bstrOption | : [in] オプション
ppICaoRobot | : [out] CaoRobot IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoController::AddTask | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoTask ** | ppICaoTask
 | ) |

タスクオブジェクトの追加

CaoTasks::Add()と同じ機能です．

引数:
bstrName | : [in] タスク名
bstrOption | : [in] オプション
ppICaoTask | : [out] CaoTask IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoController::AddVariable | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoVariable ** | ppICaoVar
 | ) |

変数オブジェクトの追加

CaoVariables::Add()と同じ機能です．

引数:
bstrName | : [in] 変数名
bstrOption | : [in] オプション
ppICaoVar | : [out] CaoVariable IFポインタのアドレス
戻り値:
HRESULT

HRESULT CCaoController::CustomGetIDsOfNames | ( | REFIID | riid,
 |  | LPOLESTR * | rgszNames,
 |  | UINT | cNames,
 |  | LCID | lcid,
 |  | DISPID * | rgdispid
 | ) | [virtual]

IDispatch::GetIDsOfNames().

  IDispatch::GetIDsOfNames()関数の機能拡張 BindCmds, BindExecの優先度で処理される．

引数:
riid | : [in] 予約
rgszNames | : [in] メソッド名リスト
cNames | : [in] メソッド名リストの要素数
lcid | : [in] ロケールID
rgdispid | : [in] DISPID
戻り値:
HRESULT

ICaoDispatchImpl< ICaoController, piid,&LIBID_CAOLib >を再定義しています。

HRESULT CCaoController::CustomInvoke | ( | DISPID | dispidMember,
 |  | REFIID | riid,
 |  | LCID | lcid,
 |  | WORD | wFlags,
 |  | DISPPARAMS * | pdispparams,
 |  | VARIANT * | pvarResult,
 |  | EXCEPINFO * | pexcepinfo,
 |  | UINT * | puArgErr
 | ) | [virtual]

IDispatch::Invoke().

  IDispatch::Invoke()関数の機能拡張

引数:
dispidMember | : [in] DISPID
riid | : [in] 予約
lcid | : [in] ロケールID
wFlags | : [in] 起動対象メソッドのコンテキストフラグ
pdispparams | : [in] メソッドに渡すパラメータ
pvarResult | : [in] メソッドコールの結果
pexcepinfo | : [in] 例外情報
puArgErr | : [in] エラーのあった先頭引数
戻り値:
HRESULT

ICaoDispatchImpl< ICaoController, piid,&LIBID_CAOLib >を再定義しています。

STDMETHODIMP CCaoController::Execute | ( | VARIANT | vntCommand,
 |  | VARIANT * | pVal
 | ) |

拡張コマンドの実行

引数:
vntCommand | : [in] コマンド
pVal | : [out] 結果
戻り値:
HRESULT

HRESULT CCaoController::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoController::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoController::get_CommandNames | ( | BSTR | bstrOption,
 |  | VARIANT * | pVal
 | ) |

コマンド名リストの取得

引数:
bstrOption | : [in] オプション
pVal | : [out] コマンド名リスト
戻り値:
HRESULT

STDMETHODIMP CCaoController::get_Commands ( ICaoCommands ** ppICaoCommands )

コマンドコレクションの取得

引数:
ppICaoCommands : [out] CaoCommands IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoController::get_ExtensionNames | ( | BSTR | bstrOption,
 |  | VARIANT * | pVal
 | ) |

拡張ボード名リストの取得

引数:
bstrOption | : [in] オプション
pVal | : [out] 拡張ボード名リスト
戻り値:
HRESULT

STDMETHODIMP CCaoController::get_Extensions ( ICaoExtensions ** ppICaoExtensions )

拡張ボードコレクションの取得

引数:
ppICaoExtensions : [out] CaoExtensions IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoController::get_FileNames | ( | BSTR | bstrOption,
 |  | VARIANT * | pVal
 | ) |

ファイル名リストの取得

引数:
bstrOption | : [in] オプション
pVal | : [out] ファイル名リスト
戻り値:
HRESULT

STDMETHODIMP CCaoController::get_Files ( ICaoFiles ** ppICaoFiles )

ファイルコレクションの取得

引数:
ppICaoFiles : [out] CaoFiles IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoController::get_RobotNames | ( | BSTR | bstrOption,
 |  | VARIANT * | pVal
 | ) |

ロボット名リストの取得

引数:
bstrOption | : [in] オプション
pVal | : [out] ロボット名リスト
戻り値:
HRESULT

STDMETHODIMP CCaoController::get_Robots ( ICaoRobots ** ppICaoRobots )

ロボットコレクションの取得

引数:
ppICaoRobots : [out] CaoRobots IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoController::get_TaskNames | ( | BSTR | bstrOption,
 |  | VARIANT * | pVal
 | ) |

タスク名リストの取得

引数:
bstrOption | : [in] オプション
pVal | : [out] タスク名リスト
戻り値:
HRESULT

STDMETHODIMP CCaoController::get_Tasks ( ICaoTasks ** ppICaoTasks )

タスクコレクションの取得

引数:
ppICaoTasks : [out] CaoTasks IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoController::get_VariableNames | ( | BSTR | bstrOption,
 |  | VARIANT * | pVal
 | ) |

変数名リストの取得

引数:
bstrOption | : [in] オプション
pVal | : [out] 変数名リスト
戻り値:
HRESULT

STDMETHODIMP CCaoController::get_Variables ( ICaoVariables ** ppICaoVariables )

変数コレクションの取得

引数:
ppICaoVariables : [out] CaoVariables IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoController::GetMessage ( ICaoMessage ** ppICaoMessage )

メッセージの取得

引数:
ppICaoMessage : [out] CaoMessage IFポインタのアドレス
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoController.h
  • CaoController.cpp
Generated on Wed Dec 7 19:02:01 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoController メンバ一覧

これは全メンバの一覧です。CCaoController継承メンバも含んでいます。
_CCaoBaseTmpl() | _CCaoBaseTmpl< CCaoController, pclsid, ICaoController, piid > | [inline]
_CCaoProvConnectionObjTmpl() | _CCaoProvConnectionObjTmpl< CCaoController,&CLSID_CaoController, ICaoController,&IID_ICaoController, ICaoProvController > | [inline]
_Close() | CCaoController |
_FireOnMessage(IUnknown *pVal, long lOption) | CCaoController |
_GetICaopObj(IUnknown **ppICaopObj) | CCaoController |
_GetICRDObj(IUnknown **ppICRDObj) | CCaoController |
_Initialize(VARIANT vntArgs[]) | CCaoController |
_PutIndex(long lVal) | _CCaoBaseTmpl< CCaoController, pclsid, ICaoController, piid > | [inline]
AddCommand(BSTR bstrName, BSTR bstrOption, ICaoCommand **ppICaoCommand) | CCaoController |
AddExtension(BSTR bstrName, BSTR bstrOption, ICaoExtension **ppICaoExtension) | CCaoController |
AddFile(BSTR bstrName, BSTR bstrOption, ICaoFile **ppICaoFile) | CCaoController |
AddRobot(BSTR bstrName, BSTR bstrOption, ICaoRobot **ppICaoRobot) | CCaoController |
AddTask(BSTR bstrName, BSTR bstrOption, ICaoTask **ppICaoTask) | CCaoController |
AddVariable(BSTR bstrName, BSTR bstrOption, ICaoVariable **ppICaoVar) | CCaoController |
CCaoController() | CCaoController | [inline]
CheckAccess(DWORD dwChkList) | _CCaoBaseTmpl< CCaoController, pclsid, ICaoController, piid > | [inline, protected]
CProxy_ICaoOnMessageEvent() | CProxy_ICaoOnMessageEvent< CCaoController, 0x1 > | [inline]
CreateMessage(ICaoProvMessage *pICaopMess, ICaoMessage **ppVal) | CProxy_ICaoOnMessageEvent< CCaoController, 0x1 > | [inline]
CustomGetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | CCaoController | [virtual]
CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | CCaoController | [virtual]
Execute(VARIANT vntCommand, VARIANT *pVal) | CCaoController |
FinalConstruct() | CCaoController |
FinalRelease() | CCaoController |
Fire_OnMessage(IUnknown *pVal) | CProxy_ICaoOnMessageEvent< CCaoController, 0x1 > | [inline]
get_Attribute(long *pVal) | _CCaoProvConnectionObjTmpl< CCaoController,&CLSID_CaoController, ICaoController,&IID_ICaoController, ICaoProvController > | [inline]
get_CommandNames(BSTR bstrOption, VARIANT *pVal) | CCaoController |
get_Commands(ICaoCommands **ppICaoCommands) | CCaoController |
get_ExtensionNames(BSTR bstrOption, VARIANT *pVal) | CCaoController |
get_Extensions(ICaoExtensions **ppICaoExtensions) | CCaoController |
get_FileNames(BSTR bstrOption, VARIANT *pVal) | CCaoController |
get_Files(ICaoFiles **ppICaoFiles) | CCaoController |
get_Help(BSTR *pVal) | _CCaoProvConnectionObjTmpl< CCaoController,&CLSID_CaoController, ICaoController,&IID_ICaoController, ICaoProvController > | [inline]
get_ID(VARIANT *pVal) | _CCaoProvConnectionObjTmpl< CCaoController,&CLSID_CaoController, ICaoController,&IID_ICaoController, ICaoProvController > | [inline]
get_Index(long *pVal) | _CCaoBaseTmpl< CCaoController, pclsid, ICaoController, piid > | [inline]
get_Name(BSTR *pVal) | _CCaoBaseTmpl< CCaoController, pclsid, ICaoController, piid > | [inline]
get_RobotNames(BSTR bstrOption, VARIANT *pVal) | CCaoController |
get_Robots(ICaoRobots **ppICaoRobots) | CCaoController |
get_Tag(VARIANT *pVal) | _CCaoProvConnectionObjTmpl< CCaoController,&CLSID_CaoController, ICaoController,&IID_ICaoController, ICaoProvController > | [inline]
get_TaskNames(BSTR bstrOption, VARIANT *pVal) | CCaoController |
get_Tasks(ICaoTasks **ppICaoTasks) | CCaoController |
get_VariableNames(BSTR bstrOption, VARIANT *pVal) | CCaoController |
get_Variables(ICaoVariables **ppICaoVariables) | CCaoController |
GetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< ICaoController, piid,&LIBID_CAOLib > | [inline]
GetMessage(ICaoMessage **ppICaoMessage) | CCaoController |
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoBaseTmpl< CCaoController, pclsid, ICaoController, piid > | [inline]
Invoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< ICaoController, piid,&LIBID_CAOLib > | [inline]
m_bstrName | _CCaoBaseTmpl< CCaoController, pclsid, ICaoController, piid > | [protected]
m_bWritable | _CCaoBaseTmpl< CCaoController, pclsid, ICaoController, piid > | [protected]
m_lIndex | _CCaoBaseTmpl< CCaoController, pclsid, ICaoController, piid > | [protected]
m_pICaopObj | _CCaoProvConnectionObjTmpl< CCaoController,&CLSID_CaoController, ICaoController,&IID_ICaoController, ICaoProvController > | [protected]
m_pICRDObj | _CCaoProvConnectionObjTmpl< CCaoController,&CLSID_CaoController, ICaoController,&IID_ICaoController, ICaoProvController > | [protected]
m_vntTag | _CCaoProvConnectionObjTmpl< CCaoController,&CLSID_CaoController, ICaoController,&IID_ICaoController, ICaoProvController > | [protected]
put_ID(VARIANT newVal) | _CCaoProvConnectionObjTmpl< CCaoController,&CLSID_CaoController, ICaoController,&IID_ICaoController, ICaoProvController > | [inline]
put_Tag(VARIANT newVal) | _CCaoProvConnectionObjTmpl< CCaoController,&CLSID_CaoController, ICaoController,&IID_ICaoController, ICaoProvController > | [inline]
~_CCaoBaseTmpl() | _CCaoBaseTmpl< CCaoController, pclsid, ICaoController, piid > | [inline]
~_CCaoProvConnectionObjTmpl() | _CCaoProvConnectionObjTmpl< CCaoController,&CLSID_CaoController, ICaoController,&IID_ICaoController, ICaoProvController > | [inline]
~CCaoController() | CCaoController | [inline]
Generated on Wed Dec 7 19:02:01 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoControllers class Reference

クラス CCaoControllers の解説

CAOのControllerのコレクションクラス. [詳細]

#include <CaoControllers.h>

CCaoControllersに対する継承グラフ

[凡例]
CCaoControllersのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoControllers ()
コンストラクタ

~CCaoControllers ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | Add (BSTR bstrProvider, BSTR bstrMachine, BSTR bstrController, BSTR bstrOption, ICaoController **ppICaoCtrl)
コントローラオブジェクトの追加 　 　オプション値 : @Machine マシン名 @EventEnable イベント許可

HRESULT | Remove (VARIANT Index)
コレクションからオブジェクトの削除

解説

CAOのControllerのコレクションクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoControllersを参照．
CaoWorkspaceクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
CaoControllerクラスのコレクションクラスとなっている．

コンストラクタとデストラクタの解説

CCaoControllers::CCaoControllers ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoControllers::~CCaoControllers ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoControllers::Add | ( | BSTR | bstrController,
 |  | BSTR | bstrProvider,
 |  | BSTR | bstrMachine,
 |  | BSTR | bstrOption,
 |  | ICaoController ** | ppICaoCtrl
 | ) |

コントローラオブジェクトの追加 　 　オプション値 : @Machine マシン名 @EventEnable イベント許可

引数:
bstrController | : [in] コントローラ名
bstrProvider | : [in] プロバイダ名
bstrMachine | : [in] マシン名
bstrOption | : [in] オプション
ppICaoCtrl | : [out] CaoController IFポインタのアドレス
戻り値:
HRESULT

HRESULT CCaoControllers::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoControllers::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoControllers::Remove ( VARIANT Index )

コレクションからオブジェクトの削除

CCaoControllers コレクションから CCaoController オブジェクトを削除します．

引数:
Index : [in] コントローラ名/番号
戻り値:
HRESULT

_CCaoCollectionTmpl< CCaoControllers,&CLSID_CaoControllers, ICaoControllers,&IID_ICaoControllers, ICaoController >を再定義しています。

このクラスの解説は次のファイルから生成されました:
  • CaoControllers.h
  • CaoControllers.cpp
Generated on Wed Dec 7 19:02:02 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoControllers メンバ一覧

これは全メンバの一覧です。CCaoControllers継承メンバも含んでいます。
_CCaoCollectionTmpl() | _CCaoCollectionTmpl< CCaoControllers,&CLSID_CaoControllers, ICaoControllers,&IID_ICaoControllers, ICaoController > | [inline]
Add(BSTR bstrProvider, BSTR bstrMachine, BSTR bstrController, BSTR bstrOption, ICaoController **ppICaoCtrl) | CCaoControllers |
CCaoControllers() | CCaoControllers | [inline]
Clear() | _CCaoCollectionTmpl< CCaoControllers,&CLSID_CaoControllers, ICaoControllers,&IID_ICaoControllers, ICaoController > | [inline]
FinalConstruct() | CCaoControllers |
FinalRelease() | CCaoControllers |
GenerateIndex(long *lVal) | _CCaoCollectionTmpl< CCaoControllers,&CLSID_CaoControllers, ICaoControllers,&IID_ICaoControllers, ICaoController > | [inline, protected]
get__NewEnum(LPUNKNOWN *pVal) | _CCaoCollectionTmpl< CCaoControllers,&CLSID_CaoControllers, ICaoControllers,&IID_ICaoControllers, ICaoController > | [inline]
get_Count(long *pVal) | _CCaoCollectionTmpl< CCaoControllers,&CLSID_CaoControllers, ICaoControllers,&IID_ICaoControllers, ICaoController > | [inline]
GetIndex(VARIANT vntIndex, long *lVal) | _CCaoCollectionTmpl< CCaoControllers,&CLSID_CaoControllers, ICaoControllers,&IID_ICaoControllers, ICaoController > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoCollectionTmpl< CCaoControllers,&CLSID_CaoControllers, ICaoControllers,&IID_ICaoControllers, ICaoController > | [inline]
IsMember(VARIANT Index, VARIANT_BOOL *pVal) | _CCaoCollectionTmpl< CCaoControllers,&CLSID_CaoControllers, ICaoControllers,&IID_ICaoControllers, ICaoController > | [inline]
Item(VARIANT Index, ICaoController **ppItem) | _CCaoCollectionTmpl< CCaoControllers,&CLSID_CaoControllers, ICaoControllers,&IID_ICaoControllers, ICaoController > | [inline]
m_map | _CCaoCollectionTmpl< CCaoControllers,&CLSID_CaoControllers, ICaoControllers,&IID_ICaoControllers, ICaoController > | [protected]
Remove(VARIANT Index) | CCaoControllers |
~_CCaoCollectionTmpl() | _CCaoCollectionTmpl< CCaoControllers,&CLSID_CaoControllers, ICaoControllers,&IID_ICaoControllers, ICaoController > | [inline]
~CCaoControllers() | CCaoControllers | [inline]
Generated on Wed Dec 7 19:02:02 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoEngine class Reference

クラス CCaoEngine の解説

CAOのEngineクラス. [詳細]

#include <CaoEngine.h>

CCaoEngineに対する継承グラフ

[凡例]
CCaoEngineのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoEngine ()
コンストラクタ

~CCaoEngine ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | get_EngineStatus (ICaoEngineStatus **ppICaoStatus)
エンジンステータスオブジェクトの取得

HRESULT | get_Workspaces (ICaoWorkspaces **ppICaoWSs)
ワークスペースコレクションの取得

HRESULT | AddWorkspace (BSTR bstrName, BSTR bstrOption, ICaoWorkspace **ppICaoWS)
ワークスペースオブジェクトの追加

HRESULT | Execute (VARIANT vntCommand, VARIANT *pVal)
ワークスペースコレクションの取得

解説

CAOのEngineクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoEngineを参照．
CAOLにおいてCOMクライアントが唯一インスタンス作成可能なクラス．

コンストラクタとデストラクタの解説

CCaoEngine::CCaoEngine ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoEngine::~CCaoEngine ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoEngine::AddWorkspace | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoWorkspace ** | ppICaoWS
 | ) |

ワークスペースオブジェクトの追加

CaoWorkspaces::Add()と同じ機能です．

引数:
bstrName | : [in] ワークスペース名
bstrOption | : [in] オプション
ppICaoWS | : [out] CaoWorkspace IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoEngine::Execute | ( | VARIANT | vntCommand,
 |  | VARIANT * | pVal
 | ) |

ワークスペースコレクションの取得

引数:
vntCommand | : [in] コマンド
pVal | : [out] 結果
戻り値:
HRESULT

HRESULT CCaoEngine::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoEngine::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoEngine::get_EngineStatus ( ICaoEngineStatus ** ppICaoEngineStatus )

エンジンステータスオブジェクトの取得

引数:
ppICaoEngineStatus : [out] CaoEngineStatus IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoEngine::get_Workspaces ( ICaoWorkspaces ** ppICaoWSs )

ワークスペースコレクションの取得

引数:
ppICaoWSs : [out] CaoWorkspaces IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoEngine::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

  riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : [in] インタフェース
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoEngine.h
  • CaoEngine.cpp
Generated on Wed Dec 7 19:02:02 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoEngine メンバ一覧

これは全メンバの一覧です。CCaoEngine継承メンバも含んでいます。
AddWorkspace(BSTR bstrName, BSTR bstrOption, ICaoWorkspace **ppICaoWS) | CCaoEngine |
CCaoEngine() | CCaoEngine | [inline]
CustomGetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< ICaoEngine,&IID_ICaoEngine,&LIBID_CAOLib > | [inline, virtual]
CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< ICaoEngine,&IID_ICaoEngine,&LIBID_CAOLib > | [inline, virtual]
Execute(VARIANT vntCommand, VARIANT *pVal) | CCaoEngine |
FinalConstruct() | CCaoEngine |
FinalRelease() | CCaoEngine |
get_EngineStatus(ICaoEngineStatus **ppICaoStatus) | CCaoEngine |
get_Workspaces(ICaoWorkspaces **ppICaoWSs) | CCaoEngine |
GetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< ICaoEngine,&IID_ICaoEngine,&LIBID_CAOLib > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | CCaoEngine |
Invoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< ICaoEngine,&IID_ICaoEngine,&LIBID_CAOLib > | [inline]
~CCaoEngine() | CCaoEngine | [inline]
Generated on Wed Dec 7 19:02:02 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoEngineStatus class Reference

クラス CCaoEngineStatus の解説

CAOのEngineStatusクラス. [詳細]

#include <CaoEngineStatus.h>

CCaoEngineStatusに対する継承グラフ

[凡例]
CCaoEngineStatusのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoEngineStatus ()
コンストラクタ

~CCaoEngineStatus ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

HRESULT | get_Version (BSTR *pVal)
CAOエンジンのバージョンの取得.

HRESULT | get_Values (VARIANT vntName, VARIANT *pVal)
将来用の予約

HRESULT | get_StartDateTime (VARIANT *pVal)
開始日時の取得

HRESULT | get_ObjectCounts (VARIANT vntName, long *pVal)
オブジェクト数の取得

HRESULT | get_ComputerName (BSTR *pVal)
コンピュータ名の取得

HRESULT | get_CurrentDateTime (VARIANT *pVal)
現在日時の取得

解説

CAOのEngineStatusクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoEngineStatusを参照．
CaoEngineクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  CaoEngineのステータス情報を提供する．

コンストラクタとデストラクタの解説

CCaoEngineStatus::CCaoEngineStatus ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoEngineStatus::~CCaoEngineStatus ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoEngineStatus::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in] vntArgs[0] - 開始日時
戻り値:
HRESULT

HRESULT CCaoEngineStatus::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoEngineStatus::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoEngineStatus::get_ComputerName ( BSTR * pVal )

コンピュータ名の取得

引数:
pVal : [out] コンピュータ名
戻り値:
HRESULT

STDMETHODIMP CCaoEngineStatus::get_CurrentDateTime ( VARIANT * pVal )

現在日時の取得

  VT_DATE型を返す

引数:
pVal : [out] 現在日時
戻り値:
HRESULT

STDMETHODIMP CCaoEngineStatus::get_ObjectCounts | ( | VARIANT | vntName,
 |  | long * | pVal
 | ) |

オブジェクト数の取得

引数:
vntName : [in] クラス名／番号
0: CaoEngine
1: CaoWorkspaces,2: CaoWorkspace
3: CaoControllers,4: CaoController
5: CaoExtensions,6: CaoExtension
7: CaoFiles,8: CaoFile
9: CaoRobots,10: CaoRobot
11: CaoTasks,12: CaoTask
13: CaoVariables,14:CaoVariable
15: CaoCommands, 16:CaoCommand
17: CaoMessage
18: CaoEngineStatus
pVal : [in] オブジェクト数
戻り値:
HRESULT

STDMETHODIMP CCaoEngineStatus::get_StartDateTime ( VARIANT * pVal )

開始日時の取得

引数:
pVal : [out] 開始日時
戻り値:
HRESULT

STDMETHODIMP CCaoEngineStatus::get_Values | ( | VARIANT | vntName,
 |  | VARIANT * | pVal
 | ) |

将来用の予約

引数:
vntName | : [in] ステータス名/番号
pVal | : [out] データ
戻り値:
HRESULT

STDMETHODIMP CCaoEngineStatus::get_Version ( BSTR * pVal )

CAOエンジンのバージョンの取得.

引数:
pVal : [out] バージョン
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoEngineStatus.h
  • CaoEngineStatus.cpp
Generated on Wed Dec 7 19:02:02 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoEngineStatus メンバ一覧

これは全メンバの一覧です。CCaoEngineStatus継承メンバも含んでいます。
_Initialize(VARIANT vntArgs[]) | CCaoEngineStatus |
CCaoEngineStatus() | CCaoEngineStatus | [inline]
FinalConstruct() | CCaoEngineStatus |
FinalRelease() | CCaoEngineStatus |
get_ComputerName(BSTR *pVal) | CCaoEngineStatus |
get_CurrentDateTime(VARIANT *pVal) | CCaoEngineStatus |
get_ObjectCounts(VARIANT vntName, long *pVal) | CCaoEngineStatus |
get_StartDateTime(VARIANT *pVal) | CCaoEngineStatus |
get_Values(VARIANT vntName, VARIANT *pVal) | CCaoEngineStatus |
get_Version(BSTR *pVal) | CCaoEngineStatus |
~CCaoEngineStatus() | CCaoEngineStatus | [inline]
Generated on Wed Dec 7 19:02:02 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoExtension class Reference

クラス CCaoExtension の解説

CAOのExtensionクラス. [詳細]

#include <CaoExtension.h>

CCaoExtensionに対する継承グラフ

[凡例]
CCaoExtensionのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoExtension ()
コンストラクタ

~CCaoExtension ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | _GetICaopObj (IUnknown **ppICaopObj)
ICaoProvExtensionの取得.

HRESULT | _GetICRDObj (IUnknown **ppICRDObj)
CRDプロバイダのICaoProvExtensionの取得.

HRESULT | get_VariableNames (BSTR bstrOption, VARIANT *pVal)
変数名リストの取得

HRESULT | get_Variables (ICaoVariables **ppICaoVariables)
変数コレクションの取得

HRESULT | AddVariable (BSTR bstrName, BSTR bstrOption, ICaoVariable **ppICaoVar)
変数オブジェクトの追加

HRESULT | Execute (VARIANT vntCommand, VARIANT *pVal)
拡張コマンドの実行

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

HRESULT | CustomGetIDsOfNames (REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid)
IDispatch::GetIDsOfNames().

HRESULT | CustomInvoke (DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr)
IDispatch::Invoke().

解説

CAOのExtensionクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoExtensionを参照．
CaoExtensionsクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  CaoプロバイダのCaoProvExtensionオブジェクトと１対１に対応する．

コンストラクタとデストラクタの解説

CCaoExtension::CCaoExtension ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoExtension::~CCaoExtension ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoExtension::_GetICaopObj ( IUnknown ** ppICaopObj )

ICaoProvExtensionの取得.

  スクリプトコードから直接アクセスは禁止されています(restricted)

引数:
ppICaopObj : [out] CaoProvExtension IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoExtension::_GetICRDObj ( IUnknown ** ppICRDObj )

CRDプロバイダのICaoProvExtensionの取得.

  スクリプトコードから直接アクセスは禁止されています(restricted)

引数:
ppICRDObj : [out] CRDプロバイダのCaoProvExtension IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoExtension::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in]　vntArgs[0] - 拡張ボード名
          vntArgs[1] - CaoExtension番号
          vntArgs[2] - CaoProvExtension IFポインタ
          vntArgs[3] - CRDプロバイダの CaoProvExtension IFポインタ
          vntArgs[4] - 書き込み属性フラグ
戻り値:
HRESULT

STDMETHODIMP CCaoExtension::AddVariable | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoVariable ** | ppICaoVar
 | ) |

変数オブジェクトの追加

CaoVariables::Add()と同じ機能です．

引数:
bstrName | : [in] タスク名
bstrOption | : [in] オプション
ppICaoVar | : [out] CaoVariable IFポインタのアドレス
戻り値:
HRESULT

HRESULT CCaoExtension::CustomGetIDsOfNames | ( | REFIID | riid,
 |  | LPOLESTR * | rgszNames,
 |  | UINT | cNames,
 |  | LCID | lcid,
 |  | DISPID * | rgdispid
 | ) | [virtual]

IDispatch::GetIDsOfNames().

  IDispatch::GetIDsOfNames()関数の機能拡張 BindCmds, BindExecの優先度で処理される．

引数:
riid | : [in] 予約
rgszNames | : [in] メソッド名リスト
cNames | : [in] メソッド名リストの要素数
lcid | : [in] ロケールID
rgdispid | : [in] DISPID
戻り値:
HRESULT

ICaoDispatchImpl< ICaoExtension, piid,&LIBID_CAOLib >を再定義しています。

HRESULT CCaoExtension::CustomInvoke | ( | DISPID | dispidMember,
 |  | REFIID | riid,
 |  | LCID | lcid,
 |  | WORD | wFlags,
 |  | DISPPARAMS * | pdispparams,
 |  | VARIANT * | pvarResult,
 |  | EXCEPINFO * | pexcepinfo,
 |  | UINT * | puArgErr
 | ) | [virtual]

IDispatch::Invoke().

  IDispatch::Invoke()関数の機能拡張

引数:
dispidMember | : [in] DISPID
riid | : [in] 予約
lcid | : [in] ロケールID
wFlags | : [in] 起動対象メソッドのコンテキストフラグ
pdispparams | : [in] メソッドに渡すパラメータ
pvarResult | : [in] メソッドコールの結果
pexcepinfo | : [in] 例外情報
puArgErr | : [in] エラーのあった先頭引数
戻り値:
HRESULT

ICaoDispatchImpl< ICaoExtension, piid,&LIBID_CAOLib >を再定義しています。

STDMETHODIMP CCaoExtension::Execute | ( | VARIANT | vntCommand,
 |  | VARIANT * | pVal
 | ) |

拡張コマンドの実行

引数:
vntCommand | : [in] コマンド
pVal | : [out] 結果
戻り値:
HRESULT

HRESULT CCaoExtension::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoExtension::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoExtension::get_VariableNames | ( | BSTR | bstrOption,
 |  | VARIANT * | pVal
 | ) |

変数名リストの取得

引数:
bstrOption | : [in] オプション
pVal | : [out] 変数名リスト
戻り値:
HRESULT

STDMETHODIMP CCaoExtension::get_Variables ( ICaoVariables ** ppICaoVariables )

変数コレクションの取得

引数:
ppICaoVariables : [out] CaoVariables IFポインタのアドレス
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoExtension.h
  • CaoExtension.cpp
Generated on Wed Dec 7 19:02:02 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoExtension メンバ一覧

これは全メンバの一覧です。CCaoExtension継承メンバも含んでいます。
_CCaoBaseTmpl() | _CCaoBaseTmpl< CCaoExtension, pclsid, ICaoExtension, piid > | [inline]
_CCaoProvConnectionObjTmpl() | _CCaoProvConnectionObjTmpl< CCaoExtension,&CLSID_CaoExtension, ICaoExtension,&IID_ICaoExtension, ICaoProvExtension > | [inline]
_GetICaopObj(IUnknown **ppICaopObj) | CCaoExtension |
_GetICRDObj(IUnknown **ppICRDObj) | CCaoExtension |
_Initialize(VARIANT vntArgs[]) | CCaoExtension |
_PutIndex(long lVal) | _CCaoBaseTmpl< CCaoExtension, pclsid, ICaoExtension, piid > | [inline]
AddVariable(BSTR bstrName, BSTR bstrOption, ICaoVariable **ppICaoVar) | CCaoExtension |
CCaoExtension() | CCaoExtension | [inline]
CheckAccess(DWORD dwChkList) | _CCaoBaseTmpl< CCaoExtension, pclsid, ICaoExtension, piid > | [inline, protected]
CustomGetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | CCaoExtension | [virtual]
CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | CCaoExtension | [virtual]
Execute(VARIANT vntCommand, VARIANT *pVal) | CCaoExtension |
FinalConstruct() | CCaoExtension |
FinalRelease() | CCaoExtension |
get_Attribute(long *pVal) | _CCaoProvConnectionObjTmpl< CCaoExtension,&CLSID_CaoExtension, ICaoExtension,&IID_ICaoExtension, ICaoProvExtension > | [inline]
get_Help(BSTR *pVal) | _CCaoProvConnectionObjTmpl< CCaoExtension,&CLSID_CaoExtension, ICaoExtension,&IID_ICaoExtension, ICaoProvExtension > | [inline]
get_ID(VARIANT *pVal) | _CCaoProvConnectionObjTmpl< CCaoExtension,&CLSID_CaoExtension, ICaoExtension,&IID_ICaoExtension, ICaoProvExtension > | [inline]
get_Index(long *pVal) | _CCaoBaseTmpl< CCaoExtension, pclsid, ICaoExtension, piid > | [inline]
get_Name(BSTR *pVal) | _CCaoBaseTmpl< CCaoExtension, pclsid, ICaoExtension, piid > | [inline]
get_Tag(VARIANT *pVal) | _CCaoProvConnectionObjTmpl< CCaoExtension,&CLSID_CaoExtension, ICaoExtension,&IID_ICaoExtension, ICaoProvExtension > | [inline]
get_VariableNames(BSTR bstrOption, VARIANT *pVal) | CCaoExtension |
get_Variables(ICaoVariables **ppICaoVariables) | CCaoExtension |
GetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< ICaoExtension, piid,&LIBID_CAOLib > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoBaseTmpl< CCaoExtension, pclsid, ICaoExtension, piid > | [inline]
Invoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< ICaoExtension, piid,&LIBID_CAOLib > | [inline]
m_bstrName | _CCaoBaseTmpl< CCaoExtension, pclsid, ICaoExtension, piid > | [protected]
m_bWritable | _CCaoBaseTmpl< CCaoExtension, pclsid, ICaoExtension, piid > | [protected]
m_lIndex | _CCaoBaseTmpl< CCaoExtension, pclsid, ICaoExtension, piid > | [protected]
m_pICaopObj | _CCaoProvConnectionObjTmpl< CCaoExtension,&CLSID_CaoExtension, ICaoExtension,&IID_ICaoExtension, ICaoProvExtension > | [protected]
m_pICRDObj | _CCaoProvConnectionObjTmpl< CCaoExtension,&CLSID_CaoExtension, ICaoExtension,&IID_ICaoExtension, ICaoProvExtension > | [protected]
m_vntTag | _CCaoProvConnectionObjTmpl< CCaoExtension,&CLSID_CaoExtension, ICaoExtension,&IID_ICaoExtension, ICaoProvExtension > | [protected]
put_ID(VARIANT newVal) | _CCaoProvConnectionObjTmpl< CCaoExtension,&CLSID_CaoExtension, ICaoExtension,&IID_ICaoExtension, ICaoProvExtension > | [inline]
put_Tag(VARIANT newVal) | _CCaoProvConnectionObjTmpl< CCaoExtension,&CLSID_CaoExtension, ICaoExtension,&IID_ICaoExtension, ICaoProvExtension > | [inline]
~_CCaoBaseTmpl() | _CCaoBaseTmpl< CCaoExtension, pclsid, ICaoExtension, piid > | [inline]
~_CCaoProvConnectionObjTmpl() | _CCaoProvConnectionObjTmpl< CCaoExtension,&CLSID_CaoExtension, ICaoExtension,&IID_ICaoExtension, ICaoProvExtension > | [inline]
~CCaoExtension() | CCaoExtension | [inline]
Generated on Wed Dec 7 19:02:02 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoExtensions class Reference

クラス CCaoExtensions の解説

CAOのExtensionのコレクションクラス. [詳細]

#include <CaoExtensions.h>

CCaoExtensionsに対する継承グラフ

[凡例]
CCaoExtensionsのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoExtensions ()
コンストラクタ

~CCaoExtensions ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | Add (BSTR bstrName, BSTR bstrOption, ICaoExtension **ppICaoExtension)
拡張ボードオブジェクトの追加

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

解説

CAOのExtensionのコレクションクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoExtensionsを参照．
CaoControllerクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
CaoExtensionクラスのコレクションクラスとなっている．

コンストラクタとデストラクタの解説

CCaoExtensions::CCaoExtensions ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoExtensions::~CCaoExtensions ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoExtensions::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in]　vntArgs[0] - 親オブジェクトのIFポインタ
          vntArgs[1] - 書き込み属性フラグ
          vntArgs[2] - 親オブジェクトのクラスNo
戻り値:
HRESULT

STDMETHODIMP CCaoExtensions::Add | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoExtension ** | ppICaoExtension
 | ) |

拡張ボードオブジェクトの追加

引数:
bstrName | : [in] 拡張ボード名
bstrOption | : [in] オプション
ppICaoExtension | : [out] CaoExtension IFポインタのアドレス
戻り値:
HRESULT

HRESULT CCaoExtensions::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoExtensions::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

このクラスの解説は次のファイルから生成されました:
  • CaoExtensions.h
  • CaoExtensions.cpp
Generated on Wed Dec 7 19:02:03 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoExtensions メンバ一覧

これは全メンバの一覧です。CCaoExtensions継承メンバも含んでいます。
_CCaoCollectionTmpl() | _CCaoCollectionTmpl< CCaoExtensions,&CLSID_CaoExtensions, ICaoExtensions,&IID_ICaoExtensions, ICaoExtension > | [inline]
_Initialize(VARIANT vntArgs[]) | CCaoExtensions |
Add(BSTR bstrName, BSTR bstrOption, ICaoExtension **ppICaoExtension) | CCaoExtensions |
CCaoExtensions() | CCaoExtensions | [inline]
Clear() | _CCaoCollectionTmpl< CCaoExtensions,&CLSID_CaoExtensions, ICaoExtensions,&IID_ICaoExtensions, ICaoExtension > | [inline]
FinalConstruct() | CCaoExtensions |
FinalRelease() | CCaoExtensions |
GenerateIndex(long *lVal) | _CCaoCollectionTmpl< CCaoExtensions,&CLSID_CaoExtensions, ICaoExtensions,&IID_ICaoExtensions, ICaoExtension > | [inline, protected]
get__NewEnum(LPUNKNOWN *pVal) | _CCaoCollectionTmpl< CCaoExtensions,&CLSID_CaoExtensions, ICaoExtensions,&IID_ICaoExtensions, ICaoExtension > | [inline]
get_Count(long *pVal) | _CCaoCollectionTmpl< CCaoExtensions,&CLSID_CaoExtensions, ICaoExtensions,&IID_ICaoExtensions, ICaoExtension > | [inline]
GetIndex(VARIANT vntIndex, long *lVal) | _CCaoCollectionTmpl< CCaoExtensions,&CLSID_CaoExtensions, ICaoExtensions,&IID_ICaoExtensions, ICaoExtension > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoCollectionTmpl< CCaoExtensions,&CLSID_CaoExtensions, ICaoExtensions,&IID_ICaoExtensions, ICaoExtension > | [inline]
IsMember(VARIANT Index, VARIANT_BOOL *pVal) | _CCaoCollectionTmpl< CCaoExtensions,&CLSID_CaoExtensions, ICaoExtensions,&IID_ICaoExtensions, ICaoExtension > | [inline]
Item(VARIANT Index, ICaoExtension **ppItem) | _CCaoCollectionTmpl< CCaoExtensions,&CLSID_CaoExtensions, ICaoExtensions,&IID_ICaoExtensions, ICaoExtension > | [inline]
m_map | _CCaoCollectionTmpl< CCaoExtensions,&CLSID_CaoExtensions, ICaoExtensions,&IID_ICaoExtensions, ICaoExtension > | [protected]
Remove(VARIANT Index) | _CCaoCollectionTmpl< CCaoExtensions,&CLSID_CaoExtensions, ICaoExtensions,&IID_ICaoExtensions, ICaoExtension > | [inline]
~_CCaoCollectionTmpl() | _CCaoCollectionTmpl< CCaoExtensions,&CLSID_CaoExtensions, ICaoExtensions,&IID_ICaoExtensions, ICaoExtension > | [inline]
~CCaoExtensions() | CCaoExtensions | [inline]
Generated on Wed Dec 7 19:02:03 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoFile class Reference

クラス CCaoFile の解説

CAOのFileクラス. [詳細]

#include <CaoFile.h>

CCaoFileに対する継承グラフ

[凡例]
CCaoFileのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoFile ()
コンストラクタ

~CCaoFile ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

HRESULT | _GetICaopObj (IUnknown **ppICaopObj)
ICaoProvFileの取得.

HRESULT | _GetICRDObj (IUnknown **ppICRDObj)
CRDプロバイダのICaoProvFileの取得.

HRESULT | get_DateCreated (VARIANT *pVal)
ファイル作成日時の取得

HRESULT | get_DateLastAccessed (VARIANT *pVal)
ファイル最終アクセス日時の取得

HRESULT | get_DateLastModified (VARIANT *pVal)
ファイル更新日時を取得

HRESULT | get_FileNames (BSTR bstrOption, VARIANT *pVal)
ファイル名リストの取得

HRESULT | get_Files (ICaoFiles **ppICaoFiles)
ファイルコレクションの取得

HRESULT | get_Path (BSTR *pVal)
パスの取得

HRESULT | get_Size (long *pVal)
ファイルサイズの取得

HRESULT | get_Type (BSTR *pVal)
ファイルタイプの取得

HRESULT | get_Value (VARIANT *pVal)
ファイルの内容の取得

HRESULT | put_Value (VARIANT newVal)
ファイルの内容の設定

HRESULT | get_VariableNames (BSTR bstrOption, VARIANT *pVal)
変数名リストの取得

HRESULT | get_Variables (ICaoVariables **ppICaoVariables)
変数コレクションの取得

HRESULT | AddFile (BSTR bstrName, BSTR bstrOption, ICaoFile **ppICaoFile)
ファイルオブジェクトの追加

HRESULT | AddVariable (BSTR bstrName, BSTR bstrOption, ICaoVariable **ppICaoVar)
変数オブジェクトの追加

HRESULT | Copy (BSTR bstrName, BSTR bstrOption)
ファイルの複写

HRESULT | Delete (BSTR bstrOption)
ファイルの削除

HRESULT | Execute (VARIANT vntCommand, VARIANT *pVal)
拡張コマンドの実行

HRESULT | Move (BSTR bstrName, BSTR bstrOption)
ファイルの移動

HRESULT | Run (BSTR bstrOption, BSTR *bstrName)
タスクの生成

HRESULT | CustomGetIDsOfNames (REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid)
IDispatch::GetIDsOfNames().

HRESULT | CustomInvoke (DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr)
IDispatch::Invoke().

解説

CAOのFileクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoFileを参照．
CaoFilesクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  CaoプロバイダのCaoProvFileオブジェクトと１対１に対応する．

コンストラクタとデストラクタの解説

CCaoFile::CCaoFile ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoFile::~CCaoFile ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoFile::_GetICaopObj ( IUnknown ** ppICaopObj )

ICaoProvFileの取得.

  スクリプトコードから直接アクセスは禁止されています(restricted)

引数:
ppICaopObj : [out] CaoProvFile IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoFile::_GetICRDObj ( IUnknown ** ppICRDObj )

CRDプロバイダのICaoProvFileの取得.

  スクリプトコードから直接アクセスは禁止されています(restricted)

引数:
ppICRDObj : [out] CRDプロバイダのCaoProvFile IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoFile::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in]　vntArgs[0] - ファイル名 　　　　　vntArgs[1] - ファイル番号 　　　　　vntArgs[2] - CaoProvFile IFポインタ 　　　　　vntArgs[3] - CRDプロバイダの CaoProvFile IFポインタ 　　　　　vntArgs[4] - 書き込み属性フラグ
戻り値:
HRESULT

STDMETHODIMP CCaoFile::AddFile | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoFile ** | ppICaoFile
 | ) |

ファイルオブジェクトの追加

CaoFiles::Add()と同じ機能です．

引数:
bstrName | : [in] ファイル名
bstrOption | : [in] オプション
ppICaoFile | : [out] CaoFile IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoFile::AddVariable | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoVariable ** | ppICaoVar
 | ) |

変数オブジェクトの追加

CaoVariables::Add()と同じ機能です．

引数:
bstrName | : [in] タスク名
bstrOption | : [in] オプション
ppICaoVar | : [out] CaoVariable IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoFile::Copy | ( | BSTR | bstrName,
 |  | BSTR | bstrOption
 | ) |

ファイルの複写

引数:
bstrName | : [in] 複写先ファイル名
bstrOption | : [in] オプション
戻り値:
HRESULT

HRESULT CCaoFile::CustomGetIDsOfNames | ( | REFIID | riid,
 |  | LPOLESTR * | rgszNames,
 |  | UINT | cNames,
 |  | LCID | lcid,
 |  | DISPID * | rgdispid
 | ) | [virtual]

IDispatch::GetIDsOfNames().

  IDispatch::GetIDsOfNames()関数の機能拡張 BindCmds, BindExecの優先度で処理される．

引数:
riid | : [in] 予約
rgszNames | : [in] メソッド名リスト
cNames | : [in] メソッド名リストの要素数
lcid | : [in] ロケールID
rgdispid | : [in] DISPID
戻り値:
HRESULT

ICaoDispatchImpl< ICaoFile, piid,&LIBID_CAOLib >を再定義しています。

HRESULT CCaoFile::CustomInvoke | ( | DISPID | dispidMember,
 |  | REFIID | riid,
 |  | LCID | lcid,
 |  | WORD | wFlags,
 |  | DISPPARAMS * | pdispparams,
 |  | VARIANT * | pvarResult,
 |  | EXCEPINFO * | pexcepinfo,
 |  | UINT * | puArgErr
 | ) | [virtual]

IDispatch::Invoke().

  IDispatch::Invoke()関数の機能拡張

引数:
dispidMember | : [in] DISPID
riid | : [in] 予約
lcid | : [in] ロケールID
wFlags | : [in] 起動対象メソッドのコンテキストフラグ
pdispparams | : [in] メソッドに渡すパラメータ
pvarResult | : [in] メソッドコールの結果
pexcepinfo | : [in] 例外情報
puArgErr | : [in] エラーのあった先頭引数
戻り値:
HRESULT

ICaoDispatchImpl< ICaoFile, piid,&LIBID_CAOLib >を再定義しています。

STDMETHODIMP CCaoFile::Delete ( BSTR bstrOption )

ファイルの削除

引数:
bstrOption : [in] オプション
戻り値:
HRESULT

STDMETHODIMP CCaoFile::Execute | ( | VARIANT | vntCommand,
 |  | VARIANT * | pVal
 | ) |

拡張コマンドの実行

引数:
vntCommand | : [in] コマンド
pVal | : [out] 結果
戻り値:
HRESULT

HRESULT CCaoFile::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoFile::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoFile::get_DateCreated ( VARIANT * pVal )

ファイル作成日時の取得

  VT_DATE型を返す

引数:
pVal : [out] ファイル作成日時
戻り値:
HRESULT

STDMETHODIMP CCaoFile::get_DateLastAccessed ( VARIANT * pVal )

ファイル最終アクセス日時の取得

  VT_DATE型を返す

引数:
pVal : [out] ファイル最終アクセス日時
戻り値:
HRESULT

STDMETHODIMP CCaoFile::get_DateLastModified ( VARIANT * pVal )

ファイル更新日時を取得

  VT_DATE型を返す

引数:
pVal : [out] ファイル更新日時
戻り値:
HRESULT

STDMETHODIMP CCaoFile::get_FileNames | ( | BSTR | bstrOption,
 |  | VARIANT * | pVal
 | ) |

ファイル名リストの取得

引数:
bstrOption | : [in] オプション
pVal | : [out] ファイル名リスト
戻り値:
HRESULT

STDMETHODIMP CCaoFile::get_Files ( ICaoFiles ** ppICaoFiles )

ファイルコレクションの取得

引数:
ppICaoFiles : [out] CaoFiles IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoFile::get_Path ( BSTR * pVal )

パスの取得

引数:
pVal : [out] パス文字列
戻り値:
HRESULT

STDMETHODIMP CCaoFile::get_Size ( long * pVal )

ファイルサイズの取得

引数:
pVal : [out] ファイルサイズ（Byte）
戻り値:
HRESULT

STDMETHODIMP CCaoFile::get_Type ( BSTR * pVal )

ファイルタイプの取得

引数:
pVal : [out] ファイルタイプ
戻り値:
HRESULT

STDMETHODIMP CCaoFile::get_Value ( VARIANT * pVal )

ファイルの内容の取得

引数:
pVal : [out] ファイル内容
戻り値:
HRESULT

STDMETHODIMP CCaoFile::get_VariableNames | ( | BSTR | bstrOption,
 |  | VARIANT * | pVal
 | ) |

変数名リストの取得

引数:
bstrOption | : [in] オプション
pVal | : [out] 変数名リスト
戻り値:
HRESULT

STDMETHODIMP CCaoFile::get_Variables ( ICaoVariables ** ppICaoVariables )

変数コレクションの取得

引数:
ppICaoVariables : [out] CaoVariables IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoFile::Move | ( | BSTR | bstrName,
 |  | BSTR | bstrOption
 | ) |

ファイルの移動

  ファイルを移動する．ファイル名の変更にも使用する．

引数:
bstrName | : [in] 移動先ファイル名
bstrOption | : [in] オプション
戻り値:
HRESULT

STDMETHODIMP CCaoFile::put_Value ( VARIANT newVal )

ファイルの内容の設定

引数:
newVal : [in] ファイル内容
戻り値:
HRESULT

STDMETHODIMP CCaoFile::Run | ( | BSTR | bstrOption,
 |  | BSTR * | bstrName
 | ) |

タスクの生成

  タスクを生成し，タスク名を取得する．

引数:
bstrOption | : [in] オプション
bstrName | : [out] タスク名
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoFile.h
  • CaoFile.cpp
Generated on Wed Dec 7 19:02:03 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoFile メンバ一覧

これは全メンバの一覧です。CCaoFile継承メンバも含んでいます。
_CCaoBaseTmpl() | _CCaoBaseTmpl< CCaoFile, pclsid, ICaoFile, piid > | [inline]
_CCaoProvConnectionObjTmpl() | _CCaoProvConnectionObjTmpl< CCaoFile,&CLSID_CaoFile, ICaoFile,&IID_ICaoFile, ICaoProvFile > | [inline]
_GetICaopObj(IUnknown **ppICaopObj) | CCaoFile |
_GetICRDObj(IUnknown **ppICRDObj) | CCaoFile |
_Initialize(VARIANT vntArgs[]) | CCaoFile |
_PutIndex(long lVal) | _CCaoBaseTmpl< CCaoFile, pclsid, ICaoFile, piid > | [inline]
AddFile(BSTR bstrName, BSTR bstrOption, ICaoFile **ppICaoFile) | CCaoFile |
AddVariable(BSTR bstrName, BSTR bstrOption, ICaoVariable **ppICaoVar) | CCaoFile |
CCaoFile() | CCaoFile | [inline]
CheckAccess(DWORD dwChkList) | _CCaoBaseTmpl< CCaoFile, pclsid, ICaoFile, piid > | [inline, protected]
Copy(BSTR bstrName, BSTR bstrOption) | CCaoFile |
CustomGetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | CCaoFile | [virtual]
CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | CCaoFile | [virtual]
Delete(BSTR bstrOption) | CCaoFile |
Execute(VARIANT vntCommand, VARIANT *pVal) | CCaoFile |
FinalConstruct() | CCaoFile |
FinalRelease() | CCaoFile |
get_Attribute(long *pVal) | _CCaoProvConnectionObjTmpl< CCaoFile,&CLSID_CaoFile, ICaoFile,&IID_ICaoFile, ICaoProvFile > | [inline]
get_DateCreated(VARIANT *pVal) | CCaoFile |
get_DateLastAccessed(VARIANT *pVal) | CCaoFile |
get_DateLastModified(VARIANT *pVal) | CCaoFile |
get_FileNames(BSTR bstrOption, VARIANT *pVal) | CCaoFile |
get_Files(ICaoFiles **ppICaoFiles) | CCaoFile |
get_Help(BSTR *pVal) | _CCaoProvConnectionObjTmpl< CCaoFile,&CLSID_CaoFile, ICaoFile,&IID_ICaoFile, ICaoProvFile > | [inline]
get_ID(VARIANT *pVal) | _CCaoProvConnectionObjTmpl< CCaoFile,&CLSID_CaoFile, ICaoFile,&IID_ICaoFile, ICaoProvFile > | [inline]
get_Index(long *pVal) | _CCaoBaseTmpl< CCaoFile, pclsid, ICaoFile, piid > | [inline]
get_Name(BSTR *pVal) | _CCaoBaseTmpl< CCaoFile, pclsid, ICaoFile, piid > | [inline]
get_Path(BSTR *pVal) | CCaoFile |
get_Size(long *pVal) | CCaoFile |
get_Tag(VARIANT *pVal) | _CCaoProvConnectionObjTmpl< CCaoFile,&CLSID_CaoFile, ICaoFile,&IID_ICaoFile, ICaoProvFile > | [inline]
get_Type(BSTR *pVal) | CCaoFile |
get_Value(VARIANT *pVal) | CCaoFile |
get_VariableNames(BSTR bstrOption, VARIANT *pVal) | CCaoFile |
get_Variables(ICaoVariables **ppICaoVariables) | CCaoFile |
GetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< ICaoFile, piid,&LIBID_CAOLib > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoBaseTmpl< CCaoFile, pclsid, ICaoFile, piid > | [inline]
Invoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< ICaoFile, piid,&LIBID_CAOLib > | [inline]
m_bstrName | _CCaoBaseTmpl< CCaoFile, pclsid, ICaoFile, piid > | [protected]
m_bWritable | _CCaoBaseTmpl< CCaoFile, pclsid, ICaoFile, piid > | [protected]
m_lIndex | _CCaoBaseTmpl< CCaoFile, pclsid, ICaoFile, piid > | [protected]
m_pICaopObj | _CCaoProvConnectionObjTmpl< CCaoFile,&CLSID_CaoFile, ICaoFile,&IID_ICaoFile, ICaoProvFile > | [protected]
m_pICRDObj | _CCaoProvConnectionObjTmpl< CCaoFile,&CLSID_CaoFile, ICaoFile,&IID_ICaoFile, ICaoProvFile > | [protected]
m_vntTag | _CCaoProvConnectionObjTmpl< CCaoFile,&CLSID_CaoFile, ICaoFile,&IID_ICaoFile, ICaoProvFile > | [protected]
Move(BSTR bstrName, BSTR bstrOption) | CCaoFile |
put_ID(VARIANT newVal) | _CCaoProvConnectionObjTmpl< CCaoFile,&CLSID_CaoFile, ICaoFile,&IID_ICaoFile, ICaoProvFile > | [inline]
put_Tag(VARIANT newVal) | _CCaoProvConnectionObjTmpl< CCaoFile,&CLSID_CaoFile, ICaoFile,&IID_ICaoFile, ICaoProvFile > | [inline]
put_Value(VARIANT newVal) | CCaoFile |
Run(BSTR bstrOption, BSTR *bstrName) | CCaoFile |
~_CCaoBaseTmpl() | _CCaoBaseTmpl< CCaoFile, pclsid, ICaoFile, piid > | [inline]
~_CCaoProvConnectionObjTmpl() | _CCaoProvConnectionObjTmpl< CCaoFile,&CLSID_CaoFile, ICaoFile,&IID_ICaoFile, ICaoProvFile > | [inline]
~CCaoFile() | CCaoFile | [inline]
Generated on Wed Dec 7 19:02:03 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoFiles class Reference

クラス CCaoFiles の解説

CAOのFileのコレクションクラス. [詳細]

#include <CaoFiles.h>

CCaoFilesに対する継承グラフ

[凡例]
CCaoFilesのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoFiles ()
コンストラクタ

~CCaoFiles ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | Add (BSTR bstrName, BSTR bstrOption, ICaoFile **ppICaoFile)
ファイルオブジェクトの追加

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

解説

CAOのFileのコレクションクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoFilesを参照．
CaoControllerクラスとCaoFileクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
CaoFileクラスのコレクションクラスとなっている．

コンストラクタとデストラクタの解説

CCaoFiles::CCaoFiles ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoFiles::~CCaoFiles ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoFiles::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in]　vntArgs[0] - 親オブジェクトのIFポインタ
          vntArgs[1] - 書き込み属性フラグ
          vntArgs[2] - 親オブジェクトのクラスNo
戻り値:
HRESULT

STDMETHODIMP CCaoFiles::Add | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoFile ** | ppICaoFile
 | ) |

ファイルオブジェクトの追加

引数:
bstrName | : [in] ファイル名
bstrOption | : [in] オプション
ppICaoFile | : [out] CaoFile IFポインタのアドレス
戻り値:
HRESULT

HRESULT CCaoFiles::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoFiles::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

このクラスの解説は次のファイルから生成されました:
  • CaoFiles.h
  • CaoFiles.cpp
Generated on Wed Dec 7 19:02:03 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoFiles メンバ一覧

これは全メンバの一覧です。CCaoFiles継承メンバも含んでいます。
_CCaoCollectionTmpl() | _CCaoCollectionTmpl< CCaoFiles,&CLSID_CaoFiles, ICaoFiles,&IID_ICaoFiles, ICaoFile > | [inline]
_Initialize(VARIANT vntArgs[]) | CCaoFiles |
Add(BSTR bstrName, BSTR bstrOption, ICaoFile **ppICaoFile) | CCaoFiles |
CCaoFiles() | CCaoFiles | [inline]
Clear() | _CCaoCollectionTmpl< CCaoFiles,&CLSID_CaoFiles, ICaoFiles,&IID_ICaoFiles, ICaoFile > | [inline]
FinalConstruct() | CCaoFiles |
FinalRelease() | CCaoFiles |
GenerateIndex(long *lVal) | _CCaoCollectionTmpl< CCaoFiles,&CLSID_CaoFiles, ICaoFiles,&IID_ICaoFiles, ICaoFile > | [inline, protected]
get__NewEnum(LPUNKNOWN *pVal) | _CCaoCollectionTmpl< CCaoFiles,&CLSID_CaoFiles, ICaoFiles,&IID_ICaoFiles, ICaoFile > | [inline]
get_Count(long *pVal) | _CCaoCollectionTmpl< CCaoFiles,&CLSID_CaoFiles, ICaoFiles,&IID_ICaoFiles, ICaoFile > | [inline]
GetIndex(VARIANT vntIndex, long *lVal) | _CCaoCollectionTmpl< CCaoFiles,&CLSID_CaoFiles, ICaoFiles,&IID_ICaoFiles, ICaoFile > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoCollectionTmpl< CCaoFiles,&CLSID_CaoFiles, ICaoFiles,&IID_ICaoFiles, ICaoFile > | [inline]
IsMember(VARIANT Index, VARIANT_BOOL *pVal) | _CCaoCollectionTmpl< CCaoFiles,&CLSID_CaoFiles, ICaoFiles,&IID_ICaoFiles, ICaoFile > | [inline]
Item(VARIANT Index, ICaoFile **ppItem) | _CCaoCollectionTmpl< CCaoFiles,&CLSID_CaoFiles, ICaoFiles,&IID_ICaoFiles, ICaoFile > | [inline]
m_map | _CCaoCollectionTmpl< CCaoFiles,&CLSID_CaoFiles, ICaoFiles,&IID_ICaoFiles, ICaoFile > | [protected]
Remove(VARIANT Index) | _CCaoCollectionTmpl< CCaoFiles,&CLSID_CaoFiles, ICaoFiles,&IID_ICaoFiles, ICaoFile > | [inline]
~_CCaoCollectionTmpl() | _CCaoCollectionTmpl< CCaoFiles,&CLSID_CaoFiles, ICaoFiles,&IID_ICaoFiles, ICaoFile > | [inline]
~CCaoFiles() | CCaoFiles | [inline]
Generated on Wed Dec 7 19:02:03 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoMessage class Reference

クラス CCaoMessage の解説

CAOのControllerクラス. [詳細]

#include <CaoMessage.h>

CCaoMessageに対する継承グラフ

[凡例]
CCaoMessageのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoMessage ()
コンストラクタ

~CCaoMessage ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | get_DateTime (VARIANT *pVal)
メッセージ作成日時の取得

HRESULT | get_Description (BSTR *pVal)
メッセージの説明の取得

HRESULT | get_Destination (BSTR *pVal)
送り先の取得

HRESULT | get_Number (long *pVal)
メッセージ番号の取得

HRESULT | get_SerialNumber (long *pVal)
メッセージ連番の取得

HRESULT | get_Source (BSTR *pVal)
送り元の取得

HRESULT | get_Value (VARIANT *pVal)
メッセージ本文の取得

HRESULT | Clear (void)
メッセージのクリア

HRESULT | Reply (VARIANT vntData)
メッセージの返信

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

解説

CAOのControllerクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoMessageを参照．
CaoControllerクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  CaoプロバイダのCaoProvMessageクラスをラッピングします． 　OnMessageイベントではこのクラスが渡される．

コンストラクタとデストラクタの解説

CCaoMessage::CCaoMessage ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoMessage::~CCaoMessage ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoMessage::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in]　vntArgs[0] - CaoProvMessage IFポインタ
          vntArgs[1] - シリアル番号
戻り値:
HRESULT

STDMETHODIMP CCaoMessage::Clear ( void )

メッセージのクリア

戻り値:
HRESULT

HRESULT CCaoMessage::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoMessage::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoMessage::get_DateTime ( VARIANT * pVal )

メッセージ作成日時の取得

  VT_DATE型を返す

引数:
pVal : [in] 作成日時
戻り値:
HRESULT

STDMETHODIMP CCaoMessage::get_Description ( BSTR * pVal )

メッセージの説明の取得

引数:
pVal : [in] 説明文字列
戻り値:
HRESULT

STDMETHODIMP CCaoMessage::get_Destination ( BSTR * pVal )

送り先の取得

引数:
pVal : [in] 送り先
戻り値:
HRESULT

STDMETHODIMP CCaoMessage::get_Number ( long * pVal )

メッセージ番号の取得

引数:
pVal : [in] メッセージ番号
戻り値:
HRESULT

STDMETHODIMP CCaoMessage::get_SerialNumber ( long * pVal )

メッセージ連番の取得

引数:
pVal : [in] メッセージ連番
戻り値:
HRESULT

STDMETHODIMP CCaoMessage::get_Source ( BSTR * pVal )

送り元の取得

引数:
pVal : [in] 送り元
戻り値:
HRESULT

STDMETHODIMP CCaoMessage::get_Value ( VARIANT * pVal )

メッセージ本文の取得

引数:
pVal : [in] メッセージ本文
戻り値:
HRESULT

STDMETHODIMP CCaoMessage::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

  riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : [in] インタフェース
戻り値:
HRESULT

STDMETHODIMP CCaoMessage::Reply ( VARIANT vntData )

メッセージの返信

引数:
vntData : [in] 返信データ
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoMessage.h
  • CaoMessage.cpp
Generated on Wed Dec 7 19:02:04 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoMessage メンバ一覧

これは全メンバの一覧です。CCaoMessage継承メンバも含んでいます。
_Initialize(VARIANT vntArgs[]) | CCaoMessage |
CCaoMessage() | CCaoMessage | [inline]
Clear(void) | CCaoMessage |
FinalConstruct() | CCaoMessage |
FinalRelease() | CCaoMessage |
get_DateTime(VARIANT *pVal) | CCaoMessage |
get_Description(BSTR *pVal) | CCaoMessage |
get_Destination(BSTR *pVal) | CCaoMessage |
get_Number(long *pVal) | CCaoMessage |
get_SerialNumber(long *pVal) | CCaoMessage |
get_Source(BSTR *pVal) | CCaoMessage |
get_Value(VARIANT *pVal) | CCaoMessage |
InterfaceSupportsErrorInfo(REFIID riid) | CCaoMessage |
Reply(VARIANT vntData) | CCaoMessage |
~CCaoMessage() | CCaoMessage | [inline]
Generated on Wed Dec 7 19:02:04 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoRobot class Reference

クラス CCaoRobot の解説

CAOのRobotクラス. [詳細]

#include <CaoRobot.h>

CCaoRobotに対する継承グラフ

[凡例]
CCaoRobotのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoRobot ()
コンストラクタ

~CCaoRobot ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | _GetICaopObj (IUnknown **ppICaopObj)
ICaoProvRobotの取得.

HRESULT | _GetICRDObj (IUnknown **ppICRDObj)
CRDプロバイダのICaoProvRobotの取得.

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

HRESULT | get_VariableNames (BSTR bstrOption, VARIANT *pVal)
変数名リストの取得

HRESULT | get_Variables (ICaoVariables **ppICaoVariables)
変数コレクションの取得

HRESULT | Accelerate (long lAxis, float fAccel, float fDecel)
ACCEL文の実行.

HRESULT | AddVariable (BSTR bstrName, BSTR bstrOption, ICaoVariable **ppICaoVar)
変数オブジェクトの追加

HRESULT | Change (BSTR bstrName)
CHANGE文の実行.

HRESULT | Chuck (BSTR bstrOption)
GRASP文の実行.

HRESULT | Drive (long lNo, float fMov, BSTR bstrOpt)
Drive文の実行.

HRESULT | Execute (VARIANT vntCommand, VARIANT *pVal)
拡張コマンドの実行

HRESULT | GoHome ()
GOHOME文の実行.

HRESULT | Halt (BSTR bstrOption)
強制停止

HRESULT | Hold (BSTR bstrOption)
一時停止

HRESULT | Move (long lComp, VARIANT vntPose, BSTR bstrOpt)
Move文の実行.

HRESULT | Rotate (VARIANT vntRotSuf, float fDeg, VARIANT vntPivot, BSTR bstrOpt)
ROTATE文の実行.

HRESULT | Speed (long lAxis, float fSpeed)
SPEED/JSPEED文の実行.

HRESULT | Unchuck (BSTR bstrOption)
RELEASE文の実行.

HRESULT | Unhold (BSTR bstrOption)
動作再開

HRESULT | CustomGetIDsOfNames (REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid)
IDispatch::GetIDsOfNames().

HRESULT | CustomInvoke (DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr)
IDispatch::Invoke().

解説

CAOのRobotクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoRobotを参照．
CaoRobotsクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  CaoプロバイダのCaoProvRobotオブジェクトと１対１に対応する．

コンストラクタとデストラクタの解説

CCaoRobot::CCaoRobot ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoRobot::~CCaoRobot ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoRobot::_GetICaopObj ( IUnknown ** ppICaopObj )

ICaoProvRobotの取得.

  スクリプトコードから直接アクセスは禁止されています(restricted)

引数:
ppICaopObj : [out] CaoProvRobot IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoRobot::_GetICRDObj ( IUnknown ** ppICRDObj )

CRDプロバイダのICaoProvRobotの取得.

  スクリプトコードから直接アクセスは禁止されています(restricted)

引数:
ppICRDObj : [out] CRDプロバイダのCaoProvRobot IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoRobot::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in]　vntArgs[0] - ロボット名
          vntArgs[1] - ロボット番号
          vntArgs[2] - CaoProvRobot IFポインタ
          vntArgs[3] - CRDプロバイダの CaoProvRobot IFポインタ
          vntArgs[4] - 書き込み属性フラグ
戻り値:
HRESULT

STDMETHODIMP CCaoRobot::Accelerate | ( | long | lAxis,
 |  | float | fAccel,
 |  | float | fDecel
 | ) |

ACCEL文の実行.

SLIMのACCEL文の仕様参照

引数:
lAxis | : [in] 軸番号
fAccel | : [in] 加速度
fDecel | : [in] 減速度
戻り値:
HRESULT

STDMETHODIMP CCaoRobot::AddVariable | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoVariable ** | ppICaoVar
 | ) |

変数オブジェクトの追加

CaoVariables::Add()と同じ機能です．

引数:
bstrName | : [in] 変数名
bstrOption | : [in] オプション
ppICaoVar | : [out] CaoVariable IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoRobot::Change ( BSTR bstrName )

CHANGE文の実行.

SLIMのCHANGE文の仕様参照

引数:
bstrName : [in] ハンド名
戻り値:
HRESULT

STDMETHODIMP CCaoRobot::Chuck ( BSTR bstrOption )

GRASP文の実行.

SLIMのGRASP文の仕様参照

引数:
bstrOption : [in] オプション
戻り値:
HRESULT

HRESULT CCaoRobot::CustomGetIDsOfNames | ( | REFIID | riid,
 |  | LPOLESTR * | rgszNames,
 |  | UINT | cNames,
 |  | LCID | lcid,
 |  | DISPID * | rgdispid
 | ) | [virtual]

IDispatch::GetIDsOfNames().

  IDispatch::GetIDsOfNames()関数の機能拡張 BindCmds, BindExecの優先度で処理される．

引数:
riid | : [in] 予約
rgszNames | : [in] メソッド名リスト
cNames | : [in] メソッド名リストの要素数
lcid | : [in] ロケールID
rgdispid | : [in] DISPID
戻り値:
HRESULT

ICaoDispatchImpl< ICaoRobot, piid,&LIBID_CAOLib >を再定義しています。

HRESULT CCaoRobot::CustomInvoke | ( | DISPID | dispidMember,
 |  | REFIID | riid,
 |  | LCID | lcid,
 |  | WORD | wFlags,
 |  | DISPPARAMS * | pdispparams,
 |  | VARIANT * | pvarResult,
 |  | EXCEPINFO * | pexcepinfo,
 |  | UINT * | puArgErr
 | ) | [virtual]

IDispatch::Invoke().

  IDispatch::Invoke()関数の機能拡張

引数:
dispidMember | : [in] DISPID
riid | : [in] 予約
lcid | : [in] ロケールID
wFlags | : [in] 起動対象メソッドのコンテキストフラグ
pdispparams | : [in] メソッドに渡すパラメータ
pvarResult | : [in] メソッドコールの結果
pexcepinfo | : [in] 例外情報
puArgErr | : [in] エラーのあった先頭引数
戻り値:
HRESULT

ICaoDispatchImpl< ICaoRobot, piid,&LIBID_CAOLib >を再定義しています。

STDMETHODIMP CCaoRobot::Drive | ( | long | lNo,
 |  | float | fMov,
 |  | BSTR | bstrOpt
 | ) |

Drive文の実行.

  SLIMのDRIVE文の仕様参照
  SLIMのように同時に複数の軸を動かすことはできない．
  その場合は，MOVEを使うことを推奨．

引数:
lNo | : [in] 軸番号
fMov | : [in] 移動量
bstrOpt | : [in] 動作オプション
戻り値:
HRESULT

STDMETHODIMP CCaoRobot::Execute | ( | VARIANT | vntCommand,
 |  | VARIANT * | pVal
 | ) |

拡張コマンドの実行

引数:
vntCommand | : [in] コマンド
pVal | : [out] 結果
戻り値:
HRESULT

HRESULT CCaoRobot::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoRobot::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoRobot::get_VariableNames | ( | BSTR | bstrOption,
 |  | VARIANT * | pVal
 | ) |

変数名リストの取得

引数:
bstrOption | : [in] オプション
pVal | : [out] 変数名リスト
戻り値:
HRESULT

STDMETHODIMP CCaoRobot::get_Variables ( ICaoVariables ** ppICaoVariables )

変数コレクションの取得

引数:
ppICaoVariables : [out] CaoVariables IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoRobot::GoHome ( )

GOHOME文の実行.

SLIMのGOHOME文の仕様参照

戻り値:
HRESULT

STDMETHODIMP CCaoRobot::Halt ( BSTR bstrOption )

強制停止

  SLIMのHALT文の仕様参照 　SLIMではプログラムの強制停止の意味だか，CAOではロボット動作の強制停止を意味している．

引数:
bstrOption : [in] オプション
戻り値:
HRESULT

STDMETHODIMP CCaoRobot::Hold ( BSTR bstrOption )

一時停止

  SLIMのHOLD文の仕様参照 　SLIMではプログラムの一時停止の意味だか，CAOではロボット動作の一時停止を意味している．

引数:
bstrOption : [in] オプション
戻り値:
HRESULT

STDMETHODIMP CCaoRobot::Move | ( | long | lComp,
 |  | VARIANT | vntPose,
 |  | BSTR | bstrOpt
 | ) |

Move文の実行.

  SLIMのMOVE文の仕様参照
  補間指定は，1:PTP 2:直線 3:円弧
  ポーズ列の指定は各メーカ依存．円弧補間の場合などは，配列になる．
  動作オプションのデフォルト値は""

引数:
lComp | : [in] 補間指定
vntPose | : [in] ポーズ列
bstrOpt | : [in] 動作オプション
戻り値:
HRESULT

STDMETHODIMP CCaoRobot::Rotate | ( | VARIANT | vntRotSuf,
 |  | float | fDeg,
 |  | VARIANT | vntPivot,
 |  | BSTR | bstrOpt
 | ) |

ROTATE文の実行.

  SLIMのROTATE文の仕様参照
  回転面の指定は各メーカ依存．

引数:
vntRotSuf | : [in] 回転面
fDeg | : [in] 角度
vntPivot | : [in] 回転中心
bstrOpt | : [in] 動作オプション
戻り値:
HRESULT

STDMETHODIMP CCaoRobot::Speed | ( | long | lAxis,
 |  | float | fSpeed
 | ) |

SPEED/JSPEED文の実行.

SLIMのSPEED/JSPEED文の仕様参照

引数:
lAxis | : [in] 軸番号
fSpeed | : [in] 速度
戻り値:
HRESULT

STDMETHODIMP CCaoRobot::Unchuck ( BSTR bstrOption )

RELEASE文の実行.

SLIMのRELEASE文の仕様参照
  SLIMのReleaseは予約語で使えないためChuck/Unchuckに変更．

引数:
bstrOption : [in] オプション
戻り値:
HRESULT

STDMETHODIMP CCaoRobot::Unhold ( BSTR bstrOption )

動作再開

  SLIMのHOLD文の解除 　SLIMではHOLD文はプログラムの一時停止の意味であるため，再開のコマンドが規定されていないが， 　CAOではロボット動作の一時停止を意味しているので，その再開に使う．

引数:
bstrOption : [in] オプション
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoRobot.h
  • CaoRobot.cpp
Generated on Wed Dec 7 19:02:04 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoRobot メンバ一覧

これは全メンバの一覧です。CCaoRobot継承メンバも含んでいます。
_CCaoBaseTmpl() | _CCaoBaseTmpl< CCaoRobot, pclsid, ICaoRobot, piid > | [inline]
_CCaoProvConnectionObjTmpl() | _CCaoProvConnectionObjTmpl< CCaoRobot,&CLSID_CaoRobot, ICaoRobot,&IID_ICaoRobot, ICaoProvRobot > | [inline]
_GetICaopObj(IUnknown **ppICaopObj) | CCaoRobot |
_GetICRDObj(IUnknown **ppICRDObj) | CCaoRobot |
_Initialize(VARIANT vntArgs[]) | CCaoRobot |
_PutIndex(long lVal) | _CCaoBaseTmpl< CCaoRobot, pclsid, ICaoRobot, piid > | [inline]
Accelerate(long lAxis, float fAccel, float fDecel) | CCaoRobot |
AddVariable(BSTR bstrName, BSTR bstrOption, ICaoVariable **ppICaoVar) | CCaoRobot |
CCaoRobot() | CCaoRobot | [inline]
Change(BSTR bstrName) | CCaoRobot |
CheckAccess(DWORD dwChkList) | _CCaoBaseTmpl< CCaoRobot, pclsid, ICaoRobot, piid > | [inline, protected]
Chuck(BSTR bstrOption) | CCaoRobot |
CustomGetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | CCaoRobot | [virtual]
CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | CCaoRobot | [virtual]
Drive(long lNo, float fMov, BSTR bstrOpt) | CCaoRobot |
Execute(VARIANT vntCommand, VARIANT *pVal) | CCaoRobot |
FinalConstruct() | CCaoRobot |
FinalRelease() | CCaoRobot |
get_Attribute(long *pVal) | _CCaoProvConnectionObjTmpl< CCaoRobot,&CLSID_CaoRobot, ICaoRobot,&IID_ICaoRobot, ICaoProvRobot > | [inline]
get_Help(BSTR *pVal) | _CCaoProvConnectionObjTmpl< CCaoRobot,&CLSID_CaoRobot, ICaoRobot,&IID_ICaoRobot, ICaoProvRobot > | [inline]
get_ID(VARIANT *pVal) | _CCaoProvConnectionObjTmpl< CCaoRobot,&CLSID_CaoRobot, ICaoRobot,&IID_ICaoRobot, ICaoProvRobot > | [inline]
get_Index(long *pVal) | _CCaoBaseTmpl< CCaoRobot, pclsid, ICaoRobot, piid > | [inline]
get_Name(BSTR *pVal) | _CCaoBaseTmpl< CCaoRobot, pclsid, ICaoRobot, piid > | [inline]
get_Tag(VARIANT *pVal) | _CCaoProvConnectionObjTmpl< CCaoRobot,&CLSID_CaoRobot, ICaoRobot,&IID_ICaoRobot, ICaoProvRobot > | [inline]
get_VariableNames(BSTR bstrOption, VARIANT *pVal) | CCaoRobot |
get_Variables(ICaoVariables **ppICaoVariables) | CCaoRobot |
GetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< ICaoRobot, piid,&LIBID_CAOLib > | [inline]
GoHome() | CCaoRobot |
Halt(BSTR bstrOption) | CCaoRobot |
Hold(BSTR bstrOption) | CCaoRobot |
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoBaseTmpl< CCaoRobot, pclsid, ICaoRobot, piid > | [inline]
Invoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< ICaoRobot, piid,&LIBID_CAOLib > | [inline]
m_bstrName | _CCaoBaseTmpl< CCaoRobot, pclsid, ICaoRobot, piid > | [protected]
m_bWritable | _CCaoBaseTmpl< CCaoRobot, pclsid, ICaoRobot, piid > | [protected]
m_lIndex | _CCaoBaseTmpl< CCaoRobot, pclsid, ICaoRobot, piid > | [protected]
m_pICaopObj | _CCaoProvConnectionObjTmpl< CCaoRobot,&CLSID_CaoRobot, ICaoRobot,&IID_ICaoRobot, ICaoProvRobot > | [protected]
m_pICRDObj | _CCaoProvConnectionObjTmpl< CCaoRobot,&CLSID_CaoRobot, ICaoRobot,&IID_ICaoRobot, ICaoProvRobot > | [protected]
m_vntTag | _CCaoProvConnectionObjTmpl< CCaoRobot,&CLSID_CaoRobot, ICaoRobot,&IID_ICaoRobot, ICaoProvRobot > | [protected]
Move(long lComp, VARIANT vntPose, BSTR bstrOpt) | CCaoRobot |
put_ID(VARIANT newVal) | _CCaoProvConnectionObjTmpl< CCaoRobot,&CLSID_CaoRobot, ICaoRobot,&IID_ICaoRobot, ICaoProvRobot > | [inline]
put_Tag(VARIANT newVal) | _CCaoProvConnectionObjTmpl< CCaoRobot,&CLSID_CaoRobot, ICaoRobot,&IID_ICaoRobot, ICaoProvRobot > | [inline]
Rotate(VARIANT vntRotSuf, float fDeg, VARIANT vntPivot, BSTR bstrOpt) | CCaoRobot |
Speed(long lAxis, float fSpeed) | CCaoRobot |
Unchuck(BSTR bstrOption) | CCaoRobot |
Unhold(BSTR bstrOption) | CCaoRobot |
~_CCaoBaseTmpl() | _CCaoBaseTmpl< CCaoRobot, pclsid, ICaoRobot, piid > | [inline]
~_CCaoProvConnectionObjTmpl() | _CCaoProvConnectionObjTmpl< CCaoRobot,&CLSID_CaoRobot, ICaoRobot,&IID_ICaoRobot, ICaoProvRobot > | [inline]
~CCaoRobot() | CCaoRobot | [inline]
Generated on Wed Dec 7 19:02:04 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoRobots class Reference

クラス CCaoRobots の解説

CAOのRobotのコレクションクラス. [詳細]

#include <CaoRobots.h>

CCaoRobotsに対する継承グラフ

[凡例]
CCaoRobotsのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoRobots ()
コンストラクタ

~CCaoRobots ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | Add (BSTR bstrName, BSTR bstrOption, ICaoRobot **ppICaoRobot)
ロボットオブジェクトの追加

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

解説

CAOのRobotのコレクションクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoRobotsを参照．
CaoControllerクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
CaoRobotクラスのコレクションクラスとなっている．

コンストラクタとデストラクタの解説

CCaoRobots::CCaoRobots ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoRobots::~CCaoRobots ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoRobots::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in]　vntArgs[0] - 親オブジェクトのIFポインタ
          vntArgs[1] - 書き込み属性フラグ
          vntArgs[2] - 親オブジェクトのクラスNo
戻り値:
HRESULT

STDMETHODIMP CCaoRobots::Add | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoRobot ** | ppICaoRobot
 | ) |

ロボットオブジェクトの追加

引数:
bstrName | : [in] ロボット名
bstrOption | : [in] オプション
ppICaoRobot | : [out] CaoRobot IFポインタのアドレス
戻り値:
HRESULT

HRESULT CCaoRobots::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoRobots::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

このクラスの解説は次のファイルから生成されました:
  • CaoRobots.h
  • CaoRobots.cpp
Generated on Wed Dec 7 19:02:04 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoRobots メンバ一覧

これは全メンバの一覧です。CCaoRobots継承メンバも含んでいます。
_CCaoCollectionTmpl() | _CCaoCollectionTmpl< CCaoRobots,&CLSID_CaoRobots, ICaoRobots,&IID_ICaoRobots, ICaoRobot > | [inline]
_Initialize(VARIANT vntArgs[]) | CCaoRobots |
Add(BSTR bstrName, BSTR bstrOption, ICaoRobot **ppICaoRobot) | CCaoRobots |
CCaoRobots() | CCaoRobots | [inline]
Clear() | _CCaoCollectionTmpl< CCaoRobots,&CLSID_CaoRobots, ICaoRobots,&IID_ICaoRobots, ICaoRobot > | [inline]
FinalConstruct() | CCaoRobots |
FinalRelease() | CCaoRobots |
GenerateIndex(long *lVal) | _CCaoCollectionTmpl< CCaoRobots,&CLSID_CaoRobots, ICaoRobots,&IID_ICaoRobots, ICaoRobot > | [inline, protected]
get__NewEnum(LPUNKNOWN *pVal) | _CCaoCollectionTmpl< CCaoRobots,&CLSID_CaoRobots, ICaoRobots,&IID_ICaoRobots, ICaoRobot > | [inline]
get_Count(long *pVal) | _CCaoCollectionTmpl< CCaoRobots,&CLSID_CaoRobots, ICaoRobots,&IID_ICaoRobots, ICaoRobot > | [inline]
GetIndex(VARIANT vntIndex, long *lVal) | _CCaoCollectionTmpl< CCaoRobots,&CLSID_CaoRobots, ICaoRobots,&IID_ICaoRobots, ICaoRobot > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoCollectionTmpl< CCaoRobots,&CLSID_CaoRobots, ICaoRobots,&IID_ICaoRobots, ICaoRobot > | [inline]
IsMember(VARIANT Index, VARIANT_BOOL *pVal) | _CCaoCollectionTmpl< CCaoRobots,&CLSID_CaoRobots, ICaoRobots,&IID_ICaoRobots, ICaoRobot > | [inline]
Item(VARIANT Index, ICaoRobot **ppItem) | _CCaoCollectionTmpl< CCaoRobots,&CLSID_CaoRobots, ICaoRobots,&IID_ICaoRobots, ICaoRobot > | [inline]
m_map | _CCaoCollectionTmpl< CCaoRobots,&CLSID_CaoRobots, ICaoRobots,&IID_ICaoRobots, ICaoRobot > | [protected]
Remove(VARIANT Index) | _CCaoCollectionTmpl< CCaoRobots,&CLSID_CaoRobots, ICaoRobots,&IID_ICaoRobots, ICaoRobot > | [inline]
~_CCaoCollectionTmpl() | _CCaoCollectionTmpl< CCaoRobots,&CLSID_CaoRobots, ICaoRobots,&IID_ICaoRobots, ICaoRobot > | [inline]
~CCaoRobots() | CCaoRobots | [inline]
Generated on Wed Dec 7 19:02:04 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoTask class Reference

クラス CCaoTask の解説

CAOのTaskクラス. [詳細]

#include <CaoTask.h>

CCaoTaskに対する継承グラフ

[凡例]
CCaoTaskのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoTask ()
コンストラクタ

~CCaoTask ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | _GetICaopObj (IUnknown **ppICaopObj)
ICaoProvTaskの取得.

HRESULT | _GetICRDObj (IUnknown **ppICRDObj)
CRDプロバイダのICaoProvTaskの取得.

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

HRESULT | get_FileName (BSTR *pVal)
対応ファイル名の取得

HRESULT | get_VariableNames (BSTR bstrOption, VARIANT *pVal)
変数名リストの取得

HRESULT | get_Variables (ICaoVariables **ppICaoVariables)
変数コレクションの取得

HRESULT | AddVariable (BSTR bstrName, BSTR bstrOption, ICaoVariable **ppICaoVar)
変数オブジェクトの追加

HRESULT | Delete (BSTR bstrOption)
タスクの削除

HRESULT | Execute (VARIANT vntCommand, VARIANT *pVal)
拡張コマンドの実行

HRESULT | Start (long lMode, BSTR bstrOption)
タスクの開始

HRESULT | Stop (long lMode, BSTR bstrOption)
タスクの停止

HRESULT | CustomGetIDsOfNames (REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid)
IDispatch::GetIDsOfNames().

HRESULT | CustomInvoke (DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr)
IDispatch::Invoke().

解説

CAOのTaskクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoTaskを参照．
CaoTasksクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  CaoプロバイダのCaoProvTaskオブジェクトと１対１に対応する．

コンストラクタとデストラクタの解説

CCaoTask::CCaoTask ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoTask::~CCaoTask ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoTask::_GetICaopObj ( IUnknown ** ppICaopObj )

ICaoProvTaskの取得.

  スクリプトコードから直接アクセスは禁止されています(restricted)

引数:
ppICaopObj : [out] CaoProvTask IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoTask::_GetICRDObj ( IUnknown ** ppICRDObj )

CRDプロバイダのICaoProvTaskの取得.

  スクリプトコードから直接アクセスは禁止されています(restricted)

引数:
ppICRDObj : [out] CRDプロバイダのCaoProvTask IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoTask::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in]　vntArgs[0] - タスク名
          vntArgs[1] - タスク番号
          vntArgs[2] - CaoProvTask IFポインタ
          vntArgs[3] - CRDプロバイダの CaoProvTask IFポインタ
          vntArgs[4] - 書き込み属性フラグ
戻り値:
HRESULT

STDMETHODIMP CCaoTask::AddVariable | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoVariable ** | ppICaoVar
 | ) |

変数オブジェクトの追加

CaoVariables::Add()と同じ機能です．

引数:
bstrName | : [in] タスク名
bstrOption | : [in] オプション
ppICaoVar | : [out] CaoVariable IFポインタのアドレス
戻り値:
HRESULT

HRESULT CCaoTask::CustomGetIDsOfNames | ( | REFIID | riid,
 |  | LPOLESTR * | rgszNames,
 |  | UINT | cNames,
 |  | LCID | lcid,
 |  | DISPID * | rgdispid
 | ) | [virtual]

IDispatch::GetIDsOfNames().

  IDispatch::GetIDsOfNames()関数の機能拡張 BindCmds, BindExecの優先度で処理される．

引数:
riid | : [in] 予約
rgszNames | : [in] メソッド名リスト
cNames | : [in] メソッド名リストの要素数
lcid | : [in] ロケールID
rgdispid | : [in] DISPID
戻り値:
HRESULT

ICaoDispatchImpl< ICaoTask, piid,&LIBID_CAOLib >を再定義しています。

HRESULT CCaoTask::CustomInvoke | ( | DISPID | dispidMember,
 |  | REFIID | riid,
 |  | LCID | lcid,
 |  | WORD | wFlags,
 |  | DISPPARAMS * | pdispparams,
 |  | VARIANT * | pvarResult,
 |  | EXCEPINFO * | pexcepinfo,
 |  | UINT * | puArgErr
 | ) | [virtual]

IDispatch::Invoke().

  IDispatch::Invoke()関数の機能拡張

引数:
dispidMember | : [in] DISPID
riid | : [in] 予約
lcid | : [in] ロケールID
wFlags | : [in] 起動対象メソッドのコンテキストフラグ
pdispparams | : [in] メソッドに渡すパラメータ
pvarResult | : [in] メソッドコールの結果
pexcepinfo | : [in] 例外情報
puArgErr | : [in] エラーのあった先頭引数
戻り値:
HRESULT

ICaoDispatchImpl< ICaoTask, piid,&LIBID_CAOLib >を再定義しています。

STDMETHODIMP CCaoTask::Delete ( BSTR bstrOption )

タスクの削除

引数:
bstrOption : [in] オプション
戻り値:
HRESULT

STDMETHODIMP CCaoTask::Execute | ( | VARIANT | vntCommand,
 |  | VARIANT * | pVal
 | ) |

拡張コマンドの実行

引数:
vntCommand | : [in] コマンド
pVal | : [out] 結果
戻り値:
HRESULT

HRESULT CCaoTask::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoTask::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoTask::get_FileName ( BSTR * pVal )

対応ファイル名の取得

引数:
pVal : [out] ファイル名
戻り値:
HRESULT

STDMETHODIMP CCaoTask::get_VariableNames | ( | BSTR | bstrOption,
 |  | VARIANT * | pVal
 | ) |

変数名リストの取得

引数:
bstrOption | : [in] オプション
pVal | : [out] 変数名リスト
戻り値:
HRESULT

STDMETHODIMP CCaoTask::get_Variables ( ICaoVariables ** ppICaoVariables )

変数コレクションの取得

引数:
ppICaoVariables : [out] CaoVariables IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoTask::Start | ( | long | lMode,
 |  | BSTR | bstrOption
 | ) |

タスクの開始

  開始モードの値は以下のようになる．
  １：１サイクル実行，２：連続実行，３：１ステップ 送り，４：１ステップ 戻し

引数:
lMode | : [in] 開始モード
bstrOption | : [in] オプション
戻り値:
HRESULT

STDMETHODIMP CCaoTask::Stop | ( | long | lMode,
 |  | BSTR | bstrOption
 | ) |

タスクの停止

  停止モードの値は以下のようになる．
  ０：デフォルト停止，１：瞬時停止，２：ステップ停止，３：サイクル停止，４：初期化停止
  デフォルト停止は実際には何れかの停止方法をとる．

引数:
lMode | : [in] 停止モード
bstrOption | : [in] オプション
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoTask.h
  • CaoTask.cpp
Generated on Wed Dec 7 19:02:05 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoTask メンバ一覧

これは全メンバの一覧です。CCaoTask継承メンバも含んでいます。
_CCaoBaseTmpl() | _CCaoBaseTmpl< CCaoTask, pclsid, ICaoTask, piid > | [inline]
_CCaoProvConnectionObjTmpl() | _CCaoProvConnectionObjTmpl< CCaoTask,&CLSID_CaoTask, ICaoTask,&IID_ICaoTask, ICaoProvTask > | [inline]
_GetICaopObj(IUnknown **ppICaopObj) | CCaoTask |
_GetICRDObj(IUnknown **ppICRDObj) | CCaoTask |
_Initialize(VARIANT vntArgs[]) | CCaoTask |
_PutIndex(long lVal) | _CCaoBaseTmpl< CCaoTask, pclsid, ICaoTask, piid > | [inline]
AddVariable(BSTR bstrName, BSTR bstrOption, ICaoVariable **ppICaoVar) | CCaoTask |
CCaoTask() | CCaoTask | [inline]
CheckAccess(DWORD dwChkList) | _CCaoBaseTmpl< CCaoTask, pclsid, ICaoTask, piid > | [inline, protected]
CustomGetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | CCaoTask | [virtual]
CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | CCaoTask | [virtual]
Delete(BSTR bstrOption) | CCaoTask |
Execute(VARIANT vntCommand, VARIANT *pVal) | CCaoTask |
FinalConstruct() | CCaoTask |
FinalRelease() | CCaoTask |
get_Attribute(long *pVal) | _CCaoProvConnectionObjTmpl< CCaoTask,&CLSID_CaoTask, ICaoTask,&IID_ICaoTask, ICaoProvTask > | [inline]
get_FileName(BSTR *pVal) | CCaoTask |
get_Help(BSTR *pVal) | _CCaoProvConnectionObjTmpl< CCaoTask,&CLSID_CaoTask, ICaoTask,&IID_ICaoTask, ICaoProvTask > | [inline]
get_ID(VARIANT *pVal) | _CCaoProvConnectionObjTmpl< CCaoTask,&CLSID_CaoTask, ICaoTask,&IID_ICaoTask, ICaoProvTask > | [inline]
get_Index(long *pVal) | _CCaoBaseTmpl< CCaoTask, pclsid, ICaoTask, piid > | [inline]
get_Name(BSTR *pVal) | _CCaoBaseTmpl< CCaoTask, pclsid, ICaoTask, piid > | [inline]
get_Tag(VARIANT *pVal) | _CCaoProvConnectionObjTmpl< CCaoTask,&CLSID_CaoTask, ICaoTask,&IID_ICaoTask, ICaoProvTask > | [inline]
get_VariableNames(BSTR bstrOption, VARIANT *pVal) | CCaoTask |
get_Variables(ICaoVariables **ppICaoVariables) | CCaoTask |
GetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< ICaoTask, piid,&LIBID_CAOLib > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoBaseTmpl< CCaoTask, pclsid, ICaoTask, piid > | [inline]
Invoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< ICaoTask, piid,&LIBID_CAOLib > | [inline]
m_bstrName | _CCaoBaseTmpl< CCaoTask, pclsid, ICaoTask, piid > | [protected]
m_bWritable | _CCaoBaseTmpl< CCaoTask, pclsid, ICaoTask, piid > | [protected]
m_lIndex | _CCaoBaseTmpl< CCaoTask, pclsid, ICaoTask, piid > | [protected]
m_pICaopObj | _CCaoProvConnectionObjTmpl< CCaoTask,&CLSID_CaoTask, ICaoTask,&IID_ICaoTask, ICaoProvTask > | [protected]
m_pICRDObj | _CCaoProvConnectionObjTmpl< CCaoTask,&CLSID_CaoTask, ICaoTask,&IID_ICaoTask, ICaoProvTask > | [protected]
m_vntTag | _CCaoProvConnectionObjTmpl< CCaoTask,&CLSID_CaoTask, ICaoTask,&IID_ICaoTask, ICaoProvTask > | [protected]
put_ID(VARIANT newVal) | _CCaoProvConnectionObjTmpl< CCaoTask,&CLSID_CaoTask, ICaoTask,&IID_ICaoTask, ICaoProvTask > | [inline]
put_Tag(VARIANT newVal) | _CCaoProvConnectionObjTmpl< CCaoTask,&CLSID_CaoTask, ICaoTask,&IID_ICaoTask, ICaoProvTask > | [inline]
Start(long lMode, BSTR bstrOption) | CCaoTask |
Stop(long lMode, BSTR bstrOption) | CCaoTask |
~_CCaoBaseTmpl() | _CCaoBaseTmpl< CCaoTask, pclsid, ICaoTask, piid > | [inline]
~_CCaoProvConnectionObjTmpl() | _CCaoProvConnectionObjTmpl< CCaoTask,&CLSID_CaoTask, ICaoTask,&IID_ICaoTask, ICaoProvTask > | [inline]
~CCaoTask() | CCaoTask | [inline]
Generated on Wed Dec 7 19:02:05 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoTasks class Reference

クラス CCaoTasks の解説

CAOのTaskのコレクションクラス. [詳細]

#include <CaoTasks.h>

CCaoTasksに対する継承グラフ

[凡例]
CCaoTasksのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoTasks ()
コンストラクタ

~CCaoTasks ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | Add (BSTR bstrName, BSTR bstrOption, ICaoTask **ppICaoTask)
タスクオブジェクトの追加

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

解説

CAOのTaskのコレクションクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoTasksを参照．
CaoControllerクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
CaoTaskクラスのコレクションクラスとなっている．

コンストラクタとデストラクタの解説

CCaoTasks::CCaoTasks ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoTasks::~CCaoTasks ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoTasks::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in]　vntArgs[0] - 親オブジェクトのIFポインタ
          vntArgs[1] - 書き込み属性フラグ
          vntArgs[2] - 親オブジェクトのクラスNo
戻り値:
HRESULT

STDMETHODIMP CCaoTasks::Add | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoTask ** | ppICaoTask
 | ) |

タスクオブジェクトの追加

引数:
bstrName | : [in] タスク名
bstrOption | : [in] オプション
ppICaoTask | : [out] CaoTask IFポインタのアドレス
戻り値:
HRESULT

HRESULT CCaoTasks::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoTasks::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

このクラスの解説は次のファイルから生成されました:
  • CaoTasks.h
  • CaoTasks.cpp
Generated on Wed Dec 7 19:02:05 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoTasks メンバ一覧

これは全メンバの一覧です。CCaoTasks継承メンバも含んでいます。
_CCaoCollectionTmpl() | _CCaoCollectionTmpl< CCaoTasks,&CLSID_CaoTasks, ICaoTasks,&IID_ICaoTasks, ICaoTask > | [inline]
_Initialize(VARIANT vntArgs[]) | CCaoTasks |
Add(BSTR bstrName, BSTR bstrOption, ICaoTask **ppICaoTask) | CCaoTasks |
CCaoTasks() | CCaoTasks | [inline]
Clear() | _CCaoCollectionTmpl< CCaoTasks,&CLSID_CaoTasks, ICaoTasks,&IID_ICaoTasks, ICaoTask > | [inline]
FinalConstruct() | CCaoTasks |
FinalRelease() | CCaoTasks |
GenerateIndex(long *lVal) | _CCaoCollectionTmpl< CCaoTasks,&CLSID_CaoTasks, ICaoTasks,&IID_ICaoTasks, ICaoTask > | [inline, protected]
get__NewEnum(LPUNKNOWN *pVal) | _CCaoCollectionTmpl< CCaoTasks,&CLSID_CaoTasks, ICaoTasks,&IID_ICaoTasks, ICaoTask > | [inline]
get_Count(long *pVal) | _CCaoCollectionTmpl< CCaoTasks,&CLSID_CaoTasks, ICaoTasks,&IID_ICaoTasks, ICaoTask > | [inline]
GetIndex(VARIANT vntIndex, long *lVal) | _CCaoCollectionTmpl< CCaoTasks,&CLSID_CaoTasks, ICaoTasks,&IID_ICaoTasks, ICaoTask > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoCollectionTmpl< CCaoTasks,&CLSID_CaoTasks, ICaoTasks,&IID_ICaoTasks, ICaoTask > | [inline]
IsMember(VARIANT Index, VARIANT_BOOL *pVal) | _CCaoCollectionTmpl< CCaoTasks,&CLSID_CaoTasks, ICaoTasks,&IID_ICaoTasks, ICaoTask > | [inline]
Item(VARIANT Index, ICaoTask **ppItem) | _CCaoCollectionTmpl< CCaoTasks,&CLSID_CaoTasks, ICaoTasks,&IID_ICaoTasks, ICaoTask > | [inline]
m_map | _CCaoCollectionTmpl< CCaoTasks,&CLSID_CaoTasks, ICaoTasks,&IID_ICaoTasks, ICaoTask > | [protected]
Remove(VARIANT Index) | _CCaoCollectionTmpl< CCaoTasks,&CLSID_CaoTasks, ICaoTasks,&IID_ICaoTasks, ICaoTask > | [inline]
~_CCaoCollectionTmpl() | _CCaoCollectionTmpl< CCaoTasks,&CLSID_CaoTasks, ICaoTasks,&IID_ICaoTasks, ICaoTask > | [inline]
~CCaoTasks() | CCaoTasks | [inline]
Generated on Wed Dec 7 19:02:05 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoVariable class Reference

クラス CCaoVariable の解説

CAOのVariableクラス. [詳細]

#include <CaoVariable.h>

CCaoVariableに対する継承グラフ

[凡例]
CCaoVariableのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoVariable ()
~CCaoVariable ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

HRESULT | get_DateTime (VARIANT *pVal)
値のタイムスタンプの取得

HRESULT | get_Value (VARIANT *pVal)
変数の値の取得

HRESULT | put_Value (VARIANT newVal)
変数の値の変更

HRESULT | get_Microsecond (long *pVal)
マイクロ秒のタイムスタンプの取得

解説

CAOのVariableクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoVariableを参照．
CaoVariablesクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  CaoプロバイダのCaoProvVariableオブジェクトと１対１に対応する．

コンストラクタとデストラクタの解説

CCaoVariable::CCaoVariable ( ) [inline]

CCaoVariable::~CCaoVariable ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoVariable::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in]　vntArgs[0] - 変数名 　　　　　vntArgs[1] - 変数番号 　　　　　vntArgs[2] - CaoProvVariable IFポインタ 　　　　　vntArgs[3] - CRDプロバイダの CaoProvVariable IFポインタ 　　　　　vntArgs[4] - 書き込み属性フラグ
戻り値:
HRESULT

HRESULT CCaoVariable::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoVariable::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoVariable::get_DateTime ( VARIANT * pVal )

値のタイムスタンプの取得

引数:
pVal : [in] 時刻データ
戻り値:
HRESULT

STDMETHODIMP CCaoVariable::get_Microsecond ( long * pVal )

マイクロ秒のタイムスタンプの取得

引数:
pVal : [in] マイクロ秒のタイムスタンプ
戻り値:
HRESULT

STDMETHODIMP CCaoVariable::get_Value ( VARIANT * pVal )

変数の値の取得

引数:
pVal : [in] 変数の値
戻り値:
HRESULT

STDMETHODIMP CCaoVariable::put_Value ( VARIANT newVal )

変数の値の変更

引数:
newVal : [in] 変数の値
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoVariable.h
  • CaoVariable.cpp
Generated on Wed Dec 7 19:02:05 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoVariable メンバ一覧

これは全メンバの一覧です。CCaoVariable継承メンバも含んでいます。
_CCaoBaseTmpl() | _CCaoBaseTmpl< CCaoVariable, pclsid, ICaoVariable, piid > | [inline]
_CCaoProvConnectionObjTmpl() | _CCaoProvConnectionObjTmpl< CCaoVariable,&CLSID_CaoVariable, ICaoVariable,&IID_ICaoVariable, ICaoProvVariable > | [inline]
_Initialize(VARIANT vntArgs[]) | CCaoVariable |
_PutIndex(long lVal) | _CCaoBaseTmpl< CCaoVariable, pclsid, ICaoVariable, piid > | [inline]
CCaoVariable() | CCaoVariable | [inline]
CheckAccess(DWORD dwChkList) | _CCaoBaseTmpl< CCaoVariable, pclsid, ICaoVariable, piid > | [inline, protected]
CustomGetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< ICaoVariable, piid,&LIBID_CAOLib > | [inline, virtual]
CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< ICaoVariable, piid,&LIBID_CAOLib > | [inline, virtual]
FinalConstruct() | CCaoVariable |
FinalRelease() | CCaoVariable |
get_Attribute(long *pVal) | _CCaoProvConnectionObjTmpl< CCaoVariable,&CLSID_CaoVariable, ICaoVariable,&IID_ICaoVariable, ICaoProvVariable > | [inline]
get_DateTime(VARIANT *pVal) | CCaoVariable |
get_Help(BSTR *pVal) | _CCaoProvConnectionObjTmpl< CCaoVariable,&CLSID_CaoVariable, ICaoVariable,&IID_ICaoVariable, ICaoProvVariable > | [inline]
get_ID(VARIANT *pVal) | _CCaoProvConnectionObjTmpl< CCaoVariable,&CLSID_CaoVariable, ICaoVariable,&IID_ICaoVariable, ICaoProvVariable > | [inline]
get_Index(long *pVal) | _CCaoBaseTmpl< CCaoVariable, pclsid, ICaoVariable, piid > | [inline]
get_Microsecond(long *pVal) | CCaoVariable |
get_Name(BSTR *pVal) | _CCaoBaseTmpl< CCaoVariable, pclsid, ICaoVariable, piid > | [inline]
get_Tag(VARIANT *pVal) | _CCaoProvConnectionObjTmpl< CCaoVariable,&CLSID_CaoVariable, ICaoVariable,&IID_ICaoVariable, ICaoProvVariable > | [inline]
get_Value(VARIANT *pVal) | CCaoVariable |
GetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< ICaoVariable, piid,&LIBID_CAOLib > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoBaseTmpl< CCaoVariable, pclsid, ICaoVariable, piid > | [inline]
Invoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< ICaoVariable, piid,&LIBID_CAOLib > | [inline]
m_bstrName | _CCaoBaseTmpl< CCaoVariable, pclsid, ICaoVariable, piid > | [protected]
m_bWritable | _CCaoBaseTmpl< CCaoVariable, pclsid, ICaoVariable, piid > | [protected]
m_lIndex | _CCaoBaseTmpl< CCaoVariable, pclsid, ICaoVariable, piid > | [protected]
m_pICaopObj | _CCaoProvConnectionObjTmpl< CCaoVariable,&CLSID_CaoVariable, ICaoVariable,&IID_ICaoVariable, ICaoProvVariable > | [protected]
m_pICRDObj | _CCaoProvConnectionObjTmpl< CCaoVariable,&CLSID_CaoVariable, ICaoVariable,&IID_ICaoVariable, ICaoProvVariable > | [protected]
m_vntTag | _CCaoProvConnectionObjTmpl< CCaoVariable,&CLSID_CaoVariable, ICaoVariable,&IID_ICaoVariable, ICaoProvVariable > | [protected]
put_ID(VARIANT newVal) | _CCaoProvConnectionObjTmpl< CCaoVariable,&CLSID_CaoVariable, ICaoVariable,&IID_ICaoVariable, ICaoProvVariable > | [inline]
put_Tag(VARIANT newVal) | _CCaoProvConnectionObjTmpl< CCaoVariable,&CLSID_CaoVariable, ICaoVariable,&IID_ICaoVariable, ICaoProvVariable > | [inline]
put_Value(VARIANT newVal) | CCaoVariable |
~_CCaoBaseTmpl() | _CCaoBaseTmpl< CCaoVariable, pclsid, ICaoVariable, piid > | [inline]
~_CCaoProvConnectionObjTmpl() | _CCaoProvConnectionObjTmpl< CCaoVariable,&CLSID_CaoVariable, ICaoVariable,&IID_ICaoVariable, ICaoProvVariable > | [inline]
~CCaoVariable() | CCaoVariable | [inline]
Generated on Wed Dec 7 19:02:05 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoVariables class Reference

クラス CCaoVariables の解説

CAOのVariableのコレクションクラス. [詳細]

#include <CaoVariables.h>

CCaoVariablesに対する継承グラフ

[凡例]
CCaoVariablesのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoVariables ()
~CCaoVariables ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | Add (BSTR bstrName, BSTR bstrOption, ICaoVariable **ppICaoVar)
変数オブジェクトの追加

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

解説

CAOのVariableのコレクションクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoVariablesを参照．
このクラスは以下のクラスから呼び出される.
   - CaoController 　 - CaoExtension 　 - CaoFile 　 - CaoRobot 　 - CaoTask 　外部からインスタンスの作成は不可能．
CaoVariableクラスのコレクションクラスとなっている．

コンストラクタとデストラクタの解説

CCaoVariables::CCaoVariables ( ) [inline]

CCaoVariables::~CCaoVariables ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoVariables::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in]　vntArgs[0] - 親オブジェクトのIFポインタ
          vntArgs[1] - 書き込み属性フラグ
          vntArgs[2] - 親オブジェクトのクラスNo
戻り値:
HRESULT

STDMETHODIMP CCaoVariables::Add | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoVariable ** | ppICaoVar
 | ) |

変数オブジェクトの追加

引数:
bstrName | : [in] 変数名名
bstrOption | : [in] オプション
ppICaoVar | : [out] CaoVariable IFポインタのアドレス
戻り値:
HRESULT

HRESULT CCaoVariables::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoVariables::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

このクラスの解説は次のファイルから生成されました:
  • CaoVariables.h
  • CaoVariables.cpp
Generated on Wed Dec 7 19:02:06 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoVariables メンバ一覧

これは全メンバの一覧です。CCaoVariables継承メンバも含んでいます。
_CCaoCollectionTmpl() | _CCaoCollectionTmpl< CCaoVariables,&CLSID_CaoVariables, ICaoVariables,&IID_ICaoVariables, ICaoVariable > | [inline]
_Initialize(VARIANT vntArgs[]) | CCaoVariables |
Add(BSTR bstrName, BSTR bstrOption, ICaoVariable **ppICaoVar) | CCaoVariables |
CCaoVariables() | CCaoVariables | [inline]
Clear() | _CCaoCollectionTmpl< CCaoVariables,&CLSID_CaoVariables, ICaoVariables,&IID_ICaoVariables, ICaoVariable > | [inline]
FinalConstruct() | CCaoVariables |
FinalRelease() | CCaoVariables |
GenerateIndex(long *lVal) | _CCaoCollectionTmpl< CCaoVariables,&CLSID_CaoVariables, ICaoVariables,&IID_ICaoVariables, ICaoVariable > | [inline, protected]
get__NewEnum(LPUNKNOWN *pVal) | _CCaoCollectionTmpl< CCaoVariables,&CLSID_CaoVariables, ICaoVariables,&IID_ICaoVariables, ICaoVariable > | [inline]
get_Count(long *pVal) | _CCaoCollectionTmpl< CCaoVariables,&CLSID_CaoVariables, ICaoVariables,&IID_ICaoVariables, ICaoVariable > | [inline]
GetIndex(VARIANT vntIndex, long *lVal) | _CCaoCollectionTmpl< CCaoVariables,&CLSID_CaoVariables, ICaoVariables,&IID_ICaoVariables, ICaoVariable > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoCollectionTmpl< CCaoVariables,&CLSID_CaoVariables, ICaoVariables,&IID_ICaoVariables, ICaoVariable > | [inline]
IsMember(VARIANT Index, VARIANT_BOOL *pVal) | _CCaoCollectionTmpl< CCaoVariables,&CLSID_CaoVariables, ICaoVariables,&IID_ICaoVariables, ICaoVariable > | [inline]
Item(VARIANT Index, ICaoVariable **ppItem) | _CCaoCollectionTmpl< CCaoVariables,&CLSID_CaoVariables, ICaoVariables,&IID_ICaoVariables, ICaoVariable > | [inline]
m_map | _CCaoCollectionTmpl< CCaoVariables,&CLSID_CaoVariables, ICaoVariables,&IID_ICaoVariables, ICaoVariable > | [protected]
Remove(VARIANT Index) | _CCaoCollectionTmpl< CCaoVariables,&CLSID_CaoVariables, ICaoVariables,&IID_ICaoVariables, ICaoVariable > | [inline]
~_CCaoCollectionTmpl() | _CCaoCollectionTmpl< CCaoVariables,&CLSID_CaoVariables, ICaoVariables,&IID_ICaoVariables, ICaoVariable > | [inline]
~CCaoVariables() | CCaoVariables | [inline]
Generated on Wed Dec 7 19:02:06 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoWorkspace class Reference

クラス CCaoWorkspace の解説

CAOのWorkspaceクラス. [詳細]

#include <CaoWorkspace.h>

CCaoWorkspaceに対する継承グラフ

[凡例]
CCaoWorkspaceのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoWorkspace ()
コンストラクタ

~CCaoWorkspace ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | get_Controllers (ICaoControllers **ppICaoCtrls)
コントローラコレクションの取得

HRESULT | get_ProviderNames (BSTR bstrOption, VARIANT *pVal)
プロバイダ名リストの取得

HRESULT | AddController (BSTR bstrController, BSTR bstrProvider, BSTR bstrMachine, BSTR bstrOption, ICaoController **ppICaoCtrl)
コントローラオブジェクトの追加

HRESULT | Execute (VARIANT vntCommand, VARIANT *pVal)
拡張コマンドの実行

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

解説

CAOのWorkspaceクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoWorkspaceを参照．
CaoWorkSpacesクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．

コンストラクタとデストラクタの解説

CCaoWorkspace::CCaoWorkspace ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoWorkspace::~CCaoWorkspace ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoWorkspace::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in]　vntArgs[0] - CaoWorkspace名 　　　　　vntArgs[1] - CaoWorkspace番号
戻り値:
HRESULT

STDMETHODIMP CCaoWorkspace::AddController | ( | BSTR | bstrController,
 |  | BSTR | bstrProvider,
 |  | BSTR | bstrMachine,
 |  | BSTR | bstrOption,
 |  | ICaoController ** | ppICaoCtrl
 | ) |

コントローラオブジェクトの追加

CaoControllers::Add()と同じ機能です．

引数:
bstrController | : [in] コントローラ名
bstrProvider | : [in] プロバイダ名
bstrMachine | : [in] マシン名
bstrOption | : [in] オプション
ppICaoCtrl | : [out] CaoController IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoWorkspace::Execute | ( | VARIANT | vntCommand,
 |  | VARIANT * | pVal
 | ) |

拡張コマンドの実行

引数:
vntCommand | : [in] コマンド
pVal | : [out] 結果
戻り値:
HRESULT

HRESULT CCaoWorkspace::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoWorkspace::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CCaoWorkspace::get_Controllers ( ICaoControllers ** ppICaoCtrls )

コントローラコレクションの取得

引数:
ppICaoCtrls : [out] CaoControllers IFポインタのアドレス
戻り値:
HRESULT

STDMETHODIMP CCaoWorkspace::get_ProviderNames | ( | BSTR | bstrOption,
 |  | VARIANT * | pVal
 | ) |

プロバイダ名リストの取得

  この関数を呼び出した時点での最新のテーブルを返す．

引数:
bstrOption | : [in] オプション
pVal | : [out] プロバイダ名リスト
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CaoWorkspace.h
  • CaoWorkspace.cpp
Generated on Wed Dec 7 19:02:06 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoWorkspace メンバ一覧

これは全メンバの一覧です。CCaoWorkspace継承メンバも含んでいます。
_CCaoBaseTmpl() | _CCaoBaseTmpl< CCaoWorkspace,&CLSID_CaoWorkspace, ICaoWorkspace,&IID_ICaoWorkspace > | [inline]
_Initialize(VARIANT vntArgs[]) | CCaoWorkspace |
_PutIndex(long lVal) | _CCaoBaseTmpl< CCaoWorkspace,&CLSID_CaoWorkspace, ICaoWorkspace,&IID_ICaoWorkspace > | [inline]
AddController(BSTR bstrController, BSTR bstrProvider, BSTR bstrMachine, BSTR bstrOption, ICaoController **ppICaoCtrl) | CCaoWorkspace |
CCaoWorkspace() | CCaoWorkspace | [inline]
CheckAccess(DWORD dwChkList) | _CCaoBaseTmpl< CCaoWorkspace,&CLSID_CaoWorkspace, ICaoWorkspace,&IID_ICaoWorkspace > | [inline, protected]
CustomGetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< ICaoWorkspace, piid,&LIBID_CAOLib > | [inline, virtual]
CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< ICaoWorkspace, piid,&LIBID_CAOLib > | [inline, virtual]
Execute(VARIANT vntCommand, VARIANT *pVal) | CCaoWorkspace |
FinalConstruct() | CCaoWorkspace |
FinalRelease() | CCaoWorkspace |
get_Controllers(ICaoControllers **ppICaoCtrls) | CCaoWorkspace |
get_Index(long *pVal) | _CCaoBaseTmpl< CCaoWorkspace,&CLSID_CaoWorkspace, ICaoWorkspace,&IID_ICaoWorkspace > | [inline]
get_Name(BSTR *pVal) | _CCaoBaseTmpl< CCaoWorkspace,&CLSID_CaoWorkspace, ICaoWorkspace,&IID_ICaoWorkspace > | [inline]
get_ProviderNames(BSTR bstrOption, VARIANT *pVal) | CCaoWorkspace |
GetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< ICaoWorkspace, piid,&LIBID_CAOLib > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoBaseTmpl< CCaoWorkspace,&CLSID_CaoWorkspace, ICaoWorkspace,&IID_ICaoWorkspace > | [inline]
Invoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< ICaoWorkspace, piid,&LIBID_CAOLib > | [inline]
m_bstrName | _CCaoBaseTmpl< CCaoWorkspace,&CLSID_CaoWorkspace, ICaoWorkspace,&IID_ICaoWorkspace > | [protected]
m_bWritable | _CCaoBaseTmpl< CCaoWorkspace,&CLSID_CaoWorkspace, ICaoWorkspace,&IID_ICaoWorkspace > | [protected]
m_lIndex | _CCaoBaseTmpl< CCaoWorkspace,&CLSID_CaoWorkspace, ICaoWorkspace,&IID_ICaoWorkspace > | [protected]
~_CCaoBaseTmpl() | _CCaoBaseTmpl< CCaoWorkspace,&CLSID_CaoWorkspace, ICaoWorkspace,&IID_ICaoWorkspace > | [inline]
~CCaoWorkspace() | CCaoWorkspace | [inline]
Generated on Wed Dec 7 19:02:06 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CCaoWorkspaces class Reference

クラス CCaoWorkspaces の解説

CAOのWorkspaceのコレクションクラス. [詳細]

#include <CaoWorkspaces.h>

CCaoWorkspacesに対する継承グラフ

[凡例]
CCaoWorkspacesのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CCaoWorkspaces ()
コンストラクタ

~CCaoWorkspaces ()
デストラクタ

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | Add (BSTR bstrName, BSTR bstrOption, ICaoWorkspace **ppICaoWS)
ワークスペースオブジェクトの追加

解説

CAOのWorkspaceのコレクションクラス.

デュアルインターフェースを持つCOMのクラス．詳細はICaoWorkspacesを参照．
CaoEngineクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
CaoWorkspaceクラスのコレクションクラスとなっている．

コンストラクタとデストラクタの解説

CCaoWorkspaces::CCaoWorkspaces ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CCaoWorkspaces::~CCaoWorkspaces ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CCaoWorkspaces::Add | ( | BSTR | bstrName,
 |  | BSTR | bstrOption,
 |  | ICaoWorkspace ** | ppICaoWS
 | ) |

ワークスペースオブジェクトの追加

引数:
bstrName | : [in] ワークスペース名
bstrOption | : [in] オプション
ppICaoWS | : [out] CaoWorkspace IFポインタのアドレス
戻り値:
HRESULT

HRESULT CCaoWorkspaces::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CCaoWorkspaces::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

このクラスの解説は次のファイルから生成されました:
  • CaoWorkspaces.h
  • CaoWorkspaces.cpp
Generated on Wed Dec 7 19:02:06 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CCaoWorkspaces メンバ一覧

これは全メンバの一覧です。CCaoWorkspaces継承メンバも含んでいます。
_CCaoCollectionTmpl() | _CCaoCollectionTmpl< CCaoWorkspaces,&CLSID_CaoWorkspaces, ICaoWorkspaces,&IID_ICaoWorkspaces, ICaoWorkspace > | [inline]
Add(BSTR bstrName, BSTR bstrOption, ICaoWorkspace **ppICaoWS) | CCaoWorkspaces |
CCaoWorkspaces() | CCaoWorkspaces | [inline]
Clear() | _CCaoCollectionTmpl< CCaoWorkspaces,&CLSID_CaoWorkspaces, ICaoWorkspaces,&IID_ICaoWorkspaces, ICaoWorkspace > | [inline]
FinalConstruct() | CCaoWorkspaces |
FinalRelease() | CCaoWorkspaces |
GenerateIndex(long *lVal) | _CCaoCollectionTmpl< CCaoWorkspaces,&CLSID_CaoWorkspaces, ICaoWorkspaces,&IID_ICaoWorkspaces, ICaoWorkspace > | [inline, protected]
get__NewEnum(LPUNKNOWN *pVal) | _CCaoCollectionTmpl< CCaoWorkspaces,&CLSID_CaoWorkspaces, ICaoWorkspaces,&IID_ICaoWorkspaces, ICaoWorkspace > | [inline]
get_Count(long *pVal) | _CCaoCollectionTmpl< CCaoWorkspaces,&CLSID_CaoWorkspaces, ICaoWorkspaces,&IID_ICaoWorkspaces, ICaoWorkspace > | [inline]
GetIndex(VARIANT vntIndex, long *lVal) | _CCaoCollectionTmpl< CCaoWorkspaces,&CLSID_CaoWorkspaces, ICaoWorkspaces,&IID_ICaoWorkspaces, ICaoWorkspace > | [inline]
InterfaceSupportsErrorInfo(REFIID riid) | _CCaoCollectionTmpl< CCaoWorkspaces,&CLSID_CaoWorkspaces, ICaoWorkspaces,&IID_ICaoWorkspaces, ICaoWorkspace > | [inline]
IsMember(VARIANT Index, VARIANT_BOOL *pVal) | _CCaoCollectionTmpl< CCaoWorkspaces,&CLSID_CaoWorkspaces, ICaoWorkspaces,&IID_ICaoWorkspaces, ICaoWorkspace > | [inline]
Item(VARIANT Index, ICaoWorkspace **ppItem) | _CCaoCollectionTmpl< CCaoWorkspaces,&CLSID_CaoWorkspaces, ICaoWorkspaces,&IID_ICaoWorkspaces, ICaoWorkspace > | [inline]
m_map | _CCaoCollectionTmpl< CCaoWorkspaces,&CLSID_CaoWorkspaces, ICaoWorkspaces,&IID_ICaoWorkspaces, ICaoWorkspace > | [protected]
Remove(VARIANT Index) | _CCaoCollectionTmpl< CCaoWorkspaces,&CLSID_CaoWorkspaces, ICaoWorkspaces,&IID_ICaoWorkspaces, ICaoWorkspace > | [inline]
~_CCaoCollectionTmpl() | _CCaoCollectionTmpl< CCaoWorkspaces,&CLSID_CaoWorkspaces, ICaoWorkspaces,&IID_ICaoWorkspaces, ICaoWorkspace > | [inline]
~CCaoWorkspaces() | CCaoWorkspaces | [inline]
Generated on Wed Dec 7 19:02:06 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CComCoClass class Reference

クラス CComCoClass の解説

CComCoClassに対する継承グラフ

[凡例]
このクラスの解説は次のファイルから生成されました:
  • CaoObjectTmpl.h
Generated on Wed Dec 7 19:02:07 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CComObjectRootEx class Reference

クラス CComObjectRootEx の解説

CComObjectRootExに対する継承グラフ

[凡例]
このクラスの解説は次のファイルから生成されました:
  • CaoObjectTmpl.h
Generated on Wed Dec 7 19:02:08 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CEventSink class Reference

クラス CEventSink の解説

CAOのイベントシンククラス. [詳細]

#include <EventSink.h>

CEventSinkに対する継承グラフ

[凡例]
CEventSinkのコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

CEventSink ()
コンストラクタ

~CEventSink ()
デストラクタ

HRESULT | InterfaceSupportsErrorInfo (REFIID riid)
オートメーションIFのエラーオブジェクトのサポート判定

HRESULT | FinalConstruct ()
ファイナルコンストラクタ

void | FinalRelease ()
ファイナルデストラクタ

HRESULT | _Initialize (VARIANT vntArgs[])
初期化処理

HRESULT | _Terminate ()
後処理

HRESULT | OnMessage (IUnknown *pVal, long lOption)
OnMessageのイベント処理.

解説

CAOのイベントシンククラス.

シンクインターフェースを持つCOMのクラス．詳細はIEventSinkを参照．
CaoControllerクラスから呼び出されるクラス．外部からインスタンスの作成は不可能．
  プロバイダからのOnMessageイベントを受け取る．

コンストラクタとデストラクタの解説

CEventSink::CEventSink ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CEventSink::~CEventSink ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

STDMETHODIMP CEventSink::_Initialize ( VARIANT vntArgs[] )

初期化処理

  オブジェクト生成時の初期化は FinalConstruct() を使うこと．

引数:
vntArgs [] : [in]　vntArgs[0] - CaoControllerのIFポインタ
          vntArgs[1] - CaoProvControllerのIFポインタ
戻り値:
HRESULT

STDMETHODIMP CEventSink::_Terminate ( )

後処理

  オブジェクト消滅時の後処理は FinalRelease() を使うこと．

戻り値:
HRESULT

HRESULT CEventSink::FinalConstruct ( )

ファイナルコンストラクタ

オブジェクト生成時に一度だけ呼ばれます．

void CEventSink::FinalRelease ( )

ファイナルデストラクタ

オブジェクト消去時に一度だけ呼ばれます．

STDMETHODIMP CEventSink::InterfaceSupportsErrorInfo ( REFIID riid )

オートメーションIFのエラーオブジェクトのサポート判定

riid に指定されたインターフェイスがIErrorInfo インターフェイスをサポートするかどうかを示す．

引数:
riid : [in] インタフェース
戻り値:
HRESULT

STDMETHODIMP CEventSink::OnMessage | ( | IUnknown * | pVal,
 |  | long | lOption
 | ) |

OnMessageのイベント処理.

  CaoProviderで発生したOnMessageイベントを処理する．

引数:
pVal | : [in]　CaoPropMessageのIFポインタ
lOption | : [in]メッセージオプション
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • EventSink.h
  • EventSink.cpp
Generated on Wed Dec 7 19:02:08 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CEventSink メンバ一覧

これは全メンバの一覧です。CEventSink継承メンバも含んでいます。
_Initialize(VARIANT vntArgs[]) | CEventSink |
_Terminate() | CEventSink |
CEventSink() | CEventSink | [inline]
FinalConstruct() | CEventSink |
FinalRelease() | CEventSink |
InterfaceSupportsErrorInfo(REFIID riid) | CEventSink |
OnMessage(IUnknown *pVal, long lOption) | CEventSink |
~CEventSink() | CEventSink | [inline]
Generated on Wed Dec 7 19:02:08 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CPreload class Reference

クラス CPreload の解説

オブジェクト自動登録クラス 　 　指定したCaoWorkspaceにCRDファイルのオブジェクト構造を登録します。 [詳細]

#include <Preload.h>

すべてのメンバ一覧

Public メソッド

CPreload ()
virtual | ~CPreload ()
HRESULT | PreloadObject (ICaoWorkspace *pICaoWS, BSTR bstrCRDFile)
オブジェクトの自動生成

解説

オブジェクト自動登録クラス 　 　指定したCaoWorkspaceにCRDファイルのオブジェクト構造を登録します。

コンストラクタとデストラクタの解説

CPreload::CPreload ( ) [inline]

virtual CPreload::~CPreload ( ) [inline, virtual]

メソッドの解説

HRESULT CPreload::PreloadObject | ( | ICaoWorkspace * | pICaoWS,
 |  | BSTR | bstrCRDFile
 | ) | [inline]

オブジェクトの自動生成

  指定されたCRDファイルと同じオブジェクト構造を生成します。

引数:
pICaoWS | : [in] オブジェクトを追加するワークスペース
bstrCRDFile | : [in] CRDファイルのパス
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • Preload.h
Generated on Wed Dec 7 19:02:08 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CPreload メンバ一覧

これは全メンバの一覧です。CPreload継承メンバも含んでいます。
CPreload() | CPreload | [inline]
PreloadObject(ICaoWorkspace *pICaoWS, BSTR bstrCRDFile) | CPreload | [inline]
~CPreload() | CPreload | [inline, virtual]
Generated on Wed Dec 7 19:02:08 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


TemplateCProxy_ICaoCommandsEvents< T > class Reference

クラス テンプレートCProxy_ICaoCommandsEvents< T > の解説

CAOのコントローライベントプロキシテンプレートクラス. [詳細]

#include <CAOCP.h>

CProxy_ICaoCommandsEvents< T >に対する継承グラフ

[凡例]
CProxy_ICaoCommandsEvents< T >のコラボレーション図

[凡例]
すべてのメンバ一覧

解説

template<class T>
class CProxy_ICaoCommandsEvents< T >

CAOのコントローライベントプロキシテンプレートクラス.

CaoControllerクラスのイベントのコネクションポインタを公開するテンプレート．

このクラスの解説は次のファイルから生成されました:
  • CAOCP.h
Generated on Wed Dec 7 19:02:09 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CProxy_ICaoCommandsEvents< T > メンバ一覧

これは全メンバの一覧です。CProxy_ICaoCommandsEvents< T >継承メンバも含んでいます。
Fire_ExecuteComplete(long lIndex) CProxy_ICaoExecuteCompleteEvent< T, 0x1 > [inline]
Generated on Wed Dec 7 19:02:09 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


TemplateCProxy_ICaoControllerEvents< T > class Reference

クラス テンプレートCProxy_ICaoControllerEvents< T > の解説

CAOのコントローライベントプロキシテンプレートクラス. [詳細]

#include <CAOCP.h>

CProxy_ICaoControllerEvents< T >に対する継承グラフ

[凡例]
CProxy_ICaoControllerEvents< T >のコラボレーション図

[凡例]
すべてのメンバ一覧

解説

template<class T>
class CProxy_ICaoControllerEvents< T >

CAOのコントローライベントプロキシテンプレートクラス.

CaoControllerクラスのイベントのコネクションポインタを公開するテンプレート．

このクラスの解説は次のファイルから生成されました:
  • CAOCP.h
Generated on Wed Dec 7 19:02:09 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CProxy_ICaoControllerEvents< T > メンバ一覧

これは全メンバの一覧です。CProxy_ICaoControllerEvents< T >継承メンバも含んでいます。
CProxy_ICaoOnMessageEvent() | CProxy_ICaoOnMessageEvent< T, 0x1 > | [inline]
CreateMessage(ICaoProvMessage *pICaopMess, ICaoMessage **ppVal) | CProxy_ICaoOnMessageEvent< T, 0x1 > | [inline]
Fire_OnMessage(IUnknown *pVal) | CProxy_ICaoOnMessageEvent< T, 0x1 > | [inline]
Generated on Wed Dec 7 19:02:09 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


TemplateCProxy_ICaoExecuteCompleteEvent< T, dispid > class Reference

クラス テンプレートCProxy_ICaoExecuteCompleteEvent< T, dispid > の解説

CAOのExecuteCompleteイベントテンプレートクラス. [詳細]

#include <CAOCP.h>

CProxy_ICaoExecuteCompleteEvent< T, dispid >に対する継承グラフ

[凡例]
すべてのメンバ一覧

Public メソッド

HRESULT Fire_ExecuteComplete (long lIndex)

解説

template<class T, DISPID dispid>
class CProxy_ICaoExecuteCompleteEvent< T, dispid >

CAOのExecuteCompleteイベントテンプレートクラス.

クライアントに対してイベントのコネクションポインタを公開するテンプレート．
ExecuteCompleteイベントのIFを持つ．
このテンプレートクラスを継承することによってExecuteCompleteイベントを発生させることが可能となる．

メソッドの解説

template<class T, DISPID dispid>
HRESULT CProxy_ICaoExecuteCompleteEvent< T, dispid >::Fire_ExecuteComplete ( long lIndex ) [inline]

このクラスの解説は次のファイルから生成されました:
  • CAOCP.h
Generated on Wed Dec 7 19:02:09 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CProxy_ICaoExecuteCompleteEvent< T, dispid > メンバ一覧

これは全メンバの一覧です。CProxy_ICaoExecuteCompleteEvent< T, dispid >継承メンバも含んでいます。
Fire_ExecuteComplete(long lIndex) CProxy_ICaoExecuteCompleteEvent< T, dispid > [inline]
Generated on Wed Dec 7 19:02:09 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


TemplateCProxy_ICaoOnMessageEvent< T, dispid > class Reference

クラス テンプレートCProxy_ICaoOnMessageEvent< T, dispid > の解説

CAOのOnMessageイベントテンプレートクラス. [詳細]

#include <CAOCP.h>

CProxy_ICaoOnMessageEvent< T, dispid >に対する継承グラフ

[凡例]
すべてのメンバ一覧

Public メソッド

CProxy_ICaoOnMessageEvent ()
HRESULT | Fire_OnMessage (IUnknown *pVal)
OnMessageイベントの発生.

HRESULT | CreateMessage (ICaoProvMessage *pICaopMess, ICaoMessage **ppVal)
ICaoMessageオブジェクトの作成.

解説

template<class T, DISPID dispid>
class CProxy_ICaoOnMessageEvent< T, dispid >

CAOのOnMessageイベントテンプレートクラス.

クライアントに対してイベントのコネクションポインタを公開するテンプレート．
OnMessageイベントのIFを持つ．
このテンプレートクラスを継承することによってOnMessageイベントを発生させることが可能となる．

コンストラクタとデストラクタの解説

template<class T, DISPID dispid>
CProxy_ICaoOnMessageEvent< T, dispid >::CProxy_ICaoOnMessageEvent ( ) [inline]

メソッドの解説

template<class T, DISPID dispid>
HRESULT CProxy_ICaoOnMessageEvent< T, dispid >::CreateMessage | ( | ICaoProvMessage * | pICaopMess,
 |  | ICaoMessage ** | ppVal
 | ) | [inline]

ICaoMessageオブジェクトの作成.

引数:
pICaopMess | : [in] ICaoProvMessage IFポインタ
ppVal | : [out] ICaoMessage IFポインタ
戻り値:
HRESULT

template<class T, DISPID dispid>
HRESULT CProxy_ICaoOnMessageEvent< T, dispid >::Fire_OnMessage ( IUnknown * pVal ) [inline]

OnMessageイベントの発生.

引数:
pVal : [in] ICaoProvMessage IFポインタ
戻り値:
HRESULT

このクラスの解説は次のファイルから生成されました:
  • CAOCP.h
Generated on Wed Dec 7 19:02:09 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CProxy_ICaoOnMessageEvent< T, dispid > メンバ一覧

これは全メンバの一覧です。CProxy_ICaoOnMessageEvent< T, dispid >継承メンバも含んでいます。
CProxy_ICaoOnMessageEvent() | CProxy_ICaoOnMessageEvent< T, dispid > | [inline]
CreateMessage(ICaoProvMessage *pICaopMess, ICaoMessage **ppVal) | CProxy_ICaoOnMessageEvent< T, dispid > | [inline]
Fire_OnMessage(IUnknown *pVal) | CProxy_ICaoOnMessageEvent< T, dispid > | [inline]
Generated on Wed Dec 7 19:02:09 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CServiceModule class Reference

クラス CServiceModule の解説

CAOのサービスクラス. [詳細]

#include <StdAfx.h>

すべてのメンバ一覧

Public メソッド

CServiceModule ()
コンストラクタ

~CServiceModule ()
デストラクタ

HRESULT | RegisterServer (BOOL bRegTypeLib, BOOL bService)
オブジェクト エントリの登録

HRESULT | UnregisterServer ()
オブジェクト エントリの削除

void | Init (_ATL_OBJMAP_ENTRY *p, HINSTANCE h, UINT nServiceNameID, const GUID *plibid=NULL)
オブジェクト初期化

void | Start ()
サービスのスタートアップおよび登録

void | ServiceMain (DWORD dwArgc, LPTSTR *lpszArgv)
サービスメイン

void | Handler (DWORD dwOpcode)
サービスのステータス処理を行う

void | Run ()
サービスの実行

BOOL | IsInstalled ()
サービス登録確認

BOOL | Install ()
サービス登録

BOOL | Uninstall ()
サービス登録解除

LONG | Unlock ()
グローバルロック回数のデクリメント

void | LogEvent (DWORD dwLevel, LPCTSTR pszFormat,...)
イベントログに出力

void | SetServiceStatus (DWORD dwState)
コントロール要求処理

void | SetupAsLocalServer ()
long | IncObjectCount (short iClsNo)
CAOの各クラスのインスタンス数をインクリメント.

long | DecObjectCount (short iClsNo)
CAOの各クラスのインスタンス数をデクリメント.

HANDLE | CreateWorkerSemaphore (long lInit=CAO_WORKT_MAX, long lMax=CAO_WORKT_MAX)
ワーカスレッド用の同期オブジェクト作成

void | DeleteWorkerSemaphore (HANDLE hSemaphore)
ワーカスレッド用の同期オブジェクトの削除

BOOL | ReleaseWorkerSemaphore (HANDLE hSemaphore)
ワーカスレッド用の同期オブジェクトの解放

HANDLE | BeginWorkerThread (HANDLE hSemaphore, void(__cdecl *pFunc)(void *pThis), void *pArglist)
ワーカスレッドの作成

void | ExitWorkerThread ()
ワーカスレッドの終了

void | DeleteWorkerThread (HANDLE hThread, HANDLE hTerminate)
ワーカスレッドの削除

HRESULT | ParseParameter (BSTR bsrCommand, WCHAR wc, VARIANT *pVal)
パラメータ文字列の処理

HRESULT | GetOptionValue (BSTR bstrOption, BSTR bstrKeyWord, VARTYPE Type, VARIANT *pVal)
オプションからキーワード値の取得

HRESULT | CreateUniqueName (WORD wClsNo, PVOID pObject, BSTR *pbstrName)
  名前の生成

HRESULT | CheckLicense ()
License Check.

Public 変数

TCHAR | m_szServiceName [256]
SERVICE_STATUS_HANDLE | m_hServiceStatus
SERVICE_STATUS | m_status
DWORD | dwThreadID
BOOL | m_bService
DWORD | m_dwPriority
DWORD | m_dwLocaleID
DWORD | m_dwLogType
DWORD | m_dwLogLevel
long | m_lObjectCount [CLS_NO_MAX]
TCHAR | m_szLogFile [256]
BOOL | m_bPreload
TCHAR | m_szCRDFile [256]

解説

CAOのサービスクラス.

サービス起動、レジストリアクセス及びCAOで使用するメソッドを提供するクラスです．

コンストラクタとデストラクタの解説

CServiceModule::CServiceModule ( ) [inline]

コンストラクタ

オブジェクト生成時の処理．

CServiceModule::~CServiceModule ( ) [inline]

デストラクタ

オブジェクト消滅時の処理．

メソッドの解説

HANDLE CServiceModule::BeginWorkerThread | ( | HANDLE | hSemaphore,
 |  | void(__cdecl *pFunc | )(void *pThis),
 |  | void * | pArglist
 | ) |

ワーカスレッドの作成

引数:
hSemaphore | : [in] セマフォオブジェクトのハンドル
pThis | : [in] スレッドの実行開始アドレス
pArglist | : [in] スレッドに渡す引数のリスト
戻り値:
HANDLE

HRESULT CServiceModule::CheckLicense ( )

License Check.

  ライセンスキーの確認

戻り値:
HRESULT

HRESULT CServiceModule::CreateUniqueName | ( | WORD | wClsNo,
 |  | PVOID | pObject,
 |  | BSTR * | pbstrName
 | ) |

  名前の生成

  以下の形式の名前を生成します。 　“$<クラス番号>-<オブジェクトポインタ>$”

引数:
wClsNo | : [in] クラス番号
pObject | : [in] オブジェクトのポインタ
pbstrName | : [out] 名前
戻り値:
HRESULT

HANDLE CServiceModule::CreateWorkerSemaphore | ( | long | lInit = CAO_WORKT_MAX,
 |  | long | lMax = CAO_WORKT_MAX
 | ) |

ワーカスレッド用の同期オブジェクト作成

  (注) CAO_WORKT_MAX > 2 にするとイベントの発生順序が問題になる．未対応．

引数:
lInit | : [in] 初期のカウント
lMax | : [in] 最大カウント
戻り値:
HANDLE : セマフォオブジェクトのハンドル

long CServiceModule::DecObjectCount ( short iClsNo )

CAOの各クラスのインスタンス数をデクリメント.

引数:
iClsNo : [in] クラス番号
戻り値:
long : インスタンス数

void CServiceModule::DeleteWorkerSemaphore ( HANDLE hSemaphore )

ワーカスレッド用の同期オブジェクトの削除

引数:
hSemaphore : [in] セマフォオブジェクトのハンドル

void CServiceModule::DeleteWorkerThread | ( | HANDLE | hThread,
 |  | HANDLE | hTerminate
 | ) |

ワーカスレッドの削除

  同時に同期オブジェクトも削除する．

引数:
hThread | : [in] スレッドハンドル
hTerminate | : [in] スレッド終了イベントハンドル

void CServiceModule::ExitWorkerThread ( )

ワーカスレッドの終了

  (注) Mutexを使う場合は，Mutexを所有するスレッドしか解放できないことに注意する．

HRESULT CServiceModule::GetOptionValue | ( | BSTR | bstrOption,
 |  | BSTR | bstrKeyWord,
 |  | VARTYPE | Type,
 |  | VARIANT * | pVal
 | ) |

オプションからキーワード値の取得

  オプション文字列から指定したオプションの値を指定した型で取得する．

引数:
bstrOption | : [in] オプション文字列
bstrKeyWord | : [in] 検索文字列
Type | : [in] 要求型
pVal | : [in] 結果値
戻り値:
HRESULT 　括り記号として()，[]，{}，<>のうち一種類を使用することが出来る．
オプション文字列内で最初に出現した括弧を，その文字列の括り記号とする．
  2番目以降に現れた括弧は括り文字ではなく，文字列内にあるただの記号として扱う．
  括り記号はネストして使用できる．
  括弧内では”=”，”,”は文字列の一部とされる．
括弧の外にあるスペースは削除する。 　結果の値から一番外側の括り記号のみを削除する．ネストしている括り記号は削除されない．

void CServiceModule::Handler ( DWORD dwOpcode ) [inline]

サービスのステータス処理を行う

  サービスマネージャのステータス処理を行う

引数:
dwOpcode : [in] オプション

long CServiceModule::IncObjectCount ( short iClsNo )

CAOの各クラスのインスタンス数をインクリメント.

引数:
iClsNo : [in] クラス番号
戻り値:
long : インスタンス数

void CServiceModule::Init | ( | _ATL_OBJMAP_ENTRY * | p,
 |  | HINSTANCE | h,
 |  | UINT | nServiceNameID,
 |  | const GUID * | plibid = NULL
 | ) | [inline]

オブジェクト初期化

  インライン展開されます

引数:
p | : [in] オブジェクト マップ エントリの配列へのポインタ
h | : [in] DLLMain に渡される HINSTANCE
nServiceNameID | : [in] サービスID
plibid | : [in] ライブラリID

BOOL CServiceModule::Install ( ) [inline]

サービス登録

  インライン展開されます

戻り値:
BOOL

BOOL CServiceModule::IsInstalled ( )

サービス登録確認

戻り値:
BOOL

void CServiceModule::LogEvent | ( | DWORD | dwLevel,
 |  | LPCTSTR | pFormat,
 |  | ... |
 | ) |

イベントログに出力

  インライン展開されます

引数:
dwLevel | : [in] メッセージのログレベル
pFormat | : [in] 書式制御
... : [in] オプションの引数

HRESULT CServiceModule::ParseParameter | ( | BSTR | bsrCommand,
 |  | WCHAR | wc,
 |  | VARIANT * | pVal
 | ) |

パラメータ文字列の処理

�<パラメータ文字列>::= "<パラメータ1> {<任意のデリミタ> <パラメータn>}"

引数:
bsrCommand | : [in] パラメータ文字列
wc | : [in] デリミタ
pVal | : [in] パラメータの文字配列
戻り値:
HRESULT

HRESULT CServiceModule::RegisterServer | ( | BOOL | bRegTypeLib,
 |  | BOOL | bService
 | ) | [inline]

オブジェクト エントリの登録

  インライン展開されます

引数:
bRegTypeLib | : [in] キーの登録
bService | : [in] サービス登録
戻り値:
HRESULT

BOOL CServiceModule::ReleaseWorkerSemaphore ( HANDLE hSemaphore )

ワーカスレッド用の同期オブジェクトの解放

引数:
hSemaphore : [in] セマフォオブジェクトのハンドル
戻り値:
BOOL

void CServiceModule::Run ( )

サービスの実行

void CServiceModule::ServiceMain | ( | DWORD | dwArgc,
 |  | LPTSTR * | lpszArgv
 | ) | [inline]

サービスメイン

  インライン展開されます

void CServiceModule::SetServiceStatus ( DWORD dwState )

コントロール要求処理

void CServiceModule::SetupAsLocalServer ( )

void CServiceModule::Start ( ) [inline]

サービスのスタートアップおよび登録

  インライン展開されます

BOOL CServiceModule::Uninstall ( ) [inline]

サービス登録解除

  インライン展開されます

戻り値:
BOOL

LONG CServiceModule::Unlock ( )

グローバルロック回数のデクリメント

  モジュールのグローバルロック回数をデクリメントする．

戻り値:
LONG : [in] グローバルロック回数

HRESULT CServiceModule::UnregisterServer ( ) [inline]

オブジェクト エントリの削除

  インライン展開されます

戻り値:
HRESULT

変数の解説

DWORD CServiceModule::dwThreadID

BOOL CServiceModule::m_bPreload

BOOL CServiceModule::m_bService

DWORD CServiceModule::m_dwLocaleID

DWORD CServiceModule::m_dwLogLevel

DWORD CServiceModule::m_dwLogType

DWORD CServiceModule::m_dwPriority

SERVICE_STATUS_HANDLE CServiceModule::m_hServiceStatus

long CServiceModule::m_lObjectCount[CLS_NO_MAX]

SERVICE_STATUS CServiceModule::m_status

TCHAR CServiceModule::m_szCRDFile[256]

TCHAR CServiceModule::m_szLogFile[256]

TCHAR CServiceModule::m_szServiceName[256]

このクラスの解説は次のファイルから生成されました:
  • StdAfx.h
  • CAO.cpp
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

CServiceModule メンバ一覧

これは全メンバの一覧です。CServiceModule継承メンバも含んでいます。
BeginWorkerThread(HANDLE hSemaphore, void(__cdecl *pFunc)(void *pThis), void *pArglist) | CServiceModule |
CheckLicense() | CServiceModule |
CreateUniqueName(WORD wClsNo, PVOID pObject, BSTR *pbstrName) | CServiceModule |
CreateWorkerSemaphore(long lInit=CAO_WORKT_MAX, long lMax=CAO_WORKT_MAX) | CServiceModule |
CServiceModule() | CServiceModule | [inline]
DecObjectCount(short iClsNo) | CServiceModule |
DeleteWorkerSemaphore(HANDLE hSemaphore) | CServiceModule |
DeleteWorkerThread(HANDLE hThread, HANDLE hTerminate) | CServiceModule |
dwThreadID | CServiceModule |
ExitWorkerThread() | CServiceModule |
GetOptionValue(BSTR bstrOption, BSTR bstrKeyWord, VARTYPE Type, VARIANT *pVal) | CServiceModule |
Handler(DWORD dwOpcode) | CServiceModule | [inline]
IncObjectCount(short iClsNo) | CServiceModule |
Init(_ATL_OBJMAP_ENTRY *p, HINSTANCE h, UINT nServiceNameID, const GUID *plibid=NULL) | CServiceModule | [inline]
Install() | CServiceModule | [inline]
IsInstalled() | CServiceModule |
LogEvent(DWORD dwLevel, LPCTSTR pszFormat,...) | CServiceModule |
m_bPreload | CServiceModule |
m_bService | CServiceModule |
m_dwLocaleID | CServiceModule |
m_dwLogLevel | CServiceModule |
m_dwLogType | CServiceModule |
m_dwPriority | CServiceModule |
m_hServiceStatus | CServiceModule |
m_lObjectCount | CServiceModule |
m_status | CServiceModule |
m_szCRDFile | CServiceModule |
m_szLogFile | CServiceModule |
m_szServiceName | CServiceModule |
ParseParameter(BSTR bsrCommand, WCHAR wc, VARIANT *pVal) | CServiceModule |
RegisterServer(BOOL bRegTypeLib, BOOL bService) | CServiceModule | [inline]
ReleaseWorkerSemaphore(HANDLE hSemaphore) | CServiceModule |
Run() | CServiceModule |
ServiceMain(DWORD dwArgc, LPTSTR *lpszArgv) | CServiceModule | [inline]
SetServiceStatus(DWORD dwState) | CServiceModule |
SetupAsLocalServer() | CServiceModule |
Start() | CServiceModule | [inline]
Uninstall() | CServiceModule | [inline]
Unlock() | CServiceModule |
UnregisterServer() | CServiceModule | [inline]
~CServiceModule() | CServiceModule | [inline]
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib::EventSink class Reference

クラス CAOLib::EventSink の解説

import "CAO.idl";

このクラスの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoCommand interface Reference

インタフェースICaoCommand の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | _PutIndex ([in] long newVal)
HRESULT | Attribute ([out, retval] long *pVal)
HRESULT | Help ([out, retval] BSTR *pVal)
HRESULT | Index ([out, retval] long *pVal)
HRESULT | Name ([out, retval] BSTR *pVal)
HRESULT | Parameters ([out, retval] VARIANT *pVal)
HRESULT | Parameters ([in] VARIANT newVal)
HRESULT | Result ([out, retval] VARIANT *pVal)
HRESULT | State ([out, retval] long *pVal)
HRESULT | Tag ([out, retval] VARIANT *pVal)
HRESULT | Tag ([in] VARIANT newVal)
HRESULT | Timeout ([out, retval] long *pVal)
HRESULT | Timeout ([in] long newVal)
HRESULT | ID ([out, retval] VARIANT *pVal)
HRESULT | ID ([in] VARIANT newVal)
HRESULT | Cancel ()
HRESULT | Execute ([in, defaultvalue(0)] long lMode)

メソッドの解説

HRESULT ICaoCommand::_PutIndex ( [in] long newVal )

HRESULT ICaoCommand::Attribute ( [out, retval] long * pVal )

HRESULT ICaoCommand::Cancel ( )

HRESULT ICaoCommand::Execute ( [in, defaultvalue(0)] long lMode )

HRESULT ICaoCommand::Help ( [out, retval] BSTR * pVal )

HRESULT ICaoCommand::ID ( [in] VARIANT newVal )

HRESULT ICaoCommand::ID ( [out, retval] VARIANT * pVal )

HRESULT ICaoCommand::Index ( [out, retval] long * pVal )

HRESULT ICaoCommand::Name ( [out, retval] BSTR * pVal )

HRESULT ICaoCommand::Parameters ( [in] VARIANT newVal )

HRESULT ICaoCommand::Parameters ( [out, retval] VARIANT * pVal )

HRESULT ICaoCommand::Result ( [out, retval] VARIANT * pVal )

HRESULT ICaoCommand::State ( [out, retval] long * pVal )

HRESULT ICaoCommand::Tag ( [in] VARIANT newVal )

HRESULT ICaoCommand::Tag ( [out, retval] VARIANT * pVal )

HRESULT ICaoCommand::Timeout ( [in] long newVal )

HRESULT ICaoCommand::Timeout ( [out, retval] long * pVal )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoCommand メンバ一覧

これは全メンバの一覧です。ICaoCommand継承メンバも含んでいます。
_PutIndex([in] long newVal) | ICaoCommand
Attribute([out, retval] long *pVal) | ICaoCommand
Cancel() | ICaoCommand
Execute([in, defaultvalue(0)] long lMode) | ICaoCommand
Help([out, retval] BSTR *pVal) | ICaoCommand
ID([out, retval] VARIANT *pVal) | ICaoCommand
ID([in] VARIANT newVal) | ICaoCommand
Index([out, retval] long *pVal) | ICaoCommand
Name([out, retval] BSTR *pVal) | ICaoCommand
Parameters([out, retval] VARIANT *pVal) | ICaoCommand
Parameters([in] VARIANT newVal) | ICaoCommand
Result([out, retval] VARIANT *pVal) | ICaoCommand
State([out, retval] long *pVal) | ICaoCommand
Tag([out, retval] VARIANT *pVal) | ICaoCommand
Tag([in] VARIANT newVal) | ICaoCommand
Timeout([out, retval] long *pVal) | ICaoCommand
Timeout([in] long newVal) | ICaoCommand
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoCommands interface Reference

インタフェースICaoCommands の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | _NewEnum ([out, retval] LPUNKNOWN *pVal)
HRESULT | Item ([in] VARIANT Index,[out, retval] ICaoCommand **ppICaoCommand)
HRESULT | Count ([out, retval] long *pVal)
HRESULT | Add ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoCommand **ppICaoCommand)
HRESULT | Remove ([in] VARIANT Index)
HRESULT | Clear ()
HRESULT | IsMember ([in] VARIANT Index,[out, retval] VARIANT_BOOL *pVal)

メソッドの解説

HRESULT ICaoCommands::_NewEnum ( [out, retval] LPUNKNOWN * pVal )

HRESULT ICaoCommands::Add | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoCommand ** | ppICaoCommand
 | ) |

HRESULT ICaoCommands::Clear ( )

HRESULT ICaoCommands::Count ( [out, retval] long * pVal )

HRESULT ICaoCommands::IsMember | ( | [in] VARIANT | Index,
 |  | [out, retval] VARIANT_BOOL * | pVal
 | ) |

HRESULT ICaoCommands::Item | ( | [in] VARIANT | Index,
 |  | [out, retval] ICaoCommand ** | ppICaoCommand
 | ) |

HRESULT ICaoCommands::Remove ( [in] VARIANT Index )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoCommands メンバ一覧

これは全メンバの一覧です。ICaoCommands継承メンバも含んでいます。
_NewEnum([out, retval] LPUNKNOWN *pVal) | ICaoCommands
Add([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoCommand **ppICaoCommand) | ICaoCommands
Clear() | ICaoCommands
Count([out, retval] long *pVal) | ICaoCommands
IsMember([in] VARIANT Index,[out, retval] VARIANT_BOOL *pVal) | ICaoCommands
Item([in] VARIANT Index,[out, retval] ICaoCommand **ppICaoCommand) | ICaoCommands
Remove([in] VARIANT Index) | ICaoCommands
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoController interface Reference

インタフェースICaoController の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | _PutIndex ([in] long newVal)
HRESULT | Attribute ([out, retval] long *pVal)
HRESULT | ExtensionNames ([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal)
HRESULT | Extensions ([out, retval] ICaoExtensions **ppICaoExtensions)
HRESULT | FileNames ([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal)
HRESULT | Files ([out, retval] ICaoFiles **ppICaoFiles)
HRESULT | Help ([out, retval] BSTR *pVal)
HRESULT | Index ([out, retval] long *pVal)
HRESULT | Name ([out, retval] BSTR *pVal)
HRESULT | RobotNames ([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal)
HRESULT | Robots ([out, retval] ICaoRobots **ppICaoRobots)
HRESULT | Tag ([out, retval] VARIANT *pVal)
HRESULT | Tag ([in] VARIANT newVal)
HRESULT | TaskNames ([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal)
HRESULT | Tasks ([out, retval] ICaoTasks **ppICaoTasks)
HRESULT | VariableNames ([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal)
HRESULT | Variables ([out, retval] ICaoVariables **ppICaoVariables)
HRESULT | CommandNames ([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal)
HRESULT | Commands ([out, retval] ICaoCommands **ppICaoCommands)
HRESULT | ID ([out, retval] VARIANT *pVal)
HRESULT | ID ([in] VARIANT newVal)
HRESULT | AddExtension ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoExtension **ppICaoExtension)
HRESULT | AddFile ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoFile **ppICaoFile)
HRESULT | AddRobot ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoRobot **ppICaoRobot)
HRESULT | AddTask ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoTask **ppICaoTask)
HRESULT | AddVariable ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoVariable **ppICaoVar)
HRESULT | AddCommand ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoCommand **ppICaoCommand)
HRESULT | Execute ([in] VARIANT vntCommand,[out, retval] VARIANT *pVal)
HRESULT | GetMessage ([out, retval] ICaoMessage **ppICaoMessage)

メソッドの解説

HRESULT ICaoController::_PutIndex ( [in] long newVal )

HRESULT ICaoController::AddCommand | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoCommand ** | ppICaoCommand
 | ) |

HRESULT ICaoController::AddExtension | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoExtension ** | ppICaoExtension
 | ) |

HRESULT ICaoController::AddFile | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoFile ** | ppICaoFile
 | ) |

HRESULT ICaoController::AddRobot | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoRobot ** | ppICaoRobot
 | ) |

HRESULT ICaoController::AddTask | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoTask ** | ppICaoTask
 | ) |

HRESULT ICaoController::AddVariable | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoVariable ** | ppICaoVar
 | ) |

HRESULT ICaoController::Attribute ( [out, retval] long * pVal )

HRESULT ICaoController::CommandNames | ( | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoController::Commands ( [out, retval] ICaoCommands ** ppICaoCommands )

HRESULT ICaoController::Execute | ( | [in] VARIANT | vntCommand,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoController::ExtensionNames | ( | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoController::Extensions ( [out, retval] ICaoExtensions ** ppICaoExtensions )

HRESULT ICaoController::FileNames | ( | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoController::Files ( [out, retval] ICaoFiles ** ppICaoFiles )

HRESULT ICaoController::GetMessage ( [out, retval] ICaoMessage ** ppICaoMessage )

HRESULT ICaoController::Help ( [out, retval] BSTR * pVal )

HRESULT ICaoController::ID ( [in] VARIANT newVal )

HRESULT ICaoController::ID ( [out, retval] VARIANT * pVal )

HRESULT ICaoController::Index ( [out, retval] long * pVal )

HRESULT ICaoController::Name ( [out, retval] BSTR * pVal )

HRESULT ICaoController::RobotNames | ( | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoController::Robots ( [out, retval] ICaoRobots ** ppICaoRobots )

HRESULT ICaoController::Tag ( [in] VARIANT newVal )

HRESULT ICaoController::Tag ( [out, retval] VARIANT * pVal )

HRESULT ICaoController::TaskNames | ( | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoController::Tasks ( [out, retval] ICaoTasks ** ppICaoTasks )

HRESULT ICaoController::VariableNames | ( | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoController::Variables ( [out, retval] ICaoVariables ** ppICaoVariables )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoController メンバ一覧

これは全メンバの一覧です。ICaoController継承メンバも含んでいます。
_PutIndex([in] long newVal) | ICaoController
AddCommand([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoCommand **ppICaoCommand) | ICaoController
AddExtension([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoExtension **ppICaoExtension) | ICaoController
AddFile([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoFile **ppICaoFile) | ICaoController
AddRobot([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoRobot **ppICaoRobot) | ICaoController
AddTask([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoTask **ppICaoTask) | ICaoController
AddVariable([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoVariable **ppICaoVar) | ICaoController
Attribute([out, retval] long *pVal) | ICaoController
CommandNames([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal) | ICaoController
Commands([out, retval] ICaoCommands **ppICaoCommands) | ICaoController
Execute([in] VARIANT vntCommand,[out, retval] VARIANT *pVal) | ICaoController
ExtensionNames([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal) | ICaoController
Extensions([out, retval] ICaoExtensions **ppICaoExtensions) | ICaoController
FileNames([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal) | ICaoController
Files([out, retval] ICaoFiles **ppICaoFiles) | ICaoController
GetMessage([out, retval] ICaoMessage **ppICaoMessage) | ICaoController
Help([out, retval] BSTR *pVal) | ICaoController
ID([out, retval] VARIANT *pVal) | ICaoController
ID([in] VARIANT newVal) | ICaoController
Index([out, retval] long *pVal) | ICaoController
Name([out, retval] BSTR *pVal) | ICaoController
RobotNames([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal) | ICaoController
Robots([out, retval] ICaoRobots **ppICaoRobots) | ICaoController
Tag([out, retval] VARIANT *pVal) | ICaoController
Tag([in] VARIANT newVal) | ICaoController
TaskNames([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal) | ICaoController
Tasks([out, retval] ICaoTasks **ppICaoTasks) | ICaoController
VariableNames([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal) | ICaoController
Variables([out, retval] ICaoVariables **ppICaoVariables) | ICaoController
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoControllers interface Reference

インタフェースICaoControllers の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | _NewEnum ([out, retval] LPUNKNOWN *pVal)
HRESULT | Item ([in] VARIANT Index,[out, retval] ICaoController **ppICaoCtrl)
HRESULT | Count ([out, retval] long *pVal)
HRESULT | Add ([in] BSTR bstrController,[in] BSTR bstrProvider,[in, defaultvalue("")] BSTR bstrMachine,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoController **ppICaoCtrl)
HRESULT | Remove ([in] VARIANT Index)
HRESULT | Clear ()
HRESULT | IsMember ([in] VARIANT Index,[out, retval] VARIANT_BOOL *pVal)

メソッドの解説

HRESULT ICaoControllers::_NewEnum ( [out, retval] LPUNKNOWN * pVal )

HRESULT ICaoControllers::Add | ( | [in] BSTR | bstrController,
 |  | [in] BSTR | bstrProvider,
 |  | [in, defaultvalue("")] BSTR | bstrMachine,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoController ** | ppICaoCtrl
 | ) |

HRESULT ICaoControllers::Clear ( )

HRESULT ICaoControllers::Count ( [out, retval] long * pVal )

HRESULT ICaoControllers::IsMember | ( | [in] VARIANT | Index,
 |  | [out, retval] VARIANT_BOOL * | pVal
 | ) |

HRESULT ICaoControllers::Item | ( | [in] VARIANT | Index,
 |  | [out, retval] ICaoController ** | ppICaoCtrl
 | ) |

HRESULT ICaoControllers::Remove ( [in] VARIANT Index )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoControllers メンバ一覧

これは全メンバの一覧です。ICaoControllers継承メンバも含んでいます。
_NewEnum([out, retval] LPUNKNOWN *pVal) | ICaoControllers
Add([in] BSTR bstrController,[in] BSTR bstrProvider,[in, defaultvalue("")] BSTR bstrMachine,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoController **ppICaoCtrl) | ICaoControllers
Clear() | ICaoControllers
Count([out, retval] long *pVal) | ICaoControllers
IsMember([in] VARIANT Index,[out, retval] VARIANT_BOOL *pVal) | ICaoControllers
Item([in] VARIANT Index,[out, retval] ICaoController **ppICaoCtrl) | ICaoControllers
Remove([in] VARIANT Index) | ICaoControllers
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


TemplateICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass > class Reference

クラス テンプレートICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass > の解説

CAOのカスタムDispatchインターフェース. [詳細]

#include <CaoObjectTmpl.h>

ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass >に対する継承グラフ

[凡例]
ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass >のコラボレーション図

[凡例]
すべてのメンバ一覧

Public メソッド

HRESULT | GetIDsOfNames (REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid)
virtual HRESULT | CustomGetIDsOfNames (REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid)
HRESULT | Invoke (DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr)
virtual HRESULT | CustomInvoke (DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr)

解説

template<class T, const IID * piid, const GUID * plibid = &CComModule::m_libid, WORD wMajor = 1, WORD wMinor = 0, class tihclass = CComTypeInfoHolder>
class ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass >

CAOのカスタムDispatchインターフェース.

CAOのDispatchインターフェース拡張用のテンプレートクラス．

メソッドの解説

template<class T, const IID * piid, const GUID * plibid = &CComModule::m_libid, WORD wMajor = 1, WORD wMinor = 0, class tihclass = CComTypeInfoHolder>
virtual HRESULT ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass >::CustomGetIDsOfNames | ( | REFIID | riid,
 |  | LPOLESTR * | rgszNames,
 |  | UINT | cNames,
 |  | LCID | lcid,
 |  | DISPID * | rgdispid
 | ) | [inline, virtual]

CCaoController, CCaoExtension, CCaoFile, CCaoRobot, と CCaoTaskで再定義されています。

template<class T, const IID * piid, const GUID * plibid = &CComModule::m_libid, WORD wMajor = 1, WORD wMinor = 0, class tihclass = CComTypeInfoHolder>
virtual HRESULT ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass >::CustomInvoke | ( | DISPID | dispidMember,
 |  | REFIID | riid,
 |  | LCID | lcid,
 |  | WORD | wFlags,
 |  | DISPPARAMS * | pdispparams,
 |  | VARIANT * | pvarResult,
 |  | EXCEPINFO * | pexcepinfo,
 |  | UINT * | puArgErr
 | ) | [inline, virtual]

CCaoController, CCaoExtension, CCaoFile, CCaoRobot, と CCaoTaskで再定義されています。

template<class T, const IID * piid, const GUID * plibid = &CComModule::m_libid, WORD wMajor = 1, WORD wMinor = 0, class tihclass = CComTypeInfoHolder>
HRESULT ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass >::GetIDsOfNames | ( | REFIID | riid,
 |  | LPOLESTR * | rgszNames,
 |  | UINT | cNames,
 |  | LCID | lcid,
 |  | DISPID * | rgdispid
 | ) | [inline]

template<class T, const IID * piid, const GUID * plibid = &CComModule::m_libid, WORD wMajor = 1, WORD wMinor = 0, class tihclass = CComTypeInfoHolder>
HRESULT ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass >::Invoke | ( | DISPID | dispidMember,
 |  | REFIID | riid,
 |  | LCID | lcid,
 |  | WORD | wFlags,
 |  | DISPPARAMS * | pdispparams,
 |  | VARIANT * | pvarResult,
 |  | EXCEPINFO * | pexcepinfo,
 |  | UINT * | puArgErr
 | ) | [inline]

このクラスの解説は次のファイルから生成されました:
  • CaoObjectTmpl.h
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass > メンバ一覧

これは全メンバの一覧です。ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass >継承メンバも含んでいます。
CustomGetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass > | [inline, virtual]
CustomInvoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass > | [inline, virtual]
GetIDsOfNames(REFIID riid, LPOLESTR *rgszNames, UINT cNames, LCID lcid, DISPID *rgdispid) | ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass > | [inline]
Invoke(DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS *pdispparams, VARIANT *pvarResult, EXCEPINFO *pexcepinfo, UINT *puArgErr) | ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass > | [inline]
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoEngine interface Reference

インタフェースICaoEngine の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | EngineStatus ([out, retval] ICaoEngineStatus **ppICaoEngineStatus)
HRESULT | Workspaces ([out, retval] ICaoWorkspaces **ppICaoWSs)
HRESULT | AddWorkspace ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoWorkspace **ppICaoWS)
HRESULT | Execute ([in] VARIANT vntCommand,[out, retval] VARIANT *pVal)

メソッドの解説

HRESULT ICaoEngine::AddWorkspace | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoWorkspace ** | ppICaoWS
 | ) |

HRESULT ICaoEngine::EngineStatus ( [out, retval] ICaoEngineStatus ** ppICaoEngineStatus )

HRESULT ICaoEngine::Execute | ( | [in] VARIANT | vntCommand,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoEngine::Workspaces ( [out, retval] ICaoWorkspaces ** ppICaoWSs )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoEngine メンバ一覧

これは全メンバの一覧です。ICaoEngine継承メンバも含んでいます。
AddWorkspace([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoWorkspace **ppICaoWS) | ICaoEngine
EngineStatus([out, retval] ICaoEngineStatus **ppICaoEngineStatus) | ICaoEngine
Execute([in] VARIANT vntCommand,[out, retval] VARIANT *pVal) | ICaoEngine
Workspaces([out, retval] ICaoWorkspaces **ppICaoWSs) | ICaoEngine
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoEngineStatus interface Reference

インタフェースICaoEngineStatus の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | CurrentDateTime ([out, retval] VARIANT *pVal)
HRESULT | ComputerName ([out, retval] BSTR *pVal)
HRESULT | ObjectCounts ([in] VARIANT vntName,[out, retval] long *pVal)
HRESULT | StartDateTime ([out, retval] VARIANT *pVal)
HRESULT | Values ([in] VARIANT vntName,[out, retval] VARIANT *pVal)
HRESULT | Version ([out, retval] BSTR *pVal)

メソッドの解説

HRESULT ICaoEngineStatus::ComputerName ( [out, retval] BSTR * pVal )

HRESULT ICaoEngineStatus::CurrentDateTime ( [out, retval] VARIANT * pVal )

HRESULT ICaoEngineStatus::ObjectCounts | ( | [in] VARIANT | vntName,
 |  | [out, retval] long * | pVal
 | ) |

HRESULT ICaoEngineStatus::StartDateTime ( [out, retval] VARIANT * pVal )

HRESULT ICaoEngineStatus::Values | ( | [in] VARIANT | vntName,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoEngineStatus::Version ( [out, retval] BSTR * pVal )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoEngineStatus メンバ一覧

これは全メンバの一覧です。ICaoEngineStatus継承メンバも含んでいます。
ComputerName([out, retval] BSTR *pVal) | ICaoEngineStatus
CurrentDateTime([out, retval] VARIANT *pVal) | ICaoEngineStatus
ObjectCounts([in] VARIANT vntName,[out, retval] long *pVal) | ICaoEngineStatus
StartDateTime([out, retval] VARIANT *pVal) | ICaoEngineStatus
Values([in] VARIANT vntName,[out, retval] VARIANT *pVal) | ICaoEngineStatus
Version([out, retval] BSTR *pVal) | ICaoEngineStatus
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoExtension interface Reference

インタフェースICaoExtension の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | _PutIndex ([in] long newVal)
HRESULT | Attribute ([out, retval] long *pVal)
HRESULT | Help ([out, retval] BSTR *pVal)
HRESULT | Index ([out, retval] long *pVal)
HRESULT | Name ([out, retval] BSTR *pVal)
HRESULT | Tag ([out, retval] VARIANT *pVal)
HRESULT | Tag ([in] VARIANT newVal)
HRESULT | VariableNames ([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal)
HRESULT | Variables ([out, retval] ICaoVariables **ppICaoVariables)
HRESULT | ID ([out, retval] VARIANT *pVal)
HRESULT | ID ([in] VARIANT newVal)
HRESULT | AddVariable ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoVariable **ppICaoVar)
HRESULT | Execute ([in] VARIANT vntCommand,[out, retval] VARIANT *pVal)

メソッドの解説

HRESULT ICaoExtension::_PutIndex ( [in] long newVal )

HRESULT ICaoExtension::AddVariable | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoVariable ** | ppICaoVar
 | ) |

HRESULT ICaoExtension::Attribute ( [out, retval] long * pVal )

HRESULT ICaoExtension::Execute | ( | [in] VARIANT | vntCommand,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoExtension::Help ( [out, retval] BSTR * pVal )

HRESULT ICaoExtension::ID ( [in] VARIANT newVal )

HRESULT ICaoExtension::ID ( [out, retval] VARIANT * pVal )

HRESULT ICaoExtension::Index ( [out, retval] long * pVal )

HRESULT ICaoExtension::Name ( [out, retval] BSTR * pVal )

HRESULT ICaoExtension::Tag ( [in] VARIANT newVal )

HRESULT ICaoExtension::Tag ( [out, retval] VARIANT * pVal )

HRESULT ICaoExtension::VariableNames | ( | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoExtension::Variables ( [out, retval] ICaoVariables ** ppICaoVariables )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoExtension メンバ一覧

これは全メンバの一覧です。ICaoExtension継承メンバも含んでいます。
_PutIndex([in] long newVal) | ICaoExtension
AddVariable([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoVariable **ppICaoVar) | ICaoExtension
Attribute([out, retval] long *pVal) | ICaoExtension
Execute([in] VARIANT vntCommand,[out, retval] VARIANT *pVal) | ICaoExtension
Help([out, retval] BSTR *pVal) | ICaoExtension
ID([out, retval] VARIANT *pVal) | ICaoExtension
ID([in] VARIANT newVal) | ICaoExtension
Index([out, retval] long *pVal) | ICaoExtension
Name([out, retval] BSTR *pVal) | ICaoExtension
Tag([out, retval] VARIANT *pVal) | ICaoExtension
Tag([in] VARIANT newVal) | ICaoExtension
VariableNames([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal) | ICaoExtension
Variables([out, retval] ICaoVariables **ppICaoVariables) | ICaoExtension
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoExtensions interface Reference

インタフェースICaoExtensions の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | _NewEnum ([out, retval] LPUNKNOWN *pVal)
HRESULT | Item ([in] VARIANT Index,[out, retval] ICaoExtension **ppICaoExtension)
HRESULT | Count ([out, retval] long *pVal)
HRESULT | Add ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoExtension **ppICaoExtension)
HRESULT | Remove ([in] VARIANT Index)
HRESULT | Clear ()
HRESULT | IsMember ([in] VARIANT Index,[out, retval] VARIANT_BOOL *pVal)

メソッドの解説

HRESULT ICaoExtensions::_NewEnum ( [out, retval] LPUNKNOWN * pVal )

HRESULT ICaoExtensions::Add | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoExtension ** | ppICaoExtension
 | ) |

HRESULT ICaoExtensions::Clear ( )

HRESULT ICaoExtensions::Count ( [out, retval] long * pVal )

HRESULT ICaoExtensions::IsMember | ( | [in] VARIANT | Index,
 |  | [out, retval] VARIANT_BOOL * | pVal
 | ) |

HRESULT ICaoExtensions::Item | ( | [in] VARIANT | Index,
 |  | [out, retval] ICaoExtension ** | ppICaoExtension
 | ) |

HRESULT ICaoExtensions::Remove ( [in] VARIANT Index )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoExtensions メンバ一覧

これは全メンバの一覧です。ICaoExtensions継承メンバも含んでいます。
_NewEnum([out, retval] LPUNKNOWN *pVal) | ICaoExtensions
Add([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoExtension **ppICaoExtension) | ICaoExtensions
Clear() | ICaoExtensions
Count([out, retval] long *pVal) | ICaoExtensions
IsMember([in] VARIANT Index,[out, retval] VARIANT_BOOL *pVal) | ICaoExtensions
Item([in] VARIANT Index,[out, retval] ICaoExtension **ppICaoExtension) | ICaoExtensions
Remove([in] VARIANT Index) | ICaoExtensions
Generated on Wed Dec 7 19:02:10 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoFile interface Reference

インタフェースICaoFile の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | Value ([out, retval] VARIANT *pVal)
HRESULT | Value ([in] VARIANT newVal)
HRESULT | _PutIndex ([in] long newVal)
HRESULT | Attribute ([out, retval] long *pVal)
HRESULT | DateCreated ([out, retval] VARIANT *pVal)
HRESULT | DateLastAccessed ([out, retval] VARIANT *pVal)
HRESULT | DateLastModified ([out, retval] VARIANT *pVal)
HRESULT | FileNames ([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal)
HRESULT | Files ([out, retval] ICaoFiles **ppICaoFiles)
HRESULT | Help ([out, retval] BSTR *pVal)
HRESULT | Index ([out, retval] long *pVal)
HRESULT | Name ([out, retval] BSTR *pVal)
HRESULT | Path ([out, retval] BSTR *pVal)
HRESULT | Size ([out, retval] long *pVal)
HRESULT | Tag ([out, retval] VARIANT *pVal)
HRESULT | Tag ([in] VARIANT newVal)
HRESULT | Type ([out, retval] BSTR *pVal)
HRESULT | VariableNames ([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal)
HRESULT | Variables ([out, retval] ICaoVariables **ppICaoVariables)
HRESULT | ID ([out, retval] VARIANT *pVal)
HRESULT | ID ([in] VARIANT newVal)
HRESULT | AddFile ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoFile **ppICaoFile)
HRESULT | AddVariable ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoVariable **ppICaoVar)
HRESULT | Copy ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption)
HRESULT | Delete ([in, defaultvalue("")] BSTR bstrOption)
HRESULT | Execute ([in] VARIANT vntCommand,[out, retval] VARIANT *pVal)
HRESULT | Move ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption)
HRESULT | Run ([in, defaultvalue("")] BSTR bstrOption,[out, retval] BSTR *bstrName)

メソッドの解説

HRESULT ICaoFile::_PutIndex ( [in] long newVal )

HRESULT ICaoFile::AddFile | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoFile ** | ppICaoFile
 | ) |

HRESULT ICaoFile::AddVariable | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoVariable ** | ppICaoVar
 | ) |

HRESULT ICaoFile::Attribute ( [out, retval] long * pVal )

HRESULT ICaoFile::Copy | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption
 | ) |

HRESULT ICaoFile::DateCreated ( [out, retval] VARIANT * pVal )

HRESULT ICaoFile::DateLastAccessed ( [out, retval] VARIANT * pVal )

HRESULT ICaoFile::DateLastModified ( [out, retval] VARIANT * pVal )

HRESULT ICaoFile::Delete ( [in, defaultvalue("")] BSTR bstrOption )

HRESULT ICaoFile::Execute | ( | [in] VARIANT | vntCommand,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoFile::FileNames | ( | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoFile::Files ( [out, retval] ICaoFiles ** ppICaoFiles )

HRESULT ICaoFile::Help ( [out, retval] BSTR * pVal )

HRESULT ICaoFile::ID ( [in] VARIANT newVal )

HRESULT ICaoFile::ID ( [out, retval] VARIANT * pVal )

HRESULT ICaoFile::Index ( [out, retval] long * pVal )

HRESULT ICaoFile::Move | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption
 | ) |

HRESULT ICaoFile::Name ( [out, retval] BSTR * pVal )

HRESULT ICaoFile::Path ( [out, retval] BSTR * pVal )

HRESULT ICaoFile::Run | ( | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] BSTR * | bstrName
 | ) |

HRESULT ICaoFile::Size ( [out, retval] long * pVal )

HRESULT ICaoFile::Tag ( [in] VARIANT newVal )

HRESULT ICaoFile::Tag ( [out, retval] VARIANT * pVal )

HRESULT ICaoFile::Type ( [out, retval] BSTR * pVal )

HRESULT ICaoFile::Value ( [in] VARIANT newVal )

HRESULT ICaoFile::Value ( [out, retval] VARIANT * pVal )

HRESULT ICaoFile::VariableNames | ( | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoFile::Variables ( [out, retval] ICaoVariables ** ppICaoVariables )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoFile メンバ一覧

これは全メンバの一覧です。ICaoFile継承メンバも含んでいます。
_PutIndex([in] long newVal) | ICaoFile
AddFile([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoFile **ppICaoFile) | ICaoFile
AddVariable([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoVariable **ppICaoVar) | ICaoFile
Attribute([out, retval] long *pVal) | ICaoFile
Copy([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption) | ICaoFile
DateCreated([out, retval] VARIANT *pVal) | ICaoFile
DateLastAccessed([out, retval] VARIANT *pVal) | ICaoFile
DateLastModified([out, retval] VARIANT *pVal) | ICaoFile
Delete([in, defaultvalue("")] BSTR bstrOption) | ICaoFile
Execute([in] VARIANT vntCommand,[out, retval] VARIANT *pVal) | ICaoFile
FileNames([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal) | ICaoFile
Files([out, retval] ICaoFiles **ppICaoFiles) | ICaoFile
Help([out, retval] BSTR *pVal) | ICaoFile
ID([out, retval] VARIANT *pVal) | ICaoFile
ID([in] VARIANT newVal) | ICaoFile
Index([out, retval] long *pVal) | ICaoFile
Move([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption) | ICaoFile
Name([out, retval] BSTR *pVal) | ICaoFile
Path([out, retval] BSTR *pVal) | ICaoFile
Run([in, defaultvalue("")] BSTR bstrOption,[out, retval] BSTR *bstrName) | ICaoFile
Size([out, retval] long *pVal) | ICaoFile
Tag([out, retval] VARIANT *pVal) | ICaoFile
Tag([in] VARIANT newVal) | ICaoFile
Type([out, retval] BSTR *pVal) | ICaoFile
Value([out, retval] VARIANT *pVal) | ICaoFile
Value([in] VARIANT newVal) | ICaoFile
VariableNames([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal) | ICaoFile
Variables([out, retval] ICaoVariables **ppICaoVariables) | ICaoFile
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoFiles interface Reference

インタフェースICaoFiles の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | _NewEnum ([out, retval] LPUNKNOWN *pVal)
HRESULT | Item ([in] VARIANT Index,[out, retval] ICaoFile **ppICaoFile)
HRESULT | Count ([out, retval] long *pVal)
HRESULT | Add ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoFile **ppICaoFile)
HRESULT | Remove ([in] VARIANT Index)
HRESULT | Clear ()
HRESULT | IsMember ([in] VARIANT Index,[out, retval] VARIANT_BOOL *pVal)

メソッドの解説

HRESULT ICaoFiles::_NewEnum ( [out, retval] LPUNKNOWN * pVal )

HRESULT ICaoFiles::Add | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoFile ** | ppICaoFile
 | ) |

HRESULT ICaoFiles::Clear ( )

HRESULT ICaoFiles::Count ( [out, retval] long * pVal )

HRESULT ICaoFiles::IsMember | ( | [in] VARIANT | Index,
 |  | [out, retval] VARIANT_BOOL * | pVal
 | ) |

HRESULT ICaoFiles::Item | ( | [in] VARIANT | Index,
 |  | [out, retval] ICaoFile ** | ppICaoFile
 | ) |

HRESULT ICaoFiles::Remove ( [in] VARIANT Index )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoFiles メンバ一覧

これは全メンバの一覧です。ICaoFiles継承メンバも含んでいます。
_NewEnum([out, retval] LPUNKNOWN *pVal) | ICaoFiles
Add([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoFile **ppICaoFile) | ICaoFiles
Clear() | ICaoFiles
Count([out, retval] long *pVal) | ICaoFiles
IsMember([in] VARIANT Index,[out, retval] VARIANT_BOOL *pVal) | ICaoFiles
Item([in] VARIANT Index,[out, retval] ICaoFile **ppICaoFile) | ICaoFiles
Remove([in] VARIANT Index) | ICaoFiles
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoMessage interface Reference

インタフェースICaoMessage の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | DateTime ([out, retval] VARIANT *pVal)
HRESULT | Description ([out, retval] BSTR *pVal)
HRESULT | Destination ([out, retval] BSTR *pVal)
HRESULT | Number ([out, retval] long *pVal)
HRESULT | SerialNumber ([out, retval] long *pVal)
HRESULT | Source ([out, retval] BSTR *pVal)
HRESULT | Value ([out, retval] VARIANT *pVal)
HRESULT | Clear ()
HRESULT | Reply (VARIANT vntData)

メソッドの解説

HRESULT ICaoMessage::Clear ( )

HRESULT ICaoMessage::DateTime ( [out, retval] VARIANT * pVal )

HRESULT ICaoMessage::Description ( [out, retval] BSTR * pVal )

HRESULT ICaoMessage::Destination ( [out, retval] BSTR * pVal )

HRESULT ICaoMessage::Number ( [out, retval] long * pVal )

HRESULT ICaoMessage::Reply ( VARIANT vntData )

HRESULT ICaoMessage::SerialNumber ( [out, retval] long * pVal )

HRESULT ICaoMessage::Source ( [out, retval] BSTR * pVal )

HRESULT ICaoMessage::Value ( [out, retval] VARIANT * pVal )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoMessage メンバ一覧

これは全メンバの一覧です。ICaoMessage継承メンバも含んでいます。
Clear() | ICaoMessage
DateTime([out, retval] VARIANT *pVal) | ICaoMessage
Description([out, retval] BSTR *pVal) | ICaoMessage
Destination([out, retval] BSTR *pVal) | ICaoMessage
Number([out, retval] long *pVal) | ICaoMessage
Reply(VARIANT vntData) | ICaoMessage
SerialNumber([out, retval] long *pVal) | ICaoMessage
Source([out, retval] BSTR *pVal) | ICaoMessage
Value([out, retval] VARIANT *pVal) | ICaoMessage
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoRobot interface Reference

インタフェースICaoRobot の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | _PutIndex ([in] long newVal)
HRESULT | Attribute ([out, retval] long *pVal)
HRESULT | Help ([out, retval] BSTR *pVal)
HRESULT | Index ([out, retval] long *pVal)
HRESULT | Name ([out, retval] BSTR *pVal)
HRESULT | Tag ([out, retval] VARIANT *pVal)
HRESULT | Tag ([in] VARIANT newVal)
HRESULT | VariableNames ([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal)
HRESULT | Variables ([out, retval] ICaoVariables **ppICaoVariables)
HRESULT | ID ([out, retval] VARIANT *pVal)
HRESULT | ID ([in] VARIANT newVal)
HRESULT | Accelerate ([in] long lAxis,[in] float fAccel,[in, defaultvalue(0)] float fDecel)
HRESULT | AddVariable ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoVariable **ppICaoVar)
HRESULT | Change ([in] BSTR bstrName)
HRESULT | Chuck ([in, defaultvalue("")] BSTR bstrOption)
HRESULT | Drive ([in] long lNo,[in] float fMov,[in, defaultvalue("")] BSTR bstrOpt)
HRESULT | Execute ([in] VARIANT vntCommand,[out, retval] VARIANT *pVal)
HRESULT | GoHome ()
HRESULT | Halt ([in, defaultvalue("")] BSTR bstrOption)
HRESULT | Hold ([in, defaultvalue("")] BSTR bstrOption)
HRESULT | Move ([in] long lComp,[in] VARIANT vntPose,[in, defaultvalue("")] BSTR bstrOpt)
HRESULT | Rotate ([in] VARIANT vntRotSuf,[in] float fDeg,[in] VARIANT vntPivot,[in, defaultvalue("")] BSTR bstrOpt)
HRESULT | Speed ([in] long lAxis,[in] float fSpeed)
HRESULT | Unchuck ([in, defaultvalue("")] BSTR bstrOption)
HRESULT | Unhold ([in, defaultvalue("")] BSTR bstrOption)

メソッドの解説

HRESULT ICaoRobot::_PutIndex ( [in] long newVal )

HRESULT ICaoRobot::Accelerate | ( | [in] long | lAxis,
 |  | [in] float | fAccel,
 |  | [in, defaultvalue(0)] float | fDecel
 | ) |

HRESULT ICaoRobot::AddVariable | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoVariable ** | ppICaoVar
 | ) |

HRESULT ICaoRobot::Attribute ( [out, retval] long * pVal )

HRESULT ICaoRobot::Change ( [in] BSTR bstrName )

HRESULT ICaoRobot::Chuck ( [in, defaultvalue("")] BSTR bstrOption )

HRESULT ICaoRobot::Drive | ( | [in] long | lNo,
 |  | [in] float | fMov,
 |  | [in, defaultvalue("")] BSTR | bstrOpt
 | ) |

HRESULT ICaoRobot::Execute | ( | [in] VARIANT | vntCommand,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoRobot::GoHome ( )

HRESULT ICaoRobot::Halt ( [in, defaultvalue("")] BSTR bstrOption )

HRESULT ICaoRobot::Help ( [out, retval] BSTR * pVal )

HRESULT ICaoRobot::Hold ( [in, defaultvalue("")] BSTR bstrOption )

HRESULT ICaoRobot::ID ( [in] VARIANT newVal )

HRESULT ICaoRobot::ID ( [out, retval] VARIANT * pVal )

HRESULT ICaoRobot::Index ( [out, retval] long * pVal )

HRESULT ICaoRobot::Move | ( | [in] long | lComp,
 |  | [in] VARIANT | vntPose,
 |  | [in, defaultvalue("")] BSTR | bstrOpt
 | ) |

HRESULT ICaoRobot::Name ( [out, retval] BSTR * pVal )

HRESULT ICaoRobot::Rotate | ( | [in] VARIANT | vntRotSuf,
 |  | [in] float | fDeg,
 |  | [in] VARIANT | vntPivot,
 |  | [in, defaultvalue("")] BSTR | bstrOpt
 | ) |

HRESULT ICaoRobot::Speed | ( | [in] long | lAxis,
 |  | [in] float | fSpeed
 | ) |

HRESULT ICaoRobot::Tag ( [in] VARIANT newVal )

HRESULT ICaoRobot::Tag ( [out, retval] VARIANT * pVal )

HRESULT ICaoRobot::Unchuck ( [in, defaultvalue("")] BSTR bstrOption )

HRESULT ICaoRobot::Unhold ( [in, defaultvalue("")] BSTR bstrOption )

HRESULT ICaoRobot::VariableNames | ( | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoRobot::Variables ( [out, retval] ICaoVariables ** ppICaoVariables )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoRobot メンバ一覧

これは全メンバの一覧です。ICaoRobot継承メンバも含んでいます。
_PutIndex([in] long newVal) | ICaoRobot
Accelerate([in] long lAxis,[in] float fAccel,[in, defaultvalue(0)] float fDecel) | ICaoRobot
AddVariable([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoVariable **ppICaoVar) | ICaoRobot
Attribute([out, retval] long *pVal) | ICaoRobot
Change([in] BSTR bstrName) | ICaoRobot
Chuck([in, defaultvalue("")] BSTR bstrOption) | ICaoRobot
Drive([in] long lNo,[in] float fMov,[in, defaultvalue("")] BSTR bstrOpt) | ICaoRobot
Execute([in] VARIANT vntCommand,[out, retval] VARIANT *pVal) | ICaoRobot
GoHome() | ICaoRobot
Halt([in, defaultvalue("")] BSTR bstrOption) | ICaoRobot
Help([out, retval] BSTR *pVal) | ICaoRobot
Hold([in, defaultvalue("")] BSTR bstrOption) | ICaoRobot
ID([out, retval] VARIANT *pVal) | ICaoRobot
ID([in] VARIANT newVal) | ICaoRobot
Index([out, retval] long *pVal) | ICaoRobot
Move([in] long lComp,[in] VARIANT vntPose,[in, defaultvalue("")] BSTR bstrOpt) | ICaoRobot
Name([out, retval] BSTR *pVal) | ICaoRobot
Rotate([in] VARIANT vntRotSuf,[in] float fDeg,[in] VARIANT vntPivot,[in, defaultvalue("")] BSTR bstrOpt) | ICaoRobot
Speed([in] long lAxis,[in] float fSpeed) | ICaoRobot
Tag([out, retval] VARIANT *pVal) | ICaoRobot
Tag([in] VARIANT newVal) | ICaoRobot
Unchuck([in, defaultvalue("")] BSTR bstrOption) | ICaoRobot
Unhold([in, defaultvalue("")] BSTR bstrOption) | ICaoRobot
VariableNames([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal) | ICaoRobot
Variables([out, retval] ICaoVariables **ppICaoVariables) | ICaoRobot
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoRobots interface Reference

インタフェースICaoRobots の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | _NewEnum ([out, retval] LPUNKNOWN *pVal)
HRESULT | Item ([in] VARIANT Index,[out, retval] ICaoRobot **ppICaoRobot)
HRESULT | Count ([out, retval] long *pVal)
HRESULT | Add ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoRobot **ppICaoRobot)
HRESULT | Remove ([in] VARIANT Index)
HRESULT | Clear ()
HRESULT | IsMember ([in] VARIANT Index,[out, retval] VARIANT_BOOL *pVal)

メソッドの解説

HRESULT ICaoRobots::_NewEnum ( [out, retval] LPUNKNOWN * pVal )

HRESULT ICaoRobots::Add | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoRobot ** | ppICaoRobot
 | ) |

HRESULT ICaoRobots::Clear ( )

HRESULT ICaoRobots::Count ( [out, retval] long * pVal )

HRESULT ICaoRobots::IsMember | ( | [in] VARIANT | Index,
 |  | [out, retval] VARIANT_BOOL * | pVal
 | ) |

HRESULT ICaoRobots::Item | ( | [in] VARIANT | Index,
 |  | [out, retval] ICaoRobot ** | ppICaoRobot
 | ) |

HRESULT ICaoRobots::Remove ( [in] VARIANT Index )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoRobots メンバ一覧

これは全メンバの一覧です。ICaoRobots継承メンバも含んでいます。
_NewEnum([out, retval] LPUNKNOWN *pVal) | ICaoRobots
Add([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoRobot **ppICaoRobot) | ICaoRobots
Clear() | ICaoRobots
Count([out, retval] long *pVal) | ICaoRobots
IsMember([in] VARIANT Index,[out, retval] VARIANT_BOOL *pVal) | ICaoRobots
Item([in] VARIANT Index,[out, retval] ICaoRobot **ppICaoRobot) | ICaoRobots
Remove([in] VARIANT Index) | ICaoRobots
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoTask interface Reference

インタフェースICaoTask の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | _PutIndex ([in] long newVal)
HRESULT | Attribute ([out, retval] long *pVal)
HRESULT | FileName ([out, retval] BSTR *pVal)
HRESULT | Help ([out, retval] BSTR *pVal)
HRESULT | Index ([out, retval] long *pVal)
HRESULT | Name ([out, retval] BSTR *pVal)
HRESULT | Tag ([out, retval] VARIANT *pVal)
HRESULT | Tag ([in] VARIANT newVal)
HRESULT | VariableNames ([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal)
HRESULT | Variables ([out, retval] ICaoVariables **ppICaoVariables)
HRESULT | ID ([out, retval] VARIANT *pVal)
HRESULT | ID ([in] VARIANT newVal)
HRESULT | AddVariable ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoVariable **ppICaoVar)
HRESULT | Delete ([in, defaultvalue("")] BSTR bstrOption)
HRESULT | Execute ([in] VARIANT vntCommand,[out, retval] VARIANT *pVal)
HRESULT | Start ([in, defaultvalue(0)] long lMode,[in, defaultvalue("")] BSTR bstrOption)
HRESULT | Stop ([in, defaultvalue(0)] long lMode,[in, defaultvalue("")] BSTR bstrOption)

メソッドの解説

HRESULT ICaoTask::_PutIndex ( [in] long newVal )

HRESULT ICaoTask::AddVariable | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoVariable ** | ppICaoVar
 | ) |

HRESULT ICaoTask::Attribute ( [out, retval] long * pVal )

HRESULT ICaoTask::Delete ( [in, defaultvalue("")] BSTR bstrOption )

HRESULT ICaoTask::Execute | ( | [in] VARIANT | vntCommand,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoTask::FileName ( [out, retval] BSTR * pVal )

HRESULT ICaoTask::Help ( [out, retval] BSTR * pVal )

HRESULT ICaoTask::ID ( [in] VARIANT newVal )

HRESULT ICaoTask::ID ( [out, retval] VARIANT * pVal )

HRESULT ICaoTask::Index ( [out, retval] long * pVal )

HRESULT ICaoTask::Name ( [out, retval] BSTR * pVal )

HRESULT ICaoTask::Start | ( | [in, defaultvalue(0)] long | lMode,
 |  | [in, defaultvalue("")] BSTR | bstrOption
 | ) |

HRESULT ICaoTask::Stop | ( | [in, defaultvalue(0)] long | lMode,
 |  | [in, defaultvalue("")] BSTR | bstrOption
 | ) |

HRESULT ICaoTask::Tag ( [in] VARIANT newVal )

HRESULT ICaoTask::Tag ( [out, retval] VARIANT * pVal )

HRESULT ICaoTask::VariableNames | ( | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoTask::Variables ( [out, retval] ICaoVariables ** ppICaoVariables )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoTask メンバ一覧

これは全メンバの一覧です。ICaoTask継承メンバも含んでいます。
_PutIndex([in] long newVal) | ICaoTask
AddVariable([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoVariable **ppICaoVar) | ICaoTask
Attribute([out, retval] long *pVal) | ICaoTask
Delete([in, defaultvalue("")] BSTR bstrOption) | ICaoTask
Execute([in] VARIANT vntCommand,[out, retval] VARIANT *pVal) | ICaoTask
FileName([out, retval] BSTR *pVal) | ICaoTask
Help([out, retval] BSTR *pVal) | ICaoTask
ID([out, retval] VARIANT *pVal) | ICaoTask
ID([in] VARIANT newVal) | ICaoTask
Index([out, retval] long *pVal) | ICaoTask
Name([out, retval] BSTR *pVal) | ICaoTask
Start([in, defaultvalue(0)] long lMode,[in, defaultvalue("")] BSTR bstrOption) | ICaoTask
Stop([in, defaultvalue(0)] long lMode,[in, defaultvalue("")] BSTR bstrOption) | ICaoTask
Tag([out, retval] VARIANT *pVal) | ICaoTask
Tag([in] VARIANT newVal) | ICaoTask
VariableNames([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal) | ICaoTask
Variables([out, retval] ICaoVariables **ppICaoVariables) | ICaoTask
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoTasks interface Reference

インタフェースICaoTasks の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | _NewEnum ([out, retval] LPUNKNOWN *pVal)
HRESULT | Item ([in] VARIANT Index,[out, retval] ICaoTask **ppICaoTask)
HRESULT | Count ([out, retval] long *pVal)
HRESULT | Add ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoTask **ppICaoTask)
HRESULT | Remove ([in] VARIANT Index)
HRESULT | Clear ()
HRESULT | IsMember ([in] VARIANT Index,[out, retval] VARIANT_BOOL *pVal)

メソッドの解説

HRESULT ICaoTasks::_NewEnum ( [out, retval] LPUNKNOWN * pVal )

HRESULT ICaoTasks::Add | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoTask ** | ppICaoTask
 | ) |

HRESULT ICaoTasks::Clear ( )

HRESULT ICaoTasks::Count ( [out, retval] long * pVal )

HRESULT ICaoTasks::IsMember | ( | [in] VARIANT | Index,
 |  | [out, retval] VARIANT_BOOL * | pVal
 | ) |

HRESULT ICaoTasks::Item | ( | [in] VARIANT | Index,
 |  | [out, retval] ICaoTask ** | ppICaoTask
 | ) |

HRESULT ICaoTasks::Remove ( [in] VARIANT Index )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoTasks メンバ一覧

これは全メンバの一覧です。ICaoTasks継承メンバも含んでいます。
_NewEnum([out, retval] LPUNKNOWN *pVal) | ICaoTasks
Add([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoTask **ppICaoTask) | ICaoTasks
Clear() | ICaoTasks
Count([out, retval] long *pVal) | ICaoTasks
IsMember([in] VARIANT Index,[out, retval] VARIANT_BOOL *pVal) | ICaoTasks
Item([in] VARIANT Index,[out, retval] ICaoTask **ppICaoTask) | ICaoTasks
Remove([in] VARIANT Index) | ICaoTasks
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoVariable interface Reference

インタフェースICaoVariable の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | Value ([out, retval] VARIANT *pVal)
HRESULT | Value ([in] VARIANT newVal)
HRESULT | _PutIndex ([in] long newVal)
HRESULT | Attribute ([out, retval] long *pVal)
HRESULT | DateTime ([out, retval] VARIANT *pVal)
HRESULT | Help ([out, retval] BSTR *pVal)
HRESULT | Index ([out, retval] long *pVal)
HRESULT | Name ([out, retval] BSTR *pVal)
HRESULT | Tag ([out, retval] VARIANT *pVal)
HRESULT | Tag ([in] VARIANT newVal)
HRESULT | ID ([out, retval] VARIANT *pVal)
HRESULT | ID ([in] VARIANT newVal)
HRESULT | Microsecond ([out, retval] long *pVal)

メソッドの解説

HRESULT ICaoVariable::_PutIndex ( [in] long newVal )

HRESULT ICaoVariable::Attribute ( [out, retval] long * pVal )

HRESULT ICaoVariable::DateTime ( [out, retval] VARIANT * pVal )

HRESULT ICaoVariable::Help ( [out, retval] BSTR * pVal )

HRESULT ICaoVariable::ID ( [in] VARIANT newVal )

HRESULT ICaoVariable::ID ( [out, retval] VARIANT * pVal )

HRESULT ICaoVariable::Index ( [out, retval] long * pVal )

HRESULT ICaoVariable::Microsecond ( [out, retval] long * pVal )

HRESULT ICaoVariable::Name ( [out, retval] BSTR * pVal )

HRESULT ICaoVariable::Tag ( [in] VARIANT newVal )

HRESULT ICaoVariable::Tag ( [out, retval] VARIANT * pVal )

HRESULT ICaoVariable::Value ( [in] VARIANT newVal )

HRESULT ICaoVariable::Value ( [out, retval] VARIANT * pVal )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoVariable メンバ一覧

これは全メンバの一覧です。ICaoVariable継承メンバも含んでいます。
_PutIndex([in] long newVal) | ICaoVariable
Attribute([out, retval] long *pVal) | ICaoVariable
DateTime([out, retval] VARIANT *pVal) | ICaoVariable
Help([out, retval] BSTR *pVal) | ICaoVariable
ID([out, retval] VARIANT *pVal) | ICaoVariable
ID([in] VARIANT newVal) | ICaoVariable
Index([out, retval] long *pVal) | ICaoVariable
Microsecond([out, retval] long *pVal) | ICaoVariable
Name([out, retval] BSTR *pVal) | ICaoVariable
Tag([out, retval] VARIANT *pVal) | ICaoVariable
Tag([in] VARIANT newVal) | ICaoVariable
Value([out, retval] VARIANT *pVal) | ICaoVariable
Value([in] VARIANT newVal) | ICaoVariable
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoVariables interface Reference

インタフェースICaoVariables の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | _NewEnum ([out, retval] LPUNKNOWN *pVal)
HRESULT | Item ([in] VARIANT Index,[out, retval] ICaoVariable **ppICaoVar)
HRESULT | Count ([out, retval] long *pVal)
HRESULT | Add ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoVariable **ppICaoVar)
HRESULT | Remove ([in] VARIANT Index)
HRESULT | Clear ()
HRESULT | IsMember ([in] VARIANT Index,[out, retval] VARIANT_BOOL *pVal)

メソッドの解説

HRESULT ICaoVariables::_NewEnum ( [out, retval] LPUNKNOWN * pVal )

HRESULT ICaoVariables::Add | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoVariable ** | ppICaoVar
 | ) |

HRESULT ICaoVariables::Clear ( )

HRESULT ICaoVariables::Count ( [out, retval] long * pVal )

HRESULT ICaoVariables::IsMember | ( | [in] VARIANT | Index,
 |  | [out, retval] VARIANT_BOOL * | pVal
 | ) |

HRESULT ICaoVariables::Item | ( | [in] VARIANT | Index,
 |  | [out, retval] ICaoVariable ** | ppICaoVar
 | ) |

HRESULT ICaoVariables::Remove ( [in] VARIANT Index )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoVariables メンバ一覧

これは全メンバの一覧です。ICaoVariables継承メンバも含んでいます。
_NewEnum([out, retval] LPUNKNOWN *pVal) | ICaoVariables
Add([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoVariable **ppICaoVar) | ICaoVariables
Clear() | ICaoVariables
Count([out, retval] long *pVal) | ICaoVariables
IsMember([in] VARIANT Index,[out, retval] VARIANT_BOOL *pVal) | ICaoVariables
Item([in] VARIANT Index,[out, retval] ICaoVariable **ppICaoVar) | ICaoVariables
Remove([in] VARIANT Index) | ICaoVariables
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoWorkspace interface Reference

インタフェースICaoWorkspace の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | _PutIndex ([in] long newVal)
HRESULT | Controllers ([out, retval] ICaoControllers **ppICaoCtrls)
HRESULT | Index ([out, retval] long *pVal)
HRESULT | Name ([out, retval] BSTR *pVal)
HRESULT | ProviderNames ([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal)
HRESULT | AddController ([in] BSTR bstrController,[in] BSTR bstrProvider,[in, defaultvalue("")] BSTR bstrMachine,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoController **ppICaoCtrl)
HRESULT | Execute ([in] VARIANT vntCommand,[out, retval] VARIANT *pVal)

メソッドの解説

HRESULT ICaoWorkspace::_PutIndex ( [in] long newVal )

HRESULT ICaoWorkspace::AddController | ( | [in] BSTR | bstrController,
 |  | [in] BSTR | bstrProvider,
 |  | [in, defaultvalue("")] BSTR | bstrMachine,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoController ** | ppICaoCtrl
 | ) |

HRESULT ICaoWorkspace::Controllers ( [out, retval] ICaoControllers ** ppICaoCtrls )

HRESULT ICaoWorkspace::Execute | ( | [in] VARIANT | vntCommand,
 |  | [out, retval] VARIANT * | pVal
 | ) |

HRESULT ICaoWorkspace::Index ( [out, retval] long * pVal )

HRESULT ICaoWorkspace::Name ( [out, retval] BSTR * pVal )

HRESULT ICaoWorkspace::ProviderNames | ( | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] VARIANT * | pVal
 | ) |

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoWorkspace メンバ一覧

これは全メンバの一覧です。ICaoWorkspace継承メンバも含んでいます。
_PutIndex([in] long newVal) | ICaoWorkspace
AddController([in] BSTR bstrController,[in] BSTR bstrProvider,[in, defaultvalue("")] BSTR bstrMachine,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoController **ppICaoCtrl) | ICaoWorkspace
Controllers([out, retval] ICaoControllers **ppICaoCtrls) | ICaoWorkspace
Execute([in] VARIANT vntCommand,[out, retval] VARIANT *pVal) | ICaoWorkspace
Index([out, retval] long *pVal) | ICaoWorkspace
Name([out, retval] BSTR *pVal) | ICaoWorkspace
ProviderNames([in, defaultvalue("")] BSTR bstrOption,[out, retval] VARIANT *pVal) | ICaoWorkspace
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ICaoWorkspaces interface Reference

インタフェースICaoWorkspaces の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT | _NewEnum ([out, retval] LPUNKNOWN *pVal)
HRESULT | Item ([in] VARIANT Index,[out, retval] ICaoWorkspace **ppICaoWS)
HRESULT | Count ([out, retval] long *pVal)
HRESULT | Add ([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoWorkspace **ppICaoWS)
HRESULT | Remove ([in] VARIANT Index)
HRESULT | Clear ()
HRESULT | IsMember ([in] VARIANT Index,[out, retval] VARIANT_BOOL *pVal)

メソッドの解説

HRESULT ICaoWorkspaces::_NewEnum ( [out, retval] LPUNKNOWN * pVal )

HRESULT ICaoWorkspaces::Add | ( | [in] BSTR | bstrName,
 |  | [in, defaultvalue("")] BSTR | bstrOption,
 |  | [out, retval] ICaoWorkspace ** | ppICaoWS
 | ) |

HRESULT ICaoWorkspaces::Clear ( )

HRESULT ICaoWorkspaces::Count ( [out, retval] long * pVal )

HRESULT ICaoWorkspaces::IsMember | ( | [in] VARIANT | Index,
 |  | [out, retval] VARIANT_BOOL * | pVal
 | ) |

HRESULT ICaoWorkspaces::Item | ( | [in] VARIANT | Index,
 |  | [out, retval] ICaoWorkspace ** | ppICaoWS
 | ) |

HRESULT ICaoWorkspaces::Remove ( [in] VARIANT Index )

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

ICaoWorkspaces メンバ一覧

これは全メンバの一覧です。ICaoWorkspaces継承メンバも含んでいます。
_NewEnum([out, retval] LPUNKNOWN *pVal) | ICaoWorkspaces
Add([in] BSTR bstrName,[in, defaultvalue("")] BSTR bstrOption,[out, retval] ICaoWorkspace **ppICaoWS) | ICaoWorkspaces
Clear() | ICaoWorkspaces
Count([out, retval] long *pVal) | ICaoWorkspaces
IsMember([in] VARIANT Index,[out, retval] VARIANT_BOOL *pVal) | ICaoWorkspaces
Item([in] VARIANT Index,[out, retval] ICaoWorkspace **ppICaoWS) | ICaoWorkspaces
Remove([in] VARIANT Index) | ICaoWorkspaces
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


IConnectionPointImpl class Reference

クラス IConnectionPointImpl の解説

IConnectionPointImplに対する継承グラフ

[凡例]
このクラスの解説は次のファイルから生成されました:
  • CAOCP.h
Generated on Wed Dec 7 19:02:11 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


IDispatchImpl class Reference

クラス IDispatchImpl の解説

IDispatchImplに対する継承グラフ

[凡例]
このクラスの解説は次のファイルから生成されました:
  • CaoObjectTmpl.h
Generated on Wed Dec 7 19:02:12 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


IEventSink interface Reference

インタフェースIEventSink の解説

import "CAO.idl";

すべてのメンバ一覧

Public メソッド

HRESULT OnMessage ([in] IUnknown *pVal,[in, defaultvalue(0)] long lOption)

メソッドの解説

HRESULT IEventSink::OnMessage | ( | [in] IUnknown * | pVal,
 |  | [in, defaultvalue(0)] long | lOption
 | ) |

このインタフェースの解説は次のファイルから生成されました:
  • CAO.idl
Generated on Wed Dec 7 19:02:12 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

IEventSink メンバ一覧

これは全メンバの一覧です。IEventSink継承メンバも含んでいます。
OnMessage([in] IUnknown *pVal,[in, defaultvalue(0)] long lOption) IEventSink
Generated on Wed Dec 7 19:02:12 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


ISupportErrorInfo class Reference

クラス ISupportErrorInfo の解説

ISupportErrorInfoに対する継承グラフ

[凡例]
このクラスの解説は次のファイルから生成されました:
  • CaoObjectTmpl.h
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


PROV_MESSAGE struct Reference

構造体 PROV_MESSAGE の解説

メッセージ格納用構造体 [詳細]

#include <CaoController.h>

すべてのメンバ一覧

Public 変数

ICaoProvMessage * | pICaopMsg
通信プロトコル

long | lOption
オプション

解説

メッセージ格納用構造体

変数の解説

long PROV_MESSAGE::lOption

オプション

ICaoProvMessage* PROV_MESSAGE::pICaopMsg

通信プロトコル

この構造体の解説は次のファイルから生成されました:
  • CaoController.h
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


メンバ一覧

PROV_MESSAGE メンバ一覧

これは全メンバの一覧です。PROV_MESSAGE継承メンバも含んでいます。
lOption | PROV_MESSAGE
pICaopMsg | PROV_MESSAGE
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


Hierarchical Index

DENSO WAVE CAO Project クラス階層

クラス階層図を見る。

この継承一覧はおおまかにはソートされていますが、完全にアルファベット順でソートされてはいません。

  • CAOLib::_ICaoCommandsEvents
  • CAOLib::_ICaoControllerEvents
  • _IID
  • _MIDL_PROC_FORMAT_STRING
  • _MIDL_TYPE_FORMAT_STRING
  • CAOLib::CaoCommand
  • CAOLib::CaoCommands
  • CAOLib::CaoController
  • CAOLib::CaoControllers
  • CAOLib::CaoEngine
  • CAOLib::CaoEngineStatus
  • CAOLib::CaoExtension
  • CAOLib::CaoExtensions
  • CAOLib::CaoFile
  • CAOLib::CaoFiles
  • CAOLib::CaoMessage
  • CAOLib::CaoRobot
  • CAOLib::CaoRobots
  • CAOLib::CaoTask
  • CAOLib::CaoTasks
  • CAOLib::CaoVariable
  • CAOLib::CaoVariables
  • CAOLib::CaoWorkspace
  • CAOLib::CaoWorkspaces
  • CComCoClass
    • _CCaoBaseTmpl< T, pclsid, T1, piid >
      • _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >
    • _CCaoBaseTmpl< CCaoCommand, pclsid, ICaoCommand, piid >
      • _CCaoProvConnectionObjTmpl< CCaoCommand,&CLSID_CaoCommand, ICaoCommand,&IID_ICaoCommand, ICaoProvCommand >
        • CCaoCommand
    • _CCaoBaseTmpl< CCaoController, pclsid, ICaoController, piid >
      • _CCaoProvConnectionObjTmpl< CCaoController,&CLSID_CaoController, ICaoController,&IID_ICaoController, ICaoProvController >
        • CCaoController
    • _CCaoBaseTmpl< CCaoExtension, pclsid, ICaoExtension, piid >
      • _CCaoProvConnectionObjTmpl< CCaoExtension,&CLSID_CaoExtension, ICaoExtension,&IID_ICaoExtension, ICaoProvExtension >
        • CCaoExtension
    • _CCaoBaseTmpl< CCaoFile, pclsid, ICaoFile, piid >
      • _CCaoProvConnectionObjTmpl< CCaoFile,&CLSID_CaoFile, ICaoFile,&IID_ICaoFile, ICaoProvFile >
        • CCaoFile
    • _CCaoBaseTmpl< CCaoRobot, pclsid, ICaoRobot, piid >
      • _CCaoProvConnectionObjTmpl< CCaoRobot,&CLSID_CaoRobot, ICaoRobot,&IID_ICaoRobot, ICaoProvRobot >
        • CCaoRobot
    • _CCaoBaseTmpl< CCaoTask, pclsid, ICaoTask, piid >
      • _CCaoProvConnectionObjTmpl< CCaoTask,&CLSID_CaoTask, ICaoTask,&IID_ICaoTask, ICaoProvTask >
        • CCaoTask
    • _CCaoBaseTmpl< CCaoVariable, pclsid, ICaoVariable, piid >
      • _CCaoProvConnectionObjTmpl< CCaoVariable,&CLSID_CaoVariable, ICaoVariable,&IID_ICaoVariable, ICaoProvVariable >
        • CCaoVariable
    • _CCaoBaseTmpl< CCaoWorkspace,&CLSID_CaoWorkspace, ICaoWorkspace,&IID_ICaoWorkspace >
      • CCaoWorkspace
    • _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >
    • _CCaoCollectionTmpl< CCaoCommands,&CLSID_CaoCommands, ICaoCommands,&IID_ICaoCommands, ICaoCommand >
      • CCaoCommands
    • _CCaoCollectionTmpl< CCaoControllers,&CLSID_CaoControllers, ICaoControllers,&IID_ICaoControllers, ICaoController >
      • CCaoControllers
    • _CCaoCollectionTmpl< CCaoExtensions,&CLSID_CaoExtensions, ICaoExtensions,&IID_ICaoExtensions, ICaoExtension >
      • CCaoExtensions
    • _CCaoCollectionTmpl< CCaoFiles,&CLSID_CaoFiles, ICaoFiles,&IID_ICaoFiles, ICaoFile >
      • CCaoFiles
    • _CCaoCollectionTmpl< CCaoRobots,&CLSID_CaoRobots, ICaoRobots,&IID_ICaoRobots, ICaoRobot >
      • CCaoRobots
    • _CCaoCollectionTmpl< CCaoTasks,&CLSID_CaoTasks, ICaoTasks,&IID_ICaoTasks, ICaoTask >
      • CCaoTasks
    • _CCaoCollectionTmpl< CCaoVariables,&CLSID_CaoVariables, ICaoVariables,&IID_ICaoVariables, ICaoVariable >
      • CCaoVariables
    • _CCaoCollectionTmpl< CCaoWorkspaces,&CLSID_CaoWorkspaces, ICaoWorkspaces,&IID_ICaoWorkspaces, ICaoWorkspace >
      • CCaoWorkspaces
    • CCaoEngine
    • CCaoEngineStatus
    • CCaoMessage
    • CEventSink
  • CComObjectRootEx
    • _CCaoBaseTmpl< T, pclsid, T1, piid >
    • _CCaoBaseTmpl< CCaoCommand, pclsid, ICaoCommand, piid >
    • _CCaoBaseTmpl< CCaoController, pclsid, ICaoController, piid >
    • _CCaoBaseTmpl< CCaoExtension, pclsid, ICaoExtension, piid >
    • _CCaoBaseTmpl< CCaoFile, pclsid, ICaoFile, piid >
    • _CCaoBaseTmpl< CCaoRobot, pclsid, ICaoRobot, piid >
    • _CCaoBaseTmpl< CCaoTask, pclsid, ICaoTask, piid >
    • _CCaoBaseTmpl< CCaoVariable, pclsid, ICaoVariable, piid >
    • _CCaoBaseTmpl< CCaoWorkspace,&CLSID_CaoWorkspace, ICaoWorkspace,&IID_ICaoWorkspace >
    • _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >
    • _CCaoCollectionTmpl< CCaoCommands,&CLSID_CaoCommands, ICaoCommands,&IID_ICaoCommands, ICaoCommand >
    • _CCaoCollectionTmpl< CCaoControllers,&CLSID_CaoControllers, ICaoControllers,&IID_ICaoControllers, ICaoController >
    • _CCaoCollectionTmpl< CCaoExtensions,&CLSID_CaoExtensions, ICaoExtensions,&IID_ICaoExtensions, ICaoExtension >
    • _CCaoCollectionTmpl< CCaoFiles,&CLSID_CaoFiles, ICaoFiles,&IID_ICaoFiles, ICaoFile >
    • _CCaoCollectionTmpl< CCaoRobots,&CLSID_CaoRobots, ICaoRobots,&IID_ICaoRobots, ICaoRobot >
    • _CCaoCollectionTmpl< CCaoTasks,&CLSID_CaoTasks, ICaoTasks,&IID_ICaoTasks, ICaoTask >
    • _CCaoCollectionTmpl< CCaoVariables,&CLSID_CaoVariables, ICaoVariables,&IID_ICaoVariables, ICaoVariable >
    • _CCaoCollectionTmpl< CCaoWorkspaces,&CLSID_CaoWorkspaces, ICaoWorkspaces,&IID_ICaoWorkspaces, ICaoWorkspace >
    • CCaoEngine
    • CCaoEngineStatus
    • CCaoMessage
    • CEventSink
  • CPreload
  • CProxy_ICaoExecuteCompleteEvent< T, dispid >
  • CProxy_ICaoExecuteCompleteEvent< CCaoCommands, 0x1 >
    • CProxy_ICaoCommandsEvents< CCaoCommands >
      • CCaoCommands
  • CProxy_ICaoExecuteCompleteEvent< T, 0x1 >
    • CProxy_ICaoCommandsEvents< T >
  • CProxy_ICaoOnMessageEvent< T, dispid >
  • CProxy_ICaoOnMessageEvent< CCaoController, 0x1 >
    • CProxy_ICaoControllerEvents< CCaoController >
      • CCaoController
  • CProxy_ICaoOnMessageEvent< T, 0x1 >
    • CProxy_ICaoControllerEvents< T >
  • CServiceModule
  • CAOLib::EventSink
  • ICaoCommand
  • ICaoCommands
  • ICaoController
  • ICaoControllers
  • ICaoEngine
  • ICaoEngineStatus
  • ICaoExtension
  • ICaoExtensions
  • ICaoFile
  • ICaoFiles
  • ICaoMessage
  • ICaoRobot
  • ICaoRobots
  • ICaoTask
  • ICaoTasks
  • ICaoVariable
  • ICaoVariables
  • ICaoWorkspace
  • ICaoWorkspaces
  • IConnectionPointImpl
    • CProxy_ICaoCommandsEvents< T >
    • CProxy_ICaoCommandsEvents< CCaoCommands >
    • CProxy_ICaoControllerEvents< T >
    • CProxy_ICaoControllerEvents< CCaoController >
  • IDispatchImpl
    • _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >
    • _CCaoCollectionTmpl< CCaoCommands,&CLSID_CaoCommands, ICaoCommands,&IID_ICaoCommands, ICaoCommand >
    • _CCaoCollectionTmpl< CCaoControllers,&CLSID_CaoControllers, ICaoControllers,&IID_ICaoControllers, ICaoController >
    • _CCaoCollectionTmpl< CCaoExtensions,&CLSID_CaoExtensions, ICaoExtensions,&IID_ICaoExtensions, ICaoExtension >
    • _CCaoCollectionTmpl< CCaoFiles,&CLSID_CaoFiles, ICaoFiles,&IID_ICaoFiles, ICaoFile >
    • _CCaoCollectionTmpl< CCaoRobots,&CLSID_CaoRobots, ICaoRobots,&IID_ICaoRobots, ICaoRobot >
    • _CCaoCollectionTmpl< CCaoTasks,&CLSID_CaoTasks, ICaoTasks,&IID_ICaoTasks, ICaoTask >
    • _CCaoCollectionTmpl< CCaoVariables,&CLSID_CaoVariables, ICaoVariables,&IID_ICaoVariables, ICaoVariable >
    • _CCaoCollectionTmpl< CCaoWorkspaces,&CLSID_CaoWorkspaces, ICaoWorkspaces,&IID_ICaoWorkspaces, ICaoWorkspace >
    • CCaoEngineStatus
    • CCaoMessage
    • CEventSink
    • ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass >
    • ICaoDispatchImpl< ICaoCommand, piid,&LIBID_CAOLib >
      • _CCaoBaseTmpl< CCaoCommand, pclsid, ICaoCommand, piid >
    • ICaoDispatchImpl< ICaoController, piid,&LIBID_CAOLib >
      • _CCaoBaseTmpl< CCaoController, pclsid, ICaoController, piid >
    • ICaoDispatchImpl< ICaoEngine,&IID_ICaoEngine,&LIBID_CAOLib >
      • CCaoEngine
    • ICaoDispatchImpl< ICaoExtension, piid,&LIBID_CAOLib >
      • _CCaoBaseTmpl< CCaoExtension, pclsid, ICaoExtension, piid >
    • ICaoDispatchImpl< ICaoFile, piid,&LIBID_CAOLib >
      • _CCaoBaseTmpl< CCaoFile, pclsid, ICaoFile, piid >
    • ICaoDispatchImpl< ICaoRobot, piid,&LIBID_CAOLib >
      • _CCaoBaseTmpl< CCaoRobot, pclsid, ICaoRobot, piid >
    • ICaoDispatchImpl< ICaoTask, piid,&LIBID_CAOLib >
      • _CCaoBaseTmpl< CCaoTask, pclsid, ICaoTask, piid >
    • ICaoDispatchImpl< ICaoVariable, piid,&LIBID_CAOLib >
      • _CCaoBaseTmpl< CCaoVariable, pclsid, ICaoVariable, piid >
    • ICaoDispatchImpl< ICaoWorkspace, piid,&LIBID_CAOLib >
      • _CCaoBaseTmpl< CCaoWorkspace,&CLSID_CaoWorkspace, ICaoWorkspace,&IID_ICaoWorkspace >
    • ICaoDispatchImpl< T1, piid,&LIBID_CAOLib >
      • _CCaoBaseTmpl< T, pclsid, T1, piid >
  • IEventSink
  • ISupportErrorInfo
    • _CCaoBaseTmpl< T, pclsid, T1, piid >
    • _CCaoBaseTmpl< CCaoCommand, pclsid, ICaoCommand, piid >
    • _CCaoBaseTmpl< CCaoController, pclsid, ICaoController, piid >
    • _CCaoBaseTmpl< CCaoExtension, pclsid, ICaoExtension, piid >
    • _CCaoBaseTmpl< CCaoFile, pclsid, ICaoFile, piid >
    • _CCaoBaseTmpl< CCaoRobot, pclsid, ICaoRobot, piid >
    • _CCaoBaseTmpl< CCaoTask, pclsid, ICaoTask, piid >
    • _CCaoBaseTmpl< CCaoVariable, pclsid, ICaoVariable, piid >
    • _CCaoBaseTmpl< CCaoWorkspace,&CLSID_CaoWorkspace, ICaoWorkspace,&IID_ICaoWorkspace >
    • _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >
    • _CCaoCollectionTmpl< CCaoCommands,&CLSID_CaoCommands, ICaoCommands,&IID_ICaoCommands, ICaoCommand >
    • _CCaoCollectionTmpl< CCaoControllers,&CLSID_CaoControllers, ICaoControllers,&IID_ICaoControllers, ICaoController >
    • _CCaoCollectionTmpl< CCaoExtensions,&CLSID_CaoExtensions, ICaoExtensions,&IID_ICaoExtensions, ICaoExtension >
    • _CCaoCollectionTmpl< CCaoFiles,&CLSID_CaoFiles, ICaoFiles,&IID_ICaoFiles, ICaoFile >
    • _CCaoCollectionTmpl< CCaoRobots,&CLSID_CaoRobots, ICaoRobots,&IID_ICaoRobots, ICaoRobot >
    • _CCaoCollectionTmpl< CCaoTasks,&CLSID_CaoTasks, ICaoTasks,&IID_ICaoTasks, ICaoTask >
    • _CCaoCollectionTmpl< CCaoVariables,&CLSID_CaoVariables, ICaoVariables,&IID_ICaoVariables, ICaoVariable >
    • _CCaoCollectionTmpl< CCaoWorkspaces,&CLSID_CaoWorkspaces, ICaoWorkspaces,&IID_ICaoWorkspaces, ICaoWorkspace >
    • CCaoEngine
    • CCaoMessage
    • CEventSink
  • PROV_MESSAGE
Generated on Wed Dec 7 19:01:58 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


Compound Member Index

DENSO WAVE CAO Project 構成メンバ

_ | a | b | c | d | e | f | g | h | i | l | m | n | o | p | r | s | t | u | v | w | x | ~

これはクラスメンバの一覧で、それぞれが属しているクラスの解説へリンクしています。

- _ -

  • _CCaoBaseTmpl() : _CCaoBaseTmpl< T, pclsid, T1, piid >
  • _CCaoCollectionTmpl() : _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >
  • _CCaoProvConnectionObjTmpl() : _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >
  • _Close() : CCaoController
  • _Execute0() : CCaoCommand
  • _FireExecuteComplete() : CCaoCommands
  • _FireOnMessage() : CCaoController
  • _GetICaopObj() : CCaoTask, CCaoRobot, CCaoFile, CCaoExtension, CCaoController, CCaoCommand
  • _GetICRDObj() : CCaoTask, CCaoRobot, CCaoFile, CCaoExtension, CCaoController, CCaoCommand
  • _Initialize() : CEventSink, CCaoWorkspace, CCaoVariables, CCaoVariable, CCaoTasks, CCaoTask, CCaoRobots, CCaoRobot, CCaoMessage, CCaoFiles, CCaoFile, CCaoExtensions, CCaoExtension, CCaoEngineStatus, CCaoController, CCaoCommands, CCaoCommand
  • _NewEnum() : ICaoCommands, ICaoVariables, ICaoTasks, ICaoRobots, ICaoFiles, ICaoExtensions, ICaoControllers, ICaoWorkspaces
  • _PutIndex() : _CCaoBaseTmpl< T, pclsid, T1, piid >, ICaoCommand, ICaoVariable, ICaoTask, ICaoRobot, ICaoFile, ICaoExtension, ICaoController, ICaoWorkspace
  • _Terminate() : CEventSink

- a -

  • Accelerate() : CCaoRobot, ICaoRobot
  • Add() : CCaoWorkspaces, CCaoVariables, CCaoTasks, CCaoRobots, CCaoFiles, CCaoExtensions, CCaoControllers, CCaoCommands, ICaoCommands, ICaoVariables, ICaoTasks, ICaoRobots, ICaoFiles, ICaoExtensions, ICaoControllers, ICaoWorkspaces
  • AddCommand() : CCaoController, ICaoController
  • AddController() : CCaoWorkspace, ICaoWorkspace
  • AddExtension() : CCaoController, ICaoController
  • AddFile() : CCaoFile, CCaoController, ICaoFile, ICaoController
  • AddRobot() : CCaoController, ICaoController
  • AddTask() : CCaoController, ICaoController
  • AddVariable() : CCaoTask, CCaoRobot, CCaoFile, CCaoExtension, CCaoController, ICaoTask, ICaoRobot, ICaoFile, ICaoExtension, ICaoController
  • AddWorkspace() : CCaoEngine, ICaoEngine
  • Attribute() : ICaoCommand, ICaoVariable, ICaoTask, ICaoRobot, ICaoFile, ICaoExtension, ICaoController

- b -

  • BeginWorkerThread() : CServiceModule

- c -

  • c : _IID
  • Cancel() : CCaoCommand, ICaoCommand
  • CCaoCommand() : CCaoCommand
  • CCaoCommands() : CCaoCommands
  • CCaoController() : CCaoController
  • CCaoControllers() : CCaoControllers
  • CCaoEngine() : CCaoEngine
  • CCaoEngineStatus() : CCaoEngineStatus
  • CCaoExtension() : CCaoExtension
  • CCaoExtensions() : CCaoExtensions
  • CCaoFile() : CCaoFile
  • CCaoFiles() : CCaoFiles
  • CCaoMessage() : CCaoMessage
  • CCaoRobot() : CCaoRobot
  • CCaoRobots() : CCaoRobots
  • CCaoTask() : CCaoTask
  • CCaoTasks() : CCaoTasks
  • CCaoVariable() : CCaoVariable
  • CCaoVariables() : CCaoVariables
  • CCaoWorkspace() : CCaoWorkspace
  • CCaoWorkspaces() : CCaoWorkspaces
  • CEventSink() : CEventSink
  • Change() : CCaoRobot, ICaoRobot
  • CheckAccess() : _CCaoBaseTmpl< T, pclsid, T1, piid >
  • CheckLicense() : CServiceModule
  • Chuck() : CCaoRobot, ICaoRobot
  • Clear() : CCaoMessage, _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >, ICaoMessage, ICaoCommands, ICaoVariables, ICaoTasks, ICaoRobots, ICaoFiles, ICaoExtensions, ICaoControllers, ICaoWorkspaces
  • CommandNames() : ICaoController
  • Commands() : ICaoController
  • ComputerName() : ICaoEngineStatus
  • Controllers() : ICaoWorkspace
  • Copy() : CCaoFile, ICaoFile
  • Count() : ICaoCommands, ICaoVariables, ICaoTasks, ICaoRobots, ICaoFiles, ICaoExtensions, ICaoControllers, ICaoWorkspaces
  • CPreload() : CPreload
  • CProxy_ICaoOnMessageEvent() : CProxy_ICaoOnMessageEvent< T, dispid >
  • CreateMessage() : CProxy_ICaoOnMessageEvent< T, dispid >
  • CreateUniqueName() : CServiceModule
  • CreateWorkerSemaphore() : CServiceModule
  • CServiceModule() : CServiceModule
  • CurrentDateTime() : ICaoEngineStatus
  • CustomGetIDsOfNames() : CCaoTask, CCaoRobot, ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass >, CCaoFile, CCaoExtension, CCaoController
  • CustomInvoke() : CCaoTask, CCaoRobot, ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass >, CCaoFile, CCaoExtension, CCaoController

- d -

  • DateCreated() : ICaoFile
  • DateLastAccessed() : ICaoFile
  • DateLastModified() : ICaoFile
  • DateTime() : ICaoMessage, ICaoVariable
  • DecObjectCount() : CServiceModule
  • Delete() : CCaoTask, CCaoFile, ICaoTask, ICaoFile
  • DeleteWorkerSemaphore() : CServiceModule
  • DeleteWorkerThread() : CServiceModule
  • Description() : ICaoMessage
  • Destination() : ICaoMessage
  • Drive() : CCaoRobot, ICaoRobot
  • dwThreadID : CServiceModule

- e -

  • EngineStatus() : ICaoEngine
  • Execute() : CCaoWorkspace, CCaoTask, CCaoRobot, CCaoFile, CCaoExtension, CCaoEngine, CCaoController, CCaoCommand, ICaoCommand, ICaoTask, ICaoRobot, ICaoFile, ICaoExtension, ICaoController, ICaoWorkspace, ICaoEngine
  • ExecuteComplete() : CAOLib::_ICaoCommandsEvents
  • ExitWorkerThread() : CServiceModule
  • ExtensionNames() : ICaoController
  • Extensions() : ICaoController

- f -

  • FileName() : ICaoTask
  • FileNames() : ICaoFile, ICaoController
  • Files() : ICaoFile, ICaoController
  • FinalConstruct() : CEventSink, CCaoWorkspaces, CCaoWorkspace, CCaoVariables, CCaoVariable, CCaoTasks, CCaoTask, CCaoRobots, CCaoRobot, CCaoMessage, CCaoFiles, CCaoFile, CCaoExtensions, CCaoExtension, CCaoEngineStatus, CCaoEngine, CCaoControllers, CCaoController, CCaoCommands, CCaoCommand
  • FinalRelease() : CEventSink, CCaoWorkspaces, CCaoWorkspace, CCaoVariables, CCaoVariable, CCaoTasks, CCaoTask, CCaoRobots, CCaoRobot, CCaoMessage, CCaoFiles, CCaoFile, CCaoExtensions, CCaoExtension, CCaoEngineStatus, CCaoEngine, CCaoControllers, CCaoController, CCaoCommands, CCaoCommand
  • Fire_ExecuteComplete() : CProxy_ICaoExecuteCompleteEvent< T, dispid >
  • Fire_OnMessage() : CProxy_ICaoOnMessageEvent< T, dispid >
  • Format : _MIDL_PROC_FORMAT_STRING, _MIDL_TYPE_FORMAT_STRING

- g -

  • GenerateIndex() : _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >
  • get__NewEnum() : _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >
  • get_Attribute() : _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >
  • get_CommandNames() : CCaoController
  • get_Commands() : CCaoController
  • get_ComputerName() : CCaoEngineStatus
  • get_Controllers() : CCaoWorkspace
  • get_Count() : _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >
  • get_CurrentDateTime() : CCaoEngineStatus
  • get_DateCreated() : CCaoFile
  • get_DateLastAccessed() : CCaoFile
  • get_DateLastModified() : CCaoFile
  • get_DateTime() : CCaoVariable, CCaoMessage
  • get_Description() : CCaoMessage
  • get_Destination() : CCaoMessage
  • get_EngineStatus() : CCaoEngine
  • get_ExtensionNames() : CCaoController
  • get_Extensions() : CCaoController
  • get_FileName() : CCaoTask
  • get_FileNames() : CCaoFile, CCaoController
  • get_Files() : CCaoFile, CCaoController
  • get_Help() : _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >
  • get_ID() : _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >
  • get_Index() : _CCaoBaseTmpl< T, pclsid, T1, piid >
  • get_Microsecond() : CCaoVariable
  • get_Name() : _CCaoBaseTmpl< T, pclsid, T1, piid >
  • get_Number() : CCaoMessage
  • get_ObjectCounts() : CCaoEngineStatus
  • get_Parameters() : CCaoCommand
  • get_Path() : CCaoFile
  • get_ProviderNames() : CCaoWorkspace
  • get_Result() : CCaoCommand
  • get_RobotNames() : CCaoController
  • get_Robots() : CCaoController
  • get_SerialNumber() : CCaoMessage
  • get_Size() : CCaoFile
  • get_Source() : CCaoMessage
  • get_StartDateTime() : CCaoEngineStatus
  • get_State() : CCaoCommand
  • get_Tag() : _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >
  • get_TaskNames() : CCaoController
  • get_Tasks() : CCaoController
  • get_Timeout() : CCaoCommand
  • get_Type() : CCaoFile
  • get_Value() : CCaoVariable, CCaoMessage, CCaoFile
  • get_Values() : CCaoEngineStatus
  • get_VariableNames() : CCaoTask, CCaoRobot, CCaoFile, CCaoExtension, CCaoController
  • get_Variables() : CCaoTask, CCaoRobot, CCaoFile, CCaoExtension, CCaoController
  • get_Version() : CCaoEngineStatus
  • get_Workspaces() : CCaoEngine
  • GetIDsOfNames() : ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass >
  • GetIndex() : _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >
  • GetMessage() : CCaoController, ICaoController
  • GetOptionValue() : CServiceModule
  • GoHome() : CCaoRobot, ICaoRobot

- h -

  • Halt() : CCaoRobot, ICaoRobot
  • Handler() : CServiceModule
  • Help() : ICaoCommand, ICaoVariable, ICaoTask, ICaoRobot, ICaoFile, ICaoExtension, ICaoController
  • Hold() : CCaoRobot, ICaoRobot

- i -

  • ID() : ICaoCommand, ICaoVariable, ICaoTask, ICaoRobot, ICaoFile, ICaoExtension, ICaoController
  • IncObjectCount() : CServiceModule
  • Index() : ICaoCommand, ICaoVariable, ICaoTask, ICaoRobot, ICaoFile, ICaoExtension, ICaoController, ICaoWorkspace
  • Init() : CServiceModule
  • Install() : CServiceModule
  • InterfaceSupportsErrorInfo() : CEventSink, _CCaoBaseTmpl< T, pclsid, T1, piid >, CCaoMessage, CCaoEngine, _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >
  • Invoke() : ICaoDispatchImpl< T, piid, plibid, wMajor, wMinor, tihclass >
  • IsInstalled() : CServiceModule
  • IsMember() : _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >, ICaoCommands, ICaoVariables, ICaoTasks, ICaoRobots, ICaoFiles, ICaoExtensions, ICaoControllers, ICaoWorkspaces
  • Item() : _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >, ICaoCommands, ICaoVariables, ICaoTasks, ICaoRobots, ICaoFiles, ICaoExtensions, ICaoControllers, ICaoWorkspaces

- l -

  • LogEvent() : CServiceModule
  • lOption : PROV_MESSAGE

- m -

  • m_bPreload : CServiceModule
  • m_bService : CServiceModule
  • m_bstrName : _CCaoBaseTmpl< T, pclsid, T1, piid >
  • m_bWritable : _CCaoBaseTmpl< T, pclsid, T1, piid >
  • m_dwLocaleID : CServiceModule
  • m_dwLogLevel : CServiceModule
  • m_dwLogType : CServiceModule
  • m_dwPriority : CServiceModule
  • m_hServiceStatus : CServiceModule
  • m_lIndex : _CCaoBaseTmpl< T, pclsid, T1, piid >
  • m_lObjectCount : CServiceModule
  • m_map : _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >
  • m_pICaopObj : _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >
  • m_pICRDObj : _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >
  • m_status : CServiceModule
  • m_szCRDFile : CServiceModule
  • m_szLogFile : CServiceModule
  • m_szServiceName : CServiceModule
  • m_vntTag : _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >
  • Microsecond() : ICaoVariable
  • Move() : CCaoRobot, CCaoFile, ICaoRobot, ICaoFile

- n -

  • Name() : ICaoCommand, ICaoVariable, ICaoTask, ICaoRobot, ICaoFile, ICaoExtension, ICaoController, ICaoWorkspace
  • Number() : ICaoMessage

- o -

  • ObjectCounts() : ICaoEngineStatus
  • OnMessage() : CEventSink, CAOLib::_ICaoControllerEvents, IEventSink

- p -

  • Pad : _MIDL_PROC_FORMAT_STRING, _MIDL_TYPE_FORMAT_STRING
  • Parameters() : ICaoCommand
  • ParseParameter() : CServiceModule
  • Path() : ICaoFile
  • pICaopMsg : PROV_MESSAGE
  • PreloadObject() : CPreload
  • ProviderNames() : ICaoWorkspace
  • put_ID() : _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >
  • put_Parameters() : CCaoCommand
  • put_Tag() : _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >
  • put_Timeout() : CCaoCommand
  • put_Value() : CCaoVariable, CCaoFile

- r -

  • RegisterServer() : CServiceModule
  • ReleaseWorkerSemaphore() : CServiceModule
  • Remove() : CCaoControllers, _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >, ICaoCommands, ICaoVariables, ICaoTasks, ICaoRobots, ICaoFiles, ICaoExtensions, ICaoControllers, ICaoWorkspaces
  • Reply() : CCaoMessage, ICaoMessage
  • Result() : ICaoCommand
  • RobotNames() : ICaoController
  • Robots() : ICaoController
  • Rotate() : CCaoRobot, ICaoRobot
  • Run() : CServiceModule, CCaoFile, ICaoFile

- s -

  • s1 : _IID
  • s2 : _IID
  • SerialNumber() : ICaoMessage
  • ServiceMain() : CServiceModule
  • SetServiceStatus() : CServiceModule
  • SetupAsLocalServer() : CServiceModule
  • Size() : ICaoFile
  • Source() : ICaoMessage
  • Speed() : CCaoRobot, ICaoRobot
  • Start() : CServiceModule, CCaoTask, ICaoTask
  • StartDateTime() : ICaoEngineStatus
  • State() : ICaoCommand
  • Stop() : CCaoTask, ICaoTask

- t -

  • Tag() : ICaoCommand, ICaoVariable, ICaoTask, ICaoRobot, ICaoFile, ICaoExtension, ICaoController
  • TaskNames() : ICaoController
  • Tasks() : ICaoController
  • Timeout() : ICaoCommand
  • Type() : ICaoFile

- u -

  • Unchuck() : CCaoRobot, ICaoRobot
  • Unhold() : CCaoRobot, ICaoRobot
  • Uninstall() : CServiceModule
  • Unlock() : CServiceModule
  • UnregisterServer() : CServiceModule

- v -

  • Value() : ICaoMessage, ICaoVariable, ICaoFile
  • Values() : ICaoEngineStatus
  • VariableNames() : ICaoTask, ICaoRobot, ICaoFile, ICaoExtension, ICaoController
  • Variables() : ICaoTask, ICaoRobot, ICaoFile, ICaoExtension, ICaoController
  • Version() : ICaoEngineStatus

- w -

  • Workspaces() : ICaoEngine

- x -

  • x : _IID

- ~ -

  • ~_CCaoBaseTmpl() : _CCaoBaseTmpl< T, pclsid, T1, piid >
  • ~_CCaoCollectionTmpl() : _CCaoCollectionTmpl< T, pclsid, T1, piid, TIChd >
  • ~_CCaoProvConnectionObjTmpl() : _CCaoProvConnectionObjTmpl< T, pclsid, T1, piid, TProv >
  • ~CCaoCommand() : CCaoCommand
  • ~CCaoCommands() : CCaoCommands
  • ~CCaoController() : CCaoController
  • ~CCaoControllers() : CCaoControllers
  • ~CCaoEngine() : CCaoEngine
  • ~CCaoEngineStatus() : CCaoEngineStatus
  • ~CCaoExtension() : CCaoExtension
  • ~CCaoExtensions() : CCaoExtensions
  • ~CCaoFile() : CCaoFile
  • ~CCaoFiles() : CCaoFiles
  • ~CCaoMessage() : CCaoMessage
  • ~CCaoRobot() : CCaoRobot
  • ~CCaoRobots() : CCaoRobots
  • ~CCaoTask() : CCaoTask
  • ~CCaoTasks() : CCaoTasks
  • ~CCaoVariable() : CCaoVariable
  • ~CCaoVariables() : CCaoVariables
  • ~CCaoWorkspace() : CCaoWorkspace
  • ~CCaoWorkspaces() : CCaoWorkspaces
  • ~CEventSink() : CEventSink
  • ~CPreload() : CPreload
  • ~CServiceModule() : CServiceModule
Generated on Wed Dec 7 19:01:58 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


Namespace Index

DENSO WAVE CAO Project 名前空間一覧

名前空間の一覧です。
CAOLib
std
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


CAOLib Namespace Reference

名前空間 CAOLib の解説

構成

interface | _ICaoCommandsEvents
interface | _ICaoControllerEvents
class | CaoCommand
class | CaoCommands
class | CaoController
class | CaoControllers
class | CaoEngine
class | CaoEngineStatus
class | CaoExtension
class | CaoExtensions
class | CaoFile
class | CaoFiles
class | CaoMessage
class | CaoRobot
class | CaoRobots
class | CaoTask
class | CaoTasks
class | CaoVariable
class | CaoVariables
class | CaoWorkspace
class | CaoWorkspaces
class | EventSink

関数

importlib ("stdole32.tlb")
importlib ("stdole2.tlb")

関数の解説

importlib ( "stdole2.tlb" )

importlib ( "stdole32.tlb" )

Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


std Namespace Reference

名前空間 std の解説

Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


File Member Index

DENSO WAVE CAO Project ファイルメンバ

_ | a | b | c | d | e | f | g | h | i | l | m | o | p | r | s | t | u | v

これはファイルメンバの一覧です。それぞれが属しているファイルの解説へリンクしています。

- _ -

  • __MIDL_itf_CAO_0000_v0_0_c_ifspec : CAO.h
  • __MIDL_itf_CAO_0000_v0_0_s_ifspec : CAO.h
  • __MIDL_ProcFormatString : CAO_p.c
  • __MIDL_TypeFormatString : CAO_p.c
  • __pad0__ : CAO.h
  • __pad10__ : CAO.h
  • __pad11__ : CAO.h
  • __pad12__ : CAO.h
  • __pad13__ : CAO.h
  • __pad14__ : CAO.h
  • __pad15__ : CAO.h
  • __pad16__ : CAO.h
  • __pad17__ : CAO.h
  • __pad18__ : CAO.h
  • __pad19__ : CAO.h
  • __pad1__ : CAO.h
  • __pad20__ : CAO.h
  • __pad21__ : CAO.h
  • __pad2__ : CAO.h
  • __pad3__ : CAO.h
  • __pad4__ : CAO.h
  • __pad5__ : CAO.h
  • __pad6__ : CAO.h
  • __pad7__ : CAO.h
  • __pad8__ : CAO.h
  • __pad9__ : CAO.h
  • __REQUIRED_RPCNDR_H_VERSION__ : CAO.h
  • __REQUIRED_RPCPROXY_H_VERSION__ : CAO_p.c
  • _ATL_FREE_THREADED : StdAfx.h
  • _ICaoCommandsEvents : CAO.h
  • _ICaoControllerEvents : CAO.h
  • _Module : StdAfx.h, CAO.cpp
  • _PutIndex() : CAO.h
  • _tWinMain() : CAO.cpp
  • _WIN32_WINNT : StdAfx.h

- a -

  • Accelerate() : CAO.h
  • Add() : CAO.h
  • AddCommand() : CAO.h
  • AddController() : CAO.h
  • AddExtension() : CAO.h
  • AddFile() : CAO.h
  • AddRobot() : CAO.h
  • AddTask() : CAO.h
  • AddVariable() : CAO.h
  • AddWorkspace() : CAO.h
  • AFX_PRELOAD_H__3181624D_10F6_4F8D_9A2E_35A67005CCE9__INCLUDED_ : Preload.h
  • AFX_STDAFX_H__024E8F04_C596_11D2_A0DE_00C04FDB1900__INCLUDED_ : StdAfx.h

- b -

  • BSTR_UserFree() : CAO.h
  • BSTR_UserMarshal() : CAO.h
  • BSTR_UserSize() : CAO.h
  • BSTR_UserUnmarshal() : CAO.h

- c -

  • Cancel() : CAO.h
  • CAO_CHK_REMOVED : StdAfx.h
  • CAO_CHK_WRITEABLE : StdAfx.h
  • CAO_DISPID_CMDS : StdAfx.h
  • CAO_DISPID_EXEC : StdAfx.h
  • CAO_EXECUTE_ASYNC : StdAfx.h
  • CAO_FUNCSTR_MAX : StdAfx.h
  • CAO_LOG_MSGBOX : StdAfx.h
  • CAO_OBJ_REMOVED : StdAfx.h
  • CAO_WAIT_INTAVAL : StdAfx.h
  • CAO_WORKT_MAX : StdAfx.h
  • CAO_WORKT_TIMEOUT : StdAfx.h
  • CaoCommand : CAO.h
  • CaoCommands : CAO.h
  • CaoController : CAO.h
  • CaoControllers : CAO.h
  • CaoEngine : CAO.h
  • CaoEngineStatus : CAO.h
  • CaoExtension : CAO.h
  • CaoExtensions : CAO.h
  • CaoFile : CAO.h
  • CaoFiles : CAO.h
  • CaoMessage : CAO.h
  • CaoRobot : CAO.h
  • CaoRobots : CAO.h
  • CaoTask : CAO.h
  • CaoTasks : CAO.h
  • CaoVariable : CAO.h
  • CaoVariables : CAO.h
  • CaoWorkspace : CAO.h
  • CaoWorkspaces : CAO.h
  • Change() : CAO.h
  • Chuck() : CAO.h
  • CINTERFACE_PROXY_VTABLE() : CAO_p.c
  • Clear() : CAO.h
  • CLSID : CAO_i.c
  • CLSID_CaoCommand : CAO_i.c, CAO.h
  • CLSID_CaoCommands : CAO_i.c, CAO.h
  • CLSID_CaoController : CAO_i.c, CAO.h
  • CLSID_CaoControllers : CAO_i.c, CAO.h
  • CLSID_CaoEngine : CAO_i.c, CAO.h
  • CLSID_CaoEngineStatus : CAO_i.c, CAO.h
  • CLSID_CaoExtension : CAO_i.c, CAO.h
  • CLSID_CaoExtensions : CAO_i.c, CAO.h
  • CLSID_CaoFile : CAO_i.c, CAO.h
  • CLSID_CaoFiles : CAO_i.c, CAO.h
  • CLSID_CaoMessage : CAO_i.c, CAO.h
  • CLSID_CaoRobot : CAO_i.c, CAO.h
  • CLSID_CaoRobots : CAO_i.c, CAO.h
  • CLSID_CaoTask : CAO_i.c, CAO.h
  • CLSID_CaoTasks : CAO_i.c, CAO.h
  • CLSID_CaoVariable : CAO_i.c, CAO.h
  • CLSID_CaoVariables : CAO_i.c, CAO.h
  • CLSID_CaoWorkspace : CAO_i.c, CAO.h
  • CLSID_CaoWorkspaces : CAO_i.c, CAO.h
  • CLSID_EventSink : CAO_i.c, CAO.h
  • Copy() : CAO.h
  • CoUninitializeEx() : CAO.cpp

- d -

  • DECLSPEC_UUID() : CAO.h
  • Delete() : CAO.h
  • DIID__ICaoCommandsEvents : CAO_i.c, CAO.h
  • DIID__ICaoControllerEvents : CAO_i.c, CAO.h
  • Drive() : CAO.h

- e -

  • EventSink : CAO.h
  • Execute() : CAO.h

- f -

  • FACILITY_ERROR : CAOEventInfo.h
  • FACILITY_INFORMATIONAL : CAOEventInfo.h
  • FACILITY_WARNING : CAOEventInfo.h
  • FindOneOf() : CAO.cpp

- g -

  • get_Attribute() : CAO.h
  • get_CommandNames() : CAO.h
  • get_Commands() : CAO.h
  • get_ComputerName() : CAO.h
  • get_Controllers() : CAO.h
  • get_Count() : CAO.h
  • get_DateCreated() : CAO.h
  • get_DateLastAccessed() : CAO.h
  • get_DateLastModified() : CAO.h
  • get_DateTime() : CAO.h
  • get_Description() : CAO.h
  • get_Destination() : CAO.h
  • get_ExtensionNames() : CAO.h
  • get_Extensions() : CAO.h
  • get_FileName() : CAO.h
  • get_FileNames() : CAO.h
  • get_Files() : CAO.h
  • get_Help() : CAO.h
  • get_ID() : CAO.h
  • get_Index() : CAO.h
  • get_Microsecond() : CAO.h
  • get_Name() : CAO.h
  • get_Number() : CAO.h
  • get_ObjectCounts() : CAO.h
  • get_Parameters() : CAO.h
  • get_Path() : CAO.h
  • get_ProviderNames() : CAO.h
  • get_Result() : CAO.h
  • get_RobotNames() : CAO.h
  • get_Robots() : CAO.h
  • get_SerialNumber() : CAO.h
  • get_Size() : CAO.h
  • get_Source() : CAO.h
  • get_StartDateTime() : CAO.h
  • get_State() : CAO.h
  • get_Tag() : CAO.h
  • get_TaskNames() : CAO.h
  • get_Tasks() : CAO.h
  • get_Timeout() : CAO.h
  • get_Type() : CAO.h
  • get_Value() : CAO.h
  • get_Values() : CAO.h
  • get_VariableNames() : CAO.h
  • get_Variables() : CAO.h
  • get_Version() : CAO.h
  • get_Workspaces() : CAO.h
  • GetMessage() : CAO.h
  • GoHome() : CAO.h

- h -

  • Halt() : CAO.h
  • Hold() : CAO.h

- i -

  • ICaoCommand : CAO.h
  • ICaoCommand__PutIndex_Proxy() : CAO.h
  • ICaoCommand__PutIndex_Stub() : CAO.h
  • ICaoCommand_Cancel_Proxy() : CAO.h
  • ICaoCommand_Cancel_Stub() : CAO.h
  • ICaoCommand_Execute_Proxy() : CAO.h
  • ICaoCommand_Execute_Stub() : CAO.h
  • ICaoCommand_get_Attribute_Proxy() : CAO.h
  • ICaoCommand_get_Attribute_Stub() : CAO.h
  • ICaoCommand_get_Help_Proxy() : CAO.h
  • ICaoCommand_get_Help_Stub() : CAO.h
  • ICaoCommand_get_ID_Proxy() : CAO.h
  • ICaoCommand_get_ID_Stub() : CAO.h
  • ICaoCommand_get_Index_Proxy() : CAO.h
  • ICaoCommand_get_Index_Stub() : CAO.h
  • ICaoCommand_get_Name_Proxy() : CAO.h
  • ICaoCommand_get_Name_Stub() : CAO.h
  • ICaoCommand_get_Parameters_Proxy() : CAO.h
  • ICaoCommand_get_Parameters_Stub() : CAO.h
  • ICaoCommand_get_Result_Proxy() : CAO.h
  • ICaoCommand_get_Result_Stub() : CAO.h
  • ICaoCommand_get_State_Proxy() : CAO.h
  • ICaoCommand_get_State_Stub() : CAO.h
  • ICaoCommand_get_Tag_Proxy() : CAO.h
  • ICaoCommand_get_Tag_Stub() : CAO.h
  • ICaoCommand_get_Timeout_Proxy() : CAO.h
  • ICaoCommand_get_Timeout_Stub() : CAO.h
  • ICaoCommand_put_ID_Proxy() : CAO.h
  • ICaoCommand_put_ID_Stub() : CAO.h
  • ICaoCommand_put_Parameters_Proxy() : CAO.h
  • ICaoCommand_put_Parameters_Stub() : CAO.h
  • ICaoCommand_put_Tag_Proxy() : CAO.h
  • ICaoCommand_put_Tag_Stub() : CAO.h
  • ICaoCommand_put_Timeout_Proxy() : CAO.h
  • ICaoCommand_put_Timeout_Stub() : CAO.h
  • ICaoCommands : CAO.h
  • ICaoCommands_Add_Proxy() : CAO.h
  • ICaoCommands_Add_Stub() : CAO.h
  • ICaoCommands_Clear_Proxy() : CAO.h
  • ICaoCommands_Clear_Stub() : CAO.h
  • ICaoCommands_get__NewEnum_Proxy() : CAO.h
  • ICaoCommands_get__NewEnum_Stub() : CAO.h
  • ICaoCommands_get_Count_Proxy() : CAO.h
  • ICaoCommands_get_Count_Stub() : CAO.h
  • ICaoCommands_IsMember_Proxy() : CAO.h
  • ICaoCommands_IsMember_Stub() : CAO.h
  • ICaoCommands_Item_Proxy() : CAO.h
  • ICaoCommands_Item_Stub() : CAO.h
  • ICaoCommands_Remove_Proxy() : CAO.h
  • ICaoCommands_Remove_Stub() : CAO.h
  • ICaoController : CAO.h
  • ICaoController__PutIndex_Proxy() : CAO.h
  • ICaoController__PutIndex_Stub() : CAO.h
  • ICaoController_AddCommand_Proxy() : CAO.h
  • ICaoController_AddCommand_Stub() : CAO.h
  • ICaoController_AddExtension_Proxy() : CAO.h
  • ICaoController_AddExtension_Stub() : CAO.h
  • ICaoController_AddFile_Proxy() : CAO.h
  • ICaoController_AddFile_Stub() : CAO.h
  • ICaoController_AddRobot_Proxy() : CAO.h
  • ICaoController_AddRobot_Stub() : CAO.h
  • ICaoController_AddTask_Proxy() : CAO.h
  • ICaoController_AddTask_Stub() : CAO.h
  • ICaoController_AddVariable_Proxy() : CAO.h
  • ICaoController_AddVariable_Stub() : CAO.h
  • ICaoController_Execute_Proxy() : CAO.h
  • ICaoController_Execute_Stub() : CAO.h
  • ICaoController_get_Attribute_Proxy() : CAO.h
  • ICaoController_get_Attribute_Stub() : CAO.h
  • ICaoController_get_CommandNames_Proxy() : CAO.h
  • ICaoController_get_CommandNames_Stub() : CAO.h
  • ICaoController_get_Commands_Proxy() : CAO.h
  • ICaoController_get_Commands_Stub() : CAO.h
  • ICaoController_get_ExtensionNames_Proxy() : CAO.h
  • ICaoController_get_ExtensionNames_Stub() : CAO.h
  • ICaoController_get_Extensions_Proxy() : CAO.h
  • ICaoController_get_Extensions_Stub() : CAO.h
  • ICaoController_get_FileNames_Proxy() : CAO.h
  • ICaoController_get_FileNames_Stub() : CAO.h
  • ICaoController_get_Files_Proxy() : CAO.h
  • ICaoController_get_Files_Stub() : CAO.h
  • ICaoController_get_Help_Proxy() : CAO.h
  • ICaoController_get_Help_Stub() : CAO.h
  • ICaoController_get_ID_Proxy() : CAO.h
  • ICaoController_get_ID_Stub() : CAO.h
  • ICaoController_get_Index_Proxy() : CAO.h
  • ICaoController_get_Index_Stub() : CAO.h
  • ICaoController_get_Name_Proxy() : CAO.h
  • ICaoController_get_Name_Stub() : CAO.h
  • ICaoController_get_RobotNames_Proxy() : CAO.h
  • ICaoController_get_RobotNames_Stub() : CAO.h
  • ICaoController_get_Robots_Proxy() : CAO.h
  • ICaoController_get_Robots_Stub() : CAO.h
  • ICaoController_get_Tag_Proxy() : CAO.h
  • ICaoController_get_Tag_Stub() : CAO.h
  • ICaoController_get_TaskNames_Proxy() : CAO.h
  • ICaoController_get_TaskNames_Stub() : CAO.h
  • ICaoController_get_Tasks_Proxy() : CAO.h
  • ICaoController_get_Tasks_Stub() : CAO.h
  • ICaoController_get_VariableNames_Proxy() : CAO.h
  • ICaoController_get_VariableNames_Stub() : CAO.h
  • ICaoController_get_Variables_Proxy() : CAO.h
  • ICaoController_get_Variables_Stub() : CAO.h
  • ICaoController_GetMessage_Proxy() : CAO.h
  • ICaoController_GetMessage_Stub() : CAO.h
  • ICaoController_put_ID_Proxy() : CAO.h
  • ICaoController_put_ID_Stub() : CAO.h
  • ICaoController_put_Tag_Proxy() : CAO.h
  • ICaoController_put_Tag_Stub() : CAO.h
  • ICaoControllers : CAO.h
  • ICaoControllers_Add_Proxy() : CAO.h
  • ICaoControllers_Add_Stub() : CAO.h
  • ICaoControllers_Clear_Proxy() : CAO.h
  • ICaoControllers_Clear_Stub() : CAO.h
  • ICaoControllers_get__NewEnum_Proxy() : CAO.h
  • ICaoControllers_get__NewEnum_Stub() : CAO.h
  • ICaoControllers_get_Count_Proxy() : CAO.h
  • ICaoControllers_get_Count_Stub() : CAO.h
  • ICaoControllers_IsMember_Proxy() : CAO.h
  • ICaoControllers_IsMember_Stub() : CAO.h
  • ICaoControllers_Item_Proxy() : CAO.h
  • ICaoControllers_Item_Stub() : CAO.h
  • ICaoControllers_Remove_Proxy() : CAO.h
  • ICaoControllers_Remove_Stub() : CAO.h
  • ICaoEngine : CAO.h
  • ICaoEngine_AddWorkspace_Proxy() : CAO.h
  • ICaoEngine_AddWorkspace_Stub() : CAO.h
  • ICaoEngine_Execute_Proxy() : CAO.h
  • ICaoEngine_Execute_Stub() : CAO.h
  • ICaoEngine_FormatStringOffsetTable : CAO_p.c
  • ICaoEngine_get_EngineStatus_Proxy() : CAO.h
  • ICaoEngine_get_EngineStatus_Stub() : CAO.h
  • ICaoEngine_get_Workspaces_Proxy() : CAO.h
  • ICaoEngine_get_Workspaces_Stub() : CAO.h
  • ICaoEngine_ProxyInfo : CAO_p.c
  • ICaoEngine_ServerInfo : CAO_p.c
  • ICaoEngineStatus : CAO.h
  • ICaoEngineStatus_get_ComputerName_Proxy() : CAO.h
  • ICaoEngineStatus_get_ComputerName_Stub() : CAO.h
  • ICaoEngineStatus_get_CurrentDateTime_Proxy() : CAO.h
  • ICaoEngineStatus_get_CurrentDateTime_Stub() : CAO.h
  • ICaoEngineStatus_get_ObjectCounts_Proxy() : CAO.h
  • ICaoEngineStatus_get_ObjectCounts_Stub() : CAO.h
  • ICaoEngineStatus_get_StartDateTime_Proxy() : CAO.h
  • ICaoEngineStatus_get_StartDateTime_Stub() : CAO.h
  • ICaoEngineStatus_get_Values_Proxy() : CAO.h
  • ICaoEngineStatus_get_Values_Stub() : CAO.h
  • ICaoEngineStatus_get_Version_Proxy() : CAO.h
  • ICaoEngineStatus_get_Version_Stub() : CAO.h
  • ICaoExtension : CAO.h
  • ICaoExtension__PutIndex_Proxy() : CAO.h
  • ICaoExtension__PutIndex_Stub() : CAO.h
  • ICaoExtension_AddVariable_Proxy() : CAO.h
  • ICaoExtension_AddVariable_Stub() : CAO.h
  • ICaoExtension_Execute_Proxy() : CAO.h
  • ICaoExtension_Execute_Stub() : CAO.h
  • ICaoExtension_get_Attribute_Proxy() : CAO.h
  • ICaoExtension_get_Attribute_Stub() : CAO.h
  • ICaoExtension_get_Help_Proxy() : CAO.h
  • ICaoExtension_get_Help_Stub() : CAO.h
  • ICaoExtension_get_ID_Proxy() : CAO.h
  • ICaoExtension_get_ID_Stub() : CAO.h
  • ICaoExtension_get_Index_Proxy() : CAO.h
  • ICaoExtension_get_Index_Stub() : CAO.h
  • ICaoExtension_get_Name_Proxy() : CAO.h
  • ICaoExtension_get_Name_Stub() : CAO.h
  • ICaoExtension_get_Tag_Proxy() : CAO.h
  • ICaoExtension_get_Tag_Stub() : CAO.h
  • ICaoExtension_get_VariableNames_Proxy() : CAO.h
  • ICaoExtension_get_VariableNames_Stub() : CAO.h
  • ICaoExtension_get_Variables_Proxy() : CAO.h
  • ICaoExtension_get_Variables_Stub() : CAO.h
  • ICaoExtension_put_ID_Proxy() : CAO.h
  • ICaoExtension_put_ID_Stub() : CAO.h
  • ICaoExtension_put_Tag_Proxy() : CAO.h
  • ICaoExtension_put_Tag_Stub() : CAO.h
  • ICaoExtensions : CAO.h
  • ICaoExtensions_Add_Proxy() : CAO.h
  • ICaoExtensions_Add_Stub() : CAO.h
  • ICaoExtensions_Clear_Proxy() : CAO.h
  • ICaoExtensions_Clear_Stub() : CAO.h
  • ICaoExtensions_get__NewEnum_Proxy() : CAO.h
  • ICaoExtensions_get__NewEnum_Stub() : CAO.h
  • ICaoExtensions_get_Count_Proxy() : CAO.h
  • ICaoExtensions_get_Count_Stub() : CAO.h
  • ICaoExtensions_IsMember_Proxy() : CAO.h
  • ICaoExtensions_IsMember_Stub() : CAO.h
  • ICaoExtensions_Item_Proxy() : CAO.h
  • ICaoExtensions_Item_Stub() : CAO.h
  • ICaoExtensions_Remove_Proxy() : CAO.h
  • ICaoExtensions_Remove_Stub() : CAO.h
  • ICaoFile : CAO.h
  • ICaoFile__PutIndex_Proxy() : CAO.h
  • ICaoFile__PutIndex_Stub() : CAO.h
  • ICaoFile_AddFile_Proxy() : CAO.h
  • ICaoFile_AddFile_Stub() : CAO.h
  • ICaoFile_AddVariable_Proxy() : CAO.h
  • ICaoFile_AddVariable_Stub() : CAO.h
  • ICaoFile_Copy_Proxy() : CAO.h
  • ICaoFile_Copy_Stub() : CAO.h
  • ICaoFile_Delete_Proxy() : CAO.h
  • ICaoFile_Delete_Stub() : CAO.h
  • ICaoFile_Execute_Proxy() : CAO.h
  • ICaoFile_Execute_Stub() : CAO.h
  • ICaoFile_get_Attribute_Proxy() : CAO.h
  • ICaoFile_get_Attribute_Stub() : CAO.h
  • ICaoFile_get_DateCreated_Proxy() : CAO.h
  • ICaoFile_get_DateCreated_Stub() : CAO.h
  • ICaoFile_get_DateLastAccessed_Proxy() : CAO.h
  • ICaoFile_get_DateLastAccessed_Stub() : CAO.h
  • ICaoFile_get_DateLastModified_Proxy() : CAO.h
  • ICaoFile_get_DateLastModified_Stub() : CAO.h
  • ICaoFile_get_FileNames_Proxy() : CAO.h
  • ICaoFile_get_FileNames_Stub() : CAO.h
  • ICaoFile_get_Files_Proxy() : CAO.h
  • ICaoFile_get_Files_Stub() : CAO.h
  • ICaoFile_get_Help_Proxy() : CAO.h
  • ICaoFile_get_Help_Stub() : CAO.h
  • ICaoFile_get_ID_Proxy() : CAO.h
  • ICaoFile_get_ID_Stub() : CAO.h
  • ICaoFile_get_Index_Proxy() : CAO.h
  • ICaoFile_get_Index_Stub() : CAO.h
  • ICaoFile_get_Name_Proxy() : CAO.h
  • ICaoFile_get_Name_Stub() : CAO.h
  • ICaoFile_get_Path_Proxy() : CAO.h
  • ICaoFile_get_Path_Stub() : CAO.h
  • ICaoFile_get_Size_Proxy() : CAO.h
  • ICaoFile_get_Size_Stub() : CAO.h
  • ICaoFile_get_Tag_Proxy() : CAO.h
  • ICaoFile_get_Tag_Stub() : CAO.h
  • ICaoFile_get_Type_Proxy() : CAO.h
  • ICaoFile_get_Type_Stub() : CAO.h
  • ICaoFile_get_Value_Proxy() : CAO.h
  • ICaoFile_get_Value_Stub() : CAO.h
  • ICaoFile_get_VariableNames_Proxy() : CAO.h
  • ICaoFile_get_VariableNames_Stub() : CAO.h
  • ICaoFile_get_Variables_Proxy() : CAO.h
  • ICaoFile_get_Variables_Stub() : CAO.h
  • ICaoFile_Move_Proxy() : CAO.h
  • ICaoFile_Move_Stub() : CAO.h
  • ICaoFile_put_ID_Proxy() : CAO.h
  • ICaoFile_put_ID_Stub() : CAO.h
  • ICaoFile_put_Tag_Proxy() : CAO.h
  • ICaoFile_put_Tag_Stub() : CAO.h
  • ICaoFile_put_Value_Proxy() : CAO.h
  • ICaoFile_put_Value_Stub() : CAO.h
  • ICaoFile_Run_Proxy() : CAO.h
  • ICaoFile_Run_Stub() : CAO.h
  • ICaoFiles : CAO.h
  • ICaoFiles_Add_Proxy() : CAO.h
  • ICaoFiles_Add_Stub() : CAO.h
  • ICaoFiles_Clear_Proxy() : CAO.h
  • ICaoFiles_Clear_Stub() : CAO.h
  • ICaoFiles_get__NewEnum_Proxy() : CAO.h
  • ICaoFiles_get__NewEnum_Stub() : CAO.h
  • ICaoFiles_get_Count_Proxy() : CAO.h
  • ICaoFiles_get_Count_Stub() : CAO.h
  • ICaoFiles_IsMember_Proxy() : CAO.h
  • ICaoFiles_IsMember_Stub() : CAO.h
  • ICaoFiles_Item_Proxy() : CAO.h
  • ICaoFiles_Item_Stub() : CAO.h
  • ICaoFiles_Remove_Proxy() : CAO.h
  • ICaoFiles_Remove_Stub() : CAO.h
  • ICaoMessage : CAO.h
  • ICaoMessage_Clear_Proxy() : CAO.h
  • ICaoMessage_Clear_Stub() : CAO.h
  • ICaoMessage_get_DateTime_Proxy() : CAO.h
  • ICaoMessage_get_DateTime_Stub() : CAO.h
  • ICaoMessage_get_Description_Proxy() : CAO.h
  • ICaoMessage_get_Description_Stub() : CAO.h
  • ICaoMessage_get_Destination_Proxy() : CAO.h
  • ICaoMessage_get_Destination_Stub() : CAO.h
  • ICaoMessage_get_Number_Proxy() : CAO.h
  • ICaoMessage_get_Number_Stub() : CAO.h
  • ICaoMessage_get_SerialNumber_Proxy() : CAO.h
  • ICaoMessage_get_SerialNumber_Stub() : CAO.h
  • ICaoMessage_get_Source_Proxy() : CAO.h
  • ICaoMessage_get_Source_Stub() : CAO.h
  • ICaoMessage_get_Value_Proxy() : CAO.h
  • ICaoMessage_get_Value_Stub() : CAO.h
  • ICaoMessage_Reply_Proxy() : CAO.h
  • ICaoMessage_Reply_Stub() : CAO.h
  • ICaoRobot : CAO.h
  • ICaoRobot__PutIndex_Proxy() : CAO.h
  • ICaoRobot__PutIndex_Stub() : CAO.h
  • ICaoRobot_Accelerate_Proxy() : CAO.h
  • ICaoRobot_Accelerate_Stub() : CAO.h
  • ICaoRobot_AddVariable_Proxy() : CAO.h
  • ICaoRobot_AddVariable_Stub() : CAO.h
  • ICaoRobot_Change_Proxy() : CAO.h
  • ICaoRobot_Change_Stub() : CAO.h
  • ICaoRobot_Chuck_Proxy() : CAO.h
  • ICaoRobot_Chuck_Stub() : CAO.h
  • ICaoRobot_Drive_Proxy() : CAO.h
  • ICaoRobot_Drive_Stub() : CAO.h
  • ICaoRobot_Execute_Proxy() : CAO.h
  • ICaoRobot_Execute_Stub() : CAO.h
  • ICaoRobot_get_Attribute_Proxy() : CAO.h
  • ICaoRobot_get_Attribute_Stub() : CAO.h
  • ICaoRobot_get_Help_Proxy() : CAO.h
  • ICaoRobot_get_Help_Stub() : CAO.h
  • ICaoRobot_get_ID_Proxy() : CAO.h
  • ICaoRobot_get_ID_Stub() : CAO.h
  • ICaoRobot_get_Index_Proxy() : CAO.h
  • ICaoRobot_get_Index_Stub() : CAO.h
  • ICaoRobot_get_Name_Proxy() : CAO.h
  • ICaoRobot_get_Name_Stub() : CAO.h
  • ICaoRobot_get_Tag_Proxy() : CAO.h
  • ICaoRobot_get_Tag_Stub() : CAO.h
  • ICaoRobot_get_VariableNames_Proxy() : CAO.h
  • ICaoRobot_get_VariableNames_Stub() : CAO.h
  • ICaoRobot_get_Variables_Proxy() : CAO.h
  • ICaoRobot_get_Variables_Stub() : CAO.h
  • ICaoRobot_GoHome_Proxy() : CAO.h
  • ICaoRobot_GoHome_Stub() : CAO.h
  • ICaoRobot_Halt_Proxy() : CAO.h
  • ICaoRobot_Halt_Stub() : CAO.h
  • ICaoRobot_Hold_Proxy() : CAO.h
  • ICaoRobot_Hold_Stub() : CAO.h
  • ICaoRobot_Move_Proxy() : CAO.h
  • ICaoRobot_Move_Stub() : CAO.h
  • ICaoRobot_put_ID_Proxy() : CAO.h
  • ICaoRobot_put_ID_Stub() : CAO.h
  • ICaoRobot_put_Tag_Proxy() : CAO.h
  • ICaoRobot_put_Tag_Stub() : CAO.h
  • ICaoRobot_Rotate_Proxy() : CAO.h
  • ICaoRobot_Rotate_Stub() : CAO.h
  • ICaoRobot_Speed_Proxy() : CAO.h
  • ICaoRobot_Speed_Stub() : CAO.h
  • ICaoRobot_Unchuck_Proxy() : CAO.h
  • ICaoRobot_Unchuck_Stub() : CAO.h
  • ICaoRobot_Unhold_Proxy() : CAO.h
  • ICaoRobot_Unhold_Stub() : CAO.h
  • ICaoRobots : CAO.h
  • ICaoRobots_Add_Proxy() : CAO.h
  • ICaoRobots_Add_Stub() : CAO.h
  • ICaoRobots_Clear_Proxy() : CAO.h
  • ICaoRobots_Clear_Stub() : CAO.h
  • ICaoRobots_get__NewEnum_Proxy() : CAO.h
  • ICaoRobots_get__NewEnum_Stub() : CAO.h
  • ICaoRobots_get_Count_Proxy() : CAO.h
  • ICaoRobots_get_Count_Stub() : CAO.h
  • ICaoRobots_IsMember_Proxy() : CAO.h
  • ICaoRobots_IsMember_Stub() : CAO.h
  • ICaoRobots_Item_Proxy() : CAO.h
  • ICaoRobots_Item_Stub() : CAO.h
  • ICaoRobots_Remove_Proxy() : CAO.h
  • ICaoRobots_Remove_Stub() : CAO.h
  • ICaoTask : CAO.h
  • ICaoTask__PutIndex_Proxy() : CAO.h
  • ICaoTask__PutIndex_Stub() : CAO.h
  • ICaoTask_AddVariable_Proxy() : CAO.h
  • ICaoTask_AddVariable_Stub() : CAO.h
  • ICaoTask_Delete_Proxy() : CAO.h
  • ICaoTask_Delete_Stub() : CAO.h
  • ICaoTask_Execute_Proxy() : CAO.h
  • ICaoTask_Execute_Stub() : CAO.h
  • ICaoTask_get_Attribute_Proxy() : CAO.h
  • ICaoTask_get_Attribute_Stub() : CAO.h
  • ICaoTask_get_FileName_Proxy() : CAO.h
  • ICaoTask_get_FileName_Stub() : CAO.h
  • ICaoTask_get_Help_Proxy() : CAO.h
  • ICaoTask_get_Help_Stub() : CAO.h
  • ICaoTask_get_ID_Proxy() : CAO.h
  • ICaoTask_get_ID_Stub() : CAO.h
  • ICaoTask_get_Index_Proxy() : CAO.h
  • ICaoTask_get_Index_Stub() : CAO.h
  • ICaoTask_get_Name_Proxy() : CAO.h
  • ICaoTask_get_Name_Stub() : CAO.h
  • ICaoTask_get_Tag_Proxy() : CAO.h
  • ICaoTask_get_Tag_Stub() : CAO.h
  • ICaoTask_get_VariableNames_Proxy() : CAO.h
  • ICaoTask_get_VariableNames_Stub() : CAO.h
  • ICaoTask_get_Variables_Proxy() : CAO.h
  • ICaoTask_get_Variables_Stub() : CAO.h
  • ICaoTask_put_ID_Proxy() : CAO.h
  • ICaoTask_put_ID_Stub() : CAO.h
  • ICaoTask_put_Tag_Proxy() : CAO.h
  • ICaoTask_put_Tag_Stub() : CAO.h
  • ICaoTask_Start_Proxy() : CAO.h
  • ICaoTask_Start_Stub() : CAO.h
  • ICaoTask_Stop_Proxy() : CAO.h
  • ICaoTask_Stop_Stub() : CAO.h
  • ICaoTasks : CAO.h
  • ICaoTasks_Add_Proxy() : CAO.h
  • ICaoTasks_Add_Stub() : CAO.h
  • ICaoTasks_Clear_Proxy() : CAO.h
  • ICaoTasks_Clear_Stub() : CAO.h
  • ICaoTasks_get__NewEnum_Proxy() : CAO.h
  • ICaoTasks_get__NewEnum_Stub() : CAO.h
  • ICaoTasks_get_Count_Proxy() : CAO.h
  • ICaoTasks_get_Count_Stub() : CAO.h
  • ICaoTasks_IsMember_Proxy() : CAO.h
  • ICaoTasks_IsMember_Stub() : CAO.h
  • ICaoTasks_Item_Proxy() : CAO.h
  • ICaoTasks_Item_Stub() : CAO.h
  • ICaoTasks_Remove_Proxy() : CAO.h
  • ICaoTasks_Remove_Stub() : CAO.h
  • ICaoVariable : CAO.h
  • ICaoVariable__PutIndex_Proxy() : CAO.h
  • ICaoVariable__PutIndex_Stub() : CAO.h
  • ICaoVariable_get_Attribute_Proxy() : CAO.h
  • ICaoVariable_get_Attribute_Stub() : CAO.h
  • ICaoVariable_get_DateTime_Proxy() : CAO.h
  • ICaoVariable_get_DateTime_Stub() : CAO.h
  • ICaoVariable_get_Help_Proxy() : CAO.h
  • ICaoVariable_get_Help_Stub() : CAO.h
  • ICaoVariable_get_ID_Proxy() : CAO.h
  • ICaoVariable_get_ID_Stub() : CAO.h
  • ICaoVariable_get_Index_Proxy() : CAO.h
  • ICaoVariable_get_Index_Stub() : CAO.h
  • ICaoVariable_get_Microsecond_Proxy() : CAO.h
  • ICaoVariable_get_Microsecond_Stub() : CAO.h
  • ICaoVariable_get_Name_Proxy() : CAO.h
  • ICaoVariable_get_Name_Stub() : CAO.h
  • ICaoVariable_get_Tag_Proxy() : CAO.h
  • ICaoVariable_get_Tag_Stub() : CAO.h
  • ICaoVariable_get_Value_Proxy() : CAO.h
  • ICaoVariable_get_Value_Stub() : CAO.h
  • ICaoVariable_put_ID_Proxy() : CAO.h
  • ICaoVariable_put_ID_Stub() : CAO.h
  • ICaoVariable_put_Tag_Proxy() : CAO.h
  • ICaoVariable_put_Tag_Stub() : CAO.h
  • ICaoVariable_put_Value_Proxy() : CAO.h
  • ICaoVariable_put_Value_Stub() : CAO.h
  • ICaoVariables : CAO.h
  • ICaoVariables_Add_Proxy() : CAO.h
  • ICaoVariables_Add_Stub() : CAO.h
  • ICaoVariables_Clear_Proxy() : CAO.h
  • ICaoVariables_Clear_Stub() : CAO.h
  • ICaoVariables_get__NewEnum_Proxy() : CAO.h
  • ICaoVariables_get__NewEnum_Stub() : CAO.h
  • ICaoVariables_get_Count_Proxy() : CAO.h
  • ICaoVariables_get_Count_Stub() : CAO.h
  • ICaoVariables_IsMember_Proxy() : CAO.h
  • ICaoVariables_IsMember_Stub() : CAO.h
  • ICaoVariables_Item_Proxy() : CAO.h
  • ICaoVariables_Item_Stub() : CAO.h
  • ICaoVariables_Remove_Proxy() : CAO.h
  • ICaoVariables_Remove_Stub() : CAO.h
  • ICaoWorkspace : CAO.h
  • ICaoWorkspace__PutIndex_Proxy() : CAO.h
  • ICaoWorkspace__PutIndex_Stub() : CAO.h
  • ICaoWorkspace_AddController_Proxy() : CAO.h
  • ICaoWorkspace_AddController_Stub() : CAO.h
  • ICaoWorkspace_Execute_Proxy() : CAO.h
  • ICaoWorkspace_Execute_Stub() : CAO.h
  • ICaoWorkspace_get_Controllers_Proxy() : CAO.h
  • ICaoWorkspace_get_Controllers_Stub() : CAO.h
  • ICaoWorkspace_get_Index_Proxy() : CAO.h
  • ICaoWorkspace_get_Index_Stub() : CAO.h
  • ICaoWorkspace_get_Name_Proxy() : CAO.h
  • ICaoWorkspace_get_Name_Stub() : CAO.h
  • ICaoWorkspace_get_ProviderNames_Proxy() : CAO.h
  • ICaoWorkspace_get_ProviderNames_Stub() : CAO.h
  • ICaoWorkspaces : CAO.h
  • ICaoWorkspaces_Add_Proxy() : CAO.h
  • ICaoWorkspaces_Add_Stub() : CAO.h
  • ICaoWorkspaces_Clear_Proxy() : CAO.h
  • ICaoWorkspaces_Clear_Stub() : CAO.h
  • ICaoWorkspaces_get__NewEnum_Proxy() : CAO.h
  • ICaoWorkspaces_get__NewEnum_Stub() : CAO.h
  • ICaoWorkspaces_get_Count_Proxy() : CAO.h
  • ICaoWorkspaces_get_Count_Stub() : CAO.h
  • ICaoWorkspaces_IsMember_Proxy() : CAO.h
  • ICaoWorkspaces_IsMember_Stub() : CAO.h
  • ICaoWorkspaces_Item_Proxy() : CAO.h
  • ICaoWorkspaces_Item_Stub() : CAO.h
  • ICaoWorkspaces_Remove_Proxy() : CAO.h
  • ICaoWorkspaces_Remove_Stub() : CAO.h
  • IDI_CAO : resource.h
  • IDR_CAO : resource.h
  • IDR_CAOCONTROLLER : resource.h
  • IDR_CAOCONTROLLERS : resource.h
  • IDR_CAOENGINE : resource.h
  • IDR_CAOERRORINFO : resource.h
  • IDR_CAOFILE : resource.h
  • IDR_CAOFILES : resource.h
  • IDR_CAOROBOT : resource.h
  • IDR_CAOROBOTS : resource.h
  • IDR_CAOSTATUS : resource.h
  • IDR_CAOTASK : resource.h
  • IDR_CAOTASKS : resource.h
  • IDR_CAOVARIABLE : resource.h
  • IDR_CAOVARIABLES : resource.h
  • IDR_CAOWORKSPACE : resource.h
  • IDR_CAOWORKSPACES : resource.h
  • IDR_EVENTSINK : resource.h
  • IDS_E_CAO_CMD_EXECUTE : resource.h
  • IDS_E_CAO_COLLECTION_REGISTERED : resource.h
  • IDS_E_CAO_COMPUTER_NAME : resource.h
  • IDS_E_CAO_NOT_WRITABLE : resource.h
  • IDS_E_CAO_OBJECT_NOTFOUND : resource.h
  • IDS_E_CAO_PROV_INVALID : resource.h
  • IDS_E_CAO_REMOTE_ENGINE : resource.h
  • IDS_E_CAO_REMOTE_PROVIDER : resource.h
  • IDS_E_CAO_SEM_CREATE : resource.h
  • IDS_E_CAO_SERVICE_PROCESS_NOSTART : resource.h
  • IDS_E_CAO_THREAD_CREATE : resource.h
  • IDS_E_CAO_VARIANT_TYPE_NOSUPPORT : resource.h
  • IDS_E_CRDIMPL : resource.h
  • IDS_SERVICENAME : resource.h
  • IEventSink : CAO.h
  • IEventSink_OnMessage_Proxy() : CAO.h
  • IEventSink_OnMessage_Stub() : CAO.h
  • IID : CAO_i.c
  • IID_ICaoCommand : CAO_i.c, CAO.h
  • IID_ICaoCommands : CAO_i.c, CAO.h
  • IID_ICaoController : CAO_i.c, CAO.h
  • IID_ICaoControllers : CAO_i.c, CAO.h
  • IID_ICaoEngine : CAO_i.c, CAO.h
  • IID_ICaoEngineStatus : CAO_i.c, CAO.h
  • IID_ICaoExtension : CAO_i.c, CAO.h
  • IID_ICaoExtensions : CAO_i.c, CAO.h
  • IID_ICaoFile : CAO_i.c, CAO.h
  • IID_ICaoFiles : CAO_i.c, CAO.h
  • IID_ICaoMessage : CAO_i.c, CAO.h
  • IID_ICaoRobot : CAO_i.c, CAO.h
  • IID_ICaoRobots : CAO_i.c, CAO.h
  • IID_ICaoTask : CAO_i.c, CAO.h
  • IID_ICaoTasks : CAO_i.c, CAO.h
  • IID_ICaoVariable : CAO_i.c, CAO.h
  • IID_ICaoVariables : CAO_i.c, CAO.h
  • IID_ICaoWorkspace : CAO_i.c, CAO.h
  • IID_ICaoWorkspaces : CAO_i.c, CAO.h
  • IID_IEventSink : CAO_i.c, CAO.h
  • IsMember() : CAO.h
  • Item() : CAO.h

- l -

  • LIBID_CAOLib : CAO_i.c, CAO.h
  • LM_AAV_ORIN_SDK : StdAfx.h
  • LM_FUNC_CAO : StdAfx.h
  • LM_VER_ORIN_SDK : StdAfx.h
  • lOption : CAO.h

- m -

  • MIDL_PROC_FORMAT_STRING : CAO_p.c
  • MIDL_TYPE_FORMAT_STRING : CAO_p.c
  • MIDL_user_allocate() : CAO.h
  • MIDL_user_free() : CAO.h
  • Move() : CAO.h
  • MSG_CAO_LOG : CAOEventInfo.h

- o -

  • Object_StubDesc : CAO_p.c

- p -

  • PROC_FORMAT_STRING_SIZE : CAO_p.c
  • PROCESS_PRIORITY : CAO.cpp
  • PROXY_DELEGATION : dlldata.c
  • put_ID() : CAO.h
  • put_Parameters() : CAO.h
  • put_Tag() : CAO.h
  • put_Timeout() : CAO.h
  • put_Value() : CAO.h

- r -

  • REFERENCE_PROXY_FILE() : dlldata.c
  • Remove() : CAO.h
  • Reply() : CAO.h
  • Rotate() : CAO.h
  • Run() : CAO.h

- s -

  • SIZEOFARRAY : StdAfx.h
  • Speed() : CAO.h
  • Start() : CAO.h
  • STATUS_SEVERITY_ERROR : CAOEventInfo.h
  • STATUS_SEVERITY_INFORMATIONAL : CAOEventInfo.h
  • STATUS_SEVERITY_WARNING : CAOEventInfo.h
  • Stop() : CAO.h
  • STRICT : StdAfx.h

- t -

  • TYPE_FORMAT_STRING_SIZE : CAO_p.c

- u -

  • Unchuck() : CAO.h
  • Unhold() : CAO.h
  • USE_STUBLESS_PROXY : CAO_p.c

- v -

  • VARIANT_UserFree() : CAO.h
  • VARIANT_UserMarshal() : CAO.h
  • VARIANT_UserSize() : CAO.h
  • VARIANT_UserUnmarshal() : CAO.h
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


Namespace Member Index

DENSO WAVE CAO Project 名前空間メンバ

i

これは名前空間の一覧です。それぞれの名前空間の解説へリンクしています。

- i -

  • importlib() : CAOLib
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


Graphical Class Hierarchy

DENSO WAVE CAO Project クラス階層図

クラス階層図を見る。

Generated on Wed Dec 7 19:02:17 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001


Graph Legend

グラフの凡例

このページでは、doxygen で生成されたグラフをどのようにみたらよいかを説明します。

次の例を考えてみます。

/*! 省略されて見えないクラス */
class Invisible { };

/*! 省略されたクラス(継承関係は隠されている) */
class Truncated : public Invisible { };

/* doxygen コメントによるドキュメントがないクラス */
class Undocumented { };

/*! public で継承されたクラス */
class PublicBase : public Truncated { };

/*! protected で継承されたクラス */
class ProtectedBase { };

/*! private で継承されたクラス */
class PrivateBase { };

/*! 継承されたクラスで使われているクラス */
class Used { };

/*! 複数のクラスを継承している上位クラス */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
{
  private:
    Used *m_usedClass;
};
設定ファイル中で、タグ MAX_DOT_GRAPH_HEIGHT が 200 にセットされた場合、次のようなグラフとなります。

上のグラフ内のボックスには次のような意味があります。

  • 黒く塗りつぶされたボックスは、このグラフに対応する構造体やクラスを表します。
  • 黒枠のボックスはドキュメントがある構造体やクラスを表します。
  • 灰色の枠のボックスはドキュメントがない構造体やクラスを表します。
  • 赤枠のボックスはドキュメントがある構造体やクラスを表しますが、指定されたサイズに収まらないために継承・包含関係をすべて図示することができなかったことを示します。
矢印には次のような意味があります。
  • 青い矢印は二つのクラス間の public 継承関係を示します。
  • 緑の矢印は protected 継承関係を示します。
  • 赤の矢印は private 継承関係を示します。
  • 紫の破線矢印は、そのクラスが他のクラスに含まれていたり、利用されていることを示します。また、矢印が指しているクラスや構造体をどの変数でアクセスできるかを矢印のラベルとして示しています。
Generated on Wed Dec 7 19:02:13 2005 for DENSO WAVE CAO Project by doxygen 1.2.18, © 1997-2001